I have a Macbook from late 2008 (version 10.5.8). I cannot use any kind of flash player on it. If I install Snow Leopard, will flash player work?

  • Asked about:  Mac OS X 10.6 Snow Leopard

No Answers have been submitted