I have a mid 2007 mac mini 2.0, with OS X 10.6.8. Can I upgrade to 10.7.5? Apple states that I need a 2009 or newer Mac mini to be able to upgrade.

1 Answer from the Community

  • Almost always if Apple says a device is not compatible with an Operating system, it is not compatible.

    Best regards,

    • Answered by Avery S from Woodland Park
    • 20-Jan-2017