will this work on a powerpc g5?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    No, snow leopard requires an intel Mac. You must have either a macBook, iMac Intel, MacBook Pro, MacBook Air, or Intel Mac Mini. The highest you can go is 10.5.8 leopard.