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Introduction

With the continuing popularity of the RED® family of cameras  
(www.red.com), Final Cut Pro editors have been looking for proven 
workflows with REDCODE® RAW files. This white paper outlines how 
best to use the native RED support in Final Cut Pro and how professional 
production companies are achieving excellent results when recording 
with RED cameras, editing in Final Cut Pro, and finishing in applications 
such as DaVinci Resolve.

This document outlines two complete RED-based post-production 
workflows. The first method focuses on the functionality in Final Cut Pro, 
and the second uses a range of third-party applications for a larger-
scale approach.

http://www.red.com
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Roundtrip Workflow Using XML

You can edit your R3D RAW project in Final Cut Pro and color grade it in 
DaVinci Resolve using a seamless XML workflow. Here’s a summary:

1. Import REDCODE RAW (R3D) files into Final Cut Pro.

Important: When you import the media, make sure to deselect the 
“Create optimized media” and “Create proxy media” options, because 
any transcoding work done during import will be discarded if you 
adjust the RAW settings in the following steps. In addition, deselect 
“From folders” in the Keywords section. (Because each R3D RAW file 
is contained in its own folder, selecting this option would clutter your 
library with many impractical Keyword Collections.)

2. Adjust the levels of the imported media using the RED RAW Settings 
controls in Final Cut Pro.

3. Sync audio and video files (by choosing Clip > Synchronize Clips).

4. Optionally transcode your media to Apple ProRes (optimized or 
proxy media).

5. Edit your project in Final Cut Pro and lock picture.

6. Export an XML file of the project from Final Cut Pro.

7. Import the XML file into DaVinci Resolve and color grade the project 
(using either high-quality Apple ProRes files or R3D RAW files).

Note: You can relink the project XML file to the original R3D files in 
either REDCINE-X PRO® or DaVinci Resolve.

8. From DaVinci Resolve, render out Apple ProRes files and export an 
XML file, then import the XML file back into Final Cut Pro.

9. Make final adjustments and sync the mixed soundtrack in Final Cut Pro.

10. Export a final master file from Final Cut Pro.

This method combines the best of both worlds—the speed of editing 
with Apple ProRes on a wide variety of notebook and desktop systems, 
and the color grading advantages of RAW in the finishing phase.

The following sections include additional detail about each stage of  
the workflow.



 5RED Workflows with Final Cut Pro November 2020

Roundtrip Workflow Using XML

Adjust Levels for RED RAW Files 
in Final Cut Pro
After importing RED RAW media into Final Cut Pro, you can make 
adjustments with the RED RAW Settings controls.

Metadata about REDCODE RAW (R3D) files can be stored in two locations:

• Internal (embedded) settings: This is metadata information recorded 
by the camera and embedded in the R3D RAW file. It always remains 
with the file. These camera settings can be superseded by settings in 
the external RMD file, but they are never overwritten. You can revert 
to these camera settings by deleting any existing RMD file or by 
choosing Original Camera Settings from the Revert To pop-up menu 
in the RED RAW Settings window.

• External RMD file: This is an external metadata file with the file 
extension .RMD. This file is created by Final Cut Pro, REDCINE-X PRO, 
or similar software applications. If you adjust RED RAW settings 
in Final Cut Pro and an RMD file already exists, the existing file is 
overwritten when the changes are saved. The embedded camera 
settings remain intact.

Adjust levels for RED RAW files
1. Install the appropriate plug-in.

In order for Final Cut Pro to recognize the R3D RAW files, you must 
download and install the corresponding plug-in. For more information, 
go to www.red.com.

2. In the browser or the timeline, select the clip or clips you want to adjust.

Note: When you select the original R3D RAW clips and adjust the 
levels using the RED RAW Settings controls in Final Cut Pro, reference 
clips (such as synced clips, compound clips, and multicam clips) that 
refer to those R3D RAW clips are updated automatically.

3. To open the Inspector, do one of the following:

• Choose Window > Show Inspector (or press Command-4).

• Click the Inspector button in the toolbar.

4. Click the Info button at the top of the pane that appears.

5. In the Info inspector, click the Modify RED RAW Settings button.

6. In the RED RAW Settings window, adjust the settings.

http://www.red.com


 6RED Workflows with Final Cut Pro November 2020

Roundtrip Workflow Using XML

You can control color space, gamma, ISO, and other important 
settings for adjusting the look and video levels of the R3D RAW files. 
Final Cut Pro displays the RAW camera settings that were defined by  
the director of photography on the set or, if they exist, the external  
RMD settings defined in REDCINE-X PRO.

As you adjust the RAW file in Final Cut Pro, your changes are saved 
nondestructively to an external metadata file with the file extension 
.RMD, overwriting any existing RMD metadata file. Unlike video effects 
that are applied to a clip, these adjustments are associated with the file 
(via the RMD metadata file). Any changes you make to these settings are 
applied to all copies of the selected clip or clips.

You can return to the original (embedded) settings at any time by 
choosing Original Camera Settings from the Revert To pop-up menu at 
the bottom of the RED RAW Settings window. After the initial RED RAW 
settings have been adjusted, you can continue to make fine color grading 
decisions using the Final Cut Pro color correction tools.

Transcode RED RAW Files to Optimized 
or Proxy Media (Optional)
After you have imported the RED RAW files into Final Cut Pro and made 
your initial RED RAW Settings adjustments, you can immediately begin 
organizing media and editing. RED cameras record a RAW file (R3D) 
that must be “debayered” and decompressed to convert the original 
sensor data to viewable pixels, so that the file can play back in video 
editing software. Although you can get excellent playback performance 
with RED RAW files in Final Cut Pro, if you have a slower or older Mac, 
you may choose to transcode the RAW files for better performance. 
Apple ProRes is an excellent choice for this conversion because it’s a 
codec optimized for both quality and editing speed.

You can choose to transcode to optimized or proxy media in the 
background while editing.
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Roundtrip Workflow Using XML

Transcode to optimized or proxy media
1. Select the RED RAW clips in the browser, Control-click them, and 

choose Transcode Media from the shortcut menu.

2. In the window that appears, select one of the following options:

• Create optimized media: Creates Apple ProRes 4444 files. If 
you select this option, you can begin editing, and when the new 
Apple ProRes 4444 media has been created, it automatically 
replaces the R3D RAW files in the browser.

• Create proxy media: Creates proxy files with the codec and frame 
size of your choice: either Apple ProRes 422 Proxy or H.264, at 
100%, 50%, 25%, or 12.5% of the original frame size.

3. Click OK.

The transcoding process may take a while, depending on the  
options you selected. You can see the status of all the background 
processes currently running in the Background Tasks window. You 
can continue to edit using the original media until the transcoding  
has been completed.

4. If you selected the “Create proxy media” option and the transcoding 
is complete, choose Proxy Preferred or Proxy Only from the View 
pop-up menu in the upper-right corner of the viewer.

If you later change the RED RAW settings, you’re prompted to first  
delete the optimized or proxy media because new media must be 
generated with the updated settings. If you’re working with proxy media, 
choose Proxy Preferred from the View pop-up menu before making the 
change. This setting allows mixing of proxy and original media. As you 
continue to edit, Final Cut Pro replaces the original media with proxy 
media as it is regenerated.

Edit in Final Cut Pro and Export XML
After you import all of your media, you can edit just as you would 
any other project. Final Cut Pro is designed for modern, file-based 
workflows, making it easy to browse, organize, and edit large amounts of 
material. Use skimming to quickly view your footage. Mark range-based 
keywords and favorites, and save custom searches as Smart Collections. 
Quickly and easily arrange clips in the timeline and add titles and effects, 
which render in the background as you work.

When you’re finished editing, you can open your project in a third-party 
finishing system such as DaVinci Resolve. Just open the project in the 
timeline or select the project in the browser, choose File > Export Project 
XML, and select a location to save the XML file.
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Roundtrip Workflow Using XML

Color Grade in DaVinci Resolve 
and Export XML

Choose Apple ProRes or RAW for Grading
Before importing the Final Cut Pro XML file into DaVinci Resolve, you can 
choose between a few different color grading workflows. If you edited 
with Apple ProRes 422 HQ or Apple ProRes 4444 in Final Cut Pro, you 
may want to grade these same files in DaVinci Resolve.

Alternatively, you can relink the project to the original R3D files in either 
DaVinci Resolve or REDCINE-X PRO. These RAW files offer a wide range 
of values to use when grading, which can help improve the look of 
images that were shot without extensive lighting control or that need a 
unique style. And you can get more image detail out of the highlights and 
shadows, which is why so many colorists choose to use the RAW files in 
the color grading stage.

Relink to the original R3D media in DaVinci Resolve
1. In the DaVinci Media Page, add the location of the R3D files to the 

Media Pool.

Note: If the project settings don’t match the properties of your 
media, a window appears with instructions for updating the  
project settings.

2. Open the Edit Page and choose File > Import AAF, EDL, XML.

3. Select the XML file that you exported from Final Cut Pro.

4. In the Load XML window, make sure the “Automatically import source 
clips into media pool” checkbox is not selected.

5. Select any other options that are applicable to your project. 

For example, you can import the Final Cut Pro sizing and color 
information so that DaVinci Resolve can use it in the grade.

6. Click OK.

DaVinci Resolve imports the XML file and automatically relinks the 
original R3D files using reel name and timecode.
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Roundtrip Workflow Using XML

Render New Media
After color grading the final project in DaVinci Resolve, select the Export 
to Final Cut Pro easy setup in the Deliver Page and choose the render 
format based on your final delivery. For example, you may choose to 
render Apple ProRes 4444 for theater projection, or Apple ProRes 422 
if you’re delivering a master for the web or TV. You may want to set a 
handle length for the rendered media (at least one second), so that 
you can make additional changes such as adding a longer dissolve or 
extending an edit. For more details, see the DaVinci Resolve manual at  
www.blackmagicdesign.com/support.

Export XML from DaVinci Resolve and Import 
into Final Cut Pro
After you render the media in DaVinci Resolve, you can transfer 
the project back to Final Cut Pro by exporting an XML file from 
DaVinci Resolve.

Export an XML file from DaVinci Resolve
1. Open the Edit Page and, in the Timeline list, select the timeline you 

want to export an XML file from.

2. Choose File > Export AAF, XML.

3. In the Export XML dialog, choose an XML version from the Format 
pop-up menu.

Choose the latest version that is compatible with your system.

4. Type a name and choose a location for the exported XML file, and 
click Save.

An XML version of that session is saved, complete with internal 
references to the graded media you rendered, and ready for importing 
into Final Cut Pro.

Import the XML file back into Final Cut Pro using the Import XML 
command in the File menu. Make sure that you’re linking to the  
high-quality media by choosing Optimized/Original from the View  
pop-up menu in the upper-right corner of the viewer. Now you can 
add finished audio, adjust titles, insert graphics, and continue to make 
editorial changes. Because you’ve imported the individual media files 
and the XML metadata instead of a single QuickTime movie, you can 
make changes right up to the last minute before delivery. For more 
information about Final Cut Pro, see the Final Cut Pro User Guide.

http://www.blackmagicdesign.com/support/
https://support.apple.com/guide/final-cut-pro/welcome
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Roundtrip Workflow Using XML

Export a Master from Final Cut Pro
The final step in the workflow is to export a finished master from 
Final Cut Pro.

Export your project as a master file
1. Select the project in the browser and choose File > Share > 

Master File.

2. In the Share window, click Settings, and make sure the quality is set 
appropriately in the “Video codec” pop-up menu.

If this is your master file to be used for distribution or exhibition, 
choose a high-quality setting such as Apple ProRes 422 HQ or 
Apple ProRes 4444. For information about the other options, see the 
Final Cut Pro User Guide.

3. Click Next, type a name and choose a location for the exported file, 
and click Save.

If your project is large, make sure you have enough space on the 
destination disk before beginning the export. An estimated size appears 
at the bottom of the Share window.

If you’re exporting for review on the web, you can export an H.264 
version directly to a private account on YouTube or Vimeo.

If you have Compressor installed, you can choose File > Send to 
Compressor to transfer your project to that application for total control 
over your final export settings. Compressor also allows you to set  
up render clusters that use the processors of multiple computers  
on a network and to create custom export settings for unique  
delivery requirements.

If you need to output to tape, many major video I/O device manufacturers 
offer free software to support tape delivery, such as AJA‘s VTR Xchange 
and Blackmagic Design’s Media Express. Download the application  
that works with your video I/O device and use the exported file to lay 
back to tape.

https://support.apple.com/guide/final-cut-pro/welcome
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Large-Scale Workflow 
Using Additional Software

If your project involves a large number of files and many editors, 
consider the following workflow, in which you use third-party 
applications before importing into Final Cut Pro.

1. Transcode REDCODE RAW files to Apple ProRes using 
REDCINE-X PRO.

2. Optionally apply a one-light color correction during the transcoding 
process.

3. Batch sync audio and video files as appropriate.

4. Import synced files into Final Cut Pro.

During import, Final Cut Pro can automatically create lightweight 
proxy files for editing. Or, if you have a lot of footage and multiple 
editors, you can use Compressor to create the proxy files. In this case, 
DaVinci Resolve relinks to the original RED RAW files.

The following sections include additional detail about each stage of  
the workflow.
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Large-Scale Workflow  
Using Additional Software

Transcode RED RAW Files to Apple ProRes 
Using REDCINE-X PRO
You can transcode the files in a batch using the free RED application 
REDCINE-X PRO. REDCINE-X PRO also allows you to apply a “one-light” 
color correction during the transcoding process, which is just like the 
adjustments you can make in Final Cut Pro. If you choose this method 
to adjust the RED RAW settings and transcode to Apple ProRes, you will 
need to return to the REDCINE-X PRO application to make changes to 
the video settings and regenerate new media using that application. For 
more information, see Apply One-Light Color Correction, below.

When you transcode your files to Apple ProRes using REDCINE-X PRO, 
choose the level of quality that’s appropriate to your specific production.

Workflow Apple ProRes codec

Disk space is a consideration, or you’re  
editing a large multicam project.

Apple ProRes 422 Proxy or Apple ProRes 
422 LT

You’re delivering Apple ProRes files as  
a final master for the web or TV.

Apple ProRes 422 or Apple ProRes 422 HQ

You’re delivering for theater projection  
or effects compositing.

Apple ProRes 4444

Although you can transcode to the final delivery quality and then work 
with that throughout post-production, it’s more efficient to work with 
smaller frame sizes and higher image compression during the craft edit. 
So even though you may have shot at 4K or 5K resolution in the field, 
you can transcode to a smaller frame size to save time and disk space. 
For example, you can set the resolution to 1920x1080 or 1280x720, and 
you can set the debayer quality to 1/4.

If you’re generating Apple ProRes files for use as proxy media, you 
can also choose to superimpose, or “burn in,” the source timecode 
and filename over the image. This makes it easy to go back to the 
original R3D files at any point during post-production for a quick visual 
double-check that the files are correct. For more details, see the 
REDCINE-X PRO manual at www.red.com/downloads.

https://www.red.com/downloads/
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Large-Scale Workflow 
Using Additional Software

Apply One-Light Color Correction
When recording with RED cameras, it’s common to shoot a scene “flat” 
to avoid clipping highlights and shadows and provide more flexibility 
when manipulating images in post-production. This recording setup can 
give the footage a washed-out appearance. Many editors and clients 
prefer working with more visually appealing images that include higher 
contrast and color saturation.

To accommodate this workflow, the free REDCINE-X PRO application 
allows you to add a one-light color correction as part of the transcoding 
process. You can choose from several presets to create more common 
looks, or you can create your own look. Be sure to keep the original 
names of the R3D files when you generate new Apple ProRes media so 
that you can easily relink to them later.

After you apply the one-light color correction during transcoding, it stays 
with the image until you go back to the original R3D file and create a new 
Apple ProRes version.

Batch Sync Audio and Video Files
After all your media has been transcoded, you can choose to sync 
second-source audio to the video files. You can sync the files directly 
in Final Cut Pro using the built-in synchronization feature that 
analyzes waveforms to match the scratch audio in your video files to 
the high-quality audio from your field recorder. You can also use a 
third-party application such as Intelligent Assistance’s Sync-N-Link X 
(www.intelligentassistance.com), RED’s REDCINE-X PRO (www.red.com/
downloads), or Red Giant’s PluralEyes (http://www.redgiant.com). Simply 
select all the audio and Apple ProRes video files and batch sync. Then 
export the XML to Final Cut Pro, and all of the synced material is imported 
into a library, ready for editing.

Import Files into Final Cut Pro
After creating Apple ProRes files with REDCINE-X PRO, you can import 
these files directly into Final Cut Pro. Even if you transcode R3D files to 
a high-quality Apple ProRes codec such as Apple ProRes 4444, you may 
still choose to use lightweight proxy files for editing. Final Cut Pro allows 
you to generate proxy files in the background and seamlessly switch 
to these files for editing, providing great flexibility when editing on a 
notebook, for example.

http://www.intelligentassistance.com
https://www.red.com/downloads/
https://www.red.com/downloads/
http://www.redgiant.com
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Large-Scale Workflow 
Using Additional Software

Create proxy files while importing media
1. In Final Cut Pro, choose File > Import > Media.

2. Select a file or folder, or Command-click to select multiple files 
to import.

3. When you’re ready to import, click Import Selected.

4. In the window that appears, do one of the following:

• Add the imported files to an existing event: Select “Add to existing 
event,” and choose the event from the pop-up menu.

• Create a new event: Select “Create new event in,” choose the 
library where you want to create the new event, and type a name 
for the event.

5. In the Media Storage section, select a storage location for the 
media files:

• Copy the files to a library or to a different folder on your storage 
device: Select “Copy files into” and confirm the current library, or 
use the pop-up menu to choose a different library or a folder.

• Link to the files at their current location: Select “Leave files in place.”

If you’re working with a SAN and want to keep the files in a central 
location, choose this option.

6. In the Transcode section, select the “Create proxy media” checkbox, 
and then choose the codec and frame size you want.

When this option is selected, Final Cut Pro creates proxy files in the 
background after the media files are imported. You can begin to edit 
your project and then switch to the proxy files when they’re available.

7. Click Import.

Final Cut Pro imports your media in the background, and then 
creates proxy files in the background. You can view the progress 
of the background tasks in the Background Tasks window. You can 
now begin editing with the original media, even if importing and 
transcoding are not yet complete.

8. To switch to the proxy files after transcoding is complete, choose 
Proxy Preferred or Proxy Only from the View pop-up menu in the 
upper-right corner of the viewer.

It’s just as easy to switch back to the original media when the creative 
editing is finished and you want to work on color or effects at the  
highest quality. When you change these settings, all media in the library 
is affected.
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Strategies for Working 
with Multiple Frame Sizes

Many projects use different cameras during production, which can 
result in a mix of frame sizes in the same project. If you have multiple 
final delivery requirements for the project, such as an HD version for 
broadcast or the web and a 4K version for theatrical release, you may 
need to track, reposition, and reframe many shots. One of the benefits  
of working at 4K or larger frame sizes is that delivery at 2K or 1080 
allows the editor to make creative choices for framing.

The process described below can be employed with either of the 
workflows described earlier. You can use keywords to manage 
clips of various frame sizes and to create separate projects for 
different deliverables.
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Strategies for Working  
with Multiple Frame Sizes

Create a version of your project with a smaller frame size
1. As you import clips of a particular frame size, apply a keyword 

indicating the frame size.

2. When it’s time to create a new master project with a different frame 
size, duplicate the project by Control-clicking it in the browser and 
choosing Duplicate Project As from the shortcut menu.

3. In the window that appears, enter a name for the new project, choose 
a frame size to match your delivery requirements, specify the other 
settings for the duplicate project, and then click OK.

4. In the browser, double-click the duplicate project to open it in  
the timeline.

5. Click the Timeline Index button in the lower-left corner of the 
Final Cut Pro main window (or press Command-Shift-2), and click  
the Tags button at the top of the timeline index.

6. To quickly find and select all the shots that need to be repositioned, 
enter the frame size keyword (that you created in step 1) in the 
search field at the top of the timeline index.

You can use the timeline index to either select all the clips and adjust 
them all at once, or jump to each clip in order and adjust it separately.

7. With the clips selected in the timeline, click the Inspector button in 
the toolbar, and then click the Video button at the top of the pane 
that appears.

8. In the Transform section of the Video inspector, use the Scale slider 
to adjust the frame size of the selected clips as appropriate for the 
new project frame size.

9. To fine-tune the scaling or positioning of the individual clips in the 
project, select them one at a time and choose Transform from the 
pop-up menu in the lower-left corner of the Viewer (or press Shift-T).

These kinds of aesthetic changes don’t degrade image quality, because 
Final Cut Pro operates on the original 4K or larger frame, not on the 
resized 2K or 1080 frame.
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Conclusion

Final Cut Pro offers powerful workflows with RED RAW files that both 
simplify and speed up post-production. You can choose to work with 
the original files or transcode in the background while editing in the 
foreground. And using Apple ProRes for editing and R3D RAW files for 
color grading enables a highly flexible workflow optimized for speed, 
quality, and creative control. This process also takes advantage of 
the metadata and XML capabilities of Final Cut Pro, which have been 
designed for the future of file-based production. By using this document 
as a template for working with RED and Final Cut Pro, editors and 
post-production facilities can further customize the process to suit  
their unique needs.
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