i just got a 5th gen ipod. I am currently running 10.5.8. What do I need to do to be able to use it?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    You need at least Snow Leopard, 10.6.8, and the most up to date iTunes.