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What’s new in Logic Pro

What’s new in Logic Pro 10.7.3
New monitoring formats for Dolby Atmos and surround mixes

The updated Dolby Atmos plug-in and the new Spatial Audio Monitoring plug-in offer new
formats for monitoring your Dolby Atmos and surround mixes. These include binaural
formats used by Apple Music and for Apple headphones with head tracking support. If you
use Logic Pro on a computer that supports Spatial Audio playback on built-in speakers, you
can now use them to monitor your Dolby Atmos and surround mixes.
See Dolby Atmos plug-in and the Spatial Audio Monitoring chapter of Logic Pro Instruments.

Miscellaneous enhancements
•

The MIDI Environment window is now opened by pressing and holding the Option key
and choosing Window > Open MIDI Environment.

What’s new in Logic Pro 10.7
Refreshed interface

Logic Pro has a refreshed, colorful interface aligned with the macOS Big Sur and Monterey
system interface changes. You can now choose to view Logic Pro preferences, system
dialogs, and other system-related windows in the Light appearance or Dark Mode,
independent of the system setting. See General Display preferences.

Spatial Audio mixing with Dolby Atmos

You can now create and export spatial audio mixes for surround systems and devices
that support Dolby Atmos. Spatial audio lets audio signals be interpreted as objects in
3D space. You can position and move these objects, making individual sounds seem like
they are coming from any direction around the listener. During playback on a Dolby Atmos
compatible system or device, the information describing the position and movement of
each object is rendered in real time, providing a reliable reproduction of the intended mix.
You can export your project as an ADM BWF file, the format required to submit a Dolby
Atmos mix to Apple Music. See Overview of spatial audio.
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Step Sequencer enhancements

Step Sequencer features a variety of enhancements for creating and playing patterns:
You can record patterns in real time with Live Pattern Recording, and can also record MIDI
input step-by-step using Step Recording. When using Step Sequencer with Drum Machine
Designer patches, changing the note or octave step values now transposes the pad kit
piece for the row rather than triggering a different pad. You can split a pattern region with
a Drum Machine Designer patch into multiple pattern regions, one for each row assigned
to a kit piece. You can constrain step entry to a single row in Mono mode, use the Legato
function to ensure smooth playback, add custom row names, and assign note input to
existing rows when using the Learn function. You can also convert MIDI regions to pattern
regions and convert pattern regions to MIDI regions in the Tracks area. See Overview of
Step Sequencer.

New Sound Library content and ability to filter by sound pack

Logic Pro 10.7 includes eleven new sound packs featuring a variety of genres, and including
content from some of the world’s top producers. You can download the new sound packs
from the Sound Packs and Producer Packs sections of the Sound Library Manager. In the
Library, you can now browse patches for a particular sound pack or Producer pack. See
View patches for a particular sound pack.
The new sound packs include the following:
•

Sound Packs: Alpha Waves (Modern Ambient), Backlight Bounce (Slap House), and
Ultimate 808s.

•

Producer Packs: Boys Noize, Mark Lettieri, Oak Felder, Soulection, Take a Daytrip, Tom
Misch, TRAKGIRL, and Watch the Sound With Mark Ronson.

In addition, Logic Pro 10.7 includes new surround content such as a Surround Live Loops
grid and ES2, Sculpture, and Delay Designer presets.
New Step Sequencer pattern loops have been added to the Apple Loops > Step Sequencer
content pack in the Sound Library.

MIDI input port and channel filtering per track

In the Track inspector, you can now choose a particular MIDI In port or channel for
each software instrument or external MIDI track. This allows you to assign multiple
MIDI devices, for example two keyboards, to different tracks and then record your
performances simultaneously. You can also use hardware sequencers to play multiple
software instruments, while keeping your MIDI keyboard free for other tasks. See Edit track
parameters and Record multiple MIDI devices to multiple tracks.

Use Logic Pro in Complete mode or Simplified mode

You can choose to use the full set of Logic Pro features for a complete music production
system, or work in a simplified mode that streamlines tools and menus to provide you with
a core set of features. GarageBand users and others new to Logic Pro can start working
with a basic feature set and familiar interface, and enable the complete feature set at any
time. See Use the complete set of Logic Pro features.
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Miscellaneous enhancements
•

In the Loop Browser, the Key column of the results list now displays whether an Apple
Loop is in the major or minor mode, in addition to the key.

•

For working with plug-in delay compensation, Low Latency mode is now renamed to
Low Latency Monitoring to more precisely describe its function. See Work with plug-in
latencies.

•

In the Mixer, when a plug-in has a side chain source, the channel strip includes an
indicator after the name in the plug-in slot. See Work in the plug-in window.

•

Pedalboard can now be inserted as either a stereo or a dual mono instance. The difference
is visible in the Router busses. See Use the Pedalboard Router in Logic Pro Effects.

What’s new in Logic Pro 10.6
Optimized for Apple Silicon

New Universal version provides improved performance and efficiency on Mac computers
with Apple silicon.

Live Loops enhancements

You can now move and duplicate multiple scenes in the Live Loops grid. The Zoom tool
is now in the Tool menu and can be activated with a key command. See Edit Live Loops
scenes and Change Live Loops view settings.

Sampler enhancements

You can now add a track with a Sampler instrument by dragging a single audio file to the
area below all existing tracks in the Tracks area. New menu commands let you optimize
the loop start and loop end of audio files in the Waveform display. You can now assign
modulation sources directly in the Synth pane by Control-clicking a target parameter and
choosing the desired modulation source in the shortcut menu. See the Sampler chapter in
Logic Pro Instruments.

Step Sequencer

Now you can use Logic Remote to design beats on your iPhone or iPad using Multi-touch.
See the Logic Remote User Guide.

New region color preference

You can now set whether regions can be colored individually or follow the track color as a
Tracks Display preference. See Tracks Display preferences.

New content and tutorial project

A new Keyboard Collection sound pack is now included in the Sound Library. A new tutorial
project for Drum Machine Designer is available in the Project Chooser.

Logic Pro User Guide
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What’s new in Logic Pro 10.5
Live Loops

With Live Loops, you can arrange and play with musical ideas in real time in a grid of cells,
each containing a musical phrase or loop. You can start and stop cells freely while keeping
everything in sync with the beat and the project tempo. Additionally, you can record a Live
Loops performance to the Tracks area. Live Loops is designed for use in live performance,
and can be used with compatible hardware control surfaces. You can use MIDI controller
assignments to start and stop cells and scenes, record to a cell, enable performance
recording, activate key commands, and perform other functions. See Live Loops overview.

Remix FX

Remix FX includes a set of buttons, sliders, and XY pads you can use to control real-time
effects commonly used in electronic and dance music. It makes it easy to scratch mix a
project, like a DJ using a turntable, to play audio in reverse, to stop or downsample the
song, and to apply a variety of other dance-oriented effects. You can also use Remix FX
together with Live Loops. See the Remix FX chapter in Logic Pro Effects.

Step Sequencer

Step Sequencer features a grid with steps you can edit to create repeating patterns.
Each row controls either a sound or an automation parameter, and each step represents a
definable length of musical time. You can easily create drum and rhythm-based patterns,
as well as instrument and melodic patterns. You can adjust a wide range of parameters
for individual steps, including velocity, pitch, gate time, and more; and edit pattern and
row settings including pattern length, loop start and end points, playback position, and
rotation. See Step Sequencer overview.

New drag-and-drop workflows

You can quickly create new tracks and choose one of several instrument plug-ins, insert an
instrument plug-in on a software instrument track, replace the sound for Alchemy or Quick
Sampler, create Sampler zones, and add samples to Drum Machine Designer pads using
drag and drop. See Create tracks using drag and drop and Insert an instrument plug-in on a
track. Also see the Alchemy, Drum Machine Designer, Quick Sampler, and Sampler chapters
in Logic Pro Instruments for plug-in specific drag and drop workflows. There are also dragand-drop workflows for Live Loops.

Sampler

Sampler is a full-featured software sampler in a modern design that provides synthesis,
mapping, and zone editing areas in a single window interface. You can show and hide
different sets of controls to easily switch between synthesizer processing and sampler
instrument editing. The zone editor offers detailed control over start, end, and loop points,
while the mapping editor enables fast and flexible assignment of samples across the
keyboard. Sampler supports all existing EXS24 mkII instruments. See the Sampler chapter
in Logic Pro Instruments.
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Quick Sampler

Quick Sampler makes it easy to capture audio and to create a sampler instrument using a
single audio file. You can record directly to Quick Sampler or drag an audio file to use as
the starting point for an instrument. Quick Sampler analyzes the audio and can intelligently
create slices, find loop points, and adjust sample length and pitch independently. You can
make adjustments in the waveform display to fine-tune the results, and add synthesizertype processing using filters, envelopes, and other controls. See the Quick Sampler
chapter in Logic Pro Instruments.

Drum Synth

This powerful but easy-to-use plug-in creates synthesized drum sounds. Choose from a
diverse collection of drum models and shape their sound with up to eight simple controls.
Drum Synth is also directly integrated into the bottom of the Drum Machine Designer
interface, giving you a focused set of sound-shaping controls. See the Drum Synth chapter
in Logic Pro Instruments.

Drum Machine Designer enhancements

Drum Machine Designer is the ideal way to create, organize, and interact with electronic
drum kits and drum kit pieces. You can use it for electronic Drummer tracks, as well as on
instrument channel strips. To help you quickly edit sounds, Quick Sampler and Drum Synth
are directly integrated into the Drum Machine Designer interface. In the Drum Machine
Designer window, you can view and edit Kit Controls for the overall kit, or Pad Controls
for an individual kit piece. Use drag-and-drop workflows to quickly reorder pads, and add
samples by dragging them to pads. Drum Machine Designer provides a flexible platform for
groove production when combined with Step Sequencer. See the Drum Machine Designer
chapter in Logic Pro Instruments.

Logic Remote

You can control Live Loops and Remix FX in Logic Remote. Play, queue, and edit cells,
trigger scenes, record to cells, record a performance to the Logic Pro Tracks area and
more, from your iPad or iPhone. See the Logic Remote User Guide.

More Content

Logic Pro User Guide

•

Over 2,500 new loops in a variety of instruments and genres covering modern and
classic hip-hop, electro house, reggaeton, future bass, techno, and transition effects.

•

17 Live Loops starter grids covering a range of electronic and hip-hop genres.

•

More than 70 new Drum Machine Designer kits.

•

Over 1,500 new patches.

•

Original multi-track project of Billie Eilish “Ocean Eyes.”

14

What’s new in Logic Pro 10.4
Smart Tempo

With Smart Tempo you can record a performance without the metronome and have
Logic Pro adapt the project tempo to match the tempo of the recording, or keep the project
tempo and flex the recording to match it. You can also use Smart Tempo when importing
audio files with different tempos or tempo variations to have Logic Pro keep the project
tempo and flex the audio regions to match it, or adapt the project tempo to use the tempos
of the audio files. Smart Tempo can also be used with multitrack audio recordings and with
MIDI regions. See Smart Tempo overview and Work in the Smart Tempo Editor.

Articulation Handling

For software instruments that provide multiple articulations, Logic Pro provides new
controls for creating, editing, and choosing articulations. You can view and change
parameters for existing Articulation Sets, and create and save new Articulation Sets, using
the Articulation Editor, then quickly change articulations while working in the Editors. See
Manage articulations with the Articulation Set Editor and Manage articulations for software
instruments.

Mixer enhancements

The responsiveness and performance of the Mixer is improved, particularly for projects
with high channel strip counts. In addition, the Mixer provides several new capabilities,
including creating a default channel strip configuration, disabling autoscrolling to the
selected channel strip, and highlighting channel strips corresponding to a send or
routing destination. In addition, selecting multiple channel strips also selects the tracks
assigned to them.

Dynamic plug-in loading

When you open a project, Logic Pro analyzes the project to determine which channels
are needed for project playback. Only plug-ins needed to enable the full signal flow for
playback (including auxes, busses, and outputs) are loaded. This allows projects to quickly
be opened and be ready for playback and editing. While you are working on the project,
other plug-ins are loaded as needed. You can prevent a track from loading when you open
a project using the On/Off button in the track’s header.
Dynamic loading of plug-ins is active when the “Only load plug-ins needed for project
playback” checkbox is selected in Project Settings > General.

New Drummers

Two new Drummers and a new Brush Kit have been added to Logic Pro. You can now find
Austin and Tyrell in the Songwriter category.

Logic Pro User Guide
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Studio instruments

The Studio instruments are high quality multisampled brass and string players that offer
a collection of solo and grouped instrument presets. Each preset provides a range of
articulations that let you create expressive, nuanced performances and recordings.

Vintage Mellotron

Vintage Mellotron recreates the features and a number of sounds from this famous
keyboard instrument that has been featured on dozens of classic rock and pop songs from
the 1960s, 1970s, and beyond.

Alchemy

Several modulation enhancements, including new Envelope Follower and MIDI modulation
functions, have been added. Also included are new loop length settings, new solo
functions, and improved undo and drag and drop behavior.

Effects

Logic Pro features a variety of new effects to use in your projects, including: DeEsser II,
Vintage EQ collection, Phat FX, and Step FX. The Expander, Space Designer and Direction
Mixer plug-ins have been extensively redesigned.

Support for ARA with the Melodyne plug-in

Logic Pro now supports Audio Random Access (ARA) for the Melodyne plug-in. ARA
enables Logic Pro and the Melodyne plug-in to share song structure information and
analysis results. See Support for ARA 2 compatible plug-ins.

Adjust panning for sends independently

Using the Independent Pan setting for a send, you can adjust the pan type and position for
the send independently from the pan type and position for the channel strip. See Adjust
panning for sends independently.

Automatic slurs in the Score Editor

You can apply automatic slurs to notes in the Score Editor. Automatic slurs can cover a
selected group of notes, and adjust when the notes are copied, moved, or transposed.
Using key commands, you can quickly add and edit automatic slurs for an entire line, part,
or score. See Add dynamic marks, slurs, and crescendi to a score.

Manage Logic Pro content

You can relocate the Sound Library to a different volume or partition. See Manage
Logic Pro content.

Logic Pro Help

Logic Pro Help now includes complete information about the included instruments and
effects in one combined document, for easy searching and browsing.

Logic Pro User Guide
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What’s new in Logic Pro 10.3
User interface

Logic Pro has a new visual design with an expanded color scheme for enhanced readability
in different working environments.

Track alternatives

Track alternatives allow you to create alternate edited versions of a track and switch
between them at any time to audition or edit the different options. See Use track
alternatives.

Selection-based processing

Selection-based processing allows effect plug-ins to be applied to audio regions and
marquee selections directly in the Tracks area, either non-destructively or destructively.
See Use selection-based processing.

New Pan modes

New pan modes include Stereo Pan and Binaural Pan, available in the Mixer. See Set
channel strip pan or balance positions.

Add tracks with GarageBand for iOS

You can share a Logic Pro project with GarageBand for iOS using iCloud Drive. In
GarageBand, the project appears as a new song with a single track containing a mixdown
of the project. You can add tracks using GarageBand Touch Instruments, and then send the
project back to Logic Pro to continue working. See Share a project to GarageBand for iOS.

Touch Bar support

If your computer has a Touch Bar, you can use the Touch Bar to work in the Tracks area,
work with Smart Controls, apply key commands, and play software instruments. See
Touch Bar shortcuts.

Drummer Loops

Logic Pro includes Apple Loops associated with a drummer, which can be customized after
being added to a project. See Apple Loops in Logic Pro.

New Drummers

New percussion players in the styles of Pop, Songwriter, and Latin.

Enhanced Quick Help

Quick Help has been enhanced, and can now be viewed in a Coaching Tip-style window
next to the pointer, as a movable floating window, or in the Inspector. See How to get help.

Logic Pro User Guide
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What’s new in Logic Pro 10.3
Alchemy

Logic now includes Alchemy, an easy to use yet powerful sample manipulation synthesizer.
Alchemy features additive, spectral and granular synthesis and resynthesis, sampling, and
virtual analog engines, and offers realtime performance controls and an extensive preset
library. For more information, see the Alchemy chapter in Logic Instruments.

MIDI Controllers

For supported USB MIDI controllers, Logic Pro supports automatic assignment of hardware
controls, including buttons, knobs, and faders, to Smart Controls and other functions. See
Automatic MIDI controller assignment.

Editing

Extended MIDI editing options: Create and edit MIDI data using new features and tools
including Note Repeat, Spot Erase, the Brush tool, and Collapse view.

Mixing

VCA groups: You can use VCA channel strips to control the volume, or automate a submix,
of tracks that are assigned to the VCA group.

Instruments and effects

Plug-in Manager: You can organize and manage plug-ins in the Plug-in Manager, create
new plug-in categories, rename or remove existing plug-ins, and search for individual
plug-ins by name.
Compressor: The Compressor plug-in has been redesigned.

What’s new in Logic Pro 10.0
User interface

Modern interface: The Logic Pro interface is redesigned for increased functionality. The
transport controls are now at the top of the window for better visibility and access, the
Library is relocated next to the track headers, and multiple tracks can now be selected and
moved in one operation. Menus are reorganized and streamlined, and there are a host of
other ergonomic improvements. Groups of features can be turned on or off in the Use the
complete set of Logic Pro features pane, letting you optimize the interface to suit your way
of working.
Quick Help: View brief descriptions of windows, controls, and other elements of the
Logic Pro interface without leaving the app or interrupting your workflow. You can view
Quick Help either in the inspector, or in a movable floating window.

Logic Pro User Guide
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Projects

New project structure: In Logic Pro, project assets can be saved directly in the project
or in a project folder, and can also be referenced from a location outside the project. For
information about handling project assets, see Manage project assets. You can also save
project alternatives in different states, including different cuts or mixes, and go back to
earlier, automatically saved versions of a project using backups.
New sharing options: You can share Logic Pro projects to SoundCloud to distribute and use
with other apps on your Mac. See Sharing overview.
Auto Save: Logic Pro regularly saves your work in the background. In the event of
an unplanned interruption, you can reopen your project with the latest changes and
continue working.

Tracks area

Drummer: Select from a variety of virtual drummers, each with its own drum kit and
playing style, to add to your projects. Choose from a variety of both acoustic and electric
drummers. Adjust performance parameters including loudness, complexity, and kit piece
focus for each Drummer region. Drummer can respond interactively to other tracks and
regions in a project. See Overview.
Smart Controls: Quickly adjust the sound of a track using a set of visual screen controls.
You can customize Smart Controls by mapping their screen controls to channel strip or
plug-in parameters, then manipulate them using external MIDI hardware. See Overview of
Smart Controls in Logic Pro.
Track Stacks: Easily organize complex arrangements by collapsing multiple tracks into one.
Create layered instruments with multiple software instruments. Create submixes to manage
complex Mixer setups. See Track Stacks overview.
Patches: Save and recall complex, multiple channel strip configurations along with their
Smart Controls. Patches contain the instrument, effects, and routing settings that control
the sound of a track. See Patches overview.
Arrangement track: Organize a project into sections, then move or copy the sections to
build an arrangement. See Add arrangement markers.
Groove tracks: Set one track in the project as the groove track, then select other tracks you
want to follow the timing of the groove track. See Control timing with the groove track.

Editing

Flex Pitch: Manipulate pitch and other parameters of vocal and monophonic instrument
recordings. You can make quick pitch corrections in the Tracks area, or use the full Flex
Pitch functionality to quantize and edit pitch and adjust other parameters in the Audio
Track Editor. See Flex Time and Pitch overview.
Audio Track Editor: Edit audio regions non-destructively in a close-up view of a single
track, including making Flex Time and Flex Pitch edits. See Overview.
Redesigned editors: The Piano Roll Editor and Score Editor have been redesigned and
improved. See Overview and Overview.
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Mixing

New Mixer options: The redesigned Mixer now includes gain reduction meters. The new
multi-functional Effect slot design simplifies choosing, opening, and bypassing plug-ins.
See Mixing overview for information about using the Mixer.

Instruments and effects

Drum Kit Designer plug-in: Customize or build drum kits to use with Drummer, or to play
and sequence drum tracks manually. You can choose multiple drums, then adjust individual
parameters for each drum.
Arpeggiator/MIDI plug-ins: Create sophisticated arpeggiator patterns for any software
instrument using the Arpeggiator. Use other MIDI plug-ins to perform a variety of realtime operations. See Plug-ins overview. For complete information about MIDI plug-in
parameters, see the MIDI plug-ins section of the Logic Pro Effects manual.
Redesigned vintage instruments: The three vintage instrument plug-ins (EVP88, EVB3, and
EVD6) have been redesigned and renamed Vintage Electric Piano, Vintage B3, and Vintage
Clav. For more information, see the relevant sections of the Logic Pro Instruments manual.
Retro Synth: Retro Synth is a flexible, easy-to-use 16-voice synthesizer that can produce
a wide variety of sounds. This instrument plug-in provides four synthesizer types—
Analog, FM, Sync, and Wavetable—each of which can generate unique sounds. For more
information, see the Retro Synth section of the Logic Pro Instruments manual.
Bass Amp Designer: This effect plug-in emulates the sound of famous bass guitar
amplifiers and the speaker cabinets used with them. For more information, see the Bass
Amp Designer section of the Logic Pro Effects manual.
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Get started with Logic Pro

Get started with Logic Pro overview

Welcome to Logic Pro. This chapter introduces the main working areas of Logic Pro, and
presents some basic tasks to help you start working in the app.
Logic Pro is a full-featured music and audio app you can use for every aspect of music
creation: recording, arranging, mixing, and more–everything from sketching your initial
ideas to producing polished final mixes. You can use Logic Pro for any type of project, from
simply recording yourself singing or playing all the way to complex multi-track, multisection compositions.
For a quick tour of the Logic Pro interface, see Logic Pro main window, then choose topics
from the list on the left that introduce specific features and working areas, with basic tasks
to help you get started.

Open Logic Pro

Do one of the following:
•

On your Mac, click the Launchpad icon in the Dock, then click the Logic Pro icon in
Launchpad.

•

Double-click the Logic Pro icon in the Applications folder.

The first time you open Logic Pro, it downloads basic content, including software
instrument presets and Apple Loops, that you can use in your projects. After the download
is complete, the Project Chooser opens so you can create a new project or open an
existing one.
To learn more about creating and opening projects, see Projects.
Tip: If you’re using Logic Pro on a portable computer or with a smaller display, you can
hide the Dock to maximize available screen space. To hide the Dock, Control-click the area
in the Dock between the last app icon and the Downloads icon, then choose Turn Hiding On
from the shortcut menu.
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Logic Pro workflow overview

To give you an idea of the possibilities, some major steps in putting together a Logic Pro
project are described below. You don’t have to do every step, and you might perform some
steps in a different order. You could, for example, go all the way through mixing and adding
effects, then add more recordings or media files to your project before finalizing the mix
and sharing the finished project.

Create a project

You start working in Logic Pro by creating a project to hold your musical material and all
the changes you make. You can add tracks for your recordings and for loops and other
media files you add to the project. Media files and other assets can be saved in the project,
or referenced in their current location.

Record your material

Add musical material by recording your performances in the Tracks area. You can record
vocals and instruments on audio tracks. Using a USB music keyboard or other MIDI
controller, you can play and record a wide variety of software instruments on software
instrument tracks. You can also record MIDI regions to play back on external MIDI devices,
such as synthesizers and sound modules.

Add Apple Loops and other media files

Add Apple Loops from the large collection included with Logic Pro. Apple Loops are
prerecorded audio and MIDI files optimized to create repeating patterns that can be
extended to fill any amount of time. You can also add audio files, movies, and other
prerecorded media files to a project.

Create the arrangement

Organize your recordings and other media to build an arrangement in the Tracks area.
Recordings, loops, and other media files appear in the Tracks area as regions that you can
can copy, move, resize, loop, and edit in other ways. You can also use arrangement markers
to define and easily rearrange entire sections of a project.

Edit regions

Logic Pro offers a set of editors you can use to edit both audio and MIDI regions in a variety
of ways. For audio regions, you can also precisely edit the timing of individual notes and
other events using Flex Time, and adjust the pitch of notes using Flex Pitch. You can also
edit Drummer regions in the Drummer Editor.
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Mix and add effects

As your project takes shape, you mix it to balance the individual parts and blend them into
a cohesive whole. In the Mixer, you can adjust volume levels and pan (balance) positions
of tracks, and use routing and grouping to control the signal flow. Logic Pro features a
set of professional-quality effects plug-ins that you can use to enhance particular song
components and create a polished final mix. You can control changes to mix, effects, and
other parameters over time using automation.

Make global changes

You can manipulate different aspects of an overall project using global tracks, including
the Arrangement track, Marker track, Signature track, Tempo track, and Transposition
track. For movie projects, you can also access the Movie track to view video frames and
synchronize them with musical events.

Share your project

When your project is ready to share, you can export a stereo file of your final mix in one of
several standard audio file formats. You can also produce multiple stem files, formatted for
most common surround encoding schemes. Projects can be shared to iTunes, shared to
other devices using AirDrop or MailDrop, and can also be burned to a CD or DVD.

Get started with the Logic Pro main window

The Logic Pro main window is where you work on your projects. You can access all of the
major working areas of Logic Pro in the main window.
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The central part of the main window is the Tracks area. You record and arrange the musical
material in your project on the tracks in the Tracks area. There are several different track
types, including audio, software instrument, and Drummer tracks. When you make a
recording, or add an Apple Loop or other media file, it appears as a rectangular region on
the selected track.
Across the top of the main window is the control bar, which includes buttons that let you
access different parts of Logic Pro, transport controls for controlling project playback, a
Master Volume slider to adjust the overall project volume, and other controls. In the center
of the control bar is the LCD, where you can view the current playhead position, move the
playhead, and set the project tempo, key, and time signature.
To start working with audio tracks, see Audio tracks. To start working with software
instrument tracks, see Software instrument tracks. To start working with your recordings
and other material in the Tracks area, see Arranging regions.
You can open the following working areas of Logic Pro by clicking their buttons in the
control bar:
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•

Library: You can audition patches and choose a patch for the selected track in the
Library. A patch contains the instrument, effects, and routing settings that control the
sound of a track. When you choose a patch, those settings are applied to the currently
selected track. The Library shows available patches for the selected track. You can
choose a category on the left to see available patches or subcategories on the right.

In addition to patches, you can view and select plug-in presets and other settings in
the Library, when the corresponding item is selected. For information about choosing
patches and other items in the Library, see Patches overview.
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•

Inspector: You can view and edit parameters for the selected region, the selected
track, and other items in the inspector. The available inspectors and parameters
change, depending on which working area has focus, and what is selected. The channel
strips for the selected track and its output appear in the lower part of the inspector, so
you can view and quickly edit channel strip parameters and plug-ins.

The Quick Help area at the top of the inspector shows a brief description of whatever
part of the Logic Pro interface you move the pointer over. Some Quick Help descriptions
contain links to more detailed information.
For information about editing region and track parameters, see Use the Region
inspector and Edit track parameters.
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•

Smart Controls: Smart Controls let you quickly adjust the sound of the selected track
using a set of onscreen controls. When you open the Smart Controls pane, you see the
screen controls for the the selected track. Screen controls can control both channel
strip and plug-in parameters, including software instruments and effects. Move the
knobs and other screen controls, and hear how sound changes.

To start working with Smart Controls, see Smart Controls. For more information, see
Overview of Smart Controls in Logic Pro.
•

Mixer: The Mixer is where you adjust volume, pan, and other channel strip settings,
mute and solo channel strips, add and edit plug-ins assigned to a channel strip, and
control the signal flow of your project.

The Mixer shows the channel strips for every track in your project, including auxiliary
and output channel strips, and the master channel strip. This makes it easy to see and
adjust relative levels and other track settings. You can adjust the level and pan position
of each channel strip, insert instrument and effect plug-ins and edit their parameters,
mute and solo tracks, and send the output to auxiliary or output channel strips.
To start working in the Mixer, see Mixing. For more information, see Mixing overview.
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•

Editors: Logic Pro includes a set of editors you can use to edit individual tracks and
regions, and manipulate their contents precisely. The available editors depend on the
type of track or region selected.

•

The Piano Roll Editor shows notes in selected MIDI regions on software instrument
(or external MIDI instrument) tracks. Each note appears as a bar that indicates the
point in time where it starts playing, how long the note plays, and the note’s pitch.
To start working in the Piano Roll Editor, see Piano Roll Editor. For more information,
see Piano Roll Editor overview.

•

The Audio Track Editor displays the audio waveform of the regions on an audio
track. In the Audio Track Editor, you can copy, paste, move, trim, split, and join audio
regions. You can also quantize and edit the timing and pitch of audio material using
Flex Time and Flex Pitch.
To start working in the Audio Track Editor, see Audio Track Editor. For more
information, see Audio Track Editor overview and Flex Time and Pitch overview.

•

The Score Editor displays MIDI regions in a project as music notation, including
notes, rests, and other MIDI events such as sustain pedal markings. You can add and
edit notes and other musical symbols.
For more information about the Score Editor, see Score Editor overview.

Logic Pro User Guide

28

•

Loop Browser: Logic Pro includes an extensive collection of prerecorded Apple
Loops that you can add to your projects. You browse or search for loops in the Loop
Browser, where you can preview them to choose the ones you want to use.

To start working with Apple Loops, see Apple Loops. For more information, see Apple
Loops in Logic Pro.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional features, browsers, and editors are available.
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Get started with Logic Pro projects

You create your music in a Logic Pro project. A project is the document that contains all
of your recordings, the media files you add, and all the edits you make. You start working
in Logic Pro by creating a project or opening an existing one. GarageBand users can
open their GarageBand projects in Logic Pro and continue working, with the expanded
capabilities of Logic Pro.
You can create new projects and open existing projects. Logic Pro includes templates
and demo projects that you can use to try out the tasks presented in the following Get
Started topics.
Logic Pro also includes several tutorial projects that you can use to learn about features of
the app by following steps in a hands-on setting. You can access tutorial projects for Live
Loops, Quick Sampler, and Step Sequencer from the Project Chooser.

Create a project from a template

1. In Logic Pro, choose File > New to open the Project Chooser.
2. In the Project Chooser, click Project Templates on the left, then double-click a template
on the right.

You can also create your own templates and choose them in the Project Chooser.

Open an existing project

1. In Logic Pro, choose File > Open.
2. Browse to the location of the project, select it, then click Open.
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Open a tutorial project

1. In Logic Pro, choose File > New to open the Project Chooser.
2. In the Project Chooser, click Tutorials on the left, then double-click a tutorial project on
the right.

Open a demo project

1. In Logic Pro, choose File > New to open the Project Chooser.
2. In the Project Chooser, click Demo Projects on the left, then double-click a demo
project on the right.

Save your project
•

In Logic Pro, choose File > Save (or press Command-S).

For more information about working with projects, see Projects overview. For information
about creating projects, see Create projects.
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Get started with project playback in Logic Pro

You can play back the project at any time to hear your latest changes. You control playback
and navigate the project using the playhead, the ruler, and the transport buttons, located in
the control bar.
The playhead extends from the top to the bottom of the Tracks area, and moves as the
project plays, showing the currently playing point in the project. At the top of the playhead
is a triangle that you can drag to move the playhead to a different time position, or scrub
the project by moving the playhead across the Tracks area to quickly locate a particular
musical passage.
At the top of the Tracks area, the ruler shows units of time in bars, beats, and beat
divisions (depending on the zoom level).

The control bar contains a group of buttons called transport buttons that you can use to
control playback, move the playhead, and start recording. The transport buttons include
the following:

You can use the cycle area to define part of a project to play back repeatedly. The cycle
area can be used for composing, practicing a part before recording, recording multiple
takes, and other purposes. When you turn on the cycle area, it appears as a yellow strip in
the upper part of the ruler.

Start and stop playback
In Logic Pro:
•

To start playback: Click the Play button (or press the Space bar).
When the project is playing, the Go to Beginning button becomes a Stop button.
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To stop playback: Click the Stop button (or press the Space bar again).

•

To start playback from the clicked position: Double-click the lower part of the ruler.
Double-click again to stop playback.
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Move the playhead

In Logic Pro, do any of the following:
•

Drag the playhead to a new position.

•

Click the lower part of the ruler to move the playhead to the clicked position. If the
project is playing, playback continues from the clicked position.

•

Shift-click in an empty part of the Tracks area at the new position.

•

While the project is playing, click the Rewind or Forward button.
Each time you click Rewind, the playhead jumps back to the previous bar. Each time you
click Forward, the playhead jumps forward to the next bar.

•

In the LCD, click and hold one of the numbers in the Position display and drag vertically.

Move the playhead to the start of the project
•

In Logic Pro, click the Go to Beginning button in the control bar (or press Return).

Play a section repeatedly with the cycle area
1. In Logic Pro, click the Cycle button
cycle area.

in the control bar (or press C) to activate the

The cycle area appears in the ruler.
2. Hold the pointer over either the left or right edge of the cycle area, then drag to resize
it.
The left and right edges of the cycle area are called locators.

3. Press the Space bar to start playback.
The playhead loops continually within the cycle area.
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Move the cycle area

In Logic Pro, grab the cycle area by the middle (the pointer turns into a hand) and drag it
left or right.
For iPad users, a separate app is available that you can use to navigate Logic Pro projects,
and perform mixing, editing, and other functions, on your iPad. The Logic Remote app is
available on the App Store.
For more information about playback and navigation, see Play a project and Control
playback with the transport buttons. For information about using the cycle area, see Use
the cycle area.

Get started with Logic Pro project properties

Each project has a set of properties, including tempo, key, and time signature. For new
projects, the default project tempo is 120 beats per minute (bpm), the key is C, and the
time signature is 4/4. You can change these project properties when you create a project,
or later while you’re working.
The project tempo, key, and time signature are displayed in the LCD in the center of the
control bar, along with the current playhead position.

Tempo

The project tempo defines the musical speed of the project, expressed as the number of
beats per minute (bpm). Changing the tempo can affect the playback speed of audio and
software instrument recordings, Drummer regions, and Apple Loops, in the project.

Key

The project key defines the central note (called the tonic), and whether the project uses
the major or minor scale. Changing the key affects the playback of Apple Loops in the
project, and the display of MIDI notes in the Score Editor.

Time signature

The project time signature defines how musical time is divided into measures and beats.
The time signature contains two numbers separated by a slash (/), which looks similar
to a fraction. The first number controls the number of beats in each bar, and the second
number controls the beat value (the note that counts as one beat). Changing the time
signature does not affect playback, but does affect the units displayed in the ruler and the
bars in the Score Editor.
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Show project properties in the LCD
•

In Logic Pro, click the triangle on the right side of the LCD, then choose Beats & Project
from the pop-up menu.

Set the project tempo in the LCD
•

In Logic Pro, click and hold the tempo value (above the letters “bpm”) and drag up or
down.

Set the project key in the LCD
•

In Logic Pro, click and hold the key, then choose a new key from the pop-up menu.

Set the project time signature in the LCD
•

In Logic Pro, click and hold the signature, then choose a new signature from the pop-up
menu.
Choose Custom to add a new time signature.

For more information about working with project properties, see Project
properties overview.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add tempo, key, and time signature changes in a project.

Tracks
Get started with Logic Pro audio tracks

You can record sound from a microphone, or from an electric instrument (such as an
electric guitar) connected to your computer, on an audio track in the Tracks area. The
recording appears as an audio region on the selected audio track, showing an audio
waveform. You can arrange and edit audio regions in the Tracks area, and edit them in a
close-up view in the Audio Track Editor.
When you add a track, you can choose a patch for the track in the Library. You can quickly
audition patches to find the one you want to use, and change the effects for an audio track
by choosing a different patch. Each audio patch contains one or more audio effects, and
can include sends and other routing settings.
Logic Pro includes a metronome, which plays a steady beat to help you play in time while
recording. You can have the metronome play as you record, or only play a one-bar count-in
before recording starts.
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Add an audio track

1. In the Logic Pro toolbar, click the Add Tracks button

.

2. Click one of the two Audio icons at the top of the New Tracks dialog.
•

To create an audio track for recording from a microphone: Click the Microphone icon.

•

To create an audio track for recording a guitar or bass connected to your computer:
Click the Guitar icon.

3. If necessary, click the Details triangle to open the bottom of the dialog.
4. Choose the audio device and input channel (or stereo pair) from the Input pop-up menu
on the left.
5. Make sure that “Output 1-2” appears on the Output pop-up menu on the right.
6. Click Create.

Choose an audio patch

1. In the Logic Pro Library, click a category on the left.
2. Click a patch name on the right.
You can audition audio patches by clicking them, then playing your instrument, singing,
or making sound, to find the one you want to use. For more information about choosing
patches, see Patches overview.

Prepare for audio recording

Before you start recording audio in Logic Pro, do the following:
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•

Make sure that your microphone or instrument, and any other audio equipment you’re
using, such as an audio interface, is connected to the audio input on your computer,
and is working.

•

Make sure there is enough free storage space on your computer or connected storage
device.

•

Sing or play, and check the input level meter in the track header to be sure that the
track is receiving the audio signal.

•

To hear the sound from your microphone or instrument while you’re recording, click the
Input Monitoring button in the track header.
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Record on an audio track

1. In the Logic Pro track list, select the header of the audio track you want to record on.
2. Move the playhead to the point where you want to start recording.
3. Click the Record button

in the control bar (or press R) to start recording.

4. Start singing or play your instrument.
After a one-bar count-in, recording starts. The recording appears as a new audio region
on the track as you record.

5. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

You can record multiple takes simultaneously, and quickly create comps of the best
moments from each take. For more information about recording on an audio track, see
Recording overview and Record sound from a microphone or an electric instrument.
For information about connecting microphones and other audio devices, see Audio
devices overview.

Get started with Logic Pro software instrument tracks

If you have a USB or MIDI keyboard (or another type of MIDI controller) connected to your
computer, you can play and record software instruments. Logic Pro features a complete
library of professional-quality software instruments, including synthesizers and other
keyboards, guitars, drums, world instruments, and more.
A patch contains the instrument, effects, and routing settings that control the sound of the
track. You can change the sound of a software instrument track by choosing a different
patch from the Library. In the Library, you can also audition patches to find the one you
want to use.
You record a software instrument on a software instrument track in the Tracks area.
The recording appears as a MIDI region on the selected software instrument track. You
can arrange MIDI regions in the Tracks area, and edit them in the Piano Roll Editor and
other editors.
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Logic Pro includes a metronome, which plays a steady beat to help you play in time while
recording. You can have the metronome play as you record, or play only a one-bar count-in
before recording starts.

Play a software instrument

Select a software instrument track, then play notes on your music keyboard.
If your music keyboard has pitch bend and modulation wheels, move them as you play, to
see how the sound changes. If your music keyboard has other controls, such as faders,
knobs, or drum pads, try using them as well.

Add a software instrument track

1. In the Logic Pro toolbar, click the Add Tracks button

.

2. Click the Software Instrument icon at the top of the New Tracks dialog.

3. If necessary, click the Details arrow to open the bottom of the dialog.
4. Make sure that “A Software Instrument” appears on the pop-up menu on the left, and
“Output 1-2” appears on the Output pop-up menu on the right.
5. Make sure the Open Library checkbox is selected.
6. Click Create.
The new track appears in the Tracks area, and the Library opens on the left.

Choose a software instrument patch

In the Library, click a category on the left, then click a patch name on the right.
You can audition software instrument patches by clicking them in the Library, then playing
your music keyboard, to find the one you want to use. For more information about choosing
patches, see Patches overview.
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Record a software instrument

1. Select the software instrument track you want to record to.
2. Move the playhead to the point where you want to start recording.
3. Click the Record button

in the control bar (or press R) to start recording.

4. After a one-bar count-in, recording starts. The recording appears as a new software
instrument region on the track as you record.
5. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

For more information about recording software instruments, see Overview and Record
software instruments. For information about connecting a music keyboard, see MIDI
devices overview.

Get started with Logic Pro track header controls

Each track has a track header that shows the track name and icon, as well as a number of
track controls including Mute, Solo, and Record Enable buttons. Audio tracks also feature
an Input Monitoring button. The track headers are located along the left side of the Tracks
area, so you can easily see the mute, solo, and other settings for all tracks while working.
Some track header controls, including volume, pan, mute, and solo controls, correspond to
channel strip controls on the track’s channel strip in the Mixer—changing one (for instance,
dragging the Volume slider in a track header) produces a corresponding change in the
other (in this case, the Volume fader on the track’s channel strip).

Mute a track
•

In Logic Pro, click the track’s Mute button

Solo a track
•

In Logic Pro, click the track’s Solo button

in the track header.

in the track header.

The Solo button turns yellow, and the Mute buttons of all unsoloed tracks flash blue.
Click the button a second time to restore the track to its previous state.

Adjust a track’s volume level
•

In a Logic Pro track header, drag the Volume slider left to lower the volume level, or
drag it right to raise the volume level.
Option-click the slider to return it to a neutral level (0 dB gain).
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Adjust a track’s pan or balance position
•

In a Logic Pro track header, drag the Pan/Balance knob counterclockwise to pan to the
left, or drag clockwise to pan to the right. The dot on the wheel indicates the current
position.
Option-click the Pan/Balance knob to return it to the center position.
Note: You might have to resize the track header in order to see the Pan/Balance knob.

Change track buttons on multiple tracks
•

In Logic Pro, click and hold a button on a track header, then drag the pointer up or down
over additional tracks.
The corresponding buttons on all the swiped tracks switch to the same state.

For more information about working with tracks, see Tracks overview. For information about
using the track controls, see Track header overview.

Get started with patches

A patch contains the instrument, effects, Smart Controls, and routing settings that control
the sound of a track. You choose a patch in the Library, which applies those settings to
the selected track. You can try out different sounds for the track by choosing different
patches, as long as the patch is compatible with the track type.
Patches can include one or more channel strip settings, and can also contain routing
information (auxes) and metadata (for Smart Controls and controller mapping). Patches for
audio tracks can include default effects settings. Patches for software instrument tracks
include an instrument plug-in as well as effects settings.
You can choose a patch in the Library when you create a track, and choose a different
patch at any time while you’re working. The patches displayed in the Library depend on
the track type. For example, when an audio track or software instrument track is selected,
patches for that track type are available.

Choose a patch for the selected track
1. In Logic Pro, click the Library button
header) to open the Library.

in the control bar (or double-click the track

2. Choose a patch category from the list on the left, then choose a patch from the list on
the right.
You can quickly move through the patches in the list using the Up and Down Arrow keys.
You can search for patches by name in the Library, edit patches by changing channel
strip settings, adding plug-ins, or editing plug-in parameters, and save your own
custom patches.
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Get started arranging regions in Logic Pro

The Tracks area is where you arrange the recordings, Apple Loops, and other musical
material in your project, organizing them into sections such as intro, verse, and chorus
to build an arrangement. The Tracks area shows a visual representation of time moving
from left to right. You build a project by arranging regions in rows called tracks, that run
horizontally across the Tracks area.
Regions are the building blocks of a project, representing your recordings, Apple Loops,
and other media files you add to the project. Regions appear as rounded rectangles in the
Tracks area. There are several different types of regions, depending on the track type.
The two primary region types are audio regions, which show the audio waveform, and MIDI
regions, which show note events as thin rectangles.

You can arrange regions in a variety of ways in the Tracks area, by moving, looping,
resizing, splitting, joining, and deleting them. Try following the tasks below, using regions
in the project.

Move a region

In Logic Pro, do any of the following:
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Drag a region left or right to move it to a new time position.

•

Drag an audio region up or down to another audio track.

•

Drag a MIDI region up or down to another software instrument track.
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Resize a region

1. In the Logic Pro Tracks area, move the pointer over the lower-right edge of a region.
The pointer becomes a Resize pointer.
2. Drag the edge of the region horizontally to shorten or lengthen it.

Loop a region

1. In the Logic Pro Tracks area, place the pointer over the upper-right edge of the region.
The pointer becomes a Loop pointer.

2. Drag the right edge of the region several bars to the right.
When you drag the edge of the region out by its full length, rounded corners indicate the
beginning and end of each complete repetition of the region.

Split a region using the playhead

1. In the Logic Pro Tracks area, select the region you want to split.
2. Move the playhead over the point in the region where you want to split it, then choose
Edit > Split.

Only the selected region is split, even if an unselected region on another track is under
the playhead as well. If multiple regions are selected and are under the playhead, they are
all split.
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Split a region using the Scissors tool

1. In the Logic Pro Tracks area, select the region you want to split.
2. Select the Scissors tool, then click and hold the region.

The help tag shows the current split position.
3. Release the mouse button.
When selecting a cut point with the Scissors tool, you can move backward and forward in
steps of one division. The grid is based on the Snap pop-up menu setting. For information
about using Snap, see Snap items to the grid.

Delete a region
•

Select the region, then choose Edit > Delete (or press the Delete key).

For more information about arranging a project, see Arranging overview. For information
about working in the tracks area, see Tracks area overview.

Editing regions
Get started with the Logic Pro Piano Roll Editor

The Piano Roll Editor shows the notes in MIDI regions on a software instrument track as
colored bars in a time grid. On the grid, a note’s horizontal position indicates where the
note starts playing, while its vertical position indicates its pitch. A keyboard graphic along
the left edge of the Piano Roll Editor provides an easy guide to the pitches of notes.

On the left are controls for quantizing the timing and pitch of MIDI notes, and editing their
velocity. Along the top of the Piano Roll Editor, a ruler shows time divisions, based on the
time format chosen in the LCD. The header shows the name of the selected region, or the
number of regions (if more than one is selected), as well as the pitch and position of the
pointer in the region.
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Open the Piano Roll Editor
•

In the Logic Pro Tracks area, select a software instrument (or external MIDI instrument)
track, then click the Editors button .

Add a note
•

In Logic Pro, select the Pencil tool from the Tool menu, then click a position in the Piano
Roll Editor background.

Note: You can change the note length as you add a note, by holding down the mouse
button and dragging left or right.

Select a group of notes
•

In the Logic Pro Piano Roll Editor, drag over the keys on the keyboard graphic for the
notes you want to select.

Move notes
•

In the Logic Pro Piano Roll Editor, select one or more notes, then drag left or right.

Copy notes
•
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In the Logic Pro Piano Roll Editor, press and hold Option while dragging notes to a new
position.

44

Resize notes
•

In the Logic Pro Piano Roll Editor, position the pointer over the left or right edge of a
note, then drag horizontally.

While you drag, a help tag shows the precise end point and length of the note.
Tip: It might sometimes be difficult to grab the corner of very short notes. You can use
the Finger tool, which allows you to grab notes anywhere to alter their length, or zoom in
for a closer view.

Change the pitch of notes
•

In the Logic Pro Piano Roll Editor, drag notes up or down to a new pitch.

Edit the velocity of notes

In the Logic Pro Piano Roll Editor, do one of the following:
Select one or more notes, then drag the Velocity slider left or right.
Drag a note vertically with the Velocity tool.

A help tag indicates the velocity value of the note you clicked, with the value changing
as you drag. The color of the note event changes and the horizontal line inside the event
either lengthens or shortens.
For more information about working in the Piano Roll Editor, see Overview.
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Get started with the Logic Pro Audio Track Editor

The Audio Track Editor shows a close-up view of part of an audio track in the Tracks area,
displaying the audio waveforms of the regions on the track.
In the Audio Track Editor, you can move, trim, split, and join audio regions, play a region in
isolation, and edit regions in other ways. Edits you make in the Audio Track Editor are nondestructive, so you can always return to your original recordings.
You can edit the timing of individual notes, chords, or sounds in the Audio Track Editor
using Flex Time, and quantize and edit the pitch of audio material in the Audio Track
Editor using Flex Pitch. When you choose a Flex Pitch algorithm, the contents of the audio
track are analyzed for pitch, and the results are displayed as a pitch curve overlaid on
the waveform.

Open the Audio Track Editor

In Logic Pro, do one of the following:
•

Select an audio track, then click the Editors button

.

•

Double-click an audio region to open it in the Audio Track Editor.

The Audio Track Editor opens below the Tracks area. Along the top of the Audio Track
Editor is a ruler showing time divisions, based on the time format chosen in the LCD, and
a menu bar with local menus. The main area of the Audio Track Editor shows the audio
waveform of the regions in the selected audio track.
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Trim an audio region

1. In the Logic Pro Audio Track Editor, place the pointer over the lower-left or lower-right
edge of the region.
The pointer changes to a trim pointer.

2. Drag the pointer to trim the beginning or end of the region.

Split an audio region

In the Logic Pro Audio Track Editor, do one of the following:
•

Select the Scissors tool, then click the point where you want to split the region.

You can scrub regions to find the point where you want to cut by dragging across the
regions with the Scissors tool.
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•

Select the region, move the playhead over the time position where you want to split the
region, then choose Edit > Split.

Before moving or deleting a segment of a split audio region, click to select it.

Join regions

1. Select the split regions.
2. Do one of the following:
•

Choose Edit > Bounce and Join > Join.

•

Select the Glue tool, then click the selected regions.

Turn on flex in the Audio Track Editor

1. Open the Audio Track Editor by doing one of the following:
•

Select an audio track in the Tracks area, then choose View > Show Editors.

•

Select an audio track in the Tracks area, then click the Editors button
control bar.

•

Double-click an audio region.

2. Click the Flex button

in the

in the Audio Track Editor menu bar.

Note: Click the Audio Track Editor’s workspace before using the key command, to make
sure that the Audio Track Editor has key focus.
A Flex Mode pop-up menu appears to the right of the Flex button in the Audio Track
Editor menu bar.
3. Choose Flex Pitch or one of the Flex Time algorithms from the Flex Mode pop-up menu.

Change the pitch of a note

1. In the Logic Pro Audio Track Editor, turn on Flex, then choose Flex Pitch from the Flex
Mode pop-up menu.
2. Drag a note vertically to a new pitch.
For more information about working in the Audio Track Editor, see Overview.
For more information about Flex Time and Flex Pitch, see Flex Time and Pitch overview. You
can also open the Audio File Editor to make permanent (destructive) edits to the source
audio file for a region.
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Get started with Drummer in Logic Pro

Using Drummer, you can add a virtual drummer to your project. You can choose from
different genres, and choose different drummers in each genre. Each drummer has a
specific drum kit and playing style. You can choose a drummer preset, edit drum settings
to adjust the playing style, exchange drum kits, and choose individual drum sounds.
To work with Drummer, you add a Drummer track to the project. A Drummer track is similar
to a software instrument track, but it contains only Drummer regions, rather than MIDI
regions. Both track and region parameters can be edited in the Drummer Editor.

Add a Drummer track

1. In the Logic Pro toolbar, lick the Add Tracks button

.

2. Click the Drummer icon (the drum kit) at the top of the New Tracks dialog.

3. Click Create.
A Drummer track is added, along with one 8-bar region. The Library opens, and a
default patch is loaded to the track.
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Choose a genre and drummer

1. In the Logic Pro Library, click a genre.
The available drummers for the selected genre appear to the right of the genres.

2. Select a drummer.
A drummer card appears in the upper part of the Library, showing the drummer’s name
and a description of the drummer’s style.

Choose a different drummer preset

Each drummer includes a variety of presets, which appear on the left side of the
Drummer Editor.
•

In the Logic Pro Drummer Editor, click a preset.

A preset consists of a number of region settings, visible to the right of the presets area.

Play the selected Drummer region using the current preset
•
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In Logic Pro, click the Play button in the ruler at the top of the Drummer Editor.
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Adjust the complexity and loudness of a preset

In the Logic Pro Drummer Editor, reposition the puck in the XY pad.

The farther right you place the puck, the more complex the sound becomes; the higher you
place the puck, the louder the sound plays.

Choose a pattern variation for a drum or percussion instrument
In the Logic Pro Drummer Editor, do any of the following:
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•

For Tambourine, Shaker, and Handclap: Click an instrument, then drag the Percussion
slider or choose an increment.

•

For Cymbals, Toms, and Hi-Hat: Click a kit piece, then drag the kit piece slider or
choose an increment.
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•

For Kick and Snare: Drag the Kick & Snare slider or choose an increment.

Exchange a drum

1. In the Logic Pro Drummer Editor, click the plug-in button at the bottom of the
drummer’s card to open Drum Kit Designer.
2. Click a drum.
The Exchange panel opens to the left if exchange pieces are available for that kit piece.
3. Click the Info button of a selected kit piece to view its description.
4. Click the kit piece that you want to exchange in the Exchange panel. You may need to
scroll in order to find the one you want to use.
The piece is exchanged and the respective drum sound is loaded.
Note: The toms and crash cymbals can only be exchanged as a group.
5. Click anywhere in the plug-in window background to close the panels.

Edit other performance parameters

In the Logic Pro Drummer Editor, do any of the following:
•

Drag the Fills knob downward to reduce, or upward to increase, the number and length
of fills.

You can click the lock to prevent any changes to the fills setting when switching presets
or drummers.
•

Drag the Swing knob vertically to adjust the shuffle feel of the currently playing pattern.

You can click the lock to prevent any changes to the swing setting when switching
presets or drummers.
Logic Pro User Guide

52

•

Click the Details button to reveal the following knobs:

•

Drag the Feel knob to the right to have the drummer play ahead of the beat (Push),
or to the left to play behind the beat (Pull).

•

Drag the Ghost Notes knob to adjust the level of ghost notes—syncopated snare and
kick hits—in the beat.
Note: The presence of ghost notes depends on the chosen drummer and the
complexity setting.

•

Drag the Hi-Hat knob to adjust the degree to which the Hi-Hat is opened and closed
during the drum performance.
Note: This is relevant only if the Hi-Hat is selected in the drum kit representation.

Any changes or selections you make in the Drummer Editor affect only the selected
region, not the entire track. For more information about using Drummer in your projects,
see Overview.

Get started with Smart Controls in Logic Pro

Smart Controls let you quickly adjust the sound of a track, without having to edit channel
strip settings or open individual plug-in windows.
Each Smart Control includes a set of screen controls that you can adjust to control the
sound of the patch. Smart Controls typically include EQ or tone controls, reverb and other
effects controls, and controls specific to the type of track or instrument. For example, the
Smart Control for a synthesizer might include screen controls for choosing the waveform
and adjusting the resonance and filter cutoff, while one for a string instrument might
include controls for changing the articulation.

When you open the Smart Controls pane, you see the screen controls for the selected
track. Each screen control is labeled to make its function easy to understand.
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Open the Smart Controls pane
•

In Logic Pro, select a track, then click the Smart Controls button

in the control bar.

Manipulate screen controls

In the Logic Pro Smart Controls pane, turn the knobs, click the switches, and move the
other screen controls to see how they affect the sound of the patch.
Each screen control has a text label indicating what aspect of the sound it controls.
You can also change the layout for a Smart Control, save your own Smart Controls, map
screen controls to channel strip and plug-in parameters, and assign controllers on your
MIDI devices to screen controls. For more information about using Smart Controls, see
Overview of Smart Controls in Logic Pro.

Get started with Live Loops in Logic Pro

Live Loops makes it easy to improvise and create music like a DJ or electronic music
producer. With Live Loops, you can play, arrange, and record new musical ideas in real
time. Each musical phrase or loop exists in a cell in the Live Loops grid. You can start
and stop playback of cells freely, while keeping everything in sync with the beat and the
project tempo.
You can start using Live Loops with an empty grid, or choose a Live Loops template with
a set of instruments and prerecorded cells from the Project Chooser. You can also add
regions or loops from the Tracks area to the grid, and record a Live Loops performance to
the Tracks area.
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Show the Live Loops grid

In the Logic Pro Tracks area menu bar, click the Show/Hide Live Loops button

.

Create an empty Live Loops project

1. In Logic Pro, choose File > New (or press Command-N).
2. Click New Project, then click the Live Loops project icon.

Choose a Live Loops template

1. In Logic Pro, choose File > New (or press Command-N).
2. Click Templates and choose a Live Loops template from the list.
For more information about working with Live Loops, see the Live Loops overview.

Get started with mixing Logic Pro projects

Mixing a project involves balancing the different parts of the project and blending them into
a cohesive whole.
In the Mixer, each track has a channel strip that corresponds to its track type. You can
control the sound of the track using its channel strip controls, which include Mute and Solo
buttons, a Volume fader and level meter, a Pan/Balance knob, and others. You can also
add effect plug-ins, change plug-in settings, and control the signal flow using sends and
auxiliary (aux) channel strips.
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The channel strip for the currently selected track also appears in the lower-left part of the
inspector, along with the channel strip for its output. You can try out the following tasks
using either the inspector channel strips or the channel strips in the Mixer.

Open the Mixer

Click the Mixer button

in the control bar (or press X).

The Mixer opens below the Tracks area.
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Mute and unmute a channel strip
•

In the Logic Pro Mixer, click the channel strip’s Mute button (with an “M”).
Click the button again to unmute the channel strip.

Solo and unsolo a channel strip
•

In the Logic Pro Mixer, click the channel strip’s Solo button (with an “S”).
When you solo a channel strip, the Mute buttons of all unsoloed channel strips flash.
Click the button again to unsolo the channel strip.

Adjust track volume using a channel strip
•

In the Logic Pro Mixer, drag a channel strip Volume fader up or down.

Adjust track pan or balance using a channel strip
•

In the Logic Pro Mixer, drag the Pan control vertically.

Choose a channel strip setting
•

In the Logic Pro Mixer, click and hold the Setting button at the top of the channel strip,
then choose a setting from the pop-up menu.

Choose a different plug-in

In the Logic Pro Mixer, do one of the following:
•

Click the rightmost part of the Effect slot (with the Up and Down arrows), then choose a
plug-in from the pop-up menu.

•

Place the pointer above or below an existing slot, click the blue line that appears, then
choose a plug-in from the pop-up menu.

Open a plug-in window

In the Logic Pro Mixer, click the center area of a plug-in slot.

For detailed information about mixing a project, see Mixing overview. For more information
about channel strip controls, see Channel strip controls.
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Get started with Apple Loops in Logic Pro

Apple Loops are prerecorded musical patterns that you can use to quickly add drum beats,
rhythm parts, and other musical phrases to a project. Apple Loops contain musical patterns
that can be repeated over and over, seamlessly. After you add a loop to the Tracks area,
you can extend it to fill any amount of time. When you add an Apple Loop to a project, it
automatically matches the project tempo and key.
Apple Loops are available in a variety of instruments, genres, and moods in the
Loop Browser.

There are three types of Apple Loops:
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•

Audio Apple Loops: You add audio loops to audio tracks, and edit them like other
audio regions.

•

Software Instrument Apple Loops: You add software instrument loops to software
instrument tracks, and edit them like other MIDI regions.

•

Drummer Apple Loops: You can add Drummer loops to Drummer tracks, and then
change the artist and edit parameters in the Drummer Editor. You can also convert
Drummer loops to software instrument loops by adding them to software instrument
tracks, or convert them to audio loops by adding them to audio tracks.
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Open the Loop Browser
•

In Logic Pro, click the Loop Browser button

in the control bar (or press O).

Browse for loops
•

In the Logic Pro Loop Browser, click the Button View button, then click keyword buttons
to see matching loops in the results list. Keywords with no matching loops are dimmed.

Preview loops
•

In the Logic Pro Loop Browser, click a loop in the results list.

You can adjust the preview volume, and choose a different key for the loop.
To stop preview playback, click the loop again.
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Add a loop to the Tracks area

In Logic Pro, do one of the following:
Drag the loop to a track of the same type to add it to that track.
Drag the loop to an empty part of the Tracks area to create a new track with the loop.

After you add the loop to the Tracks area, you can drag it left or right to adjust the point
where it starts playing.
You can also search for loops by name, key, or time signature. For more information about
using Apple Loops in your projects, see Apple Loops in Logic Pro.

Get started with Smart Tempo

With Smart Tempo you can record a performance without the metronome and have Logic
Pro adapt the project tempo to match the tempo of the recording, or keep the project
tempo and flex the recording to match it. You can create remixes using audio files and MIDI
regions with different tempos that all conform to the project tempo, or adapt the project
tempo to the tempo of an imported audio file or MIDI region. You can also use Smart Tempo
with multitrack audio recordings.
To use Smart Tempo, you choose the Project Tempo mode to set the overall tempo
behavior for the project, and choose the Flex & Follow setting for individual audio regions
to set how they interact with the chosen Project Tempo mode.

Choose the Project Tempo mode

In the Logic Pro LCD, click the middle of the Tempo display, then do one of the following:

•

To maintain the project tempo: Choose Keep Project Tempo from the pop-up menu.

•

To adapt the project tempo to the tempo of a recording or imported audio file: Choose
Adapt Project Tempo from the pop-up menu.

•

To have Logic Pro choose the project tempo behavior: Choose Automatic Mode from the
pop-up menu.

You can set the default Project Tempo mode for a project in the Smart Tempo
project settings.
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Choose the Flex & Follow setting for an audio region
1. In the Logic Pro Tracks area, select the audio region.

2. In the Region inspector, select one of the following from the Flex & Follow pop-up menu:
•

Off: The region doesn’t follow changes to the project tempo, and isn’t Flex enabled.

•

On: The region is Flex enabled, so it follows any manual Flex edits. It also follows any
changes to the project tempo.

•

Bars (On + Align Bars): The region is Flex enabled, and Smart Tempo beat markers
are used to conform the region to the project tempo at every downbeat (bar).
Because the region is conformed to each bar, the 1/1 setting is not available in the
Quantize menu.

•

Beats (On + Align Bars and Beats): The region is Flex enabled, and Smart Tempo
beat markers are used to conform the region to the project tempo at every beat.
Because the region is conformed to each (1/4-note) beat, the 1/1, 1/2, 1/4 settings
aren’t available in the Quantize menu.

You can view and edit Smart Tempo analysis results in the Smart Tempo Editor, including
markers and other tempo information. After you record an audio or MIDI region or import a
file using Smart Tempo, you can refine the tempo analysis and correct any tempo detection
errors to define the musical intent more accurately. When Adapt is the Project Tempo
mode, tempo and time signature changes are transferred to the project tempo and time
signature tracks.
You can set the default Flex & Follow settings for audio recordings and imported audio files
in the Smart Tempo project settings.
You can view and edit Smart Tempo analysis results in the Smart Tempo Editor, including
beat markers and other tempo information. After you record an audio or MIDI region or
import a file using Smart Tempo, you can refine the tempo analysis and correct any tempo
detection errors to define the musical intent more accurately. When you open the Smart
Tempo Editor, the audio file or MIDI region is displayed along with the tempo analysis
results. You can make quick tempo, beat, and timing adjustments, or make more complex
edits to the tempo information for a single beat, a selection, or the entire file or region.
For more information about using Smart Tempo, see Smart Tempo overview. For more
information about the Smart Tempo Editor, see Work in the Smart Tempo Editor.

Get started sharing Logic Pro projects

You can share a project to the Music app to play. If you have a SoundCloud account,
you can share a project to SoundCloud, choose the quality and visibility level, and set
permissions for the shared project from within Logic Pro.

Share the project to the Music app

1. In Logic Pro, choose File > Share > Song to Music.
2. To rename the shared file, select the name in the Title field, then enter a new name.
3. Type artist, composer, and album information for the shared file in the respective text
fields.
4. Choose the quality level for the shared file from the Quality pop-up menu.
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5. To export only part of the project, select the “Export cycle region only, or length of
selected regions” checkbox.
6. Click Share.
When you share a project to the Music app, the entire project, from the beginning to the
end of the last region, is exported. Any silence at the beginning or end of the project is
trimmed. If Cycle mode is on when you share the project, the part of the project between
the start and end of the cycle region is exported.
The shared project appears in the Music app, where you can add it to playlists, convert it,
or burn it to a CD.

Share a project to SoundCloud

1. In Logic Pro, choose File > Share > To SoundCloud.
2. If you aren’t currently logged in to your SoundCloud account, enter your email address
and password, then click Connect.
Alternatively, you can log in to your Facebook account.
3. In the Share to SoundCloud dialog, do the following:
•

To sign in to a different SoundCloud account, click Change, then enter the login
information for the account.

•

To share the current project, select Bounce as the Source.

•

To share an audio file, select File as the Source, click Browse, then browse to the
location of the file.

•

Type title, artist, composer, and album information for the project in the respective
text fields.
Projects must have a title in the Title field. The remaining information is optional.

•

Choose the quality level for the project from the Quality pop-up menu.

•

Choose the visibility level for the project from the Visibility pop-up menu.

•

Set download and streaming permissions for the project in the Permissions section.

4. Click Share.
To return to Logic Pro without sharing the project, click Close.
You can also burn a project to a CD or DVD and share projects in other ways. For details
about sharing your projects, see Sharing overview.
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Logic Pro basics

What is Logic Pro?

Logic Pro is a powerful, full-featured music app with all the tools you need to create
professional-quality music productions. You can record, arrange, and edit audio and MIDI
regions, add high-quality effects, mix your music in stereo or surround, and export the final
mix in a variety of formats for distribution.
Using Logic Pro you can create many different kinds of projects, from simple songs to
complex ensemble arrangements. Logic Pro gives you the flexibility to customize the app
to suit your way of working.
Some of the things you can do in Logic Pro include:
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•

Record vocals, instruments, or any sound that can be captured by a microphone,
including recording takes and comps.

•

Play and record the software instruments included with Logic Pro using a USB keyboard
or other MIDI controller. You can also play and record third-party Audio Units software
instruments.

•

Add virtual drummers to your projects to create detailed, realistic virtual drum
performances that adjust dynamically to the genre, the content of the project, and other
parameters.

•

Add Apple Loops and other media files to your projects.
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•

Arrange regions containing your musical material in the Tracks area. You can also define
sections of the project and quickly rearrange them using arrangement markers.

•

Edit audio and MIDI regions using a set of editors optimized for different tasks and
region types.

•

Edit the timing and pitch of audio regions, and of individual notes, chords, and sounds.

•

Mix your project in the Mixer, where you can view and edit channel strip controls,
customize routing options, and add and edit plug-ins.

•

Automate changes over time for mix, effects, and plug-in settings using total recall mix
automation. You can record automation changes in real time and edit them later.

•

Control global settings including tempo, transposition, and time and key signature to
shape the overall project. Use markers to define and quickly move to different sections
of a project.

•

View MIDI regions in a project as music notation, add and edit notes and other musical
symbols, and print the finished score as well as individual parts.
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Logic Pro interface overview
Logic Pro main window interface

You create and play projects in the Logic Pro main window. The main window is organized
into different areas to help you focus on different aspects of your project, such as
recording, arranging, and mixing. Buttons in the control bar show or hide different areas
of the app.

The main areas of the Logic Pro window include:
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•

Tracks area: Where you record audio and MIDI regions, add Apple Loops and other
media files, and arrange the regions to build your project.

•

Control bar: Includes the transport controls you use to control playback of your project,
buttons to show and hide the different areas of Logic Pro, and buttons for other
frequently used commands. You can customize the control bar to suit your way of
working.

•

Toolbar: Contains additional buttons and controls for the Tracks area and other areas of
Logic Pro. You can show and hide the toolbar to optimize available screen space.

•

Inspector: Shows parameters for selected regions, tracks, and other items. The
available parameters change depending on the area in which you are working, and what
type of item is selected.
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•

Smart Controls: A simplified set of visual controls that you can use to quickly modify
the sound of the current patch without having to edit individual channel strip or plug-in
settings.

•

Mixer: Shows channel strips for each track in the project, as well as auxiliary, output,
and master channel strips. You can view and edit channel strip controls, customize
routing options, and add and edit plug-ins in the Mixer.

•

Editors: Logic Pro features a set of editors, including the Audio Track Editor, Piano Roll
Editor, Score Editor, Step Editor, and Audio File Editor, which you use to make precise
changes to individual regions and their contents.

•

List Editors: An area where you can view and edit MIDI events, markers, tempo, and time
signature events numerically.

•

Note Pad: Features text areas where you can create, view, and edit project and track
notes.

•

Loop Browser: Gives you access to the included Apple Loops library so you can search
for loops and preview them, then add them to your project.

•

Browsers: You can view the audio files in your project in the Project Audio Browser and
browse your computer and connected storage devices using the All Files Browser.

You can show or hide different areas as part of the main window. Some can also be opened
as separate, movable windows. You can also open multiple instances of the main window,
and configure each one differently.

Open an instance of the Logic Pro main window
•

Choose Window > Open Main Window (or press Command-1).

Logic Pro Tracks area interface

The Tracks area is the primary workspace in Logic Pro, where you record and arrange audio
and MIDI regions to create your project. The main elements of the Tracks area include:
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•

Tracks area menu bar: Contains local Tracks area menus as well as tool menus, controls
for showing track automation and Flex edits, a Catch Playhead button, Snap and Drag
pop-up menus, a Waveform Zoom button, and scroll and zoom sliders.

•

Ruler: Shows divisions of time, either in bars and beats or in hours, minutes, and
seconds. The ruler lets you align items in the Tracks area and mark project sections,
and has additional uses for various playback and recording tasks.

•

Track headers: Each track has a header that shows the track name and icon, and
includes controls for muting and soloing the track, arming the track for recording, and
other functions.

•

Workspace: All audio and MIDI regions appear on horizontal lanes called tracks,
aligned to time positions in a grid. The workspace is the primary area for recording and
arranging audio and MIDI regions.

•

Playhead: The thin vertical line extending from the top to bottom of the Tracks area, the
playhead shows the part of the project currently playing or where playback starts. You
can use the playhead to help align regions and other items, and for editing tasks, such
as splitting regions.

For information about working in the Tracks area, see Tracks area overview.

Logic Pro Library interface

You can view available patches for the currently selected track, and choose a new patch,
in the Library. Categories appear on the left, and patches for the selected category are
displayed on the right. You can search for patches, create, save, and delete patches, and
choose routing options.
You can view all available patches for the track, or view only patches for a particular
sound pack.
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When a Drummer track is selected, you can choose drum genres and drummers in the
Library, which apply to all regions in the Drummer track. You can choose preset settings for
the selected drummer from the left side of the Drummer Editor.

•

Track icon: The icon for the selected track is displayed in the upper part of the Library.

•

View pop-up menu: Choose which patches to display. You can display all available
patches, or filter patches by sound pack.

•

Search field: Quickly search for patches by name.

•

Category and Patch lists: Select a category on the left, then select a patch on the right.

•

Options pop-up menu: Define the default patch and merge patches.

•

Revert button: Revert to the saved settings for a patch, erasing any changes you have
made.

•

Delete button: Delete a saved patch.

•

Save button: Save the patch with its current settings as a new custom patch.

You can also access the following file types in the Library, when the corresponding item
is selected:
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•

Channel strip settings (.cst)

•

Plug-in presets (.pst)
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•

Sampler instruments (.exs)

•

Environment instruments, and programs or banks of MIDI instruments created in the
Audio MIDI Setup utility

Open the Library

Do one of the following:
Click the Library button

in the control bar.

Choose View > Show Library.
For information about using the Library, see Patches overview.

Logic Pro Inspector interface

You can view and edit parameters for regions, tracks, and other items in the various
inspectors. The parameters displayed depend on the type of item selected, and which
working area has key focus. When you’re working in the Tracks area, the inspector displays
region and track parameters and the inspector channel strips, as shown below:
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•

Region inspector: View and edit playback parameters, including transposition and
quantization, for selected regions. Region parameters affect the playback of regions,
but don’t alter the data in the region itself. If you change region parameters while the
project is playing, you hear the changes immediately.

•

Track inspector: View and edit various track parameters, including transposition,
velocity, and delay. All regions on the track are affected by the track parameters.

•

Inspector channel strips: The left channel strip is the channel strip for the selected
track. The right channel strip shows the output for the left channel strip by default,
but can also show an aux used by the left channel strip (if one exists). You can adjust
the level, pan, sends, and inserts, change effects, and control audio routing for these
channel strips without opening the Mixer.

Inspectors for other working areas, such as the Event inspector, Display Parameters
inspector, and Score inspector are described in their respective chapters.

Open the inspector

Do one of the following:
Click the Inspector button

in the control bar.

Choose View > Show Inspector (or press I).

Open the Region inspector as a separate window
Press Option-R.

Logic Pro Mixer interface

The Mixer shows the channel strips for every track in your project, including auxiliary
and output channel strips, and the master channel strip. This makes it easy to see and
adjust relative levels and pan (balance) positions. You can also add effects, mute and solo
tracks, use busses and sends to control the signal flow, and use groups to control multiple
channel strips.
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•

Channel strips: Use to process audio or MIDI information that is routed from tracks.

•

Channel strip controls: Adjust the level and other aspects of the audio signal played
through the channel strip.
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•

View buttons: Use to switch between Single, Tracks, and All views, limiting the Mixer
view to channel strips required for the task at hand.

•

Filter buttons: Use to limit the channel strips displayed in the Mixer to specific types.

Open the Mixer

Do one of the following:
Click the Mixer button

in the control bar.

Choose View > Show Mixer (or press X).

Open the Mixer as a separate window

Choose Window > Open Mixer (or press Command-2).
For more information about the Mixer, see Mixing overview. For information about using
channel strip controls, see Channel strip controls.

Logic Pro Smart Controls interface

Smart Controls let you quickly view and adjust the most important parameters of the
selected track, without opening the Mixer or individual plug-in windows. Each Smart
Control features a set of screen controls. Adjusting a single screen control can modify one
or more channel strip or plug-in parameters for the track.

•

Smart Control inspector: Choose a different layout, view existing mappings, map screen
controls to parameters, and assign hardware controllers to screen controls.

•

Screen controls: Visual controls that modify aspects of the sound of the track. Each
Smart Control has a set of screen controls optimized for the type of track or instrument.
Screen controls are labeled to make their functions easier to understand.

Open the Smart Controls pane
Do one of the following:

Click the Smart Controls button

in the control bar.

Choose View > Show Smart Controls.

Open the Smart Controls as a separate window
Choose Window > Open Smart Controls.

For information about working with Smart Controls, see Overview of Smart Controls in
Logic Pro.
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Editors
Logic Pro Audio Track Editor interface
The Audio Track Editor displays the audio waveform of the region on an audio track. In the
Audio Track Editor, you can copy, paste, move, trim, split, and join audio regions. Using the
Audio Track Editor grid, you can precisely align edits with specific points in time.

•

Audio Track Editor menu bar: Contains menus with region editing commands and
functions, as well as buttons for Flex editing, selecting editing tools, and zooming the
editor.

•

Audio Track Editor inspector: When Flex Pitch is turned on, contains controls for
quantizing time and pitch, correcting pitch, and adjusting gain.

•

Waveform display: Shows the audio waveform for the region on a time grid.

•

Ruler: Shows time divisions so you can align regions and make edits at precise time
positions.

•

Playhead: Reflects the current playback position.

When Flex Pitch is turned on, you can quantize the timing and pitch of audio regions, and
adjust their pitch and gain in the Audio Track Editor inspector. All edits in the Audio Track
Editor are non-destructive, so you can always return to your original recordings.

Open the Audio Track Editor
Do one of the following:

Double-click an audio region in the Tracks area.
Select an audio track, then click the Editors button

in the control bar.

Select an audio track, then choose View > Show Editors.
For more information about using the Audio Track Editor, see Overview. For information
about making Flex Time and Flex Pitch edits, see Flex Time and Pitch overview.
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Logic Pro Piano Roll Editor interface
The Piano Roll Editor shows notes in MIDI regions as rectangles on a time grid. The position
of each note on the grid shows the time position where it starts playing, its duration
(length), and pitch. Note velocity is indicated by color.
You can edit individual notes by moving them, resizing them, dragging them vertically to
change their pitch, and in a variety of other ways.

•

Piano Roll Editor menu bar: Contains menus with region editing commands and
functions, as well as buttons for viewing automation, activating MIDI input and output,
selecting editing tools, and zooming the editor.

•

Piano Roll Editor inspector: Contains controls for quantizing note timing and adjusting
note pitch and velocity.

•

Display area: Shows the notes in the MIDI region or regions as bars on a time grid.

•

Ruler: Shows time divisions so you can align and edit notes at precise time positions.

•

Playhead: Reflects the current playback position.

Open the Piano Roll Editor
Do one of the following:

Double-click a MIDI region in the Tracks area.
You can change this default behavior for opening the Piano Roll Editor in Logic Pro >
Preferences > General.
Select a software instrument or external instrument track, then click the Editors button
the control bar.

in

Select a software instrument or external instrument track, then choose View >
Show Editors.

Open the Piano Roll Editor as a separate window

Choose Window > Open Piano Roll (or press Command-4).
For more information about using the Piano Roll Editor, see Overview.
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Logic Pro Drummer Editor interface
If you add a Drummer track to a project, you can view and edit Drummer track and region
parameters in the Drummer Editor.
The Drummer Editor shows settings for the selected Drummer region, including presets, an
XY pad for adjusting the complexity and loudness of the region performance, and controls
for editing performance parameters, including kit piece pattern variations and fill settings.
You can view and select a genre to view drummers for that genre, and then select a
drummer, in the Library when a Drummer track is selected.

•

Genres and drummers: Select a genre to view the drummers for that genre, then select
the drummer for the track.

•

Drummer presets: Choose a preset for the selected Drummer region. A preset consists
of all region settings, visible to the right of the presets area. You can use the default
settings, or you can edit them and save your own presets.

•

XY pad: Adjust the complexity and loudness of the region performance.

•

Drum kit controls: Turn on different instruments, and choose between different
variations for the drum and percussion pieces. You also have the option to play half time
or double time for kick and snare.

•

Performance controls: Adjust the number and length of fills using the Fills knob. Adjust
the shuffle feel of the region performance using the Swing knob. Click the Details
button to reveal additional performance controls.

Open the Drummer Editor
Do one of the following:

Double-click a Drummer region on a Drummer track.
Select one or more Drummer regions on a Drummer track, then click the Editors button
in the control bar.
Select a Drummer track, then click the Editors button

.

The Drummer Editor opens below the Tracks area.
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Logic Pro Score Editor interface
The Score Editor displays MIDI regions as music notation, including notes, rests, and other
MIDI events such as sustain pedal markings. You can add and edit notes and other musical
symbols. Lyrics, titles, and other text can also be included in the score. You can control the
display of individual staffs, extract parts from the score, modify the overall score layout,
and print or export complete scores, partial scores, and parts.

•

Score working area: Displays music notation for selected MIDI regions, tracks, or the
entire project.

•

Region inspector: Choose visual quantization and other display settings for selected
regions.

•

Event inspector: Control appearance and position settings for individual notes and other
items in the score.

•

Part box: Displays available musical symbols, organized in groups. Select musical
symbols to add to the score, and customize the order of symbols in the Part box.

Open the Score Editor

Double-click a MIDI region in the Tracks area, then click Score.

Open the Score Editor as a separate window

Choose Window > Open Score Editor (or press Command-5).
For more information about using the Score Editor, see Overview.
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Logic Pro Step Editor interface
The Step Editor displays notes or controller events for selected MIDI regions as beams in
a user-defined time grid. You can easily add or edit note velocities or other controller data
(making some editing tasks, such as data scaling, much faster), or quickly create and edit
MIDI drum parts.

•

Lane parameters: Determine the type of event displayed or modified. When you select a
row in the name column, its event definition is shown in the Lane inspector.

•

MIDI events: Represented by vertical beams in a time grid. Controller values, note
velocity, and other values are indicated by the height of each beam (taller beams
indicate higher values).

Open the Step Editor

Choose Window > Open Step Editor.
For more information about using the Step Editor, see Step Editor overview.

Logic Pro Audio File Editor interface
The Audio File Editor displays the audio waveform of regions on an audio track. In the Audio
File Editor, you can destructively edit audio files (and regions), and use audio processing
tools to quantize audio, change sample rates, and extract MIDI grooves from audio files.
The Audio File Editor is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
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The Audio File Editor has its own ruler, playhead, and Zoom slider.
•

Ruler: Indicates the position and length of the region selected in the Tracks area, or in
the Project Audio Browser.

•

Info display: Displays the start point and length of the selected area.

•

Waveform overview: Displays a miniature view of the entire audio waveform.

•

Waveform display: Provides a detailed view of the area selected in the waveform overview.

•

Playhead: Reflects the current playback position.

•

Anchor: Displays the absolute start point of the audio file.

•

Region area: Edit this beam to adjust the region length.

Open the Audio File Editor
Do one of the following:

Select an audio region, then choose Window > Open Audio File Editor (or press
Command-6).
Option-double-click an audio region in the Project Audio Browser.
For more information about using the Audio File Editor, see Audio File Editor overview.

Note Pads
Logic Pro project notes interface
You can create, view, and edit notes for a project in the Project Notes pane. Each Logic Pro
project can contain one set of project notes. You can type text notes in the Project Text
area, and add images by dragging them into the note.
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•

Project Text area: View and edit project notes in the Project Text area.

•

Project Text Edit button: Use to add or edit project-specific text in the Project Text area.
You can also double-click the Project Text area.

Open the Project Notes pane
Do one of the following:

Click the Note Pads button

in the control bar.

Choose View > Show Note Pads.

Logic Pro track notes interface
You can create, view, and edit notes for each track in the Track Notes pane. You can type
text notes in the Track Text area, and add images by dragging them into the note.
•

Track Text area: View and edit notes for the selected track in the Track Text area.

•

Track Text Edit button: Use to add or edit track-specific text in the Track Text area. You
can also double-click the Track Text area.

Open the Track Notes pane
Do one of the following:

Click the Note Pads button

in the control bar, then click Track.

Choose View > Show Note Pads, then click Track.
For more information about track notes, see Add track notes in the Mixer.
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List Editors
Logic Pro Event List interface
The Event List shows all the events in your project, such as MIDI note events or region start
events, in a vertical list format. You can use it to make precise edits, and for other tasks
better suited to numeric rather than graphic edits. You can display all events or limit them
by category.
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•

Display Level button: Click to move up one display level in the Event List. This view lets
you see all regions in the current project.

•

Add Event button and Type pop-up menu: Add an event, and choose the type of event
to add.

•

MIDI In/MIDI Out buttons: Click MIDI In to input notes directly to the Event List. Click
MIDI Out to hear the output of MIDI data in the Event List.

•

Event Type buttons: Click to show or hide specific event types.

•

List area: Shows the list of events or regions, organized in columns.

79

Open the Event List

Do one of the following:
Click the List Editors button

in the control bar, then click Event.

Choose View > Show List Editors, then click Event.

Open the Event List as a separate window

Choose Window > Open Event List (or press Command-7).
For more information, see Event List overview.

Logic Pro Marker List interface
The Marker List displays all the markers in the project. You can create, select, and edit markers
in the Marker List, and click a marker name to move the playhead to that marker position.
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•

Create button: Creates a marker at the playhead position.

•

Marker List area: Lists all the markers in your project, showing the name, bar position,
and length of each marker. Drag vertically in the Position column to edit a marker’s
position, or double-click and enter a new value.
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•

Marker Text Area button: Shows or hides the Marker Text area. Use this area to enter or
edit text for the selected marker.

•

Marker Text area: Enter text for the selected marker by double-clicking the area or
clicking the Marker Text Area button.

•

Marker Set pop-up menu: Choose the marker set to view and edit.

Open the Marker List

Do one of the following:
Click the List Editors button

in the control bar, then click Marker.

Choose View > Show List Editors, then click Marker.
For more information, see Markers overview.

Logic Pro Tempo List interface
The Tempo List displays all the tempo events in the project, and lets you create and edit
tempo events.
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•

Create button: Click to create a new tempo event.

•

Tempo List area: Displays all tempo changes, and their position in a project.

•

Tempo Set pop-up menu: Choose the tempo set to view and edit.

Open the Tempo List

Do one of the following:
Click the List Editors button

in the control bar, then click Tempo.

Choose View > Show List Editors, then click Tempo.
For more information, see Tempo List overview.

Logic Pro Signature List interface

The Signature List shows all the time and key signature changes in your project, as well as
any score symbols in the project score. You can create, copy, move, and delete time and
key signature events in the Signature List.
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•

Create button: Click to create a new signature event.

•

Signature List area: Displays all time and key signature changes, and their position in
a project.
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•

Signature Set pop-up menu: Choose the signature set to view and edit.

Open the Signature List
Do one of the following:

Click the List Editors button

in the control bar, then click Signature.

Choose View > Show List Editors, then click Signature.
For more information, see Time and key signature overview.

Logic Pro Loop Browser interface

The Loop Browser makes it easy to find Apple Loops and add them to your project. You can
browse for loops or search using various criteria, preview matching loops, and add them to
your project by dragging them into the Tracks area.
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•

View buttons: Switch between column view, button view, and sound effects view.

•

View pop-up menu: Choose which loops to display. You can display all available loops,
or filter loops by Jam Pack or the user’s loop library.

•

Search field: Type text to search for loops by name.

•

Keyword buttons: Filter loops by clicking keyword buttons. Matching loops appear in the
results list below.

•

Category columns: Filter loops by choosing categories and subcategories from left to
right. Matching loops appear in the results list below.

•

Results list: Displays all loops that match the search criteria. Click a loop to preview it,
and drag a loop from the results list into the Tracks area to add it to your project.

•

Volume slider: Adjusts the volume of loops you are previewing.
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Open the Loop Browser
Do one of the following:

Click the Loop Browser button

in the control bar.

Choose View > Show Apple Loops.
For more information about using the Loop Browser, see Apple Loops in Logic Pro.

Browsers
Logic Pro Project Audio Browser interface
The Project Audio Browser shows the audio files used in the project, and displays an
overview of the regions derived from each audio file. You can add, edit, delete, and rename
audio files and regions in the Project Audio Browser.
The Project Audio Browser is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
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•

File path: Shows the location of the audio file.

•

Name column: Displays audio files by name. Click the disclosure arrow to the left of an
audio file to reveal regions associated with the file.

•

Icon column: Displays icons to indicate missing or timestamped files, files that follow
the project tempo, or files that contain tempo information.

•

Info column: Shows sample rate, bit depth, input format, and file size details. Also indicates
file length using horizontal bars. Colored sections indicate the location and size of
regions within the audio file. The Info column can also display waveform overviews.

•

BPM column: Shows the original tempo of audio files.

•

Play button: Plays the selected audio file or region. Click again to stop playback.

•

Cycle button: Loops playback of the selected audio file or region. Use in combination
with the Play button.

•

Volume slider: Sets the playback volume.

Open the Project Audio Browser
Do one of the following:

Click the Browsers button

in the control bar, then click Project.

Choose View > Show Browsers, then click Project.

Open the Project Audio Browser as a separate window

Choose Window > Open Project Audio (or press Command-8).
For more information about using the Project Audio Browser, see Project Audio
Browser overview.
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Logic Pro All Files Browser interface
The All Files Browser is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced. Browse with the All Files Browser to locate all the file
types that you can use in a Logic Pro project.

The All Files Browser displays the following file types found on your computer or any
connected storage device:
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•

Logic Pro project files (including projects created with previous versions of Logic Pro)

•

GarageBand projects

•

Audio files

•

QuickTime movies

•

All file formats that can be imported into a Logic Pro project
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The All Files Browser includes the following features and controls:
•

Back and Forward buttons: Move back and forward through previously viewed levels of
the folder hierarchy.

•

Computer, Home, and Project buttons: Choose the location to browse for files.

•

View buttons: Switch the file list between List view and Column view.

•

Search field: Search for files by name. Click the plus button to display additional search
filters that allow you to narrow your search further. Results are displayed in the File list
below.

•

Search filters: Narrow your search according to specific file types, file formats, length,
date, size, and other criteria.

•

File list: Shows folders and files at the current location, or folders and files that match
the search criteria.

•

Action pop-up menu: Use to add a selected audio file to the Project Audio Browser,
show the file location in the Finder, use Quick Look, or create a new folder.

•

Play button: Plays the selected file. Click again to stop playback.

Open the All Files Browser
Do one of the following:

Click the Browsers button

in the control bar, then click All Files.

Choose View > Show Browsers, then click All Files.

Logic Pro project basics

You start working in Logic Pro by creating a new project, or opening an existing one. A
project is the document that contains all your recordings, the location of media files you
add, and all the changes you make. You can have multiple projects open at the same time,
and transfer media and other data between them.
Each project has a set of properties, including tempo, key, and time signature, which you
define when you create the project, and change later while you’re working. Projects can
also contain assets including audio files, a movie file, instruments, and other files. You can
save assets with the project or reference them in another location.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can save a project as either a single file (package), or as a project folder containing the
project file and subfolders for project assets.
For more information about working with projects, see Projects overview. For information
about creating Logic Pro projects, see Create projects.
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The basic elements of a Logic Pro project include the following:

Tracks

The horizontal rows in the Tracks area are called tracks. Tracks help you organize and
control the sound of the recordings, loops, and other material in a project. You record
your performances on tracks, and arrange the representing the recordings, loops, and
other material in a project on tracks. There are several types of tracks you can use in a
Logic Pro project:

•

Audio tracks: Can contain audio recordings, audio Apple Loops, and imported audio
files.

•

Software instrument tracks: Can contain software instrument recordings, software
instrument Apple Loops, and imported MIDI files.

•

Drummer tracks: Can contain Drummer regions. Used in conjunction with the Drum Kit
Designer plug-in and Drummer Editor. You can also add MIDI regions to a Drummer
track.

•

External MIDI tracks: Can contain MIDI recordings that send MIDI data to external MIDI
devices, such as synthesizers and sound modules.

•

Track Stacks: Track Stacks let you organize and control multiple tracks, and create
audio subgroups.

•

Folder tracks: Can contain folders, which are containers for other tracks. Folder tracks
are not assigned to a channel strip in the Mixer.

There are additional track types that do not contain regions, including auxiliary (aux) and
output tracks, used for routing the output of other tracks; global tracks, used to control
aspects of the overall project; and the master track, which you can use to control the
overall volume level of the project.
For more information about working with tracks, see Tracks overview. For information about
working in the Tracks area, see Tracks area overview. For information about working with
global tracks, see Global tracks overview.
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Regions

Regions are the building blocks of a project. Each time you make a recording, drag an
Apple Loop to the Tracks area, or add a media file to your project, a region representing
the recording or file appears in the Tracks area. Different types of regions correspond to
different track types and types of material.

•

Audio regions refer to (point to) an underlying audio file (a recording made in Logic Pro,
an audio Apple Loop, or an imported audio file). An audio region can represent the
entire audio file or only a portion of one. When you edit the region in the Tracks area or
the Audio Track Editor, the original audio file is not changed.

•

MIDI regions contain MIDI data for notes and other MIDI events, such as controller and
program change information. They are stored as part of the project, but can also be
saved as individual files.

In the Tracks area, you can move, copy, and work with both audio and MIDI regions in a
variety of ways to build your arrangement. You can also edit audio regions in the Audio
Track Editor, and edit MIDI regions in the Piano Roll Editor (and the Score Editor).
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can edit the source audio files for audio regions in the Audio File Editor.
For more information about arranging regions in the Tracks area, see Arranging overview.
For information about editing audio regions in the Audio Track Editor, see Overview. For
information about editing MIDI regions in the Piano Roll Editor, see Overview.
For more information about working with regions, see Regions overview.

Patches

You can control the sound of the tracks in your project using patches. A patch can contain
one or more channel strips, each with its own settings and plug-ins, as well as a set of
Smart Controls. Patches can also contain auxiliary channel strips for more complex routing.
You can choose a patch for a track in the Library when you create the track, and choose a
different patch later while you’re working. Custom patches can be saved in the Library.
For more information about working with patches, see Patches overview.
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Channel strips

Each track in a project is represented and controlled by a channel strip corresponding to
the track type. Channel strips contain controls to adjust the volume level and pan position
of the track, mute and solo the track, insert plug-ins, route the output signal, and control
the track in other ways.
You can view and edit the channel strips for a project in the Mixer. The inspector displays
channel strips for the selected track, and also for the primary destination (output) for the
selected track’s channel strip.
In addition to track channel strips, projects contain output channel strips and a master
channel strip (which controls the overall volume of the project). They can also contain
auxiliary channel strips, which are used to route the output from multiple tracks to a single
destination.
For more information about working with channel strips in the Mixer, see Mixing overview.

Plug-ins

Logic Pro includes a collection of professional-quality plug-ins you can use to shape the
sound of your recordings and other material. There are several types of plug-ins used in
Logic Pro channel strips: MIDI plug-ins, effects plug-ins, and instrument plug-ins.
•

MIDI plug-ins are inserted in software instrument channel strips and process or
generate MIDI data—played from a MIDI region or a MIDI keyboard—in real time.

•

Effects plug-ins can be used in audio, instrument, auxiliary, and output channel strips.
In general, they modify the sound (the input signal) of the channel strip.

•

Instrument plug-ins can be used on software instrument channel strips. They respond
to MIDI note messages and so can be played using a USB music keyboard or another
MIDI controller.

For more information about working with instrument and effects plug-ins, see Plug-ins
overview. For complete information about individual plug-ins, see the Logic Pro Instruments
and Logic Pro Effects manuals.

Work with windows in Logic Pro
Open and close windows in Logic Pro

You can open editors and other working areas as separate windows, open multiple windows
simultaneously, customize your window setup, and save different window arrangements as
screensets. The contents of each window update to show your latest changes.
Only one window can have key focus at a given time, this is called the active window. When
several normal windows overlap, the active window is the window in the foreground. The title
of the window with key focus is black (the titles of other open windows are gray). Inside a
window, the area with key focus (for example, the Tracks area) is bordered by a blue frame.
In the Logic Pro main window, different areas can be given key focus by clicking the
background or title bar of the window, or by using a tool in the window. Key commands only
affect the window or area with key focus.
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Some areas, including the Preferences and Project Settings windows, open as floating
windows in the foreground, above even the key focus window. When one floating window
covers another, click the one you want to move to the foreground.
Access for working areas is available in the Window menu when Enable Complete
Features is selected in Logic Pro > Preferences > Advanced. When Logic Pro is operating in
Simplified mode, you can access the Logic Pro main window, the Keyboard, and the Musical
Typing window from the Window menu.

Open a window

In Logic Pro, choose the window you want to open from the Window menu.
If the window is open but in the background, it comes to the foreground. If it’s already in
the foreground, another window of the same type opens.
Tip: The key commands for opening different working areas as separate windows are
shown beside the window name in the Window menu.

Give a window key focus

In Logic Pro, click the window title bar, or within the working area.
When clicking in the working area, be careful not to accidentally insert an event or region if
the Pencil tool is active in the window.

Cycle through open windows

In Logic Pro, choose Window > Cycle Through Windows (or use the corresponding
key command).
This command assigns key focus to the next open window, if it is fully obscured by
other windows.
You can also cycle through working areas using Tab (cycles forward) and Shift-Tab (cycles
backward).

Close a window

In Logic Pro, do one of the following:
Click the close button at the top-left corner of the window.

Choose File > Close (or press Command-W).
The window with key focus closes.

Close all windows (of the active project)

In Logic Pro, Option-click the close button to close all windows of the active project.
Note: If you close all open windows of a project, Logic Pro asks if you want to save your
changes.
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Move and resize windows in Logic Pro

You can move and resize open windows individually, even across multiple monitors. You
can also change the size of all window elements that feature a resize bar.

The size relationship of the Tracks area and editors in the Logic Pro main window can also
be adjusted, by clicking between them and dragging vertically. The pointer changes to a
Resize pointer. The vertical height of the Mixer is independent of the height you set for
the editors.

Move a window
•

In Logic Pro, drag the window to a new position.

Adjust the size of window elements

1. In Logic Pro, move the pointer over the resize bar.
2. When the pointer turns into the Resize pointer, drag the window element.
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Zoom windows in Logic Pro

You can also zoom in to see regions or events in closer detail, or zoom out to see more of
the project. Most Logic Pro windows have zoom sliders.

When you zoom in or out, the top-left (and selected) event or region remains in the visible
area of the screen. If no selected region or event is visible, zooming is centered around the
playhead. If the playhead isn’t visible, the current center of the window is retained.
You can store three different zoom settings for each window using the Save as Zoom 1–3
key commands. Use the Recall Zoom 1–3 key commands to recall your zoomed settings.
These commands apply only to the active window or window area.

Zoom the Tracks area or editor
•

In Logic Pro, do one of the following:
•

To zoom vertically: Drag the Vertical Zoom slider left or right. Dragging left increases
the number of visible tracks, and dragging right increases the track height.

•

To zoom horizontally: Drag the Horizontal Zoom slider left or right. Dragging left
shows more of the Tracks area, and dragging right zooms in for a more detailed view.

•

Automatically zoom vertically: Click the Vertical Auto Zoom button to fill the available
vertical space.

•

Automatically zoom horizontally: Click the Horizontal Auto Zoom button to fill the
available horizontal space.

Zoom the Tracks area or editor using the playhead
•

In Logic Pro, press and hold Option as you click and hold in the lower section of the
ruler, then drag the top of the playhead up or down. Dragging down zooms in, while
dragging up zooms out.

Zoom using your computer trackpad
•
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In Logic Pro, pinch on the trackpad using two fingers. Pinch open to zoom in, or pinch
closed to zoom out.
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Zoom a section of the Tracks area using the Zoom tool

1. In Logic Pro, select the Zoom tool from the Tool menu (or press and hold ControlOption).
When the pointer is over an empty part of the Tracks area, you can simply press and
hold the Option key.
2. Drag to select the area you want to zoom with the Zoom tool.

The selected area fills the window. You can repeat the process to zoom in further.

Save and recall zoom settings

1. In Logic Pro, adjust the zoom setting you want to store.
2. Use one of the Save as Zoom key commands (1–3).
3. To recall a saved zoom setting, use the corresponding Recall Zoom key command (1–3).

Revert to the previous zoom setting
•

In Logic Pro, click the background with the Zoom tool.
This action returns the zoom level to the original setting, or backtracks through
previous zoom steps if the tool was used multiple times.

Scale windows in Logic Pro

You can adjust the size of individual plug-in windows to increase their readability.

Adjust the size of an individual plug-in window
In Logic Pro, do one of the following:
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•

Drag the lower-right corner of the plug-in window.

•

Choose the window size in the plug-in window’s View pop-up menu.
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Move through display levels in Logic Pro

The windows in a Logic Pro project have several display levels, with the Tracks area at
the highest level, and the editors normally at the lowest level. You can work on different
types of tasks, such as arranging the overall project, editing the contents of a folder, or
refining individual regions, at different levels. In many cases, you can switch between these
different levels directly, without needing to open or access another window.

Move one display level higher

In Logic Pro, do one of the following:
•

Click the Display Level button

in the upper-left corner of a window.

•

Double-click the background area of a window.

In the Piano Roll and Step Editors, a step up the display hierarchy shows the events of all
regions in the Tracks area.
In the Event List, clicking the Display Level button moves you up one level in the display
hierarchy. The display remains much the same but shows a list of regions, rather than a list
of individual events, along with region positions, names, track numbers, and lengths. The
MIDI region that you were just editing is selected within the list of region names.
In the Score Editor, clicking the Display Level button takes you to the higher display level.
Double-clicking a staff (at an empty point), reverts to a lower display level.

Control windows using Catch modes in Logic Pro

You can control how windows update to reflect changes to the playhead position using
Catch modes. When you work in Catch mode, the visible section of a window follows the
playhead during playback or recording.
If the Catch button is inactive, the display does not update, even when the playhead moves
past the right edge of the visible portion of the window.
In the Logic Pro > Preferences > General > Catch pane, you can set the following options:
•

Catch when starting playback: Turns on Catch mode whenever you click Play or Pause.

•

Catch when moving playhead: Turns on Catch mode whenever you move the playhead.

You also have the option of using Catch mode together with the Scroll in Play setting. The
View menus of all windows that display time horizontally (Tracks area, Score Editor, Piano
Roll Editor, and Step Editor) offer the View > Scroll in Play setting. If the Catch function of
the window is also activated, the playhead remains in the middle of the window, while the
background scrolls smoothly from right to left.
Content Catch mode is commonly used in the Tracks area, with linked MIDI editor windows
updating to show the events in the MIDI region currently under the playhead (on the
selected track).
Content Catch mode is available only when Additional Options for Advanced editing is
selected in Logic Pro > Preferences > Advanced.
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Turn on Catch mode
•

In Logic Pro, click the Catch button

Turn on Content Catch mode

1. In Logic Pro, click the Catch button

in the Tracks area (or editor) menu bar.

to turn on Catch mode.

2. Do one of the following:
•

In the Tracks area, Event Editor, Step Editor, or Score Editor, choose View > Link >
Content.

•

In the Piano Roll Editor, choose View > Link.

3. Control-click the Catch button, then choose “Catch Content by Position if Catch and
Link are Enabled” from the shortcut menu.
Note: To set Content Catch as the default for newly opened areas, turn on the Logic Pro >
Preferences > General > Catch > “Catch content by position if Catch and Link are enabled”
preference.

Link windows in a Logic Pro project

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can independently link or unlink windows (including the Tracks area, Piano Roll Editor,
Score Editor, and Event List) to control the relationship between what they display. For
example, you could set up two Event Lists, one showing arrange regions, and the other
showing their contents, then click a region in the first Event List to update the contents of
the second one.

The Link mode options—Off, Same Level, and Content—allow you to control how
information is displayed when working with related editor windows.
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Set the Link mode
•

In Logic Pro, choose View > Link, then choose one of the following:
•

Off: Unlinks the window from other windows.

•

Same Level: When selected, the editor window always displays the same contents
as the window with key focus, and updates whenever the window with key focus
changes. For example, if the Score Editor has key focus, in Same Level Link mode,
the Event List displays the same data as the Score Editor (numerically, of course).

•

Content: When selected, the editor window always shows the contents of the region
selected in the window with key focus. In this case, the display level is always one
level lower than that of the top window. For example, if the Tracks area is the active
window, any open MIDI editor shows the events of the selected MIDI region. You
can also use Content Link mode in one Tracks area to display the folder contents of
another Tracks area.

The Piano Roll Editor and Score Editor also include a Link button that you can use to set
the Link mode, and view the current Link mode.
•

Piano Roll Editor: The Link button is yellow when set to Content. Same Level is not
available.

•

Score Editor: The Link button is purple when the Link mode is set to Same Level, and
yellow when set to Content.

Control windows using screensets
Create and recall screensets in Logic Pro
You position windows in a layout that suits the way you work. This layout of various
windows, including their display size, zoom levels, position, and other settings, is called
a screenset. Once defined, you can save, and freely switch between different screensets,
much as you might between different computer displays.
Screensets are numbered from 1 to 99 (using any numeric key except 0—the 0 key is
assigned to the Stop command by default).
You don’t need to save screensets with an explicit command. It happens automatically, as
soon as you switch to another screenset. Thus, without any effort, your current working
view is always stored as the current screenset.
You can also switch a screenset automatically during playback using meta events.

Create a screenset

1. In Logic Pro, press any numeric key except 0.
For screensets with two-digit numbers, press and hold Shift while entering the first
digit.
2. Arrange your windows, including changes to zoom settings, the relationship of the
Tracks area and editor, open or closed inspector and Browsers or List Editors areas, and
so on.
Note: When you choose a screenset number that has not been saved, a maximized main
window opens.
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Recall or switch between screensets
In Logic Pro, do one of the following:
•

Type the number of the screenset (1 to 9).
For screensets with two-digit numbers, press and hold Shift while entering the first
digit.

•

Choose the screenset from the Screenset menu.

•

Use the Next Screenset or Previous Screenset key commands.

Note: Screensets 1 to 9 can be recalled by freely defined key commands, not only the
number keys on your computer keyboard. This allows you to use the number keys for other
purposes, such as opening or closing windows. The 1 to 9 key commands are called Recall
Screenset 1–9 in the Key Commands window.

Switch a screenset during playback

1. In Logic Pro, select the MIDI region into which you want to insert the meta event.
2. Set the playhead to the point where you want the screenset to change.
3. Click the Create button in the Event List, then click the Meta Events button.
The inserted meta event has a default value of 50 (Project Select).
4. Alter the number in the Num column from 50 to 49.
This changes the name to screenset.

5. Enter the screenset number in the Val column.
You can stop screenset switching by muting the MIDI region that contains the
meta 49 event.
For information about using the Event List, see Event List overview. For information about
meta events, see Meta events.
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Copy, rename, and delete screensets in Logic Pro
You can protect, copy, rename, and delete a screenset.

Prevent the current screenset from being altered
•

In Logic Pro, choose Screensets > Lock (or use the Lock/Unlock Current Screenset
key command).
A bullet appears in front of the screenset number to indicate that it is locked. Repeat
the key or menu command to unlock the screenset.

Important: The File > New command unlocks all screenset locks.

Copy screensets

1. In Logic Pro, switch to the screenset you want to copy, then choose Screensets >
Duplicate (or use the Duplicate Screenset key command).
2. In the Duplicate Screenset dialog, enter the target screenset number (the screenset
number that you want to copy to), and give it a name.

3. Click OK.

Rename the current screenset

1. In Logic Pro, choose Screensets > Rename (or use the Rename Screenset key
command).
2. In the Rename Screenset dialog, do one of the following:

•

Enter a new name.

•

Click the Auto Name button to automatically name the screenset. The default is the
visible window names. The name is automatically updated whenever a window or
view is opened or closed.

3. Click OK.

Delete the current screenset
•
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In Logic Pro, choose Screensets > Delete (or use the Delete Screenset key command).
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Import screensets from other Logic Pro
You can import screensets from another project.

Import all screensets from another project
1. In Logic Pro, do one of the following:
•

Choose File > Project Settings > Import Project Settings.

•

Click the Browsers button, then click All Files to open the All Files Browser.

2. Navigate to and select the project file that you want to import screensets from, then
click the Import button.
Note: If accessing this feature via the All Files Browser, you also need to click the Import
Settings button, which appears after clicking the Import button.
3. In the Import Settings dialog, select the Screensets option.
4. Click the Import button.
The settings are imported into the active project.

Revert to saved screensets in Logic Pro
You can easily revert to saved screensets.

Revert to a saved screenset
•

In Logic Pro, choose Screensets > Revert to Saved (or use the Revert to Saved
Screenset key command).

Your screen is reset to its original state.
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Work with tools in Logic Pro
Overview of tools in Logic Pro

Logic Pro provides tools for a variety of editing tasks and other functions. Tool menus
are available in the Tracks area, in various editors (including the Piano Roll, Audio Track,
Audio File, Score, and Step Editors), and in the Environment. Some tools are available in
all working areas, and others are available only in one or several working areas. When you
choose a tool from the Tool menu, the pointer changes to show the chosen tool.
In general, you use a tool by clicking a region, note, or other item in that working area.
If multiple regions are selected when you use a tool, the edits apply to all the selected
regions (for example, the Scissors tool cuts all selected regions at the same time position).

Where tools are available, there are two Tool menus: a Left-click and a Command-click Tool
menu. You can assign separate tools to the Left-click and Command-click Tool menus. (You
can also assign the right mouse button if your mouse supports one.) For information about
assigning tools, see Assign tools.
The Command-click and Right-click Tool menus are available when Enable Complete
Features is selected in Logic Pro > Preferences > Advanced.

Open the Tool menu
•

In Logic Pro, press the T key.
You can also click the Tool menu to open it, or close it if it’s open.

Choose a tool
•

In Logic Pro, do one of the following:
•

In the Tool menu, click the tool.

•

Use the key command for the tool.

The pointer changes to show the chosen tool, and the Tool menu closes.
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Assign tools in Logic Pro

You can assign tools to the Left-click and Command-click Tool menus. The pointer adopts
the shape of the active tool, so you can quickly identify which tool is being used.

The Command-click Tool menu is located on the right by default, but is located in the
middle when a third (Right-click) tool is assigned. You can assign the Right-click tool in the
Logic Pro > Preferences > General > Editing pane. See Editing preferences.
If you have a suitable mouse, you can also assign the right mouse button to any of the
following:
•

A third tool (Right-click tool)

•

Tool menu

•

Shortcut menu (default setting)

You can set two different behaviors for the Pointer tool when using it in the Tracks area.
The Command-click and Right-click Tool menus are available when Enable Complete
Features is selected in Logic Pro > Preferences > Advanced.

Assign the Left-click tool
•

In Logic Pro, click the Left-click Tool menu to open it, then choose a tool.

Press the “T” key twice to return to the default Pointer tool.

Assign the Command-click tool
•

In Logic Pro, click the Command-click Tool menu, then choose a tool.

Releasing the Command key reverts to the Left-click tool.

Set the behavior of the right mouse button

1. In Logic Pro, choose Logic Pro > Preferences > General (or use the corresponding key
command).
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2. Click Editing, then choose a setting from the Right Mouse Button pop-up menu.
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•

Is Assignable to a Tool: When this option is chosen, a third Tool menu (Right-click
Tool menu) appears to the right of the Left-click and Command-click Tool menus.
Choose the appropriate menu item to assign the tool, which is available when the
right mouse button is pressed while editing.

•

Opens Tool Menu: Right-clicking in the working area of the active window opens the
Tool menu with the Pointer tool (and not the currently selected tool) located under
the pointer position. Click a tool to choose it. When the Tool menu is open, you can
also use the key shown next to a tool to select it.
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Note: When you choose a tool from the Tool menu by right-clicking, the tool is
assigned to the left mouse button. Right-double-clicking in the working area of the
active window resets the assigned tool to the Pointer tool.
•

Opens Shortcut Menu: Right-clicking in the working area of the active window
displays a menu that contains a number of area-specific selection and editing
commands.

Set the behavior of the Pointer tool in the Tracks area

1. In Logic Pro, choose Logic Pro > Preferences > General (or use the corresponding key
command).
2. Click Editing, then select the behavior you want for the Pointer tool.
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•

Fade Tool Click Zones: When selected, placing the pointer over the upper-left and
upper-right edges of a region activates the Fade pointer and behavior. The Loop
pointer and behavior can still be accessed in these click zones by holding down
Option.

•

Marquee Tool Click Zones: When selected, placing the pointer over the lower half of
a region (with the exception of the lower-left and lower-right edges) activates the
Marquee pointer and behavior.
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Tools common to multiple working areas in Logic Pro
The following section describes tools available in the Tracks area and in other
working areas.

Pointer tool

The Pointer is the default tool when you open Logic Pro. You can use the Pointer tool to:
•

Select events, regions, or other items by clicking them. You can select multiple items by
holding down Shift and dragging around the items.

•

Move items (by grabbing and dragging).

•

Copy items (by Option-dragging).

•

Change the length of items (by grabbing the bottom-right or bottom-left corner and
dragging).

•

Loop regions (by grabbing the upper-right corner and dragging).

The pointer also takes the shape of this tool when outside the working area, when making a
menu selection, or entering a value.

Pencil tool

Use the Pencil tool to add new regions or events. You can also select, drag, loop, and alter
the length of regions or events using the Pencil tool. In the Score Editor, you can use the
Pencil tool to add dynamic markings, accents, and other symbols to notes.

Eraser tool

Use the Eraser tool to delete selected regions or events. When you click a region or event
with the Eraser tool, all of the currently selected regions or events are deleted (similar to
pressing the Delete key). The Eraser tool can also delete an unselected region or event by
clicking it.

Text tool

Use the Text tool to rename regions and other items, or add text to a score in the
Score Editor.

Scissors tool

Use the Scissors tool to split regions and events, allowing individual sections to be copied,
moved, or deleted.

Glue tool

Use the Glue tool to join selected regions or events into a single region or event.

Solo tool

Click and hold a region with the Solo tool to listen to the selected region or event apart
from the rest of the project. Moving the mouse horizontally also scrubs any events the
pointer touches.
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Mute tool

Click an event or region with the Mute tool to silence it. You can unmute the region or event
by clicking it a second time with the Mute tool. If multiple regions or events are selected,
the mute state of the clicked region or event applies to all selected regions or events.

Zoom tool

Use the Zoom tool to zoom in by dragging over regions or other material, or over an empty
part of the Tracks area. To revert to the normal zoom level, click the window background
with the Zoom tool, or click while holding Control-Option.
You can also access the Zoom function by pressing and holding Control-Option, regardless
of which tool is active. When the pointer is over an empty part of the Tracks area, Piano
Roll Editor, Score Editor, or Step Editor, you can access the Zoom function by pressing and
holding Option.

Fade tool

Use the Fade tool to create and edit fades, or to change the shape of fade curves.

Automation Select tool

Use the Automation Select tool to select automation data and create automation points at
region borders.

Automation Curve tool

Use to Automation Curve tool to bend or reshape the curve between two automation
points, creating a nonlinear transition between the points.

Marquee tool

Use the crosshair-shaped Marquee tool to select and edit parts of regions. In the Tracks
area, you can select part of a region or regions with the Marquee tool and apply selectionbased processing with audio effects.

Flex tool

Use the Flex tool for quick access to fundamental Flex editing functionality, without having
to turn on Flex view in the Tracks area.

Tools for specific working areas

Tools specific to a particular editor or other working area are covered in the respective
chapters for that working area.
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•

The Finger tool is available in the Piano Roll Editor and the Step Editor.

•

The Quantize and Velocity tools are available in the Piano Roll Editor and the Score Editor.

•

The Brush tool is available in the Piano Roll Editor.

•

The Vibrato and Volume tools are available in the Audio Track Editor.

•

The Move tool is available in the Audio File Editor.

•

The Camera, Layout, Resize, and Voice Separation tools are available in the Score Editor.

•

The Line tool is available in the Step Editor.

•

The MIDI Thru tool is available in the MIDI Environment.
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Use the complete set of Logic Pro features

Logic Pro provides the power and flexibility of a complete professional music production
system, while also allowing you to work in a simplified mode that streamlines tools and
menus across the app to provide you with a core set of features for music production.
•

Complete mode: For experienced users who have upgraded from earlier versions
of Logic Pro or worked with other DAW apps, the full set of Logic Pro features and
options is active. Complete mode is active by default if older versions of Logic Pro have
previously been installed on your Mac.

•

Simplified mode: Users new to Logic Pro can start working with basic features and a
simplified interface. In particular, if you are familiar with GarageBand, you will find a
direct match for most GarageBand features along with some additions. When you open
an existing Logic Pro project, any tools or options used by the project are turned on
automatically.

Turn on Complete mode

1. Choose Logic Pro > Preferences > Advanced.
2. Select the Enable Complete Features checkbox.
Note: When the Enable Complete Features checkbox is unselected, Logic Pro is working
in Simplified mode. The Simplified button appears in the upper-right edge of the control
bar, showing you the working state. You can click the Simplified button to open Logic Pro >
Preferences > Advanced directly, so that you can turn on Complete mode.
In the Logic Pro User Guide, features that require Complete mode have this icon:

.

If a Logic Pro project makes use of a feature (for example, Track Stacks) that can only
be created or edited in Complete mode, items using the feature will still play back when
operating in Simplified mode.
When you turn on Complete mode, you gain access to the following controls and options:

User interface
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•

Access the Event, Marker, Tempo, and Signature Lists.

•

Access the Project Audio Browser and All Files Browser.

•

Access the Step Editor (formerly Hyper Editor) to graphically edit MIDI events.

•

Customize the control bar and toolbar with additional buttons and controls.

•

Access the Marker, Signature, and Beat Mapping global tracks.

•

Customize key commands in the Key Commands window.

•

Access additional preferences and project settings.

•

Access additional track header controls in the Tracks area, including On/Off buttons,
Hide buttons, track numbers, and color bars.

•

Customize your workflow using screensets.

•

Open editors and other working areas as separate windows.

•

Access the Event and Region inspector floating windows.
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Projects
•

Open and work on multiple projects.

•

Manage different versions of projects called alternatives.

•

Revert to automatically saved versions of a project called backups.

•

Save assets either inside the project or in a project folder with subfolders for different
asset types.

Recording
•

Use additional recording functionality, including: Quick Punch-In, Autopunch, advanced
recording commands, and automatic coloring of takes when recording.

•

Use Quick Swipe Comping to create composite takes (comps).

•

Use step input recording to manually enter MIDI events rather than recording them in
real time.

•

Generate separate note events for bars, beats, divisions, and groupings with the
metronome.

Arranging
•

Hide tracks in the Tracks area.

•

Snap items in the Tracks area to the grid using Snap pop-up menu settings.

•

Control the results of moving, resizing, or deleting regions in the Tracks area and other
working areas using drag modes.

•

Maximize visibility of tracks using individual track zoom and waveform zoom.

•

Organize track content using folders.

•

Configure track header components.

•

Show track headers on a single line.

•

Color regions in the Tracks area using the Color palette.

•

Use the secondary ruler and marquee ruler in the Tracks area and other working areas.

•

Access additional track parameters, including Channel, Freeze Mode, Q-Reference,
Delay, Flex Mode, and Staff Style in the Track inspector.

•

Access additional region parameters, including Delay, Dynamics, Gate Time, Clip
Length, Q-Vel, Q-Length, Q-Flam, Q-Range, Q-Strength in the Region inspector.

•

Create your own Sampler, Drum Machine Designer, or Alchemy instruments by
converting audio into samples on a new software instrument track.

Audio
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•

Use the Audio File Editor for destructive editing of audio files and advanced
configuration options.

•

Use the Project Audio Browser to view audio files and regions that have been added to
or recorded in your project.

•

Create crossfades on adjacent and overlapping audio regions.
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Editing
•

Export to file formats such as AAF and XML.

•

Access advanced features in the Piano Roll Editor.

•

Perform extensive MIDI edits in the MIDI Transform window.

•

Create and edit MIDI note and controller data using the Step Editor.

•

Use drum replacement and doubling.

•

Use Varispeed to speed up or slow down an entire project.

•

Configure the tuning system used for included software instruments.

•

Use the the second and third Tool menus.

•

Use advanced tools, including the Solo, Automation Select, and Automation Curve tools.

•

Create and edit custom key commands.

•

Access Undo History.

Mixing
•

Filter channel strips by type in the Mixer.

•

Access the Sends on Faders pop-up menu.

•

Use Track Stacks to organize and control tracks, manage projects with high track
counts, and create and manage audio subgroups.

•

Define channel strip groups in the Mixer and automate groups to control changes over
time.

•

Turn on plug-in latency compensation to synchronize audio processed by plug-ins, and
turn on Low Latency Monitoring to route audio around latency-causing plug-ins.

•

Access the Compare, Copy/Paste, Undo/Redo, Link, and Side Chain controls in plug-in
windows.

•

Organize and manage built-in and Audio Units plug-ins using the Plug-in Manager.

Loops and media files
•

Create Apple Loops from your own audio and software instrument recordings.

Smart Controls
•

Change the layout for a Smart Control, map screen controls and edit mappings, rename
screen controls, and assign external controllers to screen controls in the Smart Control
inspector.

Score Editor
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•

View and edit multiple tracks.

•

Access additional score view options.

•

Add notes and symbols from the Part box.

•

Add lyrics and other text.

•

Customize staff styles and score sets.

•

Edit the score layout.
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Surround
•

Use surround capabilities (in the Mixer) with a surround speaker setup.

MIDI Environment
•

Use the Environment for MIDI signal flow control and real-time processing of MIDI data.

Control surfaces
•

Connect and configure control surfaces.

•

Create and edit control surface assignments.

Undo and redo edits in Logic Pro

You can undo one or more edit operations, and redo undone edits. Logic Pro includes an
Undo History window with a time-ordered list of all edits that can be undone. You can also
change the number of steps that can be undo in Logic Pro preferences.

Undo your last edit operation
•

In Logic Pro, choose Edit > Undo (or press Command-Z) immediately after making the
undesired edit.

You can undo virtually any edit, including moves, deletions, renaming, and parameter
changes; and the creation of new events, regions, channel strips, and more.

Open the Undo History window
•

In Logic Pro, choose Edit > Undo History (or press Option-Z).

The Undo History window displays a list of all actions that can be undone. The most recent
editing operation, which will be the first to be undone, is selected.
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Undo or redo multiple steps
•

In Logic Pro, click any entry to undo or redo all steps between the clicked and
highlighted entries.

Delete the Undo History
•

In Logic Pro, choose Edit > Delete Undo History.

WARNING: Take care with this command. No undos or redos are possible for the deleted
steps, once the Undo History has been deleted.

Change the number of undo steps

1. In Logic Pro, choose Logic Pro > Preferences > General, then click Editing.
2. Change the number in the Number of Undo Steps value slider.

Manage Logic Pro content

Logic Pro features an extensive Sound Library of Apple Loops, patches, drum kits, and
other content that you can use in your projects. When you install Logic Pro, essential
sounds and instruments are included as part of the installation. Additional content is
available to download after the installation is complete.
You can view available content and select content to download in the Sound Library
Manager. Some items in the Sound Library Manager have a disclosure arrow, which you
can click to show and select individual content types to download. You can also download
updated sounds and reinstall the complete Sound Library using the Sound Library
Manager. Some additional content can also be downloaded directly in the Library and the
Loop Browser.
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Additional content is required to use some sounds and other features. When you select an
item that requires additional content, a dialog appears, asking if you want to download the
content. In the Library and the Loop Browser, items with content not yet installed include a
Download button
that allows you to download the content directly.

Content types

The Sound Library includes the following types of content:
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•

Apple Loops

•

Drum kits

•

Patches

•

Plug-in settings

•

Quick Sampler samples

•

Sampler instruments and their associated samples

•

Impulse responses

•

Legacy and compatibility content, including Jam Packs, sounds, and instruments
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Content locations

Logic Pro installs Sound Library content in several different locations on your computer:
Content type

Location

Apple Loops

/Library/Audio/Apple Loops/Apple/

Impulse responses

/Library/Audio/Impulse Responses/Apple/

Patches

Patches are stored inside Logic Pro. They may be added, updated, or
removed when a new version is installed.

Plug-in settings

Plug-in settings are stored inside Logic Pro and in /Library/Application
Support/Logic/Plug-In Settings.*

Sampler instruments

/Library/Application Support/Logic/Sampler Instruments

Samples

• /Library/Application Support/Logic/Alchemy Samples

• /Library/Application Support/Logic/EXS Factory Samples

• /Library/Application Support/Logic/Samples/Quicksampler
• /Library/Application Support/Logic/Ultrabeat Samples

*Plug-in settings with asset dependencies are stored in the Plug-In Settings folder, while
other plug-in settings are stored inside Logic Pro.

Relocating the Sound Library

You can relocate the Sound Library to another compatible volume or partition, provided
enough free space exists for the Sound Library. When you relocate the Sound Library,
Sound Library content except for Apple Loops, Impulse Responses, patches, software
instrument presets, and those plug-in settings stored in the app bundle is moved to the
new location. User-created content is not affected.
Relocating the Sound Library to an external drive can free up a large amount of disk space
on your system drive. If you change your mind or decide you no longer want to keep the
content in another location, you can relocate the Sound Library back to its original location.
When you install additional content after relocation, it is installed in the new location. For
detailed information on relocating content and possible issues, see the Support article
Move Logic Pro and MainStage content on the support.apple.com website.
Note: Other Apple music creation apps such as MainStage and GarageBand share the same
Sound Library location. When you relocate the Sound Library, it is also relocated for these
apps if they are installed on your computer.

Reinstalling the Sound Library

You can reinstall the Sound Library. This can be useful to make sure you have the latest
version of all available content, and also in case the drive containing the Sound Library is
no longer available.
If the Sound Library is available in its current location when you reinstall it, it is reinstalled
in the same location. If the Sound Library is not available (for example, if it is installed on
an external drive that is lost or not connected to your computer), it is reinstalled in the
default location on your system drive.
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Deleting Logic Pro content

You can view and delete Logic Pro content by choosing About This Mac from the Apple
menu, clicking Storage, then clicking the Manage button for your system storage drive.
Content for Logic Pro (as well as other music creation apps, including GarageBand and
MainStage) is listed in the Music Creation section. You can view the capacity of the
Instrument Library and Apple Loops library and delete each of these items.
If you delete Logic Pro content that is required for a patch or software instrument, Logic Pro
prompts you to re-download that content the next time you try to use the patch or instrument.

Open the Sound Library Manager

Choose Logic Pro > Sound Library > Open Sound Library Manager.

Download additional content

1. In Logic Pro, do one of the following:
•

In the Sound Library Manager, select the checkbox for each content package you
want to download.

•

To download all uninstalled content, click the Select All Uninstalled button.

2. Click Install.
While additional content is downloading, a progress bar appears in the lower part of the
LCD. You can view more detailed information about the progress of the download by
clicking the progress bar.

Download additional content in the Library or the Loop Browser

Items in the Library and the Loop Browser that require additional content are indicated by a
Download button .
•
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In Logic Pro, click the Download button

next to the item name.

114

Download all available sounds
•

In Logic Pro, choose Logic Pro > Sound Library > Download All Available Sounds.

Relocate the Sound Library

1. Choose Logic Pro > Sound Library > Relocate Sound Library.
The Relocate Sound Library window opens, showing available drives and the free space
available on each. Unsuitable drives are dimmed, with the reason for their unsuitability
shown in the Comments column.
2. Select the new Sound Library location, then click Relocate.
The Sound Library is relocated to the selected location. If other music creation apps
such as GarageBand or MainStage are open, you are asked to close them before
relocation can proceed.
When relocation is complete, the Relocate Sound Library window closes.

Reinstall the Sound Library
•

Choose Logic Pro > Sound Library > Reinstall Sound Library.

How to get help for Logic Pro

Logic Pro provides several ways for you to get answers to questions, learn about controls
and functions while you’re working, and view detailed information about all aspects of the
app. You can also view information directly in the app using the Quick Help feature.
In addition to being available from the Logic Pro Help menu, the full suite of support
documents is available online in HTML, PDF, and EPUB formats. All content in the Logic Pro
Instruments and Logic Pro Effects guides is now integrated into the Logic Pro User Guide in
the app and at the support.apple.com website.

Quick Help

You can view a brief description of windows, controls, and other elements of the Logic Pro
interface without leaving the app or interrupting your workflow. You can view Quick Help in
the inspector, in a movable floating window, or in yellow bubbles next to the pointer.
•

To turn on Logic Pro Quick Help, click the Quick Help button
choose Help > Quick Help.

in the control bar, or

•

To view Logic Pro Quick Help in the inspector, choose Help > Quick Help appears
as > Inspector Pane.

•

To view Logic Pro Quick Help in a floating window, choose Help > Quick Help
appears as > Floating Window.
(You can also click and hold the title bar of the Quick Help pane in the inspector,
then drag the Quick Help pane out of the inspector.)

•
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To view Logic Pro Quick Help in yellow bubbles next to the pointer, choose Help >
Quick Help appears as > Bubbles at Pointer Location.
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Logic Pro tutorial projects

Several tutorial projects are available in the Logic Pro Project Chooser. Each tutorial project
provides simple, step-by-step instructions for one of the features in the latest version of
Logic Pro. You can open a tutorial project and follow the steps at your own pace, making
hands-on changes to the project as you learn more about working in Logic Pro.
•

•

To view Logic Pro Tutorial projects, do one of the following:
•

Choose Help > Logic Pro Tutorials.

•

Choose File > New (or press Command-N), then click Tutorials.

To open a tutorial project, double-click it.

Logic Pro Help

Describes the Logic Pro interface, commands, and menus and gives step-by-step
instructions for creating Logic Pro projects and for accomplishing specific tasks.
•

To view Logic Pro Help in Logic Pro, choose Help > Logic Pro Help.

•

To view the Logic Pro User Guide in other available formats, use the links at the bottom
of the page, or search for Logic Pro Instruments in the store in Apple Books.

Logic Pro Instruments

Provides comprehensive instructions for using the powerful collection of instruments
included with Logic Pro.
•

To view the Logic Pro Instruments guide in Logic Pro, choose Help > Logic Pro
Instruments.

•

To view the Logic Pro Instruments Guide in other available formats, use the links at the
bottom of the page, or search for Logic Pro Instruments in the store in Apple Books.

Logic Pro Effects

Provides comprehensive instructions for using the powerful collection of effects included
with Logic Pro.
•

To view the Logic Pro Effects guide in Logic Pro, choose Help > Logic Pro Effects.

•

To view the Logic Pro Effects Guide in other available formats, use the links at the
bottom of the page, or search for Logic Pro Effects in the store in Apple Books.

Logic Pro Control Surfaces Support

Provides comprehensive instructions for configuring and using specific hardware control
surfaces with Logic Pro.
•
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To view the Logic Pro Control Surfaces Support Guide online, choose Help > Logic Pro
Control Surface Support or browse to the Logic Pro Control Surfaces Support Guide
Welcome page.
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View Smart Help on Logic Remote

You can use the Logic Remote app to view detailed Help information on your iPad while
you work in Logic Pro, as well as control many aspects of Logic Pro. The Logic Remote app
is available on the App Store, and can be downloaded directly from within Logic Pro by
choosing Logic Pro > Download Logic Remote.
When you open Smart Help in Logic Remote, you can view detailed Help information about
the Logic Pro interface, commands, and menus, including step-by-step instructions for
using Logic Pro on your Mac while you are working, simply by placing the pointer over
different parts of the interface.
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Connect external devices

Logic Pro hardware connection overview

You can use Logic Pro with a wide variety of audio and MIDI devices, including
microphones, keyboards and other musical instruments, mixers, and other audio
equipment.
To connect audio devices to your computer, you can use an audio interface. Keyboards and
other MIDI devices can be connected directly, or using a MIDI interface. Some audio and
MIDI interfaces require that you install a device driver before opening Logic Pro, so the app
can find and use the device at startup.
•

See Audio devices overview.

•

See MIDI devices overview.

Connect audio devices
Using audio devices with Logic Pro overview

Logic Pro works with Core Audio–compliant audio devices, including USB, Thunderbolt,
FireWire, and PCI audio interfaces. You can connect microphones, electric musical
instruments, and other musical equipment to your computer, or to an audio interface or
other audio device. Logic Pro supports input from digital audio interfaces up to a maximum
sample rate of 192 kHz, and a maximum bit depth of 24 bits.
If you use an audio interface to connect instruments or other audio devices, check the
manufacturer’s specifications to make sure the interface is compatible with the macOS
version required by Logic Pro. Also make sure the audio interface uses a format supported
by your computer. Follow the manufacturer’s instructions, which may include installing the
correct driver on your computer. Check the documentation that came with the device, and
the manufacturer’s website, for more information.
Logic Pro automatically recognizes any installed Core Audio hardware, and uses the
default settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio MIDI
Setup). However, you may want to optimize the settings for your individual hardware setup,
particularly if you use several audio interfaces or a multiple input/output device. If possible,
you should avoid using different audio devices for input and output.
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For details about setting up your Core Audio device preferences (in the Logic Pro >
Preferences > Audio > Core Audio pane), see Devices preferences. You can also consult
the “Change the sound input settings on Mac” article in the macOS User Guide, and the
“Set up audio devices” article in the Audio MIDI Setup User Guide for more information.

Connect a microphone to a computer running Logic Pro

You can connect a microphone to your computer to record your voice, an instrument, or
any other sound to an audio track. You can connect a microphone to your computer’s audio
input port, a USB port, or to an audio interface connected to your computer. You can also
use your computer’s built-in microphone to record sound.

Connect a microphone to your computer
Do one of the following:
•

Connect the microphone to an input on the audio interface using a standard XLR cable.

•

Connect a USB microphone to your computer’s USB port on your computer. Choose the
USB microphone as the track’s input source.

•

Connect an audio interface to your computer’s Thunderbolt or USB port, then connect a
microphone to the audio interface for recording.

•

Connect an audio mixer or console to an audio interface, then connect the interface to
your computer.

•

If your computer has an audio input port, connect the microphone to the audio input,
then choose Built-in Input as the track’s input source.

•

If you’re using your computer’s built-in microphone, choose Built-in Microphone as the
input source in Logic Pro > Preferences > Audio > Devices.

After you connect a microphone, you choose the input source for the track you want to
record to; you can also turn on monitoring to hear sound from your microphone as you
play. You can choose the input source in the New Tracks dialog when you create a track, or
choose it from the Input slot on the track’s channel strip in the Mixer or the inspector.
You can also Set the input format in the Mixer or the inspector so that it matches the
format of the microphone.
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Connect an electric instrument to a computer
running Logic Pro

You can connect an electric instrument, such as an electric guitar or bass, to your
computer to play and record in an audio track. You can record the sound from your guitar
to an audio track, and use the amps and pedalboard effects to shape your guitar sound.
There are several ways to connect an electric instrument to your computer.

Connect an electric instrument to your computer
Do one of the following:
•

Connect an audio interface to your computer’s Thunderbolt or USB port, then connect
an electric instrument to the audio interface.

•

Connect the electric instrument to a channel on the audio interface or the adapter
cable, using a standard 1/4-inch tip-sleeve instrument cable.

•

If your computer has an audio input port, connect an electric instrument to the audio
input port using an adapter cable. Choose Built-in Input as the track’s input source.

After you connect an electric instrument, you choose the input source for the track you
want to record to; you can also turn on monitoring to hear your instrument as you play. You
can choose the input source in the New Tracks dialog when you create a track, or choose it
from the Input slot on the track’s channel strip in the Mixer or the inspector.
You can also Set the input format in the Mixer or the inspector so that it matches the
format of the instrument.
If you connect your electric instrument to an audio interface, check the manufacturer’s
specifications to make sure the interface is compatible with macOS and Core Audio.
Also make sure the audio interface uses a format supported by your computer. Follow
the manufacturer’s instructions, which might include installing the correct driver on
your computer.
Connecting some electric instruments, such as electric guitars, to your computer’s audio
input port may result in a low-level input signal. To increase the input signal, you can
connect the guitar to a preamplifier, and connect the preamplifier to your computer.
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Connect an audio interface to a computer running Logic Pro

Using an audio interface, you can connect microphones, instruments, and other music
equipment to your computer and record the output to an audio track. You can also connect
a mixer, speakers or monitors, headphones, and other equipment to hear the audio output
from Logic Pro.
Logic Pro supports plug-and-play for audio interfaces, making it possible to connect and
turn on a new audio interface while Logic Pro is open. An alert appears when you connect
a new device, and prompts you to select and confirm the audio interface and driver you
want to use.
All digital audio interfaces can be susceptible to latency—a noticeable delay between the
time the audio signal is produced, and when you hear it. You should always attach your
audio interface directly to the computer, rather than through a hub, or daisy-chaining
it through another device. Doing so can cause an unacceptable amount of latency,
particularly with slower USB 1.1 devices.
You can also consult the “Change the sound input settings on Mac” article in the macOS
User Guide, and the “Set up audio devices” article in the Audio MIDI Setup User Guide for
more information.

Connect an audio interface to your computer
Do one of the following:
•

Connect an audio interface to your computer’s Thunderbolt or USB port.

•

Connect an audio interface to a PCIe (Peripheral Component Interconnect Express)
card installed in your computer. PCIe provides extremely high bandwidth and fast data
transfer rates, allowing you to record and play back large numbers of files at the highest
possible sample rates and bit depths.

After connecting an audio interface to your computer, be sure to set the audio interface as
your audio input. You can then set the individual inputs on the audio interface as the input
source for the audio tracks you want to record to. For details on choosing the audio input,
see Devices preferences.
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Connect speakers to a computer running Logic Pro

You can connect speakers or monitors to your computer to hear your projects with better
audio quality. A variety of speakers is available that you can connect to your computer
or audio interface. The way you connect them depends on your system and the type of
speakers you use.
Surround projects require a surround speaker system. For information about using
speakers in a Surround project, see Speaker placement.
After connecting speakers or monitors to your computer, be sure to set them as your audio
output. For details, see Devices preferences.

Configure audio devices to use with Logic Pro

Many Core Audio–compliant devices don’t require a driver to work with Logic Pro. For other
audio devices, you may need to install, select, activate, and configure the driver for the
device. Check the instructions that came with the device, and the manufacturer’s website,
for more information.
For devices that do require an audio driver, you configure the driver in Audio Devices
preferences.

Open Audio Devices preferences

In Logic Pro, choose Logic Pro > Preferences > Audio (or use the Open Audio Preferences
key command), then click the Devices tab.
Logic Pro automatically recognizes any installed Core Audio hardware, and uses the default
settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio MIDI Setup).
In most cases, however, you may want to optimize the settings for your individual hardware
setup, particularly if you use several audio interfaces or a multiple input/output device. If
possible, you should avoid using different audio devices for input and output.
For details about setting up your Core Audio device preferences, see Devices preferences.

Configure Apogee and Euphonix devices to use
with Logic Pro

You can configure Apogee or Euphonix audio hardware in the utilities provided by
these manufacturers. The configuration utilities for connected devices can be opened
directly from Logic Pro. Consult the documentation provided with the device for specific
configuration instructions.
Note: EuCon is now fully supported on Mac computers with Apple silicon.

Open the Apogee Control Panel

In Logic Pro, choose Mix > Open Apogee Control Panel.

Open the EuControl Settings

In Logic Pro, choose Mix > Open EuControl Settings.
The EuControl Settings panel is available when Avid EuControl software is installed and
running on your computer.
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Connect MIDI devices
Using MIDI devices with Logic Pro overview

Logic Pro works with many USB and MIDI keyboard controllers and with other MIDI devices
including sound modules, control surfaces, effects processors, mixers, lighting controllers,
pedals, and switches.
Logic Pro recognizes all MIDI devices set up in the Audio MIDI Setup (AMS) utility, the
integrated audio and MIDI configuration tool of macOS. You can find the AMS utility in the
Applications/Utilities folder. For more information on use, see AMS Help.
Many controllers and other MIDI devices connect to your Mac via a USB port. If a MIDI
device has MIDI In and Out ports rather than a USB port, you can connect it to a MIDI
interface and connect the MIDI interface to your computer. Some MIDI interfaces are
automatically recognized by your Mac, but others may require you to install driver software.
Check the documentation that came with the device, and the manufacturer’s website, for
more information.

Connect a USB music keyboard to use with Logic Pro

You can connect a USB music keyboard to your computer to play and record software
instruments, or record MIDI regions to use with external MIDI devices such as synthesizers
or sound modules.

Connect a USB music keyboard to your computer
•

Connect the USB cable from the keyboard to your computer.

If the keyboard has MIDI ports instead of a USB port, see Connect MIDI keyboards
and modules.
Be sure to follow the instructions that came with the keyboard, which may include installing
the correct driver on your computer. Check the manufacturer’s website for the latest driver
software. If you’re using a MIDI interface, be sure to follow the instructions that came with
the interface.
When you connect a supported USB MIDI controller, the knobs, sliders, and other hardware
controls on the controller are automatically assigned to Smart Controls and other functions
in Logic Pro. For more information, see Automatic MIDI controller assignment.
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Connect MIDI devices to use with Logic Pro

You can connect a MIDI keyboard to your computer to play and record software
instruments, or record MIDI regions to use with external MIDI devices such as synthesizers
or sound modules.

Connect a MIDI keyboard
Do one of the following:
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•

Connect the MIDI Out port to a MIDI In port on a MIDI interface, and connect the MIDI
In port on the keyboard to a MIDI Out port on the MIDI interface using MIDI cables.
Connect the MIDI interface to your computer.

•

For keyboard controllers without tone generators: You only need to connect the MIDI
Out port of the keyboard to a MIDI In port on your MIDI interface, using a MIDI cable.

•

For keyboards with tone generators: You should also connect the MIDI Out port of the
MIDI interface to the keyboard MIDI In port. If your MIDI interface offers more than one
MIDI output, connect any other tone generators (or other MIDI devices, such as control
surfaces that require bidirectional MIDI communication) to these.
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•

If your MIDI interface has only one MIDI output: You need to connect the MIDI In of the
second tone generator to the keyboard MIDI Thru port. A third device can be connected
to the MIDI Thru of the second unit, and so on.

The MIDI Thru port replicates the signals coming into the MIDI In port of the device. It’s
better to use a direct connection from the computer MIDI Out port to a device, rather
than chaining too many units, one after the other. Doing so can cause timing problems
in the chain if numerous MIDI commands are sent quickly, due to the slight delays
introduced by each MIDI In to MIDI Thru transaction. As such, a multi input/output MIDI
interface is recommended in studios with several MIDI tone generators and controllers.

About multichannel MIDI devices and Logic Pro

Multi-timbral MIDI tone devices can simultaneously receive MIDI data on multiple MIDI
channels. Each MIDI channel can be assigned a tone or sound, such as piano, strings, bass,
and so on.
To take full advantage of the capabilities of such multi-timbral devices, you should use
separate MIDI Out ports (from a computer MIDI interface to the MIDI In ports) for each
device. For example, use separate MIDI Out ports when you have four MIDI devices that
are capable of receiving data on multiple channels and all devices can receive on all 16
MIDI channels.
Logic Pro is capable of channelizing MIDI data (routing it to MIDI channels 1 to 16) and
sending the channelized data to specific MIDI Out ports. When you use a multi-output MIDI
interface, MIDI can be separated onto different channels by choosing a MIDI out channel
from the MIDI Out Channel pop-up menu in the Track inspector and by specifying the MIDI
ports on each device. For example, Logic Pro can assign and send:
•

A recording/performance on MIDI channel 1 to port A/module 1

•

A separate recording/performance—also on MIDI channel 1—to port B/module 2

•

A further recording/performance on MIDI channel 1 to port C/module 3, and so on with
subsequent channels and modules

In effect, having a multi-output MIDI interface is something like having more MIDI channels.
In this scenario, it would be like having 48 independent MIDI channels, with 16 channels
per port (A, B, and C).
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Not only does this allow you to play up to 48 different sounds simultaneously through your
tone generators, it also provides full MIDI control for each channel of each device. This
becomes increasingly important when you are arranging and orchestrating a large number
of instrument parts.
If your computer offers several MIDI inputs, you can connect the MIDI outputs of other MIDI
expanders and controllers to it.

Stop local sound generation for MIDI devices in Logic Pro
If your MIDI keyboard has an internal sound source, it’s important that you stop the
keyboard from generating sounds directly from its own keyboard.

For example, if you buy a new keyboard to be used without a sequencer, and connect it
to an amplifier, you would expect the device to make a sound when you press its keys—in
other words, the keyboard is directly connected to the sound generator.
When using the MIDI keyboard with Logic Pro, however, this is not what you want to
happen. In this situation, the keyboard is used as a computer input device, and Logic Pro
passes the incoming performance information back to the keyboard’s sound generator (or
to an internal software instrument or another connected sound module, if you like).
If the direct connection between the keyboard and its tone generator isn’t cut, a doubling
of each note results—one played directly from the keyboard to the internal tone generator,
and another sent through Logic Pro back to the tone generator.
Not only does this cause a phased sound, but it also halves the polyphony of the
keyboard’s tone generator. In situations where you want to control or record another sound
module or software instrument with your keyboard, you would hear both the keyboard
sound (due to the direct keyboard–to–tone generator connection) and the sound of the
software or MIDI instrument. This is why the keyboard must be separated from its own
internal sound generator.
This function is known as Local Off, and is set directly on your keyboard. Don’t worry
about losing the ability to use the tone generator of your keyboard. Logic Pro will still be
able to communicate with your keyboard tone generator just like any other connected,
keyboardless sound module or software instrument.
Note: If you can’t find the Local Off function in the MIDI menu of your keyboard, check its
manual on sequencer use. Some keyboards allow you to select from Local, MIDI, or Both
for each of their Parts (individual MIDI channels/sounds in multi-timbral MIDI devices). The
MIDI setting, if applicable to your keyboard, is the equivalent of Local Off.
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Work with projects

Overview of projects in Logic Pro

A project is a Logic Pro document that contains all of your recordings, the location of
media files you add, and all the changes you make. You start working in Logic Pro by
creating a project, or opening an existing project. You can have multiple projects open at
the same time, and transfer media and other data between them.
Logic Pro projects are organized in a new way compared to earlier Logic Pro versions.
Project assets (such as audio and video files, samples for the Sampler or Ultrabeat, and
Space Designer reverb impulse response files) can be saved directly in the project, or in a
separate project folder. As in earlier Logic Pro versions, assets can be referenced from a
location outside the project, letting you access media files without copying or moving them
into the project. You can manage project assets in a variety of ways.
Each project has project properties including tempo, key and time signature, and more. You
can set project properties when you create a project, or later while you’re working. You can
preview projects in the Finder using Quick Look, clean up and rename projects, and share
data and settings between projects.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can save a project as either a single file (package) or as a project folder containing
the project file and subfolders for project assets. You can also create and save project
alternatives, each with a unique name and different settings, and access saved backups
of a project.

Create Logic Pro projects

You start working in Logic Pro by creating a new project. In the Project Chooser, you can
choose a template to use as the starting point for a new project.
Each project has project properties including the project tempo, time and key signature,
and more. You can edit some project properties in the Project Chooser when you create
a project, and change them later while you’re working. For full details about project
properties, see Project properties overview.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can choose to have Logic Pro create a project folder that contains the project file,
along with subfolders for assets and other files used in the project (including audio files,
impulse responses, sample instruments, samples, and Ultrabeat samples).
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When you create a project folder for a new project, the project file is saved in the project
folder, and the file types selected in the Save dialog are saved to the corresponding
subfolder in the project folder.

Create a project

1. In Logic Pro, choose File > New (or press Command-N).
2. In the Project Chooser, select an option from the list on the left:

•

To create a new, empty project: Click New Project.

•

To see recently open projects: Click Recent.

•

To open a Live Loops starter grid: Click Starter Grids.

•

To open a tutorial project: Click Tutorials.

•

To open a demo project: Click Demo Projects.

•

To choose a project template: Click Project Templates.

•

To choose a user-created template: Click My Templates.

3. Select the type of project you want to create.
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4. To edit project settings for the project, click the Details triangle in the lower-left part of
the Project Chooser and do any of the following:

•

To set the project tempo: Drag the Tempo slider, enter a tempo in the Tempo field, or
click the Tap Tempo button several times.

•

To have regions in the project use the musical grid: Select the “Use musical grid”
checkbox.

•

To set the key signature: Choose a key from the Key Signature pop-up menu, then
click Major or Minor.

•

To set the time signature: Click the arrows to change the number of beats, or
double-click the time signature and enter a new time signature.

•

To set the audio input: Choose an input source from the Audio Input pop-up menu
(for audio tracks only).

•

To set the audio output: Choose an output (device) from the Audio Output pop-up
menu.

•

To set the project sample rate: Choose a sample rate from the Sample Rate pop-up
menu.

•

To set the project frame rate: Choose a frame rate from the Frame Rate pop-up menu.

•

To set the surround format for surround projects: Choose a surround format from the
Surround Format pop-up menu.

5. Click Choose.
The new project opens.
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When you create a project, the project is automatically saved. The first time you close the
project, close Logic Pro, or create a project alternative, the Save dialog appears, so you
can set the project name and location.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also choose whether to save the project as a single file (package) or folder, and
select which assets are saved in the project. For more information about saving projects,
see Save projects. For more information about project assets, see Manage project assets.

Create an empty default project

1. In Logic Pro, use the New Empty Project key command (Shift-Command-N).
2. In the New Tracks dialog, choose the track type and number of tracks to add to the
project.
3. Click Create.
You can also set Logic Pro to create a project automatically on startup by choosing a
startup action in the Logic Pro > Preferences > General > Project Handling pane. For more
information, see Project Handling preferences.

Open Logic Pro projects

You can open an existing project to continue working. You can also open several projects
simultaneously, allowing you to copy or move data between them, or to compare different
versions of a project.

Opening projects created in earlier Logic Pro versions

You can open projects created in Logic Pro 5 or later. Projects saved in Logic Pro are not
backward-compatible with earlier Logic Pro versions.
When you open a project created in an earlier version of Logic Pro, the project is converted
to a Logic Pro project. In the Save dialog, you can select whether to save the converted
project as a project package or a project folder.
You can configure Logic Pro to open a project automatically on startup by choosing a
startup action in the Logic Pro > Preferences > General > Project Handling pane. For more
information, see Project Handling preferences.
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Open a Logic Pro project

1. In Logic Pro, choose File > Open (or press Command-O).

If another project is open, a dialog appears, asking whether you want to close the open
project. You can turn off this prompt in the Logic Pro > Preferences > General > Project
Handling pane.
2. Locate and select the file, then click Open.
You can also open a Logic Pro project (or a MIDI file) by dragging it onto the Logic Pro icon
in the Dock.

Open a recent project

In Logic Pro, do one of the following:
•

Choose File > Open Recent, then choose your project.

•

In the Project Chooser, click Recent, then double-click the project.

You can clear all items in the Open Recent submenu by choosing Clear Menu.
Tip: If you set the Startup Action in Logic Pro > Preferences > General > Project
Handling to Open Most Recent Project, Logic Pro reopens the last open project
automatically.

Open a demo project

1. In Logic Pro, choose File > New (or press Command-N).
2. In the Project Chooser, select Demo Projects on the left.
3. Double-click one of the demo projects on the right.

Open multiple projects

1. In Logic Pro, open one project, then open one or more additional projects.
2. In the dialog that appears, click Don’t Close.

Switch between open projects
•
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In Logic Pro, choose the project name at the bottom of the Window menu. The active
project is marked with a checkmark.
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Switch between open projects using key commands

When multiple projects are open, you can switch between the current, previous, and next
projects, and between up to 20 projects in the order in which you opened them.
•

Use one of the following key commands (no default assignment):
•

Select Previous Project: Switches to the previously opened project.

•

Select Next Project: Switches to the project that was opened after the current
open project.

•

Select Project 1–20: Switches to the project based on the order in which they
were opened. The last opened project is Project 1, the previously opened project
is Project 2, and so on.

When you open a project, Logic Pro analyzes the project to determine which channels
are needed for project playback. Only plug-ins needed to enable the full signal flow for
playback (including auxes, busses, and outputs) are loaded. This allows projects to quickly
be opened and be ready for playback and editing. While you’re working on the project,
other plug-ins are loaded as needed. You can prevent a track from loading when you open
a project by using the On/Off button in the track header.
Plug-ins load dynamically when the “Only load plug-ins needed for project playback”
checkbox is selected in Project Settings > General.

Save Logic Pro projects

When you save a project in Logic Pro, your recordings and all the changes you make are
saved with the project.
Logic Pro autosaves your work so that you don’t lose important changes if the app quits
unexpectedly. Logic Pro shows a dialog when you reopen the project, asking if you want to
use the autosaved version. If you choose not to, Logic Pro opens the last manually saved
version of the project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can save a project as either a package or a project folder containing the project file
and subfolders for assets used in the project (including audio files, impulse responses,
sample instruments, samples, and Ultrabeat samples).
•

Project package: Project assets are copied to the project package, or are referenced
from another location, depending on which asset types are selected in the Save dialog.
By default, the converted project is saved inside the existing project folder, if one exists.

•

Project folder: Project assets are copied to the appropriate subfolders of the project
folder, or are referenced from another location, depending on which asset types are
selected in the Save dialog. By default, the existing project folder and subfolders are
used, if present, and any additional subfolders needed for project assets are created.

With either a project package or folder, you can choose to copy audio files and other
assets in the project or reference them in another location. Saving assets in the project
ensures that they are still available when you move or copy the project to another location.
You can change how assets are saved later by choosing File > Project Settings > Assets.
For more information, see Manage project assets.
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You can also save a project as a template, and use the template to create new projects.
Templates make it easier to create projects with frequently used instruments or Mixer
configurations, or video or surround projects, for example. Screensets can be customized
for each template or copied between templates using the various Import Settings
commands. For more information, see Import data and settings from other projects.

Save the current project
•

In Logic Pro, choose File > Save.

The first time you save a new project, the Save dialog appears. In the Save dialog, you can
type a name choose the location to save the project.

Save the project with a different name or location
1. In Logic Pro, choose File > Save As.

2. In the Save As dialog, enter a new name for the project.
3. Do one of the following:
•

To save the project as a file (package) containing project assets: select the Organize
my project as: Package button.

•

To save the project as a folder containing subfolders for project assets: select the
Organize my project as: Folder button.

4. Select the type of assets to copy to the project, then click Save.

For more information about managing project assets, see Manage project assets.

Save a copy of the project, including project assets
1. In Logic Pro, choose File > Save a Copy As.

2. In the Save As dialog, enter a new name for the project.
3. Select the type of assets to copy to the project, then click Save.
For more information about managing project assets, see Manage project assets.
When you choose Save a Copy as, copies of all your recordings are saved in the project
copy. You can use the Save a Copy As option for archiving and moving data.
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Save a project as a template
•

In Logic Pro, choose File > Save As Template (or use the corresponding key command),
then enter a name.

In the Project Chooser, click My Templates to view and access templates you have created.
You can organize your templates in folders with the Create Folder button in the Save As
Template dialog. When all your user templates are placed in subfolders, the subfolder
names are shown below the factory collections.
Tip: You can add descriptive text to your templates by adding a comment to the project
file in the Finder. The Templates dialog displays the icon assigned to a template file,
making it easy to change if you wish. For more information on how to add a comment to a
file, or change the icon of a file, see Mac Help.

Revert to the last saved version of a project

If you decide you don’t want to keep your latest edits to a project, you can revert to the last
saved version of the project.
•

In Logic Pro, choose File > Revert to (or use the corresponding key command), then
choose the last saved version (at the top of the list).

Important: After a project is saved as a Logic Pro project, it can no longer be opened in
earlier versions of Logic Pro.

Delete Logic Pro projects

If you no longer want to keep a project, you can delete it from your computer.
Important: If audio files and other assets are stored in a project, they are deleted with
the project.

Delete a project

1. Locate the project in the Finder.
By default, projects are saved in the Logic subfolder in the Music folder on your
computer.
2. Drag the project to the Trash.
If you later decide you want to keep the project, you can drag it out of the Trash if you
haven’t emptied the Trash. After you empty the Trash, the project cannot be recovered.
3. Choose Finder > Empty Trash.
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Play and navigate projects
Play a project in Logic Pro

You can play a project any time you’re working on it, in order to hear your latest changes.
When you play a project, playback starts from the current position of the playhead. If Cycle
mode is turned on, playback starts from the beginning of the cycle area.

Start playback
•

In Logic Pro, click the Play button in the control bar (or press the Space bar).

While the project is playing, the Go to Beginning button in the control bar becomes a
Stop button.

Stop playback
•

In Logic Pro, click the Stop button in the control bar (or press the Space bar).

For more information about project playback, see Control playback with the
transport buttons.

Set the playhead position in Logic Pro

The playhead is the vertical line showing the current playback position in the Tracks area
and other time-based windows (such as the Audio Track Editor, Piano Roll Editor, and
Score Editor).
If your Mac has a Touch Bar, you can use the Touch Bar to set the playhead position.

Set the playhead in the ruler
•

In Logic Pro, click a position in the lower half of the ruler.

Set the playhead position in the Tracks area
•

In Logic Pro, shift-click an empty part of the Tracks area at the new position.

Set the playhead position in the LCD
In Logic Pro, do one of the following:
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•

Click and hold any of the numbers in the Position display and drag vertically.

•

Double-click either display field, and then enter a new position.
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The LCD can display the playhead position in Beats or Time format, or both, depending on
which display mode you choose. Beats displays the playhead position in bars, beats, beat
divisions, and ticks, while Time displays the playhead position in hours, minutes, seconds,
and fractions of a second.
You can edit the individual divisions of the Position display by dragging, or edit the position
as a whole by double-clicking and typing.

Set the playhead to the start of a marker
•

In Logic Pro, click anywhere on the marker while holding down Option.

Set the playhead position using the Touch Bar

1. If your Mac has a Touch Bar, tap the Mode button on the left side of the Touch Bar, then
in Logic Pro tap the Tracks area button
.
2. Tap the Touch Bar at the position you want to set the playhead.

Control playback in Logic Pro

You can use the transport buttons in the control bar to control playback, or to set the
playhead position. You can click the buttons to activate or deactivate functions, or use the
corresponding key commands to speed up your workflow.
The default set of transport buttons includes the Rewind, Forward, Stop, Play, and
Record buttons to the left of the LCD, and the Cycle, Replace, Autopunch, Solo, and Click
(Metronome) buttons to the right of the LCD. You can customize the control bar to show
additional buttons for other functions. For more information, see Customize the control bar.

Control playback with the default transport buttons
In Logic Pro, click any of the following:
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•

Rewind/Fast Rewind button: Moves the playhead one bar to the left. Click and hold to
fast rewind, or drag to scrub playback. Command-clicking moves the playhead to the
previous marker.

•

Forward/Fast Forward button: Moves the playhead one bar to the right. Click and hold to
fast forward, or drag to scrub playback. Command-clicking moves the playhead to the
next marker.
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•

Stop button: Stops playback or recording. Click a second time to move the playhead to
the start of the project, or to the left locator position when in Cycle mode. Right-click
for more stop options. You can also press Return.

•

Play button: Starts playback at the playhead position, or from the left locator position
when in Cycle mode. Right-click for more play options. You can also press Return.

•

Record button: Starts or stops recording on record-enabled tracks. You can also
press Asterisk (*).

Use additional transport buttons

In Logic Pro, click any of the following:
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•

Go to Beginning button: Moves the playhead to the start of the project.

•

Go to Position button: Moves the playhead to a target bar or time position that you
specify in the Go to Position dialog.

•

Go to Left Locator button: Moves the playhead to the left locator position shown in the
ruler. The left locator defines the cycle area start point. Use the cycle area to repeatedly
play, or record over, a section.

•

Go to Right Locator button: Moves the playhead to the right locator position shown
in the ruler. The right locator defines the cycle area end point. Use the cycle area to
repeatedly play, or record over, a section.

•

Go to Selection Start button: Moves the playhead to the start point of the first selected
region or event. You can also press Shift-Return.

•

Play from Beginning button: Plays from the start of the project.
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•

Play from Left Window Edge button: Plays from the leftmost visible point in the active
workspace.

•

Play from Left Locator button: Plays from the left locator position shown in the ruler.
The left locator defines the cycle area start point. Use the cycle area to repeatedly play,
or record over, a section.

•

Play from Right Locator button: Plays from the right locator position shown in the ruler.
The right locator defines the cycle area end point. Use the cycle area to repeatedly play,
or record over, a section.

•

Play from Selection button: Plays from the start point of the first selected region or
event. You can also press Shift-Return.

•

Pause button: Pauses playback or recording, until you click either the Pause or Play
button.

•

Capture Recording button: Captures the most recent performance, even if Logic Pro
was not in record mode while you were playing.

Use transport shortcut menus in Logic Pro

Some transport functions are only accessible from shortcut menus. Both the Stop/Go
to Beginning button and the Play button in the control bar have shortcut menus with
additional transport functions.

Use the Stop button transport functions

1. In Logic Pro, Control-click the Stop/Go to Beginning button in the control bar.
2. Choose any of the following items from the shortcut menu:
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•

Stop: Stops project playback.

•

Stop and Go to Left Locator: Stops playback. The playhead moves to the left locator
position.

•

Stop and Go to Last Locate Position: Stops playback. The playhead moves to the last
locate position.

•

Jump Between Marquee and Project Start: Moves the playhead back and forth
between the marquee start position and the project start position, when Logic Pro is
stopped. Applies only if there is an active marquee selection.

•

Jump Between Cycle and Project Start: Moves the playhead back and forth between
the cycle area start position and the project start position, when Logic Pro is
stopped. Applies only if there is an active cycle area.

•

Jump Between Selected Region and Project Start: Moves the playhead back and
forth between the start position of the first selected region and the project start
position, when Logic Pro is stopped. Applies only if a region or folder is selected.

•

Jump Between Last Locate Position and Project Start: Moves the playhead back and
forth between the last locate position and the project start position, when Logic Pro
is stopped.
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Use the Play button transport functions

1. In Logic Pro, Control-click the Play button in the control bar.
2. Choose any of the following items from the shortcut menu:
•

Play From Marquee Selection: Starts playback within a marquee selection. Playback
stops at the end of the selection unless Cycle mode is on.

•

Play From Cycle: Starts playback from the left locator position when Cycle mode is on.

•

Play From Selected Region: Starts playback from the start of the first selected region.

•

Play From Last Locate Position: Starts playback from the last playhead position.

Use transport key commands in Logic Pro

Some transport functions are available as key commands. Most of these transport key
commands have no default assignment, and need to be assigned manually. See Assign
key commands.
For supported USB MIDI controllers, button controls on the device may be automatically
assigned to transport key commands. For more information, see Automatic MIDI controller
assignment.
•

Play or Stop: Starts or stops playback. Press the Space bar.
Tip: The Space bar can be used to start or stop playback of audio files or regions in
the Audio File Editor, Project Audio Browser, or Loop Browser, when these windows have
key focus.

•

Play from Previous Bar: Starts playback at the start of the previous bar.

•

Stop or Play from Last Position: Stops playback at the current playhead position, or
starts playback from the last playhead position, depending on the play or stop status
when the command is used.

•

Stop and Go to Left Locator: Stops playback, and moves the playhead to the left locator
position.
Note: You can assign this command directly to the Stop button, by Control-clicking the
Stop button and choosing the setting in the shortcut menu.

•

Go to Last Locate Position: Moves the playhead to the last position reached with a
positioning command, or direct positioning of the playhead using the mouse or ruler.

•

Stop and Go to Last Locate Position: As above, but stops playback.
Note: You can assign this command directly to the Stop button, by Control-clicking the
Stop button and choosing the setting in the shortcut menu.
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•

Play or Stop and Go to Last Locate Position: Starts playback at the current playhead
position, or stops playback and moves the playhead to its last position, depending on
the play or stop status when the command is used.

•

Stop and Go to Beginning: Stops playback and moves the playhead to the project start
position.
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•

Shuttle Rewind and Shuttle Forward: Repeated key presses increase the winding
speed. Repeated presses of the opposing shuttle key slow down the shuttle speed,
and eventually change the winding direction. Shuttle disables Cycle mode. Shuttling is
halted by the Stop command.

•

Go to Selection End: Moves the playhead to the end of the first selected region or event
in the active window.

Note: There are also Go To key commands for navigating with markers. For more
information, see Navigate using markers.

Customize the Logic Pro control bar

The control bar offers a default set of buttons and other controls, providing commonly
used options. In the center of the control bar is the LCD, which shows the playhead
position and the project tempo, key, and time signature.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can customize the control bar in the following ways:
•

You can show or hide the entire control bar to maximize the amount of available space
in the main window.

•

You can show or hide individual buttons and other controls in the control bar.

•

You can open one or more giant beats display or giant time display as a floating window.

•

You can configure it to show SMPTE time with or without SMPTE view offset.

•

You can customize the time, tempo, and clock format in Display preferences.

Open a giant beats display or giant time display
In Logic Pro, do one of the following:
•

To open a giant beats display: Click the triangle on the right side of the LCD, then
choose Open Giant Beats Display from the pop-up menu.

•

To open a giant time display: Click the triangle on the right side of the LCD, then choose
Open Giant Time Display from the pop-up menu.

You can open multiple giant beats and time display windows, and resize and reposition
each one independently.
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Turn the Use SMPTE View Offset setting on or off

You can set a SMPTE offset for the project. As songs don’t always need to start precisely
at bar 1, you can select any bar position to be played at the set SMPTE time.
•

In Logic Pro, click the triangle on the right side of the LCD, then choose Use SMPTE
View Offset from the pop-up menu.

Change the time, tempo, and clock format

1. Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).

2. Choose one of the following settings in the Display Time as pop-up menu:
•

With Bits: Subframes (SMPTE bits 0 to 79) are shown.

•

Without Bits: Subframes are not shown.

•

With Quarter Frames: Quarter frames are shown.

•

As Feet Frames, 35 mm film: The display is displayed in feet and frames, for 35mm
film.

•

As Feet Frames, 16 mm film: The display is displayed in feet and frames, for 16mm
film.

•

With Milliseconds: The frame fractions are displayed in milliseconds instead of
SMPTE bits (also called subframes). Remember that this value is dependent on
the frame rate: at 25 fps, a frame is 40 milliseconds long, at 30 fps, approximately
33 ms.

•

With Samples: Frame fractions are shown as sample values.

•

With Frames and Samples: Both fractional frame and sample values are shown.

3. Select the “Zeros as spaces” checkbox if you want zero values to appear as blank
spaces, rather than the number 0 in SMPTE time displays.
4. Choose one of the following settings in the Display Tempo as pop-up menu:
•

Beats Per Minute (BPM, Maelzel): Beats per minute, to four individually adjustable
decimal places.

•

BPM without Decimals: Beats per minute, with no decimal places.

•

Frames Per Click with Eighths: Frames per beat with eighths. After the value, you will
see fpc.

•

Frames Per Click with Decimals: Frames per beat, to four decimal places. Take care,
as this display can easily be confused with the bpm display.

5. Choose a clock format from the Clock Format pop-up menu.
Logic Pro User Guide

141

Change the controls on the control bar

1. In Logic Pro, Control-click the control bar, then choose Customize Control Bar from
the menu.
2. Add or remove a control by selecting its checkbox in the dialog.

3. Do one of the following:
•

Click the Cancel button to keep the previously saved control bar layout.

•

Click the OK button to make the new control layout active.

•

Click the Save As Default button to save your current layout as the default, which is
then applied whenever you create an empty new project, open a new main window,
or click the Restore Defaults button.

•

Click the Restore Defaults button to return to the default layout.

Change the LCD display mode in Logic Pro

In the LCD, located in the center of the control bar, you can view the playhead position in
either time or beats, and set the project tempo, key, and time signature.

Set the display mode for the LCD

The LCD has display modes that let you view the time format in either musical units (bars
and beats) or absolute time units (minutes and seconds), independent of the time format of
the ruler. You can show additional information using the Custom display mode.
•
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In Logic Pro, click the down-pointing arrow on the right side of the LCD, then choose a
display mode from the pop-up menu:
•

Beats & Project: Displays the time format in bars and beats, and displays project
properties (tempo, key, and time signature).

•

Beats & Time: Displays the playhead position in both musical and absolute time
formats.

•

Beats: Displays the playhead position in musical time format.
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•

Time: Displays the playhead position in absolute time format.

•

Custom: Displays the playhead position in both musical and absolute time formats,
and additional information, such as the tempo, key, project end, left and right locator
positions, MIDI In and MIDI Out status, and CPU and HD usage.

Custom display mode is available only when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced. The Beats and Project, Beats and Time, Beats, and
Time modes are available at all user levels.

Monitor and reset MIDI events in Logic Pro

When the LCD is set to Custom, the top line of the MIDI Activity display shows the last MIDI
message received, and the bottom line shows the last MIDI message transmitted. You can
use the MIDI Activity display for checking MIDI connections. When Logic Pro receives more
than one MIDI note simultaneously, the simultaneous notes are interpreted and displayed
as chords.
Sometimes MIDI modules can continue to sound even when no note data is being sent to
them. This indicates that they have not responded to the All Notes Off messages sent by
Logic Pro.

Turn off stuck notes

In Logic Pro, do one of the following:
•

Click the lower section of the MIDI Activity display.

•

Click the Stop button twice in rapid succession.

Stop hung notes
•

In Logic Pro, double-click the MIDI Activity display (or use the Send discrete Note Offs
(Panic) key command).

This sends separate Note Off messages for every note, on all channels of every MIDI port.

Stop unwanted modulation
•

In Logic Pro, use the Send Reset Controllers key command.

This transmits control change message #121, with a value of 0 (reset all controllers),
on all MIDI channels and outputs used by defined instruments. This neutralizes all MIDI
controllers, such as modulation or pitch bends.

Set all MIDI channels to maximum volume
•

In Logic Pro, choose Options > Send to MIDI > Maximum Volume (or use the Send
Maximum Volume key command).

This transmits a control change message #7 (main volume), with a value of 127, on all MIDI
channels and outputs used by defined instruments.
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Use the cycle area in Logic Pro

You can use the cycle area to repeatedly play a particular part of a project. The cycle area
can be used for composing, practicing a part before recording, recording multiple takes,
and other purposes.

When Cycle mode is on, the cycle area is displayed as a yellow strip in the upper part of
the ruler (or in the center, when the secondary ruler is visible).
The left and right locators are the start and end points of the cycle area. When Cycle mode
is turned off, the cycle area (and the locators) are no longer visible.
You can also create a skip cycle to skip a passage during playback; for example, to try
out different transitions from one project section to another without moving regions. Skip
cycle is also useful when editing, to leave out parts of the project that you don’t want to be
affected by the edit.
You can add buttons to the control bar to set, go to, or start playback from the left or right
locator position, and to swap locators (for a skip cycle). For information, see Customize the
control bar.

Turn Cycle mode on or off

In Logic Pro, do one of the following:
•

Click the Cycle button in the control bar (or press C).

•

Click the upper part of the ruler.

Set the cycle area in the ruler
•

In Logic Pro, drag left or right in the upper part of the ruler.

The cycle area appears as a yellow strip in the ruler, and Cycle mode is automatically
turned on.
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Set the locator positions in the LCD

1. In Logic Pro, click the triangle on the right side of the LCD, then choose Custom from
the pop-up menu.
The left and right locator positions appear in both beats and time formats in the LCD.

2. Do one of the following:
•

Click and hold individual units of the left or right locator position, then drag
vertically.

•

Double-click the left or right locator position, then enter a new position.

Set the locator positions automatically

You can set the locator positions (and thereby set the cycle area) to automatically “follow”
the marquee selection, the currently selected region, or selected note in the MIDI region.
1. In Logic Pro, Control-click the Cycle button
Locators.

in the control bar, then click Auto Set

2. Choose any of the following from the shortcut menu:
•

By Marquee Selection: The locators (and the cycle area) are set to the borders of the
marquee selection in the marquee stripe.

•

By Region Selection: The locators (and the cycle area) are set to the borders of the
currently selected region.

•

By Note Selection: The locators (and the cycle area) are set to the bar in which
the selected MIDI note appears. If the note crosses multiple bars, the locators
encompass all the bars in which the note is located.

When Auto Set Locators is selected, the Cycle button changes to indicate that the cycle
area is set automatically.

Set the locator positions using key commands
•
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In Logic Pro, use any of the following key commands:
•

Set Locators by Regions/Events/Marquee: Sets the locators at the start and end
points of the selected regions or events, or the marquee selection.

•

Set Locators and Play: Sets the locators at the start and end points of the selected
regions or events, or the marquee selection, and starts playback.

•

Set Rounded Locators by Regions/Events/Marquee: Rounds the position of the
locators to the barline that is nearest to the beginning and end points of the selected
regions or events, or the marquee selection.
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•

Set Rounded Locators and Play and Set Rounded Locators and Record: Rounds the
position of the locators to the barline that is nearest to the beginning and end points
of the selected regions or events, and starts playback or recording.

•

Set Rounded Locators and Cycle Play and Set Rounded Locators and Cycle Record:
Rounds the position of the locators to the barline that is nearest to the beginning
and end points of the selected regions or events, and switches to cycle play or
record mode.

Move the cycle area
•

In Logic Pro, grab the yellow cycle strip by the middle (the pointer turns into a hand)
and drag it horizontally.

Resize the cycle area

In Logic Pro, do one of the following:
•

Grab the left or right edge of the cycle area to move the start or end points.

•

Shift-click a position in the ruler.
This works even when the stripe is outside the visible range, or Cycle mode is turned
off.

Create a skip cycle

In Logic Pro, do one of the following:
•

Press and hold the Command key while selecting a cycle area in the ruler.

•

Set the cycle area to the part of the project you want to skip, then click the Swap Left
and Right Locators button in the control bar (or use the Swap Left and Right Locator
key command).
The cycle area changes color, indicating that it is now a skip cycle.

You can add the Swap Left and Right Locators button by customizing the control bar. For
information, see Customize the control bar.
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Use the Chase Events function in Logic Pro

If you start playback in the middle of a project, some events might not be heard (such
as MIDI notes, sustain pedal events, and pitch bend events that start before the point
where playback begins). With the Chase Events function, Logic Pro analyzes the project to
include some or all of these events when the project plays back.
There is a potential problem when using Chase Events with notes used to trigger a drum
loop in a sampler. Unless you start the MIDI region precisely at the beginning of the sample
loop, the sample will be triggered at the wrong time and will play out of sync with other
regions (at least until the next trigger note). The problem occurs because most samplers
can only play samples from the beginning, and can’t synchronize them to the beat when
started in the middle.
The Chase Events function is available only when Enable Complete Features is selected
in Logic Pro > Preferences > Advanced.

Set up the Chase Events function

1. In Logic Pro, choose File > Project Settings > MIDI (or use the Open MIDI Project
Settings key command), then click Chase.
2. Select the checkboxes of all events you want to include in project playback.

For more information, see Chase settings.

Avoid triggering sampler drum loops when chasing note events

1. In the Logic Pro Track inspector, select the No Transpose parameter of your drum loop
instrument.
2. Deselect the In ‘No Transpose’ Instrument Channel Strips option in the File > Project
Settings > MIDI > Chase pane.
These settings prevent your sampler’s drum loops from playing until they reach the next
trigger note, whenever the project jumps to a new position.
The No Transpose parameter actually prevents transposition by the region playback
parameters, which is also not desirable for drum sounds or loops.
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Use Apple Remote to control Logic Pro

You can use your Apple Remote to control Logic Pro from a distance. Press the controls as
shown for the following functions:

Press and hold the controls as shown for the following functions:

Note: Apple Remote is compatible with Apple products that have a built-in Infrared (IR)
receiver.

Use Logic Remote to control Logic Pro projects

You can use Logic Remote to remotely control many workflow functions in Logic Pro—project
playback and navigation, recording, loading patches and plug-ins, mixing, and automation.
You can also use Touch Instruments in Logic Remote to play software instruments in
Logic Pro and create custom layouts for the key commands you use most often.
The Smart Help feature in Logic Remote displays detailed Help information about the
Logic Pro interface, commands, and menus. You can view step-by-step instructions for
using Logic Pro on your Mac while you are working, simply by placing the pointer over
different parts of the interface.
You can connect your iOS or iPadOS device to the macOS computer running Logic Pro
either wirelessly or with a Lightning cable.
For more information about using Logic Remote, see Logic Remote Help for iPad or
Logic Remote Help for iPhone. To download Logic Remote from the App Store, choose
Logic Pro > Download Logic Remote, or visit the App Store on your iOS or iPadOS device.
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Set project properties
Logic Pro project properties overview

Each Logic Pro project has properties that include the project tempo, key and scale, time
signature, and sample rate. You can set project properties when you create a project,
and change them later while you’re working. Some project properties, such as tempo and
sample rate, should be set when you create the project if possible, because they can affect
recordings or media files you add to the project, creating extra work.
You can also set the project start and end points and set the overall project
playback volume.

Set the tempo of a project in Logic Pro

You can set the basic project tempo in the LCD. The tempo is displayed in beats per
minute (bpm), ranging from 5 to 990 bpm. You can also tap the tempo using your
computer keyboard.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can set the project tempo in the Tempo track or Tempo List.

Set the basic project tempo

In Logic Pro, do one of the following:
•

•
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Click the down-pointing arrow on the right side of the LCD and choose Beats & Project
from the pop-up menu, then do one of the following:
•

Click and hold the tempo value and drag up or down.

•

Double-click the tempo value, then enter a new value in the Tempo field.

In the Tempo List, do one of the following:
•

Click and hold the tempo value and drag up or down.

•

Double-click the tempo value, then enter a new value in the Tempo field.
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•

Open the Tempo track, then drag the tempo line up or down with the Pointer tool.

•

Assign a key command to Tap Tempo, then use the key command to set the tempo.
The first time you tap the tempo, an alert appears, asking if you want to enable Tap Tempo.

For information about the Tempo List, see Tempo List overview. For information about the
Tempo track, see Logic Pro tempo track overview.

Set the key and scale for a project in Logic Pro

Each project has a key, which defines the central note to which the other notes relate. By
default, new projects are in the key of C major. You can choose a new key when you create
a project, and change it later while you’re working. When you add Apple Loops to your
project, they match the key of the project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also add key signature changes in a project. Key signature changes affect only the
display of MIDI notes in the Score Editor—they do not affect the playback of MIDI regions
or Apple Loops. For more information about key signature changes, see Time and key
signature overview.

Set the project key
•

In Logic Pro, with the playhead at the start of the project, click the triangle on the right
side of the LCD and choose Beats & Project, click the key, then choose a key from the
pop-up menu.

•

In the Score Editor, double-click a staff between the clef and time signature, then
choose a key in the Key Signature dialog. You can also drag the key signature from the
Part box to the beginning of the project.

•

Click the Create Key Signature button in the Signature List.

When you change the project’s scale type from major to minor or vice versa, in some cases
the key may change enharmonically (for example, from Db major to C# minor). These
changes follow common practice for printed music, and affect only the key as shown in the
menu, not the pitch of regions in your project.
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Set the time signature of a project in Logic Pro

Each project has a time signature, which defines how musical time is divided into bars
and beats. The time signature contains two numbers separated by a slash (/), which looks
similar to a fraction. The first number controls the number of beats in each measure, and
the second number controls the beat value (the length of the note that gets one beat).
You can set the time signature of the project in the LCD, the Signature List, or the
Signature track. Changing the time signature does not affect project playback, but does
determine the time grid in the Tracks area and MIDI editors.
The division value defines the duration of the division in all position displays (in the LCD
and in the editors), and forms the basis of the grid for various length and placement
operations. The division value is normally set to 1/16 notes, but can range in value from
1/4 to 1/192 notes. If the note value of the division is equal to or greater than the bar
denominator, the third value of the position display is removed.
Tip: You can use the Set Next Higher/Lower Division key command to switch to the next
highest or lowest division.
The tempo indicator in the LCD always relates to quarter notes, even if eighth notes are
chosen as the denominator for the time signature.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also add time signature changes using the Signature List or the Signature track.

Change the time signature

In Logic Pro, do one of the following:
•

•
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Click the down-pointing arrow on the right side of the LCD and choose Beats & Project,
then do one of the following:
•

Click the time signature, then choose a new time signature.

•

Click the time signature, choose Custom, then enter a new time signature.

In the Signature List:
•

Click and hold the time signature value, then drag up or down.

•

Double-click the time signature value, then enter a new value in the field.
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•

Open the Signature track, then double-click the value shown. Set the Numerator and
Denominator values (and other settings, if you like).

For more information about time signatures, see Time and key signature overview.

Set the sample rate of a project in Logic Pro

The project’s sample rate determines the number of samples Logic Pro uses for audio
playback. When you record or add audio files to your project, their sample rate is matched
to the project sample rate if the “Convert audio file sample rate when importing” project
setting is active. You can turn on this setting in the File > Projects Settings > Assets pane.
The higher the sample rate, the more audio processing power is required when working on
the project. CDs and many music streaming services use the rate of 44.1 kHz, while video
formats commonly use 48 kHz.
Some audio files in your project may not match the newly selected sample rate. The
playback of files that don’t match the project’s sample rate is slower (the file’s sample rate
is higher) or faster (the file’s sample rate is lower) than it should be. You can match the
sample rate of individual audio files to the project sample rate in the Project Audio Browser.

Set the project sample rate

In Logic Pro, do one of the following:
•

Choose File > Project Settings > Audio (or use the Open Audio Project Settings key
command), then choose a sample rate from the Sample Rate pop-up menu.

•

Click the Sample Rate display in the LCD, then choose a sample rate from the pop-up
menu.

Note: If the LCD does not show the Sample Rate display, Control-click the LCD and choose
Customize Control Bar from the shortcut menu. Select the Sample Rate checkbox in the
Customize Control Bar dialog.
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Match a file’s sample rate with the project sample rate
•

In Logic Pro, use the Project Audio Browser’s Copy/Convert File(s) command (which is
also available by Control-clicking the Project Audio Browser or using the corresponding
key command), then replace the file in the project.

Logic Pro performs a real-time, native sample rate conversion. Any sample rate available
in Logic Pro (via Audio > Sample Rate) can be used for the conversion—even if your audio
hardware doesn’t support the selected sample rate.
The native software sample rate conversion function matches the sample rate of any audio
hardware, thereby allowing the playback of projects on virtually any audio system, even if
the hardware is—in sample rate terms—not compatible. Nothing is lost in the process. Any
internal processing and bouncing is always performed at the original sample rate, and at
the highest quality, even in cases where the hardware doesn’t support a particular sample
rate. This feature allows you to work on projects originally created on high-end audio
systems, with lower-end setups.
For example, imagine a project was created with audio hardware set to operate at 96 kHz.
Moving this project to another computer (for example, a notebook computer) that doesn’t
support the original project’s sample rate will result in the wrong playback speed. The
native real-time sample rate conversion function will counteract this effect, allowing
correct playback of the project on the portable computer, at any sample rate.
Note: Higher sample rates not only use up more disk space, but also require more
processing.

Set the start and end points for a project in Logic Pro

A project normally starts at position 1 1 1 1 (as shown in the LCD in Bars mode, or in Bars
and Time mode). You can move the project start point to an earlier position, allowing
upbeats or program change commands to be played before the first downbeat. You
can also move the project end point; for example, to remove unused bars at the end of
the project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Project Start marker and Project End marker are available in the ruler.

Set the project start point
•

In Logic Pro, hold the pointer over the Project Start marker in the ruler until the Project
Start pointer appears, then drag the Project Start marker to the left or right.

As you move the marker, a text box appears showing the position of the project start
and end points.
Note: The Project Start marker can be dragged to the right only when it is located at
position 1 1 1 1 or earlier.
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Set the project end point

In Logic Pro, do one of the following:
•

Hold the pointer over the Project End marker in the ruler until the Project End pointer
appears, then drag the Project End marker to the left or right.

•

Set the value in the LCD’s numerical Project End display (by dragging in the value field
or double-clicking and entering a new value).

Note: If the Project End display doesn’t appear in the LCD, Control-click the LCD and
choose Customize Control Bar and Display in the shortcut menu. Select the Key Signature/
Project End checkbox in the Customize Control Bar dialog.
During playback, a project stops when it reaches the Project End marker. When recording,
the Project End marker moves to accommodate the end of the recording (if recording
extends past the current position of the marker).

Set the playback volume of a Logic Pro project

You can set the basic project playback volume by dragging the Master Volume slider in
the control bar. The Master Volume slider controls the master channel strip in the Mixer,
and acts as a master volume control for the overall project. This slider not only sets the
playback volume of your project, but also affects the overall volume of your mix.

Adjust the project playback volume
•

In Logic Pro, drag the Master Volume slider left or right.

You can also control project volume using the master channel strip in the Mixer.
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Manage projects
Overview of project management in Logic Pro

You can manage Logic Pro projects to control where files used in the project are saved,
how projects are organized, and perform other management functions.
A project can include various assets, which are media files and other files used in the
project. By default, project assets are saved in the project. Assets can also be referenced
from an external location. When you save a project, you can determine whether assets are
saved in the project, or are referenced.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can manage projects in the following ways.
•

Have Logic Pro create a project folder with subfolders for different asset types when
you save a project

•

Create and edit project alternatives for the current project

•

Access different backups, which are manually saved versions of a project

•

Clean up project files to reduce the project size by removing unneeded files

•

Consolidate assets in a project

•

Rename projects from within Logic Pro

•

Set an external audio recording path outside the project or project folder

•

Move files out of project

Use project alternatives and backups in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create alternative versions of a project, each with a unique name and different
settings. Project alternatives let you save “snapshots” of a project in different states,
including different cuts or mixes. They’re saved as part of the project and share
the same assets. Alternatives for the current project appear in the File > Project
Alternatives submenu.
Backups let you go back to earlier saved versions of a project. Each time you save a project
using the File > Save menu item (or pressing Command-S), a version of the current project
alternative is saved (up to ten backups per alternative). In the File > Revert to submenu,
backups for the current alternative are listed in descending order from newest to oldest.

Create a project alternative

1. In Logic Pro, choose File > Project Alternatives > New Alternative.
2. Enter a unique name for the alternative, then click Done.
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Edit project alternatives

1. In Logic Pro, choose File > Project Alternatives > Edit Alternatives.

2. In the Edit Alternatives window, select an alternative from the list, then do either of the
following:
•

To rename the alternative: Click Rename, then enter a new name.

•

To delete the alternative: Click Remove.
You cannot remove the Main alternative.

3. Click Done.

Choose a different alternative
•

In Logic Pro, choose File > Project Alternatives, and choose a different alternative from
the list.

If you have made changes after you last saved the current alternative, a Save dialog
appears, so that you can save your changes in the current alternative before switching to a
different alternative.

Choose a different backup of the current alternative

1. In Logic Pro, choose File > Revert to, and choose a backup from the submenu.
2. In the Revert to Backup dialog, click OK.
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Clean up Logic Pro projects

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can clean up a project by deleting unused or unneeded media files using the Clean
Up command.

Clean up project files

1. In Logic Pro, choose File > Project Management > Clean Up.
2. In the dialog that appears, select the checkboxes for the cleanup options you want to
apply to the current project.
•

Delete Unused Files: Files not used in any project alternative are deleted from the
project, and removed from the Project Audio Browser.
Note: Selecting Delete Unused Files will also select Delete Backups.

•

Delete Backups: Backups for all project alternatives are deleted from the project.

3. Click OK.
4. A dialog appears, showing all of the files to be deleted from the project. To keep any
individual files from being deleted from the project, deselect the Delete checkbox for
those files.
5. Click OK.

Manage project assets in Logic Pro

When you create or save a project, you can choose whether the assets in your project are
saved in the project, or referenced from their location on your computer or a connected
storage device. Assets include audio and video files, samples for the Sampler or Ultrabeat,
and Space Designer reverb impulse response files.
Saving projects without assets can save disk space, but as a result, the project can’t
access the referenced files when moved, unless the assets are also moved.
You can manage project assets in the Assets pane of the Logic Pro project settings. You
can use this pane to determine which specific asset types to save in the project, and which
to reference from their external location.
MIDI data from software instrument recordings, added loops or MIDI files, and parameter
settings for the channel strips and plug-ins are always saved as part of a project.
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Open the Assets project settings

In Logic Pro, choose File > Project Settings > Assets (or use the Open Assets Project
Settings key command).

•

To copy the respective file types to the project: Select any of the copy checkboxes.

•

To automatically convert the sample rate of all imported files (with a different sample
rate) to match the project sample rate: Select the “Convert audio file sample rate
when importing” checkbox.

•

If you deselect the “Copy Sampler audio files into project” option, only Sampler
instrument files are copied to the project when saving, not the samples associated
with the Sampler instrument files.

Files are copied into the project when the project is saved.
Once the project is saved, you can move or copy the project without losing any references
to files in the project.
You can also create your own folder structure to save the project and different assets
in categorized folders, or reference media files anywhere on your system. You can also
specify a recording path for audio files outside the project, in File > Project Settings >
Recording > Audio Recording Path. For more information about Recording project settings,
see Recording settings.
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Consolidate project assets in Logic Pro

Using the Consolidate command, you can create a “consolidated” copy of a project, and
select which types of assets to copy into the consolidated project.

Create a consolidated copy of project assets

1. In Logic Pro, choose File > Project Management > Consolidate (or use the Consolidate
Project key command).

2. Select the checkboxes for the file types you want to copy into the consolidate project,
then click OK.

Rename Logic Pro projects

You can rename the currently open project without leaving Logic Pro.
If the project contains only one alternative, and both have the same name, both
are renamed.
If a project contains multiple alternatives, and all alternatives have their default names
(project name #1, project name #2, and so on), then the project and all alternatives
are renamed.

Rename the current project

1. In Logic Pro, choose File > Project Management > Rename Project.
2. In the dialog that appears, enter a new name for the project.

Copy and move Logic Pro projects

You can copy and move projects in the Finder, using any of the standard macOS file
operations.
When copying or moving project folders, keep in mind that if the project references
external audio files or other assets, these are not copied or moved with the project. Before
copying or moving a project to another computer or storage device, you may want to
specify that all assets are included in the project. For information on managing project
assets, see Manage project assets and Consolidate assets in a project.
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Import data and settings from other Logic Pro projects

You can import data from another project including track content (regions and folders),
plug-ins (including settings), sends (including level, routing, and destination channel
strips), Input/Output assignments, automation, and track notes.
In the All Files Browser, you can choose which data to import in the Track Import view, and
whether to add the data to new tracks in your current project, or replace existing data.
You can also import the following project settings from another project:
•

Screensets

•

Transform sets

•

Hyper sets

•

Score sets, staff styles, text styles, and settings

•

Sync settings

•

Metronome settings

•

Record settings

•

Tuning settings

•

Audio settings

•

MIDI settings

•

Movie settings

•

Asset settings

Import data from another project

1. In Logic Pro, do one of the following:
•

Choose File > Import > Logic Projects.

•

Click All Files in the Browser.

2. Locate and select the project from which you want to import data.
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•

If using the Import dialog, the Import button becomes active.

•

If using the Browser pane, an Import button appears at the bottom-right corner of
the pane.
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3. Click the Import button, or double-click the project file.
The All Files Browser updates to show a Track Import view.

4. Select the data that you want to import by selecting the relevant checkboxes. You can
filter which tracks or channel strip types are displayed using the buttons above the
Track Import table.
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•

Num(ber): Shows the track number. No number is displayed for channel strips that
do not appear in the Tracks area. Folder tracks are also displayed with an entry such
as 3-1, where 3 is the track number and 1 is the folder number. You can double-click
a folder track to reveal its contents at the next level. Note that take folder tracks are
imported with all takes and comps.

•

Name: Shows the track or channel strip name as it appears in the source project.

•

Type: Shows the track or channel strip type.

•

Content: Use to import the region or folder contents of a track. In the case of folder
tracks, you can double-click a folder to access its individual tracks.

•

Cells: Use to import any Live Loops cells in the project.

•

Plug-ins: Use to import any plug-ins and their settings, inserted in a channel strip.
The plug-ins are listed in their insertion order, from the top down. For software
instrument channel strips, instrument plug-ins are also imported.
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•

Sends: Use to import any sends inserted in a channel strip, including level, routing,
and all destination channel strips.

•

I/O: Use to import the I/O settings of a channel strip.
Note: In the case of software instrument channel strips, importing I/O settings does
not include the instrument plug-in. See the Plug-ins entry above.

•

Auto: Use to import track automation data.

•

Notes: Use to import track-specific notes.

Tip: You can customize the Column view by Control-clicking the table header, then
showing or hiding the columns. You can also change the column order by dragging the
column headers. These settings are automatically stored with the preferences when
Logic Pro is closed, and apply to all projects.
Tip: Press the Right Arrow key to select all checkboxes of the selected line, or the
Left Arrow key to deselect them.
5. Do one of the following:

•

To add the selected data to the current project: Click the Add button (or press and
hold Command while pressing the Down Arrow key).
The tracks are added below the selected track in the Tracks area.

•

To replace the data of the currently selected track with the selected data from the
other project: Click the Replace button.
Note: The Replace function only works when data on a single row is selected—not
with multiple row selections.

Import settings from another project
1. In Logic Pro, do one of the following:
•

Choose File > Project Settings > Import Project Settings (or use the corresponding
key command, default: Option-Command-I).

•

Click All Files in the Browser.

2. Locate and select the project from which you want to import settings, then click Import.
Note: If accessing the settings from the Browser pane, you also need to click the Import
Project Settings button, which appears after you click the Import button.
3. In the Import Settings window, select the settings you want to import by selecting the
relevant checkboxes, then click Import.
The settings are imported into the active project.
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Preview Logic Pro projects in the Finder

Every Logic Pro project includes a preview image, so that you can view the contents of a
project in the Finder using Quick Look, without having to open the project. The image is
updated each time the project is saved to show the current state of the project.

Preview a project with Quick Look
In Logic Pro, do one of the following:
•

Select a project file in the Finder, then press the Space bar.

•

Browse to a project file in the All Files Browser, then choose Quick Look from the Action
pop-up menu.

•

Browse to a project file in the All Files Browser, Control-click the file, then choose Quick
Look from the shortcut menu.

A thumbnail image of the selected project file is displayed in Quick Look, together with a
list of project alternatives.

Close Logic Pro projects

You can close the active project when you want to stop working on it.

Close the currently active project
•

In Logic Pro, choose File > Close Project (or press Option-Command-W).

If you have made any changes since the last Save operation, Logic Pro prompts you to save
the project before closing.
Important: The Close Project without Saving key command closes the currently active
project without saving it—and you will not be asked to do so. This command was included
at the request of many experienced Logic Pro users. Only use it if you’re sure that this is
what you want to do.
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View project information in Logic Pro

In the Project Information window, you can view the number of regions and other objects in
a project, the number of different MIDI events, and the amount of memory they use.
A project may occasionally become corrupted due to driver or memory conflicts, or
may feel sluggish. If corruption occurs, Logic Pro displays a warning message letting
you know about the problem. These problems can generally be fixed in the Project
Information window.
The Project Information window also provides the Reorganize Memory function that
allows you to increase the amount of free memory, and to fix a number of potential project
corruptions or problems.

Open the Project Information window

1. In Logic Pro, assign a key command to the Project Information key command.
The Project Information key command has no default assignment.
2. Use the Project Information key command to show the Project Information window.

Reconfigure project memory
•

In Logic Pro, click the Reorganize Memory button in the Project Information window.

When you reorganize memory, Logic Pro checks the current project for any signs of
damage, structural problems, and unused blocks. If any unused blocks are found, you will
be able to remove these, and repair the project.
Note: Logic Pro also reorganizes project memory automatically after saving or opening
a project. A common (and good) use of this feature is to free up memory after closing a
project, if two or more projects were open prior to the Close operation.
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Work with tracks

Overview of tracks in Logic Pro

Tracks help you organize and control the sound of the recordings and other material in a
project. You record and arrange audio and MIDI regions on tracks in the Tracks area. Each
track is assigned to a channel strip in the Mixer.
When you create a track, you choose the track type, format, and output. You can also
choose a patch, which controls the sound of the track, and modify the sound of a patch
using Smart Controls.

A Logic Pro project can include the following track types:
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•

Audio tracks: Contain audio regions from audio recordings, audio Apple Loops, and
imported audio files.

•

Software instrument tracks: Contain MIDI regions from software instrument recordings,
software instrument Apple Loops, and imported MIDI files.

•

Drummer tracks: Behave like software instrument tracks, but with no MIDI input.
Drummer tracks support the Drum Kit Designer plug-in so you can add virtual drummers
to your projects. For more information, see Overview.

•

External MIDI tracks: Contain MIDI regions that send MIDI data to an external MIDI
device.

•

Folder tracks: Contain folders, which are containers for multiple tracks and regions.
Unlike other tracks, folder tracks are not assigned to a channel strip in the Mixer.
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Each track has a track header located to the left of the track, which shows the track’s name
and icon. Track headers also contain controls that you can use to mute, solo, and adjust
the volume level and pan position of the track, and control the track in other ways.
You can use Track Stacks to organize projects with high track counts, and simplify the
creation of audio subgroups for related tracks. There are several different types of Track
Stacks, designed for different situations.
You can edit track parameters for the selected track in the Track inspector.
Additionally, there are other track types called global tracks. Global tracks, which appear
below the ruler in the Tracks area and in linear editors, are used to view and edit different
aspects of the overall project, such as tempo and transposition, which affect all tracks in
the project.

Track basics
Create tracks in a Logic Pro project

You add tracks to a project to hold your recordings, loops, and other material. When you
add a track, you can choose the track type, format, input source (for audio tracks), and
output, and create multiple tracks. The options in the New Tracks dialog vary, depending
on the type of track you are creating.
When you create a new track, a corresponding new channel strip is also created. The new
track appears in the Tracks area, and the new channel strip appears in the Mixer. You can
choose a patch, which controls the sound of the track.

Create one or more new tracks

1. In Logic Pro, click the Add Tracks button

, located above the track headers.

2. Select the track type in the upper part of the New Tracks dialog.
3. If the Details area at the bottom of the New Tracks dialog is closed, click the Details
disclosure arrow to open it.
4. Do one of the following, depending on the track type:
•

For audio tracks: Choose the input channel or channels from the Audio Input pop-up
menu.

•

For software instrument tracks: Choose an instrument plug-in from the Instrument
pop-up menu.
Note: When Logic Pro > Preferences > Display > General > “Show icons in New
Tracks dialog” is selected, choose An Instrument Plug-in from the Use pop-up menu.

•

For external MIDI tracks: Select the “Use External Instrument plug-in” checkbox,
then choose the device and the input channel or channels from the MIDI Destination
pop-up menu.
Note: When Logic Pro > Preferences > Display > General > “Show icons in New
Tracks dialog” is selected, choose An external USB or MIDI Device from the Use
pop-up menu.

•
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For Drummer tracks: Choose the genre from the Genre pop-up menu.
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Tip: Below the Input pop-up menu, a line of text shows the current input device.
To change the input device, click the arrow next to the device name, then change the
device in the Audio preferences pane.
5. Choose the audio output and output channel (or channels) from the Output pop-up
menus.
Tip: The current output device is listed below the Output pop-up menu and
associated checkboxes. To change the output device, click the arrow next to the text,
then choose another device in the Audio preferences pane.
6. Do any of the following:
•

To set the number of multi-timbral parts for software instrument tracks: Select the
Multi-timbral checkbox, then enter the number of multi-timbral or layer parts.
Multi-timbral refers to the number of different sounds a software instrument can play
simultaneously.

•

To have the Library open automatically so you can choose a patch for the track:
Select the Open Library checkbox.
Tip: Deselect the Open Library checkbox if you want to add an empty track
containing no plug-ins.

•

To include the default patch for audio tracks: Select the Load Default Patch
checkbox.

•

To choose an instrument plug-in for software instrument tracks: Choose the
instrument plug-in from the pop-up menu below the Load Patch or Instrument Plugin checkbox.

•

To turn on monitoring for audio tracks: Select the Input Monitoring checkbox.
When Logic Pro > Preferences > Display > General > “Show icons in New Tracks
dialog” is selected, the checkbox is labeled “I want to hear my instrument as I play
and record.”

•

To record-enable audio tracks: Select the Record Enable checkbox.
When Logic Pro > Preferences > Display > General > “Show icons in New Tracks
dialog” is selected, the checkbox is labeled “Prepare new audio tracks for immediate
recording.”

•

To create multiple tracks: Select the number in the “Number of tracks to create”
field, and enter a new number.

7. Click Create.
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The new track appears in the Tracks area. If the Open Library checkbox is selected, the
Library opens so you can choose a patch for the track.

For information about choosing patches, see Choose a patch.

Create an empty track
Do one of the following:
•

To create an empty track of the same type as the focused track: Hold down Option and
click the Add Tracks button .

•

To create an empty track of the opposite type as the focused track: Hold down OptionShift and click the Add Tracks button .

Create a track below the selected track

1. In Logic Pro, Control-click the track header.
2. Choose a track type from the shortcut menu.
A new track of the chosen type, with default settings, is created below the selected track.

Create a track below all existing tracks

1. In Logic Pro, select a track of the same type as the one you want to create.
2. Double-click the empty area below the track headers.
When you create a Drummer track, the track contains one 8-bar region. For more
information about working with Drummer tracks, see Overview.
You can also Create an Instrument track from an audio recording using Flex Pitch.

Logic Pro User Guide

168

Create tracks using drag and drop in Logic Pro

You can quickly create a new track by dragging one or more audio files, regions, or Apple
Loops to the area below all existing tracks in the Tracks area. When you drag an audio file
to the area below existing tracks, an audio track is created; when you drag a region or an
Apple Loop, a track of the corresponding type (audio, software instrument, or Drummer)
is created.
You can create a new software instrument track by dragging an audio file, audio or
software instrument region, or Apple Loop to the area below the track headers in the
Tracks area, or between two existing tracks. When you create a track by dragging
content, you can choose whether the track uses a Quick Sampler, Alchemy, Drum Machine
Designer, or Sampler instrument plug-in. For Quick Sampler, Alchemy, and Sampler, there
are additional choices for how the plug-in processes the material. After the new track is
created, the instrument plug-in you selected opens for viewing and editing.
When you create a new track by dragging a software instrument region, either below the
track headers or between tracks, the region is bounced to an audio file, which is then used
by the chosen instrument plug-in on the track.
Note: To quickly create a track with predetermined slices and mapping, drag the content
to the Drum Machine Designer zone. If you want to be able to edit individual slices, drag
the item to one of the Quick Sampler zones. With Quick Sampler set to Slice mode, you
can edit individual slices. After you finish editing slices in Quick Sampler, you can create a
Drum Machine Designer instrument using the command “Create Drum Machine Designer
Track” in the Action pop-up menu.

Create tracks with a Sampler plug-in (single files only)

Dragging an audio file to one of the available Sampler zones creates a software instrument
track with a Sampler instrument plug-in.
•

Sampler (Zone Per Note) creates a software instrument track with a Sampler instrument
plug-in with a zone for each detected note in the audio file.

See the Sampler chapter in Logic Pro Instruments.

Create a track with a Quick Sampler plug-in (single files only)

Dragging content to one of the available Quick Sampler zones creates a software
instrument track with Quick Sampler as the instrument plug-in. Depending on the audio
material, Quick Sampler uses Slice, One Shot, or Classic sample mode to process
the content.
•

Quick Sampler (Original) uses the original tuning, loudness, looping, and length of the
content.

•

Quick Sampler (Optimized) analyzes the content and optimizes its tuning and loudness,
searches for loop points, and crops silence.

See the Quick Sampler chapter in Logic Pro Instruments.
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Create a track with an Alchemy plug-in (single files only)

Dragging content to one of the available Alchemy zones creates a software instrument
track with an Alchemy instrument plug-in using the synthesis type you choose: Additive,
Granular, or Spectral.
See the Alchemy chapter in Logic Pro Instruments.

Create a track with a Drum Machine Designer plug-in (single or multiple
files)

Dragging content to the Drum Machine Designer zone creates a software instrument track
with a Drum Machine Designer instrument plug-in using the sliced audio content, and a
MIDI region to trigger the slices. When multiple items are dragged, each file or region is
placed on its own pad in the Drum Machine Designer grid, rather than being sliced and
placed on multiple pads.
See the Drum Machine Designer chapter in Logic Pro Instruments.

Create tracks with a Sampler plug-in (multiple files only)

Dragging multiple audio files to one of the available Sampler zones creates a software
instrument track with a Sampler instrument plug-in using the mapping method you choose.
•

Sampler (Chromatic Map) maps samples to successive chromatic notes.

•

Sampler (Optimized Map) maps samples according to analysis of the material.

See the Sampler chapter in Logic Pro Instruments.

Add a track by dragging an audio file, region, or loop to the Tracks area

1. Drag one or more audio files, regions, or Apple Loops to the area below all existing
tracks in the Tracks area.
A track of the corresponding type is added below the existing tracks.
When you drag multiple audio files, regions, or loops, an Add Files to Tracks dialog
appears.
2. For multiple audio files, select whether to create new tracks, use existing tracks, or
place all files one one track.

Add a track by dragging a single file, region, or loop to the track header area
1. In Logic Pro, do one of the following:
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•

Drag an audio file, region, or Apple Loop to the area below the track headers.

•

Hold down the Command key and drag an audio file, region, or Apple Loop between
two existing track headers.
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2. When the “Create New Track using” dialog appears, drag the item to one of the
available zones to choose the type of instrument plug-in used on the track.

Add a track by dragging multiple files, regions, or loops to the track header area
1. In Logic Pro, do one of the following:
•

Drag multiple audio files, regions, or Apple Loops to the area below the track
headers.

•

Hold down the Command key and drag multiple audio files, regions, or Apple Loops
between two existing track headers.

2. When the “Create New Track using” dialog appears, drag the items to one of the
available zones to choose the type of instrument plug-in used on the track.

You can control whether or not the the plug-in window opens after new tracks are created
using the Logic Pro > Preferences > Display > Mixer > Plug-in Window > Open plug-in
window on insertion checkbox.
In addition to creating tracks, you can drag an an audio file, audio or software instrument
region, or Apple Loop to the track header of a software instrument track with one of the
above-mentioned instrument plug-ins to replace the current sample (on a track with Quick
Sampler or Alchemy, or a Drum Machine Designer subtrack with Quick Sampler) or add
the content as a new sample (on a track with Sampler or a Drum Machine Designer master
track). See Insert an instrument plug-in on a track and the relevant chapters in Logic Pro
Instruments.
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Create tracks using existing channel strips in Logic Pro

When you create a new track using the New Tracks dialog, a new channel strip for the
track is also created. In some situations, however, you may want to create tracks that use
existing channel strips.
For example, when using a Sampler instrument with a drum kit loaded, you may want
to send multiple tracks, with MIDI regions that trigger individual drum sounds, to the
channel strip on which the Sampler instrument is inserted. Having a separate track for
each sound allows you to independently mute or solo sounds in the kit. If you use a multioutput version of the Sampler instrument, you can process each sound in the drum kit with
different effects.
You can also copy tracks in the Tracks area. The copied track uses the same channel strip
as the original track, and all selected regions are moved from the original track to the copy.
This allows you to double-track or “thicken” parts, and makes it easier to create unison
voicings (an octave apart) software instrument (or external MIDI instrument) tracks. After
copying the track, you can replicate or restore the copied regions on the original track.

Create a track with the same channel strip or instrument assignment
1. In Logic Pro, select a track in the Tracks area.
2. Do one of the following:
•

Choose Track > Other > New Track With Same Channel (or use the corresponding
key command).

•

Option-click the Duplicate Track button

above the track headers.

A new track is created below the selected track.

Create a track with the next channel strip or instrument assignment
•

In Logic Pro, select a track in the Tracks area, then choose Track > Other > New Track
With Next Channel (or use the corresponding key command).

This command creates a new track below the selected track, and assigns the next channel
strip to it. If no next channel strip exists, one is created automatically.
If the selected track is a part or sub-channel track of a multi-timbral software instrument
or external instrument, the command is New Track with Next MIDI Channel. A new track is
created, with the next MIDI channel assigned to the same multi-timbral software instrument
or external MIDI device.

Create a new track for selected regions
•

In Logic Pro, select the regions, then choose Track > Other > New Track For Selected
Regions.

The selected regions are moved from the source track to the new track, which uses the
same channel strip as the source track. In other words, only one channel strip is used for
all tracks.
If you use this command with regions selected across several tracks, a new track is created
for each source track. For example, if you select regions on three source tracks, three new
tracks will be created for the regions.
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Create a new track for overlapped regions
•

In Logic Pro, select the regions, then choose Track > Other > New Track For Overlapped
Regions.

New tracks are created for wholly or partly overlapped regions, which are redistributed
across the newly created tracks. A new track is created for each overlap. All tracks use the
same channel strip as the original track. In other words, only one channel strip is used for
all tracks.

Copy a track in the Tracks area
•

In Logic Pro, option-drag the track header up or down.

All selected regions and any automation data on the original track are copied to the new
track. The new track has the same channel strip as the original track.

Replicate or restore regions on the original track
•

In Logic Pro, option-drag the regions on the destination track.

Assign tracks to different channel strips in Logic Pro

You can reassign a track to a different channel strip. For example, you can reassign the
output of a software instrument track to another instrument channel strip, so that the MIDI
regions on both tracks are played through the same software instrument plug-in.

Reassign a track to a different channel strip
1. In Logic Pro, Control-click the track header.

2. Choose Reassign Track from the shortcut menu, then choose a channel strip from the
submenu.
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Globally reassign multiple tracks that share the same channel strip
•

In Logic Pro, press and hold Option when reassigning a track channel strip, then confirm
the action by clicking the Reassign All Tracks button.

The new channel strip will be used for every track that shared the original channel strip in
the current project (including tracks in folders).
In addition to reassigning tracks to channel strips, you can reassign them to either of the
following destinations:
•

No Output: Tracks assigned as No Output send no data. This can be useful in situations
in which you want to store data (such as SysEx) that you don’t want to send from
Logic Pro.

•

Folder: This setting is used when you want the track to play a folder region. (See
Folders overview.) Normal regions will not play on a track set up for folder playback.

Select tracks in Logic Pro

Some track operations, such as duplicating tracks or assigning tracks to a different channel
strip, require that you first select the track or tracks.
You can select multiple tracks. When multiple tracks are selected, the first selected track
is the focused track. Some operations, such as choosing a patch in the Library, only affect
the focused track when multiple tracks are selected.
When multiple tracks are selected, the track number of the focused track also appears
selected (lighter gray color) on the left edge of the track header, unlike the other
selected tracks.

Select a track
•

In Logic Pro, click any empty part of the track header.

When you select a track, all regions on the track (or those that fall within the cycle, if Cycle
mode is on) are selected. To select a track without changing the current region selection,
Option-click the track.

Select multiple tracks

In Logic Pro, do one of the following:
•

To select adjacent tracks: Press and hold Shift as you click the track headers.

•

To select nonadjacent tracks: Press and hold Command as you click the track headers.

Select the track above or below the selected track
•
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In Logic Pro, use one of the following key commands:
•

Select Previous Track

•

Select Next Track

174

Change the focused track in a multiple selection

When multiple tracks are selected, only one can have focus. You can change the focused
track while keeping the multiple selection using the track numbers.
•

In Logic Pro, with multiple tracks selected, click the track number (to the left of the
track header) for the track you want to have focus.

Deselect all selected tracks
•

In Logic Pro, select any unselected track.

Duplicate tracks in Logic Pro

You can duplicate a track, creating a new track below the original track with the same
instrument and effects settings. The duplicate track is empty, and does not contain
any regions.

Duplicate a track
•

In Logic Pro, select the track, then do one of the following:
•

Click the Duplicate Track button

, located above the track headers.

•

Choose Track > Other > New Track With Duplicate Settings.

To copy regions from the original to the duplicate track, Option-drag them.

Rename tracks in a Logic Pro

When you choose a patch for a track, the track takes the name of the patch. You can
rename a track at any time.

Rename a track

In Logic Pro, do one of the following:
•

Double-click the name in the track header, then enter a new name for the track.

•

Control-click the track header, choose Rename Track from the shortcut menu, then
enter a new name for the track.

Rename multiple tracks

You can rename multiple tracks by renaming channel strips in the Mixer. See Rename
multiple channel strips.
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Change track icons in Logic Pro

By default, tracks use the same icon as the patch chosen for the track. You can change a
track’s icon at any time.

Change the icon for a track

In Logic Pro, do one of the following:
•

Control-click the icon in the track header, then choose a new icon from the shortcut
menu.

•

Select the track, click the track icon in the Track inspector, then choose a new icon
from the Icon pop-up menu.

•

Select the track, choose Track > Assign Track Icon, then choose a new icon from the
Icon pop-up menu.

Add a custom track icon

1. In Logic Pro, Control-click the icon in the track header, then choose Custom Icons from
the shortcut menu.
2. Click the Add button (+) in the upper left area of the Icon palette.
3. Browse to the location of the image file and select the file.
4. Click Open.
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Change track colors in Logic Pro

By default, track colors reflect the track type. You can change the color of specific
tracks, to use color to help visually organize the Tracks area and identify tracks in a large
arrangement. Track colors are visible when you configure track header components to
show the track color bars.
Changing the color of a track also changes the color of the corresponding channel strip in
the Mixer.

Change the color of a track

In Logic Pro, do one of the following:
Select the track, choose Track > Assign Track Color, then select a color from the
Color palette.
Control-click the track header, choose Assign Track Color from the shortcut menu, then
select a color from the Color palette.

Reorder tracks in Logic Pro

You can reorder tracks in the Tracks area. Changing the order of tracks doesn’t affect the
sound of a project, but lets you organize tracks visually to keep instruments in a particular
order, or keep related tracks together. For example, you can keep all drum tracks together,
or keep all tracks that double the same melody together.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also sort tracks by choosing one of the options in the Track > Sort Tracks By menu.

Reorder tracks
•

In Logic Pro, press and hold an empty part of the track header, then drag the track up or
down.

Sort tracks
•
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In Logic Pro, choose Track > Sort Tracks By, then choose an item from the submenu:
•

MIDI Channel

•

Audio Channel

•

Output Channel

•

Instrument Name

•

Track Name

•

Used or Unused
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Zoom tracks in Logic Pro

In the Tracks area, tracks can be zoomed using the Tracks area zoom controls (and
Waveform Zoom slider) and also zoomed independently. When a window is first opened,
there is a default zoom setting that provides a compromise between optimal visibility and
working space in the Tracks area.
You can also vertically zoom the Tracks area to fill the available space.

Zoom a track

1. In Logic Pro, move the pointer to the bottom-left corner of a track.
The pointer changes to a pair of up- and down-pointing arrows.

2. Drag vertically.
The individual track zoom factor, compared to the overall window zoom level, is shown
in the help tag while the mouse button is held down.

Automatically zoom the focused track

When multiple tracks are selected, the first selected track is the focused track. You can
zoom the focused track.
•

In Logic Pro, choose View > Zoom Focused Track from the Tracks area menu bar (or
press Control-Z).

Zoom all tracks

1. In Logic Pro, move the pointer to the bottom-left corner of a track.
The pointer changes to a pair of up- and down-pointing arrows.
2. Press and hold Command while dragging up or down.

Reset all tracks to the default zoom level

1. In Logic Pro, move the pointer to the bottom-left corner of a track.
The pointer changes to a pair of up- and down-pointing arrows.
2. Press and hold Shift while dragging up or down.
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Zoom tracks using key commands

In Logic Pro, use any of the following key commands:
•

Individual Track Zoom In and Individual Track Zoom Out: Increases or decreases the
“individual track zoom” factor of the selected track by one.

•

Toggle Individual Track Zoom: Switches the selected track between its individual zoom
level and the window zoom level. This option is useful for zooming in on a track to edit
its automation data. After editing, use the Toggle Individual Track Zoom key command
to return to the original zoom level.

•

Individual Track Zoom Reset: Resets the selected track to the window zoom level.

•

Individual Track Zoom Reset for All Tracks: Resets all zoomed tracks to the window
zoom level.

Replace or double drum sounds in Logic Pro

Using drum replacement, you can replace individual drum sounds on an audio track without
re-recording the entire track. To replace or double the drum sounds, you use an audio track
that contains a recording of a single drum (or other percussion instrument) to create a
software instrument track with matching MIDI trigger notes. The software instrument track
plays drum samples using the Sampler instrument.

Replace or double a recorded drum signal

1. In Logic Pro, select the audio track with the drum recording.

2. Choose Track > Replace or Double Drum Track (or use the corresponding key
command).
The following changes take place in the Tracks area:

Logic Pro User Guide

•

All files on the selected audio track are analyzed for transients (if they have not been
previously analyzed). The selected track is vertically zoomed.

•

A software instrument track is created below the audio track, and the Sampler
instrument is inserted into the Instrument slot.

•

The Library opens with the Sampler instrument selected, so that you can choose the
sound that best matches the project.

•

A MIDI region containing trigger notes based on the detected transients is created
on the software instrument track.
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•

The Drum Replacement/Doubling dialog opens.

3. In the Drum Replacement/Doubling dialog, set the following parameters:

•

Instrument pop-up menu: Choose the drum sound you want to replace or double
(Kick, Snare, Tom, or other).

•

Mode buttons: Choose one of the following modes:
•

Replacement: The new sound replaces the original, and all regions on the original
track are muted.

•

Doubling: The new sound is added to the original (the original sound is not muted).

•

Relative Threshold slider: Set the threshold value for transients, above which trigger
notes are generated.

•

Preview button: Click to start playback of both the original (audio) and replacement
(software instrument) track from the current playhead position. The two tracks are
soloed, so all other tracks in the project are silent.
You may want to set the playhead or activate the cycle area to preview a part of the
project requiring special attention for drum replacement. Click Preview again to stop
playback, return the playhead to the previous play position, and unsolo the two tracks.
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•

Trigger Note pop-up menu: Set the pitch of the trigger notes created on the
software instrument track. Choosing AUTO (the default setting) sets the trigger note
as follows:
•

Kick = C1 (36)

•

Snare = D1 (38)

•

Tom = A1 (45)

•

other = C3 (60) and AUTO menu not available, as there is no automatic choice for
this setting.

Note: Any changes to the trigger note do not change the instrument setting.
However, any changes to the instrument setting change the trigger note, either to
Auto or C3 (60).
•

Timing Offset slider: Shift the position of trigger notes earlier (negative values) or
later (positive values). The offset should normally be set to 0.0 ms (which places the
MIDI trigger notes exactly at transient timing positions), but may need to be adjusted
when using your own, or third-party, instruments.

•

“Set average attack time” button: Set the average offset of all regions on the source
audio track.

4. Click OK to confirm the action.
Clicking OK resets the vertical zoom of the original audio track, mutes its regions if
you selected the Replacement option, and deselects the track. MIDI trigger notes for
the Sampler instrument are created on the software instrument track, and the track is
selected.

Use track header controls
Overview of track header controls in Logic Pro

Each track includes a track header that displays the track name and icon and features a
number of track controls. By default, these include Mute, Solo, and Record Enable buttons
on all tracks and an Input Monitoring button on audio tracks.

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional track header controls are available, including On/Off and Hide buttons, and Track
Number and Color Bars options.
You can customize the track header by showing or hiding different track header controls,
to optimize your workflow. You can also resize the track headers to give yourself more
room to work in the Tracks area.
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Show or hide track header components

1. In Logic Pro, Control-click the track header.
2. Choose Track Header Components from the shortcut menu, then select or deselect
items from the submenu. Selected items are indicated with a checkmark.

Configure track header components

1. In Logic Pro, open the Track Header Configuration popover by doing one of the following:
•

Choose Track > Configure Track Header (or use the corresponding key command).

•

Control-click any track header, then choose Configure Track Header from the
shortcut menu.

2. Modify the track header elements in the Track Header Configuration popover.
•

Buttons section: Select the checkboxes of the buttons you want to display in the
track header.

•

Controls section: Select checkboxes to display volume and pan controls. From the
pop-up menu, choose whether the Pan knob controls the pan/balance setting, or the
level of one of the available sends.

•

Additional Name Column pop-up menu: Choose which if any items are displayed in
the additional name column.

•

Other View Options section: Select the checkboxes of the buttons you want to
display in the track header.
•

Control Surface Bars checkbox: When selected, control surface bars appear,
indicating which tracks are accessed by control surfaces connected to your
system. Each control surface can be assigned a different color in the Device
inspector. For more information, see the Logic Pro Control Surfaces Support
manual.

•

Track Numbers checkbox: Select to display track numbers on the left side of the
track headers. Tracks are numbered automatically in ascending order.
During playback, each track number is replaced with a small level meter showing
the output level (for audio tracks) or velocity value (for software instrument tracks).

•

Color Bars checkbox: Select to show a color bar on the left edge of each track
header.

•

Groove Track checkbox: When selected, the groove indicator appears on the left
edge of each track header.

•

Track Icons checkbox: Select to show track icons in the track header.

•

Track Alternatives checkbox: Select to show the Track Alternatives menu in the
track header.

3. To close the popover, click outside its borders.

Horizontally resize all track headers

1. In Logic Pro, position the pointer over the line dividing the track headers from the left
edge of the tracks.
The pointer changes to a Resize pointer.
2. Drag the line left or right to resize the track headers.
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Mute tracks in Logic Pro

You can silence, or mute, a track so that you don’t hear it when you play the project.
Muting tracks is useful when you want to hear how the project sounds without the track,
compare alternative versions of a track, or try different loops in a project.
When you mute a track using the Mute button, the channel strip to which the track is
assigned is muted; all tracks in the project that use the same channel strip are also
silenced. Plug-ins on the muted channel strip are still processed, however, so the system
responds very quickly when tracks are muted or unmuted.
You can silence individual tracks assigned to the same channel strip by turning them off.

Mute a track
•

In Logic Pro, click the track’s Mute button

in the track header.

Mute a track when the Mute buttons are hidden
•

In Logic Pro, use the Toggle Track Mute key command (M) to mute and unmute a track.

Mute multiple tracks
•

In Logic Pro, click and hold a Mute button

, then drag the pointer up or down.

The Mute buttons of all swiped tracks switch to the same state.
You can also use the Toggle Track Mute of all Tracks of Folder key command.

Mute all tracks
•

In Logic Pro, press and hold Command while clicking the Mute button
header.

in a track

All Mute buttons that match the state (muted or unmuted) of the clicked button also
switch to its new state. For example, if you click an unmuted Mute button, all unmuted
tracks are then muted.
Muted tracks and regions appear slightly differently in the Tracks area, depending on how
they are muted:
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•

When a track is muted using its Mute button, the regions on the track are gray, but the
region names are in color.

•

When a track is turned off using its On/Off button, both the regions on the track and the
region names are gray.

•

When an individual region is muted, the region and its name are gray, and a small
colored dot precedes the name.

•

When a track is muted because another track is soloed, the regions on the track are
gray, but the region names are in color.
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Solo tracks in Logic Pro

You can solo a track, silencing all tracks that are not also soloed. Soloing tracks is useful
when you want to work on a track individually, or work on a few tracks, without hearing the
other tracks in the project.
The first time any track in a project is soloed, a large Clear/Recall Solo button appears in
the area above the track headers. You can quickly unsolo or resolo all soloed tracks using
this button.

Solo a track
•

In Logic Pro, click the Solo button

in the track header.

The Solo button turns yellow, and the Mute buttons of all unsoloed tracks flash blue.
Click the button a second time to restore the track to its previous state.

Solo a track when the Solo buttons are hidden
•

In Logic Pro, click the Solo button in the control bar, then click the track.

Solo multiple tracks

In Logic Pro, do one of the following:
•

Click and hold a Solo button

in a track header, then drag the pointer up or down.

The Solo buttons of all swiped tracks switch to the same state.
•

Press and hold Shift while the Solo button in the control bar is active, then click the
names of the tracks you want to solo.

Unsolo all soloed tracks
•

In Logic Pro, click the Clear/Recall Solo button in the area above the track headers.
To resolo all previously soloed tracks, click the Solo button above the track headers
again.

Set track volume levels in Logic Pro

You can set the volume level of each track, to balance the relative volume of the tracks in
your project.

Adjust track volume
•

In a Logic Pro, track header, drag the Volume slider left to lower the volume level, or
drag it right to raise the volume level.

Note: You might have to resize the track header in order to see the Volume slider.
•

Option-click the slider to return it to a neutral level (0 dB gain).

The level meter in a track’s Volume slider shows the output volume for the track as the
project plays. You can watch the level meter as you record to the track to see if clipping
occurs on the track.
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Set track pan positions in Logic Pro

The Pan/Balance (pan is short for panorama) knob controls whether a track is heard from
the left, right, or center of the stereo field. You can set the pan or balance position for each
track in a project.
Mono channel strips feature a Pan knob, which determines the position of a mono signal in
the stereo image. At the center position, the Pan knob sends equal amounts of the signal
to both sides of the stereo image. If you turn the Pan knob to the left, more of the signal
moves to the left.
Stereo channel strips display a Balance knob, which differs from the Pan knob in that it
controls the relative levels of two signals (Left and Right) at the stereo outputs.
Alternatively, you can use the Pan/Balance knob to control the send level for a send on the
track’s channel strip by first choosing the send, then adjusting the send level using the
Pan/Balance knob.

Adjust a track’s pan or balance position
•

In a Logic Pro track header, drag the Pan/Balance knob counterclockwise to pan to the
left, or drag clockwise to pan to the right. The line on the knob indicates the position.

Note: You might have to resize the track header in order to see the Pan/Balance knob.
•

Option-click the Pan/Balance knob to return it to the center position.

Control a track’s send level

1. In Logic Pro, do one of the following:
•

In the track header, Control-click the Pan/Balance knob, then choose a send from
the shortcut menu.

•

Control-click the track header, choose Track Header Components from the shortcut
menu, then choose the send from the submenu.

2. Drag the Pan/Balance knob to adjust the send level.
When a channel strip output is set to Surround, the Pan or Balance knob is replaced by a
Surround Panner. For information about using surround channel strips, effects, and the
surround panner, see Logic Pro surround overview.
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Enable tracks for recording in Logic Pro

You enable (arm) a track for recording using the Record Enable button in the track header.
Similar to corresponding buttons on a hardware multitrack recorder, Record Enable buttons
have multiple states:
•

For audio tracks: Off (gray), Armed (blinking red), Recording (solid red). For the focused
track, the letter R in its Record Enable button turns red to indicate that it will be enabled
together with the Record function.

•

For software instrument tracks: Off/No input (gray), Receiving MIDI input and/or
Recording (solid red).

You can record enable multiple audio tracks, as long as each track has a unique input
(chosen in the Input slot). Multiple tracks that use the same input cannot be simultaneously
enabled for recording. If several tracks are assigned to the same channel strip (for
example, “Audio 1”), the new audio region is recorded to the focused track assigned to the
channel strip. If none of the record-enabled tracks is focused, the region is recorded to the
first (uppermost) of the tracks. For more information, see Record to multiple audio tracks.
If you record enable multiple software instrument tracks, a new MIDI region is recorded
on the focused MIDI track, and an alias of the recorded MIDI region is created on the
other record-enabled MIDI tracks. For more information, see Record to multiple software
instrument tracks.
Note: When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Record Enable buttons appear with the letter R. When Enable Complete Features is not
selected, Record Enable buttons appear with a circle that lights red when the track is
record-enabled.

Enable a track for recording
•

In Logic Pro, click the Record Enable button in the track header.
Click the Record Enable button again to disable the track for recording.

You can also select one or more tracks with different inputs in the Tracks area, and use the
Record Enable Track key command (default: Control-R) to enable them for recording.
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Use input monitoring with audio tracks in Logic Pro

You can turn on input monitoring to monitor audio tracks that are not enabled for recording.
This is useful for setting audio levels or practicing parts before you commit to recording.
Tip: You can leave input monitoring turned on before, after, and during recording. When
input monitoring is on, the Record Enable button and the Auto Input Monitoring feature do
not affect software monitoring—that is, you can always hear incoming audio signals. When
you’re punch recording, however, you should use Auto Input Monitoring rather than the
Input Monitoring buttons. For more information about Auto Input Monitoring, see Punch in
and out of audio recordings.

Turn on input monitoring for an audio track
•

In Logic Pro, click the Input Monitoring button (with the “I” icon) in the track header.
Click the Input Monitoring button again to turn off input monitoring for the track.

Note: Input monitoring always involves some latency. The amount of latency depends on
the audio hardware and the driver settings. In certain configurations, it may be best not to
turn on input monitoring, to obtain the best possible timing. Route the signal you want to
record directly to headphones or a monitoring amplifier—and to the audio interface inputs,
for recording. You won’t accidentally overdrive your A/D converters, because the input level
meters display a clipping warning if an overload occurs.

Use track alternatives in Logic Pro

You can create and edit track alternatives and switch between them. Each alternative can
contain different regions or arrangements, while sharing the same channel strip and plugins. Track alternatives are like “playlists” for individual tracks that can be used to try out
different ideas or archive tracks at different stages of development.
One track alternative is always active and plays when you play the project. You can switch
between different alternatives to choose and edit the one you want to use.
By default, new track alternatives are named alphabetically (A, B, C, and so on) when
you create them. You can rename track alternatives to follow a different organization, for
example, or to use descriptive names.
You can use track alternatives to easily create comps (composite takes) by copying regions
or selections from different track alternatives into a new, empty track alternative. You
can also unpack takes to new track alternatives. For information about takes, see Record
multiple audio takes and Record additional software instrument takes.
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When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can show and use track alternatives.

Show track alternatives

In Logic Pro, do one of the following:
•

Choose Tracks > Show Track Alternatives.

•

Configure track header components to show the Track Alternatives button

Add a track alternative
•

In a Logic Pro track header, click the Track Alternatives button
the shortcut menu.

.

, then choose New from

A new, empty track alternative is added. The track name changes to show the name of
the new alternative. By default only the active track alternative is visible.
Note: Any regions on the track when you create a new alternative are saved to the
previous alternative.

Duplicate the active track alternative

In a Logic Pro track header, click the Track Alternatives button
from the shortcut menu.

, then choose Duplicate

A new, duplicate track alternative, containing copies of the regions in the alternative it
was duplicated from, is added. The track name changes to show the name of the new
alternative.

Choose a different track alternative

In a Logic Pro track header, click the Track Alternatives button
track alternative from the list at the top of the shortcut menu.

, then choose a different

Rename track alternatives

In Logic Pro,do one of the following:
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•

Double-click the existing name, then type a new name.

•

In the track header, click the Track Alternatives button
shortcut menu, then type a new name.

, choose Rename from the
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Rename track alternatives using region names
1. In the Logic Pro Tracks area, select a region.

2. In the track header, click the Track Alternatives button
Region.

Show all existing track alternatives

, then choose Rename by

In a Logic Pro track header, click the Track Alternatives button
Inactive from the shortcut menu.

, then choose Show

Inactive track alternatives appear below the active one. Inactive alternatives (when visible)
can be edited like normal tracks: regions can be copied, moved, or deleted, and so on.
Note: When you are working on grouped tracks with alternatives, the Track Alternatives
checkbox in the Group Settings must be selected (on).

Hear an inactive track alternative
•

In Logic Pro, click the On/Off button
in the track header for the inactive alternative.
The alternative will be audible when you play the project, in place of the active
alternative.

Make a track alternative active
•

In Logic Pro, click the upward-pointing arrow in the track header for the inactive
alternative. The alternative will be exchanged with the active alternative (which
becomes inactive).

Move or copy regions to the active alternative using key commands

1. In Logic Pro, select the regions you want to move or copy (on any inactive alternative).
2. Do one of the following:
•

To move regions to the active alternative: Use the Move Selected Regions to
Selected Track key command.

•

To copy regions to the active alternative: Use the Copy Selected Regions to Selected
Track key command.

Delete all inactive track alternatives
•

In a Logic Pro track header, click the Track Alternatives button
Inactive from the shortcut menu.

, then choose Delete

All track alternatives other than the active one are deleted, including any regions they
contain.
Logic Pro can also create track alternatives automatically for overlapping recordings. For
information, see Recording preferences.
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Turn off tracks in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can turn tracks off in the Tracks area. Turning off a track lets you silence a track while
still hearing other tracks in the project assigned to the same channel strip.
When no other track is assigned to the same channel strip, turning off a track also saves
processing power, because plug-ins on the channel strip are no longer processed. Turning
a track off (or turning it back on) takes slightly longer than muting or unmuting the track,
due to internal pre-processing. Unlike muting a track, turning off a track can not be
automated.
You can also control dynamic loading of plug-ins on a track using the On/Off button. When
you open a project, plug-ins on tracks that are turned off aren’t loaded, even if the tracks
contain regions. While working on the project, plug-ins aren’t loaded on a track that is
turned off when the track is focused, or when regions are added to the track. When the
track is turned on, plug-ins are loaded if the track becomes focused. You can also make
the plug-ins on a track inactive using the On/Off button.
Plug-ins load dynamically if the “Only load plug-ins needed for project playback” checkbox
is selected in Project Settings > General.

Turn off a track
•

In Logic Pro, click the On/Off button

in the track header.

If the On/Off button is not visible, you can show it or configure track header components.
To turn the track on, click the On/Off button again.

Make plug-ins inactive on a track
•

In Logic Pro, hold down Option and click the On/Off button

in the track header.

If the On/Off button is not visible, you can show it or configure track header
components.
To reactivate plug-ins on the track, Option-click the On/Off button again.
When a Software Instrument track is turned off, all MIDI regions on the track are silenced,
but live input (playing) is still audible.

Protect tracks in Logic Pro

You can protect a track to prevent accidental changes. While a track is protected, you
can’t record on the track, edit regions on the track, or create new regions on the track. If
you want to edit the track, you can unprotect it, make the changes, and then protect the
track again.

Protect a track

1. In Logic Pro, click the Protect button

in the track header.

If the Protect button is not visible, you can show it or configure track header
components.
The lock turns green to indicate that the track is protected.
2. To unprotect the track, click the Protect button
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Protect all tracks

1. In Logic Pro, Command-click the Protect button

in any track header.

The locks turn green to indicate that all tracks are protected.
To change the state of multiple tracks, click and hold the Protect button of one track,
then drag the pointer up or down. The Protect buttons of all swiped tracks switch to the
same state.
If the Protect button is not visible, you can show it or configure track header components.
2. To unprotect all tracks, Command-click the Protect button

on any track header.

If you try to make changes to a protected track, a dialog tells you that the track is locked.

Freeze tracks in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can freeze a track, reducing the processing power needed for playback. This reduces
its processor usage to that of a high-resolution audio track with no effects plug-ins,
regardless of the number or complexity of the plug-ins actually used on the track. Freezing
is particularly useful for software instrument tracks and for audio tracks that use complex
effects. It is not available for multi-output software instruments.
When you freeze a track, the track is bounced to an audio file. The freeze file includes the
output of any plug-ins on the track and any track automation. While the track is frozen,
the freeze file plays back in place of the original track, which is temporarily deactivated
(including any plug-ins). Channel strip controls (such as track mute and solo) are available,
but no track content can be edited (including region mute and solo, for example).
While a track is frozen, it cannot be edited. If you want to edit the track, you can unfreeze
it, make the changes, and then freeze the track again.
Freeze is designed to circumvent very CPU-intensive processes, such as software
instruments with a complex voice architecture, and complex plug-ins (such as reverbs,
filter banks, or FFT-based effects). If your computer can calculate all active processes in
real time, freezing tracks is unnecessary. Freezing tracks is recommended when tracks
with CPU-intensive software instrument or effects plug-ins are in a finalized state, or
require no further changes.
By freezing tracks, you can:
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•

Use extra effects plug-ins or software instruments in additional audio or software
instrument tracks, which would normally be impossible as it would exceed the CPUprocessing limits of your computer.

•

Play back projects created on computers with greater CPU power.
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Freeze a track

1. In Logic Pro, click the Freeze button

in the track header.

If the Freeze button is not visible, you can show it or configure track header components.
2. In the Track inspector, choose a Freeze mode:
•

Source Only: Freezes the track signal without any effects plug-ins. When selected,
the Freeze button appears blue. This Freeze mode is useful when using processorintensive software instruments or flex modes.

•

Pre Fader: Freezes the track signal including all effects plug-ins. When selected, the
Freeze button appears green.

3. Click the Play button

in the control bar.

4. To unlock the track, click the Freeze button again.
To change the freeze state of multiple tracks, click and hold the Freeze button of one track,
then drag the pointer up or down. The Freeze buttons of all swiped tracks switch to the
same state.
If you try to make changes to a frozen track, a dialog informs you that the track is frozen.

Hide tracks in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can hide tracks in the Tracks area. This is useful when you’re working on projects with
a large number of tracks, for example. Hiding a track has no effect on playback. It affects
only the appearance of the Tracks area.
You can hide and unhide tracks using the menu commands in the Track menu (Hide
Selected Track(s), Unhide All Tracks, and Show/Hide Hidden Tracks), or using key
commands. The first time you hide a track, you use the key command. When any track in a
project is hidden, the Hide button (with the letter H) appears above the track headers.

Hide one or more tracks

1. In Logic Pro, click the Hide button (H) above the track headers to show the Hide buttons
in the track headers.
2. Do one of the following:
•

Click the Hide buttons in the track headers of the tracks you want to hide.

•

Control-click the track header of each track you want to hide, then choose Show/
Hide Selected Track(s) from the shortcut menu.

3. Choose Track > Hide Hidden Tracks, or click the Hide button above the track headers
again.
The tracks with active Hide buttons are hidden.
4. To unhide the hidden tracks, choose Track > Unhide All Tracks, or click the Hide button
above the track headers again.

Logic Pro User Guide

192

Hide or unhide a track using key commands
1. In Logic Pro, select the track.

2. Use the Hide Selected Tracks key command (default assignment: Control-H).
To unhide the hidden track, use the Hide Selected Tracks key command again.
The following menu functions and key commands also affect the Hide Tracks feature:
•

Even when the toolbar Hide button is deactivated, you can still hide an individual track
with the Track > Hide Selected Track(s) and Select Next Track command (or press
Control-H).

•

The Track > Unhide All Tracks command (or the corresponding key command) resets
the Hide buttons of each track, making them all visible.

Note: You can also link the Hide functions of all tracks belonging to a group by selecting
Hide in the Group Settings window. (For more information on groups, see Groups overview.)
Keep in mind that there is no Unhide Selected Track key command because there is no way
that you can select a hidden track.

Delete tracks in Logic Pro

You can delete a track to remove it from the project. When you delete a track, all regions
on the track are deleted.

Delete a track
•

In Logic Pro, Control-click the track header, then choose Delete Track from the shortcut
menu.

Edit multiple tracks in a Logic Pro

You can make edits to multiple tracks in the Tracks area simultaneously by dragging the
pointer vertically over track header buttons (such as Solo, Mute, Hide, Protect, and Freeze)
on multiple tracks. Slide activation is similar to running your finger across several channel
strip buttons on good hardware mixing consoles.
To try out slide activation in Logic Pro, click and hold the Mute button
of one track,
then drag the pointer up or down. The Mute buttons of all swiped tracks switch to the
same state.
Simply drag over the Mute buttons of the same tracks to undo the mute.

Edit track header controls on multiple tracks
•

In Logic Pro, click and hold a control on one track header, then drag the pointer up or
down over additional tracks.
The corresponding control on all the swiped tracks switch to the same state.
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Work with patches in the Library
Logic Pro patches overview

A patch contains the instrument, effects, Smart Controls, and routing settings that control
the sound of a track. When you choose a patch, those settings are applied to the currently
selected track. You can try a different sound for the track by choosing a different patch, as
long as the patch is compatible with the track type.
You can choose a patch in the Library when you create a track, and choose a different
patch at any time while you’re working. The patches displayed in the Library depend on the
track type. For example, when you select an audio or software instrument track, patches
for that track type are available. You can view all available patches for the track type, or
view patches for a particular sound pack only.
Patches can include one or more channel strip settings, and can also contain routing
information (auxes) and metadata (for Smart Controls and controller mapping). Patches
for audio tracks can include default effects settings. Patches for software instrument
tracks include an instrument plug-in as well as effects settings. Specially designed
performance patches make it easy to play multiple instrument articulations. See Map
performance patches.
You can edit patches by changing channel strip settings, adding plug-ins, or editing plug-in
parameters, and save your own custom patches. You can also search for patches by name
in the Library.
For Track Stacks, the patches available in the Library vary, depending on the Track Stack
type, and which track in the Track Stack is selected. For more information, see Track
Stacks and the Library.
Note: You can also choose presets, channel strip settings, and other items in the Library.
If you have saved channel strip settings from a previous version of Logic Pro, they appear
along with patches when the corresponding track type is selected.
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Choose patches in the Library in Logic Pro

You can view available patches for the selected track in the Library. When you create a
new track, you can choose a patch from the Library, and choose a different patch for the
selected track at any time.
A track can have only one patch for the length of a project, and you can only choose
patches that match the track type of the selected track.

Choose a patch for the selected track
1. In Logic Pro, click the Library button
header) to open the Library.

in the control bar (or double-click the track

2. Choose a patch category from the list on the left, then choose a patch from the list on
the right.
You can quickly move through the patches in the list using the Up and Down Arrow keys.
After you select a new patch, you can start playing it immediately.
When you choose a patch, the left inspector channel strip shows the patch name, along
with the instrument (for software instrument patches) and effects plug-ins the patch uses.
To view presets for a plug-in in the Library, click the space immediately to the left of the
plug-in on the left inspector channel strip. Select the patch name again to return the view
to available patches, so you can choose a different one.
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Choose presets and other files in the Library in Logic Pro

In addition to patches, you can view and choose the following file types in the Library,
when the corresponding item is selected:
•

Plug-in presets (.pst)

•

Channel strip settings (.cst)

•

Sampler instruments (.exs)

•

Environment instruments, and programs or banks of MIDI instruments created in the
Audio MIDI Setup utility

View presets for a plug-in in the Library
•

In Logic Pro, in the inspector, click immediately to the left of the plug-in slot on the left
inspector channel strip.
The Library Focus triangle appears to the left of the plug-in slot.
To view patches again, click immediately to the left of the Setting button on the left
inspector channel strip.

View patches for a particular sound pack

Logic Pro includes a large collection of patches you can use in your projects. You can
download additional patches and loops in sound packs, available for a variety of sounds
and genres. When viewing patches in the Library, you can view all available patches for the
selected track, or limit what is shown to a particular sound pack or Producer pack installed
on your Mac.
For information about downloading patches and loops, see Manage Logic Pro content.

Search for patches by name in Logic Pro

You can search for patches by name in the Search field, located just below the patch icon
in the Library. You can quickly compare the search results by selecting and playing them.

Search for a patch

1. In Logic Pro, select the track, then click the Library button
already open.

if the Library is not

2. Enter search text in the Search field.
Search results appear below the Search field. You can audition patches by clicking
them, then playing your connected instrument.
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Merge patch settings in Logic Pro

You can merge patch settings from another patch with the current patch. This has
several uses: for example, you can merge effects with a patch while keeping the existing
instrument, or conversely try out different instruments while preserving the existing
effects setup.
The patch merging area contains buttons for four types of patch settings: MIDI effects,
instruments, audio effects, and sends. By default, all four types are selected, in which case
selecting a patch replaces the current patch. By deselecting some items, you can choose
which patch settings are merged with the current patch. When you choose a different
patch from the Library, only those settings corresponding to the selected buttons are
changed, while other settings remain unaltered.
If you deselect the Sends button, the channel strip (or strips) in the patch can access the
existing project auxes (or any auxes created by existing tracks/channel strips).

Open the patch merging area
•

In Logic Pro, choose Enable Patch Merging from the Action pop-up menu at the bottom
of the Library.

Choose which settings are not merged
•

In Logic Pro, click one or more buttons to deselect those patch setting types.

Selected patch setting types are merged when you choose a different patch, while
deselected types are kept unchanged.

Close the patch merging area
•

In Logic Pro, click the close box at the upper-left corner of the patch merging area.

When the patch merging area is closed, choosing a patch from the Library replaces the
current patch (equivalent to all buttons being selected).
When the main track of a summing stack is selected, patch merging is not available.

Reset patches in Logic Pro

You can reset a patch to its original settings, discarding any changes you previously made.

Reset a patch to its original settings

1. In Logic Pro, select the track, then click the Library button
already open.

if the Library is not

2. In the Library, select the patch you want to reset from the list on the right, then click
Revert.
If you want to save your changes to the patch, save the patch with a different name, then
reset the original patch.
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Save custom patches in Logic Pro

You can save a patch’s settings in the Library and apply the settings to other instruments,
or use them in another project.
You can delete a patch you have saved from the Library if you no longer want to use it. You
can’t delete the sounds included with Logic Pro.

Save a custom patch

1. In Logic Pro, select the track you want to use as a starting point for the custom patch.
2. Customize the patch settings by changing channel strip or plug-in parameters, or
adding or changing plug-ins.
3. Open the Library if it is not currently open.
4. In the inspector, make sure the blue triangle in the left channel strip points to the
Setting button.
5. Click the Save button in the lower-right corner of the Library.
6. In the dialog that appears, enter a name for the saved patch.
After you save a patch for the first time, a User Patches folder appears in the Library. Saved
patches are saved to the User Patches folder. You can use them in any Logic Pro project.
Note: If you have MainStage 2 or later installed on your computer, custom patches you save
in MainStage appear in a MainStage Patches subfolder of the User Patches folder, and can
be used in Logic Pro.

Delete a saved patch

1. In Logic Pro, select the track, then click the Library button
already open.

if the Library is not

2. In the Library, select the patch you want to delete from the list on the right, then click
Delete.
Important: After you delete a patch, it can’t be recovered for any project. Deleting a patch
cannot be undone.
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Map performance patches in Logic Pro

This section describes the keyboard mapping and articulations of Sampler-based
percussion instrument performance patches. See Patches overview.
Performance patches are designed to make it easy for you to play multiple articulations
of a specific percussion instrument with a MIDI keyboard. Performance patches include a
small number of related instruments, such as several shakers, with articulations assigned
to individual keys. This approach differs from other percussion patches that contain a
larger variety of percussion instruments.
Many performance patches also feature performance keys, which enable you to play
a number of related instrument articulations with a single keyboard key. For example,
the Conga performance patch performance key uses velocity splits to access three
articulations. If you play the key at low velocity, the Conga Mute articulation is triggered. If
you play the key at moderate velocity, the Conga Open articulation is triggered. If you play
the key at high velocity, the Conga Slap articulation is triggered. This makes it easy for you
to create realistic conga performances with your keyboard or a drum pad.
Performance patches can also exhibit interesting characteristics that differ when playing
live and when playing back a region. When you play a note live on the keyboard, the
sample is played from the sample anchor—a marker that represents the musical focus
of the sample, or the position that should land on a beat. When you play back recorded
MIDI events, however, the full sample is played, even if it starts before the note on event.
This behavior leads to more natural-sounding instruments—for example, the sound of a
tambourine that is generated before the actual palm hit.
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Use the Blocks and Bells performance patch

Blocks & Bells: Velocity splits are used to emulate different playing styles such as muted,
stick, and mallet strikes. There is no performance key mapping in this instrument.
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Use the Bongos and Bongos Stick performance patches

Bongos and Bongos Stick: Velocity splits are used to emulate different playing styles, such
as fingertips, open palm, or thumbstrikes.
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Use the Cajon performance patch

Cajon: Velocity splits are used to emulate different playing styles, such as open palm or
fingertips. There is no performance key mapping in this instrument.
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Use the Claps and Snaps performance patch

Claps & Snaps: Velocity splits are used to emulate different articulations, such as group
size and timing. There is no performance key mapping in this instrument.
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Use the Congas and Congas Bright performance patches

Congas and Congas Bright: The performance key uses velocity splits to access three
articulations. If you play the key at low velocity, the Conga Mute articulation is triggered.
Moderate velocity triggers the Conga Open articulation, and high velocity triggers the
Conga Slap articulation.
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Use the Shakers 1 and Shakers 2 performance patches

Shakers 1 and 2: The performance key triggers different shaker speed articulations based
on velocity. In addition, pressing and releasing the performance key triggers different
shaker forward and backward articulations, emulating the movement of real shaker players.
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Use the Tambourines performance patch

Tambourines: The Tambourines performance triggers different articulations, such as shake
speed variations at different velocities. It also offers different movement articulations
(forward/backward) for note on/off triggers.
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Use the Timbales performance patch

Timbales: Velocity splits are used to emulate different playing styles, such as stick strokes,
rim shots, and rolls.
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Work with Track Stacks
Logic Pro Track Stacks overview

Track Stacks provide a convenient way to organize and control tracks, to manage projects
with high track counts, and to create and manage audio subgroups. You can create a Track
Stack from a group of existing tracks, and use the controls on the master track to control
all the subtracks in the Track Stack.
Logic Pro has two types of Track Stacks: folder stacks and summing stacks. Both types
have a main track and one or more subtracks. The track header for the main track features
a disclosure arrow that lets you show or hide the subtracks. When you close the stack, only
the main track appears in the Tracks area.
Subtracks can include any track type: audio, software instrument (including layered and
multi-output software instruments), external MIDI instrument, or aux tracks. Folder stacks
can also include summing stacks as subtracks.

Folder stacks

Folder stacks let you combine multiple tracks and control them as one unit, without
changing the audio routing of the individual subtracks. When you create a folder stack,
the channel strip assigned to the main track is called the stack master. Using the main
track or the stack master channel strip, you can mute, solo, and adjust the volume level
for the folder stack. This is similar to the way a VCA master fader functions on a hardware
mixing console.

Individual subtracks in a folder stack can have Smart Controls, but the main track has no
Smart Controls. There are no patches for the main track of a folder stack, and no patch can
be saved when the main track is selected.
There are no regions on the main track of a folder stack, only on its subtracks. When the
folder stack is closed, the main track displays an overview of the combined contents of all
subtracks.
When you mute a folder stack using the Mute button on the main track (or stack master
channel strip), the mute or solo state of individual subtracks is preserved, and becomes
active again when the main track is unmuted.
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Summing stacks

Summing stacks let you combine multiple tracks and route their output to an audio
subgroup. When you create a summing stack, the outputs from the subtracks are routed to
a bus. The destination aux of the bus is assigned to the main track. When the main track
is selected, you can mute, solo, and adjust volume and send levels for the summing stack,
and add and edit plug-ins, affecting the sound of all the subtracks in the summing stack.
This is similar to the way an audio group works.

If a summing stack contains software instrument tracks as subtracks, you can record and
play MIDI regions on the main track. MIDI events on the main track are played by all the
software instrument subtracks in the summing stack. You can also record and play MIDI
regions on individual (software instrument) subtracks. When the summing stack is closed,
the main track displays an overview of the combined contents of all subtracks.
When the main track of a summing stack is selected, you can choose a different patch
for the summing stack, and create your own patches. Patches for a summing stack can
include the main track and all subtracks, along with their channel strip and plug-in settings.
Logic Pro includes a set of factory patches designed for use with summing stacks.
The main track of a summing stack, as well as its subtracks, can have Smart Controls.
Screen controls for the Smart Control on the main track can be mapped to channel strip or
plug-in parameters on any of the subtracks as well as the main track.
For summing stack patches included with Logic Pro, only the main track has a Smart
Control layout, which remains visible in the Smart Controls pane when a subtrack is
selected. However, summing stack patches you create keep their individual Smart Control
layouts for subtracks.
Summing stacks provide a convenient way to work with a multi-output software instrument
(MOSI) and its individual outputs as a single unit. This can be used, for example, for
programmed drum kits. You can create a summing stack for a MOSI with the MOSI channel
strip on the first subtrack, with additional subtracks for the output aux channel strips of the
MOSI stack. When you record and edit MIDI regions on the main track, the MIDI events are
sent to the subtrack containing the MOSI for playback.
After you create a summing stack, you can route individual subtracks to different
destinations. In the Bus submenu of the Send pop-up menu on subtracks, local busses are
sorted into stack submenus. Note that if you route subtracks to a destination “outside” of
the stack, those subtracks are no longer affected by the controls on the main track. Audio
subgroups you create are saved as part of the summing stack, and their auxes appear as
the last (bottom) subtracks in the summing stack.
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When a Track Stack contains a single software instrument subtrack, that subtrack appears
in the left inspector channel strip, and its routing destination (usually the main track aux)
appears in the right inspector channel strip when the main track is selected. Similarly, when
a Track Stack contains a single audio subtrack (and no software instrument subtracks),
that subtrack appears in the left inspector channel strip, and its routing destination
(usually the main track aux) appears in the right inspector channel strip when the main
track is selected.

Create and edit Track Stacks in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create and edit Track Stacks. If Enable Complete Features is not selected, you
can play back existing Track Stacks in a project, but you can’t create new ones or edit
existing ones.
You create a Track Stack by selecting (adjacent or nonadjacent) tracks in the Tracks area.
Nonadjacent tracks move so that all tracks are grouped together in the Track Stack. Both
types of Track Stacks can contain any combination of track types as subtracks. A folder
stack can also include summing stacks as subtracks.
You can hide the subtracks of a Track Stack to save space in the Tracks area, or show them
in order to record or edit. You can add or remove tracks from a Track Stack, and reorder
tracks in a Track Stack (reordering tracks doesn’t affect the sound).
After creating the summing stack, you can route individual subtracks to a different
destination. If you do so, however, the rerouted subtracks are no longer controlled by the
main track’s channel strip.

Create a Track Stack

1. In Logic Pro, select the tracks you want to include in the Track Stack. The selected
tracks can be adjacent or nonadjacent.
2. Do one of the following:
•

Choose Track > Create Track Stack.

•

Control-click the header of one of the selected tracks, then choose Create Track
Stack from the shortcut menu.

3. In the Track Stack dialog, do one of the following:
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•

To create a folder stack: Select Folder Stack, then click OK.

•

To create a summing stack: Select Summing Stack, then click OK.
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Show or hide the subtracks for a Track Stack
•

In Logic Pro, click the disclosure arrow to the left of the track icon in the main track.
To show or hide the subtracks for all track stacks in a project, Option-click the
disclosure arrow for any track stack in the project.

Add a track to a Track Stack
•

In Logic Pro, drag the header of the track you want to add between two of the subtracks
in the Track Stack.

Note: When you add a track to a summing stack, its routing changes to the aux assigned to
the main track.

Reorder subtracks
•

In Logic Pro, drag a subtrack by its header up or down inside the Track Stack.

Remove a subtrack from a Track Stack
•

In Logic Pro, drag the subtrack outside of the Track Stack (below the last subtrack, or
above the main track).

When you remove a subtrack from a summing stack, the track’s output routing changes
from the aux used by the main track to the main outputs.

Flatten a Track Stack

You can flatten a Track Stack, in which case the subtracks again become normal tracks.
•

When you flatten a folder stack, the main track is deleted if its volume fader is set at 0
dB (unity gain) and it contains no automation data.

•

When you flatten a summing stack, the audio subgrouping is retained, unless there is
no audio processing on the main track aux (no plug-ins, volume fader set at 0 dB, Pan/
Balance set to neutral, and no automation data). In this case, all subtracks (or their
audio subgroups) are routed to the Stereo (or Surround) Main output, and the main
track Aux is deleted.

In Logic Pro, do one of the following:
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•

Select either the main track or a subtrack, then choose Track > Flatten Track Stack from
the Tracks area menu bar.

•

Control-click the track header of the main track or a subtrack, then choose Flatten
Track Stack from the shortcut menu.
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Track Stacks and the Library in Logic Pro

The patches available in the Library vary depending on the Track Stack type, and which
track in the Track Stack is selected:
•

When the main track of a folder stack is selected, no patches are available in the
Library, and patches can’t be saved.

•

When the main track of a summing stack is selected, the patches available in the Library
depend on the channel strip types of the subtracks.

•

For both types of stacks, when a subtrack is selected, patches for the appropriate track
type are available.

•

If you choose a Track Stack patch when a subtrack of a folder stack is selected, the
entire Track Stack is loaded into the folder stack.

Control timing with the groove track in Logic Pro

You can set a track as a groove track, and match (synchronize) the timing of other tracks in
the project to it. When you play the project, the timing of matched tracks adjusts to match
the timing of the groove track.
Only one track in a project can be a groove track. You can select which tracks in the
project match the timing of the groove track. When a track is set to match the groove
track, time quantization is unavailable for that track.

Set the groove track

1. In Logic Pro, hold the pointer over the left edge of the header of the track you want to
set as the groove track.
If the groove track is not available, you can show it or configure track header
components so that it is visible.
2. Click the star that appears in the narrow rectangle on the left edge of the track header.

Match other tracks to the groove track
•

In Logic Pro, select the Match Groove Track checkbox on the left side of each track
header.

To prevent a track from matching the groove track, deselect the Match Groove Track
checkbox.
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Turn off the groove track
•

In Logic Pro, click the star in the header of the current groove track.

Note: If a project contains Apple Loops, the original loop follows the groove track, but loop
repetitions do not follow the groove track.

Work with articulations
Logic Pro articulation editing overview

Sampled instruments that emulate real instruments often allow you to switch between the
unique playing techniques that the real instrument is capable of. These playing techniques
are called articulations in Logic Pro. Each articulation will be identified with a unique
Articulation ID. For example, a sampled violin instrument might offer articulations to switch
between tremolo, pizzicato, and sustained notes, while a sampled horn instrument might
include articulations for sustained and staccato notes, trills, and falls.
Logic Pro offers various ways to choose which articulation to use for the notes
that you play:
•

All the information regarding the available articulations is stored in Articulation Sets.
Articulation Sets are saved both within saved patches and saved projects.

•

For instruments that load with pre-configured Articulation Sets, you can choose an
articulation from the plug-in window header or a pop-up menu in the Editors.

•

When you record a performance, each note will be recorded with its respective
articulation. For recorded (or manually created) notes you can change the articulation
using the Articulation pop-up menu in the various Editors. For more information, see
Manage articulations in the Editors.

•

You can choose an Articulation Set in the Track inspector. You can create, view and
change parameters for existing Articulation Sets using the Articulation Set Editor.

Manage articulations in the Editors in Logic Pro

If articulations have been recorded along with notes and events in a region, an Articulation
pop-up menu becomes available in the Piano Roll Editor.
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You can also select all notes that use the same articulation and choose articulations via the
shortcut menu. Finally, you can color notes by articulation as well. Other MIDI Editors, such
as the Event List and Score Editor, also allow you to view and edit articulations. See Edit
articulation IDs for note events, and Change note articulations for more information on how
to work with articulations in those editors.

Choose an articulation in the Piano Roll Editor
•

In Logic Pro, select one of the available articulations in the Articulation pop-up menu.

Manage software instrument articulations in Logic Pro

If an Articulation Set is loaded, you can select between articulations using the Articulations
pop-up menu in the plug-in window header. Some software instruments let you view the
most recently played articulation in the plug-in interface as well.

You can also view and change articulations using the Keyswitches view of the Smart
Controls pane. In addition to getting a graphic view of the assigned keyswitches, you can
use this view to enable or disable keyswitches, and change the octave and key where
keyswitches are located.

Choose an articulation from the plug-in window header
•

In Logic Pro, click the Articulation pop-up menu in the plug-in header and choose from
the available articulations.

When you choose a new articulation, it affects notes played live, but doesn’t change the
articulation of previously recorded notes.
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Open Keyswitches view

In Logic Pro, do one of the following:
•

In the Smart Controls pane, click the Keyswitches tab.
If the articulations are spread over more than one octave of keys, click the mini
keyboards above the keys to view different octaves of keyswitches.

•

Use the Show/Hide Keyswitches key command.
If the Smart Controls pane is not already open, it will open to the Keyswitches tab.
Note: You can also open the Keyswitches tab of the Smart Controls pane as a floating
window using the Show/Hide Keyswitches window key command.

Enable or disable keyswitches
•

In Logic Pro, click the “MIDI Remote” button in the top left of the Keyswitches view.

Change the octave used for keyswitches
•

In Logic Pro, click the Octave Offset pop-up menu and choose an octave.

Switch articulations in the Keyswitches view
•

In Logic Pro, click one of the keys that has an articulation assigned to it.

Use the Articulation Set Editor in Logic Pro

The Articulation Set Editor can be used to create sophisticated key switch and controller
switch definitions, and define output transformations, which enables compatibility
with third party sample libraries. You can also use the Articulation Set Editor to create
Articulation Sets for instruments that have assigned Articulation IDs to sample groups, but
do not have pre-configured articulations. For example, some Sampler instruments come
pre-configured with specific sample groups identified by an Articulation ID but do not have
pre-configured Articulation Sets.
The Articulation Set Editor consists of three panes: Articulations, Switches, and Output.
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The Articulations pane

The Articulations pane is where you can define specific articulations, including their names
and IDs. The articulations defined here populate the articulation menus in the plug-in
header and the various editors.

You can set articulations to be triggered by MIDI channel rather than an articulation ID.
This can be useful for instruments whose MIDI channels are used to control additional
properties.
The Articulations pane contains a table showing the following parameters:
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•

Name field: Type a name for your articulation in this field.

•

Articulation ID field: Type a number to be the Articulation ID for your articulation. For
Sampler-based instruments that use the articulation ID for group selection choose
the corresponding articulation ID. For any other instruments, an output transformation
needs to be defined on the output page (converting the articulations back into
keyswitches), and the IDs can be arbitrary.

•

Channel pop-up menu: Choose a MIDI channel for the articulation, or choose “-” for all
MIDI channels.

•

Symbol pop-up menu: Choose a notation symbol to represent the articulation in the
Score Editor.

•

Revert button: Reverts any changes done to the the articulations to their saved state.

•

Plus and minus buttons: Use these buttons to create and remove articulations.

216

The Switches pane

The Switches pane is where you create and customize keyswitches and controller switch
assignments for each articulation. You can determine the type of MIDI message to use for
switches, what values within that MIDI message to use, and you can specify the articulation
behavior when the switch is triggered.

It includes the following controls:
•

MIDI Remote button: This button has to be active for your articulation switches to
respond to the defined MIDI messages. If MIDI Remote is off, you cannot control
your articulation switches remotely with your attached MIDI device. For example, you
might want to turn off MIDI Remote if you want to play an instrument live using the full
keyboard range without risking an accidental switch between articulations.

•

MIDI Channel pop-up menu: Sets a specific MIDI channel for all your keyswitches. This
is useful if you have a dedicated keyboard for keyswitches or you wish to limit your
keyswitches to a particular MIDI channel.

•

Octave Offset pop-up menu: Sets an offset for the octave used for keyswitches. You
can set an offset of up to plus or minus ten octaves. This can be useful in particular
for bass instruments; since keyswitches are often set to very low octaves, with bass
instruments you may want to move the keyswitches to higher octaves and leave the
lower octaves free for playing.

These three Switches controls can be set locally in the Switches pane, or globally to affect
how all instruments with articulations will behave. To determine if these settings are local
or global, see Articulation Switches.
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Below the controls is a table showing each articulation along with the following parameters:
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•

Type pop-up menu: Chooses the specific type of MIDI message used to activate the
articulation. Note On is the standard MIDI message used to trigger articulations, but
Note Off, Poly Aftertouch, Controller, Program (program change), Aftertouch, Pitch
Bend, and Velocity are also supported.

•

Selector pop-up menu: Determines which specific value of the MIDI message chosen
in the Type column triggers the articulation. For example, if you chose Note On in the
Type column, here is where you would choose the specific note for the keyswitch. If you
chose Controller in the Type column, you would choose the specific controller number.
If you choose Program, Aftertouch, or Pitch Bend in the Type column, there will be no
Selector value.

•

Value Start slider: Defines the low end of the range for the controller switches. For Note
On/Off messages, this relates to velocity values.

•

Value End slider: Defines the high end of the range for the controller switches. For Note
On/Off messages, this relates to velocity values.

•

Mode pop-up menu: Selects between different switch modes. These different switch
modes exist in order to support both variations in your playing style and special
articulation features.
•

Permanent: Switches to the selected articulation, which will then be used for all
subsequent notes until another articulation is selected. This is useful for the main
(standard) articulations such as Sustain, Staccato, and other common playing
techniques.

•

Permanent (Retrigger): Stops the currently sounding note and retriggers it
immediately with the newly selected articulation. The new articulation will be used
for all the following notes until another articulation is selected.

•

Permanent (Trigger): Immediately applies the newly selected articulation to the
currently playing note. As soon as the switch is disengaged all notes are stopped.
This is useful to trigger falls, doits, and so on, at the end of a musical phrase.

•

Momentary: Activates the keyswitch only while the switch is within its defined
Value range. For Note On or Note Off articulations this means the articulation
switches only while the key is depressed or released respectively; for controllers the
articulation is selected as long as the value is within the value start and end range.
This is useful for articulations you only want to use for one note or a very short
passage such as growls, trills, and so on.

•

Momentary (Retrigger): Stops the current note and retriggers it immediately with
the selected articulation while the switch is within its defined Value range. For Note
On or Note Off articulations this means the articulation switches only while the key
is depressed or released respectively; for controllers the articulation is selected as
long as the value is within the value start and end range.

•

Momentary (Trigger): Immediately applies the newly selected articulation to the
currently playing note while the switch is within its defined Value range. As soon as
the switch is disengaged all notes are stopped. This is useful to trigger falls, doits,
and so on, at the end of a musical phrase.
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•

Toggle: Activates the selected articulation when the switch is engaged. When the
switch is engaged again it reactivates the previous articulation. This is useful when
you want to toggle between two articulations, such as sustained notes and palm
muting.

•

Toggle (Retrigger): Stops the currently sounding note and retriggers it immediately
with the newly selected articulation. When the switch is engaged again it reactivates
the previous articulation.

•

Toggle (Trigger): Immediately applies the newly selected articulation to the currently
playing note. As soon as the switch is disengaged all notes are stopped. This is
useful to trigger falls, doits, and so on, at the end of a musical phrase.

•

Articulation pop-up menu: Choose from among the available articulations. You can use
the same articulation multiple times, each triggered by a different status or selector,
and with different value ranges.

•

Revert button: Reverts any changes made to the switches to their saved state.

•

Plus and minus buttons: Use these buttons to create and remove switches.

The Output pane

For instruments that don’t support the use of articulation IDs directly, you can use Output
pane to define how articulations are accessed in your particular instrument. Output
articulations are mostly keyswitches. Some third-party sampler instruments also use
controllers as switches.
Working in the Output pane, you can define output triggers for articulations, which means
that you can use triggers with third-party libraries for which pre-configured Articulation
Sets do not already exist. Because the output triggers are independent of the switches,
they can be used to create setups with consistent switches across different libraries.
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The Output pane consists of a table showing each articulation along with the following
parameters:
•

Name field: Displays the name of the articulation.

•

Type pop-up menu: Choose the specific type of MIDI message that is used to activate
the articulation. Note On is the standard MIDI message used to trigger articulations, but
Note Off, Poly Aftertouch, Controller, Program (program change), Aftertouch, and Pitch
Bend are also supported.

•

Channel pop-up menu: Choose a MIDI channel for the articulation, or choose “-” for
all MIDI channels. This is useful when third party sample libraries use specific MIDI
channels for articulations.

•

Selector pop-up menu: Determines which specific value of the MIDI message chosen
in the Type column triggers the articulation. For example, if you chose Note On in the
Type column, here is where you would choose the specific note for the keyswitch. If you
chose Controller in the Type column, you would choose the specific controller number.

•

Value Start slider: Defines the low end of the range for the controller switches.

•

Value End slider: Defines the high end of the range for the controller switches.

•

Activate Multiple Outputs checkbox: Define up to three MIDI messages that can be
sent to an instrument in order to activate an articulation. This may be necessary for
instruments that require, for example, one MIDI message to chose a category and
another MIDI message to choose an articulation within within that category.

•

Revert button: Reverts any changes made to the output assignments to their saved
state.

Choose an Articulation Set
•

In the Logic Pro Track inspector, choose an Articulation Set from the Articulation Set
pop-up menu.

Open the Articulation Set Editor

In the Logic Pro Track inspector, choose Edit from the Articulation Set pop-up menu.

Create a new articulation
•

In Logic Pro, in the Articulations pane, click the “+” button at the bottom left of the
Articulation Set Editor window.

Remove an articulation
•

In Logic Pro, in the Articulations pane, select an articulation and click the “-” button at
the bottom left of the Articulation Set Editor window.

Revert to the previously saved version of articulations
•
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In Logic Pro, click the “Revert” button at the bottom left of the Articulation Set Editor
window.
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Bounce tracks and regions in place
Logic Pro bounce in place overview

You can bounce tracks or regions in place, so that the resulting audio files are placed at the
same position as the originals in the Tracks area. You can also bounce all tracks in place in
a single operation.
Using the Bounce in Place commands, you can process audio, software instrument, or
Drummer tracks, or the regions on those tracks. The audio file format of the bounce
(sample rate and resolution) is set in the Recording preferences.
The Bounce in Place function might seem similar to the Freeze function, but there are
several differences:
•

Both save CPU power by rendering all effects (or instrument) plug-ins of a track.

•

Freeze allows you to return to the original state of the tracks and their automation data,
unlike Bounce in Place.

•

Freeze (in 32-bit float) safeguards against volume clipping.

Note: A bounce in place is performed offline, not in real time. Audio and software
instrument tracks with internal sound sources can be bounced in place. The Bounce in
Place functions cannot be used with MIDI tracks (including external instrument MIDI tracks)
or with audio channel inputs. Instead, you can use real-time bounces to render such sound
sources to an audio file. See Bounce a project to an audio file.

Bounce a track in place in Logic Pro

You can render one or more selected audio, software instrument, or Drummer tracks
(including active plug-ins and automation on the tracks) to a new audio file.

Bounce one or more tracks in place
1. In Logic Pro, select the track.

2. Choose File > Bounce > Track in Place (or use the Bounce Track in Place key command).
3. In the Bounce Track In Place dialog, define the following parameters:

•
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Name field: Enter a name for the bounce file in the field. The name defaults to the
region name of the first selected region, with the extension _bip added at the end.
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•

•

Destination buttons: Define the track on which the bounce file is placed. You have
two options:
•

New Track: Creates a new audio track below the selected track, and places the
bounce file on that track.

•

Replace Track: Replaces the existing track, and places the bounce file on it.

Include Instrument Multi-Outputs checkbox: Select to include aux channel strips
with multi-output signals of the instrument in the bounce process. Otherwise, only
the channel strips of tracks with selected regions are bounced.
•

As Additional Tracks checkbox: Select to create additional bounce files for every
aux with any multi-output of the selected multi-output software instrument as
input source.

•

Bypass Effect Plug-ins checkbox: Select to disable all plug-ins on the source track
during the bounce process.

•

Include Volume/Pan Automation checkbox: Select to have volume and pan
automation performed during the bounce process, with their result influencing
the bounce file. Otherwise, the volume and pan automation is simply copied, not
performed.

•

Normalize pop-up menu: Choose between three states of normalization:

•

•

Off: Turns off normalization.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: Allows full bidirectional normalization.

Restore Defaults button: Click to set all parameters in the dialog to their default
settings.

4. Click OK to trigger an in-place bounce of the selected track or tracks.
Following the bounce in place, the original track content (all regions, and all automation
data except for volume, pan, and sends) is lost, and the original instrument or track
channel strip is reset. You can use the Undo command if you want to return to the prebounce state.
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Bounce all tracks in place in Logic Pro

You can perform an in-place bounce-and-replace for all audio, software instrument, and
Drummer tracks in the Tracks area.

Perform an in-place bounce of all tracks

1. In Logic Pro, choose File > Bounce > And Replace All Tracks.
2. You are prompted to save your project; click Yes or No, as appropriate.
3. In the Bounce Replace All Tracks dialog, define the following parameters:

•

Bypass Effect Plug-ins checkbox: Select to disable all plug-ins on the source track
during the bounce process.

•

Include Volume/Pan Automation checkbox: Select to have volume and pan
automation performed during the bounce process, with their result influencing
the bounce file. Otherwise, the volume and pan automation is simply copied, not
performed.

•

Normalize pop-up menu: Choose between three states of normalization:
•

Off: Turns off normalization.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: Allows full bidirectional normalization.

4. Click OK to trigger the in-place bounce-and-replace for all tracks.
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Bounce a region in place in Logic Pro

You can render one or more selected regions on audio or software instrument tracks into
an audio file, including all active plug-ins and automation data.

Bounce one or more regions in place

1. In Logic Pro, select one or more regions on an audio or software instrument track.
2. Do one of the following:
•

Choose File > Bounce > Regions in Place (or use the corresponding key command).

•

Control-click the selected regions, then choose Bounce Regions in Place from the
shortcut menu.

3. In the Bounce Regions In Place dialog, define the following parameters:

•

Name field: Enter a name for the bounce file in the field. The name defaults to the
region name of the first selected region, with the extension _bip added at the end.

•

Destination buttons: Define the track on which the bounce file is placed. You have
two options.

•
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•

New Track: Creates a new audio track below the selected track, and places the
bounce file on that track.

•

Selected Track: Places the bounce file on the selected track.

Source buttons: Define what happens to the source regions after bouncing. You have
three options:
•

Leave: Leaves the source region unaltered after processing the bounce file.

•

Mute: Mutes the source region after processing the bounce file.

•

Delete: Deletes the source region from the original track after processing the
bounce file.

•

Include Instrument Multi-Outputs checkbox: Select to include aux channel strips
with multi-output signals of the instrument in the bounce process. Otherwise, only
the channel strips of tracks with selected regions are bounced.

•

Bypass Effect Plug-ins checkbox: Select to disable all plug-ins on the source track
during the bounce process.
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•

Add Effects Tail to File checkbox: Select to continue the bounce process after the
end of the bounce range—either to the end of the cycle or to the end of the last
selected region—until there is no longer a signal. Otherwise, only the bounce range
is bounced.

•

Add Effects Tail to Region checkbox: Select to include the entire bounce file in the
bounce region. Otherwise, the bounce region only includes the bounce range.

•

Include Volume/Pan Automation checkbox: Select to have volume and pan
automation performed during the bounce process, with their result influencing
the bounce file. Otherwise, the volume and pan automation is simply copied, not
performed.

•

Normalize pop-up menu: Choose between three states of normalization:

•

•

Off: Turns off normalization.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: Allows full bidirectional normalization.

Restore Defaults button: Click to set all parameters in the dialog to their default
settings.

4. Click OK to trigger an in-place bounce of the selected region or regions.
Note: When you click OK, the settings chosen above are stored in the preferences and
recalled when you next access the Bounce Regions in Place function.

Use selection-based processing in Logic Pro

While working in the Tracks area, you can apply one or more audio effect plug-ins to
selected audio regions or to marquee selections of audio regions. You can preview the
result and make further adjustments before applying the resulting changes to the selection.
Effects can include both plug-ins included with Logic Pro as well as Audio Units effect
plug-ins, and are independent of the plug-ins used on the track.
You can apply effects to a selection, or create a new take with the processed file(s). When
processing a marquee selection, you can maintain the original region borders or create
a new region containing the processed marquee selection. When both Split at Marquee
Borders and Create New Take are selected (and the marquee selection is on a region,
not a take folder), the created take folder contains only the marquee selection. If Split
at Marquee Borders is not selected or if a take folder rather than a region is marquee
selected, a new take is created for the entire original region.
The Selection-Based Processing window includes two separate sets of plug-ins, marked
A and B. You can switch between sets. For each set, you can choose a complete channel
strip setting or add plug-ins individually and modify their settings. You can then compare
set A and set B and choose which one to use.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can access and use the Selection-Based Processing window.
You can also apply selection-based processing when working in the Audio Track Editor.
For information about using effect plug-ins, see Plug-ins overview.
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Apply effect plug-ins to regions or a marquee selection
1. In Logic Pro, do one of the following:
•

Select one or more audio regions in the Tracks area or the Audio Track Editor.

•

Make a marquee selection in the Tracks area or the Audio Track Editor.

2. Do one of the following:
•

Choose Functions > Selection-Based Processing from the Tracks area or Audio Track
Editor menu bar (or use the Show/Hide Selection-Based Processing key command).

•

Control-click a selected region, then choose Processing > Apply Selection-based
Processing from the shortcut menu.

In the Selection-Based Processing window, do any of the following:
•

To select the active process: Click the On/Off switch for Set A or Set B.
Turning on one process turns off the other one. You can switch between processes
freely during playback.

•

To apply a complete channel strip setting to the selection: Choose a setting from the
Channel Strip Setting pop-up menu.
After you choose a channel strip setting, you can add, remove, and modify individual
plug-ins.

•

To add a plug-in: Click an empty slot in the active process (Set A or Set B), and
choose a plug-in from the pop-up menu.
When you add a plug-in, the plug-in window opens so you can adjust its settings.

•
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To create a new audio region containing the selected portion of a marquee selection:
Select the Split at Marquee Borders checkbox.
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•

To create a new take containing an audio file with the changes: Select the Create
New Take checkbox.

•

To extend the length of the created file to include any instrument release and
potential effect tail: Select the Add Effect Tail checkbox.

•

To set the gain compensation for the selection: Choose a setting from the Gain popup menu.

•

•

No Change: No gain change is applied to the signal.

•

Loudness Compensation: Alters the level of the processed signal to match the
perceived loudness of the unprocessed signal.

•

Overload Protection: Lowers the processed signal in case of overloads (levels >
0dB) to eliminate clipping, while levels below 0 dB are unchanged.

•

Normalize: Increases or decreases the processed signal to the highest possible
level without causing clipping (distortion).

To preview changes: Click the Preview button. You can adjust the volume of the
preview with the Preview slider.
By default, the preview is soloed. To hear the preview together with the project,
choose Preview enables Solo from the Action pop-up menu
to deselect it.
To turn on the cycle area when previewing, choose Preview enables Cycle from the
Action pop-up menu .

3. To apply your changes, click Apply.

Apply the current selection-based processing again
In Logic Pro, do one of the following:

Choose Functions > Apply Selection-Based Processing Again from the Tracks area or Audio
Track Editor local menu bar.
Control-click the region, then choose Apply Selection-based Processing Again from the
shortcut menu.
You can use this command to make a new selection and quickly apply the current
selection-based processing to the selection.
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Export tracks and regions
Export tracks as audio files in Logic Pro

You can export one or more selected tracks as audio files, or export all tracks (all audio,
software instrument, and Drummer tracks) in a project as audio files—one file per track.
When you export tracks as audio files, you can specify the naming of the audio files using
filename elements.

Export selected tracks as an audio file

1. In Logic Pro, select the track to export, then choose File > Export > Track as Audio File.
2. Choose a file format for the exported audio file from the Save Format pop-up menu.
3. Choose the bit depth for the exported audio file from the Bit Depth pop-up menu.
4. Set the following parameters, as necessary:
•

Range: Choose whether to trim silence at the end of the exported file(s), export only
the cycle range, or extend silence to the project end.

•

Multi-Output Software Instruments: For software instrument tracks with multi-output
software instruments, choose one of the following options:
•

One File per Track: Mixes the multi-output signals with the main output into one
file, for each multi-output software instrument track. In situations where multiple
tracks use the same multi-output software instrument channel strip, one file is
created for each track.

•

One File per Channel Strip: Creates additional files for each aux channel strip that
has an output of the selected track’s multi-output software instrument as Input
source.

•

Bypass Effect Plug-ins: Select to disable all plug-ins on the source track.

•

Include Audio Tail: Select to extend the length of the created file to include any
instrument release and potential effect tail (reverb, delay, and so on).

•

Include Volume/Pan Automation: Select to have volume and pan automation
performed on export, with their result influencing the created file. Otherwise, the
volume and pan automation is simply copied, but not performed.
Note: If you plan to use the exported regions with an external app for processing,
mixing, or editing, exporting them with no volume and pan automation is generally
desirable.

•

Normalize: Choose one of the following options:
•

Off: The exported file is not normalized.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: The exported file is normalized both for overloads and for Lowell levels.

5. Select the Add resulting files to Project Audio Browser checkbox to add the exported
file to the Project Audio Browser.
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6. To specify the filename pattern: Drag one or more elements to the Pattern field in the
order you want them to have in the filenames.
To add a custom name, drag the Custom element to the Pattern field, then type in the
Custom field.
An example filename appears below the elements.
7. Browse to a location to save the exported file or files.
8. Click Save.

Export all tracks as audio files

1. In Logic Pro, choose File > Export > All Tracks as Audio Files.
2. Choose a file format for the exported audio files from the Save Format pop-up menu.
3. Choose the bit depth for the exported audio file from the Bit Depth pop-up menu.
4. Set the following parameters, as necessary:
•

Multi-Output Software Instruments: For software instrument tracks with multi-output
software instruments, choose one of the following options:
•

One File per Track: Mixes the multi-output signals with the main output into one
file, for each multi-output software instrument track. In situations where multiple
tracks use the same multi-output software instrument channel strip, one file is
created for each track.

•

One File per Channel Strip: Creates additional files for each aux channel strip that
has a multi-output of the selected track’s multi-output software instrument as
Input source.

•

Bypass Effect Plug-ins: Select to disable all plug-ins on the source track.

•

Include Audio Tail: Select to extend the length of the created file to include any
instrument release and potential effect tail (reverb, delay, and so on).

•

Include Volume/Pan Automation: Select to have volume and pan automation
performed on export, with their result influencing the created file. Otherwise, the
volume and pan automation is simply copied, but not performed.
Note: If you plan to use the exported regions with an external app for processing,
mixing, or editing, exporting them with no volume and pan automation is generally
desirable.

•

Normalize: Choose one of the following options:
•

Off: The exported file is not normalized.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: The exported file is normalized both for overloads and for lower levels.

5. Select the Add resulting files to Project Audio Browser checkbox to add the exported
file to the Project Audio Browser.
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6. To specify the filename pattern: Drag one or more elements to the Pattern field in the
order you want them to have in the filenames.
To add a custom name, drag the Custom element to the Pattern field, then type in the
Custom field.
An example filename appears below the elements.
7. Browse to a location to save the exported file or files.
8. Click Save.

Export regions as audio files in Logic Pro

You can export audio or MIDI regions as audio files to reuse in Logic Pro or use with
another audio app. When you export regions as audio files, you can specify the file naming
of the audio files using filename elements. Any fades are included in the exported audio
file, and volume and pan automation can also be included.

Export audio or MIDI regions as audio files

1. In Logic Pro, select the region or regions in the Tracks area, then choose File > Export >
Region as Audio File.

When multiple regions are selected, the menu item appears as Regions as Audio Files.
2. For a single region, enter a name for the exported audio file, and browse to a location to
save it. When multiple regions are selected, the audio files receive the same names as
the regions.
3. Choose a file format for the audio files from the Save Format pop-up menu.
4. Choose the bit depth for the new audio files from the Bit Depth pop-up menu.
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5. Set the following parameters, as necessary:
•

Multi-Output Software Instruments: For regions on software instrument tracks with
multi-output software instruments, choose one of the following options.
•

One File per Track: Mixes the multi-output signals with the main output into one
file, for each multi-output software instrument track. In situations where multiple
tracks use the same multi-output software instrument channel strip, one file is
created for each track.

•

One File per Channel Strip: Creates additional files for each aux channel strip that
has a multi-output of the selected track’s multi-output software instrument as
Input source.

•

Bypass Effect Plug-ins: Select to disable all plug-ins on the source track.

•

Include Audio Tail: Select to extend the length of the created file to include any
instrument release and potential effect tail (reverb, delay, and so on).

•

Include Volume/Pan Automation: Select to have volume and pan automation
performed on export, with their result influencing the created file. Otherwise, the
volume and pan automation is simply copied, but not performed.
Note: If you plan to use the exported regions with an external app for processing,
mixing, or editing, exporting them with no volume and pan automation is generally
desirable.

•

Normalize: Choose one of the following options:
•

Off: The exported file is not normalized.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: The exported file is normalized both for overloads and for lower levels.

6. Select the Add resulting files to Audio Bin checkbox to add the exported files to the
Project Audio Browser.
7. To specify the filename pattern: drag one or more elements to the Pattern field in the
order you want them to have in the filenames. An example filename appears below the
elements.
8. Click Save.
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Move audio files used for audio regions in Logic Pro

You can move audio files used for audio regions to a new location. This is useful if the
audio files are saved in the project, or are referenced outside the project in multiple
locations.
When you select one or more audio regions and choose Move Files, all audio files used for
the selected regions are moved to the location you choose, including audio files stored in
the project and audio files referenced from outside the project.

Move audio files used for audio regions to a new location
1. In Logic Pro, select the audio regions in the Tracks area.

2. Control-click one of the selected files, then choose Export > Move File(s) out of project
from the shortcut menu.
If only audio regions from audio files referenced outside the project are selected, the
command appears as Move File(s).
3. In the Move File(s) dialog, browse to and select the new location for the files, then
click Choose.

Export MIDI regions as MIDI files in Logic Pro

You can export one or more MIDI regions as standard MIDI files to use in other music apps.
If your project contains only MIDI regions, you can merge the regions and export the entire
project as a single MIDI file. Before exporting, must perform the steps to prepare the MIDI
regions as described in the following task.
Because Standard MIDI file Format 0 files can save only a single MIDI region, you must also
join MIDI regions you want to export as a Format 0 MIDI file. You can do this by selecting
the regions and choosing Edit > Bounce and Join > Join, or using the Glue tool.

Prepare MIDI regions for export

1. In Logic Pro, Control-click the regions, then choose Functions > MIDI Region
Parameters > Apply All Parameters Permanently from the shortcut menu.
2. Control-click the regions, then choose MIDI > Apply Quantization Permanently from the
shortcut menu.
3. Convert any aliases to region copies by choosing Functions > Region Alias > Convert
Alias to a Copy from the Tracks area menu bar (or use the Convert Alias to a Region
Copy key command).
4. Convert all loops into regions by selecting the loops and choosing Convert > Convert
Loops to Regions from the shortcut menu.
5. Convert all MIDI regions on each track into a continuous MIDI region by choosing Edit >
Bounce and Join > Join per Tracks (or use the Join Regions per Tracks key command).
6. Insert all instrument MIDI settings as events by choosing Functions > Insert Instrument
MIDI settings as Events from the Tracks area menu bar.
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Export one or more MIDI regions as standard MIDI files
1. In Logic Pro, select the MIDI regions to export.
2. Choose File > Export > Selection as MIDI File.
3. Choose the destination directory, enter a name, then click Save. The selected MIDI
regions are saved as a Format 1 MIDI file.
Note: If you’re exporting MIDI files to use with a hardware sequencer, you may need to
limit the filenames to an 8.3 character name; such as “proj0001.MID.”

Export a single MIDI region as a Format 0 MIDI file

1. Choose Logic Pro > Preferences > General, click Project Handling, then select the
“‘Export MIDI File…’ saves single MIDI Regions as Format 0” checkbox.
2. Select a single MIDI region to export.
3. Choose File > Export > Selection as MIDI File.
4. Choose the destination directory, enter a name, then click Save. The selected MIDI
region is saved as a Format 0 MIDI file.

Edit track parameters in Logic Pro

Each track has a set of parameters. The parameters available depend on the track type
(some parameters are common to all track types, while some are specific to audio tracks or
software instrument tracks only). You can view and edit parameters for the selected track
in the Track inspector, located below the Region and Event inspectors.
All track types have a track name, which is shown at the top of the Track inspector when
the track is selected, and a track icon, which appears below the track name in the Track
inspector. Other track parameters include the following:

Audio tracks
•

Channel: Shows the channel strip type and number for the track. The Channel
parameter is not editable.

•

Freeze Mode pop-up menu: Choose Source Only to freeze the track signal without
effect plug-ins, or choose Pre Fader to freeze the track with all effect plug-ins. See
Freeze tracks.

•

Q-Reference checkbox: When selected, all regions on the track contribute their
transients as reference points during the quantization process. See Flex tracks Quantize
menu.

•

Flex Mode pop-up menu: Choose the flex mode for the track. See Flex Time algorithms
and parameters.
Depending on which flex mode you choose, other parameters become available below
the Flex Mode pop-up menu.
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Software Instrument tracks
•

Channel: Shows the channel strip type and number for the track. The Channel
parameter is not editable.

•

MIDI Input Port pop-up menu: Choose a MIDI port for the track input, all input ports,
or Internal & Remote (which routes input from the Musical Typing keyboard and from
Logic Remote).

•

MIDI Input Channel pop-up menu: Choose the MIDI channel for the track input, or all
input channels.

•

MIDI Output Channel pop-up menu: Choose the MIDI channel for the track output, or all
output channels.

•

Freeze Mode pop-up menu: Choose Source Only to freeze the track signal without
effect plug-ins, or choose Pre Fader to freeze the track with all effect plug-ins. See
Freeze tracks.

•

Transpose pop-up menu: Choose the transposition for the track in octaves.

•

Velocity value slider: Click and hold the area right of the parameter name, then drag to
increase or decrease the velocity for notes in all regions on the track.

•

Key Limit value slider: Click and hold the lower or upper key value, then drag to change
the value. The two values together define the key range; any notes outside this range
are not played.

•

Velocity (Vel) Limit value slider: Click and hold the lower or upper velocity value, then
drag to change the value. The two values together define the velocity range; any notes
with a velocity outside this range are not played.

•

Delay value slider: Click and hold to choose whether to display the delay value in ticks
or in milliseconds, then drag to increase or decrease the amount of delay applied to
regions on the track.

•

No Transpose checkbox: When selected, regions on the track are not transposed.
(In other words, the Transpose Region parameter is ignored.) This can be useful for
instruments assigned to drum or other samples mapped across the keyboard on a single
MIDI channel.

•

No Reset checkbox: When selected, no reset messages are sent to the track’s
instrument. This can be useful when using controllers for nonmusical purposes, such
as Mixer automation.

•

Staff Style pop-up menu: Choose the default staff style for the track. See Assign staff
styles to tracks.

•

Articulation Set pop-up menu: Choose an articulation set, or edit the current set. See
Use the Articulation Set Editor.

Note: Drummer tracks include all software instrument track parameters except for Freeze
Mode, Transpose, and Velocity.
External instrument tracks include both audio track parameters (except Q-Reference) and
software instrument track parameters.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional track parameters are available, including Channel, Freeze Mode, Q-Reference,
Delay, Flex Mode, and Staff Style parameters.
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Edit track parameters for a track

1. In the Logic Pro Tracks area, select the track.
2. In the Track inspector, do any of the following:
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•

To edit the track name: Click the name at the top of the Track inspector, enter a new
name, then press Return.

•

To change the track icon: Click the icon in the Track inspector, then choose a new
icon.

•

To edit other track parameters: Follow the descriptions above to edit individual
parameters for the selected track.
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Record your voice or a musical instrument

Overview of recording in Logic Pro

In Logic Pro, you have many powerful recording options for recording vocals, acoustic
instruments, electric instruments, and software instruments. When recording either
audio or MIDI, you can choose to record one track at a time, record multiple tracks at
once (called multitrack recording), replace audio or MIDI recordings, or record multiple
performances over the same section of a track, called take recording.
Once you have created your audio takes, you can then comp your audio recordings. This
process involves selecting the best parts from the different performances and piecing
them together into a single, master composite take. You can also punch in and out of audio
recordings to overwrite a portion of a previously recorded track.
With software instruments, you can record the MIDI parts using real-time recording
techniques, or you can use step input recording techniques, which allow you to insert
MIDI notes when not recording in real time. And there are several advanced recording
techniques available that can help speed up your workflow.
Note: If you have added a fade out, it is temporarily deactivated during recording, so that
you can hear what you record.

Record audio
Before recording audio in Logic Pro

You can record vocals, an acoustic instrument, or any other sound using your computer’s
built-in microphone or a microphone connected to your computer either directly or via an
audio interface. You record sound from a microphone to an audio track.
Before you start recording audio, do the following:
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•

Check hardware connections and settings, making sure that any sound source you plan
to use in your session—microphone or mixer, for example—is connected to the audio
inputs of your system and is working. You should also check hardware settings such as
the system memory requirement and disk space.

•

Choose the recording file type—AIFF, WAV, or CAF—for audio data before recording.

•

Set the audio recording path, which is only necessary if you want to save recorded
audio outside of the project.
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•

Set the project sample rate, which is the number of times per second the audio signal is
sampled. Recording at a sample rate of 44.1 kHz is recommended for most situations.

•

Set the project bit depth, which is the number of digital bits each sample contains.
Recording at a bit depth of 24 bits is recommended for most situations and is the
default setting.

•

Add an audio track, which is used to record a voice, an acoustic instrument, or any
other sound from a microphone.

•

Set the metronome, which plays a steady beat so you can play and record in time, or as
a count-in before recording starts.

•

Enable software monitoring, which allows you to monitor incoming audio through any
effects that are inserted into a record enabled audio track, if desired. Many audio
interfaces offer a direct or hardware monitoring option which sends the audio signal
being recorded to a monitor output before the signal is sent to Logic Pro. If your
interface offers direct recording you should use it, and only use software monitoring if
you’re using effects on an record enabled channel strip.

•

Check the monitoring level, which controls the playback (or monitoring) level, not the
recording level.

•

Tune any instruments that are connected to your system to ensure that your external
instrument recordings are in tune with any software instruments, samples, or existing
recordings in your project. You can access the Tuner using the Tuner button in the
control bar or in the Smart Controls menu bar (for audio tracks). For details about the
Tuner plug-in, see the Logic Pro Effects manual.

Record sound from a microphone or instrument in Logic Pro
You can record sound from a microphone (to record vocals or an acoustic instrument, for
example), or from an electric instrument (such as an electric guitar) connected to your
computer, on an audio track.

Record live audio

1. In Logic Pro, select the header of the audio track you want to record to.

If the Record Enable button is present on the track header, the letter “R” will be red to
indicate that the track is automatically enabled for recording.
2. Move the playhead to the point in the ruler where you want to start recording.
3. Set the metronome for recording if desired.
4. Click the Record button

in the control bar (or press R) to start recording.

5. Start singing or play your instrument.
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The recording appears as a new audio region on the track as you record.

6. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can view the newly recorded audio region in the Project Audio Browser.

Record multiple audio takes in Logic Pro

When you’re recording, you can record multiple versions, or takes, of a phrase or section in
quick succession. Take recording can be helpful especially when you’re improvising a lead
or solo part and want to capture several versions while you’re feeling inspired.
When you record multiple takes, a take folder is created on the track, containing the take
recordings. After recording, you can preview take recordings and choose which one you
want to use in the project. You can also create and edit comps, by selecting the best parts
from several takes and combining these parts into one master comp.
An example would be if you record three different guitar solos, each one as its own take.
All three takes would be available to you in the takes folder for you to choose between, or
you could use the comp feature to edit all three guitar solo takes into one guitar solo that
contains pieces of each of your three solos.
You can also record multiple audio takes into Live Loops cells. See Record and edit
takes in cells.

Record multiple audio takes

1. In Logic Pro, do one of the following:
•

Choose Record > Overlapping Audio Recordings > Cycle > Create Take Folder.

•

Choose Logic Pro > Preferences > Recording, then choose Create Take Folder from
the Overlapping Track Recordings > Audio > Cycle on pop-up menu.

2. Drag left or right in the top part of the ruler.
The cycle area appears as a yellow strip in the ruler, and Cycle mode is automatically
turned on.
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3. Set the metronome for recording, if desired.
4. Click the Record button

in the control bar (or press R) to start recording.

Recording starts automatically at the beginning of the defined cycle area. Record as
many cycle passes as you wish. After the second cycle pass, a take folder is created on
the track. Each subsequent cycle pass is added to the take folder.

5. Click the Stop button
in the control bar (or press the Space bar) after you finish
capturing cycle passes.
6. Open the take folder by doing one of the following:
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•

Click the disclosure arrow in the upper-left corner of the take folder.

•

Double-click the take folder.

•

Select the take folder and press Control-F.
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Record to multiple audio tracks in Logic Pro

You can record to more than one audio track at a time, allowing you to record several
instruments at once—placing each instrument on a separate track, for example. You can
also choose not to use take folders, and to record multiple audio versions to new tracks.
To record multiple input sources simultaneously, you need an audio interface that has
multiple inputs. See Audio devices overview.

Record to multiple audio tracks simultaneously
1. In Logic Pro, do one of the following:
•

Choose Record > Overlapping Audio Recordings > Cycle > Create Tracks and Mute.

•

Choose Preferences > Recording, then choose Create Tracks and Mute from the
Overlapping Recordings “Cycle On” pop-up menu.

•

Control-click the Record button
in the control bar, choose Recording Preferences
from the shortcut menu, then choose Create Tracks and Mute from the Overlapping
Recordings “Cycle On” pop-up menu.

2. Set the instrument or microphone input source for each track you want to record to.
To record the same input source to multiple tracks, set the input source for each track
to the same input on your audio interface. If you want to record multiple sources onto
multiple tracks, set the input source for each track to a different input from your audio
interface.
3. Click the Record Enable button in the track header of each track you want to record
to. Each clicked Record Enable button blinks red to indicate that the track is ready for
recording.
Note: You must have the Record Enable button visible in the track headers to record to
multiple audio tracks. See Enable tracks for recording.
4. Move the playhead to the point in the ruler where you want to start recording.
5. Set the metronome for recording, if desired.
6. Click the Record button

in the control bar (or press R) to start recording.

7. Everyone being recorded can start singing or playing their instruments.
A new audio region appears on each of the record-enabled tracks.

8. Click the Stop button
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in the control bar (or press the Space bar) to stop recording.
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Record multiple audio versions to new tracks
1. In Logic Pro, do one of the following:
•

Choose Record > Overlapping Audio Recordings > Cycle > Create New Track.

•

Choose File > Project Settings > Recording, then choose Cycle > Create Tracks from
the Overlapping Recordings: Audio pop-up menu.

•

Control-click the Record button
in the control bar, choose Recording Settings
from the shortcut menu, then choose Cycle > Create New Folder from the
Overlapping Audio Recordings pop-up menu.

2. Drag the pointer across the top part of the ruler to encompass the area you wish to
record.
This automatically turns on Cycle mode, and the cycle area appears as a yellow strip.
3. Set the metronome for recording, if desired.
4. Select the initial track on which you want to record.
5. Click the Record button

in the control bar (or press R) to start recording.

Recording starts automatically on the selected track at the beginning of the defined
cycle area. Each new cycle pass, a new track is created for a new recording. Record as
many cycle passes as you wish.
6. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

Punch in and out of audio recordings in Logic Pro

Punch recording is a technique you can use to overwrite a portion of a previously recorded
track, during playback, without touching any of the recording before or after that portion.
You punch in to interrupt playback and make the recording, then punch out to return to
playback mode. You can choose between two punch recording modes: Quick Punch-In
mode and Autopunch mode.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Punch recording is available.

Quick Punch-In mode

A useful and common recording practice is to switch in and out of recording mode while
listening to the previously recorded material, sometimes referred to as “punching in on the
fly.” This helps you fix mistakes or create alternate takes for a particular section. To ensure
the transition between playing and recording occurs without any audible gaps, you must
turn on Quick Punch-In mode.
When Quick Punch-In mode is on, recording occurs in the background from the moment
you start playback. This means there needs to be twice the number of available channel
strips than the number enabled for recording. A dialog appears if you exceed the number of
channel strips needed.
Important: It is recommended that you leave Quick Punch-In mode turned on (which it is,
by default). You only need to turn it off if you’re recording more than the number of channel
strips available (in a new project that’s more than 128 tracks), or if your hard disk is unable
to accommodate recording a large number of tracks. To turn it off, choose Record > Allow
Quick Punch-In, or Control-click the Record button, then choose Allow Quick Punch-In
from the shortcut menu.
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Autopunch mode

Autopunch describes the use of predefined punch-in and punch-out points to start and
stop recording. One advantage is that you can concentrate on your playing, rather than on
controlling the software. Another advantage is that you can set the starting and stopping of
recordings far more precisely than is possible if “punching in on the fly.”

Note: Only record-enabled tracks are affected by punch recording.
When it comes to judging punch-in and punch-out points during punch recording, you
should turn on auto input monitoring (which it is, by default). This setting allows you to
hear the input signal only during the actual recording; before and afterward you’ll hear
the previously recorded audio on the track. If auto input monitoring is turned off, you can
always hear the input signal.

Turn on auto input monitoring

In Logic Pro, do one of the following:
•

Choose Record > Auto Input Monitoring.

•

Control-click the Record button
from the shortcut menu.

in the control bar, then choose Auto Input Monitoring

Record on the fly using Quick Punch-in mode

1. In Logic Pro, turn on Quick Punch-In mode by doing one of the following:
•

Choose Record > Allow Quick Punch-In.

•

Control-click the Record button
in the control bar, then choose Allow Quick
Punch-In from the shortcut menu.

2. Click the Play button
in the control bar, then use the Record Toggle key command at
the point where you want to start recording.
Audio recording starts immediately.
3. Click the Stop button
in the control bar, or use the Record Toggle key command a
second time to stop recording. If an audio region already existed where you recorded on
the fly, a new audio region with your recording replaces the previously recorded region.
If you use the Record Toggle key command a second time, recording ends, but playback
continues.
Note: You can also use the Record Toggle key command when not in Quick Punch-In
mode. However, this causes a delay when you switch between playback and record
modes, accompanied by a dropout of all audio tracks.
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Record in Autopunch mode

1. In Logic Pro, turn on Autopunch mode by doing one of the following:
•

Click the Autopunch button

in the control bar.

Note: You can add the Autopunch button by customizing the control bar. For
information, see Customize the control bar.
•

Option-Command-click anywhere in the ruler.

The autopunch area is indicated by a red stripe in the middle third of the ruler, with the
left and right autopunch locators serving as punch-in and punch-out points.

2. Set the autopunch area by doing one of the following:
•

Drag the Punch In and Punch Out locators in the ruler.

•

Drag vertically in the autopunch locator fields in the control bar.

•

Drag the cycle area into the autopunch area to quickly match the autopunch area to
the cycle range.

3. Place the playhead at any position before the punch-in point.
4. Click the Record button
5. Click the Stop button

in the control bar (or press R) to start recording.
in the control bar (or press the Space bar) to stop recording.

A region that matches the length of the autopunch area is created. Any audio input
received before the punch-in or after the punch-out point streams through Logic Pro as
usual, but is not recorded.
If you want to improve a difficult part of a certain passage, you can use a combination of
the Cycle and Autopunch functions. Cycle mode recording allows you to practice as many
times as you like before performing the final take. On each cycle pass, only events or audio
that falls within the area defined by the autopunch locators is recorded. This lets you make
use of the preceding song section to “get into the groove.”
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Replace audio recordings in Logic Pro

You can record over an existing audio recording, or a portion of it, replacing the original
recording with the new recording. You do this by recording in Replace mode. In Replace
mode, any audio regions from when you start recording until the end of recording will be
erased, even if nothing is played.
You can access the Replace pop-up menu by long-clicking (or right-clicking) on the
Replace button
in the control bar or in the Recording preferences window.
Note: You can also replace software instrument recordings. For information on replacing
MIDI recordings, see replace software instrument recordings.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Replace recording is available.

Replace an audio recording

1. In Logic Pro, click the Replace button

in the control bar.

2. Click the Record Enable button in the track header of the track you want to record to.
The button blinks red to indicate that the track is ready for recording.
3. Move the playhead to the point in the ruler where you want to start recording.
4. Set the metronome for recording, if desired.
5. Click the Record button

in the control bar (or press R) to start recording.

6. Start singing or play your instrument.
7. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

A new audio region is created on top of the existing one.
The original recording is replaced with the new recording.

Delete audio recordings in Logic Pro

You can delete an audio region that was recorded before or since the current project
session was opened.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also delete an audio recording and its related audio file in the Project
Audio Browser.

Delete an audio recording from the Tracks area
•

In Logic Pro, select the audio region in the Tracks area, then press the Delete key.

The audio region is removed from the Tracks area but the audio file remains in the project.

Delete an audio recording and its related audio file from the project
•

In Logic Pro, choose Audio File > Delete File(s) from the Project Audio Browser menu
bar.

The deleted audio files are sent to the System Trash where they remain until you empty
the Trash.
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Record software instruments
Before recording software instruments in Logic Pro

You can connect a music keyboard to your computer to play and record the software
instruments built into Logic Pro. You also need to add a software instrument track and
choose a sound.

Connect a music keyboard to your computer
In Logic Pro, do one of the following:
•

If the keyboard is a USB music keyboard, connect the USB cable from the keyboard to
your computer.

•

If the keyboard is a standard MIDI keyboard, connect the keyboard to a MIDI interface
using standard MIDI cables, then connect the MIDI interface to your computer.

•

If the keyboard is a Bluetooth or Wifi music keyboard, consult its documentation for
instructions on how to pair it to your computer.

Be sure to follow the instructions that came with the keyboard, which may include installing
the correct driver on your computer. Check the manufacturer’s website for the latest driver
software. If you’re using a MIDI interface, be sure to follow the instructions that came with
the interface.

Add a software instrument track and choose a patch
1. In Logic Pro, do one of the following:
•

Choose Track > New Software Instrument Track. (If you use this method, you can
skip steps 2 and 3.)

•

Choose Track > New Tracks.

•

Click the Add Tracks button

above the track headers.

2. In the New Tracks dialog, select Software Instrument, and make sure that An Instrument
plug-in is chosen as the input source from the Input pop-up menu. You may also choose
a software instrument from the Instrument pop-up menu.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
the New Tracks dialog differs from the one above. In this New Tracks dialog, click
the Software Instrument button. You may also choose a software instrument from the
Instrument pop-up menu.
3. Click Create.
4. In the Library, select a patch category from the list on the left, then select the patch you
want to use from the list on the right. If you’ve already chosen a software instrument for
the track, the software instrument may change depending on the patch you select.

Logic Pro User Guide

245

Play software instruments in Logic Pro

You can play your chosen software instrument using musical typing or the onscreen
keyboard. You can also use a music keyboard.
If your computer has a Touch Bar, you can play the software instrument on the selected
software instrument track using the Keyboard screen and play drum kits and percussion
instruments on the selected Drummer track using the Drum Pads screen.

Play a software instrument using musical typing

1. In Logic Pro, choose Window > Show Musical Typing.
The Musical Typing window appears, showing the layout of keys used for playing notes
and changing controller information.

2. Select the software instrument track you want to play.
3. Play the software instrument using the keys on your computer keyboard. Use the other
keys shown in the window to perform the following actions:
•

Press Z or X to move down or up by octaves.

•

Press C or V to lower or raise the velocity.

•

Press 4 through 8 to change the modulation (mod wheel) value, or 3 to turn off
modulation.

•

Press 1 or 2 to bend the pitch down or up. The pitch is bent for as long as you press
the key.

•

Press Tab to turn sustain on or off (similar to using a sustain pedal).

As you play, the notes you play are highlighted in the Musical Typing window.
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Play a software instrument using the onscreen keyboard
1. In Logic Pro, choose Window > Show Musical Typing.

The Musical Typing window appears. In the upper-left area of the window, there are two
buttons for switching between the Musical Typing window and the onscreen keyboard.

2. Click the Keyboard button in the upper-left area of the window.
The onscreen keyboard appears.

3. To play the onscreen keyboard, click the notes on the keyboard.
You can click when the project is playing or stopped, and record by clicking during
recording. Clicking notes lower on the keys plays the notes with higher velocity, and
clicking higher plays them with lower velocity.
4. To change the range of the onscreen keyboard, do one of the following:
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•

Drag the blue rectangle in the overview over the range you want to play.

•

Click an area of the overview outside the blue rectangle to move it to where you
clicked.

•

Click one of the small triangles to the left and right of the keys. Clicking the left
triangle lowers the range by an octave, and clicking the right triangle raises the
range by an octave.
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Play a software instrument using the Touch Bar

1. In Logic Pro, tap the Mode button on the left side of the Touch Bar, then tap the
Keyboard button
2. Tap the keys on the Touch Bar keyboard to play notes.
3. To adjust the size of the Touch Bar keyboard, tap one of the Keyboard Size buttons to
the left of the Touch Bar keyboard.
4. To limit notes to a musical scale: Tap the Scale button, then tap to select the root note
and the mode.

Record software instruments in Logic Pro

Before you start recording, make sure you connect a music keyboard to your computer and
create a software instrument track to record to. You should also familiarize yourself with
how to use musical typing and the onscreen keyboard.

Record a software instrument

1. In Logic Pro, select the software instrument track you want to record to.
2. Move the playhead to the point in the ruler where you want to start recording.
3. Set the metronome for recording, if desired.
4. Click the Record button

in the control bar (or press R) to start recording.

5. Use your MIDI keyboard, Musical Typing window, or onscreen keyboard to play some
notes.
The recording appears as a new MIDI region on the track as you record.

6. Click the Stop button
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Record additional software instrument takes in Logic Pro

You can record multiple versions, or takes, in quick succession. Later, you can preview the
take recordings and choose which one you want to use in the project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can record multiple MIDI takes.

Record multiple MIDI takes

1. Choose Logic Pro > Preferences > Recording, then choose Create Take Folder from the
Overlapping MIDI Recordings pop-up menu.
2. Drag left or right in the top part of the ruler.
The cycle area appears as a yellow strip in the ruler, and Cycle mode is automatically
turned on.

3. Click the Record button

in the control bar (or press R) to start recording.

Recording starts automatically at the beginning of the defined cycle area.
4. Use your MIDI keyboard, Musical Typing window, or onscreen keyboard to play some
notes. Record as many cycle passes as you wish.
Note: Each previously recorded take is automatically muted during recording.
5. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

The selected track contains a closed take folder with multiple take regions inside.
6. Open the take folder by doing one of the following:
•

Click the disclosure arrow in the upper-left corner of the take folder.

•

Double-click the take folder.

•

Select the take folder and press Control-F.

Overdub software instrument recordings in Logic Pro

Overdubbing is the process of recording a performance on top of an existing performance,
merging them into a single region. You can use this process to add a supplementary
recorded sound to a previously recorded performance, for example. You can also use spot
erase to remove any unwanted notes from a recorded performance.

Overdub a software instrument recording

1. In the Logic Pro Tracks area, select a MIDI region.
2. Click the Set Locators button in the toolbar.
Cycle mode is turned on and the left and right locators match the start and end points
of the selected MIDI region.
3. Click the Record button

in the control bar (or press R) to start recording.

Recording begins after the predefined count-in.
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4. Use your MIDI keyboard, Musical Typing window, or onscreen music keyboard to record
a part. Record as many cycle passes as you wish.
5. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

The end result is a single MIDI region that contains the merged performances from each
cycle pass. However, you can also overdub a MIDI recording when not in Cycle mode.

Spot erase software instrument recordings in Logic Pro

You can use spot erase to remove any unwanted notes from a recorded performance.

Spot erase existing notes in a region

1. In Logic Pro, click the Spot Erase button in the toolbar (or use the corresponding key
command).
Spot Erase is turned on, indicated by a floating window with a red flashing icon.
2. In playback or recording mode, hold down on your music keyboard or the onscreen
Musical Typing keyboard the note that you want to delete.
Each instance of that note is deleted in regions on the selected track as the playhead
passes over them.
3. To turn off Spot Erase, do any of the following:
•

Close the Spot Erase floating window.

•

Click the Spot Erase button in the toolbar (or use the corresponding key command).

Use Note Repeat in Logic Pro

It’s possible to transform incoming MIDI notes into a repeated MIDI note of the same
pitch, as long as the key is held down. You can define parameters such as repetition
rate, velocity, and gate length, as well as assign MIDI controllers for controlling these
parameters.

Transform incoming MIDI notes

1. In Logic Pro, click the Note Repeat button in the toolbar (or use the corresponding key
command).

2. In the initial Note Repeat dialog, you can do the following:
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•

Choose a repetition rate from the Rate pop-up menu.

•

Define a velocity value in the Velocity field or leave it “As played” (default).

•

Define a gate length value in the Gate field.
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3. Click the disclosure arrow in the upper-left area of the dialog to reveal additional
settings, then you can do the following:

•

Select the checkboxes to make the MIDI controller pop-up menus available, then
choose a controller for rate, velocity, and gate time.

•

Define the maximum and minimum values for rate and gate time.

•

Define the maximum and minimum offset values for velocity.

4. Select the Key Remote checkbox in the lower-left area of the dialog to display the
keyboard, then use the keys to define the rate and gate time settings.

The Note Repeat and Spot Erase keys have On/Off buttons, which offer the following
functions:
•

When turned off (default), Note Repeat or Spot Erase is always active as long as the
respective window is open.

•

When turned on, Note Repeat or Spot Erase is active only as long as the respective
remote key is held down.

Record to multiple software instrument tracks in Logic Pro
You can record to multiple software instrument tracks simultaneously.

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also record to multiple software instrument tracks successively (in Cycle mode).

Record to multiple software instrument tracks simultaneously

1. In Logic Pro, click the Record Enable button in the track header of each track you want
to record to. Each clicked Record Enable button turns red to indicate that the track is
ready for recording.
2. Move the playhead to the point in the ruler where you want to start recording.
3. Set the metronome for recording, if desired.
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4. Click the Record button

in the control bar (or press R) to start recording.

5. Use your MIDI keyboard, Musical Typing window, or onscreen music keyboard to record
a part.
6. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

A MIDI region is recorded to the selected track. Aliases of the MIDI region on the selected
track are recorded to the other record-enabled tracks. Any subsequent edits to the
“parent” MIDI region affect all aliases. This is known as layer recording. For details about
the difference between layer recording and multiplayer recording, see Recording settings.

Record to multiple software instrument tracks successively
In Logic Pro:
•

•

To continue playing previous tracks while recording, do one of the following:
•

Choose Record > Overlapping MIDI Recordings > Cycle Mode On > Create Tracks.

•

Choose File > Project Settings > Recording, then choose Cycle > Create Tracks from
the Overlapping MIDI Recordings pop-up menu.

•

Control-click the Record button
in the control bar, choose Recording Settings
from the shortcut menu, then choose Cycle > Create Tracks from the Overlapping
MIDI Recordings pop-up menu.

To mute all previous tracks while recording, do one of the following:
•

Choose Record > Overlapping MIDI Recordings > Cycle Mode On > Create Tracks
and Mute.

•

Choose File > Project Settings > Recording, then choose Cycle > Create Tracks and
Mute from the Overlapping MIDI Recordings pop-up menu.

•

Control-click the Record button in the control bar, choose Recording Settings
from the shortcut menu, then choose Cycle > Create Tracks and Mute from the
Overlapping MIDI Recordings pop-up menu.

Replace software instrument recordings in Logic Pro

When you’re recording, you can replace all or part of a previous performance while
recording a new one. You do this by recording in Replace mode. You can choose one of the
following Replace mode behaviors from the Replace pop-up menu:
•

Region Erase: Erases MIDI regions from the Tracks area across the entire recording,
even if nothing is played.

•

Region Punch: Erases MIDI regions only where MIDI events have been recorded.

•

Content Erase: Erase only MIDI content inside of MIDI regions, across the entire
recording, even if nothing is played.

•

Content Punch: Erase only the MIDI content inside of MIDI regions, but only where MIDI
events have been recorded.

You can access the Replace pop-up menu by long-clicking (or right-clicking) on the
Replace button
in the control bar or in the Recording preferences window.
Note: For information on replacing audio recordings, see replace audio recordings.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
replace recording is available.
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Record over an existing MIDI region

1. In Logic Pro, click the Replace button

in the control bar.

2. Drag left or right in the top part of the ruler.
The cycle area appears as a yellow strip in the ruler, and Cycle mode is automatically
turned on.

3. Click the Record button

in the control bar (or press R) to start recording.

Recording starts automatically at the beginning of the defined cycle area.
4. Use your MIDI keyboard, Musical Typing window, or onscreen music keyboard to play
some notes. Record as many cycle passes as you wish.
5. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

A new MIDI region is created on top of the existing one in Region Erase or Region Punch
modes. The content of the existing region is replaced in Content Erase and Content
Punch modes.
6. Click the Stop button in the control bar (or press the Space bar) to stop recording.
Your new recording now replaces the previously recorded portion of your material.

Record multiple MIDI devices to multiple tracks in Logic Pro

Just as you can record multiple audio performances simultaneously on multiple
audio tracks, you can record multiple MIDI input devices simultaneously, each device
representing a unique performance and triggering different sounds, on multiple instrument
tracks. Before you start recording, make sure you create software instrument tracks for
each MIDI Input device you wish to record, and configure each MIDI input device that you’ll
be recording to transmit on a unique MIDI channel. See the documentation for your MIDI
input device, for information on how to change its MIDI output channel.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can record multiple MIDI input devices simultaneously to multiple software
instrument tracks.

Record multiple MIDI input devices to multiple instrument tracks

1. In the Track inspector for each track, use the MIDI In Port and MIDI In Channel pop-up
menus to choose a unique MIDI port and MIDI channel that matches the MIDI output
port and channel for the MIDI input device sending to that specific track. For more
information about track parameters see Edit track parameters.
2. Click the Record Enable button in the track header of each track you want to record
to. Each clicked Record Enable button turns red to indicate that the track is ready for
recording.
3. Move the playhead to the point in the ruler where you want to start recording.
4. See Use the metronome if you wish to use the metronome during recording.
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5. Click the Record button

in the control bar (or press R) to start recording.

Recording begins after the predefined count-in.
6. Use each MIDI input device to record parts.
7. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

A MIDI region is recorded to each record enabled track. If a MIDI input device outputs MIDI
on a channel for which there was no instrument track, that device’s MIDI output is recorded
to the selected instrument track.

Record software instruments and audio simultaneously
in Logic Pro

You can record software instruments using MIDI input devices and audio using
microphones, electric, electronic, and acoustic instruments simultaneously. You
can choose to record a single music keyboard to a software instrument track while
simultaneously recording audio tracks, or you can record multiple MIDI input devices to
separate software instrument tracks while simultaneously recording audio tracks.

Record a software instrument and audio simultaneously

Before you start recording, make sure you create tracks for each instrument you want
to record and connect a music keyboard to your computer. Also, follow the procedures
outlined in Before recording audio.
1. In Logic Pro, click the Record Enable button in the track header of each track you want
to record to. Each clicked Record Enable button on an audio track blinks red to indicate
that the track is ready for recording. Each clicked Record Enable button on a Software
Instrument track turns red to indicate that the track is ready for recording.
2. Select one of the software instrument tracks.
3. Move the playhead to the point in the ruler where you want to start recording.
4. Click the Record button

in the control bar (or press R) to start recording.

Recording begins after the predefined count-in.
5. Use a MIDI keyboard, the Musical Typing window, or onscreen keyboard to record
software instrument parts and start singing or playing instruments to record audio.
6. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

Record multiple MIDI input devices and audio simultaneously

You can record multiple MIDI input devices simultaneously, each device representing a
unique performance and triggering different sounds, on multiple software instrument
tracks at the same time you record multiple audio sources. You need to configure each
MIDI input device that you are recording to transmit on a unique MIDI channel. Consult
the documentation of your MIDI input device for information on how to change its MIDI
output channel.
Before you start recording, make sure you create tracks for each instrument you want
to record and connect a music keyboard to your computer. Also, follow the procedures
outlined in Before recording audio.
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When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can record multiple MIDI input devices simultaneously to multiple software
instrument tracks.
1. In the Track inspector for each software instrument track, use the MIDI In Port and MIDI
In Channel pop-up menus to choose a unique MIDI port and MIDI channel that matches
the MIDI output port and channel for the MIDI input device sending to that specific
track. For more information about track parameters see Edit track parameters.
2. Click the Record Enable button in the track header of each track you want to record
to. Each clicked Record Enable button turns red to indicate that the track is ready for
recording.
3. Move the playhead to the point in the ruler where you want to start recording.
4. Click the Record button

in the control bar (or press R) to start recording.

Recording begins after the predefined count-in.
5. Use each MIDI input device to record software instrument parts, and start singing or
playing instruments to record audio.
6. Click the Stop button

in the control bar (or press the Space bar) to stop recording.

Use step input recording in Logic Pro

Step input allows you to insert MIDI notes when you’re not recording in real time. You can
use step input to create note runs that may be too fast for you to play or to replicate sheet
music that’s too difficult for you to play.
You can use one or more of the following for step input:
•

Musical Typing keyboard

•

Step Input keyboard

•

MIDI keyboard

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Step Input Keyboard is available.

Insert notes using musical typing

1. In Logic Pro, choose Window > Show Musical Typing.
The Musical Typing window appears, showing the layout of keys used for playing notes
and changing controller information.
2. Select the software instrument track you want to play.
3. Play the software instrument using the keys on your computer keyboard. Use the other
keys shown in the window to perform the following actions:
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•

To move down or up by octaves: Press Z or X.

•

To lower or raise the velocity: Press C or V.

•

To change the modulation (mod wheel) value: Press 4 through 8, or 3 to turn off
modulation.

•

To bend the pitch down or up: Press 1 or 2 (the pitch is bent for as long as you press
the key).

•

To turn sustain on or off (similar to using a sustain pedal): Press Tab.
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Insert notes using the Step Input keyboard

1. In Logic Pro, open the MIDI region in the editor you want to work in.
Note: If you choose to work in the Score Editor, you should turn off Interpretation for the
MIDI region. See Turn interpretation on or off for instructions.
2. Move the playhead to the point where you want to insert notes.
3. Click the MIDI In button on the menu bar of the editor if it is not already active (red).
4. Choose Window > Show Step Input Keyboard.
5. Do one or more of the following:
•

To insert a note of the key’s pitch: Click a key.

•

To set the length of the inserted note: Click the Note Length buttons.

•

To set the velocity of the inserted note: Click the Velocity buttons.
There are eight velocity values—represented by the traditional volume indicators
ppp, pp, p, mp, mf, f, ff, and fff. These correspond to MIDI velocity values 16, 32, 48,
64, 80, 96, 112, and 127, respectively.

•

To make the next three notes you enter a triplet group: Click the Triplet button.
The rhythmic value of the triplets is based on the currently selected note value.

•

To lengthen the selected note by half of the selected note value: Click the Dot
button.

•

To lengthen the selected note by the selected note length value: Click the Sustain
Inserted Notes button.

•

To correct the timing of the start of the next inserted note to the nearest bar or beat
line: Click the Quantize button.
The position of the playhead is critical when you use this option.

•

To choose the MIDI channel of an inserted note: Open the Channel pop-up menu.
The channel settings of individual notes usually have no effect on the playback
channel, and therefore the sound, of the MIDI region. The channel settings of
individual notes are used mainly for polyphonic score display.

•

To insert multiple notes at different pitches at the same time: Click the Chord button.
The notes are “stacked” at the same position, resulting in a chord. The playhead
doesn’t advance until the Chord button is clicked again (turned off). Chord mode
prevents the playhead from moving after the insertion of a note, allowing you to
insert as many notes as you like at the same bar position. Before you insert the last
note into the chord, click the Chord button again to turn off Chord mode, and the
playhead advances as usual after a note is inserted.

Insert notes using a MIDI keyboard
•
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In Logic Pro, inserting notes with a MIDI keyboard is similar to using the Step Input
keyboard. However, you press keys on your real-world MIDI keyboard, rather than
clicking onscreen keyboard notes.
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Insert rests

In Logic Pro, you can insert rests using step recording techniques.
•

If the Musical Typing window is displayed, press Tab without a key that represents a note.

•

Using the Step Input keyboard, make sure the previously created note is unselected in
the Piano Roll Editor and click the Sustain inserted note(s) button.

•

Using your MIDI keyboard, without any keys being pressed, step on the sustain pedal.

•

Using the steps described in the Assign key commands section, assign the Rest and/or
Step Forward key command to keys on your keyboard. Then press the key command to
insert a rest.

Use the metronome in Logic Pro

Logic Pro includes a metronome, which plays a steady beat (like a “click track”) to help
you play and record in time. You can turn the metronome on or off when you’re recording,
or any time your project is playing. The metronome always plays at the project tempo.
This means that if a tempo map has been created by Smart Tempo, the metronome
automatically follows it. It also means that if Smart Tempo is automatically adapting the
project tempo to the performance being recorded, the timing of the metronome adapts
along with it. For more information about Smart Tempo, see Smart Tempo overview.
The included metronome uses a dedicated software instrument named Klopfgeist to
generate clicks. You have the option of using any audio or MIDI instrument to generate
metronome clicks. You can also access a pop-up menu to set if you want the metronome to
play during playback, recording, or both.
You can also set the metronome to play a one-measure “count-in” before recording starts.

Turn the metronome on or off

In Logic Pro, do one of the following:
•

Click the Metronome button

in the control bar.

•

Press the key command assigned to toggle the metronome on and off.

Set conditions for the metronome click
•

In Logic Pro, click-hold the Metronome button

in the control bar.

To limit the metronome to only click when you toggle the metronome on, choose Simple
Mode. With this mode selected, the other metronome settings in the pop-up menu are
unavailable.
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If you want the metronome to click during recording whether or not the metronome is
toggled on or off, choose Click While Recording.
If you want the metronome to click only during recording count-in whether or not the
metronome is toggled on or off, choose “only During Count-In.”
Note: Click While Recording must also be chosen for “only During Count-In” to work.
If you want the metronome to click during playback, choose Click While Playing. This
setting has the same effect as toggling the metronome on and off.
You can choose Metronome Settings from this menu to access the rest of the metronome
settings available in Project Settings > Metronome. For more information, see
Metronome settings.

Turn the count-in on or off

In Logic Pro, do one of the following:
•

Click the Count-in button
in the control bar to have the metronome play a
predefined count-in before recording starts.

•

Press the key command assigned to toggle the count-in on and off.

Set the number of bars for the count-in
In Logic Pro, do one of the following:
•

Choose Record > Count-in, then choose the number of bars from the submenu.

•

In Project Settings > Recording, choose the number of bars from the Count-in
pop-up menu.

Advanced recording techniques
Advanced recording commands in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can use several advanced commands to speed up the recording process:

•

Record/Record Toggle: Use to stop recording but to continue playback. Use it again to
resume recording from the playhead position.

•

Record/Record Repeat: Use to delete the recording, move the playhead back to the
recording start position, and start recording again.

•

Discard Recording and Return to Last Play Position: Use to delete the recording and
move the playhead back to the last play position. Unlike Record/Record Repeat, you
need to manually begin a new recording, using any Record command.

Use advanced recording commands
In Logic Pro, do any of the following:
•
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To use Record/Record Toggle:
•

Choose Record > Record Button Options > Record/Record Toggle.

•

Control-click the Record button
Toggle from the shortcut menu.

in the control bar, then choose Record/Record
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•

•

To use Record/Record Repeat:
•

Choose Record > Record Button Options > Record/Record Repeat.

•

Control-click the Record button
Repeat from the shortcut menu.

in the control bar, then choose Record/Record

To use Discard Recording and Return to Last Play Position: Press Command-Period (.).

Color takes while recording in Logic Pro

You can color take regions in an open or closed take folder, providing you with a visual
reference while recording.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also color audio takes automatically while recording.

Color a take in an open or closed take folder
1. In the Logic Pro Tracks area, select a take.

2. Open the Color palette by doing one of the following:
•

Choose View > Show Colors (or press Option-C).

•

Click the Toolbar button
Colors button.

in the control bar to show the toolbar, then click the

3. Choose a color.

Color an audio take automatically while recording

1. In Logic Pro, open the Recording project settings by doing one of the following:
•

Choose File > Project Settings > Recording.

•

Control-click the Record button
in the control bar, then choose Recording
Settings from the shortcut menu.

2. Select the Automatically colorize takes checkbox.

When this setting is selected, audio take folders use the color selected in the Color
palette for the first take, but different colors for each of the following takes in that take
folder. All colors used in an audio take folder are selected from the same color row in
the Color palette, advancing by a predefined number of columns after each take.
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Mark takes while recording in Logic Pro

If you know you’ve recorded a good take and want to mark it so that you can find it again
later, you can do so while you’re still recording.

Mark a take while recording
•

In Logic Pro, use the Select Previous Section for Realtime Comping key command.

This command places a tag in the current take, at the position the key command was used.
All audio that precedes the use of the key command is tagged as a good take, and is used
in the final comp.

Capture most recent MIDI performance in Logic Pro

It’s possible to capture your most recent MIDI performance, even if Logic Pro isn’t
recording using the Capture Recording feature. You can use Capture Recording whether in
playback mode or stopped.
When Cycle mode is off, Capture Recording creates a region containing all the MIDI events
received during playback. In Cycle mode, you can use Capture Recording to create a new
take region for each new cycle during which MIDI events are received when you have the
Overlapping MIDI Regions preference set to “Create Take Folder.”
When playback is stopped, Capture Recording creates a separate region containing all the
MIDI events received since the last playback; however, after a pause of twenty seconds
between incoming MIDI events, those initial MIDI events before the pause are discarded.
If when playback is stopped you perform some MIDI events and then pause for 1.5 bars
or longer, those initial notes are not included in the visible part of your region. If you do
want those MIDI events to be included in the created region, you can drag the left region
boundary to expose those MIDI events.
In both playback mode and when stopped, Capture Recording captures MIDI notes, MIDI
Control Change messages, and if Record Region Automation is active, volume, pan,
and plug-in parameter adjustments as well. See Choose automation modes for more
information.
If Smart Tempo is set to ADAPT mode before using Capture Recording, the project tempo
will adapt to your captured recording. See Choose the Project Tempo mode for more
information.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Capture Recording is available.

Capture a recent performance
•

In Logic Pro, click the Capture Recording button in the control bar.

Note: If the Capture Recording button is not visible in the control bar you will need to
customize the control bar to add it. See Change the controls on the control bar for more
information.
You can also use the Capture as Recording key command.
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Use Capture Recording to create Take regions in Cycle mode

1. In Logic Pro Preferences > Recording > Overlapping Track Recordings > MIDI Cycle On,
choose Create Take Folder from the pop-up menu.
2. Turn on Cycle mode.
3. Start playback and create/perform MIDI events.
4. When you have finished your performance, click the Capture Recording button in the
control bar (or use the Capture as Recording key command).

Comp your audio recordings
Overview of comping audio performances in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
comping is available.
Imagine a scenario in which you have recorded multiple performances of a vocal solo
over the same section of a project. You can select the best parts from the different
performances and piece them together into a single take. This is the process of making a
composite take—commonly referred to as comping—and is achieved by using the Quick
Swipe Comping feature. You can also drag or cut the contents of take folders.
You can switch individual take folders between the following two editing modes, with the
active mode determining the types of edits that you can make:

•

Quick Swipe Comping: Allows quick swipe behaviors in the take folder, allowing you to
create and edit comps.

•

Quick Swipe Comping off: Turns off quick swipe behaviors in the take folder, allowing
you to cut, drag, and move takes or take folders.

Note: Quick Swipe Comping is available for audio take folders only, not MIDI take folders.

Turn Quick Swipe Comping mode on or off
In Logic Pro, do one of the following:
•
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Click the Quick Swipe Comping button in the upper-left corner of the take folder.
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•

Choose Quick Swipe Comping from the Take Folder pop-up menu.

Note: For Quick Swipe Comping mode to be available, choose Logic Pro > Preferences >
Recording > Overlapping Track Recordings, then choose Create Take Folder. See Recording
preferences.

Preview take recordings in Logic Pro

In order to create and edit comps, you first need to preview the take recordings in a take
folder. The simplest way to preview take recordings is to open the take folder. You can then
select the individual takes for playback. You can also select and preview takes in a closed
take folder.

Open a take folder and preview the takes

1. In the Logic Pro Tracks area, open the take folder by doing one of the following:
•

Click the disclosure arrow in the upper-left corner of the take folder.

•

Double-click the take folder.

•

Select the take folder and press Option-F.

2. During playback, do one of the following:
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•

If the take folder is in Quick Swipe Comping mode: Click the relevant take.

•

If the take folder is not in Quick Swipe Comping mode: Option-click the header area
of the relevant take.
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Open multiple take folders

1. In the Logic Pro Tracks area, select multiple take folders.
2. Option-click the disclosure arrow in the upper-left corner of one of the selected take
folders.

Note: If all regions in a track are selected, clicking on the disclosure arrow in the upper left
corner of any of the take folders on the track opens all the take folders.

Preview takes in a closed take folder
•

In the Logic Pro Tracks area, during playback, choose a take from the Take Folder popup menu.

You can also use the following key commands to step through take recordings in an open
or closed take folder:
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•

Select Previous Take or Comp: Moves back through the takes or comps as listed in the
take folder’s pop-up menu.

•

Select Next Take or Comp: Moves forward through the takes or comps as listed in the
take folder’s pop-up menu.
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Create, save, edit, and rename comps
Create and save comps in Logic Pro
You can use quick swipe comping techniques to select the best parts from several takes,
combining these parts into one master comp. After creating a comp, it’s a good idea
to save it so that you can easily return to it at a later point. Any subsequent changes
automatically create a new comp.

Combine sections of different takes into a comp
1. In Logic Pro, do one of the following:
•

Click the Quick Swipe Comping button in the upper-left corner of the take folder,
making sure it’s turned on.

•

Click the Take Folder pop-up menu in the upper-left corner of the take folder, and
make sure Quick Swipe Comping is chosen.

2. Drag across take sections with the Pointer or Pencil tool.
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Selecting a section in one take automatically deselects the same section in another take.

The comp sections, located in the top lane of the take folder, reflect the combined
selections from all takes. The vertical lines in the comp overview indicate the transitions
between the different take sections.

Save the current comp
•

In the Logic Pro Tracks area, choose Duplicate Comp from the Take Folder pop-up menu
in the upper-left corner of the take folder.

The current comp is saved, and added to the list of comps in the pop-up menu.
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Create a comp from the current take
•

In the Logic Pro Tracks area, choose Create New Comp from the Take Folder pop-up
menu in the upper-left corner of the take folder.

The current take is saved as a new comp named Comp X: Comp X, and is added to the list
of comps in the pop-up menu. By default, new comps are saved as Comp X: Comp X, but
you can also rename comps.

Edit comps in Logic Pro

You can edit comps by changing the start or end point of take sections, by moving a
selected comp area to the left or right, or by alternating selected comp areas between
takes. You should save a comp before editing it. Any subsequent changes automatically
create a new comp.

Edit sections of different take regions

In the Logic Pro Tracks area, do one of the following:
•
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To extend a take section: Place the pointer over the start or end point of a take
selection, then drag.
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Extending a take selection (dragging the start point to the left or the end point to
the right) shortens adjacent selections on other takes. Shortening a take selection
(dragging the start point to the right or the end point to the left) extends adjacent
selections on other takes. This ensures that you don’t create silence between take
selections.
•

To shorten a take section: Place the pointer over the start or end point of a take
selection, then Shift-drag.

Shortening a take selection (dragging the start point to the right or the end point to
the left) does not extend adjacent selections on other takes. This allows you to create
silence between take selections.
Note: If you have enabled Quick Swipe and Take Editing click zones in Preferences >
General > Editing, make sure you place the pointer over the bottom half of the take region.

Move a selected area to the left or right
•

In the Logic Pro Tracks area, place the pointer over the center area of a take selection,
then drag when the pointer changes to a two-headed arrow.

This action moves the selection, while at the same time extending or shortening any
adjacent take selections.
Note: If you have enabled Quick Swipe and Take Editing click zones in Preferences >
General > Editing, make sure you place the pointer over the bottom half of the take region.
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Alternate selected areas between take lanes
•

In the Logic Pro Tracks area, click an unselected area of a take to make that particular
area active and part of the comp.

The same area is automatically deselected in another take. This is a quick way to compare
a section of two different takes.
Note: If you have enabled Quick Swipe and Take Editing click zones in Preferences >
General > Editing, make sure you place the pointer over the bottom half of the take region.

Remove a take selection from the comp
•
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In the Logic Pro Tracks area, Shift-click the take selection.
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Remove an entire take from the comp
•

In the Logic Pro Tracks area, Shift-click the header area of the take.

If the take doesn’t contain any selections, all unselected areas in other takes are selected
in the take you click.

Rename takes and comps in Logic Pro
You can rename both takes and comps.

Rename a take

1. In the Logic Pro Tracks area, choose the take you want to rename from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Rename Take from the same pop-up menu.
3. Enter the new name in the dialog that appears, then click OK.
You can also click a take with the Text tool, then enter a new name in the text field
that appears.
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Rename a comp

1. In the Logic Pro Tracks area, choose the comp you want to rename from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Rename Comp from the same pop-up menu.
3. Enter the new name in the dialog that appears, then click OK.
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Delete takes and comps
You can delete takes and comps from take folders at any time. When deleted, they no
longer appear in the take folder’s list of takes and comps. Any comp selections using
deleted takes are also removed.

Delete a take

1. In the Logic Pro Tracks area, choose the take you want to delete from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Delete the take by doing one of the following:
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•

Choose Delete Take from the Take Folder pop-up menu.

•

Click the take with the Eraser tool.

•

Press the Delete key.
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Delete a comp

1. In the Logic Pro Tracks area, choose the comp you want to delete from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Delete Comp from the Take Folder pop-up menu.

Delete all but the currently active comp

1. In the Logic Pro Tracks area, choose the comp you want to keep from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Delete all other Comps from the Take Folder pop-up menu.
All comps, with the exception of the currently active comp, are deleted. (This command is
available only when a take folder contains more than one comp and when a comp is active.)
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Edit take regions
Edit take region start and end points in Logic Pro
You can edit the start and end points of take regions, which allows you to remove the bad
part of an otherwise good take.
Also, after cutting a take region, you might want to resize one of the two adjacent regions.
Resizing one of them might impact the length of the other.
Note: To perform the following tasks, you must turn off Quick Swipe Comping mode for the
selected take folder, or enable Quick Swipe and Take Editing click zones in Preferences >
General > Editing and click in the top half of the take region.

Edit a take region’s start or end point
•

In the Logic Pro Tracks area, place the pointer over the lower-left or lower-right edge of
the take region, then drag when you see the Resize pointer.

Edit a take region’s start or end point when bordered by another take region
•

In the Logic Pro Tracks area, place the pointer over the top-left or top-right edge of the
take region, then drag when you see the Junction pointer.

Extending a take region (dragging the start point to the left or the end point to the right)
automatically shortens the adjacent take region. Shortening a take region (dragging the
start point to the right or the end point to the left) automatically extends the adjacent
take regions. This behavior ensures that you do not create silence between different take
region sections.
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Cut take folders and take regions in Logic Pro
You can cut take folders and take regions, creating multiple take folders or multiple take
regions on the same take lane.

Cut a take folder
•

In the Logic Pro Tracks area, click the take folder with the Scissors tool.

The take folder is cut at the clicked position and all takes inside the take folder are also cut
at the same position. As a result, your track lane contains multiple take folders and your
take lanes contain multiple take regions, all of which can be edited independently.

Cut multiple take folders
•

In the Logic Pro Tracks area, select multiple take folders, then click any one of them
with the Scissors tool.

The take folders are cut at the clicked position and all takes inside the take folders are also
cut at the same position. As a result, your track lanes contain multiple take folders and your
take lanes contain multiple take regions, all of which can be edited independently.

Cut a take region
•

In the Logic Pro Tracks area, click the take region using the Scissors tool.

Multiple take regions now appear on the same take lane.
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Make multiple cuts across a take region
•

In the Logic Pro Tracks area, Option-click the take region with the Scissors tool.

The first cut occurs at the clicked position, and all additional cuts occur at equal
intervals up to the take region end point.

Slice a take region at comp section borders
•
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In the Logic Pro Tracks area, Control-click the take region, then choose Slice at Comp
Section Borders from the shortcut menu.

275

Trim a take region to active comp sections
•

In the Logic Pro Tracks area, Control-click the take region, then choose Trim to Active
Comp Sections from the shortcut menu.

Move take folders and take regions in Logic Pro
You can move take folders and take regions—within the same take lane, between take
lanes, and to other tracks. Whether or not you have chosen Overlap or No Overlap in
the Drag pop-up menu, take regions inside take folders always behave as if No Overlap
is selected.
Note: To perform all the following tasks except Moving a take folder or take region within
its own lane, you must either turn off Quick Swipe Comping mode for the selected take
folder, or click in the upper half of the take regions if you have enabled Quick Swipe and
Take Editing click zones in Preferences > General > Editing.

Move a take folder or take region within its own lane
•

In the Logic Pro Tracks area, drag the take folder or take region to the new position.

Move take regions between take lanes
•

In the Logic Pro Tracks area, drag the take region to another take lane.

Empty take lanes are automatically removed.

Create a new take lane for a take region
•

In the Logic Pro Tracks area, drag the take region onto the take folder, at a position
where it overlaps with a take region in the currently active take.

If the dragged take region does not overlap with a take region in the currently active take,
it is added to the take lane of the active take. A new take lane is created directly under the
take folder, and the take region is added as a new take.
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Manage take folder contents
Export takes and comps in Logic Pro
You can export an active take or comp from a take folder to a new track, leaving the
original take folder content intact.

Export an active take to a new track

1. In the Logic Pro Tracks area, choose the take you want to export from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Export active Take to New Track from the Take Folder pop-up menu.
The active take is copied to a new track, which is created below the take folder track. The
exported take can be made up of one or more take regions. The content of the original take
folder remains intact.
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Export an active comp to a new track

1. In the Logic Pro Tracks area, choose the comp you want to export from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Export active Comp to New Track”from the Take Folder pop-up menu.
The active comp is copied to a new track, which is created below the take folder track. The
content of the original take folder remains intact.
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Move takes and comps in Logic Pro
You can move an active take or comp from a take folder to a new track, which removes the
take or comp from the original take folder.

Move an active take to a new track

1. In the Logic Pro Tracks area, choose the take you want to move from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Move active Take to New Track from the Take Folder pop-up menu.
The active take is moved to a new track, which is created below the take folder track. This
take is no longer available in the original take folder.
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Move an active comp to a new track

1. In the Logic Pro Tracks area, choose the comp you want to move from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Move active Comp to New Track from the Take Folder pop-up menu.
The active comp is moved to a new track, which is created below the take folder track. This
comp is no longer available in the original take folder.
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Flatten and merge take folders in Logic Pro
You can flatten a take folder, which replaces the take folder with multiple regions that
represent the current comp selections. All take region sections not used in the current
comp are deleted.
You can also flatten a take folder and merge the results. The take folder is replaced with a
single region that represents the current comp selections. All take region sections not used
in the current comp are deleted.

Flatten a take folder

1. In the Logic Pro Tracks area, choose the comp you want to keep from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Flatten from the Take Folder pop-up menu.
The take folder is replaced with multiple regions that represent the current comp
selections.
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Flatten a take folder and merge the results

1. In the Logic Pro Tracks area, choose the comp you want to keep from the Take Folder
pop-up menu in the upper-left corner of the take folder.

2. Choose Flatten and Merge from the Take Folder pop-up menu.
The take folder is replaced with multiple regions that represent the current comp
selections. The new regions are then merged to create a new audio file in the Tracks area.

Unpack take folders in Logic Pro
You can unpack take folders using the original channel strip for all new tracks, or you
can unpack take folders using different channel strips for each new track. Both methods
replace the selected take folder—or take folders—with new audio tracks for each take and
each comp. You can also unpack take folders to new track alternatives, which keeps all the
takes on the same track, but as separate track alternatives. The first audio track or track
alternative reflects the active comp, followed by the takes and remaining comps in the
order they appear in the take folder’s pop-up menu.

Unpack a take folder

In the Logic Pro Tracks area, do one of the following:
•
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Control-click the take folder header area, then choose Folder > Unpack Folder to
Existing Tracks from the shortcut menu.
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•

Choose Unpack from the Take Folder pop-up menu in the upper-left corner of the take
folder.

The latter option affects only the selected take folder, not all selected take folders.
These commands use the original channel strip for all new tracks. All takes and comps,
with the exception of the currently active comp, are muted. This ensures that the playback
result remains unchanged. Any edits made to one of these tracks are reflected in all others.
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Unpack a take folder to new tracks

In the Logic Pro Tracks area, do one of the following:
•

Control-click the take folder header area, then choose Folder > Unpack Take Folder to
New Tracks from the shortcut menu.

•

Choose Unpack to New Tracks from the Take Folder pop-up menu in the upper-left
corner of the take folder.

The latter option affects only the selected take folder, not all selected take folders.
These commands use different channel strips for each new track, but automatically assigns
the original channel strip setting to all of them. None of the takes or comps is muted. Edits
can be made to each of the tracks independently.
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Unpack a take folder to new track alternatives

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can show and use track alternatives.

•

In the Logic Pro Tracks area, choose Unpack to New Track Alternatives from the Take
Folder pop-up menu in the upper-left corner of the take folder.

All the takes from the folder can be accessed as separate alternatives from the take
alternatives menu on the track header.

Note: In order to access take alternatives, you must have enabled track alternatives in the
track headers. For more information, see Use track alternatives.
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Pack regions into take folders in Logic Pro
You can select multiple regions and pack them all into a single take folder. Each region
appears as an individual take in the resulting take folder.
Note the following when packing regions into a take folder:
•

If the selected regions are located on different tracks, the newly created take folder
is placed on the topmost track. This may change the playback result, because the
take folder uses a single channel strip, whereas previously the tracks may have used
different channel strips.

•

If the selected regions are placed one after the other on a single track, the newly
created take folder defaults to one automatically created comp.

•

If only one region is packed into a take folder, it is selected as the take and no comp is
created.

Pack selected regions into a take folder
•
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In the Logic Pro Tracks area, Control-click the selected regions, then choose Folder >
Pack Take Folder from the shortcut menu.
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Use loops and other media files

Using loops and other media in Logic Pro

Logic Pro comes with a large collection of prerecorded loops, offering a great starting
point for many of your projects. You can start composing a song by dragging Apple Loops
from the Loop Browser to the Tracks area. Combining existing loops and other media files
provides a quick method for laying down project foundations.
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The Project Audio Browser and All Files Browser are available when Enable Complete
Features is selected in Logic Pro > Preferences > Advanced:
•

Project Audio Browser: Use to add and remove audio files.

•

All Files Browser: Use to import files, search for files using advanced search criteria,
and import data and settings from other projects.

Use Apple Loops in your projects
Apple Loops in Logic Pro

Apple Loops are prerecorded musical phrases or riffs in the Loop Browser that you can
use to easily add drum beats, rhythm parts, and other sounds to a project. These loops
contain musical patterns that can be repeated over and over, and can be extended to fill
any amount of time.
When you add an Apple Loop to a project, a region is created for the loop. When the
project plays, the region plays at the project tempo and key. This lets you use several loops
together, even if the loops were recorded at different speeds and in different keys.
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Logic Pro has four types of Apple Loops:
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•

Audio loops (blue) are audio recordings. You can add them to audio tracks, and edit
them just like other audio regions in the Tracks area and Audio Track Editor.

•

Software instrument loops (green) can be edited just like other MIDI regions, including
editing individual notes, and can be viewed in the Piano Roll Editor and Score Editor. You
can change the sound of the instrument used to play the loop. You can add software
instrument loops to software instrument tracks and also convert them to audio loops by
adding them to audio tracks.

•

Drummer loops (yellow) contain all the performance information necessary, such as the
artist and parameter adjustments, to play a Drummer region. You can change the artist
and parameters in the Drummer Editor to change the sound of the loop. You can convert
them to software instrument loops by adding them to software instrument tracks, and
also convert them to audio loops by adding them to audio tracks.

•

Pattern loops (yellow) contain all the notes and pattern information from a pattern
created using the Step Sequencer. Pattern loops can be edited just like other regions
in the Tracks area, but the notes themselves can be edited only in the Step Sequencer.
You can add pattern loops to software instrument tracks and also convert them to audio
loops by adding them to audio tracks.
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Using the Loop Browser, you can find loops with the instrument, genre, and feel that are
right for your project, play loops, and add loops to your project. You can also create a
selection of your favorite loops, create your own loops, and customize the Loop Browser.

Search for Apple Loops in Logic Pro

The Loop Browser is where you find loops to add to your project. Using keywords, you can
search for loops by name, instrument, genre, and other descriptors. You can also refine
your searches.

Open the Loop Browser

In Logic Pro, do one of the following:
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•

Click the Loop Browser button

in the control bar.

•

Choose View > Show Apple Loops (or press O).
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Browse for loops

In the Logic Pro Loop Browser, do one of the following:
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•

Click the Button View button
to see the category buttons. Click the category
buttons to access the keyword buttons for that category. You can also Shift-click
multiple categories for more keyword buttons. Then click the keyword buttons to see
the matching files in the results list. If a keyword is dimmed, there are no loops that
match that category. Your current selection appears under the name of the category
button.

•

Click the Column View button
to see a standard column file directory that is
hierarchically separated into All, Favorites, Genres, Instruments, and Moods search
criteria. Select a keyword type in the left column, select a category in the middle
column, then select a keyword in the right column to see the matching files in the
results list below.
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•

Click Loop Pack at the top of the Loop Browser, then from the pop-up menu that
appears, choose the Loop Pack or folder with the loops you want to view.

Clear all keyword selections
•
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In the Logic Pro Loop Browser, click the Reset button.
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Search for loops by name
•

In the Logic Pro Loop Browser, enter a search term in the search field, then press
Return.

Any files that match your search term are displayed in the results list.

Filter searches by loop type

You can limit search results in the Apple Loops Browser to one or more of the four types of
Apple Loop.
1. In the Logic Pro Loop Browser, click the Loop Types button.
2. Select one or more loop types to limit the results in the Apple Loops Browser to just
those types, or select All Loops to view all loop types.
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View or clear recent search terms

In the Logic Pro Loop Browser, do one of the following:
•

To view a recent search term: Click the magnifying glass icon at the left side of the
search field, then choose a search term from the pop-up menu to display the results.

•

To clear a search term: Click the small “x” at the right side of the search field.

•

To clear all search terms: Click the magnifying glass icon at the left side of the search
field, then choose Clear Search History from the pop-up menu.

Play Apple Loops in Logic Pro

After searching for loops in the Loop Browser, you can listen to the results to find the loop
that sounds best in your project. When you listen to a loop, you can hear it by itself (solo),
or play it together with the project.

Play a loop

1. In the Logic Pro Loop Browser, select a loop in the search results list. You can either
click on a loop to select it, or if a loop is already selected, use the Up Arrow and Down
Arrow keys to select different loops.
The selected loop plays back in the project’s tempo and key.
2. Drag the Volume slider at the bottom of the Loop Browser to adjust the volume of the
loop you’re listening to.

3. Click the loop again to stop playing.
Note: You can also trigger and stop playback of the selected loop using the Preview key
command (default assignment: Option-Space bar). If you prefer, you can assign this
function to another key command. See Assign key commands in Logic Pro.
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Choose a key for loop playback

By default, loops play in the project key. You can choose another key for playback from the
Action pop-up menu .

To choose the playback key of the loop in Logic Pro, do one of the following:
•

To play back a loop in the project key: Choose Play in Song Key from the Action
pop-up menu.

•

To play back a loop in its original key: Choose Play in Original Key from the Action
pop-up menu.

•

To play back a loop in a specific key: Choose one of the available keys from the Action
pop-up menu.

Mirror the selected filter settings in the Logic Remote app

The Logic Remote app can mirror the filter settings you select in the Logic Pro Loop
Browser. You can also use the Logic Remote app on your iPhone or iPad to change those
filter settings in Logic Pro on your Mac.
•

In Logic Pro, choose Link Filter Settings to Logic Remote in the Action pop-up menu
of the Loop Browser.
When you link these settings across an iOS or iPadOS device and your Mac, changing
the filter settings in the Logic Pro Loop Browser causes those same settings to change
in Logic Remote, and vice versa.

To revert to Logic Remote showing all available loops regardless of the filter settings in
Logic Pro, deselect Link Filter Settings to Logic Remote.
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Turn on Auto Leveling for loops

By default, Logic Pro automatically adjusts the volume level of Apple Loops so they play
back at the optimum level when previewed in the Loop Browser or added to a project. This
ensures that the loop volume is neither too quiet nor so loud that it clips the output. This
adjustment is non-destructive, meaning the loop itself isn’t changed. For blue Apple Loops,
the region gain parameter in the Region inspector is adjusted; for green and yellow Apple
Loops, the track volume is adjusted.
If you prefer not have the volume of loops automatically adjusted, you can turn off
auto leveling:
•

In Logic Pro, deselect the Auto Leveling checkbox from the Action pop-up menu
the Loop Browser.

of

To turn auto-leveling back on, select the Auto Leveling checkbox.
Note: Any loops already placed in the Tracks area are not affected by the auto
leveling feature.

Access your favorite Apple Loops in Logic Pro

You can specify loops you use frequently as “favorites,” so you can quickly access them in
the Loop Browser. This feature is ideal for compiling a collection of Apple Loops that you
use regularly. The loops you choose can be replaced or added to easily as your project
advances, but the use of favorites may form a great starting point for many of your songs.

Specify and access your favorite loops

1. To specify a loop as a favorite in Logic Pro, select the checkbox for the loop in the
Favorites column
in the Loop Browser results list.

2. To access your favorites, click the Favorites button in Button view, or select Favorites in
Column view.

Logic Pro User Guide

296

Add Apple Loops to your projects in Logic Pro

After searching for loops in the Loop Browser and finding the ones you want to use, you
add them to your project. In the Tracks area, you can move, copy, and make other changes
to the loops.

Add a loop to your project

In Logic Pro, do one of the following:
•

Drag a loop to an empty area of the Tracks area, below the existing tracks.
A new track of the appropriate type (audio or software instrument) is created, and the
loop is added to the new track.

•

Drag an audio loop (blue) to an audio track.

•

Drag a software instrument loop (green) to a software instrument track.

•

Drag a software instrument loop (green) to an audio track to convert it to an audio loop.

•

Drag a pattern loop (yellow) to a software instrument track.

•

Drag a pattern loop (yellow) to an audio track to convert it to an audio loop.

•

Drag a drummer loop (yellow) to a Drummer track.

•

Drag a drummer loop (yellow) to a software instrument track to convert it to a software
instrument loop.

•

Drag a drummer loop (yellow) to an audio track to convert it to an audio loop.

Choose a different loop in the same family

Many Apple Loops are part of a loop “family.” Loops that are part of a family have the
same name, but each has a unique number at the end. For example, Classic Rock Guitar 01
and Classic Rock Guitar 02 belong to the same family. Loops in the same family work well
together. You can quickly try out different loops in the same family to see which one you
like best.
1. In Logic Pro, click the up and down arrows in the upper-left corner of the loop.
2. Choose a new loop from the pop-up menu.
The loop you chose replaces the original loop.
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Extend a loop so it repeats

With the loop selected in Logic Pro, do one of the following:
•

Drag the upper-right edge of the region for the desired number of repetitions.

•

Click the Loop button in the Region inspector (or use the Loop Regions key command).

To learn more about looping regions, see Loop regions.
New projects default to a project tempo of 120 bpm and a key of Cmajor. If the first content
added to a project is an Apple Loop (meaning, before any audio or MIDI have been added
or recorded to the project), the project tempo and key are adjusted to match the Apple
Loop. When a project already contains content (either by recording directly into the project
or adding content), Apple Loops automatically match the current project tempo and key.
If you subsequently change the project tempo, Apple Loops automatically conform to
the new tempo. If you change the project key, the regions created from the loops are
transposed to the new key.

Create your own Apple Loops in Logic Pro

You can create Apple Loops from your own audio and software instrument recordings.
When you create an Apple Loop from a region, it’s added to the loop library and appears in
the Loop Browser, so that you can use it in other projects.
You may also find that when you move loops from their location on your hard disk to
another folder or hard disk you need to reindex your Apple Loops library.

Create Apple Loops

1. In Logic Pro, select one or more audio or software instrument regions in the Tracks area.
2. Do one of the following:
•

Choose File > Export > Region/Cell to Loop Library.

•

Control-click the regions, then choose Export > Add to Loop Library from the
shortcut menu.

•

Drag the regions into the Loop Browser.

•

Press Control-Shift-O.

3. In the Add Region to Apple Loops Library dialog, select the text in the Name field and
enter a new name. If you are adding multiple regions to the loop library at once, the
Apple Loops retain the names of the original regions.
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If you want the loop you are creating to be part of an existing loop family, give your loop
the same name as the rest of the loop family and append the next consecutive number
to the end of the name. For example, if you have a loop family consisting of two Apple
Loops, Mod Beat 01 and Mod Beat 02, and you want to create your loop as part of that
loop family, name the new loop Mod Beat 03.

4. Select the Type of Apple Loops to create by clicking one of the two radio buttons:
Loop: These Apple Loops conform to project tempo, scale, and key. In order to ensure
that the loops conform properly, the region lengths must match a whole number of
beats. Choose Loop for loops of musical material.
One-shot: These Apple Loops ignore tempo, scale, and key information, and have a
fixed duration. Choose One-shot when creating Apple Loops of sound effects, dialog,
and other sounds that are not necessarily musical in nature.
Note: If your region lengths do not fall exactly on a beat, One-shot is the only option
available. If you want to create Apple Loops but the option isn’t available, check to make
sure your regions begin and end exactly on a beat, and if they don’t, adjust the length
of your regions accordingly.
5. Choose the scale type for the loops from the Scale pop-up menu. If you do not choose a
scale type, the scale type of the project is used.
6. Choose the musical genre for the loops from the Genre pop-up menu.
7. Choose the key for the loops from the Key pop-up menu. If the project has key changes
that affect the regions being exported, those key changes will be written into the Apple
Loops. If you do not choose a key, the project key is used.
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8. The Tempo field shows the tempo of the Apple Loops to be created. The tempo for the
loops is determined by the project tempo and includes any tempo changes that affect
the regions being exported. If you wish to change the tempo for the loops, click Cancel
and then change the project tempo at the desired position in the timeline.
9. Select an instrument category from the left column of the Instrument Descriptors list,
then select an instrument from the right column.
10. Click the mood buttons to the right of the Instrument Descriptors list that fit the loops
to add mood descriptors for easy searching. The mood buttons you click will be applied
to all the loops you are exporting.
11. When you’re finished, click Create.
The loops are added to the Loop Browser and to the loop index, and saved as User Loops
in the User Library. You can find your new loops by choosing My Loops in the Loop Packs
pop-up menu, using the keyword buttons or menus, or by entering text in the search field
at the bottom of the Loop Browser and pressing Return.

Reindex the Apple Loops library

In Logic Pro, click Loop Packs at the top of the Loop Browser, then choose Reindex All
Loops from the pop-up menu.

Customize the Loop Browser in Logic Pro

When thousands of loops are installed on your hard disks, finding a particular Apple Loop
can be a daunting prospect. Fortunately, you can use a number of key criteria—location,
scale, time signature—to restrict your search or browsing results. You can also sort the
search results.

Restrict loops by location
•

In Logic Pro, click Loop Packs at the top of the Loop Browser then, from the pop-up
menu that appears, choose the Jam Pack or folder with the loops you want to view.

If you have one or more Loop Packs installed on your computer, you can display only the
loops from a particular Loop Pack or only the loops included with GarageBand. If you have
Apple Loops from third-party manufacturers installed on your computer, you can choose to
display third-party loops only. If you have created your own Apple Loops, you can display
the loops for your user account or display loops shared by all users on your computer.

Restrict loops by scale
•
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Restrict loops by time signature
•

In the Logic Pro Loop Browser, choose a time signature from the Signature pop-up menu.

Restrict loops by loop type
•
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Sort Loop Browser results
•

In the Logic Pro Loop Browser, click any of the column headers to sort the results by
that column type, in ascending or descending order.

•

Name column: Sorts Apple Loops by name.

•

Beats column: Sorts Apple Loops by beats.

•

Favorites column: Sorts Apple Loops by Favorites checkbox selection.

•

Tempo column: Sorts Apple Loops by tempo.

•

Key column: Sorts Apple Loops by key.

You can swap column positions by dragging the column header left or right, and resize
column widths by dragging the vertical line that separates the column headers.

Logic Pro User Guide

302

Work with untagged loops in Logic Pro

Apple Loops contain tempo, key, and other descriptive details, known collectively as tags,
embedded in each loop. Some loops not made by Apple lack such embedded tags; these
are known as untagged loops. You can add these untagged loops and loop collections to
the Untagged Loops tab of the Loop Browser.
You can analyze untagged loops as a batch for tempo information, preview them at either
their original tempo or the project tempo, remove existing tempo information, and have
them play back at the project tempo. Because untagged loops do not contain all the
embedded information included in Apple Loops, they do not offer all the same features as
Apple Loops.
When you drag one or more loops into the Untagged Loops tab of the Loop Browser, the
loops are added to an Untagged Loops folder on your hard drive. You can also manually
drag loops and folders of loop libraries into this folder. Once added, untagged loops are
always available to any project using this folder.
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Add untagged loops to the Loop Browser
In Logic Pro, do one of the following:
•

Drag a loop or folder containing loops into the Loop Browser. A dialog appears, asking
whether you want to add the dragged loops into the Untagged Loops folder.

After you click Add to Untagged Loops a new folder named Untagged Loops is created
in the Audio Music Apps subfolder of the Music folder.
•

In the All Files Browser, right-click a folder and select Add to Untagged Loops Library
from the shortcut menu.
This adds a new alias for that folder to the Untagged Loops folder and keeps the loops
in their original locations.

•

In the Finder, copy a loop or folder containing loops to Music > Audio Music Apps >
Untagged Loops.

Once you have added untagged loops to the Loop Browser using one of these methods,
they are available in the Untagged Loops tab of the Loop Browser.
Note: The Untagged Loops tab appears in the Loop Browser only after you add at least
one loop or folder containing untagged loops into the Loop Browser. A manually created
Untagged Loops folder does not appear in the Loop Browser.

Preview untagged loops at the project tempo

1. In Logic Pro, right-click in the Untagged Loops tab of the Loop Browser and select
Preview > At Project Tempo from the shortcut menu.
2. Click the Play button at the bottom of the Loop Browser to play the loop.
3. Drag the Volume slider at the bottom of the Loop Browser to adjust the volume of the
loop you’re listening to.

Preview untagged loops at the original tempo

1. In Logic Pro, right-click in the Untagged Loops tab of the Loop Browser and select
Preview > At Original Tempo from the shortcut menu.
2. Click the Play button at the bottom of the Loop Browser to play the loop.
3. Drag the Volume slider at the bottom of the Loop Browser to adjust the volume of the
loop you’re listening to.
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Import and search for files
Import media files into Logic Pro

The All Files Browser is your first port of call for browsing and previewing media files. You
can use the All Files Browser to access all supported media files on the local hard disk,
home directory, or current project folder.
You can also use the File > Import > Other menu and key command to import
supported files.
The All Files Browser is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
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Import media files with the All Files Browser
1. Click the Browsers button
2. Click the List View button
use.

in the control bar, then click All Files (or press F).

or Column View button

to choose the view you want to

•

List view: Shows folders and files in a list, along with details such as name, creation
date, size, and type. Double-click a folder to show its contents.

•

Column view: Shows folders and contents in columns. Select a folder to show its
contents.

3. Locate the files you want to import by doing the following:
•

To change the visible contents: Click the Computer button
Project button .

, Home button

, or

The Computer button shows the contents of the local hard disk, optical drive, or
other storage media connected to your computer. The Home button shows the
contents of your home directory. The Project button shows the contents of the
current project folder.
•

To move through the folder hierarchy: Click the folders in the file path hierarchy, or
use the Back button or Forward button .

4. Drag the files you want to import into the Tracks area.
You can also search for files by name.

Import files using File > Import > Other

You can import various file types, such as AAF, supported MIDI, XML, and project files,
using import functions in the File menu.
1. In Logic Pro, select File > Import > Other (or use the key command).
2. In the Open File window, navigate to the file you wish to open.
3. Click Import.

Logic Pro User Guide

306

Search for media files in Logic Pro

You can use the All Files Browser to search for media files by name, as well as view or clear
recent search terms, or add search criteria that allows for a more advanced file search.
The All Files Browser is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.

Search for media files by name in the All Files Browser
1. In Logic Pro, click the Browsers button

in the control bar, then click All Files.

2. Enter a search term in the search field, then press Return.

3. Speed up your search by restricting it to a particular folder or volume.
•

To change the visible contents: Click the Computer button
Project button .

, Home button

, or

The Computer button shows the contents of the local hard disk, optical drive, or
other storage media connected to your computer. The Home button shows the
contents of your home directory. The Project button shows the contents of the
current project folder.
•

To move through the folder hierarchy: Click the folders in the file path hierarchy, or
use the Back button or Forward button .

4. To sort the search results, click any of the column headers.
5. Click the small “x” at the right side of the search field to clear the search term.
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View or clear recent search terms in the All Files Browser
In Logic Pro, do one of the following:
•

To view a recent search term: Click the magnifying glass icon at the left side of the
search field, then choose a search term from the pop-up menu to display the results.

•

To clear a search term: Click the small “x” at the right side of the search field.

•

To clear all search terms: Click the magnifying glass icon at the left side of the search
field, then choose Clear Search History from the pop-up menu.

Add or remove search conditions in the All Files Browser
In Logic Pro, do one of the following:
•

To add a search condition: Click the Add button (+) to the right of the search field. You
can add additional search conditions (up to ten) by clicking the Add button (+) to the
right of an existing condition row.

•

To remove a search condition: Click the Delete button (–) to the right of the condition
row.

•

To hide search conditions: Click the Delete button (–) to the right of the search field.
All condition rows are hidden. You can restore them by clicking the Add button (+) to
the right of the search field.
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Media file search conditions in Logic Pro

You can define up to ten advanced search conditions when searching for media files in the
All Files Browser.
The All Files Browser is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
The search conditions are as follows:
First pop-up menu

Second pop-up menu

Additional pop-up menus/fields

Comment

contains, does not contain, is, is
not, starts with, ends with

Input field

File Type

is, is not

Pop-up menu, in which you can
choose between Audio, Movie, and
Project

Format

is, is not

Pop-up menu, in which you can
choose between the following
options: AIFF, Apple Loops,
WAV (BWF), Apple Lossless, AAC,
MP3, CAF, Sound Designer I,
Sound Designer II, Logic Project,
MIDI File, AAF File, and XML File

Note that AIFF format searches do
not include Apple Loops.
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Length

is, is not, is less than, is greater
than

Input field

Modified Date

is, is not, after, before

Input field

Name

contains, does not contain, is, is
not, starts with, ends with

Input field

Sample Rate

is, is not, is less than, is greater
than

Pop-up menu, in which you can
choose between the following
options: 44.1 kHz, 48 kHz,
88.2 kHz, 96 kHz, 176.4 kHz, and
192 kHz

Size

is, is not, is less than, is greater
than

Input field

Bit Depth

is, is not, is less than, is greater
than

Pop-up menu, in which you can
choose between 8 Bit, 16 Bit, and
24 Bit

Pop-up menu in which you can
choose between seconds, minutes,
and hours

Pop-up menu in which you can
choose between bytes, kilobytes,
megabytes, gigabytes, and
terabytes
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Bookmarks in the Logic Pro All Files Browser

You can bookmark folders that you wish to quickly access in the All Files Browser. This is
useful if you have folders with files you like to drag into various projects, or if you have
files scattered around your drives but consolidated into specific folders. You can access
bookmarked folders by clicking the Bookmark button.

Bookmark a folder

1. In the Logic Pro All Files Browser, navigate to a folder.
2. Right-click the folder and select “Bookmark [folder name]” from the shortcut menu.

View your available bookmarks
•

In the Logic Pro All Files Browser, click the Bookmark button

.

Open a bookmark
•
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Remove a bookmark
•

In the Logic Pro All Files Browser, right-click a bookmark in the Bookmark list and select
“Bookmark [folder name]” from the shortcut menu.

Use the Project Audio Browser
The Project Audio Browser in Logic Pro

The Project Audio Browser shows all audio files and regions that have been added to or
recorded in your project, whether or not they are used in the Tracks area. Regions shown in
the Project Audio Browser that are not used in the Tracks area are indicated in red.
You can add, edit, delete, and rename audio files and regions in the Project Audio Browser.
You can add audio files to your project by dragging them from the Project Audio Browser
into the Tracks area, where you can edit, move, and copy them.
You can also open a separate Project Audio window.
The Project Audio Browser is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
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Open the Project Audio Browser

In Logic Pro, do one of the following:
•

Click the Browsers button

in the control bar, then click Project.

•

Choose View > Show Browsers (or press B), then click Project.

Open a separate Project Audio window
•

In Logic Pro, choose Window > Open Project Audio (or press Command-8).

Add and delete audio files in Logic Pro

When you add an audio file to your project, Logic Pro automatically creates a region that
encompasses the entire file length. You can create as many regions as you like from the
same audio file. There are no length limitations to regions, as long as they don’t exceed
the length of the source audio file. Creating multiple regions from the same audio file is
beneficial for many tasks—using different portions of a vocal take that spans the length of
the project, for example.
You can delete audio regions and audio files in the Project Audio Browser. In addition to
deleting unused audio files, you can also delete unused portions of audio files. This usually
frees up a lot of space on the hard disk.

Import an audio file into your project

1. In Logic Pro, select an audio track in the Tracks area.
2. Do one of the following:
•

Choose File > Import > Audio File.

•

Click the Import Audio button in the toolbar.

3. In the Open File dialog, select the audio file that you want to add.

4. Click the Play button to play the selected audio file.
The Play button becomes the Stop button. Click to stop playback.
5. Click the Open button to add the file to the selected track, at the playhead position, in
the Tracks area.
The audio file (and region) is automatically added to the Project Audio Browser.
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Import a Music Memos file

1. In Logic Pro, choose File > Import > Music Memos File.
2. In the Open File dialog, select the Music Memos file that you want to add.
A Music Memos file can be one of the three following types:
•

Audio file: An unchanged, uncompressed idea.

•

Mixdown: A stereo mix including backing tracks.

•

GarageBand project: An editable GarageBand project with separate tracks for the
idea and each backing instrument.

3. Do one of the following:
•

If the selected file is an audio file or a mixdown: click Import.

•

If the selected file is a GarageBand song: click Open.

When you import a Music Memos audio file or mixdown, the file is added to the selected
track at the playhead position. When you import a Music Memos GarageBand project, a
dialog asks if you want to save the current project, and the file opens as a new project.

Add an audio file to the Project Audio Browser

1. In Logic Pro, choose Audio File > Add Audio File from the Project Audio Browser
menu bar.
2. Browse to and select the audio file that you want to add in the Open File dialog.

3. Click the Play button to play the selected audio file.
The Play button becomes the Stop button. Click to stop playback.
4. Click the Add button, followed by the Done button.
The audio file (and region) is added to the Project Audio Browser.
5. Click the disclosure arrow to the left of the audio file to show the region.
The region is shown in red until it’s added to the Tracks area.
6. Do one of the following to add the region to the Tracks area:
•

Drag the file onto an existing audio track.

•

Drag the file into the empty workspace in the Tracks area.

The region overview turns blue.
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Create a region from an audio file in the Project Audio Browser
In Logic Pro, do one of the following:
•

Select an audio file in the Project Audio Browser, then choose Audio File > Add Region.

•

Select an audio file in the Project Audio Browser, choose Edit > Copy (or press
Command-C) in the main menu bar, then choose Edit > Paste (or press Command-V).

The new region appears below the existing regions in the list. Each region is assigned
a unique numerical appendix. For example, organ.pngf is the parent audio file. The
automatically created region is simply called organ, and newly created regions are called
organ.1, organ.2, and so on.

Delete a region from the Project Audio Browser
•

In Logic Pro, select one or more regions, then press Delete.

Delete an audio file from the project or hard disk
In Logic Pro, do one of the following:
•

To delete an audio file from the project: Select the audio file in the Project Audio
Browser, then press Delete.
The file is deleted from the project, but not from the hard disk.

•

To delete an audio file from the hard disk: Select the audio file in the Project Audio
Browser, then choose Audio File > Delete File(s).
The deleted file is moved to the Trash, where it remains until you empty the Trash.

Delete sections of audio files that are no longer used in the project
1. In Logic Pro, do one of the following:
•

Select the audio files that you want to optimize in the Project Audio Browser.

•

Choose Edit > Select Used.

2. Choose Audio File > Optimize File(s).
Logic Pro determines which (file) segments are not contained in any of the regions used in
the Tracks area. These segments are deleted, and the remaining portions of the audio file
are retained and aligned side-by-side in the file. The regions in the Project Audio Browser
are redefined and the project is automatically saved.
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Play audio regions in the Logic Pro Project Audio Browser

The playback modes outlined below only apply to regions in the Project Audio Browser
(when the window has key focus), and have no effect on project playback.

Play an entire region

1. In Logic Pro, select the region in the Project Audio Browser.
2. Control-click the Preview button
at the bottom of the Project Audio Browser, then
choose one of the following options from the shortcut menu:
•

Auto-select Channel Strip: The audio channel strip assigned to the selected track is
used for playback.

•

Preview Channel Strip: The Environment’s Preview channel strip is used for playback.
You can access the Preview channel strip in the Environment’s Mixer layer. It is
located to the right of the highest-numbered audio channel strip.

3. Click the Preview button

(or press the Space bar) to start and stop playback.

Play a region from a specific position

1. In the Logic Pro Project Audio Browser, click-hold the region’s waveform display.
Playback starts at the click point.
2. Release the mouse button to stop playback.

Sort, group, and rename audio files in Logic Pro

The Project Audio Browser lists all audio files in your project, along with information about
file sampling rate, bit depth, format (mono/stereo), and size. Within the Project Audio
Browser, you can sort, group, and rename your audio files.

Hide or show file information in the Project Audio Browser
•

In Logic Pro, choose View > Show File Info from the Project Audio Browser menu bar.

Sort audio files
•
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In the Logic Pro Project Audio Browser, sort audio files using the following options in the
View > Files menu:
•

None: Sorts the audio files in the order they were loaded or recorded.

•

Name: Sorts the audio files in alphabetical order.

•

Size: Sorts the audio files by size, with larger files at the top of the list.

•

Drive: Sorts the audio files by storage medium.

•

Bit Depth: Sorts the audio files by bit depth, in decreasing order.

•

File Type: Sorts the audio files by file type.
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Group audio files

In the Logic Pro Project Audio Browser, do one of the following:
•

Select the files you want to group, choose View > Create Group, enter a name in the
Name field, then press Enter.

•

Select the files you want to group, then choose one of the following from View > Group
Files by:
•

Location: Creates groups that are alphabetically sorted by the names of the parent
folders of selected files. Folder names are automatically used as group names.

•

File Attributes: Creates groups based on the attributes of selected files (file type,
stereo/mono, bit depth). Group names are displayed as a summary of the file
attributes—16 bit Mono AIFF, for example).

•

Selection in Tracks: Creates groups based on regions selected in the Tracks area.
Group names are based on the first of the selected regions.

Delete a group of audio files
•

In the Logic Pro Project Audio Browser, select a group, then choose View > Delete
Selected Groups (or press Delete).

The audio files of deleted groups reappear at the top of the list in the Project Audio Browser.

Rename audio files
•

In the Logic Pro Project Audio Browser, double-click a filename in the list, enter a new
name in the Name field, then press Return.

The audio file is renamed in all currently opened projects that use the file. Any backup files
on the same disk drive are also renamed.

Move, copy, and convert audio files in Logic Pro

You can move selected audio files to another location on your computer. This is useful
when you want to move all audio files used in a project to a new folder, for example.
You can also create copies of audio files on a different hard disk, or other storage medium.
The source files remain in their original location, unlike the behavior when you move files.
You can also create one or more independent audio files from selected regions in the
Project Audio Browser and Tracks area.

Move all used audio files to a new folder

1. In Logic Pro, choose Edit > Select Used from the Project Audio Browser menu bar.
All audio files that are used in the Tracks area are selected.
2. Choose Audio File > Move File(s).
3. Click the Move button.
4. In the dialog that appears, select a folder (or create a new one), then click Save.
All audio files used in the Tracks area are saved to the selected folder. The path
information for all open projects that use the audio files is also updated. This makes
projects easier to manage when moving audio files. After you move files to a new
location, save each open project to update all audio file storage references.
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Copy or convert audio files

1. In Logic Pro, select one or more audio files.
2. Choose Audio File > Copy/Convert File(s) from the Project Audio Browser menu bar.
3. Choose settings in the “Copy/convert file as” dialog.
You can set the sample rate, bit depth, file format, stereo conversion, and dither type
for the destination file.
4. Choose the target folder for the new audio files. You can also create a new folder, by
clicking the New Folder button.
5. If you’re only copying one file, you can enter a name for the new audio file. When
simultaneously copying several audio files, existing filenames are used for the copies
derived from them. The Hide Extension checkbox hides or shows file extensions (.wav,
.pngf, and so on) in the Save As field.
6. Select the “Change file reference in Project Audio” checkbox to replace the audio file
used in the project with the copied file.
If unselected, both the copy and original audio file are shown in the Project Audio Browser.
7. Click Save.

Convert selected regions into independent audio files
1. In Logic Pro, do one of the following:
•

Choose Audio File > Save Region(s) As from the Project Audio Browser menu bar.

•

Choose Edit > Convert > Audio Region to New Audio File from the Tracks area
menu bar.

•

Choose File > Export > Region as Audio File from the main menu bar.

2. Choose settings in the dialog that appears.
3. Choose the target folder for the new audio files. You can also create a new folder, by
clicking the New Folder button.
4. If you’re only saving one region, you can enter a name for the new audio file. The Hide
Extension checkbox hides or shows file extensions (.wav, .pngf, and so on) in the Save
As field.
5. Click Save.

Export and import audio region information in Logic Pro

The Project Audio Browser provides an overview of regions that are derived from individual
audio files. You can export this region information into the audio file, which you can
then choose to import if using the audio file in another project. If using an audio file with
saved region information in another project, you have the option of importing the region
information into the project.

Export region information to an audio file

1. In Logic Pro, select the audio file in the Project Audio Browser.
2. Choose Audio File > Export Region Information from the Project Audio Browser menu bar.
The current region information for that audio file in the Project Audio Browser is saved in
the audio file. Any existing region information is overwritten.
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Import region information from an audio file

1. In Logic Pro, add the audio file to another project.
2. Select the audio file in the Project Audio Browser.
3. Choose Audio File > Import Region Information from the Project Audio Browser menu
bar.
The saved region information for that audio file is displayed in the Project Audio Browser
and can be used in the current project.

Import compressed audio files into Logic Pro

You can use the Finder to import compressed audio files of the following file types into a
Logic Pro project:
•

AIFF

•

WAV

•

AAC

•

MP3

•

Apple Lossless

The compressed audio file is added to the Tracks area, and a region that encompasses
the complete audio file is created. Audio regions that point to compressed audio files are
denoted by the following symbol:

You can edit this region in the same way as a normal audio region in the Tracks area.
Audio files you import from the Finder do not change to match the tempo or key of your
project. You can write tempo changes into the audio files when Enable Complete Features
is selected in Logic Pro > Preferences > Advanced.

Import a compressed audio file
•

In Logic Pro, drag the audio file you want to import from the Finder into the empty
workspace area below the existing tracks.

A new audio track containing the audio region is created.

Convert a compressed audio file

In Logic Pro, do one of the following:
•

Select the audio region pointing to the audio file in the Tracks area, then choose Edit >
Convert > Audio Region to New Audio File from the Tracks area menu bar.
The part of the audio file spanned by the audio region is converted to a new audio file.

•
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Select the audio file in the Project Audio Browser, then choose Audio File > Copy/
Convert File(s) from the Project Audio Browser menu bar.
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Supported media and file formats
Media and file formats in Logic Pro

Logic Pro allows you to access any digitally stored audio recordings (audio files) on your
hard disk, in the most common Mac file formats, as well as several other formats.
Audio files imported into a Logic Pro project can be at any supported bit depth and sample
rate. Logic Pro supports bit depths of 16, 20, and 24 bits, and sample rates of 44.1, 48,
88.2, 96, 176.4, and 192 kHz. Logic Pro can use the file’s sample rate, or can perform a
real-time sample rate conversion.
In addition to audio files, Logic Pro can also import MIDI and project information.
The following list describes all file formats supported by Logic Pro:
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•

WAVE and AIFF Files: Wave (WAV) and Audio Interchange File Format (AIFF) audio files
are very similar. They can be stored at different bit depths (16 and 24 bit are supported
by Logic Pro), in mono, stereo, or surround, and at sample rates up to 192 kHz. Logic Pro
also supports Broadcast Wave files, which can contain timestamp information. Files that
provide timestamp information can be recognized by a clock symbol, shown alongside
the audio region name in the Project Audio Browser. The file extension of Broadcast Wave
files is .wav, allowing them to be read by any application that supports the standard wave
file format. In such programs, the additional Broadcast Wave file information is ignored.

•

Core Audio Format Files: Core Audio Format (CAF) files are containers that support
integer and float PCM formats, A-law, u-law, and a number of others including AAC and
the Apple Lossless Audio Codec (ALAC). Unrestricted file sizes are possible, at high
sample rates and bit depths.

•

Sound Designer Files: Sound Designer I and II (SDII) audio files are similar in structure to
AIFF files and can contain timestamped region information. Use of Sound Designer format
files can make transfers between Logic Pro and older Pro Tools sessions more convenient.

•

MP3, Apple Lossless, and AAC Files: MP3 and AAC files contain compressed audio
information. They are usually far smaller than equivalent WAV, AIFF, or SDII files. This
reduction in file size is due to different encoding techniques that “throw away” some
of the audio information. As a result, MP3 and AAC files do not sound as good as their
WAV, AIFF, or SDII audio counterparts, depending on the source audio material. Apple
Lossless files also contain compressed audio information. As the name suggests, the
compression used (ALAC) does not discard audio information in the same fashion as
MP3 files. The sound of the compressed audio file is identical to the original recording.

•

Apple Loops: Audio loops contain additional identification information: time and date,
category, mood, key, and tempo. They also contain a number of transient markers,
which break them down into small time slices. The main advantage of audio loops is
their ability to automatically match the tempo and key of a Logic Pro project. Software
instrument loops contain MIDI note information that triggers a musical phrase or riff.
The motif plays, as is, when these types of Apple Loops are added to an audio track.
When added to a software instrument track, the MIDI note information can be edited, as
you would with any MIDI region.

•

Standard MIDI Files: Standard MIDI files (SMF) are a standard file format used in MIDI
sequencers. They can be read and saved in Logic Pro. SMFs may contain note, lyric,
controller, and SysEx data. They are added to MIDI or software instrument tracks in
Logic Pro.
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GarageBand projects in Logic Pro

To use a GarageBand project in Logic Pro, update to the latest versions of both apps, then
open the project in Logic Pro. There’s no need to import or convert any files. The app
recognizes the project and translates it directly into Logic Pro. This works with projects
created with GarageBand for Mac, GarageBand for iPad, and GarageBand for iPhone.
•

Logic Pro automatically creates the required number and type of tracks to mirror those
used in the GarageBand project.

•

The Logic Pro project uses the tempo of the GarageBand project.

•

The initial key signature is set in accordance with the GarageBand project key.

•

Software instrument parts are played by their respective Logic Pro counterparts.
Logic Pro also imports any mixing data and effects (plus their settings) used by
software instruments or Apple Loops–based tracks in GarageBand.

•

GarageBand patches translate one-to-one into Logic Pro—with the added benefit that
you can now access the individual plug-ins that are inserted into a patch.

•

The two GarageBand bus effects (Reverb and Echo) are also translated when opened
in Logic Pro. They are replaced by the PlatinumVerb and Echo effects on busses 1 and 2.

Once the GarageBand project is loaded into Logic Pro, you can freely change parts, mixing
levels, and plug-in parameters as in any Logic Pro project. When you save the project, it is
saved as a Logic Pro project.
Note: You cannot open Logic Pro projects in GarageBand. However, you can share a
special version of your Logic Pro project that is compatible with GarageBand for iPad and
GarageBand for iPhone.

Open a GarageBand project in Logic Pro

1. In Logic Pro, choose File > Open (or press Command-O).
2. Browse to the location of the GarageBand project (by default, GarageBand saves
projects to ~/Music/GarageBand).
3. Select the project, then click Open.
4. In the Save dialog, choose a location for the new Logic Pro project, then click Save.
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Final Cut Pro XML files in Logic Pro

You can import and export audio data between Final Cut Pro and Logic Pro using the
Final Cut Pro XML format.
You can import and export Final Cut Pro XML files when Enable Complete Features is
selected in Logic Pro > Preferences > Advanced.

Import a Final Cut Pro XML file into Logic Pro
•

In Logic Pro, choose File > Import > Final Cut Pro XML, then choose the file in the
Import dialog.

If you import sequences that use audio files with different sample rates, you are given the
following options:
•

To alter the sample rate of your Logic Pro project to match all imported Final Cut Pro
sequence audio files.

•

To retain the sample rate of your Logic Pro project. All Final Cut Pro sequence audio
files that use a sample rate that differs from the selected one are converted.

When you import Final Cut Pro sequences into Logic Pro, volume and stereo pan
automation are retained.

Export a Logic Pro project as a Final Cut Pro XML file

1. In Logic Pro, choose File > Export > Project to Final Cut Pro XML.
2. In the Export Project to Final Cut Pro XML dialog, do the following:
•

Enter a name for the export file in the Save As field.

•

Select the Export as Final Cut Compound Clip checkbox if you want to export the
project as a compound clip.

•

Select the “Include video in export” checkbox if you want to include the movie (if one
exists) in the XML file.

3. Click Save.
Software instrument tracks are always bounced to audio files. MIDI tracks are not exported.
Bouncing automatically switches to real-time mode, if necessary (such as when an I/O or
External Instrument plug-in is used).
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Standard MIDI files in Logic Pro

Standard MIDI files are not specific to a particular sequencing program, hardware
sequencer, or type of computer. They contain the following information:
•

MIDI events, including time positions and channel assignments

•

Names of the individual tracks

•

Names and positions of markers

•

Tempo changes

•

Copyright marks

With Logic Pro, you can import, open, and export both format 0 and format 1 Standard
MIDI files:
•

Format 0 files contain all data in one track.

•

Format 1 files can contain multiple tracks, each with independent data.

Neither format recognizes any division of a track (into several MIDI regions, for example).

Import a MIDI file at the playhead position
In Logic Pro, do one of the following:
•

Choose File > Import > MIDI File, then select a file in the dialog that appears.

•

Locate and select the MIDI file in the All Files Browser, then click Import.

The MIDI file is placed at the playhead position, rounded to bars.

Import a MIDI file at the pointer position
•

In Logic Pro, drag a MIDI file from the All Files Browser or Finder into the Tracks area.

The pointer position—when the mouse button is released—determines the position
(rounded to the nearest bar) and destination of the first track in the imported file.

Open a MIDI file

1. In Logic Pro, choose File > Open (or use the corresponding key command), then select
a MIDI file in the dialog that appears.
2. If a project is loaded, a dialog asks if you want to create a new environment or copy the
current environment for the MIDI file. Do one of the following:
•

To replicate the existing environment: Click Copy. The tracks of the MIDI file are
automatically assigned to suitable instruments.

•

To load the environment of the default project template: Click New.

The MIDI file is loaded as a new project that contains all MIDI events—inclusive of time
positions and channel assignments, names of individual tracks, names and positions of
markers, tempo changes, and copyright marks. The copyright mark is read as marker text.
As a default behavior, Logic Pro automatically creates software instrument tracks for each
MIDI track, and assigns an appropriate GarageBand instrument to each, when you open a
MIDI file. If you want to use external MIDI tracks for each MIDI track, press Option while
opening the MIDI file.
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Prepare all MIDI regions for a Standard MIDI file export

1. In Logic Pro, select all MIDI regions by choosing Edit > Select All (or press
Command-A).
2. Normalize all playback parameters by Control-clicking a MIDI region, then choosing
Functions > MIDI region Parameters > Apply All Parameters Permanently from the
shortcut menu.
3. Convert all playback quantization by choosing Functions > MIDI Region Parameters >
Apply Quantization Permanently.
4. Convert all aliases into real copies by choosing Functions > Region Alias > Convert Alias
to a Copy.
5. Convert all MIDI regions on each track into a continuous MIDI region by choosing Edit >
Bounce and Join > Join per Tracks.
Note: Because Standard MIDI format 0 files can save only one MIDI region, you must
also merge (or join) all MIDI regions into one if you want to export in format 0. You can
do this by choosing Edit > Bounce and Join > Join.
6. Insert all instrument MIDI settings as events by choosing Functions > Insert Instrument
MIDI settings as Events.

Save MIDI regions as a Standard MIDI file

1. In Logic Pro, select all of the MIDI regions you want to save.
2. Choose File > Export > Selection as MIDI File.
3. Choose the destination directory, enter a name, then click Save. The selected MIDI
regions are saved as a format 1 MIDI file.
Note: Remember that most hardware sequencers can read only MS-DOS formatted disks,
so limit your filename to an 8.3 character name; for example, “proj0001.MID.”

Save a MIDI region as a Format 0 file

1. In Logic Pro, select the “‘Export MIDI File…’ saves single MIDI Regions as Format 0”
checkbox in the Logic Pro > Preferences > General > Project Handling pane.
2. Select a MIDI region, then choose File > Export > Selection as MIDI File.
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AAF files in Logic Pro

AAF (Advanced Authoring Format) is used by other DAW applications such as Pro Tools.
You can use it to import multiple audio tracks, inclusive of references to tracks, time
positions, and volume automation.
You can export and import AAF files when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.

Export the current project as an AAF file

1. In Logic Pro, choose File > Export > Project as AAF File.
2. In the Save AAF File As dialog, set the following options:
•

Sample Rate: Choose 44.1 kHz, 48 kHz, 88.2 kHz, or 96 kHz.

•

Bit Depth: Choose either 16 or 24 bit.

•

File Format: Choose WAVE or AIFF.

•

Dither Type: Choose None or any of the four dither algorithms (see About dithering
algorithms).

3. Choose a location, enter a name for the file, then click OK.
The export includes all used regions, inclusive of track and position references and volume
automation.

Import an AAF file

In Logic Pro, do one of the following:
•

Choose File > Import > AAF, then select a file in the dialog that appears.

•

Locate and select the AAF file in the All Files Browser, then click Open.

Open an AAF file

1. In Logic Pro, choose File > Open.
2. Choose the AAF file in the Open dialog.
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Arrange a project

Overview of arranging in Logic Pro

After adding audio, MIDI, and Drummer regions to your project (by recording, adding loops,
using Drummer, or adding media files), you build the project by arranging the regions in the
Tracks area. As you work in the Tracks area, you can play the project at any time to hear
your latest changes.
In the Tracks area, you can do any of the following:
•

Arrange regions in a variety of ways

•

Create and edit fades, and create automatic crossfades on audio regions

•

Remove silent passages from audio files

•

Use folders to manage groups of tracks as a single unit

•

Use groove templates to apply the rhythmic feel of a region to other audio or MIDI
regions

•

Edit region parameters in the Region inspector to control the sound of both audio and
MIDI regions

You can also add arrangement markers to a project, and use them to organize the project
into sections. For information about using arrangement markers, see Add arrangement
markers and Edit arrangement markers.
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Work in the Tracks area
Logic Pro Tracks area overview

The Tracks area is where you arrange regions to build your project. The Tracks area,
located in the center of the Logic Pro main window, shows a visual representation of time
moving from left to right. You build your project by arranging regions in rows, called tracks,
that run from the beginning to the end of the Tracks area.
At the top of the Tracks area, the ruler shows units of time in either musical format (bars
and beats) or standard time format (minutes and seconds). You can position regions and
other items in the Tracks area with the units on the ruler; snap regions and other items
to the grid to precisely align them with bars, beats, or other (time) divisions; and use
alignment guides to align them with other items in the Tracks area. You can control the
result of overlapping regions and other edits using drag modes.

The playhead extends from the top to the bottom of the Tracks area, and moves as the
project plays, showing the point currently playing in the project. At the top of the playhead
is a triangle that you can drag to move the playhead to a different part of the project, or
scrub the regions in the Tracks area.
You can also scroll to see another part of the project, and zoom in for precise editing or
zoom out to see more of the project.
When you open Logic Pro, the Tracks area appears in the main window. You can also open
the Tracks area as a separate window.
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Position items using the ruler in Logic Pro

The ruler runs horizontally across the top of the Tracks area. For projects set to use the
musical grid, the ruler shows the time format in bars and beats; for projects that don’t use
the musical grid, the ruler shows the standard time format of minutes and seconds.

As the project plays, you can see the part currently playing by watching the playhead move
across the Tracks area. When you move the playhead or move regions or other items in
the Tracks area, you can use the ruler to place them at the correct point in time. Alignment
guides appear when you move regions and other items to help you align them with other
items in the Tracks area.
When Smart Snap is chosen from the Snap pop-up menu, the units shown in the ruler
reflect the value set in the Tracks area grid. For details about snapping items to the grid,
see Snap items to the grid.
To set a project to use the musical grid, go to File > Project Settings > General. You
can also show a secondary ruler that displays the alternative time format by choosing
Secondary Ruler from the Tracks area View menu. For more details about setting the
project to use the musical grid, see General settings.

Use alignment guides in Logic Pro

Alignment guides appear when the edges of a region you are moving align with another
region in the timeline and when automation points you are moving align with other items in
the timeline. Alignment guides briefly appear as the edge of the region or automation point
aligns with other items in the timeline.
You can turn alignment guides on or off in the Snap pop-up menu.

Turn alignment guides on or off
•

In Logic Pro, choose Snap > Alignment Guides in the Tracks area menu bar.

Snap items to the grid in Logic Pro

The Tracks area includes a grid that helps you align regions, automation points, and other
items with the time divisions in the ruler. When you perform any of the following actions,
the items move according to the current Snap value:
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•

Moving and resizing regions

•

Moving the playhead

•

Adjusting the cycle region

•

Dragging loops to the Tracks area

•

Moving automation points in automation curves
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When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
the Snap pop-up menu is available in the Tracks area and in time-based editors, such as
the Piano Roll Editor and Audio Track Editor. Using the Snap pop-up menu, you can set the
Snap value and perform other functions.
By default, the Snap function is relative. When you move or edit an item, it retains the same
relative distance from its original grid position. For example, if a region is placed at position
1.2.1.16, and you move the region two beats forward (with the Snap value set to Bar), the
region snaps to position 2.2.1.16, not 2.1.1.1 (or 2.2.1.1). You can move items so that they align
with the nearest grid value by choosing Snap to Absolute Value from the Snap pop-up menu.
You can show the grid in the Tracks area, to help you visualize the positions of items in the
Tracks area relative to the Snap value.

Set the Snap value for the Tracks area
•

In Logic Pro, choose a value from the Snap pop-up menu in the Tracks area menu bar:

•

Smart: Edit operations snap to the nearest bar, beat, sub-beat, and so on, depending
on the current ruler division value and the zoom level.

•

Bar: Edit operations snap to the nearest bar.

•

Beat: Edit operations snap to the nearest beat in a bar.

•

Division: Edit operations snap to the nearest division value. (This is the time
signature shown in the LCD and the ruler.)

•

Ticks: Edit operations snap to the nearest clock tick (1/3840 of a beat).

•

Frames: Edit operations snap to the nearest SMPTE frame.

•

Quarter Frames: Edit operations snap to the nearest SMPTE quarter frame.

•

Samples: Edit operations snap to the nearest sample.

•

Off: To turn off Snap To Grid, do one of the following:
•

Click the On/Off button on the left side of the Snap pop-up menu.

•

Choose the “Snap to Grid” menu item when it is checked.

Note: You can make sample-accurate edits only at a high zoom level. Use the Zoom slider
to zoom in, and take advantage of the Save and Recall Zoom Setting key commands to
speed up your workflow.
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Show the grid in the Tracks area
•

In Logic Pro, choose View > Grid Lines from the Tracks area menu bar.

Snap to an absolute position
•

In Logic Pro, choose Snap > Snap Regions to Absolute Value from the Tracks area menu
bar.
A checkmark appears to the left of this option when it’s active. This feature works in
conjunction with the chosen snap grid division. For example, if the Snap value is set
to Bar, and Snap Regions to Absolute Value is active, moving a region (from position
1.2.1.16) two bars forward results in the region being snapped to position 2.2.1.1 rather
than its relative position (2.2.1.16).
To return the Snap function to relative values, choose Snap > Snap Regions to Relative
Value from the Tracks area menu bar.

Override the Tracks area grid

In Logic Pro, do one of the following:
•

•

Select the region (or other item), then press and hold Control while dragging the item in
the Tracks area:
•

The division value you choose in the control bar (1/16, for example) determines the
editing grid scale at lower zoom levels (wider view).

•

At higher zoom levels, (close-up view), the editing grid scales by a certain factor
relative to the division value.

Select the region (or other item), then press and hold Control and Shift while dragging
the item in the Tracks area:
•

The editing grid switches to ticks if editing at lower zoom levels (wider view).

•

At higher zoom levels (close-up view), the editing grid switches to samples.

When the Tracks area is zoomed out so that the current Snap value would result in
extremely large movements or edits, the Snap pop-up menu is temporarily dimmed, and
Smart snap is used instead.
When the Tracks area is zoomed in very far, and a smaller Snap value (such as Division or
Frames) is chosen, normal mouse movements move items by larger grid units. To use the
chosen Snap value, either zoom out or press and hold Control while moving items.
Using Control-Shift breaks the 1:1 relationship between the pointer and region (or Edit tool)
movements. This means that you may need to move the pointer a long way (horizontally)
to make the region (or Edit tool) move one pixel. Watch the help tag for an exact numerical
indication.
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Automatically zoom the Tracks area in Logic Pro

You can set the Tracks area to automatically zoom vertically or horitontally to fill the
available space. When Vertical Auto Zoom is on, the Tracks area resizes when you add,
duplicate, or delete tracks so that all Tracks are visible, with no blank space.

Turn on Vertical Auto Zoom for the Tracks area
•

In Logic Pro, click the Vertical Auto Zoom button in the Tracks area menu bar.

When turned on, the button is blue.
To turn off automatic vertical zoom, click the button again.

Turn on Horizontal Auto Zoom for the Tracks area
•

In Logic Pro, click the Horizontal Auto Zoom button in the Tracks area menu bar.

When turned on, the button is blue.
To turn off automatic horizontal zoom, click the button again.
For information about zooming the Tracks area and other windows in Logic Pro, see
Zoom windows.
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Quantize regions in Logic Pro

Quantizing involves the rhythmic correction of audio or MIDI regions to a specific time grid.
Any notes not played in time are moved to the nearest position on the grid.
You can quantize regions in the Tracks area by using the Quantize parameter in the Region
inspector. Several advanced quantization parameters are also available in the Region
inspector for greater control over quantization.
Before you quantize audio regions on an audio track, you must assign a flex mode to the
audio track, and select the Flex parameter in the Region inspector for that region. For
details, see Flex Time algorithms and parameters.
The Quantize parameter in the Region inspector applies to whole regions. If you want
different parts of a region to have different Quantize values, you can split the region,
apply different quantize settings to different segments, and then join them using the Join
command or the Glue tool.

Quantize selected regions
•

In Logic Pro, choose a value from the Quantize pop-up menu in the Region inspector.

You can also step through the available Quantize values, one at a time, with the Set
Quantize Parameter to Next Value and Set Quantize Parameter to Previous Value
key commands.
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When you quantize audio regions, white lines called quantize flex markers appear over the
selected audio regions, to indicate where audio has been time-stretched during the time
quantization process.

The quantization grid for a MIDI region always begins at the start of the region. If the MIDI
region is not aligned with the beginning of a bar, neither is the quantization grid.
Important: For MIDI regions, the chosen Quantize value affects the way notes are
displayed in the MIDI editors. So, for example, you can see the effect of the chosen
Quantize value by looking at the note positions in the Piano Roll Editor.

For detailed information about Quantize values and advanced Quantize parameters, see
Quantize parameter values and Advanced quantization parameters.
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Use drag modes in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Drag pop-up menu is available in the Tracks area and in time-based editors (such as the
Audio Track Editor and Piano Roll Editor). Using drag modes, you can control the results of
moving, resizing, or deleting regions in the Tracks area.

Set the drag mode for the Tracks area
•

In Logic Pro, choose one of the following modes from the Drag pop-up menu in the
Tracks area menu bar:

•

Overlap: Preserves the current region borders when you drag one region over
another.

•

No Overlap: When two regions overlap, the overlapped area of the left (earlier)
region is shortened.

•

X-Fade: When two audio regions overlap, the overlapped area is crossfaded.

•

Shuffle R: Aligns regions when you move, resize, or delete them, in the following
ways:

•

•

Move: Moving a region to the right aligns the end point of the region with the
start point of the region that follows, so there is no space (gap) between them.

•

Resize: When you resize the left edge of a region, the preceding regions move
by the change in length. If this causes preceding regions to move past the
start of the project, the resized region then overlaps the preceding ones by the
corresponding amount.

•

Delete: The remaining regions on the track move by the length of the deleted
region.

Shuffle L: Aligns regions when you move, resize, or delete them, in the following
ways:
•

Move: Moving a region to the left aligns the start point of the region with the end
point of the preceding region, so there is no space (gap) between them.

•

Resize: When you resize the right edge of a region, the regions that follow move
by the change in length.

•

Delete: The remaining regions on the track move by the length of the deleted
region.

For both Shuffle R and Shuffle L, when you drag one region over another, the regions
switch positions.
Only one audio region at a time can be played on each track. When two audio regions on
the same track overlap, only the later (right) region is heard.
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Scrub a project in Logic Pro

You can scrub a project to locate or listen to a sound at a particular point in time. When
you scrub a project, you quickly audition it by moving the playhead across the Tracks
area. The speed at which you move the playhead controls the playback speed. Scrubbing
makes it easy to zero in on a particular drum beat or other audio event before cutting or
editing a region.
Scrubbing always applies to MIDI regions in the Tracks area. When the Scrubbing with
audio in Tracks area preference is active, audio regions are also scrubbed. Muted tracks
and regions are not scrubbed, so you can control which tracks and regions you hear by
muting or soloing them. For information about Scrubbing with audio in Tracks area, see
Audio Editing preferences.

Scrub the project

1. In Logic Pro, zoom in or out as needed to view the section you want to scrub.
2. Click the Pause button

in the control bar.

3. Grab the playhead in the Tracks area or the ruler, and move it back and forth through
the parts of the project you want to hear, at the speed you want to scrub the section (or
use the Scrub Rewind and Scrub Forward key commands).
Note: If the Pause button is not visible in the control bar, you can show it by customizing
the control bar.

Scrub specific audio regions
•

In Logic Pro, select the audio regions, then scrub the project.
Only the selected audio regions are heard. All unmuted MIDI regions are also heard.

Turn on scrubbing for MIDI regions
•

In Logic Pro, choose File > Preferences > Audio > Editing > Scrubbing with audio in
Tracks.

Scrub using a MIDI controller
•

In Logic Pro, assign any MIDI controller number to the “Scrub by MIDI value (-2-)”
function.
With this assignment, data bytes over 64 scrub forward, and those under 64 scrub
backward. For more information, see the Logic Pro Control Surfaces Support Guide.

You can also scrub via an external MIDI control (such as a control surface or keyboard
controller) using the “Scrub by MIDI value (-2-)” function (available in the Controller
Assignments window; see the Logic Pro Control Surfaces Support Guide). You can assign
any MIDI controller number to this function. Data bytes over 64 scrub forward, and those
under 64 scrub backward.
Note: Scrubbing is automatically made active when you split regions with the Scissors tool
in the Tracks area, making it easier to identify the cut position.

Logic Pro User Guide

334

Scroll and zoom in the Tracks area in Logic Pro

Depending on the size of the project and your display, you may not be able to see the
entire project at one time. You can scroll both horizontally and vertically in the Tracks area
to view other parts of the project.
You can zoom in to make precise edits and see more detail in the Tracks area, or zoom out
to view more of your project. You can also zoom the amplitude of the waveforms in audio
regions in the Tracks area.
If your device has a Touch Bar, you can use the Touch Bar to scroll in the Tracks area.

Scroll in the Tracks area
•

To scroll horizontally in Logic Pro, drag the horizontal scroll bar in the Tracks area menu
bar. Drag left to scroll to an earlier part of the project, or drag right to scroll to a later
part of the project.

•

If a project has more tracks than are currently visible in the Tracks area, a vertical scroll
bar appears along the right edge of the Tracks area. Drag the scroll bar up or down to
see the other tracks.

Scroll in the Tracks area using the Touch Bar

If your computer has a Touch Bar, you can use the Touch Bar to scroll in the Tracks area.
1. In Logic Pro, tap the Mode button on the left side of the Touch Bar, then tap the Tracks
area button
.
2. Swipe left or right on the Touch Bar to scroll through the visible area of the project.

Zoom in the Tracks area
•

In Logic Pro, drag the Horizontal Zoom and Vertical Zoom sliders in the Tracks area
menu bar. Drag the Horizontal Zoom slider left to zoom out for a wider view, or drag it
right to zoom in for a close-up view. Drag the Vertical Zoom slider up for a wider view
(more tracks), or drag it down for a close-up view (fewer tracks).
If the Tracks area grid value is set to Automatic, the units shown on the ruler change
when you zoom in or out.

Zoom audio waveforms
•

In Logic Pro, click and hold the Waveform Zoom button in the Tracks area menu bar,
then drag the slider vertically to zoom in or out.

You can speed up your workflow by using the Save and Recall Zoom Setting key
commands. If your computer has a trackpad that supports gestures, you can also scroll
and zoom in the Tracks area using gestures.
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Customize the toolbar in Logic Pro

The toolbar offers a variety of buttons and other controls for working with regions in the
Tracks area, as well as other functions. The default set of buttons provides the most
commonly used options for most users. If you find that you need to access particular
functions that are not part of the default set, you can customize the toolbar by adding
additional controls, or removing existing controls.

Change the controls on the toolbar

1. In Logic Pro, Control-click the toolbar, then choose Customize Toolbar from the shortcut
menu.
2. Add or remove individual controls by selecting their checkboxes in the Customize
dialog.
3. Choose the appropriate option, as follows:
•

Click Cancel to keep the previously saved toolbar layout.

•

Click OK to activate the new control layout.

•

Click Save As Default to save your current layout as the default, which is then
applied whenever you create an empty new project, open a new main window, or
click the Restore Defaults button.

•

Click Restore Defaults to return to the default layout.

Arrange regions in the Tracks area
Logic Pro regions overview

Regions are the building blocks of a project. When you record an instrument, drag an
Apple Loop to the Tracks area, or add a media file, a region containing the music from
the recording, loop, or media file is created. Regions appear as rounded rectangles in the
Tracks area.
You can arrange and edit the following types of regions in the Tracks area:
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•

Audio regions from audio recordings, audio Apple Loops, and imported audio files on
audio tracks

•

MIDI regions from software instrument (and external MIDI instrument) recordings,
software instrument Apple Loops, and imported MIDI files on software instrument tracks
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•

Drummer regions generated on Drummer tracks or from Drummer Apple Loops

You can edit regions in the Tracks area in several ways. For example, you can:
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•

Select regions

•

Cut, copy, and paste regions

•

Move regions to another track or to another point in the Tracks area

•

Loop regions

•

Shift the playback position of regions to create subtle changes in the rhythmic feel

•

Resize regions to change how long they play

•

Time stretch regions to change the relative distance between notes and other events

•

Split and join regions

•

Demix MIDI regions

•

Create aliases of MIDI regions

•

Change the color of regions

•

Convert audio regions to samples for a sampler instrument

•

Delete regions

•

Edit region parameters in the Region inspector
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Select regions in the Tracks area in Logic Pro

To perform some edits on regions, you must first select the regions. You can select one
or multiple regions, select regions on different tracks, and quickly select muted regions,
overlapped regions, or regions meeting other criteria. Once selected, regions appear
highlighted in the Tracks area.

Select a region
•

In Logic Pro, click the region in the Tracks area.

Select multiple regions

In Logic Pro, do one of the following:
•

Press and hold Shift as you click the regions in the Tracks area.

•

Drag around the regions to enclose them.

Select all regions in a track

In Logic Pro, click the track header.

Select all regions in a project

In Logic Pro, choose Edit > Select > All from the Tracks area menu bar.

Select regions meeting specific criteria

In Logic Pro, choose any of the following from the Tracks area Edit menu:
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•

To select all following regions in the project: Choose Select All Following.

•

To select all following regions on the same track: Choose Select All Following of Same
Track.

•

To select all regions between the left and right locators: Choose Select Inside Locators.

•

To select all empty regions in the project: Choose Select Empty Regions.

•

To select all overlapped regions: Choose Select Overlapped Regions.

•

To select all muted regions in the project: Choose Select Muted Regions.

•

To select all regions of the same color: Choose Select Same-Colored Regions.
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Select parts of regions in Logic Pro

You can select and edit parts of one or more regions, using the Marquee tool or the
marquee stripe:
•

Marquee tool: Use to select and edit region parts by dragging across them. The
Marquee tool looks like a crosshair.

•

Marquee stripe: A thin stripe shown at the top of the ruler.

Only the part of the region inside the marquee is selected, letting you select inside, or
across portions of, regions. You can perform most edits, such as moving, cutting, copying,
and deleting, in the selected area. After editing, the selected area becomes a new,
separate region. The marquee selection uses the current Tracks area Snap value.
If you play a project after making a marquee selection, playback starts at the left edge
of the selection, and ends at the right edge. If you create a marquee selection while the
project is playing, playback continues past the end of the selection.
If you start recording after making a marquee selection, Autopunch mode is activated, and
the marquee selection is replaced by the punch locators. All tracks within the marquee
selection are record-enabled, and all other tracks are record-disabled.

Select parts of regions using the Marquee tool

In Logic Pro, select the Marquee tool, then drag in the Tracks area to select parts of one or
more regions.
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Select parts of regions using the marquee stripe

1. In Logic Pro, choose View > Marquee Ruler from the Tracks area menu bar.
2. Drag in the thin marquee stripe area of the ruler to select parts of one or more regions
(also shown on selected tracks).

Remove individual tracks from the selection

In Logic Pro, Shift-click the track header of each track you want to remove.

Change the selection start or end point
In Logic Pro, do one of the following:
Using the Marquee tool:
•

Press and hold Shift, then click in the Tracks area to change the selection in any
direction.

•

Shift-click inside a selection to move the selection end closest to the pointer.

•

Option-Shift-click inside a selection to move the selection end farther from the
pointer.

Using any marquee selection:
•

Press and hold Shift while using the Left Arrow key or Right Arrow key to move the
marquee start point.
You can also use the Toggle Previous Region/Cell/Event or Move Marquee Start to
Previous Transient key commands, depending on the type of region selected.

•

Use the Left Arrow key or Right Arrow key to change the selection end points.
You can also use the Select Previous Region/Cell/Event or Move Marquee End to
Previous Transient key commands, depending on the type of region selected.

You can access Logic Pro key commands in the Key Commands window.

Move the entire selection

In Logic Pro, do one of the following:
•

Press Shift-Home (the default assignment for the Select First, or Shift Marquee
Selection Left key command).

•

Press Shift-End (the default assignment for the Select Last, or Shift Marquee Selection
Right key command).

Snap to the finest possible resolution in the current snap mode
•

In Logic Pro, press and hold Control and Shift while you make the selection.

This action snaps the selection to ticks or samples when editing MIDI or audio regions,
depending on the current zoom level. See Snap items to the grid.

Snap to the division value shown in the LCD
•

In Logic Pro, press and hold Control while you make the selection.

This action snaps items to the current division value when editing MIDI or audio regions,
depending on the current zoom level. See Snap items to the grid.
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Set locators with a marquee selection
•

In Logic Pro, Control-click the marquee stripe, then choose Set Locators by Selection
and Enable Cycle from the shortcut menu.

This action sets the locators to the marquee selection boundaries, rather than the
whole region.

Split regions at the selection border
•

In Logic Pro, Control-click the marquee stripe, then choose Split Regions/Events at
Locators or Marquee Selection from the shortcut menu.

When you edit automation data that is spanned by a marquee selection, two automation
points are automatically created at the left edge, and two at the right edge, of the
selection. This lets you quickly define and create automation data by converting the
marquee selection into automation points.

Cut and paste regions in Logic Pro

You can cut or copy regions in the Tracks area, and paste them at a different position.
You can also paste a copied region at the same time position, to double the content of
the region to use on another track. You can quickly double a region or cut it in half at its
existing location.

Cut a region
•

In Logic Pro, select the region, then choose Edit > Cut (or press Command-X).

Copy a region

In Logic Pro, do one of the following:
•

Select the region in the Tracks area, then choose Edit > Copy (or press Command-C).

•

Option-drag the region.

When you copy an audio region, a new region is automatically created in the Project Audio
Browser. The new region retains the name of the original, followed by a sequential number.
For example, for a region named MyLoop, the first copy is MyLoop.1, the second copy is
MyLoop.2, and so on.

Paste the region
•

In Logic Pro, move the playhead to the point in the Tracks area where you want the
region to start, then choose Edit > Paste (or press Command-V).

Paste a region at the same position as the copied region
•

In Logic Pro, select the track you want to paste the region into, then choose Edit > Paste
at Original Position (or use the corresponding key command).

The copied region is pasted into the selected track, at the same position as the source
region. This is useful if you want to copy a region to the same spot on a different track,
to independently process or thicken the part, for example. This function is also ideal for
creating layered MIDI or instrument parts.
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Paste multiple copies of a region
1. In Logic Pro, select the region.

2. Choose Edit > Repeat Multiple from the Tracks area menu bar.
3. In the Repeat Regions dialog, do any of the following:
•

Enter the number of copies to paste in the Number of Copies field.

•

To have the copies snap to a particular grid value, choose a grid value from the
Adjustment pop-up menu.

•

To paste the copies as regions, click the As Copies radio button.

•

To paste the copies as clones (for audio regions) or aliases (for MIDI regions), click
the As Aliases or Clones radio button.

Cut a region in half

When you cut a region in half, the region is cut at its center and the right half is discarded,
leaving only the left half.
•

In Logic Pro, select the region, then choose Edit > Length > Halve.

Double a region

When you double a region, its length is doubled and the contents are repeated in the
right half.
•

In Logic Pro, select the region, then choose Edit > Length > Double.

Change the length of a region, cell, or event

You can change the length of a region, cell, or event by an exact amount.
1. In Logic Pro, select the region, then choose Edit > Length > Change.
2. Choose the amount to shorten or lengthen the region from the Length Factor pop-up
menu, then click OK.
The Length Factor pop-up menu includes a variety of set values, ranging from 0.25 to
16.

Move regions in Logic Pro

You can move regions to a different point in the same track, or move them to another track
of the same type. You can move an audio region to another audio track, for example, but
not to a software instrument track, or vice versa. You can also move regions between open
Tracks area windows, or between different open projects.
When you move a region, it snaps to the nearest position on the Tracks area grid, using
the current Snap value. You can override the grid by holding down Control while dragging
regions to move them in steps of one division, or by holding down both Control and Shift
while dragging to move them by single ticks or samples (depending on the zoom setting).
•
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You can nudge regions (move them in small increments) left or right using key
commands. To nudge regions, you first set the nudge value, then move selected regions
by this value. Alternatively, you can nudge regions by a set value.
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•

You can slip regions, which moves the content of the region left or right by the nudge
value without moving the boundaries of the region. The content effectively moves inside
the region, which remains stationary. Slipping a region is possible only when the source
content exceeds the length of the region by the amount you slip (or greater).

•

You can also rotate regions. Similar to slipping, rotating moves the region content left
or right by the nudge value, but with the difference that content that extends past the
region border on one side reappears on the other side, as though the region were a loop.
When an audio region is rotated, it is converted to a one-track folder (indicated by a
folder icon in the upper-left corner of the region) containing two regions. If it is rotated
multiple times, the number of regions in the one-track folder stays the same, but the
junction point between the two regions moves through the folder, reflecting the extent
of the cumulative rotation. You can unpack the one-track folder, or unpack and merge
it to a single region, by clicking the folder icon and choosing corresponding commands
from the menu that appears.

You can use slip and rotate to move the content of audio or MIDI regions. When you slip or
rotate a Drummer region, it is first converted to a MIDI region, then the content of the MIDI
region is slipped or rotated.
Tip: You can also move and resize regions numerically by opening an Event Float
window. See Use the Event Float window.

Move a region

In Logic Pro, do any of the following:
•

Drag a region left or right in the Tracks area to move it to a new point in the same track.

•

Drag an audio region up or down in the Tracks area to another audio track.

•

Drag a MIDI region up or down in the Tracks area to another software instrument track.

Move a region to the current playhead position
•

In Logic Pro, select the region, then use the Move Region/Event to Playhead Position
(Pickup Clock) key command.
If more than one region is selected, all subsequent regions are moved. For audio
regions, the region anchor is placed at the current playhead position. See Project Audio
Browser overview.

Move an audio region back to its recorded position
•

In Logic Pro, select the audio region, then choose Edit > Move > To Recorded Position.
This command only works for timestamped audio files, such as those recorded in the
current project, and imported Broadcast Wave or SDII files. Timestamped files are
indicated by a clock symbol in the Project Audio Browser.

Move regions to the selected track
•

In Logic Pro, select the regions, then choose Edit > Move > To Selected Track. The
regions are moved to the selected track, keeping their existing time positions.

Nudge regions by the nudge value

1. In Logic Pro, select the regions you want to move.
2. Press and hold Option and press the Left or Right Arrow key.
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Slip regions by the nudge value
•

In Logic Pro, select the regions, then do one of the following:
•

Choose Edit > Move > Slip Left (or use the corresponding key command: ControlOption-Left Arrow).

•

Choose Edit > Move > Slip Right (or use the corresponding key command: ControlOption-Right Arrow).

Rotate regions by the nudge value
•

In Logic Pro, select the regions, then do one of the following:
•

Choose Edit > Move > Rotate Left (or use the corresponding key command: ControlOption-Command-Left Arrow).

•

Choose Edit > Move > Rotate Right (or use the corresponding key command:
Control-Option-Command-Right Arrow).

Set the nudge value

In Logic Pro, use one of the following key commands:
•

Set Nudge Value to Tick

•

Set Nudge Value to Division

•

Set Nudge Value to Beat

•

Set Nudge Value to Bar

•

Set Nudge Value to SMPTE Frame

•

Set Nudge Value to 0.5 SMPTE Frame

•

Set Nudge Value to 5 SMPTE Frames

•

Set Nudge Value to Sample

•

Set Nudge Value to 1 ms

•

Set Nudge Value to 10 ms

You can access Logic Pro key commands in the Key Commands window.

Nudge regions by a set value

In Logic Pro, use one of the following key commands:
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•

Nudge Region/Event Position Right by SMPTE Frame

•

Nudge Region/Event Position Left by SMPTE Frame

•

Nudge Region/Event Position Right by 1/2 SMPTE Frame

•

Nudge Region/Event Position Left by 1/2 SMPTE Frame

•

Nudge Region/Event Position Right by 5 SMPTE Frames

•

Nudge Region/Event Position Left by 5 SMPTE Frames

•

Nudge Region/Event Position Right by SMPTE Bit

•

Nudge Region/Event Position Left by SMPTE Bit

•

Nudge Region/Event Position Right by Tick

•

Nudge Region/Event Position Left by Tick
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•

Nudge Region/Event Position Right by Division

•

Nudge Region/Event Position Left by Division

•

Nudge Region/Event Position Right by Beat

•

Nudge Region/Event Position Left by Beat

•

Nudge Region/Event Position Right by Bar

•

Nudge Region/Event Position Left by Bar

•

Nudge Region/Event Position Right by Nudge Value

•

Nudge Region/Event Position Left by Nudge Value

•

Nudge Region/Event Position Right by Sample

•

Nudge Region/Event Position Left by Sample

•

Nudge Region/Event Position Right by 1 ms

•

Nudge Region/Event Position Left by 1 ms

•

Nudge Region/Event Position Right by 10 ms

•

Nudge Region/Event Position Left by 10 ms

You can access Logic Pro key commands in the Key Commands window.
You can limit the movement of regions to either the horizontal or vertical axis by selecting
the Logic Pro > Preferences > General > Editing > Limit Dragging to One Direction In
Tracks checkbox. If you initially move a region left or right, movement is limited to the
horizontal axis. If you want to move a region from one track to another, release the mouse
button, reselect the region, then drag it up or down. While this preference is selected, you
can override it by pressing Shift when moving regions.

Add or remove gaps in Logic Pro

Sometimes you may want to remove an entire passage from a project—for example, you
may want to remove the regions of all tracks between bars 17 and 20, so that all regions
(and bar changes, tempo changes, and global score symbols) from bar 21 on are moved
four bars to the left, closing the gap left by removing the four bars.
Alternatively, you may want to insert some empty bars in the middle of a project, to create
space for another chorus, verse, or bridge, for example. As with the previous example, all
existing tempo changes and so on are moved accordingly (to the right by the number of
inserted bars).
You can limit changes to only selected regions. If you do this, rather than moving all
regions within a project section, you are asked if you want to move global events such
as bar changes, tempo changes, and score symbols. This global edit is performed on all
regions, when used.
Note: The toolbar features a number of section-editing buttons that can be used to
perform some of the operations described below. When these buttons are used, the
operation affects all regions that fall between the locators, regardless of which regions in
the area are selected. To perform these operations on selected regions within the locators,
use the appropriate key command after selecting the regions.
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Insert a gap between regions using the locators (the cycle length)

1. In Logic Pro, set the left and right locator positions by doing one of the following:
•

Drag from left to right across a portion of the ruler.

•

Set the values in the locator fields in the LCD.

2. Select the regions you want to move by the cycle length. If no selection is made, all
regions that fall between the locators are affected.
Clicking the Insert Silence button in the toolbar also affects all regions that fall between
the locators.
3. Choose Edit > Cut/Insert Time > Insert Silence Between Locators (or use the
corresponding key command).
•

For selected regions that are longer than the cycle length: Regions are cut at the
left locator position; the second region (newly created from the cut) is moved to the
right of the right locator position, creating a gap between the regions.

•

For selected regions that fall wholly within the locators: Regions that began at the
left locator position now begin at the right locator position.

•

For a combination of partially and wholly selected regions that fall within the
locators: The encompassed section is cut, and moved to the right locator position.

Remove gaps between regions

1. In Logic Pro, select the regions.

2. Do one of the following:
•

Choose Edit > Move > Shuffle Left within Selection (or use the corresponding key
command).
The first selected region on each track remains unchanged, and all subsequent
regions are moved to the left:

•

Choose Edit > Move > Shuffle Right within Selection (or use the corresponding key
command).
The first selected region on each track is moved to the right, and all subsequent
regions remain unchanged.
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Remove a section of an arrangement using the locators

1. In Logic Pro, set the locators to span the section you want to remove (bars 5 through 8,
for example).
2. Do one of the following:
•

To cut all regions that fall between the locators: Click the Cut Section button in the
toolbar, or choose Edit > Cut/Insert Time > Cut Section Between Locators.

•

To cut selected regions that fall between the locators: Use the Cut Section Between
Locators (Selection) key command).

Any regions that span the cycle area (for example, a 16-bar region that starts at bar 1 and
ends at the start of bar 17) are cut.
The section between the locators (bars 5 to 8) is deleted from all selected regions. (In fact,
it is copied to the Clipboard and removed from the arrangement.)
All regions to the right of the right locator are moved to the left by the length of the cycle
(4 bars), including newly created regions that result from the operation.
In the case of the 16-bar region example, from above, it would be cut into two regions:
•

One would span bars 1 to 4.

•

The other would now be an 8-bar region that is placed from bar 5 to the start of bar 13.

Tip: The Snip command is ideal for situations in which you want to remove an entire
section of your arrangement, such as a chorus.

Insert a cut section into the arrangement

1. In Logic Pro, set the locators to span the section you want to remove (bars 5 through 8,
for example).
2. Do one of the following:
•

To cut all regions that fall between the locators: Click the Cut Section button in the
toolbar, or choose Edit > Cut/Insert Time > Cut Section Between Locators.

•

To cut selected regions that fall between the locators: Use the Cut Section Between
Locators (Selection) key command.

3. Set the playhead to the position where you want to insert the cut section.
4. Either click the Insert Section button in the toolbar (to affect all tracks, regardless of
selection), or choose Edit > Cut/Insert Time > Insert Section at Playhead.
All selected regions are cut at the left locator, and a passage of one cycle length is
inserted. Regions currently in the Clipboard are then pasted at the playhead position.
Tip: This workflow is perfect for when you want to insert a part (a chorus, for example)
at another point in your arrangement. To guarantee all tracks are shifted, including tempo,
time signature changes, and markers, make sure everything is selected (using Command-A
or Shift-I) before cutting and inserting.
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Copy a section of the arrangement

1. In Logic Pro, set the locators to span the section you want to copy (bars 5 through 8,
for example).
2. Choose Edit > Cut/Insert Time > Copy Section Between Locators (or use the Copy
Section Between Locators (Global) key command).
3. Set the playhead to the position where you want to insert the copied section.
4. Either click the Insert Section button in the toolbar (to affect all tracks, regardless of
selection), or choose Edit > Cut/Insert Time > Insert Section at Playhead.
All selected regions are cut at the left locator, and a passage of one cycle length is
inserted. Regions currently in the Clipboard are then pasted at the playhead position.
Tip: This workflow is perfect for when you want to insert a part (a chorus, for example)
at another point in your arrangement. To guarantee all tracks are shifted, including tempo,
time signature changes, and markers, make sure everything is selected (using Command-A
or Shift-I) before cutting and inserting.

Repeat a section of the arrangement using the locators

1. In Logic Pro, set the locators to span the section you want to repeat (bars 5 through 8,
for example).
2. Select the regions that you want to repeat. If no selection is made (or if you use the
Repeat Section button in the toolbar), all regions that fall between the locators are
affected.

3. Choose Edit > Cut/Insert Time > Repeat Section Between Locators (or use the
corresponding key command).

The portions of all regions that are wholly or partially encompassed by the locators are
copied and pasted starting at the right locator position.
You can also move, copy, and delete sections of a project using arrangement markers. For
more information, see Add arrangement markers.
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Delay region playback in Logic Pro

You can shift the playback position of regions on a track using the Delay parameter.
Positive values shift regions ahead in time (laid-back playing style or dragging), while
negative values shift regions back in time for a pre-delay (driving or rushing the music).
The Delay value is shown in both ticks and milliseconds.

Shift the playback position of selected regions on a track
1. In Logic Pro, select the regions.

2. In the Region inspector, do one of the following:
•

Click the left area of the Delay parameter, then drag up or down to set the value.

•

Click and hold the right area of the Delay parameter, then choose a value from the
Delay pop-up menu.

The Delay parameter in the Region inspector is mainly intended for creative musical
purposes, such as rhythmically offsetting regions. It can also be used to fix timing
problems in cases such as the following:
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•

The attack phase of the sound is too slow. A good musician will automatically
compensate for this by playing the notes slightly early. With very slow sounds, you may
need a pre-delay of more than 100 ms to even them out.

•

The sound generator is reacting too slowly to the incoming note on messages. Older
multi-timbral sound generators often take tens of milliseconds before outputting a
voice.

•

The delay in output is not constant, as it is dependent on the order of notes arriving at
the external MIDI sound generator. You should therefore try pre-delaying rhythmically
important tracks by as little as one tick—it can work wonders on timing.
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Loop regions in Logic Pro

You can loop regions so that they play repeatedly, and extend them to fill any amount of
musical time in the Tracks area. When you play the project, the region repeats the number
of times you have extended (looped) it.
You can also loop a region that has been resized. When you loop a resized region, only
the visible portion of the region repeats when you play the project. If you add silence by
lengthening a region, the silence is included in each repetition when you loop it.

Loop a region

1. In Logic Pro, place the pointer over the upper-right edge of the region.
The pointer becomes a Loop pointer.

2. Drag the right edge of the region until it aligns with the point where you want it to stop
playing.
As you drag the edge of the region, “notches” appear at the top and bottom of the
region, showing the beginning and end of each complete repetition.
Note: When track automation curves are visible in the Tracks area, in some cases the Loop
pointer may not be shown when you place the pointer over the edge of a region. In this
case, you can press and hold the Option key while placing the pointer over the upper-right
edge to loop the region.

Loop a region continuously
•

In Logic Pro, select the region, then select the Loop checkbox in the Region inspector.

The region loops continuously until the start of the next region in the track, or until the
end of the project. You can unloop the region by deselecting the Loop checkbox, or by
pressing L again.
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Note: Deselecting the Loop parameter resets the manually created loop length. The next
time the Loop parameter is used, the region is repeated until it either encounters another
region in the same track, or reaches the end of the project (or folder).

Convert loops into aliases or clones
•

In Logic Pro, select the original region, then choose Edit > Convert > Loops to Aliases
(or use the Convert Loops to Aliases key command).

Logic Pro converts software instrument loop repetitions into aliases, and converts audio
loop repeats into cloned audio regions. As a result, whenever you lengthen or shorten the
original region, the change affects all aliases and cloned regions. For information about
aliases, see Create aliases of MIDI regions.

Repeat regions in Logic Pro

You can repeat one or more selected regions in the Tracks area. Repeating a region pastes
one or more copies (or aliases) of the regions following (to the right of) the regions in the
same track.

Paste single copies of selected regions
•

In Logic Pro, choose Edit > Repeat from the Tracks area local menu bar (or use the
Repeat Regions key command).

Paste multiple copies of selected regions

1. In Logic Pro, choose Edit > Repeat Multiple from the Tracks area local menu bar (or use
the Repeat Regions Multiple Times key key command).
2. Enter the number of desired repetitions in the Number of Copies field.
3. To have the repeated regions snap to a particular grid value, choose a value from the
Adjustment pop-up menu.
4. To paste the copies as regions, select As Copies (default).
5. To paste the copies as clones (for audio regions) or aliases (for MIDI regions), select As
Aliases or Clones.
Note: When you repeat a looped region, the copies may overlap any existing loop
repetitions of the region.
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Resize regions in Logic Pro

You can shorten both audio and MIDI regions so that only part of the region plays. You can
lengthen MIDI regions to add silence to the beginning or end of the region. In addition,
you can resize the common edge of two adjacent regions to control the transition between
them and remove overlaps.
You can also move and resize regions numerically by opening an Event Float window. For
more information, see Event Float window.

Resize a region

1. In Logic Pro, move the pointer over the lower-right edge of the region.
2. When the Resize pointer appears, drag the region to shorten or lengthen it.

Resize two adjacent regions

1. In Logic Pro, select the Pointer or Pencil tool, then place the pointer over the upper
edge where two adjacent regions meet.
The pointer changes to the Junction pointer.

Note: If there is a gap between the regions, the Loop pointer appears when you move
the pointer over the upper-right corner of the earlier region.
2. Drag left or right.
Both regions are resized accordingly, with no gaps between them.

Resize selected regions to the same absolute length
•

In Logic Pro, press and hold Option-Shift while resizing the regions with the Pointer tool.

Resize selected region start or end points to the playhead position
In Logic Pro, do one of the following:
•

Use the Set Region/Event/Marquee Start to Playhead Position key command.

•

Use the Set Region/Event/Marquee End to Playhead Position key command.

For audio regions, using the Set Region/Event/Marquee Start to Playhead Position key
command also moves the anchor point to the playhead position.
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Remove overlaps between regions

1. In Logic Pro, select the overlapping regions, or select all regions on the track by clicking
the track header.
2. Choose Edit > Trim > Remove Overlaps (or press \).
Where the selected regions overlap, the length of the left (earlier) region is reduced to
remove the overlap.

Remove overlaps by reducing the length of the later region

1. In Logic Pro, select the left (earlier) region of a pair of overlapping regions.
2. Choose Edit > Trim > Remove Overlaps (or press \).
Where the regions overlap, the length of the right (later) region is reduced to remove
the overlap.

Lengthen regions to remove gaps between them

1. In Logic Pro, select the regions you want to lengthen.

2. Choose Edit > Trim > Region End to Next Region (or use the corresponding key
command).

The selected regions are lengthened to end at the start point of the next region on the
track.

Lengthen selected regions between locators

1. In Logic Pro, set the left and right locator positions by doing one of the following:
•

Drag from left to right across the upper part of the ruler.

•

Set the value in the locator fields in the LCD.

2. Select the regions within the locator boundaries.
You can quickly select all regions inside the locators by choosing Edit > Select > All
Inside Locators.
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3. Choose Edit > Trim > Fill within Locators (or use the corresponding key command).
All selected regions within the locator boundaries are lengthened, closing the gaps
between them. On each track, the last region within the locator boundaries is not
lengthened.

Mute and solo regions in Logic Pro

You can mute one or more regions in the Tracks area to exclude them from playback.
You can also solo individual regions, to hear them in isolation, and lock the solo status
of regions.

Mute individual regions

In Logic Pro, do one of the following:
•

Select the Mute tool, then click the regions you want to mute.

•

Select the regions, then select the Mute checkbox in the Region inspector.

•

Select the regions, then press Control–M.

Muted regions appear gray in the Tracks area, for easy identification.

Unmute muted regions

In Logic Pro, do one of the following:
•

Select the Mute tool, then click the muted regions.

•

Select the muted regions, then deselect the Mute checkbox in the Region inspector.

•

Select the muted regions, then press Control–M.

Solo individual regions

1. In Logic Pro, click and hold the region you want to solo with the Solo tool.

The region plays in isolation from the pointer position until you release the mouse
button.
You can solo multiple regions by clicking them, then clicking and holding one of the
selected regions with the Solo tool. Playback starts from the position of the pointer until
you release the mouse button.

Solo regions using the Solo button

1. In Logic Pro, click the Solo button in the control bar (or press S).

2. Select the regions you want to solo.
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3. While the project is playing, you can Shift-click additional regions to hear them. Select a
soloed region (or Shift-click multiple soloed regions) to unsolo them.
4. When you’re finished, click the Solo button (or press S) again.

Lock the solo status of regions

1. In Logic Pro, Option-click the Solo button in the control bar (or press Option-S).

2. Select the regions you want to solo.
Selecting regions while the project plays does not affect their solo status.
3. When you’re finished, click the Solo button (or press S) again.
Muted tracks and regions appear slightly differently in the Tracks area, depending on how
they are muted:
•

When a track is muted using its Mute button, the regions on the track are gray, but the
region names are in color.

•

When a track is turned off using its On/Off button, both the regions on the track and the
region names are gray.

•

When an individual region is muted, the region and its name are gray, and a small
colored dot precedes the name.

•

When a track is muted because another track is soloed, the regions on the track are
gray, but the region names are in color.

Time stretch regions in Logic Pro

When you resize regions, the position of notes and other events in the regions does not
change. Alternatively, you can time stretch regions to shorten or lengthen the relative
distance between events in the regions. Expanding regions increases the distance (the
amount of time) between events in the regions, while compressing regions decreases
the distance.
For example, you can make a region play in half time by stretching it to twice its original
length, or play in double time by shortening it to half its original length.
You can also time stretch individual notes, chords, and other items in audio regions using
Flex Time. For more information, see Flex Time and Pitch overview.

Time stretch MIDI regions
•

In Logic Pro, Option-drag the left or right edge of one or more MIDI regions.
The events within the region are stretched or compressed, proportionately, by the
amount that the MIDI region is altered in length.
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Time stretch or compress audio regions
•

In Logic Pro, Option-drag the right edge of one or more audio regions.
This action stretches or compresses the audio by the amount that the region is altered
in length, and replaces the original region with a new PCM audio file (in the original file
format, or AIFF, if the original was not PCM).

Time stretching is limited to the value of the current Tracks area grid setting (in the Snap
pop-up menu).

Choose the audio time stretching algorithm
•

In Logic Pro, choose Edit > Time Stretch > Time Stretching Algorithm, then choose an
algorithm from the submenu.
•

Universal: This high-quality algorithm, the default, is able to handle any kind of
audio material and is recommended for most time-stretching tasks. The other two
algorithms can sometimes deliver better results when the audio material exactly
matches the outlined specifications.

•

Complex: Choose this algorithm to obtain natural-sounding results when timestretching complex musical material—orchestral music or final mixes.

•

Percussive: Perfectly maintains the timing of rhythmic material, making it a good
choice for drum loops and percussive, nonharmonic signals. In comparison to
the Beats Only algorithm, the Percussive algorithm is better suited for percussive
material that has been processed through a reverb (or contains a long tail). This may
also apply to percussive playing styles, such as staccato electric piano or clavinet
parts. Beats Only may be the better alternative for dry drum recordings.
The following algorithms are located in the Legacy submenu:
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•

Version 5: Inherited from Logic 5, this algorithm can be used on most types of audio
material. It imparts a particular color on processed audio, which may be a useful
creative option.

•

Any Material: Can handle most types of audio material.

•

Monophonic: A specialized algorithm for monophonic material—an individual voice,
or brass or woodwind instrument, for example.

•

Pads: Use on polyphonic material with harmonic content—choirs or string sections
are good examples.

•

Rhythmic Material: Use on rhythmic material—can be drums and percussion, but less
obviously rhythm guitar, clavinet, and piano comp parts.

•

Beats Only: Perfectly maintains the timing of percussive material. This algorithm
should be your first choice for all kinds of dry drum loops.
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Reverse audio regions in the Tracks area in Logic Pro

You can create interesting and unusual rhythmic, melodic, or other results by reversing
audio files. You can reverse one or more audio regions using the Reverse region parameter.
Note: The Reverse parameter is not available for audio regions in tracks with Flex
Time active.

Reverse an audio region

1. In Logic Pro, select one or more audio regions in the Tracks area.
2. In the Region inspector, select the Reverse checkbox.
If the Reverse checkbox is not visible, click the More disclosure arrow in the Region
inspector to reveal it.
The selected audio regions are non-destructively reversed. You can remove the reversing
by selecting them again, then deselecting the Reverse checkbox.
There are other ways to reverse audio in Logic Pro, including the following:
•

Reversing audio in the Audio File Editor, which destructively reverses an audio file.

•

Using the Reverse button in the Remix FX plug-in.

Split regions in Logic Pro

You can split a region in the Tracks area, and use the split segments of the region in
different places in the Tracks area.
When you split a MIDI region, any notes at the split point are shortened to that point. If
notes in a split MIDI region overlap other notes by more than a 1/16 note, a dialog appears,
asking if you want to keep, shorten, or split the notes.
You can also split regions by selecting part of the regions using the marquee stripe in the
ruler. For information about selecting regions using the marquee stripe, see Select parts
of regions.

Split regions at the playhead position

1. In the Logic Pro Tracks area, select the region or regions you want to split.
2. Move the playhead over the point where you want to split the regions, then choose
Edit > Split > Regions at Playhead.
The selected region is split into two regions at the playhead position. Only the selected
region is split, even if a region on another track is under the playhead as well. If multiple
regions are selected and are under the playhead, they are all split.

Tip: To cut at the nearest bar, use the Split Regions/Events by Rounded Playhead
Position key command.
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Split regions using the Scissors tool

1. In Logic Pro, select the regions you want to split.
2. Select the Scissors tool, then click and hold the regions you want to split.

The help tag shows the current split position.
3. Release the mouse button.
All selected regions are cut at the position shown in the help tag.
When selecting a cut point with the Scissors tool, you can move backward and forward in
steps of one division. The grid is based on the Snap pop-up menu setting.

Split regions at the locator positions

1. In Logic Pro, set the left and right locator positions.
2. Select the regions you want to divide within the locator boundaries.

3. Choose Edit > Split > Region(s) by Locators (or use the Split Regions/Events by Locators
or Marquee Selection key command).

All selected regions located wholly, or partly, between the locators are cut at the left
and right locator positions. All regions created between the locator positions as a result
of the Split operation are then automatically selected.
Tip: You can achieve the same effect by defining a cycle with the pointer in the ruler,
while holding down Command.

Split regions at the marquee selection border

1. In Logic Pro, choose View > Marquee Ruler from the Tracks area menu bar.
2. Drag in the thin marquee stripe area of the ruler to select parts of one or more regions
(also shown on selected tracks).
3. Control-click the marquee stripe, then choose Split Regions/Events at Locators or
Marquee Selection from the shortcut menu.
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Split a region into portions of equal length
•

In Logic Pro, press and hold Option while cutting a region with the Scissors tool.
A plus sign appears next to the Scissors tool.

The selected region is cut into several pieces—each the same length as the first
segment.

For example, to divide a 16-bar region into eight 2-bar regions, cut the region at the
start of bar 3, while holding down Option.

Handle overlapping notes in split MIDI regions

If any notes in a split MIDI region overlap other notes by more than a 1/16 note, a dialog
appears, asking if you want to keep, shorten, or split the notes.
In Logic Pro, select one of the following options:
•

Keep: Leaves all notes unaltered. The MIDI region is cut as intended, but there may
be notes in the left half (earlier region) that are much longer than the MIDI region
containing them. Such notes play normally, unless Clip Length is activated. (See
Delay region playback.)

•

Shorten: Truncates all overlapping notes, so that they end at the point where the
original MIDI region was split.

•

Split: Splits overlapping notes across the two MIDI regions; two notes are created,
with the same pitch and velocity as the original, and with the same total length as
the original note.

When you split a region containing region automation, Logic Pro adds automation points at
the split points. For information about region automation, see Track automation vs. region
automation. For information about working with automation points, see Add and adjust
automation points.
You can split an audio recording into segments based on amplitude levels, using the
Audio > Remove Silence function in the toolbar. For details, see Remove silent passages.
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Demix MIDI regions in Logic Pro

You can split, or demix, a MIDI region (or a standard MIDI file of format 0 or 1) into separate
regions by event channels or by note pitch.

Split MIDI regions by event channels

1. In Logic Pro, select the MIDI regions you want to split.
2. Do one of the following:
•

Choose Edit > Separate MIDI Events > by Event Channel from the Tracks area menu
bar (or use the Separate MIDI Region by MIDI Channel key command).

•

Control-click the MIDI region, then choose MIDI > Separate by MIDI Channel from the
shortcut menu.
A separate MIDI region is created for every MIDI channel found, containing all
matching events. Each region is created on a track with an instrument channel that
matches the MIDI channel. If no such tracks exist, new tracks are created for each
channel.

Split MIDI regions by note pitch

1. In Logic Pro, select the MIDI regions you want to split.
2. Do one of the following:
•

Choose Edit > Separate MIDI Events > by Note Pitch from the Tracks area menu bar
(or use the Separate MIDI Region by Note Pitch key command).

•

Control-click the MIDI region, then choose MIDI > Separate by Note Pitch from the
shortcut menu.
A separate MIDI region is created for every note number found. A track is created for
each new MIDI region, assigned to the same channel strip as the original MIDI region.

This feature is especially useful for separating drum parts that have been recorded into
Logic Pro from a drum machine where all notes are on the same MIDI channel. Each note
region can then be assigned to another channel strip, or perhaps some can be deleted, to
thin out the original drum pattern.

Join regions in Logic Pro

You can join untransposed audio regions, and join MIDI regions. Regions from audio Apple
Loops, and audio regions that have been transposed, can’t be joined.
When joining audio regions, the regions must be adjacent to each other on the same track.
If you join segments of compressed audio files, the files are converted to AIFF format.
Audio regions are joined non-destructively. Logic Pro creates a new file for the joined audio
(called a mixdown) that replaces the original regions. The new audio file is stored on your
hard disk and is added to the Project Audio Browser.

Join one or more regions
•
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In Logic Pro, select the regions, then choose Edit > Bounce and Join > Join.
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Join regions with the Glue tool

1. In Logic Pro, select the Glue tool.

2. Do one of the following:
•

Select multiple regions by dragging, then click them with the Glue tool.

•

Shift-click regions with the Glue tool.

Join regions per track

1. In Logic Pro, select the regions you want to join on each track (by Shift-clicking,
dragging, or using Command-A).

2. Choose Edit > Bounce and Join > Join per Tracks (or use the Merge Regions per Tracks
key command).

The selected regions on each track are joined into a single region on that track. For
example, if you select regions on several different tracks, and then choose Edit >
Bounce and Join > Join per Tracks, the selected regions on each track are now joined
into a single region on that track.
MIDI regions must be on the same track or on adjacent tracks. When you join MIDI regions,
the joined region takes the name (and track) of the first original region. If the Transposition,
Velocity, and Dynamics region parameters differ in any of the selected regions, they are
normalized before being joined. The parameters of the joined MIDI region are all set to
neutral [default] values.
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No mixdown

If several (mono or stereo) regions on the same track are from the same original region, and
in the same relative positions, no mixdown occurs. In this case, a single region is created.
No mixdown occurs when you join two regions on tracks that are panned to opposite sides,
as the two resulting mixdown files would be identical to the original audio files (in the areas
used for the regions).
If several overlapping audio regions on a track are selected, no mixdown occurs. You are asked
to create a new audio file, which takes the name of the first region on the track. The selected
regions are then mixed together, with no changes to volume, and without clip scanning.

Genuine mixdown with Clipscan

If you combine audio regions from two or more tracks, the current pan and volume values
for the individual tracks define the pan and volume settings in the new audio file.
If you want to combine both sides of a stereo audio file (a mono channel on each of two
tracks), first set the pan controls of the component mono sides to hard left and hard right,
respectively.
Following the digital clipping scan (Clipscan) and completion of the mixdown, Logic Pro
replaces the previously selected regions with one region that contains the entire mixeddown audio file.
You can use the Edit > Undo function (Command-Z) to restore the original audio regions, if
you change your mind about the mixdown. If you do so, you are asked if you want to keep,
or delete, the newly created mixed audio file. If you keep it, it remains in the Project Audio
Browser, and can be further used and processed.
During a mixdown, the 32-bit resolution Clipscan function ensures that the highest
possible level is maintained, without clipping.

Audio crossfades in Digital Mixdown

Digital Mixdown supports crossfades between selected regions.
The Crossfade parameters are defined by choosing Logic Pro > Preferences > Audio >
Editing (or using the Audio Crossfade Options for Merge key command).

There are two faders:
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•

Crossfade Time [ms]: The length of the entire crossfade. To turn off the crossfade, set
this value to 0.

•

Crossfade Curve: To obtain a linear crossfade, set this value to 0. Other values (positive
or negative), produce various exponential fades. The fade-outs and fade-ins are always
symmetrical, to avoid deviations in level. The preset values are Time = 0 ms, Curve = 0
(linear).
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Create regions in Logic Pro

In addition to recording regions or dragging Apple Loops and other media files in Logic Pro,
you can create regions in the Tracks area. You can:
•

Create empty MIDI regions in a software instrument track

•

Create regions containing an audio file in an audio track

•

Create regions with the same Drummer settings in a Drummer track

Create an empty MIDI region in the Tracks area
•

In Logic Pro, Control-click a software instrument track, then choose Create MIDI Region
from the shortcut menu.

Create an audio region from an audio file in the Tracks area

1. In Logic Pro, Control-click an audio track, then choose Add Audio File from the shortcut
menu.
2. Choose the audio file for the region from the Open menu.

Create a Drummer region in the Tracks area
•

In Logic Pro, Control-click a Drummer track, then choose Create Drummer Region from
the shortcut menu.

Normalize audio regions in the Tracks area in Logic Pro

You can normalize the gain of selected regions in the Tracks area, without opening the
regions in the Audio Track Editor. In Logic Pro, the Normalize Region Gain menu command
is non-destructive: The original file isn’t altered, only the normalized region.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Normalize Region Gain command is available in the Functions menu.

Normalize the gain of audio regions in the Tracks area

1. In the Logic Pro Tracks area, select one or more audio regions. You can select all
regions in a track by clicking the track header.
2. Choose Functions > Normalize Region Gain in the Tracks area menu bar.
3. In the Normalize Gain dialog, do the following:
a. In the Affect pop-up menu, choose whether individual regions, individual tracks, or
the entire selection are normalized.
b. In the Algorithm pop-up menu, choose the normalization algorithm to use.
c. Use the Target Level value slider to set the intended level of normalization (in
decibels).
d. Click Apply.
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Create MIDI aliases in Logic Pro

You can create an alias for a MIDI region or a folder. An alias is a reference to a region, and
looks similar to a normal region in the Tracks area. If you alter the original region, all aliases
of the region are similarly altered.
Aliases can be useful when you want to repeat a phrase or riff in different parts of an
arrangement. If you make changes to the original region after creating aliases from it, the
changes apply to all its aliases throughout the project. If you want to edit one of the aliases
without changing the others, you can turn that alias into an independent region (a region
copy) and edit it independently.
Aliases do have some differences from their “parent” region: you can give each alias its
own name, and edit region parameters for each alias independently.
Alias names appear in italics to distinguish them from normal regions. If you name an alias,
its parent region name is shown below the alias name (provided that the zoom level is
adequate).

Any changes made to the parent region name appear on all its aliases.

Create an alias

In Logic Pro, do one of the following:
Option-Shift-drag the region to the position where you want the alias to start.
Select the track you want to create the alias on, position the playhead, select the region
you want to create an alias from, then choose Functions > Region Alias > Make Alias (or
use the Make Alias key command).
You can also use the Repeat Regions command.
If several regions are selected, their relative time and track positions are retained. The
selected track is the destination track for the first region along the Tracks area.

Reassign an alias

You can assign a new original region to an existing alias. This is exceptionally handy for
arranging tasks where the structure is right, but the specific part is wrong. You can copy
a region to a new track, create an alias, mute the existing region, and click Play, or use the
far simpler method below:
1. In Logic Pro, select both the alias and the intended new original region.
2. Choose Functions > Region Alias > Re-Assign Alias (or use the Reassign Alias key
command).

Logic Pro User Guide

364

Search for an original region or alias

If you forget where the original or source region is for a certain alias, you can search for it.
In Logic Pro, do one of the following:
•

Select the alias, then choose MIDI > Alias > Select Original (or use the Find Original of
Alias key command).

•

Choose Functions > Region Alias > Select Aliases of Region.

Convert aliases from deleted source regions

If you delete the original or source region used by one or more aliases, a dialog appears,
asking whether to convert the aliases to independent MIDI regions or to keep the aliases. In
Logic Pro, do one of the following:
•

To cancel the procedure: Click Cancel.

•

To change all alias MIDI regions into real copies: Click Convert.

•

To delete the parent region, and retain all (orphaned) alias regions: Click Keep. Although
such orphan aliases serve no useful purpose, Logic Pro doesn’t automatically delete
them, in case you decide to reassign them to new originals at a later stage.

Select and delete all orphan aliases

If your project file contains unneeded aliases, you can quickly tidy up by selecting and
deleting all orphan aliases.
1. In Logic Pro, choose Functions > Region Alias > Select Orphan Aliases (or use the
corresponding key command).
2. Choose Functions > Region Alias > Delete Orphan Aliases (or use the corresponding key
command).

Convert an alias to a normal region

You can create a real region from an alias; its contents are identical to those of the original
region referenced by the alias, but its playback parameters are those of the alias. After
it’s been converted to a real region, you can edit it (or the original parent region), without
affecting the new real region.
You can also double-click an alias to open a dialog that asks whether you want to create
and edit a real copy, or edit the original.
If you double-click an alias to edit it, Logic Pro assumes that you either want to edit the
original, or turn the alias into a real region. You are asked whether you want to create and
edit a real copy, or to edit the original.
•

Logic Pro User Guide

In Logic Pro, choose Functions > Region Alias > Convert to Region Copy from the Tracks
area menu bar (or use the Convert Alias to a Region Copy key command).
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Convert repeated MIDI regions to loops in Logic Pro

When MIDI regions with adjacent repetitions exist in the Tracks area, you can convert the
repetitions to loops. After the regions are converted to loops, any changes you make to the
original region are carried over to the loops.

Convert repetitions of a region to loops
1. Select the region in the Tracks area.

2. Choose Edit > Convert > Repetitions to Loops, or use the corresponding key command.

Color regions in Logic Pro

You can change the color of regions to identify sections of your arrangement, distinguish
between track types, or for other uses. Newly recorded or added regions use the color of
the track channel strip.

Change the color of one or more regions

1. In Logic Pro, select the region or regions you want to change.
Note: If you select all regions on a particular track, and no regions on other tracks are
selected, coloring them alters the hue of all selected regions. This also changes the
color of the selected track’s channel strip.
2. Choose Logic Pro > Preferences > Display, then click the Tracks tab. In the Tracks
Display preferences pane, make sure that the Region Color pop-up menu is set to
Individual.
Note: If the Region Color pop-up menu is set to As Track Color, you cannot color
regions individually.
3. Control-click one of the selected regions, then choose Name and Color > Show/Hide
Colors from the shortcut menu (or press Option-C).

4. Click a color.

Set regions to match the track color

1. In Logic Pro, select the regions you want to change.
If all regions are on a single track, click the track’s header to select all regions.
2. Choose Functions > Color Regions by Track Color from the Tracks area menu bar.
The colors of all selected regions are replaced with the colors of the corresponding
track channel strips.
Tip: This feature is handy after copying or moving regions between tracks, when you
may find that the Tracks area resembles a patchwork quilt.
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Convert audio regions to samples for a sampler instrument
in Logic Pro

You can quickly create your own Sampler, Drum Machine Designer, or Alchemy instruments
by converting one or more audio regions into samples. Logic Pro sets this instrument
up on a new software instrument track, allowing you to play the sample zones at their
original position.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Convert Regions to New Sampler Track command is available in the Track menu.

Convert audio regions to sample zones on a new sampler track

1. In Logic Pro, select the audio regions you want to convert in the Tracks area, then do
one of the following:
•

Choose Track > Convert Regions to New Sampler Track.

•

Control-click one of the selected audio regions, then choose Convert > Convert to
New Sampler Track from the shortcut menu.

2. Choose whether you want to create zones from regions or transient markers:
•

Regions: Converts each selected region into a sample zone. For example, a single
region is converted into a single sample zone.

•

Transient Markers: Converts each section between transient markers into a sample
zone. For example, a single region with multiple sections is converted into multiple
sample zones. This is useful for quickly slicing drum hits in a drum loop, for example.
Note: If you create zones from transient markers, Logic Pro analyzes the audio
region or regions to detect transients, if they have not previously been analyzed.

3. Select the instrument to use for the new track:
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•

Drum Machine Designer: Inserts Drum Machine Designer into the Instrument slot on
the new software instrument track. Each zone is set up on a subtrack and placed on
its own pad in the Drum Machine Designer grid.

•

Alchemy: Inserts Alchemy as the instrument plug-in on the new software instrument
track.

•

Sampler: Inserts Sampler as the instrument plug-in on the new software instrument
track.
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4. If you want the sample zones to play back in their entirety when triggered, regardless
of how long you press the trigger key, select the Create ‘1Shot’ Zones checkbox. When
unselected, the sample zone plays only for as long as you press the trigger key.
5. From the Trigger Note Range pop-up menus, choose the lowest and highest note for the
one-note zones created in the new sampler instrument, then click OK.

This creates a new software instrument track below the selected track, with the sampler
instrument inserted as the instrument plug-in. MIDI regions with ascending trigger notes
are created on this track. The new track and regions are selected, and the processed
regions are muted and dimmed.
Note: When you use Sampler or Alchemy, Logic Pro saves the samples to the project only
if you select the respective asset setting: File > Project Settings > Assets > “Copy Sampler
audio files into project” or “Copy Alchemy audio files into project.” By contrast, Logic Pro
saves the sampler instrument itself to the project regardless of this setting. Drum Machine
Designer saves the samples to the project by default. For more information, see Manage
Logic Pro project assets.

Rename regions in Logic Pro

You can rename one or more regions while you are working.

Rename a region

1. In Logic Pro, select one or more regions, then do one of the following:
•

Press Shift-N.

•

Control-click the region, then choose Name and Color > Rename Regions.

•

Select the region name in the Region inspector. When you select multiple regions,
the number of selected regions is shown in place of the region title.

2. Enter a new name.
When you rename multiple regions, and the new name ends in a number, the number is
incremented for each region.
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Delete regions in Logic Pro

You can delete one or more regions if you don’t want to use them in your project. When you
delete a region, you can move the regions that follow in the track to fill in the empty space
left by the deleted region.
When you delete an audio region that you have recorded since opening the project, a
dialog appears, asking whether you also want to delete the corresponding audio file. This
dialog does not appear for imported audio files, to assure that you do not accidentally
delete recordings used in other projects.

Delete a region

In Logic Pro, select one or more regions, then choose Edit > Delete (or press the
Delete key).
You can also delete regions using the Eraser tool.

Delete a region and move all regions that follow
•

In Logic Pro, select one or more regions, then choose Edit > Delete and Move.

Delete all selected regions, and automatically select the next one
1. In Logic Pro, select the region or regions you want to delete.
2. Use the Delete and Select Next Region/Event key command.
All selected regions are deleted, and the next region is automatically selected.

Restore deleted regions
•

In Logic Pro, choose Edit > Undo History, then click the step you want to restore.
Restoring audio and MIDI regions deleted from the Tracks area involves somewhat
different procedures. When you delete an audio region from the Tracks area, it remains
in the Project Audio Browser. You can restore it to the Tracks area by adding it from
the Project Audio Browser. Both audio and MIDI regions can be restored using the
Undo history.
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Create fades and crossfades on audio regions
Create fades on audio regions in Logic Pro

You can fade in the beginning of audio regions, and fade out the end of audio regions
(including audio Apple Loops) using either the Fade tool or the Fade In and Fade Out
parameters in the Region inspector.
Fades are visible only when you have zoomed in enough to see the waveform in the
audio region.

Create a fade-in or fade-out with the Fade tool

1. In Logic Pro, select the Fade tool from the Tool menu in the menu bar for the Tracks
area.

2. In the Tracks area, do one of the following:
•

Drag over the start or end point of an audio region.

A fade-in or fade-out is created. The length of the fade drag area determines the
length of the fade, so a longer drag area results in a longer fade time, and a shorter
drag area, a quick fade.
•

Drag over the end point of one audio region and the start point of the region that
follows.

This technique works even if the two sections don’t directly adjoin each other.
With the Fade tool selected, you can edit fades on regions after you make them.

Logic Pro User Guide

370

Create a fade-in or fade-out using the Region inspector
1. In Logic Pro, select one or more regions.

2. Set the value for the Fade In or Fade Out setting in the Region inspector by dragging the
pointer vertically, or double-clicking and entering a value.

Fades created using the Fade tool and the Region inspector are interactive. After you
create a fade using the Fade tool, for example, you can adjust the fade using the Region
inspector Fade In or Fade Out parameters.

Apply the last fade to selected regions

1. In Logic Pro, select one or more regions.
2. Use the “Apply Last Fade or Fade Marquee Selection” key command.
The “Apply Last Fade or Fade Marquee Selection” command applies the following region
parameters to the selected regions:
•

Fade In/Speed Up–Time

•

Fade In/Speed Up–Curve

•

Fade Out/Slow Down–Type

•

Fade Out/Slow Down–Time

•

Fade Out/Slow Down–Curve

Changing the Fade Out/Slow Down–Type from “Out” to “EqP Crossfade” (Equal Power
Crossfade) depends on whether the selected region is followed by an adjacent region
(which requires EqP Crossfade) or a gap (which requires Out). For similar reasons,
changing from any “Crossfade” type to “Out” depends on whether the selected region
is followed by an adjacent region or a gap.
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Apply the last fade to a marquee selection

1. In Logic Pro, make a marquee selection to part of one or more regions.
2. Use the “Apply Last Fade or Fade Marquee Selection” key command.
Logic Pro analyzes each marquee selection, and applies one of the following fade types for
every affected track:
•

If the marquee selection encloses one region end which is followed by a gap, a Fade Out
is applied from the marquee selection start to the region end.

•

If the marquee selection starts later than the region start and ends exactly on the region
end (within the same pixel, or so), a Fade Out is applied from the marquee selection
start to the region end.

•

If the marquee selection encloses exactly one junction between two adjacent regions
(starts later than the first region start, ends earlier than the second region end), an
Equal Power Crossfade is applied from the marquee selection start to the marquee
selection end, with the crossfade pivot on the region junction.

•

If the marquee selection encloses a region start, which follows a gap, or if the marquee
selection starts on the region start and the marquee selection ends before the region
end, a Fade In is applied from the region start to the marquee selection end.

Edit fades in Logic Pro

You can change the length of a fade, the fade curve shape, the fade type, and the fade
playback speed (also called Speed Fade).
You can also choose between four different fade types in the Region inspector.

Edit the length of a fade

In Logic Pro, do one of the following:
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•

Drag over the start or end point of a fade with the Fade tool.

•

Select a region, then edit the Fade In or Fade Out value in the Region inspector.
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Adjust the fade curve shape

In Logic Pro, do one of the following:
•

Drag the fade curve with the Fade tool.

•

Select a region, then edit the Curve value in the Region inspector.

In the example below, a positive curve is shown for both the fade-in and fade-out.

In this next example, a negative curve is shown for the fade-in, and a linear fade (no curve)
is shown for the fade-out.

Change the fade type

In the Logic Pro Region inspector, choose a fade type from the Fade Out pop-up menu.
•

Out: Creates a standard fade-out whenever the Fade tool or Fade parameter is used.

•

X (Crossfade): Crossfades the selected region with the following region when you
use the Fade tool or Fade parameter.

•

EqP (Equal Power Crossfade): Results in an equal power crossfade. This minimizes
volume dips between audio regions, resulting in a more even crossfade between
regions that may be slightly different in level.

•

X S (S-Curved Crossfade): Delivers an S-curved crossfade. The fade curve, as the
name suggests, is S shaped.

The last three items in the pop-up menu can only be applied to two consecutive regions.
Also note that the Fade In (and corresponding Curve) parameters are made redundant
when any of the X, EqP, or X S options are chosen.

Change the playback speed of a fade
In Logic Pro, do one of the following:
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•

For a fade in, choose the Speed Up parameter, and modify the value.

•

For a fade out, choose the Slow Down parameter, and modify the value.

373

Logic Pro offers Speed Up and Slow Down parameters in the Region inspector, which you
can use to speed up or slow down the playback speed of fades. These parameters share
pop-up menus with the Fade In and Fade Out parameters.

Create automatic crossfades in Logic Pro

Logic Pro can automatically create crossfades on overlapping audio regions on a track to
smoothly segue between adjacent (or overlapping) audio regions.

Turn on automatic crossfades
•

In Logic Pro, choose the X-Fade setting from the Drag pop-up menu in the Tracks area
menu bar. (See Control positioning with drag modes.)

You can also create crossfades manually—as well as fade-ins and fade-outs—using the
Fade tool, the Fade parameters in the Region inspector, or the shortcut menu of an existing
fade area. For information, see Create fades on audio regions and Edit fades.
You can simultaneously adjust the fade parameters for all selected audio regions.
Note: The Fade parameters are non-destructive, unlike the fade functions available in the
Audio File Editor, which change the original audio file.

Delete fades in Logic Pro

You can delete a fade with a menu command, with the Fade tool, or by modifying the
parameters in the Region inspector.

Delete a fade

In Logic Pro, do one of the following:

Logic Pro User Guide

•

Control-click an existing fade area, then choose Remove Fade from the shortcut menu.

•

Option-click an existing fade area with the Fade tool.

•

Set the Fade In or Fade Out parameter in the Region inspector to 0.
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Remove silent passages from audio files
Remove silent passages in Logic Pro

You can remove silent passages from audio regions in the Remove Silence window. The
basic process is simple: all amplitude values below a threshold level are removed, and new
regions are created from the remaining passages.

The Remove Silence window contains the following parameters:
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•

Threshold: Use to define the amplitude level that a passage must exceed, in order to
be defined as a region. In terms of the number and length of regions created by the
process, this is the most important parameter. As a general rule: a higher Threshold
value leads to numerous short regions. Low values create fewer large regions.

•

Minimum Time to accept as Silence: Use to define the length of time that a section must
be below the Threshold value, before it is considered a gap. Very small values tend to
increase the number of regions, because even short dips in amplitude are interpreted as
silence. Higher values prevent sections of audio from being interrupted by fluctuating
amplitudes.

•

Pre Attack-Time: Use to add a defined amount of pre-roll to the beginning of all regions
created by the Remove Silence process. High threshold values prevent any amplitudes
with slower attack times from being chopped. This function is useful for nonpercussive
material such as vocals, wind instruments, strings, and so on. Overlaps are permitted—
the pre-delayed start point of a region can extend back to the end of the previous
region—but only if the Threshold value is not exceeded. The pre attack-time doesn’t
affect the anchor position, which means the absolute position of the audio data (in the
project) is retained.

•

Post Release-Time: Use to define an automatic release time for the end points of all
regions, avoiding abrupt cutoffs to amplitudes that fade out gradually (particularly if you
have set a high Threshold value); for example, cymbals, open hi-hats, snares with long
reverb tails, vocals, and so on. This parameter does not allow overlaps, which means
that region end points cannot extend beyond the start point of the following region. The
post release-time doesn’t affect the anchor position, which means the absolute position
of the audio data (in the project) is retained.

•

Search Zero Crossings: Select this checkbox to automatically snap the region start and
end points to the nearest waveform zero crossings.
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Open the Remove Silence window

In Logic Pro, you can open the Remove Silence window in either the Tracks area or the
Project Audio Browser:
•

In the Tracks area, Control-click an audio region, then choose Split > Remove Silence
from Audio Region from the shortcut menu.

•

In the Project Audio Browser, Control-click an audio region, then choose Remove
Silence from the shortcut menu.

Remove silent passages from the selected region

1. In Logic Pro, set parameters in the Remove Silence window.

Note: Depending on the material in the audio file, all parameters can affect the number
and division of regions. Try different values to see what produces the best result. The
graphic display of the region updates to show the result of your changes.
2. Click OK.
If you opened the Remove Silence window from the Project Audio Browser by selecting
a region that is used in the Tracks area, a dialog asks if you want to replace the region in
the Tracks area with the new regions.
3. Do one of the following:
•

To replace the region in the Tracks area with regions created by the Remove Silence
function: Click Replace (or press Return). This ensures that the relative timing of the
individual audio segments remains unaltered.

•

To have the regions appear only in the Project Audio Browser: Click Don’t Replace.
You can add regions manually from the Project Audio Browser.

To learn about different uses for Remove Silence, see Uses for Remove Silence.
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Uses for Remove Silence in Logic Pro

You can use Remove Silence for a variety of different situations.

Remove background noises

The most common use for Remove Silence is simulation of the classic noise gate effect.
When used on long recordings with numerous gaps—such as vocals or instrumental
solos—you can obtain better results by setting a low threshold value. Background noise is
removed, without affecting the main signal.
•

For short percussive regions (drum loops), you can simulate time compression/
expansion by simply altering the tempo.

•

You can even quantize the individual segments in an audio recording.

Create segments of spoken recordings

You can use Remove Silence to divide long spoken passages into several convenient
segments, like sentences, words, or syllables. For film synchronization or jingles, you
can move or reposition the speech segments by simply dragging them around in the
Tracks area.
Tempo changes allow you to simulate a time compression or expansion effect, as the
syllables automatically move closer together, or farther apart.

Create segments for drum loops

Dividing drum loops into small segments is a good way to perfectly synchronize them. For
example, in audio passages where the bass drum and snare are completely separate, you
can often use Remove Silence to isolate each individual beat.

Optimize synchronization

Different computers, different synchronization sources (internal or SMPTE code), different
tape machines, and—in theory—different samplers or hard disk recording systems will
exhibit slight variations in clock speed. Changing just one component can lead to a loss of
synchronization between recorded audio material and MIDI. This is particularly applicable
to long audio regions.
This is another situation where the Remove Silence function can help, by creating several
shorter audio regions, with more trigger points between the audio and MIDI events.
For example, you can use this method to roughly split up a whole audio file, and then divide
the new regions, using different parameters. The new regions can then be processed again
with the Remove Silence function.

Optimize files and regions

You can use Remove Silence to automatically create regions from an audio file that
contains silent passages, such as a single vocal take that runs the length of a project. The
unused regions or portions of the audio file can be deleted, saving hard disk space, and
simplifying (file and) region management.
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Use Remove Silence to extract audio files

Many sample library discs (CD or DVD) contain thousands of audio recordings stored as
AIFF or WAV files. You can use Remove Silence to split these into individual regions, which
can be used directly in the Tracks area. In addition, you can convert regions into individual
audio files (samples), which can be used in the Sampler.

Work with folders
Logic Pro folders overview

A folder is a region that can contain other regions, similar to a folder in the Finder that
can contain different files. You can edit a folder in many of the same ways you edit a
MIDI region.
A folder can be thought of as an arrangement within an arrangement. A folder can contain
as many tracks (with their regions) as needed. When a folder is closed, it looks like a MIDI
region in the Tracks area:

When open, a folder looks just like the Tracks area for a project:

The track containing the folder doesn’t have a channel strip. Its track header shows a
folder icon in place of an instrument icon.
If you drag a folder to a software instrument track, all MIDI regions in the folder are played
by that instrument. This can be useful if the folder contains tracks for a given instrument
or instrument type, such as a drum kit, string sound, or brass section, for example. This
provides a quick way of listening to a string arrangement if some of the intended sound
sources are unavailable.
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Similarly, an entire project could itself be a folder, appearing as a gray beam in the Tracks
area. In this way, you could arrange several projects for a concert. Another possible use
might be to store different arrangements of a project in different folders, allowing you to
switch between them rapidly.
You can also use folders to represent song sections such as verses and choruses, for
example. You can nest folders within other folders, with no limit to the number of levels you
can create.

Pack and unpack folders in Logic Pro

You can pack selected regions into a folder, or create an empty folder and add regions to it.

Pack regions into a folder
•

In Logic Pro, select the regions, then choose Functions > Folder > Pack Folder from the
Tracks area menu bar.
If the selected regions are all on the same track, the folder is created on that track. If
the regions are located on different tracks, a new folder track is created.

Note: When moving a folder with a single content track between tracks of the same type,
the folder contents play using the channel strip of the hosting track.

Create an empty folder
•

In Logic Pro, with no regions selected in the Tracks area, choose Functions > Folder >
Pack Folder from the Tracks area menu bar.
The new, empty folder contains tracks assigned to all channel strips from the current
level.

Unpack a folder

1. In Logic Pro, select the folder.
2. Do one of the following:
•

Choose Functions > Folder > Unpack Folder to New Tracks from the Tracks area
menu bar.
Logic Pro creates new tracks on the same level that the folder was located on (below
the former folder track).

•

Choose Functions > Folder > Unpack Folder to Existing Tracks from the Tracks area
menu bar (or use the “Unpack Folder to Existing Tracks” key command).
The regions contained within the folder are placed on tracks assigned to appropriate
channel strips.
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Open and close folders in Logic Pro

After you have packed a folder, you can open it to make changes.
There are several ways to distinguish whether you are inside a folder, or viewing the entire
project in the Tracks area:
•

In the Tracks area, the folder itself is visible on a track, the Logic Pro main window title
bar shows the project name, and the Display Level button is dimmed.

•

When inside a folder, the folder track can’t be seen, the main window title bar shows the
project name followed by the folder name (for example; Untitled: Chorus Folder), and
the Display Level button is available.

Open a folder

In Logic Pro, do one of the following:
•

Double-click the folder.

•

Select the folder you want to open, then use the Go Into Folder or Region key command.
If a MIDI region, rather than a folder, is selected when you use the key command, the
Piano Roll Editor opens.

Double-clicking the header of a folder track opens the Mixer.

Close a folder

In Logic Pro, do one of the following:
•

Double-click the background of the Tracks area (or use the Go Out of Folder or Region
key command).

•

Click the Display Level button
Folder.

in the Tracks area menu bar. The help tag shows Leave

You move up one display level, and the contents of the Tracks area (showing the closed
folder) are visible.
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Add and remove regions from folders in Logic Pro

You can add and remove regions from a folder. This is useful as you experiment with your
arrangement, and find that you need to add or remove parts.

Add regions to a folder
•

In Logic Pro, at the top level of the Tracks area hierarchy, drag the regions onto the
folder, at the desired position.

If the folder doesn’t already contain a track that uses the same channel as the source
region, Logic Pro creates one. If it does contain a track using the same channel, the
track uses this channel. When you enter the folder, you see the dragged regions at the
drop position.

Remove regions from a folder

1. In Logic Pro, open a second Tracks area window by choosing Window > Open Tracks, or
use the Open Tracks key command (Command-1).
2. In one of the two windows, open the folder containing the regions you want to remove.
3. Drag the regions into the Tracks area in the other window.
You can also cut a region from a folder, using the Edit > Cut command to transfer the
region to the Clipboard. You can then copy the region to the position where you want it to
appear in the Tracks area using the Edit > Paste command.
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Create alias folders in Logic Pro

You can create a copy of a folder that contains aliases (of MIDI regions) and clones (of
audio regions) in the original folder. Then you can use the copied folder as an alternative
mix folder, by muting regions, and editing instrument or playback parameters, for example.
You can quickly switch between different arrangement versions simply by muting and
soloing different folders.

Create an alias folder
•

In Logic Pro, press and hold Option and Shift as you drag the folder to the position
where you want the alias to start.

Work with groove templates
Create groove templates in Logic Pro

You can create quantization grids, called groove templates, based on the rhythms of audio
or MIDI regions. You can use groove templates to capture the subtle timing deviations that
give a region its “feel” and apply that feel to other audio or MIDI regions. You can even take
the feel of an audio region and apply it to a MIDI region—helping a MIDI clavinet part to sit
well with a funk guitar Apple Loop, for example.
Note: To use an audio region for a groove template, Flex must be activated on the track
containing the region.
You can also select multiple regions to create a groove template, and all of them will
contribute their transients or notes to the new groove template. When there are multiple
transients or MIDI notes around the same musical position, however, only the first will be
evaluated for the groove template.
Tip: Two-bar MIDI regions work particularly well for groove templates, but you can use
MIDI regions of any length. Make sure that the source MIDI region actually contains a note
at every desired quantization value.

Create a groove template

1. In Logic Pro, select the audio or MIDI region or regions from which you want to create a
groove template.

If you select multiple regions, the transients or notes from all the selected regions are
used for the groove template. When there are multiple transients or MIDI notes around
the same musical position, however, only the first will be evaluated for the groove
template.
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2. In the Region inspector, choose Quantize > Make Groove Template (or use the
corresponding key command).

The new groove template appears near the bottom of the Quantize pop-up menu. By
default, the groove template takes the name of the selected region (the first selected
region, when multiple regions are selected).

3. To apply the new groove template, select the region or regions to apply it to, then select
the groove template from the Quantize pop-up menu in the Region inspector.
Important: The source audio or MIDI region (or regions) used to create a groove template
must remain in your project. If you delete the source region from the project, name of
the the groove template remains in the Quantize pop-up menu, but selecting the name
produces no result.
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Remove groove templates from the Quantize pop-up menu

1. In the Logic Pro Region inspector, open the Quantize pop-up menu of any region, and
choose the groove template.
2. Open the Quantize pop-up menu again and choose “Remove Groove Template from
List” (or use the corresponding key command).
The selected source region is deleted from the list of possible quantization templates,
removing it from the Quantize pop-up menu. The region is not removed.
Without changing the actual quantization of that region (or of any other region that may
use that groove template), the previously selected groove template is deleted, and the
region is set to the Quantize value “off (3840).”

Share a groove template between projects

1. In Logic Pro, copy or create your source regions in one project.
2. Name these regions with the Text tool.
3. Open the Quantize pop-up menu, then choose Make Groove Template for each source
region (or use the corresponding key command).
4. Pack all of these regions into a folder (and rename the folder Grooves, for example).
5. Choose File > Save As Template.
Use this template as your project starting point whenever you want to access these
quantization templates.

Edit region parameters
Use the Region inspector in Logic Pro

You can view and edit region parameters in the Region inspector, located in the upper part
of the inspector. When a single region is selected, the title bar of the Region inspector
shows the region name; when multiple regions are selected, the title bar shows the number
of selected regions.

The Region inspector shows parameters for the selected region or regions, including
Quantize and other parameters. Some parameters are shared, while others are available
for only audio or MIDI regions. You can view and edit additional advanced quantization
parameters by clicking the More disclosure arrow in the Region inspector.
You can also open the Region inspector in a separate floating window.
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Default settings

If no region is selected, the upper line of the Region inspector displays the text Default
Settings. The region parameter settings displayed are applied to newly recorded regions as
realtime playback settings.

Editing several regions simultaneously

If several regions are selected, the number of selected regions is displayed, in place
of a region name. If you alter any region parameter, all selected regions are affected. If
a given parameter is set differently in the individual regions, an asterisk (*) appears in
the parameter field. You can alter this parameter for all selected regions, and the value
differential will be retained (relative alteration). If you want to set all selected regions to the
same value, press and hold Option-Shift while changing the value (absolute alteration).
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional parameters appear in the lower part of the Region inspector. You can view and
edit these parameters by clicking the More disclosure arrow in the Region inspector.

Open the Region inspector in a separate window
•

In Logic Pro, choose Window > Open Region Inspector Float (or press Option-R).

Logic Pro audio region parameters

The following parameters are available for audio regions in the Region inspector.
•

Mute: Select to mute individual regions in the Tracks area to exclude them from
playback.

•

Loop: The playback of regions can be continuously repeated by selecting the Loop
checkbox, or by using the Loop tool. (See Loop regions.)

•

Quantize: All note events contained in the region are time corrected to the (quantize)
grid format chosen in the pop-up menu. For information on choosing the Quantize
parameter value, see Quantize parameter values.
Note: There are two types of region quantization: Classic Quantize and Smart Quantize.
You select the type by clicking the Quantize label in the Region inspector. For
information, see MIDI quantization types.
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•

Q-Swing: This percentage value alters the position of every second point in the current
quantization grid. Values over 50% delay the beats, and values under 50% pre-delay
them. The most practical settings fall between 50% and 75%, imparting a swing feel
to strictly quantized (or tightly played) audio or MIDI regions. For information about
Q-Swing and other advanced quantization parameters, see Advanced quantization
parameters.

•

Transpose pop-up menu: You can transpose the selected audio region or regions by
doing one of the following:
•

Place the pointer to the right of the word Transpose, then drag up or down to
transpose in semitones.

•

Double-click the Transpose field, then type the number of semitones to transpose
the region. Use a hyphen (-) before the number to transpose down.

•

Click the Transpose menu (indicated by up and down arrows), then choose the value
to transpose in octaves.
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•

Fine Tune: Choose the pitch offset for the region in cents. Double-click and enter an
offset, or click the arrows, then choose an offset (in increments of +/- 10).

•

Flex & Follow: Choose whether the region follows the project tempo, whether it is
flexed, and at what resolution. For more information, see Choose the Flex & Follow
setting.

•

Gain: Adjust the volume of individual audio regions by a specified amount. Double-click
and enter the gain amount (in dB).

You can access additional parameters by clicking the More disclosure arrow in the Region
inspector:
•

Delay: You can delay the playback of regions using positive values (or advance the
playback using negative values) by ticks or by milliseconds. (For more information, see
Delay region playback.)

•

Fade In/Speed Up: Use to switch between Fade In and Speed Up parameters, where you
apply fade values for volume and playback, respectively.

•

Curve: Adjusts the fade-in curve shape.

•

Fade Out/Slow Down: Use to switch between Fade Out and Slow Down parameters,
where you apply fade values for volume and playback, respectively.

•

Curve: Adjusts the fade-out curve shape.

•

Transposition: Adjusts the pitch of the Apple Loops up or down by the chosen amount.

•

Reverse: Use to have the region play in reverse. The Reverse parameter is not available
for regions in tracks with Flex Time activated.

•

Speed: Adjusts the playback speed to the chosen multiple of the original speed.
Available only for audio Apple Loops.

•

Q-Range: Defines which notes are quantized based on their proximity to quantization
grid positions. At the default value of 0, every note is quantized. At positive Q-Range
values, only notes outside the set range (that is, farther away from the grid position)
are quantized, and notes in the range keep their original position. At negative Q-Range
values, only notes in the set range are quantized, and notes outside the range remain
unchanged. The amount by which notes shift toward the grid positions depends on the
Q-Strength setting.
For example, with Q-Range set to 20 ticks and Q-Strength to 50%, only notes that
are more than 20 ticks off are quantized. Those notes are quantized by 50%, which
improves the timing without making the performance sound mechanical.

•

Q-Strength: This percentage value determines how far a note is shifted toward the
nearest grid position. 100% results in full quantization; 0% leaves the note at its
recorded position.

Some audio region parameters are different for standard audio regions than for
Apple Loops. The Fade and Gain parameters are available for standard audio regions but
not for Apple Loops, and the Transposition and Follow Tempo parameters are available for
Apple Loops and untagged loops, but not for standard audio regions.
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Logic Pro MIDI region parameters

The following parameters are available for MIDI regions (and software instrument Apple
Loops) in the Region inspector.
The MIDI region parameters also apply to folders, and globally affect all MIDI regions within
the folder.
•

Mute: Lets you mute individual regions in the Tracks area to exclude them from
playback.

•

Loop: The playback of regions can be continuously repeated by selecting the Loop
checkbox, or by using the Loop tool. (See Loop regions.)

•

Quantize: All note events contained in the region are time corrected to the (quantize)
grid format chosen in the pop-up menu. For information on choosing the Quantize
parameter value, see Quantize parameter values.
Note: There are two types of region quantization: Classic Quantize and Smart Quantize.
You select the type by clicking the Quantize label in the Region inspector. For
information, see MIDI quantization types.

•

Q-Swing: This percentage value alters the position of every second point in the current
quantization grid. Values over 50% delay the beats, and values under 50% pre-delay
them. The most practical settings fall between 50% and 75%, imparting a swing feel
to strictly quantized (or tightly played) audio or MIDI regions. For information about
Q-Swing and other advanced quantization parameters, see Advanced quantization
parameters.

•

Transpose: All note events in the region are transposed up or down in semitones during
playback. Even complete folders can be instantly transposed in this way. If several
individual MIDI regions within the folder have already been transposed, the relative
differences between them are retained.
To transpose by octaves: Click the arrows to the right of the Transposition parameter,
then choose the octave transposition from the pop-up menu. To transpose by
semitones: double-click, then type the number of semitones. To transpose downwards,
type ‘-’ before the number.
To guard against drum notes and so on being transposed, select the No Transpose
checkbox in the Track inspector. When the checkbox is selected, Logic Pro ignores
the Transpose parameter in all MIDI regions played by this channel strip (including
instrument Apple Loops added to tracks routed to instrument channels).

•
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Velocity: All notes in the relevant MIDI region are offset by the selected value. Positive
values add to the originally recorded velocity, and negative ones subtract from it,
although naturally it is impossible to go outside the limits defined by the MIDI Standard
(0–127). If you select a velocity offset that exceeds the maximum or minimum possible
value for a particular note, that note will play at the extreme possible range. For
example, a setting of +20 will cause a note with a velocity of 120 to play at 127.
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You can access additional parameters by clicking the More disclosure arrow in the Region
inspector:
•

Delay: The playback of regions can be delayed (positive values) or advanced (negative
values) by ticks or by milliseconds. (For more information, see Delay region playback.)

•

Dynamics: This parameter also affects the velocity values of notes, but instead of
adding or subtracting a fixed amount, the differences between soft and loud notes (the
dynamics) are increased or decreased. This works in a similar way to a compressor or
expander. Values above 100% expand the dynamics, thereby increasing the difference
between loud and soft, while values below 100% compress the dynamics, reducing the
differences between loud and soft.
The Fixed setting causes all notes to be transmitted at a velocity value of 64. When
used in conjunction with the Velocity parameter (see above), it’s possible to set any
fixed velocity value.
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•

Gate Time: The term gate time stems from analog synthesizers, and refers to the time
between pressing and releasing a key. This parameter affects the absolute note duration
or length, which can be different from the musical note value. The practical effect is
to make notes in the region more staccato or legato. The parameter range is related to
the original note lengths. Fix produces extreme staccato. Values below 100% shorten
the notes. Values above 100% lengthen the notes. The “legato” setting produces a
completely legato effect for all notes, no matter what their original lengths, eliminating
all space between notes in the affected region.

•

Clip Length: This function lets you alter the length of the last notes in a region directly
from the Tracks area, by adjusting the length of the MIDI region. When turned on, any
notes sounding when the region ends are abruptly cut off. When turned off, notes are
played to their normal end point, regardless of where the region ends.

•

Score: This function prevents the score display of particular regions, such as those that
only contain MIDI events that can’t be displayed in the score. When set to Hide, the
MIDI region is not displayed in the score.

•

Q-Velocity: This parameter (expressed as a percentage) determines the amount that the
velocity values of quantized notes are affected by the velocity values of a template MIDI
region. At a value of 0%, the notes retain their original velocity. At 100%, they adopt the
velocity values of the template. Negative values alter the velocity, making the deviation
from the template even greater.

•

Q-Length: This parameter (also expressed as a percentage value) determines how the
lengths of quantized notes are affected by the equivalent note lengths (notes at the
same position) of a template MIDI region. A value of 0% has no effect, while at 100%,
the notes adopt the exact note lengths of the template region. Negative values alter
note lengths further, resulting in a more significant deviation from the template.

•

Q-Flam: Notes with the same time position (chords) are spread out by this parameter.
Positive values produce an ascending (upward) arpeggio; negative values a descending
(downward) arpeggio. The position of the first note (either the bottom or top note,
assuming all notes start at the same position) in the arpeggio is unaltered.
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•

Q-Range: Defines which notes are quantized based on their proximity to quantization
grid positions. At the default value of 0, every note is quantized. At positive Q-Range
values, only notes outside the set range (that is, farther away from the grid position)
are quantized, and notes in the range keep their original position. At negative Q-Range
values, only notes in the set range are quantized, and notes outside the range remain
unchanged. The amount by which notes shift toward the grid positions depends on the
Q-Strength setting.
For example, with Q-Range set to 20 ticks and Q-Strength to 50%, only notes that
are more than 20 ticks off are quantized. Those notes are quantized by 50%, which
improves the timing without making the performance sound mechanical.

•

Q-Strength: This percentage value determines how far a note is shifted toward the
nearest grid position. 100% results in full quantization; 0% leaves the note at its
recorded position.

Apply MIDI region parameters permanently

You can apply the MIDI region parameter settings of all selected MIDI regions
and folders with the Functions > MIDI Region Parameters > Apply All Parameters
Permanently command.
This means that all settings are actually written as data, and playback parameters revert
to normal values. The audible result remains the same. The Loop parameter and advanced
quantization parameters (Q-Velocity, Q-Length, Q-Flam, Q-Range, and Q-Strength) aren’t
affected. However, use this carefully as you lose the ability to change your mind about MIDI
region edits.

Apply MIDI region parameters except Channel and Delay

Like the Merge function and the Glue tool, the Apply All Parameters Permanently function
intelligently handles stored MIDI channel numbers. If all stored events have the same MIDI
channel number, the channel is changed to that of the instrument assigned to the current
track. If the events are on different channels, Logic Pro asks whether you want to convert
the event channels.
The following options are also available in the Functions > MIDI Region Parameters menu:
•

Apply All except Channel: Leaves the stored channel number untouched.

•

Apply All except Channel & Delay: Leaves the stored channel number and Delay
parameters untouched.

If the playback instrument has a channel setting of All, or if you’re dealing with a
completely different type of Environment object (a channel splitter used as A-Playback,
for example), the stored MIDI channel numbers are also unaffected by the usual Apply All
Parameters Permanently function.
Note: If you’re editing MIDI regions that appear as notation on a polyphonic staff style,
you should use use the Apply All except Channel function, as the event channel is used to
assign notes to individual polyphonic voices in the Score Editor.

Logic Pro User Guide

389

Logic Pro MIDI quantization types

For MIDI regions, there are two types of quantization: Classic Quantize and Smart Quantize.
•

Classic Quantize quantizes MIDI notes to the nearest beat, using the current Quantize
setting and any advanced Quantize parameters.

•

Smart Quantize works similarly to Flex Time for audio regions. MIDI events near
grid positions (defined by the Q-Range setting) are analyzed. Based on a combined
weighting of proximity to the target grid position and velocity, a reference point (”center
of gravity”) is set for each group, and moved to the target grid positions. All (nearby)
MIDI events move proportionally to the reference point. How far each event moves is
determined by the Q-Strength setting. Unlike Classic Quantize, all MIDI events keep
their original order, similar to an audio region edited using Flex Time. This includes not
only notes but all MIDI data types (such as Pitch Bend and Control Change events).

In many cases, Smart Quantize can produce more natural sounding results than Classic
quantization. For example, in a MIDI piano performance, the notes of quickly arpeggiated
chords keep their relative positions, as do sustain pedal (on/off) events. Another useful
situation is in MIDI drum performances that need some quantizing, but where classic
quantization would distort rolls, flams, and other notes not played strictly on the beat (and
also possibly the relative position of Hi-Hat on/off events). In both cases, Smart Quantize
keeps the relative position of note on, note off, and CC events.

Choose the MIDI quantization type
•

In the Logic Pro Region inspector, click the Quantize label, then choose a quantization
type from the pop-up menu.

Logic Pro Quantize parameter values

You can quantize selected audio or MIDI regions (including a mixed region selection) using
the Quantize parameter in the Region inspector. This parameter determines the division of
the quantization grid.

Important: The Quantize parameter is non-destructive. It adjusts the playback positions of
notes in MIDI regions when Logic Pro is in playback or record mode. The original positions
are kept in the regions, so you can go back to the original timing.
The values of the Quantize parameter in the Region inspector are grouped in the following
categories:
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•

No quantization: The off setting plays the notes at the finest possible timing
resolution: 1/3840 note, which is unquantized playback, for practical purposes.

•

Normal quantization: The 1/1-Note, 1/2-Note, 1/4-Note, 1/8-Note, 1/16-Note, 1/32-Note,
and 1/64-Note settings quantize the MIDI region to the equivalent note value.
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•

Triplet quantization: The Triplet settings quantize the MIDI region to triplet note values.
The equivalent values are shown in parenthesis.

•

Swing quantization: The 1/16 Swing A-F settings delay the position of every second
point in the quantization grid by a fixed percentage. You can also manually alter the
swing factor of any Quantize value.

•

Odd quantization: The 5-Tuplet/4 is quarter quintuplets (1 bar = 5 beats), 5-Tuplet/8
is eighth quintuplets (1 bar = 10 beats), 7-Tuplet is septuplets (1 bar = 7 beats), and
9-Tuplet setting denotes novetuplets (1 bar = 9 beats).

•

Mixed quantization: These combine ‘straight’ and tuplet values of 1/16 and 1/18. Mixed
quantization always applies to both note values, and requires greater playing precision
when recording.

The Swing settings delay the position of every second point in the quantization grid by a
fixed percentage, as follows:
Quantize setting

Swing percentage

Swing F

71%

Swing E

66%

Swing D

62%

Swing C

58%

Swing B

54%

Swing A

50%

Logic Pro advanced quantization parameters

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can quantize regions with greater precision using the advanced quantization
parameters in the Region inspector. Using the advanced parameters, you can apply a
swing or other quantize feel to MIDI regions. Not all advanced quantization parameters are
available for audio regions.
Advanced quantization parameters in the Region inspector include the following:
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In the Region inspector, the Q-Swing field is located below the Quantize pop-up menu.
The other advanced quantization parameters are available by clicking the More disclosure
arrow. They can be applied to any quantization value (except “off”).
•

Q-Swing: Alters the position of every second point in the current quantization grid.
Values over 50% delay the beats; values under 50% pre-delay (advance) them. The
most practical settings are between 50% and 75%, which give a swing feel to strictly
quantized (or tightly played) regions.

•

Q-Strength: Determines how far a note or transient marker is shifted toward the nearest
grid position. A value of 100% results in full quantization, and 0% leaves the note or
transient marker at its recorded position.

•

Q-Range: Defines which notes are quantized based on their proximity to quantization
grid positions. At the default value of 0, every note is quantized. At positive Q-Range
values, only notes outside the set range (that is, farther away from the grid position)
are quantized, and notes in the range keep their original position. At negative Q-Range
values, only notes in the set range are quantized, and notes outside the range remain
unchanged. The amount by which notes shift toward the grid positions depends on the
Q-Strength setting.
For example, with Q-Range set to 20 ticks and Q-Strength to 50%, only notes that
are more than 20 ticks off are quantized. Those notes are quantized by 50%, which
improves the timing without making the performance sound mechanical.
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•

Q-Flam: Spreads out notes with the same time position, such as chords. Positive values
produce an ascending (upward) arpeggio, negative values a descending (downward)
arpeggio. The position of the first note (either the bottom or top note) is unaltered.

•

Q-Velocity: Determines how much the velocity values of quantized notes are affected
by the velocity values of a template MIDI region. At a value of 0%, the notes retain their
original velocity. At 100%, they adopt the velocity values of the template. Negative
values alter the velocity, making the deviation from the template even greater.

•

Q-Length: Determines how the lengths of quantized notes are affected by the
equivalent note lengths (notes at the same position) of a template MIDI region. A
value of 0% has no effect, whereas at 100% the notes adopt the exact note lengths
of the template region. Negative values alter note lengths further, resulting in a more
significant deviation from the template.
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Edit audio regions in the Audio Track Editor

The Audio Track Editor in Logic Pro

The Audio Track Editor shows a close-up view of part of an audio track in the Tracks area,
displaying the audio waveform of the regions on the track in a time grid.

In the Audio Track Editor, you can move and trim audio regions, split and join them, and
edit them in other ways. You can scroll and zoom the Audio Track Editor, and zoom the
amplitude of the waveforms in audio regions. Edits you make in the Audio Track Editor are
non-destructive, so you can always return to your original recordings.
You can also quantize and edit the pitch of audio material in the Audio Track Editor using
Flex Pitch. For more information, see Edit pitch and timing with Flex Pitch.
You can also add audio effects to selected audio regions in the Audio Track Editor using
selection-based processing.See Use selection-based processing to learn more.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
a new “File” tab appears in the Editors pane. This is an advanced audio editor called the
Audio File Editor. Edits made in the Audio File Editor are destructive, meaning that the
original recording is permanently changed. The Audio File Editor has a different set of
functions than the Audio Track Editor, allowing you to reverse and invert audio, remove DC
offset, edit transients, and more. See Overview of the Logic Pro Audio File Editor interface
to learn about the Audio File Editor.
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Open the Audio Track Editor

In the Logic Pro Audio Track Editor, do one of the following:
•

Select an audio track in the Tracks area, then click the Editors button

.

•

Select an audio track in the Tracks area, then choose View > Show Editor.

•

Double-click an audio region to open it in the Audio Track Editor.
The Audio Track Editor opens below the Tracks area. Along the top of the Audio Track
Editor is a ruler showing time divisions, and a menu bar with local menus, tools, and
other controls. The main area of the Audio Track Editor shows the audio waveform of
the regions in the selected audio track.

Vertically resize the Audio Track Editor
•

In the Logic Pro Audio Track Editor, place the pointer in the bar at the top of the Audio
Track Editor, and drag upward.
Drag downward to make the Audio Track Editor smaller again.

Zoom the Audio Track Editor horizontally
•

In the Logic Pro Audio Track Editor, drag the Zoom slider in the Audio Track Editor menu
bar left or right.

Zoom audio waveforms
•

In the Logic Pro Audio Track Editor, click-hold the Waveform Zoom button in the Audio
Track Editor menu bar, then drag the slider vertically to zoom the amplitude in or out.

Close the Audio Track Editor
•

In the Logic Pro Audio Track Editor, click the Editors button in the control bar.

Select regions in the Logic Pro Audio Track Editor

You can select one or more regions in the Audio Track Editor, select regions meeting certain
criteria, and select sections inside regions using the Marquee Tool. The cursor automatically
changes into the Marquee Tool in the lower half of the Audio Track Editor, except for the
lower-right and lower-left corner of regions, when the cursor changes to a trim pointer.

Select a region
•

In the Logic Pro Audio Track Editor, click a region in the Audio Track Editor.

Select multiple regions

In the Logic Pro Audio Track Editor, do one of the following:
•

Hold down Shift as you click the regions.

•

Drag across the regions.

Select the previous or next region on the track

In the Logic Pro Audio Track Editor, do one of the following:
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•

To select the previous region: Choose Edit > Select > Previous Region.

•

To select the next region: Choose Edit > Select > Next Region.
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Select all following regions on the track
•

In Logic Pro, choose Edit > Select > All Following of Same Track.

Select all regions on the track
•

In the Logic Pro Audio Track Editor, click the track header in the Tracks area.

Select content inside regions using the Marquee Tool
•

In the lower half of the Logic Pro Audio Track Editor, drag across the material that you
wish to select with the Marquee Tool.

Cut, copy and paste in the Logic Pro Audio
Track Editor

You can cut or copy an audio region or region segment in the Audio Track Editor and paste
the copy at a different time position.

Cut an audio region
•

In the Logic Pro Audio Track Editor, select the region or region segment with the
Marquee Tool, then choose Edit > Cut (or press Delete).

Copy an audio region

In the Logic Pro Audio Track Editor, do one of the following:
•

Option-drag the region or region segment.
When you Option-drag an audio region so that it overlaps another region, the
overlapped part of the region is cut.

•

Select the region, then choose Edit > Copy.

Paste an audio region
•

In the Logic Pro Audio Track Editor, place the playhead at the point where you want to
paste the region, then choose Edit > Paste.

Move regions in the Logic Pro Audio Track Editor

You can move an audio region or region segment in the Audio Track Editor so that it plays
back in a different time position.

Move an audio region
•

In the Logic Pro Audio Track Editor, drag the region or region segment horizontally.

When you move an audio region so that it overlaps another region, the overlapped part of
the region is cut.
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Trim regions in the Logic Pro Audio Track Editor

You can trim an audio region in the Audio Track Editor to remove part of the beginning or
end of the region.

Trim an audio region

1. In the Logic Pro Audio Track Editor, place the pointer over the lower-left or lower-right
edge of the region.
The pointer changes to a trim pointer.
2. Drag the pointer to remove the part you want to trim. As you drag, the help tag shows
the region length and the amount by which it is trimmed.

Split and join regions in the Logic Pro Audio
Track Editor

You can split an audio region into segments in the Audio Track Editor, and move the
segments so that they play back at a different point in time.
You can also join regions or region segments from audio recordings into a single region.
Regions from audio Apple Loops, and audio regions that have been transposed can’t
be joined.
To be joined, audio regions must be adjacent to each other on the same track. If you join
segments of compressed audio files, the files are converted, by default, to PCM format (the
file type is set in the Audio > General preferences pane).
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Split an audio region
•

In the Logic Pro Audio Track Editor, select the Scissors tool, then click the point where
you want to split the region.

You can scrub regions to find the point where you want to cut by dragging across the
regions with the Scissors tool. You can also split regions by selecting them in the Tracks
area, then selecting Edit > Split > Regions at Playhead.
Before moving or deleting a segment of a split audio region, click the region to select it.

Join regions or region segments

1. In the Logic Pro Audio Track Editor, select the regions or region segments.
2. Do one of the following:
•

Choose Edit > Bounce and Join > Join.

•

Select the Glue tool, then Shift-click the selected regions.

Snap to zero in the Logic Pro Audio Track Editor

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can snap edits you make in the Audio Track Editor to zero crossings. Making edits,
such as trimming or splitting audio regions, snap to zero crossings helps ensure that no
“click” or other noise is produced at the edit position.

Set edits to snap to zero crossings
•
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In the Logic Pro Audio Track Editor, choose Snap Edits to Zero Crossings from the Snap
pop-up menu in the Tracks area menu bar.
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Delete regions in the Logic Pro Audio Track Editor
You can delete audio regions in the Audio Track Editor. When you delete a region,
it’s also deleted from the Tracks area, and from the project (but not from the Project
Audio Browser).

Delete an audio region

1. In the Logic Pro Audio Track Editor, select the region or regions you want to delete in
the Audio Track Editor.
2. Choose Edit > Delete (or press Delete).

Use Flex Time and Pitch in the Audio Track Editor

You can adjust the timing and pitch of audio regions in the Audio Track Editor using Flex
Time and Pitch. Using the Audio Track Editor for editing the timing and pitch of audio
allows you to keep Flex mode off in the Tracks area, which is useful when you want the
Tracks area to show automation, for example. In addition, the Audio Track Editor offers two
tools for Flex Pitch, the Volume tool and Vibrato tool, that aren’t available in the Tracks
area. These tools are described in Edit the pitch of audio in the Audio Track Editor.
To learn more about using Flex Time and Flex Pitch, see Overview of Flex Time and Pitch.

Automation in the Logic Pro Audio Track Editor

You can create and edit automation data directly in the Audio Track Editor. To learn more
about using Automation, see Overview of automation.

Show automation in the Audio Track Editor
•

In the Logic Pro Audio Track Editor, click the Show/Hide Automation button
Audio Track Editor menu bar.

in the

An Automation button, an Automation Parameter pop-up menu, and an Automation
Mode pop-up menu appear at the bottom of the Audio Track Editor inspector. The
colors of the text and background of the selected Automation Mode pop-up menu item
display the current state of automation and if there is automation data present:
•

White text on a gray background = automation is off

•

Dark green text on a gray background = automation is on but there is no existing
automation data to display

•

Bright green text on a green background = automation is on and there is existing
automation data to display

Any existing automation is displayed in the Automation Lane under the main editor
window.
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Edit MIDI regions in the Piano Roll Editor

Overview of the Piano Roll Editor in Logic Pro

The Piano Roll Editor shows the notes in a MIDI region as colored bars in a time grid.
Horizontal lines show the time position, while vertical lines indicate pitch. A keyboard along
the left edge of the Piano Roll Editor provides a reference for the pitches of notes. The info
display after the tool pop-up menus in the Piano Roll Editor menu bar shows the note name
and time position under the pointer.
Some software instruments—most often, drum and percussion instruments—provide names
for the MIDI notes (for example, if the MIDI note G#2 plays a cowbell, the instrument will
display “Cowbell” next to the keyboard at the left edge of the Piano Roll Editor. When
displayed MIDI regions are played back by an instrument that provides note names, you
have the option to show only those note names (called “Drum Names” in Logic Pro), in
which case the keyboard is replaced by a table showing those note names.
You can also switch to Collapse Mode view, which shows only those lanes in the Piano Roll
Editor that are used by notes in the MIDI regions you’ve selected.
The Piano Roll Editor can display the MIDI regions on a track, in a folder, or on multiple
tracks in the project. See View multiple MIDI regions.
You can record notes into the Piano Roll Editor directly when the MIDI In button is activated
using step recording techniques. See Use step input recording. Make sure the MIDI Out
button is activated so that you can hear notes that you add, select, or click.

You can open the Piano Roll Editor as a pane in the main window, or as a separate,
resizable window.
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Open the Piano Roll Editor

In Logic Pro, do one of the following:
•

Select a software instrument (or external MIDI instrument) track or a MIDI region, then
click the Editors button .

•

Select a software instrument (or external MIDI instrument) track or a MIDI region, then
choose View > Show Editors.

•

Double-click a MIDI region (if Piano Roll is chosen from the Logic Pro > Preferences >
General > Editing > Double-Clicking a MIDI Region Opens pop-up menu).
The Piano Roll Editor opens below the Tracks area. On the left are controls for
quantizing the timing and pitch of MIDI regions, adjusting their pitch, and editing the
velocity of MIDI notes. Along the top of the Piano Roll Editor is a ruler showing time
divisions, and a menu bar with local menus, tools, and other controls. The header
shows the name of the selected region (or the number of regions, if more than one is
selected).

Switch the Piano Roll Editor to show only drum names
•

In Logic Pro, choose View > Drum Names in the Piano Roll Editor menu bar.
The keyboard disappears and only the note numbers and drum names are shown.

Switch the Piano Roll Editor to Collapse Mode view
•

In Logic Pro, click the Collapse Mode button in the Piano Roll Editor menu bar.

Open the Piano Roll Editor as a separate window
In Logic Pro, do one of the following:
•

Choose Window > Open Piano Roll (or press Command-4).

•

Drag the Piano Roll Editor by its title out of the main window.

Vertically resize the Piano Roll Editor
•

In Logic Pro, place the pointer in the bar at the top of the Editors window, then drag
upward.
Drag downward to make the editor smaller again.
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Hide or show the local Piano Roll Editor inspector
•

To hide the Piano Roll Editor inspector: In Logic Pro, choose Hide Local Inspector from
the Piano Roll Editor View menu.

•

To show the Piano Roll Editor inspector: In Logic Pro, choose Show Local inspector from
the Piano Roll Editor View menu.

Set the Link mode for the Piano Roll Editor

You can turn on Content Link for the Piano Roll Editor, so that it always displays the
contents of the currently selected MIDI region. Same Level Link is not available for the
Piano Roll Editor. In Logic Pro, do one of the following:
•

To set the Link mode to Content: Click the Link button in the Piano Roll Editor menu bar.

•

To set the Link mode to Off: Click the Link button in the Piano Roll Editor menu bar again.

To learn more about using Link modes, see Control window relationships.

Change the background for the Piano Roll Editor

By default, the Piano Roll Editor shows notes on a dark background. You can change the
background in Display preferences if you prefer a lighter background.
1. Choose Logic Pro > Preferences > Display.
2. Click Editors, then select the Piano Roll: Bright background checkbox.

Close the Piano Roll Editor
•

In Logic Pro, click the Editors button

.

Add and edit notes
Add notes in the Piano Roll Editor in Logic Pro

You can add notes to a MIDI region in the Piano Roll Editor using either the Pencil tool or
the Brush tool. You can also add notes with your music or computer keyboard. For more
information, see Use step input recording in.
Tip: The info display in the Piano Roll Editor menu bar shows the note name and time
position under the pointer. Watch the info display as you add notes with the pointer to
ensure that you add them at the correct position.

Add a note

In the Logic Pro Piano Roll Editor, do one of the following:
•

Control-click the Piano Roll Editor background, then choose Create Note from the
shortcut menu.

•

Select the Pencil tool, then click the start position for the note.
Press and hold the Control and Shift keys as you click to add a note at the exact click
position, regardless of the current Snap setting.

•
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Click the MIDI In button if it is not already active (red), and use your music or computer
keyboard to enter notes using step input recording methods. See Use step input
recording in.
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The newly created note’s length, velocity, and channel match that of the previously created
or edited note event. When you start a new project, the default values are a length of 240
ticks, a velocity of 80, and MIDI channel 1.
Note: When you create a note using the Pencil tool, you can edit the length of notes on the
fly. Simply press and hold the mouse button and drag left or right.

Add a note of a specific length
•

In the Logic Pro Piano Roll Editor, select the Pencil tool, click the start position for the
note, then drag right or left.

A help tag shows the length change in real time.
You can make finer adjustments by pressing and holding Option or Control while altering
the note length (see Snap items to the grid).

Add notes based on defined time and pitch settings

In the Logic Pro Piano Roll Editor, do either of the following:
•

Select the Brush tool, then drag right or left.
The repetition rate of added notes is based on the current Time Quantize settings, and
the pitch based on the current value Scale Quantize settings.

•

Select the Brush tool, drag right or left, then press and release Shift while dragging.
This restricts all notes to the same pitch.

Define a brush pattern

1. In the Logic Pro Piano Roll Editor, select the notes of a short musical phrase you want to
use as a pattern.
2. Select the Brush tool, then Control-click the selected notes with the Brush tool.
3. Choose Define Brush Pattern from the shortcut menu.
After you define a brush pattern, you can “paint” the pattern using the Brush tool. The
repetition rate of the pattern is based on the current Time Quantize settings. To restrict the
pattern to notes of a specified scale adjust the Scale Quantize settings.

Duplicate an existing note at another position or pitch

1. In the Logic Pro Piano Roll Editor, do one of the following:
•

Control-click the original note, then choose Define as Default Note from the shortcut
menu.

•

Click the original note with the Pencil tool.

Note: Editing an existing note also defines it as the default note.
2. Click a position in the Piano Roll Editor background with the Pencil tool.
The new note’s length, velocity, and channel are the same as the default note.
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Select notes in the Piano Roll Editor in Logic Pro

You must select note events before you can edit them. You can select notes by clicking,
Shift-clicking, dragging to make a marquee selection, and using the keyboard at the left
edge of the Piano Roll Editor.

Select a note
•

In the Logic Pro Piano Roll Editor, click the note.
Note: If you select the macOS preference “All controls” for Full Keyboard Access in
System Preferences > Keyboard > Shortcuts, you can use the Right and Left Arrow keys
to select a note.

Select a range of notes
•

In the Logic Pro Piano Roll Editor, Shift-click the notes, or drag to enclose them.

The Piano Roll Editor header shows the number of selected notes, along with the region
name. When multiple overlapping notes are selected, the Piano Roll Editor header shows
the chord name. When no notes are selected, the header shows the name of the most
recently selected MIDI region, or the number of regions selected.

Select all notes of the same pitch in a MIDI region
•

In Logic Pro, click the key on the keyboard at the left edge of the Piano Roll Editor.
To select all notes for a range of pitches, Shift-click or drag over a range of keys on
the keyboard.

This is similar to selecting all regions on a track by clicking the track name.

Select the previous or next event in the region

In the Logic Pro Piano Roll Editor, do one of the following:
•

To select the previous event: Choose Edit > Select > Previous Event.

•

To select the next event: Choose Edit > Select > Next Event.

Select all following events on the track
•

In the Logic Pro Piano Roll Editor, choose Edit > Select > All Following.

Select all regions on the track
•
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In Logic Pro, click the track header in the Tracks area.
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Snap to grid in the Piano Roll Editor in Logic Pro

The Piano Roll Editor has a grid, similar to the Tracks area grid.
When Enable Complete
Features is selected in Logic Pro > Preferences > Advanced, you can set the Snap value for
the Piano Roll grid, independent from the Snap value for the Tracks area grid. The Piano
Roll Editor Snap pop-up menu contains additional values including specific note values.
The Snap pop-up menu setting applies to moving, copying, cutting, and resizing note
events; moving, adding, and resizing markers; and setting the cycle area. You can snap
notes and other items using either relative or absolute positioning, and can temporarily
override the snap grid, allowing finer edits and adjustments.

Set the Snap value for the Piano Roll Editor grid
•

In Logic Pro, choose a value from the Snap pop-up menu in the Piano Roll Editor menu
bar:

•

Smart: Edit operations snap to the nearest bar, beat, sub-beat, and so on, depending
on the current ruler division value and the zoom level.

•

Bar: Edit operations snap to the nearest bar.

•

Beat: Edit operations snap to the nearest beat in a bar.

•

Division: Edit operations snap to the nearest division (this is the time signature
shown in the LCD and ruler).

•

Ticks: Edit operations snap to the nearest clock tick (1/3840 of a beat).

•

Frames: Edit operations snap to the nearest SMPTE frame.

•

Note values: Choose a note value between 1/1 (whole note) and 1/64–triplet.

By default, the Snap functionality is relative, so that when you move notes or other items,
they retain their relative distance from their original position. You can override relative
positioning with the Snap Notes to Absolute Value option.
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Snap to an absolute position
•

In Logic Pro, choose Snap Notes to Absolute Value from the Snap pop-up menu.

When Snap Notes to Absolute Value is active, moving an event moves it to the exact grid
position, not a relative position. For example, from position 1.2.1.16 to around bar 2 results
in it being snapped to the beginning of the bar (position 2.1.1.1), rather than its relative
position (2.2.1.16). Absolute positioning is useful when you want notes to fall exactly on the
beat, but it can result in a more mechanical rhythmic feel.

Override the snap grid

In Logic Pro, do one of the following:
•

Press and hold Control while performing the editing operation.
The division value chosen in the LCD (1/16, for example) determines the editing grid
scale.

•

Press and hold Control-Shift while performing the editing operation.
The editing grid switches to ticks.

For more information about snapping items to the grid, see Snap items to the grid.

Move notes in the Piano Roll Editor in Logic Pro

You can move selected notes in the Piano Roll Editor to change their time position. When
you move notes, they move according to the current Snap value for the Piano Roll Editor.
When you drag a note, a help tag shows its current time position and pitch. Its deviation
from the starting pitch is shown as a positive or negative value.
You can also move notes using an Event Float window. See Use the Event Float window.
Tip: The info display in the Piano Roll Editor menu bar shows the note name and time
position under the pointer. Watch the info display as you move notes to ensure that you
move them to the correct position.

Move notes
•

In the Logic Pro Piano Roll Editor, select one or more notes, then drag left or right.

Move notes in finer increments

1. In the Logic Pro Piano Roll Editor, select the notes.
2. Begin to drag the notes.
3. Press and hold Control and continue dragging the note to the desired position.
The drag resolution depends on the current Snap value and zoom level (see Snap items
to the grid).
Alternatively, you can press Control-Shift as you drag to move the notes in tick steps,
overriding the Snap value.

Logic Pro User Guide

405

Limit dragging to one direction

1. Choose Logic Pro > Preferences > General > Editing.
2. Select the Limit Dragging to One Direction In Piano Roll and Score checkbox.

This option helps you avoid accidentally transposing notes when moving them horizontally,
or changing their time position when moving them vertically. The initial direction—vertical
or horizontal—restricts movement to this plane while the mouse button is pressed. Release
the mouse button and click the event to move in the other direction.

Move notes using key commands

In Logic Pro, use any of the following key commands:
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•

Nudge Region/Event Position Right by SMPTE Frame

•

Nudge Region/Event Position Left by SMPTE Frame

•

Nudge Region/Event Position Right by 1/2 SMPTE Frame

•

Nudge Region/Event Position Left by 1/2 SMPTE Frame

•

Nudge Region/Event Position Right by 5 SMPTE Frames

•

Nudge Region/Event Position Left by 5 SMPTE Frames

•

Nudge Region/Event Position Right by SMPTE Bit

•

Nudge Region/Event Position Left by SMPTE Bit

•

Nudge Region/Event Position Right by Tick

•

Nudge Region/Event Position Left by Tick

•

Nudge Region/Event Position Right by Division

•

Nudge Region/Event Position Left by Division

•

Nudge Region/Event Position Right by Beat

•

Nudge Region/Event Position Left by Beat

•

Nudge Region/Event Position Right by Bar
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•

Nudge Region/Event Position Left by Bar

•

Nudge Region/Event Position Right by Nudge Value

•

Nudge Region/Event Position Left by Nudge Value

•

Nudge Region/Event Position Right by Sample

•

Nudge Region/Event Position Left by Sample

•

Nudge Region/Event Position Right by 1 ms

•

Nudge Region/Event Position Left by 1 ms

•

Nudge Region/Event Position Right by 10 ms

•

Nudge Region/Event Position Left by 10 ms

The selected events are shifted one step right or left, by the unit defined in the particular
key command.

Move other MIDI data along with notes
•

In Logic Pro, choose Functions > Include Non-Note MIDI Events setting from the Piano
Roll Editor menu bar to tie other data (such as pitch-bend, modulation, aftertouch, or
poly aftertouch) in a region to the region’s notes.

Copy notes in the Piano Roll Editor in Logic Pro

There are a number of ways to copy or move notes in the Piano Roll Editor. In addition to
Option-dragging or using the Copy and Paste menu commands, there are advanced Copy
and Move operations such as directly swapping events, or merging a group of notes from
one section of a region to the same region, or another region.

Copy notes

In the Logic Pro Piano Roll Editor, do one of the following:
•

Option-drag notes to a new position.

Tip: You can Option-drag notes between two Piano Roll Editor windows (showing
different regions, for example), or even between the Piano Roll Editor windows of
different projects.
•
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Use any of the following Clipboard commands:
•

Edit > Cut (or Command-X) to move notes to the Clipboard.

•

Edit > Copy (or Command-C) to copy notes to the Clipboard.

•

Edit > Paste (or Command-V) to paste notes at the current playhead position, at
their original pitch.
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Copy or move a range of MIDI events

1. In Logic Pro, define the area that you want to move or copy using the left and right
locators.
2. If you want to copy or move the events to another track, select the track you want to
copy the events to.
3. Set the playhead to the insert position.
4. Choose Edit > Copy MIDI Events.
5. In the Copy MIDI Events dialog, choose settings, then click OK.

•
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Mode pop-up menu: Choose one of the following options:
•

Copy Merge: The copied data is blended with any data present at the destination
position.

•

Copy Replace: The data at the destination position is deleted, and replaced with
the copied data.

•

Copy Insert: All data at the destination position is moved to the right, by the
length of the source area.

•

Move Merge, Move Replace, Move Insert: These three modes work similarly to the
Copy modes, but actually move the selected events, removing them from their
original positions.

•

Rotate: The source events are moved to the destination position. The data that was
previously at the destination position, and the data that falls between the source and
destination positions, are all moved toward the source position. This rotates the data
around a central pivot point (halfway between the source and destination positions).

•

Direct Swap: Exchanges the source data with data of the same length, starting at
the target position. This allows you to swap the notes in bar 1 of a four-bar MIDI
region with the notes in bar 3 of the same region, for example.

•

Remove: Removes the MIDI data from the source region, but leaves the region at
its original position.

•

Left Locator and Right Locator: Allow you to edit the source area you defined with
the left and right locators.

•

Destination: Defines the destination position independently of the playhead position.

•

Number of Copies: Defines the number of copies.

•

Create new Region: When selected, a new MIDI region is created at the destination
position. It contains the copied (or moved) events.
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Change pitch in the Piano Roll Editor in Logic Pro

You can change the pitch of selected notes in the Piano Roll Editor. Changing the pitch lets
you transpose parts to a different key or harmonize a melodic line.
When you drag a note, its current position and pitch are shown in a help tag. The deviation
from the starting pitch is shown in semitone steps at the bottom left of the help tag. The
starting pitch appears in the info display of the Piano Roll Editor.

Change the pitch of notes using the Pointer tool
•

In the Logic Pro Piano Roll Editor, drag notes up or down to a new pitch.
You can use the keyboard at the left edge of the Piano Roll Editor as a guide when
dragging notes.

Change the pitch of notes using Musical Typing or a music keyboard

1. In the Logic Pro Piano Roll Editor, double-click the MIDI In button if it is not engaged, or
Option-click the MIDI In button if it is already active.
The MIDI In button changes to a white outline against a red background to indicate you
can use it to edit notes.
2. Select one or more notes.
3. Play a note on your Musical Typing or music keyboard.
The pitch of the selected notes changes to the played note.

Resize notes in the Piano Roll Editor in Logic Pro

You can resize notes in the Piano Roll Editor to change their length (duration). Notes can
be resized from either their start or end point using the Pointer, Finger, or Pencil tool.
There are a number of commands in the Edit > Trim submenu in the Piano Roll Editor menu
bar to change the length of selected notes, in relation to notes surrounding or overlapping
them. They can be very useful for tidying up the start and end points of notes.

Resize a note
•

In the Logic Pro Piano Roll Editor, drag either the left or right edge of the note
horizontally, using the Pointer, Finger, or Pencil tool.

A help tag appears while you drag, showing the length of the note.
Tip: It can sometimes be difficult to grab the edge of very short notes. You can use the
Finger tool, which allows you to grab notes anywhere to alter their length.
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Resize multiple notes
•

In the Logic Pro Piano Roll Editor, select the notes, then drag either edge of one of the
selected notes.
The relative differences between the lengths of the selected notes are maintained.

Set the same end point for selected notes
•

In the Logic Pro Piano Roll Editor, press and hold Shift while altering the length of one of
the selected notes.

Make selected notes the same length
•

In the Logic Pro Piano Roll Editor, press and hold Option-Shift while dragging one of
several selected notes.

Set the start or end point of notes to the playhead position

In the Logic Pro Piano Roll Editor, use one of the following key commands:
•

Set Region/Event/Marquee Start to Playhead Position

•

Set Region/Event/Marquee End to Playhead Position

Remove note overlaps

1. In the Logic Pro Piano Roll Editor, select the notes you want to edit.
2. Choose one of the following commands in the Edit > Trim submenu in the Piano Roll
Editor menu bar:
•

Note to Remove Overlaps with Selected

•

Note to Remove Overlaps with Adjacent

•

Note to Remove Overlaps with Repeated

Make notes legato

1. In the Logic Pro Piano Roll Editor, select the notes you want to edit.
2. Choose one of the following commands in the Edit > Trim submenu in the Piano Roll
Editor menu bar:
•

Note Start to Playhead

•

Note End to Playhead

•

Note End to Selected Notes

•

Note End to Following Notes

Convert sustain pedal events to note lengths
•

In Logic Pro, choose Functions > Convert Sustain Pedal to Note Length in the Piano Roll
Editor menu bar.

All sustain pedal events (controller #64) used on selected note events are analyzed, and
the note events are increased in length. This increase matches the controller #64 (sustain
pedal) off message position.
The pedal events (controller #64 on and off) are erased after use of this command.
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Edit velocity in the Piano Roll Editor in Logic Pro

Each note in the Piano Roll Editor displays a horizontal line. The length of the line relative
to the overall length of the note shows the note’s velocity. Velocity indicates how hard
the key was struck when the note was played, which usually corresponds to the note’s
loudness (the MIDI velocity range is from 0–127, with 127 being the loudest). Velocity can
also control other synthesizer parameters, such as filter resonance or cutoff, alone or in
conjunction with volume level.
You can also display velocity using different colors, by choosing View > Set Note Color >
By Velocity from the Piano Roll Editor menu bar. When this command is chosen, higher
velocity notes appear in warmer colors, and lower velocity notes appear in cooler colors.

Color coding makes it easy to see the velocity of individual notes, and to see the overall
range of velocities in a MIDI region. As you change the velocity of the notes, their color
changes in real time.
To learn more about color assignments in the Piano Roll Editor, see Change note color.
Note: You can also edit note velocity in the Automation/MIDI area under the note display
grid. See Automation/MIDI area in the Piano Roll Editor.

Edit the velocity of notes using the pointer

In the Logic Pro Piano Roll Editor, do one of the following:
•

Select one or more notes, then drag the Velocity slider in the Piano Roll Editor header
left or right.

•

Drag over a note vertically with the Velocity tool. You can select the Velocity tool from
the Tool menu, or you can press Control-Command to temporarily change the Pointer to
the Velocity tool.

A help tag showing the note velocity updates as you drag. The line inside the note also
updates to show the velocity change.
If the MIDI Out button in the Piano Roll Editor menu bar is active, the note sounds
as you drag.
When you edit the velocity of multiple notes, the relative differences in their velocity values
are retained. If the velocity value of any of the selected notes reaches the minimum or
maximum value (0 or 127), none of the notes can be adjusted further.
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You can override this behavior by pressing and holding Option while dragging. This allows
you to continue altering the velocity values until the selected note reaches the minimum
or maximum value. By overriding, the velocity relationship of this note to the other notes
is altered.

Edit the velocity of notes using Musical Typing or a music keyboard

1. In the Logic Pro Piano Roll Editor, double-click the MIDI In button if it is not engaged, or
Option-click the MIDI In button if it is already active.
The MIDI In button changes to a white outline against a red background to indicate you
can use it to edit notes.
2. Select one or more notes.
3. Play a note on your Musical Typing or music keyboard.
The velocity of the selected notes changes to that of the played note.

Assign the same velocity value to selected notes
•

In the Logic Pro Piano Roll Editor, press and hold Option-Shift while dragging one of the
notes with the Velocity tool.

Quantize timing in the Piano Roll Editor in Logic Pro

You can quantize, or automatically correct, the timing of individual MIDI notes in the Piano
Roll Editor. This is useful when regions in the track contain the right notes, but are not
perfectly in time with the project. When you quantize the timing, items are adjusted to
the selected note value. You can quantize the timing of regions with drums, single-note
instruments, and chordal or polyphonic instruments.
The Time Quantize controls quantize notes and other items non-destructively, for playback
only. The original timing is never lost, and can be recalled by setting the value to off.

Quantize the timing of notes in a MIDI region

1. In Logic Pro, double-click a region in the software instrument track that you want to
quantize to open it in the Piano Roll Editor.

2. Select the regions you want to quantize, or select individual notes you want to quantize
in a region.
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3. From the Time Quantize pop-up menu, choose the note value you want to use to
quantize the timing of the selected items.
4. To set the degree of quantization, drag the Strength slider left or right.
5. To set the degree of swing, drag the Swing slider left or right.

Quantize note timing with the Quantize tool
•

In the Logic Pro Piano Roll Editor, click a note, or a selected group of notes, with the
Quantize tool.
The notes are quantized to the active Quantize value.

Select and quantize multiple notes
•

In the Logic Pro Piano Roll Editor, drag across notes with the Quantize tool to select
them.
The selected notes are quantized to the active Quantize value.

You can also quantize MIDI regions in the Region inspector. See MIDI region parameters,
Quantize parameter values, and Advanced quantization parameters.

Quantize pitch in the Piano Roll Editor in Logic Pro

You can quantize the pitch of notes in MIDI regions to a particular scale or key. This is
especially useful when you want to reuse a repeating pattern of notes, but transpose them
to a different key.

Quantize the pitch of notes in a MIDI region

1. In the Logic Pro Piano Roll Editor, select the notes you want to quantize.
2. Choose the scale and key from the Scale Quantize pop-up menus.
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Change articulations in the Piano Roll Editor in Logic Pro

If articulations have been recorded along with notes and events in a region, an Articulation
pop-up menu becomes available in the Piano Roll Editor. If you don’t automatically see the
Articulation pop-up menu, you may need to increase the height of the Piano Roll Editor
window. You can also use the shortcut menu to change note articulations. To learn more
about articulations, see Articulation editing overview.

When an articulation has been assigned to a note, the help tag will display the chosen
articulation.

Change articulations using the Articulation pop-up menu
•

In Logic Pro, select one or more notes in the Piano Roll Editor and choose an articulation
from the Articulation pop-up menu.

Note: If you have recorded articulations but the Articulation pop-up menu is not visible in
the Piano Roll Editor, increase the vertical size of the Piano Roll Editor. See vertically resize
the Piano Roll Editor.

Change articulations using the shortcut menu

1. In Logic Pro, select the notes in the Piano Roll Editor.
2. Control-click a selected note, then choose Articulation from the shortcut menu.
3. Choose an articulation from the submenu.
You can also change the color of notes by articulation. See Change note color.
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Lock position in the Piano Roll Editor in Logic Pro

There may be times you want to protect some events in MIDI regions from being moved;
for example, when they are synchronized to visual events in a movie. You may have already
created the music for the scene but then are asked to increase the tempo to match several
cuts of different camera angles in the corridor. Changing the tempo moves the events,
resulting in events being out of sync. Instead, you can lock the events to an absolute
(SMPTE) time position to protect their position and keep them in sync with the tempo.
To lock the time position of events, Enable Complete Features must first be selected in
Logic Pro > Preferences > Advanced.

Lock the position of one or more selected events
•

In Logic Pro, choose Functions > Lock SMPTE Position in the Piano Roll Editor menu bar
(or use the corresponding key command).
This command ensures that events that fall at a particular absolute time
position—1 hour, 3 minutes, 15 seconds, 12 frames, for example—remain at this exact
position regardless of tempo changes.

Unprotect protected events
•

In Logic Pro, choose Functions > Unlock SMPTE Position in the Piano Roll Editor menu
bar (or use the corresponding key command).

Mute notes in the Piano Roll Editor in Logic Pro

You can mute individual notes in the Piano Roll Editor, letting you experiment with different
note choices in a melody, or different chord voicings, for example.

Mute or unmute notes

In the Logic Pro Piano Roll Editor, do one of the following:
•

Click one or more notes with the Mute tool.

•

Select the notes, then click one of the selected notes with the Mute tool.

Muted notes are shown without color.
The Select Muted Regions/Events key command is also available in the Piano Roll Editor.
You can use it to select all muted notes in a MIDI region.

Mute or unmute all notes of a particular pitch
•

In Logic Pro, click a key in the keyboard at the left of the Piano Roll Editor, then click
one of the selected notes with the Mute tool.
This action mutes or unmutes all notes of the clicked pitch in the MIDI region, and is
useful for muting the hi-hats in a MIDI region that is triggering an entire drum kit, for
example. For information about assigning tools, see Assign tools.
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Change colors in the Piano Roll Editor in Logic Pro

You can change the color of notes in the Piano Roll Editor to display note velocity, region
colors, or MIDI channel colors. By default, notes correspond to the region color.

Change the color of notes

In the Logic Pro Piano Roll Editor, do one of the following:
•

•

Choose View > Set Note Color in the Piano Roll Editor menu bar, then choose an option
from the submenu.
•

By Region Color: Colors notes to correspond with the MIDI region.

•

By Velocity: Colors notes to show their MIDI note velocity.

•

By MIDI Channel: Colors notes to correspond with the MIDI channel.

•

By Articulation: Colors notes to correspond with the assigned articulation. This option
is available only if the track containing the region has an Articulation Set chosen.

Control-click the Piano Roll Editor background, then choose a color assignment from
the shortcut menu.

View Note Labels in the Piano Roll Editor in Logic Pro

You can view the note pitch and velocity information inside the note itself by turning on
Note Labels from the Piano Roll Editor View menu.

Turn on Note Labels
•

In Logic Pro, choose View > Note Labels in the Piano Roll Editor Menu bar.

Delete notes in the Piano Roll Editor in Logic Pro

You can delete notes from MIDI regions, and delete notes meeting certain criteria.

Delete one or more notes

In the Logic Pro Piano Roll Editor, do one of the following:
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•

Select the notes, then press Delete.

•

Select the notes, then click one of the selected notes with the Eraser tool.

•

Select the Eraser tool, then click the notes you want to delete.

416

Delete similar or equal events

1. In the Logic Pro Piano Roll Editor, select one of the notes you want to delete.
2. Choose Edit > Select > Select Similar Events or Edit > Select > Select Equal Events
(notes of the same pitch, for example) from the Piano Roll Editor menu bar, then delete
the selected events by pressing Delete.
You can also delete events by choosing Edit > Delete MIDI Events from the Piano Roll Editor
menu bar, then choosing an option from the submenu.

Delete doubled events
•

In Logic Pro, choose Edit > Delete MIDI Events > Duplicates from the Piano Roll Editor
menu bar, or use the Delete Duplicated Events key command (D).

Any events occurring twice or more at the same position (and pitch) are deleted, allowing
one to remain. This is true regardless of whether the duplicates have different velocity,
aftertouch, or controller values. Events on different MIDI channels are not considered
duplicates.
The “same time position” includes two notes that are output simultaneously because of the
current quantization setting.

Delete events inside or outside the locators

1. In the Logic Pro Piano Roll Editor, set the left and right locator positions.
2. Choose one of the following from the Piano Roll Editor menu bar:
•

Functions > Delete MIDI Events > Inside Locators

•

Functions > Delete MIDI Events > Outside Locators

When copying events or reducing the length of MIDI regions, events can sometimes end
up outside the limits of a MIDI region. These technically still belong to the MIDI region,
although they won’t be played or heard.

Delete events outside the MIDI region
•

In Logic Pro, choose Edit > Delete MIDI Events > Outside Region Borders from the Piano
Roll Editor menu bar.

Delete unselected events within the selection
•

In Logic Pro, choose Edit > Delete MIDI Events > Unselected Within Selection from the
Piano Roll Editor menu bar.

All unselected notes between the start of the first selected note and the end of the last
selected note are deleted.

Delete all selected events and select the next one

1. In the Logic Pro Piano Roll Editor, select the event you want to delete.
2. Use the Delete and Select Next Region/Event key command.
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Time stretch notes in the Piano Roll Editor in Logic Pro
You can use time handles to time stretch notes in the Piano Roll Editor.

Time stretch notes

1. In Logic Pro, choose Functions > Time Handles in the Piano Roll Editor menu bar.
2. Drag to select the required range of notes.
The range is highlighted with a blue rectangle, and a time handle is added at each
border, quantized to the nearest position according to the Snap setting.

3. Do one of the following:
•

To time stretch selected notes: Drag the upper part of either time handle, using the
other time handle as a pivot point.
If you move one time handle beyond the other, the relative start points of the notes
are preserved, so that the notes of a chord maintain the same start position, for
example. If you Shift-drag one time handle beyond the other, the notes are reversed.

•

To adjust the time handle borders: Drag the lower part of either time handle.

Note: You can Shift-click notes to unselect or select them. You can also Option-shift-drag
to select the required range of notes without having to choose Functions > Time Handles in
the Piano Roll Editor menu bar first.
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View multiple regions in the Piano Roll Editor
in Logic Pro

You can view the contents of several selected MIDI regions, all MIDI regions in a folder, or
all MIDI regions in a project using Link modes.
When multiple MIDI regions are displayed in the Piano Roll Editor, you can freely select
note events from different MIDI regions, and edit them. A help tag indicates the number of
selected events and their parent MIDI regions. For example, 8/2 means that eight notes are
selected from two MIDI regions.
When viewing multiple MIDI regions, you can temporarily display only the region of a note
by double-clicking the note.

View the contents of multiple MIDI regions
•

In Logic Pro, Shift-click multiple MIDI regions in the Tracks area.
Notes from all of the selected regions appear in the Piano Roll Editor. The start point
of each MIDI region is indicated by a vertical line of the same color as the MIDI region
itself.

Show only the region for a particular note
•

In the Logic Pro Piano Roll Editor, double-click the note.

•

To return to the previous view, do one of the following:
•

Double-click the Piano Roll Editor background.

•

Select a different region.

Split chords in the Piano Roll Editor in Logic Pro

The following functions let you divide chords by pitch and assign notes to different MIDI
channels by pitch.

Select the top or bottom note of selected chords

In the Logic Pro Piano Roll Editor, do one of the following:
•

Choose Edit > Select > Highest Notes from the Piano Roll Editor menu bar to select the
highest notes in the chords.

•

Choose Edit > Select > Lowest Notes from the Piano Roll Editor menu bar to select the
lowest notes in the chords.

These commands can be used with regions containing chords to separate the top note
of each chord (often the melody), or to separate the bottom note of each chord for a
bass line. Once selected, the notes can be cut or copied, and pasted into a region on a
different track.
Note: Highest Notes and Lowest Notes only select the notes. They can be used in
conjunction with other editing commands, such as Cut, to move a voice into another
MIDI region.
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Assign notes to different MIDI channels by pitch

1. In Logic Pro, select the notes you want to reassign by clicking keys on the keyboard
along the left edge of the Piano Roll Editor.
•

Shift-click to select multiple keys.

•

Drag across the keyboard to select a range of contiguous pitches.

2. Choose Functions > Set MIDI Channel to Voice Number from the Piano Roll Editor
menu bar.
Logic Pro assigns MIDI channel numbers (in ascending order) to individual note pitches in
the selected MIDI region. The highest note pitch in each chord is assigned as MIDI channel
1, the next note down in each chord channel 2, and so on.
Note: The use of these commands results in changes to the MIDI region, which contains
information spread across multiple MIDI channels, following the operation.
After using the Set MIDI Channel to Voice Number function, you can create a new MIDI
region for each note by using the Edit > Separate MIDI Events > By Event Channel menu
command in the Tracks area. Each region created from this process can then be assigned
to a different track (and channel), allowing different instruments to be assigned for
each voice.

The Automation/MIDI area in the Piano Roll Editor
in Logic Pro
You can create and edit automation data directly in the Piano Roll Editor. To learn more
about using automation, see Overview of automation.

When track automation is displayed in the Automation/MIDI area, the displayed automation
curve is identical to the automation curve displayed in the automation lane in the Tracks
area. Any adjustments to the automation curve made in either location is reflected
immediately in the other. However, with region automation, you can choose to display
either the automation curve associated with the region in the Tracks area automation lane
or the MIDI data associated with individual notes. Therefore, with region automation it is
possible to have the automation lane in the Tracks area showing the automation curve
associated with the region and the Automation/MIDI area displaying MIDI data associated
with each note (or vice versa).
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Note: Region automation is effectively the same as MIDI Draw in previous versions of
Logic Pro. If you had MIDI Draw data in a project created in a previous version of Logic Pro,
it appears as region automation data.

Show automation or MIDI controller data in the Piano Roll Editor
•

In Logic Pro, click the Show/Hide Automation button
menu bar.

in the Piano Roll Editor

An Automation button, an Automation Cycle Through button, and an Automation/
MIDI Parameter pop-up menu appear at the bottom of the Piano Roll Editor inspector.
Any existing automation or MIDI data for the selected parameter is displayed in the
Automation/MIDI lane under the main editor window.

Show track automation data in the MIDI/Automation area

1. In the Logic Pro Piano Roll Editor, if the Automation button is not already set to Track,
click the button.
2. Choose the desired automation parameter from the Automation/MIDI Parameter
pop-up menu.
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Show region automation in the MIDI/Automation area

1. In the Logic Pro Piano Roll Editor, click the Automation button and set it to Region (if it
isn’t already set to Region).
2. Choose the desired automation or MIDI controller parameter from the Automation/MIDI
pop-up menu.

Cycle through existing automation curves and MIDI data
•

In the Logic Pro Piano Roll Editor, click the Automation/MIDI Cycle Through button.

Open other editors from the Piano Roll Editor
in Logic Pro
The Piano Roll Editor provides quick access to the Event Float and Score Editor.

Quickly open the Event Float
•

In the Logic Pro Piano Roll Editor, double-click a note in the Piano Roll Editor.

The Event Float appears above the Tracks area. If it’s already open, the contents of the
parent region (of the note selected in the Piano Roll Editor) are displayed.

Quickly open the Score Editor
•

In Logic Pro, Option-double-click an event in the Piano Roll Editor.

The Score Editor opens in a new window. The Piano Roll Editor remains docked in the
editing area of the Tracks area.
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Add drummers to your project

Overview of Drummer in Logic Pro

Drummer allows you to add virtual drummers to your project, using Drummer tracks. You
can create as many Drummer tracks as you like per project. You can choose drummers
from different genres—Rock, Alternative, Songwriter, R&B, Electronic, Hip Hop, and
Percussion. Each drummer comes with its own acoustic kit or electronic drum kit and a
distinct playing style.
You can change the drummer’s playing style by choosing different presets, tweaking the
generated pattern using various settings, or having Drummer regions follow the rhythm of
another track in the project.
Note: To edit Drummer regions in the Piano Roll Editor, Event List, or Step Editor, you first
need to convert them to MIDI regions.
You can further influence the sound of the drums and percussion by choosing patches in
the Library or by exchanging drums and editing the settings of individual kick pieces in
Drum Kit Designer or Drum Machine Designer. For details about Drum Kit Designer and
Drum Machine Designer, along with usage tips, see Logic Pro Instruments Help.
If you have a device with a Touch Bar, you can edit Drummer parameters using the Smart
Controls screen and play the selected drum kit and percussion instruments using the Drum
Pads screen.
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When you add a Drummer track to your project, a drummer and a default patch associated
with that drummer are loaded. The default patch is based on a stereo mixdown of the full,
multi-miked acoustic or electric drum kit or percussion mix. These patches are optimized
for performance and recommended for uses with the Drummer Editor to compose and edit
the performance.
Once you’re happy with the performance of an acoustic drummer and want to fine-tune
the actual drum kit or percussion mix, you can replace the stereo mixdown with the
original producer patch (Producer Kit), offering full access to all mix options. When you
use electronic drummers, a Track Stack automatically loads with the selected drum and
percussion instruments, so you always have full access to all mix options. See Track Stacks
overview to learn more about Track Stacks.

Add a Drummer track

1. In Logic Pro, do one of the following:
•

Click the Add Tracks button

above the track headers.

•

Choose Track > New Tracks (or press Option-Command-N).

•

Choose Track > New Drummer Track. (If you use this method, you can skip steps 2
and 3.)

•

Use the New Drummer Track key command. (If you use this method, you can skip
steps 2 and 3.)

•

If you have a computer with a Touch Bar, tap the Add Drummer track Touch Bar
shortcut. See Overview of Touch Bar shortcuts in Logic Pro for more information. (If
you use this method, you can skip steps 2 and 3.)

2. In the New Tracks dialog, select the Drummer track and choose a genre from the Genre
pop-up menu.
3. Click Create.
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•

If the project doesn’t have arrangement markers: A Drummer track containing one
8-bar region is created.

•

If the project has arrangement markers: A Drummer track containing as many regions
as there are arrangement markers is created. The length and name of the Drummer
regions correspond to the existing arrangement markers.
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Create an additional region on a Drummer track

Yellow drummer regions contain all the performance information necessary for generative
instruments such as Drummer. You can change the artist and parameters in the Drummer
Editor to change the sound of the region.
In Logic Pro, do one of the following:
•

Move the pointer past the end of the final Drummer region in the track. Click the Add (+)
button that appears.

•

Control-click an empty area of the Drummer track, then choose Create Drummer Region
from the shortcut menu.

•

Click with the Pencil tool on an empty area of the Drummer track.

A new 8-bar yellow drummer region is created at the downbeat that precedes the clicked
position. However, if an arrangement marker exists at this position, the region matches the
length and name of the marker.
Note: You can also Option-drag an existing drummer region to create an exact copy of the
original region.

Fill the entire Drummer track with regions
•

In Logic Pro, Control-click an empty area of the Drummer track, then choose Populate
with Drummer Regions from the shortcut menu.

The Drummer track is filled with regions up to the project end point. Gaps are filled
with 8-bar regions as much as possible, without overwriting existing regions. Any gaps
smaller than one bar are not filled; the expectation is that such gaps were created for
short pauses, for example. If an arrangement track exists, as many regions as there are
arrangement markers are created, with the length and name of the regions corresponding
to the markers.
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Working with drummers and Drummer regions
Drummers and the Drummer Editor in Logic Pro

The Library includes track-based settings for the Drummer track. You can choose drum
genres and drummers whose sound and playing style are applied to all content on the
Drummer track.
The content of Drummer regions can be edited in a dedicated Drummer Editor.

The Drummer Editor includes region-based settings, which influence the complexity,
loudness, and other aspects of selected Drummer regions. You can choose and create
presets for Drummer regions. Presets offer a quick way to browse predefined, regionbased Drummer Editor settings, including percussion and kit piece pattern variations and
fill settings.

Note: Drummer regions can be edited in the Tracks area in much the same way as you
edit MIDI regions, with the exception of region overlapping. When overlapping, Drummer
regions always use the No Overlap drag mode.
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Open the Drummer Editor

In Logic Pro, do one of the following:
•

Double-click a Drummer region on a Drummer track.

•

Select one or more Drummer regions on a Drummer track, then click the Editors button
in the control bar.

•

Select a Drummer track, then click the Editors button

.

The Drummer Editor opens below the Tracks area.

Show settings for the Drummer region under the playhead

The Drummer Editor shows the settings for the currently selected region. You can set
the Drummer Editor to auto-select the Drummer region under the playhead, so that the
Drummer Editor always displays the settings of the region currently playing.
•

In Logic Pro, click the Auto-Select button in the upper-left corner of the region in the
Drummer Editor.

Choose genres and drummers in Logic Pro

Each genre comes with a number of drummers that have their own drum kit or percussion
instruments and distinct playing style.
When you add a Drummer track to the project, a default genre and drummer are loaded,
along with a default patch associated with the drummer. You can change the genre and the
drummer, with these changes influencing all regions on the track. If you change a drummer,
a new patch is loaded, which means that the drum kit or percussion instruments as well as
the kit mix are replaced with those of the new drummer. However, it’s possible to choose a
new drummer without loading a new patch, without changing any region settings you have
made on the track, or without changing the drum kit.
Note: Some drummers are only available after you download additional content.

Choose a genre and drummer

1. In Logic Pro, open the Library (if it’s not already open).
2. Choose a genre from the Drummer menu.
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You can choose Rock, Alternative, Songwriter, R&B, Electronic, Hip Hop, or Percussion.

The available drummers for the chosen genre appear. The description of the drummer’s
playing style appears under the drummer’s picture.
3. Click a drummer.
The name and picture of the selected drummer appear at the top of the Library, and the
predefined patch default patch for that drummer is loaded into the Drummer Editor.
4. Do either of the following:
•

To choose a different drummer: Choose a drummer from the Drummer menu.

•

To choose a different genre: Choose a genre from the Drummer menu.

Choose a drummer without changing the current patch
•

In the Logic Pro Library, hold down Option while choosing a drummer.

Choose a drummer without changing region settings on the track
•

In the Logic ProDrummer Editor, choose “Keep settings when changing drummers” from
the Action pop-up menu in the presets area.

Choose a drummer without changing the drum kit on the track
•
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In the Logic ProDrummer Editor, choose “Keep drum kit when changing drummers” from
the Action pop-up menu in the presets area.
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Choose drummer presets in Logic Pro

After choosing a genre and drummer you can choose from a collection of drummer-specific
presets in the Drummer Editor. Presets offer a quick way to browse predefined, regionbased Drummer Editor settings, including kit piece pattern variations and fill settings. You
can use the default settings, or you can edit them and save your own presets. User presets
can be deleted, but factory presets cannot.

Whenever you choose a different preset or edit settings for the current one, you can play
back the selected region to hear the changes. You can also play back a subtly different
version of the selected region without editing any of the region settings.

Play the selected region using the current preset
•

In the Logic ProDrummer Editor, click the Play button in the ruler at the top of the editor.

Play a subtly different version of the selected region (without editing region
settings)
In Logic Pro, do one of the following:
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•

In the Drummer Editor: Choose “Refresh region” from the Action pop-up menu in the
presets area.

•

In the Tracks area: Control-click the Drummer region, then choose Edit > Refresh Region
from the shortcut menu.
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Choose a different preset
•

In the Logic ProDrummer Editor, click a preset on the left side of the editor.

The region settings on the right side of the editor update to reflect the chosen preset and
the selected region in the Tracks area is regenerated.

Save a modified user preset
•

In the Logic ProDrummer Editor, choose “Save preset” from the Action pop-up menu in
the presets area, then enter a name for the user preset.

Delete a user preset
•

In the Logic ProDrummer Editor, choose “Delete preset” from the Action pop-up menu
in the presets area.

Recall the default preset
•

In the Logic ProDrummer Editor, choose “Recall default preset” from the Action pop-up
menu in the presets area.

Edit a drummer’s performance in Logic Pro

There are a number of settings in the Drummer Editor that affect the drummer’s playing
style. These settings are located to the right of the presets area.

You can edit the complexity and loudness of the performance, mute and unmute drum
kit and percussion pieces, and choose whether a pattern is played on the toms, cymbals,
hi-hat, or percussion instruments. You use the percussion icons to turn on different
instruments, and you can choose between different variations for the drum and percussion
pieces. You can also play half time or double time for kick and snare.
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Adjust the complexity and loudness of the performance
•

In the Logic ProDrummer Editor, drag the puck to a different position in the XY pad.

The farther right you place the puck, the more complex the sound becomes; the higher you
place the puck, the louder the sound plays.

Choose a pattern variation for acoustic drum or percussion instruments
•

In the Logic ProDrummer Editor, select an instrument, then drag the slider to the right of
the instrument to choose an increment. You can also click a specific increment.

In some cases, you can select more than one instrument in a category.

Choose a pattern variation for electronic drum or percussion instruments
•

In the Logic ProDrummer Editor, select an instrument, then drag the slider to the right of
the instrument to choose an increment. You can also click a specific increment.

In some cases, you can select more than one instrument in a category.
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Mute or unmute a drum or percussion instrument

•

To include the piece in the performance: In the Logic ProDrummer Editor, click the piece
so that it’s selected, or unmuted.

•

To remove a piece from the performance: In the Logic ProDrummer Editor, click the
piece so that it’s dimmed, or muted.

Use a half time or double time variation for acoustic kick and snare drums
•

In the Logic ProDrummer Editor, choose 1/2 or 2x at the right end of the Kick & Snare
slider.

Adjust the snare brush technique of drummers using a brush kit

When using a drummer who uses snare brushes, the Brush Sweep or Brush Tap checkbox
appears under the Kick & Snare slider. Selecting Brush Sweep enables a swirling, sweeping
brush technique reminiscent of percussion fills. Selecting Brush Taps enables a gentle
tapping snare brush technique.
•

In the Logic ProDrummer Editor, select the Brush Sweep or Brush Taps checkbox below
the left end of the Kick & Snare slider.

Note: The checkbox name reflects the brush technique used by the chosen drummer.
For example, when Austin is chosen, it becomes the Brush Taps checkbox, because
he performs brush taps. However, when Tyrell is chosen, it becomes the Brush Sweep
checkbox, because he plays brush sweeps.
The drummer performs using the selected snare brush technique.
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Edit fills and swing settings
•

Reduce or increase the number and length of fills: In the Logic ProDrummer Editor, drag
the Fills knob downward or upward.

You can click the lock to prevent any changes to the fills setting when switching presets
or drummers.
•

Adjust the shuffle feel of the currently playing pattern: In the Logic ProDrummer Editor,
drag the Swing knob vertically.

You can click the lock to prevent any changes to the swing setting when switching
presets or drummers.
•

Determine whether the swing is based on eighth notes or sixteenth notes: In the
Logic ProDrummer Editor, click the 8th or 16th button.

Edit other acoustic drum performance settings
•

In the Logic ProDrummer Editor, click the Details button, then do any of the following:

•

Drag the Feel knob to the right to have the drummer play ahead of the beat or to the
left to play behind the beat, or sloppy.

•

Drag the Ghost Notes knob to adjust the level of ghost notes—syncopated snare and
kick hits—in the beat.
Note: The presence of ghost notes depends on the chosen drummer and the
complexity setting.
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•

Drag the Hi-Hat knob to adjust the degree to which the Hi-Hat is opened and closed
during the drum performance.
Note: This is only relevant if the hi-hat is selected in the drum kit representation.

Edit other electronic drum performance settings
•

In the Logic ProDrummer Editor, click the Details button, then do any of the following:

•

Drag the Humanize knob to generate drum patterns that are not perfectly quantized,
making the performance more realistic, or human. You can click the lock to prevent
any changes to the humanize setting when switching presets or drummers.

•

Drag the Phrase Variation knob to determine the amount of rhythmic change that
occurs over the course of several bars within a region. You can click the lock to
prevent any changes to the phrase variation setting when switching presets or
drummers.

•

Select the Auto half-time checkbox to have Drummer regions generated in half time,
if the project tempo is a multiple of the preferred tempo.

•

Drag the Complexity Range sliders to offset the complexity of individual kit pieces
against the XY pad.

•

Click the drum or percussion instruments to mute the complexity offset setting of
individual kit pieces.

Any changes or selections you make in the Drummer Editor affect only the selected region,
not the entire track. Drummer regions are regenerated when adjusting the XY pad. When
you adjust the Swing and Fills knobs, the region timing is changed. When you adjust a kit
piece variation slider, the pattern for that kit piece is regenerated.
You can also refresh the selected region, without editing any region settings, to play back a
subtly different version.
Note: The Drummer Editor is disabled when recording a Live Loops performance. See
Record a Live Loops performance.
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Set Drummer to follow another track’s rhythm in Logic Pro

You can have the kick and snare portions of a Drummer region follow another track so that
the beat Drummer plays is influenced by the rhythm of the content of another instrument.
You may find, for example, that it makes more musical sense to have the chorus beat
influenced by a guitar track, while the rest of the song follows a bass track. You can
set this option on a region basis, which means that each Drummer region can follow a
different track.
The following types of audio material are best suited to lending their structure to
Drummer regions:
•

Audio files recorded using monophonic, polyphonic, or percussive instruments.

•

Audio files containing notes played on the same beat—no overlapping chord notes.

•

Audio files recorded without distortion, overdrive, compressor, or modulation effects.

Note: Before choosing an audio track, you should analyze its audio content for tempo or
adjust the timing of audio material.

Have a Drummer region follow the rhythm of another track
1. In Logic Pro, select a Drummer region in the Tracks area.

2. Select the Follow Rhythm checkbox in the Drummer Editor.
Because this behavior has an effect on the Kick and Snare portion of the beat, the Kick
& Snare pattern variation slider changes to the Follow Track pop-up menu.

Note: The Follow Rhythm checkbox and Follow Track pop-up menu are not available for
drummers in the Percussion genre.
3. Choose a track from the Follow Track pop-up menu.
As with other track types, you can also match the timing of a Drummer track to the groove
track. See Control timing with the groove track.
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Work with Producer Kits in Logic Pro

When you add a Drummer track to your project, a drummer and a default patch associated
with that drummer are loaded. If you chose an acoustic drummer, its default patch is based
on a stereo mixdown of the full, multi-miked drum kit or percussion mix. These patches are
optimized for performance. The original producer patch (Producer Kit) offers full access to
all mix options.
Important: When using Producer Kits, make sure that plug-in latency compensation is set
to All in General Audio preferences. This ensures phase-coherent playback of all channel
strips in the multi-miked drum kit mix.
For live playing, it’s recommended that you use the stereo mixdown patches or the
Unmixed+ producer patch in the Library. While some of the patches can contain latencyinducing plug-ins, you can compensate for this by turning on Low Latency mode. To do so,
click the Low Latency Monitoring button in the control bar or select the Low Latency Mode
checkbox in General Audio preferences.
Note: Producer Kits are only available after you download additional content.

Access Producer Kits
•

In Logic Pro, click the Library button
patch category.

in the control bar, then select the Producer Kits

Producer Kits are identified in the Library by a “+” at the end of the patch name. There
is an original producer patch for each stereo mixdown patch.
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Choosing a Producer Kit gives you full access to all 15 individual drum microphone
channel strips and any effect plug-ins and routings. You also have access to additional
mic and room sound settings, and additional drum replacement pieces.
Once you choose a Producer Kit for your drummer, switching drummers also switches to
the corresponding Producer Kit.
For more information on how to use producer kits, see Drum Kit Designer in Logic Pro
Instruments Help.

Convert Drummer regions to MIDI in Logic Pro

You edit Drummer regions, but not specific notes, in the Drummer Editor. To edit specific
notes, you’ need to use the Piano Roll Editor, Event List, or Step Editor. To edit notes,
you must convert your Drummer regions to MIDI regions. Once you have converted
them, they no longer interact with Drum Kit Designer and Drum Machine Designer as
Drummer regions.
After converting a Drummer region to a MIDI region, you can convert it back to a Drummer
region at a later point. However, any MIDI edits you made to the region are lost.
Note: Drummer regions can be edited in the Tracks area in much the same way as you
would edit MIDI regions, with the exception of region overlapping. When overlapping,
Drummer regions always use the No Overlap drag mode.

Convert a Drummer region to a regular MIDI region
In Logic Pro, do one of the following:
•

Control-click the Drummer region, then choose Convert > Convert to MIDI Region from
the shortcut menu.
The Drummer region is converted to a MIDI region, but the region remains on the
Drummer track.

•

Drag the Drummer region to another existing track.
The Drummer region is converted to a MIDI region.

The resulting MIDI region behaves just like any other MIDI region. You can edit it in the
Piano Roll Editor, Event List, or Step Editor.
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Convert a regular MIDI region back into a Drummer region
In Logic Pro, do one of the following:
•

If the region is on the Drummer track: Control-click the MIDI region, then choose
Convert > Convert to Drummer Region from the shortcut menu.

•

If the region is on another track: Drag the MIDI region to the Drummer track.

The resulting Drummer region do not contain any MIDI edits you may have made.
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Edit the timing and pitch of audio

Overview of Flex Time and Pitch in Logic Pro

Flex Time—similar to what is often referred to as elastic audio in other applications—
simplifies the process of editing the timing of notes, beats, and other events in audio
regions. You can compress or expand the time between specified events in an audio region
without the need for trimming, moving, nudging, or crossfading.
You can edit the timing of notes and beats in audio regions using flex markers. When you
choose a Flex Time algorithm, the contents of the audio track are analyzed for transients,
or significant peaks, and any detected transients are marked in the audio regions. You
can add a flex marker at a specific part of the waveform you want to edit. After adding
flex markers to an audio region, you use them to time stretch—compress or expand—the
audio material. The initial boundaries within which this is done are determined by the
transient markers.
Flex Pitch allows you to quantize and edit the pitch of audio material. You edit the pitch
of audio material by choosing the Flex Pitch algorithm. The contents of the audio track
are analyzed for pitch using a pitch detection process, and the results are plotted on a
pitch curve.
You can edit the timing of audio in the Tracks area and the pitch in the Audio Track Editor.
You can also extract MIDI from audio using Flex Pitch in Logic Pro.
Note: Flex Time is also integrated with the Smart Tempo feature of Logic Pro. To learn
more about Smart Tempo and how it interacts with Flex Time, see Logic Pro Smart
Tempo overview.

Turn on flex in the Tracks area

1. In Logic Pro, do one of the following to show the flex parameters:
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•

Choose Edit > Show Flex Pitch/Time from the Tracks area menu bar (or press
Command-F).

•

Click the Show/Hide Flex button

in the Tracks area menu bar.
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A Track Flex button and Flex Mode pop-up menu appear in the track header of each
audio track.

2. Click the Track Flex button

in the track header of the audio track you want to edit.

In the Tracks area, the regions on your track now display transient markers inside the
waveform as shown in the figure above. In the Region inspector the Flex & Follow popup menu is now available for use. In the Track inspector the Flex Mode pop-up menu is
now available for use.
3. Choose Flex Pitch or one of the Flex Time algorithms from the Flex Mode pop-up menu.

Turn on flex in the Audio Track Editor

1. In Logic Pro, open the Audio Track Editor by doing one of the following:
•

Select an audio track in the Tracks area, then choose View > Show Editors.

•

Select an audio track in the Tracks area, then click the Editors button
control bar.

•

Double-click an audio region.

2. Click the Show/Hide Flex button
Command-F).

in the

in the Audio Track Editor menu bar (or press

Note: Click the Audio Track Editor’s workspace before using the key command, to make
sure that the Audio Track Editor has key focus.
A dialog window asks if you want to turn on flex for the selected track, if it’s not already
on. A Flex Mode pop-up menu appears to the right of the Show/Hide Flex button in the
Audio Track Editor menu bar.
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3. Choose Flex Pitch or one of the Flex Time algorithms from the Flex Mode pop-up menu.

Assign the same flex algorithm to all audio tracks
•

In the Logic Pro Tracks area or Audio Track Editor, hold down Shift while choosing a flex
algorithm from the Flex Mode pop-up menu.

Choose how Flex Time and Follow Tempo adjust individual regions

You can configure how Flex Time and Follow Tempo adjust each region on a flex-activated
track using the Flex & Follow pop-up menu.

1. In the Logic Pro Tracks area, select an audio region.
2. In the Flex & Follow pop-up menu in the Region inspector, choose one of the following
options:
Off: Flex is not activated on the region. The region does not follow changes to the
project tempo.
On: Flex is activated on the region and the region follows any manual Flex edits. It also
follows changes to the project tempo.
On + Align Bars: Flex is activated on the region and the region follows project tempo
changes. Additionally, Smart Tempo beat markers are used to conform the region to the
project tempo at every downbeat (bar).
On + Align Bars and Beats: The region is Flex activated and the region follows project
tempo changes. Additionally, Smart Tempo beat markers are used to conform the region
to the project tempo at every beat.

Logic Pro User Guide

441

Edit the timing of audio
Flex Time algorithms and parameters in Logic Pro

Flex Time algorithms are track-based settings that determine how the timing or pitch of
your audio material can be altered—using time compression or expansion, manipulating
invisibly sliced segments, or speeding up or slowing down the material. You can choose an
algorithm based on the type of audio material you’re working with. Each algorithm comes
with its own individual parameters, located in the Track inspector.
You can also have Logic Pro choose the most suitable Flex Time algorithm based on an
automatic analysis of your audio material.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Flex options are available in the Track inspector.

Note: When you choose a flex algorithm for a track, the Freeze Mode parameter in the
Track inspector switches from Pre Fader to Source Only. This freezes the track signal
without any effects plug-ins. See Freeze tracks.

Have Logic Pro choose a Flex Time algorithm
•

In the Logic Pro Tracks area or Audio Track Editor, choose Flex Time - Automatic from
the Flex Mode pop-up menu.
The resulting algorithm is chosen as follows:
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•

Monophonic for monophonic audio material—bass line, for example

•

Slicing for percussive, non-tonal audio material—drums, for example

•

Polyphonic for chords, or complex material—mixes, for example
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Use the Slicing algorithm
•

In Logic Pro, choose Flex Time - Slicing from the Flex Mode pop-up menu.
Slicing cuts the audio material at transient markers, then shifts the audio while playing
each slice at its original speed. No time compression or expansion is applied to the
shifted audio. Any gaps that occur as a result of shifting the audio can be filled using
the decay function. Slicing is a good choice for drums and percussion and comes with
the following parameters:
•

Fill Gaps: Turns the decay function on or off, allowing you to fill any gaps that occur
between sounds as a result of shifting the audio.

•

Decay: Sets the decay time between sounds, because no time stretching takes place
to compensate for the gaps.

•

Slice Length: Shortens each slice by a percentage value. Shortening slices can be
helpful for removing unwanted pre-attack sounds from the following slice, or to
create a gated effect.

You can slice an audio region at transient marker positions, splitting it into separate regions
at each transient marker. You do this by Control-clicking the audio region, then choosing
Slice at Transient Markers from the shortcut menu.
You can also slice an audio region at flex marker positions, splitting it into a separate
regions at each flex marker you have previously placed. You do this by Control-clicking the
audio region, then choosing Slice at Flex Markers from the shortcut menu.
Note: You can use Slice at Transient Markers and Slice at Flex Markers regardless of the
flex algorithm selected.

Use the Rhythmic algorithm
•

In Logic Pro, choose Flex Time - Rhythmic from the Flex Mode pop-up menu.
Rhythmic time stretches the material, looping audio between slices in order to fill any
gaps. This algorithm is most suitable for material such as rhythmic guitars, keyboard
parts, and Apple Loops. Rhythmic comes with the following parameters:
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•

Loop Length: Sets the length of the looped section at the end of a slice that is used
for time expansion.

•

Decay: Defines a decay value for the looped area.

•

Loop Offset: Allows you to move the looped area up to 100 ms to the left, preventing
pre-attack sounds from the following transient to appear in the looped and
crossfaded area.
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Use the Monophonic algorithm
•

In Logic Pro, choose Flex Time - Monophonic from the Flex Mode pop-up menu.
Monophonic is designed to be used on melodic instruments only playing a single note at
a time, and is therefore good for solo vocals and monophonic solo instruments—melody
and bass lines, for example. When you use this flex algorithm, your recording should
be relatively dry, without audible reverberation. Otherwise, you may want to try using
Polyphonic. Monophonic comes with a single parameter:
•

Percussive: Preserves the area around transient markers to protect the percussive
part of the sound. If selected, allows better timing for all kinds of percussive
monophonic tonal material, such as plucked strings (guitar, bass) or tonal
percussion. If unselected, prevents glitches on transient markers in non-percussive
tonal material, such as bowed strings or wind instruments.

Use the Polyphonic algorithm
•

In Logic Pro, choose Flex Time - Polyphonic from the Flex Mode pop-up menu.
Polyphonic time stretches material based on a process called phase vocoding—a
process that uses phase information to time stretch an audio signal without touching
its pitch. It is the most processor intensive of all the flex algorithms, but it delivers
high sonic quality with suitable polyphonic material. It’s recommended for complex
polyphonic material and is good for all kinds of chords—such as guitar, piano, and
choir—and also complex mixes. Polyphonic comes with a single parameter:
•

Complex: Activates more internal transients in the audio material.

Use the Tempophone algorithm
•

In Logic Pro, choose Flex Time - Tempophone (FX) from the Flex Mode pop-up menu.
Tempophone emulates the effect of an historical tape-based time-stretching device
known as a tempophone, and results in a mechanical sound with many artifacts similar
to those produced with granular synthesis techniques. Tempophone is intended to be
used creatively for special effects and comes with the following parameters:
•

Grain Size: Sets the size of the grains that are played or repeated in their original
speed and crossfaded to create time compression or expansion.

•

Crossfade: Adjusts the crossfade length from 0.00, which produces hard artifacts, to
the full grain length of 1.00, which tends to sound softer.

Use the Speed algorithm
•

In Logic Pro, choose Flex Time - Speed (FX) from the Flex Mode pop-up menu.
Speed time stretches material by playing the source material faster or slower, including
pitch change. Because of the pitch shifting, this flex algorithm is mainly useful for
percussive material, but it can be used on all material for interesting creative effects.
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Time stretch using flex markers in Logic Pro

In the Tracks area, you edit the timing of audio material using flex markers. After adding
flex markers to an audio region, you use them to time stretch—compress or expand—the
audio material. The boundaries within which this is done are determined by the preceding
and following flex markers, or the region start and end positions if there are no preceding
and following flex markers.
You can also use transients in other audio regions as reference points, when dragging a
flex marker in an audio region.

Time stretch audio using a flex marker

1. In Logic Pro, choose a Flex Time algorithm for the track.
2. Add a flex marker by doing one of the following:
•

Place the pointer over or beside a transient marker in the upper half of the waveform
body (note how the pointer changes), then click.
A flex marker is added on top of the transient marker.

•

Place the pointer in the upper half of the waveform body where there is no transient
marker (note how the pointer changes), then click.
A flex marker is added at the clicked position.

3. Do one of the following:
•

Drag the flex marker to the left.
The audio material is time compressed up to the preceding flex marker, the
preceding tempo marker, or the region start position. The audio material is time
expanded up to the following flex marker or the following tempo marker (which can
also be the region end position).
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If you move the flex marker to the left and it crosses a previous flex marker, the
previous flex marker jumps back to the previous transient marker. This allows you
to extend the Flex Time editing range to the left. The same behavior occurs if a flex
marker crosses a tempo marker.

•

Drag the flex marker to the right.
The audio material is time expanded up to the preceding flex marker, the preceding
tempo marker, or the region start position. The audio material is time compressed
up to the following flex marker or the following tempo marker (which can also be the
region end position).
If you move the flex marker to the right and it crosses a following flex marker, the
following flex marker jumps forward to the next transient marker. This allows you to
extend the Flex Time editing range to the right. The same behavior occurs if a flex
marker crosses a tempo marker.

Snap a flex marker to a transient in another region

1. In Logic Pro, with Flex Time activated, click-hold the flex marker, then drag the pointer
up or down over an adjacent track.
A yellow guideline appears in the audio region on the adjacent track as you move from
transient to transient.
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2. Release the mouse button to snap the flex marker to the highlighted transient marker.

Add multiple flex markers to an audio region

In Logic Pro, inside a region on a track with Flex Time activated, do one of the following:
•

Place the pointer over or beside a transient marker in the lower half of the waveform
body (note how the pointer changes), then click.
Three flex markers are added: on the transient marker, on the previous transient marker,
and on the following transient marker.

•

Place the pointer in the lower half of the waveform body where there is no transient
marker (note how the pointer changes), then click.
Three flex markers are added: at the clicked position, on the previous transient marker,
and on the following transient marker.

Logic Pro User Guide

447

Marquee selection time stretching in Logic Pro

In the Tracks area, you can edit the timing of audio material using the Marquee tool in
combination with flex markers.

Time stretch audio using a marquee selection

1. In Logic Pro, using the Marquee tool, drag in the Tracks area to select part of a region.
2. Using the Pointer tool, do one of the following:
•

Click in the upper half of the marquee selection.
Four flex markers are added: two at the marquee borders and two outside the
marquee selection, at the previous and next transient markers.

•

Click in the lower half of the marquee selection.
Three flex markers are added: one at the clicked position and two at the marquee
borders.

3. Drag the marquee selection in either direction.
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Flex tool time stretching in Logic Pro

The Flex tool gives you quick access to basic Flex Time editing functionality, without having
to turn on Flex view. When you click a region with the Flex tool for the first time, a transient
detection process is performed on the audio material and the most suitable flex algorithm
is chosen.
You use the Flex tool in the Tracks area to grab points in the region’s waveform and move
them. The waveform’s movement is restricted by transient markers on either side of the
place you begin dragging. To extend the editing area, drag beyond these transients and the
boundary extends to the next or previous transient.

Time stretch audio using the Flex tool

In Logic Pro, on a track with Flex Time activated, do one of the following:
•

Place the Flex tool over the region body, then drag when you see the following pointer:

Three flex markers are added: on the transient marker, on the previous transient marker,
and on the following transient marker.
You are compressing or expanding the audio material between the middle flex marker
and the other two.
•

Place the Flex tool over the region body, then drag when you see the following pointer:

Three flex markers are added: at the clicked position, on the previous transient marker,
and on the following transient marker.
You are compressing or expanding the audio material between the middle flex marker
and the other two.
•

With Flex turned on, make a selection in the region with the Marquee tool, then drag the
selection using the Flex tool.
Four flex markers are added: two at the marquee borders and two outside the marquee
selection, at the previous and next transient markers.
You can edit the time position of the audio material between the first and second flex
markers or between the third and fourth flex markers. Nothing happens to the audio
material between the second and third flex markers.
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Delete, reset, and move flex markers in Logic Pro

When you delete a flex marker, any time changes that occurred in the area around the flex
marker are either removed—resetting the audio material to its original position—or reset
according to the time-stretching offset of the previous flex marker or region start position
and the following flex marker or region end position.
You can delete only those flex markers that were manually added or all flex edits that were
carried out on the audio file, which includes audio quantization.
You can also change the position of a flex marker in an audio region without changing the
timing of the audio material before or after the flex marker.

Delete a flex marker from an audio region

In Logic Pro, on a track with Flex Time activated, do one of the following:
•

Place the pointer over the flex marker, then click the “x” symbol in the region header.

•

Double-click the flex marker.

•

Drag across the flex marker with the Eraser tool.
Important: Use the Eraser tool in the body of the waveform only. Using it in the region
header deletes the entire region.

•

Control-click the flex marker, then choose Delete Flex Marker from the shortcut menu.

Delete multiple flex markers from an audio region
•

In Logic Pro, on a track with Flex Time activated, drag across multiple flex markers with
the Eraser tool.
Important: Use the Eraser tool in the body of the waveform only. Using it in the region
header deletes the entire region.

Delete all manually added flex markers from an audio region
•

In Logic Pro, on a track with Flex Time activated, Control-click the region background,
then choose Reset Manual Flex Edits from the shortcut menu.

Reset a region to its original length
•

In Logic Pro, on a track with Flex Time activated, Control-click the region background,
then choose Reset All Flex Edits from the shortcut menu.

All flex markers are deleted, including any that were placed automatically—during the audio
quantization process, for example.

Move a flex marker to a neutral position
•

In Logic Pro, on a track with Flex Time activated, Control-click the flex marker, then
choose Set to Neutral Position from the shortcut menu.

The flex marker moves to the same position the audio sample would have moved to if the
flex marker had been deleted.
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Move a flex marker without time stretching
•

In Logic Pro, on a track with Flex Time activated, hold down Option while you drag the
flex marker.

Flex tracks Quantize menu in Logic Pro

You can adjust the timing of an audio track, or a group of audio tracks, without adjusting
individual flex markers using the quantize function available in the region parameter
box. When quantizing multiple tracks in a group, you can select specific tracks to be the
Q-Reference or quantize reference tracks. This is useful for drum groups where the kick
and snare tracks (which typically keep the steadiest rhythm) can be used as reference
tracks for quantizing the entire drum kit.

Quantize timing of an audio track

With Flex activated on an audio track, you can adjust the timing of the audio so
that it adheres to a specific timing grid. This is explained in detail in the section on
quantizing regions.
•

Logic Pro User Guide

In Logic Pro, choose a value from the Quantize pop-up menu in the Region inspector.
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Quantize timing of multiple audio tracks

Quantizing multiple audio tracks requires Logic Pro groups function, which is available
when Enable Complete Features is selected in Logic Pro > Preferences > Advanced.

1. In Logic Pro, select all the audio tracks you wish to quantize and create a group. See
Work with Mixer groups for more information. In the group settings window, select both
Editing (Selection) and Quantize-Locked (Audio).

2. Choose which tracks in your group you wish to be the Q-Reference by clicking their
Q-Reference buttons.
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3. Choose a value from the Quantize pop-up menu in the Region inspector of one of the
grouped tracks.

If after quantizing your group, you feel that the audio of one track, or section of a track,
needs some additional timing correction, you can temporarily deactivate the group and
use flex markers to adjust specific sections. See Working with Mixer groups for details on
disabling groups.

Edit the pitch of audio
Flex Pitch algorithm and parameters in Logic Pro

Flex Pitch is a track-based setting that determines how the pitch of your audio material can
be altered. The algorithm comes with three parameters, located in the Track inspector.

Note: When you choose a flex algorithm for a track, the Freeze Mode parameter in the
Track inspector switches from Pre Fader to Source Only. This freezes the track signal
without any effects plug-ins. For details, see Freeze tracks in Logic Pro.
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Use the Flex Pitch algorithm
•

In Logic Pro, choose Flex Pitch from the Flex Mode pop-up menu.
Flex Pitch includes the following parameters:
•

Formant Track: Determines the interval at which formants are tracked along the
signal.

•

Formant Shift: Determines how formants adjust to pitch shifts. When set to 0,
formants are adjusted together with pitch shifts.

•

Formants pop-up menu: Choose how Flex Pitch processes formants.
•

Process always: All formants are processed.

•

Keep Unvoiced Formants: Only voiced formants are processed. This retains
sibilant sounds in a vocal performance and produces a more natural-sounding
transformation effect with some signals.

When you activate Flex Pitch, the destructive editing features in the Audio File Editor are
deactivated. If you plan on using Flex Pitch and making destructive edits to an audio file,
you’ll either need to make the edits before activating Flex Pitch, or bounce the region in
place after using Flex Pitch but before making edits to the audio file. For more information
about audio file editing, see Overview of the Logic Pro Audio File Editor.

Edit pitch and timing with Flex Pitch in Logic Pro

When you choose Flex Pitch for a track in the Audio Track Editor, or if you zoom into the
track in the Tracks area, any sections of audio on that track that are identified as individual
notes are displayed like notes in the Piano Roll Editor. When viewing Flex Pitch in this way,
you can edit the pitch, time position, and length of notes in much the same way as you
would in the Piano Roll Editor. You can also cut notes and merge multiple notes into one.
Each individual note contains “hotspots,” which you can use to edit pitch, vibrato, gain, and
other parameters.
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Change the pitch of a note
•

In Logic Pro, on a track with Flex Pitch activated, drag a note vertically.

Move a note
•

In Logic Pro, on a track with Flex Pitch activated, drag a note horizontally.

Resize a note
•
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In Logic Pro, on a track with Flex Pitch activated, drag the left or right edge of a note.
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Split a note
•

In Logic Pro, on a track with Flex Pitch activated, click a note with the Scissors tool.

Merge two or more notes
•

In Logic Pro, on a track with Flex Pitch activated, select two or more notes, then click
with the Glue tool.

Edit the parameters of a note using “hotspots”
•
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In Logic Pro, on a track with Flex Pitch activated, select a note, then do any of the
following:

•

To edit the pitch drift at the start of the note: Drag the upper-left hotspot vertically.

•

To edit the vibrato: Drag the upper-mid hotspot vertically.

•

To edit the pitch drift at the end of the note: Drag the upper-right hotspot vertically.

•

To edit the gain: Drag the lower-left hotspot vertically.

•

To edit the fine pitch: Drag the lower-mid hotspot vertically.

•

To edit the formant shift: Drag the lower-right hotspot vertically.
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Edit the vibrato of a note using the Vibrato tool

When working in the Audio Track Editor, the Vibrato tool allows you to edit the vibrato of a
note without having to drag the hotspot.

To adjust vibrato using the Vibrato tool:
1. In Logic Pro, on a track with Flex Pitch activated, select the Vibrato tool from the Tool
menu in the Audio Track Editor menu bar.
2. Drag up on the note to increase the vibrato, and down to decrease the vibrato.
Note: The Vibrato tool is only available in the Audio Track Editor, not the Tracks area.

Edit the gain of a note using the Volume tool

When working in the Audio Track Editor, the Volume tool allows you to edit the gain of a
note without having to drag the hotspot.

To adjust the gain using the Volume tool:
1. In Logic Pro, select the Volume tool from the Tool menu in the Audio Track Editor
menu bar.
2. Drag up on the note to raise the gain, and down to lower the gain.
Note: The Volume tool is only available in the Audio Track Editor, not the Tracks area.
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Quickly edit audio pitch in the Logic Pro Tracks area

When you activate Flex Pitch on a track in the Tracks area, but you haven’t vertically
zoomed into the track all the way, you don’t have access to all the Flex Pitch parameters
you do when the track is zoomed. However, in this view you can still see the pitch deviation
of individual notes from their perfect semitone represented as bars overlaying the audio
waveform in the background. You can select these bars and quickly edit the pitch of the audio.

•

The horizontal zero line in the waveform represents the perfect pitch.

•

Upward bars represent sharp notes.

•

Downward bars represent flat notes.

•

The horizontal size of bars represents the length of detected notes.

•

The vertical display range is ±0.50 cents.

If you want to move notes in time, you should use the Audio Track Editor.

Adjust the pitch of a note within the current semitone (between +0.50 and –0.50
cents/semitone)
•

In Logic Pro, on a track with Flex Pitch activated, drag the bar toward the zero line.
You can adjust the pitch within the range ±0.50 cents.

Adjust the pitch of a note to the next lower or higher semitone (beyond +0.50 and
–0.50 cents/semitone)
•

In Logic Pro, on a track with Flex Pitch activated, drag the part of the bar on the zero
line away from the line.

Set one or more notes to the perfect pitch

In Logic Pro, on a track with Flex Pitch activated, do one of the following:
•

Control-click an individual bar, then choose Set to Perfect Pitch from the shortcut
menu.

•

Control-click the audio region, then choose Set all to Perfect Pitch from the shortcut
menu.

Reset one or more notes to their original value

In Logic Pro, on a track with Flex Pitch activated, do one of the following:
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•

Double-click the bar.

•

Control-click an individual bar, then choose Set to Original Pitch from the shortcut menu.

•

Control-click the audio region, then choose Set All to Original Pitch from the shortcut
menu.
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Edit audio pitch in the Logic Pro Tracks area

When Flex Pitch is turned on in the Audio Track Editor, you can quantize, or automatically
correct, the timing of regions on an audio track. This is especially useful when regions on
the track contain the right notes but are not perfectly in time with the project tempo.
When you quantize the timing, selected regions on the selected track are adjusted to
the selected note value. You can quantize the timing of regions with drums, single-note
instruments, and chordal or polyphonic instruments. If you aren’t sure which note value to
use as the basis for timing quantization, a good starting point is the note value on which
your beats fall; in other words, if the beats in your project normally occur in 1/16th note
intervals, set your note value to 1/16th notes. If the resulting quantization doesn’t sound or
feel right to you, try again using the next higher or lower note value, until you are satisfied
with the results.

Quantize the timing of regions on an audio track
1. In Logic Pro, click the Show/Hide Flex button

in the Audio Track Editor menu bar.

2. Choose Flex Pitch from the Flex Mode pop-up menu in the Audio Track Editor menu bar.
3. Select the regions you want to quantize.
4. Choose the note value to use as the basis for timing quantization from the Time
Quantize pop-up menu.

5. Drag the Strength slider to the left to decrease the strength of quantization.
For more information about Flex editing, see Flex Time and Pitch overview.
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Quantize pitch in the Audio Track Editor in Logic Pro

When Flex Pitch is turned on in the Audio Track Editor, you can quantize, or automatically
correct, the pitch of notes on an audio track. This is especially useful when you record
audio regions that have the right “feel” and timing but are not perfectly in tune.
When you quantize the pitch, selected notes on the track are adjusted. Quantizing the
pitch can produce accurate results only for single-note (monophonic) audio regions, so be
sure the track does not include regions with chords or unpitched sounds.
By default, notes are adjusted to the closest note on the chromatic (12-note) scale. You
can also quantize regions to the notes of a particular key or scale.

Quantize the pitch of notes on an audio track
1. In Logic Pro, click the Show/Hide Flex button

in the Audio Track Editor menu bar.

2. Choose Flex Pitch from the Flex Mode pop-up menu in the Audio Track Editor menu bar.
3. Select the notes you want to quantize.
4. Drag the Pitch Correction slider to the right to increase the amount of tuning
adjustment, or drag it left to decrease the amount of adjustment.
5. To quantize the pitch of notes to a particular scale, choose the scale and key (major or
minor) from the Scale Quantize pop-up menus.

For more information about Flex editing, see Flex Time and Pitch overview.
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MIDI from audio using Flex Pitch in Logic Pro

You can create MIDI regions from audio regions in an audio track with Flex Pitch activated.
This “audio-to-MIDI” capability can be used to double the audio regions using a different
instrument or different effects, to modify the sound of the original audio recording, to
notate the music, and for other purposes.
Creating MIDI regions from an audio recording works best with monophonic material;
chords or polyphonic material may lead to errors in interpretation. Before creating the
MIDI regions, its a good idea to make any needed corrections to the audio after enabling
Flex. This could include timing corrections, missing or incorrectly pitched notes, and other
corrections. After creating the MIDI regions, you can make further corrections and changes
to the MIDI notes.
When you use the Create MIDI Track from Flex Pitch Data command, a MIDI region is
created for each audio region on the audio track.

Create MIDI regions from audio regions using Flex Pitch

1. In Logic Pro, double-click the audio region in the Tracks area to open the Audio Track
Editor.
2. Click the Show/Hide Flex button

in the Audio Track Editor menu bar.

3. Choose Flex Pitch from the Flex Mode pop-up menu in the Audio Track Editor menu bar.
4. After making any needed corrections, choose Edit > Create MIDI Track from Flex Pitch
Data in the Audio Track Editor menu bar.
A new instrument track appears in the Tracks area below the audio track, containing
MIDI regions created from the Flex Pitch data of the regions on the audio track.
5. Choose a patch for the new track from the Library.
After creating a new MIDI region, you may want to play it together with the original audio
recording to hear any inaccuracies, then make corrections to MIDI notes, adjust their
velocity, quantize the region, or perform other edits in the Piano Roll Editor. You can also
open the region in the Score Editor to view MIDI notes as music notation.
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Change the gain of notes in audio regions using Flex Pitch
in Logic Pro

When Flex Pitch is turned on in the Audio Track Editor, you can adjust the gain of individual
notes in audio regions.

Adjust the gain of individual notes in an audio region
1. In Logic Pro, click the Show/Hide Flex button

in the Audio Track Editor menu bar.

2. Choose Flex Pitch from the Flex Mode pop-up menu in the Audio Track Editor menu bar.
3. Select the notes you want to adjust in the Audio Track Editor.
4. Drag the Gain slider in the Audio Track Editor inspector horizontally to adjust the gain.

To learn more about Flex editing, see Overview of Flex Time and Pitch.

Use Varispeed in Logic Pro

Varispeed provides a way to speed up or slow down the entire project, similar to the
original varispeed feature of tape machines. The most practical use for this option is
checking how a project might sound at a faster or slower tempo, and for practicing or
recording a performance at a lower speed.
In Logic Pro, you can speed up or slow down a project between −50 percent and +100
percent, which is between 50 percent and 200 percent of the original tempo.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Varispeed feature is available in the control bar.

Turn Varispeed on or off
•
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In Logic Pro, click the Varispeed button in the control bar.
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Note: If you don’t see the Varispeed button in the control bar, Control-click the control
bar, choose Customize Control Bar and Display from the shortcut menu, choose Custom
from the LCD pop-up menu, then select the Varispeed checkbox.

Choose a Varispeed mode
•

In Logic Pro, click the upper part of the Varispeed display in the control bar, then
choose one of the following:

•

Speed Only: Use to pitch shift the master output signal to balance the pitch change
caused by varispeed. Only the speed changes, not the pitch.

•

Varispeed (Speed and Pitch): Use to emulate classic tape varispeed, where the pitch
changes to reflect the speed change.

•

Varispeed and MIDI: Use to emulate classic tape varispeed (speed and pitch) and
simultaneously transpose External MIDI tracks, quantized to semitones, so they
sound at the same pitch as the project.

Change the unit of measurement and adjust the value

1. In Logic Pro, click the unit of measurement (%, bpm, st, Hz) in the lower part of the
Varispeed display in the control bar, then choose one of the following:

•

Percentage (%): Displays the unit of measurement according to percentage.

•

Resulting Tempo (bpm): Displays the resulting tempo, dependent on the current
tempo, which changes along with any tempo changes in the project.
Note: The Tempo display in the control bar always shows the original tempo value.

•

Detune (st): Displays the unit of measurement according to pitch change.

•

Tuning Reference (Hz): Displays the unit of measurement according to tuning
reference.

2. Drag vertically on the value to adjust it, or double-click and enter a new value.
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Advanced edit features

Overview of advanced editors in Logic Pro

Logic Pro includes several advanced editing windows that you can use to process and
manipulate audio or MIDI information in unique ways.
The advanced Logic Pro editors are available when Enable Complete Features is
selected in Logic Pro > Preferences > Advanced.
•

Event List: The Event List shows MIDI events or regions as an alphanumerical list. All
available event or region values can be edited. See Event List overview.

•

Step Editor: The Step Editor shows MIDI events as steps—positioned on lanes that
resemble the tracks shown in the main window. See Step Editor overview.

•

Audio File Editor: The Audio File Editor lets you make precise adjustments to audio
files, remove pops and clicks in audio material, set sample-accurate crossover points
for looped playback, correct phase cancellation errors, and more. See Audio File Editor
overview.

•

MIDI Transform window: The MIDI Transform window is a processing utility that
transforms MIDI events into different types of events, or events with different values.
See MIDI Transform window overview.

Event List
Overview of the Event List editor in Logic Pro

The Event List is the most powerful, flexible, and complete MIDI editor in Logic Pro. All MIDI
event types are listed alphanumerically in the Event List.
The Event List is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.
You can:
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•

View all aspects of events—start and end points, length, channel, and values

•

View all events in a region

•

Filter the list to restrict this view to one or more event types, such as notes, pitch bend
events, or both
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Customized Event List views are saved to screensets and are displayed when screensets
are recalled. This makes the selection and editing of events faster and simpler.
All functions and options are shown at the top of the Event List area. The events
themselves are shown in the list below.

Open the Event List as a pane in the Logic Pro main window
•

In Logic Pro, click the List Editors button
in the control bar, then click Event (or use
the Toggle Event List key command, default assignment: D).

Open the Event List as a separate window
•
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In Logic Pro, choose Window > Open Event List (or use the Open Event List key
command, default assignment: Command-7).
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Event List display options
View events and regions in the Logic Pro Event List

By default, the Event List shows all events in the selected MIDI region.

The Event List can also display a list of all regions (and folders) in the Logic Pro main window.

View the events within a region in an open Event List window
•

In Logic Pro, click the name of the region with the Pointer tool.

The Event List can’t show the events of a multiple region selection. The Event List behaves
as follows:
•

The events of the last selected region are displayed (this also applies when selecting
multiple regions with Shift-click).

•

The events of the first selected region are displayed when a marquee selection is made.

View a list of regions (and folders)
•

In Logic Pro, click the Display Level button
window.

at the top-left corner of the Event List

This button is only accessible when the Event List is showing the contents of a region
(it’s showing events, in other words).
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Filter event types in the Logic Pro Event List
When viewing events in a selected MIDI region, you can use the event type buttons to filter
what is shown. These buttons show or hide specific event types from the list below, thus
limiting the view to events that you want to edit.
As a practical example of where these event type buttons could be used: Imagine a drum
part that you have recorded. You have found that every High Tom note event (D2) shares
a frequency with another instrument track, and is lost in the mix. Filter the view so that
only note events are visible, select one of the High Tom events, then use the Select Equal
Regions/Events key command, default assignment: Shift-E. All note events with a value of
D2 are selected, allowing you to simultaneously change them to the Mid Tom sound (B1),
for example.
Important: All selection and editing functions performed in the Event List only affect the
displayed events, protecting any invisible events from changes you may make.

Filter the display of events

In Logic Pro, do one of the following:
•

Choose the event type you want to hide or display from the pop-up menu (Notes, Pitch
Bend, and so on).

•

Click the event type buttons that match the event types you want to hide or display.
Events that match the active (illuminated) buttons are shown in the list. Events that
match the inactive (dark) buttons are hidden.

Show additional information in the filtered display

The Event List is normally restricted to one line per event. When the Additional Info button
is on, however, all information stored along with the event is also shown.
This is particularly important for editing SysEx messages. When examining note events in
the Event List, you may also notice Rel Vel (release velocity or note off messages).
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•

In Logic Pro, click the Additional Info button to show all information stored with an
event.

Score layout information is also included in the list when additional info is shown. You
can edit this in the Event List, but it is more efficient to perform such operations in the
Score Editor.

View events outside the Event List display area in Logic Pro
Often the number of events shown in the list exceeds the amount of screen space. The list
scrolls automatically when you click the Play button in the control bar, and the event at (or
nearest to) the playhead position during playback is indicated by a white line.

View events outside the display area
In Logic Pro, do one of the following:
•

Use the event type buttons to filter the list, thus reducing the number of displayed
events.

•

Drag the scroll bar at the right of the list area.

•

Choose Navigate > Scroll to Selection (or use the corresponding key command).
Note: When a marquee selection is active, using this key command moves the visible
section of the edit window to mirror the marquee selection.
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Change Event List column position and width in Logic Pro
If the length of data exceeds the width of the column, you may want to arrange the
columns in a particular order or adjust their width.

Change the position of columns in the Event List
•

In Logic Pro, click and hold the name of the column you want to move, then drag the
column left or right to the desired position.

Change the width of columns in the Event List

1. In Logic Pro, move the pointer over the line separating the names of the columns.
2. When the pointer turns into the Resize pointer, drag left or right.
When the width of the Status column is minimized, event types are represented by glyphs
or letters.

Reset position and width of columns
•

In Logic Pro, Control-click the name of any column, then choose Reset to Defaults from
the shortcut menu.

Select and create events in the Event List
Select events in the Logic Pro Event List
You can use any of the standard selection techniques in the Event List: individual selection
by clicking events, multiple selection by dragging, or both of these (without altering the
previous selection), in conjunction with the Shift key.
Tip: When selecting events with the Pointer tool, you should click the event name in the
Status column, to avoid any unintentional parameter alterations.
Right-click in the Event List to open a shortcut menu that contains selection, editing, and
other commands. Use these commands to accelerate your workflow.
Note: The right-click shortcut menu can only be accessed if the Right Mouse
Button: Opens Shortcut Menu option is chosen in Logic Pro > Preferences >
General > Editing.

Select an event, and navigate the list, with the arrow keys
•

In Logic Pro, press the Left Arrow key to select the previous event, or the Right Arrow
key to select the next event. Press and hold the respective arrow key to scroll through
the list.
Note: If the MIDI Out button (Output button) is on (it’s on by default), every newly
selected event is played. This allows you to scroll (or play) through the list and audibly
monitor events as they are selected.

Select multiple events with the arrow keys
•
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In Logic Pro, press and hold Shift and press the Left or Right Arrow key. Keep both Shift
and the arrow key held down to select multiple events.
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Refine your event selection

Use the event type buttons to filter the list of displayed events and speed up
your workflow.
•

In Logic Pro, click any of the event type buttons alone, or in conjunction with, specific
selection commands available in the Edit > Select menu or as key commands. These
include:
•

All (or press Command-A): Selects all visible events.

•

All Following (or press Shift-F): Selects all events after (below) the currently
selected event.
Note: When a marquee selection is active, using this key command extends the
marquee selection—over all tracks within a marquee selection—to the project end
point.

•

All Following of Same Pitch (or press Control-Shift-F): Selects all events of the same
pitch that follow the currently selected note event.
Note: When a marquee selection is active, using this key command extends the
marquee selection—over all tracks within a marquee selection—to the project end point.

•

All Inside Locators (or press Shift-L): Selects all events that fall within the locator
boundaries.
Note: When a marquee selection is active, using this key command sets the marquee
selection to match the locators.
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•

Invert Selection (or press Shift-I): Selects all unselected events.

•

Muted Events (or press Shift-M): Selects all muted events. This selection command
is usually a precursor for deletion (Delete).

•

Overlapped Events (or press Shift-O): Selects all events that overlap one another.
This is usually the end of one event and the start of the following event.

•

Same-Colored Events (or press Shift-C): Selects events of the same color.

•

Equal Events (or press Shift-E): Selects identical events (same event type and value).

•

Similar Events (or press Shift-S): Selects all C#3 note events, for example.

•

Same MIDI Channel (or press Shift-H): Selects events on the same MIDI channel.

•

Same Subposition (or press Shift-P): Selects events that start at the same position
within their respective bars.

•

Same Articulation ID (or press Shift-D): Selects note events that have the same
articulation ID.

•

Highest Notes (or press Shift-Up Arrow): Selects note events that are higher in pitch
than the selected note event.

•

Lowest Notes (or press Shift-Down Arrow): Selects note events that are lower in
pitch than the selected note event.

•

Previous Event (or press Left Arrow): Selects the event that precedes the selected
event.

•

Next Event (or press Right Arrow): Selects the event that follows the selected event.

•

Deselect All (or press Option-Shift-D): Deselects all events.

•

Deselect Outside Locators: Deselects all events outside the locator borders.
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Create events in the Logic Pro Event List
The Event List accepts real-time and step recording of MIDI events, as described in
Overview. Similar to the other MIDI editors, you can also create events directly in the
Event List.
You can also perform advanced Copy and Move operations within the Event List. These
commands allow you to directly swap events, or to merge a group of notes from one
section of a region to the same, or another, region. For more information, see Copy notes.

Add an event manually

1. In Logic Pro, move the playhead to the insert position.
The current playhead position is used as the insert position if it’s not moved.
2. Choose an event type from the Event Type pop-up menu.
3. Click the Add Event button (+).
The event is added at the playhead position, and is automatically selected.
Important: Events can only be created in an existing region. If no region is selected, or
exists, on the selected track, an alert appears.

Add a note event using a music or computer keyboard
1. In Logic Pro, move the playhead to the insert position.

The current playhead position is used as the insert position if it’s not moved.
2. Click the MIDI In button if it is not already active (red).
3. Use your music or computer keyboard to enter notes using step input recording
methods. See Use step input recording in.

Duplicate an existing event

This operation is useful for creating a copy of an event with a different value. For example,
creating one or more notes of a particular length and velocity at the same position as
another note lets you change the Pitch (Num column) of the duplicate notes to create a
chord, or a new chord voicing.
1. In Logic Pro, Control-click the original (source) event name in the Status column, then
choose Copy Event from the shortcut menu (or press Command-C).
2. Control-click the original (source) event name in the Status column, then choose Paste
Event from the shortcut menu (or press Command-V).
3. Enter the position for the duplicate event in the input box that appears. If you press
Return, the original event position is used for the copied event.

Add one or more events from the Clipboard

1. In Logic Pro, copy an event from another editor, then choose Edit > Paste (or
press Command-V).
2. Enter a destination position for the first event in the input box that appears. If you
press Return, the original position of the first event is retained and used. The relative
positions of other copied events are maintained.
Important: The position input box is unique to the Event List. Pasted events are not
automatically added at the playhead position, as is the case in the graphical editors.
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Edit events in the Event List
Edit Event List events in Logic Pro
The Event List L(ock), M(ute), Position, Status, Ch(annel), Num(ber), Val(ue), and Length/
Info columns display all details of all event types. In most cases, you can directly edit the
data displayed (except for the Status column, which indicates the event type).
Not all columns are used for every type of event. For example, system exclusive messages
are not MIDI-channel specific, so the Channel column is unused. Aftertouch and polyphonic
aftertouch messages have no length, so the Length/Info column is blank.
In some instances, clicking the information in the Length/Info column opens a pop-up
menu, allowing you to choose an option. For example, clicking the Length/Info value of
a MIDI controller event (Control is shown in the Status column) opens a pop-up menu of
numbered and named standard MIDI controller types. These include Controller numbers
3 = Solo, 7 = Volume, 10 = Pan, and so on.

Details about the different event types, the parameters shown in the columns, and the
impact of changes—on both the event itself and other columns—are found in these sections:
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•

Note events

•

Control change events

•

Pitch bend events

•

Program change events
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•

Aftertouch events

•

Poly aftertouch events

•

SysEx events

•

Meta events

Change event position and length in Logic Pro
The units shown in the Event List Position and Length/Info columns represent bars, beats,
divisions, and ticks (or SMPTE time, when View > Show Event Position and Length as Time
is active). Counting begins at 1 for each unit (first bar, first beat, first division, first tick: 1 1
1 1), and continues until it is carried over to the next largest unit.
Numerical input starts from the left (which means you can enter the bar number only,
and press Return, if you want to move an event to the beginning of a specific bar, when
entering a value). The units can be separated by either spaces, dots, or commas, allowing
you to type 3.2.2.2 or 3, 2, 2, 2 or 3 space 2 space 2 space 2.

Move an event in time

In Logic Pro, do one of the following:
•

Double-click the position indicator (in the Position column), then enter a new value.
Press Return to exit the field.

•

Drag the specific position unit vertically. Release the mouse button when you’re finished.

If another editor, such as the Piano Roll Editor, is open, you see the note event move as you
change the value. As soon as you alter the position of an event, the list is automatically resorted. The currently selected event remains highlighted.

Change the length of an event

In Logic Pro, do one of the following:
•

Double-click the length/info indicator (in the Length/Info column), then enter a new
value. Press Return to exit the field.

•

Drag the specific length/info unit vertically. Release the mouse button when you are
finished.

Changes to the Event List value are immediately shown in other open editors, such as the
Piano Roll Editor.
Note: The minimum possible length is one tick, because you can’t simultaneously switch a
note (or other event) on and off.

Change the appearance of the Position and Length columns
•
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Not every project is bar/beat oriented. Choose one of the following View menu
commands in Logic Pro to make changing the position and length of events easier when
working with film or video, for example.
•

View > Show Event Position and Length as Time: Displays the position and length
columns in SMPTE units.

•

View > Length as Absolute Position: Makes the length display show the absolute
position of the note off event, rather than its length from the note on position.

•

View > Relative Position: Causes the event positions to refer to their relative
positions within the MIDI region (their distance from the start of the MIDI region),
rather than to their absolute location within the project.
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Protect the position of events in Logic Pro
There are situations when you want to prevent certain events from being moved. For
example, you might use several note events to trigger footstep samples that match an
actor walking down a corridor in a movie soundtrack.
If the tempo of your soundtrack needs to be altered at a later stage, the absolute time
location of events that have already been positioned will change. The Lock SMPTE Position
function prevents this from happening. You can SMPTE-lock individual events in the
Event List or entire regions. All events inside locked regions are SMPTE-locked. For more
information see Logic Pro soundtracks overview.
The protect and unprotect functions are available when Enable Complete Features is
selected in Logic Pro > Preferences > Advanced.

Protect the position of one or more selected events
In the Logic Pro Event List, do one of the following:
•

Select one or more events, then choose Functions > Lock SMPTE Position (or use the
corresponding key command).

•

Control-click the event, then choose Lock SMPTE Position from the shortcut menu.

•

Click in the Lock column for the selected events.
A small padlock icon appears in the Lock column of protected events.

This function ensures that events that fall at a particular absolute time position—1 hour,
3 minutes, 15 seconds, 12 frames, for example—remain at this position when tempo
changes are made.

Unprotect the position of one or more events
In Logic Pro, do one of the following:
•

Select one or more locked events, then choose Functions > Unlock SMPTE Position (or
use the corresponding key command).

•

Control-click the event, then choose Unlock SMPTE Position from the shortcut menu.

•

Click the small padlock icon in the Lock column for the selected events.

Change event values in Logic Pro
You can change the event values shown in the Event List Value, Number, and Channel
columns by using the mouse as a slider or with text input. You can not directly alter the
event type in the Status column.
You can also rename regions or folders, but not events.

Alter the event type

In Logic Pro, do one of the following:
•

Choose Functions > MIDI Transform, then choose a preset.
The MIDI Transform window opens, allowing you to transform the event. For more
information, see MIDI Transform window overview.

•
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Add an event of the new type, then delete the original event.
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Override the maximum or minimum value limitation

If a parameter of one of several selected events is altered, it affects the same parameter
in all events within the selection group. When you alter parameter values in a group of
selected events, the relative differences between parameter values remain unchanged.
Parameter values can only be altered until the (same) parameter value of one of the
selected events has reached its maximum or minimum value.
•

In Logic Pro, Option-drag the value.
This technique allows you to continue altering a parameter value in a multiple selection,
even when one of the selected events has reached its maximum or minimum value.

Set a parameter to the same value for all selected events
•

In Logic Pro, press and hold Option-Shift while dragging the value.

Note: It’s possible to select different event types, and simultaneously alter the Number
or Value parameter. However, this can lead to unexpected results. It’s recommended that
you use the event type buttons to hide non-matching event types. The enhanced selection
functions may also be useful when creating or editing groups of events.

Rename regions or folders in the Event List
1. In Logic Pro, do one of the following:
•

Control-click a region or folder, then choose Rename from the shortcut menu.

•

Select a region or folder, then click the region or folder name.

2. Enter a new name, then press Return.

Edit articulation IDs for note events in Logic Pro
Some software instruments included with Logic Pro, such as the Sampler, Drum Kit
Designer, Studio Horns, and Studio Strings provide multiple articulations for MIDI notes.
For example, the software instrument Studio Strings includes pizzicato and staccato
articulations, while Drum Kit Designer includes a series of articulations for closed and open
hi-hat, with multiple steps in between.
Articulation IDs allow multiple articulations to be associated with a single MIDI note, and
provide a way to access these articulations without using complex key combinations.
You can view and edit articulation IDs in the Event List.

View articulation IDs in the Event List
•

In Logic Pro, choose View > Articulation from the Event List View menu.
An Articulation column appears in the Event List, showing articulation IDs for each MIDI
note event. When no Articulation Set is chosen, values between 1–255 can be selected.
When an Articulation Set is chosen, the names of available articulations are shown.
You can only choose Articulation from the Event List View menu when the Event List is
showing the events in a MIDI region.
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Edit articulation IDs in the Event List
•

In Logic Pro, if the track containing the region has an Articulation Set chosen, click the
name of the articulation for a note event and choose a different articulation.
As you change the value for the articulation ID parameter, the articulation for that value
plays. When there is no articulation for the selected value, you hear silence.

You can also work with articulation IDs in the Piano Roll Editor, the Score Editor, and the
Mapping pane group view in the Sampler plug-in.

Mute and delete regions and events in Logic Pro
The Mute and Delete functions go hand in hand, because you often want to remove events
you have muted.

Mute or unmute one or more selected note events

In Logic Pro, select one or more note events, then do one of the following:
•

Choose Functions > Mute Notes On/Off (or press Control–M).

•

Click in the Mute column for the selected events.
An “M” appears in the Mute column of muted note events.
When regions rather than notes are selected, the command appears as Functions >
Mute Regions On/Off.

To quickly select and delete all muted events, choose Edit > Select > Muted Events from
the Event List.

Delete events

In Logic Pro, do one of the following:
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•

Select the events, then press Delete.

•

If your mouse or trackpad supports gestures, swipe left and click delete, or swipe all the
way to the left until the event disappears.

•

Choose one of the following commands in the Edit > Delete MIDI Events menu:
•

Duplicates: Erases all duplicate events.

•

Inside Locators: Erases all MIDI events inside the locators.

•

Outside Locators: Erases all MIDI events outside the locators.

•

Outside Region Boundaries: Erases all MIDI events that fall completely outside the
region borders, which can happen when regions are resized.

•

Unselected Within Selection: Erases all unselected MIDI events within a selection,
such as between locators.
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Event Types
Note events in Logic Pro
Note events are used to trigger (play) software instruments and external MIDI sound
modules or keyboards. You can create note events and other types of MIDI events in the
Event List. For more information, see Create events in the Event List.

Note event parameters
•

Ch(annel): MIDI channel of a note from 1 to 16.

•

Num(ber): MIDI note number (or pitch). The range is from C −2 (note #0) to G8 (note
#127). Middle C is note #60 (known as C3 in MIDI terminology). On some keyboards and
synthesizer modules (notably those made by Korg and Roland), the note range is from
C −1 (note #0) to G9 (#127). Middle C is called C4 on such devices. You can use the
Display Middle C As pop-up menu in the Logic Pro > Preferences > Display pane to alter
the display to match your device.

•

Val(ue): Velocity of a note from 1 to 127. The zero value (0) acts as a note off message,
and cannot be used.

•

Length/Info: Length of the note. Although MIDI can transfer only note on or note off
messages, Logic Pro stores the position and length of all notes, which makes them easier
to access musically. The note off message is generated automatically during playback.

If the edited MIDI region is played through a mapped instrument, the names defined for
each individual note appear in the Status column. A small note symbol to the left of each
name aids in identifying these named events as note events.
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View and change note release velocity data

You can edit the release velocity of a note event when the Additional Info button is on.
•

In Logic Pro, click the Additional Info button (only available in Filter mode).

Control change events in Logic Pro
Control change events are used to transfer MIDI controller information (modulation,
sustain, volume, and pan, for example) to software instruments or external MIDI keyboards
and modules. You can create control change events and other types of MIDI events in the
Event List. For more information, see Create events in the Event List.

Control change event parameters
•

Ch(annel): MIDI channel of an event from 1 to 16.

•

Num(ber): The number of the controller. Each MIDI controller (such as the modulation
wheel or sustain pedal) is assigned a specific continuous controller (CC) number
(CC#1 or CC#64, respectively). This can vary from device to device. Several controllers
(apart from the two above) are defined in the same way by most manufacturers. These
standardized controllers include volume (CC#7) and pan (CC#10).

•

Val(ue): Value of the controller. Continuous controllers have a range of 0 to 127. Switch
controllers (CC#64–CC#90) transfer two states: off (val = 0) and on (any value between
1 and 127).

•

Length/Info: Shows the name of standardized controllers defined in the MIDI Specification.

Pitch bend events in Logic Pro
Pitch bend events in Logic Pro are used to continuously vary the pitch of MIDI notes. They
are usually generated by a centered pitch bend wheel or joystick on your keyboard. You
can create pitch bend events and other types of MIDI events in the Event List. For more
information, see Create events in the Event List.

Pitch bend event parameters
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•

Ch(annel): MIDI channel of an event from 1 to 16.

•

Num(ber): Fine pitch bend division (LSB: Least Significant Byte). Many keyboards
transmit a value of 0. If the pitch bend wheel has a 7-bit resolution, you see values of
either 0 or 64 in this column.
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•

Val(ue): The effective pitch value (MSB: Most Significant Byte), ranging from 0 to 127. A
value of 64 corresponds to the halfway setting of the wheel.

•

Length/Info: The 14-bit value is displayed in this column as a decimal figure ranging
from −8192 to 8191 (if your keyboard transmits 14-bit pitch bend data). The value in this
column can be edited in the usual ways.

Program change events in Logic Pro
Program change events transmitted to connected MIDI devices are used for patch (preset
or setting) selection. These may be sounds in a synthesizer, programs in an effects unit,
or snapshots in an automated mixing desk, for example. You can create program change
events and other types of MIDI events in the Event List. For more information, see Create
events in the Event List.

Program change event parameters
•

Ch(annel): MIDI channel of an event from 1 to 16.

•

Num(ber): Bank select. Normally you see a hyphen (-), which indicates no bank select
messages are sent. If you assign a number between 0 and 126, a bank select event is
sent before the program change event.
Bank select lets you address different sound banks (preset, internal, card, and so on)
of connected MIDI keyboards and modules. The synthesizer must be able to recognize
controller 32 as bank select, but not all manufacturers use the same standard.
If you have problems with bank select, check the documentation that came with your
synthesizer to see whether, and how, it responds to bank select commands.

•

Val(ue): A program number between 0 and 127.
•

Some manufacturers (such as Yamaha) number the programs in their devices from
1 to 128, not 0 to 127. If you have devices that follow this numbering protocol, you
must subtract 1 from the program number shown on the device itself, when adding or
altering a program change event in Logic Pro.

•

Other manufacturers use various methods of dividing internal memory locations
into groups (or banks) and sounds. The most common is divisions into 8 groups of
8 sounds, each numbered 1 to 8. These devices respond to program numbers 0 to
63 by addressing storage locations 11 to 88. The documentation for these devices
should contain conversion tables to assist you.

Note: You can change the type of bank select messages sent by Logic Pro, if necessary for
your devices. For more information, see Custom bank selects in the Logic Pro Environment.
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Aftertouch events in Logic Pro
Aftertouch events are generated by a mechanical pressure sensor beneath some MIDI
keyboards. These events can be used to modulate the synthesizer sound. All note events
on a particular MIDI channel are affected. This means that applying pressure to one note
in a held chord affects all notes in the chord. You can create aftertouch events and other
types of MIDI events in the Event List. For more information, see Create events in the
Event List.

Aftertouch event parameters
•

Ch(annel): MIDI channel of an event from 1 to 16.

•

Num(ber): This column is unused, as aftertouch events have only one data byte.

•

Val(ue): Displays the amount of pressure on the keyboard (0 to 127).

Poly aftertouch events in Logic Pro
Polyphonic (poly) aftertouch events are generated by mechanical pressure sensors
beneath each individual key on some MIDI keyboards. The resulting sound modulation
affects only the particular note that is pressed harder (after the initial keystrike). Only a
few keyboards offer this capability. You can create poly aftertouch events and other types
of MIDI events in the Event List. For more information, see Create events in the Event List.

Poly aftertouch event parameters
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•

Ch(annel): MIDI channel of an event from 1 to 16.

•

Num(ber): Displays the MIDI note name (C3, G4, and so on).

•

Val(ue): Displays the amount of pressure on the key (0 to 127).
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SysEx events in Logic Pro
System exclusive data (SysEx) is unique to individual MIDI devices. You can record
these events by using the dump utilities of your synthesizers, which let you save patch
information, or other data, outside the MIDI device (in a project or MIDI file).

You can choose whether SysEx data is displayed in the Status column in hexadecimal or
decimal format. You can view SysEx data as ASCII characters in the Length/Info column.

View SysEx data in hexadecimal format
•

In Logic Pro, choose View > SysEx in Hex Format.

View SysEx data as ASCII characters
•

In Logic Pro, click the Additional Info button.
The SysEx message is displayed in the Length/Info column. SysEx and EOX status bytes
are represented by Ⓢ and Ⓔ, respectively.

Edit SysEx Data

WARNING: Editing SysEx events requires a thorough understanding of the data format
used by the MIDI device. Incorrect edits can lead to the corruption, or loss, of sound or
other data.
1. In Logic Pro, select a SysEx event in the event list.
2. Click the Additional Info button to view the SysEx message.
3. Click in either the Status column or the Length/Info column to open a text field.
4. When you’re done editing the data, press Return.
For more information on manually programming a SysEx message, see SysEx faders in the
Environment.
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Meta events in Logic Pro
Meta events are control messages that are specific to Logic Pro. They are used
to automate certain functions, and to organize and arrange Score Editor elements
(particularly notation symbols and formatting) that can’t be represented by standard MIDI
events. You can create meta events and other types of MIDI events in the Event List. For
more information, see Create events in the Event List.

The value in the Number column determines the meta event function, and the value in the
Value column determines the value that is sent. The name of the meta event function that
corresponds to the value in the Number column appears in the Length/Info column.
You should only ever insert and edit the following column values in the Event List:
•

Ch(annel): MIDI channel of an event from 1 to 16.

•

Num = 47 (Send Byte to MIDI): This sends the track instrument any byte value (Val)
between 0 and 255 ($00-$FF). For example, if you send 246 as the byte, this is
equivalent to a MIDI tuning request message. The display shows Send Byte $F6. Use
this meta event only if you know what you’re doing—if you don’t, your sound modules
and synths may start to behave very oddly.

•

Num = 48 (Switch Fader): This sends MIDI events to a particular output number (Val) on
a cable switcher. You first need to connect a cable between a track instrument and the
cable switcher in question. For details about cable switchers, see Cable switchers in the
Logic Pro Environment.

•

Num = 49 (Go to screenset): This event selects a screenset. Val determines the
screenset number. For details about screensets, see Create, recall, and switch
screensets.

•

Num = 50 (Project Select): This event switches projects on a MIDI data filer or player.
Val determines the stored project number.

•

Num = 51 (Go to Marker): When this event is sent, playback jumps to another marker.
Val determines the marker number. For details about markers, see Logic Pro markers
overview.

•

Num = 52: This meta event stops playback.

Meta events can also be generated by fader objects in the Environment. See Overview of
the Environment in Logic Pro.
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Use the Event Float window in Logic Pro

The Event Float window provides information on the currently selected event (or region),
and can be compared with a single line of the Event List. You can edit the following
parameters in this window.

•

The start point of the selected event or region in bars, beats, divisions, and ticks, or
SMPTE time

•

The type or name of the selected event or region

•

The recorded MIDI channel and first data byte (if an event), the name of notes, and the
second data byte (if it exists for the event type)

•

The length of the selected event or region in bars, beats, divisions, and ticks, or SMPTE
time

Open an Event Float window
•

In Logic Pro, choose Window > Show Event Float (or use the Toggle Event Float key
command, default assignment: Option-E).

Switch the Event Float window between SMPTE time and the bar/beat display
In Logic Pro, do one of the following:
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•

Open the Project Settings > General pane, then click “Project Type: Use musical grid”
to show the time format in bars and beats. Click the checkbox a second time to clear it
(unchecked), which displays the time format in minutes and seconds.

•

Choose View > Show Event Position and Length as Time in the Event List. This only
applies when “Use musical grid” is active.
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Step Editor
Logic Pro Step Editor Overview

The Step Editor is a graphical editor that can be used to create or edit MIDI note and
controller data. You can use the Step Editor to view and edit different MIDI event types,
shown as vertical beams—or steps—along a timeline within a region.
The Step Editor is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

•

Step: Each beam, called a step, represents a MIDI event. The value of the event is
denoted by the beam height, providing an at-a-glance view of one or more different
events and their values. For more information, see Create steps in the Step Editor and
Change step values in the Step Editor.

•

Lane: Each MIDI event type, be it a note or MIDI controller, is arranged from top to
bottom in horizontal lanes much like the track lanes shown in the Tracks area. The
type of event shown, and controlled, on each lane is freely configurable. You do this by
setting Lane parameters (for each lane) in the inspector. For more information, see Lane
parameters overview.

•

Lane inspector: Use to alter the settings of the selected lane. For more information, see
Use the Lane inspector.

•

Lane Set pop-up menu: You can save groups of lanes (several lanes that you have
defined) as Lane Sets. You access these from the Lane Set pop-up menu in the
inspector. For more information, see Use Lane Sets.

Open the Step Editor
•
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In Logic Pro, select a MIDI region, then choose Window > Open Step Editor.
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Create and edit steps in the Step Editor
Change the Step Editor grid and step display in Logic Pro
The Grid parameter in the Lane inspector is important when creating event steps. When
you create new events, they’re automatically added at grid positions set by the Grid
parameter. This makes it easy to create a drum pattern with 4 divisions on one lane, 8
divisions on another lane, and 16 divisions on another lane—assigned to kick, snare, and
hi-hat sounds, for example.

Define the grid value for the selected lane
•

In Logic Pro, choose a grid type from the Grid pop-up menu in the inspector.

Steps that you add snap automatically to the nearest grid position. The positions of
existing steps are not affected.
Tip: When editing or constructing complex rhythm patterns, it can be useful to create
several lanes (see Create lanes) for one drum note, each with a different quantization grid.
For example, if there are two lanes for a snare drum, one with a 1/16 and the other with a
1/96 grid, you can use the Pencil tool to add individual hits in the coarser grid, and drum
rolls in the finer grid.
You can change the appearance of event steps to make event creation and editing easier.

Set the width of event steps
•

In Logic Pro, choose a value from the Pen Width pop-up menu in the inspector.

The exact step position is always aligned with the left edge of the step, regardless of the
beam width.
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When you set the Pen Width parameter to Note Length, note event steps are displayed at
their actual length. The Status parameter must be set to Note for this to work.

Change the style of step beams
•

In Logic Pro, choose a setting from the Style pop-up menu.
•

No Frames: Shows the value of the event as a beam.

•

Framed Values: Shows a hollow frame that is the full height of the lane. The value of
the event is displayed as a beam within the frame.

Create steps in the Step Editor in Logic Pro
The Step Editor provides several unique methods for creating and editing MIDI events. In
some situations, manual entry of MIDI note and controller events is more efficient than
performing and recording them. One example would be the creation of 1/16 note hi-hats in
a region when the tempo is 180 bpm, which would be difficult to play.
You can also record events with a MIDI keyboard, and then refine your performances in the
Step Editor.

Add a step

1. In Logic Pro, using the Pencil tool, click a time position in the appropriate lane.

2. Drag up or down to alter the event value before you release the mouse button.
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Add multiple steps
•

In Logic Pro, using the Pencil tool, drag horizontally over the time position on the
appropriate lane.

This action results in a freehand curve of new events that follows the (vertical and
horizontal) Pencil tool movements in the lane.

Edit multiple steps in a linear fashion
1. In Logic Pro, select the Line tool.

2. Hold the Line tool down at a position on the lane.
A help tag appears, showing the exact position and event (step) value.
3. Drag the Line tool over the steps you want to edit. This can be to the right or left.

As you move the Line tool, a line trails behind it with the exact position and event value
shown in a help tag.
4. Release the Line tool to change the values of several event beams, aligned along the
line.
Note: You can use the Line tool to alter values for all MIDI events in the Step Editor.
However, it is not possible to create MIDI note events with the Line tool.
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Create or alter a linear series of steps in sections
1. In Logic Pro, select the Line tool.

2. Click a position in the appropriate lane.
A help tag appears, showing the exact position and event value in the top line.
3. Drag the Line tool to the right or left over positions where you want to create or edit
steps.

As you drag the Line tool, a line trails behind it with the exact position and event value
shown in a help tag.
4. Release the Line tool, press and hold it again at the same position, and then drag it to a
new position.
Another line is immediately drawn from the end point of the original line.

Create new events when other events already exist in a lane
1. In Logic Pro, select the Line tool.

2. Click a position on the appropriate lane.
A help tag appears, showing the exact position and event value in the top line.

Logic Pro User Guide

488

3. Move the pointer to the end point of the line (to the right or left).

As you move the pointer, a line trails behind the Line tool, with the exact position and
event value shown in a help tag.
4. Press and hold Option when releasing the Line tool.
The values of existing events in the area between the line start and end points are aligned
along the line (creating a crescendo, for example). New events are created at every
(unoccupied) grid value.

Assign a fixed step value

You can assign a fixed value when creating event steps. When enabled, the Fix Value item
in the Lane Set pop-up menu prevents any event value from being altered with the Pointer
or Pencil tool.
This is ideal when adding steps with the Pencil tool, as all are assigned the value of the
previously selected event. This allows you to draw a succession of events with the same
value, such as a row of 1/16 note hi-hats, for example.
1. In Logic Pro, choose Fix Value from the Lane Set pop-up menu.
2. Click any existing event with the Pencil tool to use its value as a preset.
In Fix Value mode, it’s impossible to alter an event value by clicking it.
Note: When adding events with the Line tool in Fix Value mode, the preset value is always
used as the starting value of the line.

Select steps in the Step Editor in Logic Pro
You can use any of the usual selection techniques in the Step Editor, with the following
variations.

Select individual steps
•

In Logic Pro, press and hold Shift, then click the steps in a lane.

Select several contiguous steps
•

In Logic Pro, press and hold Shift, then drag to select the steps in a lane.
Take care to avoid clicking any steps. If you click or drag with the unmodified Pointer
tool, the selected event values are changed, so make sure you hold down Shift.

Select all steps on a lane
•
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In Logic Pro, click the lane name.
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Select all steps on multiple lanes
•

In Logic Pro, Shift-click the lane names.

Delete steps in the Step Editor in Logic Pro
You can use any of the standard deletion techniques to delete events in the Step Editor.

Delete a step

In Logic Pro, do one of the following:
•

Click the step with the Eraser tool.

•

Click the step, then press Delete.

Delete several contiguous steps in a lane
•

In Logic Pro, drag across the steps you want to delete with the Eraser tool.

Delete several noncontiguous steps
•

In Logic Pro, use the Pointer tool to Shift-click the steps you want to remove, then press
Delete.

Delete similar or equal steps

1. In Logic Pro, select one of the steps you want to delete.
2. Use the Select Similar Regions/Events (Shift-S) or Select Equal Regions/Events (Shift-E)
key command, then press Delete.
You can also delete events by choosing one of the Delete MIDI Events commands from the
Step Editor menu bar. For more information, see Delete notes.

Restore deleted steps in the Step Editor in Logic Pro
Accidental deletions of one or more events, a change of mind, or an editing mistake are
inevitable parts of song creation. Fortunately, you can backtrack your edits easily in
Logic Pro. You also have the option of re-creating an event with the Pencil tool.

Undo the last edit or deletion
•

In Logic Pro, choose Edit > Undo (or press Command-Z) immediately after making the
edit or deletion.

Undo or redo multiple steps

1. In Logic Pro, choose Edit > Undo History.
The Undo History window appears. The most recent edit (at the bottom of the list) is
highlighted.
2. Click any entry to undo or redo all edits between the clicked and highlighted entries.
Important: A Redo list is not displayed until an Undo operation has been performed.
The Redo list appears below the Undo items. The first item that can be redone is indicated
by gray text.
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Undo or redo an isolated edit operation

1. In Logic Pro, choose Edit > Undo History to open the Undo History window.
2. Command-click the edit operation you want to change.
A warning dialog appears.
3. Click Apply to undo or redo the edit operation. Click Cancel if you change your mind.
When the operation is applied, an isolated edit is undone or redone without influencing all
edit operations between the clicked and highlighted (most recent) entries.

Change step values in the Step Editor in Logic Pro
Steps can be altered individually or as a group. When adjusted as a group, the absolute
differences between event values remain constant.

Alter individual step values
•

In Logic Pro, grab the step beam (with the Pointer or Pencil tool), then drag vertically.

The current value is shown in a help tag as you drag.

Alter several contiguous step values
•

In Logic Pro, drag across the steps with the Pointer tool. Vertical movements affect the
value of each step.
The current value is shown in a help tag as you drag across each event.

Alter the values of multiple steps

1. In Logic Pro, select the steps you want to edit using any selection technique.
2. Grab one of the grouped (and highlighted) steps, then drag vertically.
The values of all steps are adjusted. If any of the beams in the group reaches the maximum
or minimum value, you can’t go any farther in that direction.
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Move and copy steps in the Step Editor in Logic Pro
Steps can be moved or copied to other positions in the same, or other, lanes. When moved
or copied between lanes, the event values are retained, but are converted to the target
event type. For example, moving several steps from the volume lane into the pan lane
results in the volume lane step values being used for pan position changes.

Move selected steps
•

In Logic Pro, use the Finger tool to drag the selected steps to the new position and lane.
As you drag, a help tag displays the position, event type, and value (if applicable).

Move steps with key commands
•
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In Logic Pro, assign and use the following key commands to move one or more steps.
The selected events are shifted one unit (referred to in the command) to the right (+1)
or left (−1).
•

Nudge Region/Event Position Right by SMPTE Frame

•

Nudge Region/Event Position Left by SMPTE Frame

•

Nudge Region/Event Position Right by 1/2 SMPTE Frame

•

Nudge Region/Event Position Left by 1/2 SMPTE Frame

•

Nudge Region/Event Position Right by 5 SMPTE Frames

•

Nudge Region/Event Position Left by 5 SMPTE Frames

•

Nudge Region/Event Position Right by SMPTE Bit

•

Nudge Region/Event Position Left by SMPTE Bit

•

Nudge Region/Event Position Right by Tick

•

Nudge Region/Event Position Left by Tick

•

Nudge Region/Event Position Right by Division

•

Nudge Region/Event Position Left by Division

•

Nudge Region/Event Position Right by Beat

•

Nudge Region/Event Position Left by Beat

•

Nudge Region/Event Position Right by Bar

•

Nudge Region/Event Position Left by Bar

•

Nudge Region/Event Position Right by Nudge Value

•

Nudge Region/Event Position Left by Nudge Value

•

Nudge Region/Event Position Right by Sample

•

Nudge Region/Event Position Left by Sample

•

Nudge Region/Event Position Right by 1 ms

•

Nudge Region/Event Position Left by 1 ms

•

Nudge Region/Event Position Right by 10 ms

•

Nudge Region/Event Position Left by 10 ms
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Copy selected steps
•

In Logic Pro, press and hold Option and Shift, then drag the selected steps to the new
position and lane.
As you drag, a help tag displays the position, event type, and value (if applicable).

Copy and move steps with the Clipboard
•

In Logic Pro, use the Clipboard to copy and move steps (events):
•

To copy events to the Clipboard: Choose Edit > Copy (or press Command-C).

•

To move events to the Clipboard: Choose Edit > Cut (or press Command-X).

•

To paste the events at the current playhead position, inclusive of their original
values: Choose Edit > Paste (or press Command-V).

You can also perform advanced Copy and Move operations in the Step Editor. These
allow you to directly swap steps, or to merge a group of events from one section of
a region to the same, or another, region. For more information on common editing
functions, see Copy notes.

Protect the position of steps in Logic Pro
There are times when you want to protect certain steps from being moved. For example,
several note events may be used to trigger footstep samples that match an actor walking
down a corridor in a video soundtrack. You have already created the music for this scene,
but have been asked to increase the tempo to match several cuts of different camera
angles in the corridor. Any change to the project tempo moves the events, resulting in
out-of-sync footstep samples. To circumvent this problem, Logic Pro has a feature that
preserves the absolute time position of events.
The protect and unprotect functions are available when Enable Complete Features is
selected in Logic Pro > Preferences > Advanced.

Protect the position of one or more selected steps
•

In Logic Pro, choose Functions > Lock SMPTE Position (or use the corresponding key
command). Events that fall at a particular absolute time position—1 hour, 3 minutes,
15 seconds, 12 frames, for example—remain at this position when tempo changes are
made.

Unprotect the position of one or more selected steps
•
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In Logic Pro, choose Functions > Unlock SMPTE Position (or use the corresponding key
command).
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Lane parameters
Overview of lane parameters in Logic Pro
The Lane parameters determine the event type shown on each lane. Events are shown as
vertical beams (steps) on each lane, aligned with a particular time position in the ruler.
You can use the Lane parameters to change the way beams are displayed (see Change the
grid and step display). You can also alter the grid resolution for each lane in a Lane Set,
which is useful when creating drum patterns. You adjust the height and horizontal size of
the lanes with the zoom sliders.
You select a lane (and its parameters) by clicking the lane name with the Pointer or
Pencil tool.

You can view and change Lane parameters in the inspector (see Use the Lane inspector).

Select multiple lanes

You can make simultaneous changes to the parameters of several selected lanes (for more
information, see Use the Lane inspector).
•

In Logic Pro, Shift-click each lane name with the Pointer or Pencil tool.

Create lanes in the Step Editor in Logic Pro
You can create new lanes, and set corresponding Lane parameters, in several ways.

Create a new lane

1. In Logic Pro, select a lane by clicking one of the names shown.
The selected lane is highlighted.
2. Choose Lanes > Create Lane (or press Option-Command-N).
A new lane is created. The new lane parameters are identical to those of the originally
selected lane.
3. Adjust the parameters of the new lane in the inspector.

Create one or more specific lane types

You can use the Auto Define feature to automatically create lanes for specific event types
in your project.
1. In Logic Pro, choose Auto Define from the Lane Set pop-up menu (or use the Toggle
Auto Define key command, default assignment: Control-A).
2. Open the Event List window, then click the events you want to create new lanes for.
The clicked events are added as lanes in the Lane Set.
3. Repeat the second step to add more event types to your Lane Set.
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If the Lane Set already contains a matching lane type (for a particular note pitch, as an
example), Logic Pro does not create a superfluous lane. The existing lane is moved into the
visible area of the Step Editor in this situation.
Note: Make sure that you deselect Auto Define immediately after completing your input.

Create lanes for all event types in a region
1. In Logic Pro, select the region.

2. Choose Lanes > Create Multiple Lanes (or use the corresponding key command).
3. In the dialog that appears, click the All button to confirm that you want to create lanes
for all types of events in the region.
Tip: It’s a good idea to create a new Lane Set before creating a group of new lanes. For
more information, see Use Lane Sets.

Edit lane parameters in Logic Pro
You can copy, delete, reorganize, and convert lanes and their associated parameters when
creating Lane Sets.
Tip: Use the Select Next Step Lane or Select Previous Step Lane key commands to
rapidly move between lanes.

Copy a set of Lane parameters between two Lane Sets

1. In Logic Pro, click the name of the lane you want to copy.
2. Choose Lanes > Copy Lane (or press Control-C).
3. Switch to the destination Lane Set by choosing the Lane Set name from the pop-up
menu at the top of the inspector.

4. Choose Lanes > Paste Lane (or press Control-V).

Delete lanes
•
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In Logic Pro, select one or more lanes, then choose Lanes > Delete Lane (or press
Control-Delete).
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Rearrange the order of lanes
•

In Logic Pro, grab the name of the lane that you want to move, then drag it (vertically) to
the new position.

Convert all events on a lane to another event type

You can redefine a lane (along with all event steps on the lane). The values of the events
are retained, but the event type is changed.
1. In Logic Pro, click the name of the lane you want to convert.
All steps on the lane are selected.
2. Do one of the following:
•

Choose Lanes > Convert Lane (or use the corresponding key command).

•

Double-click the name column of the lane that you want to convert.

3. Choose settings in the Convert dialog.

In the Convert pane on the left, you can see the parameters of the selected lane. The
“to” pane lets you set the parameters of the target lane. The current settings (of the
source lane) are used as default values for the target lane.
Select the Quantize Events checkbox to quantize step positions to the grid value chosen
in the right pane. If any delay value is shown on the right, this is taken into account by
the quantization.
If you open the Convert dialog, change the grid value in the area on the right, and select
the Quantize Steps checkbox (and make no further alterations), the step positions of
the selected lane are quantized.
4. Click Convert.
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Use the Lane inspector in Logic Pro
You use the Lane inspector to change the parameters of the selected lane. The most
important parameters are Status and First Data Byte. The Status parameter sets the event
type for the selected lane. The First Data Byte parameter (shown as “Number” in the
image) sets the value for the chosen event type. The appearance of the First Data Byte
parameter changes when different event types are chosen.

Name a lane

The name of the selected lane is visible beside the disclosure arrow in the inspector. This
is mirrored in the Name column in the Step Editor.
•

In Logic Pro, select the name to open a text field, enter a name, then press Return.

Note: If you define a named MIDI controller, or a note from a mapped instrument in the
Status and First Data Byte parameter lines, the relevant name is automatically shown.
Changing a note name in the inspector also alters the corresponding note name in the
mapped instrument.

Delay or advance all steps on the selected lane

The inspector’s Delay parameter is very useful for drum programming (flams, for example),
as only individual event types or note numbers are affected. It’s also useful for tightening
up or sliding notes in a region, without resorting to quantization.
•

In Logic Pro, set the Delay parameter to the value you want to use.
Position changes are immediately reflected by the steps in the lane. New events
(inserted when a grid was active) are offset from the grid positions by the Delay
parameter value.
Tip: In general, you should transmit controller data slightly before or after note
events, to improve the timing of notes. In other words, place controllers before (use a
negative delay value) the grid positions of the notes lying exactly on the grid positions.
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Change the length of new steps
•

In Logic Pro, drag the Length parameter values vertically to change the length of events
(this primarily applies to note events) to be added, measured in divisions (the left
number), and ticks (the right number).
You should avoid the use of small tick values because many MIDI devices do not
respond quickly enough when note on/note off messages are sent in quick succession,
resulting in no note being heard.

Set the MIDI channel number for a lane

1. In Logic Pro, select the MIDI channel checkbox.
•

If selected, the display is restricted to events on the set channel.

•

If unselected, the Channel parameter is ignored, and matching events on all channels
are displayed.

2. Choose a MIDI channel number from the pop-up menu to the right of the Channel
parameter.

Simultaneously change the parameters of multiple lanes

Just as you can adjust the parameters for several MIDI regions at once, you can set the
parameters of several lanes simultaneously.
In Logic Pro, do one of the following:
•

Press and hold Shift, then click several lanes in the Name column.

•

Choose Lanes > Select All Lanes, then deselect lanes you don’t want to change by
Shift-clicking them.

Any alterations you make in the inspector affect all selected lanes.

Change the event type

The event status determines the type of event controlled by each lane.
•
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In Logic Pro, drag the event type shown beside the Status parameter vertically to
choose one of the following:
•

Fader: Defines a fader event lane. Fader event data can be used to control any
possible parameter (except channel volume and pan that use controllers). Fader data
can also be used to create meta events.

•

Meta: Defines a meta event lane. Meta events are internal Logic Pro commands that
can perform tasks such as screenset switching.

•

Note: Defines a lane for a particular note pitch (useful for drum programming).

•

Control: Defines a MIDI controller lane.

•

A-Touch (Aftertouch): Defines a lane for aftertouch (also known as channel
pressure), a feature of many synthesizers that adds vibrato, for example, when you
press down on MIDI keyboard keys that are already held.

•

P-Touch (Polyphonic Aftertouch): As above, but each note can be independently
modulated.
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•

Program Change: Defines a lane that is used to create and send MIDI program
change events, allowing you to switch between sounds (electric piano and clavinet,
for example) midway through a region.

•

Pitch Bend: Defines a lane for pitch bend information.

Important: The chosen Status parameter value (event type) directly affects the
behavior (and appearance) of the First Data Byte parameter. For example, if Note is
chosen as the Status parameter type, you can use First Data Byte to determine the
pitch (MIDI note number) of the selected lane. If the MIDI region is played by a mapped
instrument, a pop-up menu of input note names (drum sound names) appears here.

Show the first data byte and set a value

The First Data Byte checkbox and pop-up menu are shown at the bottom of the inspector.

The name of the First Data Byte parameter reflects the chosen Status parameter,
as follows:
•

Fader, Meta, Control, Program: A number is shown as the first data byte.

•

Note, P-Press: Pitch is shown as the first data byte.

•

C-Press and PitchBd: The first data byte is dimmed, as it has no function.

1. Select the First Data Byte checkbox to show the defined first data byte. Select the box
a second time (unselected) to hide the first data byte. In the case of note events, the
velocity values of all notes (regardless of pitch) are displayed in the relevant lane.
2. Choose a value from the First Data Byte pop-up menu. The choices shown in the popup menu depend on the parameter shown in the Status line:
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•

If Control is chosen in the Status line, the First Data Byte pop-up menu determines
the controller type (controller number).

•

If Meta or Fader is chosen in the Status line, the First Data Byte pop-up menu
determines the meta or fader event type (meta or fader message number).

•

If channel aftertouch (C-Press), or program change events (Program) is chosen in
the Status line, the First Data Byte parameter setting is ignored and the first data
byte is displayed as a beam height.

•

When pitch bend data (PitchBd) is chosen in the Status line, the First Data Byte
parameter setting is also ignored because both data bytes are used to display the
beam height.
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Use Lane Sets in the Step Editor in Logic Pro

You can store a combination of lanes as a Lane Set. When a Lane Set is saved, the vertical
zoom setting of the Step Editor is stored. You can save as many Lane Sets as required in
each project.
The Lane Set functions let you limit the Step Editor display to only the required MIDI event
types. For example, imagine you have recorded a synthesizer lead MIDI region. You could
create a Lane Set that contains individual lanes for each note pitch in the region. Drag each
note event step vertically to adjust its level. Within the same Lane Set, you could create
two more lanes to control the lead synthesizer’s filter cutoff and resonance parameters,
allowing you to create or precisely edit filter changes.

The Step Editor provides two default Lane Sets: MIDI Controls and GM Drum Kit.
•

MIDI Controls: Provides lanes for Volume, Pan, Modulation, and several other commonly
used controller types.

•

GM Drum Kit: Provides lanes that match the note names of the General MIDI (GM) drum
map. This option lets you draw note events (steps) for drum parts, and is similar to the
use of pattern-based drum machines, where each beat is manually entered on a grid.
You can use this Lane Set for any instrument type.

If you leave the Lane Set pop-up menu set to Automatic, lanes are automatically added for
each kind of event in the MIDI region.

Switch between Lane Sets

You can switch the Step Editor display to show particular event types by loading an
existing Lane Set.
•

In Logic Pro, choose a Lane Set from the Lane Set pop-up menu in the inspector.

Create a Lane Set

In Logic Pro, do one of the following:
•

Choose Lanes > New Lane Set from the Step Editor menu bar (or use the Lane Set
pop-up menu, or corresponding key command).
The new Lane Set contains a default lane for the Volume controller (#7). Any changes
you make, such as adding or changing lanes or lane parameters, or adjusting the
vertical zoom setting, are automatically stored in the current Lane Set.

•
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Choose Lanes > New Lane Set for Current Events (or use the Lane Set pop-up menu,
or corresponding key command) to create a new Lane Set, consisting of the currently
selected event types.
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Create a Lane Set for a GM drum kit

General MIDI has an established keyboard assignment pattern (a MIDI note map) for drum
and percussion sounds. This mapping standard is often followed in non-GM, GS, or XG
compliant sound modules, samplers, and synthesizers. In some cases, however, you need
to make a few changes.
As the Step Editor is ideally suited for creating and editing drum kits, you may want to
create a Lane Set that is specifically tailored for your drum sets, including the correct drum
names and hi-hat modes.
•

In Logic Pro, choose Lanes > New Lane Set for GM Drums from the Step Editor menu
bar (or use the Lane Set pop-up menu, or corresponding key command).
You can change the names, positioning, and hi-hat modes of each drum or percussion
lane in the Lane Set. See Use the Lane inspector, for information on renaming each
drum sound in your kit, if it doesn’t match the GM mapping standard.

Define a hi-hat group

In hi-hat mode, lanes can be grouped together. Only one event from grouped lanes can be
played at any ruler position. This function is typically used to prevent different hi-hat notes
(open, closed, pedal) from being inserted at the same time position. This mirrors the realworld behavior of hi-hats, which can’t be simultaneously opened and closed.
1. In Logic Pro, click the dot shown to the left of a lane name (Open HH, for example).
2. Click the dot shown to the left of other (vertically adjacent) lane names (Ped HH, for
example).
A dotted line links the two lanes in the left edge of the column.

3. Click the dots of each lane to turn off hi-hat mode.
All lanes in a hi-hat group must be vertically adjacent to each other. To group several
events in nonadjacent lanes, move the lanes by dragging the names up or down the
Step Editor window.
If you add an event to any lane in a hi-hat group, all existing events at this time position
are deleted.
You can create as many hi-hat groups as needed in a Lane Set, but each group must be
separated by at least one lane that does not belong to a hi-hat group.
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Rename a Lane Set
•

In Logic Pro, choose Rename Lane Set from the Lane Set pop-up menu. Enter a new
name, then press Return.

Clear the current Lane Set

Clearing a Lane Set resets a Lane Set to its default, containing a single lane for the
Volume controller.
In Logic Pro, do one of the following:
•

Choose Lanes > Clear Lane Set from the Step Editor menu bar (or use the
corresponding key command).

•

Choose Clear Lane Set from the Lane Set pop-up menu in the inspector.

Delete the current Lane Set

In Logic Pro, do one of the following:
•

Choose Lanes > Delete Lane Set from the Step Editor menu bar (or use the
corresponding key command).

•

Choose Delete Lane Set from the Lane Set pop-up menu in the inspector.

Audio File Editor
Overview of the Logic Pro Audio File Editor

Most day-to-day audio editing tasks in Logic Pro are performed on audio regions in the
main window and Audio Track Editor. Using the Audio File Editor, which displays the audio
waveform of regions, you can make changes directly to audio files themselves.
The Audio File Editor is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
To start editing and processing audio in the Audio File Editor, select an area within the
waveform display. To refine your selection, you can use key commands to navigate the
audio file, zoom in and out, and play and scrub the audio.
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You can change the display settings in order to:
•

View the recorded digital data as sample bits.

•

Set the ruler time scale to display samples, minutes and seconds, SMPTE time, or bars
and beats.

•

Set the amplitude scale as percentage units or sample units.

Once you have made a selection, you can use standard Cut, Copy, Paste, and Delete
commands on the selected area, or you can do the following:
•

Use a selection to set the project tempo.

•

Use the Pencil tool to remove pops and clicks in audio material.

•

Set looping points and save them to the file.

•

Reverse audio and invert phase.

•

Normalize audio files.

•

Adjust gain.

•

Add fades.

•

Trim or add silence.

•

Remove direct current (DC) offset.

Additionally, you can use the Audio File Editor to edit transients. The first time you enable
a track for Flex Time editing, Logic Pro analyzes the audio on the track and marks the
transients it detects in the file. You can use transient markers to select audio for editing
and processing.
Important: Most edits and functions performed in the Audio File Editor are destructive,
permanently altering the original audio file. Although you can undo edits and processing
commands, you should work with copies of your audio files, rather than the originals.

Open the Audio File Editor

In Logic Pro, do one of the following:
•

Double-click an audio region, then click the File tab at the top of the Editors pane.

•

Select an audio region in the main window, click the Editors button
then click the File tab at the top of the Editors pane.

•

Select an audio region in the main window, then choose Window > Open
Audio File Editor (or use the Open Audio File Editor key command, default
assignment: Command-6).

in the control bar,

The Audio File Editor opens in a separate window.
•
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Option-double-click an audio region in the Project Audio Browser.
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Audio File Editor interface
Overview of the Logic Pro Audio File Editor interface
The Audio File Editor contains the following elements:
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•

Waveform overview: Shows a miniature view of the entire audio waveform. Click
different parts to focus them in the waveform display underneath.

•

Waveform display: Shows a detailed view of the waveform area selected in the
waveform overview.

•

Transient Editing Mode button: Analyzes the audio file for transient events, and marks
them. You can increase or decrease the number of events detected using the +/–
buttons.

•

Catch Playhead button: Reflects the current playback position.

•

Tool menus: Choose two tools from the pop-up menus. The second (alternate) tool
is chosen with the Option key.

•

Preview button: Starts and stops playback of the selected file, region, or loop.

•

Cycle button: Loops playback of the selected area.

•

Zoom sliders: Drag to adjust the vertical and horizontal zoom level.

•

Info display: Shows the start point and length of the selected area.

•

Ruler: Shows the position of the region in the project. If you have not yet added
the audio file to your song, the position marker lines are dotted, indicating no time
connection exists.

•

Region marker: Indicates the length of the region. Edit this beam to adjust the
region length.

•

Anchor: Indicates the absolute start point of the audio file.

•

Amplitude scale: Indicates the amplitude of the audio waveform as a percentage or
in sample units.
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Change the Audio File Editor waveform display in Logic Pro
When working in the Audio File Editor, you can switch the waveform from its usual view to
one that shows the structure of the recorded digital data. This view is useful when you are
eliminating clicks and pops from your recordings, for example.

Display the waveform as sample bits
•

Choose View > Show as Sample & Hold from the Audio File Editor menu bar.
Note: You need to zoom the waveform display to high magnification levels to see
sample bits.

Change the Audio File Editor waveform amplitude scale in Logic Pro
When working in the Audio File Editor, you can customize the waveform’s amplitude scale
along the vertical axis in either percentage units or sample units.
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Display the amplitude scale in percentage units
•

In Logic Pro, choose View > Amplitude Percentage from the Audio File Editor menu bar.

Display the amplitude scale in sample units
•

In Logic Pro, choose View > Amplitude Sample Value from the Audio File Editor menu bar.

Tip: You can also open the amplitude scale shortcut menu by Control-clicking the
waveform amplitude scale itself.

Change the Audio File Editor ruler display in Logic Pro
In the Logic Pro Audio File Editor, you can change the scale units in the ruler to display
samples, minutes and seconds, SMPTE time, or bars and beats. The info display above the
waveform overview uses the scale units you have set to show the start point and length of
the currently selected area.

Change the Audio File Editor ruler scale units
•

In Logic Pro, choose one of the following scale units from the Audio File Editor’s View
menu:
•

Samples: Displays the number of samples.

•

Min:Sec:Ms: Displays the absolute scale in hours, minutes, seconds, and
milliseconds.

•

SMPTE Time: Displays the SMPTE scale in hours, minutes, seconds, and frames.

•

Bars/Beats: Displays the scale in bars, beats, divisions, and ticks.

Tip: You can also access these options via a shortcut menu by Control-clicking
the ruler.

Play audio files in the Audio File Editor in Logic Pro

There are a number of playback options in the Audio File Editor. Playback of audio files in
the Audio File Editor occurs independently of the project playhead position. To hear the
audio file in the context of your arrangement, you should use the control bar buttons.
The Mixer’s Preview channel strip is used for monitoring in the Audio File Editor. You can
access the Preview channel strip by clicking the All button in the Mixer menu bar. The
Preview channel strip is located to the right of the highest-numbered audio channel strip.
Important: If the waveform position is shifted vertically away from the zero amplitude line,
you can remove the DC offset to help center the waveform and reduce crackling sounds at
the start and end of the audio region during playback.

Audio File Editor playback key commands

In Logic Pro, you can use the following key commands to enhance your playback options:
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•

Play/Stop All: Plays back the whole audio file, regardless of the selected area.

•

Play/Stop Region: Toggles between playback of the region start and end points,
regardless of the selected area.

•

Play/Stop Region to Anchor and Play/Stop Region from Anchor: Allows you to check the
region anchor position by listening to the parts just before and after the anchor.
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Control playback with the Preview button

1. In Logic Pro, Control-click the Preview button, then choose an option from the shortcut
menu:

•

Auto-select Channel Strip: Plays the region displayed in the Audio File Editor through
the audio channel strip assigned to the region’s source track (shown in the main
window).

•

Preview Channel Strip: Plays back using the Preview channel strip. You can access
the Preview channel strip in the Environment’s Mixer layer. It’s located to the right of
the highest-numbered audio channel strip.

2. Click the Preview button (or use the Play/Stop Selection key command, OptionSpace bar) to start playback.
3. Click the Preview button (or use the Play/Stop Selection key command, OptionSpace bar) to stop playback.

Control playback with the ruler
•

In Logic Pro, double-click the ruler at the point where you want playback to begin. A
second double-click stops playback.

Control playback with the waveform overview
In Logic Pro, do one of the following:
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•

Click and hold at the point where you want playback to begin. The pointer turns into a
Preview icon. Release the mouse button to stop playback.

•

Double-click at the point where you want playback to begin.
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Scrub audio
•

In Logic Pro, click and hold the ruler, then move the pointer.

Audio playback follows the speed and direction of your pointer. This technique helps you to
quickly locate a particular position within an audio file.

Repeat the selected area continuously
1. Click the Cycle button.

2. Click the Preview button (or use the Play/Stop Selection key command, Option-Space bar).
You can change the start and end points of the selected area during looped playback, to
create a perfect drum loop cycle, for example. When you’re satisfied with the loop, you can
make the selected area a new region.
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Navigate audio files in the Audio File Editor in Logic Pro

You can use the Audio File Editor navigation features in Logic Pro to move to specific parts
of an audio file, making selection and editing simpler, faster, and more accurate.
Clicking the waveform overview displays the selected area (surrounding the playhead
position) in the waveform display. The scroll bars and zoom controls are used in the same
way as in other windows.

Use Edit menu navigation commands

In Logic Pro, choose one of the following Edit > “Go to” menu commands to quickly
navigate to a specific position in an audio file.
•

Selection Start (or press Control-Shift–Left Arrow)

•

Selection End (or press Control-Shift–Right Arrow)

•

Region Start (or press Control–Left Arrow)

•

Region End (or press Control–Right Arrow)

•

Region Anchor (or press Control–Down Arrow)

•

Previous Transient (or press Command–Left Arrow)

•

Next Transient (or press Command–Right Arrow)

Navigate to the loudest point in an audio file

In Logic Pro, the Audio File Editor includes a feature that scans a selected audio file for its
loudest point. When it locates the loudest point, it positions the playhead at this point in
the waveform display.
•

Choose Functions > Search Peak (or press Shift-P).

Navigate to silent passages in an audio file

In Logic Pro, you can scan a selected audio file, or a selection, for sections containing
silence. When the Audio File Editor locates sections containing silence, it moves the
playhead to the start point of the first silent section.
•

Choose Functions > Search Silence (or press Shift-S).
This command can be used repeatedly to select and remove, or to modify, silent
sections in your audio files.
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Make selections in the Audio File Editor
Select audio in the Audio File Editor in Logic Pro
To start editing and processing audio in the Audio File Editor, select an area within the
waveform display. Any editing or processing you perform affects only the selected area.
The start point and length of the currently selected area are shown in the info display—
above the waveform overview. The format of the information is based on the setting chosen
in the View menu. See Change the ruler display.

Use the basic selection techniques outlined below to select an entire audio file, or part of
an audio file, for editing or processing.
For tips about accelerating the selection process, see Navigate audio files in the Audio
File Editor.

Select the entire audio file
•
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In Logic Pro, choose Edit > Select All (or press Command-A).
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Select a section of an audio file
•

In Logic Pro, click and hold the start or end of the area you want to select in the
waveform display, then drag to the right or left.

The start point and length are displayed (as sample words) in a help tag while you make
your selection.

Extend an existing selection area

In Logic Pro, do one of the following:
•

Choose Edit > Select All Previous (or use the corresponding key command).

•

Choose Edit > Select All Following (or use the corresponding key command).

Define the selected area using a region
•

In Logic Pro, select a region in the Browser or main window, then choose Edit > Region
→ Selection.

This function is useful if you want to reselect the entire region for cycled playback—after
performing a number of edits, for example.
The reverse can also be done, allowing you to redefine the length of an existing region by
choosing Edit > Selection → Region.
You can modify selections by changing their start or end point, or you can move the entire
selected area completely.
Note: If you choose Edit > Snap Edits to Zero Crossings, any length adjustments to audio
region start or end points snap to the nearest zero-crossing point of the waveform.
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Change the start or end point of an existing selection
In Logic Pro, do one of the following:
•

Shift-click in the waveform display to move the start or end point.

•

Press and hold Shift as you drag the start or end point of the selected area in the
waveform display.

Using either method, the proximity of your click—to the start or end of the selected area—
determines whether you change the start or end point boundary. The closest one wins.
Tip: If you press and hold Option-Shift, the more distant selection boundary is changed
(rather than the nearer).

Move the selected area

You can move the whole selection to the left or right without changing its length.
1. In Logic Pro, do one of the following:
•

Option-click the selection.

•

Click the selection with the Move tool.

2. Drag left or right.
When you move the selected area, the pointer or Move tool turns into a two-headed arrow.
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Select audio with transient markers in Logic Pro
You can use transient markers to select part of an audio file for editing purposes.
Note: To do this, you first need to turn on Transient Editing mode in the Audio File Editor.
For more information, see Edit audio files with transient markers in Logic Pro.

Select a section of an audio file between two transient markers
•

In Logic Pro, double-click the area of the waveform display between the two transient
markers.

Use transient marker menu commands
•
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In Logic Pro, choose Edit > Set from the Audio File Editor menu bar to use the following
commands:
•

Selection Start to Previous Transient: The selection start is extended to the left, up
to the preceding transient marker.

•

Selection Start to Next Transient: The selection start is shortened to the right, up to
the following transient marker.

•

Selection End to Previous Transient: The selection end is shortened to the left, up to
the preceding transient marker.

•

Selection End to Next Transient: The selection end is extended to the right, up to the
following transient marker.

•

Selection Start and End to Previous Transient: The selection start and end are both
moved to the left, up to the preceding transient marker.

•

Selection Start and End to Next Transient: The selection start and end are both
moved to the right, up to the following transient marker.

•

Selection Start and End to Previous Transient and Play: The selection start and end are
both moved to the left, up to the preceding transient marker, then playback begins.

•

Selection Start and End to Next Transient and Play: The selection start and end are
both moved to the right, up to the following transient marker, then playback begins.

•

Region Anchor to Previous Transient: The region anchor is moved to the left, up to
the preceding transient marker.

•

Region Anchor to Next Transient: The region anchor is moved to the right, up to the
following transient marker.
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Set project tempo with selected audio in Logic Pro
Just like automatic tempo matching functions in the main window, you can set the project
tempo to match the current locator positions and selected area in the Audio File Editor.
Although this operation is similar to the one described in Match the tempo to an audio
region, it applies only to the selected area of the audio file in the Audio File Editor, rather
than to the overall length of the region.

Use an audio file selection and locators to set the project tempo

1. In Logic Pro, click and hold the start or end of the area you want to select in the
waveform display, then drag to the right or left.
2. Adjust the locator positions in the control bar or ruler, if necessary.
3. Choose Functions > Adjust Tempo by Selection and Locators.
The project tempo changes in accordance with the current locator positions and
selected area in the Audio File Editor.

Edit and process audio in the Audio File Editor
Use commands to edit audio in Logic Pro
The Audio File Editor in Logic Pro includes several standard audio editing and processing
commands and functions.
When you have selected an area of an audio file, you can use the Cut, Copy, Paste, and
Delete commands in the Edit menu to cut, copy, paste, or remove the selected area.

Edit menu commands
•

Cut: Cuts a selected passage out of an audio file, and copies it to the Clipboard. All
audio sections that follow move forward—toward the start point of the audio file—to fill
the gap.

•

Copy: Copies a selected passage to the Clipboard, leaving the selected area in its
original location. Unlike the other Edit menu commands, the Copy command is nondestructive.

•

Paste: Inserts the contents of the Clipboard at the clicked position. All audio data that
follows the paste (insert) point is moved back—toward the end of the audio file—to
make room for the Clipboard contents.

WARNING: Anything selected at the time of the paste is deleted—replaced by the
Clipboard contents.
•

Delete: Erases the selection, without placing it in the Clipboard. A gap is left in the
audio file.

•

Delete and Move: Erases the selection, without placing it in the Clipboard. All data
beyond the deleted passage is moved forward—toward the start point of the audio file—
to fill the gap.

Most audio editing and processing activities in the Audio File Editor are destructive.
Destructive activities modify the data of the original audio file, rather than make changes
to playback parameters. You can, however, use the Undo feature (see Undo Audio File
Editor edits).
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Tip: Although you can undo edits and processing commands, you should work with
copies of your audio files, rather than the originals. For details about creating and restoring
backups in the Audio File Editor, see Backup audio files.
Note: You cannot make destructive edits to an audio file if Flex Pitch has been activated
for a region containing the audio file. If possible, make destructive edits to the audio file
before activating Flex Pitch, or use Bounce in Place and make the destructive edits to the
resulting audio file.
You can use key command to perform destructive sample editing functions. When doing
so, you are asked to confirm your actions before making any changes and overwriting the
original audio file. You can bypass this safety feature.

Turn off the key command warning
•

In Logic Pro, choose Preferences > Audio > Audio File Editor, then deselect the
“Warning before processing function by key command” checkbox.

Edit audio files with transient markers in Logic Pro
You can use transient markers to edit selected areas of an audio file, or the entire file, in
the Audio File Editor. You can also add or move transient markers within audio files. You do
all of these tasks in Transient Editing mode.
Note: When you’re working in Transient Editing mode, the Command-click tool changes its
default value, from the Move tool to the Pencil tool.

Turn on Transient Editing mode

In Logic Pro, do one of the following:
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•

Choose View > Transient Editing Mode from the Audio File Editor menu bar (or use the
Toggle Transient Editing Mode key command).

•

Click the Transient Editing Mode button in the Audio File Editor.
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When you turn on Transient Editing mode, the audio file is analyzed for transient events,
and all detected transients are marked in the audio file.

The level of transient detection confidence is based on the clarity of the transients. If
an audio file does not have clear, sharp transients, transients are detected with a lower
level of confidence. You can display more or fewer transients by using the Plus and Minus
(+/−) buttons.
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•

Plus button (+): Increases the number of transients in the selected area of the audio
file, or across the entire audio file. You can also use the Increase Number of Transients
key command, default assignment: Command-Plus (+).

•

Minus button (−): Decreases the number of transients in the selected area of the audio
file, or across the entire audio file. You can also use the Decrease Number of Transients
key command, default assignment: Command-Minus (−).
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Create a transient marker in an audio file
•

In Logic Pro, click the waveform display with the Pencil tool.

A transient detection process is started for the audio material around the clicked position,
and the transient with the highest energy becomes valid and is marked. If no transient is
found in the catch area, a transient marker is created at the clicked position.

Move a transient marker in an audio file
•

In Logic Pro, drag an existing transient marker to another position.

Note: The new position may or may not snap to zero crossings, depending on whether
or not Snap Edits to Zero Crossings is chosen in the Edit menu. You can also Controlclick to open a shortcut menu and choose Snap Edits to Zero Crossings.

Delete transient markers from an audio file
In Logic Pro, do one of the following:
•

Double-click individual markers with the Pointer or Pencil tool.

•

Click individual markers with the Eraser tool.

•

Drag over multiple markers with the Eraser tool.

•

Select an area of the audio file and press the Delete key.

All transient markers in the selected area are deleted.
Note: Transient markers are not actually deleted. Instead, their display threshold is set
to maximum, making them invalid. You can revalidate a transient marker using the Plus
button (+).
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Detect transient markers in an audio file
•

In the Audio File Editor, choose Audio File > Detect Transients (or use the Detect
Transients of Audio File key command).

Transients are detected across the audio file, overwriting (after you confirm the action) any
manually added or edited transients.
Note: You can also detect transients in factory audio Apple Loops. A copy of the loop is
saved in the project’s Audio Files folder.

Use the Audio File Editor Pencil tool in Logic Pro
You can use the Pencil tool in the Audio File Editor to correct clicks and pops in your audio.
You may find it useful to change the view of the waveform so that it shows the data
structure. For more information, see Change the waveform display.
Note: You cannot edit Apple Loops with the Pencil tool. If possible, bounce the region in
place and make the edits to the resulting audio file.

Correct pops and clicks with the Pencil tool

1. In Logic Pro, navigate in the Audio File Editor to the section of the waveform you want to
correct.
Tip: Pops and clicks are often the loudest part of an audio file, so you may find the
Functions > Search Peak command useful when looking for them.
2. Use the zoom sliders to magnify that section of the waveform, then use the Pointer tool
to scrub the audio around the pop or click.
This action helps you identify exactly where you need to draw.
3. Select the Pencil tool and drag from left to right (including up or down movements) to
draw in a new shape for the waveform spike.
The edges of drawn sections are automatically smoothed.
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Press Option to affect both sides of stereo waveforms.

As long as the mouse button is held down, the drawn waveform can be replaced by the
original waveform, by moving the pointer to the left.

Trim or silence audio files in Logic Pro
With the Trim function in the Audio File Editor, you can remove areas of the audio file that
are not selected. The function is, for example, useful for removing unimportant passages—
such as silence—from the start and end of your audio files. You can also use the Trim
function to remove portions of audio files that are not used by regions.
You can use the Silence command to set all amplitude values to 0, rather than removing
(with Cut, Delete, or Trim) all data from the selected area of an audio file. This function is
generally used to silence unwanted background noise in quiet passages.
Note: You cannot use the Trim or Silence functions on Apple Loops, surround files, or
regions on tracks where Flex Pitch is turned on. If possible, bounce the region in place and
make the edits to the resulting audio file.

Trim all unselected portions of an audio file
•

In Logic Pro, choose Functions > Trim from the Audio File Editor menu bar (or
press Control-T).

Important: Make sure the areas you are about to trim (delete) do not contain any regions
that you may need. Regions outside the selected area are lost. Portions of regions that fall
partly outside the selected area are also removed, resulting in a length reduction of the
region. If any such regions are being used in the main window, a warning dialog gives you
the option of canceling the Trim operation.
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Silence the selected area of an audio file
•

In Logic Pro, choose Functions > Silence from the Audio File Editor menu bar (or press
Control-Delete).

Remove DC offset in Logic Pro
Some audio interface hardware can layer direct current (DC) over the audio signal. The
resulting vertical shift of the waveform position is clearly visible in the Audio File Editor.
DC offset can also cause crackling sounds at the start and end of the audio region during
playback. Removing DC offset centers the waveform around the zero amplitude line.
Note: You cannot remove DC offset on Apple Loops, surround files, or regions on tracks
where Flex Pitch is turned on. If possible, bounce the region in place and make the edits to
the resulting audio file.

Remove DC offset
•

In Logic Pro the Audio File Editor, select the audio file, then choose Functions > Remove
DC Offset.

Set audio file levels in Logic Pro
You can use the Change Gain command to change the level of an audio file in the Audio
File Editor. Typically used on an entire audio file, this command can also be used to boost
portions of the file.
Note: You cannot use the Change Gain command on Apple Loops, surround files, or regions
on tracks where Flex Pitch is turned on. If possible, adjust the Gain parameter in the region
inspector, or bounce the region in place and make the edits to the resulting audio file.

Raise or lower the level of the selected audio file (or area) by a specific amount
1. In Logic Pro, choose Functions > Change Gain from the Audio File Editor menu bar.
2. Choose your settings in the Change Gain dialog:

•

Set the required level change in the Change Relative fields by clicking the up or down
arrows, or by directly entering values, in either field. You can use the percentage or
decibel field to indicate the amount of increase or decrease you prefer.

•

Click the Search Maximum button to search for the peak level. This automatically
sets a value that is used to alter the level of the audio file. The Results in Absolute
fields display the maximum level that is achieved by changing the gain—by the
amount shown in the Change Relative fields.

3. Click Change to perform the gain change.
Important: You should never make a gain change that results in a value over 100%,
because this results in digital clipping.
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Normalize audio files in Logic Pro
Normalization raises the peak level of an audio file by a specified amount—typically to its
highest possible digital level without introducing distortion through clipping. The amount
of level increase is applied to the rest of the selected audio, preserving the dynamic
characteristics of the audio file.
In the Audio File Editor, you can set the maximum level (as a percentage or in decibels) in
one of the “Peak at” fields in the Function Settings window (choose Functions > Function
Settings or click the Settings button in the Normalize dialog).
These settings are automatically stored in Logic Pro preferences when the app is closed,
and they apply to all projects.

Tip: You should not choose 100% (0 dB) in these fields, as this may result in clipping
if you need to increase the gain (with an EQ, for example) of the overall signal later in the
production process. A good rule of thumb is to reserve 3 to 6 dB of headroom or more, to
allow for further audio processing tasks, such as mixing and effects processing.
Note: You cannot use the Normalize command on Apple Loops, surround files, or regions
on tracks where Flex Pitch is turned on. Use the Normalize Region Gain function in the
Tracks area, or bounce the region in place and make the edits to the resulting audio file.

Normalize the selected area of an audio file
•

In Logic Pro, in the Audio File Editor menu bar, choose Functions > Normalize (or
press Control-N).
Logic Pro locates the point with the highest volume in the selected area, and determines
how far it is from the maximum possible level. The normalization process then raises the
level of the selected area by this amount. The dynamic relationships of sample levels
within the audio passage remain unaltered.

Tip: The start and end points for the section being normalized should generally
not fall within a continuous section of audio because this results in abrupt increases
in volume after normalization. The start and end points should therefore be located in
sections that occur just after, or before, musical gaps.

Add fades to audio files in Logic Pro
You can use the Audio File Editor to destructively add a fade-in or fade-out to an entire
audio file, or on a selected area of the file. Your changes permanently alter the original file.
•

Fade-In: Volume is set to 0 at the start point of the selected area, and the fade-in
occurs over the length of the selection.

•

Fade-Out: Volume is set to 0 at the end point of the selected area, and the fade-out
occurs over the length of the selection.

The fade-in or fade-out time is determined by the selected area within the audio file.
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Note: You cannot use the Fade-In and Fade-Out functions on Apple Loops, surround files,
or regions on tracks where Flex Pitch is turned on. If possible, you can bounce the region in
place and add fades to the resulting audio file. Alternatively, you can use the Fade tool or
the Fade-In and Fade-Out parameters in the Region inspector to create more flexible and
non-destructive fades.

Create a fade-in or fade-out

1. In Logic Pro, select a section of the audio file to determine the length of the fade-in or
fade-out area.
2. Do one of the following:
•

To create a fade-in: Choose Functions > Fade-In from the Audio File Editor menu bar
(or press Control-I).

•

To fade passages out automatically: Choose Functions > Fade-Out from the Audio
File Editor menu bar (or press Control-O).

Tip: If you use the Silence function (see Trim or silence audio files) to remove unwanted
background noise from silent passages, small jumps in volume can sometimes occur at the
silence start and end points. If this happens, zoom in and select a small area just before
and after the start point of the signal, then use the Fade-In function.

Adjust the fade curves

1. In Logic Pro, choose Functions > Settings from the Audio File Editor menu bar to open
the Function Settings window.

2. Edit the Curve value to change the shape of the fade-in or fade-out curve.
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3. Select the S Curve checkboxes if you want to create S-shaped curves.

These settings are automatically stored in Logic Pro preferences when the app is closed,
and they apply to all projects.
Tip: The Fade tool in the main window offers a flexible, non-destructive fade option. For
more information, see Create fades on audio regions.

Reverse audio and invert phase in the Audio File Editor in Logic Pro
The Reverse command is most commonly used on an entire audio file—to reverse a cymbal
sound, for example. It can also be used as a creative option on selected portions of audio
files. For example, the reverb tail at the end of a file can be reversed, copied, and pasted to
the beginning of the file.
The Invert command is useful for correcting phase cancellation errors, or when several
out-of-tune signals (or several signals processed through chorus effects) are to be mixed
down to mono. You can also use the Invert function to decode mono/stereo recordings, but
it’s easier to use the Direction Mixer plug-in for this task.
Important: The Reverse and Invert commands are destructive, permanently altering the
original audio file. Although you can undo edits and processing commands, you should
work with copies of your audio files, rather than the originals.
Note: You cannot use the Reverse and Invert commands on Apple Loops, untagged loops,
surround files, or regions on tracks where Flex Pitch is turned on. If possible, use the
Reverse parameter in the Region inspector, or bounce the region in place and use the
Reverse command on the resulting audio file.

Reverse the selected area of an audio file
•

In Logic Pro, choose Functions > Reverse from the Audio File Editor menu bar (or
press Control-Shift-R).

Reverse the phase of all selected audio material
•

In Logic Pro, choose Functions > Invert from the Audio File Editor menu bar (or use the
corresponding key command).
All negative amplitude values become positive, and vice versa.
Note: This doesn’t audibly change the file, if heard in isolation.
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Create Loops in the Audio File Editor in Logic Pro
The Audio File Editor Loop commands, available from the Edit menu, are ideal for use
with Sampler.
You can also use these functions to generate audio files that contain the loop settings in
the file header. This allows you to make full use of these files in any app that can read the
loop information in the file header.

Use the Audio File Editor Loop commands

1. In Logic Pro, choose either of the following commands from the Edit menu:
•

Sample Loop → Selection: The loop area (defined by the loop start and end points) is
used to select a portion of the overall audio file.

•

Selection → Sample Loop: The selected area is used to set the loop start and end
points.

2. Choose Edit > Write Sample Loop to Audio File.
The new loop values are written to the file header.

Undo Audio File Editor edits in Logic Pro
Most Audio File Editor functions in Logic Pro, are destructive, changing the files stored on
your hard disk. However, you can use the Undo feature if things do not go your way.

Compare (or undo) your edits with the original audio file
•

Choose Edit > Undo (or press Command-Z).

Cancel a destructive edit that is in progress
•

Press Command-Period (.).

The audio file is retained in its original state, even if it appears that a portion of the editing
function has occurred.
You can configure the Audio File Editor’s Undo function in the Preferences > Audio > Audio
File Editor pane. See Audio File Editor preferences.

Backup audio files in the Audio File Editor in Logic Pro
Although the Undo History and standard Undo functions are available in Logic Pro, try to
get in the habit of creating backups before processing or editing. This provides a safety
copy of your audio recordings in case something unexpected happens, due to a processing
error or other unforeseen event.
You can make manual backups of the file you’re editing, or replace it with a backup version
at any time, using a variety of functions.

Duplicate the audio file you’re working on
•

In Logic Pro, choose Audio File > Create Backup from the Audio File Editor menu bar (or
press Control-B).

A copy of the audio file (with the extension .dup) is created in the same folder as the
source file.
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Revert to a backup file
•

In Logic Pro, choose Audio File > Revert to Backup from the Audio File Editor menu bar
(or press Control-Option-Command-B).

This function completely replaces the current audio file with the backup (provided
one exists).
Important: You cannot reverse this function with Undo.

Save a copy with a different name to a specific location

1. In Logic Pro, choose Audio File > Save A Copy of Audio File As from the Audio File Editor
menu bar.
2. Choose your settings in the Save A Copy As dialog:

You can set the sample rate, bit depth, file format, stereo conversion, and dither type
for the destination file. The dialog also features an “Add resulting files to Project Audio”
option, allowing you to add the file to the Project Audio Browser, following the save.
3. Browse to the location (such as a hard disk and folder) where you want to store the
audio file, then enter a name for the audio file in the Save As field.
4. Click Save.

Save the selected area as a new audio file
•

In Logic Pro, choose Audio File > Save Selection As from the Audio File Editor menu bar
(or press Shift-Command-S).
The Save Selection As dialog includes the same file conversion choices as the Save A
Copy As dialog.
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Use an external sample editor with Logic Pro

You can configure Logic Pro to open an audio region or file in an external sample
editing app.

Use an external sample editing app

1. In Logic Pro, open Audio preferences by doing one of the following:
•

Choose Preferences > Audio (or use the Open Audio Preferences key command).

•

Click the Preferences button in the control bar, then choose Audio from the pop-up
menu.

2. Click File Editor, then click Choose.
In the dialog, browse for the app, then click Choose.

Open a selected audio file in the external sample editor
•

In Logic Pro, choose Edit > Open in [external sample editor] from the Audio Track Editor
menu bar (or press Shift-W).

The external sample editor opens, allowing you to perform edits on the audio file.

Transfer audio edited in the external sample editor back to Logic Pro
•

Save the file in the external sample editor, then switch back to Logic Pro.

The edited audio is updated in the Browser and main window, if regions based on the audio
file are in use.
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MIDI Transform window
Overview of the MIDI Transform window in Logic Pro

The MIDI Transform window is so named because it transforms MIDI events—based on
conditions, operations, and values you choose—into different types of events, or events
with different values.
The MIDI Transform window is available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
The MIDI Transform window is a powerful tool for edits that would otherwise be impossible
(or tedious). For example, imagine an orchestral project that has been sent to you for
editing. The individual violin and viola parts were recorded with a different string library.
Two hundred MIDI regions contain aftertouch information that introduces an unpleasant
pitch modulation, and some sample layer switching artifacts when played with your string
samples. After looking at this aftertouch information, you discover that only a small
range of values is causing the problem. Your options: edit your sampler instruments,
manually remove all aftertouch information (region by region, or globally, thus losing the
performance benefits that the aftertouch information provides), or alter the problematic
values in the MIDI Transform window.
A number of preset transform sets are available for many common editing tasks. These
may be all you’ll ever require, but should the need arise, you can create and save your own
transform sets, and recall them later.

Tip: The Environment contains a similar transformer object that you can use for realtime transformations of MIDI events. See Transformer objects.
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Open the MIDI Transform window
In Logic Pro, do one of the following:
•

Choose Window > Open MIDI Transform (or use the Open Transform key command,
default assignment: Command-9).

•

If you want to transform events that you have selected in one of the MIDI editors,
choose a preset from the Functions > MIDI Transform submenu.
Note: You can choose the Window > Open MIDI Transform command while you are in a
MIDI editor, but you need to manually select a preset.

Use MIDI transform sets in Logic Pro

The Presets pop-up menu is shown at the top-left corner of the MIDI Transform window.
The first 18 items in the menu are write-protected preset templates for common
editing tasks, such as creating crescendos or fixing note lengths. See MIDI Transform
window presets.

You can temporarily change the used parameters of a preset, but all changes are discarded
when you exit the preset.
Depending on your needs, it may be worthwhile to create your own transform sets. These
can be configured and saved as part of a project. (Doing this in your template projects
makes your transform sets available in all projects.) Your transform sets are shown at the
bottom of the Presets pop-up menu.

Use a transform preset

1. In Logic Pro, select the MIDI regions or events that you want to transform.
2. Choose a transform set from the Presets pop-up menu in the MIDI Transform window.
For more information, see MIDI Transform window presets.
3. In the Mode pop-up menu, choose how you want to transform the selected events
within the regions.
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4. Set the selection conditions.
5. Define the operations you want to perform.
Note: You can deselect the “Hide unused parameters” checkbox (turn it off) to show all
conditions and operations, allowing you to make more advanced choices.
6. Do one of the following:
•

To select all events that meet the selection conditions: Click Select Only. The events
are not transformed. You can use this option to refine your selection, and make sure
that your conditions only affect the events that you truly want to transform.

•

To transform all selected events, in accordance with the operations settings: Click
Operate Only. (The selection conditions have no effect.) This is useful if you want to
edit events that you’ve already selected manually.

•

To select all events that match the conditions, and transform them according to the
operations settings: Click Select and Operate.
Note: The number of selected regions and events (that match the conditions) are
displayed above the selection and operation buttons.

Create a user transform set

1. In Logic Pro, choose Create New Transform Set from the Presets pop-up menu in the
MIDI Transform window.
2. Set conditions and operations.
3. Select the “Hide unused parameters” checkbox. This helps to avoid changes to
conditions and operations that aren’t required for (or may disturb) your transform set.
4. Choose New Parameter Set (Number) from the Presets pop-up menu. Enter a new name
for your transform set.

This transform set now appears at the bottom of the Presets list in all MIDI Transform
windows for this project. You should consider saving your user transform sets in one or
more template projects. This way, they are always available to you in all future projects.
Tip: Renaming an existing transform set creates a new transform set that is identical
to the original. The existing (source) transform set is retained.
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Import all transform sets from another project

You can import transform sets from other projects, allowing fast access to a transform
preset you created earlier. This function is also useful for adding existing transform sets
to new template projects.
1. In Logic Pro, choose File > Project Settings > Import Project Settings (or press
Command-I).
2. Browse to, and select, the project that contains the transform sets you want to import.
3. Click the Import button.
The project’s tracks are displayed in the All Files Browser.
4. Click the Import Project Settings button at the bottom of the All Files Browser, then
select the Transform Sets checkbox.
5. Click the Import button.
The names of imported transform sets are retained and added to the bottom of the
Presets list.

Overview of MIDI Transform presets in Logic Pro

The following table describes the operations performed by the MIDI Transform window
presets in Logic Pro.
Preset

Operation

Fixed Velocity

Sets a fixed velocity for note events. Change the Velocity value field in the
Operations area to adjust all selected events to the chosen velocity.

Random Pitch

Sets a random pitch for note events. Change the Pitch condition values to
alter your selection range.

Random Velocity

Sets a random velocity for note events. Change the Velocity condition
values to alter your selection range.

Random Pitch, Velocity, Length

Sets a random pitch, velocity, and length for note events. Change the
Pitch, Velocity, and Length condition values to alter your selection ranges.

Crescendo

Used to gradually increase the velocities of a group of notes from low to
high values (or vice versa—decrescendo or diminuendo).

• Select the area (Position column) that contains the note events that you
want to perform a crescendo on.
• Set the velocity values in the Operations area, ranging from 1 to 127.
• If you want a less dynamic crescendo, set a smaller value range.

• To perform a diminuendo, set a higher value in the top Velocity field,
and a lower value in the bottom field.
Scale 14 Bit PitchBd

Scales pitch bend data, keeping the 14-bit information intact. The length
of pitch bend events is expressed as a decimal value ranging from −8192
to 8191, and this is the 14-bit information that is retained.
• Choose the multiplication factor for the fine pitch bend (LSB) and
effective pitch values (MSB) in the top value field shown in the
Operations area.

• Set the (14 bit) value in the lower field, which is then added to the
scaled (multiplied) events.
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Preset

Operation

Double Speed

Doubles the tempo by halving event positions and lengths. By default, the
Div(ision) value fields for the Position and Length operations are set to
2.0000. This preset is a useful creative option for drum regions. Change
the values in both fields to 4.000 to quadruple the tempo.

Half Speed

Halves the tempo by doubling event positions and lengths. The Mul(tiply)
value fields for the Position and Length operations are set to 2.0000 by
default. Set both Mul operation value fields to 1.5000 to reduce the tempo
by approximately 30%.

Humanize

Adds a random value to the position, velocity, and length of selected note
events. It can add life to strictly quantized material, or manually entered
notes. This preset is useful on rhythmic parts, such as clavinet, piano,
drum, and percussion.
Alter the values for Position, Velocity, or Length to increase or decrease
the random factor for each of these event parameters.

Reverse Position

Reverses the positions of events (usually notes) within a section. Change
the Position condition values to alter your selection range.

Reverse Pitch

Inverts the pitch of all note events. Change the Flip operation value to set
a pivot point note number, around which note event pitches are reversed.

Transposition

Transposes all note events.

• Change the Add operation value to the required amount (in semitone
steps).
• Set a negative value in the field for a downward transposition.

Exponential Velocity

Alters the scaling of the velocity curve. This preset is useful for software
or MIDI instrument parts. Velocity is often used to control both the initial
volume of instruments and to trigger filter envelopes, making the sound
brighter or darker. Transforming regions can be faster than changing
velocity scaling or filter parameters of your MIDI or software instruments.
Change the Velocity value field in the Operations area to change the
velocity curve. This is reflected in the map area.

Velocity Limiter

Limits the velocity to a maximum value. This is useful for transforming
instrument parts that are too strident, by limiting the velocity. Change the
Max operation field value to limit the velocity to a maximum value. This is
reflected in the map area.

Fixed Note Length

Creates constant note lengths. Useful on many instruments, particularly
drums and other rhythmic parts, such as pianos, clavinets, and basses.

Change the Length value field in the Operations area to resize all selected
events to the chosen length. Both shorter and longer events are changed
to match the specified length value.
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Maximum Note Length

Sets the maximum length of all note events. Change the Length value
field in the Operations area to define the maximum note length. Existing
notes that are shorter than the length defined in the Length field retain
their lengths. Events that are longer than the defined value are reduced in
length.

Minimum Note Length

Sets the minimum note length. Change the Min value field in the
Operations area to define the minimum note length. Existing note lengths
that are longer than the length defined in the Min field retain their lengths.
Note events that are shorter than the defined value are increased in
length.

Quantize Note Length

Change the Length value field in the Operations area to define the length
that note end positions are quantized to.
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MIDI Transform window parameters
Overview of MIDI Transform parameters in Logic Pro
The MIDI Transform window in Logic Pro includes the following parameters and elements
that can be used to process your MIDI data. See MIDI Transform window examples.

These parameters globally affect the MIDI Transform window appearance and
operating mode.

Global parameters
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•

Presets pop-up menu: Choose one of the transform presets or one of your own
transform sets.

•

Mode pop-up menu: Choose one of the following options to determine how events are
transformed.
•

Apply operations to selected events: Applies the operations to all selected events.
The selected events are determined by the selection conditions.

•

Apply operations and delete unselected events: Transforms the selected events,
and deletes all unselected events. Only events that match the selection conditions
remain after the transform operation. This mode allows you to use the MIDI
Transform window as a programmable filter, where only events that match the
conditions survive.

•

Delete selected events: Deletes all events that match the conditions, leaving all
other remaining events unchanged. This mode allows you to use the MIDI Transform
window as a programmable erase function. The operation settings are irrelevant in
this mode.

•

Copy selected events, then apply operations: Retains the selected events in their
original form, copies them, and applies the operations.
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•

Options pop-up menu: Choose additional options from this menu.
•

Hide Unused Parameters: Hides all unused menus in the Selection Conditions and
Operations areas. This provides a better overview of the settings in use. It also
prevents you from making accidental alterations.

•

Relative Position: Position range values correspond to the start of the region.

•

Absolute Position: Position range values correspond to the start of the project.

•

Marquee selection defines position range: Position range values correspond to the
events selected by the Marquee tool.

Set MIDI Transform selection conditions in Logic Pro
You can define conditions that determine which events are selected for transform
operations. This is done in the Selection Conditions area of the MIDI Transform window.
Each column represents a different MIDI event parameter.
The condition is considered to be fulfilled when an event matches the defined effective
range, and values, of all event parameters. These ranges and values are determined in the
pop-up menus and fields found under each of the event parameter columns.

Selection conditions
•

Position: Determines the time position of the event, referenced to the start point of the
MIDI region (not the start point of the project).

•

Status: Determines the event type.

•

Channel: Recorded MIDI channel of the event

•

Data Byte 1/Pitch: First data byte (controller number) or note pitch

•

Data Byte 2/Velocity: Second data byte (controller value) or note velocity
Note: The parameters displayed in the Data Byte fields are dependent on the Status
pop-up menu setting. Certain Status pop-up menu settings do not show the Data Byte
fields at all.

•

Length: Length of the note or event

•

Subposition: Time position of the event, within a bar

Choose the event type
•
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In Logic Pro, open the Status pop-up menu in the MIDI Transform window to determine
which events will be selected. You have a choice of two settings:
•

All: All event types fulfill the condition.

•

“=”: An additional pop-up menu is displayed (below the Status pop-up menu), where
you can define the event type. These include note, poly aftertouch, control change,
program change, aftertouch, pitch bend, meta, and fader.
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Set all other selection conditions
•

In Logic Pro, open the pop-up menus in the MIDI Transform window (in each column
that is needed) to define the selection criteria for events. One or two value fields appear
below the pop-up menu, unless Map is chosen. You can assign one of the following
value conditions for each of the parameter columns:
•

“=”: The event must be equal to the value in the field, for the condition to be fulfilled.
For example, only note C#3 events meet the condition.

•

Unequal: The event must not be equal to the value in the field, for the condition to
be fulfilled. All events that are not C#3 meet the condition, for example.

•

Smaller/Equal (<=): The event value must be less than, or equal to, the value in the
field (a note velocity less than, or equal to 98, for example) for the condition to be
fulfilled.

•

Larger/Equal (>=): The event value must be larger than, or equal to, the value in the
field (a note pitch higher than, or equal to C#3, for example), for the condition to be
fulfilled.

•

Inside: The event must fall within the value range (of event positions or note pitches,
for example) of both fields, for the condition to be fulfilled.

•

Outside: The event must be outside the value range (of event positions or note
pitches, for example) of both fields, for the condition to be fulfilled.

•

Map: Most conditions are numerical relationships, and the condition is met if the
incoming MIDI event value satisfies the condition. The last condition, Map, works
a little differently. Two numerical parameters are specified, and the incoming value
is first converted by the map, to create a mapped value. The mapped value is then
compared with the two parameters to see if it falls inside them. Incoming events with
a mapped value that falls within the range fulfill the condition—all other events do
not fulfill the condition. For more information, see Use the MIDI Transform map.

Set the values for a selection condition
•

Use the mouse as a slider, or enter a value directly into the field.

Set MIDI Transform operations parameters in Logic Pro
The Operations area is used to define the changes you want to make to events that meet
the selection conditions. As with the selection condition pop-up menus, you choose an
operation in the appropriate event parameter columns. One or two value fields may appear,
depending on the chosen operation.

Define the operation for the status event parameter column
•

Open the pop-up menu, then choose one of the following operations for the Status
condition:
•

Thru: The event type passes through unaltered.

•

Fix: The event type is altered. Choose a new event type from the pop-up menu that
appears below the Status Operations pop-up menu. Choices include fader, meta,
note, poly aftertouch, control change, program change, aftertouch, and pitch bend.
This operation effectively converts one type of event to another.
Note: When you convert note events, two events are created: one for the note on
event, and one for the note off event.
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•

MapSet: Choosing this setting means that events that match the Status condition
(note events, for example) are used to control the map of a subsequent operation—in
the Channel, Data Byte 1, Data Byte 2, and Length columns.
•

The Data Byte 1 value selects the position in the map.

•

The Data Byte 2 value determines the value at this map position.

Internally, Logic Pro sends a meta event pair: #123 for the position, and #122 for the
value at this position. These types of meta events can also be created in other ways.

Define the operation for all other event parameter columns
•
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In Logic Pro, choose one of the following operations in the MIDI Transform window for
the Channel, First or Second Data Byte, and Length columns (as required). One or more
value fields appear below the respective operations pop-up menus.
•

Thru: The event passes through unaltered.

•

Fix: Fixes the event parameter to the set value. You could use this to set the pitch of
all note events to a specific note value, making it easy to convert a bass groove into
a hi-hat pattern, for example.

•

Add: Adds the value to events. For example, a value of 8 could be added to all
incoming note velocity events, thus making the notes louder.

•

Sub: Subtracts the value from events. You could use this to reduce all controller
10 (Pan) events, thereby narrowing the stereo spread of an electric piano part, for
example.

•

Min: Parameter values lower than the defined value are replaced (by this value).
Larger parameter values are not altered. You could use this to replace all note
velocity messages below 45, thereby reducing the dynamic range of a MIDI region—
or put another way, making the soft notes louder.

•

Max: Parameter values that exceed the set value are replaced by it. Smaller event
parameter values remain unaltered. This could be used to restrict filter resonance
modulation events above a value of 100, for example, resulting in a softer filter
sound.

•

Flip: All parameter values that match the conditions are reversed around a pivot point
(the value defined here). Events above this value are moved by the same distance
below it, and vice versa. For example, you could move a note from E3 to G#2, if the
pivot point value was set to C3. Effectively, the E3 event, which is 4 (pitch) values
above the C3 pivot point is flipped to 4 values below (G#2). This can also be used to
reverse selected note positions around a particular bar or beat, as another example.

•

Mul: The parameter value is multiplied by the set value (accurate to four decimal
places). The effect, and use, of this operation is best illustrated by the Half Speed
preset.

•

Div: The parameter value is divided by the set value (accurate to four decimal
places). The effect, and use, of this operation is best illustrated by the Double Speed
preset.

•

Scale: The parameter value is multiplied by the top value, and the bottom value is
then added. This is a combination of Mul and Add. If you enter a negative number
here, values can be subtracted from—rather than added to—the value resulting from
the multiplication.
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•

Range: Parameter values outside the set value range are replaced by the values of
the (range) limits (combination of Min and Max).

•

Random: Random values are generated within the set limits.

•

+-Rand.: A random value between zero and the set value (positive or negative) is
added.

•

Reverse: The parameter value is reversed within its value range (no value can be
set here).

•

Quantize: The parameter value is quantized to a multiple of the set value.

•

Qua & Min: Like Quantize, but the quantization does not fall below the set value (a
combination of the Quantize and Min functions, with the same set value).

•

Expon.: The parameter value is scaled exponentially. The extreme values (0 and 127)
remain unaltered. The set value determines the shape of the curve. Positive values
result in the exponential scaling of data (increasing input values remain lower for
longer, and then rise quickly), and negative values result in the logarithmic scaling
of data (decreasing input values remain higher for longer, and then drop off more
quickly).

•

Crescendo: This only works if the Inside Position selection condition is selected
(crescendos need start and end points). Crescendo creates a smooth alteration of
the current parameters, between the set value boundaries.

•

Rel.Cres: This only works if the Inside Position selection condition is selected.
The effect is similar to that achieved by Crescendo, but the previous values of the
parameters being altered are taken into account when the crescendo is created,
preserving the relative feel of the original.

•

Use Map: The set map is used when this operation is selected. For more information,
see Use the MIDI Transform map.

Set the values for an operation
•

Use the mouse as a slider, or enter a value directly into the field.

Use the MIDI Transform map in Logic Pro
The map display in the MIDI Transform window contains 128 vertical bars that reflect the
full MIDI value range (from 0 to 127), and provide a visual overview of the transformation.
Each bar represents a particular MIDI value that can be mapped to a different value.
The type of event, and operations, are determined in the Selection Conditions and
Operations areas.

•
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The map is visible only when chosen in one of the Operations pop-up menus.
Appropriate selection conditions must also be set, or the map does not appear.
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•

The map is universal, which means that it remaps one MIDI value to another.

•

The map does not know what type of MIDI data is sent to it. It only affects the value of
the data.

This means that one map can be used to simultaneously alter the pitch, velocity, and length
values of incoming note events, for example.

Map usage example
•

Each of the bars could represent a MIDI note number (from 0 to 127) value.

•

By default, there is a 1:1 relationship for each bar, where value 1 = value 1, value 15
= value 15, and so on, throughout the 128 bars. Applying this to MIDI note numbers,
bar 60 = C3 (middle C), bar 61 would represent C#3, bar 62 = D3, and so on.

The default and mapped values are shown in the two fields at the lower left of
the map area.
•

You can alter these values directly in the fields, or by dragging any of the bars vertically.
As you do so using either method, the corresponding field or bar is updated.

•

If you alter the bar 60 (middle C) value to show 72 in the “mapped to” field, this value is
remapped accordingly when the Transform operation is applied.

This results in all MIDI note number 60 messages being transformed into MIDI note number
72 messages (effectively transposing all C3 notes to C4).

Exchange MIDI Transform parameter values in Logic Pro
You can reroute the value of each of the three event parameters—Channel, Data Byte 1, and
Data Byte 2—to the value of a different parameter from this group.

Replace the source (Condition value) with the target parameter value
•

Click the dots on the lines between the Selection Conditions and Operations areas.

Repeated clicks cycle between different targets.
Note: The value is exchanged before the operation is performed.
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MIDI Transform window examples in Logic Pro

This section provides several usage examples for the MIDI Transform window in Logic Pro.

Add a mod wheel controller event (#1) with a value that matches the note’s
velocity
1. In Logic Pro, choose the following settings in the MIDI Transform window:

•

Mode pop-up menu: Copy selected events, then apply operations.

•

Selection Conditions area: Set Status to Note.

•

Operations area:
•

Set Position to Add, then enter a value of 1 in the field below it.

•

Set Status to Fix, then choose Control from the pop-up menu below it.

•

Set Pitch to Fix, then enter a value of 1 in the field below it. This means “the
first data byte receives the value of 1” (the first data byte defines the controller
number for controller events, and mod wheel events happen to be #1).

Note: When you convert MIDI note events to controller events, two controller events
are created: one for the note on event, and one for the note off event.
2. Click Select and Operate.
If you analyze these settings, you’ll see that all note events are selected for operation. A
copy of each is made, then moved one tick later than the original, and converted to CC#1
(mod wheel), with a value that corresponds to the velocity of the original note. This is
because the second data byte (Vel) is left unaltered.
The automatic offset by one tick after each note start point and end point avoids potential
conflicts with the source note events.

Create a transform set that fixes all note velocities to a defined amount

1. In Logic Pro, choose Create Initialized User Set from the Presets pop-up menu in the
MIDI Transform window.
2. Set the Status pop-up menu in the Selection Conditions area to “=.”
3. Choose Note from the pop-up menu below.
4. Choose the Fix setting from the Velocity pop-up menu in the Operations area.
5. Change the amount to 127 in the field below the Velocity pop-up menu.
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Convert MIDI note events to MIDI controller 1 events

1. Choose the following settings in the MIDI Transform window:

•

Mode pop-up menu: Apply operations to selected events.

•

Selection Conditions area: Set Status to Note.

•

Operations area:
•

Set Status to Fix, then choose Control from the pop-up menu below it.

•

Set Pitch to Fix, then enter a value of 1 in the field below it.

Note: When you convert MIDI note events to controller events, two controller
events are created: one for the note on event, and one for the note off event.
2. Click Select and Operate.

Randomly change the pitch of MIDI note events

1. In Logic Pro, choose the following settings in the MIDI Transform window:

•

Mode pop-up menu: Apply operations to selected events.

•

Selection Conditions area: Set Status to Note.

•

Operations area: Set Pitch to +-Random, and set the max deviation from the root
note in the field below. If you set a value of 12, you’ll achieve a deviation of one
octave up and one down (two octaves, around the root note, in other words).

2. Click Select and Operate.
Tip: To restrict the randomness to one direction—up or down, as opposed to both—
use the other Random Option, which limits the range that notes fall into.
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Make note selections for edit operations

1. In Logic Pro, choose the following settings in the MIDI Transform window:
•

Selection Conditions area:
•

Set Status to Note.

•

Set Position to Inside, then choose the range.

2. Click the Select Only button.
All notes in the defined range are selected for you to cut, move, or otherwise modify.

Delete volume events (MIDI CC#7) from a MIDI region

1. In Logic Pro, choose the following settings in the MIDI Transform window:

•

Mode pop-up menu: Delete Selected Events.

•

Selection Conditions area:
•

Set Status to Control.

•

Set Data Byte 1 to a value of 7.

2. Click Select and Operate.
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Delete all controller events from a region

1. In Logic Pro, choose the following settings in the MIDI Transform window:
•

Mode pop-up menu: Delete selected events.

•

Selection Conditions area: Set Status to Control.

2. Select the MIDI region you want to transform, then click Select and Operate.

Create an ascending pitch pattern from notes of one pitch

1. In Logic Pro, choose the following settings in the MIDI Transform window:

•

Mode pop-up menu: Apply operations to selected events.

•

Selection Conditions area:

•

•

Set Status to Note.

•

Set Position to Inside, then define the range. (Cresc. only works if the Inside
Position selection condition is chosen, as crescendos need start and end points.)

Operations area: Set Pitch to Cresc., then enter a value of D0 and G6 in the fields
below.

2. Click Select and Operate.

Experiment with the Double Speed preset in the Step Editor

This example assumes that a 4/4 kick, snare, hi-hat, and other percussion sounds region is
being viewed in the Logic Pro Event List editor.
1. Click the Name column of one of the drum sounds.
All note events of a particular pitch in the region are selected.
2. Change the Length field to a value that does not match the Position field, or vice versa.
3. Repeat the steps with other drum or percussion sounds.
This can lead to interesting polyrhythms you may not have thought of.
The example illustrates the use of the same Transform operation multiple times on the
same region. You can also combine different transform presets to achieve an end result, by
using them one after the other.
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Mix a project

Overview of mixing in Logic Pro

When you mix a project, you balance the different parts and blend them into a cohesive
whole. You can also add effects to alter the sound, use routing and grouping to control the
signal flow, and use automation to create changes in your project over time. In Logic Pro
you do this in the Mixer, which opens below the Tracks area or as a separate window.
Although there are no hard rules for mixing, it typically involves the following steps. You
may find yourself moving back and forth between steps as you work on the mix:
•

Set channel strip volume levels to balance different instruments.

•

Set channel strip pan or balance positions to place instruments in the stereo field.

•

Add and adjust plug-ins (effects and instruments) to change the sound of a track or the
overall project.

•

Control signal flow to route a signal to multiple destinations, create subgroups, or
process sounds individually.

•

Create changes over time using automation curves on individual tracks or regions, or on
the master track.

In the process of mixing, you can find different ways to accelerate and simplify your
workflow, by muting and soloing channel strips, working with channel strip settings and
Mixer groups, and customizing the Mixer.
If you decide not to keep any adjustments to channel strips or plug-ins you make in the
Mixer, you can undo them using Mixer Undo.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can choose from different Mixer views, displaying only those channel strips that you
need for the task at hand.
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Open the Mixer in the main window
In Logic Pro, do one of the following:
•

Click the Mixer button

in the control bar.

•

Choose View > Show Mixer (or press X).

Open the Mixer as a separate window
•

In Logic Pro, choose Window > Open Mixer (or press Command-2).

Control which channel strips appear in the Mixer
In Logic Pro, do any of the following:
•

To show the signal flow of the channel strip that corresponds to the selected track in
the Tracks area, click the Single button.

•

To show the signal flow of all channel strips that correspond to tracks in the Tracks
area, click the Tracks button.

•

To show the signal flow of all channel strips available in the project, click the All button.

Note: Aux and output channel strips are examples of channel strips that don’t have
a corresponding track in the Tracks area. You can, however, create tracks for such
channel strips by choosing Options > Create Tracks for Selected Channel Strips from
the Mixer menu bar.
•

You can also filter channel strips by type in the Mixer.

•

Use the Cycle Through Mixer Modes key command.

Show or hide Track Stack channel strips

In Logic Pro, click the disclosure arrow at the bottom of the channel strip in the Mixer.
Make sure that View > Follow Track Stacks is chosen from the Mixer menu bar to mirror the
display of Track Stack subtracks in both the Mixer and Tracks area.
You can also perform some basic mixing tasks in the Tracks area.
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Mixer channel strips
Channel strip types in Logic Pro

You use channel strips to process audio or MIDI information that is routed from tracks. The
Mixer shows all channel strips in your project, including track channel strips, auxiliary and
output channel strips, Voltage Controlled Amplifier (VCA) channel strips, and the master
channel strip. When you create a new project from a template, the Mixer includes channel
strips for the audio, instrument, and MIDI tracks in the template, as well as the master
channel strip and one or more output channel strips, depending on your audio interface. As
you add tracks to a project, Logic Pro adds channel strips to the Mixer for each new track.
You can also add Auxiliary and VCA tracks from the Mixer > Options menu, as described in
the use aux channel strips and use VCA groups groups sections.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can filter channel strips by type, displaying only those you need for the task at hand.
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•

Audio channel strips: Used to control the playback and recording of audio signals on
audio tracks. All data on the audio track is routed to the audio channel strip assigned in
the track list.

•

Instrument channel strips: Used to control software instruments. You insert a software
instrument using the channel strip Instrument slot. The instrument channel strip can
then produce sound from any MIDI regions on the associated track, or from notes you
play on a MIDI keyboard.
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•

Aux (Auxiliary) channel strips: Used for a variety of signal-routing purposes. Aux
channel strips are used to set up send returns, where a channel strip signal is routed
to an aux channel strip for effects processing. They are also used for grouping and for
distributing a signal to multiple destinations via sends.

•

Output channel strips: Represent the physical audio outputs of your audio interface.
They are used to adjust the overall level and stereo balance or pan position of all audio,
instrument, or aux channel strips routed to them. The number of available output
channel strips is determined by the audio interface you are using.

•

VCA channel strips: Represent a VCA group, used to control the volume, or automate a
submix, of tracks that are assigned to the VCA fader.

•

Master channel strip: Used as a global volume control for all output channel strips. The
master channel strip changes the gain of all output channel strips without affecting
the level relationships between them. This is helpful as a proportional output volume
control, and is particularly useful in Logic Pro surround format, where you can use it to
create fades in the complete surround mix.

•

MIDI channel strips: Used to control external MIDI tracks. MIDI data on these tracks
is routed to a MIDI output port and channel, for control of MIDI sound modules and
keyboards.

Note: Bus and input channel strips are included for compatibility with earlier versions of
Logic Pro. Signal routing and other bus channel strip functions are now handled by aux
channel strips. Audio hardware inputs are now handled by audio channel strips.

Delete channel strips
•

In Logic Pro, select one or more channel strips and press the Delete key.
If the channel strips you wish to delete are assigned to tracks or receiving signal from
active busses, a dialog appears informing you that you can choose to delete all the
selected channel strips, or to deselect those that are assigned and only delete the
remaining channel strips.

Filter channel strips by type
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•

In Logic Pro, click a filter button in the Mixer to show or hide the channel strip type.

•

Option-click a filter button to show that channel strip type; all other channel strip types
are hidden.
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Scroll to specific channel strip types

When you have more channel strips than can be viewed in the Mixer at once, scroll the
mixer in Logic Pro by doing one of the following:
•

Select Autoscroll to Selection in the Mixer > View menu.
When you select a channel strip, the mixer scrolls to include the selected channel strip.

•

Choose a channel strip type in the Scroll To submenu in the Mixer > View menu.

The Mixer scrolls to the first channel strip of the type selected.

Select a single channel strip

To select a single channel strip in Logic Pro, do one of the following:
•

Click on a portion of a channel strip not containing a channel strip control.

•

With the Mixer in focus, use the right and left arrow keys to select a channel strip.

When a channel strip is selected, any tracks associated with the selected channel strip are
selected in the Tracks area.

Select multiple channel strips

To select multiple channel strips in Logic Pro, do one of the following:
•

Click on a portion of a channel strip not containing a channel strip control and drag the
pointer over additional channel strips to add to your selection.

•

With a channel strip selected, press the Shift key and use the right and left arrow keys
to add additional channel strips to your selection.

When you select multiple channel strips, any tracks associated with those channel strips
are selected in the Tracks area.
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Channel strip controls in Logic Pro

Each channel strip has a set of controls (also called components), which varies according
to channel strip type. You can adjust the channel strip volume and pan position, mute and
solo channel strips, add and adjust effects, and send the output to auxiliary or output
channel strips.

•
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Audio Device controls: The following audio channel strip controls are visible only when
you are using a compatible audio interface. See your audio interface user guide for
more information.

•

Input type slot: Choose the type of audio device connected to the input, for example
microphone, instrument, line level equipment, and so on.

•

Phantom power button: Sends phantom power to an attached microphone. Check your
microphone documentation to determine if your microphone needs phantom power.
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•

Filter button: Activates a low-cut filter across the input. This can reduce the amount
of low-frequency rumble recorded, if present in the source signal.

•

Phase reverse button: Use this button to reverse the phase of the audio signal. This
can be useful when recording the same signal with multiple microphones. When the
button is lit, the phase is reversed.

•

Input gain field: Displays the amount of input gain added to the audio signal.

•

Input gain knob: Use to set the amount of input gain.

•

Direct hardware monitoring button: Activates or deactivates direct hardware
monitoring for the channel. This allows you to hear your recorded material without
the latency incurred by monitoring your signal through Logic Pro. See your audio
interface’s documentation for details on how it implements direct hardware
monitoring.

•

Setting button: Use to load, browse, or save channel strip settings for the selected
track. These settings represent the entire routing configuration of a single channel strip,
including plug-ins and their settings. See working with channel strip settings.

•

Gain Reduction meter: Displays the gain reduction of the first Compressor plug-in, or (if
no compressor is inserted), the gain reduction of an inserted Limiter or Adaptive Limiter
plug-in on the channel strip.

•

EQ display: Do any of the following:
•

Click to insert a Channel EQ into the first unused Insert slot, or to open the topmost
inserted Channel or Linear Phase EQ.

•

Option-click to insert a Channel EQ into the first slot and move any inserted plug-ins
down one slot.

•

Shift-click to insert a Linear Phase EQ into the first unused Insert slot.

•

Option-Shift-click to insert a Linear Phase EQ into the first slot and move any
inserted plug-ins down one slot.

You can use EQ effects to shape an audio signal by adjusting specific frequency range
levels. See use the Channel EQ in Logic Pro.
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•

MIDI Effect slot: Inserts a MIDI effect into the software instrument channel strip.

•

Input/Instrument slot: Choose the channel strip’s input source—the input source that
your microphone or instrument is connected to.

•

Audio Effect slot: Inserts an audio effect into the channel strip. Use effects to alter
signals in real time. See overview of plug-ins in Logic Pro.

•

Send slot: Routes the signal to an aux channel strip. The Send Level knob that appears
defines the amount of signal to route. Use sends to process effects for multiple signals
at the same time. See send signals to multiple destinations in Logic Pro.

•

Send Level knob: Controls the amount of signal sent to an aux channel strip. Use sends
to process effects for multiple signals at the same time.

•

Output slot: Choose the channel strip’s output destination—where the channel strip
signal is sent to. You can also choose the output type, and pan or balance type.

•

Group slot: Controls a channel strip’s group assignment. Use the Group Settings window
to define which parameters are controlled for the entire group at once. See overview of
groups in Logic Pro.
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•

Automation Mode button: Sets how channel strip and plug-in changes are handled
during recording and playback. See Choose automation modes.

•

Track icon: Displays the track icon of the track assigned to the channel strip, for easier
cross-referencing.

•

Pan/Balance knob: Sets the channel strip signal’s position. On mono channel strips, it
controls the signal’s left/right position. On stereo channel strips, it controls the balance
between the left and right signals. See set channel strip pan or balance positions in
Logic Pro.

•

VCA slot: Assigns the channel strip to an existing VCA group. See use VCA groups in the
Logic Pro Mixer.

•

Peak level display: Updates during playback to show the highest peak level reached. A
red display indicates signal clipping.

•

Volume display: Shows the playback volume.

•

Volume fader: Adjusts the playback volume of the channel strip signal.

•

Level meter: Shows the level of the input signal—when playing an instrument or singing,
for example. Amber and yellow signals are safe. Red indicates signal clipping.

•

Record Enable button: Arms the track or channel strip for recording.

•

Input Monitoring button: Allows you to hear incoming audio on audio tracks that aren’t
armed for recording. Use to set audio levels or to practice parts before recording.

•

Bounce button: Used to bounce the output of any output channel strip to an audio file.

•

Mute button: Removes the signal from the overall composition so that it can’t be heard.

•

Solo button: Isolates the signal from the overall composition so that it can be heard
alone.

•

Channel Mode button: Switches the channel strip input format between Mono and
Stereo. Click to choose Left, Right, or Surround format.

•

Dim button: Turns on Dim Volume mode. This sets the playback volume to the Dim value
set in the Logic Pro > Preferences > Audio > General pane.
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Choose which channel strip controls to display

You can choose which channel strip controls you want displayed on channel strips by doing
one of the following:
•
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In the Logic Pro Channel Strip Components or MIDI Channel Strip Components
submenus of the Mixer > View menu, choose a control to display, or deselect a control
to remove it.
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•

Control-click a portion of a channel strip not containing a channel strip control and
in the Channel Strip Components submenu of the pop-up menu choose a control to
display, or deselect a control to remove it from channel strips.

•

Choose Configure Channel Strip Components from the Mixer > View menu, the channel
strip pop-up menu, or press the Configure Channel Strip Components key command
and choose which controls you wish to display.
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Save a configuration of channel strip controls as default

1. In Logic Pro, choose Configure Channel Strip Components from the Mixer > View menu
or Control-click a channel strip and choose Configure Channel Strip Components from
the pop-up menu.
2. Choose Store as User Defaults from the Actions menu.

Apply a saved configuration of channel strip controls to the Mixer

1. In Logic Pro, choose Configure Channel Strip Components from the Mixer > View menu
or Control-click a channel strip and choose Configure Channel Strip Components from
the pop-up menu.
2. Choose Apply User Defaults from the Actions menu.

Revert channel strip controls to factory defaults

1. In Logic Pro, choose Configure Channel Strip Components from the Mixer > View menu
or Control-click a channel strip and choose Configure Channel Strip Components from
the pop-up menu.
2. Choose Revert to Factory Defaults from the Actions menu or click the Revert button.
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Set channel strip volume and check levels
Peak level display and signal clipping in Logic Pro

The peak level display is a numerical display located above the level meter. It updates
during playback to show the peak level reached, after the entire signal has been played
through to the end, and provides a guide that should be used to set the Volume fader.

Signal clipping occurs when a signal that is too loud is fed through the output channel
strip, thereby exceeding the limit of what can be accurately reproduced, resulting in
distorted sound. The value shown in the peak level display lights red (on output channel
strips) or orange (on other channel strip types) when the signal clips. This part of the peak
level display is called the clipping indicator.
Note: It’s not an issue if individual channel strips show evidence of clipping, as long as the
output channel strip—the summed level of all channel strips in the signal flow—does not
indicate clipping.
To avoid clipping, you need to bring down the Volume fader by the same value that is
shown in the peak level display. For more information, see Set volume levels.

Avoid clipping

1. In Logic Pro, observe the value shown in the peak level display on the channel strip.
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In the figure, 11.3 dB is shown in the peak level display when the Volume fader is set to
2.2 dB.
2. Drag the Volume fader down to a value of 0.5 or so.
Tip: You may find, however, that a Volume fader value of −1.2 sounds best in the context
of the overall mix, and clips only once (by 0.3 dB) during playback. If this is the case, it’s
nothing to worry about. Use your ears rather than your eyes as a guide.

Reset all clipping indicators
•

In Logic Pro, click any clipping indicator (or use the Clear Overload Flag in Audio
Channel Display key command) on a channel strip.

Set channel strip volume in Logic Pro

You can set the volume level of each channel strip independently, balancing the relative
volume of the tracks in your project. You can also quickly switch between two different
volume levels on a channel strip.

Set a channel strip’s volume level
In Logic Pro, do one of the following:
•

Drag the Volume fader up or down.

•

Option-click the Volume fader to return it to a neutral level (0 dB gain).

•

Press and hold Shift while dragging the Volume fader to change the volume level in finer
increments.

The level meter, located to the right of the Volume fader, shows the channel strip output
volume as the project plays. When you record, watch the level meter to make sure the
channel strip volume is not too high.

Switch between two different volume levels

1. In Logic Pro, select a non-instrument channel strip.
2. Drag the Volume fader to the level you want.
3. Use one of the Toggle Level of Channel Strips key commands listed below.
Note that the channel strip’s Volume fader is all the way down.
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4. Drag the Volume fader to a different level.
The chosen Toggle Level of Channel Strips key command now toggles between the two
volume levels. It does so for all channel strips of the same type at once, allowing you to
create two different mixes from one set of channel strips.
You can use the following key commands to quickly switch between two different volume
levels on a channel strip:
•

Toggle Level of Audio Channel Strips

•

Toggle Level of Auxiliary Channel Strips

•

Toggle Level of Output Channel Strips

•

Toggle Level of Input Channel Strips

•

Toggle Level of Bus Channel Strips

Check channel strip levels in Logic Pro

All channel strips feature a segmented level meter that shows the playback or input
monitoring level. The input monitoring level is shown when you arm an audio track in
preparation for recording.

The colors of the level meter segments provide an at-a-glance overview of individual
channel strip monitoring levels:
•

Amber and yellow: These signals are safe, and do not clip the channel strip output.

•

Red: These signals are considered “hot” levels, but the occasional peak is nothing to
worry about unless the clipping indicator is continually or regularly lit.

The peak level display is a numerical display located above the level meter. It updates
during playback to show the peak level reached, after the entire signal has been played
through to the end, and provides a guide that should be used to set the Volume fader. For
more information about signal clipping, see Peak level display and signal clipping.
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Set pre-fader metering in Logic Pro

The level meters normally show you the signal level after the channel strip volume fader.
This is the most effective way to use the level meters when mixing your project. You can
also set the level meters to show you the signal level before the channel strip volume fader,
called pre-fader metering. You may want to use pre-fader metering when you want to
adjust a signal using the controls on your audio hardware before recording.

Turn pre-fader metering on or off
Do one of the following:

In Logic Pro, choose Mix > Pre-Fader Metering.
Click the Pre-Fader Metering button if displayed in the control bar. You may need to add
the Pre-Fader Metering button to the control bar. See Customize the control bar.
Use the Toggle Pre-Fader Metering key command. You may need to assign this key
command. See Assign key commands.

Set channel strip input formats in Logic Pro

The channel input format determines the mono, stereo, or surround state of the channel
strip. The symbol on the button indicates the current state as follows:
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•

Mono: One circle represents a mono input format. The level meter shows a single
column.

•

Stereo: Two interlocked circles represent a stereo input format. The level meter divides
into two independent columns when a stereo input format is chosen.

•

Left: Two circles, with the left one filled, indicate a left channel input format. Only the
left channel of a stereo audio file is played back. The level meter shows a single column.

•

Right: Two circles, with the right one filled, indicate a right channel input format. Only
the right channel of a stereo audio file is played back. The level meter shows a single
column.

•

Surround: Five circles indicate the surround channel input format. The level meter
divides into multiple linked columns (the number matches the project surround format)
when the surround input format is chosen.
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Set the channel strip input format
In Logic Pro, do one of the following:
•

Click the Channel Mode button to switch between mono and stereo input format.

•

Long-click the Channel Mode button, then choose an input format from the pop-up
menu.

Set channel strip pan or balance positions
in Logic Pro

Instead of having instruments compete with one another in a mix, you can separate them
by positioning audio and instruments in the stereo mix from left to right. Typically, you want
to have the most important tracks (lead vocals, solo instruments, drums, bass) positioned
in the center of the mix, and have other tracks (rhythm instruments, instruments doubling
the melody) to the sides. In general, most of the mix should be close to the center, with
tracks panned far to the sides only for an unusual effect.
The Pan (short for panorama) knob defines whether a track is heard from the left, right, or
center of the stereo field. You can set the pan position for each track in a project. Logic Pro
includes several different panning modes. The options available depend on the type of
channel strip:
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•

Pan: This is the default panning mode for mono channel strips. The panner determines
the position of a signal in the stereo image. At the center pan position, the channel strip
sends equal amounts of the signal to both sides of the stereo image. If you increase the
pan position on the left side and decrease it on the right, the sound would move to the
left.

•

Stereo Pan: The Stereo Pan mode is only available on stereo channel strips. Use this
mode to place the position of the left and right signals individually in the stereo field, as
if you had two separate pan knobs.

•

Balance: This is the default panning mode for stereo channel strips. It differs from
Stereo Pan mode in that it controls the relative levels of two signals (Left and Right) at
their outputs.

•

Binaural: Binaural panning is a method to simulate the full range of spatial information—
angle, elevation, and distance—on the panning plane. Binaural panning is best suited for
headphone playback. For more information on binaural panning, see Use the Binaural
Pan knob.
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Mono channel strips have a Pan knob by default. Stereo channel strips have a Balance knob
by default.
Signals at the center of the stereo panorama might sound louder than those panned
hard right or hard left. To compensate for this perceived increase in volume at the
center position, Logic Pro offers numerous options for pan laws, or amounts of volume
reduction for signals panned to the center. The Pan Law pop-up menu is in the General
Audio Settings.
Note: If you have configured a send to be in Independent Pan mode, the pan knob for that
channel strip controls the stereo panorama to the send. The pan options above still apply
to the pan knob when controlling a send. See Adjust panning for sends independently for
more information about Independent Pan mode.

Select a panning mode for a channel strip
•

In Logic Pro, Control-click the Pan knob, then choose a panner from the shortcut menu.

Set the Pan knob or Balance knob position for a channel strip
In Logic Pro, do one of the following:
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•

Drag the Pan knob or Balance knob for the channel strip horizontally or vertically.

•

Option-click the Pan knob to return it to the center position.

•

Press and hold Shift while you drag the knob to change the pan position in finer
increments.
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Adjust the Stereo Pan knob for a channel strip

In Logic Pro, do the following:
•

To adjust the stereo spread of one channel without affecting the other channel, drag the
white handle. For example, if you want to narrow the stereo field of the left channel only,
drag the white handle of the left channel vertically closer to the center position.

•

To invert the right and left channels, Command-click anywhere inside the Stereo Pan
knob or ring. The signal ring changes color from green to orange (or back again).

•

To widen or narrow the stereo spread range, drag the green or orange ring vertically.

•

To adjust the center position of the stereo spread, drag the center of the Stereo Pan
knob vertically.

•

To reset the stereo spread and center position to their initial values, Option-click
anywhere inside the Stereo Pan knob or ring.

When a channel strip output is set to Surround, the knob is replaced by a Surround control.

Mute and solo channel strips in Logic Pro

You can silence (mute) a channel strip so that you don’t hear it when you play the project.
Muting channel strips is useful when you want to compare how the project sounds with and
without the target track, compare alternative versions of a track, or try different loops in
a project.
You can also listen to a channel strip signal alone (solo), silencing all other channel strips.
Soloing channel strips is useful when you want to work on a track or region individually;
for example, when you’re editing regions on the track, re-recording a part, or adjusting
volume curves.

Mute a channel strip
•

In Logic Pro, click the channel strip’s Mute button.

The Mute button turns blue. Click the button a second time to restore the channel strip to
its previous level.
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Mute multiple channel strips
•

In Logic Pro, click a Mute button, then drag the pointer horizontally.
The Mute buttons of all swiped channel strips switch to the same state.

Solo a channel strip

In Logic Pro, click the channel strip’s Solo button.

The Solo button turns yellow. The Mute buttons of all unsoloed channel strips flash blue,
with the exception of external MIDI channel strips.

Solo multiple channel strips
•

In Logic Pro, click a Solo button, then drag the pointer horizontally.
The Solo buttons of all swiped channel strips switch to the same state.

Solo a channel strip when another channel strip is already soloed
•

In Logic Pro, option-click an unsoloed channel strip.

This action solos the selected channel strip and unsolos any other channel strip.

Disable the solo state of one or more channel strips
In Logic Pro, do one of the following:
•

Click an active Solo button.

•

Option-click any active Solo button. The solo state of all channel strips is deactivated.

Make a channel strip solo-safe
•

In Logic Pro, Control-click an inactive Solo button.

A red slash across the Solo button indicates that the channel strip is solo-safe. When
you solo another channel strip, the channel strip no longer mutes. Control-click again to
deactivate the channel strip’s solo-safe state.
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Work with plug-ins
Overview of plug-ins in Logic Pro

Logic Pro includes a large collection of built-in effects and instrument plug-ins. It also
supports third-party plug-ins in the Audio Units format. Logic Pro also includes a Plug-in
Manager that can be used to activate, deactivate, and organize both the built-in plug-ins
and Audio Units plug-ins. Plug-ins can be broken down into the following categories:
•

Audio effects: Can be inserted in audio, instrument, aux, and output channel strips.
Logic Pro offers a range of digital signal processing (DSP) effects and processors that
are used to color or tonally shape existing audio recordings, software instruments, and
external audio sources—in real time.

•

MIDI effects: Can only be inserted in instrument channel strips. Logic Pro offers easy
access to real-time MIDI processing formerly only possible via the Environment.

•

Software instruments: Can only be inserted in instrument channel strips. Logic Pro
offers a range of software-based instruments that include innovative synthesizers, a
powerful sampler, and authentic re-creations of vintage instruments, that can be used
in real time.

•

GarageBand instruments: Can only be inserted in instrument channel strips.
GarageBand instruments are accessed by pressing and holding Option when clicking an
Instrument slot. They appear in a submenu called “Legacy.”

You can use selection-based processing with audio effects.

Add, remove, move, and copy plug-ins in Logic Pro

You can add plug-ins, replace a plug-in with a different one, and remove plug-ins from a
channel strip. You can also move, copy, and bypass plug-ins. If you’re unhappy with any of
your plug-in adjustments, you can undo them.

Add a MIDI effect plug-in

In a Logic Pro channel strip, do one of the following:
•
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Click the MIDI Effect slot, then choose a plug-in from the pop-up menu.
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•

Place the pointer above or below an occupied MIDI Effect slot, click the green line that
appears, then choose a plug-in from the pop-up menu.

Add an audio effect plug-in

In a Logic Pro channel strip, do one of the following:
•

Click an Audio Effect slot, then choose a plug-in from the pop-up menu.

The last visible empty Audio Effect slot in a channel strip is shown at half its height; use
it in the same way.
•

Option-click an Audio Effect slot.
You can now choose legacy plug-ins from the pop-up menu.
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Add an instrument plug-in

In a Logic Pro channel strip, do one of the following:
•

Click the Instrument slot, then choose a plug-in from the pop-up menu.

•

Option-click an Instrument slot.
You can now choose legacy plug-ins from the pop-up menu.

Replace a plug-in
•

Logic Pro User Guide

In a Logic Pro channel strip, place the pointer over the plug-in slot, click the arrows that
appear to the right, then choose a plug-in to replace the existing one.
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Remove a plug-in
•

In a Logic Pro channel strip, place the pointer over the plug-in slot, click the arrows that
appear to the right, then choose No Plug-in from the pop-up menu.

Move a plug-in
•

In a Logic Pro channel strip, drag the plug-in up or down in the channel strip, or to
another channel strip.
For guidance, use the colored line that appears when moving the plug-in.

Copy a plug-in
•

In a Logic Pro channel strip, press and hold Option and drag the plug-in to an unused slot.

Bypass a plug-in

If you want to deactivate a plug-in, but don’t want to remove it from the channel strip, you
can bypass it. Bypassed plug-ins don’t drain system resources.
•

In Logic Pro, to bypass a single plug-in, do one of the following:
•
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Place the pointer over the plug-in slot, then click the Bypass button that appears to
the left.
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•

•

Option-click the plug-in slot.

•

Click the center area of the plug-in slot to open the plug-in window, then click the
Bypass button at the left side of the plug-in window header.

To bypass multiple plug-ins, click a plug-in slot, then drag the pointer up or down.
All swiped plug-in slots switch to the same state.

Insert an instrument plug-in on a track using drag and drop
in Logic Pro

You can insert an instrument plug-in on a software instrument track that contains no
instrument plug-in by dragging audio files, audio or software instrument regions, or Apple
Loops to the track header. When you drag the content over the track header, you can
choose whether to insert a Quick Sampler, Alchemy, or Drum Machine Designer instrument
plug-in. Quick Sampler and Alchemy offer additional choices for how the plug-in processes
the material.

Insert a Quick Sampler plug-in (single files only)

Dragging content to one of the available Quick Sampler zones inserts a Quick Sampler
instrument plug-in. Depending on the content of the audio material, Quick Sampler uses
Slice, One Shot, or Classic sample mode.
See the Quick Sampler chapter in Logic Pro Instruments.
•

Quick Sampler (Original) uses the original tuning, loudness, looping, and length of the
content.

•

Quick Sampler (Optimized) analyzes the content and optimizes its tuning and loudness,
searches for loop points, and cuts silence.

Insert an Alchemy plug-in (single files only)

Dragging content to one of the available Alchemy zones inserts an Alchemy instrument
plug-in using the type of synthesis you choose: Additive, Granular, or Spectral.
See the Alchemy chapter in Logic Pro Instruments.

Insert a Drum Machine Designer plug-in (single or multiple files)

Dragging content to the Drum Machine Designer zone inserts a Drum Machine Designer
instrument plug-in using the sliced audio content, and a MIDI region to trigger the slices.
When you drag multiple audio files, each one is placed on its own pad in the Drum Machine
Designer grid, rather than being sliced.
See the Drum Machine Designer chapter in Logic Pro Instruments.
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Insert an instrument plug-in by dragging a single file, region, or loop

1. In Logic Pro, drag an audio file, audio or software instrument region, or Apple Loop to a
software instrument track that currently has no instrument plug-in.
2. When the Insert Plug-in dialog appears, drag the item to one of the available zones to
choose the type of instrument plug-in inserted on the track.

Insert an instrument plug-in by dragging multiple files, regions, or loops

1. In Logic Pro, drag multiple audio files, regions, or Apple Loops to a software instrument
track that currently has no instrument plug-in.
2. When the Insert Plug-in dialog appears, drag the items to one of the available zones to
choose the type of instrument plug-in inserted on the track.

Activate plug-ins on inactive channels in Logic Pro

If the “Only load plug-ins needed for project playback” setting is enabled, any channel strip
not in the playback signal flow will be inactive, and its plug-ins will be dimmed. In order to
hear the plug-ins, first you need to activate the channel. To activate an inactive channel in
Logic Pro, do one of the following:
•

Add a plug-in to an inactive channel strip.

•

Click a plug-in on an inactive channel strip.

•

Click a plug-in slot on an inactive channel strip and select “Activate Plug-ins” from the
pop-up menu.

For more information on the “Only load plug-ins needed for project playback” setting, see
General Project Settings.
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Use the Channel EQ in Logic Pro

The Channel EQ is an audio effect, like any other. In most mixing situations, it’s used as the
first effect on a channel strip, allowing you to shape the sound of individual channel strip
signals, or for tone-shaping on an overall project mix, before applying other effects. The
graphic controls make it easy to view and change the audio signal in real time.

Add a Channel EQ to a channel strip
In Logic Pro, do one of the following:
•

If Audio Effect slot 1 is not used: Click the EQ area.
The Channel EQ is inserted in the first Audio Effect slot, and the EQ area changes to a
thumbnail view of the Channel EQ display.
Note: Shift-click the EQ area to insert the Linear Phase EQ in the first Audio Effect slot.
The EQ area changes to a thumbnail view of the Linear Phase EQ display.

•

If Audio Effect slot 1 is used: Option-click the EQ area.
The Channel EQ is inserted as the first plug-in, all existing plug-ins are moved one slot
down, and any existing automation data is redirected.
Note: Shift-Option-click the EQ area to insert the Linear Phase EQ in the first Audio
Effect slot, and move all existing plug-ins one slot down. Any existing automation data
is redirected.

•

If Audio Effect slot 1 is used: Double-click the EQ area.
The Channel EQ is inserted in the next available (unused) slot.
Note: Shift–double-click the EQ area to insert the Linear Phase EQ in the next available
(unused) slot.

Work in the plug-in window in Logic Pro

You edit plug-in parameters in the plug-in window, which opens automatically when you
insert a plug-in.
Note: You can turn off this behavior by deselecting the “Open plug-in window on insertion”
checkbox in the Logic Pro > Preferences > Display > Mixer pane.
The header area at the top of a plug-in window is common to all plug-ins. You can use it to
adjust the size of the window, link plug-in windows when more than one is open, switch the
plug-in parameter view, and route side chain source signals.
Some plug-ins have additional parameters that don’t appear in the main plug-in window. In
this case, a disclosure arrow appears at the bottom-left corner of the plug-in window.
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Open a plug-in window (when it’s closed)
•

In a Logic Pro channel strip, click the center area of the plug-in slot.

Close a plug-in window
•

In a Logic Pro channel strip, click the close button at the top-left corner of the plug-in
window.

Adjust plug-in parameters

In a Logic Pro channel strip, do any of the following:
•

To adjust a slider: Drag it vertically or horizontally. You can Command-click anywhere in
the slider’s value range to set it to the clicked value.

•

To adjust a rotary knob: Drag it vertically. You can Command-click anywhere in the value
circle surrounding the knob to set it to the clicked value.

•

To adjust a numerical field: Drag its numerical value vertically. You can also double-click
in the numerical field, then type a new value using your computer keyboard.

•

To reset any parameter to a neutral (or centered) value: Option-click the parameter.

•

To make finer parameter adjustments: Press and hold the Shift key before dragging a
control.

Undo a plug-in parameter change

In a Logic Pro channel strip, do one of the following:
•

Click the Undo button in the plug-in window header.

•

Choose Edit > Undo (or press Command-Z).

Redo a plug-in parameter change

In a Logic Pro channel strip, do one of the following:
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•

Click the Redo button in the plug-in window header.

•

Choose Edit > Undo (or press Shift-Command-Z).
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Hide or show the plug-in window header
•

In a Logic Pro channel strip, click the icon at the top-right corner of the plug-in window.

Adjust the size of a plug-in window
In Logic Pro, do one of the following:
•

Drag any corner of the plug-in window.

•

Choose a window size from the plug-in window’s View pop-up menu.

Both of these scalings apply to individual plug-ins.

Switch the plug-in parameter view
•

In Logic Pro, choose Editor or Controls from the plug-in window’s View pop-up menu.

Editor view shows the plug-in’s graphical interface, if it offers one. Controls view displays
all plug-in functions as a set of horizontal sliders, with numerical fields to the left of each
parameter. These fields are used for both the display and entry of data.
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Link or unlink plug-in windows

When linked, a single plug-in window is used to either display all open plug-ins or all
plug-ins in the same insert slot row across the Mixer.
1. In Logic Pro, Control-click the Link button to the right of the plug-in window header.

2. Choose one of the following options from the Link shortcut menu:
Off: Plug-in windows are not linked. Clicking in the center of any plug-in slot opens the
plug-in in a new plug-in window.
Single: A single plug-in window is used to display all open plug-ins. Each time you open
a new plug-in, the window updates to reflect the newly chosen plug-in. In Single mode,
the Link button turns purple.
Multi: As you select channel strips or plug-ins, a single plug-in window updates to display
plug-ins in the same insert slot position (first row, second row, and so on). You can open
multiple plug-in windows and set each window to Multi-mode in order to display the
plug-ins of more than one row of inserts as you select different channel strips.
For example, you could insert a Channel EQ plug-in into the first insert slot, and a
Compressor plug-in into the second insert slot, of multiple channel strips. If you then
open a Channel EQ plug-in window, a Compressor plug-in window, and put both plug-in
windows in Multi mode, as you select each channel strip when mixing, the Channel EQ
and Compressor plug-in for the selected channel strip will be displayed. In Multi mode,
the Link button turns yellow.
Note: You can simply click on the Link button to toggle between Off and Single mode.
The Link mode affects the entire project—it is not possible to have the Link mode set
differently in different plug-in windows of the same project. The Link mode can either be
set to Single for the entire project or for Multi mode for one or more rows of plug-ins. This
means that if Multi mode is selected, clicking the Link button on additional plug-ins from
any not currently linked rows engages Multi mode for that row of plug-ins, and if Single
mode is selected in any open plug-in, Multi mode is turned off.

Choose a source for a side chain signal into a plug-in

For plug-ins with a Side Chain Source pop-up menu, you can use audio from an audio or
software instrument track, hardware input, or bus to trigger the plug-in. For example, the
dynamics of a drum groove can be used to rhythmically change the compression, and
therefore dynamics, of a guitar, synthesizer, or bass part. The side chain signal is used to
control the plug-in, but it is not processed by the plug-in.
•

In Logic Pro, click the Side Chain Source pop-up menu in the plug-in header area, then
choose one of the available sources.

The audio signal from the selected side chain source now serves to control the plug-in.
You can change external side chain sources, or select an internal side chain source if no
external audio signal is available.
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When a plug-in has a side chain source, an indicator with a left-pointing arrow appears
after the plug-in name (which may be abbreviated) in the plug-in slot. When you hold the
pointer over the slot, a Help tag showing the plug-in name and the name of the side chain
source appears.
Some third-party Audio Units plug-ins do not allow the side chain to be controlled
internally, and so “None” replaces “Internal” in the Side Chain Source pop-up menu.
To learn more about using Audio Units plug-ins, see Work with Audio Units plug-ins.

Hide or show additional parameters (if available for the plug-in)

In Logic Pro, click the disclosure arrow at the bottom-left corner of the plug-in window.

Work with plug-in settings in Logic Pro

Plug-in settings are stored with the project file and are automatically recalled the next time
the project is opened. In the plug-in window, you can load, copy and paste, compare, save,
create default, and delete plug-in settings. You can also load, save, and delete plug-in
settings in the Library.

Load a plug-in setting

In Logic Pro, do one of the following:
•

Select the relevant channel strip in the Mixer, then click the triangle that appears to the
left of the effect or instrument slot in the inspector channel strip.
The Library updates to show presets for the selected plug-in slot, and you can choose
the preset you want to add.

•

In the plug-in window, do one of the following:
•

Open the Settings pop-up menu, then choose a setting from the submenus.

•

Open the Settings pop-up menu, click Load Setting, then choose a setting in the
dialog that appears.

Choose the next or previous plug-in setting
In Logic Pro, do one of the following:
•

•
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In the plug-in window, do one of the following:
•

Click the left arrow to choose the previous setting, or the right arrow to choose the
next setting.

•

Open the Settings pop-up menu, then choose Next Setting or Previous Setting.

Use the following key commands:
•

Next Plug-in Setting

•

Previous Plug-in Setting

•

Next Plug-in Setting or Sampler Instrument

•

Previous Plug-in Setting or Sampler Instrument

•

Next Channel Strip or Plug-in Setting or Sampler Instrument

•

Previous Channel Strip or Plug-in Setting or Sampler Instrument
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Compare edited plug-in parameters with the original setting

You can audition your audio or instrument track through two variations of a plug-in.
1. In a Logic Pro plug-in, adjust any of the plug-in parameters.
The Compare button turns blue, indicating that you have made changes, but have not
saved the edited settings in the project.

2. Click the Compare button to listen to the setting that was originally saved with the
project.
The Compare button turns black.
3. Click the Compare button again to switch back to the edited plug-in setting.
The Compare button again turns blue.

Copy and paste a plug-in setting

In Logic Pro you can copy and past plug-in settings in either of two ways:
1. To copy a plug-in setting, do one of the following:
•

Click the Copy button in the plug-in window header.

•

Open the Settings pop-up menu in the plug-in window, then choose Copy Setting.

All parameter settings are copied into a plug-in settings Clipboard, which is
independent of the global Clipboard.
2. To paste the plug-in setting, do one of the following:
•

Click the Paste button in the plug-in window header.

•

Open the Settings pop-up menu in the plug-in window, then choose Paste Setting.

Reset a plug-in setting
•

In the Logic Pro plug-in window, open the Settings pop-up menu, then choose Reset
Setting.

Save a plug-in setting

In Logic Pro you can save a plug-in setting in either of two ways:
•

•
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In the plug-in window, do one of the following:
•

Open the Settings pop-up menu, then choose Save Setting. This command
overwrites the existing plug-in setting.

•

Open the Settings pop-up menu, then choose Save Setting As. Name and save the
new setting. You can also create a folder location, which must be in the associated
plug-in folder.

In the Library, click the Save button.

572

Create a default plug-in setting
•

In the Logic Pro plug-in window, open the Settings pop-up menu, then choose Save
Setting As Default.
This setting loads whenever that plug-in type is opened. You can also revert to this user
default setting at any point by choosing Recall Default Setting from the Settings pop-up
menu.

Delete a plug-in setting

In a Logic Pro plug-in, do one of the following:
•

In the plug-in window, open the Settings pop-up menu, then choose “Delete [name of
setting].”

•

In the Library, click the Delete button.

Work with plug-in latencies in Logic Pro

Some plug-ins may cause small timing delays, known as latency, when processing audio.
This processing can take the form of input latency, output latency, or both. For example,
playing a software instrument in Logic Pro incurs only an output latency because the
instrument’s audio is generated by the application. However, monitoring an audio recording
may have both an input and an output latency because the signal must be input into
Logic Pro before it can be processed. Input latency (if any) is added to the output latency,
resulting in an overall monitoring latency. Each further process—such as the use of insert
effects, for example—may add to the overall monitoring latency. However, Logic Pro can
compensate for these latencies using plug-in latency compensation to ensure that all your
audio output is perfectly synchronized.
You can turn plug-in latency compensation on or off. When plug-in latency compensation
is turned on, there can be a slight lag between the moment you start playback and the
moment when output begins, depending on the amount of latency being compensated.
In Logic Pro, you can choose to apply plug-in latency compensation either to all channel
strip types, or to only audio and software instrument channel strips:
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•

Audio and software instrument channel strips only: If you insert latency-causing
plug-ins only on audio and instrument channel strips, you can choose plug-in latency
compensation for only audio and instrument tracks. Logic Pro achieves this by delaying
audio and MIDI regions on audio and instrument tracks. This results in snappy playback
performance.

•

All channel strip types: If you insert latency-causing plug-ins on aux or output channel
strips, you can choose plug-in latency compensation for all types of channel strips.
When this setting is turned on, Logic Pro compensates for latency-causing plug-ins
by calculating the amount of latency caused by all plug-ins, and then delaying audio
streams by an appropriate amount. This type of plug-in latency compensation can
result in a slight lag in playback performance, depending on how much latency is being
compensated.
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If you use latency-causing plug-ins, it’s best to apply them only after you finish recording.
Delays in playing back audio, whether caused by a plug-in or by the plug-in latency
compensation feature, can result in your performance being out of time. However, if you
find that you need to do additional recording after you have inserted latency-causing plugins into your mix, you can activate Low Latency Monitoring, which will route your audio
around any latency-causing plug-ins, so that the recorded audio isn’t delayed.
To determine if a plug-in causes latency, see the documentation for the plug-in.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
plug-in latency compensation and Low Latency mode are available.

Turn on plug-in latency compensation
•

In Logic Pro, choose one of the following options from the Compensation pop-up menu
in Logic Pro > Preferences > Audio > General:
•

Audio and Software Instrument Tracks: If you have inserted latency-causing plugins only into audio or instrument channel strips, choose this option. Logic Pro
automatically shifts audio and MIDI regions in time to keep all the output
synchronized.

•

All: If you have inserted latency-causing plug-ins into aux or output channel strips,
choose this option. Logic Pro delays all audio streams by an appropriate amount to
keep them all synchronized with each other.

Turn on Low Latency Monitoring mode
In Logic Pro, do one of the following:
•

Click the Low Latency Monitoring button in the control bar.
Note: The Low Latency Monitoring button does not appear in the control bar by default.
To add this button to the control bar, see Customize the control bar.

•

Select the Low Latency Mode checkbox in Logic Pro > Preferences > Audio > General.

Recorded audio is routed around any latency-causing plug-ins in the signal path. This
ensures that the maximum delay that can occur across the signal flow (that is, across the
entirety of the current track’s signal path) is less than the latency value you set using the
Limit slider in Logic Pro > Preferences > Audio > General.
The sound may change when you turn on Low Latency mode. Depending on the plug-ins in
use, the change in sound can be anything from subtle to dramatic. If plug-ins being used
do not exceed the total latency limit, there is no audible difference.
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Work with Audio Units plug-ins in Logic Pro

In addition to the audio effect and instrument plug-ins included with Logic Pro, you can use
third-party plug-ins in the Audio Units format. Unlike the included plug-ins, Audio Units
need to first be installed onto your computer for you to use them. Some Audio Units may
already be installed on your computer, and many more are available from other sources.
You can buy Audio Units plug-ins from a variety of third-party vendors, and can find free
Audio Units plug-ins on the Internet. Please check the documentation for your Audio Units
plug-in for installation instructions, and to ensure compatibility with the latest version of
Logic Pro.
Audio Units plug-ins are located in the Audio Units submenu:

Using the Plug-in Manager, you can re-arrange the plug-ins submenus so that Audio Units
plug-ins appear alongside included plug-ins. For information on how to use the Plug-in
Manager, see Use the Plug-in Manager.
You use Audio Units plug-ins the same way as built-in plug-ins:
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•

For information on adding, removing, copying, and bypassing Audio Units, see Add,
remove, move, and copy plug-ins.

•

For information on editing Audio Units parameters, see Work in the plug-in window.

•

For information on adjusting Audio Units settings, see Work with plug-in settings.

•

For information on working with Audio Units latencies, see Work with plug-in latencies.
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What to do if an Audio Units plug-in isn’t working

Apple works with third-party developers to ensure that their Audio Units plug-ins are
fully compatible with Logic Pro. Most Audio Units you install on your computer should not
require anything other than installation—and if they are copy protected, authorization—to
function properly. However, you may install Audio Units that do not appear in the plug-in
submenus or work as expected. When this happens in Logic Pro, try one or more of the
following:
•

Check the vendor or developer’s documentation to ensure you have properly authorized
the Audio Units plug-in to run on your computer.

•

Follow the vendor or developer’s documentation to re-install the Audio Units plug-in.

•

Open the Plug-in Manager and verify that the Audio Units plug-in is enabled. If it is
disabled, you can re-scan and activate the Audio Units plug-in. Be careful, however,
as activating an Audio Units plug-in that does not pass Audio Units validation risks
crashing your system. See Use the Plug-in Manager for more information.

•

Contact the third party developer or vendor for assistance. Be sure to tell them which
version of macOS and Logic Pro you are using so that they can better assist you.

Support for ARA 2 plug-ins in Logic Pro

Celemony provides an extension of the Audio Units plug-in standard called Audio Random
Access (ARA). The ARA extension enables a host application and compatible plug-in to
share song structure information (for example, regions and their associated audio files) and
analysis results (including transients and pitch information). Logic Pro supports plug-ins
compatible with the second version of ARA, known as ARA 2, including Melodyne.
Using a compatible plug-in in ARA mode provides several benefits to enhance your
workflow. First, you no longer need to capture audio before working in the plug-in. Second,
your edits are preserved when you move or copy the audio region to another track, as long
as you insert the plug-in in ARA mode in the first Audio Effect slot. In addition, your edits to
the audio material are preserved when you copy the project.
When you insert a plug-in in ARA mode on an audio track, Flex is disabled. Also, the
Compare button is not available in the plug-in window. Before you begin working, you start
playback momentarily to transfer song information and all relevant audio analysis results
to the plug-in. You can start editing in the plug-in immediately after the information is
transferred. If you move, copy, or edit regions on the track, the updated information is
transferred the next time you start playback.
Note: Some ARA 2-compatible plug-ins are not fully compatible with the Freeze tracks
function in Logic Pro. If you need to freeze a track that uses an ARA 2-compatible plugin, contact the plug-in manufacturer for compatibility information. For more on the Freeze
tracks function, see Freeze tracks.
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Use an ARA 2-compatible plug-in on an audio track

1. In Logic Pro, in the first Audio Effect slot on an audio channel strip, choose your ARA
2-compatible plug-in.
When first inserted, choose Audio Units > [plug-in manufacturer name] > [plug-in
name] (ARA) to add your ARA 2-compatible plug-in. However, the Plug-in Manager lets
you re-organize plug-ins into custom folders; if you have moved your ARA 2-compatible
plug-in, choose it from the new location. See Use the Plug-in Manager.
2. After the plug-in window opens, start playback.
3. Edit the audio material in the plug-in window.
You can use an ARA 2-compatible plug-in as part of selection-based processing. For more
information about ARA, refer to the manufacturer’s documentation.

Use MPE with software instruments in Logic Pro

MPE (MIDI Polyphonic Expression) is an extension to the MIDI standard that gives you
capabilities to create more spontaneous, expressive performances. Using MPE, you
can simultaneously vary multiple parameters of individual notes, such as timbre, pitch,
pressure, and volume.
With traditional MIDI, control change messages such as pitch bend and modulation are
applied to all the notes you play. With MPE, every note and its messages are sent on a
separate MIDI channel, creating the ability to modulate individual notes. For example,
you can play a chord on an MPE controller and bend the top note up to a higher interval,
without affecting the other notes.
You can configure any Logic Pro instrument featuring MIDI Mono mode to provide
compatibility with MPE controllers. MIDI Mono mode allows the instrument to respond to
MIDI data (individual notes and their control change messages) on multiple MIDI channels
at the same time. In this mode, every channel is monophonic, with polyphony limited to a
maximum of up to 15 notes.
The Logic Pro instruments that support MIDI Mono mode include Alchemy, EFM1, ES2,
Quick Sampler, Retro Synth, Sampler, Sculpture, and Vintage Clav.

Configure a Logic Pro instrument for use with an MPE-capable controller

1. Click the right side of the Instrument slot in the channel strip, then choose an
instrument plug-in that supports MIDI Mono mode from the pop-up menu.
2. To view the extended parameters, click the disclosure arrow at the bottom left of the
plug-in window.
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3. Choose On (with common base channel 1) from the MIDI Mono Mode pop-up menu.
In this mode, each note and its control change messages are received on a different
MIDI channel. MIDI messages sent on the base channel affect all notes being played.
4. Enter a pitch range in the Mono Mode Pitch Range field.
Note: To ensure pitch bends are in tune, the pitch bend ranges of the MPE controller
and the Logic Pro instrument must be equal. Check the controller’s documentation for
information on this value.
You can also assign MPE controllers to control surfaces and assign MPE controller buttons
to key commands.

Use the Plug-in Manager in Logic Pro

Logic Pro uses a validation tool to ensure that only plug-ins that fully comply with the
Audio Units plug-in specification are used in Logic Pro. This minimizes problems that
may be caused by plug-ins not built into Logic Pro. The validation process takes place
automatically when Logic Pro is first opened, when an updated version of Logic Pro is
installed, and when you install new plug-ins or update existing ones.
The left column of the Plug-in Manager window lists all internal Logic Pro plug-ins sorted
by category, and all installed Audio Units plug-ins sorted by manufacturer. The results of
the validation scan are shown in the Compatibility column at the right of the window.

You can organize and manage both built-in and Audio Units plug-ins by simply dragging
within the Plug-in Manager window. You can also create new plug-in categories, rename
or remove existing categories, create custom and short names for plug-ins, and search for
individual plug-ins by name.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
Plug-in Manager is available in Logic Pro Preferences.
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Open the Plug-in Manager
•

Choose Logic Pro > Preferences > Plug-in Manager.

Create a new category

1. In the Logic Pro Plug-in Manager, click the Add button (+) in the upper-right corner of
the Category list.
2. Enter a new name for the Untitled folder that appears, then press Return.

Rename an existing category
•

In the Logic Pro Plug-in Manager, double-click the folder, enter a new name, then press
Return.

Remove an existing category or plug-in

In the Logic Pro Plug-in Manager, do one of the following:
•

Select the category or plug-in, then press the Delete key.

•

Control-click the category or plug-in, then click Remove.

Search for plug-ins by name
•

In the Logic Pro Plug-in Manager, enter the text to search for in the search field, then
press Return.

Any plug-ins that match your search term are displayed in the results list.

Manually enable Audio Units plug-ins that fail the validation test

1. In Logic Pro, select Show All in the upper-left part of the Plug-in Manager window.
2. Select the checkbox by the plug-in name in the Use column.
You should be aware that plug-ins that fail the validation test can cause problems. If you
encounter problems with manually enabled failed plug-ins, click the Disable Failed Audio
Units button underneath the left column.

Disable a plug-in

1. In Logic Pro, select Show All in the upper-left part of the Plug-in Manager window.
2. Deselect the checkbox by the plug-in name in the Use column.

Rescan a selection of plug-ins

You can rescan a selection of plug-ins after installing or updating plug-ins, or moving
components in the Finder to remove or install plug-ins manually, while the Plug-in Manager
window is open.
•

In the Logic Pro Plug-in Manager, click the Reset & Rescan Selection button.

The plug-ins are activated automatically, if they pass the validation test.
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Copy a selection of plug-ins from a Manufacturer listing to a Category listing
1. In the Logic Pro Plug-in Manager, select one or more plug-ins under the same
Manufacturer listing.

2. Drag the selection from the Manufacturer listing to the Category listing of your choice.
The selected plug-ins now appear under both the Manufacturer listing and the chosen
Category listing.

Move a selection of plug-ins from one category to another

1. In the Logic Pro Plug-in Manager, select one or more plug-ins in the same category.
2. Drag the selection to another category.
The selected plug-ins are no longer sorted under the original category, but have been
moved to the new category.

Return to default Category and Manufacturer listings
•

In the Logic Pro Plug-in Manager, click the Restore Default Settings button.

Any plug-ins you have moved return to their default Category or Manufacturer lists.
Categories you created manually remain in the Category list.

Create a custom name for a plug-in

1. In the Logic Pro Plug-in Manager, double-click in the Custom Name field for the plug-in.
2. Enter a custom name for the plug-in, then press Return.
3. Click the Done button in the lower right corner of the Plug-in Manager window.
The custom name for the plug-in now appears in the audio effect or instrument pop-up
menu when you choose a plug-in, and at the bottom of the plug-in window.

Create a short name for a plug-in

1. In the Logic Pro Plug-in Manager, double-click in the Short Name field for the plug-in.
2. Enter a short name for the plug-in, then press Return.
Use a name no longer than seven characters (the maximum number visible in a narrow
channel strip effects or instrument slot) or nine characters (the maximum number
visible in a a wide channel strip slot.) For more information on switching channel strip
width, see Change the Mixer view.
3. Click the Done button in the lower right corner of the Plug-in Manager window.
The short name for the plug-in now appears in the audio effect or instrument slot of the
channel strip.
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Work with channel strip settings in Logic Pro

Channel strip settings (.cst files) are specific to each channel strip type: Instrument
channel strips feature a number of instrument settings, separated into different categories.
Audio channel strips offer effect routings optimized for particular instrument, vocal, and
other processing tasks. Similarly, output and auxiliary channel strips provide channel strip
settings for particular mastering or sweetening processes. For more information on using
effects plug-ins, see Plug-ins overview.
You can load, copy, paste, reset, save, and delete channel strip settings in a channel strip.
You can also access channel strip settings in the Library.
By saving a channel strip setting as a performance, you can remotely switch between
settings by sending MIDI program change messages. This allows you to select your favorite
sounds by pushing a button on your MIDI keyboard.

Load a channel strip setting

In Logic Pro, do one of the following:
•

Click the Setting button at the top of the channel strip, then choose a setting from the
pop-up menu.

•

Select the relevant channel strip in the Mixer, then click the blue triangle that appears to
the left of the Setting button in the inspector channel strip.
The Library updates to show channel strip settings, and you can choose the setting you
want to add.

Choose the next or previous channel strip setting
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose Next or
Previous Channel Strip Setting from the pop-up menu.

Copy or paste a channel strip setting
•
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Paste only the plug-ins from a channel strip
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose Paste
Plug-ins Only from the pop-up menu.

Paste only the sends from a channel strip
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose Paste
Sends Only from the pop-up menu.

Remove all insert effect plug-ins from a channel strip
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose
Remove All Effect Plug-ins from the pop-up menu.

Remove any empty insert slots from a channel strip
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose
Remove Empty Insert Slots from the pop-up menu.

Remove any bypassed effect plug-ins from a channel strip
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose
Remove Bypassed Plug-ins from the pop-up menu.

Remove all sends from a channel strip
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose
Remove All Sends from the pop-up menu.

Reset a channel strip setting
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose Reset
Channel Strip from the pop-up menu.

Save a channel strip setting

1. In Logic Pro, click the Setting button at the top of the channel strip, then choose “Save
Channel Strip Setting as” from the pop-up menu.
2. In the dialog that appears, select the appropriate folder, enter a name for the channel
strip setting, and click Save.

Delete a channel strip setting
•

In Logic Pro, click the Setting button at the top of the channel strip, then choose Delete
Channel Strip Setting from the pop-up menu.

Save a channel strip setting as a performance

1. In Logic Pro, configure a channel strip that you want to have available as a performance.
2. Click the Setting button, then choose Save as Performance from the pop-up menu.
3. In the dialog that appears, enter a performance name, choose a program change
number, then click OK.
4. Send the program change number from your MIDI controller.
When a channel strip receives a program change message that corresponds to an
assigned performance number, it loads this performance. All saved performances are
shown in the Performance folder of the Settings pop-up menu.
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Control channel strip signal flow in the Mixer
Route audio via insert effects in Logic Pro

When a plug-in is inserted directly into a channel strip, it is termed an insert effect. The
channel strip’s entire signal is processed by the effect plug-in. This behavior is suitable
for equalizers or dynamic effects, such as compressors. If you have enough processing
capacity, you can use up to 15 insert effects on each channel strip.
When multiple effect plug-ins are routed to a channel strip via inserts, they are said to
be routed in series. In this type of configuration, the output of one effect is added to the
incoming signal and becomes the input of the next effect in the chain. The image below
illustrates this process.
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Route audio via send effects in Logic Pro

You use send effects when you want to isolate effect plug-ins from a channel strip’s signal
flow, or when you want to use the same effect on more than one channel strip. By creating
a send, you split the channel strip’s signal. The channel strip’s main signal continues its
route to the chosen output. The other part of the signal is routed down a parallel path,
via a bus to an aux channel strip. You use the Send Level knob to control the amount of
signal that is sent via the bus. This is known as parallel routing. You can route the signal
back into the main signal flow at a later point, or you can output the signal from the aux
channel strip.
The primary advantage of this approach over routing via insert effects is efficiency. This
method allows multiple channel strips to be processed by one inserted effect, which saves
vast amounts of processing power (and time) when compared to the alternative of inserting
the same effect directly into multiple channel strips. Another bonus is that you can quickly
switch between wet and dry versions of all channel strips that are sent to an aux channel
strip, by simply bypassing the effect on the aux. Similarly, you can completely change the
effects configuration for multiple sent channel strips by choosing different effects for the
aux channel strip.
The following image illustrates a channel strip routed to multiple aux channel strips via
sends—with reverb, chorus, and delay effects assigned to aux channel strips 1, 2, and 3,
respectively.
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The channel strip signal is split and routed to three separate effects, one on each aux
channel strip. These three independent signals are then sent back from the respective aux
channel strips and combined into an output stream from the original channel strip. You can
create up to eight sends on each audio, instrument, or aux channel strip.
You use the Send pop-up menu to configure where in the channel strip signal the send
occurs, and to set the destination for the parallel routing of the send. You have three
options for where the send can occur in the signal flow:
•

Post Pan: The signal is sent after the fader and the Pan knob; the send signal is affected
by adjustments to both channel strip volume and pan adjustments.

•

Post Fader: The signal is sent after the fader but before the Pan knob; the send signal is
affected by volume adjustments but not pan adjustments.

•

Pre Fader: The signal is sent before the fader and Pan knob; the send signal is affected
by neither volume nor pan adjustments.

Open the Send pop-up menu

Use the Send pop-up menu to configure where the send occurs, and to set the destination
for the send.
•
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Choose a destination for a send
•

In a Logic Pro channel strip, choose a bus from the submenu of the Send pop-up menu.

If you have named the aux channel strip that a bus is sending to, the name appears beside
the bus number.

Highlight the destination of a send
•

In a Logic Pro channel strip, Shift-click the send.
Any aux channel strips to which the send is routing flash three times.

Note: Double-clicking a send doesn’t affect the current selection.

Set a send to Post Pan, Post Fader, or Pre Fader send mode
•
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•

Post Pan: The signal is sent after the fader and the Pan knob; the send signal is
affected by both channel strip volume and pan adjustments. When a send is Post
Pan the Send knob ring is green.

•

Post Fader: The signal is sent after the fader but before the Pan knob; the send
signal is affected by volume adjustments but not pan adjustments. When a send is
Post Fader the Send knob ring is blue.

•

Pre Fader: The signal is sent before the fader and Pan knob; the send signal is not
affected by volume or pan adjustments. When a send is Pre Fader the Send knob
moves to the left of the Send pop-up menu, and the Send knob ring is blue.

Adjust panning for sends independently in Logic Pro

Sometimes you may want to adjust the stereo pan that a send is routing to an aux
separately from the panning of the channel strip. For example, you may want a stereo
channel strip to send to a surround aux, or you may be using sends to create a headphone
mix and want separate pan positions for the headphone mix as for the main mix. By
choosing Independent Pan for a send, you can adjust the pan type and position settings for
the send independently from the pan type and position for the channel strip.
After you choose Independent Pan for a send, you can adjust the send’s panning by setting
the send to Sends on Faders mode. In this mode, the fader controls the volume to the
send, and the pan knob controls the pan type and position to the send. To learn more about
panning and balance, see Set channel strip pan or balance positions.

Set Independent Pan mode for a send
•
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Copy the current channel strip pan setting to a send

You can copy pan settings from a channel strip directly to a send using the Copy Pan to
Send command. Using this command, you can quickly set the panning for a send without
having to first enter Sends on Faders mode and make adjustments.
•

In a Logic Pro channel strip, from the Send pop-up menu, choose Copy Pan to Send.

Note: Copy Pan to Send is available only in Independent Pan mode.

Set Sends on Faders mode for a send
In Logic Pro, do one of the following:
•

From the Send pop-up menu, choose Sends on Faders.

•

Control-click an aux track, then choose Sends on Faders from the shortcut menu.

•

Use the Sends on Faders key command.

•

Use the Sends on Faders pop-up menu in the Mixer menu bar:
•

Click the Sends on Faders On/Off button in the Mixer menu bar

•

Choose an effect return channel from the Sends on Faders pop-up menu.

The color of the send slot, send knob, pan knob, and volume slider change to reflect that a
send is in Sends on Faders mode.
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The Sends on Faders pop-up menu is available only when Enable Complete Features is
selected in Logic Pro > Preferences > Advanced.

Copy the current channel strip fader volume to the send level

You can copy fader volume from a channel strip directly to a send using the Copy Fader
to Send command. Using this command, you can quickly set the level for a send without
having to first enter Sends on Faders mode and make adjustments.
•
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Use aux channel strips
Overview of aux channel strips in Logic Pro
Aux channel strips can be used to create subgroups, to submix, to route a signal to multiple
destinations, and as additional destination channels for multi-output instruments. Typically,
you create aux channel strips as you need them. There are three ways to do this:
•

An aux channel strip is created automatically when a send assignment is made from
a channel strip, except when the chosen bus is already in use as an input source on
another channel strip.

•

When a multi-output instrument such as the Sampler is inserted into an instrument
channel strip, several aux channel strip assignments are made “behind the scenes.” You
then must create the required number of aux channel strips by clicking the Add button
(+) at the bottom of the instrument channel strip. Each time you click it, a new aux
channel strip is created (and automatically assigned to particular instrument outputs).

•

You can also create aux channel strips by choosing Options > Create New Auxiliary
Channel Strip from the Mixer menu bar.

You can delete channel strips as described in the Channel strip types in Logic Pro overview.

Create mix subgroups in Logic Pro
You can group several channel strips and route them via a single bus to a single aux
channel strip. This provides you with one set of controls over the entire group.
For example, say your mix contains multiple drum tracks that you want to manage using
a single set of channel strip controls, or you want to put a compressor across the whole
drum kit. You can do this by sending each of the drum tracks to the same bus, which in
turn sends their signals to the same aux channel strip. You might then route your vocal
tracks to a second aux channel strip, providing a separate group control for these channel
strips. Finally, you have the option to output both subgroups (drums and vocals) to the
same destination or to separate destinations.
Creating a mix subgroup using aux channel strips is similar to creating a summing
stack. The main difference is that you can add channel strips to an aux channel strip
subgroup without requiring those channel strips to be part of a Track Stack. See Track
Stacks overview.
There are also some similarities between using aux channel strips as subgroups and
working with Mixer groups. You can control the group/subgroup properties from one set
of channel strip controls. However, Mixer groups are used to control channel strip group
properties, and not the signal flow.
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Create a subgroup using an aux channel strip

1. In Logic Pro, select multiple channel strips by doing one of the following:
•

Shift-click the channel strips you want to group.

•

Drag over the background of the channel strips (drag horizontally across multiple
channel strips over the word Inserts, or I/O text, for example).

2. Click the Output slot of a selected channel strip, then choose a bus from the pop-up
menu.
The Output slots of all selected channel strips reflect the chosen bus. A new aux
channel strip is created, except when the chosen bus is already in use as an input
source on another channel strip. Its Input slot contains the channel strip signal flow
coming via the chosen bus.
3. Click the Output slot of the aux channel strip, then choose the output destination for
the main mix.
4. Use the aux channel strip controls to process the submix—adding inserts, setting
volume and pan, and so on.

Send signals to multiple destinations in Logic Pro
You can route a signal to several output destinations, using aux channel strips.
For example, you might have a main signal with the output destination set to external
speakers. At the same time, you want to hear the signal as a separate headphone mix,
including some additional effects. To do this, you would set up two separate output
destinations for your signal, with the aux channel strips controlling the headphone mix,
including the additional effects.

Output a single channel strip to two destinations

1. In Logic Pro, click the Output slot of the channel strip, then choose the main output
destination for the mix, such as speakers.
2. Click the channel strip’s Send slot, then choose the bus to send the separate signal to.
An aux channel strip is created automatically. Your chosen bus is reflected in the aux
channel strip’s Input slot.
3. Click the Output slot of the aux channel strip, then choose the second output
destination for the mix, such as headphones.
Your signal flow is now routed to two separate output destinations. The main signal flow
to the speakers is heard in its dry state. The second signal flow—via a bus to the aux
channel strip, and output to headphones—can be modified and heard in its wet state.
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Use multi-output instruments in Logic Pro

There are two reasons to use multi-output instruments in your mix:
•

To process each sound individually in a drum kit, for example, with different effects

•

To route the different software instrument outputs to different outputs on your audio
interface

Logic Pro supports the multiple outputs of all instruments that provide a multi-output
configuration (including Drum Kit Designer, Sampler, Studio Horns, Studio Strings,
Ultrabeat, and all Audio Unit instruments). One or more multi-output options may be
displayed in addition to the mono and stereo versions shown in the plug-in pop-up menu of
the Instrument slot.

Note: Not all instruments offer multi-output options.

Insert and set up a multi-output instrument

1. In a Logic Pro channel strip, click the Instrument slot, then choose the multi-output
instance from the pop-up menu.
The first two outputs of a multi-output instrument are always played back as a stereo
pair by the instrument channel strip that the plug-in is inserted into. Additional outputs
(3 and 4, 5 and 6, and so on) are accessed via aux channel strips.
2. In the plug-in window, set up the output routing for individual sounds or samples. This
is generally done using a pop-up menu with entries such as Main, 3-4, 5-6, and so on.
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3. In the Mixer, click the Add button (+) of the instrument channel strip that you inserted
the multi-output instrument into.

Note: The Add button (+) appears only on multi-output instrument channel strips.
An aux channel strip is created to the right of the multi-output instrument channel strip.
Use this new channel strip to isolate and route a sound for independent mixing and
processing.

4. Repeatedly click the Add button (+) to create more aux channel strips, for all stereo or
mono outputs available to the instrument plug-in.
You should create only as many aux channel strips as are required for the number of
outputs used by the multi-output instrument.
After you create the first aux channel strip for your multi-output instrument, a Delete
button (–) appears beside the Add button (+).
Click the Delete button (–) to remove aux channel strips.
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Use output channel strips in Logic Pro

By default, a project contains one output channel strip that takes the signal from all
the individual tracks in the project. You add additional output channel strips to assign
submixes, or to prevent them from being controlled by the master channel strip.
When using output channel strips in this way, you can’t apply any further send effects to
the signal flow, as you would using aux channel strips. You can, however, control settings
and insert effect plug-ins using the individual controls of the output channel strip.

In some cases, you might want to prevent individual output channel strips from being
controlled by the master channel strip—outputs used as send effects to external hardware
devices, for example. Simply make such output channel strips solo-safe and they won’t be
affected by the master channel strip.
The Insert slots of output channel strips allow signal processing during the mastering
process, as well as during normal playback. Typical mastering tools are the compressors,
de-essers, and equalizers. Due to technical reasons, you can only use plug-ins that don’t
require mono to stereo conversions. In other words, you can use stereo to stereo plugins on stereo output channel strips, and mono to mono plug-ins on mono output channel
strips. Surround (or multi-mono) versions of plug-ins can be used on mono or stereo
output channel strips. Mono to multi-mono variants can be used on mono output channel
strips. Stereo to surround, stereo to multi-mono, and true surround versions of plug-ins are
accessible in stereo output channel strips.
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Define a channel strip’s stereo output in Logic Pro

In Logic Pro, you can choose the physical output pair on which the stereo output is played.
By default, it’s played on Stereo Output (Output 1-2). However, you can easily change the
stereo output preference—if you’re exchanging projects with another studio that uses a
different output pair, for example.
You can also define the output pair for individual channel strips in the Mixer.

Define the stereo output for a channel strip
1. Choose Logic Pro > Preferences > Audio.
2. Click I/O Assignments, then click Output.
3. Choose an output pair from the Output pop-up menu in the Stereo section.
The Mirroring checkbox becomes available for all chosen output pairs, with the
exception of Output 1-2.

4. Do one of the following:
•

Deselect the Mirroring checkbox to have the output signal routed to the chosen
output pair (Output 3-4, for example).

•

Select the Mirroring checkbox to have the output signal routed to the chosen output
pair (Output 3-4, for example), as well as to the physical outputs (Output 1-2). This
is useful when feeding the signal to a second pair of monitors, for example.

Define the output pair for a channel strip
•

In Logic Pro, click the channel strip’s Output slot, then choose an output pair from the
pop-up menu.

Define a channel strip’s mono output in Logic Pro

You can define a channel strip’s mono output setting directly from the channel strip’s
Output slot.

Define the mono output for a channel strip
•
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Create tracks for signal flow channel strips in Logic Pro

Signal flow channel strips, which include aux and output channel strips, do not contain
regions, but serve to route the signals from other channel strips. Signal flow channel strips
do not normally appear in the Tracks area. However, you can add signal flow channel strips
to the Tracks area if, for example, you want to automate parameters on them. You can add
signal flow channel strips to the Tracks area either as individual tracks or as a Track Stack.

Create individual tracks for signal flow channel strips

1. In Logic Pro, select one or more signal flow channel strips.
2. Choose Options > Create Tracks for Selected Channel Strips, or press Control-T.
A new channel strip is created in the Tracks area for each of the selected channel strips.

Create a Track Stack for signal flow channel strips

1. In Logic Pro, select the signal flow channel strips that you want to be in the Track Stack.
2. Choose Options > Create Track Stack for Selected Channel Strips.
A new Track Stack containing all the selected signal flow channel strips is created in
the Tracks area, and the selected channel strips are combined into a Track Stack in the
Mixer. If you created a Folder Stack, the disclosure arrow in the Mixer is closed by default,
and only the Folder Stack channel strip appears. If you created a Summing Stack, the
disclosure arrow in the Mixer is open by default, and the selected channel strips appear
along with the enclosing Summing Stack auxiliary channel strip. For more information on
Track Stacks, see Track Stacks overview.

Work with Mixer groups
Overview of groups in Logic Pro

Before mixing, you may find it useful to create channel strip groups. You could, for
example, group all drum channel strips under one drum group. This would allow you to
adjust group parameters (volume, pan, mute, solo, sends, and so on) using a single control,
while still maintaining the relative parameter values of each channel strip. Using the groups
feature, you can:
•

Create new groups and add and remove channel strips from a group. See Edit group
membership.

•

Define which mixer features affect every channel strip in a group. See Groups inspector.

•

Automate a group. See Automate groups.

•

Edit every channel strip in a group simultaneously. See Group editing.

The Logic Pro mixer also supports a special kind of channel strip group designed
specifically for submixing the volume of multiple channel strips routed to different outputs,
called a VCA group. See Use VCA groups.
You can have a maximum of 64 groups. A channel strip can also be a member of
multiple groups.
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It is possible to use aux channel strips for grouping purposes, but with aux channel strips
the emphasis is on controlling overall signal flow.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
The Mixer groups feature is available.

Groups inspector in Logic Pro

You use the Groups inspector to define the behavior of each Mixer group. The Groups
inspector appears in the Track inspector when one or more groups have been created, and
it can be opened as a floating window as well. It contains the following settings:
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•

“Groups active” checkbox: Enables or disables all groups and group controls. Turn off
this setting to edit track parameters outside of all groups. Press Command-G to do so
when the Group Settings window is closed.

•

On checkbox: Enables or disables a particular group. Turn off this setting to edit track
parameters outside of the specified group.

•

Name field: Shows the group name, which you can create or edit by double-clicking.

•

H checkbox: When selected, hides all tracks belonging to the group. If the Hide Track
buttons of grouped tracks are in different states, the H checkbox displays “–”.

•

Editing (Selection) checkbox: When selected, selecting a region in the Tracks area
selects the same horizontal region range of all tracks in the group.

•

Quantize-Locked (Audio) checkbox: Defines whether an edit group is phase-locked or
independent when quantizing audio.

•

Automation Mode checkbox: When selected, changing the automation mode of one
track changes the automation mode of all tracks in the group.

•

Volume checkbox: When selected, changing the Volume fader of one track changes
the volume level of all tracks in the group. The channel strips continue to maintain their
relative volume levels.

597

•

Mute checkbox: When selected, changing the mute state of one track changes the mute
state of all tracks in the group.

•

Input checkbox: When selected, changing the input state of one track changes the input
state of all tracks in the group.

•

Pan checkbox: When selected, changing the Pan knob of one track changes the Pan
knob of all tracks in the group. The channel strips continue to maintain their relative pan
positions.

•

Solo checkbox: When selected, changing the solo state of one track changes the solo
state of all tracks in the group.

•

Record checkbox: When selected, changing the record-enabled state of one track
changes the record-enabled state of all tracks in the group. Multiple channel strips can
be simultaneously record enabled only if they use different inputs.

•

Send 1 to 8 checkboxes: When selected, links the Send Level knobs individually for
Send slots 1 to 8, while still maintaining the relative positions between them.

•

Color checkbox: When selected, changing the color of one track assigns this color to all
tracks in the group.

•

Track Zoom checkbox: When selected, zooming a region in the Tracks area zooms the
regions of all tracks in the group.

•

Hide Track (H) checkbox: When selected, selecting the Hide Track button of a grouped
track selects the Hide Track buttons of all tracks in the group.

Open the Groups inspector

In Logic Pro, do one of the following:
•

Double-click the header area of the Groups inspector.

•

Click the Groups inspector’s disclosure arrow.

•

Click the Group slot of a channel strip, then choose Open Group Settings from the popup menu.

•

Choose Mix > Show Groups.

Open the Groups inspector as a floating area
•
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In Logic Pro, drag the Groups inspector out of the inspector.
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Edit group membership in Logic Pro

You can add a channel strip to, or remove a channel strip from, single or multiple groups.
You can also temporarily disable all group parameter links—applying a Group Clutch—to
change the volume of an individual channel strip, for example.

Add a channel strip to a group

In Logic Pro, do one of the following:
•

Click the channel strip’s Group slot, then choose a group from the pop-up menu.

•

Select one or more channel strips in the Mixer, then choose Add Selected Channel
Strips in the Groups inspector Action pop-up menu.

Add a channel strip to multiple groups
•

In Logic Pro, click the channel strip’s Group slot, then press and hold Shift while
choosing a group from the pop-up menu.

Quickly add the most recent group setting to another channel strip
•

In Logic Pro, press and hold Option and click the channel strip’s Group slot.

The most recently accessed group setting—including the setting for overlapping groups—is
applied to the current channel strip.

Remove a channel strip from a group
In Logic Pro, do one of the following:
•

Click the Group slot, then choose the group from which you want to remove the
channel strip.

•

Select one or more channel strips in the Mixer, then choose Remove Selected
Channel Strips from the Groups inspector Action pop-up menu.

Remove a channel strip from all groups
•
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In Logic Pro, click the Group slot, then choose No Group.
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Disable all groups

In Logic Pro, do one of the following:
•

Deselect Mix > Groups Active (or press Shift-G).

•

Deselect Options > Enable Groups from the Mixer menu bar.

•

Deselect the “Groups active” checkbox in the Group Settings window.

When groups are disabled, all Group slots change color from yellow to light gray.

Enable all groups

In Logic Pro, do one of the following:
•

Select Mix > Groups Active (or press Shift-G).

•

Select Options > Enable Groups from the Mixer menu bar.

•

Select the “Groups active” checkbox in the Group Settings window.

When groups are enabled, all Group slots are yellow.

Automate groups in Logic Pro

By automating groups, you can easily change the values of parameters for a group of
channel strips over time. For example, you may wish to group all of your guitar channel
strips together and have all of their relative volumes change at the same time throughout
a project.
When you automate mixing functions (such as volume, pan, mute, or sends), any member
of the group can act as the mix automation master for that group. When you use that group
member to write an automation parameter value, the same value is written for the other
group members, depending on their automation mode.
The data is written individually for each channel strip. As a result, you can disable the
group later without affecting the automation of any group member, and you can edit or
change channel strips individually when you remove them from the group.
To learn more about automation, see Overview of automation.

Group editing in Logic Pro

Group editing allows you to perform many editing, arrangement and timing operations
on all group member tracks simultaneously. For example, you can combine the comping
feature with group editing so that every comp uses the same takes. You can move, resize,
and arrange regions for all group member tracks together. You can also adjust the timing of
the group, ensuring the group remains in time.
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Enable group editing
•

In the Logic Pro Groups settings window in the Track inspector, select both Editing
(Selection) and Quantize-Locked (Audio).

Use VCA groups in Logic Pro

Hardware mixing desks sometimes contain separate channels designed specifically to
enable the engineer to submix—in other words, to route and control the signal flow of
multiple channels at once using a single channel strip. Analog mixing desks often utilize
Voltage Controlled Amplifiers (VCAs) in their circuitry for these submix channels, hence
the name “VCA groups” for this kind of channel strip. You can use VCA channel strips to
control the volume, or automate a submix, of tracks that are assigned to the VCA group.
While much of the functionality of VCA groups can also be accomplished with aux
(auxiliary) channel strips, VCA groups have some unique advantages:
•

VCA groups can contain channel strips that are routed to different outputs.

•

VCA channel strips use less processing power than an aux channel strip utilized as a
group master.

•

Adjusting the volume of a VCA channel strip changes the volume of each individual
channel. This can be important when mixing. For example, if you use post-fader send
effects, the amount of signal sent to an effect by a channel assigned to a VCA group
follows the VCA group volume changes.

Create a VCA channel strip

In Logic Pro, do one of the following:
•

Choose Options > Create New VCA Fader from the Mixer menu bar.

•

Select one or more channel strips, then choose Options > Create New VCA for Selected
Channel Strips from the Mixer menu bar.

You can delete channel strips as described in the Channel strip types in Logic Pro overview.
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Assign a channel strip to an existing VCA group
•

In Logic Pro, click the channel strip’s VCA slot, then choose a VCA fader from the popup menu.

Remove a channel strip’s VCA group assignment
•

In Logic Pro, click the channel strip’s VCA slot, then choose No VCA from the pop-up
menu.

Surround panning in Logic Pro

You can mixdown in several surround formats, even if your audio hardware offers only two
outputs. Because it would be difficult to mix or record in surround format without being
able to hear the result, it’s best not to select this option if you’re monitoring or mixing
through stereo speakers. All audio, instrument, and aux channel strips can be individually
set to different surround formats.
Surround panning is available when Surround is selected in Logic Pro >
Preferences > Advanced.

Set a channel strip’s output to surround
•

In Logic Pro, click the channel strip’s Output slot, then choose Output > Surround from
the pop-up menu.

The Surround Panner control replaces the Pan knob. The loudspeakers are represented by
dots, and the pan position is indicated by a green dot that can be dragged.

For full details about using the surround feature, see Surround overview.

Set the surround position
In Logic Pro:
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•

Drag the green dot in the panning field to the desired location.

•

Option-click the dot to reset the green dot to the front center position.
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Binaural panning
Overview of binaural panning in Logic Pro

An important part of mixing audio signals is the placement of individual sound sources at
different spatial positions. Most common recording and mixing techniques simply send a
given signal at different levels to the available loudspeakers—two for stereo, or more for
quadraphonic or surround setups—to create a virtual sound stage.
This approach is somewhat flawed, however, because human beings are able to locate
sound sources at different positions with just two ears. Virtually all spatial information for
all sounds the listener hears is included in the two signals arriving at the two eardrums.
From these signals, human beings can determine characteristics such as inter-aural time,
level differences, and—based on the listening experience—information about the spatial
origin of the sounds being heard. Are they coming from in front or behind, from the left
or right, from above or below? This ability to perceive where a sound originates from is
referred to as binaural hearing.
In theory, the spatial positioning of any sonic experience can be reproduced during
playback, so no special techniques need to be employed during recording. There is,
however, one drawback to this approach: every person has differently shaped ears and
different body and head proportions, all of which influence the way sound signals arrive
at the eardrum—not to mention aspects such as hearing loss, subjective responses to the
sounds being heard, and so on. Given these physical differences, each person listening
to the same sound source, while standing or sitting in the same position, hears slightly
different binaural signals.
Therefore, perfect reproduction would only be possible if you could make a recording with
tiny microphones placed inside your auditory canals. Because this is impractical, binaural
hearing has been emulated in sound laboratories by using mannequin heads with built-in
microphones. This approach has led to binaural recordings to fit the average person, which
are more or less compatible with the way most people hear.
Playback of binaural recordings is best suited to headphones, ideally combined with signal
conditioning (processing) that ensures the signals are accurately reproduced. Given
a specialized listening environment, it’s also possible to reproduce these signals with
loudspeakers, utilizing a process known as crosstalk cancellation.
As you are unlikely to have the technology required to make binaural recordings, your best
chance of simulating binaural signals is by processing the sound signal on playback. This is
known as the head-related transfer function (HRTF), which approximates the change that a
signal undergoes on its way from the source to the eardrum.
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Use the Binaural Panner knob in Logic Pro

The Binaural Panner knob is available when Surround is selected in Logic Pro >
Preferences > Advanced.
By setting the channel strip’s panning mode to Binaural, you can use the Binaural Panner
knob to position the signals on the panning plane. The signal that results from using the
Binaural Panner knob is best suited for headphone playback. You can, however, process the
Binaural output using the Binaural Post-Processing plug-in, which allows you to play back
the binaural panning effect through loudspeakers.
You set the channel strip panning mode to Binaural as described in Select a panning mode
for a channel strip.
You can control the panning effect directly on the channel strip by using the Binaural
Panner knob to position the panning pucks on the panning plane. You can also access the
Binaural panning pucks and even more Binaural panning parameters in the Binaural window.
These are the window’s main elements:
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•

Angle, Elevation, Distance: Information fields that adjust automatically when changes
are made to the puck positions.

•

Spread: Information field that adjusts automatically when changes are made to the puck
positions. You can also interact directly with it by dragging its numerical value. (Making
changes here also affects the left and right puck positions.)

•

Panning plane: Area for positioning the signals—using the pucks—in the stereo image.

•

Pucks: Used for positioning the signals on the panning plane—pan and direction.
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•

Mode pop-up menu: Determines the virtual shape of the panning plane, which can be
planar or spherical.

•

Mode image: Represents the resulting position of the audio signal in the panning plane.
In Planar mode you can adjust the Vertical Offset, Tilt Amount, and Tilt Direction by
clicking the green dot and dragging the pointer.

•

Vertical Offset, Tilt Amount, Tilt Direction: Information fields that are present only
when Planar mode is selected. They adjust automatically when changes are made to
the Mode image.

•

Doppler button: Turns on or off the Doppler effect—a change in the pitch of a signal
perceived by a person who is moving relative to the source of the signal.

•

Size field and slider: Determines the size of the plane or sphere, expressed as the
radius of the circular plane.

•

Extended parameters: Click the disclosure arrow to reveal additional parameters for
headphone playback and Planar mode.

Adjust a channel strip’s Binaural Panner knob

You can make basic adjustments to the binaural panning field using the channel strip
Binaural knob.

In Logic Pro, do the following:
•

Drag the center puck in the panning plane to adjust the position of the signal.

•

Option-click in the panning plane to reset the center puck to center front position
and the spread to 90˚.

•

Drag the spread in the panning field to adjust its pan position.

Open the Binaural Panner window

1. In Logic Pro, command-click the channel strip’s Binaural knob, then choose Binaural
from the pop-up menu.
The Binaural Panner control replaces the Pan knob.
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2. Double-click the Binaural Panner control to open the Binaural Panner.

Control the binaural panning position

1. In Logic Pro, drag the left or right puck (panning pucks) to make the stereo image wider
or narrower.
The pucks also work on a second axis—up and down—relative to the third puck.
2. Drag the third puck (the direction puck) to determine the forward and backward
direction.
As you adjust the direction puck, the two panning pucks move accordingly. The Angle,
Elevation, Distance, and Spread values also change.
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3. Select the Mode (virtual shape) of the panning plane:
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•

If set to Planar, the panning results are shown on a flat circular plane.

•

If set to Spherical, the results are placed on a virtual sphere. If it helps, imagine the
sphere as a virtual head. When the direction puck is placed in the top half of the
circular plane, the sound is in front of the listener. As the direction puck is moved
toward the lower half of the plane, the sound passes up, and over your head, and
ends up behind the listener.
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4. Set the size of the plane or sphere by doing one of the following:
•

Drag the Size slider.

•

Double-click the Size field, then enter a new value.

•

Option-click the Size field to reset it to its default value (1.50m).

5. Click the Doppler button to turn on or off the Doppler effect.
6. Select the Diffuse-Field Compensation checkbox in the Extended Parameters area to
ensure a neutral sound for headphone playback, utilizing diffuse-field compensation.
Note: When using multiple Binaural Panners on several channel strips, turn this option
off and route the output of the Binaural Panners to an aux channel strip, in which you
insert the Binaural Post-Processing plug-in. The Binaural Post-Processing plug-in
allows you to apply diffuse-field compensation to all Binaural Panner outputs at once,
saving CPU power.
7. If in Planar mode, drag the Mode image to control the vertical offset and tilt of the
circular plane.

The Binaural Post-Processing plug-in in Logic Pro

The Binaural Post-Processing plug-in is available in aux and output channel strips. This
plug-in allows you to apply various compensation modes on a stereo bus or output,
through which several, or all, binaural signals are routed. This saves CPU power and makes
it easy to switch between compensation modes.
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Work with MIDI channel strips
Overview of MIDI channel strips in Logic Pro

MIDI channel strips in the Mixer work as remote controls for the mixing parameters of your
MIDI-controlled sound modules and synthesizers, such as volume and pan.

Logic Pro User Guide

•

Program buttons: Use to select a sound by name. Click one to open a pop-up menu
that contains either GM sound names (the default setting) or sound names created or
imported by the user. Each channel strip has its own pop-up menu, whose content can
vary depending on the Bank number selected in the Bank fields.

•

Bank fields: If your sound source “understands” bank select events, you can choose the
bank number for each of the MIDI channel strips. The lower value sends controller value
32, and the upper value sends controller value 0; this is for MIDI instruments that have
127 x 127 banks. You can use several different bank select formats (see Custom bank
selects) if your device does not use the standard controller 0/32 messages. Remember
that not all synthesizers support bank select events.

•

Assign 1 to 5: Display up to five knobs that you can freely assign to any MIDI controller
number.
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View the MIDI channel strip controls (if hidden)
•

In Logic Pro, choose View > MIDI Channel Strip Components from the Mixer menu bar,
then choose a component.

The basic channel strip controls, such as volume, pan, and mute, are always shown on MIDI
channel strips.

Adjust MIDI channel strips in Logic Pro

On MIDI channel strips, you can adjust the volume level and pan position, control MIDI data
transmission, and assign controller data.

Adjust the volume of a MIDI channel strip
•

In Logic Pro, drag the Volume fader up or down.

Controller #7 is sent via your MIDI interface.

Set the pan position of a sound
•

In a Logic Pro MIDI channel strip, drag the Pan knob vertically.

Controller #10 is sent via your MIDI interface.

Stop or start the sending of MIDI data from the MIDI channel strip
•

In Logic Pro, click the Mute button.

When the Mute button is on, the MIDI channel strip stops sending MIDI data.

Assign a controller to one of the knobs

You can use each of the Assign 1 to 5 knobs to send MIDI controller data to the external
MIDI instrument, allowing you to remotely control parameters such as volume, pan,
and chorus.
1. In a Logic Pro MIDI channel strip, click the label above the knob.

2. Choose a controller from the pop-up menu.
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Save and restore MIDI channel strip settings in Logic Pro

MIDI channel strip settings in the Mixer directly affect the Track inspector. The current
settings of all channel strips are saved with the project.
If the active settings of your sound module are not maintained when you switch it off (some
devices reset to default values), any Logic Pro Mixer settings that affect the unit are lost.
Fortunately, Logic Pro Mixer settings are automatically restored and transmitted to all MIDI
devices when you reload the project. If this doesn’t happen—due to MIDI communication
issues with some devices, for example—you can manually resend the MIDI channel
strip settings.

Resend the MIDI channel strip settings
•

In Logic Pro, choose Options > Send All MIDI Mixer Data from the Mixer menu bar.

Customize the Mixer
Change the Mixer view in Logic Pro

When the number of channel strips in the Mixer exceeds the amount of available space,
you can change the Mixer view.
You can use the Single, Tracks, or All button to display only those channel strips that you
need for the task at hand, or filter channel strips by type, using the channel strip filter
buttons. You can use the View menu in the mixer and key commands to hide or shows
specific types of channel strips. You also have the option of working with narrow channel
strips or hiding the legend that appears on the left side of the Mixer.

Hide or show signal flow channel strips
In Logic Pro, do one of the following:
•

Choose View > Signal Flow Channel Strips in the Mixer menu bar.

•

Use the Show/Hide Signal Flow Channel Strips key command.

Hide or show only channel strips with sends
•

In Logic Pro, choose View > Channels with Sends Only in the Mixer menu bar.

Show or hide all tracks assigned to the same channel strip or instrument
In Logic Pro, do one of the following:
•

Choose View > All Tracks with Same Channel Strip/Instrument in the Mixer menu bar.

•

Use Show/Hide All Tracks with Same Channel Strip/Instrument key command.

Show or hide channel strips for tracks not normally shown in the mixer
In Logic Pro, do one of the following:
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•

Choose View > Other Tracks in the Mixer menu bar.

•

Use the key command for Show/Hide Other Tracks.
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Switch between narrow and wide channel strips
In Logic Pro, do either of the following:
•

Click the Narrow Channel Strips button in the Mixer menu bar to reduce the width of
channel strips.

•

Click the Wide Channel Strips button in the Mixer menu bar to increase the width of
channel strips.

Hide or show the Mixer legend
•

In Logic Pro, choose View > Hide Legend in the Mixer menu bar.
Choose View > Show Legend to show it again.

Navigate within the Mixer in Logic Pro

You can quickly move to the next or previous channel strip in the Mixer using the following
key commands:
•

Select Next (Right) Channel Strip (or press the Right Arrow key)

•

Select Previous (Left) Channel Strip (or press the Left Arrow key)

When multiple channel strip types are visible in the Mixer, you can choose a command to
jump to a particular channel strip type. This feature is useful when your Mixer view contains
dozens, or hundreds, of channel strips.

Navigate to a specific channel strip type
•
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In Logic Pro, choose View > Scroll To from the Mixer menu bar, then choose a channel
strip type from the pop-up menu.
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View channel strips linked to folder tracks in Logic Pro
A folder track in the Tracks area is represented by a channel strip in the Mixer.

Note: Make sure that View > Folder Tracks is chosen from the Mixer menu bar.

Enter a folder

In Logic Pro, do one of the following:
•

Double-click the folder track in the Mixer.

•

Double-click the folder region in the Tracks area.

•

Select the folder, then use the Go Into Folder or Region key command.

The Mixer now displays only those channel strips that are in the folder track.

Exit the folder

In Logic Pro, do one of the following:
•

Click the Display Level button

at the left side of the Mixer or Tracks area.

•

Double-click the Tracks area background.

•

Use the Go Out of Folder or Region key command.

The Mixer now displays all channel strips, including the folder channel strip.
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Rename channel strips in Logic Pro

By default, the Track Name area at the bottom of each channel strip displays the name of
the associated track in the Tracks area. However, you can rename channel strips directly in
the Mixer.

Rename a channel strip

1. In Logic Pro, double-click the Track Name area of a channel strip.
2. Enter a new name for the channel strip in the text field of the Track Name area.
You can also Control-click the Track Name area and choose Rename Channel Strip from the
shortcut menu to rename a channel strip.

Rename multiple channel strips

1. In Logic Pro, select multiple channel strips.
2. Control-click the Track Name area of one of the selected channel strips and choose
Rename Channel Strip from the shortcut menu.
3. Enter a new name in the text field of that channel strip’s Track Name area.
The names of all the selected channel strips change to the new name.
If the new channel strip name ends in a number, the selected channel strips are numbered
sequentially from the leftmost selected channel strip to the final selected channel strip,
regardless of which channel strip is used to enter the name. For example, if you select
three channel strips and rename them using the middle channel strip. If you rename that
middle channel strip “vox 1,” the leftmost channel strip is renamed “vox 1,” the middle
channel strip “vox 2,” and the rightmost channel strip “vox 3.”
When you rename channel strips in the Mixer, the tracks in the Tracks area that are
associated with the channels strips reflect the change. You can customize exactly how
channel strip names are displayed in the track headers by configuring track header
components. See Rename tracks and Track header overview.
The Track Name area of each channel strip displays two lines of two lines of 11 characters
in narrow channel strip mode, and 14 characters in wide channel strip mode. If the name
exceeds these limits, Logic Pro truncates the middle characters of the name and replaces
them with an ellipsis (three periods). Keeping channel strip names as concise as possible
makes easier to read. If you need to write more information about a channel strip, use the
Track Notes feature. See add track notes in Logic Pro.

Logic Pro User Guide

614

Add track notes in the Mixer in Logic Pro
You can view, add, edit, and delete track notes in the Mixer.

You can also access track notes in the Note Pad, where you can change the text format and
view and edit text with greater visibility.

Access notes in the Mixer

In Logic Pro, do one of the following:
•

Choose View > Channel Strip Components > Notes from the Mixer menu bar.

•

Control-click the Mixer, then choose Track Notes from the shortcut menu.

Add, edit, or delete track notes in the Mixer
•

In Logic Pro, double-click the Notes area, then add or delete text.

The track notes in the Main window’s Note Pad are also updated accordingly.

View control surface bars in Logic Pro

You can see which tracks are accessed by control surfaces connected to your system.

View control surface bars in the Mixer
Do one of the following:
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•

In Logic Pro, choose View > Channel Strip Components Control Surface Bars from the
Mixer menu bar.

•

Control-click the Mixer, then choose Control Surface Bars from the shortcut menu.
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Link control surfaces to the Mixer in Logic Pro

You can have control surface groups follow changes in the Mixer, including changes to the
Mixer view.

Link control surfaces to the Mixer
•

In Logic Pro, choose View > Link Control Surfaces from the Mixer menu bar.

Use the I/O Labels window in Logic Pro

You can use the I/O Labels window to define names for all channel strip Input, Output, and
Send (Bus) menu items, to use in place of the default labels (such as “Input 1”).

Open the I/O Labels window

In Logic Pro, do one of the following:
•

Choose Mix > I/O Labels.

•

Choose Options > I/O Labels from the Mixer menu bar.

Choose a device from the Device pop-up menu, if you have multiple audio interfaces.
I/O labels can be individually defined for each hardware driver type, but are valid for
all projects.

Edit the labels for Input, Output, and Send slots

1. In the Logic Pro I/O Labels window, select the button in the User column.
2. Double-click the “-” in the Long (name) column, enter a new name, then press Return.
3. Repeat the process for the Short (name) column.
Channel strip items can have both a long name and a short name. The short name appears
in Send slots.
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Revert to default labels

In the Logic ProI/O Labels window, do one of the following:
•

Click the corresponding button in the Channel column.

•

Choose one of the following from the Reset pop-up menu:
•

Reset All Labels

•

Reset Input Labels

•

Reset Output Labels

•

Reset Bus Labels

Use the labels provided by hardware drivers
•

In the Logic Pro I/O Labels window, click the corresponding button in the Provided by
Driver column.

Undo and redo Mixer and plug-in adjustments
in Logic Pro

Using the Mixer Undo and Redo commands and the Undo History, you can undo and redo
adjustments that you make to channel strips and plug-ins in the Mixer. Undoing or Redoing
Mixer and plug-in adjustments is exactly like undoing adjustments in other areas of Logic
Pro. The main difference is in the Undo History, where you can choose to include or remove
changes from the Mixer and plug-ins from the Undo History action list. If you want to undo
changes you make in the Mixer and to plug-ins, make sure that you have the buttons for
Include Parameter Changes From for both Mixer and Plug-in turned on.

There are also specific Mixer and plug-in undo commands in the Mixer > Edit menu:
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•

Mixer Undo: Undo last Mixer Action.

•

Mixer Redo: Redo last Mixer Action.

•

Undo selected Channel Strips: Undo last changes, such as fader adjustments, to the
selected channel strips.
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•

Redo selected Channel Strips: Redo last changes, such as fader adjustments, to the
selected channel strips.

•

Include Mixer Undo Steps in Project Undo History: Select to include Mixer and plug-in
undo steps in the Project Undo History.

•

Delete Mixer Undo History: Deletes the Undo History for parameter changes in the
Mixer.

To learn more about using Undo, Redo, and the Undo History window, see Undo and redo
edits. To learn more about using undo and redo from the plug-in window header, see Undo
a plug-in parameter change and Redo a plug-in parameter change.
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Automate mix and effects settings

Overview of automation in Logic Pro

Automation refers to recording, editing, and playing back the movements of faders, knobs,
and switches. Using automation, you can create changes over time to volume, pan, and
other settings. You can add automation to all track types.
Each track in your project has automation curves for volume and pan, and you can add
curves to automate plug-in settings. To create changes over time, you do the following:
•

Show the automation curve you want to work on, and choose between track automation
and region automation.

•

Choose an automation mode.

•

Add automation points to the curve at the start and end points for the change you want,
then adjust the automation points.

You can also snap automation to positions in the grid and edit automation in the
Automation Event List.

Track automation vs. region automation in Logic Pro

Logic Pro offers two types of automation: track automation and region automation. Track
automation can be applied to the entire track, from the beginning to the end of your
project. Region automation applies only to the specific region the automation parameters
are connected to. With track automation, if you re-record, move, or copy regions (either to
another point on the same track or to another track entirely) the automation data remains
tied to the initial point on the track in which it was created. However, with region automation,
if you re-record the region, the automation is lost; if you move or copy the region (either to
another point on the same track, or to another track) the automation remains with the region.
Region automation is particularly useful when you are automating instrument parameters.
When using region automation with instrument tracks and Drummer tracks, you can also
automate MIDI data for individual notes. In addition, you can also convert track automation
to region automation and vice versa.

A single track can have track automation on the track, and regions on that track with region
automation. To switch between which type of automation to view, see Switch between track
automation and region automation.
Note: In previous versions of Logic Pro, MIDI Draw was used to automate MIDI data for
individual notes. Region automation includes all the functionality of MIDI Draw.
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Convert between types of automation

In Logic Pro, choose one of the following commands from the Mix > Convert
Automation submenu:
•

Convert Visible Track Automation to Region Automation: Converts displayed track
automation to region automation.

•

Convert Visible Region Automation to Track Automation: Converts displayed region
automation to track automation.

•

Convert All Track Automation to Region Automation: Converts all track automation to
region automation, regardless if it is currently visible onscreen.

•

Convert All Region Automation to Track Automation: Converts all region automation to
track automation, regardless if it is currently visible onscreen.

Note: These commands all have assignable key commands as well.

Show automation curves in Logic Pro

Before you can add automation points to a track’s automation curves, you need to show the
automation curves. Automation curves are displayed as colored curves and points on top of
audio and MIDI regions across the track, running the length of the project. You can choose
whether to view and edit automation across the track (track automation) or only within the
track’s regions (region automation).

After you show the automation curves, you can choose which parameter you want to work
with—Volume, Pan, or any other track parameter. You can work with multiple parameters on
the same track by switching between automation curves using the Automation Parameter
pop-up menu, or you can work in separate subtracks, which appear below the main track.

Show automation curves
•

In Logic Pro, do one of the following:
•

Choose Mix > Show Automation (or press A).

•

Click the Show/Hide Automation button

in the Tracks area menu bar.

An Automation button, an Automation Parameter pop-up menu, and an Automation
Mode pop-up menu appear in each track header. When you chose an automation mode,
for most automation modes the background color of the Automation Mode pop-up menu
reflects the mode:
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•

Gray background = automation is off

•

Mustard background = Touch mode

•

Orange background = Latch mode

•

Purple = Write mode
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For Read mode, however, the button and text color display the current state of
automation and if there is automation data present:
•

Green text on a gray background = automation is on but there is no existing
automation data to display

•

White text on a green background = automation is on and there is existing
automation data to display

Any existing automation is displayed on the track or within the regions. If you show
automation on a collapsed Track Stack, all the automation from included tracks is
displayed. You can choose the parameter you want to automate—Volume fader, Pan
knob, or any other track parameter—from the Automation Parameter pop-up menu.

Switch between track automation and region automation

You can easily switch between viewing track automation and region automation. See Track
automation vs. region automation for details on the differences between the two types of
automation.
•
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In Logic Pro, click the Automation button in the track header to switch between track
automation and region automation.
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Choose the parameter to automate
In Logic Pro, do one of the following:
•

Choose a parameter from the Automation Parameter pop-up menu in the track header.

•

Control-click the track lane, then choose an automation parameter from the Automation
Parameter pop-up menu in the shortcut menu that appears.

The parameter currently shown in the automation lane is shown at the top of the
Automation Parameter pop-up menu. Volume, Pan, Solo, and Mute appear in the “Main”
submenu. A submenu is also shown for Smart Controls; for more information on automating
Smart Controls, see automate screen control movements.
Below the Smart Controls submenu, the Automation Parameter pop-up menu contains a
submenu for each plug-in on the track. The plug-in submenus are numbered and named
after the slot position and plug-in: 1 Sampler, for example. When using region automation
with an instrument or Drummer track, a MIDI sub-section shows all available MIDI
parameters available for you to automate.
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Note: Logic Pro offers more than two dozen unassigned key commands that you can use
to select the automation curves of various region automation parameters directly. You can
assign these key commands to keys, controllers, or a Touch Pad using the Key Commands
window. When you select one or more regions and then use one of these key commands,
the chosen automation curve will be shown on all tracks with regions selected. If you use
one of these key commands without any regions selected, the selected track will show the
chosen automation curve. See assign key commands.

Automatically select which automation parameter to display

You can automatically show the automation curve of any parameter you click in a channel
strip, plug-in editor, or track header on the main automation lane.
•

In Logic Pro, choose Mix > Autoselect Automation Parameter in Read Mode (or use the
Toggle Autoselect Automation Parameter in Read Mode key command).

Automation must show in the main automation lane, and the automation mode must be
set to Read, for “Autoselect Automation Parameter in Read Mode” to work. See Choose
automation modes to learn more about the automation modes.
Note: When Autoselect Automation Parameter in Read Mode is active, Record Automation
with MIDI Regions is disabled. See Choose automation modes.

Mute an automation parameter curve

You can mute an individual automation parameter by turning it off in the track header.
1. In Logic Pro, choose a parameter from the Automation Parameter pop-up menu in the
track header.
2. Place the pointer over the Automation Parameter pop-up menu, then click the On/Off
button that appears.

When muted, the automation curve for the parameter will turn gray.
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Show multiple parameter curves on automation subtracks

1. In Logic Pro, click the disclosure arrow at the lower left of a track header.

2. Choose the parameter that you want to automate from the Automation Parameter popup menu in the track header.

3. To add additional subtracks, click the Plus button (+) that appears when you place the
pointer over the track header.

All additional automation subtracks are revealed. Each additional subtrack is set to an
automation parameter type that’s already recorded but not currently shown. The active
automation parameter remains on the main track.
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Add, remove, and reorder automation subtracks
In Logic Pro, do any of the following:
•

To add a subtrack: Place the pointer over the subtrack header, then click the Plus (+)
that appears.

•

To remove a subtrack: Place the pointer over the subtrack header, then click the X icon
that appears.
The selected subtrack is removed without deleting its automation.

•

To reorder subtracks: Drag the subtrack up or down.

Tip: You may find it easier to work with automation curves at a higher zoom level. To do
so, drag the lower edge of the track header downward.

Choose automation modes in Logic Pro

Automation modes determine how automation tracks are treated. Automation is either
being read or being written. You can independently set the automation mode for each
track. You can also trim automation values and record relative automation data.

Logic Pro User Guide

•

Read: Plays back all automation that exists on the track. If volume data exists,
for example, the Volume fader moves during playback, following the prerecorded
automation on the track. You can’t change the value of the chosen automation
parameter by moving controls when in Read mode. However, you can record region
information directly into a MIDI region in Read mode.

•

Touch: Plays back automation in the same way as Read mode. You can modify the value
of the chosen automation parameter by moving controls in Touch mode. After the fader
or knob is released, the parameter follows existing automation on the track.

•

Latch: Works like Touch mode, but after the fader or knob is released, the new
parameter value replaces existing automation on the track.

•

Write: Erases existing automation on the track as the playhead passes over it. Records
the new control movement or deletes the existing data if you do nothing.

•

Trim: Offsets the value of the existing automation (Volume, Pan, Send levels) by
adjusting it up or down by the amount you move the fader or control. Works in
combination with Touch and Latch automation modes.

•

Relative: Adds a secondary automation curve that offsets the existing primary curve
for the selected parameter. There are three channel strip parameters for which you
can create relative automation: Volume, Pan, and Send levels. When both relative and
absolute automation exists for one of these parameters, both curves are visible and can
be edited separately. Relative automation mode works in combination with Touch, Latch,
and Write automation modes.
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Set the automation mode for a track
In Logic Pro, do one of the following:
•

Show the track’s automation curves, then choose a mode from the Automation Mode
pop-up menu in the track header.

•

Chose a mode from the Automation mode pop-up menu on a track’s channel strip.

Set the same automation mode for selected tracks
In Logic Pro, do one of the following:
•

Shift-click track headers to select them, then choose a mode from the Automation
Mode pop-up menu in one of the track headers.

•

Shift-click channel strips in the Mixer to select them, then choose a mode from the
Automation Mode pop-up menu in one of the selected channel strips.

Set the automation modes using key commands

In Logic Pro, you can set the automation mode using the following key commands:
•

Toggle Current Track Automation Off/Read

•

Set Current Track to Automation Read

•

Toggle Current Track Automation Touch/Read

•

Toggle Current Track Automation Latch/Read

•

Toggle Current Track Automation Write/Read

•

Set All Tracks to Automation Off

•

Set All Tracks to Automation Read

•

Set All Tracks to Automation Touch

•

Set All Tracks to Automation Latch

•

Set All Tracks to Automation Write

Use Trim Automation mode

1. In Logic Pro, choose Touch or Latch from the Automation Mode pop-up menu in the
track header or the track’s channel strip.
2. Choose Trim from the Automation Mode pop-up menu in the track header or the track’s
channel strip.
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Either T-Touch or T-Latch appears in the Automation Mode display. The Volume fader
moves to a center position and the fader becomes transparent.

Now when you move the Volume fader during playback, it does not write completely new
volume automation data but adjusts it proportionally to the existing data.

Use Relative Automation mode

1. In Logic Pro, choose Touch, Latch, or Write from the Automation Mode pop-up menu in
the track header or the track’s channel strip.
2. Choose Relative from the Automation Mode pop-up menu in the track header or the
track’s channel strip.
Either R-Touch, R-Latch, or R-Write appears in the Automation Mode display. The
Volume fader moves to a center position and the fader becomes transparent.

Relative automation is only available for the following parameters: Volume, Pan, and
Send level.
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Consolidate Relative and Absolute automation curves

If you do not need to edit relative and absolute automation curves separately, you may
want to tidy up your automation curves by consolidating absolute and relative automation
curves into the same curve.
•

In Logic Pro, with automation curves shown, Control-click the track header and choose
Consolidate Relative and Absolute [Parameter] Automation from the shortcut menu.

Consolidating the relative and absolute curves has no effect on automation playback.

Record MIDI region automation when in Read mode

When recording, you can record region automation data into MIDI regions on software
instrument tracks even if the track is in Read mode. In Logic Pro, do one of the following:
•

Choose Record Automation with MIDI Regions from the Automation mode pop-up menu
on the channel strip of a software instrument track.

•

Choose Record Automation with MIDI Regions from the Automation Mode pop-up menu
in the track header of a software instrument.

Note: When Record Automation with MIDI Regions is active, Auto-Select Automation
Parameter in Read Mode is disabled. See Show automation curves to learn about AutoSelect Automation Parameter in Read Mode.
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Add automation to tracks
Add and adjust automation points in Logic Pro

To create changes over time to volume, pan, and effects settings, you add automation
points to a track’s automation curve at different places, and then adjust the automation
points so the value of the setting changes. You can adjust automation points by moving
them up or down to a new value or by moving them left or right to a new point in the
timeline. Numerical values are displayed alongside each automation point. You can also
raise or lower the value of MIDI parameters associated with notes in instrument tracks or
Drummer tracks. Note and numerical values are displayed alongside each MIDI data point.
You can also add automation points at selection area or region borders.

When splitting a region containing region automation, automation points are automatically
added to the automation curves of the original region and the new region at the point of
the split. These new points can then be adjusted and moved to create new changes over
time for the new region. For more information on splitting regions, see Split regions.

Add one or more automation points to an automation curve
With Logic Pro in automation mode, do any of the following:
•

To add an automation point to an empty automation curve: Click anywhere in the
automation track.
This adds an automation point at the project start position, using the current fader
value.

•

To add an automation point to an existing automation curve, do any of the following:
•

Click the automation curve.

•

Double-click an empty area of the automation track.

•

Click on or outside the automation curve with the Pencil tool.

All of these actions add an automation point at the clicked position.

Add a series of MIDI data points using region automation
•

With Logic Pro in automation mode, and a MIDI controller data parameter showing in the
Automation Parameter pop-up menu, drag a line across the portion of the region.
New MIDI data is created. If Velocity is the chose MIDI controller data parameter, new
MIDI data is created at every point at which notes intersect the line you drew.
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Add a series of automation points using the Pencil Tool

You can use the Pencil Tool to draw multiple automation points on an automation curve.
•

With Logic Pro in automation mode, click-drag or Option-click-drag the Pencil Tool
across the automation curve.

The organization of automation points depends upon the Pencil Tool setting in the
Automation preferences. You have two options:
Hold Option for Stepped Editing: In this mode, click-dragging with the Pencil Tool creates
a series of automation points in a curved formation, and Option-click-dragging creates a
series of automation points in a stepped formation.
Hold Option for Curved Editing: In this mode, click-dragging with the Pencil Tool creates
a series of automation points in a stepped formation, and Option-click-dragging creates a
series of automation points in a stepped formation.

Add automation points at marquee borders

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can do the following:

•

With Logic Pro in automation mode, drag across a region with the Marquee tool, then
click the marquee selection.

Add automation points at region borders

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can do either of the following:

•

To add one automation point at each region border: With Logic Pro in automation mode,
select the region, then choose Mix > Create Track Automation > Create 1 Automation
Point at Region Borders.

•

To add two automation points at each region border: With Logic Pro in automation
mode, select the region, then choose Mix > Create Track Automation > Create 2
Automation Points at Region Borders.

Add automation points at selection borders

With Logic Pro in automation mode, do either of the following:
•

To add one automation point at each selection border: Control-Shift-drag across the
Tracks area.

•

To add two automation points at each selection border: Control-Shift-Option-drag
across the Tracks area.

Adjust automation points

With Logic Pro in automation mode, do any of the following:
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•

Drag an automation point up or down to change its value.

•

Drag an automation point left or right to move it to a different point in the timeline. Use
the ruler to make sure automation points are aligned with a beat or measure.
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Adjust MIDI values in region automation

1. With Logic Pro in automation mode, and a MIDI data parameter showing in the
Automation Parameter pop-up menu, select one more more MIDI values.
2. Drag up or down to change its value.

Adjust an automation point range in Logic Pro

You can adjust the automation data for an entire track in one go. If the track is part
of a group, and if the relevant settings are selected in the Groups inspector, the track
automation data across all tracks in the group adjusts accordingly. However, the relative
parameter values of each track are maintained.
You use the trim behavior in the track header to adjust automation points for:
•

An entire track

•

A partial selection (marquee) across a track

•

Multiple selected tracks

•

Multiple selected subtracks

Adjust a range of automation points
•

With Logic Pro in automation mode, after making your selection, place the pointer over
the numerical display in the track header (the parameter value changes to Trim), then
drag vertically to change the value (the offset or trim amount).

Tip: If the Trim field is not visible, position the pointer over the line dividing the track
headers from the left edge of the tracks, then (when you see the Resize pointer) drag
the line left or right to resize the track headers.
When you release the mouse button, the numerical display reverts to showing the value of
the active automation parameter at the playhead position.
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Record live automation in Logic Pro

When either Touch, Latch, or Write mode is active, you can record automation in record or
playback mode. When you touch or move a parameter, the automation lane displays the
chosen parameter and automation is recorded at the current point in the project as the
playhead moves, based on the chosen mode. When not recording or playing, the modes are
ignored, and no data is written if a control is moved.
You have the following Write options for track automation:
•

Move any fader or control on the selected channel strip with the automation mode set
to Touch, Latch, or Write. In real-world usage, you’ll rarely (if ever) use the destructive
Write mode, which erases all automation. The standard Write modes are Touch and
Latch.

•

Choose a parameter from the Automation Parameter pop-up menu in the track header,
then adjust the numerical display in the track header, with one of the modes turned on.

•

Move the faders or knobs of a connected hardware controller, with one of the modes
turned on.

•

Use the Pointer or Pencil tool to draw your automation curve.

When you record track automation in Touch, Latch, or Write mode, the automation is
written to the track, and the automation curve of the parameter you are adjusting is
automatically displayed in the main automation lane.
When you record region automation in Touch, Latch, or Write mode to regions on a
track, region automation is written to the regions on that track. When you record region
automation in Touch, Latch, or Write mode, and multiple tracks are assigned to the channel
strip recording live automation, the following conditions determine where automation
is recorded:
•

If one track is selected, region automation only writes automation to regions on that
track.

•

If there are selected regions on one of the tracks, region automation only writes to
those selected regions.

•

If no track or regions are selected, region automation only writes to the region most
recently created.

You can specify the mode that the application switches to after a Write operation has been
performed using the Automation Preferences pane. See Automation preferences.
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Select, copy, move, and delete automation
Select, copy, and move automation in Logic Pro

After you create automation points and curves, you can easily change things to meet your
needs. You can copy automation within a track or between tracks and can move automation
within a track. When moving regions, you can choose whether or not to move any existing
automation with it.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can use the Automation Select and Automation Curve tools to select and bend
automation curves.

Select automation

With Logic Pro in automation mode, do one of the following:
•

Drag across any selection of automation points and curves.

•

Click the automation curve with the pointer or Automation Select tool.

Select non-contiguous automation

With Logic Pro in automation mode, do one of the following:
•

Hold down Shift and drag across multiple non-contiguous automation points and
curves.

•

Hold down Shift and click multiple non-contiguous automation points and curves with
the pointer or Automation Select tool.

Select specific automation values within a time range

Sometimes you may want to only select a specific range of automation points and curves
in a time range. Rather than every automation point and curve. You can do this by holding
down the Option key.
•

With Logic Pro in automation mode, hold down Option and drag across a range of
automation curves both vertically to select a value range, and horizontally to select a
time range.
Note: Automation curves connected to points that have been selected also appear
selected, even if those curves continue outside the selected range.

Select all automation following an automation point or curve
With Logic Pro in automation mode, do one of the following:
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•

To select all automation following an automation curve that is part of a selection:
Option-Click on an automation curve.

•

To select the automation data before, and all automation after, a selected automation
point: Option-Click on an automation point.
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Copy automation within a track
•

With Logic Pro in automation mode, select the points or curves you want to copy, then
Option-drag the selection to a different location on the track.

Any existing points in the target location are deleted.
Note: Depending on zoom level, it can be challenging to select only the automation you
wish to move. Be sure to zoom in on the automation points or curves that you wish to
select for best results. See Zoom windows.

Copy automation between tracks

1. With Logic Pro in automation mode, hold down Shift while dragging a selection within
the automation area.
2. Choose Edit > Copy (or use the corresponding key command).
3. Select the track you want to copy the automation to.
4. Choose Edit > Paste (or use the corresponding key command).

Move automation
•

With Logic Pro in automation mode, select the points or curves you want to move, then
drag them horizontally or vertically.

Any existing points in the target location are deleted.

Adjust automation curve symmetrically between two horizontally aligned points

When two automation points have the same value but occur at different times, the
automation curve between them is a horizontal line. You can adjust the two points so that
both points are moved together or apart equally.
1. With Logic Pro in automation mode, click the automation curve between the two points.
2. Option-Shift-Drag the automation curve horizontally to increase or decrease the
automation curve between the two points.

Create a vertical automation line

When the display shows two automation points with different values connected by a
vertical automation curve—in other words, they occur at the same moment—it creates the
effect of an instant parameter change. This can be useful if you wish to create an “instant
on” or “instant off” type of effect, rather than a gradual parameter change.
•

With Logic Pro in automation mode, drag an automation point or curve to the left,
toward an automation point with a higher or lower value.
The automation point you are dragging snaps to a position directly above or below the
stationary automation point.
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You can also drag an automation point to the right toward an automation point with a higher
or lower value, but the automation point you are dragging does not snap into a vertical
automation line.

Move regions with or without automation
•

•

In Logic Pro, choose one of the following Move Automation with Regions options in
Logic Pro > Preferences > Automation:
•

Never: Does not move automation when you move regions.

•

Always: Always moves automation when you move regions. The automation area
encompassed by the region boundaries is moved.

•

Ask: A dialog prompts you to move the automation—or leave it where it is—whenever
you move a region.

In Logic Pro, Control-click the track lane, then choose one of the following options from
the shortcut menu that appears:
•

Never move Automation with Regions

•

Always move Automation with Regions

•

Ask to move Automation with Regions

Move a region selection with its automation

1. In Logic Pro, drag across the region with the Marquee tool.
2. Choose Edit > Copy from the Tracks area menu bar.
3. Select the track you want to copy the automation data to, then move the playhead to
the insertion point.
4. Choose Edit > Paste from the Tracks area menu bar.
The region selection, along with its automation, is copied to the target track at the
playhead position.

Bend an automation curve

With Logic Pro in automation mode, do one of the following:
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•

Drag an automation curve with the Automation Curve tool.

•

Hold down Control-Shift while dragging an automation curve with the Pointer tool.
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Change an automation curve into stepped automation

Normally, an automation curve between two automation points represents continuously
changing parameter values. Using the Automation Curve tool, you can change any
automation curve into stepped automation.
With Logic Pro in automation mode, do one of the following:
•

Option-click an automation curve with the Automation Curve tool. Option-click the
automation curve with the Automation Curve tool again to return the automation curve
to its previous state.

•

Control-Shift-Option-click an automation curve with the Pointer tool. Control-ShiftOption-click the automation curve again to return the automation curve to its previous
state.

Delete automation in Logic Pro

You can delete individual automation points, multiple automation points, or use a number of
commands to delete automation across tracks.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
commands to delete automation are available.

Delete a single automation point

With Logic Pro in automation mode, do one of the following:
•

Double-click the automation point.

•

Select the automation point, then press Delete.

•

Drag across the automation point with the Eraser tool.

Delete multiple automation points
•

With Logic Pro in automation mode, select multiple automation points, then press
Delete.
Important: Make sure that no regions are selected, or they also are deleted.

Delete automation using commands
•
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In Logic Pro, choose one of the following options from Mix > Delete Automation:
•

Delete Visible Automation on Selected Track: Removes automation for the active
automation parameter.

•

Delete All Automation on Selected Track: Removes all automation from the selected
track.

•

Delete Orphaned Automation on Selected Track: Removes all orphaned automation
from the selected track. Automation can become orphaned when copied between
tracks.
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•

Delete Redundant Automation Points: Removes all redundant automation points on
all regions and tracks.

•

Delete All Track Automation: Removes all automation from all tracks.

Note: You can also use key commands for all the delete commands in the Mix menu except
Delete All Track Automation.

Snap automation to grid position in Logic Pro

You can snap track automation to grid positions. You can choose if you want automation
to automatically use the division value chosen in the Snap menu, or you can choose a
different snap value for automation.
When snapping is available, and when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced, you can also offset automation, by moving it slightly
forward or backward in time. Offsetting automation compensates for any audio hardware
latencies, excessive processor loads, or plug-in delays.

Snap automation points to the chosen Snap Automation value
•

In Logic Pro, choose Snap Automation from the Snap pop-up menu and select a value
from the submenu.

Automation edits snap to the value chosen in the Snap Automation submenu.
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Offset automation when Snap Automation is active

1. In Logic Pro, choose Automation Snap Offset from the Snap pop-up menu.

2. Adjust the Snap Offset parameter in tick values (can be positive or negative).

All automation on all tracks is offset by the chosen number of ticks.

Edit in the Automation Event List in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can edit automation in a dedicated Automation Event List window. This floating list
window includes only recorded automation data, unlike the standard Event list that includes
all recorded MIDI data and can either be a floating window or one of the List Editors in the
main window.

Open the Automation Event List window
•

In Logic Pro, use the Track Automation Event List key command (default assignment:
Control-Command-E).
Note: You may need to assign this key command in the Key Command Editor in order to
use it. See Assign key commands.

Edit track automation
•
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In Logic Pro, Edit individual events in the Automation Event List window. You can edit
the position, length, value, and so on, of your automation data in this window.
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Write automation with controllers in Logic Pro

Logic Pro provides support for a number of dedicated control surfaces that make writing
and editing track automation fast, efficient, and easy. Depending on the facilities available,
you can simultaneously write automation for several channels, or multiple plug-in
parameters. Any MIDI controller—such as the modulation wheel, or a front panel slider
or knob on your MIDI keyboard—can be used to write automation. You can use one such
controller for all automation writing duties, or you can assign individual controllers (if
available on your MIDI keyboard) to different parameters.
The Automation Quick Access (AQA) feature makes track automation extremely fast and
simple if you only have one hardware MIDI controller available—one fader on your MIDI
keyboard, or just the modulation wheel, for example. You can use this single hardware
controller to automate the currently active automation parameter of the selected track in
the main window.

Set up Automation Quick Access

1. Choose Logic Pro > Preferences > Automation.
In the Automation pane, Automation Quick Access is turned off by default.

2. Click the On button in the Automation Quick Access section.
A dialog prompts you to assign a controller.
3. Click the Assign button and slowly move the hardware controller that you want to use
for Automation Quick Access. Make sure that it’s moved through its entire range.
4. Confirm your selection by clicking the Done button below the Off/On buttons in the
Automation Quick Access section.
The Done button changes into a Learn Message button. Clicking the Learn Message
button allows you to assign a new controller for Automation Quick Access. Clicking
the Edit button opens the Controller Assignments window, where you can assign the
controller manually. See the Logic Pro Control Surfaces Support manual for more
information. Once set up, you have hardware control over the active automation
parameter on the current track.
Tip: If you choose the modulation wheel for Automation Quick Access, you might want
to switch between using it for Automation Quick Access and normal modulation wheel
duties—as MIDI controller 1. You can do this quickly using the Toggle Automation Quick
Access key command (or pressing Control-Option-Command-A).
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Use Smart Controls

Overview of Smart Controls in Logic Pro

With Smart Controls, you can control the sound of the selected track using a set of
onscreen controls. Smart Controls can control both channel strip and plug-in parameters,
including software instruments (on software instrument tracks) and effects (on audio,
software instrument, and Drummer tracks). Smart Controls provide a quicker alternative to
opening plug-in windows and adjusting individual parameters.
Each Smart Control has a set of screen controls. Adjusting a single screen control can
change one or more parameters for the track’s channel strip, instrument, and effect plugins. Smart Controls typically include EQ or tone controls, reverb and other effect controls,
and controls specific to the type of track or instrument. For example, the Smart Control
for a synthesizer might include screen controls for choosing the waveform and adjusting
the resonance and filter cutoff, while one for a string instrument might include controls for
changing the articulation. Screen controls are labeled to help you understand which aspect
of the sound each one affects.
To work with Smart Controls, open the Smart Controls pane. The Smart Controls menu bar
includes several tabs, including Controls and EQ. Other tabs may be available, depending
on the type of patch selected. You can also show Smart Controls for master effects and for
local send effects.
For audio tracks, you can access the Tuner using the Tuner button in the Smart Controls
menu bar. For software instrument tracks, you can access the Arpeggiator using the
Arpeggiator button.
If your computer has a Touch Bar, you can use the Touch Bar to adjust screen controls on
the selected track.
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When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can change the layout for a Smart Control, map screen controls and edit mappings,
rename screen controls, and assign external controllers to screen controls in the Smart
Control inspector.

Open the Smart Controls pane in the main window
•

If your computer has a Touch Bar, select a track in the Logic Pro Tracks area, then click
the Smart Controls button
.

Open the Smart Controls as a separate window
•

In Logic Pro, choose Window > Open Smart Controls.

Adjust screen controls using the Touch Bar

1. In Logic Pro, tap the Mode button on the left side of the Touch Bar, then tap the Smart
Controls button
.
2. Tap the screen control name, then drag the slider left or right to adjust the screen
control setting.

Show Smart Controls for master effects
in Logic Pro

In addition to showing screen controls for the selected track, you can view and edit screen
controls for master effects on the output track. To view master effects, click the Master
button in the Smart Controls menu bar.
When you select Master in the Smart Controls menu bar, the effects on the master track
are available in the following sections:
•

Controls: Work with effects including a compressor, limiter, and others.

•

EQ: Use the Channel EQ to shape the overall sound of the project.

Show Smart Controls for the output track
•
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In Logic Pro, click the Master button on the left side of the Smart Controls menu bar,
then do one of the following:
•

To see screen controls for effects on the output track: Click the Controls tab.

•

To see the Channel EQ for the overall project: Click the EQ tab.
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Show Smart Controls for bus effects

In addition to master effects on the output track, you can view and edit Smart Controls for
effects on any bus the selected track is routed to.
•

In Logic Pro, choose a bus effect from the Master Effects pop-up menu, located to the
right of the Master button.

Choose a Smart Control layout in Logic Pro

Each Smart Control features a layout, with a background graphic and a set of screen
controls in a defined order. Each layout is designed for a particular type of instrument or
track. If the selected track doesn’t contain plug-ins, an empty layout is displayed.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can choose a different layout for the current Smart Control to change the number or
arrangement of screen controls. In the Layout menu, you can choose between layouts for
the selected Smart Control, along with a Factory Layouts submenu containing additional
layouts. You can also have Logic Pro automatically choose an appropriate layout.
For Track Stacks, you can choose a layout for the main track of a summing stack, but not
for the main track of a folder stack. Subtracks for both folder stacks and summing stacks
can have their own Smart Control layout.
When a subtrack of a summing stack is selected, an additional Main Track Smart Controls
item appears in the Layout menu. Choosing this item shows the layout for the main track
of the summing stack, rather than a separate layout for the subtrack. Adjusting any screen
controls switches focus to the main track of the summing stack.
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Choose a different layout for the current Smart Control
1. In Logic Pro, click the Inspector button

in the Smart Controls menu bar.

The Smart Control inspector opens, showing additional parameters for the Smart
Control.

2. Click the name of the current layout at the top of the Smart Control inspector, then
choose a new layout from the Layout pop-up menu.
To have Logic Pro choose an appropriate layout, choose Automatic Smart Controls.

Automatic MIDI controller assignment in Logic Pro

Logic Pro supports automatic assignment of hardware controls for a variety of USB MIDI
controllers. When a supported USB MIDI controller is connected, the knobs, sliders, and
other hardware controls on the controller are automatically assigned to Smart Controls and
other functions in Logic Pro.
•

Buttons are assigned to button screen controls. Buttons for common transport functions
(including Play, Stop, Pause, Record, Cycle and others), marker functions (including
Previous Marker, Next Marker, and Add Marker), and other functions are assigned to the
corresponding key commands for these functions.

•

Knobs are assigned to knob screen controls.

•

Faders are assigned to fader screen controls, with the following exception: when the
controller has only one fader, labeled Volume, that fader is assigned to Mixer volume for
the selected channel strip. For devices without knobs, faders may also be assigned to
knob screen controls.

Enable a USB MIDI controller for automatic assignment

The first time you connect a supported USB MIDI controller, a dialog appears, asking if you
want to use the device as a control surface.
To have Logic Pro automatically assign the controls on the device to Smart Controls and
other functions: click Auto Assign.
To use the device as a MIDI controller without automatic assignment: click No.
You can change the setting for each connected device in Logic Pro > Control Surfaces >
Preferences > MIDI Controllers. For more information, see MIDI Controllers preferences and
the Control Surfaces Support Guide for Logic Pro.
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Map screen controls automatically in Logic Pro

When you choose Automatic Smart Controls as the layout, all screen controls are mapped
automatically. You can also automatically map screen controls for a Smart Control for which
you have chosen a layout, in which case Logic Pro determines an appropriate mapping for
the screen controls.
Automatic mapping is useful when you have added plug-ins to an empty channel strip, for
tracks with Apple Loops, and with projects created in previous versions of Logic Pro.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can choose whether to automatically map all screen controls in the current Smart
Control, or only unmapped screen controls. In order to map screen controls, the Smart
Control (and the track) must have at least one plug-in inserted.

Apply automatic mapping to a Smart Control

1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. In the Parameter Mapping area, click a mapping, then choose one of the following:
•

To map all screen controls: Choose Map all Controls.

•

To map only unmapped screen controls: Choose Map all Unmapped Controls.

Map screen controls in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can map screen controls to channel strip and plug-in parameters for the selected
track. Each screen control can be mapped to one or more channel strip or plug-in
parameters for the selected track. Parameter mappings are saved with the patch.
You can map screen controls using either the Learn process, or the Parameter pop-up
menu in the Smart Control inspector. When you map a screen control, it jumps to the
mapped parameter value. Only one screen control can be selected at a time.
You can copy and paste mappings, which is useful for sharing mappings between different
screen controls of the same patch. When two tracks have identical plug-ins, mappings can
also be copied from the Smart Control on one track and pasted to the Smart Control on
the other track (in which case they control the corresponding parameters for the track on
which they are pasted).

Map a screen control using the Learn button

1. In Logic Pro, in the Smart Controls pane, click the the Inspector button
Controls menu bar.

in the Smart

2. Select a screen control.
3. In the Smart Control inspector, click Parameter Mapping.
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The Parameter Mapping area opens. When an unmapped screen control (or no screen
control) is selected, the Name field shows Unmapped. When you select a mapped
screen control, the Name field shows the name of the parameter.

4. Click the Learn button.
5. Click the channel strip or plug-in parameter to which you want to map the screen
control.
6. To map additional screen controls, select another screen control, then click a
parameter.
7. When you’re finished mapping screen controls, click the Learn button again to end the
Learn process.

Map a screen control using the Parameter Mapping pop-up menu

1. In Logic Pro, in the Smart Controls pane, click the the Inspector button
Controls menu bar.

in the Smart

2. Select a screen control.
3. In the Smart Control inspector, click Parameter Mapping.

4. In the Parameter Mapping area, click the parameter name (if the screen control is
already mapped) or the word Unmapped, then choose a channel strip or plug-in
parameter from the Parameter Mapping pop-up menu.

Logic Pro User Guide

645

Add a mapping

1. In Logic Pro, in the Smart Controls pane, click the the Inspector button
Controls menu bar.

in the Smart

2. Select a screen control.
3. In the Smart Control inspector, click a mapping, then choose Add Mapping from the
Parameter Mapping pop-up menu.
4. Choose the parameter for the added mapping, either using the Learn process or the
Parameter Mapping pop-up menu.

Open the plug-in window for a mapping

1. In Logic Pro, in the Smart Controls pane, click the the Inspector button
Controls menu bar.

in the Smart

2. Select a screen control.
3. In the Smart Control inspector, click Parameter Mapping.
4. Do one of the following:
•

Click the plug-in icon

next to the name of the mapping.

•

Control-click the screen control, then choose Open Plug-in Window from the
shortcut menu.

Copy a mapping

1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. Select the screen control.
3. In the Smart Control inspector, click a mapping, then choose Copy Mapping from the
Parameter Mapping pop-up menu.
4. Click a different parameter name, then choose Paste Mapping.
The copied parameter replaces the selected one.

Copy all mappings for a screen control

1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. Select the screen control.
3. In the Smart Control inspector, click a mapping, then choose Copy All Mappings from
the Parameter Mapping pop-up menu.
4. Click any parameter name, then choose Paste Mappings.
The copied parameters replace the existing ones.
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Reorder mappings for a screen control

If a screen control has multiple mappings, a handle, indicated by three dots, appears on
the left edge of each mapping in the Smart Control inspector, so that you can reorder
mappings in the list. The screen control values are determined by the topmost mapping.
1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. Select the screen control.
3. In the Smart Control inspector, drag a mapping up or down by its handle.

Delete a mapping

1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. Select the screen control.
3. In the Smart Control inspector, click a mapping, then choose Delete Mapping from the
Parameter Mapping pop-up menu.
After you map a screen control, you can edit mapping parameters, and scale parameter
values using parameter mapping graphs. You can also map screen controls automatically.

Edit mapping parameters in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can set the maximum and minimum range values and invert the range for the selected
parameter mapping in the Parameter Mapping area of the Smart Control inspector. Each
mapping can have its own values, including multiple mappings for the same screen control.
You can also scale input values using the parameter mapping graphs.

Edit mapping parameters for the selected screen control
In Logic Pro, do any of the following:
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•

To set the maximum (high) value for the mapped parameter: Drag the Range Max value
slider.

•

To set the minimum (low) value for the mapped parameter: Drag the Range Min value
slider.

•

To invert the maximum and minimum values in relation to the direction used to adjust
the selected screen control: Select the Invert Range checkbox.
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Use parameter mapping graphs in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can edit the Parameter graph for each parameter mapping to remap (or scale) input
values from the screen control to different output values. The graph includes a series of
preset curves that you can apply. The graph for one mapped parameter can be copied
and pasted to another mapped parameter. You can also invert the range of values or reset
the graph.

Open the Parameter graph

In Logic Pro, in the Parameter Mapping area of the Smart Control inspector, click the
Scaling: Open button.
The Parameter graph window opens. The title of the graph window shows the
parameter name.

The graph shows the range of input values on the horizontal (x) axis, moving from left to
right, and the range of output values on the vertical (y) axis, moving from bottom to top.
In the graph window, you have several ways of working: you can edit the graph curve
directly, set the graph to use one of the predefined curves, or change the minimum and
maximum range values for the graph.

Edit the graph

1. In Logic Pro, do any of the following:
•

Click a curve button (in the upper-left part of the window) to use one of the preset
curves.

•

Click the curve at the location where you want to add a curve point, then drag the
curve point to the desired value. Drag horizontally to change the input value or
vertically to change the output value.
As you drag, the current values of the curve point appear next to the pointer.
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•

Double-click the curve at the location where you want to add a curve point, then edit
the values for the curve point.

•

Option-click any part of the curve (except a curve point), then drag the dotted part
of the curve to make the curve nonlinear.

•

Click Invert to invert the values of the curve.

•

Click Reset to reset the graph to its original (default) values.

2. Continue adding and adjusting points until you’re happy with the result.
3. When you’re finished, click the close button at the upper-left corner of the graph window.

Copy the graph
•

In Logic Pro, click the Copy button on the right side of the graph window.

Paste a copied graph
•

In Logic Pro, click the Paste button on the right side of the graph window.

Open the plug-in window for a screen control
in Logic Pro

For screen controls that are mapped to a plug-in, you can open the plug-in window used by
the screen control from within the Smart Controls pane.

Open the plug-in window for a mapped screen control
In Logic Pro, do one of the following:
•

In the Smart Controls pane, Control-click the screen control, then choose Open Plug-in
Window from the shortcut menu.
If the screen control is mapped to multiple plug-ins, the plug-in windows for all of the
mapped plug-ins open.

•

Open the Smart Control inspector, then click the Plug-in Window button
Parameter Mapping row for a mapping.

in the

Rename a screen control in Logic Pro

When you map a screen control, it takes the name of the parameter to which it is mapped
(in the case of multiple mappings, the first mapped parameter). The screen control name
appears in the Smart Control inspector above the Parameter Mapping area.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can change the name in the Smart Control inspector.

Change the name of a screen control

1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. Select the screen control.
3. In the Smart Control inspector, select the name, then enter a new name for the screen
control.
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Use articulation IDs to change articulations
in Logic Pro

Some software instruments that use the Sampler software instrument, including drummers,
strings, and other orchestral instruments, provide multiple articulations for MIDI notes
using articulation IDs. For patches containing these software instruments, you can map a
screen control to the Articulation ID parameter and use it to change note articulations in
real time while you play the patch.

Map a screen control to the Articulation ID parameter

1. In Logic Pro, in the Smart Controls pane, click the the Inspector button
Controls menu bar.

in the Smart

2. Select a screen control.
To switch between two values, select a button screen control. To select between a
larger range of values, select a knob or slider screen control.
3. In the Smart Control inspector, click Parameter Mapping.
4. In the Parameter Mapping area, click the parameter name, then choose Nonautomatable > Main > Articulation ID from the pop-up menu.
5. Set the Range Min to 1 (one). Set the Range Max to the next value (to switch between
two values) or to the number of used articulation IDs (to select between all used
values).
When you play the patch, you can change articulations by manipulating the screen control.

Assign hardware controls to screen controls
in Logic Pro

To use Smart Controls with a MIDI controller, you assign hardware controls on the
controller (faders, knobs, buttons, drum pads, pedals, and other controls) to screen
controls. After you assign a hardware control to a screen control, the screen control
receives the MIDI messages from the hardware control.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can assign hardware controls to screen controls using the Learn process, which is
similar to learning controller assignments for a control surface. You can select only one
screen control at a time, and each screen control can have only one assignment. When
you assign a hardware control, it keeps the assignment for all Logic Pro projects, until you
reassign it.

Assign an external hardware control using the Learn button

1. In Logic Pro, in the Smart Controls pane, click the Inspector button
Controls menu bar.

in the Smart

2. Select a screen control.
3. Click External Assignment.
The External Assignment area opens. If the selected screen control currently has no
assignment, the Name field shows Unassigned. If the selected screen control has an
assignment, the Name field shows the name of the assignment.
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4. Click the Learn button.
5. On your MIDI device, move the control you want to assign.
6. While the Learn process is active, you can learn additional controller assignments by
selecting another screen control and moving the hardware control you want to assign to
it.
7. When you’re finished assigning controls, click the Learn button again to end the Learn
process.

Compare Smart Control edits with saved settings
in Logic Pro

While you’re working with a Smart Control, you may want to compare your edits to the
saved settings to hear how your changes affect the sound. The Compare function only
compares changes to parameters to which screen controls are mapped; other parameter
changes are not included in the comparison.

Compare your edits to the saved Smart Control settings
•

In Logic Pro, click the Compare button in the Smart Controls menu bar.
To return to the edited version, click the Compare button again.

Use the Arpeggiator in a Logic Pro project

You can use the Arpeggiator MIDI plug-in with the Smart Controls on a software instrument
track. When you turn on the Arpeggiator, chords you play on the keyboard are arpeggiated,
or played one note at a time rather than simultaneously.
After you turn on the Arpeggiator, the Arpeggiator pop-up menu appears in the menu bar.
You can choose an Arpeggiator preset and adjust Arpeggiator settings, including note
order, note range, and octave range from the Arpeggiator pop-up menu. You can also open
the Arpeggiator MIDI plug-in window to make further changes.

Turn on the Arpeggiator
•

In Logic Pro, click the Arpeggiator button

in the Smart Controls menu bar.

The Arpeggiator pop-up menu appears in the menu bar.
Turning on the Arpeggiator inserts the Arpeggiator plug-in on the channel strip, after which
you can use the Arpeggiator button to bypass the Arpeggiator. You can also open the
Arpeggiator plug-in from the channel strip.
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Choose an Arpeggiator preset
•

In Logic Pro, choose a preset from the Arpeggiator pop-up menu in the Smart Controls
menu bar.

Adjust Arpeggiator settings

In the Arpeggiator pop-up menu in Logic Pro, do any of the following:
Choose Note Order, then choose the direction of arpeggiated notes from the submenu.
Choose Note Range, then choose a note value for arpeggiated notes, based on the tempo
of the song.
Choose Octave Range, then choose how many octaves the arpeggio covers.

Open the Arpeggiator MIDI plug-in
•

In Logic Pro, choose Open Arpeggiator from the Arpeggiator pop-up menu in the Smart
Controls menu bar.

For full details about using the Arpeggiator MIDI plug-in, see the MIDI plug-ins section of
the Logic Pro Effects manual.

Automate screen control movements in Logic Pro

You can automate the movements of screen controls, just as you can automate plug-in
parameters. When you automate a screen control, the actual screen control movements,
rather than underlying parameter values, are written.
Automation for multi-mapped screen controls is retained even when the underlying plugin is changed or removed. However, if all of the plug-ins to which the screen control is
mapped are removed, the automation is deleted.

Automate movements of a screen control

1. In Logic Pro, choose the automation mode for the track as described in Choose
automation modes in Logic Pro.
2. Record screen control movements as described in Record live automation in Logic Pro.
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Use Live Loops

Logic Pro Live Loops overview

Live Loops lets you arrange and play with musical ideas in real time in a grid of cells, each
containing a musical phrase or loop. You can start and stop cells freely while keeping
everything in sync with the beat and the project tempo. Each grid row uses the same signal
routing and channel strip settings as the adjacent track in the Tracks area. Cells in grid
columns, called scenes, can be triggered together to act as musical sections. An extensive
set of parameters gives you full control over playback, recording, and looping, so you can
spontaneously take your music in new directions.
To the right of the Live Loops grid, the Divider column separates the grid from the Tracks
area. Buttons in the Divider column show the status of playing or queued cells in each
track. You can use the buttons to pause, start, or stop cells individually or all at once. You
can also use the Divider column to switch playback between cells and regions on individual
or multiple tracks. See How the Live Loops grid and Tracks area interact.
Live Loops is designed for use with the Remix FX plug-in, a multi-effect featuring several
realtime DJ-style effects. You can also use a control surface or Logic Remote to control
Live Loops, helping enhance your creative flow and achieve greater flexibility and precision.
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You can record to both audio and software instrument cells, add regions or Apple Loops to
the Live Loops grid, and record a Live Loops performance as regions to the Tracks area.
Logic Pro provides several starter grids containing instruments and prerecorded cells to
help you get started.

Show the Live Loops grid

You can view either the Live Loops grid or Tracks view, or both at the same time.

In Logic Pro, do either of the following:
•

Show or hide the Live Loops grid: Click the Live Loops Grid button
menu bar or use the Show/Hide Live Loops Grid key command.

in the Tracks area

•

Show or hide Tracks view: Click the Tracks View button

•

Toggle between the Live Loops grid and Tracks view: Click the active button (or use the
corresponding key command, default: Option-V).

•

Show Live Loops grid and Tracks view: Press Option-B.

in the Tracks area menu bar.

You can add Live Loops to any existing project by showing the Live Loops grid and
adding cells.
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Create a Live Loops project

1. Choose File > New from Template (or press Command-N).
2. In the Project Chooser, select an option from the list on the left:
•

To create a new, empty Live Loops project: Click New Project, then select Live Loops.

•

To open a Live Loops starter grid: Click Starter Grids, select the project you want to
open, then click Choose.

Import a Live Loops grid from another project

You can import a Live Loops grid from another Logic Pro project, including cells and track
settings, into your current project.
•

Choose File > Import > Live Loops Grid.
New tracks and rows containing the imported track settings and cells are now visible
under those in the current project.

You can also import cells from individual tracks when you import data and settings from
other projects by selecting the checkbox in the Cells column in the Track Import view.
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Start and stop Live Loops cells in Logic Pro

You can start and stop cells individually, or start and stop all the cells in a scene (a column
in the grid) simultaneously. Only one cell can play on a track at any time. You can select
one or more cells in different scenes and queue them to play together. While a cell is
playing, a circular indicator in the middle of the cell shows the current playback position. If
cell looping is turned off, a rectangular indicator shows the current playback position.

The point in time when a cell starts or stops is determined by the Quantize Start value.
Quantize Start ensures that cells start at musically meaningful positions (beats or bars),
so they are in sync with other cells and the project playhead position. You can change the
Quantize Start value for the grid, for scenes, or for individual cells. Triggered cells flash to
indicate that they are queued to start at the next quantize start point.
If you trigger a cell too late to start at the desired quantize start point, it starts playing
at the next quantize start point. The cell will still be in sync with the project tempo, but
it might lead to undesirable musical results, especially when cells are following a short
quantize start value. Smart Pickup ensures that cells start immediately at the correct
position, even when triggered slightly late. However, this can result in the beginnings of
the cells being skipped in order to ensure that the cells are at the correct position when
they start playing. In order to avoid this and ensure that cells start playing from the Start
position set in the Cell inspector, turn Smart Pickup off and trigger cells with enough time
before the upcoming quantize start point.
Cells in the Live Loops grid play at the project tempo. Apple Loops and untagged loops
added to cells automatically play at the project tempo, as do any audio files containing
tempo information. When you add an audio file without tempo information to a cell,
Logic Pro analyzes the tempo of the audio file and adjusts the file to the project tempo. You
can manually edit Smart Tempo and transients in the Cell Editor.
By default, when a cell is playing on a track containing regions, the regions on that track
are silent. You can change this behavior using the buttons in the Divider column. See How
the Live Loops grid and Tracks area interact.
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Play cells

In Logic Pro, do either of the following:
•

Start a cell: Click the Play button in the center of a cell.

•

Start all the cells in a scene: Click the trigger

•

Start all selected cells: Use the Play Live Loops key command (Return).

below a scene.

When cells are playing, the Play buttons in the cells become Stop buttons.

Stop cell playback

In Logic Pro, do any of the following:
•

•

•

•
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Stop playback of a cell:
•

Click the Stop button of the playing cell.

•

Click the Stop button of an empty cell on the same track as the one playing.

Stop playback of all cells at the next quantize start point:
•

Click the Grid Stop button

•

Click the Scene trigger

at the bottom of the Divider column.

below an empty scene.

Stop playback of all cells immediately:
•

Use the Play or Stop key command (Space bar).

•

Use the Stop key command (0 on the numeric keypad).

Stop playback of all selected cells: Use the Play Live Loops key command (Return).
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Queue cells and scenes

You can queue cells and scenes to start playing when project playback starts or when you
want cells in different scenes to start at the same time. Playing cells are automatically
queued when you stop a project. You can then move the playhead and restart the queued
cells at a different project position.
In Logic Pro, do any of the following:
•

Queue a cell: Option-click the center of the cell you want to queue.

•

Queue multiple cells: Select one or more cells, then do either of the following:

•

•

Control-click one of the selected cells, then choose Queue Cell Playback from the
shortcut menu.

•

Use the Queue Cell/Scene Playback key command (Option-Return).

Queue a scene:
•

Option-click the trigger of the scene you want to queue.

•

Control-click the trigger of the scene you want to queue, then choose Queue Scene
from the shortcut menu.

•

Select the scene you want to queue, then use the Queue Cell/Scene Playback key
command (Option-Return).

The queued cells start flashing.
To start queued cells playing, do one of the following: Start project playback, click the
Restart button
in any of the queued cells or use the Play Live Loops key command
(Return) to play queued cells at the next quantize start point.

You can dequeue all queued cells by using the Queue Cell/Scene Playback key
command again.
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Set the Quantize Start value

You can set the Quantize Start value for the entire Live Loops grid, for a scene, or for
individual cells, and change it while cells are playing. When you trigger a scene, all cells
in the scene use the Quantize Start value for that scene. When you start or stop individual
cells, each cell uses its own Quantize Start value.
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•

To set the Quantize Start value for the Live Loops grid: Choose a value from the
Quantize Start pop-up menu near the upper-right corner of the grid.

•

To set the Quantize Start value for a scene: Control-click the Scene trigger
Quantize Start, then choose a value from the submenu.

•

To set the Quantize Start value for cells: Select one or more cells, then do one of the
following:

, choose

•

Click the disclosure arrow in the Cell inspector next to Play Mode, then choose a
value from the Quantize Start pop-up menu.

•

Control-click a cell, choose Playback > Quantize Start, then choose a Quantize Start
value from the submenu.
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In addition to bar and beat values, you can also choose the following Quantize
Start options:
•

Cell End: If another cell in the same row is playing, the triggered cell starts when the
playing cell reaches the end of the loop.

•

Off: Cells start and stop when you click them, regardless of the Quantize Start value.
Note that this can lead to cells playing out of sync.

•

Global: The cell or scene follows the Quantize Start value of the grid. This is the default
setting for cells and scenes, and probably the best choice for most situations.

Turn on Smart Pickup
•

Click the Quantize Start pop-up menu in the upper-right corner of the grid, then choose
Smart Pickup.

Set the play mode

The play mode in Logic Pro determines how a cell starts and stops when you click the Play/
Stop button. Both actions are subject to the Quantize Start value. You can choose three
play modes:
•

Start/Stop: Cells start and stop playing when you click them.

•

Momentary: Cells start playing when you click and hold the pointer on them, and stop
playing when you release the pointer.

•

Retrigger: If a cell is playing and you click it again, it starts playing from the beginning.
Cells set to Retrigger can be stopped only by starting another cell in the same row, by
stopping the row using the Divider column, or by stopping the entire grid.

Do either of the following:
•

Select one or more cells, then choose a play mode from the Play Mode pop-up menu in
the Cell inspector.

•

Control-click a cell, choose Playback > Play Mode, then choose a play mode from the
submenu.

You can also change the play mode for scenes.
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Change the start behavior of a cell

The Play From setting determines the start behavior of a cell. By default, cells start playing
from the Start position. However, depending on the content and timing of your music, you
can choose other start behavior settings to create interesting transitions between cells.
•

In Logic Pro, select one or more cells and choose one of the following settings from the
Play From pop-up menu in the Cell inspector:

•

Start: The cell starts at the position determined by the set Start position.

•

Stop Position: The cell starts playing from the point where it last stopped, similar to
Play/Pause.

•

Playing Cell Position: If another cell in the same row is playing, the cell starts playing
from the position where the first cell stops. Otherwise, the cell starts from the Start
position.

•

Playhead Position: The cell starts from the position where it would be, as if it had
been playing from the beginning of the project. Otherwise, the cell starts from the
Start position.

Work with Live Loops cells in Logic Pro

You can add regions or loops to cells in the Live Loops grid, as long as the region or loop
matches the track type for the track containing the cell. For example, you can add audio
regions to cells on audio tracks, and MIDI or pattern regions to cells in rows on software
instrument tracks.
After adding Drummer regions or pattern regions to the grid, you can convert them to MIDI
cells to allow for precise editing of notes and make use of functions not available in Step
Sequencer. You can also extract loops from audio cells, with optimal loop start and end
points set by Logic Pro.
In addition to adding regions to cells, you can record to Live Loops cells, and record a Live
Loops performance as regions to the Tracks area. You can also copy cells to the Tracks
area, as well as copy and paste scenes to the playhead position in the Tracks area. When
copying cells to the Tracks area, take care to match the track type to the cell type (for
example, you can paste audio cells only to audio tracks).
When you add an audio file without tempo information to a cell, Logic Pro analyzes the
tempo of the audio file. You can edit the tempo information using the Edit Smart Tempo and
Edit Transients commands in the Cell Editor Edit menu.
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If you plan to record audio without a constant tempo to a cell, it is recommended that you
record the audio to an audio track in the Tracks area using the Smart Tempo functions in
Logic Pro. Once the audio region is tagged with correct tempo information, you can add the
region to an audio cell and have it play at a constant tempo.

Add a region from the Tracks area to the Live Loops grid
In Logic Pro, do one of the following:
•

Drag a region from the Tracks area to a cell of the same type in the Live Loops grid.

•

Drag a region from the Tracks area to an empty area of the grid, below the existing
tracks.
A new track of the appropriate type (audio or software instrument) is created, and the
cell is added to the new track. The new track has the same channel strip settings as the
original track.

When you drag a region from the Tracks area to the Live Loops grid, Logic Pro places a
copy of the region in the cell. The original region in the Tracks area remains unchanged. If
the cell already contains a region, it is replaced with the new region.

Create new tracks when dragging multiple items to the Live Loops grid

When you drag multiple items (for example, cells, regions, Apple loops, or files from the
Finder) to the empty area below the Live Loops grid, you can create a new track for each
individual item.
•

Press Shift when dragging the items to the empty area below the Live Loops grid.

The items are arranged vertically and a new track is created for each individual item when
you drop them below the Live Loops grid. Press Shift again before you drop the items to
arrange them horizontally and add them to a single new track.

Copy and paste regions to cells in the Live Loops grid

1. In Logic Pro, select one or more regions in the Tracks area, then choose Edit > Copy (or
press Command-C).
2. Select a cell.
3. Choose Edit > Paste (or press Command-V).
If you copy one region, you can paste it only to a cell on a track of the same type. If you
copy multiple regions, you can paste them only to cells on the same tracks where the
original regions are located.

Copy regions within the cycle range to Live Loops
•
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Control-click the cycle area and choose Copy Cycle to Live Loops from the shortcut
menu.
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Copy regions to Live Loops based on selection

Using the Copy to Live Loops key command in Logic Pro, you can copy various
combinations of regions to new scenes, depending on what you have selected in the
Tracks area. This is especially useful for populating a Live Loops grid in an existing project
containing many different regions, sections, or markers. You can copy any of the following
to Live Loops:
•

Marquee selection: Copies the content on each track between the left and right edges
of the marquee selection to the first empty scene.

•

One or more regions: Copies the selected regions to a single cell in the first empty
scene.

•

Cycle range: If the cycle area is on and nothing is selected, copies the section between
the locators to a single cell in the first empty scene.

•

Markers: If Cycle mode is off and one or markers are selected, copies the regions
between the start or end points for each selected marker to a new scene. Arrange
markers have priority over normal markers.

•

All Arrange markers: If Cycle mode is off and nothing is selected but the project
contains arrange markers, copies all arrange markers to new scenes. This is a good way
to quickly create a Live Loops scene for each section of a project.

1. In Logic Pro, determine what you want to copy to Live Loops (marquee, region, cycle, or
marker).
2. Choose Edit > Copy to Live Loops or use the Copy to Live Loops key command
(Command-Home or Command-Fn-Left Arrow).
The exact wording of the command in the menu changes depending on what you select.

Import an audio file to an empty cell
•

In Logic Pro, Control-click an empty audio cell and choose Add Audio File (or press
Shift-Command-I).
A new audio cell is created containing the audio file.

Convert Drummer and pattern cells to MIDI cells

You can convert Drummer cells and pattern cells to MIDI cells, to edit individual notes of a
Drummer performance or to perform edits not possible in Step Sequencer.
•

In Logic Pro, Control-click the Drummer or pattern cell you want to convert and choose
Convert > Convert to MIDI Cell.

Extract loops from audio cells

Logic Pro can analyze the musical and sonic characteristics of a longer audio file in an
audio cell and extract the best sounding loops to empty cells (up to 10) on the same track.
You can choose the length of loops you want to extract, or let Logic Pro extract the best
loops of any size.
By default, Logic Pro examines only the detected downbeat positions for potential loop
start points. However, you can deactivate this setting to let loop points be set at other
musically meaningful positions. You can always manually change the resulting loop points,
if necessary.
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To work effectively, loop extraction requires audio containing repetitions and accurate
tempo information. To get the best results, check the cell in the Smart Tempo Editor before
extracting loops and determine whether they show accurate beat mapping.
The loop extraction algorithm looks for loop points that deliver a smooth transition from
loop end to loop start. Those loop points may not necessarily coincide with the musical
structure of the analyzed audio.
•

In Logic Pro, Control-click an audio cell and choose any of the following from the
Extract Loops submenu:
•

Set Optimal Full Loop: Extracts the longest loop within the selected cell.

•

Extract Best 2-Bar Loops: Determines the best two-bar loops and copies them to the
next empty cells to the right.

•

Extract Best 4-Bar Loops: Determines the best four-bar loops and copies them to
the next empty cells to the right.

•

Extract Best 8-Bar Loops: Determines the best eight-bar loops and copies them to
the next empty cells to the right.

•

Extract Best Loops of Any Size: Determines the best loops of any size throughout the
audio file and copies them to the next empty cells to the right.

To consider all musically meaningful positions for potential loop start points, not just
downbeats, make sure Limit Loop Points to Downbeats is turned off in the Extract Loops
submenu.
Loop extraction is disabled if:
•

The cell is empty or contains multiple regions.

•

The region in the cell is shorter than two bars.

•

Flex & Follow in the Cell inspector is turned off.

•

The cell contains Apple Loops or untagged loops.

•

Multiple cells are selected.

Create cells

You can create new cells and then edit them in the Cell Editor or record audio and MIDI.
Software instrument tracks can contain MIDI and pattern cells.
•
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In Logic Pro, do any of the following:
•

To create an audio cell: Control-click an empty cell on an audio track, then choose
Create Cell.

•

To create a MIDI cell: Control-click an empty cell on a software instrument track,
then choose Create MIDI Cell.

•

To create a pattern cell: Control-click an empty cell on a software instrument track,
then choose Create Pattern Cell.

•

To create a Drummer cell: Control-click an empty cell on a Drummer track, then
choose Create Drummer Cell.
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Add a cell from the Live Loops grid to the Tracks area
In Logic Pro, do one of the following:
•

Drag a cell to a track of the same type in the Tracks area.

•

Drag a cell to an empty area of the Tracks area, below the existing tracks.
A new track of the appropriate type (audio or software instrument) is created, and the
region is added to the new track. The new track has the same channel strip settings as
the original track.

When you drag a cell from the Live Loops grid to the Tracks area, Logic Pro places a copy
of the cell as a region in the Tracks area. The original cell in the Live Loops grid remains
unchanged. If a track already contains a region at the position where you place the cell, it
is replaced or overlapped with the resulting new region.

Copy a scene to the Tracks area

1. In Logic Pro, in the Tracks area, set the playhead at the position where you want to
paste cells in the scene as regions.
2. In the Live Loops grid, Control-click the scene and choose one of the following:
•

To shift the content of all tracks right of the playhead position by the length of
the inserted scene: Choose Insert Scene at Playhead (or press Command-End or
Command-Fn-Right Arrow).

•

To copy the scene to the playhead position: Choose Copy Scene to Playhead.
WARNING: When you copy a scene to the playhead position, any existing regions are
overwritten or overlapped.

Create an Apple Loop from a cell

You can create Apple Loops from your own audio and software instrument cell recordings.
When you create an Apple Loop from a cell, it’s added to the Apple Loops library and
appears in the Loop Browser, so that you can use it in other projects.
•

In Logic Pro, do one of the following:
•

Control-click a cell, then choose Export > Add to Loop Library from the shortcut
menu.

•

Select a cell, then choose File > Export > Region to Loop Library.

The Add Region to Apple Loops Library window opens, providing several options for the
Apple Loop. See Create your own Apple Loops.
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Record to cells
Record to Live Loops cells in Logic Pro

You can record to an audio or MIDI cell, even while other cells are playing. The settings
for audio signal flow, software instruments, and the metronome are the same as when you
record regions in the Tracks area.
If you need both hands to play an instrument while recording, you can set the length of the
recording to a predefined value (determined by the cell length); otherwise you can set it to
the nearest bar or beat while recording.
When the end of the recording length is reached, you can stop recording and automatically
play what you recorded, continue recording multiple takes to the cell, or merge software
instrument performances.
Once you have enabled tracks for recording, a Cell Record button appears on empty cells
when you move the pointer over them. Clicking the Cell Record button triggers the cell to
start recording at the next quantize start point. If the quantize start is longer than one bar,
recording begins at the next bar.
You can use the Record Into Cell key command to trigger cells to start and stop recording
and to set the record length while recording. You can assign the key command to a
controller, such as a footswitch or pedal to accelerate your workflow.
You can control cell recording using the following parameters in the Cell inspector:
•

Recording: Determines what happens to existing cell content when you record in
a cell. You can replace the previous performance with the current one, record new
performances to a take folder, or, for software instruments, merge the performances.

•

Rec-Length: Determines the duration of the recording. You can set it to match the Cell
Length value, or manually set it to the next bar or beat while recording.

•

At Rec-End: Determines what happens when the Record-Length is reached. You can
set it to immediately play back what you record, continue recording multiple takes of a
performance, or merge multiple software instrument performances, depending on the
Recording setting.

Note: You can’t record to Drummer or Pattern cells.

Set the recording mode

The recording mode determines what happens to existing cell content when you record
to a cell. You can replace a previous recording or create multiple takes. With software
instruments, you can also record continuously in a loop, merging each pass in a single cell.
This can be useful for creating drum patterns or melodies on the fly. You can choose one of
three recording modes:
•

Takes: Each new recording is added to a take folder in the cell. After recording, you can
preview the takes and choose the one you want to use in the cell.

•

Merge: Each new recording merges with the previous recording.
This mode is available only for software instruments.

•
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Replace: Each new recording replaces the previous recording.
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In Logic Pro, do either of the following:
•

Select the cell you want to record to, then choose a mode from the Recording popup menu in the Cell inspector.

•

Control-click the cell you want to record to, choose Recording > Mode, then choose
a recording mode from the submenu.

Set the Rec-Length parameter

You can set the length of the cell recording using the Rec-Length parameter. You can
choose from the following settings:
•

Cell Length: The length of the recording is determined by the Cell Length value under
the Play From settings in the Cell inspector.

•

Automatic (Bars): The length of the recording is set to the nearest bar when you click
the cell or use the Record Into Cell key command while recording.

•

Automatic (Beats): The length of the recording is set to the nearest beat when you click
the cell or use the Record Into Cell key command while recording.

In Logic Pro, do either of the following:
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•

Select the cell you want to record to, then choose a setting from the Rec-Length
pop-up menu in the Cell inspector.

•

Control-click the cell you want to record to, choose Recording > Rec-Length, then
choose a setting from the submenu.
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Set the At Rec-End action

The At Rec-End action determines what happens at the end of a recording pass. Depending
on how you set this up, it can be useful for recording multiple takes of a performance, or
for merging multiple performances when recording a software instrument. You can choose
either of the following settings:
•

Change to Play Mode: At the end of the recording, Live Loops stops recording and the
cell immediately begins playing the performance you just recorded.

•

Continue Recording: At the end of the recording, Live Loops continues recording and
overwrites the previous recording, creates takes, or merges each subsequent recording,
depending on the recording parameter. When Continue Recording is selected and the
Rec-Length parameter is set to Automatic, a Plus button (+) is visible in the middle
of the cell while the cell is recording. Clicking the button sets the Rec-Length to the
nearest bar or beat and starts the next recording pass.

In Logic Pro, do either of the following:
•

Select the cell you want to record to, then choose a setting from the At Rec-End
pop-up menu in the Cell inspector.

•

Control-click the cell you want to record to, choose Recording > Rec-End Action,
then choose a setting from the submenu.

Record to a cell

1. In Logic Pro, click the Record Enable button in the track header of the track containing
the cell you want to record to.
2. Set the metronome and count-in for recording if desired.
3. Select a cell and set the parameters for Recording, Rec-Length, and At Rec-End in the
Cell inspector if necessary.
4. Do any of the following:
•
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Move the pointer over an empty cell and click the Cell Record button in the center of
the cell.
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•

Select a cell and use the Record Into Cell key command (Option-R).

•

Control-click a cell and choose Record Into Cell from the shortcut menu.

If cells are already playing, recording starts at the next Quantize Start point.
5. Play, sing, or otherwise create the sound you want to record.
If the Rec-Length is set to Cell-Length and the At Rec-End action is set to Change to
Play Mode, recording stops automatically and the cell plays.
6. If you use different cell recording settings, do either of the following:
•

If the Rec-Length is set to Automatic and the At Rec-End action is set to Continue
Recording, click the Plus button (+) in the cell to set the record length to the nearest
bar or beat.

•

If the Rec-Length is set to Automatic and the At Rec-End action is set to Change to
Play Mode, or the Rec-Length is set to Cell Length and the At Rec-End action is set
to Continue Recording, click the Play button in the cell to stop recording and play the
cell.

You can also use the Record Into Cell key command to start and stop cell recording and
set the record length while recording.

Set recording defaults for cells by type

In some cases it can be convenient to set the cell length, recording mode, and MIDI
quantization for cells before recording. You can set defaults for all cells of a particular type
(audio or MIDI).
1. In Logic Pro, click in the Live Loops grid to ensure it is active.
2. Select a track of the type for which you want to set the defaults.
3. Deselect all cells in the grid (use Shift-D).
In the Cell inspector, Cell: Audio Defaults or Cell: MIDI Defaults appears, depending on
the track type you selected.
4. In the Cell inspector, set the default values, including default cell length, recording
settings, or quantize value for MIDI recordings.
Note: Some default settings you make in the Cell inspector apply to both newly
recorded cells and regions of the specified type.

Set recording defaults for an individual cell

You can also set defaults for individual cells. This can be useful when you want to predefine
different recording lengths for different scenes, while keeping automatic recording lengths
in bars as a general default.
1. In Logic Pro, select one or more cells for which you want to set recording defaults. The
cells must all be of the same type (audio or MIDI).
2. In the Cell inspector, set the default values, including default cell length, recording
settings, or quantize value for MIDI recordings.
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Record and edit takes in cells in Logic Pro

When you set the Recording parameter to Takes, each new recording in a cell creates a
new take. If a cell contains takes, the number of takes is displayed in the lower-left corner
of the cell, and the currently active take is displayed in the upper left. You can choose and
preview each take individually, even while the cell is playing. You can also rename, delete,
flatten, move, and copy takes.

You can move take folders from the Tracks area to cells, and move take folders from cells
to the Tracks area. If you want to edit comps in a cell, you must drag the cell to the Tracks
area, edit the comps there, then drag the resulting region back to the Live Loops grid when
you are finished.

Open the Take Folder pop-up menu
•

In Logic Pro, click the upper-left corner of a cell containing takes.

Preview takes in a cell
•

In Logic Pro, choose a take from the Take Folder pop-up menu, then play the cell.

Rename takes

1. In Logic Pro, choose the take you want to rename from the Take Folder pop-up menu.
2. Choose Rename Take from the Take Folder pop-up menu.
3. Enter the new name in the dialog that appears, then click OK.

Delete takes

1. In Logic Pro, choose the take you want to delete from the Take Folder pop-up menu.
2. Choose Delete Take from the Take Folder pop-up menu.

Delete all but the currently active take

1. In Logic Pro, choose the take you want to keep from the Take Folder pop-up menu.
2. Click the upper-left corner of the cell, then choose Flatten from the Take Folder
pop-up menu.
All takes, except the currently active take, are deleted.
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Copy and move takes

You can copy or move takes to other cells, scenes or tracks.
1. In Logic Pro, choose the take you want to copy or move from the Take Folder pop-up
menu.
2. To copy a take, choose any of the following from the “Copy Take to” submenu:
•

New Scene: Copies the currently selected take to a new scene.

•

Next Empty Cell Right: Copies the take to the next empty cell to the right.

•

New Track: Copies the take to a new track below the current track.

•

Next Matching Empty Cell Below: Copies the take to the next empty cell on the same
kind of track below.

3. To move a take, choose any of the following from the “Move Take to” submenu:
•

New Scene: Moves the currently selected take to a new scene.

•

Next Empty Cell Right: Moves the take to the next empty cell to the right.

•

New Track: Moves the take to a new track below the current track.

•

Next Matching Empty Cell Below: Moves the take to the next empty cell on the same
kind of track below.

Unpack a take folder

You can unpack a cell take folder to other cells, scenes, or tracks.
1. In Logic Pro, open the Take Folder pop-up menu.
2. Choose one of the following from the “Unpack Take Folder to” submenu:
•

New Scenes: Unpacks each take to a new scene.

•

Next Empty Cells Right: Unpacks each take to the next empty cells to the right.

•

New Tracks: Unpacks each take to a new track below the current track.

•

Next Matching Empty Cells Below: Unpacks each take to the next empty cell on the
same kind of track below.

Change loop settings for cells in Live Loops
for Logic Pro

When you select a cell, you can change the loop settings in the Cell inspector. You can
create interesting variations by changing the following settings:
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•

Start: Determines the initial starting position of the cell. By default, this is the same
as the Loop Start setting, but you can change it so the cell starts at a different place
initially than when it loops. This setting is ignored if the Play From setting is set to a
value other than Start, or if the Set the Quantize Loop Start position is set to On.

•

Loop Start: Determines the position in the cell where the loop starts after the initial start
and playback of the cell. For example, if you have a cell containing a four-bar piece of
musical material, you can change the Start setting so the loop initially starts at the first
bar, then plays from the third bar on each time it loops.

•

Loop Length: Determines the length of the loop. Changing the Loop Length value can be
useful when you want to loop only a particular portion of a cell.
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•

Cell Length: Determines the overall length of the cell. This can be longer than
the amount of musical material contained in the cell. When the Loop checkbox is
deselected, the cell plays to the end of the cell length, then stops.

You can also change these settings graphically for audio and MIDI cells in the Cell Editor.

Change the start position of a cell
1. In Logic Pro, select a cell.

2. In the Cell inspector, click the disclosure arrow next to Play From to view the start
position, then do one of the following:
•

Double-click the start position, then enter a new value. Press Return to exit the field.

•

Drag the specific position unit vertically. Release the mouse button when you’re
finished.

When you change the start position in the Cell inspector for an audio or MIDI cell, the start
marker moves in the ruler of the Cell Editor. You can also drag the start marker in the Cell
Editor to change the start position.

Change the loop start position of a cell
1. In Logic Pro, select a cell.

2. In the Cell inspector, click the disclosure arrow next to Play From to view the loop start
position, then do one of the following:
•

Double-click the loop start position, then enter a new value. Press Return to exit the
field.

•

Drag the specific position unit vertically. Release the mouse button when you’re
finished.

When you change the loop start position in the Cell inspector for an audio or MIDI cell,
the loop start locator moves in the Cell Editor. You can also drag the loop start locator to
change the loop start position.

Change the loop length of a cell
1. In Logic Pro, select a cell.

2. In the Cell inspector, click the disclosure arrow next to Play From to view the loop
length, then do one of the following:
•

Double-click the Loop Length setting, then enter a new value. Press Return to exit
the field.

•

Drag the specific position unit vertically. Release the mouse button when you’re
finished.

When you change the loop length in the Cell inspector for an audio or MIDI cell, the loop
end locator moves in the Cell Editor. You can also drag the loop end locator to change the
loop length.
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Change the cell length

1. In Logic Pro, select a cell.
2. In the Cell inspector, click the disclosure arrow next to Play From to view the cell length,
then do one of the following:
•

Double-click the Cell Length setting, then enter a new value. Press Return to exit the
field.

•

Drag the specific position unit vertically. Release the mouse button when you’re
finished.

When you change the cell length in the Cell inspector for an audio or MIDI cell, the
end marker moves in the Cell Editor. You can also drag the end marker to change the
cell length.

Set the Quantize Loop Start position

If the start and loop start positions are different, you can choose which position should hit
an upcoming quantize start point when you trigger a cell. This can be useful if the start
position is set to an upbeat position, for example.
•

In Logic Pro, select one or more cells, click the disclosure arrow next to Play From in the
Cell inspector, then choose one of the following settings from the Q Loop Start pop-up
menu:
•

Off: The cell starts playing from the start position when the upcoming quantize start
point is reached.

•

On: The cell starts playing as soon as possible, so that the loop start position is
reached at the next upcoming quantize start position. Some content after the start
position may be skipped.

•

On, Preserve Start: The cell always starts playing from the start position, so that
the loop start position is reached at the upcoming or any following quantize start
position. The cell may start later but plays all content between the start and loop
start positions.

Turn off cell looping
•

In Logic Pro, do one of the following:
•

Select one or more cells, then deselect the Loop checkbox in the Cell inspector.

•

Control-click a cell, then deselect Settings > Loop from the submenu.

•

Click the cycle area in the ruler of the Cell Editor.

The circular waveform in the cell changes to a linear shape. When the cell starts, it
plays once to the end of the cell length, then stops (one-shot).

View cell length and loop length as positions
In Logic Pro, do one of the following:
•

Choose View > Length as Position from the Tracks area menu bar.

•

Control-click anywhere in the Cell inspector, then choose Show Length as Position from
the shortcut menu.

Cell Length appears as Cell End, Loop Length appears as Loop End, and both show a
position value.
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View start positions as an offset

In Logic Pro, do one of the following:
•

Choose View > Show Start Positions as Offset from the Tracks area menu bar.

•

Control-click anywhere in the Cell inspector, then choose Show Start Positions as Offset
from the shortcut menu.

The positions appear in the Cell inspector as the distance from the beginning of the cell.

Change the resolution of the position and length values

You can change the resolution shown for position and length values from the View menu, or
from the shortcut menu in the Cell inspector.
1. In Logic Pro, do one of the following:
•

Choose View > Live Loops: Position and Length Resolution from the Tracks area
menu bar.

•

Control-click anywhere inside the Cell inspector.

2. Choose one of the following from the menu:
•

Bars Only: View the position and length value for cells as bars.

•

Bars and Beats: View the position and length value for cells as bars and beats.

•

Bars, Beats, and Division: View the position and length value for cells as bars, beats,
and division.

•

Bars, Beats, Division, and Ticks: View the position and length value for cells as bars,
beats, division, and ticks.

How the Live Loops grid and Tracks area interact
in Logic Pro

On each track in Logic Pro, you can listen to either a cell in the Live Loops grid or a region
in the Tracks area—never both simultaneously. When you start a cell, any regions on
the same track become inactive. When you stop a cell, the regions are not immediately
reactivated; you need to use buttons in the Divider column or key commands to do this.
You can also pause cells and activate regions on the same track simultaneously. The
Divider column shows circular indicators next to tracks where cells are playing. When
cells are stopped, the Track Activation buttons in the Divider column indicate with a solid
arrow whether the cells or regions are activated. If you have a combination of tracks with
activated cells and regions, both arrows of the Track Activation button at the top of the
Divider column are hollow.
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When you play cells while the project is stopped, the playhead starts. If the playhead starts
from a quantize start point, the cells start playing immediately; otherwise, they start when
the playhead reaches the next quantize start point.
If the playhead reaches the project end marker while cells are playing, the playhead stops
and the cells continue playing.
If you are only using Live Loops in your project, it is recommended to turn on Cycle mode.
However, it is important to turn it off when you record a Live Loops performance.

Activate regions on an individual track
In Logic Pro, do the following:
•

While a cell is not playing: Click the Track Activation button
Divider column.

for the track in the

The region on the track is immediately audible. To reactivate the cell, click the Track
Activation button
again in the Divider column or play the cell.
•

While a cell is playing: Move the pointer over the Loop Position indicator in the Divider
column, press Option, then click the Pause button .
At the next quantize start point, the cell pauses and the regions on the track are
audible. To restart the cell, press Option and click the Restart button
in the Divider
column, or click the Restart button on the paused cell.

Activate regions on all or multiple tracks
•

In Logic Pro, do the following:
•

While cells are not playing: Click the Grid Stop button at the bottom of the Divider
column to stop all cells, or stop multiple cells individually, then click the Track
Activation button
at the top of the Divider column.
The regions on the tracks are immediately audible. To reactivate the cells, click the
Track Activation button
again in the Divider column.
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•

While cells are playing: Press Option, then click the Pause button
the Divider column.

at the bottom of

At the next quantize start point, the cells pause and the regions are audible. To
restart the cells, press Option and click the Restart button
at the bottom of the
Divider column, press Option and click the Restart button in the Divider column on
any track, or click the Restart button on any of the paused cells.
•

When a scene is playing: Option-click the Scene trigger of the scene that is playing.
At the next quantize start point, any cells playing in the scene pause and the regions
on the same tracks are audible.

Edit Live Loops cells in Logic Pro

You can arrange and edit cells in the Live Loops grid much as you do when working
with regions. Basic functions to cut, copy, paste, move, or delete cells are similar to the
equivalent functions for regions in the Tracks area.
Parameters for selected cells appear in the Cell inspector, which replaces the Region
inspector when cells are selected. When you select a single cell, the title bar of the Cell
inspector shows the cell name; when you select multiple cells, the title bar shows the
number of selected cells.
You can use the Cell Editor to view and edit the regions in cells, similar to the way you edit
regions in the Piano Roll Editor, Audio Track Editor, and Drummer Editor.

Select cells in the Live Loops grid
•

In Logic Pro, do any of the following:
•

Select a single cell: Click the upper part of the cell.

•

Select multiple cells: Do any of the following:
•

Shift-click the upper part of cells.
Shift-click the upper part of selected cells to deselect them.

•

Starting from any empty cell, drag around cells to enclose them.

•

Shift-click a cell to start a selection, then continue to hold Shift as you drag
around other cells to enclose them.

•

Select all cells: Choose Edit > Select > All (or press Command-A).

•

Select all following cells: Select a cell, then choose Edit > Select > All Following (or
press Shift-F).
All cells in the same scene, and all other cells to the right, are selected.

•

Select all following cells on the same track: Select one or more cells, then choose
Edit > Select > All Following of Same Track (or press Control-Shift-F).
All of the cells to the right of, and on the same track as, the selected cell are
selected.

•
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Select all cells on the same track: Select one or more cells, Control-click one of the
selected cells, then choose Edit > Select > All Cells of Same Track from the shortcut
menu.
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•

Select all cells in the same scene: Select one or more cells, Control-click one of the
selected cells, then choose Edit > Select > All Cells of Same Scene from the shortcut
menu.

•

Select all muted cells: Choose Edit > Select > Muted Cells (or press Shift-M).

•

Select all cells of the same color: Choose Edit > Select > Same-Colored Cells (or
press Shift-C).

•

Select all empty cells in the Live Loops grid: Choose Edit > Select > Empty Cells.

•

Invert selection of cells within a row: Choose Edit > Select > Invert Selection (or
press Shift-I).

Cut a cell
•

In Logic Pro, select the cell, then choose Edit > Cut (or press Command-X).

Copy a cell
•

In Logic Pro, do either of the following:
•

Select the cell, then choose Edit > Copy (or press Command-C).

•

Option-drag the cell.

Paste a cell
•

In Logic Pro, select a cell, then choose Edit > Paste (or press Command-V).

Move a cell

You can move cells to an empty or filled cell in the same row, or to another row of the same
type. For example, you can move an audio cell to another row with audio cells, but not to a
row with software instrument cells. If you move or paste cells to cells that already contain
content, the new content replaces the existing content.
•

In Logic Pro, select a cell and do any of the following:
•

Drag an audio cell to another cell on an audio track.

•

Drag a MIDI cell to another cell on a software instrument track.

•

Drag a Drummer cell to another cell on a Drummer track.

•

Drag a pattern cell to another cell on a software instrument track.

Swap cells

You can swap cells with other cells of the same type.
1. In Logic Pro, select one or more cells, and drag them to the cells you want to swap them
with.
2. Before releasing the mouse, press and hold the Control key as you drop the cells.
Left and right arrows appear with the pointer to indicate the cells are being swapped.

Rename a cell

1. In Logic Pro, do any of the following:
•

Control-click a cell, choose Name and Color > Rename Cell from the shortcut menu.

•

Select a cell, then click the name of the cell in the Cell inspector.

•

Select a cell, then press Shift-N.

2. Enter a new name for the cell, then press the Return key.
Logic Pro User Guide

677

Delete a cell
•

In Logic Pro, select one or more cells, then do either of the following:
•

Choose Edit > Delete.

•

Press the Delete key.

•

Control-click one of the selected cells and choose Edit > Delete from the shortcut
menu.

Mute a cell

When you mute a cell, it stops playing. To hear the cell again, you must first unmute, then
restart the cell.
•

In Logic Pro, select one or more cells, then do one of the following:
•

Control-click one of the selected cells and choose Playback > Mute from the
shortcut menu (or press Control-M).

•

Click the selected cells with the Mute tool.

•

Select the Mute checkbox in the Cell inspector.

Set an audio cell to ignore project tempo

In some cases you might want an audio cell to ignore the project tempo and play at its
original tempo. This can be useful if you have cells containing spoken word, a one-shot, or
nonlooping sound effects, for example.
•

In Logic Pro, select an audio cell and do the following:
•

For Apple Loops: Deselect the Follow Tempo checkbox in the Cell inspector.

•

If the track is in Flex mode: Turn off Flex & Follow in the Cell inspector.

Change the playback speed of a cell
•

In Logic Pro, select one or more cells, then do one of the following:
•

Control-click one of the selected cells, choose Settings > Speed, then choose a
value from the submenu.

•

Click the disclosure arrow in the Cell inspector next to Play Mode, then choose a
value from the Speed pop-up menu.

The Speed parameter is not available for audio cells that have Flex & Follow turned on in
the Cell inspector.
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Reverse cell playback
•

In Logic Pro, select one or more cells, then do one of the following:
•

Click the disclosure arrow in the Cell inspector next to Play Mode, then select the
Reverse checkbox in the Cell inspector.

•

Control-click one of the selected cells, then choose Playback > Reverse from the
submenu.

•

Use the Reverse key command (Control-Shift-R).

The Reverse parameter is not available for audio cells that have Flex & Follow turned on in
the Cell inspector.

Edit Live Loops scenes in Logic Pro

In addition to playing cells individually, you can play cells in a scene together, like a section
in a musical arrangement. You can select, duplicate, rename, move, and delete scenes. You
can also change the Quantize Start value and play mode for each scene. When you trigger
a scene, all cells in the scene use that scene’s Quantize Start value and play mode. When
you start or stop individual cells in a scene, each cell uses its own Quantize Start value and
play mode. You can add currently playing cells from different scenes to an empty scene or
to a scene already containing cells.

Scene selection and focus

Scenes are similar to tracks regarding focus and selection: When you select multiple
scenes, the first selected scene is the focused scene. Some operations, such as using
a key command to trigger a scene, only affect the focused scene when multiple scenes
are selected.
When multiple scenes are selected, the area around the trigger of the focused scene
appears gray, unlike the other selected scenes.

Logic Pro User Guide

679

Select scenes
•

In Logic Pro, do the following:
•

Select single scene: Click the scene name directly under the Scene trigger.

•

Select the previous or next scene:
•

When a scene is selected: Press the the Left Arrow or Right Arrow keys.

•

When no scenes are selected: Press the Option-Left Arrow or Option-Right Arrow
keys.

•

Select multiple scenes: Shift-click the area under the Scene trigger to add that
scene to the selection.

•

Extend scene selection to previous or next scene: Press Shift and the Left Arrow or
Right Arrow key.

Change the focused scene in a multiple selection

When multiple scenes are selected, only one can have focus. You can change the focused
scene while keeping the multiple selection.
•

In Logic Pro, with multiple tracks selected, do one of the following:
•

Move focus to previous or next scene: Press the Left Arrow to choose the previous
scene, or the Right Arrow key to choose the next scene.

•

Move focus to specific scene: Click the scene name under the Scene trigger for the
scene you want to have focus.

Trigger focused scene
•

In Logic Pro use the Trigger Focused Scene key command.
When no cells are selected and the Live Loops grid is active, you can also use the Play
Live Loops key command (or press Return) to trigger the focused scene.

Copy currently playing cells to a scene

You can copy playing cells to a single scene. This is useful if you want to combine cells
from different scenes into a new scene. If you copy playing cells to a scene that already
contains cells, the copied cells replace any existing cells on the same track in the scene.
•

In Logic Pro, do one of the following:
•

Control-click the Scene trigger
Cells Here.

of the destination scene and choose Copy Playing

•

Select a scene and use the Copy Playing Cells Here key command.

Reorder scenes
•

In Logic Pro, click and hold the area under the Scene trigger, then drag the scene left or
right.

Duplicate scenes
•
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In Logic Pro, select one or more scenes, Control-click the Scene trigger
the selected scenes and choose Duplicate from the shortcut menu.

for any of

680

Insert an empty scene
•

In Logic Pro, do one of the following:
•

Control-click the Scene trigger

and choose Insert Empty Scene.

•

Select a scene and use the Insert Empty Scene key command.

A new empty scene is created and the following scenes move to the right.

Add multiple empty scenes to the end of the grid

1. In Logic Pro, move the pointer over the right edge of the last scene in the Live Loops
grid.
2. When the pointer changes to a resize pointer, drag it to the right to add empty scenes,
or to the left to remove empty scenes.

Rename a scene

New scenes are numbered by default. You can rename them to help organize and arrange
your Live Loops grid.
1. In Logic Pro, do one of the following:
•

Control-click the Scene trigger

, then choose Rename from the shortcut menu.

•

Double click the name of the scene.

2. Enter a new name for the scene, then press Return.

Delete a scene
•

In Logic Pro, select one or more scenes, then do one of the following:
•

Control-click the Scene trigger
from the shortcut menu.

•

Press the Delete key.

of one of the selected scenes, then choose Delete

Change the play mode for a scene
•

In Logic Pro, Control-click the Scene trigger
Mode submenu.

Change the Quantize Start value for a scene
•

In Logic Pro, Control-click the Scene trigger
the Quantize Start submenu.

and choose a play mode from the Play

and choose a Quantize Start value from

Change the Quantize Start value or play mode for all scenes

You can change the Quantize Start value or play mode for all scenes at the same time.
•

In Logic Pro, Control-click the Scene trigger
, choose Set All Scene Triggers, then
choose a Quantize Start value or play mode from the relevant submenu.
Any previous changes you made to the Quantize Start value or play mode of an
individual scene are updated with the new setting.

Logic Pro User Guide

681

Work in the Cell Editor in Logic Pro

You can use the Cell Editor to view and edit the regions in cells, similar to the way you edit
regions in the Piano Roll Editor, Audio Track Editor, Drummer Editor, and Step Sequencer.
You can graphically change loop settings for audio and MIDI cells. Audio and MIDI cells can
contain multiple regions, so you can add regions to cells and edit them in the Cell Editor.
You can also edit Smart Tempo, transient markers, Flex audio, and region automation for
individual cells.

Open the Cell Editor
•

In Logic Pro, do any of the following:
•

Double-click the top of a cell to open it in the Cell Editor.

•

Select a cell, then click the Editors button

•

Select a cell, then choose View > Show Editor.

(or press E).

The Cell Editor opens below the Live Loops grid and the Tracks area (if visible). Audio cells
show the audio waveform of the cell, MIDI cells show a Piano Roll interface, Drummer cells
show the Drummer Editor controls, and pattern cells show the Step Sequencer.

Change loop settings for audio and MIDI cells

While you can change the loop settings for all cells numerically in the Cell inspector, you
can also change them graphically for audio and MIDI cells in the Cell Editor.

In Logic Pro, open the Cell Editor and do any of the following:
•

•

•

•
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Move the start position:
•

Drag the start marker to the desired position.

•

Control-click the ruler where you want the start position to be and choose Set Start
Position Here from the shortcut menu.

Move the loop start position:
•

Drag the loop start to the desired position.

•

Control-click the ruler where you want the loop start to be and choose Set Loop
Start Here from the shortcut menu.

Move the loop end position:
•

Drag the loop end to the desired position.

•

Control-click the ruler where you want the loop end to be and choose Set Loop End
Here from the shortcut menu.

Move the end position: Drag the end marker to the desired position.
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Move the loop area
•

Move the loop area: Grab the loop area by the middle (the pointer turns into a hand) and
drag it horizontally.

•

Move the loop area forward or backwards by the length of the loop:
•

Forward: Control-click the ruler in the Cell Editor and choose Move Loop Forward by
Loop Length from the shortcut menu (or press Shift-Command-Period).

•

Backward: Control-click the ruler in the Cell Editor and choose Move Loop Backward
by Loop Length from the shortcut menu (or press Shift-Command-Comma).

Edit Smart Tempo and transients for audio cells

You can edit transients and Smart Tempo for individual audio cells.
1. In Logic Pro, double-click a audio cell to open it in the Cell Editor.
2. If the cell contains multiple regions, click the audio waveform to select the region you
want to edit.
3. Choose one of the following:
•

To edit Smart Tempo: Choose Edit > Edit Smart Tempo from the Cell Editor menu bar.

•

To edit transients: Choose Edit > Edit Transients from the Cell Editor menu bar.

4. When you are done, click the Display Level button
are working in.

in the menu bar of the editor you

Show and edit automation curves for a cell

Each region within a cell can have its own set of automation curves that you can view and
edit in the Cell Editor. You can add and adjust automation points similar to the way you edit
automation in the Audio Track editor and edit automation and MIDI parameters in the Piano
Roll. When a cell contains automation curves, an Automation symbol
appears in the
lower-right corner of the cell in the Live Loops grid.
1. In Logic Pro, click the Show/Hide Automation button

in the Cell Editor menu bar.

2. Choose the automation or MIDI controller parameter you want to edit from the
Automation pop-up menu.
3. Click the Show/Hide Automation button again when you are done.
Tip: If you have automation for many different parameters, click the Automation/MIDI
Cycle Through button to cycle through existing automation curves and MIDI data.
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Bounce Live Loops cells in Logic Pro

You can bounce audio or MIDI cells into a new audio cell, similar to the way you bounce
regions in place in the Tracks area.
If you bounce a cell that has different start and loop start positions, the resulting bounce
cell consists of a pass from the start position to the loop end position, and a pass from the
loop start position to the loop end position (loop range). If cell looping is turned off, the
bounce range extends from the start position to the end of the source cell.
You can choose to include an extra bounce of the loop range in the bounce cell. This is
particularly useful if you want to ensure that any instrument release or effect tails (reverb,
delay, and so on) at the end of the source cell’s loop range will be audible at the start of
the bounce cell’s loop range.
If you bounce multiple cells, the bounce range begins where the source cells start playing
and ends when they all reach their loop end positions simultaneously.

Bounce one or more cells in place

1. In Logic Pro, select one or more cells on an audio or software instrument track.
2. Do one of the following:
•

Choose File > Bounce > Cells in Place (or press Control-B).

•

Control-click the selected cells, then choose Bounce and Join > Bounce Cells in
Place from the shortcut menu.

3. In the Bounce Cells in Place dialog, define the following parameters:
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•

Name: Enter a name for the bounce cell in the field.

•

Destination: Indicate the type of track on which the bounce cell is placed. You have
two options:
•

New Track: Creates a new audio track below the selected track and places the
bounce cell on that track.

•

Selected Track: Places the bounce cell on the selected track.
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•

Source: Define what happens to the source cells after bouncing. You have three
options:
•

Leave: Leaves the source cells unaltered after processing the bounce cell.

•

Mute: Mutes the source cells after processing the bounce cell.

•

Delete: Deletes the source cells from the original tracks after processing the
bounce cell.

•

Include Instrument Multi-Outputs: Select to include aux channel strips with multioutput signals of the instrument in the bounce process. Otherwise, only the channel
strips of tracks with selected cells are bounced.

•

Bypass Effect Plug-ins: Select to disable all plug-ins on the source track during the
bounce process.

•

Bounce Second Loop Pass: Select to include an extra bounce of the loop range in the
bounce cell.

•

Include Audio Tail in File: Select to continue the bounce process after the end of
the bounce range, including any instrument release and potential effect tail (reverb,
delay, and so on), until there is no longer a signal. Otherwise, only the bounce range
is bounced.

•

Include Audio Tail in Region: Select to include the entire bounce file in the bounce
cell. Otherwise, the bounce cell includes only the bounce range.

•

Include Volume/Pan Automation: Select to have volume and pan automation
performed during the bounce process, with their result influencing the bounce file.
Otherwise, the volume and pan automation curves are simply copied to the bounce
cell.

•

Normalize: Choose between three states of normalization from the pop-up menu:

•

•

Off: Turns off normalization.

•

Overload Protection Only: Allows downward normalization in case of overloads—
levels above 0 dB, which would lead to clipping—but no normalization in case of
lower levels.

•

On: Allows full bidirectional normalization.

Restore Defaults: Click to set all parameters in the dialog to their default settings.

4. Click OK to trigger an in-place bounce of the selected cells.
Note: When you click OK, the settings you have chosen are recalled the next time you
access the Bounce Cells in Place function.
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Record a Live Loops performance in Logic Pro

When you record a Live Loops performance, the cells that you play as part of the
performance appear as regions in the Tracks area. After you are done recording your
performance, you can play it back in the Tracks area, edit the regions, and finalize the mix
just as you would with any other Logic Pro project.
You cannot record to a cell while recording a Live Loops performance. However, you can
record to an audio or software instrument track. This lets you record a vocal or instrument
performance, for example, along with the Live Loops performance.

Record a Live Loops performance

1. In Logic Pro, click the Enable Performance Recording button at the upper-left corner of
the Live Loops grid.

2. Make sure that Cycle mode is turned off (click the Cycle button
in the Control Bar)
and the project playhead in the Tracks area is positioned where you want to start
recording your Live Loops performance.
3. Click the Record button

in the control bar (or press R) to start recording.

4. Start playing scenes, cells, or a combination of both. If you queue cells or scenes before
clicking the Record button, they will start playing when recording starts.
The cells that you play as part of the performance are recorded as regions in the Tracks
area.
5. To stop recording:
•

Click the Stop button

•

Click the Play button

in the control bar (or press the Space bar) to stop recording.
in the control bar.

The Live Loops performance stops recording, but the project continues to play.
When you record a Live Loops performance, you can also record changes to track controls
and effect parameters using automation. See Overview of automation in Logic Pro.
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Change Live Loops view settings in Logic Pro

You can zoom cells horizontally in the Live Loops grid, control the shape of the cells when
zooming, and change the width of the grid.

Control the shape of cells when zooming
•

In Logic Pro, choose View > Try to Keep Cells Squared When Zooming from the Tracks
area menu bar.

By default, cells keep their square shape when you vertically zoom the tracks. However,
if your project contains many scenes and you view the Live Loops grid and Tracks area at
the same time, you can disable this so cells appear as thinner, vertical rectangles. This can
help you maintain a visible overview of the scenes.

Zoom a section of the Live Loops grid

1. In Logic Pro, select the Zoom tool from the Tool menu (or press and hold ControlOption).
2. Drag to select the area you want to view in detail with the Zoom tool.

The selected area fills the window. You can repeat the process to zoom in further.
3. Click an empty part of the Live Loops grid with the Zoom tool to zoom out again.

Zoom cells horizontally

You can zoom cells horizontally in and out. This is useful if you want to see the names of
cells that are too long to fit in the top of the cell. You can set the zoom factor and toggle
the zoom on and off.
1. In Logic Pro, click and hold the Grid Zoom button

until the Zoom slider appears.

2. Drag the slider horizontally to adjust the zoom.
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3. Release the pointer when you’re done.
4. Click the Grid Zoom button to turn zoom on and off, or use the Toggle Grid Horizontal
Zoom key command.

Change the size of the Live Loops grid

If you view the Live Loops grid and the Tracks area at the same time, you can change the
size of the Live Loops grid in relation to the Tracks area.
1. Move the pointer over the Divider column between the Live Loops grid and Tracks area.
2. When the pointer becomes a resize icon, drag it left or right.

Control Live Loops in Logic Pro with other devices

You can assign a MIDI control surface to Live Loops functions and key commands. For
example, you can use controller assignments to start and stop cells and scenes, record to a
cell, enable performance recording, and toggle activation of track regions. You can assign
cells and scenes to the pads on a matrix controller, helping to enhance your creative flow
and help you achieve greater flexibility and precision.
Logic Pro provides a dedicated support profile for Novation Launchpad controllers,
automatically mapping Live Loops to the pads and controls when a Launchpad device is
attached. For more information, see Logic Pro Control Surfaces Support.
You can also control Live Loops remotely using Logic Remote with your iPad or iPhone.

Assign a controller to Live Loops cells and scenes
1. Click a cell or Scene trigger

.

2. Choose Logic Pro > Control Surfaces > Learn Assignment for [Live Loops cell or scene
name], or press Command-L.
The Controller Assignments window opens in Learn mode, waiting for a MIDI message
from your control surface.
3. On your control surface, press the button or other controller you want to assign to the
cell or scene.
The controller is assigned to the cell or scene.
4. To make another assignment, select another cell or scene, then move the desired
controller on the control surface.
5. Click the Learn Mode button, close the Controller Assignment window, or press
Command-L to complete the Learn process.
For more information, see Overview of controller assignments.
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Assign a controller to Live Loops key commands

You can use Live Loops key commands and assign them to controllers on a MIDI control
surface to optimize your workflow.
1. Choose Logic Pro > Key Commands to open the Key Commands window, or press
Option-K.
2. Scroll down to the key commands grouped under Live Loops Grid. You can also search
for the key command in the Search field.
3. Select the key command you want to assign to your control surface.
4. Click the Learn New Assignment button under the Assignments field.
5. Press the control surface button that you want to assign to the key command. This
sends a MIDI message to Logic Pro.
The name of the controller appears in the Assignments field.
6. Repeat steps 3 to 5 to make additional assignments.
7. Close the Key Commands window when you are finished.
For more information, see Assign controller buttons to key commands.
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Use Step Sequencer

Overview of Step Sequencer in Logic Pro

Step Sequencer is inspired by classic hardware step sequencers that have rows of
configurable switches or knobs used to generate repeating musical patterns. In Step
Sequencer, you create patterns by editing multifunctional steps in the step grid. Each row
controls either a sound (which can be a drum kit piece, a note on an instrument, or a range
of notes) or an automation parameter (letting you create automation changes over time in
the pattern). Each step represents a definable length of musical time–by default, steps are
of equal length, but you can change the length for individual rows or steps. You can adjust
a wide range of parameters for individual steps, including velocity, pitch, gate time, and
more; and edit pattern and row settings including pattern length, row loop start and end
points, playback position, and rotation.
Step Sequencer appears in the Editors working area below the Tracks area. The Step
Sequencer interface includes the following:
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•

Step grid: The main working area where you turn steps on and off, and graphically edit
step settings using edit modes. See Edit Step Sequencer steps.

•

Step Sequencer menu bar: Contains menus with various editing and view functions,
buttons to show the Pattern Browser and the Step Sequencer inspector, MIDI In and
MIDI Out buttons, a Mono mode button, an Edit Mode selector, a Live Pattern Recording
button, a Preview button, and Zoom controls.

•

Pattern Browser: Access preset patterns and templates to use in your projects, and save
custom patterns and templates. See Load and save patterns.
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•

Step Sequencer inspector: Contains tabbed sets of controls providing a central location
to view and edit pattern, row, and step settings. See Edit Step Sequencer pattern, row,
and step settings.

•

Row headers: Each header contains a row icon, a disclosure arrow to show subrows, and
a set of controls for the row, including Mute and Solo buttons, a Row Assignment popup menu, Rotate buttons, and Increment/Decrement Value buttons. See Modify Step
Sequencer pattern playback and Edit Step Sequencer rows.

Pattern regions and pattern cells

Step Sequencer patterns are contained in pattern regions (in the Tracks area) and pattern
cells (in the Live Loops grid). Pattern regions and cells are used primarily on MIDI-based
(software instrument, external instrument, and Drummer) tracks. Pattern regions (but
not pattern cells) can also be used on audio tracks to automate effect and channel strip
parameters. A project can contain any number of pattern regions or cells.
Each pattern region or cell functions as an independent step sequencer, with its own
pattern, configuration, and settings. You can copy and move pattern regions like other
regions in the Tracks area. Pattern cells can be copied, moved, triggered, and queued like
other Live Loops cells. You can modify pattern region and cell parameters in the Region
inspector or Cell inspector, respectively.
All pattern, row, and step settings, as well as Step Sequencer view settings, are stored
with the pattern. You can also save a pattern as a template, which contains all the current
settings except for the step values, so you can use it as a starting point for creating
new patterns.
Patterns can include two types of rows:
•

Note rows: Generate MIDI note events (for each active step). By default, all notes in a
note row have the same pitch, but you can change the pitch for individual steps using
the Note and Octave edit modes.

•

Automation rows: Generate stepped automation events for an automatable parameter.
You can assign an automation row to any automatable parameter, including MIDI
continuous controller (CC) parameters, channel strip controls, plug-in parameters, and
Smart Controls.

Each row can have its own length, step rate, playback mode, start offset, and other
settings. Patterns can be from 12 to 64 steps in length, allowing for different time
signatures and multiple bar patterns.
You can add rows to a pattern manually or using Learn mode. When Learn mode is active,
rows are added when you play notes for which no row exists, or when you manipulate
an automation parameter for which no row exists. Using Learn (Assign) mode, you can
reassign existing note rows to match incoming note events, or reassign automation rows to
match automation parameters.
See Pattern creation basics and Work with Step Sequencer pattern length and step rate.
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Edit modes

Using edit modes, you can control different attributes of the note or event triggered by a
step. Some edit modes apply to only one row type, while others are common to both types.
For note rows, you can change the velocity, pitch, gate time, number of note repetitions
in a step, and other attributes. For automation rows, you can change the value of the
automated parameter. Edit modes common to both row types include skipping and tying
steps, changing the loop start and end point, and changing the step rate.

You select the edit mode for all rows in the pattern using the Edit Mode selector in the
Step Sequencer menu bar. You can also view and edit multiple edit modes per row using
subrows. Rows always match the edit mode selected in the Edit Mode selector, while
you can choose any unused edit mode for a subrow. You can add and delete subrows
as needed.

See Use Step Sequencer edit modes.

Use Step Sequencer with Drum Machine Designer
in Logic Pro

Step Sequencer is especially suited to creating drum patterns using Drum Machine
Designer patches. When you create a new pattern region on a track with a Drum Machine
Designer patch, note rows show names and icons matching the kit pieces in the patch
(rather than MIDI note names), and the Row Assignment pop-up menu shows the kit piece
names rather than MIDI note names.
When using Step Sequencer with a Drum Machine Designer patch, changing the note or
octave values for steps transposes the pad kit piece rather than changing the drum sound,
as it does for Drum Kit Designer or other drum kit software instruments. Unlike with other
types of instruments, the row name retains the name of the kit piece rather than changing
to Melodic.
You can separate a pattern region using a Drum Machine Designer patch into multiple
pattern regions, so that each row is separated into its own one-row pattern region. The
separated regions are placed on the subtracks of the Drum Machine Designer Track Stack
matching the originating kit piece rows. This can be useful when you want to work with the
resulting rows as separate regions. This function is similar to the MIDI Separate by Note
Pitch function.
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Separate a Drum Machine Designer pattern region per kit piece
1. In the Logic Pro Tracks area, select the pattern region.

2. Do one of the following:
•

Choose Edit > Convert > Separate by Kit Piece in the control bar.

•

Choose Edit > Convert > Separate by Kit Piece in the Tracks Area menu bar.

•

Control-click the region, then choose Convert > Separate Pattern Region by Kit Piece
from the shortcut menu.

3. To view and edit the new pattern region for each row, click the disclosure arrow to open
the Track Stack.
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Create Step Sequencer patterns
Pattern creation basics in Logic Pro

Using Step Sequencer, you can create rhythm-based drum patterns and note-based
instrument patterns using any available software instrument. You can start with an empty
pattern, or use an existing pattern or template as a starting point.
You create a pattern by turning steps on and off, modifying the sound and duration of steps
using edit modes, and editing aspects of the overall pattern, including the pattern length,
the step rate for the pattern, and the pattern key. You can increase the number of notes or
drum sounds in a pattern by adding rows and choosing the row assignment. By activating
Learn mode, you can quickly add rows by playing notes or manipulating automation
parameters.

Create an empty pattern region in the Tracks area
•

In Logic Pro, Control-click in an empty software instrument track, then choose Create
Pattern Region from the shortcut menu.

•

In Logic Pro, select an empty software instrument region, click the Step Sequencer tab
in the Editors area, then click a step in the step grid.
Note: When you select a MIDI region or MIDI cell, the editor that appears in the Editors
area is the editor last used for a MIDI region or MIDI cell. After you work with a pattern
region or cell, the next time you click in a new cell, the Step Sequencer editor is
available in the Editors area, so you can start editing steps without first creating an
empty pattern cell.

Create an empty pattern cell in the Live Loops grid
•

In Logic Pro, select an empty software instrument cell, click the Step Sequencer tab in
the Editors area, then click a step in the step grid.
Note: When you select a MIDI region or MIDI cell, the editor that appears in the Editors
area is the editor last used for a MIDI region or MIDI cell. After you work with a pattern
region or cell, the next time you click in a new cell, the Step Sequencer editor is
available in the Editors area, so you can start editing steps without first creating an
empty pattern cell.

•

Control-click an empty software instrument cell in the Live Loops grid, then choose
Create Pattern Cell from the shortcut menu.

Turn steps on or off
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•

In Logic Pro, with the Edit Mode selector set to Step On/Off, click an inactive step in the
grid to turn it on.

•

Click an active step to turn it off.
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Enter steps monophonically

Using Mono mode, you can easily create monophonic lines by suppressing the creation of
more than one note per step position. When you turn on a step, and another step is already
active at the same vertical position, the previously active step is turned off. This can be
useful, for example, when creating patterns for a monophonic instrument.
Turning on Mono mode will not turn off steps that are already active, but once you activate
a new step, Step Sequencer turns off all other active steps at the same step position.
When Mono mode is active, triggering Randomize All Step On/Off Row Values respects the
Mono mode setting, so that no notes are created at the same step position.
•

To turn on Mono mode, click the Mono Mode button

in the Step Sequencer menu bar.

Preview a pattern
•

In Logic Pro, with the project stopped, click the Preview button
Sequencer menu bar.

in the Step

Click the Preview button again to stop the pattern playing.

Add a row

You can add a row, and choose the pitch (for note rows) or automation parameter (for
automation rows) directly from the Add Row pop-up menu. You can also add rows using
Learn mode.
1. In the Step Sequencer menu bar, choose one of the following from the Add Row pop-up
menu :
•

To add a note row: Choose Notes, then do one of the following:
•

Choose a fixed pitch or a drum sound for the row from the Notes submenu.

•

Choose Melodic if you plan to add a note row with steps set to different pitches.
When you add a Melodic row, Note and Octave subrows are created for the row
by default.

•

To add an automation row: Choose Automation, then choose the automation
parameter for the row from one of the submenus.

•

To activate Learn mode: Choose Learn, then follow the steps described in Add rows
using Learn (Add) mode.

2. After adding a row, you can turn steps on or off, and edit other settings using edit
modes.
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Add rows using Learn (Add) mode

You can add rows by playing MIDI notes or manipulating automatable parameters using
Learn mode. When Learn (Add) mode is active, Step Sequencer creates a new note row
for any played MIDI note for which a row does not already exist. Similarly, it creates a
new automation row for any received parameter controller event for which a row does not
exist. Learn (Add) mode simplifies the process of creating a step grid with the notes, drum
sounds, and automation parameters you want to use in your pattern.
1. To activate Learn (Add) mode, choose Learn (Add) from the Add Row pop-up menu

.

While Learn (Add) mode is active, a red Learn button appears in place of the Add Row
pop-up menu.

2. Do either of the following:
•

To add note rows: Play notes on a connected MIDI keyboard or other MIDI controller.

•

To add automation rows: Manipulate a control for an automatable parameter, either
in Logic Pro or using a connected MIDI controller.

3. To turn off Learn mode, click the Learn button.
After adding a row, you can turn steps on or off, and edit other settings using edit modes.

Reassign rows using Learn (Assign) mode

You can reassign existing rows by playing MIDI notes or manipulating automatable
parameters using Learn (Assign) mode. When Learn (Assign) mode is active, Step
Sequencer reassigns the selected row to match any played MIDI note for which a row does
not already exist, or to match any received parameter controller event for which a row does
not exist.
1. To activate Learn (Assign) mode, choose Learn (Assign) from the Add Row pop-up menu
.
While Learn (Assign) mode is active, an amber Learn button appears in place of the Add
Row pop-up menu.

2. Select the row you want to reassign.
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3. Do either of the following:
•

To reassign a note row: Play notes on a connected MIDI keyboard or other MIDI
controller.

•

To reassign an automation row: Manipulate a control for an automatable parameter,
either in Logic Pro or using a connected MIDI controller.

4. To turn off Learn (Assign) mode, click the Learn button.
After adding a row, you can turn steps on or off, and edit other settings using edit modes.
Step Sequencer provides many controls and functions for working with patterns. You can
modify pattern playback, edit steps and rows, and edit pattern, row, and step settings in
the Step Sequencer inspector. You can also customize different aspects of Step Sequencer
to suit your workflow, see Customize the Step Sequencer interface.

Change the musical length of a pattern in Logic Pro

Several factors determine the musical length of a Step Sequencer pattern (the time in bars
and beats before the pattern repeats). The most fundamental are the pattern length, which
defines the maximum number in steps available to each row, and the pattern step rate,
which defines the length of each step in musical divisions (note values).
Another important factor affecting the musical length of a pattern is the Loop Start/
End edit mode. Using Loop Start/End, you can set the number of steps for each row
independently from the pattern length, and the length of other rows. Technically, the
musical length of a pattern is the length of the longest row. For example, if all rows in a
pattern loop after four steps, and each step has a step rate of 1/16th, then the musical
length is only one beat (1/4), even if the pattern length is 16 steps or longer.
When row lengths are evenly divisible with one another, the overall length is equal to the
longest row. For example, if you shorten several rows in a 16-step pattern to four or eight
steps (which both divide evenly into 16), the pattern remains a one-bar pattern. When
row lengths are not evenly divisible, however, the musical length is increased (sometimes
substantially) because the pattern doesn’t repeat until all rows start at the same
time again.
Using the Skip edit mode can also result in the length of rows changing, which affects
the overall musical length of the pattern in a similar manner to changing the Loop Start/
End setting.
The playback mode can also affect the musical length of the pattern. Choosing PingPong as the playback mode doubles the pattern length, while setting any row to Random
playback mode can result in the musical length of the pattern being essentially infinite.
Ultimately, how long a pattern plays in a project depends on the length of the pattern
region or pattern cell. If the musical length of the pattern exceeds the region or cell length,
it plays only until the end of the region or cell is reached. When the region or cell length
exceeds the pattern length, the pattern repeats until the end of the region or cell, or
restarts if the region or cell is looping. If the musical length of the pattern, or of any row,
does not fit equally into the region length (or cell length), then the rows in the pattern
restart before they complete a full cycle.
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Change the pattern length
•

In Logic Pro, choose a new length from the Pattern Length pop-up menu in the Step
Sequencer menu bar.

When you increase the pattern length, the added steps duplicate the existing pattern. You
can edit the added steps to add variation or change the pattern.
When the pattern length is more than 16 beats, the entire pattern may not be visible in the
step grid, depending on the zoom level. In this case, the pattern is divided into sections
called pages, each showing a part of the complete pattern. An overview of each page
appears above the step grid. You can click the page overviews to quickly switch between
different parts of the pattern.
You can also change the pattern length in the Step Sequencer inspector.

Change the step rate for the pattern

The step rate sets the duration of steps in the step grid as a note value. You can set the
step rate for the overall pattern, and set a different step rate for individual rows and steps.
•

In Logic Pro, choose a new step rate from the Step Rate pop-up menu in the Step
Sequencer menu bar.

You can also change the step rate for the pattern in the Step Sequencer inspector.
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Use Step Sequencer edit modes in Logic Pro

You can control different aspects of the event triggered by a step using edit modes. You
can choose the edit mode for a pattern, and view multiple edit modes for each row using
subrows. Some edit modes are common to both note rows and automation rows, while
others are specific to one row type.
The Edit Mode selector in the Step Sequencer menu bar controls the edit mode for all rows
in the pattern. Step On/Off mode is always available on the left-side button on the selector.
You can choose other edit modes from the menu on the right side of the selector. The
chosen edit mode appears on the right-side button. Edit modes include the following:

Edit modes for both row types
•

Step On/Off: Click steps to turn them on or off. Active steps appear highlighted in the
step grid, while inactive steps appear darker.

•

Tie: Click the right edge of a step to tie it to the following step, or click the left edge
to tie it to the previous step. The duration of the step is lengthened by the value of the
step it is tied to.
Note: You can also tie steps in other edit modes (except Tie, Step Rate, and Loop Start/
End) by pressing and holding Command-Option, then dragging from a step across one
or more following steps.
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•

Loop Start/End: When this mode is active, a frame appears around the row. Drag the
left edge of the frame to set the start of the row relative to the overall pattern. Drag the
right edge of the frame to set the end of the row relative to the overall pattern. You can
also click a step to set the start or end point (whichever is closest) to that step, and
drag vertically to other rows to set their start or end positions.

•

Chance: Drag vertically in the step to set the Chance percentage. Chance controls the
probability that the step plays each time the pattern repeats. The active state of the
step is determined when you edit the Chance value and does not change until you edit it
again.

•

Start Offset: Drag vertically in the step to move the start offset of the step from –50 to
+50 percent of the step rate.

•

Step Rate: Drag vertically in the step to set the length of the step (in note values,
relative to the project tempo). This determines how long it takes for the playhead to
move across the step, whether or not it is active.

•

Skip: Click a step to turn skipping on or off. When skipping is on, the step is skipped
and playback moves immediately to the next step, in effect shortening the row by the
duration of the skipped step.
699

Edit modes for note rows
•

Velocity: Drag vertically in the step to set the Velocity value from 1 to 127. Velocity
typically controls the loudness of the note attack, but can control other parameters
depending on the parameter mapped to Velocity for the patch.

•

Gate: Drag vertically in the step to set the Gate value as a percentage of the step. The
Gate value shortens the note length to less than the duration of the step.

•

Note: Drag vertically in the step to set the Note value from –12 to 12 semitones,
transposing the pitch of the step in notes.
When you change the pitch of a step in a fixed-pitch note row, the row header label
changes to Melodic to indicate that the row contains multiple pitches.

•

Octave: Drag vertically in the step to set the Octave value from –2 to 8 octaves,
transposing the pitch of the step in octaves.

•

Note Repeat: Drag vertically in the step to set the Note Repeat value from 1 to 16. Note
Repeat controls how often the note repeats during the duration of the step.

Edit modes for automation rows
•

Value: Drag vertically to set the value for the automation parameter controlled by the
row. The value range depends on which parameter the row is set to control.

Note: In the Edit Mode selector, choosing Velocity / Value sets the edit mode to velocity
for note rows, and to the automation value for automation rows. In row headers, Velocity
appears in the Edit Mode pop-up menu for note rows only.

View and edit multiple edit modes for a row using subrows

You can view and edit multiple edit modes for a row using subrows. When you click the
disclosure arrow in the row header, a default set of subrows appear, each with its own edit
mode. When you add a subrow, it defaults to the next available edit mode for that row type.
Two subrows of a row cannot have the same edit mode.

Choose the edit mode for the pattern

The Edit Mode selector consists of three parts: Step On/Off can always be selected directly
using the left-side button. The right-side button shows the edit mode currently selected
in the Edit Mode pop-up menu, which is accessed using the arrows on the right side of
the selector.

In Logic Pro, do one of the following:
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•

To choose Step On/Off, click the button on the left side of the Edit Mode selector.

•

To choose a different edit mode, click the up and down arrows on the right side of the
selector and choose the edit mode from the list.
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When you choose an edit mode from the list, it becomes active for all rows. Subrows
keep their current edit mode.

Change edit mode values for steps in the grid

1. In Logic Pro, in the Step Sequencer menu bar, choose an edit mode from the Edit Mode
selector.
By default, each step shows the current value for the selected mode. You can change
the display of step values in the step grid.

2. In the step grid, edit the value of each step.
For most edit modes (except Tie and Skip), you edit the value by dragging vertically in
the step. The value appears above the step as you drag. Some edit modes have only
on and off states, rather than a range of values. In this case, clicking the step switches
between the two states. For Loop Start/End, clicking a step sets the loop start or loop
end position (whichever is closer) to that step.

Create ramped values across steps

1. In Logic Pro, set the value of the first step you want to include in the ramp.
2. Press and hold Option-Shift, then drag across the steps you want to include in the
ramp.
3. While still pressing and holding Option-Shift, make sure the last step in the ramp is set
to the correct value.
When you finish, the values of all steps in the range increment or decrement in perfect
intervals between the start and end steps.
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Show subrows for a row

You can view and edit multiple edit modes for a row at the same time using subrows.
•

In Logic Pro, click the disclosure arrow to the left of the row header icon.

By default, several subrows appear below the row, depending on the row type.
You can Add subrows and change the edit mode for a subrow.

Change the edit mode for a subrow
•

In Logic Pro, choose a new edit mode from the Edit Mode pop-up menu, located in the
upper-right area of the subrow header.

Add a subrow

When you add a subrow, it defaults to the next available edit mode for that row type. Two
subrows of one row cannot have the same edit mode.
1. In Logic Pro, hold the pointer over the left edge of a subrow header, then click the Add
Subrow icon that appears.

A subrow appears below the subrow, set to the next available edit mode for the row.
2. Click the Edit Mode pop-up menu and choose an edit mode for the subrow.
The steps in the subrow show the values for the selected edit mode.

Delete a subrow
•
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In Logic Pro, hold the pointer over the left edge of the subrow header, then click the
Delete Subrow icon that appears.
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Pattern creation examples

The following examples provide steps to follow as well as general guidelines for working
with different types of patterns.

Drum pattern example

For drum and percussion (rhythm-based) patterns, edit modes such as Velocity and Note
Repeat can be effective for creating interesting-sounding patterns. You can also create
interesting variations by copying the pattern and changing the pattern length of the copy.
1. In Logic Pro, choose an Electronic Drum Kit patch that uses Drum Machine Designer
from the Library.
2. Create an empty pattern region in the Tracks area, or an empty pattern cell in the Live
Loops grid.
3. Turn on some steps in the pattern to create a basic beat. It’s often good to begin with
a simple kick pattern to set the foundation, followed by a few snare hits and a hi-hat
pattern.
4. Click the Preview button
work.

in the Step Sequencer menu bar to hear the pattern as you

5. Choose Velocity / Value from the Edit Mode selector and adjust the velocity of steps.
6. Choose Note Repeat from the Edit Mode selector and add note repetition to some steps.
This can work especially well with closed hi-hats or other sounds with a quick decay.
7. Click the Preview button again to stop the pattern playing.
8. Choose a different pattern length from the Pattern Length pop-up menu.
9. With either the Tracks area or the Live Loops grid in focus, press Command-R (or
choose Edit > Repeat > Once) to create a copy of the region (or cell) to the right of the
original one.
10. With the new region or cell selected, choose the /8 step rate from the Pattern Step Rate
pop-up menu above the row headers, and listen to the difference in how the pattern
sounds at the new step rate.

Instrumental pattern example

Edit modes such as Velocity, Note, Octave, and Tie can be useful for creating interesting
instrument and melodic patterns.
1. In Logic Pro, choose a synthesizer patch featuring a relatively fast note attack from the
Library (such as the Analog Poly Synth, Luminous Tines, or Short Pulse Waves patches
in the Synthesizer > Classics subdirectory).
2. Create an empty pattern region in the Tracks area, or an empty pattern cell in the Live
Loops grid.
3. Click the Preview button
work.

in the Step Sequencer menu bar to hear the pattern as you

4. Turn on some steps in the pattern to create the basic feel.
5. Choose Velocity / Value from the Edit Mode selector and adjust the velocity of steps.
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6. While still in Velocity / Value edit mode, press and hold the Command key while clicking
steps to turn them on or off. You can use this key command while in any edit mode
other than Step On/Off.
7. Choose Tie from the Edit Mode selector and tie some steps to lengthen some notes.
8. Click the disclosure arrow on the left edge of a row header to show subrows for that
row.
9. In the Gate subrow, choose Note from the Edit Mode pop-up menu to change the edit
mode for the subrow.
10. Drag vertically in some steps to change their pitch. The new pitch appears above the
step as you edit it.
Note: When you change the pitch of individual steps in a row, the row is labeled Melodic
to indicate that the steps in that row no longer trigger the same pitch.

Adding automation example

Using Learn mode to quickly add automation rows by manipulating Smart Controls and
other parameters simplifies the process of adding automation to a pattern.
1. In Logic Pro, open the Loop Browser, choose Abstract Harps Pattern 01 (as an example),
and drag it to a new software instrument track or Live Loops cell.
2. Click the Preview button in the Step Sequencer menu bar and listen to the pattern.
3. Choose Window > Open Smart Controls.
4. Click the Add Row pop-up menu
activate Learn mode.

located above the row headers, and choose Learn to

5. Manipulate the Timbre screen controls in the Smart Controls window and look for a row
created for that parameter in Step Sequencer.
6. Choose Velocity / Value in the Edit Mode selector.
7. Change the value for a few steps in the new row for the Timbre parameter in the
pattern.
Notice how the parameter moves abruptly from one value to the next.
Note that changes to the Timbre value will be audible only on steps that are turned on.
8. Open the Step Sequencer inspector, click the Row tab to show the Row inspector, then
choose Slide from the Automation Mode pop-up menu.
Notice that automation parameters now move smoothly between values.
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Record Step Sequencer patterns live in Logic Pro

With Live Pattern Recording, you can record both MIDI note events and automatable
parameter events to a pattern region or pattern cell while the pattern is playing. Notes
matching existing note rows are recorded as steps in those rows, and new note rows are
created for notes that do not match an existing row. Similarly, automation parameters for
which a row exists are recorded to those rows, and new automation rows are created for
parameters with no existing row.
When you play intervals or chords, steps on note rows matching the pitches played are
turned on, unless Mono mode is active. Mono mode restricts note input so that only one
step for each time position is active. That is, when multiple notes are played, only the last
note received in the time range of the step is active.
During Live Pattern Recording, when the selected row is a Melodic row, incoming note
events turn on steps on that row only, with each active step set to the correct Note and
Octave value. Live Pattern Recording on Melodic note rows is always monophonic. If
notes are played simultaneously, the last note received during the time range of the step
determines the pitch of that step.
When incoming note or automation events fall between steps, the step closest to the time
position of the event is activated.

Live Pattern Recording options

You can control whether to capture note velocity and length during Live Pattern Recording,
as well as whether to quantize the recorded note or automation events to the start of the
step they activate. The Live Pattern Recording options include:
•

Velocity: When selected, the velocity of the incoming note events is applied to the newly
activated steps. When deselected, the new steps retain the existing value of the step.

•

Note Length: When selected, the duration of notes played during recording is captured
and played back. Step Gate and Tie values are modified to make the step the same
length as the recorded MIDI event. If the played note is shorter than the step length,
Step Sequencer reduces the Gate value to shorten the step to match the played note.
If the played note is held longer than the step length, a Tie is activated for the step
to increase its duration. The Gate value is also adjusted for the tied step to match the
length of the played note as closely as possible. When Note Length is deselected, then
tie and gate values do not change to reflect the duration of held notes. Only the step
closest to the start of the incoming event is activated, at its standard step length.
In general, it's best to keep off Note Length off when recording drums, and turn it on
when recording pitched instrument events.

•
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Quantize: When Quantize is selected, notes snap to the start of active steps so they
play in perfect metronomic time, with no offset. When deselected, a Step Offset value is
added to each active step so that the event is triggered at the precise time position of
the played note.
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Create a live pattern recording

1. In Logic Pro, start the pattern playing by doing one of the following:
•

Click the Preview button in the Step Sequencer menu bar.

•

Start the project playing. When the playhead reaches the start of the pattern region,
recording starts, and continues until the playhead reaches the end of the pattern
region.
Note: You can extend recording time for the pattern by setting the cycle area to the
start and end of the pattern region.

•

For a pattern cell, click the cell to start playback. Recording continues until the cell
stops playing.

2. Click the Live Pattern Recording button

in the Step Sequencer menu bar.

3. Perform the parts you want to record. Both played notes and controller-driven
automation changes are recorded.
4. When you finish, click the Live Pattern Recording button again to stop recording.

Set live recording options
•

In Logic Pro, in the Step Sequencer menu bar, do any of the following:
•

To have recorded steps match the velocity of incoming note events, choose
Functions > Live Record Options > Velocity.

•

To have recorded steps match the duration of incoming note events, choose
Functions > Live Record Options > Note Length.

•

To add an step offset to recorded steps to match the start time of incoming note
events, choose Functions > Live Record Options > Quantize.

Step record patterns in Step Sequencer in Logic Pro
With Step Recording, you can record both MIDI note events and automatable parameter
events to a pattern region or pattern cell in sequence, similar to step input recording of
MIDI events. You can step record to a pattern with the playhead either running or stopped.
When step recording is active, incoming MIDI events turn on steps in sequence (one step
at a time), starting from the position of the currently selected step. If a row assigned to
the incoming MIDI event exists, the step on that row is activated. If no corresponding row
exists, a row assigned to that event is created, similar to the way Learn mode and Live
Pattern Recording function.
For incoming note events, once the Note Off message for the last held note event is
received, the next step in the row is selected. For example, if you are using a standard
MIDI keyboard controller, the step is enabled when you press a key on the controller, and
the next step is selected when you release the key. If you press additional keys on the
controller before releasing the currently held ones, the next step is not selected until you
release the last held key. This makes it easier to input chord notes.
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Unlike note events, MIDI CC and automation events do not move to the next step
automatically. When Logic Pro detects a new incoming event, either the matching row is
selected or a new one is created, and then a step is activated at the current location with
the current parameter value. The value of that step continues to change as long as the
parameter or CC value is manipulated, until the user selects a new step, either directly or
by using the left or right Arrow to move to the next (or another) step location.

Create a pattern using step recording
1. Click the MIDI In button

in the Step Sequencer menu bar to turn on step recording.

2. Play the notes, and manipulate any parameter automation changes.
3. When you finish, click the MIDI In button again to turn off step recording.

Load and save patterns in Step Sequencer
in Logic Pro

Step Sequencer includes a Pattern Browser where you can choose and save patterns and
templates. The Pattern Browser contains a variety of premade patterns for drums, bass,
keys, and other instrument categories that you can use in your projects. The Pattern
Browser also features templates, which include pattern, row, and step settings but with an
empty step grid, that you can use as as a starting point for creating patterns.
Patterns can also be contained in pattern loops. A pattern loop contains the patch for
the pattern’s sound as well as the pattern, row, and step settings, and step values. The
Loop Browser includes a collection of pattern loops you can use in your projects. You add
pattern loops to the Tracks area or the Live Loops grid in the same way as other loops.

Choose a pattern from the Pattern Browser

1. In Logic Pro, click the Pattern Browser button

in the Step Sequencer menu bar.

The Pattern Browser opens to the left of the step grid.

2. In the Pattern Browser, choose a pattern.
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Search for patterns by name
•

In Logic Pro, enter a search term in the Pattern Browser search field, then press Return.

Transpose the selected pattern to the project key

1. In Logic Pro, select one or more patterns in the Pattern Browser.
2. Choose Use Project Key from the Pattern Browser Action pop-up menu.

Save a pattern to the Pattern Browser
•

In Logic Pro, with the pattern open in Step Sequencer, choose Save Pattern from the
Action pop-up menu in the Pattern Browser.

Save a pattern as a template
•

In Logic Pro, with the pattern open in the Step Sequencer, choose Save Template from
the Action pop-up menu in the Pattern Browser.

Create folders for patterns and templates

1. In Logic Pro, with the pattern open in the Step Sequencer, click User in the Pattern
Browser, then click either Pattern or Template.
2. Choose New Folder from the Action pop-up menu in the Pattern Browser.
A new untitled folder appears, selected and ready to name.
3. Enter a name for the folder, then press Return.

Convert a MIDI region or cell to a pattern region or cell

You can convert MIDI regions in the Tracks area to Step Sequencer pattern regions. The
position of notes is accurately reproduced using offset values, and note lengths are
recreated using a combination of tie and gate values used (in the same way both are used
when using the Live Record feature). The resulting pattern region can have a maximum
of 64 steps; so for best results, use a MIDI region not longer than 4 bars in the 4/4 time
signature. Also, for the most accurate conversion, use a MIDI region with successive MIDI
events that are not less than 1/16th note apart.
•

In the Tracks area in Logic Pro, Control-click the MIDI region, then choose Convert >
Convert to Pattern Region.

Convert a pattern region or cell to a MIDI region or cell
In Logic Pro, do either of the following:
•

In the Tracks area, Control-click the pattern region, then choose Convert > Convert to
MIDI Region.

•

In the Live Loops grid, Control-click the pattern cell, then choose Convert > Convert to
MIDI Cell.

Delete a user-created folder
•
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In Logic Pro, select the folder, then choose Delete Folder from the Action pop-up menu
in the Pattern Browser.
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Add a pattern loop from the Loop Browser

1. In the Logic Pro control bar, click the Loop Browser button

to open the Loop Browser.

2. In the Loop Browser, click the Loop Types button and select Pattern Loops from the
pop- up menu.

3. Drag a pattern loop to a software instrument track or Drummer track. If regions already
exist on the track, the pattern loop uses the existing track instrument; if the track is
empty, the track uses the patch (including the instrument) saved with the pattern. You
can also drag a pattern loop to the empty area below the bottom track.

Modify pattern playback in Step Sequencer
in Logic Pro

Some options in Step Sequencer control how and when steps play back, and can be fun to
manipulate while the pattern is playing. For example, you can mute and solo rows, rotate
rows (moving all steps in a row left or right, including their step values and other edit
mode settings), and change the playback mode for the pattern or for a row, and perform
other actions while the pattern is playing. In addition to controls and menu items, Step
Sequencer includes a collection of key commands to facilitate making these and other
changes in real time, see Step Sequencer key commands.

Mute a row
•

In Logic Pro, click the Mute button

in the row header.

Click the Mute button again to unmute the row.

Solo a row
•

In Logic Pro, click the Solo button

in the row header.

Click the Solo button again to unsolo the row.
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Rotate a row

When you rotate a row, all steps in the row, including their edit mode values, are shifted
either left (counterclockwise) or right (clockwise). When you rotate a subrow, the edit
mode value for that subrow is shifted left or right.
•

To rotate the row left (counterclockwise): Click the Rotate Left button
header.

•

To rotate the row right (clockwise): Click the Rotate Right button

in the row

in the row header.

Rotate all steps in the pattern
•

In Logic Pro, do one of the following in the Step Sequencer menu bar:
•

To rotate steps left (counterclockwise): Click the Rotate Left button

•

To rotate steps right (clockwise): Click the Rotate Right button

.

.

Rotate edit mode values for steps in a row

When you use the Rotate controls in a subrow, you can rotate edit mode values for the
subrow independently of the step values (on or off). You can use this technique to, for
example, keep the same rhythm while changing the pitches being played.
1. In Logic Pro, click the disclosure arrow to show subrows for a row.
2. If necessary, change the edit mode for a subrow to show the one you want to rotate.
3. Click the Rotate Left button
edit mode values.

or the Rotate Right button

in the subrow to rotate

Change the playback mode for the pattern

By default, steps in a pattern sound from left to right, similar to how the playhead moves
from left to right in the Tracks area. You can change the playback mode for the overall
pattern, and choose a different playback mode for individual rows.
•

In Logic Pro, choose a playback mode from the Playback Mode pop-up menu in the Step
Sequencer menu bar.

The choices are:
•

Forward: Steps play from left to right.

•

Backward: Steps play from right to left.

•

Ping-Pong: Playback alternates between left to right and right to left.

•

Random: Steps play in an undetermined order.

You can also change the playback mode for the pattern in the Step Sequencer inspector.
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Change the playback mode for a row
•

In Logic Pro, choose a playback mode from the Playback Mode pop-up menu in the row
header.

The choices are:
•

Forward: Steps play from left to right.

•

Backward: Steps play from right to left.

•

Ping-Pong: Playback alternates between left to right and right to left.

•

Random: Steps play in an undetermined order.

You can also change the playback mode for a row in the Step Sequencer inspector.

Edit Step Sequencer steps in Logic Pro

You can edit individual steps in several ways, including cutting, copying, and pasting
steps. You can also repeat a step, decrement or increment the values of all steps in a row,
transpose all steps in a pattern by semitones or octaves, randomize values for all steps in a
row or all steps in the pattern, and reset steps to default values.
Pattern regions can be edited only in the Step Sequencer, not in the other MIDI editors. You
can convert a pattern region to a MIDI region, which can be edited in the Tracks area and in
the Piano Roll Editor.

Cut a step

1. In Logic Pro, do one of the following to select the step:
•

In any edit mode except for Loop Start/End, Shift-click the step, then choose Edit >
Cut (or press Command-X).

•

Control-click the step, then choose Cut from the shortcut menu.

When you cut a step, the step value and edit mode settings are cut, but the empty step
remains in the step grid. The order of following steps does not change.

Copy and paste a step

You can copy a step, including all of its step settings. When you paste a copied step, the
destination row should be of the same row type (note or automation) as the source row.
All step settings are copied, with one exception: If the step rate was not edited for that
individual step (that is, if it still uses the pattern or row step rate), the pasted step inherits
the step rate of the step that it replaces.
1. In Logic Pro, do one of the following:
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•

In any edit mode except for Loop Start/End, Shift-click the step, then choose Edit >
Copy (or press Command-C).

•

Control-click the step, then choose Copy from the shortcut menu.
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2. Do one of the following:
•

Shift-click the destination step, then choose Edit > Paste (or press Command-V).

•

Control-click the destination step, then choose Paste from the shortcut menu.

Repeat a step

In Logic Pro, do one of the following:
•

Shift-click the step to select it, then choose Edit > Repeat Step from the Step
Sequencer menu bar.

•

Control-click the step, then choose Repeat from the shortcut menu.

Raise or lower the value of all steps in the pattern
In Logic Pro, do one of the following:
•

To lower the value of all steps in the pattern: Click the Decrement Value button
the top row header.

•

To raise the value of all steps in the pattern: Click the Increment Value button
the top row header.

above
above

You can also continuously change the value for all steps in the pattern by clicking either
button and dragging vertically.
When the edit mode is set to Step On/Off, clicking the Increment Value button turns on all
steps, and clicking Decrement Value button turns off all active steps.When the edit mode
is set to Tie, clicking the Increment Value button ties all steps (except the last step), and
clicking Decrement Value button unties all tied steps.

Raise or lower the values of all steps in a row
In Logic Pro, do one of the following:
•

To lower the value of all steps in a row: Click the Decrement Value button
header.

•

To raise the value of all steps in a row: Click the Increment Value button
header.

in the row
in the row

You can also continuously change the value for all steps in a row by clicking either button
and dragging vertically.

Transpose all steps in a pattern

In Logic Pro, choose one of the following from the Functions menu in the Step
Sequencer menu bar:
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•

To transpose the pattern up one semitone: Choose Transpose +1 Semitone.

•

To transpose the pattern down one semitone: Choose Transpose –1 Semitone.

•

To transpose the pattern up one octave: Choose Transpose +1 Octave.

•

To transpose the pattern down one octave: Choose Transpose –1 Octave.
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Randomize step values for the current edit mode

You can randomize the values for a specific edit mode for a single row, for all note rows or
all automation rows, or for all rows in the pattern.
•

To randomize settings for a row: Select the row, then choose Functions > Randomize
Row Values > Current Edit Mode from the Step Sequencer menu bar.

•

To randomize settings for all note rows: Select the row, then choose Functions >
Randomize All Row Values > Current Edit Mode for Note Rows from the Step Sequencer
menu bar.

•

To randomize settings for all automation rows: Select the row, then choose Functions >
Randomize All Row Values > Current Edit Mode for Automation Rows from the Step
Sequencer menu bar.

•

To randomize settings for all applicable rows: Choose Functions > Randomize All Row
Values > Current Edit Mode from the Step Sequencer menu bar.

Reset row values to default settings

When you create a pattern, many Step Sequencer settings, including all edit modes and
the playback mode, have a default value. After you change the value for a step, it no longer
retains the default value. You can clear steps, which resets all their edit mode values to
default values (for the step rate, the default is defined by the row step rate). You can clear
a single step, all steps in a row, or all steps in the pattern. You can also clear the values for
the currently selected edit mode in a single row, for all note rows or all automation rows, or
for steps in all rows in the pattern.
•

To clear edit mode values for a step: Shift-click the step to select it, then choose
Functions > Clear Step from the Step Sequencer menu bar.

•

To clear edit mode values for all steps in a row: Select the row, then choose Functions >
Clear Row from the Step Sequencer menu bar. Alternatively, you can Control-click the
row, then choose Clear Row from the shortcut menu.

•

To clear edit mode values for all steps in all note rows: Choose Functions > Clear All
Row Values > Current Edit Mode for Note Rows from the Step Sequencer menu bar.

•

To clear edit mode values for all steps in all automation rows: Choose Functions > Clear
All Row Values > Current Edit Mode for Automation Rows from the Step Sequencer
menu bar.

•

To clear all steps in the pattern: Choose Functions > Clear Pattern from the Step
Sequencer menu bar.

You can also view and edit many step settings in the Step Sequencer inspector.
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Edit Step Sequencer rows in Logic Pro

You can edit Step Sequencer rows in a variety of ways, including copying and pasting
rows or row settings, duplicating a row with the next row assignment, changing the row
assignment, resetting row values to a default setting, and deleting a row.

Copy and paste rows

1. In Logic Pro, click the row icon to select the row, then choose Edit > Copy Row from the
Step Sequencer menu bar.
2. Select a row that you want to replace with the pasted row.
3. Choose Edit > Paste Row from the Step Sequencer menu bar.
When the copied and pasted rows are both fixed note rows, the Note and Octave values are
ignored. You can copy and paste a row to duplicate the rhythm of the copied row to a row
with a different drum sound or pitch. When you copy from a Melodic note row, however, the
Note and Octave values are maintained.

Copy a row to a new row

1. In Logic Pro, click the row icon to select the row, then choose Edit > Copy Row from the
Step Sequencer menu bar.
2. Choose Edit > Paste to New Row.
This can be particularly useful when you want to copy a row from one pattern to another.

Copy and paste row settings

1. In Logic Pro, click the row icon to select the source row, then choose Edit > Copy Row
from the Step Sequencer menu bar.
2. Select the destination row (in the same or another pattern region) and choose Edit >
Paste Row Settings from the Step Sequencer menu bar.

Duplicate a row with the next available row assignment
•

In Logic Pro, click the row icon to select a row, then choose Edit > Duplicate Row with
Next Assignment from the Step Sequencer menu bar.

The row, including row settings and active steps, is duplicated using the next available row
assignment.

Change the row assignment

You can change the row assignment for a row, including changing the row type.
•

In Logic Pro, click and hold the Row Assignment menu in the row header, then do one of
the following:
•

For a note row: Choose Notes, then choose a different note value from the submenu,
or else choose Melodic (if you plan to assign different pitches to different steps).
Note: When a pattern using a Drum Machine Designer patch is selected, the Row
Assignment pop-up menu shows the kit piece names rather than MIDI note names.
For patches using Ultrabeat or a Sampler instrument set to show note labels, choose
Labeled Notes to display notes with their descriptive label.
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•

For an automation row: Choose Automation, then choose an automation parameter
from one of the submenus.

You can also change the row assignment in the Step Sequencer inspector.

Reset row values to default settings
In Logic Pro, do one of the following:
•

To clear row values: Select the row, choose Functions > Clear Row Values from the Step
Sequencer menu bar, then choose which edit mode values you want to clear.

•

To clear all row values: Choose Functions > Clear All Row Values from the Step
Sequencer menu bar.

Delete a row
•

In Logic Pro, select the row, then choose Edit > Delete Row from the Step Sequencer
menu bar.

Delete all unused rows
•

In Logic Pro, choose Edit > Delete Unused Rows from the Step Sequencer menu bar.
The Delete Unused Rows command is available only if there are unused rows.

You can also view and edit many row settings in the Step Sequencer inspector.

Edit Step Sequencer pattern, row, and step
settings in Logic Pro

You can edit a variety of settings for patterns, rows, and individual steps in the Step
Sequencer inspector. When you open the Step Sequencer inspector, you see tabs along the
top for Pattern, Row, and Step inspectors. Clicking a tab displays settings for that level.
Some controls in the Step Sequencer inspector are also available in other parts of Step
Sequencer (for example, some pattern settings are available in the Step Sequencer menu
bar, and many row settings are available in the row headers). By viewing and editing
them in the inspector, you can more easily compare values, and copy and paste values
between settings.

Open the Step Sequencer inspector
•

In Logic Pro, click the Inspector button
choose View > Show Local Inspector).

to show the Step Sequencer inspector (or

Edit pattern settings

1. In Logic Pro, click the Pattern tab in the Step Sequencer inspector to show the Pattern
inspector.
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2. Do any of the following:
•

To change the pattern length: Choose the number of steps in the pattern from the
Pattern Length pop-up menu.

•

To change the step rate: Choose the note value for steps in the pattern from the
Step Rate pop-up menu.

•

To change the playback mode: Click one of the Playback Mode buttons. The choices
are, from left to right:
•

Forward: Steps play from left to right.

•

Backward: Steps play from right to left.

•

Ping-Pong: Playback alternates between left to right and right to left.

•

Random: Steps play in an undetermined order.

•

To change the Swing percentage: Set the Swing percentage using the Swing value
slider, then click one of the Swing Note Value buttons to apply the swing value to
either 8th or 16th notes.

•

To change the key: Choose a musical key for the pattern from the Pattern Key popup menu.
By default, when you choose a key from the Pattern Key pop-up menu, steps are
transposed to the new key. You can also choose No Transpose from the menu. When
No Transpose is active, steps do not transpose when you choose a new key.

•

To change the scale: Choose a musical scale for the pattern from the Scale Quantize
pop-up menu.

•

To quantize unquantized notes to the scale: Click the Quantize (Q) button next to the
Scale Quantize pop-up menu.
After you choose the scale from the Scale Quantize pop-up menu, notes are
quantized and the Quantize (Q) button is inactive. The Quantize button becomes
active when you change the row assignment or Note value for a step to a note
outside the chosen scale. Click the Quantize button to reapply scale quantization to
those nonconforming notes.
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•

To set all rows in the pattern to use Legato mode: Select the Legato checkbox.
When selected, a 100% gate value is increased by one tick so that it overlaps slightly
with the following step. When triggering notes on a synthesizer or other software
instrument, this ensures that the steps trigger the legato behavior of the instrument.

•

To set the MIDI channel for all rows in the pattern: Set the MIDI channel from the
MIDI Channel value slider. Changes overwrite any existing settings, and are used
when new rows are created.

•

To set the automation mode for the pattern: Choose a mode from the Automation
Mode pop-up menu. Changes overwrite any existing settings, and are used when
new rows are created.The choices are:
•

Latch: Once set, the automation parameter value remains constant until a step
with a different value is triggered.

•

Slide: Interpolates between the last automation parameter value and the next one
to produce a smooth, gradual change.

Note: When Scale Quantize is set to Off, changing the pattern key transposes notes but
does not conform them to a Scale, unless No Transpose is selected in the Pattern Key
pop-up menu. (See above in “To change the key”.) When Scale Quantize is set to any other
setting, changing the key both transposes notes and conforms them to the chosen scale.

Edit row settings

1. In Logic Pro, click a row header to select the row.
2. In the Step Sequencer inspector, click the Row tab to show the Row inspector.

3. Do any of the following:
•

To change the row assignment:
•

For note rows: Choose a note value or drum sound from the Note submenu of the
Row Assignment pop-up menu.
When a pattern using a Drum Machine Designer patch is selected, the Row
Assignment pop-up menu shows the kit piece names rather than MIDI note names.

•
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For automation rows: Choose a parameter from the Automation submenu of the
Row Assignment pop-up menu.
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•

To add a custom name for the row: Select the Row Name field and enter the name for
the row. The row name is displayed on the row header, replacing the row assignment
label.

•

To change the step rate for the row: Choose a note value for steps in the row from
the Step Rate pop-up menu.

•

To change the playback mode for the row: Click one of the Playback Mode buttons.
The choices are, from left to right:
•

Forward: Steps play from left to right.

•

Backward: Steps play from right to left.

•

Ping-Pong: Playback alternates between left to right and right to left.

•

Random: Steps play in an undetermined order.

•

To change the loop start: Set the value in steps using the Loop Start value slider.

•

To change the loop end: Set the value in steps using the Loop End value slider.

•

To change the MIDI channel for the row: Set the channel number from the MIDI
Channel value slider.

•

To set the automation mode for the row: Choose a mode from the Automation Mode
pop-up menu. The choices are:
•

Latch: Once set, the automation parameter value remains constant until a step
with a different value is triggered.

•

Slide: Interpolates between the last set automation parameter value and the next,
to produce a smooth, gradual change.

Edit step settings

1. In Logic Pro, Shift-click a step to select it.
2. In the Step Sequencer inspector, click the Step tab to show the Step inspector.
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3. Do any of the following:
•

To turn the step on or off: Select the Step On/Off checkbox.

•

To change the note or sound for the step: Set the note or drum sound using the Note
value slider.

•

To change the velocity level for the step: Set the velocity value from 1 to 127 using
the Velocity value slider.

•

To change the gate amount for the step: Set the gate value from 1 to 127 using the
Gate value slider.

•

To change the note repeat value for the step: Set the value from 1 to 16 using the
Note Repeat value slider.

•

To change the Chance value for the step: Set the percentage using the Chance value
slider.

•

To change the offset value for the step: Set the percentage using the Start Offset
value slider.

•

To change the step rate for the step: Choose a note value for the step from the Step
Rate pop-up menu.

•

To skip the step during playback: Select the Skip checkbox.

•

To tie the step during playback: Select the Tie checkbox.

Customize the Step Sequencer interface
in Logic Pro

You can customize several aspects of Step Sequencer to suit the pattern you are working
on and the task you want to accomplish. You can zoom in and out to work in greater detail
or view a larger part of the step grid, show or hide step values, color rows and steps, and
reorder rows and subrows. You can also save the current pattern configuration as the
default template for the channel strip, and revert to the original default template for the
channel strip.

Zoom the step grid
•

In Logic Pro, do one of the following:

•

To zoom vertically: Drag the Vertical Zoom slider left or right.

•

To zoom horizontally: Click one of the Step Width buttons.
The Step Width buttons switch between minimum and maximum step widths. The
actual widths vary depending on the overall width of the Step Sequencer pane and
the pattern length. When the entire pattern is not visible in the step grid, page
overviews appear above the step grid. You can click the page overviews to move to
different parts of the pattern.

•
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Automatically zoom vertically: Click the Vertical Auto Zoom button to fill the available
vertical space.
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Show or hide step values

In Logic Pro, choose one of the following from View > Display Edit Mode Values in the Step
Sequencer menu bar:
•

To display step values only when editing a step: Choose Only When Editing Values.

•

To display step values for the selected row: Choose Always for Selected Row.

•

To display step values for all rows: Choose Always for All Rows.

Sort rows by type, name, and note assignment

You can sort the rows in a Step Sequencer pattern (region or cell) in several ways,
including by row type, note assignment, row name, or a combination of several of these.
For patterns using Drum Machine Designer patches, you can also sort by the order in which
the subtracks appear in the Tracks area. When sorting, you can choose to display rows in
either ascending or descending order.
In addition to reorganizing rows in the pattern, the sort options determine where rows
created using Learn (Add), Live Pattern Recording, or Step Record are added to the
pattern. The selected sort order is maintained until you manually move a row from the
sort order.
•

In Logic Pro, choose View > Sort Rows in the Step Sequencer menu bar, then choose
one of the following from the submenu:
•

By Type: Sorts rows by type without changing the current order within each type.
Types are ordered as follows: notes, Melodic, MIDI CC, pitchbend, channel pressure,
channel strip parameters, Smart Controls, plug-in parameters.

•

By Type and Note: Sorts all rows by type and then sorts note rows by their note
assignment. If you use this option with a pattern region or cell using a Drum Machine
Designer patch, Step Sequencer references the Input note for the drum pad when
sorting the row.

•

By Type and Name: Sorts all rows by type and then by row name. The row name is
the name displayed on the row header. By default, this is the row assignment unless
you have created a custom row name.

•

By Type and DMD Subtrack: Sorts all rows by type and then sorts rows for Drum
Machine Designer subtracks by the order in which the subtracks appear in the
Tracks area.

•

Ascending or Descending: These mutually exclusive choices determine the sort
direction regardless of which of the above options is selected.

Change row colors

1. In Logic Pro, click a row header to select the row.
2. Choose View > Show Row Colors from the Step Sequencer menu bar.
3. Select a color from the Color palette.

4. When you are finished, choose View > Hide Row Colors to close the Color palette.
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Reorder rows
•

In Logic Pro, click and hold a row header, then drag the row up or down.

Turn on MIDI Out for note rows and steps

When the MIDI Out button in the Step Sequencer menu bar is turned on, the note or drum
sound for a fixed note row sounds when you select the row, and the note or drum sound of
a step sounds when you edit the step using either the Note or Octave edit mode.
•

Click the MIDI Out button in the Step Sequencer menu bar to turn it on.
Click the MIDI Out button again to turn it off.

Save a pattern as the default template

You can save the current row assignments and view state of Step Sequencer as the default
template for new patterns created on the same track, or another track using the same
channel strip. This also determines the default view of the editor when the track is selected
and there is no region on the track.
•

In Logic Pro, with the pattern open in Step Sequencer, choose Functions > Store as
Default Pattern Template from the Step Sequencer menu bar.

Revert to the original default template

You can clear the pattern configuration data so that new patterns, and the default view,
appear as they did before the “Save as Row Default” option was used.
•
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In Logic Pro, with the pattern open in Step Sequencer, choose Functions > Revert to
Default Pattern Template from the Step Sequencer menu bar.
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Edit global project settings

Logic Pro global changes overview

In addition to working with individual tracks, regions, and channel strips, you can
manipulate different aspects of an overall project.
•

You can control the overall project volume using the Master Volume slider, the master
track, or the master channel strip.

•

You can tag different parts of a project, then select and edit those parts, using markers.

•

You can organize a project into sections, and quickly rearrange those sections, using
arrangement markers.

•

You can add time signature changes that affect the ruler and the Score Editor display.

•

You can add key signature changes that affect the Score Editor display.

•

You can control the project tempo by adding tempo changes, which affect project
playback.

•

You can transpose parts of a project to different keys. Transposition affects playback of
MIDI regions and Apple Loops in the project, and can also apply to audio regions.

•

You map notes not in a strict tempo with beats in the ruler using beat mapping.

Logic Pro features several ways to control aspects of the overall project. A set of global
tracks (including the Marker track, Arrangement track, Signature track, Tempo track, and
Transposition track) is available in the Tracks area and various editors. For video projects,
you can use the Movie track to view frames of the video while you work with the project.
You can also add effects to output or aux tracks, and automate effects and other
parameters on output or aux tracks, which can affect the overall project.
For information about automating project parameters, see Automation overview.
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Use the global tracks
Logic Pro global tracks overview

Logic Pro includes a set of global tracks that you can use to control different aspects of the
overall project. You can show global tracks in the Tracks area and in the time-based editors
(including the Audio Track Editor, Piano Roll Editor, and Step Editor). When you show the
global tracks, they appear below the ruler for that particular area.
By default, the following global tracks are available:
•

Arrangement track: Contains arrangement markers, which you can move, copy, and edit
to quickly reorganize a project. For more information, see Add arrangement markers and
Edit arrangement markers.

•

Tempo track: Contains the project tempo, and all tempo changes in the project. For
more information, see Tempo track overview.

•

Transposition track: Contains transposition events used to transpose parts of a project
up or down in pitch. Transposition affects MIDI regions and Apple Loops, and can also
affect audio regions. For more information, see Transposition overview.

•

Movie track: Displays frames of a QuickTime movie as thumbnails that are synchronized
with the ruler, for use in film scoring. Cuts in the movie can be detected automatically
and marked. For more information, see Use the Movie track.

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, the
following additional global tracks are available:
•

Marker track: Contains markers, which are used to label bar positions and parts of the
project. Their length, text, and color can be edited freely. For more information, see
Markers overview.

•

Signature track: Contains the basic time and key signatures of the project, along with
any signature changes. For more information, see Time and key signature overview.

•

Beat Mapping track: Use to adjust the tempo to follow recordings that do not follow
a strict tempo, without changing the rhythmic feel of the recordings. For more
information, see Beat mapping overview.

Show and hide global tracks in Logic Pro

Global tracks can be displayed in the Tracks area and in the time-based editors (including
the Audio Track Editor, Piano Roll Editor, and Step Editor). In each window, global tracks
appear below the ruler. You can select which global tracks to display, and resize and
reorder global tracks. By default, the Arrangement, Marker, Signature, and Tempo tracks
are visible when you show the global tracks.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can configure global tracks:
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Show or hide the global tracks

In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button

.

In the Tracks area, the Global Tracks button appears above the track headers. In the
editors, it appears on the left side of the editor.

Show or hide individual global tracks
In Logic Pro, do one of the following:
•

Choose Track > Global Tracks, then choose specific tracks from the submenu.

•

Control-click anywhere in the global tracks header area, then choose specific tracks
from the shortcut menu.

Choose which global tracks are displayed
In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Configure Global Tracks, then select the corresponding
checkboxes.

•

Control-click anywhere on a global track, choose Configure Global Tracks from the
shortcut menu, then select the corresponding checkboxes.

The tracks you select in the Global Tracks Configuration dialog only affect the
active window.
You can also assign and use any of the following Show/Hide key commands for each
individual ruler track: Marker, Transposition, Signature, Tempo, Beat Mapping, and
Movie. The key commands work directly, without having to open the Global Tracks
Configuration dialog.
Tip: Click the Enable All or Disable All buttons to show or hide all global tracks, or use
their corresponding key commands—Show All Global Tracks and Hide All Global Tracks.
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Resize and reorder global tracks in Logic Pro

You can resize the entire global tracks area, and resize global tracks individually. You can
also change the order of global tracks.

Resize the overall global tracks area
•

In Logic Pro, position the pointer over the line separating the global tracks from the
Tracks area (or editor) workspace, then drag up or down.

Resize individual global tracks
•

In Logic Pro, position the pointer over the lower dividing line for the global track, then
drag up or down.

Change the order of global tracks
•

In Logic Pro, grab the header of the global track, then drag up or down.

The display order of global tracks is saved independently for each window.
If the Protect buttons are visible (View > Configure Track Header > Protect Buttons), you
can prevent unintentional changes to individual global tracks by clicking the corresponding
Protect button.
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Work with markers
Logic Pro markers overview

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can use markers to tag different parts of a project, and quickly select the parts for
playback, arranging, and editing. Markers can help you organize your project, and also act
as storage areas for locator positions.
There are several ways to create and edit markers in Logic Pro. You can view and edit
markers in the following work areas:

•
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Marker track: Displays markers as rectangular sections. You can select, copy, move, or
resize markers in the Marker track.

726

•

Marker List: Displays marker names, bar position, and length information in a scrollable,
editable list.

•

Marker Text area and Marker Text window: Display marker text. You can type and edit
comments or other text that is saved with the marker.

For supported USB MIDI controllers, button controls on the device may be automatically
assigned to marker key commands. For more information, see Automatic MIDI controller
assignment.

Show the Marker track

In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button

.

If the Marker track is not visible, Control-click anywhere in the global tracks header area,
then choose Marker in the dialog that appears. For more information, see Show and hide
global tracks.

Open the Marker List in the main window
•

In Logic Pro, click the List Editors button
button.

in the control bar, then click the Marker

Open the Marker List as a separate window
In Logic Pro, do one of the following:
•

Choose Navigate > Open Marker List.

•

Drag the Marker List out of the main window.

Open the Marker Text window

In Logic Pro, do one of the following:
•

Choose Navigate > Open Marker Text.

•

Option-double-click any marker in the Marker track with the Pointer tool.

The Marker Text window is also available at the bottom of the Marker List, where it’s called
the Marker Text area.
Tip: Many marker-related commands can be accessed by Control-clicking in the Marker
track or Marker List, when the Right Mouse Button: Opens Shortcut Menu pop-up menu
option is chosen in the Logic Pro > Preferences > General > Editing pane.
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Add markers in Logic Pro

You can add a marker at any position in your project. When you create a marker, it can be
rounded to the nearest quarter note, to the nearest bar, or not rounded.
You can use the Create Marker key commands to add markers during playback.

Add a marker rounded to the nearest quarter note
In the Logic Pro Marker track, do one of the following:
•

Place the playhead at the position where you want to create a marker, then click the Add
Marker button .

•

Select the Pencil tool, then click where you want to add a marker.

Add a marker rounded to the nearest bar
In Logic Pro, do one of the following:
•

In the Marker List: Choose Options > Create.

•

In any workspace: Use the Create Marker key command.

A marker is added at the playhead position (if the playhead is aligned with a bar) or at the
next bar position (if the playhead is between two bars). If a marker already exists at a bar
position (or up to a quarter note before or after it), no new marker is created.
The length of the marker automatically extends to the start point of the next marker, or to
the end of the project or folder, if no ensuing markers exist.

Add a marker without rounding

In Logic Pro, do one of the following:
•

In the Marker List: Choose Options > Create Without Rounding.

•

In any workspace: Use the Create Marker without rounding key command.

Add a marker at a rounded playhead position
•

In the Logic Pro Marker List, click the Add Marker button

.

Add a marker and set its position
•
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In the Logic Pro Marker List, click in the Marker List area with the Pencil tool, then enter
a position in the Position field.
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Add markers at the positions of all selected regions
In Logic Pro, do one of the following:
•

In the Marker track: Click and hold the word Marker, then choose Create Markers From
Regions from the shortcut menu.

•

In any working area: Use the Create Marker by Regions key command.
Markers created in these ways are automatically assigned the names, bar position,
length, and color of the regions they are derived from.

Add a marker corresponding to the cycle area
•

In Logic Pro, drag the cycle area to the Marker track.

Edit markers in Logic Pro

You can copy and move markers, adjust their lengths, and color them. You can also change
the appearance of marker text in the Marker Text window (or area).

Copy a marker

In Logic Pro, do one of the following:
•

In the Marker track: Option-drag the marker.
You can also copy a marker, move the playhead to the position where you want to paste
the copy, and then paste it.
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•

In the Marker List: Use the Copy (Command-C) and Paste (Command-V) commands.

Move a marker to a new position

In Logic Pro, do one of the following:
•

In the Marker track: Drag the marker left or right to a new position.

•

In the Marker List: Use the pointer as a slider in the Position field, or double-click a
position value and enter a new value.

•

In the ruler: Command-drag a marker left or right to a new position.

Note: The increments by which markers can be moved in the Marker track depend on the
horizontal zoom level of the Tracks area and the Snap pop-up menu setting. Watch the help
tag for precise feedback on movements. If you need to adjust markers in finer increments,
use the Marker List.

Protect the position of selected markers

There are times when you may want to protect markers from being moved. Logic Pro has a
feature that preserves the absolute time position of events.
•

In Logic Pro, choose Options > Lock SMPTE Position in the Marker List (or use the
corresponding key command).

This command locks (fixes) the time position of markers, and a lock symbol is displayed at
the beginning of the marker name.

These markers always retain their absolute time position: if the project tempo is changed,
the bar positions will change to keep the markers at the same time positions.
Tip: You can also lock and unlock the time positions of markers from the Region menu in
the Tracks area, and the Functions menu in the Piano Roll Editor and Step Editor, if you turn
on the display of global tracks.
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Unprotect the position of selected markers
•

In Logic Pro, choose Options > Unlock SMPTE Position in the Marker List (or use the
corresponding key command).

Note: You cannot unlock the time position of scene markers. See Use movie scene markers.

Change the length of a marker

In Logic Pro, do one of the following:
•

In the Marker track: Place the pointer over the left or right edge of the marker. When the
pointer changes to a Resize pointer, drag the marker edge to the new position.

•

In the Marker List: Use the pointer as a slider in the Position field, or double-click a
position value and enter a new value.

Markers cannot overlap. The edge of one marker cannot be dragged over another marker.
Tip: If you set the length of a marker to one (1) tick, the marker automatically extends to
the start of the next marker.

Trim the start or end point of a marker
•

To trim the start point: In the Logic Pro Marker track, press and hold Shift–Command
and click the marker at the location where you want to trim the start point.

•

To trim the end point: In the Logic Pro Marker track, press and hold Command and click
the marker at the location where you want to trim the end point.

Adjust a marker to fit the cycle area
•

In Logic Pro, drag the cycle area onto a marker in the Marker track.

Dragging the cycle area in the ruler is limited to either horizontal or vertical movements.
This ensures that you do not accidentally:
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•

Move the cycle when creating markers (by dragging the cycle into the lower third of the
ruler or into the Marker track)

•

Create markers when moving the cycle
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Tip: When you press and hold Shift after clicking and holding the cycle, the cycle can
be moved horizontally, and then dragged to a marker in one go. When you press and hold
Shift before clicking the cycle, the nearest cycle border is set to the clicked position.

Color a marker

1. In Logic Pro, choose View > Show Colors to open the Color palette.
2. Select the marker in the Marker track, then click a color in the Color palette.
When you select a dark color, the marker text is automatically shown in an inverse color.

Change the appearance of marker text

1. In Logic Pro, double-click the marker text you want to change.
2. Click the Font button in either the Marker Text window or the Marker Text area.

3. Choose settings in the Font window.

The text in the Marker Text window changes to match the settings. The text in the
Marker track is not affected.
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Rename markers in Logic Pro

Newly created markers (except markers derived from regions) are named “Marker
<number>,” where “<number>” reflects the order in which the marker appears along the
ruler (resulting in “Marker 1,” “Marker 2,” and so on). This numbering depends on the order
of all markers in the project, including markers that have been renamed.
Markers can be renamed in the Marker track, the Marker Text area of the Marker List, the
Marker Text window, or the ruler. The length of the name displayed in the Marker track and
Marker List depends on available screen space, or the position of the marker that follows.

Create and name a marker

In Logic Pro, hold Control-Option-Command while clicking the desired position in the
Marker track, enter the marker name in the field that appears, then press Return.
If the Marker track isn’t visible, you can create and name a marker by Control-ShiftCommand-double-clicking the ruler.

Rename a marker in the Marker track
1. In Logic Pro, do one of the following:
•

Double-click the marker.

•

Click the marker with the Text tool.

•

Choose Options > Marker > Rename Marker.

2. Enter the new name.

Edit a marker name in the Marker List
1. In Logic Pro, do one of the following:
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•

Select the marker name and click the Marker Text Edit button.

•

Select the marker name and double-click in the Marker Text area.

•

Double-click the marker in the Marker Name column.
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2. Enter the new marker name in the Marker Text area.

Rename a marker in the ruler

If the Marker track is hidden, you can rename markers directly in the ruler.
•

In Logic Pro, Command-double-click a marker, then enter a new marker name.

Edit a marker name in the Marker Text window

1. In Logic Pro, select the marker in the Marker List.
2. Do one of the following:
•

Click the Marker Text Edit button.

•

Double-click in the Marker Text area.

3. Enter the new marker name in the Marker Text area.
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The first portion of text in the window is used as the marker name.

All text below the first paragraph is also displayed in the Marker track, if space allows.
(You can resize the Marker track to view all text.) This space can be used for musical or
technical notes, for example. In this scenario, the marker color appears only in the title line,
with the remaining text displayed white on gray.
Note: If you use the Return key to create paragraphs in the Marker Text area, the first
paragraph of the text is displayed in a separate title line (of the marker) in the Marker track.

Navigate using markers in Logic Pro

You can navigate through your project using markers. This is useful when you want
to quickly jump to, and edit, regions or events at a specific position in your project,
for example.

Move the playhead to a marker

In Logic Pro, do one of the following:
•

Press and hold Option and click the marker in the Marker track.

•

Use the Go to Marker Number 1 to 20 key commands (20 different commands).
The marker numbers in these commands refer to the (serial) order of all markers in the
project. By default, when you create a marker, the name shows the marker number.

•

Use the Go to Marker key command to open a window where you can enter any marker
number.
The playhead moves to the beginning of the chosen marker.

Move to the next or previous marker
•

In Logic Pro, use the Go to Previous Marker and Go to Next Marker key commands.

The locators are set to the beginning and end points of the selected marker.
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Create a cycle from a marker

In Logic Pro, do one of the following:
•

Drag the marker into the upper part of the ruler.

This action sets the cycle area to the position and length of the marker.
•

Select the marker, then use one of the following key commands:
•

Set Locators by Marker and Enable Cycle

•

Set Locators by Previous Marker and Enable Cycle

•

Set Locators by Next Marker and Enable Cycle

Use marker sets in Logic Pro

You can create marker sets, and choose between different marker sets in a project. Only
markers that are part of the current set appear in the Marker track and Marker List. When
you create new markers, they become part of the current marker set.
Creating different marker sets lets you use markers for different purposes (such as
identifying sections, adding performance notes, and preserving production information) in
the same project.

Create a marker set
•

In the Logic Pro Marker List, choose New Set from the Marker Set pop-up menu.

When you create a new marker set, previously added markers are no longer visible in
the Marker track or Marker List. When you create new markers, they become part of the
current marker set.

Rename a marker set

1. In Logic Pro, select the marker set, then choose Rename Set from the Marker Set popup menu.
2. Enter a new name for the marker set, then click OK.

Choose a marker set
•

In the Logic Pro Marker List, choose a set from the Marker Set pop-up menu.

When you choose a marker set, only markers that are part of the set appear in the Marker
track and Marker List.

Delete a marker set
•
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In Logic Pro, select the marker set, then choose Delete Set from the Marker Set pop-up
menu.
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Set marker display in the Logic Pro Marker List

There are two display options for marker position and length in the Marker List. You can
switch between bar positions and time positions, and between actual (relative) length and
(absolute) display of the marker’s end position (shown as a bar position).

Switch the marker display between bar positions and time positions
•

In Logic Pro, choose View > Show Event Position and Length as Time.

Switch the marker length display between relative length and the marker’s
absolute end bar position
•

In Logic Pro, choose View > Length as Absolute Position.

Use marker information from audio files in Logic Pro

When you record or bounce an audio file, the current Marker List is added to the file. In
some situations, you may want to import marker information from an audio file that was
recorded in a different project.

Import marker information from an audio file
•

In Logic Pro, choose Navigate > Other > Import Marker from Audio File.

You can also export the current Marker List within the borders of any selected audio region
to an audio file. However, you should first remove any marker information that exists in the
audio file.

Remove marker information from an audio file
•

In Logic Pro, choose Navigate > Other > Remove Marker from Audio File.

You can then export the current marker information to the audio file.

Export marker information to an audio file
•

In Logic Pro, choose Navigate > Other > Export Marker to Audio File.

Delete markers in Logic Pro

You can delete markers at any time. After you delete a marker, it no longer appears in the
Marker track, Marker List, or Marker Text window.

Delete markers

In the Logic Pro Marker track or Marker List, do one of the following:
Select the markers, then choose Edit > Delete (or press Delete).
Control-click the marker, then choose Delete Marker.
Click the markers with the Eraser tool.
See Markers overview for information on how to show the Marker track and Marker List.
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Build a project with arrangement markers
Add arrangement markers in Logic Pro

You can add arrangement markers to a project to create different sections, such as an
intro, verse, and chorus, and then move the sections in the Tracks area to quickly rearrange
the project. Arrangement markers can be particularly useful when you have added some
material (recordings, loops, or media files) to the project and want to try out different
arrangements.
By default, arrangement markers are eight bars long. The first arrangement marker begins
at the start of the project. Each additional arrangement marker you add starts at the end of
the previous one, with no space between. Arrangement markers are most useful if you add
them to every section of the project, so that you can rearrange the entire project.
You add and edit arrangement markers in the arrangement track, which appears at the top
of the Tracks area. When you add an arrangement marker, it is eight bars long. You can
resize it to cover the section of the project you want it to include, and rename it to reflect
its place in the project.
Note: If you add arrangement markers to a project, then add a Drummer track, Drummer
regions for each arrangement marker are added, with the length and name of the regions
corresponding to the markers.

Show the arrangement track

In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button

.

Add an arrangement marker
•

In Logic Pro, click the Add Marker button (+) in the arrangement track.

The arrangement marker appears at the start of the project, or at the end of the last
existing arrangement marker.

Resize an arrangement marker
•
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In Logic Pro, drag the right edge of the arrangement marker left or right.
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Rename an arrangement marker

In Logic Pro, do one of the following:
•

Click the name of the selected arrangement marker, then choose a name from the
shortcut menu.

•

Double-click the marker (except on the name), then enter a new name.

Edit arrangement markers in Logic Pro

After you add arrangement markers to the arrangement track, you can use them to
rearrange your project. You can select arrangement markers, move and copy them, replace
them, and delete them from the arrangement track.
When you move or copy an arrangement marker, all of the regions in that section of the
project are moved or copied, including the markers on every track in the section, and the
automation points on every automation curve in the section. If any tracks in the project are
locked, you should unlock them before editing the arrangement markers in the project.
You can also disconnect arrangement markers from the project so that you can move,
resize, or delete them without affecting the underlying content.

Select an arrangement marker
•

In the Logic Pro arrangement track, click the arrangement marker.

To select multiple arrangement markers, Shift-click them.
You can’t select noncontiguous arrangement markers.

Move an arrangement marker
•

In Logic Pro, drag the arrangement marker to a new position in the arrangement track.

When you move an arrangement marker between two existing arrangement markers, the
marker to the right moves right to make room for the new marker. When you drag one
arrangement marker directly over another one in the arrangement track, the two markers
switch places (all their content is swapped).

Copy an arrangement marker
•

In Logic Pro, Option-drag the arrangement marker to the position where you want to
place the copy.

When you place the copy between two existing arrangement markers, the marker to the
right moves right to make room for the copied marker.

Replace an arrangement marker
•

In Logic Pro, Command-drag an arrangement marker directly over another one.

Delete an arrangement marker together with its regions
•

In Logic Pro, select the arrangement marker, then press Delete to delete the regions
in the Tracks area below the arrangement marker so it is empty. Press Delete again to
delete the arrangement marker.

Important: In case you accidentally delete regions that you want to keep, use Undo to
restore them.
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When you move or delete an arrangement marker, the sections to the right move left to fill
the deleted section, closing up the empty space.

Disconnect arrangement markers
•

In Logic Pro, Control-click the title Arrangement in the arrangement track header, then
choose Suspend Content Connection from the shortcut menu that appears.
To re-connect arrangement markers, choose Suspend Content Connection again.

Work with time and key signatures
Logic Pro time and key signature overview

Time and key signatures are global events that affect all tracks in a project. When you
create a new project, you can set the time and key signature in the Project Chooser. You
can view time and key signatures in the Signature track, the Signature List, and the Score
Editor, and add and edit signature changes in a variety of ways.
The initial time signature and key signature are project properties. For information on
setting the initial time and key signature, see Project properties overview.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
the Signature track and Signature List are available so that you can create time and key
signature changes.

Time signatures

Time signatures determine the number of beats in each bar (as shown in the ruler), and so
define the editing grid in the Tracks area and the time-based editors (including the Audio
Track Editor, Piano Roll Editor, and Step Editor). Time signature changes do not affect the
playback of audio or MIDI regions.
In addition to the ruler, time signatures affect the score display. All functions that rely on
the chosen time signature and bar positions (such as MIDI metronome click or Transform
window functions) are affected if bar positions are used to restrict a function to a certain
part of the project.

Key signatures

When you create a project, the key signature defaults to C major, unless you choose a
different key signature. The initial key signature affects the playback of Apple Loops in the
project. Key signature changes affect the display of MIDI notes in the Score Editor, but do
not have an effect on MIDI playback.
You can add any number of key signature changes to a project. When you add a key
signature change, it changes the key from the insertion point forward, until the next key
signature change is reached.
You can store up to nine signature sets, which are reflected in the Signature track,
Signature List, and Signature window.
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Show the Signature track

In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button

.

By default, the global Arrangement, Marker, Signature, and Tempo tracks are visible when
you show the global tracks in the Tracks area (or an editor). If the Signature track is not
visible, Control-click anywhere in the global tracks header area, then select Signature in
the dialog that appears. For more information, see Show and hide global tracks.
Note: The Signature track must be visible—and must not be protected—in order to select
and copy signatures.

Open the Signature List

In Logic Pro, do one of the following:
•

Click the List Editors button

, then click Signature.

•

Shift-double-click in the Signature track.

The Signature List displays time and key signatures in a numerical list, and also displays
global score symbols such as repeat signs, double bar lines, and so on.

Create time signature changes in Logic Pro

When you create a new project, by default it has one time signature that lasts for the
entire project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add time signature changes to a project in the Signature List, Signature track, or
Score Editor.

Create a time signature change

In Logic Pro, do one of the following:
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•

In the Signature List, make sure Time is selected in the Signature pop-up menu, click
the Add Signature button , then edit the values in the Time Signature dialog.

•

In the Score Editor, drag the time signature symbol from the Part box to the target time
position.

•

Click the target time position in the Signature track with the Pencil tool, then edit the
values in the Time Signature dialog.
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•

You can enter beat groups for composite time signatures in the Beat Grouping field.
For example, to create a group of two beats, followed by another group of two, and
then a group of three, you enter “223.” The number of beats in a bar is the sum of
these groups, so 7 in this example. The sum is displayed as the numerator in the
Score Editor unless you have selected the Print Composite Signature checkbox. Beat
Grouping affects the way in which notes are beamed together regardless of whether
Print Composite Signature is selected.

•

You can also change the automatic beaming in normal time signatures. In 4/4-time
“1+1+1+1” produces four beamed groups (one for every beat), instead of the two
groups displayed as a default.

•

Select the Print Composite Signature checkbox to show the breakdown of the beat
grouping in the Score Editor. This is useful for indicating how a beat count should be
split. For example, a 5/4 meter could have a beat grouping of 3/4 and 2/4 or 2/4 and 3/4.

•

Select the Hide Signature checkbox to hide a time signature change in the published
score. The signature is still displayed in the Score Editor, but dimmed, and is not
included in the calculation of spacing between notes and symbols. As a result,
signatures may overlap notes in the Score Editor but not in the published score. This
can be used for notating cadenza-like passages, which contain more notes than
would normally fit the time signature.

Create key signature changes in Logic Pro

When you create a new project, by default it has one key signature that lasts for the
entire project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add key signature changes to a project in the Signature List, Signature track, or
Score Editor.

Create a key signature change

In Logic Pro, do one of the following:
•

Click the word Time in the Signature List and choose Key from the pop-up menu, then
click the Add Signature button .

•

Click a position in the Signature track’s key signature area with the Pencil tool, then
choose a key in the Key Signature dialog.
You may need to expand the Signature track until you see separate areas for time and
key signature changes.
In the Key Signature dialog, you can enable the use of double flats and sharps by
deselecting the “Disable bb, x” checkbox.

•
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In the Score Editor, double-click a staff between the clef and time signature, then
choose a key in the Key Signature dialog. You can also drag the key signature from the
Part box to the target time position.
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Edit time and key signatures in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can select time and key signatures in the Signature track, Signature List, or Score
Editor by clicking them, or Shift-clicking to select multiple signatures.
In the Signature track, you can also select multiple signatures in conjunction with regions.
This is useful when you want to copy or move complete parts of a song (along with
signature changes). You can select parts of the project to copy or move using the Edit >
Select All Inside Locators command.
Note: When a marquee selection is active, using this command sets the marquee selection
to match the locators.
You can copy time signatures and key signatures in the Signature track or Signature List.
You can also copy all time and key signatures from one project to another. Subsequent
signatures are inserted at bar positions that correspond to their original distance from the
first copied signature.

Edit the time signature

In Logic Pro, do one of the following:
•

In the Signature track (or the Score Editor), double-click a time or key signature, then
edit the signature in the (Time or Key) Signature dialog.

•

For projects with a single time signature, choose a new signature from the LCD.

•

For projects with multiple time signatures, move the playhead onto or to the right of the
time signature you want to change, then choose a new signature from the LCD. The last
time signature event to the left of the playhead changes to the new value.

Move a signature
•

In the Logic Pro Signature track, select a time or key signature and drag it to a new
position.

Split a signature
•

In the Logic Pro Signature track, use the Scissors tool to cut bars. For example, to
divide one 5/4 measure into a 3/4 and a 2/4 measure, cut the measure at the fourth
beat.
If you make a cut in the middle of a bar—in a section where the time signature doesn’t
change—two corresponding shorter measures are inserted, with the original time
signature resuming after the cut.

Merge signatures
•

In the Logic Pro Signature track, Shift-click the signatures with the Glue tool.

Copy signatures in a project using drag and drop
•
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Copy signatures in a project using the Clipboard

1. In Logic Pro, select the time and key signatures in the Signature track or Signature List.
2. Choose Edit > Copy (or press Command-C).
3. Do one of the following:
•

In the Signature track: Move the playhead to the insert position, then choose Edit >
Paste (or press Command-V).

•

In the Signature List: Choose Edit > Paste (or press Command-V), enter a bar value
in the Position field, then press Return.

Copy signatures between projects

1. In Logic Pro, select signatures in the Signature track or Signature List.
2. Choose Edit > Copy (or press Command-C).
All signature changes of the source project are copied to the Clipboard.
3. Switch to the target project.
4. Make the Signature track or Signature List active, then choose Edit > Paste (or press
Command-V).
The copied meter changes are pasted into the target project.

Delete signatures in Logic Pro

You can delete time and key signature changes in a project, but you can’t delete the initial
time and key signature.

Delete a signature

In Logic Pro, do one of the following:
•

Select the signature in the Signature track, Signature List, or Score Editor, then choose
Edit > Delete (or press Delete).
Tip: To erase all time signature events, select a signature, choose Edit > Select
Similar Objects, then press Delete.

•

Click the signature with the Eraser tool in the Signature track, Signature List, or Score
Editor.

Use signature sets in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create signature sets, and choose between different signature sets in a project.
Only signatures that are part of the current set appear in the Signature track and Signature
List. When you create a new signature, it becomes part of the current signature set.

Create a signature set
•

In the Logic Pro Signature List, choose New Set from the Signature Set pop-up menu.

When you create a new signature set, previously added signature changes are no
longer visible in the Signature track or Signature List. When you create new signatures,
they become part of the current signature set. The initial time and key signature are
always visible.
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Rename a signature set

1. In Logic Pro, select the signature set, then choose Rename Set from the Signature Set
pop-up menu.
2. Enter a new name for the signature set, then click OK.

Choose a signature set
•

In the Logic Pro Signature List, choose a set from the Signature Set pop-up menu.

When you choose a signature set, only signature changes that are part of the set appear in
the Signature track and Signature List.

Delete a signature set
•

In Logic Pro, select the signature set, then choose Delete Set from the Signature Set
pop-up menu.

Work with tempo
Logic Pro tempo overview

Every project has a tempo, which is expressed in beats per minute (bpm). You can set the
tempo in the Project Chooser when you create a project, and change it later while you are
working. You can set the project tempo in the LCD in the control bar. By default, the tempo
for new projects is 120 bpm.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add tempo changes and control the tempo of a Logic Pro project in a
variety of ways:
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•

Use Smart Tempo to conform audio recordings and imported audio files to the project
tempo, or adapt the project tempo to an audio file.

•

Make quick tempo changes, edit beat markers, and make other tempo edits in the Smart
Tempo Editor.

•

Create tempo changes using the Tempo track or the Tempo List.

•

Use tempo sets to switch between different tempo changes.

•

Match audio recordings to the project tempo, or match the tempo to an audio region.

•

Record tempo changes in Logic Pro.

•

Use the Tempo Operations window and Tempo Interpreter window for more complex
control of the project tempo.

•

Control tempo changes using the tempo fader in the Environment.
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Create tempo changes with the Tempo track
Logic Pro tempo track overview
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add and edit tempo changes in the Tempo track. The Tempo track is available in
the Tracks area, Piano Roll Editor, Step Editor, and Score Editor.

In the Tempo track, tempo changes are represented by tempo points. You create tempo
changes by adding tempo points and editing their values. You can expand the Tempo track
to give yourself more room to work, and adjust the range of values for the Tempo track.
The Tempo track also determines the relationship between incoming timecode and the
current playhead position, for projects using timecode.

Show the Tempo track

In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button

.

If the Tempo track is not visible, Control-click anywhere in the global tracks header area,
then select Tempo in the dialog than appears. For more information, see Show and hide
global tracks.

Adjust the range of the Tempo track
In Logic Pro, do one of the following:
•
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•

Double-click either value and enter a numerical value in the field.

Add and edit tempo points in Logic Pro
In the Tempo track, tempo changes appear as tempo points. You create tempo changes
by adding tempo points, then editing their values. You can move and copy tempo points,
create tempo curves, and edit tempo points in other ways. You can also apply smoothing to
tempo points or replace selected tempo points by the average tempo.

Add a tempo point

In Logic Pro, do one of the following:
•

Click the target time position with the Pointer tool.

•

Click the target time position with the Pencil tool.

When using the Pencil tool, watch the help tag, and don’t release the mouse button until
it shows the intended tempo and position. No help tag appears when you double-click
with the Pointer tool.
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•

To set the tempo numerically, press and hold Control-Option-Command and click the
target time position, enter the bpm value in the field that appears, then press Return.

Change the value of a tempo point
•

In Logic Pro, drag the tempo point up or down. A help tag displays the tempo value.
You can also drag the line connecting two tempo points, changing the values of both
tempo points.
To change the value in finer increments, press and hold Shift while dragging a tempo
point.

Note: To prevent unintentional changes, tempo points are restricted to either vertical or
horizontal movement. You can change either the value of a tempo change event or the
position of a tempo change event, but not both at once.

Snap tempo points to a beat value
•

In the header of the Logic Pro Tempo Track choose Tempo > Snap, then choose a beat
value from the submenu.

Create a constant tempo across multiple tempo points
•

In Logic Pro, select multiple tempo points, Control-click the selected tempo points, then
choose Replace By Average from the shortcut menu.

Apply smoothing to selected tempo points

Smoothing reduces the number of tempo changes while maintaining the length (duration)
of the performance, maintaining its average tempo.
•

In Logic Pro, select the tempo points, then choose Tempo > Apply Smoothing to
Selected Points from the pop-up menu in the Tempo Track header.

Replace selected tempo points by the average tempo

Using this function, the selected tempo points are replaced by their average value (the
weighted average) so that the length (duration) of the performance is maintained.
•
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In Logic Pro, select the tempo points, then choose Tempo > Replace Selected Points by
Average Tempo from the pop-up menu in the Tempo Track header.
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Delete a tempo point

In Logic Pro, do one of the following:
•

Select the tempo point, by either clicking it or the line to the right of it, then choose
Edit > Delete (or press the Delete key).

•

Double-click the tempo point with the Pointer tool.

•

Click the tempo point with the Eraser tool.

Move and copy tempo points in Logic Pro
You can move and copy tempo points in a number of ways:

Move a tempo point in time
•

In Logic Pro, drag the tempo point left or right.

Move the selected tempo point to the current playhead position
•

In Logic Pro, use the Move Region/Event to Playhead Position (Pickup Clock) key
command.

Move the selected tempo point, replacing the previous one
•

In Logic Pro, Control-click a tempo point, then choose Extend Left from the shortcut
menu.
The selected tempo point is moved left to the position of the previous one, which it
replaces.

Note: This menu item is not available for the first tempo point.

Copy a tempo point

In Logic Pro, do one of the following:
•

Press and hold Option while dragging a tempo point.

•

Use the standard Copy and Paste operations (via the Edit menu or the corresponding
key command). The tempo point is pasted at the playhead position.
If you copy multiple tempo points using Copy and Paste, the first tempo point is pasted
at the playhead position.

Copy or move multiple tempo points
•

In Logic Pro, Shift-click or drag to select (while pressing and holding Control), then drag
all tempo points to the target position.

Note: Any tempo points at the target positions are replaced by the moved or copied ones.

Copy tempo changes from a passage

1. In Logic Pro, set the locators to the passage containing the correct tempo change.
2. Choose Edit > Select Inside Locators.
Note: When a marquee selection is active, using this key command sets the marquee
selection to match the locators.
3. Copy the tempo points to the Clipboard (Command-C).
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4. Deselect all tempo points (by clicking the background).
5. Paste the tempo points from the Clipboard (Command-V).
6. By default, the first tempo point is pasted at the current playhead position, but this can
be changed. A Position field appears alongside the first pasted tempo point, allowing
you to alter the bar position. If the first tempo point is not at the start of the in the
passage, be sure to alter the bar number, and leave the beat, sub-beat, and frame or
tick values unaltered.
7. Press Return.
The copied tempo changes are selected, and you can undo the operation if necessary.

Create tempo curves in the Logic Pro Tempo track
You can create a continuous transition, or tempo curve, between two tempi using a
tempo curve.

Create a tempo curve between two tempi
1. In Logic Pro, select the two tempo points.

2. While you click and hold, drag the tip of the right angle line (the corner) above or below
the second tempo point.

A curve or diagonal line results (a Move Curve Node help tag is shown), which can be
dragged—horizontally or vertically—to alter the curve shape. The process is similar to
drawing track automation curves with the pointer.

Change the snap value of a tempo curve
•

In Logic Pro, choose a value from the Snap pop-up menu in the Tempo track to define
the number of tempo changes that are actually performed when using curves.

When the value in the Snap pop-up menu in the Tempo track is set to 1/16, there are
four tempo changes per quarter note; 1/1 generates only one tempo change per bar,
which results in a more abrupt transition. You can define a different snap value for each
tempo curve.

Delete a tempo curve
•
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Use the Tempo List
Logic Pro Tempo List overview
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can view and edit tempo changes in the Tempo List. You can open the Tempo List in
the main window, or as a separate window.

Open the Tempo List in the main window
In Logic Pro, click the List Editors button

in the control bar, then click Tempo.

Open the Tempo List as a separate window
•

In Logic Pro, drag the Tempo List out from the main window.

Add tempo changes in the Logic Pro Tempo List
The layout and functions of the Tempo List are similar to those of the Event List. Below
are the most important Tempo List operations. For information on general Event List
operations, see Event List overview.
Creating a tempo curve can lead to the creation of numerous tempo change events. These
tempo change events can be viewed in the Tempo List.
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Create a tempo change in the Tempo List

1. In Logic Pro, move the playhead to the position where you want to add the tempo
change event.
2. In the Logic Pro Tempo List, click the Add Tempo button

.

A tempo change event (which uses the current project tempo value) appears. You can
alter the value in the Tempo column.

Change the position of a tempo change
•

In Logic Pro, drag any of the position numbers up or down, or double-click in the
Position or SMPTE column and enter a new position.

Move the selected tempo change event to the current playhead position
•

In Logic Pro, use the Move Region/Event to Playhead Position (Pickup Clock) key
command.

Display additional events in the Tempo List
•

In the Logic Pro Tempo List, click the Additional Info button.
All tempo change events, including those located on the tempo curve, are displayed in
the Tempo List.

Delete a tempo change event in the Tempo List
In Logic Pro, do one of the following:
•

Click the tempo change event with the Eraser tool.

•

Select the tempo change event, then choose Edit > Delete (or press Delete).

Set the granularity level for tempo curves
•

In Logic Pro, choose Options > Granularity from the local Tempo List menu, then choose
the note value from the submenu.

Use tempo sets in Logic Pro
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create tempo sets, and choose between different tempo sets in a project. Only
tempo changes that are part of the current set appear in the Tempo track and Tempo List.
When you create new tempo changes, they become part of the current tempo set.

Create a tempo set
•

In the Logic Pro Tempo List, choose New Set from the Tempo Set pop-up menu.

When you create a new tempo set, previously added tempo changes are no longer visible
in the Tempo track or Tempo List. When you create new tempo changes, they become part
of the current tempo set. The initial tempo is always visible.

Rename a tempo set

1. In Logic Pro, select the tempo set, then choose Rename Set from the Tempo Set pop-up
menu.
2. Enter a new name for the tempo set, then click OK.
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Choose a tempo set
•

In the Logic Pro Tempo List, choose a set from the Tempo Set pop-up menu.

When you choose a tempo set, only tempo changes that are part of the set appear in the
Tempo track and Tempo List.

Delete a tempo set
•

In Logic Pro, select the tempo set, then choose Delete Set from the Tempo Set pop-up
menu.

Use Smart Tempo
Logic Pro Smart Tempo overview
Smart Tempo brings powerful new tempo analysis and editing capabilities to Logic Pro.
With Smart Tempo, you can record a performance without the metronome and have
Logic Pro adapt the project tempo to match the tempo of the recording, or keep the project
tempo and flex the recording to match it. Smart Tempo also makes it easy to create remixes
using audio files and MIDI regions with different tempos that all conform to the project
tempo, or adapt the project tempo to the tempo of an imported audio file or MIDI region.

To use Smart Tempo, you choose the Project Tempo mode to set the overall tempo
behavior for the project, and use the Flex & Follow setting for individual audio regions to
set how they interact with the chosen Project Tempo mode.
Unlike audio quantization, which identifies transient peaks in an audio file, Smart Tempo
analysis places beat markers based on the musical tempo detection of an audio file. When
used with complex musical material, Smart Tempo analysis can deliver better results
(particularly when Flex & Follow is set to Bars or Beats) than using audio quantization.
Though transients can be edited destructively in the Audio File Editor, you edit Smart
Tempo beat markers and other tempo information in the Smart Tempo Editor.
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You can also use Smart Tempo with MIDI regions in a project. MIDI regions always follow
the project tempo, and so behave similarly to flexed audio files with the Flex & Follow
region setting set to On. Because MIDI regions have no source audio file, the Smart Tempo
analysis and any edits you make in the Smart Tempo Editor are saved directly to the MIDI
regions and stored with the project.

The Project Tempo mode

The Project Tempo mode determines whether the project tempo is maintained, or adapts
to the tempo of audio recordings, imported audio files, and MIDI regions. You choose the
Project Tempo mode in the LCD Tempo display.
The Project Tempo modes are:
•

Keep Project Tempo: Maintains the project tempo when you record audio or MIDI, or
when you import audio files. Audio regions for which the Flex & Follow parameter is
not set to Off conform to the project tempo. Choose this mode to work as in previous
versions of Logic Pro.

•

Adapt Project Tempo: Alters the project tempo to match the tempo of recorded or
imported regions. When you move or copy regions, the tempo information of the regions
moves with them. Choose this mode for free recording without the metronome or other
tempo reference, or when you want the project tempo to follow region edits.

•

Automatic: Logic Pro chooses the appropriate behavior (Keep or Adapt) based on
whether or not a musical tempo reference (such as the metronome or another region) is
present. When a musical tempo reference is present, the project tempo is maintained.
When no musical tempo reference is present, the project tempo adapts to match the
tempo of recorded or added material.

In the Tempo track, the Tempo curve changes color depending on the Project Tempo mode
and tempo analysis:
•

Blue: The project tempo is unchanged.

•

Orange: The project tempo will be defined by the tempo of a new recording.

•

Red: The existing project tempo will be replaced, affecting existing regions.

Each Project Tempo mode is useful for different workflows. For detailed information about
Project Tempo modes, see Choose the Project Tempo mode. You can also set the Project
Tempo mode in the Smart Tempo project settings.

The Flex & Follow audio region parameter

When Flex is enabled for a track, the Flex & Follow pop-up menu is available in the Region
inspector for audio regions, replacing the Flex checkbox in earlier versions of Logic Pro.
You use the Flex & Follow setting to enable Flex for a region, to control whether it follows
the project tempo, and to set whether it additionally uses Smart Tempo beat markers at the
bar or beat level.
The choices for the Flex & Follow parameter are:
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•

Off: The region is not Flex enabled, and does not follow changes to the project tempo.

•

On: The region is Flex enabled, and so follows any manual Flex edits. It also follows
changes to the project tempo.
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•

Bars (On + Align Bars): The region is Flex enabled, and follows project tempo changes.
Additionally, Smart Tempo beat markers are used to conform the region to the project
tempo at every downbeat (bar).

•

Beats (On + Align Bars and Beats): The region is Flex enabled, and follows project
tempo changes. Additionally, Smart Tempo beat markers are used to conform the region
to the project tempo at every beat.

There is no Flex & Follow setting for MIDI regions. MIDI regions always follow the project
tempo, similarly to flexed audio regions with Flex & Follow set to on.
For information about choosing Flex & Follow settings, see Choose the Flex & Follow
setting. You can change the default settings for the Flex & Follow region parameter for new
recordings and imported audio files in the Smart Tempo project settings, and set whether
they are trimmed to the downbeat.

Musical tempo reference

When using Smart Tempo in Adapt mode (or when Auto uses Adapt behavior), the results
depend on whether a musical tempo reference is present in the part of the project to which
you are recording or adding a file. A musical tempo reference exists when the metronome
is active, when audio, MIDI, or Drummer regions are present in the part of the project
where you are working, or when Cycle mode is turned on.
In most cases, when you hear any musical material while recording, a musical tempo
reference is present. If you do not hear any material, no musical tempo reference
is present.
Tip: To avoid having a musical tempo reference while recording, solo the track you are
recording to before recording.

Use Smart Tempo for free recording

When you make a recording in an empty project with the metronome off, and with the
Project Tempo mode set to Adapt (or Auto), the project tempo adapts to the tempo of
the new recording. The Tempo track shows the detected tempo, including any tempo
variations, which appear as red lines in the new region during recording. After recording,
you can turn on the metronome and hear how closely it follows the tempo of the recording.
When the Flex & Follow parameter for a new audio recording is set to On, the recorded
audio region follows tempo changes but individual beats are not flexed. If individual beats
do not match the tempo closely enough, you can set the Flex & Follow setting to Bars (On +
Align Bars) or Beats (On + Align Bars and Beats) so the audio region conforms at either the
bar or beat level.
When you make additional audio recordings, they conform to the project tempo, as long as
their Flex & Follow parameter is not set to Off. You can set the Flex & Follow setting to Bars
or Bars and Beats to conform them at the bar or beat level, or simply delete them and make
a new recording. When you add audio files to the project, they also conform to the project
tempo, as long as their Flex & Follow parameter is not set to Off. You can change the Flex
& Follow setting to Bars or Bars and Beats to conform them at the bar or beat level, so they
are in sync with the first recording and with each other. Additional MIDI recordings always
follow the project tempo.
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Use Smart Tempo with remixes

When creating a remix, you often work by combining files recorded at different tempos,
and that may contain tempo changes. With the Project Tempo mode set to Keep, imported
files do not affect the project tempo.
Imported audio files conform to the project tempo, as long as their Flex & Follow parameter
is not set to Off. By setting the Flex & Follow parameter for the audio regions to Bars or
Bars and Beats, beat markers are additionally used to conform them at the bar or beat
level. The audio regions from the files can be transposed as needed so they play back in
the same key. Any audio regions with their Flex & Follow parameter set to Off keep their
original tempo, and do not conform to the project tempo. MIDI regions always follow the
project tempo.

Use Smart Tempo with existing projects

You can use Smart Tempo with existing projects, including projects created in an earlier
version of Logic Pro. For most projects, the workflow described in Use Smart Tempo
with multitrack audio is recommended, because it allows you to define which audio files
contribute to the Smart Tempo analysis, and allows the analysis results to be shared
between all audio files. In cases where you do not want the Smart Tempo analysis results
to be shared across audio files, and in which the project contains a single region having a
clearly audible and consistent rhythmic pattern throughout (for example, a stereo recording
of the overhead mics of a drum kit), you can use the following workflow:
After opening the project, make sure the Project Tempo mode is set to Keep, and open
the audio file corresponding to the rhythmic region in the Smart Tempo Editor. Turn on
the Smart Tempo Editor metronome and audition the file to verify that the Smart Tempo
analysis is correct, making any needed edits. After verifying and correcting the region,
choose Apply Region Tempo to Project Tempo from the Edit pop-up menu (or Control-click
the region in the Tracks area and choose the corresponding command from the shortcut
menu). In the dialog, make sure both the “Align downbeat to nearest project downbeat” and
“Maintain relative position of all other regions” checkboxes are selected, then click Apply.
This writes the analyzed tempo from the selected region to the Tempo track, aligns the
selected region to the downbeat, and maintains the relative positions of the other regions
(as well as other data such as automation curves) to the analyzed region. Using this
workflow, tempo-synced regions (such as Apple Loops or Drummer regions) and effects
added to the project also conform to the project tempo.

Choose the Project Tempo mode in Logic Pro
The Project Tempo mode determines whether the project tempo is maintained, or adapts
to the tempo of recordings and imported audio or MIDI regions. Each mode is useful for
different situations, as described in the following sections:

Keep Project Tempo mode

In Keep Project Tempo mode, Logic Pro maintains the project tempo. When you make a
recording or move regions to a different time position, the project tempo does not change.
You can use Logic Pro functions, including the metronome and Cycle mode, the same as
with earlier versions of Logic Pro. Audio recordings and imported audio files conform to the
project tempo as long as their Flex & Follow parameter is set to On, On + Align Bars, or On
+ Align Bars and Beats.
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Adapt Project Tempo mode

In Adapt Project Tempo mode, Logic Pro adapts the project tempo to a recording or an
imported audio or MIDI file. When you choose Adapt mode in the Tempo display, the Tempo
track opens so you can see how the project tempo changes after recording, importing
files, or moving regions in the Tracks area. When you make a recording in an empty project
with the metronome off, the project tempo adapts to the recording. During recording, red
lines in the newly recorded region show detected tempo changes. If the metronome is
on, it is used as the tempo reference and the project tempo does not change. The project
tempo does not adapt to subsequent recordings in that part of the project, because the
previous recording provides the tempo reference. If a recording extends beyond that part
of the project, the project tempo adapts to the portion of the region extending beyond the
borders of the first recording.
The project tempo does change to adapt to imported audio or MIDI files. When you move
recorded or imported regions to a different time position, the project tempo at their original
position “follows” them to the new position.
Adapt mode is mutually exclusive with Cycle mode. If the Cycle mode is on when you
choose Adapt in the Tempo display, it is turned off, and the recording starts at the
beginning of the Cycle region.
Important: In general, Adapt Project Tempo mode should be used only temporarily when
making a free recording, when adding a file you want the project tempo to conform to, or
when you specifically want the Tempo track to follow region edits you are making. Because
it results in changes to the project tempo, it should be used with some caution.

Automatic mode

In Automatic (Auto) mode, Logic Pro determines whether to use Keep or Adapt behavior
based on whether a musical tempo reference is present in the part of the project to
which you record or add audio or MIDI. When a musical tempo reference exists, Logic Pro
maintains the project tempo (Keep mode behavior). When no musical tempo reference
exists, Logic Pro adapts the project tempo to the tempo of audio recordings or imported
audio files (Adapt mode behavior).
When you make an initial recording in an empty project with Auto mode active, the
metronome state determines which behavior is used. If the metronome is on, the project
tempo is preserved as in previous versions of Logic Pro (Keep mode behavior). If the
metronome is off, the project tempo changes to match the recording (Adapt mode
behavior). In Adapt mode behavior, the project tempo does not change for any subsequent
recordings you add in the same range as the first recording, or if you add or move files in
that range, because a musical tempo reference now exists in that part of the project.
When Auto mode uses Keep behavior, there is no conflict with Cycle mode. When Auto
mode uses Adapt behavior and the Cycle mode is on, it is turned off, and the recording
starts from the beginning of the Cycle region.
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Choose the Project Tempo mode

In the Logic Pro LCD, click the middle of the Tempo display, then do one of the following:

•

To maintain the project tempo: Choose Keep Project Tempo from the pop-up menu.

•

To adapt the project tempo to the tempo of a recording or imported audio file: Choose
Adapt Project Tempo from the pop-up menu.

•

To have Logic Pro choose the project tempo behavior: Choose Automatic Mode from the
pop-up menu.

You can set the default Project Tempo mode for a project in the Smart Tempo
project settings.

Apply the tempo of a region to the project

In some cases you may want to have the project tempo follow the tempo of a region,
regardless of the Project Tempo mode.
1. In Logic Pro, Control-click the region in the Tracks area, then choose Tempo > Apply
Region Tempo to Project Tempo from the shortcut menu. In the Apply Region Tempo to
Project Tempo dialog, you can also select the following options:
•

To align the region downbeat with the closest project downbeat: Select the “Align
downbeat to nearest project downbeat” checkbox.

•

To move all other regions so that they keep the same relative position: Select the
“Maintain relative position of all other regions” checkbox.

2. Click Apply.
The Apply Region Tempo to Project Tempo command is also available in the Tempo menu,
and in the Edit menu of the Smart Tempo Editor.

Move the detected downbeat to align with the beat

When a region is moved so that the region start no longer aligns with a beat on the ruler,
you can move the first detected downbeat in the region to the nearest beat. In Logic Pro,
do one of the following:
•

Choose Edit > Move > To Beat from the menu bar.

•

Control-click the region, then choose Move > Move to Beat from the shortcut menu.

Edit the sole region in a part of the project

If a region is the sole region in a part of a project, trimming, moving, or deleting the region
affects the project tempo if the Project Tempo mode is set to Adapt (or Auto with Adapt
behavior).
Trimming the region also trims the corresponding project tempo events.
Moving the region also moves the corresponding project tempo events.
Deleting the region also deletes the corresponding project tempo events.
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Choose the Flex & Follow setting in Logic Pro
On Flex enabled audio tracks, the Flex & Follow pop-up menu replaces the Flex checkbox
for audio regions in the Region inspector. You use the Flex & Follow setting to enable
Flex Time for a region, to set whether it follows the project tempo, and to set whether it
additionally uses Smart Tempo beat markers at the bar or beat level.

You can edit Smart Tempo beat markers in the Smart Tempo Editor. If the Flex & Follow
pop-up menu is set to Bars or Beats, edits in the Smart Tempo Editor immediately update
in the region displayed in the Tracks area (similar to how transient markers update when an
audio region is quantized).
When you open a project created in an earlier version of Logic Pro, audio regions in
projects for which the Flex checkbox was selected (turned on) have their Flex & Follow
parameter set to On. Audio regions for which the Flex checkbox is unselected (turned off)
have their Flex & Follow parameter set to Off.

Choose the Flex & Follow setting for an audio region
1. In Logic Pro, select the audio region.

2. In the Region inspector, select one of the following from the Flex & Follow pop-up menu:
•

Off: The region does not follow changes to the project tempo, and is not Flex
enabled.

•

On: The region is Flex enabled, so it follows any manual Flex edits. It also follows any
changes to the project tempo.

•

Bars (On + Align Bars): The region is Flex enabled, and Smart Tempo beat markers
are used to conform the region to the project tempo at every downbeat (bar).
Because the region is conformed to each bar, the 1/1 setting is not available in the
Quantize menu.

•

Beats (On + Align Bars and Beats): The region is Flex enabled, and Smart Tempo
beat markers are used to conform the region to the project tempo at every beat.
Because the region is conformed to each (1/4-note) beat, the 1/1, 1/2, 1/4 settings
are not available in the Quantize menu.

You can set the default Flex & Follow settings for audio recordings and imported audio files
in the Smart Tempo project settings.
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Use Smart Tempo with multitrack audio files in Logic Pro
You can use Smart Tempo analysis with multitrack audio recordings, both with recordings
you make in Logic Pro and when you add a set of multitrack audio files to a project. For
multitrack audio recordings, Smart Tempo analyzes the multitrack audio files together
and applies the analysis results to all of them. By default, all the multitrack audio files
contribute to the analysis, but you can exclude audio files from the analysis while still
having the analysis results applied to them.
To work with Smart Tempo, Logic Pro organizes multitrack audio recordings into a
Smart Tempo multitrack set. You can create a Smart Tempo multitrack set in any of the
following ways:
•

Create a multitrack audio recording in Logic Pro.

•

Drag a set of multitrack audio files to the Tracks area.

•

Create a Smart Tempo multitrack set from existing audio regions.

When you create or edit a Smart Tempo multitrack set, Logic Pro does the following:
•

Creates a downmix of the audio files in the multitrack set.

•

Analyzes the downmix using Smart Tempo analysis.

•

Writes the results of the Smart Tempo analysis to all the audio files in the multitrack set.

In addition, you can use Smart Tempo to create a group including all the tracks in the
multitrack set, so they can be edited together.
The downmix is created from the multitrack audio files for which the Contributes to
Analysis checkbox is selected in the Smart Tempo Multitrack window. The Smart Tempo
analysis results for the downmix are applied to all files in the Smart Tempo multitrack set.
The Smart Tempo analysis for the downmix can be viewed and edited in the Smart Tempo
Editor, and the edits applied to all files in the multitrack set. For information, see Work in
the Smart Tempo Editor.
To combine all the tracks into a multitrack set group for editing, select “Create matching
Edit group when creating Smart Tempo Multitrack Set” in File > Project Settings >
Smart Tempo.
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Create a multitrack audio recording in Logic Pro

1. Before recording in Logic Pro, make sure that at least one of the following conditions
is true:
•

The Project Tempo mode is set to Adapt.

•

The Flex & Follow region parameter is set to either On + Align Bars or On + Align
Beats.

2. Record to multiple audio tracks following the steps described in Record to multiple
audio tracks simultaneously.

Add multitrack audio files to the Tracks area

You can add a set of multitrack files to the Tracks area and have them analyzed together as
a multitrack set. The multitrack files should be files originally played and recorded together
at the same tempo, and have the same start point.
1. In Logic Pro, drag a set of multitrack audio files to the Tracks area.
2. In the Add Selected Files to Tracks dialog, ensure that either the “Create new tracks”
button or the “Use existing tracks” button is selected.
3. Select the “All selected files are stems from one project” checkbox, then click OK.

Create a Smart Tempo multitrack set from selected audio regions

You can select audio regions in the Tracks area to use in a Smart Tempo multitrack set. The
regions should be from files originally played and recorded together at the same tempo,
and that have the same start point.
1. In Logic Pro, select the audio regions you want to include in the Smart Tempo multitrack
set.
2. Do one of the following:
•

Choose Edit > Tempo > Create Smart Tempo Multitrack Set.

•

Control-click one of the selected regions and choose Tempo > Create Smart Tempo
Multitrack Set from the shortcut menu.

3. In the Smart Tempo Multitrack window, ensure that all the files you want to use in the
set are listed in the File list, then click Analyze.
You can view which audio files are included in the multitrack set, remove files from the
multitrack set, and make other edits in the Smart Tempo Multitrack window.

Edit a Smart Tempo multitrack set

You can add and remove audio files from a multitrack set and change which audio files
contribute to the Smart Tempo analysis. You can also break up the multitrack set if you
want to start over.
Limiting which audio files contribute to the analysis can be useful when you want the
Smart Tempo analysis results to apply to some files, but those files might not meaningfully
contribute to the analysis. For example, if you have a multitrack band recording with a
synth effect track, you may want the track to conform to the analysis results but not be
used to create the downmix, because it might confuse the analysis.
1. In Logic Pro, Control-click one or more audio regions used in the set.
2. Choose Tempo > Edit Smart Tempo Multitrack Set from the shortcut menu.
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The Smart Tempo Multitrack window opens, showing the files currently used in the
Smart Tempo multitrack set.

3. Do any of the following:
•

To add an audio file to the multitrack set: Close the Smart Tempo Multitrack Set
window, select the files you want to include, then open the window again.

•

To delete an audio file from the multitrack set: Select the row for the audio file and
press the Delete or Backspace key.

•

To set which audio files contribute to the Smart Tempo multitrack analysis: Deselect
the checkboxes for any audio files you want to exclude.

•

To break up the multitrack set: Click Break Up Set.

4. To start Smart Tempo multitrack analysis with your changes, click Analyze.

Work in the Logic Pro Smart Tempo Editor
In the Smart Tempo Editor, you can view and edit Smart Tempo analysis results, including
beat markers and other tempo information. After you record an audio or MIDI region or
import a file using Smart Tempo, you can refine the tempo analysis and correct any tempo
detection errors to define the musical intent more accurately. When working in Adapt
mode, tempo and time signature changes are transferred to the project tempo and time
signature tracks.
When you open the Smart Tempo Editor, the audio file or MIDI region is displayed along
with the tempo analysis results. The entire audio file or MIDI region is shown in the
overview, with the visible area of the file highlighted by a colored rectangle. The main
display shows the visible part of the file, with the detected beats indicated by orange beat
markers. Beat markers for downbeats are displayed more prominently than for other beats.
You can preview the file or region; make quick tempo, beat, and timing adjustments; or
make more complex edits to the tempo information for a single beat, a selection, or the
entire file or region. The tempo analysis, and any edits you make in the Smart Tempo Editor,
are stored in the audio file, so you can still access them if you copy the file or use it in
another project. For MIDI regions, the analysis and edits are stored with the project.
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You can make adjustments in two different ways: by playing the file or selection and
tapping the D and T keys on your computer keyboard to indicate downbeats (D) and beats
(T), or by editing beat markers in the main display. When tapping in a selection, only the
downbeats or beats in the selected area are changed.
Each beat marker has several handles, each with a different function. Holding the pointer
over a handle displays a tag showing the handle’s function. You can make a selection
before clicking a handle; if there is no selection, Logic Pro makes a default selection of the
beats affected by the edit. Depending on the selection, not all editing functions may be
available.
You can view any of the audio files in a Smart Tempo multitrack set, including the downmix,
in the Smart Tempo Editor. Edits to the Smart Tempo analysis results of the downmix are
applied to all audio files in the multitrack set.

The Smart Tempo Editor includes the following controls and working areas:
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•

Edit pop-up menu: Choose tempo actions including adapting the project tempo to a
region, maintaining the relative position of all regions, reanalyzing the file or region,
and removing tempo edits made to the file. When an audio file used in a Smart Tempo
multitrack set is selected, you can also open the Smart Tempo Multitrack window.

•

View pop-up menu: Choose view options, including scroll in play and showing an
overlay of the tempo curve. When an audio file used in a Smart Tempo multitrack set is
selected, you can also choose to view the downmix waveform.

•

Catch button: Turn on Catch mode, so that the visible part of the display follows the
playhead during playback.

•

Filename display: Shows the name of the file or region displayed in the Smart Tempo
Editor. When an audio file that is part of a Smart Tempo multitrack set is selected, the
Filename display becomes a pop-up menu where you can select any file used in the set,
including the downmix file.

•

Bar and Beat display: Shows the current playhead position in bars and beats.

•

Tempo display: Shows the detected file tempo; if multiple tempi are detected, shows as
Variable. You can select the tempo and enter a new file tempo.

•

Double Tempo and Half Tempo buttons: Use to double or halve the tempo of the audio
file, or of the current selection.

•

Signature display: Shows the detected time signature at the playhead position. To
change the time signature, click the display and choose a new time signature from the
pop-up menu. Editing the signature changes the time signature for the complete file,
removing any signature changes.

•

Tempo pop-up menu: Shows whether the file has a constant or variable tempo. By
choosing the alternative option, you can trigger a new analysis of the audio file.

•

Metronome button: Turn the metronome on or off.
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•

Volume slider: Adjust the relative volume between the metronome and the audio file.

•

Preview button: Start or stop playback of the audio file.

•

Cycle button: Turn Cycle mode on or off. If a selection exists, the Cycle region matches
the selection. If no selection exists, Cycle mode extends the length of the audio file.

•

Horizontal Zoom slider: Drag left or right to show a smaller part of the file or region in
more detail, or show a larger part of the file or region in less detail. Click left or right on
the arrows to change the zoom level.

•

Overview: Shows the entire audio file or MIDI region. The visible area of the file appears
highlighted in a colored rectangle.

•

Main display: Shows the visible area of the audio file or MIDI region, with markers
showing the detected beats and downbeats.

Note: Edits you make in the Smart Tempo Editor do not alter the audio data in the source
audio file, but only the tempo information Logic Pro uses to conform (flex) the file to the
project tempo.

Open the Smart Tempo Editor

In Logic Pro, do one of the following:
•

Control-click a region in the Tracks area, then choose Tempo > Show/Hide Smart Tempo
Editor from the shortcut menu.

•

Select a region in the Tracks area, then choose Window > Open Smart Tempo Editor.

•

Use the Show/Hide Smart Tempo Editor key command.

Start or stop file or region playback
•

In Logic Pro, click the Preview button (with the speaker icon).

Scroll and zoom in the Smart Tempo Editor
In Logic Pro, do any of the following:
•

Press the Left Arrow to scroll left.

•

Press the Right Arrow to scroll right.

•

Press the Up Arrow to zoom out so that the entire audio file or MIDI region is visible.

•

Press the Down Arrow to zoom in incrementally until the pointer is centered in the main
display.

Set downbeats and beats

1. In Logic Pro, start playback of the file or region, or of the current selection.
2. While the file is playing, press the D key on your computer keyboard to indicate
downbeats, and press the T key to indicate beats.
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Change the time signature

In Logic Pro, do one of the following:
•

To change the time signature of the audio file or selection: Click the Signature display,
then choose a new signature from the pop-up menu.

•

To add a time signature change at a downbeat: Place the pointer next to a downbeat
in the main display, then choose a new signature from the Signature pop-up menu that
appears next to the downbeat.

Changing the signature replaces any signature stored in the audio file.

Double or halve the file or region tempo

In Logic Pro, you can change the tempo of the audio file (if there is no selection) or the
current selection:
•

To double the tempo: Click the X2 button in the Tempo display.

•

To halve the tempo: Click the /2 button in the Tempo display.

Edit beat markers

When you place the pointer over a beat marker, a set of circular handles appears along the
length of the beat marker. Dragging the pointer vertically over each handle shows a tag
describing the function of that handle. Press and hold the Command key while dragging a
beat marker to have it snap to significant analysis points.

•

To set a beat as the downbeat: Place the pointer over the beat marker and click the Set
Downbeat handle.
Setting a beat as the downbeat also moves the region, unless the project tempo is set
to Keep and Flex & Follow is set to Off. This handle is not available for beat markers
already on a downbeat.

•

To move an individual beat: Click and hold the Move Marker handle and drag the beat
marker to a new position.

•

To scale beat markers in a selection: Make a selection, click and hold the Scale
Selection handle for a beat marker in the selection, then drag to scale the selected beat
markers.
If you drag a Scale Selection handle when there is no selection, Logic Pro automatically
selects the bar in which the beat marker is located. If the beat marker is a downbeat,
the preceding and following bars are selected.

•
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To scale preceding beat markers and move following beat markers: Make a selection,
click and hold the Scale Left, Move Right handle for a beat marker, then drag the beat
marker. The selected area is scaled, and beats to the right of the selected area are
moved. If you click and hold the handle on a downbeat, the preceding bar and the
following part of the file are selected. This is useful for correcting tempo detection
where the music temporarily slows down or speeds up.
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•

To scale all beat markers in the file or region (or in a selection): Click and hold the Scale
All handle for a beat marker, then drag the beat marker.

•

To move all beat markers in the file or region (or in a selection) by the same amount:
Click and hold the Move All handle for a beat marker, then drag the beat marker left or
right.

Select sections of the file or region
•

To select the section from the start of the file or region to the pointer, press Shift-Left
Arrow.

•

To select the section from the pointer to the end of the file or region, press Shift-Right
Arrow.

Apply tempo actions to the file or region

You can choose the following tempo actions from the Edit menu in the Smart Tempo Editor
control bar:
•

Apply Region Tempo to Project Tempo: Applies the tempo of the selected region to
the project tempo. In the Apply Region Tempo to Project Tempo dialog you can select
additional options:
•

Align downbeat to nearest project downbeat: Aligns the region downbeat to the
nearest downbeat in the project, regardless of Project Tempo mode.

•

Maintain relative positions of all other regions: When selected, maintains the
temporal relationship between regions in the project when applying the region tempo
to the project tempo. This can be particularly useful in Adapt mode.

•

Apply Project Tempo to Region and Downbeat: Keeps the project tempo, adapts the
region tempo to the project tempo, and aligns the region downbeat with the project.

•

Maintain Time Position of All Regions: When selected, maintains the temporal
relationship between regions in the project when making edits in the Smart Tempo
Editor. This can be particularly useful in Adapt mode.

•

Revert Changes: Discard all edits in the current Smart Tempo Editor session (the initial
tempo analysis is preserved).

•

Analyze Again: Perform a new tempo analysis of the file or region or the current
selection.
If no musical tempo reference is present, the tempo, downbeat, and beat positions are
reanalyzed. If a musical tempo reference is present, only beat positions are analyzed,
not the tempo or downbeat.
For MIDI regions, this command reanalyzes the region based on the original positions of
MIDI note events when the file was first recorded, first analyzed, or for projects created
in earlier versions of LP, the first time you open the region in the Smart Tempo Editor.

•

Remove Original Recording Tempo and Analyze Again: Delete the existing tempo and
perform a new tempo analysis.
Use this feature with caution. In most cases it is best to keep the original file tempo.
The primary use of this feature is to remove original recorded tempo data that you know
is invalid–for example, for a recording without a metronome in Keep mode.
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For MIDI regions, this command reanalyzes the region based on the current positions of
MIDI note events, replacing the original positions of MIDI note events when the region
was first recorded, first analyzed, or for projects created in earlier versions of LP, the
first time you open the region in the Smart Tempo Editor.
•

Revert to Original Recording Tempo: Delete the tempo analysis, preserving the tempo of
the original recording.

•

Edit Smart Tempo Multitrack Set: Opens the Smart Tempo Multitrack Set window
showing the current multitrack set.

•

Set Average Tempo for Selection: Sets a single average tempo for the selected area of
the file or region.

•

Set Average Tempo within each Bar: Sets an average tempo within each bar of the
selected area of the file or region.

•

Extend First Tempo in Selection to Beginning: Sets the part of the region preceding the
selection to use the first (leftmost) tempo in the selection.

•

Extend Last Tempo in Selection to End: Sets the part of the region following the
selection to use the last (rightmost) tempo in the selection.

•

Scroll in Play: After the playhead reaches the center of the display, it stays centered,
while the display scrolls as the file or region plays.

When you edit beats or other tempo information in the Smart Tempo Editor, the edits are
saved when you save the project.

Match audio regions to the Logic Pro project tempo

When the Project Type in File > Project Settings > General is set to “Use musical grid”, the
length of imported audio regions is linked to the project tempo. If you add a tempo change
at a particular ruler position, the length of regions changes, starting from that position. The
playback speed of the imported regions doesn’t change, but all existing MIDI regions that
were in sync with audio regions will now be out of sync. Audio regions that are lengthened
(by increasing the tempo) may overlap subsequent regions on the same track, with the
result that the overlapped parts of the regions are not heard. All audio region loop lengths
(set with the Loop parameter in the Region inspector) change, resulting in irregular loops
and rhythmic conflicts between tracks.
The following audio files can automatically match the project tempo and will follow any
tempo changes made in the global Tempo track.
•

Audio recordings made in Logic Pro (7.0 and later)
Note: If you drag a file recorded in one project to another project using the Finder, the
file does not follow the project tempo. However, files copied between two projects are
able to follow the project tempo if the Flex & Follow region parameter is not set to Off.

•

Apple Loops

•

Audio regions on tracks for which Flex Time is turned on

•

Audio bounces made in Logic Pro (7.0 and later)
Note: Bounce files can only follow the project tempo if the Add resulting files to Project
Audio Browser option is selected in the Bounce dialog when the file is bounced or
exported. As with audio recordings, the bounce conforms to the project tempo if the
Flex & Follow region parameter is not set to Off.
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•

Audio files exported from Logic Pro (7.0 and later)
Note: Exported files can only follow the project tempo if the Add resulting files to
Project Audio Browser option is selected in the Export dialog when the file is bounced
or exported. As with audio recordings, the bounce conforms to the project tempo if the
Flex & Follow region parameter is not set to Off.

Audio files that follow the project tempo (and first key signature) are flagged with the
Follow Tempo symbol, in both the Tracks area and the Project Audio Browser.

All other imported audio files require adjustment of either the region or the project tempo.
You can set an audio region to follow the project tempo, or add the region to the Apple
Loop library as an Apple Loop. For information about creating Apple Loops, see Create your
own Apple Loops.

Make audio recordings follow the project tempo
•

In Logic Pro, select the audio region in the Tracks area, then choose On from the Flex &
Follow pop-up menu in the Region inspector.

Match the tempo to an audio region in Logic Pro

You can adjust the project’s tempo to match the tempo of an audio region. The length of
the region remains constant, and the tempo changes to match the region.
For example, imagine you have imported a one-bar drum loop that doesn’t match your
project tempo. The drum loop adapts to your project tempo, becoming shorter or longer
than one bar. You can set the project tempo to match the original tempo of the drum loop,
using the Adjust Tempo using Region Length and Locators command.
The Adjust Tempo using Region Length and Locators command adjusts the project tempo
by creating a tempo change event at the start point of the selected audio region. This
ensures that the length of the selected audio region matches exactly the distance between
the locators.

Match the project tempo to an audio region

1. In the Logic Pro Tracks area, select the audio region to which you want to match the
project tempo.
2. Control-click the Cycle button in the control bar, and make sure the Auto Set Locators
by Region Selection option is not selected.
3. Set the left and right locator positions in the ruler.
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The locator range should closely match the length of the region—usually to the nearest
bar.

4. Choose Edit > Tempo > Adjust Tempo using Region Length and Locators.
A dialog asks if you want to change the tempo of the entire project, or create a tempo
change for the section of the project occupied by the selected region.
5. Do one of the following:
•

To adjust the tempo of the complete project to the audio region: Click Globally.

•

To create a tempo change that spans the length of the audio region: Click Create.

The project tempo is recalculated to conform with the audio length (and locators).

Use audio file tempo information in Logic Pro

When you record or bounce an audio file, the current Tempo List is added to the file. You
can then use the saved tempo information for importing or exporting purposes.
In some situations, you may want to import tempo information from an audio file that was
recorded in a different project. The tempo of the selected audio file is used in place of
the project tempo, but only within the borders (start and end points) of that file in the
Tracks area.
For example, if you have an audio recording containing slight tempo variations, how do you
get it to follow the tempo of your current project? First, beat map the track to associate
beat in the region with the project tempo (see Beat mapping overview), then remove the
tempo information from the audio file. As a final step, export the current project tempo
information to the audio file.

Import tempo information from an audio file
•

In Logic Pro, choose Edit > Tempo > Apply Region Tempo to Project Tempo.

You can also export the current tempo value within the borders (start and end points)
of a selected audio file in the Tracks area. However, you should first remove any tempo
information that exists in the audio file.
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Remove tempo information from an audio file
•

In Logic Pro, choose Edit > Tempo > Remove Tempo Information from Audio File.

You can then export the current tempo information to the audio file.

Export tempo information to an audio file
•

In Logic Pro, choose Edit > Tempo > Write Project Tempo to Audio File.

Record tempo changes in Logic Pro

All tempo changes made when Logic Pro is in record mode are stored as tempo change
events on the Tempo track. You can record tempo changes with an external MIDI controller,
the Environment tempo fader, or external synchronization signals. You can edit recorded
tempo change events in the Tempo track or using one of the tempo editors—Tempo List,
Tempo Operations window, Tempo Interpreter window, or tempo fader.

Turn on tempo change recording

1. In Logic Pro, open the Recording project settings by doing one of the following:
•

Choose File > Project Settings > Recording, or use the Open Recording Project
Settings key command, Option-Asterisk (*).

•

Control-click the Record button
Settings from the pop-up menu.

in the control bar, then choose Recording

2. Select the “Allow tempo change recording” checkbox.
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Use Tempo Operations
Logic Pro Tempo Operations overview
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can use the Tempo Operations window for greater control of the project tempo.
You use Tempo Operations to create tempo changes, and edit existing tempo changes. The
window automatically displays the area you’ve selected for editing. Changes are displayed
graphically in real time, as the tempo curve is processed, so you can see the results of
your edits.

Open the Tempo Operations window
•

In Logic Pro, choose Edit > Tempo > Tempo Operations (or use the Open Tempo
Operations key command).

Add tempo changes in the Logic Pro Tempo Operations window
You can create tempo changes in the Tempo Operations window using the following
operations:
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•

Create Tempo Curve: Lets you create numerous tempo change events with just a few
parameters, and provides a smooth overall change in tempo.

•

Create Constant Tempo: Creates a constant tempo in the selected area. The default
setting assigns an average tempo for the selected project section (based on existing
tempo change events).

•

Scale Existing Tempo: Alters existing tempo changes proportionally (scales them).
This allows you to speed up an entire project section, without losing the relationships
between any subsequent tempo changes within the area. Scaling is done by percentage.

•

Stretch Existing Tempo Curve: Stretches or compresses an existing tempo curve.

•

Thin Out Existing Tempo Changes: Reduces the number of tempo changes in the
selected area.
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•

Randomize Tempo: Adds random tempo changes based on the parameters you specify.

•

Round Existing Tempo Changes: Rounds existing tempo changes in the specified range
to whole BPM or 1/10 BPM units.

Create a tempo change in the Tempo Operations window

1. In the Logic Pro Tempo Operations window, choose Operation > Create Tempo Curve.
2. Use the Position or Time field to define the area that the tempo change should take
place across: the left field sets the curve start point and the right field, the curve end
point.
3. Enter start and end tempi in the Tempo line.
4. Select a curve type.
Three kinds of tempo curves are available from the Curve Type pop-up menu. Each of
these offers a Curvature parameter (the field to the right of the Curve Type pop-up
menu), which determines if the tempo should speed up or slow down, depending on
whether positive or negative curvature values are entered.
5. Adjust the Curvature parameter.
6. Alter the concentration of graphical tempo change events with the Density parameter.
Values of 1/8 and finer should be used only if really necessary (with very slow or fast
tempo changes, for example). Don’t select a resolution higher than 1/8 or finer, just to
make the curve look smoother. This results in an unnecessary amount of processing,
and the creation of more tempo change events than are needed.
As you change the values, the displayed tempo curve (which is calculated from the
tempo settings you’ve made) is shown in red.
Note: The “Continue with new Tempo” checkbox determines whether the original tempo
resumes after the tempo curve ends (unselected), or the new tempo (the last tempo
change event in the curve) is maintained (selected).
7. Click Apply when you’re done.

Create a constant tempo curve
•

In the Logic Pro Tempo Operations window, choose Operation > Create Tempo Curve,
then do one of the following:
•

To remove all tempo variations between two points without changing the SMPTE
time for the rightmost position: Click the Apply button.

•

To retain the new tempo or return to the initial tempo: Select the “Continue with new
Tempo” checkbox.

Scale tempo changes

1. In the Logic Pro Tempo Operations window, choose Operation > Scale Existing Tempo
Changes.
2. Adjust the scaling percentage using the Scale value slider.
Positive percentage values speed up sections, and negative ones slow them down.
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Stretch tempo curves

1. In the Logic Pro Tempo Operations window, choose Operation > Stretch Existing Tempo
Changes.
2. Define the start point for tempo changes using the Position or Time parameter.
3. Do one of the following:
•

Enter the new end point of the tempo curve as a bar position or SMPTE value.

•

Set a Stretch value for the tempo curve (as a percentage).

Thin out (reduce) tempo changes

In the Logic Pro Tempo Operations window, choose Operation > Thin Out Existing
Tempo Changes.
The Position or Time field defines the start and end points of the area to be processed.
Density determines the number of tempo change events that remain per bar after
processing. You can select values between one tempo change event per bar (1/1) and 32
per bar (1/32).

Randomize tempo changes

1. In the Logic Pro Tempo Operations window, choose Operation > Randomize Tempo.
2. Define the start and end points for tempo changes using the Position or Time
parameter.
3. Determine the amount of deviation from the current tempo, in beats per minute (bpm)
using the Randomize parameter.
4. Define how often the new tempo change events occur using the Density parameter. You
can select values between one per bar (1/1), and 32 times per bar (1/32).

Use the Logic Pro Tempo Interpreter

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can use the controls in the Tempo Interpreter window for greater control of the
project tempo.
You use the Tap Tempo command to generate tempo timing events by tapping a key on
a computer or USB keyboard. You can define the values for Tap Tempo using the Tempo
Interpreter. The parameters that control how Logic Pro responds to Tap Tempo commands
can be found in the Tempo Interpreter window.

Turn on Manual Synchronization mode
In Logic Pro, do one of the following:
•

Choose File > Project Settings > Synchronization > General, then choose Manual in the
Sync Mode pop-up menu.

•

Select the “Auto enable external sync” checkbox (on by default) in the Project
Settings > Synchronization > General pane.

If Logic Pro “hears” a Tap Tempo command, it automatically follows this tempo.
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Set the tempo values in the Tempo Interpreter window

1. In Logic Pro, choose Edit > Tempo > Tempo Interpreter (or use the Open Tempo
Interpreter key command).
2. In the Tempo Interpreter window, adjust any of the following:
•

Tap Step: Sets the note value that Logic Pro assigns to manual taps. You achieve the
best results with larger, rather than smaller, values. 1/4 note usually works well.

•

Window: Determines the time span (or window) within which tap notes can be
entered (set in ticks, or 1/3840 note). Only taps made within this time window are
used to determine the tempo. Any taps outside it are ignored.
•

The narrower the window, the more effectively Logic Pro is able to withstand the
influence (on the tempo) of any taps that fall between the note values—set with
the Tap Step parameter.

•

The larger the window, the easier it becomes to create drastic tempo changes.

•

If you set the window parameter to 0, the tap window disappears altogether, and
all taps are accepted as tempo-determining information. Logic Pro also comes to
a halt, if taps are not generated.

•

Tempo Response: Sets the sensitivity to tempo changes: the larger the value, the
greater the sensitivity. You should set this value to 4, for most situations. If you find
that your tap timing is imprecise, but want Logic Pro to play at a relatively constant
tempo, reduce this value to 2 or so.

•

Max. Tempo Change: Use this parameter to set the maximum tempo change possible
per tap (in bpm). To obtain the most regular, or even tempo curve, follow this
rule: set the smallest possible value (in other words, only as large as necessary).

•

Tap Count-In: Sets the number of taps used as a count-in. Logic Pro starts following
the tempo on the first tap after the count-in taps.

•

Smoothing: Turning on this function smooths out jumps in tempo, resulting from
incoming taps (which could prove useful when using Logic Pro live). You should turn
it off if you want Logic Pro to follow your taps precisely and quickly.

•

Tempo Recording: Creates a tempo list that follows your taps, when in record mode.
This option should normally be turned off.

•

Pre and Post: Determine which tap signals are displayed:
•

Pre: Displays every incoming tap.

•

Post: Displays every accepted tap that occurs within the time window (as defined
by the Window parameter), or close to, or on, a tap step.

The Pre/Post tap signals flash yellow if the taps are within the allowed range, and red
if they are out of range.
Note: Only the selected software instrument track, and all external MIDI tracks, can play
when the Tempo Interpreter window is open.
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Use the tempo fader in Logic Pro

When Advanced MIDI Options is selected in Logic Pro > Preferences > Advanced,
you can create a real-time tempo fader in the Environment window by choosing New >
Fader > Specials > Tempo Control. This fader can control the project tempo (using Meta
event #100). There is no need to connect this fader to anything, unless you want to record
its output.

A tempo fader has a range of possible values from 50 to 177 bpm. External MIDI data can
be used to control it, with an input value of 0 resulting in a tempo of 50, and an input value
of 127 resulting in a tempo of 177.
If you place a tempo fader between the Physical Input and Sequencer Input objects in the
Environment, you can:
•

Record tempo changes

•

Control the tempo with any desired MIDI event types

This way, new Tempo track data can be recorded intelligently. The original tempo data is
only erased in areas that actually contain tempo changes.
If a tempo fader is moved during playback or recording, all data defined in the Tempo List
is turned off until you stop playback or recording.
Movements of a tempo fader are ignored when external SMPTE sync is active. A tempo
fader can therefore be used to deactivate the sync reference during playback or recording,
if you wish.
For more information about create meta event faders in the Environment, see Meta
event faders.
Note: The tempo fader’s inspector displays pitch bend events as the Input definition (by
default). This allows control of the project tempo with your keyboard’s pitch bend wheel.
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Work with transposition
Logic Pro transposition overview

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can you can transpose (change the playback pitch of) MIDI regions and Apple Loops
in a project over time using the Transposition track. The Transposition track contains
transposition points for pitch changes (transposition events). The project transposes
at the position of the transposition point, and remains at the new value until the next
transposition point.

Transposition affects both audio and software instrument Apple Loops (except drum loops,
and other Apple Loops with no defined key) as well as MIDI regions. Audio regions other
than audio Apple Loops are not transposed.
The zero position of the Transposition track is determined by the current key signature in
the Signature track. If the key signature changes during a project, the zero position of the
Transposition track changes accordingly.
Transposition works non-destructively, and transposed MIDI notes return to their original
values when the Transposition value is reset to zero (0). For example, starting with a C3
note event in a MIDI region, adding a transposition point with a value of +2 changes the
note event to a D3. If you change the transposition point to a different value, the note is
transposed by the corresponding amount. When you change the transposition point so
that the transposition value is 0, the note returns to a C3. Similarly, if you copy a region
to different parts of the project with different transposition values, the notes in the region
change by the corresponding amount.
When you add or edit a transposition point, only existing MIDI events in a project are
transposed. MIDI events recorded or created afterward are not affected.
If the No Transpose checkbox is selected in the Track inspector, MIDI events (including
instrument Apple Loops) are not transposed for that track.
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Show the Transposition track

1. In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button . In the Tracks area, the Global Tracks button
appears above the track headers; in the editors, it appears on the left side of the
editor.

2. Control-click anywhere in the global tracks header area, then select Show Transposition
in the dialog that appears.

Add and edit transposition points in Logic Pro

You control transposition by adding and editing transposition points in the Transposition
track. Working with transposition points is similar to working with automation points in the
Tracks area.

Add a transposition point

In Logic Pro, do one of the following:
•

Click a position in the Transposition track with the Pencil tool.

•

Press and hold Control-Option-Command, click a position in the Transposition track,
enter a transposition value in the field, then press Return.

A transposition point is added, set to the value you entered.
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Change the value of a transposition point
•

In Logic Pro, drag the transposition point up or down to a new value.
As you move the transposition point, a help tag appears, showing the current
transposition value.

Delete a transposition point

In Logic Pro, do one of the following:
•

Click the transposition point with the Pointer tool, then press the Delete key.

•

Click the transposition point with the Eraser tool.

Transposition events can be copied using the standard Copy and Paste operations or by
dragging them while holding Option.
You can also copy or move multiple transposition events simultaneously, which can be
useful for repeated project sections.

Work with beat mapping
Logic Pro beat mapping overview

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can access the Beat Mapping track. Beat mapping lets you map notes that don’t follow
a strict tempo with beats in the ruler. When you play the project, the project tempo adjusts
so that the beat-mapped notes are aligned with beats in the ruler.
Beat mapping has the following uses:

•

The metronome click reflects the beat-mapped tempo when you make subsequent
recordings.

•

You can apply Quantize functions to newly recorded regions.

•

Loops adjust their timing to the beat-mapped tempo.

•

The timing of MIDI regions recorded to the beat-mapped tempo appears in a musically
meaningful way in the Score Editor.

•

MIDI regions subsequently created using step input follow the beat-mapped tempo,
resulting in a more natural, less mechanical rhythmic feel.

Beat mapping involves two steps: first, you graphically connect notes to ruler positions in
the Beat Mapping track. A tempo change event is inserted at each of these ruler positions,
so that the notes align with musically meaningful time positions in the ruler, although their
absolute time position is unchanged. A beat-mapped project contains the same tempo
variations as the original recording.
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Because beat mapping can create changes in the Tempo track, altering existing tempo
changes or creating new tempo changes, you should avoid making changes in the Tempo
track after using beat mapping functions. Doing so will defeat the timing derived from the
beat mapping functions.

In the upper part of the Beat Mapping track, a ruler shows the same time divisions (bars,
beats, and subdivisions) as those that appear in the LCD (and also depend on the current
zoom level).
The following sections describe beat mapping in the Tracks area. Beat mapping is also
available in the Piano Roll Editor, Score Editor, and Step Editor. When working in these
editors, you can see the corresponding (beat-mapped) notes as you work, which can speed
your workflow.

Show the Beat Mapping track

1. In Logic Pro, do one of the following:
•

Choose Track > Global Tracks > Show Global Tracks, or use the Show/Hide Global
Tracks key command (G).

•

Click the Global Tracks button . In the Tracks area, the Global Tracks button
appears above the track headers; in the editors, it appears on the left side of the
editor.

2. Control-click anywhere in the global tracks header area, then select Beat Mapping in
the dialog that appears.

Use beat mapping on MIDI regions in Logic Pro

You can beat map MIDI regions to adjust the project tempo so that freely recorded notes in
the align with beats in the ruler.

Apply beat mapping to MIDI regions

1. In Logic Pro, select the regions that you want to use for beat mapping.
A representation of the selected regions appears in the Beat Mapping track.
Tip: You may want to zoom in to work more precisely.
2. In the Beat Mapping track, click the first (leftmost) ruler position that you want to
associate with a MIDI note.
A vertical line appears at the clicked ruler position.
3. Drag the bottom part of the line so it aligns with the beginning of the note you want to
map to the ruler position.
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The line adjusts to match the beginning of the note. If the Tempo track is displayed, a
Tempo change appears at the ruler position.

Logic Pro automatically inserts a tempo change, which appears in the Tempo track.
4. Moving from left to right, beat map the subsequent notes in the selected regions,
repeating the same steps.
5. To connect a ruler position to a position in the region where no note exists, press and
hold Control while drawing the connecting line. This allows the line to snap to any
subdivision, even where there is no note event.
6. To erase a beat mapping, double-click it with the Eraser tool, or select it and press the
Delete key.
7. To erase all beat mappings, click anywhere in the header of the Beat Mapping track
(except on the controls) to select all data in the track, then press the Delete key.
When using the Delete key, be careful not to accidentally delete other selected events
or regions.

Use beat mapping on audio regions in Logic Pro

Beat mapping audio regions works similarly to beat mapping MIDI regions. If the audio
regions don’t contain tempo information, they must be analyzed to find transients (short
amplitude peaks, usually at rhythmically prominent positions), which can be mapped to a
ruler position, before you can use them for beat mapping.
Transients appear as blue vertical lines in the lower part of the Beat Mapping track, aligned
to peaks in the audio waveform. If no transients are visible on the selected audio regions
when you open the Beat Mapping track, analyze the regions before applying beat mapping.

Detect transients in audio regions
•
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In Logic Pro, select the regions to analyze, then click the title “Beat Mapping” in the
Beat Mapping track and choose Analyze Transients from the shortcut menu.
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After the regions are analyzed, the transients appear as blue vertical lines in the lower part
of the Beat Mapping track.

Tip: It may be difficult to identify transients if the waveform overview is too small. If
transients are hard to see, click the Waveform Zoom button in the Tracks area menu bar to
visually resize the waveform in the Beat Mapping track.
The remaining steps for beat mapping audio regions are the same as for MIDI regions. To
follow those steps, see On MIDI regions.
There are a number of ways to improve the beat mapping accuracy of audio regions.
When you choose Analyze Transients, those transients above a certain threshold are
displayed. You can adjust the threshold using the Minus and Plus (–/+) buttons in the Beat
Mapping track.

Increasing the number of transients can be useful when beat mapping regions with less
distinct accents—such as soft drums in a loud mix. However, a high setting can result in
extraneous transients, with no real meaning for the rhythmic structure, being displayed.
In general, it’s better to begin with a lower setting, and move to a higher setting only if
transients are missing for obvious rhythmic elements in the music.
You can also make beat mapping easier by moving one or multiple selected audio regions,
so that the first transient marker in any of the regions is located on the nearest whole
beat position.
Sometimes, MIDI recordings may contain note events falling on musically meaningful
positions, which should not be affected by beat mapping applied to audio recordings.
In this case, you can choose the Protect MIDI option to keep those MIDI events at their
current ruler positions when beat mapping audio regions.
Audio recordings may contain flex markers falling on musically meaningful positions, which
should not be affected by beat mapping applied to MIDI recordings. In this case, you can
choose the Protect Flex option to keep those markers at their current ruler positions when
beat mapping MIDI regions.
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Change the threshold of transients displayed
In Logic Pro, do one of the following:
•

To decrease the number of transients displayed: Click the Minus button (−) in the
header of the Beat Mapping track.

•

To increase the number of transients displayed: Click the Plus button (+) in the header
of the Beat Mapping track.

Protect MIDI events from being beat mapped
•

In Logic Pro, click the title “Beat Mapping” in the Beat Mapping track, then choose
Protect MIDI from the shortcut menu.

Protect flex markers from being beat mapped
•

In Logic Pro, click the title “Beat Mapping” in the Beat Mapping track, then choose
Protect Flex from the shortcut menu.

Move the first transient marker in a region selection to the nearest whole beat
position
•

In Logic Pro, Control-click the beat mapping header, then choose Move Selection with
First Transient to Nearest Beat from the shortcut menu (or use the corresponding key
command).

The first transient marker in the region selection is moved to the nearest whole beat
position, with all selected regions moving with it.

Automatically beat map regions in Logic Pro

Logic Pro can automatically beat map audio or MIDI regions using the Beats from Region
command. You can select the note value to use for automatic mapping, and select the
beat-mapping algorithm.

Apply automatic beat mapping

1. In Logic Pro, select the region you want to beat map.
2. Click the title “Beat Mapping” in the Beat Mapping track, and choose Beats from Region
from the shortcut menu.

3. In the Set Beats by Guide Region(s) dialog, choose the note value to use for beat
mapping in the Note Value pop-up menu.
The note value defines the timing resolution used to create the map.
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4. Select one of the following algorithms:
•

Tolerate missing or additional events: Only tempo-relevant transients are used for
beat mapping (based on the project time signature). This avoids drastic tempo
changes, which are usually undesirable.
Note: This algorithm gives the best results when used with material with a regular
beat, and a fairly constant tempo. However, it can also be used with material that
features changing rhythmic divisions, and some degree of tempo change.

•

Use exactly all existing events: Every detected transient is used for beat mapping.
For usable results, the regions should have an event for each tempo-significant
transient.

5. Click OK to perform the automatic beat-mapping process.
Regions with more complex or irregular musical patterns may not initially produce useful
results with automatic beat mapping. If your first attempt produces an alert saying that
the required tempo would be too low, undo the beat mapping, then set the first downbeat
manually before choosing Beats from Region. If the alert reappears, undo again, and set
both the first and second downbeat manually before choosing Beats from Region. If this
method fails, you can record a MIDI region containing synchronized regular notes, and use
this as a guide region for beat mapping.
For information about mapping regions manually, see On MIDI regions and On
audio regions.

Apply beat mapping to audio material containing tempo changes

1. In Logic Pro, cut the audio material at the precise position of each tempo change.
2. Lock the SMPTE position of each audio region.
3. Select the first region and perform the automatic beat-mapping process as already
described.
4. Continue with the remaining audio regions.

Control the volume of a Logic Pro project

You can control the overall playback volume of a project using the Master Volume slider
in the control bar, the Output track in the Tracks area, and the master channel strip in
the Mixer. Each acts as a master volume control for the overall project, and also affects
the overall volume of the project mix. These controls don’t affect the playback volume of
external MIDI channel strips.
The Master Volume slider, Output track, and master channel strip are connected, so that
changes to one affect the other two as well. If automation data exists on the Output track,
the Master fader moves to show the volume changes when you play the project.
Generally speaking, you should adjust the output volume to a level high enough to
eliminate background noise, but not high enough to cause clipping. You can check for
clipping by watching the clipping indicators in the master level meter.
For information about automating track parameters, see Overview of automation in Logic
Pro. For details about working with the master channel strip in the Mixer, see Channel strip
types in Logic Pro.
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Adjust the overall project volume

In Logic Pro, do one of the following:
•

In the control bar, drag the Master Volume slider left or right.
Option-click the slider to return it to a neutral value (0 dB gain).

•

In the Tracks area, drag the volume slider on the header of the Output track.
If the master track is hidden, choose Track > Show Output Track.

•
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In the Mixer, drag the Master fader up or down.
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Create a musical score in Logic Pro

Overview of music notation in Logic Pro

You can view MIDI regions in software instrument (and external MIDI instrument) tracks
as music notation in the Score Editor. Notes and other musical events are displayed as
standard notation, along with common symbols such as time and key signature, bar lines,
and clef signs. You can add and edit notes, add sustain pedal markings and other symbols,
and print the score.

The Score Editor provides visual quantization so that you can control the display of note
values without altering the timing of your recordings, and change the displayed musical key
without altering the playback of your MIDI recordings.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can control many additional aspects of music notation. You can:
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•

View and edit multiple tracks in a score, displayed in a linear scrolling view, “wrapped”
view, or multi-page view

•

Add notes and symbols from the Part box, including dynamics, phrase markings, and
other symbols

•

Add lyrics and other text such as section markers and performance indications

•

Use additional tools (the Pointer, Pencil, Eraser, Text, Layout, Zoom, Voice Separation,
and Solo tools) in the Score Editor

•

Edit region parameters in the Region inspector to control how regions appear in the
score

•

Use staff styles to control the display of rests, stems, ties, and beams, and adjust the
size of and space between staffs. You can choose different staff styles or customize
and create your own staff styles to use in your scores.
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•

Define different instrument groups using score sets to create full scores, parts, and lead
sheets

•

Edit the overall score layout, including numbers, names, and spacing

•

Share the score by printing it or exporting it to a PDF file

•

Add and edit staff styles for individual MIDI regions

•

Access additional choices in the Staff Style window (for mapped instruments and
tablature)

•

Create Part box sets with your own combinations of score symbol groups for easy
access

•

Access additional symbols from the Part box, including tablature and guitar
performance symbols

•

Create and edit chord grids for guitar or other instruments, using standard or open
tunings

•

Access additional tools from the Score Editor Tool menu

•

Access additional Score preferences and Score project settings

Work in the Score Editor
Overview of the Score Editor in Logic Pro

The Score Editor can display a single MIDI region or software instrument track. In the Score
Editor, each track appears as a separate staff. Notes, rests, and other musical events in the
MIDI regions on the track are displayed in standard musical notation.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
the Score Editor can display multiple tracks containing MIDI regions, and display every
instrument track in the project.

The Score Editor menu bar includes Layout, Edit, Functions, and View pop-up menus;
Display Level, View, MIDI In, MIDI Out, and Catch buttons; Tool menus; and a Zoom slider.
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The Score inspector, located to the left of the score display, includes the following areas
that you use to control various aspects of the score:
•

Region inspector: Control visual quantization and other display settings for regions in
the score.

•

Event inspector: Control appearance and position settings for individual notes and other
items in the score.

•

Part box: Select notes and other symbols to add to the score.

•

Inspector channel strips: Control volume, pan, and other mixing functions for the
selected track and its output.

You can view the Score Editor in the Logic Pro main window, or as a separate,
resizable window.

Open the Score Editor
Do one of the following:
•

Click a track header, click the Editors button

in the control bar, then click Score.

•

Select a MIDI region in the Tracks area, click the Editors button in the control bar, then
click Score (or press N).

•

Double-click a MIDI region (if Logic Pro > Preferences > General > Editing > “Doubleclicking a MIDI region opens” is set to Score).

Open the Score Editor as a separate window
Do one of the following:
•

Choose Window > Score (or press Command-5).

•

Drag the Score Editor by its title out of the main window.

•

Press and hold Option and double-click any event in the Piano Roll Editor.

Show or hide the local Score Editor inspector

To show the Score Editor inspector: Choose View > Show Local Inspector from the Score
Editor menu bar.
To hide the Score Editor inspector: Choose View > Hide Local Inspector from the Score
Editor menu bar.
The following MIDI regions are not displayed in the Score Editor: Muted MIDI regions (if
Hide Muted Regions is selected in File > Project Settings > Score Global), MIDI regions on
muted tracks (if Hide Muted Tracks is selected in File > Project Settings > Score Global),
and MIDI regions for which the Score parameter is turned off in the Region inspector.
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View tracks as music notation in Logic Pro

The Score Editor displays MIDI regions on software instrument (and external MIDI
instrument) tracks as music notation, including notes, rests, key and time signature, and clef
signs. Bar lines show the division between measures. Gaps between regions are filled in to
display a continuous staff. If the track contains software instrument Apple Loops, notation is
displayed for each loop iteration, but only the original region of the loop can be edited.
The Score Editor has three views, optimized for different kinds of work:
•

Linear view: Shows a single software instrument track in a continuous, horizontally
scrolling view. Linear view is the standard view for editing the score.

•

Wrapped view: Shows one or more tracks in a lead sheet–style, line-wrapped view.

•

Page view: Shows the full score on facing pages. Page view displays as many pages as
possible (depending on the size of the Score Editor window and current zoom level).
You can work on the score layout and print the full score in Page view.

You can also move through display levels, to view a MIDI region, a track, multiple tracks in
a folder, or all tracks in the project.
Note: Because the Score Editor displays the contents of MIDI regions, any MIDI notes
located outside of a region (in the Piano Roll Editor, for example) are not displayed in the
Score Editor.

View a track in the Score Editor
Do one of the following:

Click a track header, click the Editors button in the control bar, then click Score.
Click a track header, choose View > Show Editors, then click Score.

Change the Score Editor view
Do one of the following:

Click the Linear View button
horizontal view.
Click the Wrapped View button
lead sheet–style view.

to display a single track in a continuous, scrolling
to display the selected track or tracks in a line-wrapped,

Click the Page View button
to display the full score on facing pages, including headers,
margins, and other layout features.
You can also change the view using the View > View Mode menu commands in the Score
Editor menu bar.
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Set the Link mode for the Score Editor

To set the Link mode to Same Level: Click the Link button in the Score Editor menu bar. The
Link button appears purple.
To set the Link mode to Content: Double-click the Link button in the Score Editor menu bar.
The Link button appears yellow.
For more information about using Link modes, see Control window relationships.

Move through score display levels
•

To show a single track: Double-click the staff of that track (or select the track in the
Tracks area).

•

To move to the next higher display level: Click the Display Level button
Editor menu bar.

•

To show all software instrument tracks in the project: Double-click the background of
the Score Editor.

in the Score

When viewing the score in Linear view, the following controls appear in the Score Editor
inspector to the left of the score display (when Show Local Inspector is chosen in the
Score View pop-up menu):
•

Insert pop-up menu: Choose the note value for notes to insert.

•

Time Quantize pop-up menu (with Strength and Swing buttons): Quantize the timing of
notes.

•

Scale Quantize pop-up menu (with Strength and Swing buttons): Transpose notes to a
different key.

•

Velocity: Change the velocity value of selected notes.

In addition, the Grid pop-up menu appears in the Score Editor menu bar, so you can set the
visual quantization of notes in the Score Editor.
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Import MusicXML files to a Logic Pro project

MusicXML is an XML-based music notation file format, supported by many notation and
music OCR apps and some music production apps. MusicXML files contain MIDI data, as
well as additional notation data that is mapped to Logic Pro notation features including
score symbols, staff styles, and more. You can import a MusicXML file to a new or existing
project, play the resulting regions in the project, and view the regions as music notation.
When you import a MusicXML file, new tracks are created below any existing tracks in
the Tracks area, with MIDI regions containing the contents of the MusicXML file. Regions
are added starting from the playhead position. The tracks (instruments) of the MusicXML
file are assigned to tracks (instruments) with the same name, if such tracks (instruments)
exist in the project. If no tracks (instruments) with the same name exist, a new software
instrument track and channel strip are created for each track (instrument) of the imported
MusicXML file.

Import a MusicXML file

Choose File > Import > MusicXML, then choose the file in the Import dialog.

Position items graphically in the Score Editor in Logic Pro

You can position items graphically to improve the readability of your score (creating space
for a grace note, for example). There are three ways to position items:
•

Using the Layout tool: The Layout tool is used to graphically move events in the Score
Editor, in order to optimize the display without altering the timing of MIDI events.

•

Using the Event inspector: You can change the graphical position of Score Editor
symbols and text in the Event inspector by editing the Vertical Position and Horizontal
Position parameters.

•

Using key commands: You can use key commands to move any score symbol that
can be positioned independently of notes or staffs, as well as text events and chord
symbols. These functions don’t alter the bar position of the affected symbols and text
events. They alter the Horizontal Position and Vertical Position parameters by ±1.

Position items using the Layout tool

Select the Layout tool, then drag notes, symbols, text, or other items.

•

When you move symbol or text objects with the Layout tool, the bar position is
retained. The Horizontal Position and Vertical Position parameters, however, are
changed (as indicated in the help tag during the process).

•

You can only edit the horizontal position of a note in relation to its bar position
using the Layout tool, not its vertical position. Dragging the note to the right or left
changes the displayed distance from the adjacent notes or rests. The bar position
(and playback) is unaltered.

Note: The bar position determines playback timing, as this is the actual MIDI event
position. Remember that the Score Editor is primarily designed to deliver notation, and
that most (but not all) editing functions are graphical, rather than physical, in nature.
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Position items using the Event inspector

1. Select the item or items you want to position graphically.
2. Enter the value for the vertical position in the Vertical Pos.: field. A value of 0 means a
position exactly on the top line of the staff, in most cases. Positive values are above,
negative values below it. In staff styles with more than one staff, the Staff parameter
determines the staff that the Vertical Position parameter refers to.
3. Enter the value for the horizontal position in the Horizontal Pos.: field. The value
determines the horizontal offset of the object’s bar position. A value of 0 corresponds
to the left edge of a note, at that particular position.

Position items using key commands

Use any of the following key commands:
•

To move the vertical position up by 1: Use the Nudge Position Up key command.

•

To move the vertical position down by 1: Use the Nudge Position Down key
command.

•

To move the horizontal position left by 1: Use the Nudge Position Left key command.

•

To move the horizontal position right by 1: Use the Nudge Position Right key
command.

•

To adjust a number of selected symbols to the same height above (or below) the
staff: Use the Align Object Positions Vertically key command.

Tip: To adjust a number of selected symbols to the same height above (or below) the
staff, use the Align Object Positions Vertically key command.

Move and copy items in the Score Editor in Logic Pro

In addition to moving and copying items using the pointer, you can also use the Layout tool,
key commands, and Copy and Paste commands.

Move and copy items using the Layout tool

Remember that you can unintentionally change a symbol’s bar position with the Pointer
tool. To limit changes to an event’s vertical and horizontal position, without changing the
bar position, use the Layout tool to move and copy items in the Score Editor. See Position
items graphically.

Move items with key commands

The Nudge Region/Event Position section of the Key Commands window contains a group
of key commands that can be used to move selected objects along the time axis. The
Nudge commands most useful for score work are those that nudge regions or events left or
right by bar, beat, or division.

Copy and paste items via the Clipboard

When you copy items via the Clipboard, the first item is pasted at the target time position.
Subsequent items retain their position relative to the first object. You can simultaneously
paste the Clipboard contents into several regions, at the original position.
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When you paste (or paste multiple) items from the Clipboard, the position of the first
inserted event is automatically quantized, in accordance with the current division value
(set in the LCD). For example, if the current bar position is 4.1.1.37, and the division value
is set to 1/16, the pasted object is inserted at position 4.1.1.1. If you want to preserve the
unquantized timing, use another method to copy and paste the items.

Move a note or symbol with the pointer

Select one or more notes or symbols, then drag to the new position.

Copy a note or symbol with the pointer

Select one or more notes or symbols, press and hold Option, then drag to the new position.
While you drag, a help tag shows the operation (drag or copy), the difference from the
original position (transpose and time shift), and the current pointer position (bar position
and, for notes, pitch).
You can simultaneously move or copy items from different regions or staffs. Each event is
moved or copied to its new position, within its original MIDI region.
Note: You can’t use the Option-drag method to copy or move events between MIDI regions
in the Score Editor. You can, however, copy and paste between regions and staffs.

Restrict movement to one direction (vertical or horizontal)
Press and hold Shift while dragging.

There is also a general preference for this constraint: Logic Pro > Preferences > General >
Editing > Limit Dragging to One Direction In: Piano Roll and Score.

Move items using key commands
Use any of the following:
•

To move the selected notes forward or backward one bar: Use Nudge Region/Event
Position Left by Bar and Nudge Region/Event Position Right by Bar.

•

To move the selected notes forward or backward one beat.Use Nudge Region/Event
Position Left by Beat and Nudge Region/Event Position Right by Beat.

•

To move the selected events forward or backward one division step (as set in the
LCD): Use Nudge Region/Event Position Left by Division and Nudge Region/Event
Position Right by Division.

Paste the Clipboard contents into several regions

1. Select all targeted regions (either in the Tracks area or Score Editor) by Shift-clicking
the staffs/regions, or dragging to select adjacent regions.
The Region inspector title indicates the number of selected regions.
2. Choose Edit > Paste Multiple (or use the Paste Multiple key command.)
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Copy an entire musical passage to the same time position in another region

You can use the Paste at Original Position and Paste Multiple at Original Position
commands to quickly copy passages from one MIDI region to another, at the same time
position. No insert position is required, and no automatic insert quantization takes place.
1. Select the notes and symbols of the passage.
2. Select the staff you want to paste the passage to.
3. Choose Edit > Paste at Original Position (or use the Paste at Original Position key
command).
The notes and symbols are pasted at the position they were originally copied from,
regardless of the current playhead position.
The Paste Multiple at Original key command works in a similar way, but allows you to paste
a musical passage to the staffs of other instruments. You need to select all destination
staffs before using the Paste Multiple command.
You can use these commands in combination with the Select Similar function, to quickly
copy all dynamic symbols from one staff into other staffs or instruments, for example.
Moving items in time is affected by the display quantization grid (Quantize) setting. If a
hybrid Quantize value is selected (16, 24 for example), the grid corresponds to the duple
value (16, in this example).
•

If note positions are not aligned with the time grid (because they were recorded in real
time), their relative offset is retained when they are moved or copied.

•

You can move or copy unquantized passages within the Score Editor, without losing the
original feel of the performance.

The following types of symbols cannot be copied or moved in the Score Editor:
•

Global symbols, such as repeat signs, time and key signature changes—except in the
Signature List and Signature track—and global text elements (headers and so on). (For
additional information, see Time and key signature overview.)

•

Symbols directly attached to notes, such as accents, fermatas, note heads, and so on.

Resize notes and symbols in the Score Editor in Logic Pro

You can change the size of notes, as well as most score symbols, using the Resize tool
(located in the Score Editor Tool menu).

Resize a note or score symbol

Grab the item with the Resize tool, and move the pointer up or down.

Reset a note or symbol to its original size

Double-click the item with the Resize tool, then click OK in the dialog.
Note: Resizing notes does not affect MIDI playback, only the notes’ visual appearance.
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Adjust display headroom in the Score Editor in Logic Pro

You can adjust the vertical headroom, or the amount of blank space at the top of the score
display. This can be helpful when there are notes with ledger lines extending above the
staff, or chords, symbols, or text above the staff.

Adjust the vertical headroom at the top of the score
1. Place the pointer at the top edge of the score display.

The pointer changes to a pair of up-and-down pointing arrows.
2. Drag up or down to adjust the vertical headroom.
You can adjust the space above or below staffs in the Staff Style window (for more
information, see Staff Style window).

Repeat events in the Score Editor in Logic Pro

The Repeat Events command is especially useful for copying complete bars (or multiple
copies), without setting any bar positions.

Copy a bar that begins with a rest on the first beat
1. Select the notes and symbols you want to repeat.

2. Choose Edit > Repeat Events (or use the Repeat Regions/Events key command).
3. In the Repeat Regions/Events dialog, insert the number of copies to create, choose Bar
from the Adjustment pop-up menu, then click OK.
For more information on the Repeat Events command, see Cut, copy, and paste regions.

Insert items in multiple regions in the Score Editor
in Logic Pro

You can add notes and symbols from the Part box into all currently selected regions, at the
same position. This technique allows you to insert notes, symbols, and even text elements
into several regions at once.
When multiple regions are selected, the top line of the Event inspector shows the number
of selected staffs (regions).
Note: Key changes, signature changes, and global signs can’t be inserted into
individual staffs.

Insert an item in multiple regions

1. In the Tracks area or Score Editor, select the regions into which you want to insert the
item.
2. Press and hold Shift and do one of the following:
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•

Drag the item from the Part box into one of the regions at the position where you
want to add it.

•

Click in one of the regions with the Pencil tool at the position where you want to add
the item.
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Edit multiple items in the Score Editor in Logic Pro

When multiple items are selected in the Score Editor, the title of the Event inspector
indicates the number of selected items. If the selection is limited to only notes, chords, or
text objects, the title also indicates the type of item selected.
If parameter fields are visible while multiple events are selected, their values can be edited
simultaneously. The asterisk symbol (*) in a parameter field indicates that the selected
items have different values. In this case, there are two options for editing these values:
Relative change (preserving relative differences between parameter values) and Absolute
change (setting all parameters to an equal value).
You can set the vertical and horizontal position of all selected items to the same value,
using any of the following key commands:
•

Align Object Positions Vertically

•

Align Object Positions Horizontally

•

Align Object Positions (affects both parameters)

These key commands set all items to the value of the first selected item. If only one item
is selected, a dialog asks if the parameters of all similar objects should be set to the same
value. This technique is very useful for aligning lyrics and chord symbols, for example.

Change the relative values of multiple items
Do one of the following:

Place the pointer over the value (or asterisk), then drag.
The value shown during this process belongs to the first of the selected objects. The other
objects are altered by the same amount (while retaining their relative values).
Double-click the value, then insert the change (a number with a plus or minus in front of it)
in the entry field.

Change the value of multiple items to the same absolute value

Press and hold the Control key with the pointer over the asterisk, then drag.
As soon as you move the pointer, the parameter is set to the same value for all selected
objects. This allows you to set all notes of a chord to the same length or velocity, or set all
selected objects to the same height (Vertical Pos), for example.

Select multiple regions in the Score Editor in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can select multiple regions in the Score Editor either from the Region inspector or in
the score display.

Select more than one region in the Score Editor

Click an instrument name in the column between the parameters and score, to select all
regions for that track (including regions on different tracks that are assigned to the same
software instrument channel), at the current display level.
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Note: The instrument name column is displayed only if View > Instrument Names is
selected.

Hide regions in the Score Editor in Logic Pro

You can hide regions so that they are not displayed in the Score Editor, or when you print
the score. This is useful for hiding regions that only contain MIDI events that can’t be
displayed in the score, such as controller or SysEx data, or for alternate versions that you
wish to not display.

Hide regions in the Score Editor

1. Select the MIDI regions you want to hide.
2. In the Region inspector, click the More disclosure arrow to reveal additional MIDI region
parameters.
3. Choose Hide from the Score parameter pop-up menu.
4. To show hidden regions, select them, then choose Show from the Score parameter popup menu.

Add notes to a score in Logic Pro

In general, you add notes to a score by recording on software instrument tracks, as
described in Record software instruments. You can record directly in the Score Editor
following the same procedure as in the Tracks area, with one exception: rather than clicking
a track header, you click the staff for the track.
There are two alternative ways to add notes to a score: using the pointer, and using
step input.
Step input lets you add notes from a music keyboard or your computer keyboard. You can
input notes and other symbols, such as rests. Step input differs from real-time recording
in that you select rhythmic values for notes you want to enter, then select the pitch, rather
than playing notes in real time. As with real-time recording, you start by selecting the staff
for the track you want to work on. If there are no MIDI regions on the track, you must add
a MIDI region before starting to add notes. For information about step input recording, see
Use step input recording.
You can add notes directly using the pointer. While viewing a score in Linear view, you can
choose note values from the Insert pop-up menu in the local Score inspector.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also add notes and other symbols from the Part box.
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Add notes using the pointer
Do one of the following:

Choose a note value from the Insert pop-up menu in the local Score Editor inspector, then
Command-click at the point where you want to add a note.
The Insert pop-up menu is available when Logic Pro is operating in Simplified mode (that
is, when Enable Complete Features is not selected in Logic Pro > Preferences > Advanced).
Click a note in the Part box, then Command-click at the point where you want to
add the note.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can also add notes and other symbols from the Part box.
You can create a new, empty region by Command-clicking in a software instrument track.

Prepare for step input

1. In the Region inspector, edit the following display settings for the selected track or
region:
•

Turn off Interpretation. (See Change note syncopation and interpretation.)

•

Set the Quantize parameter to the smallest note value that you plan to insert. (See
Quantize the timing of notes.)

2. Option-click the staff at the point where you want to begin adding notes. A help tag
shows the pointer position while the mouse button is pressed.
This function is especially helpful in Page view, where no ruler is displayed.
Note: You can set the playhead position only when playback is stopped.

Add notes and symbols from the Part box
Overview of the part box in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add notes and other symbols from the Part box in the inspector.
The Part box contains a complete collection of score symbols, arranged in groups. You can
control which symbols are displayed in the Part box, reorder symbol groups, and open the
Part box as a separate, floating window.
The Part box includes the following types of symbols:
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•

Notes and rests

•

Key and time signature symbols

•

Clef signs

•

Slurs and crescendo/decrescendo symbols

•

Note heads

•

Accents, bowing marks, fermatas, and other symbols that apply to specific notes

•

Phrasing marks
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•

Trills and other ornaments, tremolo symbols

•

Sustain pedal markings

•

Bar lines, repeat signs, and Segno and Coda markings

•

Lyrics and text

•

Chord symbols

•

Chord grids and tablature symbols

•

Page and line break symbols

Open the Part box

1. With the Score Editor open, click the Inspector button

in the control bar.

2. If the Part box is closed, click its disclosure arrow in the inspector to open it.

Open the Part box as a separate window
Drag the Part box out by its title bar.

Close the Part box

Click the disclosure arrow for the Part box in the inspector.

View score symbols in the part box in Logic Pro

The Part box displays score symbols arranged in groups. You can show and hide symbol
groups by selecting or deselecting the group buttons at the top of the Part box, and
reorder the groups in the Part box.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create score symbol sets to display different symbol groups in a particular order.
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View Part box symbol groups
•

Click a symbol group’s button at the top of the Part box to view the symbols for that
group.
Click a button again to deselect its group.

The corresponding group appears in the Part box, below other selected symbol groups.

Reorder symbol groups in the Part box

Drag a symbol group up or down by the handle on its left side.

Display all symbol groups
Click the All button.

View symbol groups in a floating window
1. Drag the Part box out by its title bar.

2. Click the buttons for the symbol groups you want to display.
You can open multiple floating Part box windows, and display different score symbols in
each one. Selecting a symbol in a floating Part box window updates the selection in all
other Part box windows, until you deselect the symbol, close the window in which it was
selected, or select a symbol in another floating Part box window.

Select score symbols using key commands

Use any of the following key commands to select score symbols or groups in a floating Part
box window:
Next Part Box Symbol
Previous Part Box Symbol
Next Part Box Group
Previous Part Box Group

Choose a score symbol set

Click and hold the name of the current score symbol set in the Part box title, then choose a
set from the Part Box Sets pop-up menu.

Create a new score symbol set

Click and hold the name of the current score symbol set in the Part box title, then choose
New Set from the Part Box Sets pop-up menu.
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Rename a score symbol set

1. Click and hold the name of the current score symbol set in the Part box title, then
choose Rename Set from the Part Box Sets pop-up menu.
2. Enter a new name for the score symbol set.

Delete the current score symbol set

Click and hold the name of the current score symbol set in the Part box title, then choose
Delete Set from the Part Box Sets pop-up menu.

Show the inspector channel strips below the Part box

The inspector channel strips appear below the Part box in the Score inspector. Depending
on the size of the Score Editor and how many groups are displayed in the Part box, the
inspector channel strips may not be visible.
Click the disclosure arrow to close the Part box in the Score inspector. If necessary, you
can close other inspectors using their disclosure triangles as well.

Select score symbols in the Part box in Logic Pro

There are several ways to select score symbols in the Part box. You can select symbols
directly by clicking, or select them using the button for the Part box group. Some symbols
can be selected using key commands.

Select a score symbol

1. If the symbol isn’t visible, click the button for the corresponding Part box group at the
top of the Part box.
2. Click the symbol.

Select note symbols using key commands
•

Use any of the following (unassigned) key commands:
•

Partbox: 1/1 Note

•

Partbox: 1/2 Note

•

Partbox: 1/4 Note

•

Partbox: 1/8 Note

•

Partbox: 1/16 Note

•

Partbox: 1/32 Note

Select triplet and dotted note symbols using key commands
Do any of the following:
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•

Press a note selection key command twice to select the corresponding triple note value.

•

Three times selects the dotted note value.

•

Four times returns to the original note value.
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Select adjacent symbols or groups using key commands
Use any of the following key commands:

To select the object to the left of the currently selected symbol: Use Previous
Partbox Symbol.
To select the symbol to the right of the currently selected symbol: Use Next Partbox Symbol.
To select the group above the currently selected one: Use Previous Partbox Group.
To select the group below the currently selected one: Use Next Partbox Group.
The most recently selected object within each group is retained when switching
between groups.
Note: As the group display can be reordered, the current display order of groups
determines the previous and next group.

Add notes and rests from the Part box in Logic Pro

In addition to using real-time recording and step input, you can add notes to a score
directly from the Part box. When you add notes to the score, they are added to the region
as MIDI events, and sound when you play the project.
Logic Pro automatically displays rests in regions in the Score Editor, based on the current
Quantize display setting. You can also add rests manually, and change the appearance of
rests in a score.

Add notes from the Part box

1. If the Notes section of the Part box isn’t visible, click the Notes button in the Part box.
2. Select the note value you want to add, then do one of the following:
•

Drag it to the score at the point where you want to add it.

•

Select the Pencil tool from the Tool menu, then click the point in the score where you
want to add the note.
A help tag appears while the mouse button is held down to help you place notes in
the correct position.

Add a rest

1. If the Rests section of the Part box isn’t visible, click the Rests button in the Part box.
2. Drag a rest from the Part box to the place in the score where you want to add it, or use
the Pencil tool.

Add a multiple bar rest

1. If the Rests section of the Part box isn’t visible, click the Rests button in the Part box.
2. Drag a multiple bar rest from the Part box to the place in the score where you want to
add it, or use the Pencil tool.
By default, the multiple bar rest fills the number of empty bars until the next note event.
You can change the length of the multiple bar rest, and also change the type (modern or
church).
3. Double-click the multiple bar rest (with the Pointer tool).
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4. In the dialog, deselect Auto Length, then enter the number of bars you want the rest to
show.
5. To change the type of multiple bar rest, select one of the Type buttons in the dialog.

Add notes and symbols to multiple regions in Logic Pro

You can add notes and other score symbols to multiple selected regions at the same
time position. This makes it easy to double parts in unison, for example, or add the same
dynamic marks to multiple instrument parts playing together. Adding symbols to multiple
selected regions works for all score symbols represented by an event, including notes,
dynamic marks, clefs, pedal markings, and even text.

Add score symbols to multiple selected regions
1. Select the regions.

2. Press and hold the Shift key and add the symbol to one of the regions, either by
dragging it from the Part box or using the Pencil tool.
A help tag indicates that the symbol will be added to multiple regions.
Using the Shift key works for adding score symbols represented by an event, but not for
note extensions including accents, staccato markings, trills, or other ornaments.

Add key and time signature changes to a score in Logic Pro

The Score Editor displays the key signature and time signature for the project, as well as
any key or time signature changes you make using the Signature track or Signature List.
You can change the key and time signature, and add key and time signature changes in the
Score Editor. Key and time signatures are global events that affect all tracks in your project.
In order to select and copy signatures, the Signature track must be visible, and must not be
protected.

Key signature changes

Key signature changes (you make in the Score Editor) affect only the display of notes in the
Score Editor—they have no effect on MIDI playback. Changing the initial key signature for a
project, however, does affect the playback of Apple Loops.
You can add any number of key signature changes to a project. When you add a key
signature change, the new key signature changes the key from the insertion point forward,
until the next key signature change is reached (if one exists).
You can store up to nine signature alternatives, which are reflected in the Signature track,
Signature List, and Signature window.
Key signatures inserted in the Score Editor (or global Signature track or Signature
List) affect all instruments on all display levels. This is reflected both visually and in
MIDI playback.
The display of key signatures and key signature changes depends on:
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•

The Score project settings in the Clefs & Signatures pane (see Clefs & Signatures settings).

•

The Key parameter in the Staff Style window (see Staff Style window).
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Time signature changes

The time signature determines the number of beats in a bar, so changing the time signature
affects how barlines appear in the score. Functions that depend on the chosen time
signature and bar positions (such as MIDI metronome click or Transform window functions)
are affected if bar positions are used to restrict a function to a certain part of the project.

Add a key signature change in the Score Editor

1. If the Key Signatures section of the Part box isn’t visible, click the Key Signature button
in the Part box.
2. Drag a key signature from the Part box to the place in the score where you want to add
it, or use the Pencil tool.

Change the key signature in Linear view

Click the key signature, then choose a new key signature in the Key Signature dialog.

Change the key signature in Wrapped view and Page view
1. Control-click the key signature.

If there is no visible key signature (key of C/A minor), Control-click between the clef and
the time signature.
2. Choose Edit Key Signature from the shortcut menu.
3. Choose a value from the Key pop-up menu.
4. Click either the Major or Minor button, then click OK.

Change the time signature in Linear view
Click the time signature.

In the Time Signature dialog, enter a value for the number of beats, choose a value from
the Note Value pop-up menu, then click OK.

Change the time signature in Wrapped view and Page view
1. Control-click the time signature.

2. Choose Edit Time Signature from the shortcut menu.
3. In the Time Signature dialog, enter a value for the number of beats, choose a value from
the Note Value pop-up menu, then click OK.

Add a time signature change in the Score Editor

1. If the Time Signatures section of the Part box isn’t visible, click the Time Signature
button in the Part box.
2. Do one of the following:
•

Drag one of the defined time signatures from the Part box to the place in the score
where you want to add it.

•

Drag one of the undefined time signature symbols (A/B or A+B/C) to the place in
the score where you want to add it, then, in the Time Signature dialog, enter the
numbers for the Number of Beats and Note Value in their respective fields.

Detailed information about key and time signatures can be found in Time and key
signature overview.
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Change the clef sign in a score in Logic Pro

Each staff style has a default clef sign. In general, you should choose a staff style with the
clef you want the part or staff to use for most of the score. For information about choosing
staff styles, see Work with staff styles.
You can add clef changes to the score to improve readability; for example, when the notes
of an instrument normally written in one clef move into a different range that would require
many ledger lines in the original clef.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a clef sign from the Part box

1. If the Clefs section of the Part box isn’t visible, click the Clefs button in the Part box.
2. Drag a clef sign from the Part box to the place in the part or score where you want to
add it.

Change the clef sign in Wrapped view or Page view
1. Control-click the clef sign.

2. Choose Select Clef from the shortcut menu.
3. Click the clef sign, then click OK (or double-click the clef sign).

Change the size of secondary clefs

1. Open the Clefs and Signatures project settings by doing one of the following:
•

Choose Layout > Clefs and Signatures (or use the Settings: Clefs and Signatures key
command).

•

Choose File > Project Settings > Score (or use the corresponding key command),
then click Clefs and Signatures.

2. Choose a value in the Smaller Clef Changes pop-up menu.
All clefs, except the first one in every staff, will be reduced in size, depending on the
value chosen here. This happens regardless of whether the clef changes are the result
of a different staff style in the same staff, or clefs inserted from the Part box.
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Add dynamic marks, slurs, and crescendi to a score
in Logic Pro

Dynamic marks indicate the dynamic level at which a performer should play a musical phrase
or section. You can add dynamic marks such as p (piano), ff (fortissimo), and sfz (sforzando).
Dynamic marks are visual symbols only, and don’t affect the volume of notes during playback.
You can add slurs to indicate notes that should be played legato, and add dynamic
crescendo and decrescendo symbols (sometimes called hairpins). Automatic slurs
can cover a selected group of notes, and adjust when the notes are copied, moved, or
transposed. Using key commands, you can quickly add and edit automatic slurs for an
entire phrase, part, or score.
After adding these symbols, you can adjust their length to indicate which notes they apply
to. These symbols are visual symbols only, and have no effect on playback.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a dynamic symbol

1. If the Dynamics section of the Part box isn’t visible, click the Dynamics button in the
Part box.
2. Drag a dynamic symbol from the Part box to the place in the score where you want to
add it.

Add an automatic slur

You can add and edit automatic slurs, which automatically adjust to cover a selected group
of contiguous notes. Automatic slurs adjust when notes are copied, moved, or transposed.
They do not overlap with notes, accidentals, or most score symbols.
1. Click the Slurs and Crescendi button in the Part box to show slurs, crescendo, and other
symbols.
2. In the Score Editor, select the notes that you want the slur to apply to.
3. Do one of the following:
•

Drag an automatic slur (with both up and down curves) from the Part box over the
selected notes.

•

Select an automatic slur in the Part box, then click the selected notes with the Pencil
tool.

•

If no notes are selected, drag or click on a note, then drag the left or right edge of
the slur to cover the intended notes.

You can also add an automatic slur when no note is selected by selecting an automatic slur
in the Part box, making a long click with the Pencil tool near a note, then dragging out the
automatic slur to cover additional notes.
An automatic slur cannot extend across region boundaries. If you want to add an automatic
slur extending between two regions, first merge the regions.
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Add automatic slurs using a key command

You can add a series of automatic slurs to a line, a part, or a full score. By selecting the
start and end notes for each individual slur, then applying the relevant key command, you
can add multiple automatic slurs in one operation. Each pair defined by the start and end
note receives an automatic slur. Individual automatic slurs cannot extend across region
boundaries.
1. Select the start and end notes for each individual slur you want to add.
2. Use the “Create Auto Slurs for non-contiguous selected notes” key command.

Edit an automatic slur

To edit the start or end point of an automatic slur: Drag the start or end point to another
note with the same voice in the same region.
To edit the curve of an automatic slur: Drag one or more of the inner handles.
To convert an automatic slur to a manual slur: Control-click the slur, then choose Convert
to Manual Slur from the shortcut menu.
Note: A manual slur cannot be converted to an automatic slur.
To reposition an automatic slur relative to notes: Control-click the slur, then choose one of
the following from the shortcut menu:
•

To position the slur above notes: Choose Slur Above.

•

To position the slur below notes: Choose Slur Below.

•

To return to the automatic position of the slur: Choose Slur Auto Direction.

To open the Score Layout settings, do one of the following:
•

Choose File > Project Settings > Score, then click the Layout tab.

•

Control-click the slur, then choose Settings: Extended Layout from the shortcut menu.

The Score Layout settings include a Slurs section where you can edit automatic slur
settings that apply to existing automatic slurs and become the default for new ones, as well
as Line Thickness settings that affect automatic and manual slurs.

Edit automatic slurs using key commands

To convert an automatic slur to a manual slur: Use the Convert Auto Slur key command.
Note: A manual slur cannot be converted to an automatic slur.
To revert all edits made to an automatic slur: Use the Reset Auto Slur key command.
To add an automatic slur with the direction set automatically: Use the Slur Auto Direction
key command.
To add an automatic slur above selected notes: Use the Auto Slur Above key command.
To add an automatic slur below selected notes: Use the Auto Slur Below key command.
To position a selected automatic slur above selected notes: Use the Auto Slur Above
key command.
To position a selected automatic slur below selected notes: Use the Auto Slur Below
key command.
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To return a selected automatic slur to the automatic position: Use the Slur Auto Direction
key command.
To set the selected note as the final note of an automatic slur: Use the Slur Last Note
key command.

Add a manual slur

Automatic slurs are useful in many instances, but using a manual slur may be preferable
in situations where independent placement or more complex curves are needed. They are
also necessary in cases where you need an enclosing slur above note groups with one or
more automatic slurs.
1. Click the Slurs and Crescendi button in the Part box to show slurs, crescendo, and other
symbols.
2. Do one of the following:
•

Drag a manual slur from the Part box to the place in the score where you want it to
start (the left edge).

•

Select a manual slur in the Part box, then click with the Pencil tool at the place where
you want the slur to start.

3. Drag the handles to reshape the slur.
Note: These are slurs, not ties. Ties cannot be inserted manually, but are displayed
automatically if a MIDI note’s length requires it. For more information, see Control how ties
are displayed.

Add a crescendo or decrescendo

1. Drag a crescendo from the Part box to the place in the score where you want it to start
(the left edge).
The crescendo remains selected, and small square handles appear at its end points.
2. Drag the handles to extend the crescendo to the place where you want it to end (the
right edge).

Edit slurs and crescendi
•

To move a slur or crescendo: Select the item, then drag (from the center). Notice that
as you move the handle, alignment guides indicate the note to which it is attached.

•

To change the length of a slur or crescendo: Drag the rightmost handle. Notice that as
you move the handle, alignment guides indicate the note to which it is attached.
In Linear Score view, you can extend a slur to a position not visible in the Score Editor
by dragging its rightmost handle to the right border of the Score Editor. The score
scrolls automatically. When the end position for the slur appears in the window, move
the pointer back to the left slightly to stop scrolling, then position the end of the slur. It
is important that you do not release the mouse button during the entire process.
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In Page Score view, you can simply drag the right handle to the desired destination on a
lower staff. The slur is displayed in several sections.
The length can exceed the end of the MIDI region. It’s possible to drag the right handle
of a crescendo to a position in the next MIDI region on the same track.
•

To change the contour of a slur: Drag one or more of the inner handles until the slur
shows the correct contour.

•

To change the opening angle of a crescendo: Drag one or more of the rightmost handles
vertically.

•

To change the overall angle of a crescendo: Drag one or more of the rightmost handles
vertically.

The start position and length of these symbols can also be edited in the Event List or Event
Float window, by changing the corresponding numerical parameter.
You can also add notes and other symbols to multiple regions.

Change the appearance of note heads in a score in Logic Pro
Logic Pro offers a wide variety of note heads for percussion notation, harmonics, and other
uses. You can change note heads by dragging a note head from the Part box into the score.
Note heads are visual symbols only and have no effect on project playback.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Change a note head

1. If the Note Heads section of the Part box isn’t visible, click the Note Heads button in the
Part box.
2. Do one of the following:
•

To change a single note head: Drag a note head from the Part box onto the note.

•

To change multiple note heads: Select multiple notes, then drag a note head from
the Part box onto the selected notes.

•

To change one or more note heads: Select a note head in the Part box, then click one
or more note heads using the Pencil tool.

•

To return altered notes to a standard note head: Select the notes, then drag the
black, round note head from the Part box onto the altered notes.

•

To make a note head invisible in the printed score: Drag the gray note head onto the
note.
The note is displayed with a gray note head onscreen, allowing further edits. Nothing
but the stem is visible in the printout. You can combine this feature with the Note
Attributes > Stem > Hide command to completely hide these notes in the printed
score.

You can also change the appearance of note heads from the Attributes submenu of the
local Functions menu.
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Add accents and other symbols to notes in a score
in Logic Pro

The Part box includes symbols such as accents, fermatas, phrasing marks, bow markings,
and others that apply to a single note, over which the symbol appears. (Trills are in a
separate section).
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add an accent or other symbol to a note

1. If the Accents section of the Part box isn’t visible, click the Accents button in the Part
box.
2. Do one of the following:
•

To add a symbol to a single note: Drag a symbol from the Part box onto the note.

•

To freely place a symbol: Press and hold Option, then drag the symbol from the part
box to the position you want to place it.

•

To add symbols to multiple notes: Select multiple notes, then drag a symbol from the
Part box onto the selected notes.

•

To add symbols to one or more notes: Select a symbol in the Part box, then click one
or more notes using the Pencil tool.

Add trills, ornaments, and tremolo symbols to a score
in Logic Pro

The Part box includes symbols for trills and other ornaments, arpeggios, and tremolo
playing. These symbols can be placed anywhere in a score and are not attached to specific
notes. This Part box group also contains accidental symbols that are mainly intended to be
used with the trill symbols. These accidentals are purely visual, and do not affect the MIDI
playback of notes.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a trill or tremolo symbol

1. If the Trills section of the Part box isn’t visible, click the Trills button in the Part box.
2. Drag a symbol from the Part box to the position in the score where you want to add it.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.
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Add sustain pedal markers to a score in Logic Pro

Piano parts can display sustain pedal down and up markings in the Score Editor. When
you open a MIDI region with Sustain data (MIDI controller #64, sustain pedal on and off)
in the Score Editor, the Sustain data appears as pedal markings. Adding pedal markings
to the score makes the affected notes sustain (that is, the MIDI playback is affected).
These pedal markings are the only score symbols apart from notes that directly represent
MIDI events.
Logic Pro intelligently inserts the on (pedal down) or off (pedal up) version of the symbol,
depending on the last preceding pedal symbol on the staff (a sustain off always follows a
sustain on, and vice versa).

Add pedal symbols from the Insert pop-up menu

Choose Ped from the Insert pop-up menu in the Score Editor inspector, then Commandclick at the point where you want to add the pedal down symbol, and drag to the point
where you want to add the pedal up symbol.

Add sustain pedal symbols from the Part box

1. If the Pedal section of the Part box isn’t visible, click the Pedal button in the Part box.
2. Drag a pedal symbol from the Part box to the place in the score where you want to add it.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced. You can also add notes and other symbols to multiple regions.

Add chord symbols to a score in Logic Pro

You can quickly add chord symbols to a score. Chord symbols include the root note and
chord quality, and can also include extensions (added notes) and a non-root bass note
(sometimes called a slash chord, because the bass note is indicated by a diagonal slash).
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a chord symbol

1. If the Text section of the Part box isn’t visible, click the Text button in the Part box.
2. Do one of the following:
•

Drag the CHORD symbol from the Part box to the position in the score where you
want to add it.

•

Select the CHORD symbol in the Part box, then click a position in the score with the
Text tool.

•

Select any text symbol in the Part box, then Option-click a position in the score with
the Text tool.
Note: Watch the help tag to make sure you insert chord symbols at the correct bar
position.

3. Enter the text for the chord symbol:
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•

Enter the root note and the chord quality, then any extensions.

•

To add a bass note, type a slash, then the bass note.

810

•

After you enter a number, everything following it is placed in the upper extension
line. If you write “G7(b9/b13),” the whole “7(b9/b13)” is placed in the upper line, and
the lower line remains blank.

•

If you enter letters before a number (FMAJ7/9, for example), the letters appear in the
lower line, and everything following the first number, in the upper line.

•

You can override the automatic placement by entering a comma: everything before
the comma is placed in the lower line, and everything after it, in the upper line. Only
one comma can be used.

•

You can type a space to create additional horizontal space between the root and the
extension.

•

While the chord symbol is selected in the score, you can reposition it by dragging
horizontally or vertically.

4. To enter another chord symbol, press Tab, then repeat steps 1 through 3. The insertion
point moves to the position of the next (displayed) note or rest. Enter the desired chord
and repeat the process to add chord symbols to the score.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add chord grids and tablature symbols to a score
in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create and edit chord grids. For information about creating and editing chord
grids, see Chord grids overview.

Logic Pro includes a large library of chord grids, using both standard tuning and a variety
of alternative tunings. The Part box also features a variety of tablature symbols that you
can add to your score, including ties, slides, bends, hammer-ons and pull-offs, and tab and
slide markings.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a chord grid

1. If the Chord & Tablature section of the Part box isn’t visible, click the Chord button in
the Part box.
2. Do one of the following:
•

Drag a chord grid symbol from the Part box into the score.

•

Choose a chord grid symbol in the Part box, then click a position in the score with
the Pencil tool.
The Chord Grid Selector pane of the Chord Grid Library opens.

3. Select the chord grid you want to add, then click OK.
While the chord grid is selected in the score, you can reposition it by dragging
horizontally or vertically.
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Add a tablature symbol

1. If the Chord & Tablature section of the Part box isn’t visible, click the Chord button in
the Part box.
2. Do one of the following:
•

Drag a symbol from the Part box into the score.

•

Choose a symbol in the Part box, then click a position in the score with the Pencil
tool.

You can also display regions as tablature using the appropriate staff style. For information
about choosing staff styles, see Staff styles overview.

Add bar lines, repeats, and coda signs to a score
in Logic Pro

You can add bar lines, repeat signs, coda signs, and other symbols at the beginning or end
of a bar, or at any visible bar position (where a note or rest is displayed). These symbols
are only visual, and have no effect on MIDI playback.
These are global symbols that are displayed in all staffs, at all display levels. When added
to a score, bar lines and repeat signs (except for first and second ending signs) replace the
regular bar line.
The one- or two-bar repeat symbols replace all notes and rests in the corresponding bars;
all other symbols remain visible. Hidden notes can still be heard, so MIDI playback is not
affected. These signs can be moved only in the Event List or Event Float window.
When a double repeat sign is positioned at a line break, it is automatically displayed as
two back-to-back repeat signs, one at the end of the line, and one at the beginning of the
next line.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a bar line, repeat sign, or coda sign

1. If the Bars and Repeats section of the Part box isn’t visible, click the Bars and Repeats
button in the Part box.
2. Drag a symbol from the Part box to the place in the score where you want to add it.

Delete an added bar line or repeat sign
Click the symbol with the Eraser tool.

Add a first or second ending symbol

1. Drag the symbol from the Part box to the place in the score where you want to add it.
After you add a repeat ending symbol, you can edit the ending number. The default text
is “1.” and “2.” To accept the defaults, press Return. Alternatively, enter any text into
these brackets. The bracket that defaults to “2.” is open—without a vertical end line, like
the “1.” ending.
2. If necessary, move the symbol to the correct position by dragging its upper-left corner.
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3. Adjust the length of the symbol by dragging its right end.
4. You can delete a repeat ending by selecting it, then pressing the Delete key.
First and second endings are only displayed on staffs with bar lines that aren’t
connected to the staff above. The Alternate Repeat Symbols (for the whole project)
option in File > Project Settings > Score > Global activates a real book–style display of
repeat signs.

Add page and line break symbols to a score in Logic Pro

You can add page and line break symbols (and No Page Break and No Line Break events)
from the Part box. Once added to the score, they cannot be moved automatically (when
you alter the Layout project settings, resize the window, and so on).

You can overrule the Page Break, Line Break, No Page Break, and No Line Break events
with the Layout tool.
Line breaks and individual staff margins can be determined for each score set, and also for
each of the extracted parts. For more information, see Line and page breaks.
The Part box is available when Enable Complete Features is selected in Logic Pro >
Preferences > Advanced.

Add a line break symbol

Drag a Line Break symbol from the Part box to the score.

Add a page break symbol

Drag a Page Break symbol from the Part box to the score.

Add a line or page break using the shortcut menu
1. Control-click a bar line.

2. Choose a line or page break setting from the shortcut menu.
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Edit notes in the Score Editor
Select notes in the Score Editor in Logic Pro

Before you can perform some edits to notes in the Score Editor, you need to select them.

Select a note

Do one of the following:
•

Click the note head.

•

Select multiple notes by Shift-clicking or by dragging around the notes to enclose them.

Select all notes

Choose Edit > Select All (or press Command-A).
All visible notes are selected.

Select all notes following the currently selected note
Choose Edit > Select All Following.

Select all following notes of the same pitch as the currently selected note
Choose Edit > Select All Following of Same Pitch.

Move and copy notes in the Score Editor in Logic Pro

You can move notes in the Score Editor to change the position in time where they start to
play back.

Move notes in the Score Editor
•

Select one or more notes, then drag left or right.

Copy notes in the Score Editor

Option-drag the note head to a new position.
Select one or more notes, then choose Edit > Copy (or press Command-C).
When you choose Edit > Paste (or press Command-V), the note is pasted at the
playhead position.
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Change note pitch, duration, and velocity in the Score Editor
in Logic Pro
You can change the pitch and duration (length) of selected notes in the Score Editor, as
well as their MIDI velocity. The Velocity value signifies how hard the key was struck when
the note was recorded. It often corresponds to the volume of the note when played back,
but can control other parameters as well.

Change a note’s pitch

Select one or more notes, then do one of the following:
•

Drag the notes up or down.

•

Use Option-Up Arrow and Option-Down Arrow to raise or lower the pitch in
semitones.

•

Edit the Pitch value in the Event inspector.

•

Use the Event Transpose +1 or the Event Transpose –1 key command.

You can also use Option-Up Arrow and Option-Down Arrow to raise or lower the pitch of
selected chord symbols.

Change a note’s length

Select one or more notes, then do one of the following:
•

Edit the Length parameter in the Event inspector (shown as bars, beats, and ticks).

•

Use one of the Nudge Region/Event Length key commands.

•

Drag the right edge of the duration bar for the note horizontally to shorten or
lengthen the note.

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can show duration bars for selected notes or for all notes by choosing the
corresponding menu item in the Score Editor’s View > Duration Bars submenu.

Change a note’s velocity
Do one of the following:
•

Select a note, then press and hold Command while dragging up or down.

•

Select one or more notes, then edit the Velocity setting in the Event inspector.

•

Select one or more notes with the Velocity tool, then move the pointer up or down.

•

In Linear view, select one or more notes, then drag the Velocity slider in the Score Editor
inspector left or right.

The Velocity value appears in a help tag as you edit it. You can also hear the change, if the
MIDI Out button
is activated.
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Change note articulations in the Score Editor in Logic Pro

For patches supporting note articulations, you can change the articulations for notes in the
Score Editor. For more information about using articulations, see Articulation editing overview.

Change the articulation of selected notes

1. Select one or more notes in the Score Editor.
2. Control-click a selected note.
3. Choose Articulation from the shortcut menu, then choose an articulation from the
submenu.

Quantize the timing of notes in the Score Editor in Logic Pro

You can quantize, or automatically correct, the timing of individual MIDI notes in the Score
Editor. This is useful when regions in the track contain the right notes, but are not perfectly
in time with the project. When you quantize the timing, items are adjusted to the selected
note value. You can quantize the timing of regions with drums, single-note instruments,
and chordal or polyphonic instruments.
The Time Quantize controls quantize notes and other items non-destructively, for playback
only. The original timing is never lost, and can be recalled by setting the value to off.
Time quantization in the Score Editor works in the same way as time quantization in the
Piano Roll Editor. In the Score Editor, you can also visually quantize the display of notes
(independent of their MIDI time quantization) in the Region inspector. For information about
visual quantization, see Quantize.

Quantize the timing of MIDI notes in the Score Editor

1. In the Score Editor, select the notes you want to quantize.
2. From the Time Quantize pop-up menu, choose the note value you want to use to
quantize the timing of the selected items.
3. To set the degree of quantization, drag the Strength slider left or right.
4. To set the degree of swing, drag the Swing slider left or right.

Edit note attributes
Overview of note attributes in Logic Pro

You can control the appearance of individual notes in the Score Editor using note
attributes. Note attributes include note size and position, accidentals, stems, beaming, and
interpretation. Using note attributes, you can enhance the readability of the score and add
performance information.
There are three ways to change note attributes: in the Note Attributes window, using
the Functions > Attributes submenu, or using key commands. You can change attributes
for a group of selected notes in the Attributes submenu (and with corresponding key
commands), but can change attributes for only one note in the Note Attributes window. You
can also change some note attributes via the Part box, and with tools.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional note attributes, including accidental type, note heads, stem position, and
syncopation are available in the Note Attributes dialog and the Note Attributes shortcut menu.
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Change note attributes
Do one of the following:
•

Select one or more notes, then choose an option from the Score Editor’s Functions >
Attributes submenu.

•

Control-click a note head, choose Attributes from the shortcut menu, then choose the
specific attribute from the submenu.

•

Double-click a note head to open the Note Attributes window.

To open the Note Attributes window by double-clicking, make sure the Note Attributes
setting is chosen in the “Double-click note to open” pop-up menu of the Logic Pro >
Preferences > Score window.

Change note heads in a score in Logic Pro
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can choose note heads to use for a variety of specific situations, such as percussion
parts, harmonics, tremolo, and for other special conditions.

Change note head attributes
Do one of the following:
•

Drag a note head from the Part box to the note you want to change.

•

Double-click a note, then choose a note head from the Note Head pop-up menu in the
Note Attributes window.

For more information about dragging note heads from the Part box, see Change
note heads.
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Change note size and position in a score in Logic Pro
The default note size is set with the Size parameter in the Staff Style window. You can
change the size of individual notes, and also change their horizontal position in the score.

Change a note’s size

Do one of the following:
•

Drag the note upward (increase) or downward (decrease) with the Resize tool.

•

Double-click a note, then choose a size from the Size pop-up menu in the Note
Attributes window.

Change a note’s horizontal position
Do one of the following:
•

Drag the note horizontally with the Layout tool.

•

Double-click a note, then choose a value from the Horizontal Position pop-up menu in
the Note Attributes window.

Change how accidentals appear in a score in Logic Pro
By default, the display of accidentals depends on the chosen key signature. Using note
attributes, you can change flats to sharps, and vice versa. For information about setting
the key signature, see Add key and time signature changes.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional options for changing note accidentals are available.
The Accidental Position attribute defines the deviation from the Acc./Note Distance value,
chosen in File > Project Settings > Score > Layout.

Change the display of accidentals
Do one of the following:
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•

In the Note Attributes window, choose a value from the Enharmonic Shift or Accidental
Type pop-up menu (see list of settings below).

•

Choose Functions > Note Attributes > Accidentals from the Score Editor menu bar, then
choose one of the following display options:
•

Default Accidental: The display of accidentals depends on the chosen key signature.

•

Enharmonic Shift#: Converts G flat to F sharp, or F to E sharp, for example.

•

Enharmonic Shiftb: Converts D sharp to E flat, or B to C flat, for example.

•

Flats To Sharps: Similar to Enharmonic Shift #, but leaves notes without flats
unaltered (useful for multiple selection).

•

Sharps To Flats: Similar to Enharmonic Shift b, but leaves notes without sharps
unaltered (useful for multiple selection).

•

Force Accidental: Forces the display of accidentals (and naturals).

•

Hide Accidental: Displays the note without accidentals (MIDI playback is not affected).

•

Guide Accidental: Forces the display of the accidentals (and naturals) in
parentheses.
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•

Control-click a note head, choose Attributes > Accidentals from the shortcut menu,
then choose an option from the submenu.

•

Use one of the following key commands:
•

Default Accidentals

•

Enharmonic Shift: #

•

Enharmonic Shift: b

•

Flats To Sharps

•

Sharps To Flats

•

Force Accidental

•

Hide Accidental

•

Guide Accidental

Change the distance between the accidental and the note

Double-click a note, then choose a value from the Accidental Position pop-up menu in the
Note Attributes window.

Control beaming in the Score Editor in Logic Pro
By default, a note’s stem direction and length depend on the settings in the Staff Style
window. You can change these attributes to improve readability; for example, to group
notes meant to be played as a voice in a polyphonic passage.
The beaming of notes depends on the chosen time signature, the Beat Grouping setting
in the Time Signature dialog, and the staff style’s Beam parameter. You can change the
beaming of individual notes to improve readability by clarifying the rhythmic structure or
phrasing of notes.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
additional options for changing note attributes are available.

Change a note’s stem direction and length
Do one of the following:
•

Double-click a note, then choose a value from the Stem Direction pop-up menu in the
Note Attributes window.
Note: The stem length cannot be changed in the Note Attributes window.

•
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Choose Functions > Note Attributes > Stems from the Score Editor menu bar, then
choose one of the following options:
•

Default: The stem direction is set in accordance with the default (staff style) setting.

•

Up: Forces the note’s stem upward.

•

Down: Forces the note’s stem downward.

•

Hide: Hides a note’s stem, and the corresponding beam or flag.

•

Stem Position: Default: Uses the default setting.

•

Stem Position: Center: Moves the stem to the center.

•

Stem Position: Side: Moves the stem to the side.
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•

Stem Position: Automatic: Moves the stem to the side.

•

Stem End: Default Length: Uses the default setting.

•

Stem End: Move Up: Moves the stem end upward. Depending on the direction, this
shortens or lengthens the stem.

•

Stem End: Move Down: As above, but moves the stem end downward.

•

Control-click a note head, choose Attributes > Stems from the shortcut menu, then
choose an option from the submenu.

•

Use one of the following key commands:
•

Stems: Default

•

Stems: Up

•

Stems: Down

•

Stems: Hide

•

Stem End: Default Length

•

Stem End: Move Up

•

Stem End: Move Down

Change the beaming of selected notes
Do one of the following:
•
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Choose Functions > Note Attributes > Beaming from the Score Editor menu bar, then
choose one of the following:
•

Beam Selected Notes: Forces a beam to the following note.

•

Unbeam Selected Notes: Interrupts the beam to the following note.

•

Default Beams: Uses the default setting.

•

Control-click a note head, choose Attributes > Beaming from the shortcut menu, then
choose an option from the submenu.

•

Use one of the following key commands:
•

Beam Selected Notes

•

Unbeam Selected Notes

•

Default Beams
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Change voice and staff assignments in the Score Editor in Logic Pro
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can change the voice or staff assignment of selected notes for cross staff beaming.
For more information about cross staff beaming, see Beam notes across staffs.

Change the voice or staff assignment for selected notes
Do one of the following:

Choose one of the following from the Score Editor’s Functions > Note Attributes >
Ties submenu:
•

Default Staff: Moves the selected notes to the appropriate staff according to their
voice assignment.

•

Staff Above Voice: Moves the selected notes to the staff above the assigned voice.

•

Staff Below Voice: Moves the selected notes to the staff below the assigned voice.

Control-click a note head, choose Attributes > Voice/Staff Assignment from the shortcut
menu, then choose an option from the submenu.

Change the direction of ties in the Score Editor in Logic Pro
By default, the tie direction is set as part of the staff style for the track (or region). You can
manually change the direction of ties for individual notes to improve readability.

Change a note’s tie direction
Do one of the following:

Choose a setting from the Score Editor’s Functions > Note Attributes > Ties submenu.
Double-click a note, then choose a tie direction from the Tie Direction pop-up menu in the
Note Attributes window.
Control-click a note head, choose Attributes > Ties from the shortcut menu, then choose
an option from the submenu.
Use one of the following key commands:

Logic Pro User Guide

•

Ties: default

•

Ties: up

•

Ties: down
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Change note syncopation and interpretation in the Score Editor
in Logic Pro
By default, note syncopation and interpretation match the settings chosen in the
Region inspector. You can change interpretation settings for individual notes to improve
readability.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can change syncopation settings for individual notes.

Change a note’s Syncopation setting
Do one of the following:

Choose a setting from the Score Editor’s Functions > Note Attributes >
Syncopation submenu.
Double-click a note, then choose a setting from the Syncopation pop-up menu in the Note
Attributes window.
Control-click a note head, choose Attributes > Syncopation from the shortcut menu, then
choose an option from the submenu.
Use one of the following key commands:
•

Default Syncopation

•

Force Syncopation

•

Defeat Syncopation

Change a note’s Interpretation setting
Do one of the following:

Choose a setting from the Score Editor’s Note Attributes > Interpretation submenu.
Double-click a note, then choose a setting from the Interpretation pop-up menu in the Note
Attributes window.
Control-click a note head, choose Attributes > Interpretation from the shortcut menu, then
choose an entry from the submenu.
Use one of the following key commands:
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•

Default Interpretation

•

Force Interpretation

•

Defeat Interpretation
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Use independent notes in the Score Editor in Logic Pro
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can display notes in the score as independent notes and edit their independent status.
Independent notes are not tied to a rhythmic position in the staff, and can be moved freely.
This can be used to add grace notes, for example, and for other purposes.

Change the independent status of a note
Do one of the following:

Choose Functions > Note Attributes > Independent from the Score Editor menu bar, then
choose one of the following settings:
•

Independent Grace: The note is displayed as a single (independent) grace note.

•

Independent: The note is displayed independent of the rhythmic context.

•

Not Independent: The note is displayed in the regular rhythmic context.

Control-click a note head, choose Attributes > Independent from the shortcut menu, then
choose an option from the submenu.
Use one of the following key commands:
•

Not Independent

•

Independent

•

Independent Grace

Change note color in the Score Editor in Logic Pro
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can assign different colors to individual notes, using the available colors in the three
color palettes.

Assign a color to a note
Do one of the following:

Select the note, then choose Functions > Note Attributes > Colors from the Score Editor
menu bar, and choose a color.
Control-click a note head, choose Attributes > Colors from the shortcut menu, then choose
an option from the submenu.
You can also turn on the Velocity or Pitch Color mode in the Colors submenu. Pitch colors
can be diatonically or chromatically mapped. Note that velocity colors match particular
MIDI velocity ranges.
You can edit the 16 color options of the Score Editor’s Functions > Attributes submenu,
the velocity colors, and the pitch colors in File > Project Settings > Score > Color. For more
information, see Colors settings.
Note: As note attributes, these settings have priority over the staff style settings, but they
only apply if the Color mode is set to Normal in the Score Editor’s View > Colors submenu.
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Reset note attributes in the Score Editor in Logic Pro
You can reset all note attributes to their default settings if you decide you don’t want to
keep your changes. When resetting note attributes, be aware that all symbols directly
attached to notes (accents, fermatas, jazz symbols, and so on) are deleted.

Reset note attribute settings
Do one of the following:

Choose the Score Editor’s Functions > Note Attributes > Reset All Attributes option (or use
the Reset Note Attributes key command).
Control-click a note head, then choose Attributes > Reset All Attributes from the
shortcut menu.

Restrict note input to the current key in the Score Editor
in Logic Pro

If you’re working in a diatonic key (major, minor, or modal), using the Diatonic Input
feature can help you quickly add notes. This feature restricts note input to the notes of the
current key.

Turn on Diatonic Input

Choose Edit > Diatonic Insert from the Score Editor menu bar.
Notes can be altered chromatically, after they have been inserted.
Note: If you protect (lock) your screensets, this function’s setting is also locked.

Control how ties are displayed in the Score Editor
in Logic Pro

Ties display the underlying rhythmic divisions of notes held over several beats, for easier
readability. Notes connected with a tie represent a single MIDI note event.
Ties are displayed automatically according to the length of the MIDI note and the rhythmic
divisions of the score (time signature). If you don’t like the way a tied note is displayed, you
can change the display by inserting a user rest at the position you want to see a graphic
note. You can’t add ties to notes manually.

Create tied notes

1. Insert a note with a value shorter than the one you want it to have.
2. Do one of the following:
•

Change the note length in the Event inspector, the Event List, or the Event Float
window.

•

Use the note’s duration bar to graphically edit the note length.

Tip: For information about using duration bars, see Display duration bars and Edit the
length of duration bars.
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Change the display of tied notes with a user rest
Insert a short rest following the tied note.

The length of the rest is not important, but you should use a shorter one (an eighth note
rest), if possible. Watch the help tag for exact positioning. After the rest is inserted, it’s no
longer visible in the score display, but the note display changes accordingly.
Note: If you want to delete or change the position of an invisible user rest, use the Event List.

Change the direction of a tie

Choose a setting from the Score Editor’s Functions > Note Attributes > Ties submenu.

Add and edit tuplets in the Score Editor in Logic Pro

You can add and edit tuplets—groups of notes evenly divided over a specific rhythmic
value—in the Score Editor. The most common tuplet is the triplet (a group of three notes
that typically occupies the space of two or four notes).
The symbol for tuplets is grouped together with the symbols for triplets in the Notes group
in the Part box.

In some cases, you need to choose an appropriate display Quantize value in the Region
inspector. See Quantize. You use the N-tuplet object for the display of other tuplets.

Change how a tuplet is displayed

1. Drag the N-tuplet symbol from the Part box onto the first note.
The target note must be indicated in the help tag before you release the mouse button.
The Tuplet window opens.
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Set the appropriate parameters in the Tuplet window:
•

Tuplet number of notes: Set the number of tuplet notes in the upper-left field.

•

Tuplet time value: Set the time value in which the tuplets occur in the upper-right
numerical field.

•

Tuplet note value: Choose the note value of the tuplets (1/8, 1/16, 1/32, and so on)
from the pop-up menu.

•

Hide bracket: Select to hide the bracket over the tuplets.

•

Hide numbers: When selected, the tuplet number will not be printed. It will be
displayed in parentheses, to allow further edits to the N-tuplet.

•

Show note value: Select to have the N-tuplet display also contain the note value (the
lower number).

•

Direction: Choose the direction of the bracket and number, or choose Auto to have
the tuplet use the staff style for the track or region.

•

Allow double values: When selected, N-tuplets can contain note values that are
twice as long as the regular tuplet value.

•

Allow half values: When selected, N-tuplets can contain note values that are half the
length of the regular tuplet value.
Tip: Most parameter changes in the Tuplet dialog are reflected in the graphic at
the top of the dialog.

2. Click OK.
In the score, the above example would look like this:

Insert tuplets with the pointer

1. Insert the first note where you want it to appear in the score.
2. Drag the N-tuplet symbol onto it.
If you press and hold Option as you insert the N-tuplet symbol, the most recently
inserted N-tuplet settings are used, without the dialog opening.
3. Define the settings in the Tuplet window.
The display initially shows a series of rests, the number of which corresponds to the
N-tuplet value. You can insert other notes at these rest positions. To do so, select a note
value that approximately matches the length of the desired N-tuplet notes.
The method described above also allows you to create N-tuplets that contain rests or
syncopated note values (double length).
Tip: If you want an N-tuplet to begin with a rest, you first need to insert a user rest from
the Part box, then drag the N-tuplet symbol onto the rest. Automatically displayed rests
cannot function as starting points for N-tuplets.
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Make tuplets play with legato phrasing
1. Select the tuplet (or other) notes.

2. Choose Functions > Note Events > Note Force Legato (selected/any) from the Score
Editor menu bar, or use the corresponding key command.

Edit tuplets

Double-click the N-tuplet number, then define settings in the Tuplet window.

Delete a tuplet

Do one of the following:
Click the tuplet number with the Eraser tool.
Double-click the N-tuplet number, then click the Delete button in the Tuplet window.

Override display quantization in the Score Editor in Logic Pro
You can override the display quantization value by using hidden tuplets. For example, if
you want to display a single 32nd–note run in a MIDI region that otherwise contains eighth
notes or longer values, you can set the Quantize value in the Region inspector to 1/8, and
then drag the N-tuplet symbol onto the first note of the 32nd figure. In the Tuplet dialog,
use the 8:8/32 setting, with “Hide brackets” and “Hide numbers” selected. The number (8)
appears onscreen, but not when you print the score.
Although this is not the normal use of tuplets, it’s a handy way to force the display of runs
of shorter note values with a display Quantize value set for longer note values.

Add grace and independent notes in the Score Editor
in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add grace notes and other independent notes to a score. Independent notes are
notes that aren’t included in the automatic rhythmic (and graphic) display calculation of a
measure, but are still played back via MIDI.

•

Independent: Displayed at their original length, as long as they are binary or dotted note
values that can be displayed as a single (not tied) note. After insertion, you can change
the stem direction, enharmonic interpretation, accidental distance, and note head, using
the Note Attributes functions. For more information, see Overview of note attributes in
Logic Pro.

•

Independent grace: Always displayed as miniature eighth notes, with a slash across the
stem, and a tie. The tie direction, stem direction, enharmonic interpretation, accidental
distance, and note head can be changed.

Both types of independent notes appear only as single notes, without beams.
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Convert notes to independent notes

Select the notes, then choose Functions > Note Attributes > Independent > Independent
from the Score Editor menu bar, or use the corresponding key command.
Choose Functions > Note Attributes > Independent > Not Independent to convert
independent notes back to regular notes.

Convert notes to grace notes

Select the notes, then choose Functions > Note Attributes > Independent > Independent
Grace from the Score Editor menu bar, or use the corresponding key command.
Choose Functions > Note Attributes > Independent > Not Independent to convert
independent notes back to regular notes.

Insert an independent note directly

Press and hold Option while selecting a note in the Part box, then drag it to the
desired position.
Grace notes cannot be inserted directly. They need to be created by converting regular or
independent notes.
Important: In most situations, you will need to create additional space between the grace
note and the note it’s associated with. The best way to do this is with the Layout tool,
which can be used to move the main note away from the grace note. For information, see
Position items graphically.
Tip: If you want to create beamed grace notes, try using a polyphonic staff style with
no rests displayed for the second voice. Assign the grace notes to the second voice, and
resize them with the Resize tool. See Add and delete staffs or voices in the Staff Style
window in Logic Pro for more information on staff styles.

Delete notes in the Score Editor in Logic Pro

You can delete notes and other items displayed in the Score Editor. Events such as MIDI
controller events or pitch bend data are not deleted, even if you delete the notes the
events were recorded with.

Delete a note or other item in the Score Editor
Do one of the following:
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•

Select the item, then choose Edit > Delete (or press the Delete key).

•

Click the item with the Eraser tool.
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Repeat signs and special bar lines cannot be selected, and can only be deleted with the
Eraser tool.

Use automation in the Score Editor in Logic Pro

You can create and edit automation data directly in the Score Editor. This is especially
useful with region automation, because you can see the notes that are affected. For
information about using Automation, see Automation overview.

Show automation in the Score Editor
Do one of the following:
•

Click the Show/Hide Automation button

•

Press A.

in the Piano Roll Editor menu bar.

An Automation button, an Automation Parameter pop-up menu, and an Automation Mode
pop-up menu appear at the bottom of the Piano Roll Editor inspector. The colors of the text
and background of the selected Automation Mode pop-up menu item display the current
state of automation and if there is automation data present:
•

White text on a gray background means automation is off

•

Dark green text on a gray background means automation is on but there is no
existing automation data to display

•

Bright green text on a green background means automation is on and there is
existing automation data to display

Any existing automation is displayed in the Automation Lane under the main editor window.
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Add lyrics and text
Overview of lyrics and text in a score in Logic Pro

When you’re scoring a song for solo voice or for a vocal ensemble, you can add lyrics,
which are automatically aligned to notes in the score. Other types of text, such as
dynamics and other performance indications, can also be added to the score. You can add
and edit text in the Score Editor and precisely control the position of text in the score.
The Score Editor includes automatic text for song name, date, and other information; you
can also add global text that appears in both the full score and in each individual part. You
can also add notes and other symbols to multiple regions.

Add lyrics to a score in Logic Pro

You can add lyrics aligned to notes in the score using the lyric object in the Part box, which
also lets you add lyrics for multiple verses. After adding lyrics, you can adjust their vertical
and horizontal position for better readability.
If you’re working with multiple staffs, be careful to add lyrics to the correct MIDI region.
It’s recommended that you insert lyrics in Linear Score view and single MIDI region display
mode—especially when inserting more than one verse. Linear Score view also makes it
easier to select several lyric objects by dragging, to change their positions, for example.

Add lyrics to a score

1. Do one of the following:
•

Drag the lyric object below the first note of the melody.

•

Select the lyric object in the Part box, then click the position of the first note with
the Text tool.
Note: Watch the help tag. Each lyric object must be at the same bar position as the
note it belongs to (taking display quantization into account).

2. Enter the text for the first note, then press Tab (not Return) to automatically move the
insertion point to the next note.
If a note is displayed as several tied notes, press Shift-Tab to move the insertion point
to the next tied note. This method allows you to write several syllables below one longer
note, and lets you enter all lyrics in one operation, although each syllable is saved as an
independent lyric object.
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3. To convert standard text to lyrics, select the text, then select the Lyric checkbox in the
Text Event inspector.

Add lyrics for multiple verses

1. Add lyrics for the first verse (as described in the previous task).
2. Drag a second lyric object to the same note position below the lyric object for the first
verse, and enter the second verse.
3. Repeat the process for any additional verses.
As long as you enter lyrics continuously and do not leave this mode, all lyric objects
for the second verse stay at the same height as the initial object—in this case, the first
word of the second verse.

Quickly align multiple lyric objects

You can use this method to quickly align sequential Lyric text objects for the same verse,
but not for different verses. Doing so would set them all to the same height.
1. Select the lyric objects you want to align.
To select all lyric objects, select one lyric object, then choose Edit > Select Similar
Objects.
2. Use the Align Object Positions Vertically key command.

Convert standard text to lyrics

Select the text, then select the Lyric checkbox in the Text Event inspector.

Add and edit text
Add text to a score in Logic Pro
You can use text objects in the Part box to add standard text (text other than lyrics,
automatic text, or global text). The basic functions for moving the pointer, deleting parts of
the text, and so on, are the same as they are for most text-editing apps.
You can also use text objects (with a music symbol font) to add and position music symbols
anywhere in the score, free of the rhythmic constraints of MIDI notes.

Add text to the score

1. Select a text object in the Part box.
2. Do one of the following:
•

Drag the text object where you want it to appear in the score.

•

Select the Text tool (or use the Set Text Tool key command), then click the position
where you want the text to appear.
An insertion point appears at the target position. (If you choose one of the automatic
text objects, the corresponding text for that object is inserted automatically.)
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3. Enter your text.

As long as you’re in Text Entry mode (indicated by the blinking insertion point), you can
click any position in the text field. You can select parts of the text by dragging the pointer
in the text field, and cut, copy, and paste text. Press Return, or click anywhere outside the
text field, to exit Text Entry mode.
Each text object (except text in the header, or at or outside the page margins) is saved as a
meta event in a particular MIDI region, at a specific bar position. This position is displayed
in the help tag as you insert the text object. Text events are also displayed in the Event List,
allowing you to change their position, but not the text itself.

Tip: You can simultaneously add text to several staffs. This is handy if you want to
insert the text “accelerando al fine,” for example, into all instruments. You can enter text
into several staffs at once just as you can other objects. For more information, see Insert
items in multiple regions.
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Edit text in a score in Logic Pro
In general, you edit text objects in the same way as other objects. If a text object is
selected, you can set its parameters in the Event inspector.
You edit standard text in a text object the same way you edit text in a text-editing program.
You can also change font settings for standard text in the Fonts window.

Edit standard text in a score
1. Do one of the following:
•

Click the text with the Text tool.

•

Double-click the text with the Pointer tool.

2. Edit the selected text.

Change font settings

1. Select the text you want to change.
2. Choose Functions > Text Attributes > Fonts from the Score Editor menu bar, then
choose settings in the Fonts window.

Edit score text event parameters in Logic Pro
You can edit event parameters for a text object in the Event inspector, including the staff
number, text style, text alignment, vertical and horizontal position, and whether or not the
text is lyric text.

Edit text event parameters

1. Select the text you want to change.
2. In the Event inspector, do any of the following:
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•

To change the staff for the text object: Drag the Staff number up or down. (This is
only relevant for multiple staff styles.)

•

To convert the text to lyric text: Select the Lyric checkbox.

•

To change the text style: Choose a different text style from the Staff Style pop-up
menu.

•

To change the text alignment: Choose a different text alignment from the Align
pop-up menu.

•

To change the position of the text object in the score: Drag the Vertical Pos and
Horizontal Pos numbers up or down.
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Use text styles in a score in Logic Pro
You control the appearance of text in the Score Editor using text styles. A text style
contains a set of text attributes, such as font, size, and style, which you can apply to
text objects. You can also create your own text styles, and import them from other
Logic Pro projects.
You apply, edit, and create text styles in the Text Styles window, which lists all the text
styles in the current project. Default text styles appear at the top of the list, followed
by user-created text styles. Each line shows the name and an example of the text style.
Double-clicking the Example line opens the Font window, where you can edit both the
default and user text styles. Any fonts installed on your system can be used.
User text styles are saved with the project file, allowing them to be different for
each project.
The default text styles have been designed for specific text elements, and are
automatically assigned when inserted.
•

Plain Text: The default setting for regular text.

•

Page Numbers, Bar Numbers, Instrument Names: Used for automatic page and bar
numbering, and display of instrument names (see Numbers & Names settings). These
styles can also be edited in File > Project Settings > Score > Numbers & Names.
Changes in either window automatically update the settings in the other window, and
affect the entire project.

•

Tuplets: Used for triplet and other tuplet numbers.

•

Repeat Endings: Used for anything written into the repeat ending boxes (usually just
numbers, but text can also be entered).

•

Chord Root, Chord Extension: Used for the display of chord symbols. The Root covers
the root and (optional) extra bass note in chord symbols. The Chord Extension is used
for everything else.

•

Multiple Rests: Used for the number above multiple rests.

•

Tablature: Used for the display of fret numbers in guitar tablature.

•

Tempo Symbols: Used for the display of numbers in tempo symbols.

•

Octave Symbols: Used for the display of octave symbols.

•

Note Heads: Used for the display of note heads.

•

Guitar Grid Fingerings: Used for the display of guitar grid fingerings.

•

Guitar Markings: Used for the display of guitar markings.

•

Fingerings: Used for the display of fingering markings.

Open the Text Styles window

Choose Layout > Text Styles from the Score Editor menu bar.

Apply a text style to a text object

Select the text object, then choose a text style from the Style pop-up menu in the Event
inspector.
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Create a new text style

Choose New > New Text Style in the Text Styles window.
A new line appears below the bottom text style entry, where you can define the attributes
of the new text style. The names of any new style can be edited in the text field, which
opens when you double-click the name of the text style.

Import text styles from another project
1. Do one of the following:
•

Choose File > Project Settings > Import Project Settings.

•

Click the Browsers button

in the control bar, then click All Files.

2. Navigate to and select the project whose styles you want to use, then click the Import
button.
Note: If accessing the settings from the All Files Browser, you also need to click the
Import Project Settings button, which appears after you click the Import button.
3. In the Import Settings window, select the Text Styles checkbox, then click the Import
button.
Text style settings are imported into the active project.

Add automatic text to a score in Logic Pro

The text group in the Part box contains four objects you can use to add the display
level, instrument name, project name, and date. The corresponding text is automatically
displayed at the position you place the object:
•

REGION: Displays the name of the current display level. This can be a MIDI region, a
folder, or even the name of the project file (on the highest level).

•

INSTR (Instrument): Displays the name of the currently displayed instrument or score
set. For more information, see Score sets overview.

•

SONG: Displays the name of the project file.

•

DATE: Displays the current date (at the time of printout).

Automatic text objects can be inserted as both global text (in the margin areas), or as text
objects related to a bar position (in one of the staffs or regions). For example, you can
insert the INSTR object as a global object to display the name of the current score set on
all pages. The appearance, and exact positioning, of these objects can be set in the Event
inspector.

Add an automatic text object

Drag a REGION, INST, SONG, or DATE text object from the Part box to the score.
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Add global text to a score in Logic Pro

Score sets determine which software instrument tracks are included in the score display.
Each project can contain as many score sets as required. For more information on score
sets, see Score sets overview.
Global text objects appear in all score sets of a project (score, parts, and so on), although
they’re inserted just once.
Unlike regular text objects, the position of global text does not relate to bar positions, but
is defined as a graphic position on the page. Global text can be inserted and viewed only in
Page view. A common example of a global text object is a song name, commonly placed in
the page header.

Add a global text object

Drag a text object from the Part box to one of the following areas of the page:
•

In the header space (set in Layout > Global Format).

•

Outside, or directly on, any of the page margin lines.

Text objects inserted in one of these areas automatically become global text objects.
After you add global text to one of the margin areas, you can move it anywhere
on the page.

Position global text

Do one of the following:
To move global text objects vertically only: Use the Pointer tool.
To move global text objects both vertically and horizontally: Press and hold Shift, then use
the Pointer tool; or use the Layout tool.
When a global text object is selected, the Event inspector contains the following additional
parameters:
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•

Align pop-up menu: Although alignments relating to bar positions are shown in the popup menu, you can’t choose them here.

•

Pages pop-up menu: Defines the pages that the global text object is displayed on. You
can choose between the following options:

•

•

1: The text will only be displayed on the first page.

•

2: The text will be displayed on all pages except the first one.

•

Odd: The text will be displayed on all pages with odd numbers.

•

Even: The text will be displayed on all pages with even numbers.

•

All: The text will be displayed on all pages.

Zone pop-up menu: The margin area that the text belongs to or is associated with. You
can choose between Top, Header, Side, Footer, and Bottom.

Work with chord grids
Overview of chord grids in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can add chord grid symbols from the Part box. Logic Pro includes a large library of
chord grids, in standard tuning and in a variety of alternative tunings.
You can review and edit existing chord grid libraries and chord grids, as well as create your
own, in the Chord Grid Library.
The Chord Grid Library window contains three panes: the Instrument Editor, Chord Grid
Selector, and Chord Grid Editor. The Instrument Editor may not be available, depending on
which method you use to open the Chord Grid Library.

Open the Chord Grid Library
Do one of the following:

Choose Logic Pro > Preferences > Chord Grid Library.
Choose Layout > Chord Grid Library from the Score Editor menu bar.
Drag a chord grid symbol from the Part box into the score.
Double-click an existing chord grid symbol in the score.
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Instrument Editor for chord grids in Logic Pro

You use the Instrument Editor pane to view, create, and edit instrument tunings and chord
grid libraries. You can also import and export chord grid libraries.

The Instrument Editor pane includes the following parameters:
•

Name column: Displays the instrument tuning name. Double-click to edit.

•

Library column: Displays the chord grid library name. Double-click to edit.

•

Tuning column: Displays the instrument tuning.

•

Strings column: Displays the number of strings.

•

Chords column: Displays the total number of chords.

•

Basic Chords column: Displays the number of basic chords.

•

Import button: Click to import a library to the Instrument Editor.

•

Export button: Click to export a library from the Instrument Editor.

•

Delete button: Click to delete a tuning or library from the Instrument Editor.

•

Create button: Click to create a library in the Instrument Editor.

Note: The Instrument Editor pane is only available if you open the Chord Grid Library from
Logic Pro preferences or from the Layout menu, not when dragging or double-clicking a
chord grid symbol.
For information about creating and editing chord grid libraries, see Add and edit chord grid
libraries. For information about importing and exporting chord grid libraries, see Import and
export chord grid libraries.
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Chord Grid Selector in Logic Pro

You can select and filter individual chord grids from your instrument tunings and chord grid
libraries in the Chord Grid Selector.

The Chord Grid Selector includes the following parameters:

Instrument parameters
•

Name pop-up menu: Choose the name of the instrument tuning you want to use.

•

Tuning field: Displays the default tuning for the chosen instrument.

•

Number of Strings field: Displays the default number of strings for the chosen
instrument.

•

Capo pop-up menu: Choose the fret on which to place the Capo. Choose 0 to play at
the original chord, 1 to place a Capo on the first fret, and so on.

Filter parameters
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•

Root Note pop-up menu: Filter the chord grids according to root note.

•

Bass Note pop-up menu: Filter the chord grids according to bass note.

•

Chord Type pop-up menu: Filter the chord grids according to chord type.

•

Difficulty pop-up menu: Filter the chord grids according to difficulty.

•

Favorites checkbox: Filter the chord grids according to those tagged as favorites.

•

Library pop-up menu: Filter the chord grids according to library (those libraries that are
linked to the chosen tuning).

839

View parameters
•

Number of Frets pop-up menu: Choose the number of frets (four, five, or six) to be
shown in the chord grids.

•

Left-Handed checkbox: Change the chord grid display to suit left-handed users.

Other parameters
•

Playback button: Click to listen to a selected chord grid.

•

Action pop-up menu: Choose how the chord grid strings are played back and at what
tempo.
•

Chord: All strings are played back simultaneously.

•

Arpeggio Up, Arpeggio Down: Each string is played back one after the other.

•

Slow, Medium, Fast: Choose the playback tempo.

•

Delete button: Click to delete a non-factory chord grid.

•

New button: Click to create a new chord grid. The Chord Grid Editor pane opens and
shows an empty chord grid.

•

Edit button: Click to edit a selected chord grid. The Chord Grid Editor pane opens and
shows the selected chord grid.
Note: This same edit action can be triggered by double-clicking a chord grid in the
Chord Grid Selector.

For information about inserting and editing chord grids, see Insert and edit chord grids.

Chord Grid Editor in Logic Pro

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create and edit chord grids in the Chord Grid Editor.
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The Chord Grid Editor includes the following parameters:

Instrument parameters
•

Name pop-up menu: Choose the instrument tuning in which to add or replace the chord
grid.

•

Tuning field: Displays the default tuning for the chosen instrument.

•

Number of Strings field: Displays the default number of strings for the chosen instrument.

•

Capo pop-up menu: Choose the fret on which to place the Capo. Choose 0 for no Capo,
1 to place a Capo on the first fret, and so on.

Chord parameters
•

Name field: Enter a name for the chord grid.

•

Root Note pop-up menu: Choose a root note for the chord grid.

•

Bass Note pop-up menu: Choose a bass note for the chord grid.

•

Chord Type pop-up menu: Choose a chord type for the chord grid.

•

Difficulty pop-up menu: Choose a difficulty level for the chord grid.

•

Favorite checkbox: Add the chord grid to your favorites.

View parameters
•

Number of Frets pop-up menu: Choose the number of frets (four, five, or six) to be
shown in the chord grids.

•

Left-Handed checkbox: Change the chord grid display to suit left-handed users.

Other parameters
•

Playback button: Click to hear a preview of the chord grid.

•

Action pop-up menu: Choose how the chord grid preview is played and at what tempo.
•

Chord: All strings are played simultaneously.

•

Arpeggio Up, Arpeggio Down: The chord is played as an arpeggio, one string at a time.
Arpeggio Up plays the strings from lowest to highest, while Arpeggio Down plays the
strings from highest to lowest.

•

Slow, Medium, Fast: Choose the playback tempo.

•

Reset/Clear button: Click the Reset button to set the chord grid back to its original state
(showing either open strings, a new chord grid, or the selected chord grid) within the
Chord Grid Selector pane. Click the Clear button to clear the chord grid, providing you
with a clean template to work on.

•

Target Library pop-up menu: Choose the library in which to add the new or edited chord
grid.

•

Replace button: Click to replace an existing chord grid.

•

Add button: Click to add a chord grid to your chosen library.

Open the Chord Grid Editor
Do one of the following:

Drag a chord grid symbol from the Part box into the score display.
Choose a chord grid symbol in the Part box, then click within the Score Editor with the
Pencil tool.
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Choose Layout > Chord Grid Library from the Score Editor menu bar, then click Chord
Grid Editor.
For information about creating and editing custom chord grids, see Create and edit
chord grids.

Edit chord grids in the Score Editor in Logic Pro
There are several ways to insert chord grids into your score.

Insert a chord grid symbol
1. Do one of the following:
•

Drag a chord grid symbol from the Part box into the score.

•

Choose a chord grid symbol in the Part box, then click in the Score Editor with the
Pencil tool.

Either technique opens the Chord Grid Selector pane in the Chord Grid Library.

2. Select a chord grid, then click OK.
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Change the scale of a chord grid

After inserting chord grids in your score, you can edit their size and position accordingly.
Control-click a chord grid symbol, then choose one of the following from the
shortcut menu:
•

Scale: reduced

•

Scale: normal

•

Scale: enlarged

The scaling values are based on the Grid scaling and Chord scaling settings in the File >
Project Settings > Score > Chords & Grids pane.

Align selected chord grids vertically

Select multiple chord grids, Control-click any one of them, then choose Align Object
Positions Vertically.
The selected chord grid symbols are aligned vertically.
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Align all chord grids vertically

1. Control-click a chord grid, then choose Align Object Positions Vertically.
2. You’re asked if you want to align all similar objects to this one. Click OK.
All chord grids are aligned vertically.

Copy an existing chord grid

Press and hold Option while dragging an existing chord grid, then release it when you
reach the desired position.

Hide the chord name

You have the option to hide or show the chord name on a chord grid.

Control-click a chord grid, then choose Hide Chord Name from the shortcut menu.

Modify the chord of an existing chord grid

Double-click the chord grid, choose another in the Chord Grid Selector, then click OK.

Create custom chord grids in the Chord Grid Editor
Create and edit chord grids in Logic Pro
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can create and edit chord grids in the Chord Grid Editor. You have many options when
creating new chord grids from scratch, or when modifying existing chord grids.

Create a new chord grid in the Chord Grid Editor

1. Click the Clear button in the Chord Grid Editor pane.
The chord grid display is cleared, allowing you to create a new one from scratch.
Note: Clicking the Clear button changes it to the Reset button.
2. Set the Chord and View parameters to suit your needs.
3. Click the Add button.
The Chord Grid Selector pane opens, with the new chord grid added to your chosen
library.
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Edit an existing chord grid in the Chord Grid Editor

1. Double-click a chord grid in the Chord Grid Selector pane.
The chord grid opens in the Chord Grid Editor pane.
2. Set the Chord and View parameters to suit your needs.
3. Click the Add or Replace button.
The Chord Grid Selector pane opens, with the edited chord grid added or replaced in
your chosen library.

Display higher positions (frets) in the chord grid

Click 1st to open a pop-up menu, then choose another fret number.

Add fingering dots to a chord grid in Logic Pro
You can add, edit, and delete fingering dots on a chord grid.

Add a fingering dot

Click the string and fret.
A black dot is created.
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Move an existing fingering dot
Do one of the following:

Click another fret on the same string.

Drag the dot to a new fret position.

Set the finger number for a fingering dot

Control-click a dot, then choose a number from the shortcut menu.
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Add an optional fingering dot
Do one of the following:

Option-click a string to create an optional dot. If another real dot exists on the same string,
the real dot remains.

Option-click an existing dot to change it to an optional dot. An empty string is shown
as a result.

Delete a fingering dot
Do one of the following:

Select a dot so that it turns green, then press the Delete key.
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Click the area at the top of the string.

The result is the same using either approach: the string is open.

Add barres to a chord grid in Logic Pro
A barre shows where the performer places his or her finger over several strings at the same
fret. You can add, edit, and delete barres on a chord grid.

Add a barre

Do one of the following:
Drag the left or right edge of an existing dot to the right or left.
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Place the pointer over a string, then drag to the left or right.

Move a barre

Drag the barre to a new fret position.

Delete a barre

Select a barre so that it turns green, then press the Delete key.

Mute strings in a chord grid in Logic Pro
You can show muted and unmuted open strings on a chord grid.

Mute a string

Click the area at the top of the string.
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The string is muted.

Unmute a string

Click the area at the top of the string.

The string is open.
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Add and edit chord grid libraries in Logic Pro

You can create a new chord grid library for an existing instrument tuning, or for a new
instrument tuning. You do this from the Instrument Editor pane in the Chord Grid Library.

Create a new chord grid library for an existing instrument tuning
1. Open the Instrument Editor pane by doing one of the following:
•

Choose Logic Pro > Preferences > Chord Grid Library, then click Instrument Editor.

•

Choose Layout > Chord Grid Library from the Score Editor menu bar, then click the
Instrument Editor tab.

2. Click the Create button.
3. In the Create Library dialog, define the following parameters:
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•

Library Name field: Enter a name for the chord grid library.

•

Tuning pop-up menu: Choose the instrument tuning in which you want to add the
library.

•

Number of Strings pop-up menu: Leave this at the default setting.

4. Click Create to add the new chord grid library to the chosen instrument tuning.

Create a new chord grid library for a new instrument tuning

1. Open the Instrument Editor pane by doing one of the following:
•

Choose Logic Pro > Preferences > Chord Grid Library, then click Instrument Editor.

•

Choose Layout > Chord Grid Library from the Score Editor, then click Instrument
Editor.

2. Click the Create button.
3. In the Create Library dialog, define the following parameters:

•

Library Name field: Enter a name for the chord grid library.

•

Tuning pop-up menu: Leave this at the default setting.

•

Number of Strings pop-up menu: Choose the number of strings.

4. Click Create to add a new instrument tuning, also containing the newly created chord
grid library.

Rename a chord grid library

Double-click the name in the Library column, then enter a new name.

Delete an instrument tuning or chord grid library

Select the instrument tuning or chord grid library that you want to delete, then click the
Delete button.
If you select an instrument tuning, the entire tuning and its chord grid libraries are deleted.
If you select a chord grid library, only that library is deleted (unless it’s the only library
within a tuning; then the instrument tuning is also deleted).
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Import and export chord grid libraries in Logic Pro

You can import and export chord grid libraries from the Instrument Editor pane.

Import a chord grid library

1. Open the Instrument Editor pane by doing one of the following:
•

Choose Logic Pro > Preferences > Chord Grid Library, then click Instrument Editor.

•

Choose Layout > Chord Grid Library from the Score Editor menu bar, then click
Instrument Editor.

2. Click the Import button.
3. Browse to the location of the library you want to import.

Export a chord grid library

1. Open the Instrument Editor pane by doing one of the following:
•

Choose Logic Pro > Preferences > Chord Grid Library, then click Instrument Editor.

•

Choose Layout > Chord Grid Library from the Score Editor menu bar, then click
Instrument Editor.

2. Select the library you want to export.
3. Click the Export button.
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4. Enter a name for the library, and browse to the location in which to save it.

5. Click Save.

Edit score region parameters
Overview of score region parameters in Logic Pro

Score region parameters let you control different aspects of how regions appear in the
score. They affect the display of notes and other events, but have no effect on the sound
or playback of the project.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can edit score region parameters for the selected region or regions in the Region
inspector, when the Score Editor has key focus. The Region inspector shows the name
of the selected region; or, when multiple regions are selected, the number of selected
regions. When multiple regions have different values for any of their parameters, a star icon
(“*”) is displayed in the corresponding parameter line. If you change this value, all selected
regions are set to the same value for that parameter.
The following sections describe individual score region parameters in the order they
appear in the Region inspector.
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Style region parameter in Logic Pro

You choose the staff style for the selected track, and for selected regions from the Staff
Style pop-up menu. For information about using staff styles, see Staff styles overview.

Quantize region parameter in Logic Pro

The Quantize parameter applies visual quantization to notes, setting the shortest note
value that can be displayed.
Note: When Logic Pro is operating is Simplified mode (that is, when Enable Complete
Features is not selected in Logic Pro > Preferences > Advanced), the Grid pop-up menu
appears in the Score Editor menu bar. You can set the visual quantization for the Score
Editor using the Grid pop-up menu.
For example, a note with a short note value, such as a 32nd note, can only be displayed at
its original length if Quantize is set to 32 or shorter. If Quantize is set to 8, the 32nd note is
displayed as an eighth note (the shortest note value displayed at that Quantize setting).

Settings in the Quantize pop-up menu that display a single value, such as 8, 16, or 128,
represent the minimum displayed note value for that Quantize setting. For settings that
display a pair of values, the first value represents the minimum note value for duple
rhythms, and the second value displays the minimum note value for triple rhythms (or
triplet figures in a duple-rhythm context). Following is a list of the triple Quantize settings
and their corresponding note values.
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Quantize setting

Corresponding note value

3

1/2-note triplets

6

1/4-note triplets

12

1/8-note triplets
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Quantize setting

Corresponding note value

24

1/16-note triplets

48

1/32-note triplets

96

1/64-note triplets

192

1/128-note triplets

384

1/256-note triplets

When a single-value setting is used, automatic triplets are not displayed at all (except for
triplets inserted with the pointer, using an N-tuplet object).
Important: The Quantize parameter must be set to a triple quantization value to enable the
automatic display of triplets.
You can override the Quantize value for a group of notes using tuplets; see Add and
edit tuplets.
The Quantize pop-up menu also includes a Default setting for new MIDI regions, which can
only be set with the Insert Defaults setting; not for existing regions. If Default is chosen,
the Quantize setting of new MIDI regions is dependent on the current division value in the
LCD. If the division value in the LCD is a duple value (such as 4, 8, or 16), the Quantize
value is set to that note value plus the next highest triple value (such as 6, 12, or 24). If the
division value is a triple value, the Quantize value is set to that value plus the duple value
that is divisible by that (triple) value.
For example, a global division value of 1/8 results in an 8,12 Quantize setting for new
regions; a value of 1/12 becomes a 4,12 Quantize value; a value of 1/16 results in a Quantize
value of 16,24, 1/24 in 8,24, and so on.
Note: If a particular Quantize value has already been set in the Insert Defaults, all new
regions use this value, regardless of the division value in the LCD. You can change any of
these values at any time.
For swing notation, use 8,12 for the Quantize parameter to display eighth-note triplets
and also display two uneven notes on one beat as regular eighth notes. For doubletime passages containing sixteenth notes, you can either cut the MIDI region containing
the double-time passage (in the Tracks area) and assign it a higher Quantize value with
the double-time note value, or use hidden N-tuplets for the sixteenth notes. For more
information, see Add and edit tuplets.
For swing sixteenth notes (shuffle funk, hip hop, and so on), the same principle applies. In
this case, choose 16,24 as the Quantize parameter.
You can fix the display quantization of all MIDI events in the projects using the Score
Editor’s Functions > Quantization > Fix displayed Note Positions and Fix displayed Note
Positions and Durations commands. These commands may be useful for exporting projects
(complete with display Quantize settings) to other notation programs that don’t feature
display quantization. The commands are also available from the shortcut menu when you
Control-click notes in the score.

Set the visual quantization value

Choose a value from the Quantize pop-up menu in the Region inspector.
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Interpretation region parameter in Logic Pro

Music notation is meant as a guide to performance, and rhythmic values are often not
notated with metronomic precision. The Interpretation setting helps you produce a more
readable score from real-time recordings. You should usually turn it off when adding notes
via step input or with the pointer.
If Interpretation is turned on, notes are generally displayed with longer length values than
their actual length, to avoid having many short rests. Short notes on a downbeat in 4/4
time, for example, are displayed as quarter notes. The score becomes slightly less precise,
but is easier to read.
If Interpretation is turned off, note lengths are displayed as closely as possible to their
real values, as determined by the Quantize value. In the following example, the same MIDI
region is shown twice, the first with Interpretation turned off, the second with it turned on:

You can use note attributes to use Interpretation on individual notes, overriding the Region
inspector setting. For more information, see Change note syncopation and interpretation.

Turn interpretation on or off

Select or deselect the Interpretation checkbox in the Region inspector.

Syncopation region parameter in Logic Pro

Syncopation involves rhythmic patterns that go against the normal rhythm as defined by
the time signature. The Syncopation setting helps you produce a cleaner-looking score by
displaying syncopated notes with fewer ties or subdivisions.
If Syncopation is turned on, each note is displayed graphically as a single note when
possible (rather than as several tied notes), regardless of its rhythmic position. If it can’t
be displayed as a single note, the note is divided into the minimum possible number of
notes, connected by ties. In some cases, the display of syncopated notes also depends on
the Max Dots setting—see Max Dots.
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The following example shows the same two bars displayed differently, the first with
Syncopation turned off, then with it turned on:

Syncopation can also be turned on and off for individual notes, independent of the
Region inspector setting, using note attributes. For more information, see Change note
syncopation and interpretation.
If the Syncopation setting produces unwanted results, you can change the graphic display
of notes connected with ties by adding a short user rest from the Part box at the bar
position where you want the tie subdivided. Once the rest is inserted, it disappears, but the
note display changes. The inserted rest can only be seen and edited in the Event List. This
trick works for all notes, not just syncopated ones. (See Override display quantization using
tuplets.) In polyphonic staff styles, the MIDI channel of the rest and the corresponding note
must be identical.

Turn syncopation on or off

Select or deselect the Syncopation checkbox in the Region inspector.

No Overlap region parameter in Logic Pro

The No Overlap setting simplifies the display of overlapping notes. No Overlap prevents
the display of overlapping notes in melodies played with an exaggerated legato by
shortening the displayed note length to the beginning of the next note. Notes beginning
simultaneously (intervals or chords) are displayed with the length of the shortest note in
the chord.
When No Overlap is turned off, the score display shows the lengths of overlapping notes
precisely (at the current Quantize value). This can be more useful to accurately notate
chords, but may be harder to read, particularly for melodic passages.
No Overlap works for monophonic, but not polyphonic, staff styles—see Staff styles
overview for details.
The first example shows a region with No Overlap turned off:
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The second example shows the same region with No Overlap turned on:

No Overlap should only be turned off when the precise display of overlapping notes is more
important than producing a smooth melodic line:

Although you can’t see that all notes continue to sound here, the result looks like this if No
Overlap is turned off:

The solution typically involves turning on No Overlap and using sustain pedal markings.
Pedal markings are automatically displayed if notes are recorded in real time with a MIDI
keyboard and sustain pedal.

Show or hide overlapping notes

Select or deselect the No Overlap checkbox in the Region inspector.
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Max Dots region parameter in Logic Pro

The Max Dots parameter affects the rhythmic display of dotted notes (notes that are
one-and-one-half times as long as the equivalent undotted note value) by controlling the
maximum number of dots that can be displayed. This makes the display of such notes less
metronomically precise, but makes the score more readable. By default, the number of Max
Dots is 1.
Unwanted dotted notes or rests can be changed by inserting user rests (which remain
invisible, if notes). See Override display quantization using tuplets for information on
changing the way notes with ties are displayed.

Set the maximum number of dots

In the Region inspector, do one of the following:
•

Drag the Max Dots value up or down.

•

Double-click the Max Dots value, then enter a new value.

Score region parameter in Logic Pro

The Score parameter in the Region inspector controls whether MIDI notes in the selected
regions appear in the score. If Hide is chosen in the Score pop-up menu, notes (and other
content) in the selected regions are not displayed in the score at any display level above
the region level.

Exclude selected regions from the score display

In the Region inspector, choose Hide from the Score pop-up menu.
You may need to click the More disclosure arrow in the Region inspector in order to see the
Score pop-up menu.
Choose Show from the Score pop-up menu to have the regions appear in the score display.

Edit default score parameters for new regions in Logic Pro

New MIDI regions created by recording, or with the Pencil tool, include a default set of
region parameters (and event parameters). You can view and edit these defaults when no
staff (no region) is selected in the Score Editor. The defaults remain as set until you quit
Logic Pro, but can be changed at any time.
You can edit the default region (and event) parameters, except for the Staff Style
parameter, which is separate for each track, and is set in the bottom line of the Track
inspector. After you edit the defaults, all new regions will use the new default settings.
If Quantize is set to “default,” the display Quantize setting of newly recorded or created
regions matches the division value shown in the LCD.

Edit region and event parameter default values

1. Click an empty area of the Score Editor background (so that no region is selected).
2. Edit any of the parameter values in the Region inspector (except the Style parameter) or
the Event inspector.
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Work with staff styles
Overview of staff styles in Logic Pro

Using staff styles, you can control the display of clefs, rests, stems, ties, and beams,
change the displayed transposition, and adjust the staff size and space between staffs.
You can choose from a variety of predefined staff styles or customize and create your own
staff styles to use in your scores. Staff styles affect the visual display of the score, but
have no effect on MIDI playback.
Staff styles are saved as part of the project, so you can use different staff styles in
different projects. You can import frequently used staff styles into other projects to speed
up your workflow.
You can assign staff styles in the Region inspector, and edit staff styles in the Staff
Style window.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can assign staff styles to tracks in your project, edit staff styles, and assign styles to
individual regions.
Tip: Create a template project with the staff styles and other score settings that you
use frequently, so they are all available when you start a new project.

Assign staff styles to tracks in Logic Pro

You can assign a different staff style to each track in the score. Changing staff styles
allows you to control the display of individual staffs in the score, and quickly create parts
for transposing instruments.
Each track has a default staff style, which appears in the Staff Style pop-up menu in the
Region inspector. When you start working on a new project, or create a project template,
you can change this setting for tracks that will use a specific staff style, so that regions
recorded on these tracks are displayed with the correct staff style with no further editing.
If you choose Auto Style from the Staff Style pop-up menu, the track is assigned a staff
style that fits the range of notes in the regions on the track. For example, if the regions
consist of notes played below middle C, a Bass staff style is assigned to the track. Twohanded parts and instruments using the Grand Staff (with notes both above and below
middle C) are assigned a Piano staff style.
Note: Auto Style can only be chosen in the Region inspector, and does not appear in the list
of staff styles in the Score Editor Region inspector.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can assign staff styles to tracks in your project and edit staff styles. You can also
assign staff styles to individual MIDI regions and to tracks, allowing you to use multiple
styles on a single staff.
This can be used to alternate between fully notated passages and “improvised” passages
using only beat slashes and chord symbols, for example.
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Assign a staff style to a track
Do one of the following:

Click the staff in the Score Editor, then choose a staff style from the Staff Style pop-up
menu in the Region inspector.

Note: If you want to show the Grand Staff, choose a Piano or Organ staff style. You can
choose staff styles with one or more voices for each staff.
You can select multiple tracks, and assign the same staff style to all selected tracks.
In Linear view, click the clef on the staff, then choose a staff style from the shortcut menu.

Set the track to determine the staff style automatically
1. In the Tracks area, select one or more tracks.

2. In the Region inspector, choose Staff Style > Auto Style.

Assign a staff style to a selected MIDI region

Select the region in the Score Editor, then choose a staff style from the Staff Style pop-up
menu in the Region inspector.
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Work in the Staff Style window in Logic Pro

You view and edit staff style parameters in the Staff Style window. The upper part of the
window shows a list of available staff styles, with a visual representation of the selected
staff style. The lower part shows the staffs that are used for the selected staff style, with
parameters for each staff. The voices used for each staff are listed to the right.

The main elements of the window include:
•

Menu bar: Contains the local New, Edit, and View menus, and the View buttons to hide
or show different parts of the Staff Style window.

•

Style overview: Shows a list of available staff styles with the type, number of voices,
and other parameters for each listed staff style, and a graphical representation of the
selected style that updates to reflect your edits to the style.

•

Staff parameters: Shows the parameters for each staff in the selected staff style.
Parameters for each staff are shown as one row.

•

Voice parameters: Shows the parameters for independent voices. Parameters for each
voice are shown as one row. Each voice can be displayed as a rhythmically independent,
polyphonic passage in the music. A voice can consist of as many simultaneous notes
(chords) as needed.

•

Assign parameters: Shows the parameters for assigning notes to different voices. Every
staff can contain up to 16 independent voices, but each voice can be displayed on only
one staff. (Consequently, a staff style must contain at least as many voices as staffs.)

You can show the entire Staff Style window, or only part of the window, using the View
buttons on the right side of the menu bar.

Open the Staff Style window
Do one of the following:

Choose Layout > Staff Styles (or use the Show/Hide Staff Style Window key command).
Double-click a staff in the score.
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Change the view for the Staff Style window
Do one of the following:
•

To show only the style overview (upper part of the window): Click the left View button.

•

To show the complete contents (both parts) of the window: Click the center View
button.

•

To show only the staff and voice parameters (lower part of the window): Click the right
View button.

Create staff styles in the Staff Style window in Logic Pro

In the Staff Style window, you can create new staff styles, or duplicate an existing style to
use as a starting point for a new one.

Create a single staff style

1. Choose New > Single Staff Style.
2. In the Staff Style window, edit the parameters for the new staff style.

Create a dual staff style

1. Choose New > Dual Staff Style.
2. In the Staff Style window, edit the parameters for the new staff style.

Duplicate a staff style
Do one of the following:

Choose New > Duplicate Style.
Option-drag a staff style in the style overview up or down.

Edit staff styles in the Staff Style window in Logic Pro

In the Staff Style window, you can edit various staff style parameters. In the style overview,
you can edit the style type, size, transpose, and range parameters.
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Edit staff style parameters

In the style overview, do any of the following:
To rename a staff style: Double-click the name and enter a new name.
To choose a different staff style type: Click and hold the type, then choose a different type
from the pop-up menu.
To change the size: Drag the size value up or down.
For staff styles with multiple staffs, the size value shows “–” if the sizes of the staffs are
not equal.
To change the transposition: Click and hold the transpose value, then choose a different
value from the pop-up menu.
For staff styles with multiple staffs, the transpose value shows “–” if the staffs have
different transposition values.
To change the note range: Drag the Lo and Hi values up or down.
To set the appearance of brackets and bar lines: You can only edit this parameter for styles
with multiple staffs: it lets you determine which staffs are bracketed (two bracket types are
available) or connected by bar lines (only at the beginning of each staff line, or at every
bar line).

If a staff style consists of more than two staffs, the brackets and bar lines can be set to
connect only certain parts of the overall staff style—they can be interrupted in between
staffs. If you want to delete any connections, grab the symbol at its end (bottom), and drag
it up, until it disappears.
The voices value in the style overview is determined by the number of voices in the staff
style. This can be changed in the Voice parameters section, but not in the style overview.
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Edit staff style parameters in the Staff Style window
in Logic Pro

After you set the number of voices and staffs in a staff style, you can edit the Staff and
Voice parameters for the selected staff style in the lower part of the Staff Style window,
and edit Assign parameters for each voice in a staff style. When you change a staff style,
all tracks using that staff style are affected.
You can edit the following Staff, Voice, and Assign parameters in the Staff Style window:
•

For all staffs: Choose the clef, show or hide the key signature, set the distance to the
next (higher and lower) staffs, set the staff size, set the number of voices in the staff,
and set the display transposition.

•

For polyphonic, multiple staff styles: Edit the configuration of brackets and bar lines
that connect the staffs.

•

For each voice: Control the display of rests, stem direction, tie direction, direction of
N-tuplet brackets and numbers, beaming, note color, and note head type.

•

Assign parameters for each voice: Set the MIDI channel assignment and definition of a
split point pitch, for separation of the different voices.

Edit Staff parameters for the selected staff style

In the Staff section of the Staff Style window, do any of the following:
•

•

Change the clef: Choose a clef from the Clef pop-up menu. In addition to the standard
clefs, there are some additional options:
•

Drum.0 to Drum.8: Staffs with 0 to 8 lines and a neutral percussion clef. The
relationship of MIDI note pitches to the top line of all staffs corresponds to the top
line in a regular bass clef (A2). No accidentals are displayed in these drum staffs.
Drum.0 also omits any ledger lines. These clefs are often used in mapped drum
styles, where the vertical position of a note on the staff doesn’t correspond to pitch,
but is determined by different drum map parameters. See Use mapped staff styles
for drum notation for more information on mapped drum styles.

•

no clef.0 to no clef.8: Like the Drum.0 to Drum.8 staffs, but without a clef.

•

TAB Guitar and TAB Bass: Twelve different options for displaying notes as guitar or
bass tablature. Tablature tuning sets are defined and edited in the Tablature window
(Layout > Guitar Tablature).

Show or hide the key signature: Select the Key checkbox for the staff.
When the Key checkbox is unselected, the staff is displayed without a key signature.
Accidentals are placed directly beside all affected notes. This can be used, for example,
for transposed French horn parts, which are sometimes written without a key signature.

•

Change the distance to adjacent staffs: Drag the upper and lower space values up or
down. The upper value controls the space above staffs, and the lower value controls the
space below staffs. For the top and bottom staffs in a full score, this controls the page
margins.
Tip: You can also change the vertical distance above the staff directly in the score,
by dragging the staff up or down (at the clef). The distance below the staff can also
be edited in the score, but only for the bottom staff in the score display (or for a single
staff). You drag the bottom line of the score display with the pointer.
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•

Change the staff size: Drag the size value up or down, or double-click and edit the
value.
The Size parameter sets the size of the staff, and the notes and symbols (including
slurs and ties) displayed on the staff. There are 16 sizes available (0–15). Here are some
size recommendations:
•

For regular instrument parts and lead sheets, use size 7 or 8.

•

The staff size you should use in full scores depends on the number of staffs in the
score, and the size and format of the paper being used. When using A4 or US letter
paper: full orchestra: 2, big band: 3, wind quintet: 4.

Note: The size of all staffs in a score set can also be affected by the Scale parameter
in the Score Sets window. (See Score sets overview.) This makes it possible to use the
same sizes for both the whole score, and parts of a piece.
•

Change the display transposition: Drag the transpose value up or down in semitones, or
double-click and edit the value.
Display transposition does not affect playback of notes, but only how they appear in the
score. If a staff contains chord symbols, these are also transposed accordingly. If the
Automatic Key Transposition project setting, in the Clefs & Signatures pane, is turned
on (which is the default), key signatures are also transposed.

Edit voice parameters for the selected staff style

In the Voice section of the Staff Style window, do any of the following:
Change how rests are displayed: Choose a value from the Rest pop-up menu. Automatic
display of rests can be turned off (by choosing Hide), or set to display beat slashes instead
of rests (by choosing Slash). This is useful for rhythm section parts, and improvised solos.
In this situation, the number of slashes per bar is determined by the nominator in the time
signature (4 slashes in 4/4-time, 6 slashes in 6/8-time, and so on). Inserted notes and
symbols are still displayed, but automatic rests are shown only if shorter than one beat.
You can insert user rests manually, to replace individual beat slashes, if needed.
Set the stem direction: Choose a value from the Stem pop-up menu. The default setting is
Auto. Up or Down forces all stems, regardless of pitch, in the corresponding direction. Hide
makes all stems (and beams and flags) invisible.
Set the stem position: Choose a value from the Stem Pos. pop-up menu.
Set the vertical direction for ties: Choose a value from the Tie pop-up menu. The default
setting is Auto. Up or Down forces all ties in the corresponding direction.
Set the direction for tuplet brackets and numbers: Choose a value from the Tuplet pop-up
menu. The default setting is Auto. Up or Down forces all N-tuplet brackets and numbers
in the corresponding direction. Hide prevents the automatic display of triplet brackets
and numbers. In this situation, the numbers are still displayed in brackets on the screen,
to allow edits to these triplets. These bracketed numbers do not appear, however, on
the printout.
If you set this parameter to Hide, you can still make particular triplets visible: double-click
the bracketed number (3) to open a tuplet dialog. If you close this dialog by clicking OK,
you convert the automatically displayed triplet to a forced triplet, which is displayed in
accordance with the parameters set in the dialog.
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Set the appearance of beams: Choose a value from the Beam pop-up menu. The default Slant
setting allows slanted beams. Horiz. only allows horizontal beams. Vocal prevents the display
of beams, as is typical in classical vocal parts, where notes are only displayed with flags.
Set the color for notes: Choose a value from the Color pop-up palette. The color options are
Black (“---”), Pitch, Velocity, and the 16 colors of the Color palette. (See Colors settings.)
These settings only affect regions if the View > Colors > Normal item is chosen in the
Score Editor (the default setting).
Set the appearance of note heads: Choose a value from the Head pop-up menu. You can
display note heads as normal, show note names or finger names, or hide the note heads
completely.
The Stem Pos. and Color parameters are available when Enable Complete Features is
selected in Logic Pro > Preferences > Advanced.

Edit assign parameters for the selected staff style

In the Assign section of the Staff Style window, do any of the following:
Set the MIDI channel assignment for a voice: Drag the channel value up or down.
Set the split point between voices: Drag the split value up or down.
For complete information about the Chan and Split parameters of the Staff Style window,
see Assign notes to voices and staffs

Add and delete staffs or voices in the Staff Style window
in Logic Pro

You can add staffs to a staff style, allowing you to create a two-staff piano style from a
single-staff style, for example.
A staff can display multiple independent melodic lines, called voices. Some predefined
staff styles display only a single voice, while others can display multiple voices (these
are called polyphonic). You can choose polyphonic staff styles to display multiple voices
(for choirs or polyphonic instruments), and can add voices to a staff style to display
independent lines. Theoretically, a staff style can display up to 16 independent voices (but
this may not be readable).
You can also duplicate staffs or voices.

Add a staff to a staff style

Click the Add Staff button (+) in the Staff section of the Staff Style window.
A new staff is added below the selected staff. If no staff is selected, the staff is added
above the first (highest) staff in the staff style.

Add a voice to a staff style

Click the Add Voice button (+) in the Voice section of the Staff Style window.
A new voice is added below the selected voice. If no voice is selected, the voice is added
above the first (highest) voice in the staff. If a staff is selected, the voice is added above
the first (highest) voice in the staff.
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Delete a voice or staff from a staff style

Select the voice or staff in the Staff Style window, then press Delete (or choose
Edit > Delete).
When you delete a staff, all the staff’s voices are deleted.
Each staff is represented by an ID number. The ID numbers are assigned automatically and
cannot be changed.

Copy staffs or voices in the Staff Style window in Logic Pro

In the Staff Style window, you can copy and paste staffs in a staff style, and also copy and
paste voices in a staff.

Copy and paste staffs in a staff style

1. In the Staff section of the Staff Style window, select the staff.
2. Choose Edit > Copy from the Staff Style window menu bar (or press Command-C).
3. Choose Edit > Paste from the Staff Style window menu bar (or press Command-V).
The copied staff is pasted above the selected staff. If no staff is selected, the copied
staff is pasted below the last (lowest) staff in the staff style.

Copy and paste voices in a staff

1. In the Voice section of the Staff Style window, select the voice.
2. Choose Edit > Copy from the Staff Style window menu bar (or press Command-C).
3. Choose Edit > Paste from the Staff Style window menu bar (or press Command-V).
The copied voice is pasted above the selected voice. If no voice is selected, the copied
voice is pasted below the last (lowest) voice in the staff. If a different staff is selected,
the copied voice is added is pasted below the last (lowest) voice in the selected staff.

Copy staff styles between projects in Logic Pro

You can copy staff styles that you use frequently to other projects. You can import all staff
styles from another project, or copy only selected staff styles.

Import all staff styles from another project
1. Do one of the following:
•

Choose File > Project Settings > Import Project Settings.

•

Click the Browsers button

in the control bar, then click All Files.

2. Navigate to and select the project file, then click the Import button.
Note: If accessing the settings from the All Files Browser, you also need to click the
Import Settings button, which appears after you click the Import button.
3. In the Import Settings window, select the Staff Styles checkbox (and deselect all other
settings that you don’t want to import), then click the Import button.
All staff styles from the other project are imported into the current one.
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Copy selected staff styles from another project

1. In the project that contains the staff styles you want to copy, open the Staff Style
window. (Single view is displayed.)
2. Double-click in the space below the Staff Style parameters to display a listing of all
staff styles.
3. Select the staff styles you want to copy, then choose Edi > Copy (or
press Command-C).
4. Open the Staff Style window in the target project, then choose Edit > Paste (or
press Command-V).
Note: If you copy a MIDI region from one project to another, and the staff style used by the
original MIDI region doesn’t exist in the target project file, it is automatically copied, along
with the MIDI region.

Delete staff styles in Logic Pro

You can delete staff styles in the Staff Style window in both Single view and List view. In
List view you can select and delete several staff styles simultaneously.

Delete the current staff style in Single view
Choose New > Delete Style.

Delete multiple staff styles in List view

Shift-click the staff styles you want to remove, then choose Edit > Delete (or press the
Delete key).
Tip: In List view, you can use the Edit > Select Unused command, to select all staff
styles that are currently not assigned to any regions or track instruments in the project.

Assign notes to voices and staffs in Logic Pro

For staff styles with multiple staffs or voices, you can control which staff or voice a note is
displayed on. You can assign notes to voices by defining a split point, or by assigning each
voice to a separate MIDI channel.
When you use a split point to separate voices, the split point and all notes above it are
displayed on the upper voice, while all notes below the split point are displayed on the
lower voice. This is useful when there is a clear division in pitch between the two voices;
for example, in a piano staff style when each hand plays in only one clef (treble or bass).
In cases where the division between voices needs to be more flexible, you can separate
voices by assigning each voice to a different MIDI channel. This allows voices to cross
while still being displayed independently. Notes not assigned to any MIDI channel are not
displayed, allowing you to “hide” notes from display (such as improvised parts or trill notes,
for example). This does not affect playback, but only the display of notes in the score (the
playback channel is determined by the setting in the Track inspector).
If you record polyphonic voices separately in real time, you can set your keyboard or MIDI
controller to the appropriate MIDI channel for each voice when you record, saving you from
having to edit the channels afterward.
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You can automatically split notes between two voices using the “Auto split notes in multi
staff chord styles” Score preference. By turning on this preference, notes you play using a
polyphonic staff style are automatically assigned MIDI channels matching the staff style’s
voice assignments. Notes at, and above, the split point are assigned the channel of the first
voice. Notes below are assigned the second voice’s channel. This creates a usable voice
assignment, which you can edit later.
Using the Voice Separation tool, you can draw a separation line between notes on a staff to
assign them to the predefined MIDI channels of the voices.

Separate voices by split point

Choose a note pitch for the voice in the Staff Style window’s Split column.

Separate voices by MIDI channel

Assign a MIDI channel to each voice in the Staff Style window’s Chan column.
When you use MIDI channels to assign notes to staffs or voices:
•

You can edit the MIDI channel in the same way you do all other events, by selecting the
events and changing the MIDI channel in the Event inspector or the Event List.

•

You can quickly change the MIDI channel of selected note events with the Event
Channel +1 and Event Channel −1 key commands. These can be especially useful when
used in combination with the Select Next Region/Event, or Set Marquee End to Next
Transient key command and the Select Previous Region/Event, or set Marquee End to
Previous Transient key command, which allow you to move the selection from note to
note.

You can also use Score Editor functions designed to speed up the process of changing
the MIDI channel settings of notes, in order to assign them to the specific voices. These
include the Auto Split preference and the Voice Separation tool.

Split previously recorded regions by MIDI channel
1. Select the region.

2. Choose Functions > Note Events > Assign MIDI Channels based on Score Split from the
Score Editor menu bar (or use the corresponding key command).
The region’s notes are assigned to voices in the staff style, according to the Auto Split
pitch in the Score preferences.
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Assign notes to MIDI channels using the Voice Separation tool

1. Select the Voice Separation tool, then draw a line (between notes) where you want to
separate the voices.

Notes below the line are moved to the MIDI channel below their current assignment.
2. If you make a mistake, move the pointer back slightly to the left.
The separation line is erased to the right of the tool, allowing you to try again.

Display polyphonic parts on separate staffs in Logic Pro

You can “explode” polyphonic parts, displaying all voices on separate staffs, regardless
of staff style settings. (Other voice parameters remain valid.) This makes it easier to add
notes using the pointer.
If you add a note to a staff style that uses MIDI channels for voice separation, it’s
automatically assigned the corresponding MIDI channel (of the staff that you add the note
to). When you’re finished adding notes, turn off the Explode Polyphony setting so all voices
are displayed correctly in one staff.
If you add notes to a polyphonic staff without turning on the Explode Polyphony setting,
the notes are assigned the MIDI channel set in the Insert Defaults of the Event inspector
(but only if that channel is used by one of the voices in the staff).

Display polyphonic parts on separate staffs

Choose View > Explode Polyphony from the Score Editor menu bar (or use the
corresponding key command).

Change the staff assignment of score symbols in Logic Pro

In addition to notes, most other score symbols can be assigned to a particular staff in a
multiple-staff staff style. The Event inspector includes a Staff parameter where you can set
the staff for these symbols.

Change the staff for a score symbol
1. Select the symbol in the score.

You might need to use the Layout tool to select the symbol.
2. In the Event inspector, drag the Staff number up or down to change the staff for the
selected symbol.
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Beam notes across staffs in Logic Pro

Music for keyboard instruments, and other instruments notated on multiple staffs, can
contain passages where notes on different staffs (played by the left and right hand, for
example) are connected with a beam, to clarify that the musical phrase continues across
the staffs.
In the Score Editor, only notes belonging to the same voice can be connected with beams.
By default, notes of the same voice are normally all displayed on the same staff. Using the
Score Editor’s Staff Assignment commands, you can display notes of the same voice on
different staffs.
For example, the following image depicts a piano passage using the Piano staff style
featuring two MIDI channels (1 and 2). The notes in the upper staff belong to voice one
(MIDI channel 1). The notes in the lower staff belong to voice two (MIDI channel 2).

Using the Voice/Staff Assignment commands in the Score Editor’s Functions menu, you can
place the right-hand notes falling below middle C in the bass staff, but maintain the beaming.
Before using the Voice/Staff Assignment commands, make sure that all the notes you want
to connect with beams use the same MIDI channel (and all notes you want to appear in the
other staff, not connected by beams, use another MIDI channel). Select notes one by one
and view their MIDI channel assignment in the Event inspector.

Beam notes across different staffs

1. If necessary, change the voice assignments for the notes that you want to connect with
beams by doing one of the following:
•

Draw a line below the notes with the Voice Separation tool.

•

Select all notes, then, in the Event inspector, change their MIDI channel to match
that of the upper voice.

The notes appear in the upper staff, possibly with multiple ledger lines.
2. Select the notes you want to connect with a beam, then choose Functions > Note
Attributes > Beaming > Beam Selected from the Score Editor menu bar (or use the
corresponding key command).
3. Select the notes to display in the bottom staff, then choose Functions > Note Attributes >
Voice/Staff Assignment > Staff Below Voice (or use the corresponding key command).
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The selected notes are moved down to the lower staff, but are still part of the upper voice.
In the reverse situation, where notes continue above the bass staff, with ledger lines,
you would follow the opposite procedure: assign all notes to the lower voice, then move
some notes to the upper staff by choosing Note Attributes > Voice/Staff Assignmen >
Staff Above Voice from the Score Editor menu bar.
4. To display all selected notes in their original staff, choose Note Attributes > Voice/Staff
Assignment > Default Staff from the Score Editor menu bar.
Note: By default, rests are displayed according to the Rest settings for the staff style. In
the cross staff beaming example described above, however, most (or all) notes belong to
the voice of the top staff, and the lower staff will contain rests—some even at positions
occupied by notes. To avoid this situation, choose a staff style where the automatic
display of rests is turned off for the bottom staff’s voice, then add rests manually from
the Part box.

Use mapped staff styles for drum notation in Logic Pro

In MIDI regions assigned to drum instruments, each MIDI note usually triggers a different
sound. When viewed using a regular staff style, the notes have no apparent relationship to
the sounds you hear. You can display these regions as a readable drum part with special
drum note heads, using mapped instruments and mapped staff styles.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced, you
can create and edit mapped staff styles. Mapped staff styles allow you to assign individual
voices to drum groups, which use specific drum note heads to display note events. You can
define the respective drum note head shapes in a Mapped Instrument window.

The best way to create drum notation for an existing region is to open the Score Editor to
view the MIDI region, and also open the Mapped Instrument window and the Staff Style
window. This way, you can directly see how parameter changes affect the score display.
Before defining the details of a mapped staff style, you should set up all drum groups, note
head shapes, and relative note position parameters in the Mapped Instrument window.
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Create a mapped staff style for drum notation

1. Create a mapped instrument in the Environment, then double-click its icon. For details
about creating mapped instruments, see Mapped instrument objects overview.
The Mapped Instrument window opens. Its default settings correspond to the General
MIDI drum note assignments, but they can be edited.
In the columns to the far right are three parameters relevant to notation.
2. In the Head pop-up menu, choose the shape of the note head for notes triggered by this
particular pitch.

A note must be assigned to a drum group to be displayed in a mapped staff style. If it’s
not, it won’t be visible.
3. In the Group pop-up menu, choose a drum group.
Some of the groups are predefined for the most commonly used drum sounds (Kick,
Snare, Hi-Hat, Toms, Cymbals, and so on).
Note: If you want to define a new drum group for another instrument sound (such as
tambourine), choose New Group from the pop-up menu, then double-click the entry to
name the new drum group.
4. Set the Rel. Pos. (Relative Position) parameter.
The Relative Position parameter assigns the note to a line in the staff. The note position
is relative to the top line of the staff. Integer values make the note fall on a line;
fractional values result in a note position between two lines.
Note: Positions can also be influenced in the Staff Style window, but this affects all
notes of a particular drum group.
These options allow you to have two different MIDI notes (different bass drum sounds,
for example) displayed in the same way in the score, or on the same line, but with
different note heads.
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5. Create a new mapped staff style by choosing New > Mapped Style in the Staff Style
window, and inserting all staffs, voices, and drum groups as described above, and in
Staff styles overview.

•

Staff section: Everything is identical to unmapped staff styles (with the exception of
the missing Transpose and Key parameters, which wouldn’t make sense here).

•

Voice section: Below Voice (in the top header line), is a separate Voice column,
where the different voices are numbered automatically. The staff style shown above
contains one staff with five independent voices.

•

Horizontal lines: Display the Staffs-Voices-Drum Groups hierarchy, indicating the
borders between these elements. Each drum group belongs to the voice at the same
horizontal position.

•

Pos parameter: Affects the vertical positioning of all notes in the corresponding
drum group. The value shown here is an offset that is added to, or subtracted from,
the relative positions (if defined for individual notes in the Mapped Instrument
window).

Mapped staff style names are preceded by the # character in the Staff Style window.
If you’re using several software instruments with different drum assignments, you can
create a separate drum map for each instrument (in the Mapped Instrument window). The
list of drum groups, however, is the same for all instruments in a project. This allows you
to display different drum tracks with the same mapped staff style. All snare drums, for
example, will be displayed in the same way.

Predefined staff styles used in Logic Pro

A variety of predefined staff styles are available in the Score Editor. The following table
lists each staff style with its Clef and Transposition parameters.
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Staff style

Clef

Transposition

Bass

Bass clef

-

Lead Sheet

Treble clef

-

Piano (two staffs)

Treble/Bass clef

-

Treble

Treble clef

-

Treble −8

Treble (−8) clef

+1 octave

Treble +8

Treble (+8) clef

−1 octave

Alto Sax

Treble clef

Eb (+9)

Baritone Sax

Bass clef

Eb (+21)

Contrabass

Bass (−8) clef

+1 octave
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Staff style

Clef

Transposition

Guitar

Tablature display

-

Guitar Mix (Tablature display and
one staff)

Tablature display/Treble (−8) clef

-

Guitar Mix 2

Treble (−8) clef/Tablature display

-

Horn in Eb

Treble clef

Eb (−3)

Horn in F

Treble clef

F (+7)

Organ 1/1/5 (3 staffs)

Treble/Bass/Bass clef

-

Organ 1/3/5 (3 staffs)

Treble/Bass/Bass clef

-

Organ 1/3+4/5 (3 staffs)

Treble/Bass/Bass clef

-

Organ 1+2/3/5 (3 staffs)

Treble/Bass/Bass clef

-

Organ 1+2/3+4/5 (3 staffs)

Treble/Bass/Bass clef

-

Piano 1/3 (2 staffs)

Treble/Bass clef

-

Piano 1/3+4 (2 staffs)

Treble/Bass clef

-

Piano 1+2/3 (2 staffs)

Treble/Bass clef

-

Piano 1+2/3+4 (2 staffs)

Treble/Bass clef

-

Piccolo

Treble clef

−1 octave

Soprano Sax

Treble clef

Bb (+2)

Tenor Sax

Treble clef

Bb (+14)

Trumpet in A

Treble clef

A (+3)

Trumpet in Bb

Treble clef

Bb (+2)

Viola

Alto clef

-

Violoncello

Bass clef

-

# Drums

Percussion Clef

Mapped
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Create scores and parts using score sets
Overview of score sets in Logic Pro

You can use score sets to control which software instrument tracks appear in the score.
Each project can contain as many score sets as needed. Score sets let you:
•

Produce a full score for a project together with individual parts

•

Reorder software instrument tracks in the score, independent of their order in the
Tracks area

•

Provide a name (and, optionally, a short name) for each software instrument track
displayed in the score, and when the score is printed

•

Control which staffs are connected by brackets or bar lines

•

Exclude tracks from being displayed in the score (for example, tracks that only contain
MIDI controller data)

•

Reduce or enlarge all staffs in each staff set using the Scale parameter, which allows
you to use the same staff styles for the printout of full scores and individual parts

•

Select from two different parameter sets (Score or Part) for page margins, header space
height, vertical distance between staff systems, and the maximum number of bars per
line

You create and edit score sets in the Score Sets window.

Open the Score Sets window

Choose Layout > Score Sets from the Score Editor menu bar (or use the Show/Hide Score
Sets Window key command).
If the All Instruments score set is chosen when you open the Score Editor, a warning
indicates that this score set cannot be edited.
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Choose a score set in the Region inspector in Logic Pro

You can view available score sets and instruments in the Filter pop-up menu in the Region
inspector. For new projects, the only available score set is All Instruments, which displays
all instruments (depending on the display level).

Choose a score set

Choose a score set from the Filter pop-up menu at the top of the inspector.
The display of a score set depends on the display mode. Because Content Link and
Content Catch display only one region at a time, it’s usually best to set the Link mode
to Off, once the desired score set is fully displayed. If only one MIDI region is displayed,
double-click below the staff, which displays the full score; then set the Link mode to Off.
For information about Link mode, see Control window relationships.
Tip: You can open multiple Score Editor windows, each showing different display levels
and different score sets.

Create and delete score sets in Logic Pro

When you open a Score Editor window while several regions are selected in the Tracks
area, Logic Pro automatically creates a score set containing the instruments of the
selected regions. You can also create a score set in the Score Sets window. Score sets you
create are saved with the project.

Create an empty score set

Choose New > New Empty Set in the Score Sets window.
You can insert instruments into the empty score set, one at a time.

Create a copy of the selected score set

Choose New > Duplicate Set in the Score Sets window.

Create a score set for selected instruments

1. Select at least one MIDI region for all software instrument tracks you want to include in
the score set.
2. Choose Layout > Create Score Set from Selection (or use the corresponding key
command) in the Score Editor.
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A new score set is created and displayed, which consists of all instruments used by the
currently selected MIDI regions. Score sets created this way are automatically named after
the instruments they contain.

Create a score set containing all software instrument tracks in the Tracks area
Choose New > New Complete Set in the Score Sets window.

If several instruments or staffs use the same MIDI sound for playback (with the same MIDI
channel on the same MIDI instrument), and you want to display these staffs with different
instrument names in the score, you need to create a separate track instrument for each
staff, in the Tracks area.

Delete a score set

Select the score set in the Score Sets window, then choose New > Delete Set.

Edit score set parameters in Logic Pro

You can edit parameters for new and existing score sets in the Score Sets window.

Edit parameters for the selected score set
Do any of the following:
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•

To rename the score set: Double-click the name in the left column of the Score Sets
window, then enter a new name in the field.

•

To place the insert mark: Click the narrow column to the left, or make multiple selection
marks by dragging vertically.

•

Instrument: This column shows which instruments are included in the score set, and
their (vertical) order of appearance in the score. Track instrument icons are also
displayed in this column, at the highest zoom level.
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•

To set the full name: Click the Full Name column to open a name field. By default, the
name of the track instrument is used for the instrument name in the score. To change
the name, select the default “@(reference)” text, and enter a new name.
Region parameters for instrument names are set in the Numbers & Names pane of the
Score project settings. (See Numbers & Names settings.)

•

To set the short name: Click the Short Name column to open a field where you can enter
the short name. The short name for each instrument is used if Short Names is chosen
in the Project Settings > Score, Numbers & Names > 1st Staff and Other Staves pop-up
menus.

•

To set which staffs are connected by brackets and bar lines: Drag vertically in the
appropriate column, until you see the appropriate display. You can define which staffs
in the score set are connected by brackets or bar lines (either at the beginning of each
staff, or throughout), in the last four columns.

Brackets and bar lines can also be interrupted between staffs, allowing you to form
groups of connected instruments in a score. If you want to delete a line or bracket,
grab the corresponding symbol at its end point (bottom), and drag it upward, until it
disappears. You can use the same method to shorten lines.
Bar line connections can also be edited directly in the score. Click the upper end of a
bar line to connect it to the next (higher) staff. Repeating the procedure disconnects
the bar lines.
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Change the instruments in a score set in Logic Pro

You can add instruments to a score set, replace an existing instrument with a different one,
and change the order of instruments.

Add an instrument to a score set
1. Do one of the following:
•

Choose New > Add Instrument Entry.

•

Double-click below the last instrument in the list.

2. Cut or copy the new entry, then paste it in the location you want in the list.
3. Click and hold the new entry, choose an instrument from the pop-up menu.

Replace an instrument in a score set

Click and hold the name of the instrument you want to replace in the Instrument column,
then choose an instrument from the pop-up menu.

Reorder instruments in a score set

1. Select the instrument you want to move by clicking in the margin to the left of the
instrument name.
2. Cut or copy the instrument.
3. Click in the margin to the left of the instrument list at the point where you want to add
the instrument, then paste the instrument.

Resize score sets in Logic Pro

You can resize a score set to between 25 and 250 percent of its original size. Scaling
affects the staffs in the score, the distance between staffs, all symbols associated with
staffs (notes, rests, and other symbols), text (including lyrics), and the thickness of slurs
and ties. Scaling doesn’t affect global text objects (header text, or text inserted outside the
margins) and text such as page numbers.
Scaling also doesn’t affect instrument parts that are created by extracting parts (as
described below; see Extract parts from a score). This lets you use the same staff styles
for both full scores and parts. In extracted parts, the staffs appear at their original size; in
the full score, their size is defined by the Scale parameter.

Scale a score set

Select the score set in the Score Sets window, then set the Scale parameter to a new value.

Note: Because the All Instruments score set can’t be edited (and therefore, can’t be
scaled), you must create a dedicated score set for the full score, in most cases.
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Create layouts for a score and its parts in Logic Pro

You can define separate layout parameters for a full score and its parts, then choose which
parameters a score set uses.

Create separate layout parameters for a full score and parts

1. Open the Global Score project settings by choosing File > Project Settings > Score (or
use the Open Score Project Settings key command), then click Global.

The Global pane offers separate page layout parameters for score and parts.
2. Edit the score and part layout parameters, including the top, bottom, left, and right
margins; header space; line distance; and maximum number of bars per line.

Choose the layout parameters used by a score set

In the Score Sets window, choose either Score or Parts from the Format pop-up menu.

For the default All Instruments score set, the Score format is used, except when a single
region is displayed. In this case, the Parts format is used.

Extract parts from a score in Logic Pro

You can quickly extract a single instrument from the score, instead of creating a score set
for every instrument in order to produce parts.
Using this method, only the track instrument names are used as instrument names in the
score. So, if you use this method to print your parts, you see the real instrument names of
the instruments as displayed in the Tracks area.

Extract an instrument part

Option-click the Score Set pop-up menu at the top of the inspector, then choose the
instrument from the list.
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Import score sets from other Logic Pro projects
You can import score sets from other projects.

Import score sets from another project
1. Do one of the following:
•

Choose File > Project Settings > Import Project Settings (or use the corresponding
key command).

•

Click All Files in the Browser.

2. Navigate to and select the project file, then click the Import button.
Note: If using the All Files Browser, you also need to click the Import Settings button,
which appears after you click the Import button.
3. In the Import Settings window, select the Score Sets checkbox (and deselect all other
settings that you don’t want to import), then click the Import button.
All score sets are imported from another project into the current project.

Edit the score layout
Overview of score layout in Logic Pro

Once you’ve added notes and symbols to your score, and edited individual staffs, the
next step is to refine the overall score layout. This process typically involves repositioning
staffs, as well as adjusting the number of bars per line, setting page margins, and changing
other Score project settings.
When editing the score layout, it’s recommended that you work in Page view, which
displays as many facing score pages as possible, depending on the size of the Score Editor
window and current zoom level.
You can choose different page display options that are useful for various printing or layout
tasks in Page view. The page display options include:
•

Show Margins: Displays page margins onscreen. These are not printed.

•

Show Pages in Pairs: Shows facing pages of the score. This setting depends on the
zoom settings and Scale region parameter.

•

Show Page Rulers: Displays horizontal and vertical rulers that make precise layout tasks
easier.

Switch to Page view

Do one of the following:
•

Choose View > Page View from the Score Editor menu bar.

•

Click the Page View button

in the Score Editor menu bar.

Change page display options

Choose View > Page Display Options from the Score Editor menu bar, then choose
display options.
To choose page display options, you must be in Page view.
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Jump to a specific page of the score

1. In Page view, choose View > Go to Page from the Score Editor menu bar.
2. Enter the page number, then click OK.
The playhead is automatically set to the beginning of the selected page, unless the
sequencer is running when you click OK. In this situation, Catch mode is turned off.
You should use Linear Score view for editing, as screen redraws are much faster, especially
on slower computers.

Edit line breaks in a score in Logic Pro

You can set line breaks individually for each score set, and also for each extracted part.
Line breaks are saved with the project.
By default, Logic Pro creates automatic line breaks based on the Spacing and Maximum
Bars/Line settings in the Global Score project settings. You can override automatic line
breaks using the Layout tool in Page view, and can also create line breaks by adding a Line
Break symbol from the Part box in any view.
For example, if the Global Score project setting for Maximum Bars/Line is 6, you can move
additional bars into a line using the Layout tool. Any unedited lines will still contain no
more than six bars. The full number of bars is only displayed if the spacing settings are low
enough to allow the proper display of that many bars.
For information about the Global project settings, see Global Score settings. For
information about adding line break symbols, see Add page and line break symbols.
Note: If you drag more bars into a line than would be displayed using the automatic line
break function, overlapping notes and symbols may result.

Move a bar up or down to the previous or next staff

In Page view, grab the bar (or bars) with the Layout tool and drag it down (the pointer
changes to a hand with a downward-pointing thumb), then release the mouse button.
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The bar is moved to the next staff system, and the remaining bars in the line are distributed
evenly over the entire width of the page.
You can also move the first bars of a staff upward into the preceding staff, by dragging
them up with the Layout tool.

Edit line breaks using the shortcut menu
1. Control-click a bar line.

2. Choose a setting from the shortcut menu to add or delete a line break, or return to the
default line break.
When you move a bar with the Layout tool, all manually edited line breaks in subsequent
lines are deleted, and automatic line breaks are recalculated from that line downward. If
you want to avoid having later lines recalculated, press and hold Option while moving the
bars with the Layout tool. This limits the line break to the staff systems you are editing;
other staff systems are unchanged.

Line and page breaks in a score set in Logic Pro

You can set page breaks individually for each score set, and also for each extracted part. Page
breaks are saved with the project. For information, see Add page and line break symbols.
When you add a Page Break symbol from the Part box, all bars following the page break are
moved to the following page. Bars on both preceding and following pages are automatically
adjusted in accordance with the Score project settings (discussed in the Edit line breaks
section). All staffs in the score are affected.

Edit local margins in a score in Logic Pro

You can move the left and right margins of each individual staff system with the Layout
tool, so they don’t align horizontally with the page margins. Local margins are saved as
part of the current score set, allowing different settings for each score set.

Move the left or right margin of a staff system

1. In Page view, choose the following settings from the Score Editor’s View > Page Display
Options submenu:
•

Show Margins

•

Show Pages in Pairs

•

Show Page Rulers

2. Click and hold (with the Layout tool) a little inside the beginning or end of the staff, then
drag to the left or right.

During this process, Left or Right Staff Margin appears in the help tag.
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Note: When altering margins, the number of bars per line adapts automatically (unless
you have manually adjusted line breaks beforehand). If the line is shortened, bars may be
moved down to the next line, depending on the Spacing parameters in the Global pane of
the Score project settings. (See Global Score settings.)

Realign an edited margin with the other staffs

Double-click at the end (or beginning) of the margin with the Layout tool.

Delete all line breaks and edited margins in the current score set
Choose Layout > Reset Line Layout from the Score Editor menu bar.

Use external symbol fonts in a score in Logic Pro

You can use an external (third-party) symbol font such as the Sonata font (available from
Adobe) or Bravura (available from the Standard Music Font Layout website) for display and
printout of notes and symbols, rather than the internal Logic Pro score font. The external
font must be properly installed on your computer.

Use an external symbol font in the Score Editor

Choose File > Project Settings > Score >, click Global, then choose a symbol font in the
Symbol Font area.

Share a Logic Pro score

When you’re ready, you can print the score, save it as a PDF file, or export as an image
using the Camera tool. The last method is most helpful if you want to export only a section
of the score. Whichever method you choose, the printed score is identical to the Score
Editor’s Page view display, except for the following items that are visible onscreen, but
not printed:
•

The dashed lines that represent page and header margins, and borders between staff
systems

•

The pointer and the playhead

•

Colors for page margins and staff lines of selected MIDI regions

•

Hidden time signature changes

•

Hidden note heads (displayed in gray on the screen) and their ties

•

Hidden bar lines (displayed as gray lines on the screen)

•

Hidden N-tuplet numbers

When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can view a score in Page view, use the Camera tool, and print to a PDF.

Print music notation for a software instrument track

1. Click the header of the Software Instrument track to select the track.
2. Choose File > Print (or press Command-P).
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Print the score

1. Choose the appropriate paper size and format in the File > Page Setup window.
2. Make sure that the Score Editor is the active window.
3. Choose File > Print (or press Command-P).
A dialog appears from which you can choose available options, such as which page
numbers you want to print, the number of copies, and whether to “print” to (Save as) a
PDF file. (The options may vary slightly for different printers.)
4. Choose the options you want to use, then click the Print button.

Export the score to a graphics file

1. Choose one of the following Camera Tool settings in the Logic Pro > Preferences >
Score pane:
•

Clipboard: The image is copied to the Clipboard so it can be pasted directly into
other apps, without saving it as a separate file.

•

PDF file: The image is saved as a PDF file. In the dialog that appears, enter a
filename and path (when the Camera tool is used to take a snapshot of the score).

2. Make sure you’re viewing the score in Page view, then select the Camera tool from the
Tool menu in the Score Editor menu bar.
3. Drag across the part of the score section you want to export. A selection rectangle
appears as you drag.
As soon as you release the mouse button, a PDF file of the selected area is created
(or the selection is copied to the Clipboard, depending on the Camera Tool setting you
chose).
When doing layout work that requires precision, such as positioning symbols and text
elements, it’s recommended that you work at high zoom levels. You can easily switch back
and forth between a normal and enlarged view of the display using the Zoom tool (or drag
to select while holding down Control, to enlarge the selected area).
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Customize the Score Editor
Choose a color mode for the Score Editor in Logic Pro

The settings in the Score Editor’s View > Colors menu determine the color mode for the
active Score Editor window. These settings have priority over all other color settings.

Choose the color mode for the Score Editor

Choose one of the following from the View > Colors submenu in the Score Editor menu bar:
•

Normal: Colors are assigned in accordance with the color settings in staff styles and
note attributes. As long as these settings haven’t been changed in new projects, the
result is a regular black-and-white printout, and black notes on a yellow background
onscreen.

•

Show Pitch: Applies colors in accordance with note pitches. The colors of notes
can be edited in the Functions > Note Attributes > Colors window. This window also
allows you to determine whether notes with accidentals match the color of those
without accidentals, or if each note in the chromatic scale has its own color.

•

Show Velocity: Applies eight different colors, in accordance with MIDI velocity. These
colors can also be edited in the Layout > Colors window.

•

Show Voice Assignment: Assigns different colors to different voices. This setting
makes sense only in staff styles that contain more than one voice. This mode
employs the colors of the User Palette, which can also be found and edited in the
Layout > Colors window, or by opening File > Project Settings > Score > Colors.

•

Force Black & White: Does exactly what the name implies. This mode is useful when
color options have been used in staff styles or have been assigned to notes using
note attributes, but you want to print a black-and-white score.

Show folder contents in a Logic Pro score

If the current display level allows more than one MIDI region to be viewed simultaneously
(linked or unlinked), the Explode Folders setting lets you display, and print, the contents of
different display (folder) levels simultaneously.
If the current display level contains folders, their contents are also displayed in the score.
Note: If this setting is not selected, folders appear as gray beams in Linear Score view, and
aren’t shown at all in Page view.

Show folder contents in the score

Choose View > Explode Folders from the Score Editor menu bar.
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Display global tracks in the Score Editor in Logic Pro

In Linear view, you can display global tracks in the Score Editor. You choose which global
track types are shown in the Score Editor, independent of those shown in the Tracks area.

Show global tracks in the Score Editor

Choose View > Global Tracks from the Score Editor menu bar.

Display instrument names in the Score Editor in Logic Pro

Use the Show Instrument Names setting to show the names of (used) track instruments, to
the left of the score display.

Display instrument names in the Score Editor

Choose View > Show Instrument Names from the Score Editor menu bar.

Display duration bars in the Score Editor in Logic Pro

You can show a graphical representation of a note’s duration by displaying duration bars in
the Score Editor.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can assign staff styles to individual MIDI regions as well as to tracks, allowing you to
use multiple styles on a single staff. This can be used to alternate between fully notated
passages and “improvised” passages using only beat slashes and chord symbols, for
example. You can show duration bars for selected notes or for all notes by choosing the
corresponding menu item in the Score Editor’s View > Duration Bars submenu.

Display duration bars in the Score Editor

Choose View > Duration Bars in the Score Editor, then choose one of the following
display modes:
•

Off: No duration bars are displayed.

•

Selected Notes: Duration bars are displayed for selected notes only.
Note: Duration bars for selected notes are displayed according to the Selection Color
setting in Logic Pro > Preferences > Score.

•

All Notes: Duration bars are displayed for all notes in the score.

Note: You can also use the Toggle Duration Bar Display key command, which toggles
between Off and the last selected display mode.
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Edit the length of duration bars in the Score Editor
in Logic Pro

When duration bars are displayed in the Score Editor, you can change their length.

Change the length of a duration bar

Place the pointer over the end point of the duration bar, then drag horizontally when the
pointer turns into the length change icon.

Display guide lines in the Score Editor in Logic Pro

You can show an object’s exact time position by displaying guide lines in the Score Editor.
Guide lines show the exact the relation of symbols, staffs, and time positions.

Display guide lines in the Score Editor

Choose View > Guides in the Score Editor menu bar, then choose one of the following
display modes:
•

Off: No guides lines are displayed.

•

Dragged Objects: Guide lines are displayed while objects are dragged.

•

Selected Objects: Guide lines are displayed for selected objects only.
Note: Guide lines for selected notes are displayed according to the Selection Color
setting in Logic Pro > Preferences > Score.

•

All Objects: Guide lines are displayed for all objects.

Note: You can also use the Toggle Guide Lines Display key command, which toggles
between All Objects and the last selected display mode.
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Share projects

Overview of sharing in Logic Pro

Logic Pro provides a variety of options you can use to distribute your projects and
songs. You can:
•

Bounce a project to an audio file

•

Burn a project to a CD or DVD

•

Share songs to the Music app

•

Share a song using AirDrop

•

Share a song using MailDrop

•

Share a song to your SoundCloud account

•

Share a project to GarageBand for iOS

•

Export a project as an AAF file

•

Export a project as an XML file

•

Export a project as a MusicXML file

You can also copy your projects to a hard drive or other storage device, or upload them to
the Internet in order to share them with other Logic Pro users. There are two things to be
aware of when sharing projects:
•

For a project to open and play on another computer, all the same assets must be
available (either in the project itself, or on the computer). Before copying your projects
to another hard drive or uploading them to the Internet, be sure to include all assets
used in the project. To save all assets into a project, select all the checkboxes in Project
Settings > Assets. See Manage project assets.

•

By default, Logic Pro saves projects as a special kind of file called a package, which
non-Apple formatted hard drives and Internet services do not support. To insure that
your project opens properly on another computer, you need to compress the Logic Pro
project package before copying or uploading. To compress a project package, select
it in the Finder and choose File > Compress or command-click the file and choose
“Compress.” If you are using compression software from manufacturers other than
Apple, please refer to its user guide for instructions.

Note: When you share a project to GarageBand for iOS, you can also share the project as a
ringtone to your iPhone or iPad.
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Bounce projects
Bounce a project to an audio file in Logic Pro

You can render, or bounce, a project to a single audio file or to multiple audio files. A
project can be bounced to several different file formats simultaneously, and a surround
project can be bounced to a set of surround audio files.
Projects can be bounced either in real time or offline (which is typically faster). All
parameters, effects, and automation on the unmuted tracks in the project are recorded as
part of the bounce file.
The format (stereo, mono, or surround) of the resulting bounce file (or files) depends on
the format of the output channel strip. Output 1-2 is the default output channel strip used
for bounces, and produces a stereo audio file. When the output channel strip is set to
mono, a mono audio file is generated.
Bounce files can be reused in Logic Pro, saving processing resources by replacing or
bypassing multiple regions, instruments, and effects. Bounces can also be used with other
music applications and devices, sent to mastering facilities, posted on the Internet, sent to
streaming and retail services, added to a music playlist, or uploaded to a mobile device.

Bounce the current project to an audio file

1. In the Logic Pro Tracks area or the Mixer, make sure that the tracks you want to include
in the bounce are routed to the main output (Output 1-2) and are not muted.
If your project has multiple output channel strips, you can bounce only the tracks routed
to a specific output channel strip using the Bnce button on that channel strip. See Use
output channel strips.
2. Choose File > Bounce > Project or Section.
3. In the Bounce dialog, select one or more destination formats in the Destination area.
4. When you select a destination format, bounce options for that format appear to the
right of the Destination area. For each selected destination format, choose bounce
options.
5. To limit the bounce to only part of the project, adjust the Start and End value sliders.
You can click the up and down arrows, or click one of the numerals and enter a new
value.
If Cycle mode is on when you choose File > Bounce, only the part of the project
enclosed by the cycle area is bounced. You can adjust the Start and End value sliders to
change what part of the project is bounced. See Set the bounce range.
Tip: To avoid having reverb and other effect tails cut off at the end of the project, set
the end position of the bounce a little bit past the end of the last region.
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6. Set the bounce mode by selecting one of the two Mode buttons:
•

Realtime: Performs the bounce in real time. Use this setting when you want to
bounce audio and software instrument tracks, or external MIDI sound sources that
are routed to the Mixer via aux channels.

•

Offline: Bouncing offline can be faster than real time for more complex projects,
and can perform bounces not possible in real time (because they might exceed the
processing power of your computer).
Only internal sources (audio or software instrument tracks) can be bounced offline;
not MIDI tracks or audio channel inputs. Offline bouncing is available only for output
channels of devices using native (Core Audio) audio drivers; not for DSP-based
audio hardware (which can be bounced only in real time.)

7. For additional control over effect tails, select either of the following Mode options:
•

Bounce 2nd Cycle Pass: The bounce process takes two repetitions of the cycle range
into account, with the creation of the bounce file starting at the second repetition.
This is useful if you want effect tails (from the first cycle pass) to be added to the
start of the bounce file.

•

Include Audio Tail: The bounce file is extended as far as necessary to include any
instrument release and effect tail.

Note: Some plug-ins, including plug-ins used for mastering and the test oscillator plugin, can add noise to the signal. Include Audio Tail should not be selected when using
these plug-ins, as the resulting bounce file would be too long.
8. Choose a normalization setting from the Normalize pop-up menu:
•

Off: No normalization is applied.

•

Overload Protection Only: Downward normalization takes place only for overloads
(levels above 0 dB, which would lead to clipping), but no normalization takes place
for lower levels.

•

On: The project (incoming audio) is scanned for the highest amplitude peak, then
the level is increased so that the peak is at the maximum possible level (without
clipping).

9. To add PCM, MP3, or M4A bounce files to the Project Audio Browser, select Add to
Project.
10. Click Bounce.
Depending on the length and complexity of the project, the bounce process may take a
few moments to complete.

Set the bounce filename and location

By default, the name of the bounce file matches the selected output channel strip (Output
1-2, if the project was bounced using the File > Bounce command). Bounce files are saved
by default to the ~/Music/Logic/Bounces folder, but you can specify a new location. The
new location is used for subsequent bounces.
When you bounce a project, you can change the name and choose a different location to
save the bounce file (or files).
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1. In the Logic Pro Bounce window, to rename the bounce file, enter a new name in the
Save As field.

2. Browse to the location where you want to save the bounce file. You can click the New
Folder button in the lower-left corner of the Bounce window to create a new folder at
any location.

3. Click Bounce.
When you bounce to multiple destination files, all the resulting files are saved in the chosen
folder. All files have the same filename, but with the appropriate file extensions (.pngff,
.mp3, .m4a, and so on).
You can also bounce individual tracks in place, or bounce all tracks in place.
Another option is to burn a project to a CD or DVD at the same time you bounce the project.

Burn a project to a CD or DVD in Logic Pro

In addition to bouncing a project to an audio file, if your computer has disc-burning
capability you can burn the project to a CD or DVD (in DVD-Audio format). Logic Pro can
directly burn Red Book audio to blank CDs or burn DVD-Audio to blank DVDs. You can
bounce to one or more audio formats and burn the project to disc at the same time.

Burn the current project to a CD or DVD

1. In the Logic Pro Tracks area or the Mixer, make sure that the tracks you want to include
are routed to the main output (Output 1-2) and are not muted.
If your project has multiple output (channel strips), you can select any of the outputs to
bounce only the tracks routed to those outputs. For information about output channel
strips, see Use output channel strips.
2. Insert a recordable CD or DVD into your computer’s optical drive.
Before burning, be sure your computer supports the recordable CD or DVD you’re using.
3. Choose File > Bounce > Project or Section.
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4. In the Bounce dialog, select Burn to CD/DVD as one of the destination formats in the
Destination area.
Note: Selecting Burn to CD/DVD automatically disables the PCM > Surround and Split
Stereo options, because CD or DVD-Audio makes use only of interleaved stereo files.

5. Choose one of the following options from the Mode pop-up menu:
•

CDDA: Burns the project to a CD. If the selected sample rate (chosen in the PCM
pane) is higher than 44.1 kHz, a copy of the bounced PCM file is created (with an
automatic sample rate conversion to 44.1 kHz) before encoding. This conversion
takes place because the CD Audio format (Red Book) does not support sampling
rates higher than 44.1 kHz.

•

DVDA: Burns the project to a DVD. Any sample rate up to 192 kHz can be used for
stereo files, and up to 48 kHz for surround files.

The Media Status field shows whether or not a disc is inserted in the chosen disc
burner. Make sure you insert a disc before burning.
6. Set burn options by selecting either of the following Mode checkboxes:
•

Simulate write only: This option simulates a CD/DVD burn, but doesn’t write data
to the blank media. This option can be used either alone or in conjunction with the
“Write as multi-session” option (if burning a CD).

•

Write as multi-session: This option is only available when CDDA is chosen in the
Mode pop-up menu. This option lets you add a data session to the same CD at a
later date—to add the project folder, for example.

7. Choose the built-in optical disc drive or another disc burner connected to your
computer from the Device pop-up menu.
8. Choose the write speed for the disc burner from the Speed pop-up menu.
The first time you open the Speed pop-up menu, Logic Pro queries the disc burner for
available speeds. This can take a few moments.
9. Choose a dithering algorithm from the Dithering pop-up menu. For details on dithering
options, see About dithering algorithms.
Note: If you attempt to switch the PCM Resolution to 16 Bit when in DVDA burn mode,
DVD burning is automatically disabled (following a warning).
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10. To limit the bounce to only part of the project, adjust the Start and End value sliders.
You can click the up and down arrows, or click one of the numerals and enter a new
value.
By default, the entire project is bounced. If Cycle mode is on when you choose File >
Bounce, only the part of the project section inside the cycle area is bounced. You can
adjust the Start and End value sliders to change what part of the project is bounced. For
more information on setting the bounce range, see Set the bounce range.
11. Choose a normalization setting from the Normalize pop-up menu:
•

Off: No normalization is applied.

•

Overload Protection Only: Downward normalization takes place only for overloads
(levels above 0 dB, which would lead to clipping), but no normalization takes place
for lower levels.

•

On: The project (incoming audio) is scanned for the highest amplitude peak, then
the level is increased so that the peak is at the maximum possible level (without
clipping).

12. Click the Bounce and Burn button.

Set the disk filename

By default, the name of the burned disk matches the selected output channel strip (Output
1-2, if the project was bounced using the File > Bounce > Project command.) When you
burn a project, you can change the filename for the disk.
•

In the Logic Pro Bounce window, to change the filename, enter a new name in the Save
As field, then click Bounce.

When you bounce to multiple destination files, all the resulting files are saved in the chosen
folder. All files have the same filename, but with the appropriate file extensions (.pngff,
.mp3, .m4a, and so on).
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Set the bounce range in Logic Pro

By default, when you bounce a project (by choosing File > Bounce > Project), the entire
project from start to end is bounced. You can bounce only part of a project by setting the
bounce range before performing a bounce. There are several ways to set the bounce range.

Set the bounce range

In Logic Pro, do one of the following:
•

Turn on Cycle mode. When Cycle mode is on, the bounce range matches the locator
positions.

•

Select one or more regions in the Tracks area. The bounce range matches the selected
area.

•

In the Bounce dialog, adjust the Start and End positions. When you open the Bounce
dialog, the Start and End positions match the bounce range (or the length of the
project, if no regions are selected and Cycle mode is off).

Set bounce options
PCM bounce options in Logic Pro
When you select PCM in the Destination area of the Bounce dialog, the following options
are available:
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•

File format pop-up menu: Choose the PCM file format (AIFF, Broadcast Wave, or CAF).
PCM files can be automatically added to the Project Audio Browser by selecting the Add
to Project checkbox.

•

Resolution pop-up menu: Define the resolution of the bounce file. The options are 16 Bit
(for CD delivery), 8 Bit (for multimedia productions,) or 24 Bit (for mastering to DVD).
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•

Sample Rate pop-up menu: Choose the sample rate for your bounce file. Options
range from 11,025 to 192,000 Hz, including the three most commonly used sample
rates: 44,100 (CD-DA), 48,000 (DAT), and 96,000 (DVD).

•

File Type pop-up menu: Choose either Split (for use in Pro Tools), or Interleaved (for
further use in Logic Pro or with CD writing software).
Note: Choosing Split disables Burn to CD/DVD, if it’s chosen in the Destination area.

•

Dithering pop-up menu: Dithering is recommended when bouncing 24-bit recordings
into 16-bit files. For details on dithering options, see About dithering algorithms.

•

Surround Bounce checkbox: Available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced. Select this checkbox to bounce all outputs in the
project surround format (File > Project Settings > Audio > Surround Format).
All surround outputs are bounced simultaneously, regardless of which output channel’s
Bounce button is clicked (or if the Bounce window was opened via File > Bounce). Each
surround channel is bounced to a separate file.
The Logic Pro > Preferences > Audio > I/O Assignments pane gives you access to the
surround settings.
•

You set the stereo and surround output formats in the Output pane.

•

The Bounce Extensions pane displays the extensions that are added to the filenames
resulting from a stereo or surround bounce. Select the various fields to edit the
extensions.

•

You set the stereo and surround input formats in the Input pane.

Note: Selecting the Surround Bounce option deselects the MP3, M4A: AAC, and Burn
checkboxes in the Destination pane if they’re selected.
•

Add to Project checkbox: Adds the bounced PCM file to the Project Audio Browser.

•

Add to Music checkbox: Check this box if you want to add the .m4a file to your Music
library.
Note: If your Mac is running macOS Mojave or earlier, an “Add to iTunes” checkbox
replaces the “Add to Music” checkbox.

MP3 bounce options in Logic Pro
You can bounce projects to MP3 (MPEG-2, Audio Layer 3) format files. The MP3 format
was developed by the Fraunhofer Institute, and allows high compression rates while
maintaining reasonable audio quality. MP3 is a widely used standard for audio file exchange
over the Internet.
Because the MP3 file format involves a loss of audio quality, you shouldn’t use MP3 files
during production if you have access to the same audio data in non-lossy formats such as
AIFF or WAV.
Bounced PCM files are also used for encoding to MP3/M4A. Note that this occurs before
dithering takes place.
Note: The MP3 format doesn’t support sampling rates higher than 48 kHz. If the selected
sample rate is higher than 48 kHz, a temporary copy of the PCM file (with a 48 kHz sample
rate) is created before the project is bounced to MP3 format.
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If PCM is unselected in the Destination area of the Bounce dialog, a temporary PCM file
is created and used as a source for bouncing to MP3 or M4A, or for burning to a CD
(depending on which options are selected).
Selecting the MP3 option in the Destination area automatically disables the PCM >
Surround option. This is because the MP3 format doesn’t support surround. However, Split
Stereo format is possible, even if the encoded MP3 file is set to Joint Stereo mode.
When you click MP3 in the Destination area, the following options are available:

•

Bit Rate (Mono/Stereo) pop-up menus: MP3 bit rates are available between 32 kbps
and 320 kbps, but default to 80 kbps mono, and 160 kbps stereo. These rates offer
acceptable quality and good file compression.
For enhanced audio quality, you can choose:
•

96 kbps for mono streams

•

192 kbps for stereo streams

You can choose higher rates, but the quality improvement afforded by bit rates above
96/192 kbps is nominal. Note that the higher the bit rate, the larger the file size of the
bounced file.
•

Use Variable Bit Rate Encoding (VBR) checkbox: Variable Bit Rate encoding compresses
simpler passages more heavily than passages that are (more) harmonically rich,
generally resulting in better quality MP3 files.
Because not all media players can accurately decode VBR-encoded files, this option is
off by default. If you know that your target listeners can decode VBR-encoded files, you
can turn this option on.
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•

Quality pop-up menu: Keep this set to Highest (the default) whenever possible.
Reducing the quality shortens the conversion process, but at the expense of audio
quality.

•

“Use best encoding” checkbox: Like the Quality parameter, if you deselect this option,
you shorten the time needed to bounce the file at the price of audio quality. This should
always be selected, unless conversion time is an issue.
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•

“Filter frequencies below 10 Hz” checkbox: When this option is selected, frequencies
below 10 Hz (which usually aren’t reproduced by speakers, and aren’t audible to
human ears at any rate) are removed. This leaves slightly more data bandwidth for the
frequencies that are audible, resulting in an improvement of the perceived quality. Only
deselect this option if you’re experimenting with subsonic test tones.

•

Stereo Mode pop-up menu: Choose Joint Stereo or Normal stereo mode. Depending
on the original file, these settings may (or may not) offer any audible difference.
Experiment with both settings to see which provides better results.

•

“Write ID3 tags” checkbox: Writes ID3 tags to the file.

•

ID3 Settings button: Opens a dialog where you can edit and configure ID3 tags.

To edit an ID3 tag, double-click any of the Content column fields to the right of the
corresponding ID3 Frame column entry, and enter your text.
Select the “Use default values” checkbox to display default settings for certain Content
columns, such as the Project Title and Tempo (Beats Per Minute) columns. Selecting
“Use default values” also sets the Initial Key column to the first entry shown in the
Signature track (This defaults to C if no key has been set for the project).
•

“Add to Music” checkbox: Select this box if you want to add the .m4a file to your Music
library.
Note: If your Mac is running macOS Mojave or earlier, an “Add to iTunes” checkbox
replaces the Add to Music checkbox.
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M4A: AAC bounce options in Logic Pro
When you click M4A: AAC in the Destination area of the Bounce dialog, the following
options are available:

•

Encoding pop-up menu: Choose Advanced Audio Codec (AAC) or Apple Lossless to set
the encoding for your .m4a (commonly referred to as MP4) file. While both encoding
algorithms provide high-quality audio, the AAC format uses a higher compression ratio,
resulting in smaller file sizes.
Choosing the M4A: AAC option in the Destination area disables PCM > Surround. Split
Stereo is still available.
If the selected sample rate is higher than 48 kHz, a copy of the bounced PCM file is
created (with an automatic sample rate conversion to 48 kHz) before encoding. This
conversion takes place because the M4A format does not support sampling rates higher
than 48 kHz.

•

Bit Rate pop-up menu: Choose a rate between 16 kbps and 320 kbps.
Note: This parameter is only available when the AAC codec is chosen.

•

“Encode with variable bit rate (VBR)” checkbox: Variable Bit Rate encoding compresses
simpler passages more heavily than passages that are (more) harmonically rich,
generally resulting in better quality files.
Because not all media players can accurately decode VBR-encoded files, this option is
off by default. If you know that your target listeners can decode VBR-encoded files, you
can turn this option on.

•

“Add to Music” checkbox: Check this box if you want to add the .m4a file to your Music
library.
Note: If your Mac is running macOS Mojave or earlier, an “Add to iTunes” checkbox
replaces the “Add to Music” checkbox.
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About dithering algorithms in Logic Pro

Logic Pro includes the professional POWr (Psychoacoustically Optimized Wordlength
Reduction) and UV22HR dither algorithms, designed to convert 24-bit recordings to 16-bit
files (as required for CD burning, for example). Dithering can be used when:
•

Burning audio files to a CD

•

Bouncing audio files to disk

•

Exporting AAF files (See Export a project as an AAF file.)

The following dithering options are available in the Bounce dialog:
•

None: No dithering is applied.

•

POWr #1 (Dithering): A special dithering curve is used to minimize quantization noise.

•

POWr #2 (Noise Shaping): Additional noise shaping is used over a wide frequency
range, which can extend the dynamic range of the bounce file by 5–10 dB.

•

POWr #3 (Noise Shaping): Additional, optimized noise shaping is used, which can
extend the dynamic range by 20 dB within the 2–4 kHz range (the range in which human
hearing is most sensitive).
Note: Noise Shaping minimizes the side effects caused by bit reduction
(downsampling), by moving the quantization noise spectrum to the frequency range
above 10 kHz (the least sensitive part of the range of human hearing). This process is
technically known as spectral displacement.

•

UV22HR: Allows for the best possible sound resolution when bouncing 24-bit
recordings into 16-bit files.

The dithering algorithm that sounds best depends on the audio material, and also your
personal taste. Audition the audio material to be dithered with each of the algorithms to
determine the best setting. In some cases, you may find that the best results are achieved
by using no dithering at all.
Important: Avoid dithering the same audio signal multiple times.
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Share songs to the Music app from Logic Pro

You can share a song to the Music app on your computer to play, add to a playlist, or
sync to your iPhone or iPad. Songs can be shared as uncompressed AIFF audio files or as
compressed audio files with various quality levels.

Share a song to the Music app:

1. In Logic Pro, choose File > Share > Song to Music.
2. In the Share to Music dialog, do the following:

•

If you want to rename the shared file, select the name in the Title field, then enter a
new name.

•

Enter information for the shared file in the Artist, Composer, Album, and Playlist
fields.
Tip: You can also add these tags in My Info preferences.

•

Choose the quality level for the shared file from the Quality pop-up menu.

•

Select the checkbox if you want to export only the part of the song within the cycle
area (if active), or the part defined by selected regions (if selected). If the checkbox
is unselected, or there is no active cycle area or selected regions, the entire project
length is exported.

3. Click Share.
The shared song appears in the Music app, where you can add it to playlists, convert it, or
burn it to a CD. The format of the shared song is determined by the import settings.
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Share songs from Logic Pro using AirDrop
AirDrop lets you quickly send songs to anyone near you—wirelessly.

Share a song to another Mac nearby

1. To see other Mac computers nearby, turn on Wi-Fi and click the AirDrop icon in the
sidebar of a Finder window. The recipients must also turn on Wi-Fi and click the AirDrop
icon on their Mac computers.
The user pictures and computer names of those near you appear in the AirDrop window.
2. In Logic Pro, choose File > Share > AirDrop.
3. In the AirDrop dialog, do the following:

•

Select Project, if you want to share a project that recipients can open and edit in
Logic Pro on another Mac.
If working with a project package, all project assets are shared.
If working with a project folder, only the project file and not the assets are shared.

•

Select Song, if you want to share an audio file mixdown that recipients can open and
play in Music or any app that supports .m4a files.
You can edit the following settings:
•

Enter a new name in the Title field.

•

Choose an audio format from the Quality pop-up menu.

•

Choose whether to bounce the entire project or only part of it based on the cycle
area or the length of selected regions.

4. Click Share.
5. Select the recipient in the Share sheet that appears.
6. Click Send.
Once the recipient accepts the file transfer, the project or song is transferred to his or
her Downloads folder.
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Share songs from Logic Pro using MailDrop
MailDrop lets you quickly send songs to anyone via Mail.

Share a song via Mail

1. In Logic Pro, choose File > Share > Mail.
2. In the Mail dialog, do the following:
•

Select Project, if you want to share a project that recipients can open and edit in
Logic Pro on another Mac.
If working with a project package, all project assets are shared.
If working with a project folder, only the project file and not the assets are shared.

•

Select Song, if you want to share an audio file mixdown that recipients can open and
play in Music or any app that supports .m4a files.
You can edit the following settings:
•

Enter a new name in the Title field.

•

Choose an audio format from the Quality pop-up menu.

•

Choose whether to bounce the entire project or only part of it based on the cycle
area or the length of selected regions.

3. Click Share.
If a mail account is available, a new email is created. The project or song attachment is
delivered, even if the size exceeds the maximum allowed size for attachments.

Share songs to SoundCloud from Logic Pro

If you have a SoundCloud account, you can share a song to SoundCloud directly from
Logic Pro. You can choose the quality and visibility level for the shared song, set
permissions, and also send an email to notify others that the song is available.

Share a song to your SoundCloud account

1. In Logic Pro, choose File > Share > Song to SoundCloud.
2. If you aren’t currently logged in to your SoundCloud account, enter your email address
and password, then click Connect.
Alternatively, you can log in to your Facebook or Google account.
3. In the Share to SoundCloud dialog, do the following:
•

To sign in to a different SoundCloud account, click Change, then enter the login
information for the account.

•

To share an audio file, select File, click Browse, then browse to the location of the
file.

•

To share the current song, select Bounce.

•

Enter title, artist, composer, and album information for the song in the respective
text fields.
Songs must have a title in the Title field. The remaining information is optional.
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Tip: You can also add these tags in My Info preferences.
•

Choose the quality level for the song from the Quality pop-up menu.

•

Choose the visibility level for the song from the Visibility pop-up menu.

•

Set download and streaming permissions for the song in the Permissions section.

4. Click Share.
To return to Logic Pro without sharing the song, click Cancel.

Share a project to GarageBand for iOS
from Logic Pro

You can share a special GarageBand for iOS-compatible version of your Logic Pro project
to iCloud. When you share a project to GarageBand for iOS you can continue to work on the
project on your iOS device, and you can also share the project as a ringtone.
The project appears in the GarageBand My Songs browser as a new song with a single
track containing a reference mix of the entire project. You can add, edit, and arrange new
tracks in GarageBand for iOS, then share the song back to iCloud. When you reopen the
project in Logic Pro, the new tracks are added to the original project.
Note: Sharing a project to GarageBand for iOS requires having an active Internet
connection and iCloud login.

Share a project to GarageBand for iOS

1. In Logic Pro, choose File > Share > Project to GarageBand for iOS.
2. In the Export to GarageBand for iOS dialog Save As field, Logic Pro defaults to naming
your shared GarageBand project with the same name as your project. If you wish to
change the name, type the new name here.

WARNING: If you change the folder from GarageBand for iOS—iCloud, your shared
project does not appear in the GarageBand for iOS My Songs browser.
3. Click Save.
To return to Logic Pro without sharing the song, click Cancel.
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Export projects
Export a Logic Pro project as an AAF file

AAF (Advanced Authoring Format) is used by other music production applications such as
Pro Tools. You can use it to import multiple audio tracks, inclusive of references to tracks,
time positions, and volume automation.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can export AAF files.

Export the current project as an AAF file

1. In Logic Pro, choose File > Export > Project as AAF File (or use the Export Project as
AAF File key command).
2. In the Save AAF File As dialog, choose the following pop-up menu options:
•

Sample Rate: Choose 44.1 kHz, 48 kHz, 88.2 kHz, or 96 kHz.

•

Bit Depth: Choose either 16 or 24 bit.

•

File Format: Choose WAVE or AIFF.

•

Dith. Type: Choose a dithering algorithm (see About dithering algorithms).

3. Choose a location, enter a name for the file, then click Save.
The export includes all used regions, inclusive of track and position references, and
volume automation.

Export a Logic Pro project as a Final Cut Pro XML file

The Final Cut Pro XML format is used to import and export audio data between Final
Cut Pro and Logic Pro. The Final Cut Pro XML format supports volume and stereo pan
automation data.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can export Final Cut Pro XML files.

Export the current project as a Final Cut Pro XML file

1. In Logic Pro, choose File > Export > Project to Final Cut Pro XML.
2. In the Export dialog, type a name for the exported file and browse to a location to save
it.
3. To include the video file in the exported XML, select the “Include video in export”
checkbox.
4. To export the file as a Final Cut compound clip, select the “Export as Final Cut
Compound Clip” checkbox.
5. Click Save.
Note: When you export to Final Cut Pro XML, audio software instrument tracks are bounced
to audio files, but MIDI tracks are ignored. Bouncing automatically switches to real-time
mode, if necessary (such as when an I/O or External Instrument plug-in is used).
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Export a score from Logic Pro as MusicXML

MusicXML is an XML-based music notation file format, supported by many notation
and music OCR applications and some music production applications. You can freely
redistribute the MusicXML DTDs and XSDs used with MusicXML under the MusicXML
Public License.
Many score writing programs (including Finale, Sibelius, and MuseScore) and Music OCR
programs (including SmartScore and PhotoScore) can open and display MusicXML files.
Some music sequencer programs (including Cubase, SONAR, and Rosegarden) can also
open these files.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
you can export MusicXML files.

Export a score project in MusicXML format

1. In Logic Pro, choose File > Export > Score as MusicXML.
2. In the Save dialog, type a name for the exported file and browse to a location to save it.
3. Click Save.
You can also import a MusicXML file, play it, and view it in the Score Editor. For
information, see Import MusicXML files.
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Work in surround

Using Surround in Logic Pro

Logic Pro offers extensive surround processing and mixing functions for all major
surround formats.
Surround features are available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
In a surround project in Logic Pro, incoming multichannel audio is recorded as interleaved
multichannel files. Imported split multichannel files are converted automatically to
interleaved multichannel files.
There are two plug-ins you can use on the surround master channel strip to check how
your surround mix sounds in different formats:
•

The Down Mixer plug-in lets you hear your surround mix in stereo and other surround
formats. The Down Mixer is not available for surround formats that use overhead
channels. For more information, see the Down Mixer chapter in the Logic Pro Effects
manual.

•

The Spatial Audio Monitoring plug-in lets you check your surround mix in the Apple
Music binaural format, on Apple headphones that support head tracking, and on built-in
computer speakers that support spatial audio. See the Spatial Audio Monitoring chapter
in the Logic Pro Effects manual.
Note: To use the Spatial Audio Monitoring plug-in, you must have MacOS Monterey 12.3
or later installed.

You can bounce multichannel projects as split and interleaved surround files. See Bounce
surround audio files in Logic Pro.
Logic Pro does not encode or decode surround files. You can use the Compressor app,
available in the Mac App Store, to encode surround files.
To work with surround, you need an audio interface that has the number of output channels
required by the chosen surround format. For example, the audio interface must have six
outputs if you use the 5.1 surround format. You will also need the same number of speakers
(and appropriate amplification) to hear the channels when mixing. See Overview of
surround formats in Logic Pro.
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Spatial audio mixing for Dolby Atmos

You can also create spatial audio mixes for playback on systems and devices that support
Dolby Atmos or for binaural playback using headphones. A Dolby Atmos mix consists
of bed tracks and object tracks. You mix and route bed tracks just like normal surround
tracks. You use the 3D Object Panner to position and move object tracks in 3D space.
The automation information describing the position and movement for each object track
is stored separately from the audio signal as metadata. See Build a Dolby Atmos mix in
Logic Pro.
The Dolby Atmos plug-in on the surround master channel strip renders the audio and
automation metadata for each object track plus the audio from the surround bed and lets
you monitor it in various surround formats, including 5.1.4 and 7.1.4. In addition to mixing
on a speaker system, you can also monitor your mix in different binaural formats with just a
pair of headphones. See Logic Pro Spatial Audio overview.
You can export your Dolby Atmos mix to an ADM BWF file.

Set up Logic Pro for surround
Surround preferences in Logic Pro

Before you can create a Logic Pro project in surround, you need to specify which outputs
of your interface are connected to which speaker. If you’re recording in surround, you also
need to specify the inputs of your audio interface.
These configurations are made in the Output and Input panes of the Audio > I/O
Assignments preferences. The I/O Assignments pane features three subpanes: Output,
Bounce Extensions, and Input. All three subpanes are linked, but can be adjusted
independently.
Note: In all but the rarest circumstances, the default settings for each surround format
should meet your needs.
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Open the I/O Assignments preferences
•

Choose Logic Pro > Preferences > Audio, then click I/O Assignments (or use the Open
Surround Preferences key command).

Set the output or input surround channel assignment

1. In the Logic Pro I/O Assignments preferences, click either Output or Input.
2. Choose the surround format you want to work in from the “Show as” pop-up menu.
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This action automatically sets the input and output channel pop-up menus in both the
Output and Input panes.
Note: The surround format chosen here only alters the layout/routing of channels to
speakers in the I/O Assignments pane. The actual project surround format is determined in
the project settings. See Set the project surround format.

Choose which speaker outputs to use

In the Surround section of the Output pane, do one of the following:
•

•

Use a standard output configuration: Click one of the three Initialize buttons below the
“Show as” pop-up menu.

•

Default: Activates the default setup of Logic Pro. For example, for the 5.1 format,
output 1 is routed to the left speaker, output 2 to the right one, output 3 to left
surround, output 4 to right surround, output 5 to the center speaker, and output 6 to
the LFE channel.

•

ITU: Assigns the International Telecommunications Union standard, used by many
professionals.

•

WG-4: Assigns the WG-4 standard, set by the DVD Forum for DVD-Audio.

Use a custom output configuration: Choose the output of your audio interface from
each of the active pop-up menus: Left, Center, Right, and so on.

If you want to work on, or create, a surround project on a computer that is not equipped
for surround playback, choose outputs that don’t exist for your hardware. These are
shown in parentheses—for example, (Output 17) or (Output 32).
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Choose which inputs to use for each surround channel

In the Surround section of the Input pane, do one of the following:
•

•
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Use a standard input configuration: Click one of the three Initialize buttons below the
“Show as” pop-up menu.

•

Default: Activates the default setup. For example, for the 5.1 format, input 1 is routed
to the left speaker, input 2 to the right one, input 3 to left surround, input 4 to right
surround, input 5 to the center speaker, and input 6 to the LFE channel.

•

ITU: Assigns the International Telecommunications Union standard, used by many
professionals.

•

WG-4: Assigns the WG-4 standard, set by the DVD Forum for DVD-Audio.

Use a custom input configuration: Choose the input of your audio interface from each of
the active pop-up menus: Left, Center, Right, and so on.
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Change the bounce extensions
1. Click Bounce Extensions.

2. Enter a new extension name in any of the active fields.
For example, the default left extension “.L” could be renamed “.Left,” or the left surround
extension “.Ls” could be changed to “.LSurr.” Don’t forget the period before the
extension.
If you change your mind, click the Reset Extensions button to revert to default entries.
Note: Changing the extension has no impact on the files—it simply makes them easier to
identify. If you find the defaults clear enough, there’s no need to change them.
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Set the surround format in Logic Pro

You choose the surround format you want to use for a Logic Pro project in the Audio
project settings. By default, every new project is set to 5.1. For more information on
surround formats, see Surround formats overview.

Choose the project surround format

1. Choose File > Project Settings > Audio.
2. Choose a format from the Surround Format pop-up menu.

Tip: Save a project that has been set up for surround format work as a template.
This way you won’t have to set the surround format every time you want to create a new
surround project. Start with the included templates, modify them as necessary, and save
them as your own templates.

Set the channel strip input format in Logic Pro

The channel strip input format determines the mono, stereo, or surround status of the
channel strip.You set the input format using the Channel Mode button.
The symbol on the Channel Mode button indicates the input status:
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•

Mono: One circle represents a mono input format. The level meter shows a single
column.

•

Stereo: Two interlocked circles represent a stereo input format. The level meter divides
into two independent columns when a stereo input format is chosen.

•

Left: Two circles, with the left one filled, indicate a left channel input format. Only the
left channel of a stereo audio file is played back. The level meter shows a single column.

•

Right: Two circles, with the right one filled, indicate a right channel input format. Only
the right channel of a stereo audio file is played back. The level meter shows a single
column.
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•

Surround: A square with five dots indicates the surround channel input format. The level
meter divides into multiple linked columns (the number matches the project surround
format) when the surround input format is chosen.

For more information on channel strip controls, see Channel strip controls in Logic Pro.

Choose the channel strip input format
•

Click and hold the Channel Mode button on the channel strip, then choose an input
format from the pop-up menu.

Set the channel strip output format in Logic Pro

Logic Pro can automatically determine the output format of specific channel strip types.
You can override the automatic choices by manually setting the output; otherwise, the
channel strip output formats follow these rules:
•

Audio channel strips: The channel strip of an empty audio track is automatically set to
the format of the first audio file added to it. If you add an audio file to a track assigned
to a different output format (adding a stereo file to a track routed to a surround output,
for example), the audio file is automatically upmixed or downmixed to match the output
format of the channel strip.
Note: The highest possible surround format is determined by the surround format in the
project settings. See Set the project surround format.

•

•

Instrument channel strips: Instrument channel strips automatically adopt the channel
format of the inserted instrument.
•

If you insert a stereo instrument, the channel strip output will be stereo.

•

If you insert a surround instance of a software instrument (ES2 or Sculpture, for
example), the channel strip output will match the project surround format.

Aux channel strips: Automatically created aux channel strips adopt the format of their
input source (if a stereo channel is routed to an aux channel strip, the aux will be
stereo). If you manually change the output format of an aux channel strip, Logic Pro
automatically:
•

Inserts a Surround Balancer or a mono/stereo to surround panner, if you are
changing the output of an aux from mono to stereo or mono/stereo to surround. See
Surround Panner overview.

•

Downmixes the signal to the required format.

If you don’t want to work with the automatic settings, you can manually set the output of all
audio, instrument, aux, and output channel strips to the chosen surround format.
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Set a channel strip output format to surround
•

In Logic Pro, click the Output slot of the channel strip, then choose Output > Surround
from the pop-up menu.

The Pan control of the channel strip is replaced by a two-dimensional Surround Panner
control. The loudspeakers are represented by dots around this control. The pan position
is indicated by a green dot that you can move with the pointer. See Overview of the
Logic Pro Surround Panner.

Set the output format of multiple channel strips to surround

1. In Logic Pro, select all channel strips that you want to set to surround output.
2. Click the Output slot of one of the selected channel strips, then choose Output >
Surround from the pop-up menu.
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Change the order of surround level meters in Logic Pro

In Logic Pro, you can determine the order of channels in surround (multichannel) level
meters. You can choose the following options.
Channel order Meter 1

Meter 2

Meter 3

Meter 4

Meter 5

Meter 6

Internal

Left

Right

L Surround

R Surround

Center

LFE

ITU

Left

Right

Center

LFE

L Surround

R Surround

Centered

L Surround

Left

Center

Right

R Surround

LFE

LCR Grouped

Left

Center

Right

L Surround

R Surround

LFE

Change the multichannel level meter order

1. Choose Logic Pro > Preferences > Display (or use the Open Display Preferences key
command).
2. Click Mixer, then choose an option from the Channel Order pop-up menu in the Level
Meters area.

Note: The setting you choose here does not apply to metering plug-ins, such as Level
Meter or MultiMeter.
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Surround features
Surround Panner
Overview of the Logic Pro Surround Panner
You use the Surround Panner in Logic Pro to place track output signals at specific speaker
positions. You can use the Surround Panner directly in a channel strip, but it is better to
open it in a separate window.
You can open multiple Surround Panner windows simultaneously and save them in
screensets. If the Link button
in the header of the Surround Panner window is enabled
(Single mode), the window shows the surround mode and current settings for the selected
channel strip.
The Surround Panner has three operation modes (mono, stereo, and surround), depending
on the channel strip input format. It provides different parameters when used in mono-tosurround and stereo-to-surround channels. When used on surround-to-surround channels,
the Surround Panner acts as a surround balancer control. See Surround Panner parameters
in Logic Pro.
The Surround Panner is also used on bed tracks when mixing in spatial audio. Object tracks
use the 3D Object Panner to position and move their signals in three-dimensional space.

Open the Surround Panner window
•

In Logic Pro, double-click the Surround Panner control of a channel strip.
The Surround Panner window provides a magnified view of the channel strip’s Surround
Panner, and contains additional parameters.
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Use the Surround Panner on mono input channel strips

If the channel strip input format is set to mono, the window acts as a mono-tosurround panner.
The graphical surround field in mono-to-surround mode controls the surround routing of
the input signal to speaker outputs. The level sliders and fields below the surround field
provide independent control of the Center and LFE channel levels. The separation controls
allow you to precisely control the separation between channels.

•

In Logic Pro, do any of the following:
•
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Drag the puck in the graphical surround field to change the diversity and angle.
•

Circular movement changes the angle.

•

The distance from the center of the surround field changes the diversity.

•

Press and hold the Command key while moving the puck to restrict changes to the
diversity value.

•

Press and hold the Command and Control keys while moving the puck to restrict
changes to the angle value.
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Use the Surround Panner on stereo input channel strips

If the channel strip input format is set to stereo, the window acts as a stereo-tosurround panner.
The graphical surround field in stereo-to-surround mode has three pan pucks: a puck for
the left (L) signal, a puck for the right (R) signal, and a third puck (a dot), which controls
both the L and R pucks as a group. It also offers a Spread field in the upper-right corner,
which controls the stereo width of the signal.

In Logic Pro, do any of the following:
•

Drag the L or R puck in the graphical surround field to move the other pucks in a
symmetrical fashion.

•

Drag the dot puck to move both the L and R pucks, while maintaining a given spread.
•

Circular movement changes the angle.

•

The distance from the center of the surround field changes the diversity.

•

Press and hold the Command key while moving the pucks to restrict changes to the
diversity value.

•

Press and hold the Command and Control keys while moving the pucks to restrict
changes to the angle value.

The circular bars around the graphical surround field indicate which speakers will carry
the respective signal source; the closer to the center a puck is moved, the wider its
corresponding bar gets (the greater its diversity, in other words).
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Use the Surround Balancer on surround input channel strips

If the channel strip input format is set to surround, the Surround Panner acts as a surround
balancer control.
Source channels are passed on to their respective output channels (speaker positions)
without any cross-panning or mixing. The pan control is represented by a single puck (a
dot), which affects the multichannel source signal as a whole.
In surround balancer mode, the Separation parameters are not available and the Diversity
parameter is replaced by Amount.

•
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Drag the puck to change the relative volume balance of the source signal.
•

Circular movement changes the angle.

•

The distance from the center of the surround field changes the amount.

•

Press and hold the Command key while moving the puck to restrict changes to the
amount value.

•

Press and hold the Command and Control keys while moving the puck to restrict
changes to the angle value.
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Surround Panner parameters in Logic Pro
In Logic Pro, the Surround Panner features a set of common parameters, regardless of the
channel strip input format.

Common Surround Panner parameters
•
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Surround Field parameters: The surround field consists of the following:
•

Four real-time display fields, for angle, diversity, elevation, and spread (stereo only).
You can directly interact with these fields by dragging the pucks.

•

A circular grid, comprising four concentric circles, divided into eight 45-degree
segments. The outer circle represents the minimum amount of diversity. The center
circle represents maximum diversity.

•

A further circle encloses the grid. This is the diversity and angle display. As you
change the diversity or angle, a portion of the display is highlighted.

•

When the separation controls are on, a square is overlaid on the grid. This indicates
the separation point between left and right channels, and also front and rear
(surround) channels. Drag the corners or edges of this separation square or use the
sliders in the lower section of the Surround Panner window to change values.

•

A number of speaker icons surround the circular grid. Blue speakers represent
surround channels and green speakers represent overhead channels. Click the
speakers to turn the respective channels on or off, thus changing the channel
surround output format.

•

Drag the pan puck to control signal routing (surround position in relation to the
speaker outputs). You can modify movement of the blue dot with these functions:
•

Press and hold Command to lock diversity.

•

Press and hold Option-Command to lock the angle.

•

Option-click the green puck to reset angle and diversity.
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•

Separation Controls parameters: When the separation controls are on, the separation
square is overlaid on the grid. Change the values of the parameters to determine the
amount of separation between channels. As you change these parameters away from
values of 1.00, the separation square changes (to a trapezoid or rectangle) in the
surround field, providing a visual representation of how changes in these values affect
the channel. The separation controls are not available when you use a surround format
with overhead channels.
•

Separation XF: Applies to the Left and Right (front) channels. Reducing Separation
from 1.00 down to 0.00 mixes the right signal into the left channel, and vice versa,
until both channels output a mono signal.

•

Separation XR: Applies to the Left and Right Surround (rear) channels. Reducing
Separation from 1.00 down to 0.00 mixes the right signal into the left channel, and
vice versa, until both channels output a mono signal.

•

Separation Y: Affects the mix relationship of the front and rear channels (in front of
or behind the listening position, in other words). It mixes the Left/Left Surround and
Right/Right Surround channels. When Separation Y is set to 0.00, the front and rear
channels output in mono.
You can edit the separation controls graphically by dragging the edges and corners
of the separation square. You can Option-click the value field for each parameter to
reset them to default values.
Note: In 7.1 ITU surround formats, the separation of Left Middle and Right Middle is
determined by the average separation value of the front and rear channels.

•

Planar or Spherical mode: When using a surround format with overhead channels, this
mode lets you take advantage of the added dimension of height and choose the virtual
shape of the panning plane.
•

Planar: Panning results are placed on a flat circular plane.

•

Spherical: Panning results are placed on the edge of a virtual sphere.

•

Center Level slider: Drag the Center Level slider or field to set the volume relationship
of the (front) center channel—typically used for dialogue in film and TV productions.

•

LFE Level slider: Drag the LFE Level slider or field to control the volume of the LFE
output. The abbreviation stands for Low Frequency Enhancement or Low Frequency
Effects, as the LFE output is most commonly sent to a subwoofer channel. The use of a
subwoofer speaker is not mandatory.
Tip: If you want only low frequency signals to reach the output, insert a multimono surround EQ into the surround master channel strip. Use this to set the LFE (or
subwoofer) output. A cutoff frequency of 120 Hz is standard for most surround apps.
For more information, see Surround master channel strip in Logic Pro.

•

Level Compensation pop-up menu: Select the surround pan law for stereo-to-surround
and mono-to-surround channels.
Note: These options appear only in projects that were mixed in surround and saved in
Logic Pro versions 8.x to 9.1.6.
•
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Unity gain at speaker: The default setting for mono-to-surround and stereo-tosurround channels. All new projects and projects imported from Logic Pro 9.1.7 or
later follow this pan law.
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A mono signal panned hard left of a stereo output with X dB gain will do the same if
panned hard left with a mono-to-surround panner. A stereo signal panned hard left
and right with X dB gain will do the same if panned hard left and right with a stereoto-surround panner.
•

Unity gain at mid-point: This was the default setting used for Logic Pro versions
9.1.4 to 9.1.6. Projects imported from these Logic Pro versions will adopt the Legacy
pan law. You can choose a different pan law from a dialog or this pop-up menu.

•

Legacy (Pre Logic 9.1.4): This was the default setting used for Logic Pro versions 8.x
to 9.1.3. Projects imported from these Logic Pro versions will adopt the Legacy pan
law. You can choose a different pan law from a dialog or this pop-up menu.

Use surround effects in Logic Pro

Logic Pro offers a number of surround effect plug-ins, and also includes surround versions
of instrument plug-ins such as the Sculpture and ES2 synthesizers, and the Sampler
instrument. Your Audio Units instruments and effects may also work in surround.
Important: The project surround format determines the surround format of plug-ins. For
more information, see Set the project surround format.

Insert a surround effect plug-in

1. In Logic Pro, set the channel strip output to Surround. See Set the channel strip output
format.
2. Click any Insert slot, then navigate to the Mono → Surround (on mono channels), Stereo
→ Surround (on stereo channels), or Surround version (on surround channels) of the
plug-in you want to use.
For example, on a stereo format channel strip, navigate to Delay > Delay Designer >
Stereo → 5.1 (ITU 775). If the project surround format is set to 7.1 (SDDS), the Plug-in
pop-up menu of a stereo channel strip is displayed as follows: Delay > Delay Designer >
Stereo → 7.1 (SDDS).
Tip: It’s possible to release the pointer on the plug-in name, instead of navigating all the
way through the hierarchy to the channel format. The plug-in opens automatically using the
default channel strip format.

Insert plug-ins that do not match the channel format
•

In Logic Pro, option-click a channel strip Insert slot.

The pop-up menu displays all available formats for the plug-in, rather than being limited
to the matching channel format. Any downmixing or upmixing that may be necessary will
happen automatically.
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•

The default format of software instruments is stereo (if available). Mono and the
project surround format are offered as additional formats.

•

The default format of effects plug-ins is the current channel strip format (at the
insert point in the signal path).

•

All plug-in format variations (based on the current channel strip input format, and
all available plug-in output formats) are offered, up to the maximum allowed by the
project surround format.
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Note: This applies only if the output of the channel strip is already routed to a
surround bus or output.
•

Logic Pro effects plug-ins can also be operated in a multi-mono configuration, based
on the project surround format.

Logic Pro automatically performs surround downmixes and upmixes whenever the format
of the input and output channels don’t match. For example, if you insert a quadraphonic
plug-in into a 5.1 bus, a downmix from 5.1 to Quad, followed by an upmix back to 5.1 occurs
automatically.

Multichannel effects
Overview of multichannel effects in Logic Pro
Effects that are not available as true surround effects can be inserted as multichannel
effects in surround channels. Logic Pro matches the surround format of a channel by
automatically providing the required number of stereo and mono instances of the plug-in.
Multichannel effect plug-ins have an advanced plug-in header.

The plug-in header can include a tab for each effect instance, an LFE tab, and a
Configuration tab . For more information, see Configure multichannel effects in
Logic Pro.
The effect tab labels indicate if effect instances are loaded in stereo or mono. Channels
joined with a hyphen (-) are loaded as a stereo instance. Channels separated with a vertical
bar (|) are mono.
•

L-R|Ls-Rs|C: Denotes left/right stereo, left/right surround stereo, mono center.

•

L-R|Rs|C (a separate left surround tab is shown): Denotes left/right stereo, mono right
surround, mono center.

•

L-R, C, and Ls-Rs shown on three separate tabs: Denotes left/right stereo, center mono,
left/right surround in stereo.

•

Couple button: When active, this applies the parameter changes you make in one tab to
the same parameters in the other tabs.

Each effect tab addresses a discrete effect unit for each channel (or channel pair). Each
tab can have different parameter settings.
Click each tab to change plug-in parameters for the L-R tab, the C tab, the Ls-Rs tab,
and the LFE tab. The parameter values of each tab are memorized when you save a plugin setting.
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Side chains and surround effects

When inserting a side chain–capable plug-in, the side chain source (selected in the plug-in
header) is routed to all surround instances.
The detection circuits of grouped plug-in instances are linked, and react as one unit. This
ensures that the spatial surround image is not skewed or deformed.
Note: This is also true when no side chain input is selected. In this case, the group’s
combined individual inputs are used to feed the linked detection circuit—effectively acting
like a side chain source.

Configure multichannel effects in Logic Pro
You can use the Configuration tab
in instances.

to determine how parameter changes affect the plug-

In Logic Pro, when a multichannel plug-in is first inserted into a surround channel, it is
automatically preconfigured to match the channel surround format, and to make the best
use of the plug-in’s capabilities. For example, a plug-in with mono and stereo capabilities is
inserted into a 5.1 bus. It is preconfigured as two stereo pairs, with the addition of a mono
center and mono LFE channel. The necessary links and tabs are created automatically.

Configuration tab parameters
•
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Link menu: Determines which effects are linked. If you link effects, parameter changes
apply to all effects in the linked group. You can choose between five groups: A, B, C, D,
and E. Channels set to none (“-”) operate independently. Each group features its own
tab. When you link channels, keep the following in mind:
•

If you link two channels as a stereo pair, the left channel is always assigned as the
master.

•

If one or more channels are added to an existing group, the new members adopt the
values of the group.

•

If you assign several channels to an unused group, the setting of the (front) left
channel is used for all group members.
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•

Bypass button: Click to bypass the channel: it is routed around the effect. This is useful
when individual channels should be exempt from processing by a particular plug-in.
Note: If the Bypass button of a grouped channel is clicked, all channels in the group are
routed around the effect.

Surround master channel strip in Logic Pro

In Logic Pro, when you set the output of at least one channel strip to surround, the existing
master channel strip in the Mixer changes to a surround master channel strip. The surround
master channel strip processes signals routed to the outputs configured in the Surround
preferences. For more information, see Set surround preferences.

You can insert surround effect plug-ins into the master channel strip.
Important: As soon as the surround master channel strip appears, the Insert slots of the
individual output channels are hidden, and any existing effects in the Insert slots (of output
channel strips) are no longer processed. The original insert configuration is memorized,
so when you remove all surround outputs, the original output channel configuration
is restored.

Logic Pro User Guide

929

Bounce surround audio files in Logic Pro

Bouncing a surround mix in Logic Pro, can create a single interleaved file, or it can create
multiple audio files—one per channel—when Split is chosen as the file type.
When multiple files are created, each file is identified by a unique extension.
Note: Use the Bounce Extensions preferences pane to define filename extensions that
will be added to the files resulting from a surround bounce. For more information, see Set
surround preferences.

Perform a surround bounce to CDDA (CD Digital Audio)
1. In Logic Pro, do one of the following:
•

Choose File > Bounce > Project or Section (or use the corresponding key command).

•

Click the Bounce button at the bottom-right corner of any output (or the surround
master) channel strip.
All outputs selected in the surround settings are bounced simultaneously, regardless
of which output channel strip Bounce button is clicked.

2. Select the Surround Bounce checkbox, below the Dithering pop-up menu in the Bounce
window.
3. Select other bounce settings, as required.
4. Click the Bounce button.
Note: You can’t use the Bounce command to create compressed surround files (AAC, MP3).
If you click a compressed format checkbox, a dialog appears, indicating that a compressed
surround (or split stereo) bounce is not possible.

Perform a surround bounce to DVD-A

Logic Pro can burn a surround mix of the current project to a DVD-A (DVD-Audio) disc.
This can be:
•

As many as 6 channels (5.1) at 24-bit depth, and 48 kHz sampling rate

•

High definition stereo at 24-bit depth, and 192 kHz sampling rate

1. Do one of the following:
•

Choose File > Bounce > Project or Section (or use the corresponding key command).

•

Click the Bounce button in the bottom-right corner of any output (or the surround
master) channel strip.
All outputs selected in the surround settings will be bounced simultaneously,
regardless of which output channel strip Bounce button is clicked.

2. Select the Burn to CD / DVD checkbox in the Destination pane.
A dialog indicates that you will need to change settings. Click Proceed.
3. Choose DVD-A from the Mode pop-up menu.
4. Choose other bounce settings, as required.
5. Click Burn.
For more information about bouncing, see Bounce a project to an audio file in Logic Pro.
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Spatial audio mixing
Overview of spatial audio in Logic Pro

In Logic Pro, you can create and export spatial audio mixes for playback on surround
systems and devices that support Dolby Atmos.
Spatial audio and other surround features are available when Enable Complete Features
is selected in Logic Pro > Preferences > Advanced.
In a typical surround mix, audio signals are routed to the discrete outputs of a multichannel
system. Surround formats that use overhead channels, such as 7.1.2 or 7.1.4, offer the
dimension of height to the mix. Although this can provide for a rich listening experience,
the quality and consistency of the surround mix can differ depending on the number and
position of speakers in the target listening environment.
When you create a spatial audio mix for Dolby Atmos, audio signals can be interpreted
as objects in 3D space. You can position and move these objects to make them sound
like they are coming from any direction around the listener. The information describing
the position and movement for each object is stored separately from the audio signal
as metadata. During playback on a system or device compatible with Dolby Atmos, this
metadata is rendered in real time, providing a reliable reproduction of the intended mix
based on the known speaker configuration.
When you are finished mixing, you can export your Dolby Atmos mix to an ADM BWF file.
ADM BWF is the required file format when you submit a Dolby Atmos mix to Apple Music
and other online music services. You can also create a new project from an ADM BWF file.
See Work with ADM BWF files in Logic Pro.

Bed tracks and object tracks

A spatial audio mix consists of bed tracks and object tracks. Bed tracks are the same as
traditional surround tracks that you route and pan with the Surround Panner to the discrete
surround outputs. As the name suggests, they provide the bed (or foundation) of your
mix. You use the 3D Object Panner to position mono or stereo object tracks in a virtual 3D
sound stage without direct speaker placement. The information describing the position
and movement for each object is sent as automation to the Dolby Atmos plug-in on the
surround master channel strip.

Dolby Atmos plug-in

The Dolby Atmos plug-in renders the audio output signals of both the bed and object
tracks, as well as the object track position and movement automation, in real time. If any
plug-ins are inserted on the surround master channel strip before the Dolby Atmos plugin, the bed tracks pass through them first. However, the object tracks are routed directly
to the Dolby Atmos plug-in, skipping any plug-ins that are inserted before it. The Dolby
Atmos plug-in is automatically inserted on the surround master channel strip when you turn
on spatial audio in your project settings. You use the Dolby Atmos plug-in to monitor your
mix in different surround formats, including binaural options specifically for mixing and
monitoring on headphones.
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Technical considerations

Creating a spatial audio mix in Logic Pro requires a large I/O buffer size, a higher sampling
rate (depending on your project), and more processing power. See Set up Logic Pro for
spatial audio mixing.

Mixing for Dolby Atmos

There are a few things to keep in mind when mixing for Dolby Atmos, particularly in regard
to audio levels, surround formats, and plug-ins on the surround master channel strip. See
Build a Dolby Atmos mix in Logic Pro.

Set up Logic Pro for spatial audio mixing

Mixing in spatial audio with Logic Pro is processor-intensive and requires a higher sample
rate and large I/O buffer size. As such, recording audio or performing live with software
instruments while mixing in spatial audio is not recommended. Instead, create a spatial
audio mix from an existing stereo or surround mix.
WARNING: If you are creating a spatial audio mix from a finished stereo or surround
mix, you may want to save a copy of your project or create a project alternative to avoid
overwriting settings and parameters in the earlier finished mix.

Project sampling rate

Spatial audio mixing supports native sample rates of 48 kHz and 96 kHz. In projects with
sample rates of 44.1 kHz or 88.2 kHz, bed and object tracks are converted in real time to
48 kHz or 96 kHz, respectively, before they are rendered by the Dolby Atmos plug-in. This
conversion may affect performance depending on the nature of your project and available
computing power. Therefore, setting the sample rate of your project to 48 kHz or 96 kHz at
the outset is recommended if you plan to mix in spatial audio.

I/O buffer size

If your project has a sample rate of 44.1 kHz or 48 kHz, you will need to set the I/O buffer
size to 512 samples. If your project has a sample rate of 88.2 kHz or 96 kHz, you will need
to set the I/O buffer size to 1024 samples. See Devices preferences in Logic Pro.

Spatial audio and surround format

When you create a spatial audio mix from an existing stereo project, Logic Pro
automatically changes the surround format to 7.1.2 when you turn on spatial audio. If you
want to use 5.1 or 7.1 as your surround format for your bed tracks, you can change it in your
project settings. See Set the project surround format.
If your project surround format is set to 7.1.2 and you use the Dolby Atmos plug-in to
monitor your mix in 5.1.4 or 7.1.4, any bed track signals routed to the top two channels of
the surround bed are balanced between the top four channels of your monitoring format.

Logic Pro User Guide

932

Output routing and project frame rate

When you turn on spatial audio in the project settings, Logic Pro makes the following
additional changes to your project:
•

Changes the outputs of all channels set to Stereo Output to Surround.

•

Creates a surround master channel strip in the Mixer with the Dolby Atmos plug-in
inserted on an Insert slot.

•

Hides the Stereo Output channel strip.
Any existing effects in the Insert slots (of output channel strips) are hidden and no
longer processed. The original insert configuration is memorized, so when you remove
all surround outputs, the original output channel configuration is restored.

•

Changes the project frame rate to 24 fps.

Set up your project for spatial audio mixing
In Logic Pro, do the following:
•
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Increase the I/O buffer: Choose Logic Pro > Preferences > Audio, click Devices, then
from the I/O Buffer Size pop-up menu, choose 512 Samples for a project sample rate of
44.1 kHz or 48kHz (or choose 1024 for a project sample rate of 88.2 kHz or 96 kHz).
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•

Turn on spatial audio: Choose File > Project Settings > Audio, click General, then
choose Dolby Atmos from the Spatial Audio pop-up menu.

3D Object Panner in Logic Pro

You use the 3D Object Panner in spatial audio mixing to position mono and stereo output
signals of object tracks in 3D space. To make the 3D Object Panner visible in the Output
slot of a channel strip, you must set up your project for spatial audio.

The output signal (post-fader) and panning automation data of the 3D Object Panner go
directly to the Dolby Atmos plug-in for spatial processing, bypassing any other plug-ins
inserted before it on the surround master channel strip.
You can use the 3D Object Panner control directly on the channel strip to control the planar
position of the object track. However, you can also control the height, size, and spread of
the object track in the 3D Object Panner window.
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The 3D Object Panner window contains two grids. Change the position of the puck in the
upper grid to move the object left, right, front, and back. Change the position of the puck
in the lower grid to move the object up, down, left, and right. Mono objects are represented
by a single pan puck. Stereo objects are represented by three pan pucks: a puck for the
left (L) signal, a puck for the right (R) signal, and a third puck (a dot) that represents the
middle of the stereo image and controls both the L and R pucks as a group. Stereo objects
also have a Spread parameter that controls the stereo width of the signal.
You can record and edit parameter changes in the 3D Object Panner as automation curves.
See Overview of automation in Logic Pro.
You can open multiple 3D Object Panner windows simultaneously and save them in
screensets. Click the Link button
to update the 3D Object Panner window so that it
reflects the surround mode and current settings of the selected channel strip.

3D Object Panner parameters

You can use 3D Object Panner parameters to control the position, size, and spread of the
object track in 3D space.
Left/Right: Indicates the left or right position of the object track in 3D space.
Back/Front: Indicates the front or back position of the object track in 3D space.
Elevation: Indicates the up or down position of the object track in 3D space.
Size: Changes how the signal of the object track is perceived in regards to its precise
location in 3D space. Increasing the value results in a more diffuse image of the actual
sound source.
Spread: Controls the width of the stereo signal in the 3D space. This parameter is available
only for stereo tracks.

Add the 3D Object Panner to a channel strip

1. In Logic Pro, make sure your project is set up for spatial audio mixing.
2. Click the Output slot of the channel strip, then choose 3D Object Panner from the list in
the shortcut menu.
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Adjust a channel strip’s 3D Object Panner control

You can make basic adjustments to the position of an object track using the 3D Object
panner control.

In Logic Pro, do any of the following:
•

Drag the center puck in the panning plane to adjust the position of the signal.

•

Option-click in the panning plane to reset the center puck to the center front position.

Open the 3D Object Panner window
•

In Logic Pro, double-click the 3D Object Panner control of a channel strip.
The 3D Object Panner window provides a magnified view of the channel strip’s 3D
Object Panner, and contains additional parameters.

Control the position, size, and width of the 3D object

In the Logic Pro 3D Object Panner window, do any of the following:
•

Drag the puck in the upper grid to move the object left, right, front, and back.

•

Drag the puck in the lower grid to move the object up, down, left, and right.

•

Drag the Size value up or down to change the perceived size of the object.

•

Drag the Spread value up or down to change the width of the stereo signal. This
parameter is available only for stereo tracks.

To reset any parameter to its default value, Option-click on the parameter.
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Dolby Atmos plug-in for Logic Pro

To create and monitor a spatial audio mix in Logic Pro, you must use the Dolby
Atmos plug-in.

When you turn on spatial audio in your project settings, Logic Pro automatically inserts this
plug-in on the surround master channel strip.

Plug-ins inserted before the Dolby Atmos plug-in affect only the bed tracks in the surround
format (up to 7.1.2) you choose for the project. Plug-ins inserted after the Dolby Atmos
plug-in affect only the audio signal in the monitoring format you choose. See Build a Dolby
Atmos mix in Logic Pro.
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3D visualization

The Dolby Atmos plug-in contains a 3D Object Viewer representing the 3D space of your
spatial mix. During playback, the positions of the object tracks are represented by small
spheres. When you move the pucks or change the coordinate values in a 3D Object Panner,
the corresponding sphere for that object track moves within the 3D Object Viewer. You can
change the perspective of the 3D Object Viewer to help visualize the positions of different
object tracks in relation to each other and the listener. You can also highlight the position
of individual object tracks, even when the project is not playing, by clicking their names in
the 3D Objects list.

Monitoring Dolby Atmos playback

You can monitor your mix in various binaural and surround formats to help determine how
it sounds on headphones and in different listening environments. If you are using Logic
Pro on a computer that supports spatial audio playback on internal speakers, you can also
monitor your spatial audio mix on the built-in speakers.
The chosen format also determines the binaural or surround format used when you bounce
your spatial audio mix to surround audio files. The resulting bounce files are intended for
playback on a system that has the same format as the chosen monitoring format. They are
not suitable for playback on Dolby Atmos systems. See Bounce surround audio files.
The monitoring format has no effect on the resulting file when you export your Dolby Atmos
mix to an ADM BWF file. See Work with ADM BWF files.
You can monitor your Dolby Atmos mix in the following formats:
Monitoring format

Description

Dolby Renderer

The standard Dolby Atmos binaural format. When you use this format, you
can edit the binaural rendering modes.

Apple Renderer

Used by Apple Music to render a binaural spatial audio mix for playback on
headphones.

Apple Renderer (Head Tracking)

Used by Apple Music to render a binaural spatial audio mix for playback
on Apple headphones that support head tracking. This format is only
available when a head tracking-capable device is selected as the output
device in Logic Pro preferences. Head tracking is turned off when
bouncing with this format.

Renderer for Built-in Speakers

This format is only available if you use Logic Pro on a computer that
supports spatial audio playback on internal speakers, and the speakers are
selected as the output device in Logic Pro preferences.

2.0

This format approximates how your Dolby Atmos mix sounds in stereo.

5.1, 7.1, 5.1.4 and 7.1.4

These are the most common standard surround formats used with Dolby
Atmos. Choose the format that matches your surround speaker setup.

Note: The monitoring formats Apple Renderer, Apple Renderer (Head Tracking), and
Renderer for Built-in Speakers require macOS Monterey 12.3 or later. In addition,
Apple Renderer (Head Tracking) also requires a Mac with Apple silicon.
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Change 3D perspective

In Logic Pro, in the Dolby Atmos plug-in, do one of the following:
•

Drag the 3D box to the desired perspective.

•

Click a position button under the 3D box.

The Custom button returns the perspective to the last position you set by dragging.

Set the monitoring format for the Dolby Atmos mix
•

In Logic Pro, in the Dolby Atmos plug-in, choose a monitoring format from the
Monitoring Format pop-up menu.

Set the binaural render mode

The Dolby Renderer monitoring format lets you assign a distance value known as a binaural
render mode to each surround bed and 3D object channel. This gives you more control
over the perceived position of each channel in the resulting binaural mix. The default
binaural render mode for each channel is Mid. The LFE channel is set to Off and cannot
be changed. Channels set to Off are still included in the binaural render without distance
modeling applied.
1. In Logic Pro, in the Dolby Atmos plug-in, choose Dolby Renderer from the Monitoring
Format pop-up menu.
2. In the Binaural Render column on the right side of the plug-in window, click the binaural
render mode for the surround bed channel or 3D object you want to change.
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3. Choose a mode (Off, Near, Mid, or Far) from the pop-up menu.

4. Click the List button

to open and close the list.

Build a Dolby Atmos mix in Logic Pro

Creating a spatial audio mix in Logic Pro is very similar to mixing in surround, but keep
in mind that getting the full benefit of the Dolby Atmos plug-in requires taking a few
additional steps.

Bed tracks and object tracks

Dolby Atmos mixes contain a mixture of bed tracks and object tracks. Bed tracks help
provide a solid foundation for your mix and usually make up the majority of the tracks.
You can create 118 mono object tracks or 59 stereo object tracks (or a mixture of both).
However, to keep the mix clear and coherent, limiting the number of object tracks to just a
few featured sounds is recommended.

Surround formats and plug-ins

When mixing in Dolby Atmos, you can use the surround formats 5.1, 7.1, or 7.1.2 for the
audio bed tracks. If your project was already mixed in 5.1 or 7.1, you can keep that format or
you can change it to 7.1.2 in the project settings. If you keep your project at 5.1 or 7.1, plugins that support those formats still work as expected. If you change your surround format
to 7.1.2, plug-ins in your project that are compatible with 7.1.2 are automatically changed
to that format. For surround plug-ins that don’t support 7.1.2, you can use multi-mono
versions. See Multichannel effects overview.
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Surround master channel plug-ins

Plug-ins inserted in surround master channel strip before the Dolby Atmos plug-in affect
only the bed tracks and are audible only in the surround format you choose for the project.
Surround plug-ins inserted after the Dolby Atmos plug-in display channel meters for
7.1.4, but they affect the audio levels only for the monitoring format you choose in the
Dolby Atmos plug-in. For example, if you choose 2.0 from the Monitoring Format pop-up
menu, a Level Meter inserted after the Dolby Atmos plug-in shows levels for the Left and
Right channels.

The loudness level of a Dolby Atmos mix must be at or below –18 LUFS (Loudness Units
relative to Full Scale) in order to play back correctly on a system or device compatible with
Dolby Atmos. This is especially important for rendering a binaural mix when the levels of
all channels are combined into just two channels. You must keep a very close eye on the
levels for each surround channel in the surround master channel. The following plug-ins
are recommended to help monitor and control these levels:
Multichannel Gain: Adjusts the signal levels of the bed tracks before they reach the Dolby
Atmos plug-in.
Limiter: Limits all surround bed channels simultaneously before they reach the Dolby
Atmos plug-in.
Level Meter: Shows all of the surround bed channels (up to 7.1.2) when inserted before
the Dolby Atmos plug-in, and up to 7.1.4 when inserted after the Dolby Atmos plug-in,
depending on the monitoring format you choose in the Dolby Atmos plug-in.
Loudness Meter: Measures the loudness of the overall mix using the LUFS standard. Insert
this after the Dolby Atmos plug-in to make sure your mix does not exceed –18 LUFS.

Logic Pro User Guide

941

The recommended order for inserting plug-ins on the Surround master channel is
Multichannel Gain, Limiter, Level Meter, Dolby Atmos, Level Meter, then Loudness Meter.

Working with VCA Groups

Creating separate VCA groups for audio bed channels and object channels is an easy way
to handle the levels of your project globally. See Use VCA groups in Logic Pro.

Work with ADM BWF files in Logic Pro

When you are finished with your Dolby Atmos mix, you can export your project or a section
of your project to a file that uses the Audio Definition Model Broadcast Wave Format (ADM
BWF). ADM BWF is the required file format when you submit a Dolby Atmos mix to Apple
Music and other online music services. ADM BWF files are also compatible with industry
tools that are used to edit and master Dolby Atmos mixes for further distribution.
ADM BWF files exported by Logic Pro contain the following:
•

A multichannel audio file containing the surround bed and the individual mono and split
stereo object tracks.

•

Metadata required for reproducing the mix on systems or devices compatible with
Dolby Atmos.

You can create a new Dolby Atmos project from an ADM BWF file. Logic Pro imports the
surround bed as a multichannel audio file, the individual mono and stereo tracks (the latter
split into separate mono object tracks), and the automation information. The new project is
automatically set up for mixing in Dolby Atmos.
You can also bounce your Dolby Atmos mix to a discrete surround audio file. The surround
format of the bounced files is determined by the monitoring format you choose in the Dolby
Atmos plug-in. See Bounce surround audio files.
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Export a Dolby Atmos mix to an ADM BWF file
•

In Logic Pro, go to File > Export, then choose one of the following options from the
menu:
•

Export your project: Project as ADM BWF

•

Export selection: Selection as ADM BWF
When you choose Selection as ADM BWF, Logic Pro exports the part of the project
enclosed by the cycle area. You can also create a marquee selection and export just
that part of the project.

Create a new project from an ADM BWF file
•

In Logic Pro, choose File > Import > Create Project from ADM BWF.

Additional surround information
Overview of surround formats in Logic Pro

Logic Pro supports eight surround formats: quadraphonic, LCRS, 5.1 (ITU 775), 5.1.2, 6.1
(ES/EX), 7.1, 7.1 SDDS, 7.1.2, and 7.1.4.
The type and number of channels for each surround format is indicated by the numbers
in its name. The first number indicates the number of main channels. The second number
indicates the number of LFE channels (often, a subwoofer). The third number indicates the
number of top channels (usually overhead speakers).
For example, a 5.1 surround system has five main speakers and one subwoofer. Similarly, a
7.1.4 system has seven main speakers, one subwoofer, and four overhead speakers.

Quadraphonic surround format

The quadraphonic surround format consists of four full-bandwidth channels, arranged as
front left and right and rear left and right (left surround and right surround). It is an old
format used for music delivery. Mike Oldfield’s “Tubular Bells” is probably the most popular
release in this format.
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LCRS surround format

LCRS stands for left, center, right, and surround channel. This is the original Dolby Pro
Logic format. The surround channel (placed directly behind the listener) is a bandwidthlimited (the treble content is reduced) monophonic channel.

5.1 (ITU 775) surround format

5.1 (ITU 775) is used for a few surround standards. This is the most common of the
surround formats, and is the one you are most likely to use. The 5.1 channels are left,
center, right, left surround (left rear), right surround (right rear), and LFE.
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5.1.2 surround format

The 5.1.2 surround format starts with the same speaker configuration as 5.1 but adds two
overhead side channels (left top mid and right top mid), placed left and right above the
listening position. The 5.1.2 channels are left, center, right, left surround (left rear), right
surround (right rear), left top mid, right top mid, and LFE.

5.1.4 surround format

The 5.1.4 surround format starts with the same speaker configuration as 5.1 but adds four
overhead channels (left top, right top, left top surround, and right top surround), placed
left and right, both in the front and rear above the listening position. The 5.1.4 channels are
left, center, right, left surround (left rear), right surround (right rear), left top, right top, left
top surround, right top surround, and LFE.
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6.1 (ES/EX) surround format

The 6.1 (ES/EX) surround format is used for Dolby Digital EX or DTS ES. The 6.1 channels
are left, center, right, left surround, surround (rear center), right surround, and LFE.

7.1 surround format

The 7.1 format is designed for use in a cinema. The 7.1 channels are left, center, right, left
mid, right mid, left surround (left rear), right surround (right rear), and LFE.
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7.1 SDDS surround format

The 7.1 Sony Dynamic Digital Sound (SDDS) surround format starts with the same speaker
configuration as 5.1 but adds two speakers (left center and right center). This is designed
for use in a cinema equipped with Sony decoding and playback hardware. The 7.1 channels
are left, center, right, left center, right center, left surround (left rear), right surround (right
rear), and LFE.

7.1.2 surround format

The 7.1.2 surround format starts with the same configuration as 7.1, but adds two overhead
channels (left top mid and right top mid), placed left and right above the listening position.
The 7.1.2 channels are left, center, right, left mid, right mid, left surround (left rear), right
surround (right rear), left top mid, right top mid, and LFE.
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7.1.4 surround format

The 7.1.4 surround format starts with the same configuration as 7.1, but adds four overhead
channels (left top, right top, left top surround, and right top surround), placed left and
right, both in the front and rear above the listening position.The 7.1.4 channels are left,
center, right, left mid, right mid, left surround (left rear), right surround (right rear), left
top, right top, left top surround, right top surround, and LFE.

Surround format channel distribution in Logic Pro

The following table provides details on the channels used by each of the supported
surround formats in Logic Pro.
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Surround format

Channels used

Quadraphonic

L - R - Ls - Rs

LCRS (Pro Logic)

L-C-R-S

5.1 (ITU 775)

L - C - R - Ls - Rs - LFE

5.1.2

L - C - R - Ls - Rs - Ltm - Rtm - LFE

5.1.4

L - C - R - Ls - Rs - Lt - Rt - Lts - Rts - LFE

6.1 (ES/EX)

L - C - R - Ls - S - Rs - LFE

7.1

L - C - R - Lm - Rm - Ls - Rs - LFE

7.1 (SDDS)

L - Lc - C - Rc - R - Ls - Rs - LFE

7.1.2

L - C - R - Lm - Rm - Ls - Rs - Ltm - Rtm - LFE

7.1.4

L - C - R - Lm - Rm - Ls - Rs - Lt - Rt - Lts - Rts - LFE
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Table key
•

C = Center

•

L = (Front) Left

•

Lc = Left Center

•

LFE = Low Frequency Effects

•

Lm = Left Mid

•

Ls = Left Surround (Rear Left)

•

Lt = Left Top

•

Ltm = Left Top Mid

•

Lts = Left Top Surround

•

R = (Front) Right

•

Rc = Right Center

•

Rm = Right Mid

•

Rs = Right Surround (Rear Right)

•

Rt = Right Top

•

Rtm = Right Top Mid

•

Rts = Right Top Surround

•

S = Surround (Rear Center)

Encode surround bounce files made in Logic Pro

Surround mixes bounced in Logic Pro are not encoded. Surround bounce files can be
encoded in the Compressor app, available in the Mac App Store, or with dedicated
hardware devices and other software.
Common surround encoded formats include:
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•

Dolby Digital: Dolby Digital (also known as AC3) includes the LFE channel. It is a
compressed format, commonly used for DVDs and digital terrestrial or satellite TV
broadcasts. It is also widely used for computer game soundtracks.

•

Dolby Digital True HD: An uncompressed (or minimally compressed) high bit-rate
format, commonly used for Blu-ray discs and high definition digital terrestrial or satellite
TV broadcasts.

•

SACD: Super Audio Compact Disc: The Sony-Philips version of DVD-A. SACD audio
is stored in a format called Direct Stream Digital, which has a sampling rate of
2.8224 MHz. SACD discs must contain a stereo mix, but usually also offer a 5.1 mix
(although this is optional).

•

Pro Logic II: Pro Logic II uses two full-range rear channels, unlike the original Pro Logic
(LCRS) format. It does not, however, use the LFE channel. In other words, this is a
5.0 format, so simply disable the LFE channel if you want to deliver a Pro Logic II
soundtrack.
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•

DTS (Digital Theater Systems): Soundtracks generally sound better than Dolby Digital
EX equivalents because they use a 3:1 compression ratio, whereas Dolby uses a 12:1
ratio. Less compression means more storage space is required on the delivery medium.

•

DTS HD Master Audio: An uncompressed (or minimally compressed) high bit-rate
format, commonly used for Blu-ray discs and high definition digital terrestrial or satellite
TV broadcasts.

Speaker placement, timing, and levels
Set up surround speakers for use in Logic Pro
The physical positioning of speakers is key to creating mixes in Logic Pro that translate
well to other surround playback systems. Because the 5.1 format is the most widely used,
this section covers 5.1 speaker placement. Much of this information can be applied to the
other formats.

Front speakers

The International Telecommunications Union (ITU) 5.1 surround definition states that front
speakers should be arranged left, center, and right, with the angle between the left or right
and center speakers being 30 degrees. A narrower angle of 22.5 degrees is suggested for
use in cinematic systems where the left and right speakers should be within four degrees
of the edge of the screen.
In the studio, you should use the wider 30-degree angle, even if scoring for film. Use of
this angle allows stereo signals to be auditioned correctly using the left and right speakers,
without moving them each time you switch between stereo and surround mixes.
The three front speakers—left, center, and right—should be placed in an arc (not a straight
line) at an equal distance from your listening position. The center speaker should be set
back slightly from an imaginary line drawn between the left and right speakers. If this isn’t
practical, don’t place the center speaker closer to the listening position than the left and
right speakers. All three speakers should be at the same height—at ear level.
If possible, your listening environment should also include a position where the left
and right speakers are at an angle of 45 to 60 degrees from the ideal central “viewing”
position. An angle close to 45 degrees is preferred if watching movies, as it approximates
the way film soundtracks are mixed and monitored. A wider angle, with the left and right
speakers farther apart, is recommended if your system is principally used for listening to
music, rather than watching movies.
It’s not essential to have a full surround setup in the studio. If you have a home
theater system, make your surround mix in the studio, then listen to or watch it in your
theater room.
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Surround speakers

The rear speakers (surround channels) should ideally be placed at the same distance from
your listening position as the front speakers, at an angle of 110 degrees from the front
center speaker. This angle is a compromise between producing an all-encompassing sound
stage (at 90 degrees) and the best rear-quadrant imaging (at 135 degrees).
The surround speakers should be placed alongside and slightly to the rear of (but
not directly behind) the listening position, well above ear level, to help minimize
localization effects. They should be aimed across the listening area, not directly at the
listening position.
This positioning creates a broad surround sound field throughout the listening area,
approximating cinema speaker systems. If the speakers are placed too far forward,
the rearward effect will be insufficient. If the speakers are too far back, the surround
information won’t be integrated with the overall sound field. Experiment with placement
and angles until the surround sound field seems to encompass you, rather than come from
behind you.
If your studio doesn’t have walls in the perfect place to mount surround speakers, try
placing them on stands above ear level. If you need to wall-mount the speakers, place them
well above ear level, and try aiming them at each other, toward the front, or to reflect off
the side walls.

Overhead speakers

Overhead speakers (also called top or height speakers) are most commonly used in
immersive audio systems to enable the overhead panning of sound objects and special
effects. The number of overhead speaker channels is identified by the third digit in the
format description. For example, in a 7.1.4 surround system, four channels are designated
for overhead speakers.
You can use various configurations for these channels. For example, in a Dolby Atmos
home theater system, upward-facing speakers, often incorporated into the front and rear
surround speakers, are commonly used for the overhead speaker channels. The sound then
reflects off the ceiling before it reaches the listener.
Discrete speakers are usually mounted on the ceiling, pointing downward. In systems
with two overhead channels, the speakers are usually placed to the left and right of the
listener. In systems with four overhead speakers, two are placed in the front above the
left and right speakers, and two are placed in the rear above the left and right surround
speakers. Speakers with a wide angle of dispersion provide the most coverage of the
listening position.

LFE speaker

The LFE is a discrete effect channel for low frequencies (such as explosions, or
avalanches) in film and TV soundtracks. In surround music mixes, LFE is used as a low
frequency channel for certain instruments (bass drum or electric basses) placed on the
center with a frequency divider that sends lower frequencies to the LFE speaker.
Bass frequencies travel much slower than higher frequencies, and are less directional.
Ideally, you should place the LFE speaker (often, a subwoofer) in a central position in front
of the listening position.
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Set surround speaker timing and levels in Logic Pro
Most people with undamaged hearing can identify where a sound is coming from: to the
left, right, in front, or behind them. Certain sounds, however, are very difficult to “position”
in relation to the listening position. For example:
•

A gunshot or car backfiring is hard to place because the sound is both loud and
quick. You may initially be able to tell that it came from your left or right but not
where, specifically, to the left or right it came from. This is because early reflections
(reverberations) rapidly build up and diffuse, making them hard to discern, directionally,
from the initial sound peak.

•

Aircraft jet engines are a low rumble that is hard to place until the plane flies directly
overhead. When it does, the volume of the sound, and the higher frequencies of the jet
engines, enable you to hear it moving from left to right or front to back.

Some sounds are easier to place:
•

Trucks, cars, and motorbikes generate a constant combination of low- and highfrequency sound, allowing you to track their movement.

•

Individual human voices are sounds that people are most familiar with, and contain a lot
of high-frequency content.

In a surround playback system, you need to set different levels and different delay times
for each speaker. This allows you to compensate for latency perceived at the listening
position, which affects your ability to correctly “place” where sounds are coming from.
Level—in particular—can alter your perception of how close a sound is, so you should
ideally set the same level for the front left and right speakers. These speakers are usually
used for incidental music/effects tracks and the main score of a film, and also often carry
an amount of the dialogue track.
The center speaker is typically used for dialogue and incidental music/effects tracks. Its
level should be similar to the left and right speakers, but can be increased to enhance the
intelligibility of dialogue.
You should aim to have the sound from all front speakers arriving at the listening position
at the same time.
You should set the levels of surround speakers and the subwoofer (LFE) to be immersive,
and part of the surround stage, rather than “additions” to the front speakers. In general,
surround speakers (and the subwoofer) are used for surround effects, main score, and
incidental music/effects tracks.
Also critical for the surround and subwoofer channels is the delay time. Assuming that the
levels of all speakers are suitable, the timing of the surround (and LFE) speakers may seem
slightly “out” in comparison to the front speakers. Most surround amplifiers allow you to
negatively or positively adjust the delay of these speakers.
The surround encoding process—performed in Compressor, available in the Mac App
Store—writes “surround encode flags” for the surround speakers, depending on the
chosen format. These flags are understood by surround decoders (AV receivers, decoding
software, or surround amplifiers).
There is no need to set slight delays between tracks. The surround encode flags are
designed to handle this.
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Video and synchronization

Logic Pro video and synchronization overview

Logic Pro provides features that let you create or edit the soundtrack of any video or film
project. See Add a movie to your Logic Pro project and Work with absolute time code in
Logic Pro.
Logic Pro supports most synchronization protocols, allowing you to work with synchronized
external video or film editing and playback hardware, or with video files stored on a locally
attached or networked hard drive. Logic Pro can transmit or receive synchronization data.
It works best transmitting to other devices or applications in your setup. See Logic Pro
Synchronization overview and External synchronization in Logic Pro.
Project movie preferences are available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.

Use movies in Logic Pro
Add a movie to your Logic Pro project

You can view a QuickTime movie file synchronously with your project, making film and
TV scoring quick and easy. Although you can’t record or edit video directly in Logic Pro,
you can replace the soundtrack of a video file with music, Foley, and dialogue arranged in
your project.
You can open a QuickTime movie in a separate Movie window and display single frames of
the movie in the global Movie track.
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When a movie is opened in a project, the upper part of the inspector shows a closed Movie
area, which can be opened by clicking the disclosure arrow.

Movie playback follows the playhead position, and vice versa, in the Movie inspector area
and in the Movie window. Audio playback for the movie is only audible if either the Movie
inspector area or Movie window is open.
Note: You will need a fast processor to ensure smooth movie playback. If you want to
record and edit your own QuickTime movie from a video recorder or digital camera, you
may need specialized hardware.

Open a movie in a project

In Logic Pro, do one of the following:
•

Choose File > Movie > Open Movie (or use the corresponding key command, default
assignment: Option-Command-O).

•

Click the Movie pop-up menu in the global Movie track header, then choose Open Movie.

•

Click any position on the Movie track with the Pencil tool.

•

Click the Media button in the control bar, then click the Movies button and choose the
movie file.

The movie opens in the floating Movie window, in its correct aspect ratio.
Note: Only one QuickTime movie can be opened in a project. If you use the Open Movie
command in a project that already contains a movie, a Movie window reopens with the
same video clip. This is particularly useful if you want to open the video clip in a different
screenset. If you choose the command while the Movie window is open, a dialog appears,
allowing you to choose a new movie file.

Remove a movie from a project

In Logic Pro, do one of the following:
•

Choose File > Movie > Remove Movie (or use the corresponding key command).

•

Open the Movie pop-up menu in the global Movie track header, then choose Remove
Movie.

All references to the movie are deleted from the project.
Logic Pro User Guide

954

Use the Movie window in Logic Pro

You can drag the slider at the bottom of the Movie window to navigate to any position in a
video file. The Logic Pro playhead will then “chase” to the corresponding project position.

Resize the Movie window

In Logic Pro, do one of the following:
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•

Drag its lower-right corner.

•

Control-click the movie, then choose one of the following image formats from the
shortcut menu.

•

0.25 Size: Reduces the movie to a quarter of its original size.

•

0.5 Size: Reduces the movie to half its original size.

•

Original Size: Displays the movie at its original size.

•

2x Size: Expands the movie to twice its original size.
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•

3x Size: Expands the movie to three times its original size.

•

Enter Full Screen: Expands the Movie window to fill the full screen.

•

Keep Aspect Ratio: If selected, the proportions of the image are retained when the
Movie window is resized.

•

Center: Places the video image in the center of your screen.

Use the Movie track in Logic Pro

The global Movie track in Logic Pro displays the opened QuickTime movie as thumbnails. If
the Movie track is not visible, see Show and hide global tracks in Logic Pro.

The number of frames displayed on the Movie track depends on both the track height
and the zoom level of the window. All frames are aligned left, with only the very last frame
aligned to the right. This guarantees that you can always see at least the first and last
frames of video, independent of the current zoom level. Given the left alignment of all
frames (except the last), the left margin of a frame is always displayed at the exact position
of that particular frame.
Movie track and region settings can be adjusted in the Movie preferences window. See
Movie preferences in Logic Pro.
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Use movie scene markers in Logic Pro

Scene markers are SMPTE-locked markers: they remain at the same absolute time position,
regardless of tempo changes, and are automatically deleted if the current movie is
removed from the project. Scene markers are identified by a filmstrip icon.

You can use the Create Movie Scene Markers function to search the movie for significant
content changes (scene cuts), and automatically generate scene markers for each of them.
The Create Movie Scene Markers function uses a fixed threshold value, which works well
for most types of movies: cartoons, real life, CGI, and so on.

Search a movie for scene cuts
•

In Logic Pro, choose a movie range from the Navigate > Other > Create Movie Scene
Markers submenu.

Search a movie for scene cuts using the Auto Range setting

The Auto Range setting in Logic Pro follows the decision path outlined below, when
determining which part of the movie will be evaluated:
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•

Marquee selection

•

Cycled project part

•

Selected regions

•

All—if none of the above criteria is met

•

Do one of the following:
•

Open the Movie pop-up menu in the global Movie track header, then choose Create
Marker Set from Scene Cuts.

•

Use the Create Scene Markers (Auto Range) key command.
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Remove individual scene markers
•

In Logic Pro, do one of the following:
•

Choose an option from the Navigate > Other > Remove Movie Scene Markers submenu.

•

Use the Remove Scene Markers (Auto Range) key command.

•

Open the Marker List, select the scene marker, then choose Edit > Cut or Edit >
Delete from the Marker List Edit menu (or use the corresponding key commands).

Remove all scene markers or marker sets
•

In Logic Pro, do one of the following:
•

Choose Remove All Scene Markers from the Navigate > Other > Remove Movie Scene
Markers submenu.
Note: This command does not remove the marker set; only the markers in the set.

•

Open the Marker pop-up menu in the global Marker track header, then choose
Marker Sets > Delete Set.

•

Open the Marker List, then choose Marker Sets > Delete Set in the Marker Set popup menu.

Convert a scene marker to a normal marker
•

In Logic Pro, open the Marker List, select the scene marker, then choose Options >
Convert to Standard Marker.

Convert a normal marker to a scene marker
•

In Logic Pro, select the marker in the Marker List, then choose Options > Convert to
Scene Marker.

Use movie audio tracks in Logic Pro

Once a movie has been opened in a project, you can use the Import Audio from Movie
or Export Audio to Movie command, found in the File menu. After the audio has been
imported, you can edit the video dialogue, record Foley, and add music with Logic Pro
audio processing and editing features.
You can export audio from your project to the movie file itself, effectively overwriting the
original movie soundtrack. You can also export the project audio between the left and right
locators to a shortened version of the movie. This is useful for sending a preliminary mix
of your soundtrack or demos of small cues and parts to other members of the production
team, for example.
You can adjust the audio level and output device in the Video project settings. See Movie
settings in Logic Pro.

Import audio from a QuickTime movie into your project

1. In Logic Pro, select the audio track or tracks you want to use.
2. Do one of the following:
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•

Choose File > Movie > Import Audio from Movie (or use the corresponding key
command).

•

Control-click anywhere in the Movie track, then choose Import Audio from Movie
from the shortcut menu.
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3. Click the required checkboxes in the dialog, then click OK.
The selected audio tracks are bounced to one or more audio files, and placed in the
Project Audio Browser. A new audio track is created for each movie audio track (when
“On separate tracks” is chosen in the dialog), and the imported audio from the movie is
added to the track (or tracks). The embedded audio is automatically muted and audio
playback occurs from the Tracks area. The movie name is retained and used for the
resulting audio file (or files).

Export audio to a QuickTime movie

If Cycle is turned on,Logic Pro exports only the project audio and section of movie between
the left and right locators. Otherwise, the exported movie contains the project audio that is
encompassed by the start and end points of the movie.
1. In Logic Pro, do either of the following:
•

Choose File > Movie > Export Audio to Movie (or use the corresponding key
command).

•

Control-click anywhere in the Movie track, then choose Export Audio to Movie from
the shortcut menu.

2. Type a name in the Save As field, then choose the location where you want to save the
movie.
3. Choose the audio format, sample rate, and bit depth from the respective pop-up menus,
then click Save.
4. Select the checkbox in the Enable column for each audio track of the original movie you
want to include in the new movie, then click OK.
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Create and edit soundtracks
Logic Pro soundtracks overview
Creating a new video soundtrack is similar to working with any Logic Pro project. You
can import or record audio and instrument parts, arrange them, process them with
effects, and mix your music, dialogue, and sound effects (known as Foley) in stereo or a
surround format.
You can also import an existing movie soundtrack, edit or enhance it in Logic Pro, and then
export your audio back to the movie file. See Use movie audio tracks.
The key difference when working with video or film is the need for synchronicity between
what is seen and what is heard. Logic Pro supports several synchronization protocols that
let you work with video at all standard frame rates. See Logic Pro Synchronization overview.
You can use video files stored on a locally attached or networked hard drive, or work with
synchronized external video or film editing and playback hardware.
Working with disk-based video is preferable because you can see the video in Logic Pro
and don’t have to wait for hardware to “catch up” when moving from one scene to another.
The imported video and Logic Pro are “frame-locked” when you move through your project
or video with either the Logic Pro or QuickTime transport and navigation controls. See Add
a movie to your project.
QuickTime video is embedded with an internal SMPTE (Society of Motion Picture and
Television Engineers) timecode. SMPTE timecode is an absolute timecode that covers a
24-hour period. It displays hours, minutes, seconds, frames, and subframes. Logic Pro
recognizes SMPTE timecode and converts it to MTC (MIDI Time Code). MTC is the MIDI
equivalent of SMPTE timecode. Different video frame rates are automatically interpreted by
Logic Pro. See MTC interpretation in Logic Pro.

Work with absolute time code in Logic Pro
The production process for video, film, or TV commercials is different from music
production. Synchronization is always used, unlike in music production, where it is not
always required. You need to work in absolute time: hours, minutes, seconds, and frames,
rather than in bars and beats. Edits to the video, including changes to scene length,
additional cuts, the use of slow or fast motion, and dialogue changes (or “redos”) are
among the many situations that you will encounter when creating or editing a soundtrack.
The Event List in Logic Pro is ideal for precise placement of timing-critical events such as
footsteps or dialogue in a video soundtrack. It also allows you to change event lengths,
which is useful if frames are removed during the video editing phase of production. In
linear editing windows, the ruler can display absolute (SMPTE) time or bars and beats
(or both).
When working with synchronized video, you will want music, sound effects, and dialogue to
play at a specific time, rather than at a particular bar position.
If the tempo of your soundtrack needs to be altered at a later stage, the absolute time
location of events that have already been positioned will change. The Lock SMPTE Position
function prevents this from happening. You can SMPTE-lock individual events in the Event
List or entire regions. All events inside locked regions are SMPTE-locked.
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The Lock (and Unlock) SMPTE Position function is available when Enable Complete
Features is selected in Logic Pro > Preferences > Advanced.
You can use the Move Region/Event to Playhead Position (Pickup Clock) key command
to move a selected event, such as a note, a tempo event, or a region, to the current
playhead position.
If you want a particular bar in the project to coincide with a specific time position, you can
change the tempo of the preceding passage.

Change the Event List display to time units
•

In the Event List in Logic Pro, choose View > Show Event Position and Length as Time.
All event positions and lengths are displayed as absolute (SMPTE) times, rather than
bar/beat values.

Lock a region or event to its current time position
1. In Logic Pro, select the region or event.
2. Do one of the following:
•

In the Main window, Event List, Step Editor, or Piano Roll Editor, choose Functions >
Lock SMPTE Position.

•

Use the Lock SMPTE Position key command.
Regions or events locked to a (SMPTE) time position display a small padlock icon in
front of their name.

Note: Copies of locked regions or events do not preserve their locked status, whether
copied or pasted via the Clipboard, or by Option-dragging.

Unlock the time position of a locked region or event
1. In Logic Pro, select the region or event.
2. Do one of the following:
•

In the Main window, Event List, Step Editor, or Piano Roll Editor, choose Functions >
Unlock SMPTE Position.

•

Use the Unlock SMPTE Position key command.

All selected regions or events that were locked to a (SMPTE) time position are now fixed
to their current bar position. This means that tempo changes will affect their position. The
padlock icon in front of the name disappears.

Move a region or event to a frame

1. In Logic Pro, move the playhead to the desired time position, such as a specific movie
frame in the Movie track, for example.
Note: In addition to the usual position commands, you can use the Rewind One Frame
and Forward One Frame key commands to move one frame backward or forward.
2. Select the region or event that you want to place at this time position.
3. Use the Move Region/Event to Playhead Position (Pickup Clock) key command to align
the start point of the region or event with this time position.
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Alternatively, you can use the Move Region/Event to Playhead Position and Select Next
Region/Event (Pickup Clock+) key command to move the region or event, then select
the next region or event.
Note: When using the Move Region/Event to Playhead Position (Pickup Clock) key
command with audio regions, it is the region anchor—not the region start point—that is
moved to the playhead position.

Position a bar to a specific time

1. In Logic Pro, open the Tempo List. See Logic Pro Tempo List overview.
2. Create a tempo event at the target bar position.
3. Set a time position for this tempo event in the (SMPTE) Position column.
The preceding tempo event is automatically adjusted, to generate the correct bar and
time position for the inserted tempo event.
4. If you want to keep the same tempo for the following passage, delete the tempo event
you inserted.

Logic Pro synchronization
Logic Pro Synchronization overview

Logic Pro supports most synchronization protocols, allowing you to synchronize it with
external hardware and software. Logic Pro can transmit synchronization data to other
devices or receive synchronization data from another device.
Synchronization functions are available when Enable Complete Features is selected in
Logic Pro > Preferences > Advanced.
In all synchronization situations, regardless of the simplicity or complexity of your studio
configuration, the following rules apply:
•

There can only be one transmitter device.

•

The transmitter device sends timecode information (synchronization signals) to one or
more receiver devices.

Important: In most cases, you will need to manually set each synchronization-capable
device—including Logic Pro itself—to transmit or receive synchronization. If you don’t
do this, there will be multiple transmitter devices in your system, which will result in
synchronization errors.

Supported synchronization protocols
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•

MIDI Time Code (MTC): Translates a SMPTE timecode signal into a MIDI standard
timecode signal. See MTC interpretation.

•

MIDI Clock: Short MIDI message for clock signals. Used to provide a timing pulse
between MIDI devices.
•

Logic Pro can send MIDI Clock signals to synchronize external devices.

•

Logic Pro can not receive MIDI Clock synchronization signals.
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•

SMPTE timecode: An audio signal that is translated into MTC by some MIDI interfaces,
such as the Unitor8.

•

Word Clock: A signal that is carried by all digital audio interface formats: ADAT, FireWire
Audio, S/P-DIF, AES/EBU, T-DIF, and others. Used to maintain the timing integrity of
sample words in audio signals that are transmitted digitally between Logic Pro and
external hardware or software. See Audio Synchronization settings.

Tip: Logic Pro also supports manual or “human” sync, when receiving synchronization.
This is not a synchronization protocol per se, but enables Logic Pro to follow tempo
changes in real time. As an example, it could chase a live drummer. See Use the Logic Pro
Tempo Interpreter.

External synchronization in Logic Pro

When you first open Logic Pro, it is in Internal Sync (transmitter) mode. The control bar
Sync button, if visible, is not activated.
When Logic Pro is receiving synchronization, the control bar Sync button is activated.
You can use the Sync button to turn external synchronization on or off at any time,
without changing the selected synchronization source. This allows you to temporarily stop
Logic Pro from receiving synchronization from an external device. This could prove useful,
for example, if you need to quickly edit a MIDI region while the external synchronization
source—tape machine, VTR, and so on—is still running.
You can use the Sync button shortcut menu to choose a synchronization source.
Note: The control bar Sync button is not displayed by default.

View the control bar Sync button

1. In Logic Pro, Control-click the control bar, then choose Customize Control Bar from the
shortcut menu.
2. Select the Sync checkbox toward the bottom of the Modes and Functions column, then
click OK.

Synchronize Logic Pro
•

In Logic Pro, click the control bar Sync button to synchronize Logic Pro to the chosen
synchronization source.

Open synchronization settings with the Sync button shortcut menu
•

In Logic Pro, Control-click the control bar Sync button to open a shortcut menu, then do
one of the following:
•
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Set the type of external synchronization (a synchronization source). Choose from:
•

Internal Sync

•

SMPTE Sync (MTC)

•

Manual Sync (Tempo Interpreter)

•

Auto Sync In
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•

Determine if MMC commands should or should not be transmitted when using the
Logic Pro control bar buttons. MMC commands are used for remote control of MIDIcontrolled tape machines. See MIDI Machine Control in Logic Pro.

•

Open the Synchronization settings. See General Synchronization settings in Logic Pro.

•

Open the tempo editors. See Logic Pro tempo overview.

View the frame rate of incoming MIDI timecode
•

In Logic Pro, click the upper (MIDI In) section of the MIDI Activity display while receiving
an external synchronization signal.

MTC interpretation in Logic Pro

The MIDI standard supports four of the seven commonly used timecode formats: the 30 fps
and 29.97 fps (frames per second) formats are not differentiated in the MIDI specification.
Logic Pro needs to determine the intended format of incoming MTC (MIDI Time Code) and
interprets it as follows:
•

23.976 fps is interpreted as 24 fps.

•

24 fps is interpreted as 24 fps.

•

25 fps is interpreted as 25 fps.

•

29.97 fps is interpreted as 29.97 fps.

•

29.97 fps drop frame is interpreted as 29.97 drop fps.

•

30 fps drop frame is interpreted as 29.97 drop fps.

•

30 fps is interpreted as 29.97 fps.

Note: MIDI Time Code (MTC) is the MIDI equivalent of the audio-based SMPTE (Society of
Motion Picture and Television Engineers) timecode format.

Manually set a frame rate
•
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In Logic Pro, choose a frame rate in the File > Project Settings > Synchronization >
General > Frame Rate pop-up menu. This setting overrides the automatic detection and
interpretation of frame rates.
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MIDI Machine Control in Logic Pro

MMC (MIDI Machine Control) is a set of MIDI commands that Logic Pro uses to control the
transport functions of any MMC-capable tape machine. The recording process can also be
controlled and automated from Logic Pro via MMC.
The tape machine provides a SMPTE signal that Logic Pro uses as a synchronization
source—with Logic Pro as the receiver.
You control connected devices from Logic Pro by using the control bar and navigation
functions, including direct positioning and cycle jumps. Dragging the playhead sends a
continuous stream of MMC Locate commands until you release the mouse button.
MMC and other synchronization functions are available when Enable Complete Features
is selected in Logic Pro > Preferences > Advanced.
Important: Logic Pro needs to wait for the connected device to finish rewinding or
forwarding.

Turn on MMC

In Logic Pro, do one of the following:
•

Control-click the control bar Sync button, then choose the MIDI Machine Control (MMC)
setting in the shortcut menu.

•

Choose File > Project Settings > Synchronization, then select the Transmit MMC
checkbox in the MIDI pane.

Set up a MMC tape machine for recording in Logic Pro

Logic Pro supports up to 64 MMC tracks, allowing devices such as the ADAT to be
operated with MIDI Machine Control.
Each track can act as a tape control track.
1. Create an instrument track.
2. Control-click the instrument icon in the Track inspector, hold down the Option key, then
select the MMC icon from the Others category.
The MMC icon is the only icon that actually affects the way a track behaves. All other
icons are purely graphical in nature.

You only need to create one instrument with the MMC icon. This instrument can be
assigned to as many tracks as required for control of (each track on) your external
recorder.
Tip: It is recommended that you group tape control tracks in a folder. Tape control
tracks must be placed at the top of the track list. If you pack tape control tracks into a
folder, this folder must be the top track in the list.
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Switch the record-enabled state of one or more MMC tape tracks

When a tape track is selected, the corresponding track on the tape machine switches to a
record-enabled state, and deactivates the record-enabled state of all other tracks. You can
also do any of the following:
•

Shift-click multiple tracks to select and record-enable several tracks on the tape
machine.

•

Control-Shift-click any track to individually toggle the record-enabled state for each
track of the tape machine: selected tracks are switched on, and unselected tracks are
switched off.

•

Control-click a track to switch all other tracks out of record-enabled mode.

•

Use of the Record Toggle key command switches the record-enabled state of the
selected track (or tracks).

Make a MMC recording with Logic Pro

1. Select a tape track to switch the corresponding track on the tape machine to a recordenabled state. Hold Shift while clicking multiple tracks to select and record-enable
several tape machine tracks.
2. If you like, you can set locators, and use the Autopunch function, to control MMC
devices. The tape machine enters record mode at the Punch In locator position, and
stops recording at the Punch Out locator position. This step is optional.
3. Click the Record button to send the record strobe command to the tape machine. The
following happens:
•

Logic Pro enters MIDI record mode, and sends an MMC Play command to the tape
machine.

•

The tape machine sends timecode. Logic Pro will start recording only when it
receives timecode from the MMC device.

4. Click the Stop button to end the recording on the tape machine. Use the Stop command
twice to rewind to the project start point. The following happens:
•

Logic Pro automatically creates an empty MIDI region on the tape track. This
indicates a recording take on the tape machine, and applies to all MMC recordings,
including Autopunch recordings. If you record-enable several tape tracks (by Shiftclicking), the corresponding number of empty regions is created. If a MIDI region
with an identical start point already exists on a tape track, no new MIDI region is
created on that track. This avoids overlapping regions.
Tip: You should finish all MMC-controlled recordings with the Stop button
or Space bar. Some tape machines react differently to a series of MMC Record
commands, which can result in Logic Pro showing a track as recording, when the
tape is actually playing back (or the opposite situation).

You can also use the Environment MMC Record to record-enable tracks on your tape
machine with Logic Pro. See MMC record buttons in the Logic Pro Environment.
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Synchronization problems and solutions in Logic Pro

Due to the number of synchronization types available, and different implementations
by various manufacturers, you may experience timing issues when using Logic Pro
synchronously with other devices or apps. This table describes common synchronization
problems and solutions.
Problem

Solution

Digital synchronization error

If Logic Pro is synchronized to external word clock (Audio Sync
Mode: External or Free), make sure that a valid digital signal is always
available.

If you see a “Sample Rate xxx kHz recognized” error message, the clock
source device (DAT machine, for example) connected to your audio
hardware’s digital input may not transmit Word Clock in stop or pause
mode (or has switched itself off).
Poor or no synchronization to an
external tape machine

Create a new project, then make a new recording in Logic Pro of the audio
on tape.
If an old recording on tape was not properly synchronized to timecode,
you won’t be able to use it. When trying to synchronize to tape, there is
one key rule: the playback situation must be identical to the recording
situation.

MIDI and audio are not synchronized Make sure you are using the correct audio sync mode. Open the File >
Project Settings > Synchronization > Audio pane and choose MTC
Continuous or MTC Trigger + Auto Speed Detection mode in the Core
Audio pop-up menu.
If your audio hardware doesn’t support either mode, you should cut
extremely long regions into shorter sections.

MIDI and SMPTE are not
synchronized

Check all frame rate settings. The frame rates of all connected devices
must be identical, including the timecode on the tape machine, the
synchronizer, and Logic Pro itself.

Some synchronizers encode the wrong frame rate in MTC. In this situation,
open the Tempo Editor, turn off the Detect option, and set the correct
frame rate manually.
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Preferences, project settings, and
key commands

Preferences
Overview of preferences in Logic Pro

In Logic Pro, you can define and modify preferences that apply to all projects in the
Preferences window. These preferences are automatically saved whenever you quit the
application. A general preferences file, named com.apple.logic10.plist, is stored in the ~/
Library/Preferences folder, as is a separate preferences file for control surfaces, named
com.apple.logic.pro.cs. You can make changes to these files only in Logic Pro. If you delete
either preferences file, a new one is created the next time you open Logic Pro, with all the
preferences reset to their default values.
When Enable Complete Features is selected in Advanced preferences, you can reset
preferences to their default values manually.
In some instances, you’ll see a button in the Preferences window that links to related
settings in the Project Settings window, and vice versa. Both the Preferences window and
the Project Settings window can be visible at the same time.

Open Logic Pro preferences
•

In Logic Pro, choose Logic Pro > Preferences, or press Command-Comma (,), then
choose the name of the pane that you want to open.

Tip: You can also access some preferences using local menus (in the Score Editor, for
example), buttons in the control bar, or shortcut menus.

Reset all Logic Pro preferences (except for key commands)
•
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In Logic Pro, choose Logic Pro > Preferences > Reset All Preferences Except Key
Commands.
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General preferences
Project Handling preferences in Logic Pro
The Project Handling pane contains the following project startup and template preferences:

•
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Startup Action pop-up menu: Defines what happens when Logic Pro is opened.
•

Do Nothing: Nothing happens when Logic Pro is opened; you need to create a new
project, or open an existing project or template.

•

Open Most Recent Project: Opens the project you were working on when you last
closed Logic Pro.

•

Open Existing Project: Shows the Open dialog, which you can use to browse for an
existing project.

•

Select a Template: Opens the Templates dialog.

•

Create New Empty Project: Opens an empty project with the New Tracks dialog,
which you use to specify the type and number of new tracks to add.

•

Create New Project Using Default Template: Opens the default template and the
Save As dialog, which you use to name and save your project.

•

Ask: Opens a Startup dialog, offering each of the above options.

•

Default Template button: Allows you to choose a default template when Create New
Project using Default Template is chosen from the Startup Action pop-up menu.

•

Auto Backup pop-up menu: Defines the number of alternatives that are saved as part of
the project.

•

Recent Items pop-up menu: Defines how many recently opened projects are displayed
in File > Recent Items. Choose None if you don’t want any items displayed.
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When Enable Complete Features is selected in Advanced preferences, the following is
available:
•

When opening a project, ask whether current project should be closed checkbox: If
selected and you open a new project before closing the old one, a dialog asks whether
or not the current project should be closed. If the option is unselected, you aren’t asked
and the current project remains open.

•

Export MIDI File command saves single MIDI region as format 0 checkbox: If only one
MIDI region is selected when you choose File > Export > Selection as MIDI File, the
contents of the region are saved in MIDI file format 0. This file format is compatible with
every MIDI file player.

Editing preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Editing
preferences are available:
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•

Number of Undo Steps slider: Determines the number of undo steps.

•

Add last edit operation to region name checkbox: When selected, adds a description of
the edit operation (cutting, for example) to the name of the region, or resulting regions.

•

Groove template edits immediately update all associated regions checkbox: Editing an
original region also alters any quantization template derived from that region. When
unselected, the groove template remains as created. This allows you to edit the region
without affecting the quantization template.

•

Create new regions after splitting loops checkbox: Determines how Logic Pro handles
the cutting of looped regions.
•

When selected, you can cut a region’s looped area (using the Scissors or Marquee
tool, or Split by Playhead command). Logic Pro automatically creates regions after—
and, if necessary, before—the cut, ensuring that these areas remain identical. This
allows you to split looped regions without altering playback in the looped area.

•

When unselected, you can’t cut a region’s looped area. Cutting the looped region
itself turns off the Loop setting in the Region inspector.
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•

Select regions on track selection checkbox: Selecting a track selects all regions on the
track lane, or regions within the cycle or autopunch area (if Cycle or Autopunch mode
is on). When unselected, selecting a track does not select regions on the track lane. In
this case:
•

Option-clicking the track header or associated channel strip continues to select the
track and all associated regions.

•

Option-Shift-clicking adds the selected track’s regions to the current selection.

•

Select tracks on region/marquee selection checkbox: Selecting a region or making a
selection with the Marquee tool also selects the track header and channel strip, without
selecting any of the other regions on the track. Option-clicking a region selects the
region without selecting the track header and channel strip.

•

Right Mouse Button pop-up menu: Determines whether the right mouse button opens
the Tool menu, displays an additional Right-click Tool menu, or opens a shortcut menu.
•

Is Assignable to a Tool: Displays a third Tool menu (Right-click Tool menu) to the
right of the Left-click and Command-click Tool menus. Choose the appropriate menu
item to assign to the tool, which is available when the right mouse button is pressed
while editing.

•

Opens Tool Menu: Opens the Tool menu with the Pointer tool (and not the currently
selected tool) located under the pointer. Simply choose the tool you want by clicking
it. When the Tool menu is open, you can also use the key shown next to a tool to
select it.

•

Opens Shortcut Menu: Displays a menu that offers a number of area-specific
selection and editing commands.

•

Opens Tool and Shortcut Menu: Opens both the Tool and shortcut menus.

•

Enable Force Touch trackpad checkbox: When selected, Force Touch is enabled on the
computer’s built-in trackpad, or on a connected external trackpad.

•

Fade tool click zones checkbox: Placing the pointer over the upper-left and upper-right
edges of a region activates the Fade tool. You can still access the Loop pointer in these
click zones by pressing and holding Option.

•

Marquee tool click zones checkbox: Placing the pointer over the lower half of a region
(with the exception of the lower-left and lower-right edges) activates the Marquee tool.
If Quick Swipe and Take Editing click zones are also enabled, placing the pointer over
the middle third of a take region activates the Marquee tool.

•

Quick Swipe and Take Editing click zones checkbox: Placing the Quick Swipe pointer
over the upper half of a take region activates the standard pointer. If Marquee Tool
click zones are also enabled, placing the pointer over the upper third of a take region
activates the standard pointer.

•

Limit Dragging to One Direction in: Piano Roll Editor and Score Editor checkbox: When
selected, you can move notes only in one direction when editing in the Piano Roll or
Score Editor. This means that a note may be either transposed or moved in time, but not
both at once.
Note: Press Shift while dragging in the editor to quickly switch between the two
behaviors.
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•

Limit Dragging to One Direction in: Tracks area checkbox: When selected, you can move
regions (including folders) only in one direction in the Tracks area. This is similar to the
previous option.
Note: Press Shift while dragging in the Tracks area to quickly switch between the two
behaviors.

•

•

Double-Clicking a MIDI Region Opens pop-up menu: Determines which editor opens
when you double-click a MIDI region in the Tracks area.
•

Score Editor: Opens the Score Editor.

•

Event List: Opens the Event List.

•

Piano Roll Editor: Opens the Piano Roll Editor.

Piano Roll Editor: Region border trimming checkbox: When selected, region boundaries
can be adjusted in the Piano Roll Editor.

Cycle preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Cycle
preferences are available.
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•

Cycle Pre-Processing pop-up menu: Processes a cycle jump slightly before its actual
position, in order to ensure a smooth cycle jump from the end point to the start point of
the cycle. You can change the pre-processing time. The default value of Off should be
suitable for most uses.

•

Smooth Cycle Algorithm checkbox: Improves the timing of cycle jumps, making it easier
to set the length of sample loops while in Cycle mode. If your computer has a very slow
processor, this setting reduces the processing requirements for graphics operations. If
you’re working in a style that involves frequent cycling of musical sections, you’ll want
to select this checkbox. If you find that your cycled sections aren’t as smooth as you’d
like (assuming that your loops are actually perfect), the default value of Off should
achieve better results. The use of Apple Loops somewhat mitigates the need for this
setting.
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Catch preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Catch
preferences are available.
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•

Catch when starting playback checkbox: Turns on Catch mode whenever you click Play
or Pause.

•

Catch when moving playhead checkbox: Turns on Catch mode whenever you move the
playhead. This makes it easier to perform edits, as moving the playhead in the Tracks
area is reflected in the open editor, and vice versa.

•

Catch content by position if Catch and Link are enabled checkbox: If the Catch button
is turned on and Content Link is selected in the local View menu, the contents of the
region at the current playhead position are shown. If turned off, the window view still
follows the playhead position within the displayed region, but doesn’t update to show
the contents of subsequent regions as the playhead passes them (in playback or record
mode).
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Notifications preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Notification
preferences are available.
You can use notification preferences to reset warnings and preferences you had previously
set to “Do not show again.”

•

Reset Selected Warnings button: Resets any selected warnings and alerts that were
previously set to “Do not show again.”

•

Reset All Warnings button: Resets all warnings and alerts that were previously set to
“Do not show again.”

Accessibility preferences in Logic Pro

You can configure elements of the Logic Pro interface to work optimally with macOS
accessibility features.
The Accessibility pane contains the following preference:
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•

Open in Controls view by default checkbox: When this option is selected, plug-in windows
open in Controls view, making plug-in parameters available for use with VoiceOver.

Audio preferences
Devices preferences in Logic Pro
Logic Pro automatically recognizes any installed Core Audio hardware, and uses the
default settings as defined in the Audio MIDI Setup utility (Applications/Utilities/Audio MIDI
Setup). However, you may want to optimize the settings for your individual hardware setup,
particularly if you use several audio interfaces or a multiple input/output device.
The Devices pane contains the following preferences:
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•

Core Audio Enabled checkbox: Enables the Core Audio driver.

•

Output Device pop-up menu: Use to choose between any installed Core Audio device,
including the internal sound hardware. This also includes aggregate audio devices,
consisting of several audio interfaces. See the Audio MIDI Setup Help for information on
aggregate devices.

•

Input Device pop-up menu: Use to choose between any installed Core Audio device,
including the internal sound hardware. This also includes aggregate audio devices,
consisting of several audio interfaces. See the Audio MIDI Setup Help for information on
aggregate devices.
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Note: When setting an output device that also provides inputs, the Input Device pop-up
menu changes accordingly. If choosing a different input device, you’ll be advised to use
a common Word Clock for both audio devices, in order to ensure the best sound quality.
•

I/O Buffer Size pop-up menu: Determines the size of the buffer used by the audio
hardware for both input and output. The smaller the buffer size, the less latency you
encounter when monitoring while recording, or using software instruments.
Some points to note:
•

As the value is reduced, a higher strain is placed on your computer’s processor or
processors.

•

There may be a point where the selected I/O buffer size is too small for your
computer, and begins to affect playback. This usually takes the form of clicks, pops,
and crackles in your audio.

•

You should aim for the lowest possible I/O buffer size value that doesn’t introduce
clicks, pops, and crackles in your audio.

Tip: If you find that a higher I/O buffer size setting provides suitably low latency
during record monitoring and software instrument playback, you should use it. This
minimizes the impact on your computer’s processor or processors.
•

Resulting Latency (Roundtrip/Output) display: Displays the resulting roundtrip and
output latency for the I/O buffer size.

•

Apply Changes button: Reloads the audio driver with any adjustments made to
preferences in this window.

When Enable Complete Features is selected in Advanced preferences, the following are
available:
•

Recording Delay slider: Delays the recording of audio by a certain fixed value, helping
you to compensate for any delays that are caused by the audio driver.
Note: You should not normally need to touch this setting.
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•

Processing Threads pop-up menu: Choose the maximum number of processing
threads used, or have the number of threads set automatically. Automatic is the default
setting, and is recommended except when you use other CPU-intensive applications
simultaneously with Logic Pro.

•

Process Buffer Range pop-up menu: Determines the size of the buffer used to compute
mixes and effects. You can choose between Small, Medium, and Large buffer sizes.

•

Multithreading pop-up menu: Determines whether multithreading is set for playback
tracks only, or for playback and live tracks.

•

Summing pop-up menu: Determines whether the Logic audio engine uses double
precision or standard precision buffers when summing audio.
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General Audio preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, the General
Audio pane is available with the following preferences:

•

Display audio engine overload message checkbox: When selected, displays an alert
message in an overload situation. Otherwise, playback simply stops without displaying
an alert.

•

Sample Accurate Automation pop-up menu: Determines which parameters, if any, are
automated with sample accuracy. This type of automation is very processor intensive.
It places higher overheads on system resources, which may affect performance
(depending on the nature of your projects, and available computing power). This is most
likely to happen during heavy project sections where a lot of software instruments and
effects are in use. Logic Pro offers three settings:

•
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•

Off: Minimal overhead on computer performance for automation playback.
Automation is less precise when this setting is active.

•

Volume, Pan, Sends: Only these parameters are automated with sample accuracy.

•

Volume, Pan, Sends, Plug-in Parameters: All of these parameters are automated with
sample accuracy. Not all Audio Units plug-ins can be automated in this way.

Automatic Bus Assignment Uses pop-up menu: Choose whether automatic bus
assignment uses all busses, or only busses above a certain number (in multiples of
eight).
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•

Software monitoring checkbox: Turns software monitoring on or off. In most situations,
you should leave it on (default).
Note: When Software monitoring is on, the audio signal is processed via software, and a
certain amount of audible delay (commonly referred to as latency) is inevitable.
If you’re listening to the recorded signal through your mixing console, or your audio
interface supports hardware monitoring, you should turn this option off.

•

Input monitoring only for the focused track, and only when input monitoring is enabled
(as in GarageBand) checkbox: When enabled, you only hear incoming audio, during
playback or recording, for the focused track and any additional record enabled tracks.
If you select a single track, it is automatically focussed. If you selected multiple tracks,
click a track number in the track header to focus it.

•

Independent monitoring level for record-enabled channel strips checkbox: Allows the
use of an independent monitoring level for record-enabled audio channel strips. This is
off by default. After record-enabling a track, you can adjust the fader to the level you
like. The original level is restored when you deselect the Record Enable button.
Note: Adjustments to the fader do not affect the recording level; they only affect the
monitoring level.

•

Dim Level slider: Sets a discrete level for the Dim function. You can set a dim level from
0 dB to –30 dB. The level chosen here is used when the Dim button is activated from
the Master channel strip.

•

Plug-in Latency Compensation pop-up menu: Compensates for audio delays that can
be introduced when using plug-ins. Plug-in latency compensation (also called plug-in
delay compensation) is useful for software effects plug-ins, and is particularly important
for DSP (digital signal processing) accelerator hardware (such as products by Universal
Audio and others).
Use the pop-up menu to activate plug-in latency compensation for either:
•

Audio and software instrument tracks

•

All (audio, instrument, auxiliary, and output channel strips)

You can also turn off compensation entirely.
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•

Playback pre-roll checkbox: When selected, all Play commands start playback a little
earlier. The exact pre-roll value depends on the current plug-in delay compensation
value. This option ensures that transients that fall exactly on the start position are
played back correctly. If this option is unselected, transients that fall precisely on the
start position can be missed or seem to fade in.

•

Low Latency mode checkbox and Limit slider: When you enable Low Latency mode by
checking this box or clicking the Low Latency Monitoring button in the control bar, the
Limit slider determines the maximum amount of allowable plug-in delay. In Low Latency
mode, audio is routed around latency-inducing plug-ins to ensure that all delays (across
the entire signal flow of the current track) remain under the Limit slider value. This is
useful when you want to play a software instrument with several latency-inducing plugins inserted in the channel.

978

Sampler preferences in Logic Pro
You can configure the way in which the Sampler instrument searches for audio samples,
stores audio samples, uses virtual memory, and more, using these settings. The Sampler
preferences window contains two tabs with configuration options: The Misc tab for
miscellaneous settings, and the Virtual Memory tab for virtual memory settings.
The Misc tab contains the following preferences:

•

Sample Storage pop-up menu: Determines how Sampler handles the bit depth of
samples. Choose one of the following:
•

Original: Loads samples into RAM at their original bit depth. These are converted to
the internal 32-bit floating point format of the host application on playback.

•

32-Bit Float: Samples are stored and loaded as 32-bit float files, which removes the
need for real-time format conversions. Sampler handles 32-bit float samples more
efficiently and can play back more voices simultaneously.
Note: This requires twice as much RAM for 16-bit samples and a third more RAM for
24-bit samples.

•

Search Samples On pop-up menu: Determines the locations that Sampler searches for
instrument samples. Choose one of the following:
•
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Local Volumes: Sampler searches storage media attached to or installed in the
computer for samples.
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•

External Volumes: Sampler searches storage media accessible over a network for
samples.

•

All Volumes: Sampler searches both internal and network media for samples.
Note: Choosing External Volumes or All Volumes may increase the time it takes
Sampler to find and load sampler instruments and files.

•

•
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Read Root Key From pop-up menu: Sets the method Sampler and Quick Sampler use to
determine the root key of audio files when loaded using Optimized mode. Choose one of
the following menu options:
•

File/Analysis: Sampler and Quick Sampler first attempt to read the root key from
the header of the AIFF, WAV, or CAF file when loading the sample into a zone. If no
root key information exists in the header, then the audio samples are analyzed to
determine the root key from the longest note detected. If no pitch is detected, C3 is
automatically assigned to the zone as the root key.

•

Filename/Analysis: Sampler and Quick Sampler first attempt to read the root key
from the filename when loading the sample into a zone. If the filename does not
contain that information, then the audio samples are analyzed to determined the root
key from the longest note detected. If this doesn’t provide useful results, Sampler
uses C3 as the default root key in the zone.

•

Filename Only: Sampler and Quick Sampler attempt to read the root key from the
filename only when loading the sample into a zone. If no root key information can be
read from the filename, C3 is automatically assigned to the zone as the root key.

•

File Only: Sampler and Quick Sampler read from the AIFF, WAV, or CAF file header
only in an attempt to detect the root key when loading the sample into a zone. If no
root key information can be read from the file header, C3 is automatically assigned
to the zone as the root key.

•

Analysis Only: Sampler and Quick Sampler analyze the audio samples in an attempt
to determine the root key from the longest note detected when loading the sample
into a zone. If no pitch is detected, C3 is automatically assigned to the zone as the
root key.

Root Key at File Name Position pop-up menu: Determine how Sampler derives the root
key from the audio file header. Choose one of the following:
•

Auto: Provides a smart analysis of numbers and keys from the filename. Sampler can
recognize a number in the filename regardless of its format—60 and 060 are both
valid. Other valid numbers range between 21 and 127. Numerical values outside of
these are generally just version numbers. A key number is also a valid possibility for
this use—C3, C 3, C_3, A-1, #C3, or C#3, for example. The possible range is C-2 up
to G8.

•

Numeric value: You can set a numeric position in the filename which Sampler uses
to find the root key. This is useful when a filename uses multiple numbers, such as a
loop that uses multiple numbers to indicate both tempo and root key. For example, a
loop might be named “loop100-60.wav” to represent that it has a tempo of 100 beats
per minute and the root is the 60th position (E6). When you know the position of the
number representing the root key, you can set a numerical value to read the root key
at position eight of the filename.
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•

Previous Instrument pop-up menu and field: Determines which MIDI event type and
data value are used for selection of the previous instrument. Choices include Note, Poly
Aftertouch, Control Change, Program Change, Channel Aftertouch, and Pitch Bend. In
the field next to each pop-up menu, you can enter either the note number or the value
of the first data byte. If you choose Control Change, the number field determines the
MIDI controller number.
Note: The Sampler Previous Instrument setting is separate from the global Previous/
Next Plug-in Setting or Sampler Instrument command. Be careful not to assign the
same MIDI event for both, otherwise both commands are executed, which can result in
unexpected behavior.

•

Next Instrument pop-up menu and field: Determine which MIDI event type and data value
are used for selection of the next instrument. Choices include Note, Poly Aftertouch,
Control Change, Program Change, Channel Aftertouch, and Pitch Bend. In the field next
to each pop-up menu, you can enter the note number or the value of the first data byte.
If you choose Control Change, the number field determines the MIDI controller number.
Note: The Sampler Previous Instrument setting is separate from the global Previous/
Next Plug-in Setting or Sampler Instrument command. Be careful not to assign the
same MIDI event for both, otherwise both commands are executed, which can result in
unexpected behavior.

•

Keep common samples in memory when switching projects checkbox: Determines
whether the samples commonly used, or shared, by two open project files are reloaded
when you switch between projects.

The Virtual Memory tab contains the following preferences:
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•

Active checkbox: Turns on or off the virtual memory feature in Sampler. With virtual
memory on, only the initial attacks of samples are loaded into RAM; the rest of the
sample streams in real time from the hard drive. If your computer has enough physical
RAM to hold all samples for a project, you can improve performance by deselecting the
Active checkbox. In projects with lots of audio tracks playing and relatively few Sampler
instances, this may affect performance. If the Active checkbox is deselected and there
is insufficient RAM to hold all samples, Sampler swaps data to and from the disk, which
degrades performance. Deselecting the Active checkbox also increases project load
times.

•

Buffer Range pop-up menu: Determines the size of the buffer used for processing audio
samples. You can choose between Small, Medium, and Large buffer sizes.

•

Host Disk Activity pop-up menu: Optimizes Sampler by indicating how much recording
and streaming of non-sampler-related audio is occurring. Choose one of the following:
•

Less: If your projects consist mostly of software instrument playback, with perhaps a
recorded instrument or vocal or two, set your Host Disk Activity to Less.

•

Average: If your projects involve recording a small number of tracks at a time, and
possibly playing back a dozen or so audio tracks and some software instruments, set
your Host Disk Activity to Average.

•

Extensive: If you are recording an entire drum kit using over a dozen microphones,
streaming live guitars and bass, recording choirs, and so on, set your Host Disk
Activity to Extensive.

•

Requires Constant RAM Allocation Of field: Shows memory requirements of the
parameter settings above. The slower your hard drive and the higher your hard disk
recording activity, the more RAM you may need to allocate to virtual memory. If you
need to apply more, change the amount and click the Apply button.

•

Disk I/O Traffic field: Shows Sampler read/write disk load. If read/write traffic exceeds
your hard drive’s throughput capacity, you may hear audio glitches.

•

Not Read From Disk in Time field: Shows the number of audio files Sampler is unable to
read in time. If audio cannot be read from disk in time, you may hear audio glitches.
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Audio Editing preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, the Audio Editing
pane is available with the following preferences:

•

Crossfade Time slider: Determines a default time value for all crossfade operations in
the Tracks area.

•

Crossfade Curve slider: Determines a global curve type for all crossfade operations in
the Tracks area.

•

Scrubbing with audio in Tracks area checkbox: When selected, you can scrub audio
regions in the Tracks area using the Scissors or Solo tools.

•

Maximum Scrub Speed pop-up menu: Sets the maximum scrubbing speed. You can
choose between normal and double playback speed.

•
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•

Normal: The normal playback speed is used for scrubbing.

•

Double: The scrubbing playback speed is twice as fast.

Scrub Response pop-up menu: Sets the reaction time for audio scrubbing. Your choices
are Slow, Normal, Fast, and Faster.
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Output preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, the Audio Output
pane is available.
Audio Output preferences let you set the physical output pair on which the stereo output is
played, and the surround format. The Output pane consists of the following preferences:
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•

Stereo Output pop-up menu: Sets the physical output pair on which the stereo output is
played.

•

Mirroring checkbox: Becomes available for all chosen output pairs, with the exception of
Output 1–2. Deselect to have the output signal routed to the chosen output pair (Output
3–4, for example). Select the checkbox to have the output signal routed to the chosen
output pair (Output 3–4, for example), as well as to the physical outputs (Output 1–2).

•

Surround Show as pop-up menu: Sets the surround format. The choice you make
automatically updates the remaining pop-up menus in the Output pane.

•

Surround Initialize buttons: Choose between the default setup, the ITU (International
Telecommunications Union) standard, and the WG-4 standard.

•

Surround speaker pop-up menus: Sets the physical output speaker for each active
position in the selected surround format. Inactive speaker position output pop-up
menus are dimmed.
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Bounce Extensions preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, the Audio
Bounce Extensions pane is available.
Audio Bounce Extensions preferences let you set the bounce extension and the surround
format. The Bounce Extensions pane consists of the following preferences:
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•

Stereo Left and Right fields: Sets the bounce extension for each audio file when
bouncing in split format. You can change the extension by typing in the text field.

•

Surround Show as pop-up menu: Sets the surround format. The choice you make
automatically updates the remaining pop-up menus in the Bounce Extensions pane.

•

Surround Initialize button: Resets the bounce extensions to their default values.

•

Surround Extensions fields: Determines the extensions that are appended to audio
filenames when bouncing in surround format. You can change the extension by typing
in the text field. The extensions also determine the channel assignment when importing
split surround files.
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Input preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Input
preferences are available.
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•

Surround Show as pop-up menu: Sets the surround format. The choice you make
automatically updates the remaining pop-up menus in the Input pane.

•

Surround Initialize buttons: Choose between the default setup, the ITU (International
Telecommunications Union) standard, and the WG-4 standard.

•

Surround Input pop-up menus: Sets the physical input for each active position in the
selected surround format. Inactive positions have their input pop-up menu dimmed.
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Audio File Editor preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Audio File Editor
preferences are available.
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•

Warning before processing function by key command checkbox: Provides a warning
before carrying out a destructive edit in the Audio File Editor when you use a key
command. This gives you the opportunity to cancel the edit before altering the data.

•

Clear Undo History when closing project checkbox: Deletes the Undo History
automatically when you close the project.

•

Record selection changes in Undo History checkbox: Select if you want to be able to
undo and redo selection changes in the Audio File Editor.

•

Record Normalize operations in Undo History checkbox: Select if you want to be able to
undo and redo Normalize function changes in the Audio File Editor.

•

Number of Undo Steps slider: Determines the maximum number of undo steps that are
retained.

•

External Sample Editor chooser and Remove button: Lets you choose an external
application for sample editing tasks. Click the Remove button to clear the External
Sample Editor.
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MP3 preferences in Logic Pro
MP3 preferences let you control bit rate, quality, stereo mode, and other MP3 options.
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•

Bit Rate (Mono/Stereo) pop-up menus: You can choose bit rates between 32 kbps
and 320 kbps. The defaults are 80 kbps mono and 160 kbps stereo. These rates offer
acceptable quality and good file compression. If you can afford the increased file size,
you should choose 96 kbps for mono and 192 kbps for stereo streams. These settings
deliver better audio quality. You can choose even higher rates, but the quality of
improvement in bit rates above 96/192 kbps is minimal.

•

Use Variable Bit Rate (VBR) encoding checkbox: Variable Bit Rate (VBR) encoding
compresses simpler passages more heavily than harmonically rich passages, generally
resulting in better-quality MP3s. Unfortunately, not all MP3 players can accurately
decode VBR-encoded MP3s, which is why this option is unselected by default. If you
know that the audience for your MP3 files can decode VBR-encoded MP3s, you can
select this option.

•

Quality pop-up menu: Keep this set to Highest whenever possible. Reducing the quality
accelerates the conversion process, but at the expense of audio quality. This option is
only accessible when the Use Variable Bit Rate Encoding (VBR) checkbox is selected.

•

Use best encoding checkbox: If you deselect this option, you gain encoding speed at
the price of audio quality. Keep selected, unless conversion time is an issue.
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•

Filter frequencies below 10 Hz checkbox: Frequencies below 10 Hz are removed, leaving
slightly more data bandwidth for the frequencies that humans can hear, resulting in
an improvement in perceived quality. Such frequencies are usually not reproduced
by speakers, and aren’t audible to human ears. Only deselect this option if you’re
experimenting with subsonic test tones, or exporting MP3s for whales.

•

Stereo Mode pop-up menu: Choose between Joint Stereo and Normal Stereo.
Depending on the original file, these settings may or may not offer any audible
difference. Experiment with both settings to determine your preference.

Recording preferences in Logic Pro

You can use Recording settings to determine how Logic Pro responds while in record mode.
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•

Audio Recording File Type pop-up menu: Select the audio file format for recording. You
can select from AIFF, BWF (Wave), or CAF files. AIFF and BWF files are the more universal
audio file formats, but CAF allows for exceptionally long recordings. If you don’t plan on
recording continuous, half-day or longer audio files, select either AIFF or BWF.

•

24-bit recording checkbox: Enables recording audio at 24-bit resolution. Keep this
selected, unless storage space is an issue.

•

Overlapping Track Recordings pop-up menus: Set the behavior when recordings onto
MIDI or audio tracks overlap.
•

Create Take Folder: A new take folder is created when recording over an existing
MIDI or audio region.

•

Merge: Merges newly recorded MIDI data with the previously recorded MIDI data in
the same MIDI region.

•

Overlap: Creates new MIDI regions that overlap the previous MIDI regions on the
same track.

•

Overlap/Merge Selected Regions: Newly recorded data is merged with all selected
regions to form a single region. This takes place after each recording is completed.

•

Create Track: A new track is created when recording over an existing MIDI or audio
region.

•

Create Track Alternative: A new track alternative is automatically created with each
recording or cycle repetition.

•

Merge Current Recording Only: This function merges the data recorded in all cycle
passes into a single region.
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•

•

•

Create Tracks: This function automatically creates a new track for each cycle
repetition. Each previous track plays while you’re recording.

•

Create Tracks and Mute: When recording in Cycle mode, this function automatically
creates a new track assigned to the same channel strip for each cycle repetition.
Tracks are created after recording has stopped.

•

Create New Track: A new audio track is created automatically when you record over
existing material. The new track is created after recording has stopped.

Replace pop-up menu: Set the behavior when Replace is enabled.
•

Region Erase: Erases regions from the Tracks area from the start of recording until
the end of recording, even if nothing is played.

•

Region Punch: Erases regions only where audio material or MIDI events have been
recorded.

•

Content Erase: Does not erase regions but the audio or MIDI content inside of them,
from the start of recording until the end of recording, even if nothing is played.

•

Content Punch: Does not erase regions but the audio or MIDI content inside of them,
only where audio material or MIDI events have been recorded.

Recording Project Settings button: Opens the Recording Project Settings window.

MIDI preferences
General MIDI preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, General MIDI
preferences are available.
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•

MIDI 2.0 checkbox: When selected, Logic Pro uses the MIDI 2.0 protocol to receive,
record, and play back MIDI data.

•

External stop message ends recording checkbox: If using external synchronization
and the timecode stops while recording, record mode is turned off. If this checkbox is
unselected, Logic Pro stops, but remains in record mode (record mode is paused).

•

Reset All MIDI Drivers button: Resets all MIDI drivers. This can help if you experience
MIDI communication problems.
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Articulation Switches

Note: If any of these parameters are being determined by the Articulation Set Editor for a
given channel strip, the preference is dimmed.
•

MIDI Remote pop-up menu: Determines whether articulation switching is on or off.

•

MIDI Remote Set pop-up menu: Determines how the MIDI Remote state is set. If
you want the MIDI Remote setting to be the same for every channel, choose Global.
Otherwise, keep this set to Per Channel Strip.

•

MIDI Channel pop-up menu: Sets the MIDI channel for articulation switches.

•

MIDI Channel Set pop-up menu: Determines how the MIDI Channel is set. If you want
the MIDI Channel setting to be the same for every channel, choose Global. Otherwise,
keep this set to Per Channel Strip.

•

Octave Offset pop-up menu: Sets the octave offset for articulation switches. You can
choose any octave between +10 and -10 octaves.

•

Octave Offset Set pop-up menu: Determines how the Octave Offset is set. If you want
the Octave Offset setting to be applied to every channel, choose Global. Otherwise,
keep this set to Per Channel Strip.

Reset Messages preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, MIDI Reset
Messages are available.
These preferences are included for compatibility with older MIDI hardware. For selected
controller types, a reset message is sent to all MIDI outputs. This reset message is sent on
cycle jumps and when playback begins. However, Logic Pro handles MIDI reset messages
automatically and intelligently, so you should generally make sure that all of these options
are unselected—which they are, by default.
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•

Control 64 (Sustain) off checkbox: Sends a Control 64 off (Sustain) message to all
software instruments on cycle jumps and when playback begins.

•

Control 1 (Modulation) to zero checkbox: Sends a set Control 1 (Modulation) to zero
message to all software instruments on cycle jumps and when playback begins.

•

Pitch Bend to center position checkbox: Sends a Pitch Bend to center position message
to all software instruments on cycle jumps and when playback begins.

•

Control 123 (All Notes Off) checkbox: Sends a Control 123 (All Notes Off) message to all
external MIDI instruments on cycle jumps and when playback begins.

•

Control 121 (Reset Controls) checkbox: Sends a Control 121(Reset Controls) message to
all external MIDI instruments on cycle jumps and when playback begins.

•

Control 64 (Sustain) off checkbox: Sends a Control 64 off (Sustain) message to all
external MIDI instruments on cycle jumps and when playback begins.

•

Control 4 (Foot Control) to zero checkbox: Sends a Control 4 (Foot Control) to zero
message to all external MIDI instruments on cycle jumps and when playback begins.

•

Control 2 (Breath Control) to zero checkbox: Sends a Control 2 (Breath Control) to zero
message to all external MIDI instruments on cycle jumps and when playback begins.

•

Control 1 (Modulation) to zero checkbox: Sends a Control 1 (Modulation) to zero
message to all external MIDI instruments on cycle jumps and when playback begins.

•

Aftertouch to zero checkbox: Sends a Aftertouch to zero message to all external MIDI
instruments on cycle jumps and when playback begins.

•

Pitch Bend to center position checkbox: Sends a Pitch Bend to center position message
to all external MIDI instruments on cycle jumps and when playback begins.

•

Send used instrument settings on reset checkbox: Sends used instrument settings to all
external MIDI instruments on cycle jumps and when playback begins.
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Sync preferences in Logic Pro
The Sync pane contains the following preferences:

When Enable Complete Features is selected in Advanced preferences, the following are
available:
•

All MIDI Output: Delay slider: Delays or advances the MIDI output for all ports, so you
can compensate for any timing differences between MIDI tracks and audio or software
instrument tracks.

•

MTC Pickup Delay slider: This should generally be set to zero, to ensure the quickest
possible pickup time while Logic Pro is in MIDI Time Code (MTC) Sync mode. There
are, however, some devices that seem to transmit imprecise MTC commands when first
started. As a result, synchronization may be unreliable, and there could be an offset
every time synchronization is established. In such situations, you can set a delay time
before incoming MTC is picked up. Essentially, Logic Pro ignores the incoming MTC
commands that occur in this time period. A (frame) value of 25 to 30 corresponds to
a delay of about one second, depending on the frame rate. Use when synchronizing to
hard disk recorders and other devices, if synchronization appears to be inconsistent.

•

Delay MTC Transmission By slider: Delays the transmission of MIDI timecode. Negative
values result in MTC being transmitted earlier, allowing you to compensate for any
reaction delays (to incoming MIDI timecode) in external devices that follow MTC from
Logic Pro.

•

MMC Uses pop-up menu: Choose between MMC standard messages and the old Fostex
format.

•
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•

MMC Standard Messages: The MIDI MMC specification is strictly followed.

•

Old Fostex Format: The old Fostex format is used for MIDI Machine Control.

Output ID (Transport) checkbox: The All checkbox sends MMC to all ports. Use the field
to the right to specify an output port ID.
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•

Input ID (Transport) checkbox: The All checkbox sends MMC to all ports. Use the field
to the right to specify an input port ID.

•

Transmit Locate Commands When: Pressing Stop twice checkbox: Transmits MMC
Locate commands when the Stop button (or Stop key command) is used twice.

•

Transmit Locate Commands When: Dragging regions or events checkbox: Transmits
MMC Locate commands with the position of a region that is dragged in the Tracks area
when Logic Pro is stopped.

•

Transmit record-enable commands for audio tracks checkbox: Transmits MMC
record-enable and record-disable commands when audio tracks are record-enabled
or disabled. In addition, any received MMC record-enable commands set the recordenabled state of audio tracks.

•

MIDI Sync Project Settings button: Opens the MIDI Sync Project Settings window.

MIDI Inputs preferences in Logic Pro
Sometimes a hardware device using the same MIDI input port to communicate with both
Logic Pro and other software applications may send large streams of MIDI data, causing
playback artifacts or corrupted projects. For example, an audio interface may use a virtual
USB MIDI port to send a continuous stream of MIDI sysex data to both its mixer software
and to Logic Pro. If you are experiencing these issues when using Logic Pro with hardware
devices or other applications, MIDI Inputs preferences can be used to deactivate specific
MIDI input ports in use by other software applications.
To determine whether these issues are due to large MIDI data streams, and to determine
which MIDI input port the data is being transmitted on, you can use a MIDI monitoring
application (free MIDI monitoring applications are available on the Internet). You can also
refer to the documentation for your MIDI hardware device to see on which ports it sends
sysex data.
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When Enable Complete Features is selected in Advanced preferences, MIDI Inputs
preferences are available.
•

On checkbox: Use these checkboxes to deactivate (or re-activate) a MIDI input port
on your hardware device. When a MIDI input port is deactivated in Logic Pro, the MIDI
hardware device still communicates with other software applications.

•

Port field: Lists the name of each available MIDI input port on all available hardware
devices. If a MIDI input port has been removed or is inactive (grayed out), you can
delete it by selecting the port in the port field and pressing Backspace.

Display preferences
General Display preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, General Display
preferences are available.
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•

Appearance pop-up menu: Choose whether the color scheme for Logic Pro preferences,
system dialogs, and other system-related windows is based on the system setting,
shown in a dark appearance, or light appearance.

•

Large local window menus checkbox: When selected, local menu items are displayed in
a larger font.

•

Large inspectors checkbox: When selected, inspector settings are displayed in a larger
font.

•

Wide playhead checkbox: When selected, a thicker playhead is used in all windows.

•

Show help tags checkbox: When selected, help tags appear throughout Logic Pro when
you move the pointer over interface elements and tools. When editing, the function
name, region or event name or number, position, and parameter values are shown.
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•

Show default values checkbox: When selected, default parameter values are displayed
in help tags. This makes it easier to determine the amount of variance from the default
value.

•

Show icons in New Tracks dialog checkbox: When selected, an icon-style New Tracks
dialog is shown. Otherwise, a text-style New Tracks dialog is displayed.

•

Show animations checkbox: When selected, various windows and functions open with
animations. If you find the animations distracting, deselect the checkbox.

•

Display Middle C As pop-up menu: Affects the description of notes in the editors. The
bottom C on a five-octave keyboard (note # 36) is labeled C1, and middle C (note # 60)
is labeled C3. According to this standard, the lowest MIDI note (note # 0) is called
C–2. This is the official standard used by most manufacturers. Use of the C3 (Yamaha)
setting sets Logic Pro to this standard mode. If you select the C4 (Roland) setting, the
bottom C on a five-octave keyboard is labeled C2, and middle C is labeled as C4. In this
standard, the lowest MIDI note is C–1.

•

Display Time As pop-up menu: Use to customize the Time display in the control bar.

•

Zeros as spaces checkbox: Displays zeros in the time display as blank spaces.

•

Display Tempo As pop-up menu: Use to customize the Tempo display in the control bar.

•

Clock Format pop-up menu: Use to customize the Beats display in the control bar.

Tracks Display preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Tracks Display
preferences are available.
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•

Show track or bar number while scrolling checkbox: When you select this, an overlay
appears in the center of the Tracks area, showing the track number or bar number as
you scroll. The track or bar number displayed depends on the direction in which you
scroll:
•

Down: The highest visible track number is displayed.

•

Up: The lowest visible track number is displayed.

•

Right: The highest visible bar number is displayed.

•

Left: The lowest visible bar number is displayed.

The overlay includes a label below the number to indicate whether track or bar numbers
are being displayed. In general, this overlay is most useful for projects with a very large
number of tracks.
•

Logic Pro User Guide

Track Color pop-up menu: Choose whether Logic Pro automatically assigns a color
to newly created tracks, and determine how it cycles through the Color palette when
assigning colors.
•

Static: Newly created tracks are not automatically assigned a new color. Tracks are
created with the default color for that specific track type, or a previously manually
assigned color from the Color palette. This is the default setting.

•

Auto-assign—24 Colors: When the first new track is created, it is assigned the
leftmost (first) color in the Color palette from the same row as the color of the
initially created track. Each subsequently created track is assigned the color from
the next box to the right in the same row in the Color palette. In this mode, only 24
colors are used for automatic color assignment.

•

Auto-assign—96 Colors: When the first new track is created, it is assigned the
leftmost (first) color in the Color palette from the next higher row as the color of the
initially created track. If the initially created track is the top-right color, the first new
track is assigned the first color of the lowest row of the Color palette. In this mode,
all 96 colors are cycled through for automatic color assignment.

•

Region Color pop-up menu: Choose whether regions can be colored individually, or
whether regions conform to the color of the track they are on.

•

Marker Color pop-up menu: Choose whether Logic Pro automatically assigns a color
to your newly created markers, and determine how it cycles through the Color palette
when assigning colors.
•

Static: Newly created markers are not automatically assigned a new color. Markers
are created with a dark gray color, or a previously manually assigned color from the
Color palette. This is the default setting.

•

Auto-assign—24 Colors: When the first new marker is created, it is assigned the
leftmost (first) color in the second row of the Color palette. Each subsequently
created marker is assigned the color from the next box to the right in the same
row in the Color palette. In this mode, only 24 colors are used for automatic color
assignment.

•

Auto-assign—96 Colors: When the first new marker is created, it is assigned the
leftmost (first) color in the Color palette from the first row of the Color palette. Each
subsequently created marker is assigned the color from the next box to the right in
the same row in the Color palette. In this mode, all 96 colors are cycled through for
automatic color assignment.
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•

Background pop-up menu: Choose whether the Tracks area uses a dark, light, or
custom background. To adjust the background manually, choose Custom and drag the
Background slider.

•

Grid Lines checkbox: Choose how the Tracks Area displays horizontal and vertical grid
lines. If you select the Automatic checkbox, Logic Pro displays vertical grid lines with a
default grayscale value. If you deselect this checkbox, you can adjust the grayscale of
the grid lines manually from white to black by using the horizontal and vertical sliders
that appear, or select a further checkbox to assign black as the default color.

•

Shaded loops checkbox: Select to show looped sections of regions in the Tracks area in
a shaded color. Otherwise, they reflect the full color of the original region.

•

Show “+” button next to Drummer regions: When you select this option, a circular
button with a Plus (+) appears to the right of Drummer regions. Click this button to add
a Drummer region to the right of the existing one.

Mixer Display preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Mixer Display
preferences are available.
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•

Open plug-in window on insertion checkbox: Opens the window of a plug-in
automatically after it is inserted in the channel strip.

•

Open in controls view checkbox: Opens plug-in windows in controls view rather than
editor view.

•

Show recent plug-in list in plug-in menu: Displays a list of recently used plug-ins in the
audio effect and instrument plug-in menus.

•

Level Meters Peak Hold Time pop-up menu: Choose the length of the peak hold time.
The choices are 800 milliseconds, 2 seconds, 4 seconds, or Infinite.
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•

•

Level Meters Return Time pop-up menu: Set the rate at which the level meters return
to zero, in decibels per second. The default value of IEC Type I (11.8dB/s) is an industry
standard that is appropriate for nearly every project. However, if your source material is
unusually fast or contains multiple tempo changes that require faster or slower return
levels, you can choose from six additional faster or slower return times.
•

Very Slow (4 dB/s)

•

EBU Slow (6.3 dB/s)

•

IEC Type II/EBU Normal (8.6 dB/s)

•

IEC Type I (11.8 dB/s)—this is the default setting.

•

Fast (20 dB/s)

•

Faster (30 dB/s)

•

Very Fast (50 dB/s)

Level Meters Channel Order pop-up menu: Determines the order of channels in
multichannel (surround) level meters.

Editors Display preferences in Logic Pro
Editors Display preferences are only available when Enable Complete Features is
selected in Advanced preferences.

•
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Bright background checkbox: Switches between a dark and light background in the
Piano Roll Editor.
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Score preferences in Logic Pro

The Score pane contains the following preferences:

When Enable Complete Features is selected in Advanced preferences, the following are
available:
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•

Show region selection in color checkbox: Displays the staff lines of the currently
selected MIDI region in color. All other regions are displayed with black staff lines.
This can be useful when changing the display parameters of regions, because the
parameters in the Region inspector affect only the currently selected regions. If this
option is unselected, all staffs are displayed in black, whether selected or not.

•

Display distance values in inches checkbox: Displays units in the Page Score view ruler
in inches. If not selected, the unit of measurement defaults to centimeters.

•

Double-Click to Open pop-up menu: Determines the window that opens when you
double-click a note head: Note Attributes, Event List, Piano Roll Editor, or Step Editor.

•

Selection Color button: Choose the color of selected objects in the Score Editor. Click
the Reset button to revert to the default color.

•

Camera Tool: Write To buttons: Choose either the Clipboard or a PDF file as the
destination for image exports with the Camera tool.

•

Auto split notes in polyphonic staff styles checkbox and Split Notes At slider: Saves
newly recorded notes automatically with the different MIDI channels used in the
corresponding staff style. This preference is relevant only if the chosen default staff
style (on the recording track) is polyphonic, and is using MIDI channels for voice
assignment.

•

Score Project Settings button: Opens the Score Project Settings window.
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Movie preferences in Logic Pro

When Enable Complete Features is selected in Advanced preferences, Movie
preferences are available.
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•

Movie to Project slider: Fine-tunes the start point of a movie.

•

Cache Resolution pop-up menu: Defines the resolution of the thumbnails kept in the
temporary internal memory (cache). Higher resolutions display more detail, but take up
more space in the cache.

•

Maximum Cache Size slider: Defines the amount of memory reserved for the thumbnail
cache. Forty megabytes is recommended for medium resolution. For higher resolutions
choose a higher value. This section of reserved memory is only occupied when actual
movie data is displayed.

•

Use Logic Pro audio output checkbox: When selected, Logic Pro uses the same output
for the movie soundtrack as it does for all the rest of your audio.

•

Lock movie window when changing screensets checkbox: When selected, the Movie
window stays in its current user-defined position, and playback continues, when
changing screensets.

•

Movie Project Settings button: Opens the Movie Project Settings window.
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Automation preferences in Logic Pro

When Enable Complete Features is selected in Advanced preferences, Automation
preferences are available.

•
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Move Track Automation with Regions pop-up menu: Determines what happens to
automation data when you move regions.
•

Never: Does not move automation when you move regions.

•

Always: Always moves automation when you move regions. The automation data area
encompassed by the region boundaries is moved.

•

Ask: A dialog prompts you to move the automation data—or leave it where it is—
whenever you move a region.

•

Include trails, if possible checkbox: Includes the automation trails of regions
(automation parameter movements in the empty space that follows a region) with all
Copy or Move actions.

•

Pencil Tool pop-up menu: Determines the behavior of the pencil tool when holding down
the Option key.
•

Hold Option for Stepped Editing: Pressing and holding the Option key while dragging
an automation lane creates automation stepped automation curves.

•

Hold Option for Curved Editing: Pressing and holding the Option key while dragging
an automation lane creates rounded automation curves.

•

Snap Offset slider: Allows a specific number of ticks to be added to, or subtracted from,
the current snapped position of all automation data (as set in the Snap pop-up menu in
the Tracks area).

•

Ramp Time slider: Determines the time required by a parameter to return to its
previously recorded setting.

•

Write Mode Changes To pop-up menu: Determines the mode that faders automatically
switch to when automation data recording has been completed.

•

Write Automation For checkboxes: Determine the types of automation data that can be
written in Touch, Latch, and Write modes.

•

Automation Quick Access controls: Allow you to use a single hardware controller
to automate the currently active automation parameter of the selected track. This
preference is discussed in detail in Automation Quick Access.
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Control surface preferences
General Control Surfaces preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, General Control
Surfaces preferences are available.
General Control Surfaces preferences include resolution of relative controls, maximum MIDI
bandwidth, and other functions.

General preferences
•

Bypass all while in background checkbox: Turn on to allow your control surface to be
shared with other applications when Logic Pro is not the active program.

•

Resolution of Relative Controls slider: Drag to set the resolution of controls that change
values in a relative manner. The default resolution is 128 steps. Choose a higher
resolution value to divide the value range into finer increments.

•

Maximum MIDI Bandwidth slider: Drag to set the maximum amount of MIDI bandwidth
that your control surface can use. This is set to a default of 50%, which should be
suitable for most situations. You can adjust the value if MIDI or automation playback is
being affected.

•

Touching fader selects track checkbox: Turn on to select the track corresponding to the
fader when you touch a fader on the control surface.
Note: This feature works only with devices that have touch-sensitive faders.
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•

Control surface follows track selection checkbox: Turn on to automatically select the
corresponding track or channel on the control surface when you select a track in the
Tracks window.

•

Jog resolution depends on horizontal zoom checkbox: Turn on to link the precision of
scrubbing (using the Jog/Shuttle Wheel of your control surface) with the horizontal
zoom level of Logic Pro. Your control surface must feature a Jog/Shuttle Wheel (or
similar control) for this to have an effect. To retain a consistent resolution, regardless
of Logic Pro window zoom levels, deselect this checkbox.
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•

Pickup mode checkbox: Turn on to use your control surface in Pickup mode (if this
mode is available).
Some control surfaces, typically those without motorized faders or knobs, do not show
parameter changes—caused by playing back existing automation data—on their interface.
Such control surfaces usually offer a Pickup mode. In Pickup mode, the controller must
reach (“pick up”) the current value before the value starts to change. This feature
prevents sudden jumps of parameter values caused by playing back automation. Your
device may provide a display (usually a pair of arrow LEDs) that indicates the direction or
distance you need to move the controller, in order to match the settings shown in Logic
Pro (also known as NULL). Once you have matched the onscreen values, you can create
or edit automation data. When Pickup mode is turned off, adjusting a fader modifies the
parameter immediately (which can result in parameter value jumps).

•

Flash Mute and Solo buttons checkbox: Turn on to make the Mute and Solo buttons on
the control surface blink (flash) on and off when mute or solo modes are engaged.

•

Multiple Controls per Parameter pop-up menu: Choose the maximum number of
encoders used for each parameter when editing plug-ins or audio instruments. The
choices are:
•

1: Parameters are always displayed using one encoder per parameter, with the least
space available for the parameter name and value in the LCD.

•

2: On each unit, encoders 1 and 2 are used for the first parameter, encoders 3 and 4
for the second, and so on.

•

4: On each unit, encoders 1 to 4 are used for the first parameter, encoders 5 to 8 for
the second, and so on.

•

8: On each unit, encoders 1 to 8 are used for the first parameter, encoders 9 to 16
for the second, and so on.

When multiple encoders are used per parameter, the encoders are divided into groups
(1/2, 3/4, 5/6, 7/8, for example). The first encoder of each group controls the parameter
shown in the display. The remaining encoders are inactive. Using more than one
encoder per parameter shows fewer parameters at any given time, but you gain space
on the LCD to cater for longer parameter names and values. The more control surfaces
you have within a control surface group, the more you benefit from this feature.
•

Only when all parameters fit on one page checkbox: Turn on to use the defined number
of encoders only when there are sufficient encoders available to show all parameters
without changing pages.
For example, if you have a Mackie Control and two Mackie Control XTs (giving you a
total of 24 encoders), a plug-in with 13 parameters is shown with one encoder per
parameter. Eleven encoders remain unused. A plug-in with 11 parameters is shown with
two encoders per parameter. Two encoders remain unused (as do the inactive encoders
of the subdivisions mentioned above). When this parameter is turned off, multiple
encoders are used for each parameter, which may require scrolling. This is not the case
if only one encoder is used for each parameter.
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•

Show Value Units For checkboxes: Turn on the two checkboxes to add the measurement
unit to parameter values, where applicable—“Hz” or “%,” for example. You can set this
option separately for instrument and plug-in parameters, and for volume and other channel
strip parameters. Turn off this option if viewing unit types makes the display too cluttered.

•

Controller Assignments button: Click to open the Controller Assignments window.

•

Setup button: Click to open the Control Surfaces Setup window.
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Help Tags preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Help Tags
preferences are available.
You can change the way help tags are shown on control surfaces that feature
programmable displays with more than six characters per line or segment. Control surface
help tags show additional information during use.

Help Tags preferences
•

While Editing Show Long Names For checkboxes: Turn on the two checkboxes in this
section to determine how parameter names and values are displayed on the LCD of the
control surface.
•

Parameter name checkbox: Turn on to show the full parameter name in the upper
LCD line when you edit a parameter.

•

Parameter value checkbox: Turn on to show the full parameter value in the lower LCD
line when you edit a parameter. If the Show value units for checkboxes (see below)
are turned on, the value is appended by the unit type where applicable (for example,
dB, Hz, or %).

Note: The following options only have an effect if at least one of the two parameters
described above is active.
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•

Display Duration slider: Set the time that parameter names and values remain on the
LCD, following selection and adjustment.

•

Show info for multiple parameters checkbox: Turn on to show the long name and
information in the LCD until the most recently edited parameter information display
times out. This may cause overlapping text. Turn off to limit the long name display to
show only the most recently edited parameter, which can cause screen flicker.

•

Show info when selecting tracks checkbox: Turn on to show “Selected” in the upper row
of the LCD and the selected track name in the lower LCD row when you select a track.

•

Show info when editing volume checkbox: Turn on to show “Volume” in the upper row of
the LCD and the edited value in the lower LCD row when you edit the volume of a track.
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•

Show Value Units For checkboxes: Turn on to show the appropriate measurement unit
(Hz or %, for example) after parameter values. You can set this option separately for
instrument and effect plug-in parameters and track volume and other parameters. If you
can work without value units, the display is less cluttered.
Note: This parameter applies only during edits to relevant values.

•

Controller Assignments button: Click to open the Controller Assignments window.

•

Setup button: Click to open the Control Surfaces Setup window..

MIDI Controllers preferences in Logic Pro
When Enable Complete Features is selected in Advanced preferences, MIDI Controllers
preferences are available.
The MIDI Controllers preference pane applies to USB MIDI controllers supported by
Lua scripts.
See the documentation for automatic assignment for USB MIDI controllers for more details.
Lua is a lightweight scripting language supported by Logic Pro. See http://lua.org/about.html.
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MIDI Controllers preferences
•

Auto checkbox: Enable to use automatic assignments for the corresponding USB MIDI
controller. The controller must be connected and turned on.
•

Assignments for this device are created immediately, based on information in the
Lua script. If a user-defined or -edited assignment for a control already exists, it is
retained, and no additional assignment is created for this control.

•

The Lua script is started, enabling its optional MIDI In and MIDI Out processing.

•

When the Auto checkbox is disabled, Lua script assignments are removed (usermodified assignments are retained) and Lua script MIDI processing is stopped.
Note: The Auto checkbox state corresponds to the Auto Assign and No options
shown in the dialog when the device is initially identified. The checkbox state is
processed every time Logic is launched, or when the Bypass All Control Surfaces
menu item is unchecked.

•

Manufacturer column: Displays the name of the controller manufacturer. This is
automatically identified and shown for all USB MIDI devices that have a corresponding
Lua script. Text is dimmed if the corresponding controller is offline.

•

Model Name column: Displays the controller name. This is automatically identified and
shown for all USB MIDI devices that have a corresponding Lua script. Text is dimmed if
the corresponding controller is offline.
Note: All Manufacturer and Model Name entries are removed when you click the
Preferences > General > Notifications > Reset Warnings button. In this situation, you will
see the No / Auto Assign dialog for all supported USB MIDI devices that are currently
online.

•

Controller Assignments button: Click to open the Controller Assignments window.

•

Setup button: Click to open the Control Surfaces Setup window.

My Info preferences in Logic Pro

The My Info pane contains song sharing preferences, which Logic Pro uses to identify your
songs when sharing them via Music or SoundCloud, for example.

Logic Pro User Guide

•

Composer Name text field: Enter the name of the song composer.

•

Artist Name text field: Enter the name of the performing artist.

•

Album Name text field: Enter the name of the album in which the song appears.

•

Playlist text field: Enter the name of the playlist in which the song appears.
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Advanced preferences in Logic Pro

This preference provides access to a number of advanced features in Complete mode.

•

Enable Complete Features checkbox: When selected, advanced features such as project
alternatives and backups, beat mapping, expanded mixing and automation capabilities,
and more are available. To learn more about Complete Features, see Use the complete
set of Logic Pro features.

To learn more, see Use the complete set of Logic Pro features.

Project settings
Overview of project settings in Logic Pro

In Logic Pro, you can define and modify settings that apply to individual projects. You
do this in the Project Settings window. These settings are automatically saved with each
project, which means that different projects can have different settings. You can save your
preferred settings in a default template, which can be used to automatically create a new
project when you open Logic Pro. You can also import project settings from other projects.
In some instances, you’ll see a button in the Project Settings window that links to related
settings in the Preferences window, and vice versa. Both the Project Settings window and
the Preferences window can be visible at the same time.

Open project settings
•

In Logic Pro, choose File > Project Settings, then choose the name of the pane that you
want to open.

Tip: You can access some project settings using local menus (in the Score Editor, for
example), buttons in the control bar, or shortcut menus.
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General settings in Logic Pro

When Enable Complete Features is selected in Advanced preferences, you can use the
musical grid setting to determine the view option for the ruler and whether or not tempo
information is written into recorded audio files.

•

Use musical grid checkbox: Sets the ruler to bars and beats, and tempo information is
recorded into audio files. If deselected, the ruler is set to time, and tempo information is
not recorded into audio files. In general, the only reason not to show the musical grid in
the primary ruler is with spoken word or other non-musical projects. If you are working
on a project containing music and you want to show time in the Tracks area, consider
using the secondary ruler to show time in addition to the primary ruler showing the
musical grid. To learn more about the primary and secondary ruler, see Position items
using the ruler.

•

Only load plug-ins needed for project playback checkbox: When checked, only plugins needed to enable the full signal flow for playback (including auxes, busses, and
outputs) are loaded when a project is opened. This includes:
•

The focused track.

•

Audio tracks containing audio regions (not including frozen tracks).

•

Software instrument tracks containing MIDI regions (not including frozen tracks).

•

Audio tracks with input monitoring active.

•

Audio and software instrument tracks with plug-ins that automatically generate
sound without requiring any input.

•

Any other tracks required for the complete signal flow.

Plug-ins on tracks that are not required for project playback are dimmed, indicating that
they are currently inactive. This includes tracks without regions on them, frozen tracks,
tracks that have been turned off, and auxiliary tracks not in the signal path.
After you open a project, inactive plug-ins load any time you:
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•

Select a track or channel strip with inactive plug-ins.

•

Add a region to a track with inactive plug-ins.

•

Unfreeze a frozen track.

•

Add a plug-in to a channel strip with inactive plug-ins.

•

Click a plug-in on an inactive track or channel strip.

•

Click a plug-in slot on an inactive channel strip and select “Activate Channel” from
the pop-up menu.
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•

Click a Channel EQ or Compressor slot on a channel with inactive plug-ins.

•

Add an additional output to a multi-output software instrument on a channel with
inactive plug-ins.

•

Record-enable one or more channel strips with inactive plug-ins.

•

Use selection-based processing on a track with inactive plug-ins.

•

Change a send or output on an active channel.

•

Set or change an input on an audio or aux channel.

Note: Inactive plug-ins do not load for tracks that are turned off.
Loading only the plug-ins as needed can be a significant time-saver when opening
complex projects with a large number of tracks and plug-ins, only some of which are
used. It also more efficiently allocates your computer’s resources, which can help guard
against audio dropouts or other glitches.
To learn more about opening projects, see open projects. To learn more about working
with plug-ins, see plug-ins overview.
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•

Region automation takes priority over track automation checkbox: If selected, track
automation is suspended between the region start and end, if the region contains
automation data for the same parameter. It’s on by default in new projects—and off by
default in projects created in older Logic versions.

•

Use preset parameter value for regions without region automation (if no track
automation is present) checkbox: If selected, the parameter value you set in the
channel strip or plug-in is applied to all regions that don’t have automation data for
that parameter. If deselected, the final parameter value of the preceding region with
automation data is used for regions without automation data.
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Synchronization settings
General Synchronization settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, General
Synchronization settings are available.
These settings are used when Logic Pro is being controlled by another device and acting
as a MIDI clock receiver.

•

•

Sync Mode pop-up menu: Defines how Logic Pro syncs with the other device.
•

Internal: Selects the internal timer of Logic Pro, with Logic Pro transmitting MIDI
clock. External devices can be synchronized via MIDI clock or MTC.

•

MTC: Selects MIDI Time Code mode, with Logic Pro following incoming MTC. MIDI
timecode can either arrive at a MIDI In port, or be generated by a MIDI interface that
translates it from incoming SMPTE timecode—the Unitor8, for example.

•

Manual: Selects Tempo Interpreter mode, with Logic Pro receiving MIDI clock
impulses that are recognized as valid beats by the Tempo Interpreter. The
parameters that control how Logic Pro responds to Tap Tempo commands can be
found in the Tempo Interpreter window.

Auto-enable external sync and Tap Tempo checkbox: When selected, Logic Pro
transmits MIDI clock until it receives a synchronization signal—either in the form of
MTC, or from the Tempo Interpreter.
Logic Pro automatically locks to the first synchronization signal it receives.
Important: Make sure that different synchronization signals don’t arrive simultaneously;
remember that only one device should transmit timecode.

•
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Frame Rate pop-up menu: Defines the frame rate, which applies to both transmitted and
received timecode.
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Note: In drop frame formats, certain frames are left out. (This follows a regular pattern.)
To distinguish between formats, those without dropped frames are sometimes referred
to as NDF or non–drop frame.

•

•

24 fps: Film, high definition video

•

25 fps: PAL video/television broadcasts

•

30 fps (drop frame): NTSC video/television broadcast; rarely used

•

30 fps: High definition video; early black-and-white NTSC video; an older rate that is
rarely used today

•

29.97 fps (drop frame): NTSC video/television broadcasts

•

29.97 fps: Standard definition NTSC

•

23.976 fps: 24 fps running at 99.9%, which facilitates easier transfer of film to NTSC
video

Auto detect format of MTC checkbox: When selected (recommended), the incoming
timecode is analyzed and the correct frame rate set automatically.
Note that it’s not possible to automatically distinguish between the 29.97 and 30 fps
MTC frame rates:
•

The MTC standard doesn’t allow a distinction.

•

A measured rate of 30 fps could also be 29.97 fps timecode running too fast, and
vice versa.

Logic Pro automatically interprets frame rates of “approximately 30 fps” as either 29.97
(drop frame) or 30 fps (non-drop frame), depending on whether or not the drop frame
format is used. This interpretation usually is correct, because these two formats are
used as a standard.
The “Auto detect format of MTC” option only switches to 29.97 (drop frame) or 30 fps
(non-drop frame) if one of the other conventional formats was previously set. If you want to
synchronize Logic Pro to one of these nonconventional frame rates, you need to define the
format manually. This setting isn’t altered by the “Auto detect format of MTC” function.
•

Validate MTC pop-up menu: Specifies how often Logic Pro checks for incoming
timecode, in order to ensure synchronization integrity. In general, you should leave this
option on “Always.” There are some devices that generate timecode pulses that may
require a specific number of frames to be set, in order to maintain synchronization.

•

Bar Position Plays at SMPTE sliders: Defines the SMPTE offset for the project. Because
projects don’t always need to start precisely at bar 1, you can select any bar position to
be played at the set SMPTE time.
The default is Bar Position: 1 1 1 1 plays as SMPTE 01:00:00:00.
The SMPTE offset of 01:00:00:00 (one hour) is normally used, because it allows you to
pre-roll an amount of timecode.

•

Enable separate SMPTE view offset checkbox: Shows the absolute time from the start of
the project in the time display, rather than the actual SMPTE time.

•

Bar Position Displayed as SMPTE sliders: Becomes available if you select the Enable
Separate SMPTE View Offset checkbox. Choose Bar Position 1 1 1 1 displayed as SMPTE
00:00:00:00 (preset). If necessary, you can set other view offset values here.
The Tempo List always shows the real SMPTE time, never the SMPTE View Offset. The
SMPTE View Offset is used in all other windows (including the control bar).
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Tip: It’s common practice in many video (and audio) post-production houses to set
a one-hour SMPTE offset (01:00:00:00). This avoids a problem commonly referred to
as midnight, where a pre-roll passes through SMPTE time 00:00:00:00, which causes
issues with some tape machines (such as the ADAT).

Audio Synchronization settings in Logic Pro
You can use Audio Synchronization settings to keep your audio and MIDI tracks
synchronized.

When Enable Complete Features is selected in Advanced preferences, the following are
available:
•

MTC slider: Shows the deviation between the incoming MTC and its nominal frame rate.
If the deviation is significant, make sure that the correct frame rate is set in the General
Synchronization pane. If in doubt, set the frame rate to 24 fps and select “Auto detect
format of MTC” in the General pane. If the frame rate is correct, you can use this display
to adjust the tape speed of the machine transmitting timecode to the nominal value (the
same speed used when the timecode was recorded). Adjust the varipitch control on the
transmitter machine, until the slider is centered.

•

Sample Rate slider: Shows the deviation of the sample rate from its nominal value. Note
that some audio hardware doesn’t allow any variation in the sample rate.

•

Deviation slider: Shows the current phase deviation of the Word Clock from the
timecode transmitter—in other words, the deviation between audio and MIDI. Varying
timecode signals shown in this display indicate how Logic Pro regulates the sample rate
of the hardware when in MTC Continuous sync mode. Even large timecode variations
result in no deviation between audio and MIDI synchronization. Your audio hardware
must be capable of continuously variable sample rates for this to function. Small
deviations between audio and MIDI are unavoidable, because MIDI can (and should)
follow the timecode transmitter directly.
Note: The real-time sample rate conversion feature of Logic Pro allows it to follow an
external MTC signal (MTC Continuous), while maintaining the correct audio playback
pitch and speed. This feature works even when recording while receiving MIDI clock.
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•

Core Audio pop-up menu: Defines how your Core Audio hardware is synchronized to an
external timecode transmitter.
•

MTC Continuous: Audio regions are started in sync, and the sample rate is
continuously regulated to match variations in the timecode transmitter signal. Even
very long audio regions stay in sync in this mode.

•

MTC Trigger + Auto Speed Detection: Similar to MTC Trigger (see below), but
the tempo of the timecode transmitter is constantly monitored while Logic Pro is
running. The next time you start Logic Pro, it uses an adapted sample rate. This
mode keeps long regions in better sync with the timecode transmitter, although not
as closely as MTC Continuous. It does, however, use a constant sample rate, which
isn’t affected by variations in the timecode transmitter signal.

•

MTC Trigger: Audio regions are started in sync, but are then played at a constant
sample rate, regardless of any variations in the timecode transmitter signal.
Logic Pro always uses the set nominal sample rate (44.1, 48, 88.2, 96, 192 kHz).
This mode is suitable when it is vital to retain the absolute pitch of a recording. If the
speed of the timecode transmitter deviates from the nominal value, you may need to
split long audio regions into shorter sections.

•

External or Free: Logic Pro has no influence on the sample rate. The audio hardware
is responsible for ensuring that the position and sample rate of audio regions match.
This mode is advisable only if you’re sure the Word Clock and timecode transmitter
are running in sync—by using an external SMPTE or Word Clock synchronizer, for
example.

MIDI Synchronization settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, MIDI
Synchronization settings are available.
You can use these settings to synchronize external devices that receive MIDI clock from
Logic Pro. You can configure MIDI clock synchronization settings independently for up to
10 external devices.
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•

Destination pop-up menu: Sets the MIDI output port that receives MIDI clock signal.
Select “All” to use the same configuration for every MIDI output port.

•

Clock checkbox: Activates MIDI clock transmission for the MIDI output port shown in the
Destination field of that row.
MIDI clock can easily be sent with other normal MIDI events (notes and controllers, for
example). When using multi-port MIDI interfaces (such as the Unitor8), better timing is
achieved by sending MIDI Clock to All ports, rather than to several individual ports.
If MIDI clock is transmitted to all ports, the events are only sent once from the computer
to the interface. If you address individual ports, one event needs to be sent for each
port, placing a higher strain on the bandwidth of all ports.

•

Delay [ms] field: Use to delay the transmission of MIDI clock signals for the MIDI output
port of that row. Negative values mean that the MIDI clock signal is transmitted earlier.
This allows you to compensate for any reaction delays in external devices receiving MIDI
clock.

•

PDC checkbox: Activates plug-in delay compensation for the MIDI output port shown
in the Destination field of that row. This compensates for delays that can be introduced
when using software plug-ins.

•

MTC checkbox: Activates the transmission of MIDI timecode for the MIDI output port
shown in the Destination field of that row.
Note: If you can avoid it, you shouldn’t send MTC to all ports, as it’s very data intensive.
If possible, use a MIDI port that isn’t being used for anything else.

•

MMC checkbox: Activates transmission of MIDI Machine Control for the MIDI output port
shown in the Destination field of that row. These commands are then sent whenever you
operate the transport functions (Start, Stop, Rewind, and so on) of Logic Pro.
Note: MMC will only be sent to the MIDI output destination if the Transmit MIDI Machine
Control (MMC) checkbox is selected.
MMC is normally used when Logic Pro is receiving an external sync signal (for example,
MTC or MIDI clock) from an external device (such as an ADAT), and you want to use
Logic Pro to control the external device’s transport functions. Logic Pro therefore
transmits MMC and receives MTC simultaneously. If you want to use the transport
controls of the external device, you don’t need to transmit MMC. In this situation,
Logic Pro only receives MTC from the transmitting device. You can also use MMC to
record-enable tracks on the MMC receiver device.

•
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Clock Mode pop-up menu: Determines the MIDI clock transmission mode for
synchronized MIDI devices.
•

Pattern—Quantized Clock Start Based on Pattern Length: Sends a Start command
to begin sequencer playback from the beginning of the pattern. The length of the
pattern must be set in the “Clock Start: with a pattern length of ____ bar(s)” field.

•

Song—SPP at Play Start and Stop/SPP/Continue at Cycle Jump: Sends a Start
command if playback begins at the start of your song. Otherwise, a Song Position
Pointer and a Continue command are sent to begin sequencer playback.

•

Song—SPP at Play Start and Cycle Jump: Sends a Song Position Pointer command
when you start playback and every time Cycle mode repeats.

•

Song—SPP at Play Start Only: Sends a Song Position Pointer command only when
you begin initial playback.
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•

Clock Start: at position field: Defines the musical position at which the MIDI Clock
output should start. Every time you start playback, a Song Position Pointer (SPP)
message is also sent. Because not all devices can process SPP, the MIDI system realtime Continue message is also sent. The exception is when you start at position 1 1 1 1.
In this situation, the real-time Start message is sent.

•

Clock Start: with a pattern length of ____ bar(s) field: When Clock Mode is set to
“Pattern—Quantized Clock Start Based on Pattern Length” use this field to select the
length of the pattern in bars.

•

Transmit MIDI Machine Control (MMC) checkbox: Activates transmission of MIDI
Machine Control to all MIDI output destinations with MMC selected.

•

Listen to MIDI Machine Control (MMC) input checkbox: Controls Logic Pro by MIDI
Machine Control and so-called Full Frame Messages.
Logic Pro recognizes the following commands when listening to MMC Input:
•

Play

•

Deferred Play

•

Stop

Deferred Play is a special command for devices receiving MIDI clock that are
mechanically slow, such as reel-based tape recorders. Rather than having the machine
play immediately, it’s asked to reach the desired SMPTE position before playback is
started. There’s no noticeable difference in the response of Logic Pro to the Play and
Deferred Play commands, because Logic Pro can start playback at any position almost
instantly.
Logic Pro ignores these messages when incoming external MTC (MIDI Time Code)
commands are detected.
Logic Pro also obeys Full Frame Messages, and sets the playhead to a new location,
without starting playback. Once again, incoming MTC data has higher priority, if
conflicting information is received.
Some synchronizers send Full Frame Messages (instead of MTC) to locate the device
receiving MIDI clock (Logic Pro in this case) to a new position, without implicitly starting
playback. This is useful when in Slow Shuttle or Single Frame Advance mode with video
machines, because the device receiving MIDI clock is perfectly located, without being in
playback mode.
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•

Save as Default button: Saves the current MIDI synchronization settings and applies
them to all new projects.

•

MIDI Sync Preferences button: Opens the Sync tab of the MIDI Preferences window.
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Unitor Synchronization settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Unitor
Synchronization settings are available.
You can use these settings to edit the major synchronization parameters for the Unitor8
MIDI interface.

•

•

SMPTE Mode buttons: You can instruct the Unitor8 to read or write SMPTE data.
•

Read: Select to read SMPTE data.

•

Generate: Select to write SMPTE data.

SMPTE Mode Refresh checkbox: Activates Refresh mode, where fresh timecode is
generated, in sync with received timecode. Refresh mode works with both VITC and LTC
(see below). You should always use Refresh mode whenever you need to copy an LTC
track, because you can’t directly copy LTC without a considerable loss of quality. When
copying entire multitrack tapes, you should patch all tracks directly, but refresh the
timecode track via the Unitor8.
Note: You should only use Refresh mode if you are copying timecode.

•

•

SMPTE Type buttons: Define the SMPTE format that you want to use.
•

LTC: Longitudinal (also called Linear) Time Code is written to a tape track.

•

VITC: Vertical Interval (or Vertically Integrated) Time Code is written invisibly to a
videotape.

•

Off: No timecode is written.

Freewheel slider: Specifies how long the synchronizer continues transferring MTC to
the sequencer, after timecode ceases to be read. The freewheel parameter affects the
SMPTE reader. You can set the freewheel time (in frames) for LTC and VITC.
Long freewheel times can maintain synchronization, even if there are dropouts in the
timecode, but they also increase the reaction time of Logic Pro after the timecode
transmitter stops. In practice, you should set a value that’s as large as necessary (for
sustained operation), and as small as possible (to reduce waiting times).
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•

•

TV Format pop-up menu: Defines the television format for timecode burn-in.
•

PAL: The video format used in Europe, South America, most Asian and African
countries, and Oceania. If you’re working with video in SECAM format (used in
France and French-speaking nations in Africa), choose PAL.

•

NTSC: The video format used in the U.S., Central America, Japan, and Canada.

VITC Line 1 and VITC Line 2 pop-up menus: VITC is written into two lines of the video
picture, which are normally invisible. The lines should not be adjacent, and are usually
situated between 12 and 20.
If the Scan option is selected, the VITC lines are automatically recognized. You should
only enter the lines manually if there are problems with Scan mode.

•

Visible Timecode Display: Size pop-up menu: Sets the size of the timecode counter
window, which is burned in to the video picture.

•

Visible Timecode Display: Style pop-up menu: Sets the style of the timecode counter
window, which is burned in to the video picture.

•

Horizontal Position and Vertical Position sliders: Sets the position of the timecode
counter window, which is burned in to the video picture.

Metronome settings in Logic Pro

The Metronome project settings combine all parameters for speaker click, MIDI click, and
Klopfgeist—a virtual metronome sound source. Klopfgeist can be used in addition to, or in
place of, the speaker and MIDI click sources.
Note: Klopfgeist is a software instrument found in the Plug-in pop-up menu of instrument
channel strips. Klopfgeist is inserted into instrument channel 256 by default. Logic Pro
automatically creates instrument channel 256 (and inserts Klopfgeist) when the Software
Click Instrument (Klopfgeist) checkbox is selected. Theoretically, any other Logic Pro or
third-party software instrument could be used as a metronome sound source on instrument
channel 256. For full details about Klopfgeist, see Logic Pro Instruments.

•
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Simple mode checkbox: When Simple mode is enabled, the metronome clicks only when
you toggle the metronome on, and the other metronome settings are unavailable.
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•

Click while recording checkbox: Turns the metronome on during recording. This is the
same as clicking the Metronome button in the control bar.

•

Only during count-in checkbox: The metronome is only audible during the project
count-in, and is then turned off.

•

Click while playing checkbox: Turns the metronome on during playback. This is the
same as clicking the Metronome button in the control bar.

•

Polyphonic clicks checkbox: The metronome sends notes, as defined for bars, beats,
and divisions. Two or three notes may be sent simultaneously at the beginning of each
measure, for example. If this option is unselected, the metronome transmits only one
note at a time.

•

Audio Click (Klopfgeist) checkbox: Turns the Klopfgeist metronome on or off.

•

Note field: Defines the note number of generated notes.

•

Velocity field: Defines the velocity of generated notes.

•

Tone slider: Changes the sound of the virtual metronome from a short click to a pitched
percussion sound, similar to a wood block or claves.

•

Volume slider: Sets the output level of the virtual click sound.

•

Output pop-up menu: Allows you to route the Klopfgeist metronome sound to a different
set of hardware outputs, if the audio hardware has more than two outputs.

When Enable Complete Features is selected in Advanced preferences, the following are
available:
•

Bar checkbox: Generates separate note events for bars.

•

Group checkbox: For compound and composite signatures, generates note events for
each group.

•

Beat checkbox: Generates separate note events for beats.

•

Division checkbox: Generates separate note events for divisions.

•

Channel field: Defines the MIDI channel of generated notes.

•

Note field: Defines the note number of generated notes.

•

Velocity field: Defines the velocity of generated notes.

•

MIDI Port pop-up menu: Choose a direct MIDI output port (or all ports) for the
metronome.

Note: To have the metronome play clicks on each beat for simple meters, and play clicks
only for each group on compound and composite meters, select the Group checkbox and
deselect the Beat checkbox.
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Smart Tempo settings in Logic Pro

These settings determine the default behavior for Smart Tempo.

•

Project Tempo Mode pop-up menu: Choose the Project Tempo mode (Keep, Adapt, or
Automatic).
•

Keep Project Tempo: The project tempo is maintained when you record audio or
import audio files. This behavior is identical to that of previous versions of Logic Pro.

•

Adapt Project Tempo: The project tempo adapts to the tempo of new regions that
don’t match the project tempo.

•

Automatic Mode: Automatic Mode uses Keep or Adapt behavior depending on
whether the metronome is active and if regions are present, among other factors.

Defaults for Flex & Follow Region Setting

The Flex & Follow region parameter determines whether regions are Flex enabled, and
whether they follow the project tempo. You can choose the default settings for new
recordings and imported files with the pop-up menus below.
•

Set New Recordings To pop-up menu: Sets the Smart Tempo behavior when recording
new audio.
•

Off: Smart Tempo does not analyze the tempo of new recordings.

•

On: Smart Tempo analyzes the tempo of the recorded audio and places tempo
markers at each point a tempo change is detected.

•

On + Align Bars: Smart Tempo analyzes the tempo of the recorded audio, and places
a tempo marker at each bar a tempo change is detected.

•

On + Align Bars and Beats: Smart Tempo analyzes the tempo of the recorded audio,
and places a tempo marker at each beat a tempo change is detected.

•

Trim start of new regions checkbox: Automatically sets the start of newly recorded
regions to the first downbeat of the file.

•

Set Imported Files To pop-up menu: Sets the Smart Tempo behavior when importing
audio files into your project.
•
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Off: Smart Tempo does not analyze the tempo of imported audio files.
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•

•

On: Smart Tempo analyzes the tempo of imported audio files and places tempo
markers at each point a tempo change is detected.

•

On + Align Bars: Smart Tempo analyzes the tempo of imported audio files and places
a tempo marker at each bar a tempo change is detected.

•

On + Align and Beats: Smart Tempo analyzes the tempo of imported audio files and
places a tempo marker at each beat a tempo change is detected.

Trim start of new regions checkbox: Automatically sets the start of imported audio files
to the first downbeat of the file.

Options

These additional options let you create a matching Edit group when creating a Multitrack
Set and choose the resolution of exported tempo information.
•

Create matching Editing group when creating Smart Tempo multitrack set checkbox:
Combines all the audio files used to create the multitrack set into a single group for
editing.

•

Export Tempo Resolution pop-up menu: Choose the resolution of the exported tempo.
•

Smoothed: Exports a tempo that smoothes out jumps in tempo from beat to beat.

•

Beats: Exports the tempo information at each beat without any smoothing.

Recording settings in Logic Pro

When Enable Complete Features is selected in Advanced preferences, Recording
settings are available.

•

•

Logic Pro User Guide

When Beginning buttons: Use to choose between a count-in or pre-roll period when
starting to record.
•

Count-in: Select to set the “Count-in” pop-up menu to set the count-in period that
precedes a recording.

•

Record pre-roll: Select to set a pre-roll time in seconds, either by typing a number or
clicking the arrows. When recording, this value is deducted from the current project
position.

Count-in pop-up menu: Sets the count-in period that precedes a recording.
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•

None: The recording begins with no count-in.

•

x Bar: The recording begins with a count-in of between 1 Bar and 6 Bars (chosen
from the pop-up menu).

•

x/4: The count-in’s time signature can be set here. These settings are useful when
the count-in falls across a bar change.

•

Allow tempo change recording checkbox: Records all tempo changes made while in
record mode.

•

Automatically colorize takes checkbox: Assigns a take folder the color chosen from the
Color palette for the first take recording, but different colors for each of the following
takes in that take folder. All colors used in a take folder are chosen from the same color
row in the Color palette, advancing by a predefined number of columns after each take.

•

MIDI data reduction checkbox: Controller events are thinned out during recording, to
reduce the data load on the MIDI bus during playback. This improves the timing of
dense arrangements when using interfaces with only a few MIDI ports. The function
actually reduces the duration of controller events, using an intelligent algorithm which
retains the value at the end of a series of controller messages.

•

Automatically erase duplicates checkbox: When selected, playing or adding a note to a
MIDI region, either through step recording or merging, at the same position, pitch, and
MIDI channel as an existing note, deletes the previous note. For the purposes of this
function, the same position is defined as two notes with the same quantized playback
position if both notes have been quantized, or within 100 ticks if quantization is not
being used.

•

Audio Recording Path buttons: Use to set or reset the audio recording path.

•

•

Set button: Allows you to select or create a recording folder outside of the project.

•

Project button: Resets the recording path back to the project.

Recording Preferences button: Opens the Recording preferences window.

Tuning description and settings
Overview of tuning in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Tuning settings
are available.
The 12-tone scale used in Western music is a development that took centuries. Hidden in
between those 12 notes are a number of other microtones—different frequency intervals
between tones.
To explain, look at the harmonic series: Imagine that you have a starting (or fundamental)
frequency of 100 Hz (100 vibrations per second). The first harmonic is double that, or
200 Hz. The second harmonic is found at 300 Hz, the third at 400 Hz, and so on. Musically
speaking, when the frequency doubles, pitch increases by exactly one octave (in the
12-tone system). The second harmonic (300 Hz) is exactly one octave—and a pure fifth—
higher than the fundamental frequency (100 Hz).
From this, you could assume that tuning an instrument so that each fifth is pure would be
the way to go. In doing so, you would expect a perfectly tuned scale, as you worked your
way from C through to the C above or below.
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The following table provides a summary of the various calculations.
Note

Frequency (Hz)

Notes

C

100

x 1.5 divided by 2.

C#

106.7871

Divide by 2 to stay in octave.

D

112.5

Divide by 2 to stay in octave.

D#

120.1355

Divide by 2 to stay in octave.

E

126.5625

Divide by 2 to stay in octave.

F (E#)

135.1524

F#

142.3828

Divide by 2 to stay in octave.

G

150

x 1.5 divided by 2.

G#

160.1807

A

168.75

A#

180.2032

B

189.8438

C

202.7287

As you can see from the table, although the laws of physics dictate that the octave
above C (100 Hz) is C (at 200 Hz), the practical exercise of a (C to C) circle of perfectly
tuned fifths results in a C at 202.7287 Hz. This is not a mathematical error. If this were
a real instrument, the results would be clear. As a workaround, choose between the
following options:
•

Each fifth is perfectly tuned, with octaves out of tune.

•

Each octave is perfectly tuned, with the final fifth (F to C) out of tune.

Detuned octaves are more noticeable to the ears, so your choice should be obvious.

The comma and equal temperament in Logic Pro
The difference between a perfectly tuned octave and the octave resulting from a tuned
circle of fifths is known as the comma. Over the centuries, numerous approaches have
been tried to solve this mystery, resulting in a range of scales (before arriving at equal
temperament—the 12-tone scale). Other historical temperaments that have been devised
emphasize different aspects of harmonic quality. Each compromises in some way or
another. Some maximize pure thirds (Mean Tone) while others emphasize pure fifths at
the expense of the thirds (Kirnberger III, for example). Every temperament has its own
character, and a given piece of music may sound fine in one key but awful in another.
Transposing a piece to a new key can completely change its character. Careful attention
must be paid to the selection of temperaments for authentic performances of historic
keyboard music. The wrong choice could result in an unsatisfactory and historically
inaccurate musical experience.
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Equal temperament takes the tuning error (the comma), and spreads it equally between
each step of a chromatic scale. The result is actually a scale of equally mistuned intervals,
with no interval grossly out of tune, but none in perfect tune. Equal temperament has
become the de facto standard for two main reasons:
•

Convenience: Retuning an instrument to a temperament that is better suited for a
particular piece of music is a hassle. Many instruments are not capable of being
alternately tuned—fretted string instruments, for example.

•

Portability: All Western musical pieces can be performed (adequately) on an instrument
tuned to equal temperament. Obviously, some of the nuances may be missing in pieces
that were originally performed in another temperament.

Hermode Tuning in Logic Pro
Hermode Tuning automatically controls the tuning of electronic keyboard instruments (or
the Logic Pro software instruments) during a musical performance. In order to create clear
frequencies for every fifth and third interval in all possible chord and interval progressions,
a keyboard instrument would require far more than 12 keys per octave. Hermode Tuning
can help with this problem: It retains the pitch relationship between keys and notes, while
correcting the individual notes of electronic instruments, ensuring a high degree of tonal
purity. This process makes up to 50 finely graded frequencies available per note, while
retaining compatibility with the fixed tuning system of 12 notes per octave.
Frequency correction takes place on the basis of analyzed chord structures. The positions
of individual notes in each chord are analyzed, and the sum of each note’s distance to
the tempered tuning scale is zeroed. In critical cases, different compensation functions
help to minimize the degree of retuning, at the expense of absolute purity, if necessary.
For example:
•

The notes C, E, and G form a C major chord.

•

To harmonically tune these, the third (the E) must be tuned 14 cents lower (a cent is
1/100th of a tempered semitone) and the fifth (the G), needs to be 2 cents higher.

It should be noted that Hermode Tuning is dynamic, not static. It is continuously adjusted
in accordance with the musical content. This is done because, as an alternative to
tempered, or normal, tuning, fifth and third intervals can also be tuned to ideal frequency
ratios: The fifth to a ratio of 3:2, the major third to 5:4. Major triads then sound strong.
With clean (scaled) tuning, Hermode Tuning changes the frequencies to values that are
partly higher or partly lower.
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Tuning settings in Logic Pro
Logic Pro includes a real-time tuning system, for use with the included software
instruments. You can configure the tuning system in the Tuning settings.

•

Software Instrument Pitch: Tune slider: Determines the global tuning of all software
instruments. The default is concert pitch A (440 Hz). Detuning is in cent (1/100th of a
semitone) steps.

•

Software Instrument Scale: Equal Tempered: Disables any tuning, and uses an equal
tempered scale.

•

Software Instrument Scale: User: Allows you to detune each semitone in steps. Drag
vertically in each semitone box until you reach the value you want, or double-click in a
box and enter a value. Click the Reset button to reset all of your tuning adjustments to
their default values.

•

Software Instrument Scale: Hermode Tuning (HMT): Allows you to set different Hermode
Tuning (HMT) modes and degrees of effect. Select this when you wish to adjust the
purity of 3rd and 5th intervals between notes while retaining the pitch relationship
between keys and notes.

When Enable Complete Features is selected in Advanced preferences, the following are
available:
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•

Software Instrument Scale: Fixed: Activates a number of fixed tuning scales and keys.
Fixed Tuning mode tunes musical keys (to different degrees) for scaled tuning systems,
and delivers a key signature character. When playing mostly white keys (in the Pure
setting, and with C as the root key), C major is the main focus, and tuning is scaled to
that chord. An A major chord that is played immediately after a C major (and is therefore
subject to C major scaled tuning) is affected somewhat by the scaled tuning effect, but
do not sound completely tempered. If you normally play polyphonic music, this mode
(when using the Pure setting) sounds most pleasing to your ears. The Fixed Tuning
scales are ideal for a number of Baroque and Medieval instruments and styles of music.

•

Fixed: Type pop-up menu: Offers the most important historic tuning scales, as well as a
few others.
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•

Fixed: Root Key pop-up menu: Allows you to choose a global key (C-B) for the chosen
scale. This provides an easy way to reference the chosen scale to any root note.

•

User: Stretch Upper slider: Determines the deviation (from the equal tempered scale)
in the treble end of the sound. The higher the value, the farther down the low notes are
tuned. A setting of 0 results in an equal tempered scale tuning.

•

User: Stretch Lower slider: Determines the deviation (from the equal tempered scale)
in the bass end of the sound. The higher the value, the farther down the low notes are
tuned. A setting of 0 results in an equal tempered scale tuning.

•

User: Root Key pop-up menu: Allows you to choose a global key (C-B) for the chosen
scale. This provides an easy way to reference the chosen scale to any root note.

•

Hermode Tuning (HMT): Type pop-up menu: Allows you to set different Hermode Tuning
modes.

•
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•

Classic (3/5-all): This mode provides a broad and regular tuning of pure 5ths and
3rds. In cases of conflict, the degree of purity is temporarily reduced. This mode
can be used for all types of music. The value of the Depth parameter indicates the
degree of the 5th and 3rd purity. A setting of 100% determines maximum purity.
A 10% value is the lowest purity setting. Off sets the tuning to an equal tempered
scale.

•

Pop/Jazz (3/5/7-all): 5ths, 3rds, and 7ths are changed in this mode. It’s great for
Pop and Jazz styles, especially when using sustained chords. It’s less suitable for
polyphonic music, as the detuning of the natural 7th is significant. This mode should
always be used with a Depth of 90% or 100%, as other values render the natural 7th
acoustically ineffective.

•

Baroque (3/5-adaptive): This mode tunes pure 5ths and 3rds (with changing
characteristics). In tonal music, with a clear harmonic center, the middle chords are
tuned very purely, whereas more distant chords are tuned with less purity. If the
harmonic center becomes unclear, all chords are tuned with equal purity. As with the
other mode parameters, a Depth value of 100% determines the highest purity, and a
value of 10%, the lowest purity.

Hermode Tuning: Depth slider: Allows you to set degrees of effect between 0% and
100%.

1026

Audio Settings
General Audio settings in Logic Pro
General Audio settings are used to determine the audio behavior in Logic Pro.

•

Sample Rate pop-up menu: Use to choose the sample rate for the project.

•

Spatial Audio pop-up menu: When you choose Dolby Atmos, all channels set to Stereo
Output are automatically set to Surround. For more information on spatial audio, see
Spatial audio overview.

•

Apple Loops: High quality checkbox: This setting enables a newer, better sounding
Apple Loops playback algorithm introduced with Logic Pro X 10.4. The setting is
disabled when opening projects created in older versions of Logic to ensure they sound
like they did originally.

When Enable Complete Features is selected in Advanced preferences, the following
settings are available:
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•

Surround Format pop-up menu: Use to choose the surround format for the project. For
more information on surround formats, see Surround formats overview.

•

Pan Law pop-up menu: Signals panned to the center position may sound louder than
signals panned hard left or right. The Pan Law value determines the amount of volume
reduction on signals that are panned to the center. You can choose from the following
settings:
•

0 dB: With no change to the volume level, signals seem louder when panned to the
center position, in comparison with extreme left or right pan positions.

•

–3 dB: A full scale signal (0 dBfs) has a level of –3 dB when panned to the center
position.

•

–3 dB Compensated: A full scale signal (0 dBfs) has a level of 0 dB when panned to
the center position (or +3 dB when panned to the extreme left or right positions).

•

-4.5 dB: A full scale signal (0 dBfs) has a level of –4.5 dB when panned to the center
position.

•

-4.5 dB Compensated: A full scale signal (0 dBfs) has a level of 0 dB when panned to
the center position (or +4.5 dB when panned to the extreme left or right positions).

•

-6 dB: A full scale signal (0 dBfs) has a level of –6 dB when panned to the center
position.

•

-6 dB Compensated: A full scale signal (0 dBfs) has a level of 0 dB when panned to
the center position (or +6 dB when panned to the extreme left or right positions).
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•

Apply Pan Law compensation to stereo balancers checkbox: Applies the Pan Law
compensation chosen from the Pan Law pop-up menu to Stereo Balance controls. For
more information on Stereo Balance controls, see Set channel strip pan or balance
positions.

Channel Strips Audio settings in Logic Pro
Channel Strips Audio settings are used to determine the behavior of channel strips in
Logic Pro.

When Enable Complete Features is selected in Advanced preferences, the following
settings are available:
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•

Automatic management of channel strip objects checkbox: Makes the creation and
management of tracks and channel strips a transparent experience. You should deselect
this setting only when you need to make manual changes to channel strips in the
Environment window.

•

Automatic naming of channel strip objects checkbox: Allows the automatic naming of
channel strips according to the last loaded setting, until the user enters a channel strip
name manually.
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MIDI settings
General MIDI settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, General
MIDI settings are available. The General pane of the MIDI project settings contains the
following settings:

•

Control change message 7/10 sets Volume fader/Pan knob for channel strips checkbox:
When selected, MIDI Control Change message #7 controls channel strip volume and
MIDI CC#10 controls channel strip pan position. Enabling this setting might interfere
with MIDI plug-ins and Smart Control mappings.

•

Instrument Without MIDI Thru Function pop-up menu: The instrument selected here
does not pass events through the computer when the instrument is assigned to the
selected track. Normally, you would set the No Output instrument here (chosen by
default).
If your master keyboard doesn’t have a Local Off setting, you can use this feature to
avoid unwanted note doubling when recording:
•

With multi-timbral sound sources, assign the instrument (usually channel 1) that
plays the part that is heard when playing with the computer turned off.

•

With mono-timbral sound sources, assign the instrument that represents the soundgenerating part of your master keyboard.

In either case, you should turn down the volume control of your master keyboard
whenever you’re recording tracks for any other instrument.
It’s possible to disable MIDI Thru for any MIDI track in the Main window, by simply
disabling the Record Enable button beside the track name.
When Enable Complete Features is selected in Advanced preferences, the following are
available:
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•

Send After Loading Project: Used instrument MIDI settings checkbox: Sends the active
instrument MIDI settings automatically after loading a project.

•

Send After Loading Project: All fader values checkbox: Sends all Environment fader
values automatically, once a project is loaded.
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•

SysEx with MIDI Thru function checkbox: Incoming SysEx messages are passed through
the computer to the MIDI outputs, along with other MIDI data. This is particularly
important when using hardware programmers, as you can immediately monitor
parameter changes to the synthesizer you’re editing.
If you want to record SysEx dumps, do not select this checkbox. It rarely makes
sense to divert dumps through the computer unless you want to record a dump and
simultaneously transmit it to a second device of the same type.

Input Filter settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Input Filter
settings are available.
These settings let you control which event types are filtered.

•

Notes checkbox: Use to filter out notes from incoming MIDI data.

•

Program changes checkbox: Use to filter out Program Change messages from incoming
MIDI data.

•

Pitch Bend checkbox: Use to filter out Pitch Bend messages from incoming MIDI data.

•

Control Changes checkbox: Use to filter out Control Changes messages from incoming
MIDI data.

•

Aftertouch checkbox: Use to filter out Aftertouch messages from incoming MIDI data.

•

Polyphonic Aftertouch checkbox: Use to filter out Polyphonic Aftertouch messages from
incoming MIDI data.

•

System Exclusive checkbox: Use to filter out program change messages from incoming
MIDI data.

To learn more about MIDI data in the Event List, see Edit events overview.
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Chase settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, MIDI Chase
settings are available.
If you start playback in the middle of a project, some events might not be heard (such
as notes, sustain pedal events, and pitch bend events that start before the point where
playback begins). Using the Chase Events function, you can have Logic Pro analyze the
project and include some or all of these events when the project plays back.
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•

Notes checkbox: Sends any notes due to start playing at the playback start point.

•

Notes: Sustained checkbox: Sends any notes that are still playing at the playback start
point (due to a sustain pedal event).

•

Notes: In No Transpose instrument channel strips checkbox: Instrument channel strips
(particularly drums) can be assigned No Transpose status in the inspector. This is a
playback parameter that is ignored if the region containing the instrument notes is
started midway through.

•

Program Change checkbox: Sends any program changes in regions that fall across the
playback start point.

•

Pitch Bend checkbox: Sends pitch bend events that immediately precede the playback
start point.

•

Control Changes, 0-15, 64-71, and All Other checkboxes: Select to search for
continuous controllers 0 to 15, continuous switch controllers 64 to 71, or all other
controllers.

•

Aftertouch checkbox: Looks for monophonic (channel) aftertouch messages.

•

Polyphonic Aftertouch checkbox: Scans for polyphonic aftertouch messages.

•

System Exclusive checkbox: Transmits the most recent SysEx message before the
playback start point.

•

Text Meta Events checkbox: Transmits the most recent Text Meta Event message before
the playback start point.
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•

Chase separate channels in All Channels instruments checkbox: Scans for events
on each MIDI subchannel, rather than the global multi-instrument channel. Multiinstruments (found in the Environment) have a global channel, and can have up to 16
MIDI subchannels.

•

Chase on cycle jump checkbox: Scans for, and sends, all event types if the cycle start
and end points fall across regions.

•

Chase on cycle jump: Notes checkbox: Limits cycle jump scan to note events.

•

Send full MIDI reset before chasing checkbox: Sends a MIDI reset message before
chasing, ensuring that all MIDI devices being triggered are set to their defaults.

Clip Length settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, MIDI Clip Length
settings are available.
Clip Length settings let you control how Logic Pro handles various MIDI messages at the
end of a MIDI region.
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•

Aftertouch to zero checkbox: Sets the Aftertouch MIDI message to zero at the end of
the MIDI region.

•

Pitch Bend to center position checkbox: Sets the Pitch Bend MIDI message to the center
position at the end of the MIDI region.

•

Control 1 (Modulation) to zero checkbox: Sets the Control 1 (Modulation) MIDI message
to zero at the end of the MIDI region.

•

Control 2 (Breath Control) to zero checkbox: Sets the Control 2 (Breath Control) MIDI
message to zero at the end of the MIDI region.

•

Control 4 (Foot Control) to zero checkbox: Sets the Control 4 (Foot Control) MIDI
message to zero at the end of the MIDI region.

•

Control 11 (Expression) to max checkbox: Sets the Control 11 (Expression) MIDI
message to its maximum value at the end of the MIDI region.
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Score settings
Global Score settings in Logic Pro
Global Score settings define global formatting options, such as page margins, note
spacing, bars per line, and more.

When Enable Complete Features is selected in Advanced preferences, the following
are available:
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•

Top, Bottom, Left, and Right Margin fields: These values show the margin distances
(in cm or inch) to the outer border of the printable area on the page. A “Top Margin
0.0 inches” value means that printing starts as close to the top of the paper as the
selected printer driver allows. This also means that the size of the printable area can
vary between printers, although the difference should be minimal.

•

Add bracket space checkbox: Creates additional space between the left margin line
and the beginning of staffs, for braces and brackets. If unselected, staffs are aligned
directly along the left margin line.

•

Alternating margins checkbox: If selected, the left and right page margin settings are
swapped on every second page. This can be useful if a score is going to be bound as a
book: The inner margin usually needs to be a little bigger than the outer one. It’s also
possible that the opposite might be preferable, in cases where extra space is needed
for remarks that may be added to the score at a later date.
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•

Header Space field: Defines the height reserved for headers, between the top margin of
the first page and the top margin of the first staff on the page (as per the assigned staff
style).
Note: Text objects inserted directly into this area automatically become global text
elements, and are displayed as headers in all score sets (full scores and parts).
You can also be change this value directly in the score, by dragging the purple line
above the first staff.

•

Line Distance field: Defines additional vertical distance between staff systems (single,
multiple, or bracketed staffs can constitute a system) on the same page. It applies to
full scores, as well as single staff parts.

•

Maximum Bars/Line field: This parameter can be useful when using small spacing values
(see below), to prevent too many bars from being displayed on one line. The number set
here limits the number of bars that can be displayed per line.
Note: This setting can be overridden when using the Layout tool to change line breaks.

•

Constant Spacing field: Determines the amount of horizontal distance between notes,
affecting the distance from note to note, regardless of rhythmic value.

•

Proportional Spacing field: Determines the amount of horizontal distance between
notes, taking the note durations into consideration.
If you only use Proportional Spacing (and set Constant Spacing to 0), every bar receives
the same amount of horizontal space. A whole note uses as much space as four quarter
notes. In the opposite situation (high constant value, proportional value set to 0), the
distance from one note to the next is always the same, regardless of note duration. A
half note takes the same amount of space as an eighth note. Other factors, such as
accidentals, ties, and so on, are also considered for note distance calculations.

•

Slash Spacing field: This is the distance parameter for slashes (used in staff styles that
display beat slashes instead of automatic rests), and is important when inserting notes
into staffs that display slashes. For example, musical styles such as funk use a lot of
sixteenth notes, so you are likely to choose a higher slash distance than you would for
music that doesn’t go beyond eighth notes. This way, the proper relationships between
notes and passages (containing only slashes and chord symbols) can be maintained.

•

Beaming Slant Factor, Minimum Slant, and Maximum Slant fields: These three
parameters affect the slant angle of beams. As with the Spacing parameters, these
parameters work together. Appropriate settings need to be found by trying different
combinations. The final settings vary, depending on the style of the music and on
personal preference.
•

Beaming Slant Factor field: Determines the general amount of beam slanting, in
relation to the intervals of the notes connected by beams.

•

Minimum Slant field: Determines the minimum interval of notes that causes beams to
be slanted.

•

Maximum Slant field: Determines the maximum beaming slant angle.

These parameters work relative to a particular scoring situation, which is why no explicit
settings can be given. Again, it’s essential to try different combinations when working
on the final layout of a piece.
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•

Default Pedal Position field: Determines the vertical position of automatic pedal symbols
(those created when you use the MIDI sustain pedal during a real-time recording). If set
to zero, recorded MIDI sustain pedal events are hidden in the score. Pedal marks that
you manually insert from the Part box are not affected by this parameter.

•

Open single staffs checkbox: Displays single staffs without vertical lines at their start
point (left side of the clef).

•

Justify last staff checkbox: Lengthens the last line (the last staff system, in full scores)
to the right page margin.

•

Alternate repeat symbols checkbox: If selected, all repeat signs in the project are
displayed with real book-style brackets.

•

Hide muted notes checkbox: Excludes muted notes from the score display. If
unselected, muted notes are displayed in the score, even though they won’t be heard
during MIDI playback.

•

Hide muted regions checkbox: Excludes muted regions from the score display. If
unselected, muted regions are displayed in the score, even though they won’t be heard
during MIDI playback.

•

Hide muted tracks checkbox: Excludes muted tracks from the score display. If
unselected, muted tracks are displayed in the score, even though they won’t be heard
during MIDI playback.

•

Choose Font pop-up menu: Choose from any installed scoring (symbol) fonts, such as
the Sonata font.

•

Font-specific spacing and positioning checkbox: If selected, the Score Editor displays
symbols with spacing and positioning specific to the chosen symbol font.

•

Score Preferences button: Opens the Score preferences window.

•

Allow alias/loop editing checkbox: Switches alias/loop editing on or off.

•

Fill gaps checkbox: Fills gaps between regions to display a continuous staff.

•

Breve pop-up menu: Choose from four different shapes of breve notes, as well as the
default no breve setting (which disables any breve notes).
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Numbers & Names settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Score Numbers
and Names settings are available.
These settings affect the automatic display of page numbers, bar numbers, and instrument
names in the score.

Page Numbers settings
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•

Page Numbers checkbox: Turns on the display of page number parameters.

•

Horizontal Position pop-up menu: Alters the horizontal alignment on the page.
•

Alternating: Alternating, beginning on the right side

•

Left, Right, or Centered: Self-explanatory

•

Reverse Alternating: Alternating, beginning on the left side

•

Vertical Position pop-up menu: Alters the vertical alignment on the page. You can
choose either Top or Bottom.

•

Page Offset field: This value is added to each actual page number, for display purposes.
This setting can be useful when writing a piece consisting of several parts, which are
saved as separate project files. To retain continuous page numbers throughout the
score, set this parameter to the number of pages contained in all preceding parts
(project files).

•

Horizontal Distance field: The horizontal distance from the outermost printing position
on the page. This is only relevant for page numbers with the Horizontal Position
parameter set to Alternating or Rev. Alternating.

•

Vertical Distance field: The vertical distance to the highest or lowest printing position
on the page (depending on whether Vertical Position is set to Top or Bottom).
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•

Hide first page number checkbox: Prevents the display (and printout) of the page
number on the first page. (All others are displayed and printed.)

•

Page Numbers Font Choose button and field: Click this button to choose a page number
font. The chosen font, style, and size is displayed in the font field.

•

Prefix checkbox: Select to enter text that is displayed with every page number.
For example, if you use the prefix Page, the word Page, followed by a space and the
actual page number, is displayed on each page. This means that page three displays
Page 3. If you want the page number in the middle of the prefix, you need to use the #
symbol as a variable for the page number. For example, “- pg.# -” on the second page
prints as “- pg.2 -.”
You can also use the following text symbols to include automatically generated text in
the prefix:
•

“\ i” for the score set name

•

“\ n” for the project (file) name

•

“\ s” for the name of the currently shown display level, which can be the MIDI region
or folder name (or even the project name, on the highest level)

•

“\ d” for the current date (at the time of printout)

Bar Numbers settings
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•

Bar Numbers checkbox: Select to turn on the display of bar number parameters.

•

Horizontal Position pop-up menu: Choose either At Bar Line or At Bar Center.

•

Vertical Position field: The height above the staff. If a negative value is set here, the bar
numbers are placed below the staff.

•

Step field: This value controls the interval (in bars) between the display of bar numbers.
A value of 4, for example, results in bar numbers at the first, fifth, ninth bar, and so on.
If you only want bar numbers to be displayed at the beginning of each staff line, set this
parameter to 0.

•

Bar Offset field: This value is added to all actual bar numbers, for display.

•

Bar Numbers Font Choose button and field: Click this button to choose a bar number
font. The chosen font, style, and size is displayed in the font field.

•

Start With field: Automatic numbering begins at the bar indicated here.

•

Hide bar numbers in linear view checkbox: Hides the bar numbers in non-Page Score
view.

•

Follow staff size checkbox: Displays bar numbers according to staff size.

•

Count multiple rests checkbox: Displays the first and last bar number below multiple
rests. This makes sense if a negative Vertical Position value is chosen, causing bar
numbers to be shown below staffs.

•

Show at double bars checkbox: Displays bar numbers at every double bar line and
repeat sign, independent of the chosen Step setting. For example, if Step is set to 0
(and Double Bars is activated) bar numbers are displayed at the beginning of each staff
line, and above or below all double bar lines and repeat signs.

•

Top/bottom staff only checkbox: In full scores, the bar number is only displayed above
the top staff, if this option is selected. (A negative Vertical Position value results in the
number being shown below the bottom staff.)
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Instrument Names settings
•

Instrument Names checkbox: Select to turn on the display of instrument name
parameters.

•

Position pop-up menu: Choose from Above Staffs or Beside Staffs.

•

Align pop-up menu: Refers to the space preceding staffs. Choose either Left (at the left
margin) or Right (at the right margin).

•

First Staff pop-up menu: Choose one of the following to display the instrument name at
the first staff: No Names, Short Names, or Full Names.

•

Other Staffs pop-up menu: As above, for other staffs.

•

Instrument Names Font Choose button and field: Click this button to choose an
instrument names font. The chosen font, style, and size is displayed in the font field.

Tablature settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Score Tablature
settings are available.
Tablature is a method of notating music for fretted string instruments—especially for guitar
and electric bass—but also for other fretted instruments. In this system, the horizontal lines
represent the strings of the instrument. Notes are always written on the line/string at which
they are played. The fret numbers are shown instead of regular note heads. Logic Pro
automatically converts notes into tablature, if a staff style containing a Clef parameter
set to one of these tuning sets is used. The exact characteristics of these tuning sets are
determined in the Tablature pane.

Twelve different tuning sets can be defined. Each of them corresponds to one line in this
pane. The regular guitar and bass tunings are already included as defaults (first line and
last five lines), as are some of the more common guitar tunings.
Logic Pro User Guide
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Tuning set parameters
•

Name field: Double-click to change the name in the text field.

•

Strings pop-up menu: Choose the number of strings (between 3 and 16).

•

Assign pop-up menu: Select the method for automatically assigning notes to strings.

•

String Pitch fields: Double-click to type, or drag vertically to select, the pitch that the
open strings are tuned to.
Note: Up to eight fields are shown directly within the pane. If more than eight are
selected, you can move the visible section by clicking the arrows, or dragging the
scroller.

Common parameters
•

Head Style button group: Choose one of these four head styles:
•

Numbers only

•

Numbers in circle

•

Circle 1/1, 1/2 notes only

•

Black and white (1/1, 1/2 notes) circles

•

Bass String buttons: Click to determine the display of the lowest string. It may be the
same as other strings, or slightly thicker.

•

Up and Down Strum buttons: Click to change the style of the Up and Down Strum
objects displayed in the Chord Grid and Tablature Markings Part box.

•

Font field: Click the Choose button to choose the common tablature font. The chosen
font is displayed in the Font field.

TAB Markings parameters
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•

Palm Mute field: Customize the name, font, and size of the Palm Mute object in the
Chord Grid and Tablature Markings Part box.

•

Let Ring field: Customize the name, font, and size of the Let Ring object in the Chord
Grid and Tablature Markings Part box.

•

Slap field: Customize the name, font, and size of the Slap object in the Chord Grid and
Tablature Markings Part box.

•

Line pop-up menu: Adjust the line: solid, dashed, or dotted.

•

Font field: Click the Choose button to choose the font for the TAB markings. The chosen
font is displayed in the Font field.
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Determine the string assignment

Because most notes can be played at different positions (frets) on different strings, the
Assign parameter in the Tablature pane performs an essential role. In most cases, the
MIDI channels of the individual notes determine the string assignment. The MIDI channel
parameter of an individual note has no impact on MIDI playback. The playback channel is
determined in the Track inspector, found in the Main window.
Click in the Assign column (for the corresponding Tuning Set), and choose from the
following string assignment options:
•

Pitch
Logic Pro assigns each note to the string on which it is playable, at the lowest
possible position. In order to influence the string assignment, there is a rule (in Pitch
mode only) that a note’s fret position cannot be lower than its MIDI channel.
This method is generally used when notes are recorded from a MIDI keyboard:
•

An A3 (on MIDI channel 1) is displayed on the second fret of the G string. If you
want the note to be displayed at a higher position (to correctly display the proper
fingering of a passage), you need to set its channel to 3 or higher. This means
that the fret position cannot be lower than 3, so the note is displayed at the D
string’s seventh fret.

•

If the channel is between 8 and 12, the A3 is assigned to the A string on the 12th
fret, and to the low E string (17th fret) for channels 13 to 16.

If you want to force even higher positions, you need to use one of the other
assignment modes.
•

Channel
In this mode, the number of the string (1 to 6, counted from the lowest string)
corresponds to the MIDI channel. Channels 7 to 16 are assigned to the highest
string.

•

Inv. Channel
Like Channel, but counted from the highest string (1) to the lowest (6 and above).
This way of numbering the strings is generally used in traditional guitar tablature.
Note: Because most Guitar-to-MIDI Converters send notes (played on different
strings) on different MIDI channels, the Channel and Inv. Channel modes are suitable
if you’re using a MIDI guitar to record MIDI regions. The tablature notation is
displayed exactly as the music was played during recording.

•

Inv. Ch–1 and Inv. Ch–2
These modes should be used when recording and notating electric bass parts with
Guitar-to-MIDI Converters.
•

“−1” is designed for five-string bass (with an additional high B string).

•

“−2” is designed for four-string bass.

The principle is the same as Inv. Channel mode, but the number of the MIDI channel is
reduced by 1 or 2, in order to properly convert the channels for bass string assignment.
The string assignment for a four-string bass is 3 to 6, and 2 to 6 (counted from
highest to lowest string in both cases) for a five-string bass, just as with guitar strings
that sound one octave higher. Notes on channel 1 are assigned to the highest string.
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Chords & Grids settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Chords and
Grids settings are available.
These settings define the font, position, and scaling of chords and grids, and
other settings.

Chord settings
•

Root Font field: Defines the font for the chord symbol’s root note.

•

Extension Font field: Defines the font for the chord symbol’s extensions.

•

Follow staff size checkbox: Displays chord symbols according to staff size.

•

Slash Note Position pop-up menu: Defines the position of the slash note.

•

Accidental Scale field: Changes the accidental size, in relation to the font size setting:
positive values result in an increased size, negative values in a diminished size of chord
symbol accidentals.

•

Language pop-up menu: Choose which language to use for accidentals and other chord
symbols.

•

Alignment pop-up menu: Determines the general horizontal alignment of chord
symbols—with an Align parameter set to def (default)—in relation to their bar position.

Grid settings
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•

Font field: Sets the general grid font.

•

Grid Scaling: Reduced field: Sets the size of the first chord grid when added in the
Score Editor.
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•

Grid Scaling: Normal field: Sets the size of the second chord grid when added in the
Score Editor.

•

Grid Scaling: Enlarged field: Sets the size of the third chord grid when added in the
Score Editor.

•

Chord Scaling: Reduced field: Sets the size of the chord on the first chord grid when
added in the Score Editor.

•

Chord Scaling: Normal field :Sets the size of the chord on the second chord grid when
added in the Score Editor.

•

Chord Scaling: Enlarged field: Sets the size of the chord on the third chord grid when
added in the Score Editor.

•

Show Fingering checkboxes: Select to show the fingering numbers on the chord grid
symbols in the Score Editor.

•

Minimum Number of Frets field: Defines the number of frets (four, five, or six) on chord
grids.

•

Barre buttons: Define the Barre style on chord grids, whether Tie or Block.

•

Thumb buttons: Define the representation of the Thumb fingering marking on chord
grids. It can be represented by a 5 or a T.

•

Left-Handed checkbox: Changes the chord grid orientation for a left-handed user.

Clefs & Signatures settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Clefs and
Signatures settings are available.
These settings define the display of clefs and signatures in the score, and other settings.
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Clefs settings
•

Clefs pop-up menu: Choose from the following clef display parameters: Every Staff,
First Staff on Every Page, First Staff on Page 1, and Hide All.

•

Display warnings at line breaks checkbox: Causes warning clef changes to be displayed
at the end of a staff or staff system (if the actual change is at the beginning of the
subsequent staff or staff system).

•

Smaller Clef Changes pop-up menu: Displays clef changes (whether caused by a
change of staff style, or by a new clef inserted from the Part box) at a smaller size than
the clefs at the beginning of staffs, depending on this setting.

Key and Time Signatures settings
•

Key Signatures pop-up menu: Choose from the following key signature display
parameters: Every Staff, First Staff on Every Page, First Staff on Page 1, and Hide All.

•

Display warnings at line breaks checkbox: Displays a warning if key signature changes
occur at the end of a staff or staff system (if the actual change is at the beginning of
the subsequent staff or staff system).

•

Automatic key transposition checkbox: Enables the automatic transposition of key
signatures in transposing staff styles. It is usually selected. An exception is for the
notation of atonal music. If unselected, all sharps and flats are displayed directly with
the notes.
Note: A similar option in the Staff Style window (Key parameter) allows you to turn off
the key signature for individual staff styles, or even for individual staffs in multi-staff
styles.

•

Minimize transposed accidentals checkbox: Allows the use of enharmonically changed
key signatures, if this results in a signature with fewer accidentals. For example, if a
piece is written in B major (5 sharps), the Bb instruments are notated in Db major (5
flats) instead of C# major (7 sharps).
Note: Logic Pro does not display key signatures with more than seven flats or sharps,
whether or not this option is selected.
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•

Show naturals checkbox: Select this checkbox to display naturals at key signature
changes, where preceding accidentals are no longer valid (when changing from E major
to G major, or to C minor, for example).

•

Show grace note accidentals checkbox: If selected, courtesy accidentals are
automatically displayed. This means wherever a diatonic note is altered by an
accidental, another accidental (a natural symbol, in many cases) is displayed when that
note appears (unaltered) in a subsequent bar.

•

Time Signatures pop-up menu: Choose between the following time signature display
parameters: Every Staff, First Staff on Every Page, First Staff on Page 1, and Hide All.

•

Display warnings at line breaks checkbox: Displays a warning if time signature changes
occur at the end of a staff or staff system (if the actual change is at the beginning of
the subsequent staff or staff system).

•

Size pop-up menu: Alters the appearance of the meter (often much larger, for
conducting purposes) on the staff. It is expressed as regular and percentage values.
Single systems show both numbers (4/4, for example) on the system. Double systems
show the upper number on the upper system, and the lower number on the lower
system.
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•

Hide bar lines checkbox: Use to hide all bar lines, which can be useful for educational
material, Gregorian plain chant notation, and other special situations.
Note: Only automatically displayed bar lines are hidden, so it’s still possible to insert bar
lines from the Part box, including the regular bar line, which are displayed and printed.

Octave Symbols settings
•

+8, –8, 0, +15, –15 fields: Use to edit the text string (and text formatting) of the
different octave symbols. Click in the appropriate field, and enter the text.

•

Octave Symbols Font Choose button and field: Click this button to choose an octave
symbols font. The chosen font, style, and size are displayed in the font field.

•

Follow staff size checkbox: Displays octave symbols according to staff size.

•

Line pop-up menu: Choose an option to adjust the line: solid, dashed, or dotted.

Layout settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Score Layout
settings are available.
These settings define the display of staff line thickness, stem length, and distance between
notes and ties, or notes and dots, and other settings.
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Line Thickness settings
•

Line Thickness parameters: Determines the line thickness of every notation element
that uses lines. staff lines, stems, ledger lines, bar lines, repeat and end lines, tuplet
brackets, text boxes, crescendi/decrescendi (also affects line objects and arrows), ties,
and slurs.
Note: If you have a high-resolution printer, try to use smaller line thickness settings
(2, or maybe even 1). Smaller staff lines, in particular, look much better. The other
parameter settings are more a matter of personal preference. These changes are only
visible at high zoom levels on the screen. To really judge the results, try some printouts
with different settings. The Slur and Tie Thickness parameters are affected by the Scale
parameter in score sets, and the Size parameter in staff styles.

Slurs
•

Slurs Line Thickness field :Use to set the line thickness for all slurs.

•

Horizontal Distance field: Use to adjust the distance between the beginning and end for
all slurs.

•

Vertical Distance field: Use to adjust the vertical hight for all slurs.

•

Curve Height field: Determines the bow of the curve for all slurs.

•

Curvature field: Determines how rounded the curvature of each slur is.

Ties
•

Ties Line Thickness field: Use to set the line thickness for all ties.

•

Horizontal Tie Position and Vertical Tie Position fields: Determine the distances
between note heads and related ties (which are displayed automatically).

Spacing settings
•

Bar Start Spacing and Bar End Spacing fields: Change the relative distance between the
first and last note of a bar, and the preceding or subsequent bar line. Keep in mind that
changing the default settings of these parameters only makes sense if rather extreme
values have been chosen for the general Spacing parameters in the Global Score pane.

•

Dot to Note Distance and Dot to Dot Distance fields: Determine the distance between
the note heads and dots, for dotted notes. Dot/Dot Distance refers to double dotted
notes.

•

Accidental to Note Distance field: Use to globally alter the horizontal distance of
accidentals from the corresponding note heads. The default setting should only be
changed if very small values are used for the Spacing parameters, which results in a tiny
distance between notes. This global setting can also be combined with the Accidental
Distance parameter of individual notes, in the Note Attributes window.

•

Accidental to Accidental Distance field: Use to globally alter the horizontal distance
between several accidentals, in chords.

Others settings
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•

Stem Length field: Determines the default setting for stem length.

•

Factory Defaults button: Click to reset all parameters to their default settings.
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MIDI Meaning settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Score MIDI
Meaning settings are available.
These settings determine if, and to what extent, the insertion of the listed symbols affects
the MIDI playback of notes (that these symbols are attached to).

•

Symbols: Symbols change the MIDI output of all notes they are attached to. The
following two parameters can be determined for each symbol:

•

Velocity: This value is added to, or subtracted from, the original velocity value of the
corresponding note.

•

Length: The original note length is shortened by the percentage chosen here. This only
affects the playback of the note, not the score display. The note length change can be
seen in the Event inspector or in the Event List.

The MIDI Meaning functions are most useful when you’re inserting notes with the mouse.
This makes it possible to work as if writing music on paper.
•

First, you write/insert the notes. They all have the same velocity, and identical rhythmic
note values have exactly the same length.

•

Accents and phrasing marks are then attached to some of the notes, which change the
velocity and (playback) length of these notes.

This technique makes playback sound much more realistic and alive.
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The default settings in the MIDI Meaning pane (in new projects) are 0 for velocity, and
100% (no change) for length. If you don’t change these values, the symbols remain purely
graphical, and don’t affect MIDI playback. If you record your regions in real time (using a
keyboard), it’s better to use these default settings, as the notes probably already sound
the way you want them to.
Important: If you do use MIDI Meaning, you need to adjust the settings before you begin
to insert accents and so on. This is because the settings have no influence on accents and
phrasing marks that have already been inserted.
Once set, the velocity and length of notes change as soon as you attach one of these
symbols to a note. When you delete the symbol, note velocity and length are reset to their
initial values.

Colors settings in Logic Pro
When Enable Complete Features is selected in Advanced preferences, Score Colors
settings are available.
These settings define the pitch, velocity, and note color options.

Pitch Colors settings
•

•
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Pitch Colors Type buttons: Each note of the octave is assigned a color. They are arranged
like piano keys. You have the following two choices when it comes to pitch color:
•

Diatonic: Allows you to use 7 different colors.

•

Chromatic: Allows you to use 12 different colors.

Pitch Color buttons: Click any color to open the standard Colors window and change
that particular color.
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Velocity Colors settings
•

Velocity Color buttons: These eight colors are applied in accordance with the MIDI
velocity of notes, from left (minimum) to right (maximum). Click any color to open the
standard Colors window and change a particular color.

Note Color Options settings
•

Accidentals checkbox: Determines whether accidentals are displayed in color
(according to their note associations), or in black.

•

Dots checkbox: Determines whether dots are displayed in color (according to their note
associations), or in black.

•

Ties checkbox: Determines whether ties are displayed in color (according to their note
associations), or in black.

•

Rests checkbox: Determines whether rests are displayed in color (according to their
note associations), or in black. Rest colors only apply to user rests, which are mainly
used in polyphonic staff styles.

User Palette settings
•

User Palette Color buttons: These colors can be freely edited and named. Click any
color to open the standard Colors window and change that particular color. Doubleclick the text boxes to edit the names. These names are displayed as color options in
different color selection menus (staff styles, note attributes).

Other settings
•

Factory Defaults button: Click to reset any changes you made in the Colors pane.

Movie settings in Logic Pro

Movie settings are used in order to determine the movie offset, volume, and tempo value.

When Enable Complete Features is selected in Advanced preferences, the following are
available:
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•

Movie Position field: Moves the position of the full movie to the left or right.

•

Region Position field: Moves the position of the movie region to the left or right.

•

Region Borders Start field: Determines the start position of the movie region. This
reflects the same SMPTE position as the Movie Position field if the movie region covers
the full movie file.

•

Region Borders End field: Determines the end position of the movie region.
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•

Region Borders Length field: Shows the length of the movie region, based on the start
and end positions.

•

Movie Volume slider: Sets the volume of the audio track.

•

Mute button: Mutes the volume of the audio track.

•

Movie Preferences button: Opens the Movie Preferences window.

Assets settings in Logic Pro

When Enable Complete Features is selected in Advanced preferences, Assets settings
are available.
These settings let you select which asset types are copied either into the project package
or into a subfolder inside the project folder, depending on how you chose to organize your
project when saving it. Ideally, you should save all project assets with the project file, but
on certain occasions you may prefer not to.
You can choose to copy the following assets into the project package or project folder:
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•

Copy audio files into project checkbox: If selected, all audio files used in the project are
stored as part of your project package or folder.

•

Convert audio file sample rate when importing checkbox: If selected, any audio files
that are imported into the project automatically are converted to the sample rate of the
project if necessary.

•

Copy Sampler audio files into project checkbox: If selected, any samples used in the
project are stored as part of your project package or folder.

•

Copy Alchemy audio files into project checkbox: If selected, any Alchemy audio data
used in the project is stored as part of your project package or folder.

•

Copy Ultrabeat audio files into project checkbox: If selected, any Ultrabeat samples
used in the project are stored as part of your project package or folder.

•

Copy Space Designer impulse responses into project checkbox: If selected, any Space
Designer impulse responses used in the project are stored as part of your project
package or folder.

•

Copy movie file into project checkbox: If selected, any movie files used in the project
are stored as part of your project package or folder.

•

Copy Apple Sound Library content into project checkbox: If selected, any Apple Sound
Library Content used in the project are stored as part of your project package or folder.
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Key commands
Key commands in Logic Pro

You can perform nearly every Logic Pro function with a key command, greatly accelerating
your workflow.
You can use the Key Commands window to browse, copy, import, and save key command
sets, as well as to assign Logic Pro functions that you use most often to computer
keyboard keys. There are also a number of functions that are only available as key
commands. Some of these may not have a default key command assignment. In those
cases, you’ll need to create a suitable key command to use the function. If you have
enabled Help Tags in Preferences > Display > General, when a Help Tag displays a
command, it also shows the corresponding key command if one is assigned.
Key commands may consist of either a single alphanumeric key or an alphanumeric key
and one or more modifier keys. The modifier keys are represented by glyphs in the Key
Commands window.
Logic Pro Help includes tables of key commands with a default computer keyboard
assignment. However, all key commands, including those unassigned to computer keyboard
keys, can be viewed in the Key Commands window. You can also Copy and print key
commands, including unassigned key commands.
Note: Logic Pro offers additional keyboard control if you select the macOS preference “All
controls” for Full Keyboard Access in System Preferences > Keyboard > Shortcuts. With “All
controls” enabled, the Tab key can be used to navigate dialogs and windows with onscreen
radio buttons, checkboxes, and text fields.
When Enable Complete Features is selected in Advanced preferences, you can access
the Key Commands window.
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Open the Key Commands window
In Logic Pro, do one of the following:
•

Choose Logic Pro > Key Commands > Edit (or press Option-K).

•

Press and hold Control while choosing a menu command.
The Key Commands window opens with the respective command selected.

Reset all key command assignments

Resetting causes you to lose your existing key command assignments, so be sure to create
a copy of your key commands file before doing so.
•

In Logic Pro, click the Actions pop-up menu
in the Key Commands window.

and choose Initialize all Key Commands

Browse, import, and save key commands in Logic Pro

Once you open the Key Commands window, you can browse or search for key commands.

You can also switch between key command sets, or import and export them. This is useful
if you need to work temporarily on another user’s Logic Pro system, because you can use
your personal key commands without altering the settings of the other system.

Browse key commands

In Logic Pro, do one of the following:
•

Click the disclosure arrow beside a key command group to show its contents.

•

Click the Actions pop-up menu
in the top left of the Key Commands window, then
choose Expand All to show the contents of all key command groups.
When you expand key command groups, your key command selection may no longer
be visible. You can quickly return to the selected key command by choosing Options >
Scroll to Selection.
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•

Click one of the filter buttons to restrict the list of key commands to the following:
•

All: Show all key commands.

•

Used: Show only assigned key commands.

•

Key: Show only key commands assigned to the keyboard.

•

Touch Bar: Show only key commands assigned to the Touch Bar.

•

Unused: Show only unassigned key commands.

•

Customized: Show only user customized key commands.

•

Multi-Used: Show only key commands used in multiple windows.

•

Conflicts: Show only key commands that conflict with other key commands.

•

Pressed: When the Pressed button is engaged, pressing a key combination on the
keyboard shows all key commands that use the pressed key.

Search for a key command
•

In Logic Pro, enter a search term in the search field.

You can click the small “x” at the right side of the search field to clear the search term.
Click the magnifying glass icon at the left side of the search field to choose a search term
from the pop-up menu.

Choose a key command set

In Logic Pro, do one of the following:
•

Choose Logic Pro > Key Commands > Presets.

•

Click the Actions pop-up menu
choose Presets.

in the top left of the Key Commands window, then

The default key command sets, along with key command sets saved in the ~/Library/
Application Support/Logic/Key Commands folder, are displayed, allowing you to quickly
switch between key command sets.

Import a key command set
•

In Logic Pro, click the Actions pop-up menu
window, then choose Import Key Commands.

in the top left of the Key Commands

You can import key command sets from any folder location using the dialog that
appears.

Save a key command set
•

In Logic Pro, click the Actions pop-up menu
window, then choose Save.

Save a key command set with a new name
•

In Logic Pro, click the Actions pop-up menu
window, then choose Save As.

in the top left of the Key Commands

in the top left of the Key Commands

You can save the current key command assignments to any location using the dialog that
appears. The default location is ~/Music/Audio Music Apps/Key Commands.
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Assign key commands in Logic Pro

Once you open the Key Commands window, you can assign particular computer
keyboard keys to Logic Pro functions, and assign control surface messages to particular
commands—effectively teaching Logic Pro to understand these messages.
If your computer has a Touch Bar, you can assign key commands to appear in the
Touch Bar. See Touch Bar shortcuts for more information.

Assign a function to a key

1. In Logic Pro, select a command in the Command column.

2. Click the Learn by Key Label button.
3. Press the relevant keyboard key, along with the modifier key or keys—Shift, Control,
Option, Command.
4. If the key command assignment is already used by Logic Pro, an alert appears. You have
the following options:
•

Cancel: Click Cancel if you don’t want to change the existing assignment.

•

Replace: Click Replace if you want to replace the existing assignment with the
selected function.

•

OK: Click OK if you want to assign the key command combination to the selected
function, while retaining the existing key command or function.

5. If the key command assignment is already used by macOS, typing the key command
triggers the system function, indicating the key command is not available. For example,
if you press Option-Command-D, the Dock in the Finder is shown or hidden, indicating
the key command is not available. In this case, choose another keyboard assignment.
6. Click the Learn by Key Label button again.
The Learn by Key Position button works in a similar way, differing in that you can assign, for
example, different commands to the alphanumeric keyboard and the numeric keyboard.
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Assign a function to the Touch Bar

1. In Logic Pro, select a command in the Command column.

2. Click the Learn Touch Bar button at the middle of the pane on the right.
3. Tap the relevant Touch Bar button, along with the modifier key or keys—Shift, Control,
Option, Command.
4. If the Touch Bar button is already assigned, an alert appears. You have the following
options:
•

Cancel: Click Cancel if you don’t want to change the existing assignment.

•

Replace: Click Replace if you want to replace the existing assignment with the
selected function.

5. In the Label column, enter a short name for the command. The name should be eight
characters or fewer, so it fits on the Touch Bar button.
6. In the Color pop-up menu, choose a color for the Touch Bar button.
The button you assigned to the Touch Bar can now be accessed from the Key Commands
screen. For more information about using the Touch Bar, see Touch Bar shortcuts.
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Learn a controller assignment

1. In Logic Pro, click the Learn New Assignment button at the bottom of the pane on
the right.

2. Select the command in the Command column.
3. Send a MIDI message from your controller.
The Assignments field displays the learned assignment, showing one or all of the following:
•

The name of the control surface—or the MIDI string, if the assignment is from an
unsupported control surface

•

The name of the control

•

The zone and mode that the assignment belongs to

The Learn New Assignment button becomes unavailable when the entire message has been
received. This avoids reception of further messages that may be sent by the device when
you release the button.
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Delete a key command or controller assignment
In Logic Pro, do one of the following:
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•

To delete a key command assignment: Select the related command in the Command
column, then click the Delete button.

•

To delete a controller assignment: Select the related command in the Command column,
then click the Delete Assignment button.
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Copy and print key commands in Logic Pro

Once you open the Key Commands window, you can copy a list of all of the key commands
to the Clipboard and then paste them into a document that accepts text for printing.

Print a key command list

1. In Logic Pro, click the Actions pop-up menu
in the top left of the Key Commands
window, then choose Copy Key Commands to Clipboard.
2. Paste the results into any document that accepts text, then format the results and print
the list.

Key command tables
Key commands for Global Commands in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Record

R

Record Into Cell

Option-R

Record/Record Toggle

𝍖 Asterisk (*)

Discard Recording and Return to
Last Play Position

Command-Period (.)

Capture as Recording

Shift-R

Play

𝍖⌅

Pause

𝍖 Period (.)

Stop

𝍖0

Play or Stop

Space bar

Available when

Enable Complete Features

Preview Selection-Based Processing Option-Underscore (_)
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Rewind

Comma (,)

Forward

𝍖V

Fast Rewind

Shift-Comma (,)

Fast Forward

Shift-Period (.)

Forward by Transient

Control-Period (.)

Rewind by Transient

Control-Comma (,)

Play from Left Window Edge

Shift-⌅

Go to Position

𝍖Z

Set Punch In Locator by Playhead

Control-Option-Command-I

Set Punch In Locator by Rounded
Playhead

Control-Option-Shift-Command-I

Enable Complete Features
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Function

Key command

Available when

Set Punch Out Locator by Playhead

Control-Option-Command-O

Set Punch Out Locator Point by
Rounded Playhead

Control-Option-Shift-Command-O

Set Locators by Regions/Events/
Marquee and Enable Cycle

Command-U

Set Rounded Locators by Regions/
Events and Enable Cycle

U

Play from Selection

Shift-Space bar

Swap Left and Right Locator

𝍖 Equal Sign (=)

Move Locators Forward by Cycle
Length

Shift-Command-Period (.)

Move Locators Backwards by Cycle
Length

Shift-Command-Comma (,)

Go to Selection Start

Control-↖

Enable Complete Features

Go to Selection End

Control-↘

Enable Complete Features

Go to End of Last Region

Option-↩

Go to Beginning

↩

Create Marker

Option-Apostrophe (’)

Create Marker Without Rounding

Control-Option-Apostrophe (’)

Create Marker for Selected Regions

Option-Shift-Apostrophe (’)

Delete Marker

Option-Delete

Set Locators by Marker and Enable
Cycle

Control-Option-C

Set Locators by Previous Marker
and Enable Cycle

Control-Option-Comma (,)

Set Locators by Next Marker and
Enable Cycle

Control-Option-Period (.)

Go to Previous Marker and Set
Locators

Option-Comma (,)

Go to Next Marker and Set Locators

Option-Period (.)

Go to Marker Number

Option-Slash (/)

Rename Marker

Shift-Apostrophe (’)

Go to Marker Number 1

𝍖1

Go to Marker Number 2

𝍖2

Go to Marker Number 3

𝍖3

Go to Marker Number 4

𝍖4

Go to Marker Number 5

𝍖5

Enable Complete Features
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Function

Key command

Available when

Go to Marker Number 6

𝍖6

Go to Marker Number 7

𝍖7

Go to Marker Number 8

𝍖8

Go to Marker Number 9

𝍖9

Go to Marker Number 10

𝍖 Control-0

Go to Marker Number 11

𝍖 Control-1

Go to Marker Number 12

𝍖 Control-2

Go to Marker Number 13

𝍖 Control-3

Go to Marker Number 14

𝍖 Control-4

Go to Marker Number 15

𝍖 Control-5

Go to Marker Number 16

𝍖 Control-6

Go to Marker Number 17

𝍖 Control-7

Go to Marker Number 18

𝍖 Control-8

Go to Marker Number 19

𝍖 Control-9

Cycle Mode

C

Double Cycle/Loop Length

Option-Shift-Command-Period (.)

Halve Cycle/Loop Length

Option-Shift-Command-Comma (,)

Autopunch Mode

Control-Option-Command-P

Replace

𝍖 Slash (/)

Solo Mode

Control-S

Set Solo Lock Mode

Option-S

Reselect Solo-Locked Regions

Option-Shift-S

Clear/Recall Solo

Control-Option-Command-S

Mute Off for All

Control-Shift-M

Cycle Audition On/Off

Control-C

MIDI/Monitor Metronome Click

K

Count In

Shift-K

Recall Screenset 1

𝍖1

Enable Complete Features

Recall Screenset 2

𝍖2

Enable Complete Features

Recall Screenset 3

𝍖3

Enable Complete Features

Recall Screenset 4

𝍖4

Enable Complete Features

Recall Screenset 5

𝍖5

Enable Complete Features

Enable Complete Features
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Function

Key command

Available when

Recall Screenset 6

𝍖6

Enable Complete Features

Recall Screenset 7

𝍖7

Enable Complete Features

Recall Screenset 8

𝍖8

Enable Complete Features

Recall Screenset 9

𝍖9

Enable Complete Features

Recall Screenset 1x

𝍖 Control-1

Enable Complete Features

Recall Screenset 2x

𝍖 Control-2

Enable Complete Features

Recall Screenset 3x

𝍖 Control-3

Enable Complete Features

Recall Screenset 4x

𝍖 Control-4

Enable Complete Features

Recall Screenset 5x

𝍖 Control-5

Enable Complete Features

Recall Screenset 6x

𝍖 Control-6

Enable Complete Features

Recall Screenset 7x

𝍖 Control-7

Enable Complete Features

Recall Screenset 8x

𝍖 Control-8

Enable Complete Features

Recall Screenset 9x

𝍖 Control-9

Enable Complete Features

Region Inspector Float

Option-Shift-R

Enable Complete Features

Open Preferences

Command-Comma (,)

Open Automation Preferences

Option-A

Enable Complete Features

Open Event List

Command-7

Enable Complete Features

Open Main Window

Command-1

Open Mixer

Command-2

Enable Complete Features

Open Smart Controls

Command-3

Enable Complete Features

Open Score Editor

Command-5

Enable Complete Features

Open Transform

Command-9

Enable Complete Features

Open Piano Roll

Command-4

Enable Complete Features

Open Environment

Command-0

Enable Complete Features

Open Project Audio

Command-8

Enable Complete Features

Note Repeat

Control-Option-↩

Spot Erase

Control-Option-Delete

Open Audio File Editor

Command-6

Show/Hide Musical Typing

Command-K

Show/Hide Event Float

Option-E

Show/Hide Mixer

X

Show/Hide Smart Controls

B

Enable Complete Features

Enable Complete Features)
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Function

Key command

Available when

Show/Hide Score Editor

N

Show/Hide Staff Style Window

Control-Option-Shift-S

Enable Complete Features

Show/Hide Score Sets Window

Control-Option-Shift-I

Enable Complete Features

Show/Hide Piano Roll

P

Show/Hide Step Input Keyboard

Option-Command-K

Show/Hide Loop Browser

O

Show/Hide Library

Y

Show/Hide Audio File Editor

W

Show/Hide Quick Help

Shift-Slash (/)

Show Detailed Help

Command-Slash (/)

Open in External Sample Editor

Shift-W

Enable Complete Features

Open Tempo List

Option-Shift-T

Enable Complete Features

Open Key Commands

Option-K

Enable Complete Features

Show/Hide Colors

Option-C

Enter/Exit Full Screen

Control-Command-F

Open Movie

Option-Command-O

Toggle Current Track Automation
Off/Read

Control-Command-O

Toggle Current Track Automation
Latch/Read

Control-Command-A

Set All Tracks to Automation Off

Control-Shift-Command-O

Set All Tracks to Automation Read

Control-Shift-Command-R

Set All Tracks to Automation Touch

Control-Shift-Command-T

Set All Tracks to Automation Latch

Control-Shift-Command-L

Track Automation Event List

Control-Command-E

Toggle Automation Quick Access

Control-Option-Command-A

Enable Complete Features

Enable/Disable Automation Groups

Shift-G

Enable Complete Features

Open Group Settings

Option-Shift-G

Enable Complete Features

Close Window

Command-W

Cycle Through Windows

Command-Grave Accent (`)

Cycle Through Windows (counter
clockwise)

Shift-Command-Grave Accent (`)

Select Previous Track

Up Arrow

Select Next Track

Down Arrow

Enable Complete Features

Enable Complete Features
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Function

Key command

Available when

New Empty Project

Shift-Command-N

Enable Complete Features

New Project

Command-N

Open

Command-O

Project Settings

Option-P

Close Project

Option-Command-W

Save

Command-S

Save Project as

Shift-Command-S

Print

Command-P

Import

Command-I

Export Selection as MIDI File

Option-Command-E

Export Track as Audio File

Command-E

Enable Complete Features

Export All Tracks as Audio Files

Shift-Command-E

Enable Complete Features

Zoom Window

Option-Command-M

Import Audio File

Shift-Command-I

Next Channel Strip Setting of
Focused Track

Shift-Right Bracket (])

Previous Channel Strip Setting of
Focused Track

Shift-Left Bracket ([)

Copy Channel Strip Setting

Option-Command-C

Paste Channel Strip Setting

Option-Command-V

Next Patch, Plug-in Setting or
Sampler Instrument

Right Bracket (])

Previous Patch, Plug-in Setting or
Sampler Instrument

Left Bracket ([)

Toggle Channel Strip Mute

M

Toggle Channel Strip Solo

S

Toggle Channel Strip Input
Monitoring

Control-I

Toggle Channel Strip Format (mono/
stereo)

Control-Shift-S

Show/Hide All Plug-in Windows

V

Set Nudge Value to Bar

Control-Option-M

Set Nudge Value to Beat

Control-Option-B

Set Nudge Value to Division

Control-Option-D

Set Nudge Value to Tick

Control-Option-T

Enable Complete Features

1062

Function

Key command

Set Nudge Value to SMPTE Frame

Control-Option-F

Set Nudge Value to 0.5 SMPTE
Frame

Control-Option-H

Set Nudge Value to Sample

Control-Option-S

Set Nudge Value to 1 ms

Control-Option-1

Set Nudge Value to 10 ms

Control-Option-0

Stop All Cells

Command-↩

Toggle Activation of All Tracks

Control-Option-Shift-T

Available when

Key commands for Global Control Surfaces Commands in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Available when

Open Controller Assignments

Option-Shift-K

Enable Complete Features

Learn new Controller Assignment

Command-L

Enable Complete Features

Key commands for various windows in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Undo

Command-Z

Redo

Shift-Command-Z

Undo History

Option-Command-Z

Cut

Command-X

Copy

Command-C

Paste

Command-V

Select All

Command-A

Show Tool Menu

T

Set Next Tool

Option-⇟

Set Previous Tool

Option-⇞

Page Up

Page Up (⇞)

Page Down

Page Down (⇟)

Page Left

Top (↖)

Page Right

End (↘)

Available when

Enable Complete Features
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Function

Key command

Show/Hide Local Inspector

Option-Shift-I

MIDI Out Toggle

Option-O

MIDI In Toggle

Option-I

Increase Last Clicked Parameter
by 1

𝍖 Right Bracket (])

Decrease Last Clicked Parameter
by 1

𝍖 Left Bracket ([)

Increase Last Clicked Parameter
by 10

𝍖 Shift-Right Bracket (])

Decrease Last Clicked Parameter
by 10

𝍖 Shift-Left Bracket ([)

Available when

Key commands for Windows Showing Audio files in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Available when

Show File(s) in Finder

Shift-Command-R

Enable Complete Features

Snap Edits to Zero Crossings

𝍖 Control-0

Add to Tracks

Command-Semicolon (;)

Preview

Option-Space bar

Show/Hide Selection-based
Processing

Option-Shift-P

Apply Selection-based Processing
Again

Control-Option-P

Key commands for Main Window Tracks and Various Editors in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

New Tracks

Option-Command-N

New Audio Track

Option-Command-A

New Software Instrument Track

Option-Command-S

New Drummer Track

Option-Command-U

New External MIDI Track

Option-Command-X

New Track with Duplicate Setting

Command-D

New Track with Next Channel/MIDI
Channel

Control-↩

Available when
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Function

Key command

Available when

New Track with Same Channel Strip/
Instrument

Control-Shift-↩

Delete Track

Command-Delete

Delete Unused Tracks

Option-Command-Delete

Deselect All

Shift-D

Enable Complete Features

Invert Selection

Shift-I

Enable Complete Features

Select All Following

Shift-F

Enable Complete Features

Select All Following of Same Track/
Pitch

Control-Shift-F

Enable Complete Features

Select All Inside Locators

Shift-L

Enable Complete Features

Select Overlapped Regions/Events

Shift-O

Enable Complete Features

Select Equal Regions/Events

Shift-E

Enable Complete Features

Select Similar Regions/Events

Shift-S

Enable Complete Features

Select Same Subpositions

Shift-P

Enable Complete Features

Select Muted Regions/Events

Shift-M

Enable Complete Features

Select Same-Color Regions/Events

Shift-C

Enable Complete Features

Select First, or Shift Marquee
Selection Left

Shift-↖

Select Last, or Shift Marquee
Selection Right

Shift-↘

Select Previous Region/Event or
Move Marquee End (or Marquee
Point) to Previous Transient

Left Arrow

Select Next Region/Event or Move
Marquee End (or Marquee Point) to
Next Transient

Right Arrow

Toggle Previous Region/Event or
Move Marquee Start (or Extend
Marquee Selection) to Previous
Transient

Shift-Left Arrow

Toggle Next Region/Event or Move
Marquee Start (or Extend Marquee
Selection) to Next Transient

Shift-Right Arrow

Scroll to Selection

Shift-Grave Accent (`)

Loop Regions/Folders On/Off

L

Quantize Selected Events

Q

Undo Quantization

Option-Command-Q

Delete Duplicated Events

Option-D

Enable Complete Features

Paste Replace

Shift-Command-V

Enable Complete Features
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Function

Key command

Available when

Repeat Regions/Events

Command-R

Join Regions/Notes

Command-J

Split Regions/Events at Locators or
Marquee Selection

Control-Command-T

Split Regions/Events at Playhead
Position

Command-T

Move Region/Event to Playhead
Position (Pickup Clock)

Semicolon (;)

Enable Complete Features

Move Region/Event to Playhead
Position and Select Next Region/
Event (Pickup Clock+)

Shift-Semicolon (;)

Enable Complete Features

Set Region/Event/Marquee Start to
Playhead Position

Command-Left Bracket ([)

Enable Complete Features

Set Region/Event/Marquee End to
Playhead Position

Command-Right Bracket (])

Enable Complete Features

Nudge Region/Event Position Right
by Nudge Value

Control-Option-Right Arrow

Enable Complete Features

Nudge Region/Event Position Left by Control-Option-Left Arrow
Nudge Value

Enable Complete Features

Nudge Region/Event Length Right
by Nudge Value

Option-Shift-Right Arrow

Enable Complete Features

Nudge Region/Event Length Left by
Nudge Value

Option-Shift-Left Arrow

Enable Complete Features

Rotate Right by Nudge Value

Control-Option-Command-Right
Arrow

Enable Complete Features

Rotate Left by Nudge Value

Control-Option-Command-Left
Arrow

Enable Complete Features

Open Track Stack

Control-Command-Right Arrow

Close Track Stack

Control-Command-Left Arrow

Mute Notes/Regions/Folders On/Off

Control-M

Snap to Grid On/Off

Command-G

Shuffle Left

Option-Left Bracket ([)

Enable Complete Features

Shuffle Right

Option-Right Bracket (])

Enable Complete Features

Show/Hide Live Loops

Option-L

Show/Hide Tracks area

Option-N

Bounce

Command-B
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Key commands for the Live Loops Grid in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Queue Cell/Scene Playback

Option-Return

Play Live Loops (Trigger Selected
Cells or Focused Scene)

Return

Trigger Focused Scene

Option-Command-Return

Retrigger Selected Cells or Focused
Scene

Control-Command-Return

Insert Empty Scene

Command-Page Down (⇟)

Copy Playing Cells Here

Command-Page Up (⇞)

Select Next Lower Cell, or Next
Track

Down Arrow

Select Next Upper Cell, or Previous
Track

Up Arrow

Extend Cell, or Track Selection Up

Shift-Up Arrow

Extend Cell, or Track Selection
Down

Shift-Down Arrow

Select Previous Scene

Option-Left Arrow

Select Next Scene

Option-Right Arrow

Enable Performance Recording On/
Off

Control-P

Unpack Take Cell to Existing Scenes

Control-Option-Command-U

Unpack Take Cell to New Scenes

Control-Option-Shift-Command-U

Toggle Grid Horizontal Zoom

Control-Option-Z

Available when

Key commands for Various Editors in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Select Same Channels

Shift-H

Enable Complete Features

Select Same Articulation IDs

Shift-A

Trim Note to Remove Overlaps for
Adjacent

Backslash (\)

Enable Complete Features

Trim Note End to Following Notes
(Force Legato)

Shift-Backslash (\)

Enable Complete Features

Select Highest Notes

Shift-Up Arrow

Enable Complete Features
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Function

Key command

Available when

Select Lowest Notes

Shift-Down Arrow

Enable Complete Features

Transpose Event +1 Semitone

Option-Up Arrow

Enable Complete Features

Transpose Event -1 Semitone

Option-Down Arrow

Enable Complete Features

Transpose Event +12 Semitones

Option-Shift-Up Arrow

Enable Complete Features

Transpose Event -12 Semitones

Option-Shift-Down Arrow

Enable Complete Features

Show Event Position and Length as
Time or Bars/Beats

Control-Option-R

Key commands for Views showing Time Ruler in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Catch Playhead Position

Grave Accent (`)

Secondary Ruler

Control-Option-Command-R

Grid

Control-G

Scroll in Play

Control-Grave Accent (`)

Show/Hide Global Tracks

G

Configure Global Tracks

Option-G

Show/Hide Arrangement Track

Shift-Command-A

Show/Hide Marker Track

Shift-Command-K

Show/Hide Movie Track

Shift-Command-O

Show/Hide Transposition Track

Shift-Command-X

Show/Hide Tempo Track

Shift-Command-T

Show/Hide Beat Mapping Track

Shift-Command-B

Enable Complete Features

Show/Hide Marker Track Only

Straight Apostrophe (')

Enable Complete Features

Zoom Horizontal Out

Command-Left Arrow

Zoom Horizontal In

Command-Right Arrow

Zoom Vertical Out

Command-Up Arrow

Zoom Vertical In

Command-Down Arrow

Recall Zoom 1

Control-Option-Command-1

Recall Zoom 2

Control-Option-Command-2

Recall Zoom 3

Control-Option-Command-3

Save as Zoom 1

Control-Option-Shift-Command-1

Enable Complete Features

Enable Complete Features

Enable Complete Features
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Function

Key command

Save as Zoom 2

Control-Option-Shift-Command-2

Save as Zoom 3

Control-Option-Shift-Command-3

Zoom to Fit Locators, Store
Navigation Snapshot

Control-Shift-Z

Toggle Zoom to Fit Selection or All
Contents

Z

Store Navigation Snapshot

Shift-Z

Navigation: Back

Option-Z

Navigation: Forward

Option-Shift-Z

Mute Notes/Regions/Folders On/Off

Control-M

Region Automation: Disable

Shift-Command-Y

Automation: Autodefine

Command-Y

Available when

Key commands for Main Window Tracks in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Extend Track Selection Up

Shift-Up Arrow

Extend Track Selection Down

Shift-Down Arrow

Select Previous Region on Selected
Track

Left Arrow

Select Next Region on Selected
Track

Right Arrow

Create 1 Automation Point at Region
Borders

Control-Shift-Command-1

Enable Complete Features

Create 2 Automation Points at
Region Borders

Control-Shift-Command-2

Enable Complete Features

Create 1 Automation Point at Every
Region Border

Control-Command-1

Enable Complete Features

Create 2 Automation Points at Every
Region Border

Control-Command-2

Enable Complete Features

Delete Redundant Automation
Points

Control-Delete

Enable Complete Features

Delete Visible Automation on
Selected Track

Control-Command-Delete

Enable Complete Features

Delete All Automation on Selected
Track

Control-Shift-Command-Delete

Delete Orphaned Automation on
Selected Track

Control-Shift-Delete

Enable Complete Features
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Function

Key command

Available when

Move Visible Region Data to Track
Automation

Control-Command-Up Arrow

Enable Complete Features

Move Visible Track Automation to
Region

Control-Command-Down Arrow

Enable Complete Features

Move All Region Data to Track
Automation

Control-Shift-Command-Up Arrow

Enable Complete Features

Move All Track Automation to
Region

Control-Shift-Command-Down
Arrow

Enable Complete Features

Pack Take Folder

Control-Command-F

Enable Complete Features

Unpack Take Folder to Existing
Tracks

Control-Command-U

Enable Complete Features

Unpack Take Folder to New Tracks

Control-Shift-Command-U

Enable Complete Features

Un/disclose Take Folder

Option-F

Flatten Take Folder

Option-Shift-U

Flatten and Merge Take Folder

Option-U

Rename Take or Comp

Shift-T

Delete Take or Comp

Option-Shift-Delete

Toggle Take Folder Quick Swipe
Comping Mode

Option-Q

Select Previous Take or Comp

Shift-Command-Up Arrow

Select Next Take or Comp

Shift-Command-Down Arrow

Create Track Stack

Shift-Command-D

Enable Complete Features

Create Folder Stack

Shift-Command-F

Enable Complete Features

Create Summing Stack

Shift-Command-G

Enable Complete Features

Flatten Stack

Shift-Command-U

Enable Complete Features

Bounce Regions in Place

Control-B

Enable Complete Features

Bounce Tracks in Place

Control-Command-B

Enable Complete Features

Drum Replacement/Doubling

Control-D

Enable Complete Features

Toggle Hide View

H

Enable Complete Features

Hide/Show Current Track and Select
Next Track

Control-H

Enable Complete Features

Unhide All Tracks

Control-Shift-H

Enable Complete Features

Toggle Hide Group 1

Control-Shift-1

Enable Complete Features

Toggle Hide Group 2

Control-Shift-2

Enable Complete Features

Toggle Hide Group 3

Control-Shift-3

Enable Complete Features

Toggle Hide Group 4

Control-Shift-4

Enable Complete Features

Enable Complete Features
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Function

Key command

Available when

Toggle Hide Group 5

Control-Shift-5

Enable Complete Features

Toggle Hide Group 6

Control-Shift-6

Enable Complete Features

Toggle Hide Group 7

Control-Shift-7

Enable Complete Features

Toggle Hide Group 8

Control-Shift-8

Enable Complete Features

Toggle Hide Group 9

Control-Shift-9

Enable Complete Features

Toggle Track On

Option-M

Toggle Track Record Enable

Control-R

Individual Track Zoom In

Control-Option-Command-Down
Arrow

Individual Track Zoom Out

Control-Option-Command-Up Arrow Enable Complete Features

Toggle Individual Track Zoom

Control-Option-Command-Z

Toggle Zoom Focused Track

Control-Z

Reset Individual Track Zoom

Control-Option-Command-Delete

Enable Complete Features

Individual Track Zoom Reset for All
Tracks

Control-Option-Delete

Enable Complete Features

Audio Crossfade Options for Merge

Option-X

Join Regions per Tracks

J

Apply Default Crossfade

Control-Option-X

Apply Last Edited Fade Again

Option-Shift-X

Convert Alias to a Region Copy

Control-A

Enable Complete Features

Select All Aliases of Region

Option-Shift-A

Enable Complete Features

Cut Section Between Locators
(Global)

Control-Command-X

Enable Complete Features

Insert Silence Between Locators
(Global)

Control-Command-Z

Enable Complete Features

Insert Snipped Section at Playhead
(Global)

Control-Command-V

Enable Complete Features

Repeat Section Between Locators
(Global)

Control-Command-R

Enable Complete Features

Rename Track

Shift-↩

Move Selected Regions to Selected
Track

Control-Shift-T

Enable Complete Features

Move Region to Recorded Position

Option-Shift-Command-R

Enable Complete Features

Copy Selected Regions to Selected
Track

Control-Option-Shift-T

Enable Complete Features

Convert Audio Region to New Audio
File

Option-Command-F

Enable Complete Features

Enable Complete Features

Enable Complete Features

Enable Complete Features
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Function

Key command

Available when

Convert Regions to New Sampler
Track

Control-E

Enable Complete Features

Time Stretch Region Length to
Locators

Option-Command-L

Enable Complete Features

Time Stretch Region Length to
Nearest Bar

Option-Command-B

Enable Complete Features

Detect Tempo of Selected Region…

Option-Command-T

Remove Silence from Audio Region… Control-X
Add Region to Loop Library

Control-Shift-O

Apply All Region/Cell Parameters
Permanently

Control-N

Enable Complete Features

Apply Quantization Destructively

Control-Q

Enable Complete Features

Convert Loops to Regions

Control-L

Enable Complete Features

Set Optimal Region Sizes Rounded
by Bar

Control-Backslash (\)

Remove Overlaps

Backslash (\)

Enable Complete Features

Trim Region End to Next Region

Shift-Backslash (\)

Enable Complete Features

Trim Regions to Fill within Locators

Option-Backslash (\)

Enable Complete Features

Crop Regions/Cells outside
Command-Backslash (\)
Locators/Playable Range or Marquee
Selection

Logic Pro User Guide

Enable Complete Features

Switch between Live Loops Grid and
Tracks View

Option-V

Show Live Loops Grid only

Option-L

Show Tracks View only

Option-N

Show Both, Live Loops Grid and
Tracks View

Option-B

Copy to Live Loops

Command-↖

Hide/Show Track Automation

A

Hide/Show Flex Pitch/Time

Command-F

Trim Region Start to Previous
Transient

Control-Shift-Left Bracket ([)

Enable Complete Features

Trim Region Start to Next Transient

Control-Shift-Right Bracket (])

Enable Complete Features

Trim Region End to Previous
Transient

Control-Left Bracket ([)

Enable Complete Features

Trim Region End to Next Transient

Control-Right Bracket (])

Enable Complete Features

Rename Regions

Shift-N

Name Regions by Track Name

Option-Shift-N
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Function

Key command

Available when

Name Tracks by Region Name

Option-Shift-Command-N

Enable Complete Features

Color Regions by Track Color

Option-Shift-C

Color Tracks by Region Color

Option-Shift-Command-C

Enable Complete Features

Waveform Vertical Zoom Out

Command-Hyphen (-)

Enable Complete Features

Waveform Vertical Zoom In

Command-Equal Sign (=)

Enable Complete Features

Show/Hide Toolbar

Control-Option-Command-T

Enable Complete Features

Configure Track Header

Option-T

Enable Complete Features

Show/Hide Editor

E

Show/Hide Note Pad

Option-N

Show/Hide List Editors

D

Show/Hide Browsers

F

Show/Hide Output Track

Shift-Command-M

Alignment Guides On/Off

Option-Command-G

New Track Alternative

Control-Option-Command-N

Duplicate Track Alternative

Control-Option-Command-D

Delete Inactive Track Alternatives

Control-Option-Command-Foward
Delete

Rename Track Alternative

Control-Option-Command-↩︎

Show/Hide Inactive Track
Alternatives

Control-Option-A

Activate Next Track Alternative

Control-Option-Up Arrow

Activate Previous Track Alternative

Control-Option-Down Arrow

Show Live Loops Grid Only

Option-L

Show Tracks Area Only

Option-N

Enable Complete Features

Key commands for the Mixer in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Cycle Through Mixer Modes (Single,
Arrange, All)

Shift-X

Enable Complete Features

Deselect All

Option-Shift-D

Select Audio Channel Strips

Shift-A

Select Instrument Channel Strips

Shift-S

Select Auxiliary Channel Strips

Shift-F
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Function

Key command

Select Output Channel Strips

Shift-O

Select MIDI Channel Strips

Shift-E

Select Same-Color Channel Strips

Shift-C

Select Muted Channel Strips

Shift-M

Select Previous (Left) Channel Strip

Left Arrow

Select Next (Right) Channel Strip

Right Arrow

Create New Auxiliary Channel Strip

Control-N

Create Tracks for Selected Channel
Strips

Control-T

Configure Channel Strip
Components

Option-X

Available when

Key commands for MIDI Environment in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Clear Cables only

Control-Delete

Enable Complete Features

Object move left

Option-Left Arrow

Enable Complete Features

Object move right

Option-Right Arrow

Enable Complete Features

Object move up

Option-Up Arrow

Enable Complete Features

Object move down

Option-Down Arrow

Enable Complete Features

Object Width -1 Pixel

Option-Shift-Left Arrow

Enable Complete Features

Object Width +1 Pixel

Option-Shift-Right Arrow

Enable Complete Features

Object Height -1 Pixel

Option-Shift-Up Arrow

Enable Complete Features

Object Height +1 Pixel

Option-Shift-Down Arrow

Enable Complete Features

Show/Hide Cables

Control-C

Enable Complete Features

Protect Cabling/Positions

Control-P

Enable Complete Features

Invert Selection

Shift-I

Enable Complete Features

Select Unused Instruments

Shift-U

Enable Complete Features

Select Cable Destination

Shift-Right Arrow

Enable Complete Features

Select Cable Origin

Shift-Left Arrow

Enable Complete Features

Send Selected Fader Values

Control-V

Enable Complete Features

Delete Layer

Command-Delete

Enable Complete Features

Cable serially

Control-S

Enable Complete Features
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Key commands for the Piano Roll in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Available when

Toggle Time Handles

Shift-T

Enable Complete Features

Define Brush Pattern & Set Brush
Tool

Control-Shift-B

Reset Brush Pattern

Control-Shift-Delete

Key commands for the Score Editor in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Page View

Control-P

Enable Complete Features

Explode Folders

Control-F

Enable Complete Features

Explode Polyphony

Control-X

Enable Complete Features

Hide/Show Instrument Names

Control-Shift-N

Enable Complete Features

Hide/Show Page Rulers

Control-Shift-R

Enable Complete Features

Go to Page

Control-Slash (/)

Enable Complete Features

Paste Multiple

Option-Shift-Command-V

Enable Complete Features

Select Next Event

Left Arrow

Select Previous Event

Right Arrow

Next Staff

Down Arrow

Previous Staff

Up Arrow

Force Interpretation

Control-Shift-I

Enable Complete Features

Defeat Interpretation

Control-I

Enable Complete Features

Stems: Up

Control-Option-Up Arrow

Enable Complete Features

Stems: Down

Control-Option-Down Arrow

Enable Complete Features

Stem End: Move Up

Option-Command-Up Arrow

Enable Complete Features

Stem End: Move Down

Option-Command-Down Arrow

Enable Complete Features

Ties: Up

Control-Option-Shift-Up Arrow

Enable Complete Features

Ties: Down

Control-Option-Shift-Down Arrow

Enable Complete Features

Beam Selected Notes

Control-B

Enable Complete Features

Unbeam Selected Notes

Control-U

Enable Complete Features

Default Beams

Control-D

Enable Complete Features
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Function

Key command

Available when

Enharmonic Shift: #

Shift-3

Enable Complete Features

Enharmonic Shift: b

Shift-B

Enable Complete Features

Reset Note Attributes

Control-Shift-Delete

Enable Complete Features

Assign MIDI Channels Based on
Score Split

Control-Shift-C

Enable Complete Features

Nudge Position Up

Control-Option-Command-Up Arrow

Nudge Position Down

Control-Option-Command-Down
Arrow

Nudge Position Left

Control-Option-Command-Left
Arrow

Nudge Position Right

Control-Option-Command-Right
Arrow

Settings: Global Format

Control-Option-Shift-F

Enable Complete Features

Settings: Numbers and Names

Control-Option-Shift-N

Enable Complete Features

Settings: Guitar Tablature

Control-Option-Shift-G

Enable Complete Features

Settings: Chords and Grids

Control-Option-Shift-C

Enable Complete Features

Settings: Clefs and Signatures

Control-Option-Shift-L

Enable Complete Features

Settings: Extended Layout

Control-Option-Shift-X

Enable Complete Features

Settings: MIDI Meaning

Control-Option-Shift-M

Enable Complete Features

Settings: Score Colors

Control-Option-Shift-O

Enable Complete Features

Insert: Crescendo

Control-Shift-Comma (,)

Insert: Decrescendo

Control-Shift-Period (.)

Clear Main Finger

Control-Option-Shift-Delete

Set Main Finger 1

Control-Option-Shift-1

Set Main Finger 2

Control-Option-Shift-2

Set Main Finger 3

Control-Option-Shift-3

Set Main Finger 4

Control-Option-Shift-4

Set Main Finger 5

Control-Option-Shift-5
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Key commands for the Event Editor in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Select Previous Event

Up Arrow

Select Next Event

Down Arrow

Length as Absolute Position

Control-Shift-A

Articulation ID

Control-Shift-D

Relative Position

Control-Shift-R

Duplicate Event and Numerical Edit

Command-D

Copy Value to All Following Events

Shift-V

Available when

Enable Complete Features

Enable Complete Features

Key commands for Step Editor in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Available when

Create Lane

Option-Command-N

Enable Complete Features

Delete Lane

Command-Delete

Enable Complete Features

Copy Lane

Control-C

Enable Complete Features

Paste Lane

Control-V

Enable Complete Features

Toggle Auto Define

Control-A

Select Next Lane

Down Arrow

Select Previous Lane

Up Arrow

Key commands for Step Sequencer in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Repeat Step

Command-R

Paste Steps

Control-Option-Command-V

Paste Row Settings

Control-Option-V

Delete Row

Command-Delete

Randomize Current Edit Mode
Values for All Rows

Shift-Command-R

Show/Hide All Edit Mode values

Control-E

Available when
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Function

Key command

Save Pattern

Shift-Command-P

Save Template

Shift-Command-T

Duplicate Row

Command-D

Learn Mode

Command-L

Select Step Above

Up Arrow

Select Step Below

Down Arrow

Select Previous Step

Right Arrow

Select Next Step

Left Arrow

Pattern Rotate Right

Control-Option-Command-Right
Arrow

Pattern Rotate Left

Control-Option-Command-Left
Arrow

Preview

Option-Underscore (_)

Available when

Key commands for Project Audio in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Select Previous Audio File

Up Arrow

Enable Complete Features

Select Next Audio File

Down Arrow

Enable Complete Features

Rename

Shift-↩

Enable Complete Features

Add Audio File

Control-F

Enable Complete Features

Add Region

Control-R

Enable Complete Features

Delete File(s)

Command-Delete

Enable Complete Features

Optimize File(s)

Control-O

Enable Complete Features

Backup File(s)

Control-B

Enable Complete Features

Copy/Convert File(s)

Control-K

Enable Complete Features

Select Unused

Shift-U

Enable Complete Features

Show All Regions

Option-Down Arrow

Enable Complete Features

Hide All Regions

Option-Up Arrow

Enable Complete Features

Remove Silence from Audio Region

Control-X

Enable Complete Features

Import Region Information

Control-I

Enable Complete Features

Export Region Information

Control-E

Enable Complete Features

Create Group

Control-G

Enable Complete Features
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Key commands for the Audio File Editor in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Available when

Play/Stop All

Control-Option-Command-Space
bar

Enable Complete Features

Play/Stop Region

Control-Option-Shift-Space bar

Enable Complete Features

Play/Stop Region from Anchor

Control-Option-Space bar

Enable Complete Features

Create Backup

Control-B

Enable Complete Features

Revert to Backup

Control-Option-Command-B

Enable Complete Features

Save Selection As…

Option-Command-S

Enable Complete Features

Region -> Selection

⇞

Enable Complete Features

Selection -> Region

⇟

Enable Complete Features

Go to Selection Start

Control-↖

Enable Complete Features

Go to Selection End

Control-↘

Enable Complete Features

Go to Region Start

Control-Option-Left Arrow

Enable Complete Features

Go to Region End

Control-Option-Right Arrow

Enable Complete Features

Go to Region Anchor

Control-Option-Down Arrow

Enable Complete Features

Go to Previous Transient

Option-Left Arrow

Enable Complete Features

Go to Next Transient

Option-Right Arrow

Enable Complete Features

Set Selection Start to Previous
Transient

Shift-Left Arrow

Enable Complete Features

Set Selection Start to Next Transient Shift-Right Arrow

Enable Complete Features

Set Selection End to Previous
Transient

Left Arrow

Enable Complete Features

Set Selection End to Next Transient

Right Arrow

Enable Complete Features

Selection Start and End to Previous
Transient

Shift-Command-Left Arrow

Enable Complete Features

Selection Start and End to Next
Transient

Shift-Command-Right Arrow

Enable Complete Features

Selection Start and End to Previous
Transient and Play

Option-Command-Left Arrow

Enable Complete Features

Selection Start and End to Next
Transient and Play

Option-Command-Right Arrow

Enable Complete Features

Toggle Transient Editing Mode

Control-T

Enable Complete Features

Increase Number of Transients

Control-Equal Sign (=)

Enable Complete Features

Decrease Number of Transients

Control-Hyphen (-)

Enable Complete Features

Select All Previous

Control-Option-Shift-Left Arrow

Enable Complete Features
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Function

Key command

Available when

Select All Following

Control-Option-Shift-Right Arrow

Enable Complete Features

Create New Region

Control-R

Enable Complete Features

Normalize

Control-N

Enable Complete Features

Change Gain

Control-G

Enable Complete Features

Fade In

Control-I

Enable Complete Features

Fade Out

Control-O

Enable Complete Features

Silence

Control-Delete

Enable Complete Features

Invert

Control-Shift-I

Enable Complete Features

Reverse

Control-Shift-R

Enable Complete Features

Trim

Control-Shift-T

Enable Complete Features

Remove DC Offset

Control-D

Enable Complete Features

Time and Pitch Machine

Control-P

Enable Complete Features

Search Peak

Shift-P

Enable Complete Features

Search Silence

Shift-S

Enable Complete Features

Lock Position in Track when Moving
Anchor

Control-A

Enable Complete Features

Key commands for the Smart Tempo Editor in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Tap Tempo

T

Tap Tempo (Downbeat)

D

Toggle Metronome

M

Scroll Left

Left Arrow

Scroll Right

Right Arrow

Select from Start to Cursor

Shift-Left Arrow

Select from Cursor to End

Shift-Right Arrow

Zoom All

Up Arrow

Center around Cursor

Down Arrow

Available when
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Sampler Instrument Editor key commands in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
Function

Key command

Load or Replace Audio File

Control-F

New Zone

Control-Z

New Group

Control-G

Available when

Shift Selected Zone(s)/Group(s) Left Option-Left Arrow
Shift Selected Zone(s)/Group(s)
Right

Option-Right Arrow

Shift Selected Zone(s)/Group(s) Left Option-Shift-Left Arrow
(Zones incl. Root Key)
Shift Selected Zone(s)/Group(s)
Right (Zones incl. Root Key)

Option-Shift-Right Arrow

Load Multiple Audio Files

Control-O

Open in Audio File Editor

Control-W

New Mapping

Option-Command-N

Duplicate Group

Command-D

Crop Sample

Option-Command-X

Crop Loop

Option-Shift-Command-X

Toggle Snap Mode

Command-G

Vertical Autozoom

Control-Option-Shift-Z

Horizontal Autozoom

Control-Option-Z

Preview Selected Zone

Option-Space bar

Key commands for the Step Input Keyboard in Logic Pro
The following table reflects default key commands included in the U.S. factory preset.
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Function

Key command

Note ‘C’

A

Note ‘C#’

W

Note ‘D’

S

Note ‘D#’

E

Note ‘E’

D

Note ‘F’

F

Note ‘F#’

T

Available when
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Function

Key command

Note ‘G’

G

Note ‘G#’

Y

Note ‘A’

H

Note ‘A#’

U

Note ‘B’

J

Rest

Space bar

Next note will be sharp

Shift-3

Next note will be flat

Shift-B

Chord Mode

Grave Accent (`)

Delete

Control-Delete

Step Backward

Left Arrow

Step Forward

Right Arrow

Octave - 2

Shift-Z

Octave - 1

Z

Octave + 1

X

Octave + 2

Shift-X

1/1 Note

1

1/2 Note

2

1/4 Note

3

1/8 Note

4

1/16 Note

5

1/32 Note

6

1/64 Note

7

1/128 Note

8

Triplets on/off

9

Dotted Note Values On/Off

0

Velocity 16 (ppp)

C

Velocity 32 (pp)

V

Velocity 48 (p)

B

Velocity 64 (mp)

N

Velocity 80 (mf)

M

Velocity 96 (f)

Comma (,)

Available when
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Function

Key command

Velocity 112 (ff)

Period (.)

Velocity 127 (fff)

Slash (/)

Sustain inserted note(s)

Hyphen (-)

Quantize note starts on/off

Q

Available when

Key commands for tools in Logic Pro
The following table reflects default Tool key commands included in the U.S. factory preset.
Tool key commands require the Tool menu to be open. See Tools overview to learn about
the Tool menu.
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Tool

Key command

Scissors tool

I

Glue tool

G

Eraser tool

E

MIDI Thru tool

Shift-M

Text tool

Shift-T

Solo tool

S

Pencil tool

P

Crosshair tool

H

Mute tool

M

Finger tool

F

Layout tool

L

Zoom tool

Y

Resize tool

Z

Voice Separation tool

J

Camera tool

C

Velocity tool

V

Quantize tool

Q

Fade tool

A

Automation Select tool

U

Automation Curve tool

W

Marquee tool

R

Flex tool

X
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Tool

Key command

Brush tool

B

Combined modifier keys and actions tables
Various windows modifier keys and actions in Logic Pro
The following table includes functions available in various windows when you use modifier
keys in combination with actions.
Function

Modifier key and action

Zoom in

Control-Option while scrolling up

Zoom out

Control-Option while scrolling down

Reset parameter to default value

Option-click a parameter

Return to previous zoom level

Option-click the background of Editor or Tracks area

Show or hide all disclosure arrows of the same type (all
those in a Track Stack, project file browser file, and so
on)

Option-click a disclosure arrow

Copy regions or events

Option key while dragging regions, events, or region
segments

Adjust multiple events or parameters to the same value

Option-Shift while dragging multiple selected events or
parameters

Select multiple regions or events

Shift-click multiple regions or events

Join regions with Glue tool

Shift-click regions with the Glue tool

Controller Assignments window modifier keys and actions in Logic Pro
The following table includes functions available in the Controller Assignments window when
you use modifier keys in combination with actions.
Function

Modifier key and action

Assign a combined hardware control action to a Mixer
or plug-in parameter

Any modifier key while moving a physical control on
hardware control surface

Tracks area modifier keys and actions in Logic Pro
The following table includes functions available in the Tracks area when you use modifier
keys in combination with actions.
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Function

Modifier key and action

Add new track (or tracks) for dragged audio files,
regions, or Apple Loops

Command key while dragging audio files, regions, or
Apple Loops between two track headers
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Function

Modifier key and action

Set marquee selection to entire region

Command-Option while clicking on a region

Set track to Solo Safe mode

Control-click Solo button in track header

Move regions by one division

Control key while dragging regions

Move regions by one tick

Control-Option while dragging regions

Snap to finest possible resolution in current snap mode

Control-Shift-click to select region

Create alias of a MIDI region or folder, or clone of an
audio region, that starts where the region was dragged

Control-Shift while dragging region or folder

Move regions by samples if zoomed in, by ticks if
zoomed out

Control-Shift while dragging region or regions

Create fade-in

Control-Shift while scrolling down from upper left
corner of audio region

Create fade-out

Control-Shift while scrolling down from upper right
corner of audio region

Create crossfade

Control-Shift while scrolling horizontally of the end of
one audio region to the beginning of an adjacent audio
region

Create new track with the same channel strip or
instrument assignment as the selected track

Option-click Duplicate Track button

Delete fade

Option-click fade area with Fade tool

Split regions into regions of equal length

Option-click with Scissors tool

Activate or deactivate Solo Lock mode

Option-click Solo button in control bar

Select entire take

Option-click take lane (with comp selected)

Open audio region in the Audio File Editor

Option key while double-clicking audio region

Move the selection end farthest from the pointer to the
pointer position

Option-Shift-click inside marquee selection

Move the selection end closest to the pointer to the
pointer position

Shift-click inside marquee selection

Extend the cycle range to the clicked position

Shift-click in cycle area of bar ruler

Select (or deselect) multiple tracks

Shift-click multiple track headers

Change marquee selection start or end point

Shift-click in Tracks area with Marquee tool

Display notes from all selected MIDI regions in the
Piano Roll Editor

Shift-click multiple MIDI regions

Restrict movement to initial drag direction

Shift key while dragging horizontally or vertically
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Global tracks modifier keys and actions in Logic Pro
The following table includes global track functions available when you use modifier keys in
combination with actions.
Function

Modifier key and action

Delete marker

Command key while dragging a marker down (with
global tracks not displayed)

Rename marker

Command-Shift while double-clicking a marker (with
global tracks not displayed)

Set cycle start and end points to the start and end of
the clicked marker

Command-Shift-click a marker (with global tracks not
displayed)

Set playhead to the start of clicked marker

Option-click a marker

Open Marker Text window

Option key while double-clicking a marker

Open Signature List

Shift key while double-clicking a Signature track

Automation modifier keys and actions in Logic Pro
The following table includes automation functions available when you use modifier keys in
combination with actions.
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Function

Modifier key and action

Adjust automation points or curve values in fine
increments

Control key while dragging automation points or curves

Temporarily change pointer to the Automation Curve
tool and bend the automation curve

Control-Shift while dragging an automation curve

Add one automation point at each selection border

Control-Shift while dragging across selected regions
when in Automation mode

Add two automation points at each selection border

Control-Shift-Option while dragging across selected
regions when in Automation mode

Select all automation following a previously selected
automation curve

Option-click on an automation curve

Toggle between stepped and interpolated automation
data

Option-click an automation curve with the Automation
Curve tool

Select automation data immediately before, and all
automation data after, a selected automation point

Option-click on an automation point

Create a series of automation points in a curved or
a stepped formation (depending on the Pencil Tool
setting in the Automation preferences)

Option-click while dragging on an automation curve
with the Pencil tool

Select specific automation values within a time range

Option key while dragging across a range of
automation curves

Increase or decrease automation curve between the
two points

Option-Shift while dragging an automation curve
selection between two horizontally aligned points

Select noncontiguous automation points and/or curves

Shift-click across multiple noncontiguous automation
points and/or curves
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Function

Modifier key and action

Select noncontiguous automation points and/or curves

Shift key while dragging across multiple noncontiguous
automation points and/or curves

Live Loops Grid modifier keys and actions in Logic Pro
The following table includes Live Loops Grid functions available when you use modifier
keys in combination with actions.
Function

Modifier key and action

Queue cell or scene for playback

Option-click at the center of a cell or trigger of a scene

Copy cell to another row

Option key while dragging a cell

Add or remove cells from multiple-cell selection

Shift-click upper part of cells

Create new track for each dragged item

Shift key while dragging multiple items to empty area
below Live Loops Grid

Mixer modifier keys and actions in Logic Pro
The following table includes functions available in the Mixer when you use modifier keys in
combination with actions.
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Function

Modifier key and action

Open software instrument editor of a software
instrument channel strip, or first audio plug-in of an
audio channel strip

Command key while double-clicking track icon

Activate or deactivate Solo Safe mode for the channel
strip

Control-click Solo button

Bypass plug-in

Option-click plug-in slot

Open audio effect plug-in menu with the Legacy
submenu visible

Option-click audio effect plug-in menu

Add Channel EQ plug-in in the top Audio Effect slot

Option key while double-clicking the EQ display

Copy plug-in from one channel strip to another

Option key while dragging plug-in between channel
strips

Add Linear Phase EQ plug-in in the top Audio Effect
slot

Option-Shift while double-clicking the EQ display

1087

MIDI Environment window modifier keys and actions in Logic Pro

The following table includes functions available in the MIDI Environment window when you
use modifier keys in combination with actions.
Function

Modifier key and action

Move selected object to the chosen layer

Option key while choosing a layer from the Layer menu

Piano Roll Editor modifier keys and actions in Logic Pro

The following table includes functions available in the Piano Roll Editor when you use
modifier keys in combination with actions.
Function

Modifier key and action

Temporarily change the pointer to the Velocity tool and
adjust velocity

Command-Control while dragging vertically on one
note

Move notes in finer increments (the exact increment
value depends on the Snap value and zoom level)

Control key while dragging notes

Use division value shown in the transport for the
editing grid

Control key while editing operation

Add note at the exact position clicked, regardless of
Snap value

Control-Shift while clicking with the Pencil tool

Move notes in ticks

Control-Shift while dragging notes

Use ticks as division value for the editing grid

Control-Shift while editing operation

Adjust selected notes to the same length

Option-Shift while dragging notes

Adjust selected notes to the same velocity

Option-Shift while dragging with the Velocity tool

Select all notes at the selected MIDI pitches

Shift-click multiple music keyboard keys

Adjust ends of all selected notes to the same position

Shift key while dragging the ends of multiple selected
notes

Add multiple notes with the same pitch and time
settings

Shift key while dragging horizontally with the Brush
tool

Score Editor modifier keys and actions in Logic Pro

The following table includes Score Editor functions available when you use modifier keys in
combination with actions.
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Function

Modifier key and action

Adjust velocity of the note

Command key while dragging up or down on a note

Copy note or symbol to another position from the same
MIDI region

Option key while dragging a note or symbol on a staff

Drag symbol or independent note from the part box to
any position

Option key while dragging a symbol or independent
note from the part box

Reposition global text objects vertically or horizontally

Shift key while dragging with the Pointer tool on text
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Event List modifier keys and actions in Logic Pro
The following table includes Event List functions available when you use modifier keys in
combination with actions.
Function

Modifier keys and actions

Override parameter’s maximum or minimum value
limitation

Option key while dragging the parameter value

Set parameter to the same value for all selected events

Option-Shift while dragging the parameter value

Step Editor modifier keys and actions in Logic Pro
The following table includes Step Editor functions available when you use modifier keys in
combination with actions.
Function

Modifier key and action

Select multiple steps whether contiguous or not

Shift-click individual steps

Select all steps in the clicked lanes

Shift-click one or more lane names

Select multiple contiguous steps

Shift key while dragging across contiguous steps

Step Sequencer modifier keys and actions in Logic Pro
The following table includes Step Sequencer functions available when you use modifier
keys in combination with actions.
Function

Modifier key and action

Turn steps on or off

Command-click steps in Value or Velocity edit mode

Select steps

Shift-click steps in any edit mode except Loop Start/
End

Flex Time modifier keys and actions in Logic Pro
The following table includes Flex Time functions available when you use modifier keys in
combination with actions.
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Function

Modifier key and action

Move flex marker without time stretching

Option key while dragging a flex marker
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Use the Touch Bar with Logic Pro

Overview of Touch Bar shortcuts in Logic Pro

If your computer has a Touch Bar, you can use gestures to start and stop playback and
recording, navigate through your song, adjust track and instrument levels, and play
instruments. The controls in the main area of the Touch Bar (to the right of the Control
Strip) change depending on the Touch Bar screen you are using and your selections
in the app.

For more information about the Control Strip button, see MacBook Pro Essentials. To
learn more about the Touch Bar, see the Apple Support article Use the Touch Bar on your
MacBook Pro.
Note: If your computer has a Touch Bar that features the Esc (Escape) control, you can use
it to perform a number of standard functions. For example, tap Esc to return an application
in Full Screen mode to normal view. This control can also operate as the Cancel button in
dialog windows, and close some pop-up windows.

Toolbar screen shortcuts
These shortcuts appear in the Touch Bar when you first open Logic Pro.
Icon
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Name

Description

Go to Selection Start

Moves the playhead to the
beginning of the selection.

Play from Selection

Starts playback from the beginning
of the selection.

Go to Project Start

Places the playhead at the
beginning of your project.
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Icon

Name

Description

Play or Stop

Starts or stops playback at the
current playhead position.

Record

Starts recording on record enabled
tracks at the current playhead
position.

Cycle

Turns Cycle mode on or off.

Move Locators Backward by Cycle
Length

Moves the locators backward by the
Cycle length.

Move Locators Forward by Cycle
Length

Moves the locators forward by the
Cycle length.

Smart Controls screen shortcuts
When you tap the Smart Controls button in Logic Pro, the following controls appear in the
Touch Bar.
Icon

Name

Description

Smart Controls

Switches to the Configuration
screen.

Level

Hold the Level button until it
becomes a Level slider. Drag the
Level slider to adjust the volume of
the track. Release the button when
you are done.

You can also tap the Level button
to switch to the Level slider screen.
On this screen, drag the Level slider
to adjust the volume of the track,
then tap the Close button to the left
of the Level slider to return to the
previous screen.
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The remainder of the Smart Controls screen shows buttons for the screen controls in the
Smart Controls pane. The buttons change for each type of track and available effects.

To adjust the Smart Controls using the Touch Bar in Logic Pro:
•

Buttons controlling levels (the button has a colored line under the text indicating a
slider): Touch and hold the button until the slider appears, and drag to adjust the slider.
Release the button when you are done.
You can also tap the button to switch to a slider screen. In the slider screen, drag the
slider left or right to adjust the slider, then tap the Close button to return to the Smart
Controls screen.

•
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Buttons not controlling levels (no colored line under the text): Tap the button to either
access additional buttons or toggle a control on or off, depending on the button.
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Configuration screen shortcuts
These shortcuts appear in the Touch Bar on the Configuration screen in Logic Pro. Note
that the fifth button is different for each track type.
Icon

Name

Description

Close

Returns you to the previous screen.

Smart Controls

Returns you to the Smart Controls
screen.

Overview

Switches to the Overview screen.

Key Commands

Switches to the Key Commands
screen.

The fifth button on the Configuration screen changes based on what kind of track is
selected in the Tracks area:
Icon

Name

Description

Audio

Switches to the Audio screen (audio
tracks only).

Keyboard

Switches to the Keyboard screen
(instrument tracks only).

Drum Pads

Switches to the Drum Pads screen
(Drummer or drum instrument
patches only).

Overview screen shortcuts
The Overview screen is a representation of the Tracks area in Logic Pro, with each track
appearing as a thin colored line. The view rectangle shows the part of the song currently
visible, with the vertical line showing the playhead position.
The Overview button remains visible at the left of the Overview screen:
Icon

Name

Description

Overview

Returns you to the Configuration
screen.

To use the Overview to navigate through your song:
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•

Drag the view rectangle left or right to move the visible area of the project.

•

Drag the line to move the playhead.
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Key Commands screen shortcuts
When you tap the Key Commands button
, the following controls appear by default.
Some buttons change depending which window or editor is in focus.
Icon

Name

Description

Key Commands

Returns you to the Configuration
screen.

Go to Selection Start

Places the playhead at the
beginning of the selection.

Play from Selection

Starts playback from the beginning
of the selection.

Go to Project Start

Places the playhead at the
beginning of your project.

Play or Stop

Starts or stops playback at the
current playhead position.

Record

Starts recording on record enabled
tracks at the current playhead
position.

Cycle

Turns Cycle mode on or off.

Move Locators Backwards by Cycle
Length

Moves the locators backward by the
Cycle length.

Move Locators Forward by Cycle
Length

Moves the locators forward by the
Cycle length.

When you press the Command key, the following controls appear in the Key Commands
screen by default:

Icon
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Name

Description

Key Commands

Returns you to the Configuration
screen.

Split Regions at Playhead

Splits the selected regions at the
current playhead position.

Split by Locators

Splits the selected regions at the
current locator positions.
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Icon

Name

Description

Crop

When an audio region is selected,
removes all parts of selected
regions that fall outside its marquee
selection.

Legato

When a MIDI Editor is in focus, trims
Note End to the value selected in
the MIDI Editor.
Join Regions

Joins multiple selected adjacent
regions into one contiguous region.

Repeat

Repeats selected events or regions.

Repeat Section

Duplicates the project section that
falls within the locator positions.
The duplicated section is pasted at
the right locator.

Quantize Selected Events

When a MIDI Editor is in focus,
quantizes selected events to the
value selected in the MIDI Editor.
Shuffle Left

Shuffles the selected regions left.

Shuffle Right

Shuffles the selected regions right.

When you press the Option key, the following controls appear in the Key Commands screen
by default:

Icon
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Name

Description

Key Commands

Returns you to the Configuration
screen.

Pointer tool

Switches to the Pointer tool.

Marquee tool

Switches to the Marquee tool.

Scissors tool

Switches to the Scissors tool.

Glue tool

Switches to the Glue tool.

Pencil tool

Switches to the Pencil tool.

Fade tool

Switches to the Fade tool.

Brush tool

Switches to the Brush tool.

Finger tool

Switches to the Finger tool.
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When you press the Control key, the following controls appear in the Key Commands
screen by default:

Icon

Name

Description

Key Commands

Returns you to the Configuration
screen.

Show/Hide Automation

Shows or hides track automation.

Touch/Read

Toggles the automation mode for
the selected track between Touch
and Read.

Read/Off

Toggles the automation mode for
the selected track between Read
and off.

Flex

Shows or hides Flex.

Enable Groups

Activates or deactivates Groups.

Add Audio Track

Adds a new audio track below the
selected track.

Add Instrument Track

Adds a new software instrument
track below the selected track.

Add Drummer Track

Adds a new Drummer track below
the selected track.

When you press the Shift key, the following controls appear in the Key Commands screen
by default:

Icon

Name

Description

Key Commands

Returns you to the Configuration
screen.

Colors

Opens the Color palette.

Show/Hide Audio Channel Strips
Show/Hide Instrument Names
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When the Mixer is in focus, shows
or hides all audio channel strips.

When the Score Editor is in focus,
shows or hides Instrument names.
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Icon

Name

Description

Tuner

When an audio track is selected,
this button turns the Tuner on or off.

Show/Hide Instrument Channel
Strips
Show/Hide Page Rulers

Selection-based Processing

Show/Hide Auxiliary Channel Strips

Plug-ins

When the Mixer is in focus, shows or
hides all instrument channel strips.
When the Score Editor is in focus,
shows or hides the page rulers.

Opens the Selection-based
Processing window.

When the Mixer is in focus, shows or
hides the auxiliary channel strips.

Show/Hide Output Channel Strips

Opens the Plug-in window for the
first plug-in on the selected track.

Event Float

Opens an Event Float window.

Groups

Opens the Groups inspector.

Note Repeat

Transforms incoming MIDI notes
into repeated MIDI notes of the
same pitch.

Spot Erase

When recording in Cycle mode, click
to temporarily use incoming notes
to delete any matching notes in the
region as the playhead passes over
them.

Show/Hide Output Channel Strips

When the Mixer is in focus, shows
or hides the output channel strips.

When the Mixer is in focus, shows
or hides the output channel strips.

You can use the Key Commands window in Logic Pro to replace the default commands
on any of the Key Commands screens and to add additional commands to custom Key
Commands screens. See Assign key commands for more information.
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Audio screen shortcuts
When you tap the Audio button on the Configuration screen, the Touch Bar shows the
following controls:
Icon

Name

Description

Input

Tap the Input button to access
the Input selector screen. Tap the
desired input format (mono or
stereo) and the desired audio input
for the selected track. Tap Close to
return to the Audio screen.

Gain slider

Drag the slider to adjust the input
gain for the selected track.

Record Enable

Enables recording for the selected
track.

Input Monitoring

Activates input monitoring for the
selected track.

Level slider

Drag the slider to adjust the volume
for the selected track.

Keyboard screen controls
When you tap the Keyboard button
, you can use the Touch Bar to play the current patch
on the selected software instrument track.
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•

Tap the keys on the Touch Bar keyboard to play notes.

•

To adjust the octave range of the Touch Bar keyboard, tap one of the Keyboard Octave
buttons to the left of the Touch Bar keyboard.

•

To limit notes to a musical scale: Tap the Scale button, then tap to select the root note
and the mode.

•

Tap the Close button

to return to the previous Touch Bar screen.
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Drum Pads screen shortcuts
When you tap the Drum Pads button, you can use the Touch Bar to play the drums on a
Drummer or software instrument track with a drum kit patch.
Icon

Name

Description

Close

Closes the Drum Pads screen.

Banks

Selects between three banks of
percussion instrument icons.

Repeat

Tap the Repeat button to reveal
the Repeat slider. Drag the line to
the desired note division. Tap the
Repeat icon to repeat the held pad.

Velocity

Tap Velocity button to access the
Velocity slider. Drag the line to the
desired velocity.

Drum Pad instruments

Triggers the sound represented by
the button.

Repeat slider

Velocity slider

To play a drum instrument in Logic Pro using the Touch Bar:
•

Tap a specific Drum Pad button to trigger the sound.
It plays at the velocity reflected in the Velocity slider.

Logic Pro User Guide

1099

Use control surfaces

Control surface requirements in Logic Pro

To use a hardware control surface to give you tactile control over Logic Pro, you need to
connect, add, and configure your control surface device for use with Logic Pro. The setup
procedures and preferences are common to all directly supported control surfaces.
Important: All macOS computers support built-in MIDI Device Profiles (MDPs) and control
surface plug-ins. macOS computers with Intel processors also support control surface
plug-ins from manufacturers other than Apple. Refer to the device manufacturer’s support
documentation to see if an MDP or plug-in is available.
Important: If you are using a MIDI controller that is supported by a Lua script, see
Automatic assignment for USB MIDI controllers. Information presented in MIDI Controllers
preferences and other topics may also apply. Some of these additional options may be
useful for your project.
To use one or more control surfaces with Logic Pro, you need:
•

A Mac running Logic Pro.

•

For devices equipped only with MIDI ports: A MIDI interface with a free MIDI input and
output port for each device. For example, if you are using a MIDI interface with eight
MIDI input and output ports—with one Mackie Control and one Mackie Control XT unit—
you need to use two MIDI In ports and two MIDI Out ports.

•

For all other supported devices: An available peripheral port. Ideally, this should be
a direct connection with the computer, rather than through a hub. However, if the
peripheral ports on your Mac don’t match that on your device—for example, if you have
a device that requires a FireWire port, but your Mac only offers USB/Thunderbolt ports—
you may have to use an adapter or a hub. Refer to the documentation provided by the
manufacturer of your device.

•

An installed driver (if required by your control surface) supported by the macOS version
running on your computer.

Important: The driver software for your MIDI interface must support SysEx communication.
Consult the documentation for your MIDI interface (or MIDI interface drivers).
In a standard control surface configuration you can use a single control surface, or several.
Each device can run independently or can be part of a control surface group comprised of
multiple devices as described in Grouping control surfaces.
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The number of devices that can be used simultaneously depends on the number of free
ports available on your system. Using multiple control surfaces allows you to control more
tracks and channels, effects, and other parameters simultaneously.

Connect control surfaces in Logic Pro

Logic Pro supports many control surfaces that connect to your computer via USB,
Ethernet, MIDI, and so on. You may need an adapter or interface to connect your control
surface—for example, if your control surface connects via MIDI, you may need a USB MIDI
interface in order to connect your control surface, or if your device connects via Ethernet,
you may need an Ethernet-to-USB-C converter. Before connecting the device, read the
installation instructions included with it, and install the latest version of any appropriate
firmware or driver software, if required. For more information, refer to the documentation
provided with the device.
Note: Some control surfaces allow you to connect footswitches or pedals as additional
controllers. If your control surface features suitable connectors, you can use optional
footswitches to remotely control playback and other functions. This frees your hands for
other controls and is helpful when using guitars or other instruments that require twohanded playing.

Connect a control surface to your computer

1. To use a control surface with Logic Pro, connect your control surface directly to your
computer. See your control surface documentation for the specific type of cable
required.
Most control surfaces transmit and receive data through a single cable, if the device
supports bidirectional communication. For more information, see the documentation for
your control surface
Important: It is recommended that you connect control surface devices directly to your
computer, rather than through a hub. Daisy-chaining devices can result in errors and
other problems, due to the amount of data transmitted in real time.

The diagram illustrates a typical setup using a single cable between computer and
control surface.
2. Once connected, press the power switch on your control surface if applicable. Some
devices are automatically powered when connected and have no physical power switch.
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When powered, its displays (such as an LCD, if your device has one) and/or LEDs are lit.
Some LCDs display a welcome message, which includes the firmware version number.
On most control surfaces with motorized faders, each fader slides to its top position,
then back to its bottom or center position. This self-diagnostic initialization procedure
indicates that your units are functioning correctly.
Note: Generally, you can turn on your computer either before or after you turn on
the control surface. Some devices, however, may require the computer to be turned
on before or after the device has initialized. Check the device documentation and
manufacturer website.

Connect a MIDI control surface

1. To use a MIDI control surface with Logic Pro, connect your MIDI control surface to a
MIDI interface, and connect the MIDI interface to your computer.
MIDI interfaces are typically connected to your computer via USB. MIDI uses separate
ports for input and output, and you must connect both the MIDI input and output to use
the device with Logic Pro. The diagram illustrates a typical setup using MIDI input and
output:
Important: You should not daisy-chain other MIDI devices via a MIDI through port to the
MIDI In or Out ports used by control surfaces. Daisy-chaining can result in errors and
other problems due to the amount of MIDI control data transmitted in real time.

The diagram illustrates a control surface MIDI connection.
2. Once connected, press the power switch on your control surface if applicable. Some
devices are automatically powered when connected and have no physical power switch.
When powered, its displays (such as an LCD, if your device has one) and/or LEDs are lit.
Some LCDs display a welcome message, which includes the firmware version number.
On most control surfaces with motorized faders, each fader slides to its top position,
then back to its bottom or center position. This self-diagnostic initialization procedure
indicates that your units are functioning correctly.
Note: Generally, you can turn on your computer either before or after you turn on
the control surface. Some devices, however, may require the computer to be turned
on before or after the device has initialized. Check the device documentation and
manufacturer website.
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Add a control surface to Logic Pro

Some control surfaces such as Mackie Control are detected automatically when you
open Logic Pro. You can add other devices that are not detected automatically using the
Setup window. See the installation and setup information in the support materials for your
particular device. Some devices may require different or additional steps, but in most cases
you only need to select the name of the device you want to use with Logic Pro, then add it.
When you add a control surface device, it is represented by an icon in the Device area of
the Control Surface Setup window.
Note: All macOS computers support built-in MIDI Device Profiles (MDPs) and control
surface plug-ins. macOS computers with Intel processors also support control surface
plug-ins from manufacturers other than Apple. Refer to the device manufacturer’s support
materials to see whether an MDP or plug-in is available.
Important: Logic Pro automatically recognizes MIDI controllers supported by Lua
and displays them in the Control Surfaces Setup and Install windows. See Automatic
assignment for USB MIDI controllers if you are using a Lua-supported keyboard or desktop
controller.

Add a control surface by scanning

1. Choose Logic Pro > Control Surfaces > Setup to open the Control Surfaces Setup
window.
2. In the Setup window, choose New > Install, then select the device from the list. You
can select more than one model by Command-clicking multiple entries in the list. If
you select more than one model, Logic Properforms the operation for each model
sequentially.
Note: If you don’t want to select the models to be scanned, you can choose New > Scan
All in the Setup window to search for all supported control surface types on all ports.
This process may take a few minutes.
3. Click the Scan button. You can also press Enter, or double-click the device name to
initiate the scanning process.
Logic Pro scans your system for connected devices, and automatically installs (and
connects to) all found devices.
4. Close the window when all devices are added to your system.

Add a control surface manually

Some control surfaces don’t support automatic scanning. Such devices must be added
manually. When you add a device manually, you also need to assign the appropriate MIDI In
and Out port parameters.
Note: It is preferable to install devices by scanning whenever possible. Logic Pro is able to
gather more information about devices through scanning than with manual installation.
1. Choose Logic Pro > Control Surfaces > Setup to open the Control Surfaces Setup
window.
2. In the Setup window, choose New > Install, then select the device from the list.
3. Click the Add button.
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If another control surface of the selected type already exists in your setup, a warning
dialog asks you to confirm the addition of the new device.
You need to manually alter the MIDI In and Out port values (in the Device parameters of
the Setup window) to match those of the connected unit.
Note: You can reinitialize the support of all connected control surfaces by choosing
Logic Pro > Control Surfaces > Rebuild Defaults.
4. Close the window when all devices are added to your system.

Automatic assignment for USB MIDI controllers
in Logic Pro

Logic Pro supports automatic assignment of hardware controls for a variety of USB MIDI
controllers. This is achieved through use of Lua scripts. Devices supported by Lua scripts
appear in the Control Surfaces Setup window and the Install window.
When a supported USB MIDI controller is connected, the knobs, sliders, and other
hardware controls are automatically assigned to Smart Controls and other Logic Pro
functions.
•

Switches (buttons) are assigned to onscreen buttons and key commands. As examples,
hardware buttons for common transport functions (including Play, Stop, Pause, Record,
and Cycle), marker functions (including Previous Marker, Next Marker, and Add Marker),
and other functions are assigned to the corresponding key commands for these
functions.

•

Knobs are assigned to knob screen controls. If the device is equipped only with faders,
onscreen knob controls are assigned to faders.

•

Faders are assigned to fader screen controls (or knob screen controls if the device
only has faders), with the following exception: when the controller has only one fader,
labeled Volume, that fader is assigned to mixer volume for the selected channel strip.

•

Assignments created by Lua scripts are created within a separate top level, modeless,
zone that is named after the device. These assignments are always active and interact
with Control Surface Group 1. See Zones and modes for further information.

Important: Some USB MIDI controllers, such as those from Arturia, use MIDI Machine
Control (MMC) commands for Transport button functions. If using a device of this type,
enable the Listen to MMC checkbox in the File > Project Settings > Synchronization > MIDI
pane. For more information see MIDI Synchronization settings.

Enable a USB MIDI controller for automatic assignment

The first time you connect a Lua script supported USB MIDI controller to Logic Pro a dialog
appears, asking if you want to use the device as a control surface.
•

Click Auto Assign to automatically assign the controls on the device to Smart Controls
and other Logic Pro functions.

•

Click No to use the device as a MIDI controller without automatic assignment.

You can change the setting for each connected device in Logic Pro > Control Surfaces >
Preferences > MIDI Controllers. For more information, see MIDI Controllers preferences.
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Create control surface groups in Logic Pro

If you have multiple control surface units, you can define how they relate to each other by
creating control surface groups. A control surface group consists of multiple devices that
you combine to create a single, unified virtual control surface.
You can create up to 20 control surface groups. Each group can consist of any number of
physical devices. The only limiting factor is the number of available ports.
You can independently determine the default behavior of each device in a group. For more
information, see Device parameters.
Note: Assignments created by Lua scripts are created within a separate top-level modeless
zone that is named after the device. These assignments are always active and interact with
Control Surface Group 1.

Create a control surface group

1. Choose Logic Pro > Control Surfaces > Setup to open the Control Surfaces Setup
window.
2. In the Setup window, drag the icons of control surfaces you want to group so they form
a single horizontal row.
The order of icons from left to right defines the order in which tracks and parameters
are arranged and displayed on grouped devices.

Use two control surfaces independently

1. Choose Logic Pro > Control Surfaces > Setup to open the Control Surfaces Setup
window.
2. In the Setup window, arrange the control surface icons in separate rows—that is, one
above the other.
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Pictured below is a multiple group example with several devices:

The top row, consisting of the Logic Control and Logic Control XT, forms a single control
surface group with 16 channels. Logic Control controls channels 1 to 8 and the XT unit
controls channels 9 to 16.
In the second row, the HUI and Mackie Control C4 form a second control surface group,
controlling instruments (on channels 1 to 8) and auxes (on channels 9 to 16).
In the third row, the Oxygen 25 forms a single unit control surface group.
Each group has individual settings, such as Flip mode, Display mode, Plug-in Parameter
Bank Offset, and others. This allows you to access, edit, and automate different sections of
the Logic Pro Mixer.
In the example above, the units in the top row could be used to control audio and MIDI
channel strips. In the second row, the HUI could be used to edit group definitions, and the
C4 could be used to control aux channel strips 1 to 8. The Oxygen 25 is a Lua supported
device and is set to a default modeless zone assignment. The physical placement of units
and the way you use them are completely flexible.
Note: In most situations, the placement of your control surface units in relation to each
other should be the same onscreen as in the real world.
Once you have created a control surface group, you can change the way it operates in the
Setup window. For more information, see Control Surface Group parameters overview.
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Control surface inspector
Overview of Control surface inspector in Logic Pro

The right area of the Control Surfaces Setup window shows the Device area. This area
offers a visual representation of every control surface device and control surface group
available. Select an icon to set up and configure that device using the parameters on
the left. See Device parameters, Special device parameters, and Control Surface Group
parameters. You can configure directly supported control surfaces by editing these
parameters. For an overview of editing control surface device parameters, see Control
Surface Group parameters overview.
Important: Any changes to settings (in the Setup window or from the device) are saved in
a preferences file, named “com.apple.logic.pro.cs.” It is found here: ~/Library/Preferences/.
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Control surface Device parameters in Logic Pro

Device parameters
•

Output Port pop-up menu: Choose the MIDI output port for your control surface from
the pop-up menu.

•

Input Port pop-up menu: Choose the MIDI input port for your control surface from the
pop-up menu.
Each control surface must be connected to an independent MIDI In and Out port (or
corresponding USB port, designated as a MIDI port by the device driver). When the
device is added, the automatic setup or scan procedure sets the appropriate MIDI input
and output port settings for the device. If the MIDI port settings are incorrect, you can
manually choose them from the Input and Out Port pop-up menus.

•

Module field: Shows the internal control surface support module being used by the
control surface.

•

Model field: Shows the model name of the control surface.
If your control surface device is internally supported by a module that was developed
for a different device than the module and model names, the module and name fields
will reflect the internally supported device, rather than the attached device. For
example, the Presonus Faderport is directly supported in Logic Pro via the Logic Control
module, so when you connect the Presonus Faderport, the Module field shows “Logic
Control” and the Model field shows “Mackie Control.”
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•

Version field: Shows the firmware version for control surfaces which report that
information. For control surface devices that do not present this information to Logic
Pro, the field is blank.

•

Color field: Click to choose a color from the color picker to indicate tracks controlled by
this control surface. In the Tracks area and Mixer, tracks controlled by this device are
marked by a bar in the chosen color when control surface bars are displayed. For more
information on control surface bars, see View control surface bars.
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•

Fader Bank Offset field: Sets the offset for the faders of the control surface device.
The offset determines which channel strips in the Mixer the device’s hardware faders
control.
Usually, when a device is added to a control surface group, the device is added to the
right of the other devices in the group, and its device icon is placed to the right of
existing device icons. The new addition to the control surface group is assigned a fader
bank offset based on how many faders are present in the other devices to the left of the
new device. For example, if there are two control surface devices, each with 8 faders,
to the left of the new device, the new device is assigned a Fader Bank Offset of 16. By
changing this parameter manually, you can choose specific banks of faders to control
specific channel strips in the Logic Pro Mixer.
As an example, Mackie C4 with 8 faders creates a control surface group with a Mackie
Control, also with 8 faders. By default, the Mackie Control would have a Fader Bank
Offset of 8, and control channel strips 9-16 in the Logic Pro Mixer. However, you may
want to dedicate the Mackie Control to VCA channel strips in positions 17-24 in the
Mixer. In this case, you could set a Fader Bank Offset of 16 so that the Mackie Control’s
channel strips would correspond to the VCA channel strips in the Mixer.
See Overview of Control Surface Group parameters to learn more about control surface
groups.

•

Live Loops Scene Offset field: Sets the Live Loops scene offset for the device within a
control surface group. The offset determines which scenes the device’s scene buttons
control.
Usually, when a grid-oriented loop-triggering hardware device such as the Novation
Launchpad is added to an existing control surface group, the new device is added to
the right of existing devices, its icon is added to the right of the existing device icons,
and the new device is given a scene offset based on the number of scenes can be
controlled by loop-triggering devices before the new device in the group. For example,
if a Launchpad is added to an existing control surface group consisting of a Launchpad
Pro and Launchpad Mini both of which can control 8 scenes each, the new Launchpad
is assigned a Live Loops Scene Offset of 16. If instead, you want the new Launchpad to
control scenes 25-32, set a Live Loops Scene Offset of 24.
Note: When multiple Launchpads are added to a control surface, the Live Loops Scene
Offset determines which scenes they control, but all the devices will control channel
strips 1-8 in the Logic Pro Mixer. Both Launchpad scene and fader control can be
globally offset using the control surface group parameters Fader Bank for Tracks View
and Live Loops Column Bank in the Control Surface Group inspector, or by using the
Launchpad’s cursor keys. See Overview of Control Surface Group parameters to learn
more about control surface groups, and Novation Launchpad in Use Control Surfaces in
Logic Pro.
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Control surface Special parameters in Logic Pro

Some control surfaces allow you to define special parameters such as fader touch
sensitivity. When a device that offers such parameters is connected, these special
parameters area appears in the inspector. Here are some special parameter that appear if
you have one of these devices:

OSC Devices
•

Host Name field: Shows the name of the network host for the OSC connected device.

•

Output Port field: Shows the network port number for outgoing OSC messages.

•

Input Port field: Shows the network port number for incoming OSC messages.

Novation Launchpad
•

Orientation field: Sets the orientation of the Novation Launchpad grid either 90 degrees
left or 90 degrees right, in order to match Logic Pro’s grid orientation. Choose the
orientation that places the Launchpad control buttons where you prefer them.

Logic Control (and Mackie Control)
•

Transport button click checkbox: Turns on or off the audible click sound when you press
one of the transport buttons.

•

Touchless moveable faders checkbox: Turns on or off the touch sensitivity of the faders.
This can improve performance if something is blocking the capacitance of your finger,
for example, if you are wearing gloves.

•

Fader Touch Sensitivity field: Fine tunes the touch sensitivity of the faders. If you feel
that the faders are too jumpy when you touch them, lower this value. If you feel the
faders are not responsive enough when you touch them, raise this value.

•

Backlight Saver Timeout (min) field: Sets the number of minutes before the LCD
backlight saver function switches off the LCD display of the device. Reduce this value
if you want the display to turn off sooner. Increase this value if you want the display to
remain on longer.

•

Serial No. field: Shows the device serial number.

Recording Light
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•

MIDI Status pop-up menu: Choose the type of MIDI message that is sent to the
recording light device. Generally, this will be a “MIDI note on” message, but other data
types can be transmitted.

•

MIDI Channel pop-up menu: Sets the MIDI channel that data is sent on.

•

Data 1: Any Record Ready LED pop-up menu: Choose how the Recording Light device
responds to a track being record-enabled in Logic Pro.

•

Data 1: Recording pop-up menu: Choose how the Recording Light device responds
when the Record button is engaged in Logic Pro.

•

Data 2: On Value field: Choose the value for the MIDI event that is sent to turn on the
Recording Light device. Typically this value is 127.
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Control Surface Group parameters
Overview of Control Surface Group parameters in Logic Pro
If you have created one or more control surface groups, you can configure these groups in
the Control Surface Group parameters window. These parameters apply only to the group
associated with the selected device and allow you to customize each group to meet your
needs. Many group parameters can also be changed directly from the control surface.
Note: Lua script supported devices have a default modeless assignment.
Control Surface Group parameters are divided into several areas. See Control Surface
Group display parameters, Control Surface Group send and plug-in parameters, and
Control Surface Group other parameters.

Control Surface Group display parameters in Logic Pro
The upper Control Surface Group parameters control aspects of device displays.
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Display parameters
•

Flip Mode pop-up menu: Choose functions for the faders and rotary encoders of
channel strips on the device. For control surfaces that have a fader and a rotary
encoder for each channel strip, Flip mode allows you to assign both controls to the
same parameter, or to swap their assignments. The choices are:
•

Off: Default flip mode, with the fader acting as a volume control.

•

Duplicate: Assigns both the fader and the encoder to the currently selected encoder
parameter.

•

Swap: Switches the fader and encoder assignments, making the fader a pan control
and the encoder a channel volume control, for example.

•

Mute: Disables the fader. This is useful when recording in the same room as the
control surface and you want to avoid the mechanical noise of the faders. Any
existing automation still functions normally.

•

Display Mode pop-up menu: Choose to display either the name or the value of the
current parameter on the display of your control surface.

•

Clock Display pop-up menu: If your control surface features a position display, you can
choose to represent it as either Beats (musical values) or SMPTE (absolute time values).
Note: The exact elements displayed, and thus their positions, depend on the selected
Displays preferences defined in General Display preferences.

•

Channel Strip View Mode pop-up menu: Determines how channel strips on your control
surface corresponds with Logic Pro channel strips. Choose one of the following views:
•

Arrange: The channel strips on the device correspond to Logic Pro channel strips.
The layout of channel strips matches the order of tracks shown (from top to bottom)
in the Tracks window. Channel strip 1 in the Mixer window is equivalent to channel 1
on the control surface, channel strip 2 in the Mixer is equivalent to channel 2, and so
on. Instruments and channels used by multiple tracks are merged into one channel.
This is the default mode of most devices.

•

All: The channel strips on the device correspond to Logic Pro channel strips of
certain types, such as MIDI or aux channels, independent of their use in tracks.
Control surfaces that support this view generally allow you to define which channel
types you want to display. The contents of the Logic Pro Mixer window automatically
follow the state of the control surface when View > Link Control Surfaces is turned
on.

•

Tracks: This view is similar to Arrange view, but individual channel strips are shown
when multiple tracks address the same channel. Typically, this is a software or MIDI
instrument channel, with several tracks routed to it.

•

Single: This view shows a single channel and its routing to auxes and so on. You can
define the editable parameters.

Note: The View is a property of the control surface group, not a global setting. One
group can display busses, while the other shows tracks, for example.
•
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Fader Bank for Tracks View field: Drag vertically, or enter an integer value to offset
tracks that are controlled by channel strips on the device in Tracks view. For example,
if your device has eight channel strips, these might normally be assigned to Logic Pro
audio channel strips 1–8. If you set this parameter to 2, the device channel strips would
control Logic Pro channel strips 3–10 (1 + 2 = 3).
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•

Fader Bank for All View field: Drag vertically, or enter an integer value to offset Logic
Pro channel strips that are controlled by the device in All view. This parameter is
available only when multiple channel strip types are displayed in the Mixer. When
single channel strip types are displayed, there are separate fader bank parameters (not
displayed in the parameter list).

•

Live Loops Column Bank field: Drag vertically, or enter an integer value to offset the
horizontal banking of Live Loops controllers such as the Novation Launchpad. For more
information on Live Loops columns, see Live Loops overview.

•

Channel Strip Parameter pop-up menu: Choose the function controlled by channel strip
encoders on the device. The choices are:

•

•

Volume: Channel strip encoders on the device set channel volume.

•

Pan: Channel strip encoders on the device set channel panorama position.

•

Format: Channel strip encoders on the device select channel format.

•

Input: Channel strip encoders on the device select channel input source.

•

Output: Channel strip encoders on the device select channel output (main outs/
auxes/surround).

•

Automation: Channel strip encoders on the device select channel automation mode.

•

Group: Channel strip encoders on the device set group membership of the track.
Editing the parameter allows you to set either “no group” or a single group. Enabling
membership of multiple groups is not possible. (This can only be done directly in the
Mixer.)

•

Displayed Par.: Channel strip encoders on the device set value of the automation
parameter selected in the Tracks window. This is especially useful if you set the
control surface to Arrange view, and your Tracks window shows multiple automation
subtracks.

Surround Parameter pop-up menu: Choose the surround parameter that rotary encoders
control. The choices are:
•

Angle: Rotary encoders on the device set surround angle.

•

Diversity: Rotary encoders on the device set surround diversity (direction).

•

LFE: Rotary encoders on the device set LFE level.

•

Spread: Rotary encoders on the device set the Spread parameter of Stereo to
Surround channel strips.

•

X: Rotary encoders on the device set surround X position.

•

Y: Rotary encoders on the device set surround Y position.

•

Center: Rotary encoders on the device set the Center channel level.

Note: The X and Y parameters are a different representation of the Angle and Diversity
parameters, and thus are independent of them. The X and Y parameters support the use
of surround joysticks.
•
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EQ Band field: Drag vertically, or enter an integer value to set the current EQ band. This
enables edits to a particular Channel EQ or Linear Phase EQ parameter for all tracks in
the EQ Multi Channel View.
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•

•

EQ Parameter pop-up menu: Choose the parameter of the selected EQ band controlled
by the control surface encoders in EQ Multi Channel View. The choices are:
•

Frequency: Rotary encoders on the device set the frequency of the selected band.

•

Gain: Rotary encoders on the device set the gain of the selected band. This
parameter controls the slope of the Low Cut (band 1) and High Cut (band 8) bands
of the Channel and Linear Phase EQs.

•

Q: Rotary encoders on the device set the Q factor of the selected band.

•

Bypass: Rotary encoders on the device bypass the selected EQ band.

All EQs Parameter Page field: Drag vertically, or enter an integer value to set the EQ
parameter displayed in EQ Channel Strip view.
The Channel and Linear Phase EQs feature eight bands per audio channel, with each
band offering four parameters. All of these parameters can be accessed with your
control surface.
If your control surface does not display all EQ parameters at once, you view them by
stepping through parameter pages in sequence. For example, if your control surface has
eight channel strips, you can directly control parameters 1 to 8 with knobs or sliders 1 to
8 when you switch to EQ Channel Strip Edit view. You then need to switch by a page to
access parameters 9 to 16.

Control Surface Group send and plug-in parameters in Logic Pro
These Control Surface Group parameters control different operational aspects of send and
plug-in parameters.

Send and plug-in parameters
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•

Send Slot field: Drag vertically, or enter an integer value to set the currently selected
Send slot. The default is 1, which sets the first (top) Send on each channel as the Send
slot. A value of 2 sets the second send as the Send slot, a value of 3, the third Send
slot, and so on.

•

Send Parameter pop-up menu: Choose the Send parameter controlled by rotary
encoders on the control surface device when in Send Multi Channel view. The choices
are:
•

Destination: Rotary encoders on the device set the bus channel number for the Send
slot.

•

Level: Rotary encoders on the device set the Send level.
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•

Position: Rotary encoders on the device set Pre, Post, or Post Pan fader modes.

•

Mute: Rotary encoders on the device mute/unmute the selected Send slot.

•

All Sends Parameter Page field: Drag vertically, or enter an integer value to set the
current page for Send parameters. Up to 32 parameters are available in Send Channel
Strip view for a given channel (eight Send slots multiplied by the four parameters listed
above).

•

Split: no. of upper parameters field: Drag vertically, or enter an integer value to set the
number of encoders that belong to Split Upper, for control surfaces that support Split
mode. The remaining encoders belong to Split Lower. A value of 0 indicates Split mode
is off—all encoders are assigned to the Split Upper area.
Control surfaces that support Split mode allow the display of two separate parameter
sections within one plug-in (or even different plug-ins). They are called Split Upper and
Split Lower.

•

Instrument Parameter Page field: Drag vertically, or enter an integer value to determine
the parameter assigned to the leftmost encoder when editing a software instrument.
The next instrument parameter is assigned to encoder 2, and so on. This applies to Split
Upper when Split mode is turned on.

•

Inst Param Page (Split Lower): Drag vertically, or enter an integer value to set the
parameter assigned to the leftmost encoder of Split Lower when editing a software
instrument when Split mode is turned on. The next instrument parameter is assigned to
encoder 2, and so on.

•

Insert Type pop-up menu: Choose an Audio or MIDI insert slot type. The former is used
for assignment and control of audio plug-ins. The latter is used for assignment and
control of instrument plug-ins.

•

Insert Slot field: Drag vertically, or enter an integer value to set the current Insert slot
number. This applies both when selecting a plug-in (in Plug-in Channel Strip view) and
when editing a plug-in’s parameters. The default is 1, which sets the first (top) plug-in
slot on each channel as the Insert slot. A value of 2 sets the second plug-in slot as the
Insert slot, and so on. This applies only to Split Upper when Split mode is turned on.

•

Insert Type (Split Lower) pop-up menu: Choose an Audio or MIDI insert slot type. The
former is used for assignment and control of audio plug-ins. The latter is used for
assignment and control of instrument plug-ins. Your choice only applies when Split
mode is turned on.

•

Insert Slot (Split Lower) field: Drag vertically, or enter an integer value to set the current
Insert slot number for Split Lower when selecting or editing a plug-in when Split mode is
turned on.
Note: The effect plug-in and instrument page parameters are separated because this
allows you to quickly switch between editing an instrument and editing an effect plug-in
on a channel, without adjusting the parameter page every time.

•
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Plug-in Parameter Page field: Drag vertically, or enter an integer value to define the
parameter assigned to the leftmost encoder when editing a plug-in. The next plug-in
parameter is assigned to encoder 2, and so on. This applies only to Split Upper when
Split mode is turned on.
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•

Plug-in Param Page (Split Lower) field: Drag vertically, or enter an integer value to
define the parameter assigned to the leftmost encoder of Split Lower when editing a
plug-in with Split mode turned on. The next plug-in parameter is assigned to encoder 2,
and so on.

•

Channel Strip Track field: Drag vertically, or enter an integer value to define the track
displayed for Channel Strip views. This applies only to Split Upper when Split mode is
turned on.

•

Channel Strip Track (Split Lower) field: Drag vertically, or enter an integer value to
define the track displayed in the Split Lower section of the control surface for Channel
Strip views, when Split mode is turned on.

•

Track Lock checkbox: Click to determine how the control surface responds when a
track is selected—in essence, this remotely affects the Track and Track (Split Lower)
parameters. When Track Lock is turned on, the control surface group continues to
display the same track, independent of the currently selected track in Logic Pro. When
Track Lock is turned off, the control surface group automatically switches to the track
selected in Logic Pro.

Control Surface Group other parameters in Logic Pro
These Control Surface Group parameters area set global group parameters.

Other parameters
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•

Track Name Format pop-up menu: Choose whether the track name display shows only
the track name or the track name and number.

•

Parameter Page Shift Mode pop-up menu: Choose whether the parameter is shifted by
one page or shifted by one parameter.

•

Relative Change Mode: Choose the mode for controller assignments that support
relative value changes (rotary encoders, for example). The choices are:
•

Coarse: Rotating the encoder adjusts the selected parameter in coarse steps.

•

Full: Rotating the encoder to the right sets the maximum value and rotating it to
the left sets the minimum value. The encoder also stops at its default value. For
example, when the Pan knob is left of center, turning the encoder to the right initially
sets the Pan parameter to the center position (its default value). A further turn to the
right sets Pan to full right (its maximum value).

•

Fine: Rotating the encoder increments or decrements the selected parameter in fine
steps—by one tick or other unit. In this mode, the highest possible resolution is used.
For example, when editing the Sample Delay plug-in Delay parameter, every encoder
tick increases or decreases the value by 1 sample, regardless of the resolution value.

•

Mix Group field: Drag vertically, or enter an integer value to determine the group edited
when in Group Edit mode.

•

Group Parameter Page field: Drag vertically, or enter an integer value to define the
parameter of the edited group assigned to the leftmost encoder.
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Overview of Control Surfaces preferences
in Logic Pro

Settings that affect the onscreen appearance and performance of control surfaces are
changed in the Control Surfaces preferences window. For complete documentation for
each Control Surfaces preferences window, see General Control Surfaces preferences.

Open the Control Surfaces preference window
•

Choose Logic Pro > Control Surfaces > Preferences (or use the Open Control Surfaces
Preferences key command).
Click the General or Help Tags button to access the associated preferences.

Temporarily disable your control surfaces
•

Choose Logic Pro > Control Surfaces > Bypass all Control Surfaces.
This command is useful for silencing motorized control surface faders when recording
in the same room. It is also handy when troubleshooting MIDI data errors or for reducing
MIDI bandwidth requirements.

Control surfaces Modal dialog display in Logic Pro

All modal dialogs (except File Open dialogs) appear on the LCD display of control surfaces
that feature text displays. Examples of modal dialogs include authorization warnings, edit
confirmations, or error messages.
Important: You cannot perform actions in any other window while a modal dialog is visible.
The modal dialog text appears in the upper row of the LCD. If the dialog text does not fit in
the LCD’s upper row, it scrolls after three seconds. You can scroll the dialog text manually
with an appropriate control for your device. Once you start scrolling the text manually,
automatic scrolling is disabled.
•

If your control surface has an Enter or OK button, press it to trigger the default button in
the dialog.

•

If your control surface has a Cancel or an Exit button, press it to trigger the button
labeled Cancel or Abort in the dialog.

•

All buttons in the modal dialog (push buttons, including Enter, Default, and Cancel, as
well as checkboxes and radio buttons, but not pop-up menus) appear in the display’s
lower row.

Pressing a control surface button below the display triggers the appropriate function in
the dialog, if applicable. Once you press an Enter or a Cancel button on the control surface
(or click it onscreen), the dialog disappears, and all controls and displays return to their
previous state.
When a File Open dialog appears onscreen, the “There is a file select dialog on the screen”
message appears on the LCD. Use your keyboard and mouse to perform the required
operation and close the dialog.
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Control surface use tips in Logic Pro

You may find that using control surfaces changes the way you use Logic Pro. Slight
changes to your working methods can help you use control surfaces more effectively. The
following hints may streamline your control surface workflow.
•

•

Customize your templates
•

Set up screensets 1–7 as your most frequently used screensets. You can access
these directly on some control surfaces. On a Mackie Control, for example, you
can access them with function keys F1 to F7, while function key 8 (F8) closes the
topmost window.

•

Assign a full-screen Tracks window, with track automation view set to On (for all
tracks), as one of your screensets.

•

Assign a full-screen Mixer window as another screenset.

Make use of markers
Markers allow you to quickly navigate from location to location in a project. Most control
surfaces feature a number of marker shortcuts which is an effective way to move
between positions in your projects.
Markers are also useful for creating or selecting cycle areas and a number of other
tasks, such as punch and replace recording.
If you tend to follow a particular song structure or like to work with a certain number
of bars (4, 8, 16 bars, and so on) for verse and chorus sections, set up a number of
markers at suitable locations in your project templates.

Control surfaces supported by Logic Pro

Control surfaces can be supported either with a MIDI Device Plug-in (MDP) or a MIDI
Device Script (MDS). Directly supported control surfaces communicate with Logic Pro via
MDPs or MDSes located in the Logic Pro application bundle. On Macs with Intel processors,
Logic Pro also checks for control surface plug-ins installed in the ~/Library/Application
Support/MIDI Device Plug-ins folder and in the ~/Library/Application Support/MIDI Device
Plug-ins folder (the preferred location).
When new control surface plug-ins are supplied directly by the device manufacturer, place
them in the folders described above or as advised in the documentation supplied with
the plug-in.
Important: All Mac computers support built-in MDPs and MDSes. Mac computers with Intel
processors also support control surface plug-ins from manufacturers other than Apple. To
use a control surface with an Apple Silicon Mac computer for which no built-in plug-in is
available, consult the manufacturer’s support materials for the control surface to see if an
MDS is available.
MDSes are located in subfolders by the manufacturer name in the ~/Music/Audio Music
Apps/MIDI Device Scripts folder. Logic Pro shows the MDS in the Install window, and the
MDS also appears in the Setup window as a generic keyboard icon. You can replace that
generic icon with a custom device icon (the icon must be a 256 x 256-pixel PNG file named
icon.png placed in the MIDI Device Script package).
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For MIDI controllers supported by MDSes (Lua scripts), see Automatic assignment for USB
MIDI controllers for details.
Important: For Mac computers with Intel processors, some devices are supported by both
a Lua script and a control surface plug-in. In this situation, the plug-in always has priority.
When you install a plug-in from a manufacturer other than Apple, any existing assignments
of a corresponding Lua script for the device are automatically replaced with assignments
generated by the control surface plug-in.

Software and firmware for Logic Pro

Most control surfaces depend on Logic Pro for functionality and cannot be operated
if Logic Pro is not running. They do not provide any additional functionality that is not
available in Logic Pro itself. One advantage of this approach is that as new functions are
added to Logic Pro, or as you create new assignments, your control surface can access
and control them.
Most control surface units do include a form of software called firmware. Firmware is
similar to the low-level boot software found in your computer, iPhone, iPad, and so on.
New behaviors, such as improved control of motorized faders and changes to the display,
can be provided by firmware updates. You should periodically visit the manufacturer’s
website for your device to check for updates that may enhance use or performance.
The firmware is usually stored on an EEPROM (Electronically Erasable Programmable ReadOnly Memory) chip. Some devices may provide a dedicated firmware update app. Other
devices may be updated via a MIDI dump procedure, in the form of a MIDI file. Should new
firmware become available, you can download the appropriate MIDI file and play it from
Logic Pro to your control surface. The steps required to perform a firmware update are
outlined in the documentation that accompanies the firmware update app or MIDI file. Read
all supplied documentation before attempting any update.
Note: Some control surfaces may require a hardware chip replacement for firmware
updates. Contact the manufacturer of your device for details.
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Assign hardware controllers

Overview of controller assignments in Logic Pro

Assigning controllers to Logic Pro parameters lets you use faders, knobs, switches, and
other controllers to remotely adjust Logic Pro functions. These controls can be used
directly or in conjunction with modifier keys. You can assign any controller capable of
generating a MIDI message to a parameter in Logic Pro.
Most supported control surfaces feature controller assignments that become active when
you add the device to your system. You can change existing assignments for supported
control surfaces and create new assignments for both supported and unsupported devices.
For example, the default assignments of the F1 to F7 buttons on the Mackie Control open
screensets 1 to 7 in Logic Pro. You can reassign these control surface buttons to other
commands—either alone or in conjunction with the Command, Shift, Option, and Control
modifier buttons on the control surface—in any combination.
You assign controllers to parameters in the Controller Assignments window using the
Learn process. The Controller Assignments window has two views: a compact Easy view,
where you can assign channel strip and plug-in parameters, and the more extensive Expert
view, where you can create and edit any type of controller assignment, including global,
automation, and control surface group assignments.
Important: When Enable Complete Features is selected in Logic Pro > Preferences >
Advanced, Easy view and Expert view are available.
The current controller assignments and all Control Surfaces preferences are stored in the
~/Library/Preferences/com.apple.logic.pro.cs file.
You do not need to save controller assignments or related preferences and settings. These
are automatically stored when you quit Logic Pro.

Logic Pro User Guide

1120

Controller Assignments Easy view
Use controller assignments Easy view in Logic Pro

Easy view offers a stripped-down window for you to assign controllers to channel strip and
plug-in parameters and to change the target track that assignments apply to.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Easy view is available.

The Easy view window contains the following fields and buttons:
•

Expert View button: Click to open the editor in Expert view.

•

Back button: Click to move back to the previous assignment.

•

Forward button: Click to move forward to the next assignment.

•

Link button: Turn on to automatically select the assignment that matches the most
recently received MIDI message.

•

Parameter field: Displays the name of the selected parameter.

•

Channel Strip pop-up menu and field: Choose whether the assignment applies to the
selected track or matches the channel strip number entered in the adjacent field.

•

Input message field: Displays the incoming MIDI message data of the controller
assigned to a function.

Open the Controller Assignments window Easy view
•
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Choose Logic Pro > Control Surfaces > Controller Assignments (or press Command-K),
then click the Easy View button.
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Assign and delete controllers in Easy view in Logic Pro

Only one set of assignment parameters is visible at a time in Easy view. You use the
Learn process to assign controllers to channel strip and plug-in parameters by moving a
controller on your control surface. This sends a MIDI message to Logic Pro, thus “teaching”
it which controller you are assigning to the chosen parameter.

Assign a controller in Easy view

1. In the Logic Pro Mixer, or in any plug-in window, select a parameter.
2. Choose Logic Pro > Control Surfaces > Learn Assignment for [parameter name].
Alternatively, you can use the Learn new Controller Assignment key command to open
the Controller Assignments window and automatically activate Learn mode.
The Controller Assignments window opens in Easy view, with the Learn Mode button
activated. In most cases, the name of the selected parameter is shown in the Parameter
field.
3. Move the hardware controller you want to assign to the selected parameter, then click
the Learn Mode button to complete the Learn process.
Moving the controller sends a MIDI message to Logic Pro, which appears in the “Input
message” field. This memorizes the controller assignment.
If you do not click the Learn Mode button, Learn mode remains active, allowing you to
make further assignments.
4. To make another assignment, select another parameter, then move the controller on the
control surface.
5. Click the Learn Mode button (or press Command-L) to complete the Learn process.

Assign a controller using a modifier key

1. Choose Logic Pro > Control Surfaces > Learn Assignment for [parameter name] (or
press Command-L) to open the Controller Assignments window.
2. Hold down the modifier key you want to use (Command, for example) as you select the
parameter you want to assign, while moving the control.
3. Click the Learn Mode button to complete the Learn process.
If Logic Pro receives a MIDI message from the device while you are holding down the
modifier key, the Learn Mode button is deactivated when you release the key, and the
Learn process is complete. If you release the modifier key before Logic Pro receives a
MIDI message, the Learn Mode button remains active, so you can still move a controller
to send a MIDI message. In this situation, be sure to click the Learn Mode button when
you are finished to end the Learn process.
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Assign a series of controllers to a series of parameters

Logic Pro includes a shortcut that makes it easy to assign a series of controllers to a series
of similar parameters. For example, you can use this shortcut to assign a series of faders to
volume; to assign a series of knobs or switches to other channel strip parameters such as
pan, solo, or mute; or to assign a series of controllers to a set of plug-in parameters.
1. In the Logic Pro Mixer, or in any plug-in window, select a parameter.
2. Choose Logic Pro > Control Surfaces > Learn Assignment for [parameter name].
Alternatively, you can use the Learn new Controller Assignment key command to open
the Controller Assignments window, and activate Learn mode.
The Controller Assignments window opens in Easy view, with the Learn Mode button
activated. In most cases, the name of the selected parameter is shown in the Parameter
field.
3. Assign the first controller in the series to the first parameter. For example, assign fader
1 to control volume for channel strip 1.
4. Assign the last controller in the series to the last parameter. For example, assign fader
16 to control volume for channel strip 16. The number of controllers between the first
and last in the series must match the number of parameters between the first and last
parameter. In the example, the distance between 1 and 16 would equal 15.
A “Do you want to fill up in between?” dialog is shown.
5. To automatically fill the controllers between the first and last with the corresponding
assignments, click OK.
Note: You can only use shortcuts for knobs that send a single channel message, where
the first data byte is the controller number and the second data byte is the value.
Alternatively, the controller number can be encoded in the MIDI channel, with a fixed
first data byte. Consult the documentation that came with your device for information
on its data structure.

Delete a controller assignment in Easy view
•
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In Logic Pro, select the assignment you want to remove in the Controller Assignments
Easy View window, then click the Delete button.
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Controller Assignments Expert view
Use controller assignments Expert view in Logic Pro

You can use Expert view to make advanced controller assignments. These include Logic
Pro parameters other than channel strip and plug-in parameters. For example, you can
assign controllers to global, automation, and control surface group parameters in Expert
view. You can also edit controller assignments in Expert view and can define zones and
modes that let you switch between groups of controllers.
The Learn process opens the Controller Assignments window in Easy view, which shows
basic parameters for the current assignment. To make assignments other than channel
strip or plug-in assignments or to edit other assignment parameters, you need to switch to
Expert view.
When Enable Complete Features is selected in Logic Pro > Preferences > Advanced,
Expert view is available.
Tip: You can only switch back to Easy view if a track or plug-in parameter is selected.

The Expert view window contains the following:
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•

Zone list: Displays available zones for the device. The No Zone entry is for zoneless
assignments—assignments that are always active, regardless of the active zone. Select
a zone in the list to see associated modes (in the Mode list), and current assignments
(in the Control/Parameter list). You can also double-click a zone to rename it. For more
information see Zones and modes.

•

Mode list: Displays modes for the currently selected zone. The No Mode entry is for
modeless assignments. Select a mode in the list to see corresponding assignments in
the Control/Parameter list, and to make it the active mode for the selected zone. You
can also double-click a mode to rename it. For more information, see Zones and modes.
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•

Control/Parameter list: Select the assignment you want to edit. The left column displays
the name of the control and the right column displays the (abbreviated) name of the
parameter being controlled. The parameters of the selected assignment appear in the
fields to the right of the list. For more information, see Control Name and Label fields.
Note: You can select multiple assignments in the list, but only the parameters of the
first selected assignment are displayed. When multiple assignments are selected,
operations performed via the Edit menu can be applied to all selected assignments. All
other operations apply only to the first assignment.

•

Controller Assignment Parameter area: All aspects of the selected controller assignment
parameter are shown, and can be changed, in this area. For more information, see
Expert view parameters.

•

Input Message area: The port and MIDI input message can be altered directly. Some
fields in this section are displays only and cannot be changed. For more information,
see Expert view Input Message parameters.

•

Value area: The range of values, and response, of the controller assignment to incoming
messages is set in this area. Feedback to the display of control surfaces can also be
determined here. For more information, see Expert view Value parameters.

Open the Controller Assignments window Expert view
•

Choose Logic Pro > Control Surfaces > Controller Assignments (or press Command-K),
then click the Expert View button.

Controller assignments Expert view parameters in Logic Pro

This section outlines each parameter shown in the fields on the right side of the Controller
Assignments window when in Expert view. See use controller assignments Expert view in
Logic Pro for how to turn on Expert view.
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Controller Assignment parameters
•

Control Name field: Displays the name of the controller for supported devices, or
“Learned” for unsupported devices. For more information see Control Name and Label
fields.

•

Label field: Displays characters that represent the label for the assignment on the
control surface display. For more information see Control Name and Label fields.

•

Flip Group field: Enter an integer value to define a flip group for the assignment. For
more information, see Flip Group and Exclusive parameters.

•

Class pop-up menu: Choose the class of parameter (parameter type) you want to
assign. For more information, see Class pop-up menu parameters.
Note: Depending on the chosen class, different fields and pop-up menus for that class
appear below the Class pop-up menu.

•

Parameter/Mode pop-up menu and field: Depending on your choice in the Class popup menu, you can choose from dozens of different parameters and modes. The options
available change as different classes are selected.

•

Group/Track/Command/Key field pop-up menu: These options also change depending
on your choice in the Class pop-up menu.

•

Bank Type pop-up menu: This pop-up menu determines the bank relationship of the
assigned parameter. This can be as per the Group setting, By One, or By Bank.

Input Message parameters

The central area shows the following parameters. See Expert view Input Message
parameters for details.
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•

MIDI Input pop-up menu: Choose a MIDI input source (MIDI Port or Caps Lock Keyboard).
This can be changed by incoming MIDI messages, shown in the Value Change field.

•

Value Change field: Displays incoming MIDI messages that cause a value change.

•

Touch/Release field: Enter an integer value to force incoming MIDI messages to change
the touch/release state of the selected parameter. This applies only to control surfaces
with touch-sensitive controls.
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Value parameters

The lower area shows the following parameters. See Expert view Value parameters
for details.
•

Min and Max fields: Enter integer values to set the range for incoming MIDI values.

•

Format pop-up menu: Choose the format used to encode negative values.

•

Multiply field: Enter a value to scale incoming MIDI values.

•

Mode pop-up menu: Choose the mode used by incoming values to modify the current
parameter value.

•

Feedback pop-up menu and checkboxes: Choose the display format of the parameter
value on the control surface display, if applicable.

Assign and delete controllers in Expert view in Logic Pro

You can use the Learn process to assign controllers in the Controller Assignments window
Expert view, just as you would in Easy view. You can also assign controllers to classes of
parameters that are not accessible in Easy view.
The procedure for reassigning an active controller (an assigned controller in the active
mode) is different from that of an inactive controller (one with an assignment in an inactive
mode). For more information, see Zones and modes.

Learn a controller for a non-channel strip or plug-in parameter

1. Choose Logic Pro > Control Surfaces > Controller Assignments (or press Command-K),
then click the Expert View button.
2. Choose a zone or mode unless you want to make a modeless assignment, then click the
plus button in the lower-left corner of the Control/Parameter list.
A new, blank assignment appears in the Control/Parameter list.
3. Click the Learn Mode button to start the Learn process.
4. Move the controller that you want to assign to the selected parameter.
Moving the controller sends a MIDI message to Logic Pro, thus “teaching” Logic Pro
the controller you are assigning. The Learn Mode button remains active, allowing you to
make further assignments. The incoming MIDI message appears in the Input message
field.
5. Choose the class of parameter you want to assign from the Class pop-up menu.
6. Assign the parameter by making choices in the pop-up menus and fields that appear
below the Class pop-up menu.
Note: A detailed explanation of classes and other assignment parameters is found in
Class pop-up menu parameters.
7. Click the Learn Mode button (or press Command-L) to complete the Learn process.
Tip: You can use the shortcut described in Assign and delete controllers in Easy view
to assign a series of controllers to a series of similar parameters.
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Delete an assignment in Expert view

Should you accidentally move the wrong controller in Learn mode, you can easily delete an
unwanted assignment.
1. In Logic Pro, select the assignment you want to delete in the Control/Parameter list.
2. Choose Edit > Delete (or press the Delete key).

Reassign an active controller
•

In Logic Pro, use the Learn process to assign an active controller (one with an
assignment in the active mode), then choose one of the options shown in the dialog:

•

Cancel: Click to delete the new assignment, retaining the existing assignment.

•

Keep both: Click to retain the new and old assignments.
This is generally used when one knob controls multiple parameters as a macro.

•

Reassign: Click to delete all existing active assignments for this parameter.
Use this option to reassign a function key such as F1 to F8 to a new key command.

Reassign an inactive controller

Supported control surfaces generally have empty user pages available, allowing for new
encoder assignments. You would select a particular user page mode (page 3, for example),
then learn an assignment for the encoder.
•

In Logic Pro, use the Learn process to assign a controller in an inactive mode.
Note: The new assignment becomes part of the active mode in the same zone that
contained the previous, inactive assignment.
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Use controller assignments zones and modes in Logic Pro

You can define a group of controllers as a zone in Expert view and switch all controls in
that zone to different parameters. Using a Mackie Control, for example, you can define
the eight rotary encoders as a zone and switch them between pan, send level, and plugin parameters. You can also define multiple zones for a control surface: one zone for
the encoders, and a second zone that switches the function keys (F1 to F8) to different
functions.
Note: Assignments created by Lua scripts are created within a separate top level,
modeless, zone that is named after the device. These assignments are always active and
interact with Control Surface Group 1.
Each set of zone parameters is called a mode. A zone can contain one or more modes,
but only one mode can be active at any given time. A zone can also contain assignments
that are always active, regardless of the active mode. These are known as modeless
assignments.
The simultaneous use of modal and modeless assignments allows you to do things such as:
•

Define a zone that switches between two modes or functions by pressing and releasing
a control surface modifier button (such as Shift or Option)—while using a particular
function button on the control surface.

•

Define a zone that allows you to use modeless assignments for display updates,
transport functions, and Save or Undo operations. The same zone could contain a
modal assignment for all Volume and Pan controls. Switching to another mode could
provide access to EQ parameters. In both modal situations, the display, transport, and
Save or Undo functions are available.

A mode can contain any number of assignments. Only the assignments for the active mode
are processed. Assignments of inactive modes are ignored. You can switch the active mode
for a zone by making special assignments.
Zones and modes can be defined across multiple control surfaces to support the use of
control surface groups.
The illustration shows one possible hierarchical arrangement of zones and modes.
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Define a zone

1. Choose Logic Pro > Control Surfaces > Controller Assignments (or press Command-K),
then click the Expert View button.

2. Click the Add button in the lower-left corner of the Zone list.
A new, blank zone appears in the Zone list. It is highlighted, allowing you to immediately
rename it.
3. Enter a name for the zone.
If you want to add controllers to the zone, see Assign and delete controllers in Expert
view.

Define a mode

1. Choose Logic Pro > Control Surfaces > Controller Assignments (or press Command-K),
then click the Expert View button.
2. Click the Add button in the lower-left corner of the Mode list.
A new, blank mode appears in the Mode list. It is highlighted, allowing you to
immediately rename it.
3. Enter a name for the mode.
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Controller assignments Control Name and Label fields
in Logic Pro

The Control Name and Label fields are shown at the top right of the Controller Assignment
parameters in the Expert View window.

Control Name and Label parameters
•

Control Name field: Shows the name of the control. For supported devices, the control
surface name is used. For assignments created with the Learn process on unsupported
control surfaces, the control name defaults to “Learned.” You can enter a new name in
the field. The control name is for display only and has no effect on function.

•

Label field: Shows characters that represent the label for the assignment that appears
on the control surface display—for supported control surfaces. Unsupported control
surfaces can only send information, not receive it, and therefore cannot display an
assignment label.
If the field contains fixed text, it can contain any number of characters. When used as
a placeholder for dynamically created text, however, the field contains three characters
that represent the label. The first character is always @, followed by two additional
characters. For example, “Send@s#” translates as “Send1,” “Send2,” and so on.
•

Second Character: This character is used to define a type for the event label.
For example: t=track, r=surround, s=send slot, S=number of sends, e=EQ band,
E=number of EQs, p=insert slot, i=instrument slot, and so on.

•

Third Character: This character is used to define a value for the chosen event label
type, such as the track number or name. For example: #=number of track, send
slot, EQ band, insert slot, and so on, n=name, p=name of parameter addressed by
the assignment, P=name of first parameter, o=parameter offset—counted from 1,
O=maximum parameter offset—counted from 1, b=parameter bank offset or bank
size—counted from 1, B=total number of banks—counted from 1.

Controller assignments Flip Group and Exclusive parameters
in Logic Pro
The Flip Group field and Exclusive checkbox are shown in the Controller Assignment
parameters at the top right of the Expert View window.

Flip Group and Exclusive parameters
•

Flip Group Field: Enter the same integer value for two assignments to define a
counterpart for Flip mode—for supported control surfaces that provide Flip mode. By
setting a fader and an encoder to the same flip group, for example, they are coupled. To
set “none,” enter a value of 0.
For unsupported devices, you need to set up two active assignments, both of which use
the same flip group. One assignment needs to be absolute (using a fader, for example),
and the other assignment needs to be relative (an encoder, for example).

•
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Exclusive checkbox: Turn on to deactivate all other assignments having Exclusive turned
off for the same control, in order to limit a modeless assignment to particular modes.
For example, faders normally control volume. To create a mode where faders control the
send level, select Exclusive.
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Controller assignments Class pop-up menu parameters
in Logic Pro

Choose the class of assignment (the type of destination parameter controlled) from the
Class pop-up menu at the right of the Controller Assignments window. Different options
appear below the Class pop-up menu when you choose a class. The following describes
the different classes, and the options available for each.

Class pop-up menu parameters
•

•
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Mode Change: Choose to use an assignment to switch from one mode to another. An
additional Mode pop-up menu appears below the Class pop-up menu, allowing you to
choose between available modes. For example, Mackie Control assignment buttons can
be used to choose different modes for the encoders. The mode chosen in the Mode
pop-up menu is activated only when the Mode menu is set to Direct. If any other Mode
menu item is chosen, the following applies:
•

Toggle: The assignment toggles between the zone’s first mode and the chosen
mode. The mode change assignment must be located in the same zone.

•

Relative: Use to step up and down through modes in a zone (using two buttons) or
to choose a mode with an encoder. The minimum destination parameter represents
this zone’s first mode, and the maximum represents the zone’s last mode. The mode
change assignment must be located in the same zone.

•

Rotate: Use to step through all available modes with a single button press. For
example, if used with a Jog Wheel, a single button press would cycle between Off,
Scrub, Shuttle, and then back to Off. The minimum destination parameter represents
this zone’s first mode, and the maximum represents the zone’s last mode. The mode
change assignment must be located in the same zone.

Global: Choose to use an assignment to control global parameters. A Parameter popup menu appears below the Class pop-up menu, showing the parameters listed below.
These only work in relative mode, where changes are relative to the starting value or
position.
•

Playhead: Controls the position of the playhead; feedback is sent in the format
specified by the control surface group’s Clock Display parameter.

•

Playhead (Beats): Playhead position feedback is sent in beats format.

•

Playhead (Time Code): Playhead position feedback is sent in SMPTE timecode
format.

•

Playhead (Beats, Scrubbing): Move the assigned controller to initiate scrubbing. The
format is specified by the control surface group’s Format parameter. The controller
value defines the scrubbing speed.

•

Move Locators: Move the left and right locators.

•

Left Locator: Set the left locator.

•

Right Locator: Set the right locator.

•

Move Punch Locators: Move the punch in and punch out locators.

•

Left Locator: Set the punch in locator.

•

Right Locator: Set the punch out locator.
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•
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•

Marker Position: Edit the position of the current marker.

•

Marker Length: Edit the length of the current marker.

•

Nudge selected Regions/Events: Nudge the selected regions or events by the
chosen nudge value. (See “Nudge Value” below.)

•

Any Solo: Feedback only. On if any (track or region) Solo button is active.

•

Nudge Value: Set the value used for Nudge selected Regions/Events. Choose from:
tick, division, beat, bar, frame, and 1/2 frame.

•

Scrub Status: Set the scrubbing status for the Playhead parameter (beats,
scrubbing). Choose from: set clock, audio scrubbing, shuttle.

•

Automation of all tracks: Switch the automation state of all tracks between the
following values: Off, Read, Touch, Latch, and Write.

•

Alert Text, Alert Button, Alert Icon: Used by plug-ins to define a special Alert mode.
This is mainly of use to control surface developers.

•

Dummy: Use to temporarily disable a modeless assignment, by using the Exclusive
checkbox. For more information, see Flip Group and Exclusive parameters.

•

Cycle: Turn Cycle mode on and off.

•

Autopunch: Turn Autopunch mode on and off.

•

Go to Marker: Move the playhead to a marker number. An additional number field
below the Parameter pop-up menu determines the destination marker number.

•

Group Clutch: Set automation group clutch; automation groups are disabled when
the clutch is enabled. For buttons, sets the group clutch to 1 when the button is
pressed, and sets it to 0 when the button is released.

•

Active Sense: Used by some control surfaces such as the HUI to process incoming
Active Sensing messages.

•

Shuttle Speed: Set the forward and backward shuttle speed. Use this for controllers
that send an absolute, rather than relative, value.

•

Waveform Zoom: Set the waveform zoom level in the key focus window.

•

Quantize Value: Set the Quantize value in the key focus window.

•

Division: Set the Division value in the key focus window.

•

Horizontal Zoom: Set the horizontal zoom level in the key focus window.

•

Vertical Zoom: Set the vertical zoom level in the key focus window.

Channel Strip: Choose to use an assignment to set a channel strip parameter. A Channel
Strip pop-up menu appears below the Class pop-up menu, showing the following
parameters.
•

Selected track: Corresponds to the selected track except when the control surface
group’s Track Lock parameter is active. In this case, the selected track is the track
chosen when Track Lock was enabled.

•

Fader Bank: Addresses a channel strip in the control surface group’s current View
(Arrange, All, Tracks, Single). This is dependent on the current Fader Bank value for
this mode. For example, if the View is All, the All view Fader Bank is five, and the
number next to this parameter is two. Thus, the eighth channel strip in the All view is
addressed (Fader Bank and No. are zero-based, so add 1).
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•

Index: The index number of a channel strip in the Mixer, independent from channel
strip type, as counted from the left end of the Mixer. The index number also includes
channel strips without track numbers, such as auxiliary tracks. The index number
changes as track order (and with it, channel strip order in the Mixer) changes.

•

Audio: An audio channel. The numerical value (No.) determines which audio channel
is addressed (zero-based; to address audio channel 2, use a value of 1).

•

Software Instrument: A software instrument channel. The numerical value (No.)
determines which channel is addressed (zero-based; to address channel 2, use a
value of 1).

•

Bus: A Bus channel. The numerical value (No.) determines which channel is
addressed (zero-based; to address Bus 2, use a value of 1).

•

Auxiliary: An Aux channel. The numerical value (No.) determines which channel is
addressed (zero-based; to address Bus 2, use a value of 1).

•

Output: An Output channel. The numerical value (No.) determines which channel is
addressed (zero-based; to address Bus 2, use a value of 1).

•

Master: The Master channel strip; if it does not exist in the project, the first output
channel strip is addressed.

If you choose the Fader Bank, Index, Audio, Software Instrument, Bus, Auxiliary, Output,
or Master setting from the Channel Strip pop-up menu, the following two parameters
become available:
•

Number field: The channel strip number defines the number of the controlled
channel for the selected channel strip type.

•

Parameter field: Text description of the addressed parameter. Can only be set by
choosing the Logic Pro > Control Surfaces > Learn Assignment for [parameter name]
menu item. Note that for plug-in and instrument parameters, Parameter Page offsets
apply, allowing you to shift parameter addressing up and down by page.

•

Key: Choose to use assignments to emulate computer keyboard keystrokes. You can
enter the key to emulate in the Key field, which appears below the Class pop-up menu.
This is not case-sensitive.

•

Key Command: Choose to use an assignment to perform a key command. You can enter
the key command in the Command field, which appears below the Class pop-up menu.
Some key commands provide on/off or enabled/disabled feedback.
If you want to execute your key command assignment repeatedly, select the Key Repeat
checkbox at the bottom of the Controller Assignments window. For further information,
see Expert view Value parameters. Click the Show button to open the Key Commands
window. The key command shown in the Command field is automatically selected and
shown in the Key Commands window.

•

Control Surface Group: Choose to set a property for the control surface group that the
assignment belongs to. When you choose this class, a Parameter pop-up menu appears
below the Class pop-up menu. This pop-up menu allows you to choose a Control
Surface Group parameter (see Control Surface Group parameters overview) or one of
the options listed:
Note: Assignments for unsupported control surfaces always belong to the first control
surface group.
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•

Fader Bank for Current View: Maps to the fader bank for the currently used View
allowing you to use one assignment per left or right button for all View modes.

•

Filter for All View: Choose to show eight additional checkboxes (for the eight channel
strip types) when the View is All. Depending on the Value mode, these switches
define which channel strips are displayed (by using Direct mode) or which are
toggled (by using X-OR mode).

•

Fader Bank for: Channel strip choices are: MIDI, Input, Audio, Instrument, Aux, Bus,
Output. These fader bank parameters are used in All View when only one channel
strip type is displayed. This allows you to switch between several channel strip
types, while retaining the current fader bank for each type.

If you choose one of the fader bank or parameter page settings from the Parameter
pop-up menu, the following Bank Type options appear below the pop-up menu:

•

•

By One: The fader bank or parameter page is shifted by one channel strip or
parameter.

•

By Bank: The fader bank or parameter page is shifted by the number of displayed
channel strips or parameters.

•

CS Group Setting: The fader bank or parameter page is shifted by the value defined
for the Parameter Page Shift Mode control surface group parameter.

Automation Group: Uses the assignment to set an automation group parameter. When
chosen, a Group field appears below the Class pop-up menu. You can determine
the edited group by entering a number in the field. Entering “0” sets this parameter
to the group selected for the Automation Group parameter (in the control surface
group parameters). A Parameter pop-up menu also appears below the Group field,
allowing you to choose the automation group parameter for the assignment. For further
information, see Groups overview.

Controller assignments Expert view Input Message
parameters in Logic Pro
The parameters in this section control different aspects of MIDI input.

Input Message parameters
•

MIDI Input pop-up menu: Choose a MIDI input port to change all assignments that use
the same input port. If the assignment belongs to a supported control surface, the
device’s MIDI input also changes in the Setup window.
This makes it easy for you to create default assignments for a new control surface.
These new assignments can be moved to other computers by copying and pasting your
preferences file into the Preferences folder of another computer. You can then open the
Controller Assignments window in Expert view on the other computer and change the
MIDI Input parameter of one assignment.

•
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Value Change field: Shows incoming MIDI messages that cause a value change in the
destination parameter, and lets you edit these MIDI messages.
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The Value Change field displays the message as a sequence of hexadecimal bytes. The
plain language meaning appears below the field. The placeholders for the variable part
of the message are:
•

Lo7: Low 7 bits of the value (LSB or Least Significant Bits)

•

Hi7: High 7 bits of the value (MSB or Most Significant Bits)

For messages containing only a Lo7 placeholder, the value is treated as 7 bit. For
messages containing both a Lo7 and Hi7 placeholder, the value is treated as 14 bit.
The order of Lo7 and Hi7 is honored, and there may be constant bytes in between. This
allows you to define Control Change LSB and MSB portions. For example, B0 08 Hi7 B0
28 Lo7 indicates a 14-bit message.
Note: When you enter multiple MIDI messages, always enter each message completely,
being sure to repeat the status byte, even if it’s the same. It may help to write out the
message to ensure that the correct byte works, as you can’t know what status the
previously sent message had.
For messages containing neither Lo7 nor Hi7 placeholders, Logic Pro assumes an
incoming value of 1. This is typical for pressed or released buttons. Also see Multiply
field in Expert view Value parameters.
•

Touch/Release field: Enter an integer value to use the incoming MIDI message for status
changes of the destination parameter from touched to released, or vice versa. A nonzero value means touched; a value of 0 means released. The messages are shown and
edited in the same way as the Value Change field.
Note: The Touch/Release setting applies only to the Channel Strip assignment class and
to parameters that can be automated.

Controller assignments OSC Message Paths in Logic Pro

The parameters in this section let you edit the OSC paths used to communicate with OSC
devices. The OSC protocol allows for real time communication between software and
hardware over a network, or when using USB or other serial interfaces. The current OSC
implementation in Logic Pro supports UDP and IPv4 network connections only.

OSC Message Path parameters
•

Value field: Determine the message for sending the parameter value. Normally the value
is a normalized float, such as 0.0 to 1.0.
Note: There is an exception to the normalized value rule: feedback for global and control
surface group parameters is always sent non-normalized. As an example, the current
fader bank is sent as per its integer form, but in float format (0.0, 1.0, 2.0 and so on).
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•

Touch/Release field: Choose from the following values: 1.0 indicates touched and a
value of 0.0 indicates released.

•

Label field: Displays the parameter name.

•

Value String field: Displays the current parameter value.
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Controller assignments Expert view Value parameters
in Logic Pro

The parameters in this section control different aspects of incoming MIDI message values.

Value parameters
•

Min and Max fields: Enter an integer value to set the minimum and maximum range for
incoming values represented by Lo7 and Hi7. Typically, the minimum defaults to 0, and
the maximum defaults to 127. Some control surfaces (such as CM Labs Motor Mix) may
use the same message, with different value ranges, for different controls. For more
specific information, refer to the documentation that came with your device.

•

Format pop-up menu: Choose the encoding format for negative values in the 7-bit
portions sent over MIDI. The choices are:
•

Unsigned: No negative values are possible. The full 7- or 14-bit range is treated as a
positive number. The value range is 0 to 127 (7 bit) or 0 to 16383 (14 bit).

•

2’s complement: If the most significant bit is set, the value is negative. To obtain the
absolute value, invert all bits and add 1. The value range is from –128 (7 bit) to 127 or
–8192 to 8191 (14 bit).

•

1’s complement: If the most significant bit is set, the value is negative. To set the
absolute value, invert all bits. Note that this allows two possible encoding values for
zero. The value range is –127 to 127 (7 bit) or –8191 to 8191 (14 bit).

•

Sign Magnitude: If the most significant bit is set, the value is negative. To set the
absolute value, clear the most significant bit. Note that this allows two possible
encoding values for zero. The value range is –127 to 127 (7 bit) or –8191 to 8191 (14
bit).
Note: The appropriate format for a device is usually specified in its documentation.
If unavailable, check the control surface manufacturer’s website or contact them for
more information.

•

•
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Multiply field: Enter a value which is used to scale incoming MIDI values. This is useful
for button presses that have a value of 1. For example:
•

To set the automation mode to Write: Set Multiply to 4.00, and Mode to Direct.

•

To decrement a parameter by 1 with a button press: Set Multiply to –1.00, and Mode
to Relative.

Mode pop-up menu: Choose the mode used by incoming values to modify the current
parameter value. The choices are:
•

Direct: The incoming value is used as the parameter value.

•

Toggle: If the parameter’s current value is 0, it is set to the incoming value. All other
values set the parameter value to 0. This option is useful for buttons that toggle a
value, such as Mute or Solo.

•

Scaled: The incoming value is scaled from its value range to the destination
parameter’s value range. This is useful for faders and rotary encoders.

•

Relative: The incoming value is added to the parameter’s current value. This is
commonly used for encoders but is also useful for buttons that increment or
decrement by a certain amount—specified by the Multiply parameter.
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•

Rotate: The incoming value is added to the parameter’s current value, cycling
between maximum and minimum values. This is useful for button presses that cycle
between modes, such as automation mode.

•

X-OR: The value defines a bit mask (a filter), which is applied to the parameter’s
current value with the “exclusive or” Boolean operation. This is useful for enabling or
disabling single channel strip types in All view.
Note: For On/Off parameters, Mode is set to Toggle by default. It is set to Scaled for
absolute controls (faders and knobs, for example) or to Relative for encoders.

•

Feedback pop-up menu: Choose the display format used for the parameter value shown
on the control surface display, if applicable. The choices are:
•

None: No feedback is sent.

•

Single Dot/Line: LED rings: only one LED; LCDs: a single vertical line.

•

Left to Right Bar: A bar from the minimum to the current value.

•

Bar from Center: A bar from the center position to the current value.

•

Right to Left Bar: A bar from the current value to the maximum.

•

Q/Spread: Two equal bars from the center to the current value.

•

Ascending Bar: A bar from the bottom to the current value.

•

Descending Bar: A bar from the top to the current value.

•

Text Only: LED rings: no feedback; LCDs: no feedback as a graphics element.

•

Automatic: Depending on the currently assigned parameter, the most suitable
feedback mode is used: Plug-in and Instrument parameters carry this information,
Pan displays a single dot or line (Single Dot/Line), and all other parameters display a
bar that runs from left to right (Left to Right Bar).

Note: Feedback works for directly supported control surfaces, but not all settings are
available for all controls. Feedback also works for Lua script supported devices that
provide a CoreMIDI input port. In this case, Lua script MIDI feedback processing is
used, including optional label and value text feedback. For Lua script supported devices
that provide both a CoreMIDI input and output port, the input message is sent to the
out port, with the value scaled to 0-127 as an absolute value. “Learned” controller and
Smart Controls assignments are automatically enabled to provide feedback. It should be
noted that feedback is not possible on IAC.
•

Text Feedback checkbox: Turn on to send a text representation of the current value
to the control surface display. The control surface display capabilities determine the
display position and number of characters used.

•

Local Feedback (Fader/Knob) checkbox: Turn on to stop feedback while the parameter
is in Touch mode. This prevents motorized faders from fighting against user movements.

•

Key Repeat checkbox: Turn on to repeatedly execute the assignment at the rate set by
the Key Repeat slider in macOS Keyboard preferences. The duration the button must be
held for before the assignment is repeated is set with the Delay Until Repeat slider in
Keyboard preferences.
Key Repeat is useful for the zoom function. For example, if you assign a Key Repeat
command to the Mackie Control Zoom buttons, holding the Zoom In button will
continuously zoom in the Logic Pro window until the button is released. The alternative
is to repeatedly press the Mackie Control Zoom buttons to zoom in or out more than
one level.
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Note: The Key Repeat checkbox is available only for key command, key presses, and
relative value changes. If any other assignment class is selected, the checkbox is
dimmed.
The default key command assignments support the Key Repeat function if useful or
applicable to the control surface or device, making changes unnecessary to use this
function. If you want to enable the Key Repeat function for your own assignments, you
may need to use the re-learn option for the assigned message. Key Repeat messages
must include the Lo7 byte, which provides information on the up (released) or down
(pressed) state of the assigned button. Logic Pro guides you through the re-learning
process. The current MIDI message is automatically cleared, Learn mode is activated,
and a help tag prompts you to send the required MIDI message. Releasing the assigned
button—after learning the MIDI message—automatically creates the Lo7 byte, and
assigns the Lo7 value (for the button release message) to the Min parameter. The Lo7
value for the button pressed message is automatically assigned to the Max parameter.
Typically, the value range of 1 to 127 is used for the button pressed message. The zero
(0) value is generally used for the button release message.
Note: Some control surfaces, such as CM Labs Motormix, may use different value
ranges. Assigning appropriate Min and Max values ensures that the Key Repeat function
works with such devices. Take care when manually changing the Min or Max value for a
key command because the complete assignment does not work in cases where the Min
and Max values do not match the button pressed (on) and button released (off) states.
Consult your control surface manual for further information about the values it uses.

Assign controller buttons to key commands
in Logic Pro

In addition to assigning controllers to parameters, you can assign control surface buttons—
and button or key release messages—to key commands.

Assign a control surface button to a key command

1. Choose Logic Pro > Key Commands to open the Key Commands window.
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2. In the Command list, click the disclosure arrow next to the category of commands you
want to reveal, then select the key command you want to assign. You can also search
for the key command in the Search field.
3. Click the Learn New Assignment button.
4. Press the control surface button that you want to assign to the key command. This
sends a MIDI message to Logic Pro.
The name of the controller appears in the Assignments field.
5. Repeat steps 2 to 4 to make additional assignments.
6. Click the close button to exit the window.

Assign a button or key release message to a key command

1. Choose Logic Pro > Key Commands to open the Key Commands window.
2. In the Command list, click the disclosure arrow to reveal the commands for a category,
then select the key command you want to assign (or use the Search field).
3. Hold down the control surface button or key that you want to assign to the key
command.
4. Click the Learn New Assignment button.
5. Release the button or key.
The name of the button or key appears in the Assignments field.
6. Click the close button to exit the window.

Delete a key command assignment

1. Choose Logic Pro > Key Commands to open the Key Commands window.
2. Select the key command with an assignment you want to delete in the Command list.
3. Select the assignment for the key command in the Assignments field.
4. Press the Delete key.

Logic Pro User Guide

1140

Work in the Environment

Overview of the Environment in Logic Pro

The Environment refers to the virtual environment of Logic Pro inside your computer. It
provides a virtual view of your MIDI studio, giving you complete control over your MIDI
setup. You can use the Environment to create virtual connections between MIDI devices,
as well as process and filter MIDI data. The Environment includes the following objects.
Note: The Environment is a legacy feature and included for compatibility with projects from
older versions of Logic Pro.

•

Physical Input and Sequencer Input objects: Represent the physical MIDI inputs of your
MIDI interface and the Logic Pro input.

•

Instrument objects: Virtual representations of each MIDI device (synthesizers and
samplers, for example) in your MIDI rig.

•

Faders, knobs, switches, and other objects: Used to create new data, or to control and
modify the MIDI signal flow in real time.

It’s not essential to know about—or even open—the Environment in order to make music
with the Logic Pro instruments or your external MIDI sound generators and keyboards.
When you create new instrument or external MIDI tracks, Logic Pro automatically generates
Mixer channel strips, and also creates and configures any Environment objects that are
needed for basic input and output.
Note: This is also true of audio channel strips (and other channel strip types, such as aux
and output channel strips), but you rarely need to access these objects in the Environment,
as you have full control over these channel strips in the Mixer.
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The Environment is available only when Logic Pro > Preferences > Advanced >
Additional MIDI Options is selected.

Open the Environment window

In Logic Pro, do one of the following:
•

While pressing and holding the Option key, choose Window > Open MIDI Environment
(or press Command-0).
Note: If you already have an Environment window open, this command opens another
Environment window.

•

Use the Show/Hide Environment key command to do one of the following:
•

Open an Environment window.

•

Bring an open Environment window to the front.

•

Close an open Environment window.

Common parameters in the Logic Pro Environment
Each Environment object has several parameters that control its behavior. You can view
and change these parameters in the Object inspector, shown in the Environment when an
object is selected.

The following parameters are shared by all object types:
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•

Name: Appears next to the disclosure arrow and can be edited by clicking. You can also
edit the name by clicking the object with the Text tool.

•

Icon: Represents the object in the Environment and main window, and can be changed
by clicking.

•

Assignable checkbox: Makes the object visible in the Reassign Track shortcut menu
in the Tracks area. (See Assign tracks to different channel strips.) This is useful for
instrument objects, but can also be useful for other objects such as touch tracks and
chord memorizers.
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Show or hide the Object inspector

In the Logic Pro Environment window, do one of the following:
•

Click the disclosure arrow in the upper-left corner of the Object inspector.

•

Choose View > Hide/Show Inspector (or press I).

Work with Environment layers
Overview of Logic Pro Environment Layers

The Environment can quickly fill up with a large number of objects. To keep things
organized, you can assign objects to different display levels, referred to as layers. Think of
layers as being different, partial views of the overall Environment. You can easily connect
objects between different layers.
The distribution of objects across different layers has no effect on their functionality—it’s
simply a better way to organize objects. The name of the current layer is shown in the
Layer pop-up menu.

The position and existence of the first two layers—All Objects and Global Objects—is
protected, and they cannot be deleted.
•
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All Objects: This layer displays all objects in the Environment. The objects in this layer
are normally shown as a list. To switch to the selected object’s layer, choose Options >
Go to Layer of Object in the Environment menu bar.
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•

Global Objects: In this layer, you can place objects that you want to be visible in
all layers. These objects appear at the same position in all layers. Try to assign as
few objects as possible to this layer, due to the onscreen clutter that global objects
can create.

Create, name, delete, and switch layers in Logic Pro
You can create, name, delete, and switch layers in the Environment.

Create a layer

In the Logic Pro Environment window, do one of the following:
•

Choose Options > Layer > Create Layer.

•

Choose Create Layer from the Layer pop-up menu.

A new, empty layer called (unnamed) is inserted above the currently selected layer.

Name a layer

1. In the Logic Pro Environment window, choose Rename Layer from the Layer pop-up
menu.
2. Enter a new name, then click OK.

Delete a layer

1. In the Logic Pro Environment window, do one of the following:
•

Choose Options > Layer > Delete Layer.

•

Choose Delete Layer from the Layer pop-up menu.

An alert warns against the accidental deletion of all objects in the layer.
2. Click Delete to confirm the deletion.

Switch between layers
•

In the Logic Pro Environment window, choose a layer from the Layer pop-up menu.

Switch back to the most recently opened layer
•
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In the Logic Pro Environment window, choose Options > Go to Previous Layer.
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Work with Environment objects
Tools in the Environment in Logic Pro

You can use the Pointer, Pencil, and Eraser tools to select, create, and delete objects in the
Environment.

The following tools are also available:
•

Text tool: Click an object with the Text tool to rename it.

•

MIDI Thru tool: Click an object with the MIDI Thru tool to assign the object to the
selected track in the main window.

Add and delete objects in the Logic Pro Environment

You can add and delete objects in the Environment using menu commands or tools.

Add an object

In the Logic Pro Environment window, do one of the following:
•

Choose an object type from the New menu in the Environment menu bar.
The object is added to the current layer.

•

Click a layer background with the Pencil tool.
A new instrument object is created.

Delete an object

In the Logic Pro Environment window, do one of the following:
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•

Select all objects you want to delete, then choose Edit > Delete in the Environment
menu bar (or press Delete).

•

Click the object with the Eraser tool.
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Move and copy objects in the Logic Pro Environment

You can move and copy objects within a layer or between layers, using a variety of
techniques.

Move an object by dragging

In the Logic Pro Environment window, do one of the following:
•

Grab the icon, name, or positioning bar to the right of the object (in the case of
keyboard and fader objects, for example), then drag it to a new position in the layer.

•

Press and hold the Shift key, then drag the object to a new position in the layer
(beneficial in the case of keyboard and fader objects, for example).
Note: Remember to first deselect any other selected objects by clicking the layer
background, to avoid moving them as well.

Move objects between layers by dragging

1. In Logic Pro, open a second Environment window (Window > Open MIDI Environment) to
display the target layer.
2. Select the objects you want to move in the first Environment window, then drag them
into the second window.

Move objects between layers using the Layer pop-up menu

1. In the Logic Pro Environment window, select the objects you want to move.
2. Press and hold the Option key, then choose a layer from the Layer pop-up menu.
The selected objects are moved to the chosen layer.

Move objects between layers using the Clipboard

1. In the Logic Pro Environment window, select the objects you want to move.
2. Choose Edit > Cut from the Environment menu bar (or press Command-X).
3. Choose a destination layer from the Layer pop-up menu.
4. Click the layer background to make sure that no objects are selected.
5. Choose Edit > Paste from the Environment menu bar (or press Command-V).
Note: If any objects are selected when you try to paste objects to the current layer, a dialog
asks if you want to replace the current selection. If you press Return or click Replace,
the selected objects are replaced by the objects in the Clipboard. The existing cabling
remains intact.

Copy an object by dragging
•

In the Logic Pro Environment window, press and hold the Option key while dragging the
object with the Pointer tool.

Copy objects between layers by dragging

1. In Logic Pro, open a second Environment window (Window > Open MIDI Environment) to
display the target layer.
2. Select the objects you want to copy in the first Environment window, press and hold the
Option key, then drag the objects into the second window.
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Copy objects between layers using the Clipboard

1. In the Logic Pro Environment window, select the objects you want to copy, and choose
Edit > Copy from the Environment menu bar (or press Command-C).
2. Choose a destination layer from the Layer pop-up menu.
3. Click the layer background to make sure that no objects are selected.
4. Choose Edit > Paste from the Environment menu bar (or press Command-V).
Cabling is preserved, so groups of objects copied this way are connected in the same way
as the originals. When you copy a single object, only its output cables are preserved.
Note: If any objects are selected when you try to paste objects to the current layer, a dialog
asks if you want to replace the current selection. If you press Return or click Replace,
the selected objects are replaced by the objects in the Clipboard. The existing cabling
remains intact.

Adjust position, size of objects in the Logic Pro Environment
Objects can be freely placed, which allows for flexibility, but can lead to overlaps or
misalignments—particularly when pasting between layers. Fortunately, you can quickly
clean up object positions.

Snap objects to a grid
•

In the Logic Pro Environment window, choose View > Snap Positions from the
Environment menu bar.
The objects are aligned to an invisible grid.

It’s useful to leave this setting turned on, but you should turn it off if you want to manually
move an object by a few pixels.

Align selected objects horizontally or vertically
•

In the Logic Pro Environment window, choose Options > Clean up > Align Objects from
the Environment menu bar.

The upper-left object stays where it is. The position of the next object determines whether
the objects are aligned in a row or a column. If it’s to the right of the upper-left object, all
objects are aligned horizontally (in a row). If it’s below the upper-left object, all objects are
aligned vertically (in a column).

Align selected objects to the invisible grid
•

In the Logic Pro Environment window, choose Options > Clean up > Positions by Grid
from the Environment menu bar.

Align objects using key commands
•

In the Logic Pro Environment window, use the following key commands to move selected
objects one pixel in the relevant direction, even when the grid is turned on:
•

Object move left

•

Object move right

•

Object move up

•

Object move down

See MIDI Environment.
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Resize an object
•

In the Logic Pro Environment window, drag the object’s bottom-right corner.

Resize a selected object to its default value
•

In the Logic Pro Environment window, choose Options > Clean up > Size by Default from
the Environment menu bar.

Resize selected objects using key commands
•

In the Logic Pro Environment window, use the following key commands to decrease or
increase the width or height of selected objects by 1 pixel:
•

Object Height +1 Pixel

•

Object Height −1 Pixel

•

Object Width +1 Pixel

•

Object Width −1 Pixel

See MIDI Environment key commands in Logic Pro.

Advanced selection commands in the Logic Pro Environment
You can move and copy objects faster and more easily using the following commands from
the Environment’s Edit menu:
•

Select Used Instruments: Selects all objects that are assigned to the selected track in
the main window, or are connected to such objects via cables.

•

Select Unused Instruments: Selects all objects that are neither used in the main window,
nor connected to any such objects via cables.

•

Select Cable Destination: Highlights the destination object of a selected cable
connection. This is particularly useful when:
•

The destination object is on a different layer. You can use the function to select and
display the destination object (and layer).

•

You can locate the destination object of a source object in the list display (View > By
Text), because selecting the source object also selects its cable connections.

This function allows you to follow the cabling from one (serially cabled) object to the
next. If several objects are connected in parallel, or several cable connections are
selected, the path of the upper cable is followed.
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•

Select Cable Origin: Highlights the source (or origin) object of a selected cable
connection. This is particularly useful for troubleshooting, or when you want to make
changes to a number of serially cabled objects (by changing the original).

•

Invert Selection: Selects all unselected objects.
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Create your MIDI signal path
MIDI signal path overview in the Logic Pro Environment

Before any MIDI events received at your computer’s MIDI inputs can be recorded by
Logic Pro, there must be a connection between two Environment objects:
•

Physical Input object: Represents the MIDI In port or ports of your MIDI interface.

•

Sequencer Input object: Represents the door into Logic Pro for incoming MIDI events.

In Logic Pro, incoming MIDI events (that arrive at the Sequencer Input object) are always
directed to the selected track in the main window, where they can be recorded into a
MIDI region.
The events played by the MIDI region are mixed with incoming events (if any), and sent to
the Environment object that the track is routed to. From here, the events are directed to a
MIDI output (see Assign direct output connections).
You can insert objects into the signal path between the Physical Input object and the
Sequencer Input object if you wish—a MIDI monitor object, which allows you to see
incoming MIDI events, for example.
You can also insert objects between the track and its destination object, enabling other
Environment processing. The track itself is not represented by an Environment object,
but you can use the Reassign Track shortcut menu to route the track’s output to an
Environment object—a MIDI region on a software instrument track routed to a mapped
instrument object, for example.
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Insert an object between the track and its destination object

1. In the Logic Pro Environment, choose New > Mapped Instrument.
2. In the Tracks area, Control-click the track header to open the Reassign Track shortcut
menu, then browse to the mapped instrument.

3. In the Environment, cable the mapped instrument to software instrument channel strip 1.
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Assign output connections in the Logic Pro Environment
You can assign a direct output connection to a physical MIDI output from any of the
following object types:
•

Instrument

•

Multi-instrument

•

Mapped instrument

•

Touch tracks

•

GM mixer

•

MIDI metronome click

Any object with a direct output assignment is indicated by a white triangle to its right. The
triangle is hollow when there is no direct assignment.

Assign a direct output connection
•

In the Logic Pro Environment window, use the the Object inspector to choose a MIDI
output from the Port pop-up menu.

The Port pop-up menu lists all MIDI outputs, including the following options:
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•

Off: Disables the connection to the MIDI interface port.

•

All: Routes the object’s output to all available MIDI ports—useful if the device is
sending a pulse, for example.
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Cable Environment objects in Logic Pro

The cabling between Environment objects provides control over the entire MIDI signal
path. A cable between a source and destination object is normally shown in gray or
another color.
Cables are assigned the same color as the source object, which makes following the signal
path much easier. You can, however, turn off cable coloring, and render them in gray with
the View > Colored Cables option.
Objects always have an (invisible) input on the left, and an output on the right. The output
of an object is shown as a small triangle, pointing to the right.

Connect two objects by dragging

1. In the Logic Pro Environment window, click and hold the triangle of the source object.
The pointer turns into a plug (patch cord) that represents a cable connection coming
from the object’s output.

2. Move the plug over the destination object, then release the mouse button when the
object is highlighted.
A cable connection is created between the two objects.

If the source object has already been directly assigned to a MIDI output port, a dialog
asks if you want to replace the direct assignment. You have three options:
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•

Cancel: The connection is not made, and the direct output assignment of the source
object remains intact.

•

No: The connection is made, but the direct output assignment remains intact. This
means that the source object is connected to two destinations—one to another
object via the cable, and one via the direct output assignment.

•

Remove: The connection is made, and the direct output assignment is removed. This
is the default selection, because you generally won’t want an object connected to
two different destinations.
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Connect two objects using menu commands

1. In the Logic Pro Environment window, Option-click the triangle of the source object.
2. In the Reassign Track shortcut menu, browse to the layer that the destination object is
in, then choose the object name.

A cable connection is created between the two objects. This method is ideal for creating
connections between layers, but can also be useful when a large number of closely
spaced objects exists in a single layer.
You can also open a second Environment window (showing the destination layer), and
connect the objects graphically between the windows.
A cable connection to another layer looks like this:

Remove a cable connection

In the Logic Pro Environment window, do one of the following:
•

Click the cable with the Eraser tool.

•

Select the cable, then press Delete.

•

Drag the cable over the triangle of the source object.

•

Choose Edit > Clear Cables only to remove the selected cables, without clearing any
objects that happen to be selected.
This is useful when you want to clear all cables leading to, or from, one or more objects,
due to the fact that selecting objects also selects all associated cable connections.
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Make multiple connections in the Logic Pro Environment

There is no limit to the number of cables that you can plug in to a destination object. All
MIDI signals are mixed at the object’s input.

Make multiple output connections from an object

1. In the Logic Pro Environment window, connect the object to a destination object.
Once an output from an object is used (cabled to another object), another output
triangle automatically appears.

2. Use the second output triangle to create a second cable connection to another
destination object.
Once this is done, a third output triangle appears, and so on.
Some objects have special outputs, and can’t be connected this way. One example is
channel splitter objects, which feature several (functionally different) outputs. Other
special objects include cable switchers and physical input objects. With these objects,
each output can only be used once.

Route the signal of special object outputs to several destinations

1. In the Logic Pro Environment window, create a monitor object by choosing New >
Monitor.
2. Plug the cable from the desired object output into the monitor object.
3. Create a cable from the monitor object to as many other destinations as you wish.
The monitor object allows you to view the MIDI events flowing through it.
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Connect several cables to a common destination

1. In the Logic Pro Environment window, select the cables.
Tip: If the cables are already connected to a common destination, the simplest way
to do this is to select the destination object.
2. Drag one of the cables to a new destination object.
You’re asked if you want to connect all selected cables to the new destination.
3. Click Connect, or press Return.

Cable in series or parallel in the Logic Pro Environment

You can cable objects in series and in parallel. Cabling objects in series is useful for quickly
connecting groups of faders that are used to control a MIDI mixing console, for example.

Cable a group of objects in series
•

In the Logic Pro Environment window, select the objects you want to cable, then choose
Options > Cable serially.

The objects are cabled in series, starting with the upper-left object.

Cable a group of the same object type to a common destination

1. In the Logic Pro Environment window, cable one of the source objects to the destination.
2. Select the source object, then choose Edit > Copy.
3. Select the other objects you want to connect to the same destination, then choose
Options > Apply Buffer Template to > Cable(s).
You can also copy more complex cabling configurations this way. Just make sure that the
object types in the group that you want to copy match the object types in the group that
you apply the buffer template to.

Exchange Environments
Overview of Exchanging Environments in Logic Pro

One of the main advantages of the Environment is that it lets you customize Logic Pro
to fully control your MIDI studio. This can, however, present a problem when you share
projects with other musicians, or use different studio setups. It also presents a problem
when you return to older projects after you’ve changed your studio. Logic Pro offers
several functions to make these transitions as easy as possible.
Whenever you want to exchange Environments between projects, there is a source project
containing the desired Environment, and a destination project with an Environment that you
want to change. The destination Environment must be in memory, and must be the active
project (one of its windows must be active). The source project can also be in memory, or it
can be a file on your hard disk (or any other media). Keep the following in mind:
•
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If there are two projects in memory, Logic Pro assumes the active project is the
destination, and the other project is the source.
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•

If there are more than two projects in memory, Logic Pro assumes the active project is
the destination, and the most recently active of the other projects is the source.

•

If there is only one project in memory, Logic Pro opens an Open dialog, allowing you to
select the source project.

Import Environments into Logic Pro

You import an Environment into Logic Pro using an Environment patch. A singlepurpose Environment patch might be an editor for a specific piece of MIDI equipment,
an Environment for a single MIDI processing task (such as a MIDI LFO), or a complex
arpeggiator/delay line configuration.

Import an Environment patch contained in a single layer
•

In the Logic Pro Environment window, choose Options > Import Environment > Layer,
then choose a layer in the dialog that appears.

This layer—including all objects in the layer—is inserted in the destination project, at the
same layer position (the same place in the Layer pop-up menu) that it occupied in the
source project. Any existing layers are shifted as needed.
You can also move Environment objects (including cabling) between projects by dragging,
or by copying and pasting. To make this even simpler, you can combine the objects
into a macro.

Import an Environment patch spread across several Environment layers
•

In the Logic Pro Environment window, choose Options > Import Environment > Merge.

All Environment objects from the source project are added to the Environment of the
destination project. Merged objects are placed in the same layer as their source, which
can create a mess if objects already occupy that layer in the destination project. To avoid
this issue, create blank layers (in the destination project) at the same layer positions of the
source project, before importing.
When importing an Environment patch in this way, be careful of the following:
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•

If unique objects in the Environment, like the Physical Input and Sequencer Input
objects, are imported, they replace their counterparts in the destination Environment
and any cables leading into them are lost. It’s best to temporarily delete these from the
source Environment before importing.

•

When you import an object, all objects cabled from the imported object are also
imported.
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Update and swap Environments in Logic Pro

You can update an Environment if you have only added objects to it, but not deleted
anything. Only the new objects are imported; the older objects (along with their cabling
and track assignments) remain in place.
Logic Pro offers several options for swapping the Environment of one MIDI setup with the
Environment of another.

Update an Environment
•

In the Logic Pro Environment window, choose Options > Import Environment > Update.

Swap an Environment

In the Logic Pro Environment window, do one of the following:
•

Choose Options > Import Environment > Replace by Port MIDI/Channel.
All objects in the destination project are replaced with objects that reference the same
port and MIDI channel strip in the source project.

•

Choose Options > Import Environment > Replace by Name.
All objects in the destination project are replaced with objects of the same name in the
source project.

•

Choose Options > Import Environment > Total Replace.
The destination project’s Environment is replaced completely with the source project’s
Environment. If you use this option, you’ll have plenty of work to do, including
reassigning main window tracks to objects, but sometimes it’s the only way.

Note: This complex task involves a lot of guesswork on the part of Logic Pro, and the
results almost always require some manual fine-tuning on your part.

Replace Environments in Logic Pro

The most flexible (but also most time-consuming) method of exchanging Environments is
to manually choose whether each Environment object is kept, deleted, or replaced. If you
choose to replace an object, you must also define the replacement object.

Replace an Environment using custom choices

1. In the Logic Pro Environment window, use the Environment menu bar to choose
Options > Import Environment > Custom.
2. Choose the destination project.
An Environment window listing all objects in the destination Environment is shown in a
column on the left, and the chosen action for each object is shown in a column on the
right.
3. Do one of the following:
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•

Select items in the list, then choose the replacement object from a pop-up menu.
This pop-up menu includes all objects in the track list of the source project.

•

Choose Import > Import Environment using current Assignment from the destination
Environment menu bar, then choose one of the following:
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•

Import > Assign as ‘Keep’: Objects are unaltered.

•

Import > Assign as ‘Delete’: Objects are deleted.

•

Import > Assign by Identical: Objects are assigned to objects from the source
project that match the type, icon, name, port, and MIDI channel. Objects with the
same Unique ID have priority.

•

Import > Assign by Unique ID: Objects are assigned to objects from the
source project with the same Unique ID. This option is useful for updating an
Environment when objects have only been added.

•

Import > Assign by Port/MIDI Channel: Objects are replaced by objects with the
same Port/MIDI channel. If a match can’t be found for an object, an object set to
Port 0 and the same MIDI channel is assigned. If a match still can’t be found, an
object with the same MIDI channel is assigned.

•

Import > Assign by Name: Objects are replaced by objects with the most similar
name. (At least 80 percent of the name must be the same.)

•

Import > Assign by Icon/Name: As above, except the object icons must also
match.

Customize the Environment in Logic Pro

You can customize the appearance of the Environment by creating more onscreen space,
displaying objects graphically or as a list, hiding or coloring cables, or using a mini
Environment window that floats on top of other windows.

Hide or show the inspector
•

In the Logic Pro Environment window, choose View > Hide/Show Inspector (or press I).

This command hides the inspector—the Layer pop-up menu and Object inspector—making
more room for the Environment’s workspace.

View objects graphically or as a list
•

In the Logic Pro Environment window, use the Environment menu bar to choose View >
By Text.

This command switches the view between the graphical display of objects and a list.
Cables are not shown in the list display.

Hide or show cables
•

In the Logic Pro Environment window, use the Environment menu bar to choose View >
Cables.
In addition to hiding or showing cables between objects, this view also hides or shows
the positioning bar (used for moving and resizing) to the right of some object types.

Tip: You can prevent the accidental alteration of the position, size, and cable
connections of all objects by choosing View > Protect Cabling/Positions.
If the cabling and object positions are protected, and the cables are hidden, the
background color changes. This usually looks better for virtual mixing desks and
fader setups.
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View colored cables
•

In the Logic Pro Environment window, use the Environment menu bar to choose View >
Colored Cables.

Cable colors are derived from the color of the source object—the object that the cable runs
from, into another object.

Assign a color to the selected object
•

In Logic Pro main window, choose View > Show Colors from the main menu bar (or press
Option-C), then click a color in the Color palette.

View a frameless Environment window

There may be times when you want to have access to particular Environment objects while
working in the main window—buttons that are used to control a tape machine, for example.
Instead of opening an Environment window each time, you can create a small window that
floats on top of other windows.
1. In the Logic Pro Environment window, do one of the following:
•

Choose Options > Layer > Create Layer.

•

Choose Create Layer from the Layer pop-up menu.

2. Create the objects, cable them if necessary, then adjust their parameters as needed.
3. Reposition the objects, then resize the Environment window so that it’s just large
enough to accommodate the objects.
4. Choose View > Frameless Floating Window from the Environment menu bar.
A mini Environment window is created, which floats above other windows.

5. Position the window, then press Shift-L to lock it as a screenset.
6. Choose this screenset to access the tape controls whenever you need them.
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Environment objects reference
Standard instrument objects
Standard instruments in the Logic Pro Environment
Logic Pro provides standard instrument objects to handle MIDI devices that only use one
MIDI channel—typically, older synthesizers, MIDI-controlled effect units, or drum machines.
Standard instruments transmit MIDI data on a single MIDI channel.

Create a standard instrument

In the Logic Pro Environment window, do one of the following:
Choose New > Instrument.
Click the Environment background with the Pencil tool.
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Standard instrument parameters in the Logic Pro Environment
Standard instruments have the following parameters:

•

Port pop-up menu: Use to set a direct connection to one of your MIDI output ports.
Remember that you can also cable an instrument object directly to (or from) other
Environment objects, allowing MIDI processing.

•

Channel pop-up menu: Sets the MIDI channel for the instrument’s output. If you set this
parameter to All, all events are sent with their original channel settings.

•

Program, Volume, and Pan: Transmit program changes, volume controller (#7), and pan
controller (#10) data.
No data is sent until you select the corresponding checkbox. If the box is already
selected, any value alterations are sent immediately. The values are also sent whenever
you select the track while holding down Option.
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Beneath the Program parameter is the Bank parameter. If your MIDI sound source
recognizes bank select messages (check the device manual), you can switch between
sound banks. If your sound source responds to the standard Bank Select message
(Controller #32), you can use this parameter directly. If not, you can define your own
bank select commands.
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•

Transposition pop-up menu: Defines the number of semitones that all note events are
transposed by, on output. Negative values transpose downward.

•

Velocity field: Use to increase or decrease the note on velocities of all note events, by
an amount between –99 and 99.

•

Key Limit field: The two note values of the Key Limit parameter define a pitch range. All
notes outside this range are ignored by the instrument when it plays a MIDI region. In
other words, this range of notes are not played.

•

Vel Limit field: The two values of the Vel Lim parameter define a velocity range. All
notes with a velocity that falls outside this range are not played by the instrument.

•

Delay pop-up menu: Causes all MIDI events to be sent early or late, allowing you to
compensate for any differences in reaction time between your various MIDI devices. Use
the Delay parameter (in the Track inspector) to create rhythmic delay effects, as this
allows longer delay times.

•

No Transpose checkbox: If selected, all regions on any tracks played by this instrument
object are protected from transposition. In other words, the Transpose Region
parameter is ignored. This is very useful for instruments assigned to drum or other
samples—mapped across the keyboard on a single MIDI channel—as transposition
triggers different sounds (rather than pitches) in these instruments.

•

No Reset checkbox: If selected, no reset messages are sent to the instrument. This can
be useful if controllers are being used for nonmusical purposes, such as when using
the instrument object for Mixer automation tasks. The Logic Pro > Preferences > MIDI >
Reset Messages settings determine which reset messages are sent. These messages
are not sent to No Reset instruments.

•

Style pop-up menu: Can be set to any of the available staff styles. Whenever a region is
created on one of the instrument’s tracks, it’s assigned the staff style displayed here.
If the Auto style is chosen (the default), Logic Pro picks an appropriate style based on
the pitch range of the notes in the region. For more information on staff styles, see Staff
styles overview.
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Multi-instrument objects
Multi-instruments in the Logic Pro Environment
A multi-instrument is like a collection of 16 standard instruments in one package.

You generally use multi-instrument objects to address multi-timbral hardware synthesizers
or samplers. A multi-timbral sound module is one that can receive on several MIDI channels
at once, playing back a different sound on each channel simultaneously.
As most modern MIDI devices are multi-timbral, the multi-instrument probably is the most
commonly used instrument object in your Environment.
The multi-instrument object parameters are a shorter set of the standard instrument
object parameters (see Common object parameters). The settings you make in the multiinstrument’s Track inspector apply globally to all subchannels.

Create a new multi-instrument object
•

In the Logic Pro Environment window, choose New > Multi-Instrument.

View the multi-instrument’s Track inspector
•

In the Logic Pro Environment window, click the icon at the top of the multi-instrument
object.

The whole multi-instrument object is selected, allowing you to set the Port parameter,
for example.
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Multi-Instrument window in the Logic Pro Environment
Double-clicking a multi-instrument opens the Multi-Instrument window. It contains the
following areas:

•

Device Name and Short Device Name fields: At the top-left corner of the window, you
can enter the full name of the multi-instrument in the Device Name field. You can also
enter a short name for the multi-instrument in the Short Device Name field. This short
name is used in the main window track list, when the program name is displayed.
Depending on whether or not you have activated the subchannel’s Program parameter,
the following information appears in the track list of the Tracks area:

•
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•

The name of the multi-instrument and channel number (if the parameter is not
activated)

•

The short name, channel number, and program name (if the parameter is activated)

Program Names area: There are 128 program names in the Multi-Instrument window.
A total of 15 banks of 128 program names is available. There are several ways to enter
program names:
•

Double-click the name (via the text field).

•

Copy (via the Clipboard) from a different multi-instrument, or from a wordprocessing program. The Clipboard functions for a whole sound bank are available in
the Options pop-up menu.
•

First, copy the program numbers or General MIDI names to the Clipboard, and
add them to a word-processing document.

•

You can then edit the names and copy the whole section back again.

•

If you want to use program numbers instead of names, choose Init Names as
Numbers from the Options pop-up menu.

•

If you want to use General MIDI program names, choose Init General MIDI Names.
If the Use GM Drum Program Names for Channel 10 checkbox, at the bottom of the
window, is activated, the standard GM drum set names are shown in the Program
pop-up menu of the inspector for subchannel 10.
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If the Program box in the selected subchannel’s inspector has a checkmark in it,
you can send a program change message by selecting a program name in the MultiInstrument window.
•

Bank pop-up menu: The Bank pop-up menu allows you to choose one of 15 available
sound banks (0 to 14). The top item—“No Bank specified. Names of Bank 0 used”—can
be used if your sound generator does not understand bank select messages, or only has
128 sound programs.
•

Bank 0 is always initialized.

•

The first time you choose one of the banks numbered 1 to 14, you are asked whether
or not you want to initialize this bank.

•

For banks that are not initialized, the names of the equivalent program numbers from
bank 0 are used.

Note: You should only initialize additional banks if you want to enter program names for
those banks, because each initialized bank uses more memory.
•

Bank Message pop-up menu: The Bank Message pop-up menu allows you to define the
MIDI events that are sent when you switch between the banks of the multi-instrument.
Different bank select formats are used by different MIDI instrument manufacturers.
Refer to your MIDI instrument’s manual to see whether or not it supports bank select
messages, and if so, what format it uses.
With modern synths, there’s a good chance the format matches one of the top items in
the menu: either controller #32 or controller #0. There are also presets to accommodate
several of the more common types of synths. If your synth doesn’t use one of the
formats listed, you can define your own bank select messages (see Custom bank
selects).

Subchannels in the Environment in Logic Pro
Each of the 16 standard instruments in a multi-instrument provides a separate MIDI
channel—mirroring the 16 MIDI channels—and is therefore called a subchannel. The multiinstrument’s interface includes a numbered square (button) for each subchannel. Clicking
a numbered square selects the corresponding subchannel, and displays its parameters in
the Object inspector.
Each subchannel has a complete set of instrument parameters, identical to those for
standard instruments. For details, see Standard instrument parameters.
The only parameter you can’t change is the MIDI channel. If you attempt to change the
MIDI channel, you’re asked to select another subchannel, or select the multi-instrument
itself to change the common driver destination. You can, however, change the channel in
the Track inspector to any subchannel of the multi-instrument, and the track is assigned to
the selected subchannel. This allows you to redirect the (regions on the) track to another
subchannel, making it easy to play multiple parts with a particular channel/sound.
Note: If you change the Output port parameter of any subchannel, the entire multiinstrument and all other subchannels are affected.
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As with any other Environment object, you can prevent subchannels from appearing in the
Reassign Track shortcut menu in the Tracks area by deselecting the Assignable checkbox
in the Object inspector. The button for the subchannel appears with a diagonal line through
it when deactivated.

In the above image, subchannel 1 is selected, subchannels 1 to 8 are activated, and
subchannels 9 to 16 have been removed from the Reassign Track shortcut menu.

Connect the output of an object directly to the input of a subchannel
•

In the Logic Pro Environment window, Option-click the source object’s output triangle,
then choose the subchannel in the Reassign Track shortcut menu. (See Cable
Environment objects.)

You can’t drag a cable to a subchannel. Any dragged cables can only be connected to the
entire multi-instrument object, not one of its subchannels.

Mapped instrument objects
Mapped instruments in the Logic Pro Environment
A mapped instrument is particularly useful for drum instruments or any drum-mode MIDI
device. A drum-mode device has different sounds assigned to different MIDI notes, but
only uses a single MIDI channel; for example, a drum kit loaded into the Sampler, or MIDI
channel 10 of a GM-compliant sound module, or a drum machine.
A mapped instrument is used just like a standard instrument, but each individual input
note can be:
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•

Named (snare, hi-hat, and so on)

•

Mapped to an output note

•

Given a velocity offset

•

Assigned its own MIDI channel

•

Sent to one of up to 16 output cables (This allows you to create a single instrument that
addresses multiple sound sources.)

•

Given its own notation parameters: note head shape, relative vertical position in the
staff, and drum group assignment (See Use mapped staff styles for drum notation.)
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The mapped instrument’s parameters are a subset of the standard instrument parameters.
The missing settings are available on a note-by-note basis in the Mapped Instrument
window. For details, see Common object parameters.

Create a new mapped instrument
•

In the Logic Pro Environment window, choose New > Mapped Instrument.

Mapped Instrument window in the Logic Pro Environment
The Mapped Instrument window opens when you double-click a mapped instrument
icon that you have already added to the Environment, or when you create a new mapped
instrument. The rows correspond to input notes, and the columns contain the various
parameters available for each note.

•
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Keyboard (Selecting Notes): The keyboard on the left represents the input notes, which
can be played by clicking them. You can also select individual notes or note ranges by
dragging the mouse over the notes you want to use. To select multiple notes, Shift-click
them. Any value alterations apply to all selected notes.

1168

•

Input Name: In the first column, you can click the input note name (E6, for example),
and enter a name of up to 12 characters. Press Return or click outside the field to
confirm the new name.
You can initialize the names of the selected notes to:
•

Pitch descriptions (C#3, for example) by choosing Initialize > Names as Notes.

•

The names of GM Standard drum sounds by choosing Initialize > Names as General
MIDI.

If a MIDI region (on a track routed to a mapped instrument object) is displayed in the
Piano Roll Editor, the names of the notes being played appear on the vertical keyboard.

•

Output Note: This column is used to set the output note. This is done by either:
•

Double-clicking the note description and editing the text

•

Dragging the beam to the right of the output note name

MIDI notes are sent while the value is being changed, allowing you to hear what you’re
doing. Use the Initialize > Output Notes command to match the output notes of the
selected pitches to the input note pitches.
•

Velocity: Use to set a velocity offset that is added to, or subtracted from, the velocity of
the incoming note. Drag the number vertically to create a velocity offset. You can also
click the specific point on the beam.
To reset all velocity offsets to 0 (no offset), choose Initialize > Output Velocities.

•

Channel: Use to set the MIDI channel of individual notes. This lets you play individual
sounds from different drum sets in the same sound generator. You normally use the
Base setting, which means that the notes are sent on the channel set in the mapped
instrument’s inspector. If you choose All in the inspector, the channel information of the
incoming notes is used. This is useful if you want to place the mapped instrument after
a multi-instrument or standard instrument in the signal path.
To set all selected notes to Base, choose Initialize > Output Channels.
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•

Cabling Mapped Instruments: You can send individual notes from a mapped instrument
object to (up to) 16 different output cables, allowing you to play sounds from different
sound sources. If you select a cable that doesn’t exist, the note won’t be sent out.
The Initialize > Output Cables command resets all cables to #1 (the top outlet of the
mapped instrument).

•

Notation Parameters: The last three columns define the notation parameters of
individual notes.
•

Head: Use to change the note head.

•

Rel. Pos.: Use to alter the relative position of the note on the staff. The pitch isn’t
altered; only the vertical positioning of the note head on a staff in the Score Editor.
Drag vertically to alter the note position.

•

Group: As the mapped instrument object is typically used for percussion
instruments, click-holding the Group field opens a pop-up menu of grouped drum
families: Kick, Snare, and so on. MIDI sound modules can have drum sounds mapped
across 127 possible notes, which would result in an interesting staff (to say the
least). Assign several related percussion sounds (tom drums, for example) to the
Toms group to place all related sounds on a single staff line. As with the relative
position, the pitch of grouped notes is not affected by grouping them on a single
line.

To neutralize the settings of the Head, Rel. Pos., and Group parameters, choose
Initialize > Score Parameters.

Custom bank selects in the Logic Pro Environment
Logic Pro provides 16 bank numbers (0 to 15) for each standard instrument, multiinstrument (including subchannels), or mapped instrument object. You can create custom
lists, consisting of as many events (of any kind, even SysEx) as you like, for each of
these banks.
Whenever you change the bank manually, or send a standard bank change message from
Logic Pro, the entire list for that bank is transmitted to your sound module.

Set up custom bank select messages

1. In the Logic Pro Environment window, select the instrument for which you want to define
bank select messages.
2. Choose Options > Define Custom Bank Messages.
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A window similar to the Event List opens, with a single, default bank select message for
banks 0 to 15. (The default used is a MIDI controller #0 message, with a value equal to
the bank number.)

You can create MIDI events here as you would in the Event List, by cutting, copying,
inserting, and editing. (See Edit events overview.) The only difference is that you enter a
bank number, rather than a time position.
The letter in parentheses next to the bank number allows you to control the order of
transmission when a bank select requires more than one message.
If there are no events defined for a particular bank, a standard bank select message is
sent for that bank.
For bank messages that need a channel (MIDI controller messages, for example),
the channel of the instrument is used. This feature is especially useful for multiinstruments, as you only need to create one set of bank messages for all 16
subchannels. If an instrument’s channel is set to All, channel 1 is used.
The custom bank select information becomes part of the instrument, and is automatically
copied with it, if you replicate the instrument object.
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Touch track objects
Touch tracks in the Logic Pro Environment
Touch tracks objects enable you to trigger MIDI regions or folders by playing a single note
on your MIDI keyboard. You can use this function to play entire MIDI passages, create a
new arrangement in real time, and so on, all with a single key press. Touch tracks are ideal
for live performances.

You can’t use touch tracks to trigger audio. Any references to regions mean folders and
MIDI regions, not audio regions. Despite this limitation, you could conceivably load your
audio regions (as files) into the Sampler, and trigger it with a touch tracks object.
Here are some things to remember:
•

Only the touch tracks input has meaning—trigger notes must appear here. Although the
object features an output triangle, it has no use, as events never appear here.

•

MIDI regions and folders triggered by touch tracks play exactly as they would from the
main window: they play back through the instruments assigned to their tracks.

•

Logic Pro must be open for touch tracks to work.

Create a touch tracks object

In the Logic Pro Environment window, do one of the following:
•

Choose New > Touch Tracks from the Environment menu bar.

•

Drag a MIDI region or folder from the Tracks area into the Environment.

Use a touch tracks object

In the Logic Pro Environment window, do one of the following:
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•

Assign the touch tracks object to a track.

•

Place the touch tracks object anywhere in the MIDI signal path.
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Touch Tracks window in the Logic Pro Environment
Double-clicking a touch tracks object opens the Touch Tracks window.

This window is similar to the Mapped Instrument window. The input note is selected via
the keyboard on the left, and the output region assignment and parameters are set in the
columns of the corresponding row. For details about mapped instruments, see Mapped
instrument objects overview.
A vertical gray line means that the setting is the same as the line above. If you change a
vertical gray line that is above another vertical gray line, the lower one changes to display
its previous value. (It’s no longer the same as the line above.)
•

Region Note Assignment: Dragging a MIDI region or folder into the Environment
automatically creates a touch tracks object. All notes (initially) trigger this region.
Middle C plays the region or folder at its original pitch, and all other notes transpose it,
relative to middle C.
In the Input Name column, you can see the input notes, and to the right, in the Region/
Folder column, the names of the assigned regions or folders. On the vertical keyboard
to the left, you can select individual notes or pitch ranges by dragging across several
keys. If you then drag a MIDI region or folder from the main window, it is only assigned
to the selected note (or note range).

•

Group: Groups behave as they do in the Step Editor. When you trigger a region, any
other (currently playing) region in the same group stops. The Off setting means that the
region is not assigned to any group.

•

Transpos (Transposition): When you drag a region to a key in the Touch Tracks window,
that key triggers the region at its original pitch (without transposition). If you want to
transpose the region, you can set the amount in the Transposition column.
If a key range is selected when you drag the region into the Touch Tracks window,
incremental transpositions are set automatically for adjacent keys (within the key
range).
When you create a touch tracks object by dragging a region into the Environment, C3
triggers the region at its normal pitch, and all other keys trigger it (transposed relative
to C3).
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•

Velocity: In the Velocity column, you can set the sensitivity of regions to the velocity
value of the trigger note: by 100% (very sensitive), 50% (somewhat sensitive), or off
(not velocity sensitive).

•

Trigger Modes: The Trigger column determines how region playback is handled:
•

Multi: Playing the trigger note starts the region. Playing it again restarts the region,
without stopping playback of the originally triggered version.

•

Single: Playing the trigger note once starts the region. Playing it again stops
playback, and restarts the region.

•

Gate: The region plays until the trigger note is released (or until the region ends).

•

Gate Loop: The region loops until the trigger note is released.

•

Toggle: Playing the trigger note starts the region. Playing it again stops playback.

•

Toggle Loop: Playing the trigger note starts region looping. Playing it again stops
playback.

•

Start: This column allows you to quantize region start and stop. Free means no
quantization. The Next 1/16, Next 1/4, or Next 1/1 settings start or stop the region at the
next 1/16 or 1/4 note, or at the beginning of the next bar, when a trigger note is played.

•

Delay: Use this column to assign a delay to the region start point. The delay is set on
the right side of the column in ticks, or on the left side in note values. You can use both
Delay and Start to make regions start at any position in the measure. For example: Set
Start to 1/1 and Delay to 480 ticks to start playback at the second 8th note in the
measure.

Fader objects
Fader objects in the Logic Pro Environment
Faders come in different forms (knobs, sliders, numerical, and buttons). You use faders
to send MIDI events by clicking or dragging them. Fader objects respond to incoming
MIDI events.

Create a new fader
•

In the Logic Pro Environment window, choose New > Fader.
A submenu appears, in which you select a style of fader. There’s also a submenu at
the bottom named Special, which you use to select various special fader types (cable
switcher, meta-fader, and so on).

Logic Pro User Guide

1174

The style of a fader determines its onscreen appearance—fader, button, or knob, for
example—and how it responds to the mouse (drag, click, or double-click and enter
a number).

The auto style fader—the default style if you create a fader with a key command—changes
styles as you alter its shape and size.
The type of fader determines what events the fader sends out and responds to. In two
cases, however, the fader doesn’t send out events at all:
•

The cable switcher routes events to its different outputs. Clicking a cable switcher
object makes it step sequentially through the outputs.

•

The alias assigner changes the references (to an original, or parent object) of fader
aliases.

In general, a fader’s style is completely independent of its type. A cable switcher can
look like a button, a knob can send out MIDI or meta or SysEx events, and so on. The one
exception is the vector style fader—these behave in a special way, by sending out two (or
four, in special cases) messages at a time, depending on the mouse location within their
2-dimensional, vector window.

Use faders in the Logic Pro Environment
Normally, you grab the surface of a fader and drag it vertically or horizontally, depending
on its style. When using the fader itself as a slider, you may notice that values jump in
larger increments, depending on the size of the fader and dragging speed. You can also
change values in single steps by dragging the slider or knob while holding down the
Control key.
Some of the fader styles have numerical displays. In these cases, double-click in the
numerical field and enter a value. When you drag any of the sliders or knobs, the series
of values that are sent out depends on the fader size and scrolling speed—not every
consecutive value is sent out at smaller sizes. If you drag slowly in the numerical field,
however, you’ll send consecutive values.

Knobs can be dragged either vertically or horizontally.
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Buttons only send two values, the lowest and highest of their range set in the Object
inspector. You change a button’s state by clicking it.
The default appearance of the text fader is like a value field that can be scrolled. Doubleclick to open a window and enter text for each menu position. Select the Behaves as Menu
checkbox to use the text fader as a pop-up menu.
A vector fader allows you to scroll in two directions, and sends out two values: one
corresponding to the vertical position, and the other to the horizontal position.

Play back fader movements in the Logic Pro Environment
As with the channel strips in the Mixer, you can record fader object movements to tracks,
and play them back.
You don’t need any special cabling to record the data generated by a fader. All data
generated by faders is recorded on the selected track when Logic Pro is in record or
record/pause mode.
Any fader reacts to incoming events that match its Input definition. The fader must, of
course, be in the MIDI signal path. Typically, you would accomplish this by cabling the track
instrument into the fader.
For fader object automation tasks, however, it’s useful to create a new (standard)
instrument for the sole purpose of fader automation. Make sure that the instrument:
•

Has no direct MIDI output

•

Uses the Channel setting All

•

Is connected to the first fader in any chain of serially cabled faders (if cabled this way)

Object groups in the Logic Pro Environment
When building a virtual mixing desk or synthesizer layout in the Environment, you often
need to work with large groups of fader objects that have the same size, regular spacing,
or a similar definition.
To save time on the definition and alignment of these groups, you can choose (one or
more) objects as prototypes (templates) by copying them into the Clipboard. (Choose
Edit > Copy.) You can then apply certain characteristics of these template objects to
selected objects.

Transfer the size of the prototypes to the selected objects
•

In the Logic Pro Environment window, choose Options > Apply Buffer Template to >
Size.

Transfer the alignment template of selected objects
•

In the Logic Pro Environment window, choose Options > Apply Buffer Template to >
Position.

The selected target objects are positioned at the top-left corner of the Environment layer,
in accordance with the layout of the template.
The Options > Apply Buffer Template to > Position and Size command combines both of
the above functions.
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•

Definition: The following describes the definition characteristics that can be transferred
to selected objects.
•

The Options > Apply Buffer Template to > Definition function transfers the
parameters of a copied template to all selected objects. If several templates of the
same type are available, the one that is closest in size is used.

•

The Options > Apply Buffer Template to > “Definition, channel increment” increases
the channel number from object to object, beginning with the top-left object. It’s not
necessary for the selected objects to have the same Input or Output definition as the
template.

•

The Options > Apply Buffer Template to > “Definition, number increment” increases
the first data byte of the definition (controller number, for example).

•

Cable serially: The Options > “Cable serially” function connects all selected objects in
series, beginning with the object at the top left.

•

Names with Numbers: If you name one object in a selected group of objects with a name
that ends in a numeral, the remaining objects adopt the name, but with sequentially
increasing numbers. For example, selecting several objects and naming one of them
“Object 1” results in the ensuing objects being renamed “Object 2,” “Object 3,” “Object
4,” and so on.

Fader styles in the Logic Pro Environment
A fader’s style is shown in the line under the icon. It can be changed by selecting the
current style name and choosing a new style from the pop-up menu.
Remember that a fader’s style does not usually affect its function—you can select the most
convenient style for the intended use of the object.
Some of the fader styles are described below.
•

Vertical/Mute: This is exactly like the Vertical 4 fader style, with an added Mute button.

When you click the Mute button, the fader sends an event (with a value of 0) that
matches the Output definition.

•
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•

The fader’s movements are not sent while the Mute button is on.

•

The current fader value is sent when you turn the Mute button off.

Buttons: Button style faders can only send two possible values: the minimum (off) and
maximum (on) values of their range. If the minimum and maximum range parameters are
set to the same value, the button sends this value each time it is clicked.
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•

Text: Text faders function like numerical faders, but can display text for each of the 128
possible MIDI values (0 to 127). Double-clicking the surface of a text fader opens the
Text Fader window.

•

Click a position in this window to send the corresponding fader value. (This is similar
to selecting programs by name in the Multi-Instrument window.)

•

Double-click a position in the window to enter new text. By default, when you create
a text style fader, the text positions contain numerical values. You can use this
feature to create numerical style faders with colored backgrounds.

You can modify the following parameters in the Text Fader window:
•

Options pop-up menu: Provides Cut, Copy, and Paste functions. You can use these
operations to transfer the entire list of names to a text editor, for more convenient
editing.
•

Empty lines (and lines that only contain spaces) are ignored.

•

If you want to insert blank positions in the list, use Option–Space bar.

•

Behave as Menu checkbox: Makes the text fader act like a pop-up menu. When
unselected, the text fader acts like a scrolling menu.

•

Text Fader Range: Determines the number of names that can be entered into a text
style fader object. If you set a text style fader’s range to 0, 1 you can only enter two
values.
You should always set the minimum necessary range for a text fader, as this saves
memory. In any case, remember that the first name corresponds to the lowest value
in the range (not necessarily 0), and the last name corresponds to the highest value
(not necessarily 127).
If you force a text fader to a value outside its range (with MIDI input) it displays “---”
for values below its range and “+++” for values above. The one exception is when
the fader’s range is 0, 1; in this case, all values above 1 display the name for value 1.
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Fader: MIDI events in the Logic Pro Environment
Each fader has an Input definition and an Output definition.
•

Input definition: Determines the types of MIDI events that can remotely control the
fader.

•

Output definition: Determines the types of MIDI events the fader sends out.

A fader can, therefore, convert one type of MIDI event to another. Most MIDI events consist
of three bytes:
•

The first byte indicates the type and channel of the MIDI event (a note on channel 3, for
example).

•

The second byte indicates the first data value (the pitch of a note event, for example).

•

The third byte indicates the second data value (the velocity of a note event, for
example).

A few MIDI events—program change and aftertouch—only use two bytes. Faders and
transformers always provide for three bytes, with the second byte being discarded when
these special, 2-byte messages are received.
Fader parameters are provided for setting the message type, MIDI channel, and the first
data value. Note that the message type and MIDI channel are actually combined in the
resulting MIDI event. The second data value is determined by the fader setting, or if the
fader is being remotely MIDI-controlled, by the incoming MIDI event.
The following are used to define the Input and Output parameters:
•

Output (or Input): Defines the event type.

•

Channel (1 to 16): Defines the MIDI channel of the event.

•

-1- (0 to 127): Defines the first data byte of the event. In some cases, such as pitch
bend, this is an actual data value. In other cases, such as MIDI controllers, this indicates
the controller type (volume, pan, and so on). In other cases, such as aftertouch, this
byte is unused.

The -1- parameter options are described here, including how the fader position affects
them (for both the Input and Output definitions):
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•

Note On: The -1- parameter sets the pitch, and the fader position sets the velocity.
This is most useful as an Input definition, for trapping specific notes and converting
them to other MIDI events, or simply monitoring their velocity. If you move a fader with
an Output definition set to Note On, a note off MIDI event immediately follows the note
on. This might be useful for creating onscreen drum pads from button style faders, for
example.

•

P-Press: The -1- parameter sets the pitch, and the fader position sets the amount of
Poly Aftertouch (polyphonic aftertouch).

•

Control: The -1- parameter sets the MIDI controller number (the controller type), and
the fader position sets the controller value. The controller type can actually be selected
by name, via the pop-up menu that appears when you click-hold the -1- parameter.

•

Program Change: The -1- parameter is ignored. The fader position determines the
program number.

•

C-Press: The -1- parameter is ignored. The fader position sets the channel aftertouch
(monophonic aftertouch) amount.
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•

PitchBd: The -1- parameter sets the pitch bend least significant byte (LSB), and the
fader position sets the most significant byte (MSB). Typically, you would set the -1parameter to 0, and use the fader to control the coarse pitch bend amount. A -1- setting
of 0, and a fader position of 64, results in no pitch bend.

SysEx and Switcher/Meta are special functions of the faders.

Fader: range, value as in the Logic Pro Environment
The following parameters determine the minimum and maximum values of a fader, and how
the fader displays these values:
•

Range: Contains two numbers—the left one sets the lowest possible fader value, and
the right one sets the highest. Note that these limits can be exceeded by MIDI remote
control. When the fader style is a button, the range determines the in and out position
values of the button.
For text style faders, the first name always corresponds to the low end of the range, and
subsequent names correspond to incremental range values, up to the top range. The
number of names that can be entered into the window is limited by the range.

•

Value as: Determines the way that numerical values are displayed by the fader:
•

Number: The fader value is displayed as a number (0 to 127).

•

Pan: Fader value 64 is displayed as 0; smaller values appear as negative numbers
and larger values as positive numbers (–64 to 63).

•

Hz, Octave, dB, ms: These display formats are tailored to various DSP functions.

•

bpm: An offset of 50 is added to the fader value. This displays the correct tempo
settings for the Special > Tempo Control fader.

If none of the above formats is suitable, consider using a text style fader, and entering
the display values you want as text. Examples include percentages, note names, and
program names.

Fader: filter in the Logic Pro Environment
This parameter provides various filtering options for MIDI events:
•

Off: All incoming MIDI events are allowed to pass through. All events that match the
input definition are converted, in accordance with the output definition.

•

Other: All MIDI events that don’t correspond to the input definition are filtered. All
events that match the input definition are converted in accordance with the output
definition, and allowed to pass through.

•

Match: All MIDI events that match the input definition are filtered; all others are allowed
to pass.

•

All: All incoming MIDI events are filtered.

•

Thru: All MIDI events coming from the Physical Input object are filtered. This is the same
as turning off all events coming from Logic Pro (from regions or the Environment).
Use this filter mode to prevent MIDI feedback by blocking incoming MIDI events from
being sent back out.

•
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Shot: When the fader is moved with the mouse, only the final value (the value when the
mouse button is released) is sent.
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•

14 Bit: The result of using this filter setting depends on how it’s used.
•

Used in conjunction with pitch bend, 2-byte (fine-tuning) pitch bend events are
allowed.

•

Used with controller messages, the fader sends two MIDI controller messages: one
for the most significant byte (MSB) and one for the least significant byte (LSB).

Note: The fader’s Input and Output definitions must be the same or the 14 Bit setting do
not work.
For controllers, the MSB uses the Input definition controller number, and the LSB uses
the controller number 32 or higher. This conforms to the MIDI standard for sending 14bit controller data.
When this filter setting is chosen, the fader’s Range can be set to a maximum value of
16,383. A fader value of 8192 represents no pitch bend.
•

Feedback: When the Feedback parameter is turned off (unselected), the fader
automatically prevents feedback loops resulting from circular cabling. (The fader
remembers when a specific MIDI event has passed through it and does not allow it to
pass through again.)
In some instances, you may want to enable feedback—to allow a MIDI event to change a
cable switcher’s position after it has passed through the switch, for example. Selecting
the Feedback checkbox allows this behavior.

Vector fader in the Environment in Logic Pro
Vector faders function like joysticks. They can be moved in two dimensions: up and down
and left and right. Each dimension generates its own MIDI events, so each time you change
the position of the crosshair with the mouse, two MIDI events are sent.

Most faders have Input and Output definitions, which determine the MIDI events sent by
the fader (Output), and those it reacts to (Input). (See Fader functions: range, value as.)
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For vector faders, Input and Output definitions are replaced with Vert and Horz definitions,
which determine the MIDI events that correspond to vertical and horizontal motion. If
corresponding MIDI events are received by the vector style fader, its crosshair display
updates accordingly.
If you set a vector fader’s Vert and Horz definitions to the same MIDI event (the same MIDI
controller and channel), the vector fader sends out the same MIDI event each time the
crosshair is moved, but on four consecutive MIDI channels, starting with the channel set in
the Vert definition.
•

Upper-left for the lowest channel (channel 3, for example)

•

Upper-right (channel 4)

•

Lower-left (channel 5)

•

Lower-right (channel 6)

The values of these MIDI events correspond to the proximity of the crosshair to the vector
fader’s four corners:
•

In the center, all channels receive a value of 32.

•

At the corners, the corresponding channel receives a value of 127 and all remaining
channels receive a value of 0 (if using the default range of 0 to 127).

If you alter the range, the center and corners behave differently, with the four values
always totaling 125.

Special faders in the Logic Pro Environment
The Environment provides a number of special fader objects that are built specifically to
perform certain functions.
Cable switchers, alias assigners, and meta messages are types of faders that do not
generate MIDI events. They share the same Output definition type, either Switch or Meta,
depending on the current -1- value setting:
•

If the -1- value is 48, the fader is a cable switcher.

•

If the -1- value is 46, the fader is an alias assigner.

•

If the -1- value is any other value, the fader sends out meta messages of a type that
corresponds to the -1- value.

Create a cable switcher

In the Logic Pro Environment window, do one of the following:
•

Choose New > Fader > Specials > Cable Switcher.

•

Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 48.

Create an alias assigner

In the Logic Pro Environment window, do one of the following:
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•

Choose New > Fader > Specials > Alias Assigner.

•

Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to 46.
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Create a meta type fader

In the Logic Pro Environment window, do one of the following:
•

Choose it from the New > Fader > Specials menu.

•

Change an existing fader’s Output definition to Switch/Meta, and set its -1- value to the
desired meta event number.

Cable switchers in the Logic Pro Environment
Cable switcher objects route events, rather than generate them. Any kind of MIDI or meta
event can be routed by a cable switcher. The only exception is events that match the cable
switcher’s Input definition. These events change the switch position (the routing), rather
than pass through the cable switcher.

A cable switcher can be assigned to any fader style. It’s practical to use the text fader
style, as it allows you to label the switcher’s various routes. Use Auto Style to actually
display the switch routing, as shown above.
A cable switcher can have up to 128 separate cable outputs—a new output is generated
each time an existing output is cabled to another object. You can click an auto style cable
switcher to step through the outlets (including the last, uncabled one).
Incoming events that match the cable switcher’s Input definition change the switch
position to that of the incoming data value. (If the data value is greater than the number of
switch positions, the last, uncabled outlet is selected.)
Data values of 126 and 127 have a special effect.
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•

An event with a value of 127 increases the output number. If you’re on the switcher’s
last output when this event is received, you’ll jump back to the first output. This is just
like clicking the fader.

•

An event with a value of 126 decreases the output number. If you’re on the switcher’s
first output when this event is received, you’ll jump to the last output.
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Meta event faders in the Logic Pro Environment
Meta faders generate special meta events, which are used to control certain Logic Pro
functions, but have no MIDI meaning, and are never sent to the MIDI output.
In some cases—Go to Screenset, Go to Project, and so on—you don’t need to cable meta
faders into another object for them to work. You can use cabling to process meta events in
the Environment, and alter their effect.
However in the majority of cases—Set fader range minimum, Bang!, Set transformer
operation minimum, and so on—the meta fader must be cabled to the object
being affected.
The following table is a summary of the currently implemented meta events that can be
generated by faders.
Meta event

Controlled function

46

Assign Alias

49

Go to Screenset

50

Go to Project

51

Go to Marker

52

Stop Playback

96

Set fader range minimum

97

Set fader range maximum

98

Set the fader value without sending

99

Bang! Causes the fader to resend its current value. The bang data
value can be used to make the fader increment-without-rollover (127),
decrement-without-rollover (125), increment-with-rollover (123) or
decrement-with-rollover (121). Use values one less than those shown to
have the bang passed through to all connected faders.

100

Tempo Control

122

Set transformer map value for the currently selected map position

123

Select transformer map position

124

Set transformer condition maximum (bottom) parameter, if any. (This
applies to all conditions not set to All.)

125

Set transformer condition minimum (top) parameter, if any. (This applies
to all conditions not set to All.)

126

Set transformer operation maximum (bottom) parameter, if any. (This
applies to all operations not set to Thru.)

127

Set transformer operation minimum (top) parameter, if any. (This applies
to all operations not set to Thru.)

To learn more about meta events 122 to 127, see Use Meta events in the Environment.
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SysEx faders in the Logic Pro Environment
The SysEx fader type is slightly different from other fader types. It is primarily designed to
send MIDI System Exclusive (SysEx) messages—messages that are exclusive to individual
manufacturers’ MIDI devices—whenever a specified fader is moved or controlled remotely.
You enter the messages that you want to send in a window that resembles the Event List.
Note: SysEx faders can actually be used for any kind of MIDI event, making them useful for
sending ordered batches of messages, such as Mixer or control panel snapshots, with one
click of the mouse.

Open the SysEx Fader Editor window
•

In the Logic Pro Environment window, select the fader, then use the inspector to choose
SysEx from either the Output or Input pop-up menu.
The SysEx Fader Editor window opens automatically.

You can also specify SysEx as an Input definition, but this has limited usefulness because
the incoming message (presumably SysEx) must be very short in order to be recognized.
(Because SysEx messages can be of any length, Logic Pro must break them into small
packets to avoid interrupting other MIDI activities.)
An important thing to remember about the SysEx fader is that only selected events have
their value altered by the fader value when the SysEx fader window is closed. Events that
are not selected are sent exactly as they appear in the window.
For SysEx messages, you can determine:
•

The bytes that are altered

•

The format (MSB/LSB, BCD, nibbles, and so on) of the value

You can also specify a checksum format, if necessary.
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SysEx messages in the Logic Pro Environment
There are several ways to enter SysEx messages in the SysEx Fader Editor window.

Teach the fader to learn a SysEx string

1. In the Logic Pro Environment window, click the MIDI In button at the top-right corner of
the window.

2. Alter the parameter on your device.
The corresponding SysEx message is displayed. You can also enter SysEx messages in the
SysEx Fader Editor window by typing the SysEx string into the Event List. (Check your MIDI
device manual for SysEx support materials.)

Manually enter SysEx strings
•

In the Logic Pro SysEx Fader Editor window, choose Syst. Exclusive from the Event Type
pop-up menu, then click the Add Event button.

A generic SysEx message appears.
•
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The first data byte in the top line (directly after the word SysEx in the Num column)
is the manufacturer’s ID. This may be several data bytes long (as there are more than
128 manufacturers of MIDI devices).
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•

The manufacturer’s ID is usually followed by a device type ID, an individual device
ID, a data type ID (which could be several bytes) and, if necessary, the number of
the multi-timbral subchannel, and the identification number or numbers of the sound
parameters plus the value of the sound parameter. There are no uniform standards
that apply here.

•

Data bytes are normally input as decimal numbers. To enter them in hex, place a $ in
front of values when you type them. Choose View > SysEx in Hex Format to see all
values in hexadecimal.

•

The last data byte (the EOX indicating the end of the SysEx message) is entered
automatically by Logic Pro. The number of data bytes in the SysEx message can be
decreased or increased by clicking the Plus and Minus buttons before and after the
word EOX.

Although you can have any number of messages (of any kind) in the SysEx fader’s Event
List, there is only one fader value, and all selected messages adopt this value.
You can use a similar method to create any kind of MIDI or meta event in the SysEx fader
window. Command-clicking any of the eight event type buttons (Note, Program Number,
Pitch Bend, Controller, Channel Aftertouch, Poly Aftertouch, SysEx, and Meta Event)
creates a new event of that type. Meta events can be created by using the expanded view
button, featuring the 0’s and 1’s on its face.
The terms SUM (for the checksum) and VAL (for the fader value) being sent are displayed
within the SysEx string.

Set the checksum and value of a SysEx event

1. In the Logic Pro SysEx Fader Editor window, select the events you want to alter.
2. Choose options from the Checksum and Value pop-up menus (found in the lower-right
corner of the window) to set the format of these bytes.
•

Checksum Format: A checksum can be created in any of the following formats:
•

Roland

•

Yamaha

•

Regular Checksum

•

2’s complement

•

1’s complement

If you don’t know which one works with your MIDI device, try “off” (= no checksum)
first or “2’s complement.”
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•

Value Byte Position: Position allows you to determine the position of the value byte.
This position is specified in bytes, counted from the end of the message: “last”
refers to the position directly before the EOX byte, “Last-1” indicates the byte before
that, and so on. Auto ensures that the value byte is inserted at the last position in
the SysEx string if no checksum was selected, or—if a checksum value was entered—
that the value is inserted as the second-to-last byte.

•

Value Byte Format: The following table outlines the resulting data format of the value
option you send: (The unused bits of the transfer in nibbles (X in 0XXXNNNN) are
sent with the information at the relevant positions of the SysEx strings. If you want to
transfer these deleted bits, you need to enter zeros in the SysEx string.)
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Value option

Result

Auto

The value is sent as one byte if the value range maximum is 127 or less. If
the maximum is higher than 127, the value is sent as two bytes, the most
significant byte (MSB) first.

One Byte

The value is sent as one byte.

MSB/LSB

The value is sent in two bytes, with the most significant byte (MSB) first.

LSB/MSB

The value is sent in two bytes, with the least significant byte (LSB) first.

BCD 4 LSB

The value is sent as Binary Coded Decimal in four bytes, in the order 1, 10,
100, 1000.

BCD 4 MSB

The value is sent as Binary Coded Decimal in four bytes, in the order 1000,
100, 10, 1.

2 Nibbles L

The value is sent in two nibbles, with the least significant nibble first.

3 Nibbles L

The value is sent in three nibbles, with the least significant nibble first.

4 Nibbles L

The value is sent in four nibbles, with the least significant nibble first.

2 Nibbles M

The value is sent in two nibbles, with the most significant nibble first.

3 Nibbles M

The value is sent in three nibbles, with the most significant nibble first.

4 Nibbles M

The value is sent in four nibbles, with the most significant nibble first.

2 ASCII M

The value is sent in two nibbles, the most significant nibble first; the
nibbles are sent in ASCII format for the hex value. For example, the value
$7F (= 127 in decimal) is transmitted as a 7 and F.

3 ASCII M

Same as 2 ASCII M, but in 3 nibbles.

4 ASCII M

Same as 2 ASCII M, but in 4 nibbles.

Special functions in the Logic Pro Environment
There are several behaviors and commands that enhance the use of fader objects.
•

Temporarily grouping faders: If you drag to select or Shift-click to select several faders
and move one of them, all selected faders move proportionately.
As long as all faders remain selected, their relative positions are retained (even after
one or more of the faders has reached its minimum or maximum position).

•

•

Option-dragging any fader in the group changes all values in a linear fashion. (The
absolute value differences are maintained.)

•

Option-Shift-dragging any fader in the group changes all faders to the same value.

Sending fader values: Choose Options > Send All Fader Values (or use the Send All
Current Fader Values key command) to make all fader objects send their current values.
Choose Options > Send Selected Fader Values to make all selected fader objects send
their current values.
Use of these commands in conjunction with the Record/Pause mode allows you to
record a snapshot of all current fader positions. This is especially useful for virtual
mixing desks, or synthesizer panels.
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The File > Project Settings > MIDI > General > “Send After Loading Project: All fader
values” option automatically sends all fader values after a project is loaded.
•

Resetting fader values: Choose Options > Reset Selected Faders to set all selected
fader values to zero, and transmit the data.

Alias objects
Alias objects in the Logic Pro Environment
You can create an alias of any Environment object, and behaves exactly like the original.
In the case of faders, the alias has its own value, which can be different from the value of
the original object. This is particularly useful when using text faders, as they consume a lot
of memory. If you need several text faders of the same name, make several aliases of one
original object.
Aliases can be reassigned with meta events. You use a special fader, known as the alias
assigner, which works like the cable switcher, to accomplish this.

Create an alias of any object
•

In the Logic Pro Environment window, select the object, then choose New > Alias.

Create an alias assigner
•

In the Logic Pro Environment window, choose New > Fader > Specials > Alias Assigner.
A meta fader, with a -1- definition set to 46, is created.

To use the alias assigner, cable its top output to the alias, and cable subsequent outputs
to the various originals that you want to assign to the alias. If you set the alias assigner’s
maximum range to match the number of originals and its minimum range to 1, you can then
connect the next cable to a new alias, and subsequent cables to originals for the alias. In
this way, the alias assigner can be used to assign multiple aliases simultaneously.
One situation in which you might use an alias assigner is when switching a delay line alias
between different originals (different delay line objects), each set to different delay times.
This method is one of several ways to provide MIDI control over delay time.
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If you copy an alias, you create a new alias of the same original. If you select and copy both
an alias and its original, you create a copy of the original with its own, separate alias.

Alias parameters in the Logic Pro Environment
Aliases share the parameters of their parent (original) objects, but they also have their
own, special parameters:

•

Reference pop-up menu: Use to select the original on which the alias is based.

•

Channel field: Rechannelizes all events (except fader events), leaving the alias to the
selected channel. If the Channel setting is All, existing channelized events are not
changed.
For faders, the Channel parameter causes the alias to act as if the original fader’s Input
and Output definitions are both set to the specified channel. (An All setting results in no
change.)

•

Share Name and Share Size: When selected, the alias shares the size and name of the
original. If unselected, it can be resized and given its own name.

Ornament objects in the Logic Pro Environment

Ornaments are simply solid backgrounds behind other Environment objects. An ornament
never covers other objects, so you can select multiple objects by dragging them without
selecting the ornament itself.

Create an ornament
•
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In the Logic Pro Environment window, choose New > Ornament.
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GM mixer objects
GM mixers in the Logic Pro Environment
The GM mixer is a collection of 16 fader modules, configured to emulate a virtual mixing
desk for 16 MIDI channels. Each module includes controls for volume, mute, preset, and
bank, and four assignable knobs (one of which is typically used for pan). There are optional
controls for standard XG and GS effects.

Create a new GM mixer
•

In the Logic Pro Environment window, choose New > GM Mixer.

The GM mixer is intended for controlling the 16 channels of a MIDI device which conforms
to the GM, XG, or GS standard. This includes the GM set of 128 program names (with
variation banks for XG or GS), MSB/LSB bank select messages, and standard controller
names (#1 for mod wheel, #2 for breath, #7 for volume, #10 for pan, #11 for expression,
and so on).

GM mixer parameters in the Logic Pro Environment
Most of the GM mixer’s setup is done in the Logic Pro Mixer, but there are also a few
parameters in the GM Mixer’s inspector:
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•

Port pop-up menu: Sets the GM mixer’s direct MIDI output connection.

•

Channel pop-up menu: Determines the channel number of the lowest GM mixer module.
You can use this (coupled with resizing the GM mixer) to create sub-mixers for any
continuous string of MIDI channels (1 to 4, for example).

•

Legend checkbox: Turns the display of the legend along the left edge of the GM mixer
off and on. The legend indicates what the rows of controls do, and is also used to set
the function of the top four rows of knobs. After the GM mixer is set up, you can hide
the legend to save space.
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•

Bank checkbox: Hides or shows the bank MSB/LSB display at the bottom of the
GM mixer. You can save space by hiding the bank display, unless you need to select
program banks numerically.

GM mixer channel strips in the Logic Pro Environment
The MIDI channel strips work as a remote control for the mixing parameters of the
controlled sound modules and synthesizers (volume and pan, for example).
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•

If your sound source understands bank select events, you can choose the bank number
with the Bank parameter field at the bottom of each channel strip (only visible if the
Bank parameter in the Object inspector is selected). Remember that not all synthesizers
support bank select events. You can use several different bank select formats (see
Mapped instrument objects overview).

•

The Program button allows you to select a sound by name. Click it to open a pop-up
menu that contains all GM sound names. Each channel has its own pop-up menu.

•

The Volume fader controls the output level of a MIDI channel. Adjusting it sends
controller 7 via your MIDI interface.

•

The Mute button switches the volume of the channel between zero and the current
Volume fader position. In practice, this means that if the button is selected, the channel
is muted. If you deselect the button, the current Volume fader position (and value) is
used.

•

You can assign any controller to each of the knobs.

•

In addition to the GM Standard, there are extended standards created by Roland (GS)
and Yamaha (XG). GS and XG mode allow you to select different effect programs, and to
control the level of the reverb and chorus effects.

•

The Reset button transmits a GS On or XG On command, and resets all controllers
to neutral positions. This allows you to reset all connected sound modules to their
standard settings, and begin a mix from scratch.
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Adjust the output level of a channel strip
•

In the Logic Pro GM Mixer window, drag the Volume fader up or down.

Mute or unmute a channel strip
•

In the Logic Pro GM Mixer window, click the Mute button.

Assign a controller to one of the knobs

1. In the Logic Pro GM Mixer window, click the label next to the knob.
2. Choose the controller you want from the pop-up menu that appears.

Display the GS or XG effects
•

Open the Logic Pro GM mixer, then choose GS/XG Effect Controls from the Mixer menu bar.
The GS/XG configuration control is displayed in the upper-right corner of the mixer,
allowing you to select different effect programs.

Configure GS or XG effects

1. In the Logic Pro GM mixer, choose the standard you want from the first pop-up menu in
the upper-right corner of the mixer.
Depending on your selection, the controllers for the extended effects appear.
2. Choose the reverb or chorus effect from the second pop-up menu.
3. Program the reverb or delay time by double-clicking the Time parameter, then entering
a value in the input field.

MMC record buttons in the Logic Pro Environment

The MMC record buttons object allows you to control the record-enable state of external
MMC-compatible recording devices. (See MIDI Machine Control.)

Create an MMC record buttons object
•

In the Logic Pro Environment window, choose New > MMC Record Buttons.

You can resize the object to determine the layout and number of track record buttons.
Select the Extra checkbox in the inspector to display the “V TC A1 A2” extra tracks:
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•

V for Video

•

TC for Timecode

•

A1 for Aux Track 1 (or A)

•

A2 for Aux Track 2 (or B)
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Keyboard objects in the Logic Pro Environment

You can use a keyboard object to create notes with the mouse. A keyboard object also
displays all notes passing through it. In this sense, you can think of it as a real-time, MIDI
note on monitor. Although you can record the output of the keyboard in Logic Pro, its main
purpose is for testing and monitoring in the Environment.

Keyboards have the following parameters:
•

Channel field: Sets the MIDI channel for the keyboard’s output.

•

Velocity field: Determines a fixed velocity value for all notes.

•

Lowest field: Defines the octave of the lowest note on the keyboard object. You can
resize the keyboard to control its range above the lowest note.

Create a keyboard object
•

In the Logic Pro Environment window, choose New > Keyboard.

Monitor objects in the Logic Pro Environment

A monitor object displays all events (MIDI and meta) passing through it. It remembers the
last 32 events, with the newest events shown at the bottom of the list. You can resize it to
show from 1 to 32 events. Clicking anywhere in the body of the monitor clears all events.

Monitors are useful as both testing and branching devices. When coupled with objects
that have functionally different outputs (channel splitters and mapped instruments,
for example), monitor objects can be used to attach more than one output cable to the
same function.

Create a monitor object
•
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In the Logic Pro Environment window, choose New > Monitor.
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Macro objects
Macro objects in the Logic Pro Environment

Macros are not actually Environment objects. Rather, they are collections of other
Environment objects and their cabling. Macros have a lot in common with standard
Environment objects; you can connect cables to and from them, they can be resized, they
have their own parameters and icons, they can be chosen as destinations in the track list,
and they can be copied or dragged between Environment layers and between projects.
Macros are limited in size. The limit depends on the memory usage of the individual objects
within the macro—typically between 100 and 200 objects.
You can nest macros, which means that a macro can contain other macros as objects.

Macros have the following parameters:
•

Auto Fader checkbox: If you select a group of faders and create a macro from them,
selecting this box makes them behave as if they were cabled serially.

•

Show All checkbox: Determines which objects remain visible when integrated into a
macro. When selected, all objects are visible (assuming the macro is not resized to hide
some of them). When unselected, only fader, monitors, ornament, and keyboard objects
are visible. You can select or unselect this checkbox at any time.

•

No Reset checkbox: When selected, the macro is prevented from responding to reset
messages (set in Logic Pro > Preferences > MIDI > Reset Messages).

•

Protected checkbox: Select to protect a macro. Protected macros cannot be unpacked,
so make sure you’ve made a copy of the objects and cabling before creating a protected
macro.

Create a new macro
•

In the Logic Pro Environment window, select all Environment objects that you want to
include, then choose New > Macro.
Logic Pro encloses all selected objects in a frame with a gray background.

If some of the objects selected when a macro is being created have cables leading to
unselected objects, these cables are deleted when the macro is created. A warning
notifies you of this behavior. In this situation, the macro is made from a copy of the original
selection of objects, and the original collection of objects remains unchanged.

Unpack a macro
•
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In the Logic Pro Environment window, double-click any empty (blank) section of the
macro object.
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The macro reverts back to its component objects and cables.

Macro input and output in the Logic Pro Environment
Because a macro is a collection of objects, individual objects need to be specified as the
macro’s input and output. This can be done in two ways: by name or by default.
•

If you name one object Macro-In and another Macro-Out, these automatically become
the macro’s input and output.

•

If there is no object named Macro-In, the upper-leftmost object becomes the macro’s
input.

•

If there is no object named Macro-Out, the lower-rightmost object becomes the macro’s
output.

Cables leading into the macro deliver events to the macro’s input object, and cables
leading from the macro carry events leaving the macro’s output object.

Arpeggiator objects
Arpeggiators in the Logic Pro Environment
An arpeggiator object turns chords into arpeggios. It plays the currently held notes—
individually—in a selectable pattern (up, down, random, and so on), and at a selectable
speed that ranges between whole notes and 768th notes.

An arpeggiator features parameters for direction, velocity, speed (Resolution), note length,
start quantize (Snap), repeats, octaves, and velocity offset (Crescendo). All parameters
can be MIDI controlled in real time, which adds immensely to its versatility.
To use an arpeggiator object, you must place it in the MIDI signal path, and Logic Pro must
be open. (For technical reasons, the arpeggiator resets on cycle jumps.)
Typically, you would assign an arpeggiator to a track, and cable its output to an instrument.
You can, of course, insert it where needed in the MIDI signal path.
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Once set up, you can use the arpeggiator with live MIDI input, or for MIDI region playback.
You can also record the output of the arpeggiator by cabling it into the Sequencer
Input object. If you do this, be sure you either record to a no output track, or break the
arpeggiator’s connection to a MIDI output.

Create a new arpeggiator
•

In the Logic Pro Environment window, choose New > Arpeggiator.

Arpeggiator parameters in the Logic Pro Environment
Arpeggiators have the following parameters:

•

•

•
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Direction pop-up menu: Determines the direction of the arpeggiated chord. You can
choose between the following settings:
•

Up: Lowest note to highest note

•

Down: Highest note to lowest note

•

Up/Down: Up and down; highest and lowest notes repeat.

•

Auto: Up or down, depending on whether the second chord note arrived before, or
after, the first chord note.

•

Up/Down2: Up and down; highest and lowest notes don’t repeat.

•

Random: Notes play in random order.

•

All: All notes play at once (useful when Repeat is on).

Velocity field: Determines the velocity values of the arpeggiated notes. You can choose
between the following settings:
•

1 to 127: Fixed velocities

•

Original: The velocities of the recorded notes are retained.

•

Random: Random velocities between 1 and the original value

Key Limit field: Defines the pitch range for the chord arpeggiation. Any chord notes
outside this range are passed directly to the output. This is useful when you want to
solo above, or play a bass line below an arpeggiated chord.
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•

Resolution pop-up menu: Sets the rhythmic note value (the speed in note divisions) of
the arpeggio. The None setting deactivates the arpeggiator.

•

Length pop-up menu: Defines the length of the arpeggiated notes. The Original setting
retains the length of incoming (or recorded) notes.

•

Snap to pop-up menu: Unless this value is set to None, the arpeggiator waits for
Logic Pro to reach the next indicated note division before starting the arpeggio. This is
useful for rhythmically synchronizing the arpeggio with other MIDI data.

•

Repeat checkbox: Selecting this option continues the arpeggio for as long as the chord
is held down. If the option is unselected, the arpeggio only plays through once.

•

Octaves field: The arpeggio can be repeated over 1 to 10 octaves.

•

Crescendo field: The velocity value set here is added every time the arpeggio is
repeated (if the Repeat parameter is on).

•

Controller Base field: All ten parameters of the arpeggiator object can be controlled
with MIDI continuous controller events. The Controller Base parameter determines
the controller number for the first parameter (Direction). The other parameters are
controlled by subsequent controller numbers.
When Controller Base is set to Off, MIDI control of the arpeggiator is disabled.

Transformer objects
Transformers in the Logic Pro Environment
You can use a transformer object to select, filter, and alter MIDI events in real time.
Transformers can also process meta events, as long as they aren’t the meta events that
affect transformers. These particular meta events change the transformer, rather than
being processed by it. For more information, see Use meta events to control condition and
operation values.

Create a new transformer object
•

In the Logic Pro Environment window, choose New > Transformer.

Transformer functions in the Logic Pro Environment
A transformer object checks whether or not an incoming event matches certain conditions.
If it does, then certain operations are carried out.
Events that do not meet the conditions may pass unchanged to the output, or may be
discarded.
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The transformer can also make copies of matching events before altering them, and can
split the selected (matching) events from the unselected ones, via its two top cables.
You must place the transformer in the MIDI signal path in order to use it.

Alter the output of an instrument

1. In the Logic Pro Environment window, cable the instrument output into the transformer.
See Cable Environment objects in Logic Pro.
This removes the instrument’s internal port assignment.
2. Choose New > Instrument to create a new instrument, and assign it to the appropriate
MIDI output port.
3. Cable the output of the transformer object into this newly created instrument (which, in
essence, is simply acting as a MIDI output port).

Transformer configuration in the Logic Pro Environment
Double-clicking a transformer icon opens the Transformer window, where you can set the
conditions and operations.

•
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Mode pop-up menu: Defines how a transformer handles MIDI events. You can choose
between the following operation modes:
•

Apply operation and let non-matching events pass thru: MIDI events that match the
condition are processed. MIDI events that don’t conform to the condition are passed
through.

•

Apply operation and filter non-matching events: MIDI events that conform to the
condition are processed. MIDI events that don’t conform to the condition are not
passed through.

•

Filter matching events: All MIDI events that match the condition are filtered out. MIDI
events that don’t conform to the condition are passed through.

•

Copy matching events and apply operation: All MIDI events that conform to the
condition are copied, and the copy is processed. The original and transformed copy
(plus any MIDI events that don’t conform to the condition) are passed through. The
unchanged original is parsed (processed) before the transformed copy.
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•

Copy matching events and apply operation (reverse order): This is the same as
above, except the original is parsed after the processed copy. You might want to use
this when converting note events to pan controllers, for example. This causes the
pan message to be sent before the note. (Many synths don’t alter the pan position of
notes that are currently playing.)

•

Condition splitter (true → top cable): Events that match the conditions are altered by
the operations, and sent to a transformer’s top output. Events that don’t match the
conditions are sent, unaltered, to a transformer’s second output. Don’t use the other
outputs as nothing ever appears there.

•

Alternating split: Events entering the transformer are alternated between the top two
outlets. No conditions or operations apply.

•

SysEx mapper (data byte 1 → position, data byte 2 → value): This transformer mode
is used to create and edit SysEx messages. The Transformer window operations are
replaced by value fields that allow you to enter the structure of the SysEX message
including its length, whether or not a checksum is required, and the values of bytes
you don’t want to change in real time.

In the Conditions area, you select the type of MIDI event that affects the data bytes
in the SysEx message. (Typically, you’ll use MIDI controller events.) Incoming MIDI
events then change the SysEx message data bytes, according to the following rules:
•

The data byte 1 value sets the position of the data byte.

•

The data byte 2 value sets the value of the data byte.

•

Channel 1: The changed SysEx message is sent.

•

Channel 2: The changed SysEx message is not sent.

•

Channel 3: The unchanged SysEx message is sent.

•

Channels 4 to 16: No meaning (reserved for future use).

The “Filter non-matching” checkbox prevents incoming MIDI events (that don’t
control the SysEx message) from being passed through. Typically, you’ll want this
feature turned on, to prevent interloping controller data from invading the SysEx data
stream.
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•

Track automation splitter (true → to cable): If the condition matches, incoming
events are sent to the track automation of the object connected to the top cable
of the transformer, after passing through the Operation field. With the appropriate
Operation field settings, incoming MIDI data is transformed into Fader event data,
allowing the automation of any possible parameter of the connected Mixer channel
strip. Exception: Channel volume and channel pan use Control events.

•

Define conditions and operations: The conditions and operations are the same as those
found in the Transform window. For more information, see MIDI Transform window
overview. The only differences arise from the fact that a transformer object works in real
time and therefore position and note length have no useful meaning.

•

Edit pitch bend events: A transformer object can process 14-bit pitch bend events,
which contain two discrete data bytes: if byte 1 is changed (by addition or scaling
with the -1- operation), the change also affects the second byte. Set the Data Byte 2
operation to Thru to ensure that 14-bit pitch bend data is processed properly.

Use Meta events in the Logic Pro Environment
You can control the values of any transformer conditions or operations by using meta
events. Meta events are internal Logic Pro messages—their form is similar to MIDI
controller events, but they have no MIDI meaning, they never leave Logic Pro, and they
control internal Logic Pro parameters.
Like MIDI controller events, meta events have two data values: the first one indicates the
type of meta event (49 to 127, but not all are used), and the second one is the event value
(0 to 127).
Meta events 122 to 127 affect transformer parameters.
•

Meta event #127 sets the first (top) operation value.

•

Meta event #126 sets the second (bottom) operation value (if available).

•

Meta event #125 sets the first (top) condition value.

•

Meta event #124 sets the second (bottom) condition value (if available).

Note: Transformers can also process meta events, as long as they are not the meta events
listed above.
Note that all numerical condition and operation parameters used (conditions not set to All
and operations not set to Thru) are affected by the same meta event. The status condition
and operation are not affected by meta events.
If you want to set numerical parameters individually, or leave some fixed, use separate
transformers in series.
•

Meta event #123 sets the transformer map position.

•

Meta event #122 sets the transformer map value for the current map position. (Use
meta event #123 to set the position first.)

Note: You can use a transformer’s Map Set operation to create these two meta events
simultaneously. When the operation status is set to Map Set, the Data Byte 1 parameter
specifies the map position, and the Data Byte 2 parameter specifies the map value at that
position. (A meta event #122 is sent with the Data Byte 1 value, followed by a meta event
#123 with the Data Byte 2 value.)
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You can create meta events with a fader object, you can transform MIDI events into meta
events with a transformer, and you can add meta events to a MIDI region from the Event
List. When you use a fader, set the Output definition to meta, then set the Data Byte 1 value
to the meta event number.
You can remotely control any fader by changing its Input definition, allowing you to use
faders (as well as other transformers) to convert MIDI events to meta events for the remote
control of transformers.

Delay line objects
Delay lines in the Logic Pro Environment
A delay line object repeats (echoes) MIDI events passing through it, at intervals ranging
from one tick to 256 whole notes.

Create a new delay line object
•

In the Logic Pro Environment window, choose New > Delay Line.

As with the arpeggiator, you need to place a delay line object in the MIDI signal path,
and Logic Pro must be in playback mode. The echoes of each incoming event are sent,
sequentially, to each cabled output of the delay line object: event 1 to cable 1, event 2 to
cable 2, and so on. Obviously, if only one cable is connected, then all events are sent to
that output.
The delay line can send up to 99 repeats, at intervals ranging from one tick to 256 whole
notes. You can also suppress the original note events.
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Delay line parameters in the Logic Pro Environment
Delay line objects have the following parameters:

•

Thru Original checkbox: If selected, the original events are passed thru. If unselected,
the original events are suppressed (which means that only the echoes are heard).

•

Repeats field: Defines the number of event repeats. The 0 setting turns the delay line
off.

•

Delay field: The delay time between the individual repeats. The left value is in divisions,
and the right value in ticks.

•

Transposition pop-up menu: Defines the transposition of note events per repeat.

•

Velocity field: Defines the change in the velocity values of note events per repeat.

Voice limiter objects
Voice limiters in the Logic Pro Environment
A voice limiter object restricts the number of MIDI notes (1 to 32) that can be held
simultaneously. It does this by note stealing—newly arriving notes cause (some of the)
currently held notes to be turned off, once the voice limit is reached.

Create a new voice limiter
•

In the Logic Pro Environment window, choose New > Voice Limiter.

Normally, you assign a voice limiter to a track, and cable its output to the instrument object
that you want to voice limit. Alternatively, you can cable it between the instrument object
that you want to voice limit and an instrument object used to represent a MIDI Out port.
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Voice limiter parameters in the Logic Pro Environment
Voice limiter objects have the following parameters:

•

Voices field: Determines the maximum number of voices that can be played
simultaneously.

•

Priority pop-up menu: Determines which notes are stolen (turned off) when the number
of held notes exceeds the limit (determined by the Voices parameter).

•

•

Last: The earliest notes (those played first) are turned off first.

•

Top: The lowest (pitched) notes are turned off first.

•

Bottom: The highest (pitched) notes are turned off first.

VelOn-Min field: Determines the velocity value of the MIDI notes. You can define a fixed
velocity from 1 to 127.

Channel splitters in the Logic Pro Environment

A channel splitter routes MIDI events by channel. Every MIDI event received at the channel
splitter input is automatically routed to the output that corresponds to its MIDI channel. If
no cable is connected to the corresponding output channel strip, the event is rerouted to
the SUM output (at the top).

Create a new channel splitter object
•
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Chord memorizer objects
Chord memorizers in the Logic Pro Environment
A chord memorizer maps individual notes to chords. You can assign one chord to each
pitch class (to C, C#, D, and so on).
The octave of the incoming note determines the octave of the resulting chord. A chord can
have 0–12 notes in it. (Zero and one-note chords can be useful for creating scale-filters
and scale-correctors).
The easiest way to use a chord memorizer is to connect its output to the instrument that
you want to play the chords through, and assign it to a track. You can, of course, place it
anywhere else in the MIDI signal path.

Create a new chord memorizer
•

In the Logic Pro Environment window, choose New > Chord Memorizer.

Chord memorizer parameters in the Logic Pro Environment
Chord memorizer objects have the following parameters:
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•

Channel field: All chord notes are sent to the defined channel.

•

Key Limit field: Notes within this range are mapped to chords. Notes outside the range
are passed through unaltered.
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•

Transposition pop-up menu: The output chords are transposed by the amount set here.
For example, if you map C to a chord consisting of CEG, and set Transposition to 1, then
C is mapped to C#FG#.

•

Key field: The entire chord map is transposed by the amount set here. For example, if
you map C to CEG, and set Key to 1, then C# is mapped to C#FG#.

•

Cable Split checkbox: Select to send all notes triggered by a chord assignment to
different chord memorizer object outputs (different cables).

Chord Memorizer window in the Logic Pro Environment
Double-clicking a chord memorizer opens the Chord Memorizer window, where you can set
up chord definitions.

The top keyboard is used to input and display the incoming note, and the lower keyboard is
used to input and display the assigned chords. Notes can be entered with the mouse, or a
MIDI keyboard.
Remember to use only notes that fall within the key limit range on the top keyboard. Also
remember that you can define only one chord for each of the 12 pitch classes (C, C#, D,
and so on). If necessary, you can use more than one chord memorizer object to define
more chord types for each pitch class.

Enter chords using the mouse

1. In the Logic Pro Chord Memorizer window, click the input note on the top keyboard.
All notes in the associated chord are inverted on the bottom keyboard.
2. Click notes on the bottom keyboard until the inverted notes of the desired chord are
shown.
You don’t need to stay within the same octave as the input note.
When you’ve entered the notes for your chord, select another input note (on the top
keyboard), or close the Chord Memorizer window.
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Enter chords using your MIDI keyboard
1. In Logic Pro, play the input note.

2. Select the Listen checkbox in the Chord Memorizer window.

The lower keyboard is inverted, indicating its readiness to record.
3. Play the notes of the desired chord.
You can play them one at a time, or as a chord. If you make a mistake, deselect the
Listen checkbox, then select it again to start over.
When you’ve entered the notes for your chord, deselect the Listen checkbox and play a
new input note, or close the Chord Memorizer window.

Physical inputs in the Logic Pro Environment

The physical input object represents the physical inputs of your MIDI interface. You can
only have one of these objects in the Environment.
The physical input object receives MIDI signals from the inputs of the MIDI interface or
interfaces connected to your computer. This object has a total of 65 outputs.
The outputs follow the input assignment of all connected MIDI interfaces. The top output
(SUM) carries the MIDI events for all individual outputs that are not cabled separately.
Remote control events are intercepted at the physical input object, and are not passed
through to its outputs. Because of this interception, remote control events do not reach the
Environment, or be recorded on main window tracks.

Create a physical input object
•

In the Logic Pro Environment window, choose New > Physical Input.

To make use of an existing object, drag it into the relevant layer. This does not affect
its cabling.

Logic Pro User Guide

1207

Sequencer inputs in the Logic Pro Environment

The sequencer input object represents the MIDI input of Logic Pro. You can only have one
of these objects in the Environment.
MIDI events arrive at main window tracks through the sequencer input object. If nothing is
cabled into the sequencer input object, nothing can be recorded in Logic Pro.
Typically, the physical input object is cabled directly to the sequencer input object but
other objects can be inserted between them. Candidates include a monitor, keyboard, or
cable switcher object (feeding various processors such as an arpeggiator, a delay line,
and so on).
You can also cable the output of simple or complex Environment processes into the
sequencer input object, in order to record the processed signal.
By default, the sequencer input object records on the MIDI channel (or channels) that the
keyboard or MIDI controller (which is sending the MIDI events) is set to.
If you turn on the sequencer input object’s Channelize parameter, the MIDI channel
assigned to the MIDI object (of the selected track) is used, and recorded. This effectively
means that if your keyboard is set to MIDI channel 7, and the track object is set to MIDI
channel 3, all incoming data is channelized to (and recorded on) MIDI channel 3.

Create a sequencer input object
•

In the Logic Pro Environment window, choose New > Sequencer Input.

To make use of an existing object, drag it to the relevant layer. This does not affect
its cabling.
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MIDI click objects in the Logic Pro Environment

The MIDI click object is used to create note events at bar, beat, and division intervals.
These can be sent to either a MIDI port or the internal speaker.

Each project can have only one MIDI click object. You only need to create a MIDI click
object if the one that existed when the project was created has been deleted.

Create a MIDI click object
•

In the Logic Pro Environment window, choose New > MIDI Metronome Click.

Turn the MIDI click on or off
•

In Logic Pro, click the Metronome button in the control bar.

You can access Metronome project settings by Control-clicking the Metronome button and
choosing Metronome Settings from the shortcut menu. In this pane, you can set the MIDI
click to play during playback or recording. The pane mirrors the settings of the MIDI click
Object inspector: checkboxes for Bar, Beat, and Division allow you to generate note events
separately for bars, beats, and divisions; the Channel, Note, and Velocity parameters
define the MIDI channel, note number, and velocity of generated notes; the MIDI Port
parameter allows you to set a direct output port for the metronome. See Metronome
settings for details.
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Channel strip objects
Channel strips in the Logic Pro Environment.
The Environment’s channel strip object is the building block of the Environment’s Mixer
layer, the Logic Pro Mixer, and the inspector’s channel strips. For details about channel
strip types, see Channel strip types in Logic Pro.

The audio and software instrument tracks you see in the main window are actually routed
to channel strip objects on the Environment Mixer layer.
The Mixer channel strips and inspector channel strips are simply remote controls for the
underlying channel strip objects in the Environment Mixer layer. Their inclusion in these
other windows makes your workflow faster and easier.
The inspector channel strips contain a reduced parameter set of the corresponding
channel strip objects in the Environment. The channel strips shown in the Mixer window
are more configurable, but the only place you can access all channel strip options is the
Environment Mixer layer.
Important: If File > Project Settings > Audio > Automatic Management of Channel Strip
objects is active (it’s on by default), you cannot create channel strips in the Environment.
This setting, when active, means that use of the track and channel strip creation options
in the main window automatically create a corresponding channel strip object in the
Environment (and therefore, remote control channel strips in the Mixer and inspector).
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In a general music-making sense, you don’t need to access the underlying channel strips
shown in the Environment. In fact, the only time you might open the Environment Mixer
layer is when you need to reconfigure channel strips at a system level, rerouting them to
different audio hardware, or perhaps to other applications.
Although channel strip objects aren’t part of the MIDI signal flow, they still allow MIDI
messages to control aspects of audio and software instrument playback in Logic Pro. Any
MIDI object can be cabled into a channel strip object, thereby feeding control data into it.

Channel strip parameters in the Logic Pro Environment
When you click a channel strip of any type (audio, software instrument, aux, output,
master, input, or bus), the following common parameters are accessible:
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•

Assignable checkbox: Makes the channel strip assignable from the Reassign Track
shortcut menu in the Tracks area; Control-click the track header.

•

Device pop-up menu: Click the visible device name (Core Audio, for example) to
reassign the selected channel strips to a different hardware device.

•

Channel pop-up menu: Click the visible channel name (Audio 1, for example), and
choose the channel strip type from the submenus. This is how you can reassign a
(newly created or existing) channel strip object (an audio channel strip is the default for
new objects) to other channel strip types. You can choose from:
•

Audio: The default channel strip type, used as the destination for audio tracks.

•

Input: Primarily retained for compatibility with projects created in earlier versions of
Logic Pro.

•

Aux: Auxiliary channel strip, used as send returns for all channel strips (via Sends),
as subgroup channels, and as individual output destinations for multichannel
software instruments (Sampler, for example).

•

Instrument: Used as the destination for (software) instrument tracks.

•

Output: Represents the physical outputs of your audio interface. You can choose
either mono or stereo (paired) outputs.

•

Bus: Primarily retained for compatibility with projects created in earlier versions of
Logic Pro. The functions of bus objects are now performed with (the more flexible)
aux channel strips in Logic Pro.

•

Master: Only one master channel strip can exist in a project. This is the master
volume control for all channel strip types (except external MIDI channel strips).

•

MIDI Channel pop-up menu: Choose a MIDI channel that can be used to control the
channel strip.

•

Q-Reference checkbox: Allows you to use the transients of regions on tracks that
reference the channel strip for audio quantization, if part of an Edit Group.

•

Flex Mode pop-up menu: Choose a flex algorithm that can be used to process the audio
material on the selected channel strip.

•

Show checkboxes: Select the corresponding checkbox to show EQs, Inserts, Sends, and
I/Os on the selected channel strip or strips.
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Input channel strip in the Logic Pro Environment
You can only create input channel strip objects in the Environment. In general, you do not
need to do so, as all audio hardware inputs are automatically seen by audio channel strips,
and can be monitored and recorded.
Input channel strips are primarily included for compatibility with earlier versions of
Logic Pro, and for use with certain audio hardware devices. The input channel strip allows
you to directly route and control signals from your audio hardware’s inputs. Once an input
channel strip is assigned to an audio channel strip, it can be monitored and recorded
directly into Logic Pro, along with its effects plug-ins.
The signal is processed, inclusive of plug-ins, even while Logic Pro is not in playback
mode. In other words, input channel strips can behave just like external hardware
processors. Aux sends can be used pre or post fader.
Input channel strips can be used as live inputs that can stream audio signals from external
sources (such as MIDI synthesizers and sound modules) into a stereo mix (by bouncing an
output channel strip).
Note: An alternative to using input channel strips in this way is the use of the I/O plug-in;
you can also click the Input Monitoring button on an audio channel strip and choose the
input or inputs you want to monitor or record via the Input slot.

Bus channel strip in the Logic Pro Environment
You can only create bus channel strip objects in the Environment. In general, you do not
need to do so, as all audio bussing (send/return routing via the Send slots of channel
strips) is handled by aux channel strips.
Bus channel strips are primarily included for compatibility with earlier versions of Logic Pro,
and for use with certain audio hardware devices.
Note: File > Project Settings > Audio > Automatic Management of Channel Strip Objects
must be unselected if you want to create input channel strips. (It’s on by default.)

Preview channel strip in the Logic Pro Environment
When you audition audio in the Project Audio Browser and in the Audio File Editor, the
source audio that you hear plays through the preview channel strip. Logic Pro creates
the preview channel strip automatically in each project—you can find it to the right of the
highest-numbered audio channel strip in the Environment. You can use the preview channel
strip in a variety of ways to set the volume of the audio you are previewing, add audio
effects just to the audio you are previewing, select outputs for previewing audio that are
separate from your main outputs, and so on.
No other channel strip can play audio from the Project Audio Browser or Audio File Editor.
Also, you cannot create another preview channel strip if you delete it.
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If you delete the preview channel strip, the highest-numbered audio channel strip in the
Environment is automatically used to play audio from the Project Audio Browser and Audio
File Editor as well as the audio track assigned to play back through that channel strip.
Depending on how you have adjusted that channel strip, this may result in the audio you
play back from the Project Audio Browser and Audio File Editor sounding significantly
different than they would unprocessed. Therefore, you should avoid deleting the Preview
channel strip, and access it only to adjust its controls or add effects.
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Glossary

AAC Abbreviation for Advanced Audio Codec. A compression and decompression
algorithm and file format for audio data.
AAF Abbreviation for Advanced Authoring Format. A cross-platform, project exchange file
format you can use to import multiple audio tracks, inclusive of references to tracks, time
positions, and volume automation.
accelerando A gradual increase in tempo. See also tempo.
ADAT Acronym for Alesis Digital Audio Tape. The ADAT is an eight-track digital multitrack
cassette recorder that uses an S-VHS video tape to record audio at 16- or 20-bit depth.
ADAT optical An optical interface for parallel transmission of eight audio channels via fiber
optic cable. ADAT optical is a well-established standard for digital multichannel interfaces.
AD converter (ADC) Abbreviation for analog-to-digital converter. A device that changes
an analog signal into a digital signal.
AES/EBU Abbreviation for Audio Engineering Society/European Broadcasting Union. This
association has a standard transmission format for professional stereo digital audio signals
also called AES/EBU. The format is similar to S/P-DIF, but uses balanced line drivers at a
higher voltage. Depending on the type of devices involved, AES/EBU and S/P-DIF coaxial
interfaces can communicate directly. See also S/P-DIF.
aftertouch A MIDI data type generated by pressure on keys after they have been struck.
There are two types—channel aftertouch, whose value is measured by a full-length
keyboard sensor and that affects all played notes, and polyphonic aftertouch, which
is individually measured and transmitted for each key. Aftertouch is also known as key
pressure or pressure sensitivity.
AIFF Abbreviation for Audio Interchange File Format. A cross-platform file format
supported by a large number of digital audio and video editing apps. AIFF audio can use a
variety of bit depths, most commonly 16- and 24-bit.
ALAC Acronym for Apple Lossless Audio Codec. An encoding/decoding algorithm that
delivers lossless audio compression.
alias A pointer to a MIDI region in the Tracks area. An alias doesn’t contain any MIDI data,
but points to the data of the original MIDI region. You can create an alias by Option-Shiftdragging a MIDI region to a new location. An alias can’t be edited directly; however, any
change to the original region also affects the alias.
All Files Browser One of the browsers in the Browsers area used for file management and
data import tasks. See also Browsers.
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allpass filter A filter that allows all frequencies to pass, providing only phase shift or
phase delay without appreciably changing the amplitude characteristic.
amplifier A device that increases the level of a signal. Sometimes called amp for short.
alternative A different version of a project, with a unique name and different settings.
Alternatives are saved as part of the project, and share the same assets. Alternatives for
the current project appear in the File > Project Alternatives submenu.
amplitude A term used to describe the amount of a signal. If you have an audio signal,
amplitude refers to the volume of the sound, measured in decibels (dB).
amplitude peak The loudest point of an audio signal.
analog signal Refers to audio data that consists of an endlessly varying voltage level.
Analog signals must be digitized, or captured, for use in Logic Pro. Compare digital.
anchor point The start point of the audio file that an audio region is based on. See also
Audio File Editor.
Apple Loops Prerecorded audio or MIDI regions commonly used for recurring rhythmic
musical elements or elements suitable for repetition. Apple Loops contain tags so you can
quickly locate files by instrument, genre, or descriptors in the Loop Browser. Audio Apple
Loops also contain transients that are used by Logic Pro for time-stretching and pitchshifting tasks.
articulation When playing sampled instruments that emulate real instruments, you can
switch between the unique playing techniques called articulations. Each articulation is
identified with a unique Articulation ID. Information regarding available articulations is
stored in Articulation Sets, which are saved both as part of a patch and with a project.
Articulation Set Editor The Articulation Set Editor can be used to create sophisticated
key switch and controller switch definitions, and define output transformations, enabling
compatibility with sample libraries from manufacturers other than Apple. You can also
create Articulation Sets for instruments that have assigned Articulation IDs, but do not
have pre-configured articulations, using the Articulation Set Editor.
ASCII Acronym for American Standard Code for Information Interchange. A standard
computer character set, allowing computers to deal with text characters. When you type
ASCII characters on the keyboard, the computer interprets them as binary so they can be
read, manipulated, stored, and retrieved. See also scan code.
attack An envelope parameter that determines the time it takes for a signal to rise from an
amplitude of 0 to 100 percent when a key is initially pressed. See also envelope.
attenuate The act of lowering the level of an audio signal. See also boosting and cutting.
audio channel strip A channel strip in the Mixer, used as a target for audio tracks in the
Tracks area. All data on the audio track is automatically routed to the audio channel strip
that was assigned in the Tracks area.
audio file Any digital recording of sound, stored on your hard disk. You can store audio
files in the AIFF, WAV, Sound Designer II (SDII), and CAF formats in Logic Pro. All recorded
and bounced WAV files are in Broadcast Wave format.
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Audio File Editor The area in Logic Pro that allows audio files to be destructively edited
and processed in a number of ways. The Audio File Editor allows editing of individual
samples within an audio file, and also provides access to a number of special sample
processing tools. In earlier versions of Logic Pro, the Audio File Editor was called the
Sample Editor. See also destructive.
audio interface The device used to get sound into and out of your computer. An audio
interface converts analog signals (from microphones or musical instruments, for example)
into digital audio data that can be processed by your computer, and, in the other direction,
converts digital audio data from your computer into analog signals that speakers can
broadcast.
Audio MIDI Setup (AMS) A utility used to configure the audio and MIDI input and output
devices connected to your computer. Logic Pro uses the settings defined in the AMS utility,
which can be found in the Applications/Utilities folder.
audio region A segment of an audio file that can be placed on audio tracks in the Tracks
area. Audio regions appear as colored rectangles in the Tracks area, and are aliases (or
pointers) to portions of audio files. They can be as short as a single sample, or as long as
the underlying audio file. Logic Pro allows you to edit audio regions without altering the
original audio file. See also region and MIDI region.
audio track A track in the Tracks area that is used for playback, recording, and editing of
audio regions. It is routed to an audio channel strip in the Mixer.
Audio Track Editor An editor in Logic Pro that shows a close-up view of part of an audio
track, displaying the audio waveform of the regions on the track. You can move and trim
audio regions, split and join them, and edit them in other ways. You can also quantize
and edit the pitch of audio material in the Audio Track Editor using Flex Pitch. See also
Flex editing.
Audio Units (AU) The standard macOS format for real-time plug-ins. Audio Units plugins can be used for audio effects, software instruments, and generators. The AU format is
incorporated into the operating system, and installed AU plug-ins can be accessed by all
applicable programs. Logic Pro supports all AU format plug-ins.
Auto Track Zoom A function in the Tracks area View menu that automatically enlarges the
currently selected track.
automation Refers to the ability to record, edit, and play back the movements of all knobs,
controls, and buttons, including volume faders, pan, EQ, and aux send controls, plus most
effect and instrument plug-in parameters.
automation point The circular indicator on an automation curve that shows the value of
the automation parameter at a particular point in time. You add and edit automation points
to control automation for the parameter.
Automation Curve tool A tool used to bend the line between two automation points,
creating a nonlinear transition between the points.
Automation Select tool A tool used to select automation data and create automation
points at region borders.
Autopunch button A button (with up and down arrows) in the control bar, used to activate
the Autopunch function. See also Autopunch function.
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Autopunch function A function that allows you to start and stop recording at predefined
positions. Autopunch mode is most commonly used to re-record a section of an otherwise
successful recording. The advantage is that you can concentrate on playing, rather than
the mechanics of starting and stopping recording. See also Autopunch button.
aux channel strip A channel strip found in the Mixer that can be used as a send/return
(bus) and subgroup control.
backup A saved version of the current project. Backups for the current alternative are
listed in reverse chronological order from newest to oldest in the File > Revert to submenu,
Balance control A rotary knob above the Volume fader of stereo channel strips. It controls
the relative level of the left and right signals at their outputs.
band rejection filter A filter that cuts the frequency band centered around the cutoff
frequency, while allowing the frequencies that lie further away on either side to pass.
Frequencies close to the cutoff frequency are attenuated, while the lows and highs remain
unchanged. See also filter.
bandpass filter A filter that allows only the frequency band centered around the cutoff
frequency to pass, while frequencies that lie further away are cut. Frequencies close to the
cutoff frequency are emphasized, while the lows and highs are attenuated, resulting in a
sound containing mostly mid-range frequencies. See also filter.
bar In musical notation, a measure that contains a specified number of beats, defined by
the project time signature. See also time signature.
bass Low-frequency sounds or components within a sound. See also frequency.
beat A musical time interval, commonly a quarter note, that marks the basic pulse of a
piece of music.
Beat Mapping track A Global track used to analyze audio or MIDI regions, and create
tempo events based on note or transient events in these regions, allowing you to more
easily synchronize recordings made without a metronome click with other material in
a project.
binaural hearing Refers to the way human beings process audio positioning information,
allowing the direction of a signal source to be recognized (in front, behind, above, below,
and to the left or right of the listening position).
binaural panning A process that emulates binaural hearing. See also pan.
bit depth The number of bits used by a digital recording or digital device. The number
of bits in each sample determines the (theoretical) maximum dynamic range of the audio
data, regardless of sample rate.
bit rate When talking about MP3 files, refers to the transfer bit rate at which the files are
encoded. Conversationally, the term is more often used to describe the relative quality of
the file, with lower bit rates resulting in less defined audio.
bit resolution An alternative term for bit depth. See bit depth and sample rate.
blue noise Refers to highpass-filtered white noise, which sounds like tape hiss.
boosting The act of raising an audio level. See also cutting.
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bounce To process MIDI or audio regions with any applied effects, such as delay or
compression, combining (rendering) them into an audio file. In Logic Pro, you can choose
between real-time and offline bouncing. Offline bouncing is faster, but doesn’t allow you to
apply live automation or record real-time audio input. You can also bounce to several files
when performing a Surround bounce. See also surround.
Bounce button The button you click to bounce the output of any output channel to an
audio file. See also bounce.
bpm Abbreviation for beats per minute. A measure of the speed or tempo of a musical
piece. For example, 120 bpm means that in one minute, there will be 120 musical beats.
See also tempo.
Broadcast Wave See Wav and Wave.
Browsers An area that appears to the right of the Tracks area when you click the Browsers
button in the control bar. The Browsers area contains the Project Audio Browser and
All Files Browser, providing access to all media types supported by Logic Pro. In earlier
versions of Logic Pro, the Browsers area was called the Media area.
bus A type of signal routing that sends audio to aux channel strips for processing or
submixing tasks.
bus channel strip A type of channel strip in the Environment Mixer layer included for
backward compatibility with projects created in older versions of Logic. Aux channel strips
perform the functions that the bus channel strips performed in earlier versions of the app.
bypass To deactivate a plug-in. Bypassed plug-ins do not drain system resources. In
Logic Pro, you can bypass a plug-in by either clicking a plug-in’s Bypass button in the
channel strip or the Bypass button in the plug-in window.
CAF Abbreviation for Core Audio Format. This file format can be used as a container for
compressed or uncompressed audio files of (almost) any size, sample rate, or bit depth.
The CAF file format can handle audio recordings of around three hours in length (at a
44.1 kHz sample rate—shorter at higher sample rates).
Camera tool A tool in the Score Editor used to select and export sections of the score as
an image or PDF file.
carrier In FM synthesis, the carrier is the equivalent of an analog synthesizer oscillator
that is producing a sine wave. The carrier frequency is modulated by the modulator.
Catch button The button that enables horizontal scrolling during playback, ensuring that
the area of the project near the current playhead position is always visible. The Catch
button is located in the Tracks area and some editors.
CD Audio A standard for stereo music CDs: 44.1 kHz sampling rate and 16-bit depth.
cell The rectangle at the intersection of a track and scene in the Live Loops grid. Each cell
contains a musical phrase or loop. You can start and stop cells individually or together in a
scene while keeping everything in sync with the beat and the project tempo. There are four
types of cells—audio cells, MIDI cells, Drummer cells, and pattern cells—each represented
by a different color.
cent A tuning division of a semitone. There are 100 cents in a semitone. Many Logic Pro
software instruments contain a Fine parameter that allows sounds to be tuned in
cent steps.
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channel strip A virtual representation of a channel strip on a mixing console. Each channel
strip contains a number of similar controls, including a Mute button, Solo button, Volume
fader, Pan/Balance knob, Input slot, Output slot, Send slots, Effect slots, and Format
button. The channel strips shown in the inspector and in the Mixer are used to process
audio or MIDI information that is routed from tracks.
channel strip setting Refers to the routing of a channel strip, including all inserted
effects or instruments (plus their presets). Logic Pro allows these settings to be saved
and recalled, simplifying the task of re-creating complex serial effect routings between
channels or projects.
chorus effect An effect achieved by layering two identical sounds with a delay, and
slightly modulating the delay time of one, or both, of the sounds. This makes the
audio signal routed through the effect sound thicker and richer, giving the illusion of
multiple voices.
clipping In digital recordings, the result of feeding too much signal through a channel
strip, thereby exceeding the limit of what can be accurately reproduced and producing a
distorted sound. Logic Pro audio channel strips feature a clip indicator, which indicates
signal level peaks above 0 dB.
clock An electrical synchronization impulse, transmitted every 1/96 note. A clock was used
in older drum machines before the advent of MIDI. MIDI Clock is a modern implementation
of simple clock signals. It runs at 24 pulses per quarter note (ppqn), or 96 pulses per note.
cloned audio region A pointer to the original audio region. When you adjust the start or
end point of a cloned region, all other regions cloned from the same original region are
adjusted in the same way.
comb filter effect The general term for a short delay of feedback that emphasizes specific
harmonics in a signal. The name is derived from the appearance of the frequency spectrum
graphic, which resembles the teeth of a comb.
comping A process where multiple recording takes are combined into a single composite
take. See also take and Quick Swipe Comping mode.
compressor An effect that restricts the dynamic range of an audio signal.
Compare expander.
Content Link mode A mode useful for situations where multiple MIDI regions are
horizontally aligned along a single track, and you’re viewing the MIDI region contents in
the Piano Roll Editor, for example. In this scenario, the Piano Roll Editor will only show the
contents of the selected MIDI region. If you want to view the contents of each MIDI region
(selected or not) in the Piano Roll Editor as the project plays, you need to activate Content
Catch mode. See also Link button.
control bar A collection of buttons located at the top of the main window, giving you
easy access to some of the most frequently used inspectors, editors, and other areas
of Logic Pro. You can customize the control bar to meet your individual needs. In earlier
versions of Logic Pro, the control bar was called the Transport bar.
controller A MIDI data type that controls a particular parameter, such as volume or pan, or
sustain. The type of command is encoded in the first data byte, while the value being sent
or received is encoded in the second data byte.

Logic Pro User Guide

1219

control surface A hardware device that communicates with Logic Pro via MIDI (or other
communication protocol). It can be used to write automation data and control parameters,
such as mixing levels and panning, and effects and instruments, as well as transport and
navigation functions, among others.
Controls view A nongraphical alternative to the Editor view of plug-in parameters.
All Logic Pro plug-ins (and Audio Units) offer a Controls view, which you can open by
choosing Controls in the View pop-up menu at the top of the plug-in window. Controls view
allows access to additional parameters and often requires less screen space. Compare
Editor view.
Core Audio A standardized audio driver system for Mac computers and iOS devices.
Core Audio is an integral part of macOS and iOS, allowing access to all audio interfaces
that are Core Audio compatible. Logic Pro is compatible with any audio hardware that is
Core Audio compliant.
Core MIDI A standardized MIDI driver system for Mac computers and iOS devices. Core
MIDI is an integral part of macOS and iOS, allowing the connection of all MIDI devices that
are Core MIDI compatible. Logic Pro is compatible with any MIDI hardware that is Core MIDI
compliant.
count-in Several metronome beats sounded prior to the start of a recording (or playback),
typically for one bar. The control bar features a Count-in button to control the count-in.
cutoff frequency The frequency at which the audio signal passing through a low or
highpass filter is attenuated (typically by 3 dB).
cutting The process of reducing a level or frequency when using EQ or other filters. The
term is also used to describe dividing and removing sections of files, regions, and other
items. See also boosting and attenuate.
cycle area In Logic Pro, an area used to repeatedly play a particular part of a project for
composing, practicing, recording multiple takes, and other purposes. When Cycle mode
is on, the cycle area is displayed as a yellow strip in the upper part of the ruler (or in the
center, when the secondary ruler is visible).
DA converter (DAC) Abbreviation for digital-to-analog converter. A device that changes a
digital signal into an audio signal.
data bytes Elements that define the content of a MIDI message. The first data byte
represents the note, or controller number, and the second represents the velocity, or
controller value.
DAW Acronym for digital audio workstation. A computer system used for recording,
arranging, mixing, and producing audio files.
dB Abbreviation for decibel. A unit of measurement that describes the relationships
between voltage levels, intensity, or power, particularly in audio systems.
DC offset An error that can result in direct current (DC) being layered over the audio
signal, producing a vertical shift in the waveform position shown in the Audio File Editor.
decay An envelope parameter that determines the time it takes for a signal to fall from the
maximum attack level to the sustain level. See also envelope.
deesser A signal processor that removes hissing or sibilance in audio signals.
default The preset value of a parameter.
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delay (1) In the main window, a region parameter that lets you move a selected region
ahead or behind the beat by a given number of milliseconds. (2) An effect that delays the
incoming audio signal, typically resulting in a sense of audio space in which the signal is
taking place. (3) In the Environment, an object that can create a series of repeats.
destructive A type of audio processing in which the actual data of an audio file is
changed, as opposed to just editing peripheral or playback parameters. Edits in the Audio
File Editor are destructive, while those in the Audio Track Editor are non-destructive. See
also Audio File Editor.
DFS Abbreviation for Digital Full Scale. Sometimes expressed as 0 dB DFS. This value—0
dB, as shown on the Logic Pro channel strip level meters—is the maximum theoretical
level that a digital signal can reach before clipping and other types of distortion may be
introduced.
digital A description of data that is stored or transmitted as a sequence of ones and
zeros. Most commonly, digital data refers to binary data represented by electronic or
electromagnetic signals. All files used in Logic Pro are digital. Compare analog.
Display Level button A button (located in the upper-left corner of many windows) that
takes you to the next higher display level. For example, if you’re viewing events of a MIDI
region inside a folder and you click the Display Level button, you’ll move to the MIDI region
in the parent folder. A second click switches the display to the folder itself.
distortion The effect that occurs when the limit of what can be accurately reproduced in a
digital signal is surpassed, resulting in a sharp, crackling or gritty sound.
division value An adjustable value (shown in notes) for the grid used in displays and
operations. The division (marked div) is the third number displayed in the control bar’s
Position display.
Drag pop-up menu A pop-up menu found in the menu bars of linear editing windows. It
determines the behavior of regions or events when dragged to an overlapping position.
driver A software program that enables various pieces of hardware and software to
be recognized by computer apps. If the proper driver is not correctly installed for your
audio hardware, your computer may not recognize or work properly with it. See also
Devices pane.
Drummer A feature in Logic Pro that allows you to add a virtual drummer to your project
using a Drummer track. You can edit the drummer’s performance in the Drummer Editor.
Drummer Editor The editor you use to modify a virtual drummer’s playing style by
choosing presets and adjusting individual settings, including kit piece pattern variations
and fill settings.
Drummer region A rectangular segment in the Tracks area that represents a realistic drum
performance, which you can edit using various settings in the Drummer Editor.
Drummer track A track in the Tracks area that is used for the playback and editing of
Drummer regions. You can only have one Drummer track per project.
DSP (digital signal processing) In Logic Pro, the mathematical processing of digital
information to modify a signal. For example, the Effect slot on channel strips assigns
DSP effects—such as dynamic compression and delay—to a channel signal. Even simple
operations such as changing volume and pan are DSP calculations.
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dynamic range The difference in level between the loudest and softest signals that an
audio system (or device) can reproduce. Technically, dynamic range is the difference
between the highest signal peak that can be reproduced and the amplitude of the highest
spectral component of the noise floor. It is measured in decibels. See also dB.
dynamics Refers to changes in volume, or other aspects of a piece of music, over time.
editor In Logic Pro, an area or window for editing MIDI or audio data. Logic Pro includes
the Piano Roll, Step, Event List, and Score Editors for MIDI event data, the Audio Track and
Audio File Editors for audio data, and the Drummer Editor for Drummer regions. The Event
List can also be used for region editing and positioning.
Editor view The default, graphical view of plug-in parameters. If Controls view is visible,
you can open Editor view from the View pop-up menu at the top of the plug-in window.
Compare Controls view.
effect A type of software algorithm that alters the sound of an audio signal in a specific
way. Logic Pro includes a complete set of EQ, dynamics, time-based, modulation, and
distortion effects in the Logic Pro native and Audio Units plug-in formats.
Effect slot A panel on Logic Pro channel strips where you can insert an audio or MIDI
effect plug-in. In earlier versions of Logic Pro, an Effect slot was called an Insert slot.
envelope An element that determines the variation in amplitude (or, sometimes, spectral
content) of a sound over time. An envelope, used as a controlling device, controls how a
sound starts, continues, and ends. Synthesizer envelopes usually consist of attack, decay,
sustain, and release phases (abbreviated as ADSR).
Environment A workspace in Logic Pro that graphically reflects the relationships between
hardware devices outside your computer and virtual devices within your computer. Beyond
basic input and output handling, the Environment can be used to process MIDI data in
real time, and can even be used to create processing machines, such as virtual rhythm
generators and step sequencers or complex synthesizer editors.
Environment layer A page in the Environment used to organize objects. Objects of the
same type (MIDI objects, for example) are generally placed on the same layer, making
usage easier.
Environment Mixer layer An Environment layer that shows all channel strips in a project
(except MIDI channel strips). For most purposes, you can use the Logic Pro Mixer to mix
your project.
EQ Abbreviation for equalizer. Equalizers are used to boost or cut frequencies in an audio
signal. Several EQ types are available in Logic Pro.
equalization The process of adjusting the relative volume (level) of different frequency
bands, using an equalizer.
Eraser tool A tool used for deleting items. You click a selected item or items with the
Eraser tool to delete them.
event An individual MIDI command, such as a note on command. Continuous controller
(CC) movements (such as those made with a modulation wheel) produce a quick
succession of individual events—each with an absolute value.
event definition Parameters used to define the event type displayed in the lanes of the
Step Editor. See also Lane Set.
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Event List A list that shows all events or regions in a project. The Event List allows you to
directly manipulate events and regions in a precise, numerical way. It also allows you to add
different types of events.
expander An effect that increases the dynamic range of an audio signal. Compare
compressor.
export To create a version of a file, such as a Logic Pro project, in a different format that
can be distributed and used by other apps.
Fade tool A tool used to create and edit fades, or to change the shape of fade curves.
filter Filters are effects used to increase (boost) or attenuate (cut) a specific frequency or
frequency range in an audio signal. For example, a lowpass filter allows frequencies below
the cutoff frequency to pass unaltered, while those above are attenuated. See also cutoff
frequency.
Filter button A button in the Event List and Mixer that you can use to hide or show specific
event types or channel strip types.
filter slope The steepness, or amount, of filter attenuation (level reduction), typically
measured per octave. For example, a filter slope of 12 dB per octave would sound much
more dramatic than a filter slope of 6 dB per octave.
Finger tool A tool in the Piano Roll Editor and Step Editor, used to edit the length
of events.
flanger effect An effect similar to the chorus effect, where a slightly delayed signal (which
is shorter than that of the chorus) is fed back into the delay line input. Flanging makes a
sound thicker, and slightly out of phase.
Flex & Follow pop-up menu A pop-up menu in the Region inspector used to choose
whether to enable Flex for a selected audio region, whether the region follows the project
tempo, and whether to use Smart Tempo beat markers.
Flex editing A process of editing the timing and pitch of notes, beats, and other events in
audio regions. See also Flex Time and Flex Pitch.
flex marker A marker that allows you to alter the timing of audio material.
flex mode A track-based setting that determines how the timing or pitch of your audio
is altered.
Flex Pitch A track-based setting that determines how the pitch of your audio material will
be altered.
Flex Time A setting that simplifies the process of editing the timing of notes, beats, and
other events in audio regions. Flex Time is similar to what is often referred to as elastic
audio in other apps. You can compress or expand the time between specified events in an
audio region without the need for trimming, moving, nudging, or crossfading.
Flex tool A tool that gives you quick access to the basic flex editing functionality, without
having to turn on Flex view in the Tracks area. See also Flex view.
Flex view A Tracks area view that allows you to edit the timing and pitch of audio material.
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folder In Logic Pro, a container for regions in the Tracks area. A folder can contain other
folders or regions, much like a folder in the Finder can contain other folders or files. You
can imagine a folder as a project within a project. The inside of a folder looks just like the
Tracks area.
folder stack A type of Track Stack that lets you combine multiple tracks and control
them as one unit, without changing the audio routing of the individual subtracks. When
you create a folder stack, the channel strip assigned to the main track is called the stack
master. Using the main track or the stack master channel strip, you can mute, solo, and
adjust the volume level for the folder stack. See also Track Stack.
frame A unit of time. A second in the SMPTE standard is divided into frames that
correspond to a single still image in a video file or on video tape.
Freeze function A process that performs individual offline bounces for each frozen track,
reducing the processing power needed to play tracks with software instruments and effect
plug-ins. All track plug-ins (including software instrument plug-ins, if applicable, along
with all related automation data) are rendered into a freeze file.
frequency A measure of the vibration of a sound signal over time, expressed in cycles per
second, or hertz (Hz). Frequency corresponds to what users hear as pitch (the highness or
lowness of a musical tone).
global tracks Tracks you can use to view, create, and edit markers, tempo events, and key
changes, as well as perform beat mapping and other operations. Global tracks are available
at the top of all time-based editors (including the Audio Track Editor, Piano Roll Editor, and
Step Editor).
Glue tool A tool used to merge regions or events by selecting and clicking them.
GM Abbreviation for General MIDI. A standard for MIDI sound modules specifying a
uniform set of instrument sounds, a standard key assignment for drum and percussion
sounds, 16-part multi-timbral performance and at least 24-voice polyphony. A musical
sequence generated by a GM instrument should play correctly on any other GM synthesizer
or sound module.
grid An element of the Tracks area and some editors represented by vertical lines that
indicate the positions of measures, beats, and sub-beats.
Groups inspector A Logic Pro inspector used to define which controls can be edited
for an entire channel strip group at the same time (Mixer group), including automation,
volume, pan, and sends. It appears in the Track inspector when one or more groups have
been created.
GS Abbreviation for General Standard, an extended General MIDI specification, developed
by Roland.
headroom A specified range (safety margin, measured in decibels) between the actual
audio level and the maximum permitted level (0 dBfs) that allows for unexpected signal
peaks. In the Score Editor, headroom is the margin of white space above the top staff.
Hermode Tuning A process that automatically controls the tuning of electronic keyboard
instruments, or the Logic Pro software instruments, during a musical performance.
Hermode Tuning retains the pitch relationship between keys and notes, while correcting
the individual notes of electronic instruments, ensuring a high degree of tonal purity.
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high cut filter A type of filter that is essentially a lowpass filter with no slope or resonance
controls. As the name suggests, it attenuates frequencies above the cutoff frequency. See
also lowpass filter.
highpass filter A filter that allows frequencies above the cutoff frequency to pass
unaltered, while frequencies below the cutoff are attenuated. A highpass filter with no
slope or resonance controls is known as a low cut filter.
import, importing The process of bringing files of various formats into a Logic Pro project.
Imported files can be created in another app, captured from another device, or taken from
another Logic Pro project.
input channel strip A type of channel strip in the Environment Mixer layer included for
backward compatibility with projects created in older versions of Logic. An input channel
strip represents the physical inputs of your audio interface and directs input from your
audio interface into Logic Pro. In general, you won’t need to access this channel strip type
in Logic Pro.
input monitoring A function that allows you to hear incoming audio when audio tracks are
playing, record-enabled, or recording. Click the Input Monitoring button on an audio track
to turn input monitoring on or off for the track.
inspector An area on the left side of the main window that contains the inspectors and
channel strips for the selected track. The inspector updates to reflect the parameters
relevant to the area with key focus (such as the selected track, regions, events, or objects).
instrument object An object in the Logic Pro Environment designed to communicate with
a single-channel MIDI device. An instrument object represents a physical or virtual device
that handles MIDI information. See also multi-instrument object.
interleaved audio file Logic Pro typically handles multichannel (stereo or surround) audio
files as interleaved. Edits to interleaved files affect both (for stereo, or all for surround)
channels equally. See also split channel audio files.
key The scale used in a piece of music, centered around a specific pitch. The specified
pitch is called the root of the key. A key can also refer to a black or white key on a music
(MIDI) keyboard.
key command A function that you can execute by pressing a specific key (or key
combination) on your computer keyboard or MIDI controller.
Key Commands window A window used for assigning key commands to computer keys or
to MIDI messages.
key focus In Logic Pro, the selected, active item—such as a window, area, track, or
scene—is said to have key focus. Only one item can have key focus at a given time. Many
key commands will function only when an item has key focus. The inspector also updates
to reflect the parameters of a window with key focus.
key signature Refers to musical notation that indicates the key (and scale) of the piece, or
the current section. The key signature of a project is shown in the LCD in the control bar.
See also key.
lane Each MIDI event type (a note or MIDI controller) is arranged from top to bottom in
horizontal lanes in the Step Editor similar to tracks in the Tracks area. You can configure
the type of event shown and controlled on each lane by setting parameters in the Lane
inspector.
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Lane inspector A Logic Pro inspector in the Step Editor window that is used to alter the
settings of the selected lane.
Lane Set A term for all simultaneously displayed event definitions in the Step Editor. See
also event definition.
latency A short delay between playing a note on your keyboard and hearing the sound. A
variety of factors contribute to latency, including the audio interface in use and audio and
MIDI drivers. You can control the amount of latency—to an extent—using the I/O buffer size,
which is set in the Devices preferences.
Layout tool A tool in the Score Editor used to graphically move events or global
text objects.
legato Method of musical performance that smoothly connects one note to the next.
level meter An indicator that displays audio input or output levels to or from your
computer. Every Inspector channel strip and each channel strip in the Mixer (except the
master channel strip) includes a level meter. You use the level meters when recording,
arranging, and editing audio files, and when creating a mix.
LFO Abbreviation for Low Frequency Oscillator. An oscillator that delivers modulation
signals below the audible frequency range—in the bandwidth that falls between 0.1 Hz and
20 Hz, and sometimes as high as 50 Hz or 400 Hz.
Library The workspace shown to the left of the Tracks area where you access patches and
settings files for plug-in presets and channel strips.
Line tool A tool in the Step Editor used to edit multiple steps by clicking a start and end
position on the lane, which changes the values of the steps between the start and end.
Linear view A view in the Score Editor that displays a single track in a continuous,
scrolling horizontal view.
Link button A button in the Piano Roll Editor and Score Editor with a chain link icon
that controls how content is linked in related workspaces. You can show all content
or the content of the selected region only. Or you can unlink related workspaces from
one another.
Lists area A workspace shown to the right of the Tracks area with four independent tabs
that show vertical lists for the following data types: events, markers, tempo changes, and
time and key signatures.
Live Loops grid One of the primary working spaces of Logic Pro. It is a grid of cells that
can be played back independently or in groups, allowing you to compose, improvise, and
arrange musical performances in a nonlinear fashion. The grid rows correspond to tracks
in the project, and the columns correspond to scenes. Triggers at the bottom of the grid
let you start and stop the cells in a scene simultaneously. You can add content or record to
cells, control and synchronize cell playback, and record a Live Loops performance to the
Tracks area. See Live Loops overview.
local menu bar Refers to a menu bar in one of the working areas of Logic Pro that contains
functions that are relevant only to that area.
Local Off mode An operating mode on a MIDI keyboard that stops the keyboard from
generating sounds directly from its own integrated sound generator. This is useful when
using the device as a master keyboard or computer input device for Logic Pro.
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locators Left and right indicators that define the cycle area, which is used for cycle or skip
playback and cycle recording operations. The locators are also used to define the editing
area for certain functions. When the LCD is set to Custom, the locators are displayed to
the right of the position indicators in the LCD. The number on top is the left locator; the
number below is the right locator.
Logic Pro main window The primary working window of the app. The Tracks area and the
Live Loops grid appear in the central area of the window, and it can incorporate all other
working areas and editors. Also referred to simply as the main window. In earlier versions
of Logic Pro, the main window was called the Arrange window.
loop An audio or MIDI file that contains recurring rhythmic musical elements or elements
suitable for repetition. Logic Pro supports Apple Loops as well as other file formats.
Loop Browser An area shown to the right of the Tracks area when you click the Loop
Browser button in the control bar. The Loop Browser is used to access and manage
Apple Loops and untagged loops.
Loop function The Loop region parameter that creates loop repeats for an audio or MIDI
region. You can loop a region using the Loop pointer or by selecting the Loop checkbox in
the Region inspector. The loop repetitions continue until the project end point is reached,
or until another region or folder is encountered on the same track.
low cut filter A type of filter that is essentially a highpass filter with no slope or resonance
controls. As the name suggests, it attenuates frequencies below the cutoff frequency. See
also highpass filter.
lowpass filter A filter that allows frequencies below the cutoff frequency to pass
unaltered, while frequencies above the cutoff are attenuated. A lowpass filter with no slope
or resonance controls is known as a high cut filter.
main menu bar The menu bar at the top of the screen, offering global functions such as
opening, saving, exporting, and importing projects. The Edit menu in the main menu bar
includes commands that apply to the window with key focus. See also local menu bar.
marker An indicator that is tied to a specific time position in a project. For example, a
marker can contain text to provide notes for different versions of a project. Markers can
also be used for a number of selection and navigation tasks.
Marker List A window (or tab) in the Lists area that shows a list of all marker events. The
Marker List also includes a Marker Text area where you can add text information (notes) to
particular marker events.
marker text Text attached to a particular marker event, for notes or other information. You
add marker text in the Marker Text window or the Marker Text area of the Marker List.
Marker track One of the global tracks, used for the creating, editing, and viewing
marker events.
Marquee tool A crosshair-shaped tool used to select and edit region parts.
master channel strip A channel strip in the Mixer that acts as a separate (final) attenuator
stage, changing the overall gain of all output channel strips while maintaining the level
relationships between them.
merge To mix or combine two or more MIDI events or regions into a single event or region.
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metadata Refers to additional descriptive information that is stored in the file header of a
number of file types (AAF, for example). Metadata is used to reference external media, to
simplify searches, and more.
metronome A device that produces a regular, metrical tick or other sound to mark the
musical beat (in bpm). Logic Pro features a metronome for practice and recording. It can
be configured in the Metronome project settings.
MIDI Acronym for Musical Instrument Digital Interface. MIDI provides a standardized
hardware and software interface for electronic musical instruments, allowing devices such
as synthesizers and computers to communicate with each other. It controls the pitch,
length, and volume of a musical note event, among other characteristics.
MIDI channel Tracks recorded in Logic Pro can be directed to different MIDI channels,
which can contain different information and play back through different sounds assigned to
each channel; for example, channel 1: piano, channel 2: bass, channel 3: strings, and so on.
Up to 16 separate MIDI channels can pass through a port simultaneously, if the receiving
devices are capable of receiving data on more than one channel and are capable of playing
back different sounds simultaneously. See also multi-timbral.
MIDI Clock A short MIDI message for clock signals used to provide a timing pulse between
MIDI devices. MIDI Clock is accurate to 24 pulses per quarter note (ppqn), although some
devices interpolate these pulse values, resulting in a more precise clock signal if each
device is capable of interpreting this additional information correctly. See also SPP.
MIDI In button The button used to turn on Step Input mode in the editors. See also Step
Input function.
MIDI interface A hardware component that allows you to connect MIDI controllers and
other MIDI devices to your computer. See also audio interface.
MIDI Machine Control (MMC) A set of MIDI commands that Logic Pro uses to control the
transport functions of any MMC-capable recording equipment (such as tape machines).
The recording process can also be controlled and automated from Logic Pro via MMC.
MIDI message A message transmitted via MIDI that consists of one status byte and zero,
one, two, or many data bytes (with system exclusive commands). See also event.
MIDI Multi mode A multi-timbral operating mode on a MIDI sound module where different
sounds can be controlled (polyphonically) on different MIDI channels. A multi mode sound
module behaves like several polyphonic sound modules. General MIDI describes a 16part multi mode (the ability to control 16 different parts individually). Most modern sound
generators support multi mode. In Logic Pro, multi mode sound modules are addressed
via multi-instrument objects. This MIDI mode and multi mode sound modules are generally
referred to as multi-timbral. See also multi-timbral.
MIDI plug-in MIDI plug-ins can be inserted in software instrument channel strips to
process or generate MIDI data played from a MIDI region or a MIDI keyboard in real time.
Logic Pro MIDI plug-ins include Arpeggiator, Chord Trigger, and Modulator, as well as
Scripter which lets you to create your own MIDI processing and generation scripts.
MIDI region A data container for MIDI events, shown in the Tracks area as a rounded
rectangular area.
MIDI Thru tool A tool in the Environment used to assign an Environment object to the
selected track in the Tracks area.
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MIDI Time Code (MTC) Refers to the translation of a SMPTE timecode signal into a MIDI
standard timecode signal. MTC is used to synchronize Logic Pro with MIDI devices, other
sequencers, video and audio tape, or hard disk machines that support MIDI Time Code.
MTC determines absolute time positions and supports start, stop, and continue messages.
mix The process of shaping the overall sound of a project by adjusting the volume levels,
pan positions, adding EQ and other effects, and using automation to dynamically alter
these and other aspects.
mixdown A term commonly used to describe either the bouncing or merging of tracks. See
also bounce and merge.
Mixer The area in Logic Pro that displays the audio, instrument and MIDI channel strips,
and master channel strip in a project. These channel strips allow you to control all
aspects of track output and processing, including level, panning, plug-in processing,
routing, and more.
modulation A slight, continuously varying change. Many Logic Pro effects and
synthesizers contain modulators.
modulation amount The strength, or intensity, of modulation.
modulation matrix The Sampler instrument (and some other Logic Pro instruments)
contains a grid that allows you to vary a number of target parameters, such as pitch, with
a number of modulation sources (modulators). This grid is referred to as the modulation
matrix in the Sampler instrument.
modulation routing The path that determines which target parameter will be affected by a
specific modulator (modulation source).
modulation wheel A MIDI controller found on most MIDI keyboards.
mono Short for monophonic sound reproduction. The process of mixing audio channels
into a single track, using equal amounts of the left and right audio channel signals.
Compare stereo.
Movie track A global track that allows you to view movie clips within a project.
MP3 Abbreviation for MPEG-2 Audio Layer 3. A compressed audio file format, frequently
used to distribute audio files over the Internet.
multi-instrument object An object in the Logic Pro Environment that represents a
multi-timbral hardware or software device that reacts to MIDI. The multi-instrument
object is essentially 16 instrument objects in a single package. Each instrument, called a
subchannel, has a fixed MIDI channel, while all share the same MIDI port. Other parameters
can be set individually. The multi-instrument object allows you to address multichannel
MIDI devices, which can receive MIDI data (and play different sounds) on separate
MIDI channels.
multi-timbral A term that describes an instrument or other device that can play several
different sounds at the same time, using multiple MIDI channels. See also MIDI Multi mode.
Multi Trigger mode A mode associated with synthesizers such as the ES1. In this mode, a
synthesizer envelope is usually retriggered by each incoming note event.
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Musical Typing keyboard An onscreen keyboard that allows you to use the computer
keyboard as a real-time MIDI keyboard, so that you can record MIDI when no music
keyboard is connected. In earlier versions of Logic Pro, the Musical Typing keyboard was
called the Caps Lock keyboard.
mute To turn off (silence) the audio output of a channel or track. You can mute a track
or channel by clicking the Mute button in the track header or at the bottom of the
channel strip.
Mute tool A tool used to silence individual regions or events.
native (1) The host-based processing of effects and software instruments in Logic Pro.
The computer processor natively calculates the effects and instruments. (2) The internal
Logic Pro plug-in format, as opposed to the Audio Units format. Logic Pro native plug-ins
only work in Logic Pro.
normalize To raise the volume of a recorded audio file to the maximum digital level,
without altering the dynamic content. For MIDI regions, normalization applies the current
parameter settings to the selected MIDI events (by altering the actual events themselves),
and clears existing parameter settings.
notch filter A filter that cuts the frequency band near the cutoff frequency, allowing all
other frequencies (both below and above) to pass.
note attributes Functions found in the Attributes menu of the Score Editor that determine
the stem direction, color, enharmonic symbols, and additional aspects for the display (and
printing) of note events.
note number The pitch of a MIDI note, controlled by the first data byte of a MIDI
note event.
object A term that refers to the graphical representation of elements in the Logic Pro
Environment. Objects can be used to both create and process MIDI data in real time, and
to create processing machines, such as virtual rhythm generators or step sequencers.
Examples of Environment objects include instruments, multi-instruments, faders, and
arpeggiators. The Environment Mixer layer contains objects that process audio data.
offset (1) Refers to a situation where the playback point in a source audio file differs from
the start point (anchor) of the file. Also known as start point offset. (2) In conjunction with
video timecode, when the start time of the Logic Pro project and QuickTime movie file are
offset (different) from each other. (3) The situation when the amplitude of a waveform is
off-axis from the center line (due to a recording error caused by hardware). This can be
rectified with the DC Offset function in the Audio File Editor. See also DC Offset.
oscillator The part of a synthesizer (often the first stage) that generates the basic sound,
using a selection of waveforms containing different amounts of harmonics, that is then
modified using other synthesizer controls.
output channel strip A channel strip in the Mixer that controls the output level and pan/
balance for each physical output of your audio interface.
Page view A view in the Score Editor that displays music notation as it will appear on
facing, printed pages.
pan Also known as pan position, describes the placement of mono audio signals in the
stereo field, by setting different levels on both sides.
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Pan control A rotary knob (directly above the Volume fader) on mono channel strips, used
to determine the position of the signal in the stereo image.
patch An element that contains the instrument, effects, and routing settings that control
the sound of a track. When you choose a patch in the Library, those settings are applied to
the track with key focus.
peak (1) The highest level in an audio signal. (2) Portions of a digital audio signal that
exceed 0 dB, resulting in clipping. You can use the level meters on each channel strip to
locate peaks and remove or avoid clipping. The Search Peak command in the Audio File
Editor Functions menu searches for the sample bit with the greatest amplitude value.
peak level display A digital audio meter that displays the absolute volume of an audio
signal as it plays, making it easier to accurately view every peak in the signal.
Pencil tool A tool used to create empty MIDI regions in the Tracks area. You can also use
the Pencil tool in conjunction with the Shift key to add audio regions to the Tracks area. In
the Audio File Editor, the Pencil tool can be used to draw out transient signal spikes (pops
and clicks) in signals.
Piano Roll Editor A MIDI track editor in Logic Pro that displays note events in MIDI regions
as horizontal beams. Events can be cut, copied, moved, resized, and edited in other ways.
pink noise A type of harmonic noise that contains more energy in the lowerfrequency range.
pitch The perceived highness (treble) or lowness (bass) of a musical sound. Pitch
corresponds to the frequency of the sound wave. See also frequency.
pitch bend message A MIDI message transmitted by the pitch bend wheel of a
MIDI keyboard.
playback Refers to playing a project, an individual region, or an audio file, so that you
can hear it.
playhead A vertical white line that indicates the current playback position in the Tracks
area and in time-based editors (such as the Piano Roll Editor and Audio Track Editor). You
can drag the playhead to change the playback position. See also scrubbing.
plug-in A software app that enhances the functionality of Logic Pro. Plug-ins are typically
software instruments or effects that can be used on Logic Pro tracks.
plug-in window A window where you can interact with the plug-in parameters. You open a
plug-in window by double-clicking the Effect slot containing the plug-in.
Pointer tool The default tool when you open Logic Pro. A tool used to select or edit
regions, events, menu or interface items, and more.
post fader A send in an analog mixer that is positioned after the Volume fader in the signal
flow, so that the level of signals going to the send changes with the fader movements.
pre fader A send in an analog mixer that is positioned before the Volume fader in the
signal flow, so the level of a signal routed pre-fader to a send remains constant, regardless
of any fader movements.
preset A set of plug-in parameter values that can be loaded, saved, copied, or pasted via
the Library or the Settings pop-up menu in the plug-in window header. See also setting and
Settings pop-up menu.

Logic Pro User Guide

1231

pressure See aftertouch.
project A Logic Pro file. It contains all MIDI regions and references to the audio files to
be played back. A project file can be saved within a project folder, which can contain the
project’s audio files and other assets (such as movie, sample files, and so on). Saving
assets in the project simplifies archiving and exchanging projects but increases the
project’s size.
Project Audio Browser One of the browsers in the Browsers area used for managing
project audio files and regions and conversion tasks. See also Browsers. In earlier versions
of Logic Pro, the Project Audio Browser was called the Audio bin.
project folder A folder that contains a Logic Pro project as well as all media files used by
the project. See also project.
project settings A collection of program settings that are specific to the current project.
These are different from the global preferences that affect all Logic Pro projects.
protected track A track that can’t have its contents moved or changed.
punch in, punch out Describes going into and out of record mode while a project is
playing, to replace a section of an existing recording. This process can be automated in
Logic Pro. See also Autopunch function.
PWM Abbreviation for Pulse Width Modulation. Synthesizers often feature this facility,
where a square waveform is deformed by adjusting its pulse width. A square waveform
usually sounds hollow and woody, whereas a pulse width modulated square wave sounds
more reedy and nasal.
Q factor A term associated with equalizers. Q factor is the quality factor of the
equalization, and is used to select a narrower or broader frequency range within the overall
sonic spectrum of the incoming signal.
quantization The process of time-correcting note start positions by moving them to the
nearest point on a time grid. When quantization is applied to any selected event or region,
Logic Pro moves all note events to align perfectly with the nearest grid position. Logic Pro
quantization is non-destructive, allowing you to try out different quantize values without
losing the original timing.
Quantize tool A tool used to quantize specific selected events, using the quantize value
specified in the Quantize pop-up menu.
Quick Help An area at the top of the inspector that shows a brief description of whatever
part of the Logic Pro interface you move the pointer over. Quick Help can also be opened
as a floating window. Some Quick Help descriptions contain links to more detailed
information.
Quick Swipe Comping mode A mode available in a selected take folder. When Quick Swipe
Comping mode is turned on, you can create and edit comps. When you turn it off, you can
cut, drag, and move take folder and take region elements in the selected take folder.
QuickTime An Apple cross-platform standard for digitized, data-compressed movie
playback and encoding. QuickTime movies can be shown in a Logic Pro window or on
the global Movie track, in sync with the project. When you move the playhead, the movie
follows, and vice versa.
real-time effects Effects that can be applied to regions in real time during playback.
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record-enable Audio tracks must be manually armed (record enabled) before you can
record on them. MIDI and software instrument tracks are automatically record enabled
when selected.
record (1) Also known as recording, the act of capturing a performance as audio or MIDI
data. (2) A term that refers to the actual data in Logic Pro. Recordings are typically referred
to using the words region or file to make things clearer.
region A rectangular segment in the Tracks area that represents the recordings and added
media files in a project, and acts as a container for audio or MIDI data. There are five types
of regions—audio regions, MIDI regions, Drummer regions, pattern regions, and folder
regions (usually referred to as folders)—each represented by a different color. See also
audio region, MIDI region, Drummer region, and folder.
Region inspector A Logic Pro inspector used to non-destructively set the playback
parameters—including quantization, transposition, velocity, compression, and delay—for
individual regions. These parameters affect how the events are played back but don’t alter
the stored data.
release An envelope parameter that determines the time it takes for a signal to fall from
the sustain level to an amplitude of zero when the key is released. See also envelope.
Remix FX Remix FX provides a number of effects commonly used in dance and urban
musical styles. It makes it easy to scratch mix your project, much like a DJ using a
turntable, to play audio in reverse, to stop or downsample the song, and to apply a variety
of other dancefloor-oriented effects using a set of buttons and XY pads. It is intended
mainly for use on the stereo output bus, but you can insert the plug-in on any type of
signal in your project.
Replace mode A type of overwrite recording mode where the existing audio regions in a
section of the Tracks area are replaced by a new recording. To turn on Replace mode, click
the Replace button in the control bar.
Resize tool A tool in the Score Editor used to change the size of a note or other symbol.
resonance A term generally associated with filters, particularly synthesizers. Resonance
emphasizes the frequency range surrounding the cutoff frequency. See also cutoff
frequency.
reverb Short for reverberation. Reverb emulates the sound of a physical space, or, more
specifically, the reflections of sound waves within a space. For example, a handclap in a
large cathedral reverberates for a long time as sound waves bounce off the stone surfaces,
while a handclap in a small broom closet hardly reverberates at all. The difference in size,
and in the materials of the wall surfaces, accounts for the difference in the amount and
quality of reverberation. Logic Pro features a variety of reverb effects that you can use to
create a sense of space or ambience for your recordings.
ritardando A gradual slowdown of tempo. See also tempo.
routing Generally refers to the way audio is sent through channels or other processing
units. Routing is also used to describe specific input and output assignments.
ruler A tool located at the top of the main window, Audio File Editor, Piano Roll Editor,
Step Editor, and Score Editor. The ruler displays the units of musical time, including
bars, measures, beats, and beat divisions. It can also display units in absolute time. It is
used to set and display the project position, the cycle area, and punch locators. See also
Autopunch function and playhead.
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sample (1) A term for digital data that represents a sound at a particular instance in time.
2) The process of converting analog audio into digital data. The sample rate of an audio
stream specifies the number of samples that are captured per second. Higher sample rates
yield higher-quality audio.
sample rate The number of times per second that audio is sampled when an audio signal
is captured digitally. Logic Pro can record and edit audio at sample rates ranging from
44.1 kHz (44,100 times per second) up to 192 kHz (192,000 times per second).
sample rate converter A device or algorithm that translates one sample rate to another.
sampler A device used for sampling. In Logic Pro, this generally refers to the Sampler
software-based sampler instrument.
saturation A term commonly associated with a slight tape distortion or the characteristics
of tube amplifiers. It describes a very high gain level that causes a slight distortion of the
incoming signal, resulting in a warm, rounded sound.
scale A group of related musical notes (or pitches) that forms the basis of the melody and
harmony in a piece of music. The most common scales are the major scale and minor scale.
When you create a project, you can choose the scale (and key) for the project.
scene marker Logic Pro can automatically extract information from (abrupt) transitions
in QuickTime movie files and create a marker, making the process of scoring to film much
faster and easier. Such transitions in a movie generally indicate a scene change.
Scissors tool A tool used for splitting regions or events.
Score Editor An editor in Logic Pro that displays MIDI regions as standard musical
notation. MIDI note events are represented as musical notes, and the silence between them
as rest symbols. Many other musical symbols—such as clefs, key and time signatures,
accents, and articulations—can also be displayed. The Score Editor allows you to adjust
and edit the layout of the score, export it as a PDF, and print it.
score set A saved collection of multiple staff styles, staffs, and other elements shown in
the Score Editor. You can use score sets to quickly switch between (and edit and print)
different portions of the score—such as a brass section—separately from the entire score.
It also simplifies experimentation with different layouts.
screen control Each Smart Control has a set of screen controls. Adjusting a screen control
can change one or more parameters of the track’s channel strip, instrument, and effect
plug-ins. Screen controls are labeled to help you understand which aspect of the sound
each one affects. See also Smart Control.
screenset A layout of various windows, including all display parameters (zoom, position,
size, and so on). You can save, recall, and switch between different screensets, much as
you might swap between different computer monitors.
scrub When you scrub a project, you quickly audition the project, or a part of it, by moving
the playhead across the Tracks area. For more information, see Scrub a project.
selection-based processing In the Tracks area, you can apply audio effect plug-ins to
individual audio regions and to marquee selections of audio regions. You can preview the
result and make further adjustments before applying the resulting changes to the selection.
self-oscillation A typical characteristic of analog filter circuits that occurs when the
filter, at high resonance values, feeds back into itself and begins to oscillate at its natural
frequency.

Logic Pro User Guide

1234

semitone The smallest interval between two pitches in the standard diatonic scale in
Western music. A semitone is also called a half step or half tone.
send Short for aux send. An output on an audio device used for routing a controlled
amount of the signal to another device. Sends are often used to send several signals to
the same effect, letting you use computationally intensive effects such as reverb more
efficiently.
Send slot A panel on mixer channel strips used to send (via a bus) some or all of the audio
signal to an aux channel strip. You can use multiple sends on channels.
sequencer A computer app used to record both audio and MIDI data and blend the sounds
together in a software mixing console. Early sequencers controlled synthesizers via a
series of control voltages and gates, or via MIDI only. No audio recording or control was
available. See also DAW.
setting (1) A parameter value. (2) A set of plug-in parameter values that can be loaded,
saved, copied, or pasted via the Settings pop-up menu. A plug-in setting is also known as
a preset. See also preset, Setting button, and Settings pop-up menu.
Setting button A panel on mixer channel strips used to load, copy, and save channel strip
settings. These settings contain setup information for a channel strip, including plug-ins.
Settings pop-up menu The menu in the gray header at the top of all plug-in windows
used to save, load, copy, and paste settings (the parameter values of effects and software
instruments).
sharing Refers to the process of distributing your projects. Logic Pro provides several
options: the Music app, SoundCloud, XML, MusicXML, and others.
shelving EQ A type of EQ that allows the frequency range above or below the specified
frequency to be increased or decreased.
Show/Hide Flex button A button in the Tracks area and Audio Track Editor. In the Tracks
area, it is used to show or hide a Track Flex button and Flex Mode pop-up menu on audio
track headers. In the Audio Track Editor, it is used to show or hide the Flex Mode pop-up
menu in the Editor.
side chain An alternative input signal—usually routed into an effect—used to control an
effect parameter. For example, you could use a side chained track containing a drum loop
to act as the control signal for a gate inserted on a sustained pad track, creating a rhythmic
gating effect of the pad sound.
Signature List A window (or tab) that lists all time and key signatures of a project.
Signature track A global track that shows all time and key signatures of a project.
Single Trigger mode A term associated with synthesizers such as the ES1. In this mode,
envelopes are not retriggered when tied (legato) notes are played.
Smart Control Smart Controls let you control the sound of the selected track using
a set of onscreen controls. Smart Controls can control both channel strip and plug-in
parameters, including software instruments and effects. See also screen control.
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Smart Tempo Smart Tempo lets you record a performance without the metronome and
have Logic Pro adapt the project tempo to match the tempo of the recording, or keep the
project tempo and flex the recording to match it. Using Smart Tempo, you can also also
create remixes using audio files and MIDI regions with different tempos that all conform
to the project tempo, or adapt the project tempo to the tempo of an imported audio file or
MIDI region.
Smart Tempo Editor In the Smart Tempo Editor, you can view and edit Smart Tempo
analysis results including beat markers and other tempo information. After recording a
region or importing a file using Smart Tempo, you can refine the tempo analysis and correct
any tempo detection errors to define the musical intent more accurately.
SMPTE Abbreviation for Society of Motion Picture and Television Engineers. The
organization responsible for establishing a synchronization system that divides time into
hours, minutes, seconds, frames, and subframes (SMPTE timecode). SMPTE timecode is
also used for synchronizing different devices. The MIDI equivalent of SMPTE timecode is
MIDI Time Code (MTC). See also MTC.
SMPTE Time ruler Refers to the Logic Pro ruler when set to display time in SMPTE format.
The SMPTE Time ruler can display timecode if a movie is added to a project.
Snap pop-up menu A pop-up menu found in the local menu bar of linear editing windows
that determines the behavior of regions or events when edited. Lengths and cuts will
snap to the nearest possible position as determined by the value chosen in the Snap
pop-up menu.
software instrument A virtual instrument for which the sound is calculated by the
computer processor, and played via the audio interface outputs. Often colloquially called
softsynths or soft samplers. Logic Pro includes a large collection of native software
instruments to use in your projects.
software instrument channel strip Logic Pro supports the use of software-based
instruments. Software instrument plug-ins are inserted into the Instrument slot of
instrument channel strips. Software instrument recording takes place on instrument tracks
in the Tracks area. Playback of these tracks is routed via the instrument channel strip in
the Mixer.
solo To temporarily isolate one or more tracks, regions, or events, allowing them to be
heard without the rest of the project.
Solo tool A tool used to play a region or event in isolation.
S/P-DIF Short for Sony/Philips Digital Interface. A standard transmission format for
professional stereo digital audio signals. The format is similar to AES/EBU, but uses 75 ohm
coaxial or optical connectors and cabling. Depending on the type of devices involved, AES/
EBU and S/P-DIF coaxial interfaces can communicate directly. Most digital audio interfaces
available today will feature S/P-DIF connectors.
split channel audio files Often the channels of multichannel audio files (stereo or
surround) are interleaved, so that edits to one channel affect the others equally. Logic Pro
allows you to separate these files into split channel audio files, so that you can edit each
channel independently. See also interleaved audio file.
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SPP Abbreviation for Song Position Pointer. A MIDI Clock timing pulse sub-message that
indicates the current “song” (project) position. It is accurate to bars (and beats for some
devices), but is not as accurate as MIDI Time Code (MTC), which is preferred when you
have a choice when synchronizing Logic Pro. See also MIDI Clock and MTC.
staff style Determines the appearance of notation on a musical staff. You can define note
sizing and spacing, number of staff lines, fonts, and more for each staff style.
Standard MIDI file (SMF) The standard file format for exchanging songs between
different sequencers or MIDI file players. Standard MIDI files are not specific to a particular
sequencer program, type of computer, or device. Any sequencer should be able to
interpret at least the type 0 MIDI file format. Standard MIDI files contain information about
MIDI events, including time positions and channel assignments, names of individual tracks,
instrument names, controller data, and tempo changes.
status byte The first byte in a MIDI message, which defines the type of message
being sent.
step A beam in the Step Editor that represents a MIDI event. The value of the event is
denoted by the beam height, providing an at-a-glance view of one, or dozens, of different
events and their values.
Step Editor A graphical editor in Logic Pro that can be used to create and edit MIDI note
and controller data. The Step Editor is ideal for drawing drum parts and creating crescendi,
among other tasks. In earlier versions of Logic Pro, the Step Editor was called the Hyper
Editor. See also event definition.
step input A feature that allows you to insert MIDI notes into a MIDI region, one at a time,
when real-time recording is not active. This technique allows you to input notes accurately,
even when they may be too fast for you to play “live.” Step input can be performed
onscreen with the mouse or with the computer or MIDI keyboard, or any combination of
these devices. See also MIDI In button.
step sequencer Originally a hardware device from the early years of analog synthesizers
with knobs that controlled the gate time (note length) and pitch of a connected
synthesizer, now both hardware and software instruments, particularly drum synthesizers,
include an integrated step sequencer that synchronizes with project playback. Logic Pro
includes Step Sequencer, which lets you sequence not only drum and instrument sounds
but also stepped parameter changes, and provides greatly increased control and flexibility
in creating and playing patterns. Ultrabeat incorporates a step sequencer that is also more
flexible than a classic analog sequencer.
stereo Short for stereophonic. Refers to the sound reproduction of two different audio
channels. Compare mono.
subframe A subdivision of a SMPTE frame, corresponding to its individual bits. One frame
consists of 80 bits.
summing stack A type of Track Stack that lets you combine multiple tracks and route
their output to an audio subgroup. When you create a summing stack, the outputs from the
subtracks are routed to a bus, the destination aux of which is assigned to the main track.
When the main track is selected, you can mute, solo, and adjust volume and send levels for
the summing stack, and add and edit plug-ins, affecting the sound of all the subtracks in
the summing stack. See also Track Stack.
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surround Describes playback systems that make use of multiple speakers. The most
common surround format is 5.1 channels (front left, front center, front right, left surround,
right surround, and an LFE, or subwoofer, channel), typically used in home theater systems
and in cinemas. Logic Pro supports all common surround formats, and provides surround
recording, plug-in, and mixing facilities.
Surround Panner control Replaces the standard Pan/Balance knob of channel strips
for surround projects. The Surround Panner control allows you to control the relative
positioning of the channel signal between the available speakers (in the chosen project
surround format).
sustain An envelope parameter that sets the steady amplitude level produced when a key
is held down. See also envelope.
sustain pedal A momentary footswitch connected to a MIDI keyboard. The sustain pedal
transmits MIDI controller number 64, which is recorded and played back by Logic Pro, and
which can be edited as an automation parameter.
Swing parameter A parameter that alters the rigid timing of a quantization grid by
delaying every other note of a specified subdivision by a definable amount.
Sync button A button in the control bar used to turn external synchronization mode
on and off.
synchronization Refers to the method of keeping several recording or playback devices
time-locked with one another. In virtually all synchronized setups, there is one transmitter
device and one or more receiver devices that derive their synchronization clock from the
transmitter.
synchronizer The central unit used to control the synchronization of several devices. In
most situations, Logic Pro will act as the device that sends or transmits synchronization
signal to other (receiving) devices.
synthesizer A hardware or software device that can generate sounds. The word is derived
from early attempts with mechanical and electronic machines to emulate (or synthesize)
the sounds of musical instruments, voices, birdsong, and so on. Logic Pro features several
software synthesizers, including the ES1, ES2, EFM1, ES E, ES M, and ES P.
SysEx Short for System Exclusive data. SysEx data forms the top tier in the hierarchy
of MIDI commands. These messages are tagged with an identification number for each
manufacturer (known as the SysEx manufacturer ID number). The actual content of
these MIDI commands is left to the manufacturer. SysEx data is often used to transfer
sound programs or system settings, or to address individual sound generation or signalprocessing parameters.
take folder A container for multiple take recordings.
take A term used to describe a recording. Logic Pro allows you to create several takes,
one after the other, without leaving record mode. These takes can then be compiled into a
composite take, or comp. See also comping.
tempo The playback speed of a piece of music, measured in beats per minute. Logic Pro
allows you to create and edit tempo changes in the Tempo track.
tempo change An event inserted into the Tempo track (as a tempo point) that indicates a
change in tempo at a particular bar or beat position.

Logic Pro User Guide

1238

Tempo track One of the Logic Pro global tracks. A Tempo track displays tempo
changes as nodes.
Text tool A tool used for editing the name of regions and other items. In the Score Editor,
you can use the Text tool to add text to a score.
tick The smallest unit of timing resolution in a MIDI sequencer. In Logic Pro, this equals
1/3840 of a note. Logic Pro allows edits at single sample accuracy (at sufficient zoom
levels) for edits and positioning, which exceeds what the MIDI protocol is fast enough to
support for playback.
timecode A format for assigning a unique, sequential time unit to each frame of video (or
project) position. The SMPTE timecode format is measured in hours, minutes, seconds,
frames, and subframes.
Time Quantize button The button (labeled with a Q) that you click to quantize selected
events. See also Quantize tool and quantization.
Time Quantize pop-up menu The Logic Pro menu from which you choose the quantize
value. See also Quantize tool and quantization.
time signature Refers to musical notation that tells you how to interpret the rhythm
of a piece of music. The time signature can be thought of as a fraction where the top
number (the numerator) tells you the number of beats in a bar and the bottom figure (the
denominator) the value of those beats. For example, a 4/4 time signature means there are
four quarter beats in a bar.
timing A measure of the ability to play notes in time (in keeping with the tempo). Timing
can also refer to synchronization between events, regions, and devices.
Tool menu A menu in a local menu bar that contains the tools for editing, zooming,
cropping, and otherwise manipulating items in that specific window.
toolbar A collection of buttons and other controls used for working with regions in the
Tracks area. By default the toolbar is hidden, but you can make it visible by clicking
the Toolbar button in the control bar. You can customize the toolbar to meet your
individual needs.
track A horizontal row in the Tracks area that contains either audio, MIDI, Drummer, or
pattern regions that can be played back over time. Each track has a specified channel strip
that data is routed to. A Logic Pro project can contain hundreds of tracks.
track arming See record-enable.
Track inspector A Logic Pro inspector used to non-destructively set the playback
parameters for each track, for example, channel and MIDI channel, Freeze mode,
transposition, and velocity. These parameters do not alter the regions on the track.
Track Protect button A button in the track header that protects or unprotects tracks from
further editing. See also protected track.
Track Stack Track Stacks provide a convenient way to organize and control tracks, to
manage projects with high track counts, and to create and manage audio subgroups. There
are two types of Track Stacks: folder stacks and summing stacks. Both types have a main
track and one or more subtracks. See also folder stack and summing stack.
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Tracks area One of the primary working spaces of Logic Pro. The Tracks area is used to
record, edit, and arrange the audio, MIDI, Drummer, and pattern regions in a project. It is
also used for recording and playback of automation. In earlier versions of Logic Pro, the
Tracks area was called the Arrange area.
transform set A collection of saved transform operations. Transform sets can be quickly
accessed via the Presets menu in the Transform window. You can also import transform
sets from other projects. See also Transform window.
Transform window An editor used to define a set of conditions and operations for
selecting and manipulating specific MIDI events.
transient A point in an audio recording where the signal becomes louder over a short
time span. It is a short burst of amplitude, normally at the onset of a sound. Because this
behavior is typical for rhythmic or percussive parts of music, such as a drumstick hitting a
snare drum, transients can be used to indicate where beats occur in an audio signal.
transient detection A process in which audio files are analyzed for transients the first time
you enable a track for flex editing. See also flex editing.
transient marker A marker that denotes a significant point or peak in an audio file. See
also transient.
transport controls A set of buttons and other controls located in the center of the control
bar, used to control recording and playback functions. The transport controls include the
Record, Pause, Play, Stop, and Rewind/Forward buttons, and other functions. You can also
open a floating Transport window.
transposition The process of changing the pitch of a project, a region, or individual notes
or chords by a number of semitones.
Transposition track One of the Logic Proglobal tracks. A transposition track allows you to
transpose parts of a project and view transposition events.
treble A term that refers to high-frequency sounds or components within a sound. See
also frequency.
untagged loop You can add untagged loops or loop libraries to the Untagged Loops tab
of the Loop Browser, where you can preview untagged loops at their original tempo or at
the project tempo, batch analyze them for tempo information, remove any existing tempo
information, and synchronize the playback of untagged loops with your project.
varispeed A way of speeding up or slowing down the entire project, similar to the original
varispeed feature of tape machines. You can change both pitch and speed, or only speed
(while pitch remains constant).
velocity Refers to the force with which a MIDI note is struck. Velocity is controlled by the
second data byte of a note event. The velocity of recorded MIDI notes can be edited in the
Piano Roll Editor.
Velocity tool A tool in the MIDI editors used to adjust the velocity of individual, or
grouped, note events.
Vibrato tool A tool in the Audio Track Editor used to adjust the amount of vibrato on notes
in Flex Pitch mode.
Voice Separation tool A tool in the Score Editor used to separate polyphonic voices onto
different staffs by drawing a dividing line (if you’re using a polyphonic staff style).
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Volume tool A tool in the Audio Track Editor used to adjust the amount of gain applied to
notes in Flex Pitch mode.
VU meter Abbreviation for Volume Unit meter. An analog meter used to monitor audio
levels, typically with a circular face and a moving needle.
WAV, WAVE The primary audio file format used by Windows-compatible computers.
In Logic Pro, all recorded and bounced WAV files are in Broadcast Wave format, which
includes high-resolution timestamp information that stores positional information. This
makes it easy to align these files in other audio and video apps.
waveform A visual representation of an audio signal. Waveform graphics run from left to
right, and are centered on a horizontal line. Louder portions of the waveform (amplitude
peaks) are indicated as taller peaks or curves in the waveform.
wet/dry mix Refers to the ratio of a signal that effects have been added to (wet), and the
original, unprocessed signal (dry).
white noise A type of noise in which all frequencies in a given frequency band sound
simultaneously, at the same intensity. Its name is analogous to white light, which consists
of a mixture of all optical wavelengths (all rainbow colors). Sonically, white noise falls
between the sound of the consonant F and breaking waves (surf). Synthesis of wind and
seashore noises, or electronic snare drum sounds, typically makes use of white noise.
Word Clock The clock signal required by digital audio interfaces to ensure that
the sampling rates of connected devices run synchronously. When two devices are
connected via a standard digital audio interface (such as S/P-DIF or ADAT optical),
Word Clock is transmitted via the audio circuit. If you want more than two digital audio
devices to communicate with each other, you need to use separate Word Clock ports for
synchronization, in most cases.
Wrapped view A view in the Score Editor that displays the selected track or tracks in a
line-wrapped, lead sheet–style view.
zero crossing A point in an audio file where the waveform crosses the zero amplitude axis.
If you cut an audio file at a zero crossing, there will be no click at the cut point.
zoom control The control that appears at the top-right corner of the Tracks area and some
other windows. The zoom control slider allows you to zoom in to see more details or zoom
out to view more of a project. Most windows have zoom sliders.
Zoom tool A tool used to zoom in on any part of the active area. The Zoom tool can be
accessed by pressing and holding Control-Option. Click the background with the tool to
revert to the normal zoom level.
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