Upgrade to
macOS High Sierra.

There are so many reasons to upgrade to macOS High Sierra now. You get access to new technologies that make your Mac more reliable, capable, and responsive. Upgrading ensures that you get the latest security enhancements. And refinements to the features and apps you use every day. Here are two more: It’s free, and it’s easy.

Chances are, your Mac can run macOS High Sierra.

Mac computers introduced in late 2009 or later can be upgraded to macOS High Sierra.

Check your Mac hardware

Make sure you’re ready to upgrade.

Before you upgrade, we recommend that you back up your Mac. Then, if your Mac is running OS X Mountain Lion 10.8 or later, you can upgrade directly to macOS High Sierra.

Upgrading is free. And easier than you think.

Visit the macOS High Sierra page on the Mac App Store. Click the download button and follow the onscreen instructions to begin your upgrade. If you don’t have broadband access, you can upgrade your Mac at any Apple Store.

Learn more about how to upgrade to macOS High Sierra

General Requirements

  • OS X 10.8 or later
  • 2GB of memory
  • 14.3GB of available storage to perform upgrade*
  • Some features require an Apple ID; terms apply.
  • Some features require a compatible Internet service provider; fees may apply.

Have an older version of OS X? Learn how to upgrade

Upgrading from previous versions of OS X

Upgrading from OS X Snow Leopard or Lion

If you’re running Snow Leopard (10.6.8) or Lion (10.7) and your Mac supports macOS Sierra, you will need to upgrade to El Capitan first. Click here for instructions.

Upgrading from OS X Leopard

If you’re running Leopard and would like to upgrade to macOS High Sierra, first you’ll need to upgrade to OS X Snow Leopard. You can purchase OS X Snow Leopard from the Apple Online Store.

Mac Hardware Requirements

For details about your Mac model, click the Apple icon at the top left of your screen, choose About This Mac. These Mac models are compatible with macOS High Sierra:

  • MacBook (Late 2009 or newer)
  • MacBook Pro (Mid 2010 or newer)
  • MacBook Air (Late 2010 or newer)
  • Mac mini (Mid 2010 or newer)
  • iMac (Late 2009 or newer)
  • Mac Pro (Mid 2010 or newer)

Feature Requirements

Siri

Requires a broadband Internet connection and microphone (built-in or external).

Dictation

Requires a microphone (built in or external).

Spotlight Suggestions

Requires a broadband Internet connection.

Gestures

Requires a Multi-Touch trackpad, Force Touch trackpad, Magic Trackpad, or Magic Mouse.

Force Touch gestures require a Force Touch trackpad.

VoiceOver gestures require a Multi-Touch trackpad, Force Touch trackpad, or Magic Trackpad.

Photo Booth

Requires a FaceTime or iSight camera (built in or external), or USB video class (UVC) camera.

FaceTime

Video calls require a built-in FaceTime camera, an iSight camera (built in or external), or a USB video class (UVC) camera; and broadband Internet connection.

Learn more

Handoff, Instant Hotspot, and Universal Clipboard

Supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook Pro (2012 or newer)
  • MacBook Air (2012 or newer)
  • Mac mini (2012 or newer)
  • iMac (2012 or newer)
  • Mac Pro (Late 2013)

Handoff requires an iPhone, iPad, or iPod touch with a Lightning connector and iOS 8 or later.

Instant Hotspot requires an iPhone or iPad with cellular connectivity with a Lightning connector and iOS 8.1 or later. Requires Personal Hotspot service through your carrier.

Auto Unlock

Supported by Mac models introduced in mid 2013 or later.

Requires an Apple Watch with watchOS 3 or later and an iPhone 5 or later.

Apple Pay on the Web

Supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook Pro (2012 or newer)
  • MacBook Air (2012 or newer)
  • Mac mini (2012 or newer)
  • iMac (2012 or newer)
  • Mac Pro (Late 2013)

Requires MacBook Pro with Touch Bar, iPhone 6 or later with iOS 10 or later, or an Apple Watch with watchOS 3 or later.

Phone Calling

Requires an iPhone with iOS 8 or later and an activated carrier plan.

SMS

Requires an iPhone with iOS 8.1 or later and an activated carrier plan.

AirDrop

AirDrop between Mac computers and iOS devices is supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook Pro (2012 or newer)
  • MacBook Air (2012 or newer)
  • Mac mini (2012 or newer)
  • iMac (2012 or newer)
  • Mac Pro (Late 2013)

AirDrop to iOS devices requires an iPhone, iPad, or iPod touch with a Lightning connector and iOS 7 or later.

AirDrop between two Mac computers is supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook (Late 2008 Aluminum or newer)
  • MacBook Pro (Late 2008 or newer)
  • MacBook Air (Late 2010 or newer)
  • Mac mini (Mid 2010 or newer)
  • iMac (Early 2009 or newer)
  • Mac Pro (Early 2009 with AirPort Extreme card, or Mid 2010 or newer)

AirPlay

AirPlay Mirroring requires an Apple TV (2nd generation or later). Supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook Pro (Early 2011 or newer)
  • MacBook Air (Mid 2011 or newer)
  • Mac mini (Mid 2011 or newer)
  • iMac (Mid 2011 or newer)
  • Mac Pro (Late 2013)

AirPlay for web video requires an Apple TV (2nd generation or later).

Peer-to-peer AirPlay requires a Mac (2012 or later) and an Apple TV (3rd generation rev A, model A1469 or later) with Apple TV software 7.0 or later.

Apple File System

Requires a Mac with all-flash internal storage.

Metal 2

Supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook Pro (Mid 2012 or newer)
  • MacBook Air (Mid 2012 or newer)
  • Mac mini (Late 2012 or newer)
  • iMac (Late 2012 or newer)
  • Mac Pro (Late 2013)

Time Machine

Requires an additional hard drive or AirPort Time Capsule (sold separately).

Power Nap

Supported by the following Mac models:

  • MacBook (Early 2015 or newer)
  • MacBook Pro with Retina display (Mid 2012 or newer)
  • MacBook Air (Late 2010 or newer)
  • Mac mini (Late 2012 or newer)
  • iMac (Late 2012 or newer)
  • Mac Pro (Late 2013)

Boot Camp

Allows Boot Camp installations of Windows 10, Windows 8.1, and Windows 7 on supported Mac models.

Learn more

Exchange Support

Requires Microsoft Office 365, Exchange 2016, Exchange 2013, or Exchange Server 2010.

Mac App Store

Available only to persons age 13 or older in the U.S. and many other countries and regions.

What’s Included

Applications

  • App Store
  • Automator
  • Calculator
  • Calendar
  • Chess
  • Contacts
  • Dashboard
  • Dictionary
  • DVD Player
  • FaceTime
  • Font Book
  • iBooks
  • Image Capture
  • iTunes
  • Launchpad
  • Mail
  • Maps
  • Messages
  • Mission Control
  • Notes
  • Photo Booth
  • Photos
  • Preview
  • QuickTime Player
  • Reminders
  • Safari
  • Siri
  • Stickies
  • System Preferences
  • TextEdit
  • Time Machine

Utilities

  • Activity Monitor
  • AirPort Utility
  • Audio MIDI Setup
  • Bluetooth File Exchange
  • Boot Camp Assistant
  • ColorSync Utility
  • Console
  • Digital Color Meter
  • Disk Utility
  • Grab
  • Grapher
  • Keychain Access
  • Migration Assistant
  • Script Editor
  • System Information
  • Terminal
  • VoiceOver Utility

Languages

  • Arabic
  • Catalan
  • Croatian
  • Simplified Chinese
  • Traditional Chinese
  • Czech
  • Danish
  • Dutch
  • English
  • Finnish
  • French
  • German
  • Greek
  • Hebrew
  • Hindi
  • Hungarian
  • Indonesian
  • Italian
  • Japanese
  • Korean
  • Malay
  • Norwegian
  • Polish
  • Brazilian Portuguese
  • Portuguese
  • Romanian
  • Russian
  • Slovak
  • Spanish
  • Spanish (Latin America)
  • Swedish
  • Thai
  • Turkish
  • Ukrainian
  • Vietnamese