I have 10.6.8 on imac with 1GB. Can you please advise what I can upgrade to. Thanks.

I want to install a passport Hard Drive, however, it is advising that I need at least OS X 10.8 or later. I am unable to download Sierra so do I need to download each update in turn?

Back To Product

Follow this Question

1 Answer from the Community

  • You can upgrade directly to any currently available OS X (OS 10.9 and OS 10.10 are no longer available).

    But first you must make sure you have at least 2GB of memory as that is minimum requirement for OS 10.7 and later.

    Look up your model identifier (Apple Menu --> About this Mac --> System Report --> More Info --> Hardware Overview --> Model Identifier).

    If it is iMac4,1 or iMac4,2 the last OS X to support it is OS 10.6.8 (Snow Leopard).

    If it is iMac5,1 or later it is supported by OS 10.11 (El Capitan).

    If it is iMac 10,1 or later it is also supported by OS 10.12 (Sierra).

    If you are running OS 10.6.8 (or later) there is an app on your Mac called "App Store". If supported by your Mac, El Capitan will be available. If you have OS 10.7 or later on your Mac, then Sierra will be available (not El Capitan).

    If you wish to upgrade to OS 10.8 (Mountain Lion), then go to the online "Apple Store" and purchase a redemption code. The redemption code will allow you to go to App Store app and download and install OS 10.8.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions