How do I eject a disk from my usb super drive if there is no icon visible?

Back To Product

Follow this Question

2 Answers from the Community

  • If there's no icon visible, first, make sure that your Finder preferences are set to display CDs and DVDs on the desktop. If that's not the problem, then it may be that the volume isn't mounted for some reason.

    If you don't have an eject key on your keyboard, the easiest way I can think of (there are probably quite a few more) is to start up Disk Utility and eject it from there. You could possibly eject it from the DVD player app even if it's a data disk, although I've never tried that.

    If you still can't get it to eject, there are a couple more things to try:

    * Reboot your Mac, holding down the mouse button (or, instead, possibly holding F12).
    * If you're comfortable with the Terminal app, execute "drutil tray eject".
    * Turn the Superdrive upside down (never tried this, but a lot of people say it works).

    Was this useful? Answer 1

    41 of 99 people found this useful

  • Press "command + E"

    Was this useful? Answer 2

    10 of 54 people found this useful

Related Questions