Does the new Magic Mouse work with any iMac? Mine is a late 2011 version.

  • Asked about:  Magic Mouse 2 - Silver

1 Answer from the Community

  • The spec-sheet states that the magic mouse 2 requires "Bluetooth-enabled Mac computer with OS X v10.11 or later" to operate. As long as you have a Bluetooth-enabled Mac running at least macOS El Capitan, then you should be good to go.


    Note that the original magic mouse requires a Bluetooth-enabled Mac running at least MacOS X Leopard 10.5.8.