i am running OS X 10.4.11 on a PowerPC G5 and want to upgrade my operating system. Will Snow Leopard work on my computer?

  • Asked about:  Mac OS X 10.6 Snow Leopard

3 Answers from the Community

  • Best Answer:

    No. Snow Leopard requires an Intel processor.

    Leopard (OS X 10.5.n) is the last version of OS X to run on Power PC processors.

  • No, Snow Leopard requires an Intel CPU and you have a PowerPC CPU.

  • No. Snow Leopard only works on Intel-based Macs.