i have a Mac mini 2009 2GHz intel core 2 duo mac, trying to upgrade to maverick however i am still on Mac Ox 10.5.8 what course should i take to upgr

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Answer

    In order to have access to the App Store from where you can download and install Mavericks, you will need OS 10.6.8 or later installed. (Do not confuse "App Store" with the "Apple Store".)

    Step 1 is to install Snow Leopard and do "Software Update" to 10.6.8. (Snow Leopard is available from the "Apple Store".)

    Step 2 is to open the App Store app and download and install Mavericks.


    Mavericks requires at least 2GB of memory, and 8GB of hard disk space. The early 2009 Mac Mini is the earliest Mac Mini model that will support Mavericks.