i have version mac os x 10.5.8 bought ilife 11 do i need to buy 10.6.3. no one told me at store if so

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    Yes you will need to purchase snow leopard to enable iLife 11 to work. iLife 11 does not work on any other old mac os x systems.