What OS X version is needed for the mac app store?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    Mac OS X 10.6.6 Snow Leopard