Whats the backward compatibility with this device? I have a Late 2015 IMac. And I am very interested in knowing what Macs can run this.

Blackmagic eGPU

Blackmagic eGPU

Product No Longer Available

2 Answers from the Community

  • Currently the eGPU requires macOS High Sierra 10.13.6 and a Thunderbolt 3 connection. So older macs will not work.

  • Blackmagic eGPU will work with all Thunderbolt 3 based Apple computers that are running macOS 10.13.6 or later. This includes MacBook Pro computers from the 2016 model year and later, 2017 iMac and iMac Pro.
    It requires Thunderbolt 3 and you cannot use older iMac or Macbook Pro with Thunderbolt 2 so not compatible for use with cable from Apple for Tb3 to Tb2.