does it work with mac os 10.6.8

Follow this Question

1 Answer from the Community

  • System Requirements
    Bluetooth-enabled Mac computer with OS X v10.11 or later

    Was this useful? Answer 1

    1 of 2 people found this useful

Similar Questions

See more Similar Questions