Can I upgrade iMac leopard 10.5 to El Capitan

Follow this Question

1 Answer from the Community

  • If your Mac is supported by each of the following versions of OS X, the procedure is as follows:

    1) Upgrade from OS 10.5 to OS 10.6, then update to OS 10.6.8.

    2) When OS 10.6.8 is running, there will be an app on the Mac called "App Store".

    3) Open App Store app and do a search for "OS X" or "Mac OS". If your Mac is supported, then "El Capitan" (OS 10.11) will be available for download and install. (Should your Mac be running OS 10.7 or later, and if your Mac is supported, then "Sierra" (OS 10.12) will be available, and "El Capitan" will not be available.)


    (Notes: First determine if your Mac is supported by OS 10.6. OS 10.6 requires Mac with an Intel processor and at least 1 GB of memory. OS 10.6 will not "install" on newer Macs, especially those originally sold with OS 10.8 or later. Then go to Apple web site and determine if your Mac meets the requirements of OS 10.11. For OS 10.11, the Mac usually can not be older than mid-2007 to early-2009, depending on the Mac model. For OS 10.12, the Mac can not be older than late-2009 or 2010, and your Mac will definitely be supported. Macs originally sold with OS 10.5 were sold from late-2007 to mid-2009.)

    Was this useful? Answer 1

    0 of 0 people found this useful

Similar Questions

See more Similar Questions