i need to connect my 6s to mac os x version 10.6.8 how can i do this please help

Follow this Question

1 Answer from the Community

  • I assume you are referring to an iPhone 6s, unfortunately, you can't. You can plug it into your Mac and it will charge, (possibly at a reduced rate), but to use iTunes to sync and back up to your computer, you need iTunes 12.5, which requires OS X 10.9 (Mavericks).

    Mavericks or higher should be available as a free upgrade in the App Store in Snow Leopard, but if you are on an unsupported machine, you are out of luck, I'm afraid.

    On the other hand, Apple has made it very easy to use the iPhone without requiring a computer, with iCloud. You could opt for, say, 200GB of storage for about three bucks a month which should be more than plenty for your backups, with room to spare for photos, app data, et cetera.

    Even if you don't decide to get additional cloud storage, you get a base 5GB for no cost.

    Was this useful? Answer 1

    0 of 0 people found this useful

Similar Questions

See more Similar Questions