I am currently using 10.5.8- nothing works as it states I'm using old software and need to upgrade. Will buying 10.6 allow for all updates to work?

Previously things like firefox and chrome worked, but now they're not. I assumed that clicking on Software Update would have updated prior, however, from googling this it appears that I need 10.6 to allow an app to then upgrade. As it is now 2017- will buying this DVD to update the software still work?

Back To Product

Follow this Question

1 Answer from the Community

  • First make sure your Mac has an Intel processor, not a PowerPC processor. Beginning with OS 10.6, an Intel processor is mandatory.

    The current OSX is OS 10.12 (Sierra). Not all Macs support more recent versions of OSX. And not all software support newer operating systems (even after updates).

    The latest versions of FireFox and Chrome require at least OS 10.9. But one should also be able to download older versions of Firefox and Chrome that work on earlier versions of OSX (after OS 10.5.8).

    For a more specific answer as to what OSX your Mac can be upgraded to, please provide the Model ID and the amount of memory on your Mac. The Model ID can be found by going to "Apple Menu" --> "About This Mac" --> "More Info" --> "System Report". Under "Hardware Overview" will be listed the "Model Identifier". When on the "About This Mac" screen, the amount of memory will be listed.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions