I have version 10.5.8, can I upgrade to el capitan or do I need to purchase snow leopard first?

makbookair

Back To Product

Follow this Question

1 Answer from the Community

  • Answer

    First determine whether whether you Mac is supported by the OS X version you wish to upgrade to. (i.e. check the system requirements for the OS X you wish to upgrade to). Snow Leopard and later require an Intel processor (not the PowerPC processor). Snow Leopard requires minimum 1GB of memory, OS 10.7 and later require at least 2GB of memory. Each OS X version depends on certain features in order to install . . . those features depend on the Mac model and year or Model Identifier.

    If your Mac is supported, here are the steps:

    1) Purchase Snow Leopard first. Install. Do Software Update to bring up to OS 10.6.8.

    2) Once OS 10.6.8 is running, there will be a new app on your Mac called "App Store". Launch "App Store" and see if OS 10.11 (El Capitan) is available for your Mac (if "El Capitan" not supported by your Mac, it will not show in "App Store".)

    3) Download El Capitan through the App Store app, and install.

    4) If your Mac is supported by OS 10.12 (Sierra) then when you run "App Store" again, Sierra should be available to download and install. (Sierra requires OS 10.7 or later in order to install, that is why an OS X version after Snow Leopard needs to be installed first.)

    Was this useful? Answer 1

    1 of 1 people found this useful

Related Questions