Is it possible to upgrade safari 5.1.10 (Browser upgrade only) for mac 10.6.8 ? I want to keep Snow Leopard.

My bank says, "to upgrade safari 5.1 browser for security" in order to log on to Pay Bill site.

Back To Product

Follow this Question

1 Answer from the Community

  • Love the Snow Leopard OS, but need more secure web browser?

    Suggestion One: If your Mac is supported by latest OS, El Capitan, which is free, why not install El Capitan on a separate partition from the partition with Snow Leopard?

    Afterwards, use Start Up Disk to have your Mac normally start in Snow Leopard. But when you want to use latest version of Safari, re-start (or start) your Mac in El Capitan and press & hold the Option Key during start up to select the partition with El Capitan.

    I have multiple partitions with different versions of the Mac OS on them or with different configurations. My most important need is to be able to start up in Snow Leopard whenever I need to use my expensive tabloid scanner, as the manufacturer didn't have an upgrade for years that would work with later versions of OS X, then when they finally introduced an upgrade that worked, the cost to upgrade was several hundreds of dollars.


    Suggestion Two: Is there another browser that will work with Snow Leopard but is secure? For example, the current version of Firefox (v 42) works with Snow Leopard.

    Was this useful? Answer 1

    1 of 9 people found this useful

Related Questions