can it work with ios 9.1 iphone 5s? thank you

Back To Product

Follow this Question

1 Answer from the Community

  • Yes. But it is best if you update your iPhone to iOS 11.
    Then functionality of W1 chip inside BeatsX will be implemented.

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions