Back To Product

Follow this Question

1 Answer from the Community

  • Yes, see system requirements:

    System requirements:
    Bluetooth-enabled Mac computer with macOS 10.12.4 or later
    iOS devices with iOS 10.3 or later

    Was this useful? Answer 1

    0 of 0 people found this useful

Related Questions