Can I download a version of Pages that accepts MAC OS X 10.5.8?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    Older versions of Pages are definitely compatible with OS X 10.5 Leopard. For example, iWork 08 will run on Intel or PowerPC systems and only requires OS X 10.4 Tiger or later.

    The problem for you is that the only place you can legally download Pages is from the Mac App Store, and that's only present in OS X 10.6 Snow Leopard and later.