Cannot open FireFox as of today. If I download 10.6 will it work again. I uninstalled/downloaded 3 times, plus Norton Virus Scan, still does not work

I have Version 10.4.11.

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    Firefox requires 10.5 or newer. If you get 10.6, it will work again. make sure you have a computer newer than 2007 to install Snow Leopard onto.