do i have to have mac os v 10.6 snow to run icloud?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Answer

    You have to have 10.7 which is called Lion to be able to use the features that are included in iCloud.