Do i need to purchase snow leopard and then also buy lion?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • You must be running at least version 10.6.6 of Snow Leopard in order to install Lion.