I have 10.6.8. What do I need to upgrade to?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    Depends on how old your Mac is.

    Macs older than 2007-2009 (date depends on the model) can not run the current Mountain Lion OS (OS 10.8).

    Lion (OS 10.7) is no longer available through the App Store, but may be available as a Legacy Product.