i have a power mac G4 will i be able to upgrade to snow leopard

  • Asked about:  Mac OS X 10.6 Snow Leopard

2 Answers from the Community

  • Best Answer:

    No! You will need a Macintosh with an Intel Processor in order to install Snow Leopard.

  • Unfortunately, no. Snow Leopard will only install and run on Intel multicore processors, and will not work on G5 or earlier processors like yours. Sorry!