I have an old MacBook (OS X 10.4.11) and a new Macbook Pro (OS X 10.6.8). Do I need to get both the Snow Leopard and the Snow Leopard Box Set?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Answer

    Absolutaly not