I have G5 PowerMac - powerpc 970 (2.2) - OS 10.4.11, so I can't update to snow leopard?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Answer

    No you need an Intel based Mac for it to work.