I have mac os x 10.4.11 and want to use Logic Express but that needs Mac OS X v10.5.7 or later. Do I upgrade to snow leopard or Mac box set? Thanks

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • You can attempt to upgrade to 10.5 but those discs are much harder to come by and have to be purchased on a 3rd party site. If your hardware on your unit can handle it I would advise calling into Apple and looking into ordering 10.6 discs. Much more cost efficient