i have snow leopard 10.6.8. what do I need in order to add airport extreme?

  • Asked by fn from Bear Creek Township
AirPort Extreme

AirPort Extreme

Product No Longer Available

1 Answer from the Community

  • Answer

    AP Extreme requires OSX 10.7.5 and Airport Utility 6.3 to set up. You'll need to upgrade your OSX. I set mine up with my current MacBook Pro running 10.7.5 but I also have an older MacBook Pro running on OSX 10.6.8 and it does recognize the AP Extreme, so apparently the Extreme is compatible with 10.6.8. Best to talk with an Apple Genius at an Apple store to be sure.

    • Answered by Daniel T from Redlands