I have snow leopard. Do I need Lion to set up icloud?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • iCloud requires Mac OS 10.7.5 to run the basic features. If you want to use the full features of iCloud, you need to run Mac OS X 10.8.