I want to download the Adobe CS5 trials but I need OSX 10.5.7 or higher, my Macbook runs 10.4.6, do I need the boxset or can I just buy the £25 disc?

  • Asked about:  Mac OS X 10.6 Snow Leopard

No Answers have been submitted