mountain lion os x requirements

Mac OS X 10.6 Snow Leopard

Mac OS X 10.6 Snow Leopard

Product No Longer Available

1 Answer from the Community

  • Answer

    Mountain Lion requirements:

    supportDOTappleDOTcom/en-ca/HT202575

    (replace each "DOT" with ".")