Upgrade to OSX 10.9: will I be able to synch my iphone 4S? Heard 10.8.5 is last 4S compatible ver. Please do not answer if not absolutely certain.

I have a macbook running 10.8.5, Itunes 12.3.1.23.

No Answers have been submitted

Be the first to answer this question.  Answer now