Will Snow Leopard run on a PowerPC G4 mac?

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    No, Snow Leopard requires an Intel Mac. Leopard 10.5 is as far as you can go.