Will this product work on an iMac with macOS Mojave Version10.14?

if so what applications will need to be downloaded to verify this. Thanks a million!!!

Harry Potter Kano Coding Kit

Back To Product

Follow this Question

1 Answer from the Community

  • Apple Responds

    System Requirements: Operating System: OS X Yosemite 10.10 or later; iOS 11 or later

    Was this useful? Answer 1

    1 of 2 people found this useful

Related Questions