I purchased my Mac in 2006. Will this new software work with my computer?

I think I have Mac OS X 10.4 or 10.5 on my current computer.

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • If it is an iBook, PowerBook or and PowerPC Mac, it will not work with your computer.