is snow leopard compatible with my current software running on 10.5.8?

I need to be able to run Quicken 2007 in particular.

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Best Answer:

    If you have a Intel CPU, yes, but if you have a Power PC CPU, no.