is this working with ibook g4(1.2 ghz)(OSX 10.5 Leopard)

  • Asked about:  Mac OS X 10.6 Snow Leopard

1 Answer from the Community

  • Answer

    No. Snow leopard requires an Intel processor.