Will Face Time work in snow leopard?

  • Asked about:  Mac OS X 10.6 Snow Leopard

2 Answers from the Community

  • Best Answer:

    Minimum OS requirements for Face Time is OS 10.6.6.

    So yes! The latest update to Snow Leopard (which is now OS 10.6.8) will work.

  • Yes. You will need to purchase the Face Time app from the App Store.