Does this work with Snow Leopard 10.6.8?

AirPort Extreme

AirPort Extreme

Product No Longer Available

2 Answers from the Community

  • Best Answer:

    As a WiFi router, yes. But you will not be able to administer the Airport Extreme as it requires Airport Utility 6.3 or higher which is only available on OS X 10.7.5 or higher.

    You can however use an iOS device running iOS6.0 or higher using the Airport Utility app.

  • Yes. You will need 10.7 to administer with Airport utility.