I noticed that 10.7.5 is required. I have 10.6.8 on my iMac, will this work?
- Asked by Edmond G from Davie
Product No Longer Available
2 Answers from the Community
You will need Airport Utility 6.3 or higher which is only available on OS X 10.7.5 or higher. However you can also configure it with a mobile device using iOS 6.0 or higher
- Answered by Tyler S from Boise
It is my understanding that you must first upgrade to 10.7.x (~$20)
Then download 10.7.5 upgrade (which I would hope is free)
I will be trying this myself in the next few days...
- Answered by Lee M from Middletown