• 1.0 out of 5 stars

    Not compatible with IOS 9.2

    I have owned an apogee one for about a year. In general an excellent sounding device.

    However when Apple updated IOS to 9.2 it stopped working and they haven't bothered fixing it. None of the inputs work without unbearable popping and clicking noise (

    I now have a device that hasn't worked for 8 weeks, pretty poor.

    Even more galling is apogee continue to advertise this device as compatible with iOS when it's not

    22 of 32 people found this useful